System Requirements
System Requirements
9.0 System Requirements
Overview
This topic provides the following server hardware and configuration requirements for running ThingWorx in a production environment:
Core operating system software requirements
Prerequisite software required by ThingWorx
Minimum sizing requirements (for production use)
The information in this section is specific to ThingWorx 9.0, unless specifically noted otherwise. Other versions of the product may introduce new or changed system requirements.
For ThingWorx Foundation Installers System Requirements, refer to the following: ThingWorx Foundation Installer.
For ThingWorx Flow Installers System Requirements, refer to the following topic: Installing ThingWorx Flow.
ThingWorx Kepware Server can be integrated with the platform to model, configure, and track data in the ThingWorx model. ThingWorx supports integration with industry data sources through the Industrial Connections functionality in Composer. Product information and system requirements for are available at https://www.kepware.com/en-us/products/kepserverex/.
ThingWorx Server Requirements
The following are minimum recommendations for production. Actual sizing will depend on the application and usage scenarios.
Hardware Sizing
Aspect
Value
Comment
Memory
16 GB
Configuration will require a percent of dedicated memory to be allocated to the Java VM.
CPU(s)
4 Cores
Virtualized environments may have their own terminology for specifying how many CPUs/Cores are being provided. This must be taken into account when determining if the environment meets the minimum requirements.
The amount of concurrent query activity, indexing and searching, as well as the amount of internal event and/or property data-change may warrant increased CPU resources.
Disk Type
*
Server-class hardware is recommended.
Disk Space
100GB
This size will accommodate the default ThingWorx web application installed in Tomcat, along with the initial ThingworxStorage (DB) directory and some initial configuration data.
* 
This does NOT include the space required for the OS or other prerequisite software.
An additional 100GB of space is required if ThingWorx Flow is also installed (for a total minimum of 200GB of disk space).
The total disk space required for any given application depends on the amount of configuration and runtime data that will be maintained. Customers should work with Sales and Field Enablement to estimate space needs according to their application requirements.
Disk Speed
10000 RPM or SSD
Speed is important if you are storing data on the ThingWorx Core. ThingWorx recommends the fastest disk(s) you can afford, but you should not use disks slower than 10000 RPM.
* 
You may wish to consider a RAID configuration to increase disk performance
If you will be executing regular system backups, it is HIGHLY recommended to use an additional physical disk on its own controller - not simply a separate partition on the same physical disk.
Operating System
Supported OS (64-bit only)
Notes
Windows Server 2012, 2016, and 2019
Windows Server 2012 R2
Not supported for use with ThingWorx Flow
Red Hat Enterprise Linux (RHEL) 7.6, 8.0, 8.2
Ubuntu 16.04, 18.04.03
Not supported for use with ThingWorx Flow
* 
The software in the table below requires downloading/installing the proper OS-specific version.
In general, you may install later minor versions of the software, but new major versions are not supported unless explicitly stated here (i.e. JDK 1.7.0.17 would be a minor version, but JDK 1.8 would be considered a major version). ThingWorx may still properly run on a newer major version but will not be officially supported until tested and certified.
Required Software
Prerequisite Software
Versions Tested
Comments
Oracle Java SE Development Kit (JDK)
Java SE Development Kit 8, Update 241 (64-bit) (1.8.0_241) or later
ThingWorx is only supported on 64-bit operating systems.
Open JDK is not currently supported.
Tomcat (Linux)
9.0.35 (64-bit)
Installed manually as the standard package management does not typically have the latest versions available.
It is strongly recommended that you upgrade Apache Tomcat to these versions to mitigate known security issues with older versions of Apache Tomcat.
ThingWorx may still properly run on a newer major version but will not be officially supported until tested and certified.
Tomcat (Windows)
9.0.35 (64-bit)
Installed using the Windows service installer.
It is strongly recommended that you upgrade Apache Tomcat to these versions to mitigate known security issues with older versions of Apache Tomcat.
ThingWorx may still properly run on a newer major version but will not be officially supported until tested and certified.
PingFederate
9.3.3 Patch 5
8.4.4 Patch 3
PingFederate is the PTC-supported method for conducting Single Sign-on (SSO) to ThingWorx. PingFederate is only required for customers implementing SSO.
PTC supports the Versions Tested and all subsequent builds within the same minor version (e.g. 9.3.x or 8.4.x).
Database Options
Database
Supported Version
Comments
PostgreSQL
9.6.17, 10.12, 11.7
Additional information is located in Using PostgreSQL as the Persistence Provider.
Microsoft SQL Server
2016, 2017, and 2019
JDBC 7.4 driver is required to support MSSQL 2019.
Additional information is located in Using Microsoft SQL Server as the Persistence Provider.
AzureSQL
Azure SQL Logical Server- V12
Azure SQL Managed Instance- V12
For information on the latest Azure SQL version, refer to https://docs.microsoft.com/en-us/azure/sql-database/sql-database-faq.
Not supported for use with ThingWorx Flow.
Additional information is located in Using Azure SQL as the Persistence Provider.
InfluxDB
1.7.10
Not supported for use with ThingWorx Flow.
Additional information is located in Using InfluxDB as the Persistence Provider.
Composer (Modeling IDE and Mashup Builder)
ThingWorx Composer is an HTML application that runs in a browser. The required minimum resolution for Composer is 1280x1024. The currently supported browsers are shown below.
* 
Application behavior may change based on browsers that auto-update (the latest versions of Chrome, Firefox, Safari). Issues that are introduced by new browser versions will be identified and fixed as soon as possible, depending on the severity. BETA and Nightly Release versions are not supported for use.
OS
Browser
Version(s)
Comments
Windows 10
MS Edge
Chromium 81.0 and later
macOS 10.15 / Windows 10
Firefox
Quantum – 68 and later
ESR – 68 and later
macOS 10.15
Safari
13 and later
macOS 10.15 / Windows 10
Chrome
67 and later
Mashup Runtime
OS
Browser
Version
Comments
Windows 10
MS Edge
Chromium 81.0 and later
macOS 10.15 / Windows 10
Firefox
Quantum – 68 and later
ESR – 68 and later
macOS 10.15
Safari
13 and later
macOS 10.15 / Windows 10
Chrome
67 and later
iOS 13
Mobile Safari