製造 > 製造參數 > 設定或修改 NC 序列參數
設定或修改 NC 序列參數
1. 按一下「參數」(Parameters) 標籤上的 「編輯參數」(Edit Parameters) 對話方塊開啟。此對話方塊內含參數表,列出 NC 序列層級能夠顯示的全部參數。
2. 欲顯示只屬於某個特定類別的參數,請從「類別」(Category) 下拉選單中選擇相應的類別。
3. 按一下「工具」(Tools) > 「參數欄」(Parameter Columns) 開啟「欄設定建造器」(Column Setup Builder) 對話方塊,此對話方塊中有用來新增或移除欄、重新排列欄,以及設定參數表中預設欄寬的選項。
4. 參數表的每一欄都會顯示參數的屬性,如下所示。只能使用「參數設定」(Parameters Setup) 對話方塊來修改這些屬性。
註解 (Comments) - 參數的註解。
參數 ID (Parameter ID) - 用來代表關係式中參數的名稱。
列印 (PPRINT) - 依據選項是開啟還是關閉,指定是否要將參數納入 CL 資料輸出結果中。輸出格式如下:
TEXT / ‘<parameter_name>:<parameter_value>’
5. 在參數表的「值」(Value) 欄中輸入參數值。必要參數的值儲存格會顯示成淡黃色。如果輸入無效的值,會顯示一則警告訊息,並還原成上一個參數值。
如果參數可接受字串值,此欄位會變成下拉選單,列出允許的值。請選取適當的值。
6. 按一下 開啟「關係」(Relations) 對話方塊並修改關係式。依預設,會預先定義所需參數的關係。您可以編輯這些預設關係。
7. 要按參數名稱或值來排序參數,請按一下對應的欄標題。再按一次欄標題可用遞減順序排序欄。或者,也可以按一下「工具」(Tools) > 「排序參數」(Sort Parameters) 選單中的選項。
8. 按一下「顯示細節」(Show Details) 可檢視所選參數的圖解。只有基本參數才會顯示圖解。如果參數已有一組預定的值,則會顯示與該指定值對應的圖解。例如,當您選取「提刀_進給」參數時,就會顯示下圖:
* 
此圖解代表使用該參數的作業。
圖中的參數位置已反白顯示。
9. 按一下「隱藏細節」(Hide Details) 可隱藏圖解。
10. 要將參數及其值儲存至磁碟中,請按一下「檔案」(File) > 「另存新檔」(Save As) 並輸入檔名。
11. 使用「檔案」(File) 選單上的下列選項,即可將參數及其值儲存至磁碟中,還可以從磁碟中擷取已儲存的參數:
另存新檔 (Save As) - 可將參數及其值儲存至磁碟中。在顯示的對話方塊中輸入檔名。即根據 NC 序列的類型,以下列副檔名之一來儲存檔案:
.mil - 銑削 NC 序列
.trn - 車削 NC 序列
.drl - 孔加工 NC 序列
.edm - 線切割 NC 序列
.aux - 輔助 NC 序列
開啟 (Open) - 從另一個 NC 序列中擷取已儲存的參數及其值。在顯示的「檔案開啟」(File Open) 對話方塊中,指定含已儲存參數的檔案。
開啟站 (Open Site) - 從位置檔案擷取已儲存的參數。必須按一下「檔案」(File) > 「開啟」(Open) 並在出現的「開啟」(Open) 對話方塊中指定位置檔案。
12. 使用「編輯」(Edit) 選單上的下列選項,可以:
複製 (Copy) - 複製目前在參數表中選取的一或多個儲存格。然後再將複製的值貼到其他一或多個儲存格中。
貼上 (Paste) - 將複製的值貼到所選的一或多個儲存格。
從工具複製 (Copy From Tool) - 內含用來將刀具參數複製到 NC 序列的選項。按一下相關的選項。
從位址繼承 (Inherit From Site) - 列出為製造模型 (它對目前序列有效) 定義的位址。選取一個位址來複製針對目前工件機床定義的地址參數。按一下「無」(None),以使位置檔案中的參數不被複製到參數表中。
從步驟複製 (Copy from Step) - 從目前 NC 模型所定義的上一個步驟中複製參數。
13. 按一下「編輯」(Edit) > 「搜尋」(Search) 以開啟「搜尋」(Search) 對話方塊,此對話方塊中有搜尋參數時所用的選項。
14. 按一下「資訊」(Information) > 「步驟」(Step) 開啟「資訊視窗」(INFORMATION WINDOW) 對話方塊,顯示有關目前 NC 步驟的所有資訊。
15. 按一下「工具」(Tools) > 「關係」(Relations),開啟「關係」(Relations) 對話方塊並修改關係式。
16. 按一下「工具」(Tools) > 「參數欄」(Parameter Columns) 開啟「欄設定建造器」(Column Setup Builder) 對話方塊,此對話方塊內有用來新增或移除參數表欄的選項。
17. 按一下「工具」(Tools) > 「顯示所有數值欄」(Show All Value Columns) 欄,在參數表內顯示所有欄。
18. 按一下「確定」(OK) 以儲存所有變更並關閉對話方塊。您必須先提供所有必要參數的值,才能使用此選項。
19. 按一下「取消」(Cancel),取消所有變更並關閉對話方塊。或者,按一下「檔案」(File) > 「退出」(Exit)
這是否有幫助?