Dessins détaillés > Définition et configuration de dessins > Options de configuration du dessin > Options de configuration relatives aux dessins détaillés
  
Options de configuration relatives aux dessins détaillés
allow_duplicate_view_names
Contrôle le changement de nom des vues de dessin.
Paramètres par défaut et paramètres disponibles :
no* : ne vous autorise pas à attribuer le nom d'une vue de dessin existante à d'autres vues dans un dessin.
 
* Vous pouvez cliquer sur Insérer (Insert) > Importer le dessin/les données (Import Drawing/Data) et importer un dessin avec des noms en double. Toutefois, un avertissement s'affiche lorsque vous cliquez sur Revoir (Review) > Mettre à jour 2D (Update Draft).
yes : vous permet d'attribuer le nom d'une vue de dessin existante à d'autres vues dans un dessin.
allow_move_attach_in_dtl_move
Contrôle le fonctionnement conjoint des commandes Déplacer (Move) et Déplacer attache (Move Attach).
Paramètres par défaut et paramètres disponibles :
no* : les commandes Déplacer (Move) et Déplacer attache (Move Attach) ne peuvent pas fonctionner conjointement.
yes : les commandes Déplacer (Move) et Déplacer attache (Move Attach) fonctionnent conjointement en mode Mise en plan (Drawing).
allow_move_view_with_move
Contrôle le déplacement des vues de dessin avec la souris.
Paramètres par défaut et paramètres disponibles :
no* : interdit le déplacement de toutes les vues avec la souris.
yes : autorise le déplacement des vues avec la souris.
allow_vert_select_in_dim_create
Contrôle la mise en surbrillance des sommets de modèle lorsque des cotes sont créées dans les dessins.
yes* : met en surbrillance les sommets de modèle.
no : ne met pas en surbrillance les sommets de modèle.
auto_center_dimension
Contrôle le placement du texte de cote entre les lignes de rappel lorsque des cotes sont créées dans les dessins.
no* : vous permet de placer le texte de cote à l'emplacement de votre choix entre les lignes de rappel.
yes : centre automatiquement le texte de cote entre les lignes de rappel.
 
* Dans le cas des cotes de référence communes, cette option contrôle uniquement le centrage de la première cote.
auto_constr_offset_tolerance
Définit la tolérance de contrainte automatique lors de la création de cotes décalées. Si la distance est inférieure à la tolérance multipliée par la taille du composant, le décalage est défini comme coïncident.
Paramètres par défaut et paramètres disponibles :
default : la valeur par défaut est zéro. Si besoin est, vous pouvez définir une valeur différente.
allow_refs_to_geom_reps_in_drws (pas dans le fichier)
Permet de créer des références de dessin par rapport à des représentations de géométrie (inclut les cotes, les notes et les lignes de repère). Il se peut que la validité de ces références soit remise en cause par la modification de la géométrie référencée, si les représentations de géométrie ne sont pas mises à jour dans les dessins.
Options par défaut et options disponibles
yes : permet de créer des références de dessin par rapport à des représentations de géométrie.
auto_regen_views
 
* La régénération d'une vue parente n'entraîne pas la régénération des vues enfants ; chaque vue du dessin doit être sélectionnée individuellement pour être régénérée, y compris les vues de détail. Chaque fois que vous enregistrez des modifications apportées au modèle, Creo Parametric les affiche sur le dessin lors sa récupération suivante, que vous ayez ou pas régénéré les vues du dessin.
Paramètres par défaut et paramètres disponibles :
yes* : rafraîchit automatiquement l'affichage lors du passage d'une fenêtre à l'autre. Creo Parametric met à jour automatiquement l'affichage du dessin via rafraîchissement lorsque vous passez d'une fenêtre à l'autre. Par exemple, lorsque vous modifiez un modèle dans une sous-fenêtre tandis que vous manipulez un dessin dans la fenêtre principale. Vous pouvez rafraîchir ou régénérer le dessin pour répercuter les modifications apportées au modèle. Lorsque vous le régénérez, le modèle est mis à jour pour refléter les modifications apportées au dessin.
no : mise à jour du dessin, pas de rafraîchissement de la fenêtre. Vous pouvez seulement mettre à jour le dessin en choisissant Actualiser (Update) dans le menu Affichage (View), puis en sélectionnant Vues du dessin (Drawing Views) ou Feuille (Sheet). Lorsque cette option est configurée sur , ni la commande Mettre à jour (Update) du menu Affichage (View), ni la commande Régénérer le modèle (Regenerate Model) du menu Edition (Edit)no ne mettent à jour le dessin, même si vous avez modifié le modèle en mode Mise en plan (Drawing) (par exemple en modifiant une valeur de cote). Vous pouvez sélectionner et régénérer simultanément autant de vues que vous le souhaitez.
Si vous essayez de modifier une vue qui n'a pas été mise à jour, le système affiche un message d'erreur vous informant que cette modification du dessin ne sera effectuée que lorsque vous aurez appliqué l'option Mettre à jour (Update) ou Régénérer le modèle (Regenerate Model) à la vue en question.
 
* L'option de configuration auto_regen_views s'applique uniquement à une vue de type filaire, caché ou non caché. Dans le cas d'une vue ombrée, elle est mise à jour quel que soit le réglage de cette option de configuration.
auto_show_3d_detail_items
Détermine si les éléments de détail 3D apparaissent lors de la création d'une vue de dessin.
Paramètres par défaut et paramètres disponibles :
yes* : les éléments de détail 3D disposant de plans d'annotation définis apparaissent automatiquement dans les vues de dessins dès leur création. Notez toutefois que les éléments de ces plans d'annotation doivent être parallèles à la vue du dessin pour s'afficher automatiquement.
no : les éléments de détail 3D n'apparaissent pas dans les dessins lors de la création de la vue.
bom_format
Définit le fichier de format de nomenclature personnalisée à utiliser. Vous devez spécifier le nom et le chemin.
Paramètres par défaut et paramètres disponibles :
Indiquez le nom et le chemin d'accès du fichier de format de nomenclature.
copied_table_note_text_padding
Met à jour le remplissage de texte dans les tables copiées à partir d'un dessin créé dans Creo 2.0 M130 ou une version antérieure.
new* : utilise le remplissage de texte actuel dans la table copiée.
source : conserve le remplissage de texte tel qu'il apparaît dans la table de dessin source.
create_drawing_dims_only
Indique où enregistrer les cotes créées dans le dessin.
Paramètres par défaut et paramètres disponibles :
yes : enregistre toutes les cotes créées dans le dessin en tant que cotes 2D associatives.
no* : enregistre toutes les cotes créées en mode Mise en plan (Drawing) dans la pièce.
 
* Si vous donnez à l'option de configuration draw_model_read_only la valeur cosmetic_only, assurez-vous que la valeur de l'option de configuration create_drawing_dims_only est no.
default_ang_dec_places
Contrôle le nombre de chiffres (0-14) par défaut des cotes angulaires créées dans un dessin. Cette option contrôle également les cotes de références angulaires créées dans tout mode.
Paramètres par défaut et paramètres disponibles :
Indiquez le nombre de décimales affichées. La valeur par défaut est 1.
default_ang_units
Définit les unités par défaut des cotes angulaires que vous créez dans les dessins et les modèles.
Paramètres par défaut et paramètres disponibles :
ang_deg* : définit les unités par défaut sur des degrés décimaux.
ang_min : définit les unités par défaut sur des degrés et des minutes décimales.
ang_sec : définit les unités par défaut sur des degrés, des minutes et des secondes décimales.
default_draw_scale
Définit l'échelle de dessin par défaut des vues ajoutées avec l'option Défaut (No Scale). La valeur doit être supérieure à 0.
Paramètres par défaut et paramètres disponibles :
-1.000000* : échelle de dessin par défaut des vues ajoutées avec l'option Défaut (No Scale).
no : le système ne définit aucune échelle de dessin par défaut.
default_font_kerning_in_drawing
Définit le paramétrage initial du crénage de police lors de la création d'annotations de dessin 2D. Le crénage réduit l'espace entre certaines paires de caractères, afin d'améliorer l'apparence de la chaîne de texte.
Paramètres par défaut et paramètres disponibles :
no* : le crénage de police n'est pas disponible pour les nouvelles annotations dans un dessin.
yes : le crénage de police est disponible pour les nouvelles annotations des dessins.
Lorsque l'option de configuration default_font_kerning_in_drawing est définie sur la valeur yes, la case Crénage (Kerning) de la boîte de dialogue Style de texte (Text Style) est sélectionnée par défaut pour les annotations créées. Dans l'onglet Annotation (Annotate), dans le groupe Format (Format), cliquez sur pour ouvrir la boîte de dialogue Style de texte (Text Style). La boîte de dialogue Style de texte (Text Style) s'affiche lorsque vous cliquez sur Format > Style de texte (Text Style). L'option de configuration default_font_kerning_in_drawing s'applique à la fois aux annotations créées dans le dessin et aux styles de texte créés à partir de la boîte de dialogue Liste des styles de texte (Text Style Gallery) qui s'affiche lorsque vous cliquez sur dans le groupe Format (Format) de l'onglet Annotation (Annotate). Le fait de définir cette option sur yes ne modifie pas les caractéristiques des notes existantes lors de leur redéfinition.
default_gtol_owned_by_model
Définit si la destination par défaut d'une tolérance géométrique créée dans l'environnement de dessin correspond au modèle supérieur.
no* : la destination par défaut correspond au dessin.
yes : la destination par défaut correspond au modèle supérieur.
dim_fraction_denominator
Définit le plus grand dénominateur de la valeur de cote qui apparaît sous forme de fraction. La valeur de dénominateur courante de la fraction est arrondie au numéro valide le plus proche de 0, 2, 4, 8, 16, 32, 64 et 128.
Paramètres par défaut et paramètres disponibles :
1/32*
0
1/2
1/4
1/8
1/16
1/64
1/128
disp_trimetric_dwg_mode_view
Affiche le modèle orienté par défaut lorsque vous placez une vue générale.
Paramètres par défaut et paramètres disponibles :
yes* : affiche le modèle orienté par défaut lorsque vous placez une vue générale sur le dessin.
non (no) : le modèle n'apparaît pas tant qu'une orientation n'a pas été choisie dans la boîte de dialogue Orientation (Orientation).
display_dwg_sketch_constraint
Active l'affichage des contraintes d'esquisse paramétriques lorsqu'un objet de dessin est sélectionné.
Paramètres par défaut et paramètres disponibles :
oui (yes) : les contraintes d'esquisse paramétriques, telles que V pour vertical, sont affichées lorsqu'un objet de dessin est sélectionné.
display_dwg_tol_tags
Définit l'affichage des étiquettes de tolérance dans les dessins. Ne contrôle pas les tolérances de cotes.
Paramètres par défaut et paramètres disponibles :
yes* : affiche les étiquettes de tolérance dans les dessins.
no : n'affiche pas les étiquettes de tolérance dans les dessins.
display_in_adding_view
Contrôle l'affichage du modèle lorsque l'option auto_regen_views est réglée sur no.
Paramètres par défaut et paramètres disponibles :
Default : utilise les réglages d'affichage du menu Environnement (Environment).
Wireframe : ajoute des vues en mode filaire et affiche les références.
Minimal_wireframe : affiche des vues en mode filaire, sans références, axes ou arêtes silhouettes.
draw_models_read_only
Détermine si les changements apportés au dessin modifient la conception du modèle.
Paramètres par défaut et paramètres disponibles :
no* : les fichiers de modèle de dessin ne sont pas en lecture seule : les changements opérés dans le dessin modifient la conception du modèle.
yes : les fichiers de modèle de dessin sont en lecture seule. Vous ne pouvez pas ajouter aux vues, des cotes pilotées, des tolérances géométriques ou des éléments similaires.
cosmetic_only : les fichiers de modèle de dessin sont en lecture seule. Vous pouvez ajouter des cotes pilotées, des tolérances géométriques, des sections et des états d'éclatement, mais elles ne modifient pas la conception du modèle.
 
* Assurez-vous que l'option de configuration create_drawing_dims est définie sur no lors de la définition de cette option de configuration sur cosmetic_only.
Les commandes suivantes sont autorisées quand la valeur de draw_models_read_only est définie sur cosmetic_only. Ces commandes génèrent un nouveau numéro de version pour le modèle, qui doit donc être enregistré :
création et modification des cotes pilotées (les cotes créées dans le dessin) ;
création et modification de l'état éclaté d'un assemblage ;
création et régénération d'une section.
 
* Le numéro de révision de la conception n'est pas incrémenté après l'enregistrement du modèle.
Modification de l'attache d'une référence prédéfinie. Cela s'applique aux cotes pilotes et aux cotes pilotées.
Les commandes suivantes sont autorisées quand la valeur de draw_models_read_only est définie sur cosmetic_only. L'utilisation de ces commandes ne génère pas de nouveau numéro de version pour le modèle :
modification des couches et de leur affichage ;
Modification du style de ligne d'un modèle solide 3D.
 
* Cette option de configuration n'empêche pas d'apporter des modifications à la pièce ou à l'assemblage en dehors du mode Mise en plan.
déplacement d'une étiquette de référence prédéfinie ;
extension ou ajustement d'un axe du modèle ;
déplacement d'un élément de détail d'une vue à une autre ;
création et modification d'une tolérance géométrique créée dans le dessin et ne faisant référence qu'au dessin ;
création et modification de notes sur les cotes 2D d'un dessin ;
création et modification d'entités 2D dans un dessin.
drawing_aa
Remplace les paramètres d'anticrénelage globaux pour les modes Mise en plan (Drawing) et associés aux dessins afin d'éviter une dégradation des performances.
drawing_ole_image_dpi
0-600 points par pouce (ppp)
Contrôle la résolution d'image des objets liés et incorporés (objets OLE) lorsque vous exportez ou enregistrez les dessins sous forme de fichiers image ou de dessins en lecture seule. La taille du fichier augmente avec la valeur en ppp.
0 : les objets OLE ne sont pas imprimés.
draw_points_in_model_units
Définit les coordonnées de la vue 2D en cours en unités de modèle plutôt qu'en unités de dessin.
drawing_setup_file
Définit les valeurs par défaut des options Détail (Detail) pour la session Creo Parametric. Sinon, le système utilise les valeurs des options Détail (Detail) par défaut.
drawing_shaded_view_dpi
0-600 points par pouce (ppp)
Contrôle la résolution d'image des vues ombrées lorsque vous exportez ou enregistrez les dessins sous forme de fichiers image ou de dessins en lecture seule. La taille du fichier image augmente avec la valeur en ppp.
0 : les vues ombrées ne sont pas imprimées.
drawing_view_origin_csys
Le repère nommé sera utilisé comme origine de la vue venant d'être créée.
Paramètres par défaut et paramètres disponibles :
none : le système n'utilise aucun repère spécifié antérieurement.
#string : le système utilise le repère indiqué.
drw_prompt_for_combined_state
Détermine si l'invite d'état combiné apparaît dans un dessin lorsque vous créez une vue générale.
Paramètres par défaut et paramètres disponibles :
Oui (Yes)* : l'invite d'état combiné s'affiche lorsque vous créez une vue générale.
Non (No) : l'invite d'état combiné ne s'affiche pas lorsque vous créez une vue générale.
dwg_legacy_annotation_msg
Définit le type des messages d'avertissement qui s'affichent lorsque vous ouvrez un dessin avec des annotations héritées, telles que des références prédéfinies et des annotations d'étiquette de référence prédéfinie.
Définit le type des messages d'avertissement qui s'affichent lorsque vous ouvrez un dessin avec des annotations héritées, telles que des références prédéfinies et des annotations d'étiquette de référence prédéfinie.
no* : le message apparaît dans une bulle temporaire.
yes : le message apparaît dans une zone de message.
none : aucun message n'apparaît.
dwg_show_screentip
Contrôle l'affichage d'une astuce de lien hypertexte.
yes* : affiche une astuce lorsque vous positionnez le pointeur sur le lien hypertexte.
no : améliore les performances de zoom et de panoramique sur les dessins volumineux.
enable_hlr_hashing
Permet d'éliminer les lignes cachées pour les hachurages.
Paramètres par défaut et paramètres disponibles :
yes : permet d'éliminer les lignes cachées pour les hachurages et optimise la vitesse du processus lorsque vous utilisez des pièces comportant un grand nombre de petites arêtes.
 
* Ce réglage peut augmenter la consommation de mémoire.
no* : désactive l'élimination des lignes cachées pour les hachurages.
Il est recommandé de définir la valeur no lorsque vous utilisez des types géométriques autres que les pièces comportant un grand nombre de petites arêtes.
enable_shaded_view_in_drawings
Active l'affichage des vues ombrées dans les dessins lorsque l'environnement est réglé sur Ombrage (Shading) ou lorsque le style d'affichage de la vue est défini sur Ombrage (Shading). Si cette option de configuration est définie sur no, les vues s'affichent en mode filaire et l'option Ombrage (Shading) de la liste Style d'affichage (Display Style) dans la boîte de dialogue Vue du dessin (Drawing View) ne peut pas être sélectionnée.
Paramètres par défaut et paramètres disponibles :
yes* : les vues ombrées sont autorisées dans le dessin.
no : l'affichage de la vue se fait en mode filaire.
 
* Si vous définissez l'option de configuration enable_shaded_view_in_drawing sur no et l'option Détail (Detail) model_display_for_new_views sur shading, la vue du dessin s'affiche en mode filaire.
fasthlr_drawing
Spécifie si l'affichage d'élimination des lignes cachées rapide est défini par défaut pour les vues de dessin.
Paramètres par défaut et paramètres disponibles :
no* : l'affichage ELC rapide n'est pas défini par défaut pour les vues de dessin.
oui (yes) : l'affichage ELC rapide est défini par défaut pour les vues de dessin.
force_wireframe_in_drawings
Contrôle l'affichage des vues de dessin.
Paramètres par défaut et paramètres disponibles :
yes : affiche toutes les vues en mode filaire.
no* : affiche les vues en fonction de l'affichage défini pour la session.
format_setup_file
Attribue un fichier de configuration donné à chaque format de dessin. Pour attribuer des valeurs de paramètre au format, vous devez récupérer le fichier de configuration du dessin dans le format.
general_undo_stack_limit
Limite le nombre d'opérations d'annulation et de rétablissement stockées dans la pile (mémoire). Si la limite est atteinte, la première opération ajoutée à la pile est la première supprimée.
Paramètres par défaut et paramètres disponibles :
50* : limite le nombre d'opérations d'annulation et de rétablissement à 50. Vous pouvez indiquer une valeur maximale d'opérations d'annulation et de rétablissement.
harn_tang_line_display
Affiche les lignes tangentes entre des câbles en mode d'affichage des câbles épais.
Paramètres par défaut et paramètres disponibles :
yes* : affiche les lignes tangentes des câbles épais.
no : n'affiche pas les lignes tangentes des câbles épais.
highlight_erased_dwg_views
Contrôle l'affichage des contours de vues effacées (option d'environnement Surbrillance des vues effacées.)
Paramètres par défaut et paramètres disponibles :
no : désactive la surbrillance des vues effacées.
highlight_new_dims
En mode Mise en plan (Drawing), met les nouvelles cotes en surbrillance rouge foncé jusqu'à ce que vous repeigniez l'écran.
Paramètres par défaut et paramètres disponibles :
no* : affiche les nouvelles cotes dans leur couleur par défaut.
yes : met les nouvelles cotes en surbrillance rouge foncé.
hlr_for_quilts
Contrôle l'affichage des surfaces composées dans le processus d'élimination des lignes cachées.
Paramètres par défaut et paramètres disponibles :
yes : inclut les surfaces composées dans le processus d'élimination des lignes cachées.
hlr_for_xhatches
Contrôle l'affichage des hachurages dans le processus d'élimination des lignes cachées.
Paramètres par défaut et paramètres disponibles :
yes : inclut les hachurages dans le processus d'élimination des lignes cachées.
hole_note_param_translation
Utilisez cette option si vous souhaitez traduire les paramètres de chaîne des notes de trou lorsque vous travaillez dans la version non anglaise de l'application.
no* : conserve les paramètres de chaîne des notes de trou en anglais.
yes : traduit les paramètres de chaîne des notes de trou en anglais dans la langue de la session en cours.
iges_in_dwg_line_font
Contrôle l'importation de styles de ligne définis par l'utilisateur. Creo Parametric traite l'entité de définition de la police de ligne IGES (type 304, forme 2) lorsque vous définissez ces options sur yes.
Paramètres par défaut et paramètres disponibles :
no* : importe les polices de ligne utilisateur en tant que lignes continues.
yes : les styles de ligne utilisateur sans nom sont affectés de noms par défaut en ordre séquentiel (IGES_1, IGES_2, etc.).
iges_out_dwg_line_font
Contrôle l'exportation des polices de ligne utilisateur via IGES. Creo Parametric traite l'entité de définition de la police de ligne IGES (type 304, forme 2) lorsque vous définissez ces options sur yes.
Paramètres par défaut et paramètres disponibles :
no* : exporte toute la géométrie sous forme de traits continus.
make_parameters_from_fmt_tables
Détermine la manière dont le système traite les valeurs saisies dans une table de format lorsque vous remplacez un format de dessin par un autre.
Paramètres par défaut et paramètres disponibles :
yes : stocke les valeurs saisies dans une table de format et les copie avec la table.
no* : vous invite à saisir de nouveau toutes les valeurs de la table de format.
make_aux_view_notes
Ajoute automatiquement des noms de vue aux vues auxiliaires nouvellement créées à l'aide du format spécifié par l'option de configuration aux_view_note_format. Vous pouvez modifier le nom une fois la vue ajoutée au dessin.
Paramètres par défaut et paramètres disponibles :
no* : les noms de vue ne sont pas automatiquement ajoutés à la vue auxiliaire.
yes : les noms de vue sont automatiquement ajoutés à la vue auxiliaire.
make_proj_view_notes
Ajoute automatiquement des noms de vue aux vues de projection dans un format spécifié. Le format par défaut est <VIEW view_name-view_name>. Vous pouvez modifier le nom de vue une fois la vue ajoutée à un dessin.
Paramètres par défaut et paramètres disponibles :
no* : les noms de vue ne sont pas automatiquement ajoutés aux vues de projection.
yes : des noms de vue sont automatiquement ajoutés aux vues de projection.
menu_manager_position
Détermine la position du Gestionnaire de menus.
Paramètres par défaut et paramètres disponibles :
extérieur : l'angle supérieur gauche du Gestionnaire de menus est aligné sur l'angle supérieur droit de la fenêtre de dessin.
intérieur : l'angle supérieur droit du Gestionnaire de menus est aligné sur l'angle supérieur droit de la fenêtre de dessin.
adaptive* : la fenêtre active détermine la position du Gestionnaire de menus. Lors du redimensionnement de la fenêtre, le Gestionnaire de menus se positionne lui-même en fonction de la fenêtre active.
open_draw_simp_rep_by_default
Définissez cette option sur yes pour toujours ouvrir la boîte de dialogue Ouvrir une représentation (Open Rep) lors de l'ouverture d'un dessin.
Paramètres par défaut et paramètres disponibles :
no* : ouvre un dessin directement lorsque vous cliquez sur Fichier (File) > Ouvrir (Open), sans ouvrir la boîte de dialogue Ouvrir une représentation (Open Rep).
yes : ouvre la boîte de dialogue Ouvrir une représentation (Open Rep) lorsque vous essayez de récupérer un dessin via la commande Fichier (File) > Ouvrir (Open).
pick_chain_tangent_only
Indique le prolongement des chaînes d'entités 2D sélectionnées.
Paramètres par défaut et paramètres disponibles :
yes : seules les entités tangentes de la chaîne seront sélectionnées.
no* : toutes les entités connectées de bout en bout sont sélectionnées.
preferred_publish_deliverable
Définit le livrable public préféré dans l'onglet Publier (Publish) en mode Mise en plan (Drawing). L'impression représente le format de sortie livrable par défaut. Vous pouvez également définir la valeur de cette option sur iges, set, dxf, step, cgm, pdf, dwg, tiff, medusa ou sur stheno selon le format auquel vous souhaitez publier le dessin.
pro_dtl_setup_dir
Définit le répertoire des fichiers d'options détaillées. Si cette option n'est pas définie, le répertoire de configuration par défaut est utilisé.
pro_format_dir
Définit le répertoire par défaut de la bibliothèque de format de dessin. Utilisez le chemin complet pour éviter toute confusion.
pro_note_dir
Spécifie le répertoire de récupération des notes entrées à partir d'un fichier. Utilisez le chemin complet pour éviter toute confusion.
pro_palette_dir
Définit le répertoire par défaut des fichiers palette des symboles de dessin.
pro_symbol_dir
Définit et crée automatiquement le répertoire par défaut d'enregistrement et de récupération des symboles utilisateurs. Si vous ne spécifiez pas de répertoire, le système utilise le répertoire de travail en cours. Utilisez le chemin complet pour éviter toute confusion.
pro_table_dir
Spécifie le chemin du répertoire défini par l'utilisateur à utiliser lorsque vous enregistrez ou récupérez des tables.
Paramètres par défaut et paramètres disponibles :
Chemin d'accès au répertoire de table défini par l'utilisateur.
remember_last_get_point_option
Définit la valeur par défaut du menu Point (Get Point) sur la dernière option choisie dans Sélect Point (Pick Pnt), Sommet (Vertex) et Sur entité (On Entity).
Paramètres par défaut et paramètres disponibles :
yes : définit la valeur par défaut du menu Point (Get Point) sur la dernière option choisie parmi Sélect Point (Pick Pnt), Sommet (Vertex) et Sur entité (On Entity).
rename_drawings_with_object
Crée une copie du dessin associé lorsque vous sélectionnez Fichier (File) > Enregistrer une copie (Save a Copy) pour copier un modèle ou un assemblage. Le nouveau dessin prend le nom de fichier de la nouvelle pièce ou de l'assemblage.
Paramètres par défaut et paramètres disponibles :
none*
part
assemblage
both
replace_view_mdl_custom_scale
Contrôle le changement automatique du paramètre d'échelle de vue du dessin de la valeur Echelle par défaut de la feuille (Default scale for sheet) à la valeur Echelle personnalisée (Custom scale) tout en remplaçant le modèle de la vue par un modèle pourvu d'une taille d'échelle différente.
no* : le paramètre d'échelle de vue n'est pas modifié.
yes : le paramètre d'échelle de vue est modifié automatiquement pour conserver la valeur d'échelle du modèle d'origine.
rotation_handle_snap_interval
Définit l'intervalle formé par les angles lorsque vous appuyez sur la touche MAJ et que vous utilisez la poignée de rotation 2D.
La valeur par défaut est de 15 degrés. Vous êtes libre de spécifier une autre valeur si nécessaire.
round_displayed_dim_value
Contrôle l'affichage d'une valeur de cote arrondie au nombre défini de décimales.
Paramètres par défaut et paramètres disponibles :
yes* : affiche la valeur de la cote arrondie au nombre défini de décimales.
no : affiche la valeur entière, stockée de la cote.
round_preWF5_displayed_dim_val
Contrôle l'affichage de la valeur de cote enregistrée dans une version antérieure à Pro/ENGINEER Wildfire 5.0.
Paramètres par défaut et paramètres disponibles :
calculated* : compare la valeur stockée avec la valeur affichée de la cote. Si ces deux valeurs sont identiques, affiche la valeur de cote sans arrondi. Si ces valeurs sont différentes, affiche la valeur arrondie de la cote.
round all : affiche la valeur arrondie de la cote.
round none : affiche la valeur entière et arrondie de la cote.
save_display
Détermine si la géométrie de la vue et des éléments de détail comme des cotes solides doivent être stockés en mode Consultation (View-Only).
Paramètres par défaut et paramètres disponibles :
no* : n'affiche pas la géométrie et les éléments de détail en mode Consultation (View-Only).
yes : enregistre la géométrie de la vue et les éléments de détail, tels que les cotes du solide. Ces éléments sont affichés lors de la récupération du dessin en mode Consultation (View-Only).
save_drawing_picture_file
Paramètres par défaut et paramètres disponibles :
no : n'intègre pas ou n'enregistre pas le dessin comme fichier image.
Embed* : intègre un fichier image dans un dessin pour visualisation.
Export : enregistre un fichier dessin comme fichier image dans le répertoire de travail courant lors de l'enregistrement d'un dessin.
Both : intègre et exporte à la fois.
save_modified_draw_models_only
Détermine si le système enregistre le modèle une fois que vous l'avez modifié.
Paramètres par défaut et paramètres disponibles :
no : enregistre le modèle à chaque enregistrement du dessin.
select_hidden_edges_in_dwg
Contrôle la sélection des arêtes masquées dans les dessins.
Paramètres par défaut et paramètres disponibles :
yes* : permet de sélectionner des arêtes cachées dans les dessins.
no : bloque la sélection d'arêtes cachées en rejetant les arêtes derrière la première surface au niveau du point de sélection.
selection_of_removed_entities
Paramètres par défaut et paramètres disponibles :
yes : vous pouvez sélectionner des entités placées devant une coupe (plane ou décalée), les ajuster (avec la profondeur de champ) ou les effacer avec le menu AFFICHAGE ARETE (EDGE DISP).
no* : vous ne pouvez pas effacer les géométries, courbes ou points de référence, les fonctions cosmétiques, les filetages, les gravures ni les repères.
show_annotations_dialog_limit
Détermine le nombre d'annotations minimal qui peuvent être affichées pour la sélection courante avant l'ouverture de la boîte de dialogue Afficher les annotations du modèle (Show Model Annotations).
Paramètres par défaut et paramètres disponibles :
0* : afficher toujours toutes les annotations du modèle.
switch_dims_for_notes
Contrôle l'affichage des cotes lors de la création d'une note de dessin.
Paramètres par défaut et paramètres disponibles :
yes* : les cotes s'affichent sous leur forme symbolique lors de la création de la note de dessin.
no : les cotes utilisent des valeurs numériques.
symbol_editor_use_symbol_font
Contrôle le type de palette de symboles utilisée dans l'Editeur de symboles.
yes* : utilise le type de palette de symboles défini dans l'option de détail symbol_font pour le modèle ou dessin courant.
no : utilise la palette de symboles héritée.
symbol_instance_palette_file
Indique l'emplacement de la palette d'instances de symbole.
symbol_palette_input
Contrôle l'affichage de la palette de symboles de texte spéciaux lors de la création d'une note.
Paramètres par défaut et paramètres disponibles :
yes* : la palette Symbole de texte (Text Symbol) est affichée lors de la création d'une note.
no : la palette Symbole de texte (Text Symbol) n'est pas affichée lors de la création d'une note.
custom_text_symbol_palette_file
Définit le chemin d'accès au fichier de schéma de palette. Utilisez le chemin d'accès complet. Par exemple, si l'un de vos fichiers est intitulé my_custom_palette.txt et se trouve sous D:\my_proe_files\palette, vous devez définir le chemin comme suit : D:\my_proe_files\palette\my_custom_palette.txt.
 
* Pour utiliser une autre palette, vous devez modifier le chemin d'accès dans l'option de configuration pour qu'il pointe vers la palette souhaitée. Vous devez ensuite quitter la session en cours puis la redémarrer afin que la palette de symboles modifiée soit disponible.
todays_date_note_format
Contrôle le format initial d'affichage de la date dans un dessin. Il s'agit d'une chaîne composée de trois parties :l'année, le mois et le jour. Vous pouvez entrer ces parties dans n'importe quel ordre.
tol_num_digits_default_driven
Définit l'état de la case à cocher Valeur par défaut (Default) pour les valeurs de tolérance de cote principale et double sous le groupe Précision (Precision) de l'onglet de ruban Cote (Dimension) lorsque vous créez une cote ou que vous souhaitez afficher une cote pour la première fois.
Paramètres par défaut et paramètres disponibles :
Yes* : la case à cocher Défaut (Par défaut) pour les valeurs de tolérance de cote principale et double est sélectionnée.
No : la case à cocher Défaut (Par défaut) pour les valeurs de tolérance de cote principale et double n'est pas sélectionnée.
Utilisez cette option de configuration afin que le nombre par défaut de décimales pour les valeurs de tolérance de cote principale et double soit le même que le nombre de décimales de la valeur nominale de la cote lorsque vous créez une cote ou souhaitez afficher la cote pour la première fois.
triangulate_filled_areas
Sous-divise les zones remplies des entités 2D en triangles. Si elle est définie sur yes, cette option peut affecter l'utilisation de la mémoire et la taille du fichier de tracé.
Paramètres par défaut et paramètres disponibles :
no* : ne sous-divise pas les zones remplies des entités 2D en triangles.
yes : sous-divise les zones remplies des entités 2D en triangles.
ttf_handling_for_plot_files
Définit la rédaction des annotations utilisant les polices TrueType dans un fichier de traçage pour une session Creo Parametric active.
Paramètres par défaut et paramètres disponibles :
use true type fonts* : inclut le nom de la police et du texte associé à l'annotation dans le fichier de traçage. Ce paramètre réduit la taille du fichier de traçage.
 
* Le paramètre ci-dessus peut engendrer un remplacement de police si votre imprimante ou votre traceur ne prend pas la police en charge. Il est recommandé d'éviter ce paramètre si vous utilisez des polices personnalisées.
stroke all fonts : inclut le texte associé à l'annotation en tant qu'objet triangulaire dans le fichier de traçage. Ce paramètre augmente la taille du fichier de traçage.
variant_drawing_item_sizes
Contrôle la taille et la position des éléments du dessin lorsque vous les déplacez ou que vous les copiez à un autre endroit sur la feuille ou le papier.
Paramètres par défaut et paramètres disponibles :
no* : les éléments de dessin déplacés ou copiés vers une autre feuille ou situés dans une feuille modifiée conservent la même taille et orientation relative sur papier.
yes : certains éléments sont redimensionnés/positionnés à l'identique sur papier et d'autres à l'écran.
warn_if_ISO_tol_missing
Contrôle l'affichage d'un message d'avertissement dans la boîte de dialogue Tolérance ISO incorrecte (Invalid ISO Tolerance). Cette boîte de dialogue s'affiche lorsque Creo Parametric valide une table de tolérances ISO et détecte qu'il manque une valeur de tolérance dans la table sélectionnée.
Si vous cliquez sur Oui (Yes) dans la boîte de dialogue Tolérance ISO incorrecte (Invalid ISO Tolerance), l'onglet de ruban Cote (Dimension) s'affiche pour vous permettre de sélectionner une autre table de tolérance ISO. Si vous cliquez sur Non (No), ce sont les tolérances existantes qui sont appliquées.
Paramètres par défaut et paramètres disponibles :
yes* : le système affiche un message d'avertissement s'il manque une valeur de tolérance dans la table sélectionnée.
no : aucun message d'avertissement n'apparaît.
 
* Lors de la régénération du modèle ou du dessin, le système enregistre un message d'avertissement dans un fichier journal pour chaque cote qui n'a pas de valeur de tolérance correspondante dans la table de tolérances ISO. Après avoir régénéré le modèle ou le dessin, vous pouvez accéder à ce fichier journal en cliquant sur Informations (Info) > Info sur la session (Session Info) > Journal des messages (Message Log). Vous pouvez imprimer ce fichier journal et l'utiliser pour corriger manuellement les cotes.