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オンプレミス環境のトラブルシューティング
このトピックは Windchill オンプレミスのシステム管理者を対象としています。
問題: プラグインのインストールを続行できない
この問題は、次の理由で発生する可能性があります。
プラグインのインストールディレクトリが推奨として設定されていない。
管理者に、必要最小限の読み取り、書き込み、および実行アクセス許可がない。
解決方法
プラグインのインストールディレクトリが正しく設定されていること、および必要なアクセス許可が管理者アカウントに付与されていることを確認します。
問題が解決しない場合は、システム管理者に問い合わせてください。
プラグインのインストールが PKIX パス構築エラーで失敗する
Windchill サイト管理者がプラグインのインストールを開始すると、次のエラーでプロセスが失敗します。
"Attempt 3 to download zip failed due to exception: PKIX path building failed".
MethodServer のログに、無効な証明書の例外が表示されます。
PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
解決方法
公開証明書を https://portal.ptc.com からダウンロードします。
keytool ユーティリティを使用して、証明書を Windchill の Java キーストアにインポートします。
ダウンロードした証明書に、必要なすべての中間証明書が含まれていることを確認します。
プラグインのステータスは「インストール完了」として表示されるが、プラグインサーバーのステータスは「停止」として表示される
AI Parts Rationalization プラグインをインストールすると、プラグインのステータスは「インストール完了」として表示されますが、プラグインサーバーのステータスは「停止」として表示されます。
解決方法
非 GUI 環境をサポートするために、次のコマンドを使用して wt.manager.cmd.executor プロパティを設定解除する必要があります。
xconfmanager -s wt.manager.cmd.executor= -t codebase/wt.properties -pF
URL の長さが原因でインデックシングに失敗する - 413 Payload Too Large エラー
MPMLink を使用している場合、URL の長さが許容される制限を超えると、オブジェクトの処理中にインデックシングが停止し、413 Payload Too Large エラーが発生します。
解決方法
MPMLink を使用している場合、長い URL でのインデックシングを有効にするには、次のように AJP および Tomcat サーバーの設定を行います。
1. Windchill シェルで、<HTTP サーバー> フォルダに移動し、次のコマンドを実行します。
ant -f config.xml configureAJPWorkers -DajpMaxPacketSize=16384
2. Windchill シェルで、<Windchill>/Tomcat フォルダに移動し、次のコマンドを実行します。
ant -f config.xml configureConnectors -DajpMaxPacketSize=16384
3. HTTPServer/conf/httpd.conf ファイルを編集し、次の行を追加します。
LimitRequestLine 16384
LimitRequestFieldSize 16384
4. Apache サーバーと Windchill サーバーを再起動して変更を適用します。
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問題が解決せず、引き続きリクエストが 413 Payload Too Large from GET エラーで失敗する場合は、コンフィギュレーション設定を確認してください。上記の手順で示されている 4 つの値すべてを増やしてみてください。その際、値には 1024 の倍数を使用してください。
問題: バルクインデックシングジョブがさまざまなエラーで失敗する
バルクインデックシングプロセス中に、Failed to upload PVZ などのエラーによって複数のジョブが失敗することがあります。この問題は通常、アップロードプロセス中のネットワーク中断が原因で発生します。
解決方法
ネットワーク接続が回復したら、これらのエラーについて失敗したキューエントリをリセットすることで、失敗したジョブを Windchill で再サブミットします。失敗したキューエントリをリセットするには、「定期的なキュー保守の実行」のトピックを参照してください。
プラグインリクエストがプロキシタイムアウトエラーで失敗する
UI からのプラグインリクエストが予想以上に時間がかかり、デフォルトの 60 秒の Apache プロキシタイムアウトを超えます。その結果、次のようになります。
実行時間の長いプラグインリクエストは 60 秒後に失敗します。
ページを再表示しても Apache を再起動しても問題は解決しません。
解決方法
タイムアウトの問題を解決するには、AI Parts Rationalization プラグインのタイムアウト値を増やします (例: 120 秒から 300 秒の範囲)。
1. Apache プロキシのコンフィギュレーションファイルを見つけます。このファイルは、プラグインのインストール時に生成されます。
例: /opt/ptc/plugins/AIPartsRationalization/AIPartsRationalization-proxy.conf
2. このタイプのエントリにタイムアウトパラメータを追加します。以下に示す値 (timeout=300) は単なる例であり、すべてのコードエントリは説明の目的で提供されています。
<Proxy balancer://AIPartsRationalization_lb/>
BalancerMember http://localhost:<plugin instance1 port>/Windchill/WCPlugins/partsearch route=AIPartsRationalization1
BalancerMember http://localhost:<plugin instance2 port>/Windchill/WCPlugins/partsearch route=AIPartsRationalization2
BalancerMember http://localhost:<plugin instance3 port>/Windchill/WCPlugins/partsearch route=AIPartsRationalization3
BalancerMember http://localhost:<plugin instance4 port>/Windchill/WCPlugins/partsearch route=AIPartsRationalization4
BalancerMember http://localhost:<plugin instance5 port>/Windchill/WCPlugins/partsearch route=AIPartsRationalization5
ProxySet stickysession=AIPartsRationalization_sticky
</Proxy>
3. 変更を行った後、Apache を再起動します。
問題: Apache を再起動できない
クラスタ設定では、プラグインのインストール中または証明書のローテーション中にノードが停止した場合、ノードがオンラインに戻ったときに Apache の再起動に失敗することがあります。この場合、MethodServer ログにエラーメッセージが表示されます。
解決方法
この問題を解決するには、Apache を手動で再起動します。
問題: インデックシングユーザーのコンフィギュレーションが HTTP 500 エラーで失敗する
インデックシングユーザーのコンフィギュレーションが HTTP 500 エラーで失敗します。このエラーは UI に表示されるほか、「ネットワーク」タブまたは API ログにも表示されます。
原因: インデックシングユーザーに必要な Windchill ライセンスがありません。
解決方法
ライセンス除外グループを使用して、インデックシングユーザーをいずれかの基本ライセンスに追加します。詳細については、「ライセンス除外グループ」を参照してください。
問題: 部品再使用プラグインで「要求された重複サーチが多すぎます。最大数は 15 です」が発生する
プラグインの「インデックス付きデータベースをサーチ」タブで形状の類似性サーチを実行すると、15 回連続してサーチされた後に「要求された重複サーチが多すぎます。最大数は 15 です」というエラーが返されます。
これは正常な動作です。管理者ユーザーがサーチを実行するたびに、新しいサーチエントリが作成されます。過負荷を防止するため、アクティブなサーチは 15 件に制限されています。
一方、ユーザーサーチでは、既存のエントリを再使用し、古いエントリを自動的に削除して、サーチ数を制限内に抑えます。
解決方法
既存の類似性の範囲を使用して「重複部品をサーチ」をクリックすることで、エンドユーザーとしてサーチを実行します。これにより、古いサーチが削除され、新しいサーチのためのスペースが空きます。ユーザーサーチを実行した後、サーチを再試行します。
問題: プラグインのインストールがセキュリティ検証エラーで失敗する
AI Parts Rationalization プラグインのインストールがセキュリティ検証エラーで失敗し、次のメッセージが表示されます: 「セキュリティ検証に失敗したため、AI Parts Rationalization プラグインのインストールに失敗しました。管理者に問い合わせてください。」
原因
このセキュリティエラーは、プラグイン JAR の署名に使用されている Java ビルドが、インストール先のシステム上で実行されている同じ Java バージョンのビルドより新しい場合に発生することがあります。
解決方法
顧客環境で、プラグイン JAR の署名に使用されているのと同じ Java バージョンの最新の Java ビルドが使用されていることを確認します。
プラグインのアップデートに失敗
プラグインをアップデートしようとすると、次のいずれかの理由によってアップデートプロセスが失敗する場合があります。
PTC SaaS Platform からの ZIP ファイルのダウンロードまたはインストールが失敗する。
JAR ファイルの検証に失敗する。
結果
このような場合、プラグインのアップデートは失敗し、既存のプラグインのバージョンは変更されません。
「プラグインマネージャ」ページがフランス語で空白になる
言語がフランス語に設定されている場合、プラグインがインストールおよび実行されていても、「サイト」 > 「プラグインマネージャ」を選択した後、「プラグインマネージャ」ページにコンテンツが表示されません。
解決方法
「プラグインマネージャ」ページを表示するには、次の手順を実行します。
1. サイト管理者としてログインし、「サイト」 > 「ユーティリティ」ページに移動します。
2. 「ビジネス管理」グループの「テキストの調整」をクリックします。これは新しいタブで開きます。
3. 「テキストの調整」「ルート」を展開します。
4. 「テキストコレクション」を右クリックし、「新規文字列オーガナイザー」オプションを選択します。
「新規文字列オーガナイザー」ダイアログボックスが開きます。
5. 「サーチ」アイコンをクリックします。
「ユーザーインタフェースのテキストを選択」ダイアログボックスが開きます。
6. PluginManagerResource をサーチして選択し、「OK」をクリックします。
「新規文字列オーガナイザー」ダイアログボックスに PluginManagerResource という名前が表示されます。
7. 「OK」をクリックします。PluginManagerResource「テキストの調整」の下に追加されます。
8. PluginManagerResource を右クリックし、「編集」を選択します。
9. PLUGIN_RUNNING_STATUS エントリを選択し、「編集」をクリックします。「エントリプロパティを表示して編集」ダイアログボックスが開きます。
10. 「ローカライズ」アイコンをクリックします。「ローカライズ」ダイアログボックスが開きます。
11. 翻訳を編集して、フランス語ロケールの文字列を「実行中」に更新します。
12. 「OK」をクリックします。
13. 「保存」または「完了」をクリックします。
14. 「プラグインマネージャ」の UI を再表示して、更新された値を確認します。
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