Vuforia Studio Tutorials and FAQs > Intermediate > Create a Simple Creo Illustrate Assembly Sequence
  
Create a Simple Creo Illustrate Assembly Sequence
For this example, we use the following assembly:
* 
To view an individual coordinate system for a part, select one of the parts and click Transform. Note that these two coordinate systems are not aligned. The Y-axes are, but the X and Z are not (RGB = XYZ). This is important because when a part is animated with an effect in a sequence, you want to know in which direction to apply the effect and to which coordinate system it is relative to (global or parent). Knowing the orientations of the parts when you begin helps to define the sequences.
1. Open PTC Creo Illustrate.
2. Navigate to File > Import > Embed to import the PVZ file you want to use for the animation sequence.
3. Save the session to create a .c3di file in your working directory.
4. From the Sequence tab, select Add Step and deselect all checkboxes of the sBOM structure, except for the box itself.
5. From the Sequence tab, click Edit to modify the item visibility in the step. For the first step, the selected parts are hidden.
6. In the Edit Step window, select all parts, except for the box, and change End from 100 to 0. Optionally, you can change the Duration of each step to 1.0 seconds.
* 
Use the Preview Sequence or Preview Step actions at any time to make sure that you have captured the correct movement and appearance.
7. Click Add Step and select the checkbox for the last part in the sBOM structure. Make sure that the part is selected (the part is highlighted in blue) to ensure that the effect added in the next step will be effective on this part.
* 
The part selected for the first step is still selected as well.
8. Select Effects > Fly In > +Y.
9. From the Sequence tab, click Edit. Ensure that there is one entry for the part, and one entry for the effect; each has the same duration.
10. In this example, we create steps for the two remaining block parts in the sBOM structure by repeating steps 7-9.
11. The last step in the assembly sequence is to have the last three parts (MS51491-042.PRT) in the structure fly into place from the X direction. Click Add Step and select the checkboxes for the three parts. Make sure that they are all selected (highlighted blue in the structure).
12. Select Effects > Fly In > -X.
13. Save the session, and then select File > Publish to complete the illustration. Publishing creates the PVZ file that is added to your Experience in Vuforia Studio.
14. Verify the final state of the sequence by selecting File > Publish Preview. Use the controls above Play to step through the sequence of steps.
15. During publishing, a .pvz file is created. Add the .pvz file as a resource in Vuforia Studio. The .pvi file is automatically extracted from the .pvz file to be used for displaying sequences in Vuforia Studio.