Data Exchange > Interface > Working with Data Exchange Formats > NX > To Append an NX File to an Existing Part
To Append an NX File to an Existing Part
1. Open a Creo part.
2. Click Model > Get Data > Import. The Open dialog box opens.
3. Select NX File (*.prt) in the Type box. You can also set the file type to All Files (*), Creo Files (.prt, .asm, .drw, .frm, .mfg, .lay, .sec, .dgm, .rep, .mrk, .int, .g, .cem), or Part (*.prt).
4. Select an NX .prt file from the current directory or browse to select the NX file from another location.
5. Click Import. The File dialog box and the Import tab open.
6. Select an NX-specific import profile from the Profile list to replace the import profile in use or click Details and open the NX — Import Profile editor and customize the import settings in the import profile editor.
7. Select other options on the File dialog box before you proceed to use options on the Import tab.
8. Click OK in the File dialog box.
9. Accept the default coordinate system or select another coordinate system on the Import tab to locate the appended data.
10. If the native part file already contains solid geometry, click one of the following buttons on the Import tab:
Add Bodies—Adds the solid bodies of the imported feature to the existing part as new bodies. Solid bodies are created in the existing part for each body of the imported feature. The body structure created in the existing part is the same as the body structure of the source model. Closed quilts do not contribute geometry to the solids. Therefore, separate bodies are not created for closed quilts.
Add Geometry—Merges the solid geometry of the bodies in the imported feature and adds the merged geometry in the default body of the existing part or the body designated as the default. Additional bodies are not created. You must select the Create new body check box on the Body Options tab to create a body with the added geometry. Closed quilts do not contribute to the default body of the existing part.
* 
The Add Geometry option is the default and is available even when an import feature fails to solidify. Repairing the quilts in Import Data Doctor is not needed to insert the imported feature in the existing part.
Remove Geometry—Removes solid geometry from a body of the existing part. You can select a body of the existing part and remove the solid geometry from the selected body.
Add Surfaces—Adds the surfaces of the import feature to the existing part. Does not create additional solid bodies in the existing part.
* 
The Body Options tab is not available on the Import tab when you select Add Bodies or Add Surfaces.
11. Click on the Import tab. The NX *.prt file is inserted as a protrusion, cut, or quilt in the native part. The import log file is automatically generated in the working directory.