Data Exchange > Interface > Working with Data Exchange Formats > Parasolid > To Append a Parasolid Part or Assembly to an Existing Model
To Append a Parasolid Part or Assembly to an Existing Model
1. Click Model > Get Data > Import with a file open to append parts as features of an existing part model.
The File Open dialog box opens.
2. Select Parasolid (.x_t, .xmt_txt, .x_b, .xmt_bin, .x_n, .xmt_neu, .xmt) in the Type box. A list of the following Parasolild file formats with their respective file extensions appear in the current working directory:
*.x_t or *.xmt_txt and *.xmt for the text format
*.x_bor *.xmt_bin for the binary format
*.x_n or *.xmt_neu for the neutral format
3. Click the name of the Parasolid file in a format that you want to append to an existing model, or browse to find the file and then click the name of the file.
4. Click Import. The File dialog box and the Import tab open.
5. Select an import profile from the Profile list to replace the import profile in use or click Details to open the import profile editor, Parasolid — Import Profile, and customize the import profile settings if required.
6. Click OK in the File dialog box.
7. On the Import tab, select a coordinate system as reference to place the imported feature or click Datum > to create an asynchronous coordinate system.
8. If the native part contains solid geometry, select one of the following options to represent the imported geometry as protrusions or solids, surfaces, or cuts:
Add Bodies—Adds the solid bodies of the imported feature to the existing part as new bodies. Solid bodies are created in the existing part for each body of the imported feature. The body structure created in the existing part is the same as the body structure of the source model. Closed quilts do not contribute geometry to the solids. Therefore, separate bodies are not created for closed quilts.
Add Geometry—Merges the solid geometry of the bodies in the imported feature and adds the merged geometry in the default body of the existing part or the body designated as the default. Additional bodies are not created. You must select the Create new body check box on the Body Options tab to create a body with the added geometry. Closed quilts do not contribute to the default body of the existing part.
* 
The Add Geometry option is the default and is available even when an import feature fails to solidify. Repairing the quilts in Import Data Doctor is not needed to insert the imported feature in the existing part.
Remove Geometry—Removes solid geometry from a body of the existing part. You can select a body of the existing part and remove the solid geometry from the selected body.
Add Surfaces—Adds the surfaces of the import feature to the existing part. Does not create additional solid bodies in the existing part.
* 
The Body Options tab is not available on the Import tab when you select Add Bodies or Add Surfaces.
9. Click on the Import tab.