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Preface

Creo Elements/Direct 2D Access is a screen-only View and Plot facility for
integration within an existing CAD system. The Creo Elements/Direct 2D Access
software allows you to easily access any Creo Elements/Direct Drafting format

2D drawing.






The 2D Access User Interface

With Creo Elements/Direct 18.0, a Fluent user interface has been introduced for
2D Access. The Fluent user interface facilitates faster access to commands by
grouping the commands according to their functionality.

The Creo Elements/Direct 2D Access consists of the following elements:
» File Tab on page 12

*  Quick Access Toolbar on page 13

* Ribbon on page 13

» Status Bar on page 14

* Drawing Area on page 15

* Part Browser on page 15

* Context Menu on page 15

* Command Line on page 15
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Figure 1: The 2D Access User Interface

2 3
RlDSR 9 o Untitled - PTC Creo Elements/Direct 2D Access - @ x
1 —= Fie 2D Access | Compare | View o @-

= Cut ﬁ Escale - R View - 47 Generate tedURL - Wievel- S~ L-pr- w v b Show
2

3 Copy [0 symbols | g7 Show - 0 show Hidden @ Show A a-
Paste ait Hidd, ; Bre
Hide = Mogen [F]inquire 2 value - o B
rd Parts Hidden URL OLE Draw | Format Utilities
Part Browser 2 x [Top

cli

W@ Top

@ redran

Ba —t—T—S5

@ new

Last

@, zoom
& Pan

ue
12 center

Recall

7 ——ff————————————————————Command Line 3 X
| > ~

+command BECEEEEE 7 otop -1 T BN —

File tab

Quick Access Toolbar
Ribbon

Part Browser

Context menu
Drawing area
Command line

Status bar

3|~

0NN N kAW~

You can middle-click to perform the following operations:

» Middle-click to end a command.
e Middle-click and rotate to zoom.

* Middle-click and drag to pan.

File Tab

The File button in the upper-left corner of the Creo Elements/Direct 2D Access
window opens the File menu. The File menu contains the following commands:

* New Session: Opens a new window.

* Open: Opens a drawing from the file system.
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*  Print: Prints or plots a drawing. For more information, see Printing and
Plotting on page 119.

* Import/Export: Imports or exports files. For more information, see Finding,
Loading, and Handling Files on page 45.

» Settings: Changes the draw and system settings. For more information, see
Viewing Drawings in Creo Elements/Direct 2D Access on page 57 and
Measuring in Creo Elements/Direct 2D Access on page 69.

Quick Access Toolbar

The Quick Access toolbar is by default at the top of the Creo Elements/Direct 2D
Access window. It provides quick access to frequently-used commands. You can
customize the Quick Access toolbar by adding commands (buttons and menus) to
it.

Ribbon

The ribbon contains commands organized as a set of tabs. On each tab, related
commands are grouped. The following figure shows the different elements of a
ribbon:

Figure 1A: Ribbon
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1. Tab: The available tabs are:

¢ 2D Access

* Compare

¢ View

Group: Commands are placed within groups according to their functionality.

Button: Each button on the ribbon consists of an icon and a label. Some
buttons also contain an arrow along with an icon and label.

The ribbon has the following types of buttons:

The 2D Access User Interface 13



Geometry & Show . .
or (Large or small button with an icon and a label):

Click this button to execute an operation.

&
r:E
Edit W Level - . .

-~ lor (Large or small button with an icon and an arrow not
separated by a line): An arrow indicates the existence of a list. Click this
button to open a list of related commands. When no line separates a
button, the icon and arrow perform the same action.

Hidden hitpd i
Mode~ || .| URE (Large or small button with an icon and an arrow
separated by a line): A line, or separation, between the icon and arrow
indicates that the icon and arrow perform different actions. Click the icon
on this button to execute an operation. Click the arrow to open a list of
related commands. The icon of the last-selected command in the current

session is displayed on the button.

~ Note
The label remains unchanged irrespective of the last selection.

O

O The tooltip displays the name of the command that the icon represents.

O The procedural topics assume that the icon of the default command in a
list is displayed on a button though you may see the icon of your last-
selected command.

Status Bar

The status bar is at the bottom of the 2D Access window and has the following
commands:

C

: Confirms a command or selection.

: Ends the current command.

. 9

: Cancels the current command.

14

: Highlights the active part in the graphics area.
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. =l Switches the full screen mode on and off (alternatively, you can press
FI1).

. : Defines a new viewing window.
. : Displays the last view.

. |:| : Fits the content into the viewport.

The status bar also displays the coordinates at which the cursor is placed in the
drawing area, the name of the current part and the catch range. For more
information on catch, see Changing the Catch Mode on page 70.

Drawing Area
The drawing is displayed in the drawing area. The drawing area is in between the
ribbon and the status bar.

Part Browser

The part browser displays the assembly structure with the parts and subparts, the
unique ID, part-sharing information, scale, and symbol for the part or the subpart.
Press F12 to hide or show the part browser.

Context Menu
The context menu opens when you right-click in the drawing area. The context
menu displays commands from the Viewing group on the View tab.

Prompt Line

The Prompt Line tells you how to proceed to complete the current operation. In the
absence of the Prompt Line, Creo Elements/Direct 2D Access displays the prompt
in the status bar.

You can enable or disable Prompt Line by clicking or clearing the Prompt Line
L=y
check box under 1> | Toolbars in the Viewing group on the View tab, respectively.

Command Line

In the Command Line (user input line) you can type the required values, when
prompted.

You can enable or disable Command Line by clicking or clearing the Command
L=y
Line check box under | | Toolbars in the Viewing group on the View tab,

respectively.
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Customizing the Creo Elements/
Direct 2D Access Ribbon

Creating a User-Defined Command ............oooiiiiiiiiiiiiiee e 19
Modifying a User-Defined Command .............ccoooiiiiiiiiiiiiii e 20
Adding a Button (Command) to the Ribbon..............oooiiii e, 21
Removing a Tab, Group, or Button from the Ribbon.................ccoiiiiiiii 21
AdAING @ TaD ... 22
P o [o [ TaTe =T €1 o 10 ] o PR 23
Adding an Element to the Ribbon............co 24
Renaming a Tab, Group, OF BUEION............ooiiiiiii e e e e 25
Hiding or Showing @ Tab OF @ GrOUP......ccuuuiiiiiiii e 25
Modifying the BUtton Style..........ooooiiii e 26
Changing the Order of a Tab, Group, or BUtton ... 27
Exporting and Re-using a User-Defined Tab ... 28
Exporting Ribbon Customization Settings.............oouvuiiiiiiii e 30
Importing Ribbon Customization Settings ..............oviiiiiiiiiiiii e 31
Restoring the Default Ribbon Settings.........ooooiviiiii 31

You can customize the Creo Elements/Direct 2D Access ribbon to quickly access
frequently-used commands.

You can customize the ribbon by:

* Creating a User-Defined Command on page 19

* Modifying a User-Defined Command on page 20

* Adding a Button (Command) to the Ribbon on page 21

* Removing a Tab, Group, or Button from the Ribbon on page 21
* Adding a Tab on page 22

* Adding a Group on page 23
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* Adding an Element to the Ribbon on page 24

* Renaming a Tab, Group, or Button on page 25

* Hiding or Showing a Tab or a Group on page 25

* Modifying the Button Style on page 26

* Exporting and Re-using a User-Defined Tab on page 28
* Changing the Order of a Tab, Group, or Button on page 27
* Exporting Ribbon Customization Settings on page 30

* Importing Ribbon Customization Settings on page 31
You can customize the ribbon using the Options dialog box.
To open the Options dialog box:

* Click File » Options.

Alternatively, right-click the ribbon and select Customize Quick Access
Toolbar.

The Options dialog box opens. The Customize Ribbon pane is selected by
default.

To apply and view the customized settings, click OK in the Options dialog box.

To cancel the modified settings, click Cancel in the Options dialog box.

18 Inspection with Creo Elements/Direct 2D Access Fluent User Interface



Creating a User-Defined Command

You can create your commands and add them to the Creo Elements/Direct 2D
Access ribbon.

To create a command:

1.

Click File » Options.

The Options dialog box opens. The Customize Ribbon pane is selected by
default.

Click New.

The Create New Command dialog box opens.

In the Command ID area, type a name for the command in the Name box.

-~ Note

Creo Elements/Direct 2D Access displays the specified name as the label
for the button on the ribbon.

Optionally, type a tooltip for the command (button) in the Tool Tip box.
Optionally, type a category for the command in the Category box.

The default category is View.

If you type a new category name, a category is created with the specified
name, and the command is added to the category.

Optionally, in the Icon area, click Browse to select an image for the button.

>~ Note

* Creo Elements/Direct 2D Access supports PNG and BMP images for
buttons.

* Creo Elements/Direct 2D Access partially supports JPG and JPEG images
for buttons. Creo Elements/Direct 2D Access converts these images to
BMP images internally.

In the Command Action box, provide the action (function) details.

See the Creo Elements/Direct Drafting / Creo Elements/Direct 2D Access
Programming Reference Guide for details about functions and commands.

Customizing the Creo Elements/Direct 2D Access Ribbon 19



-~ Note

Creo Elements/Direct 2D Access executes the specified function when you
click the button.

8. Click Add.
The command is now available in the View list of the Choose commands from
box.

~ Note

You must provide at least a name and an action to create a command.

Modifying a User-Defined Command

You can modify the user-defined commands in Creo Elements/Direct 2D Access.

To modify a user-defined command:

1.

5.
6.

Click File » Options.

The Options dialog box opens. The Customize Ribbon pane is selected by
default.

In the Choose commands from box, select User-Defined.

The user-defined commands are listed.
Select the command.
Click Modify.

The Create New Command dialog box opens.
~ Note
Modify is activated only after you select a user-defined command.

Edit the settings.
Click Modify to save the edited settings.

If you want to delete the user-defined command, click Delete in the Create New
Command dialog box.

20
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Adding a Button (Command) to the
Ribbon

You can add the default Creo Elements/Direct 2D Access buttons as well as user-
defined buttons to the Creo Elements/Direct 2D Access ribbon.

To add a button to the ribbon:

1.

Click File » Options.

The Options dialog box opens. The Customize Ribbon pane is selected by
default.

In the Customize the Ribbon list, select the group to which you want to add a
button.

In the Choose commands from box, select the tab name.

The commands on the selected tab are listed.

u Tip
To view the list of user-defined commands, select User-Defined.

Select a command and click Add.

The button for the selected command is added to the group on the ribbon.

Note
You can add buttons to user-defined groups only.

You cannot add buttons directly to a tab.

Removing a Tab, Group, or Button from
the Ribbon

To remove a tab, group, or a button from the ribbon:

1.

Click File » Options.

The Options dialog box opens. The Customize Ribbon pane is selected by
default.

In the Customize the Ribbon list, select the tab, group, or button (command).

. Click Remove.

Customizing the Creo Elements/Direct 2D Access Ribbon 21



The selected tab, group, or button is removed from the ribbon.

~ Note
*  You can remove the user-defined tabs and groups only.

* You cannot remove buttons of the default groups.

o Tip
You can also use the context menu to remove tabs, groups, or buttons.

Adding a Tab

You can add a tab to the Creo Elements/Direct 2D Access ribbon.
To add a tab:

1. Click File » Options.

The Options dialog box opens. The Customize Ribbon pane is selected by
default.

2. In the Customize the Ribbon list, select a tab below which your tab should be
added.

The selected tab is highlighted.

~ Note
+ Ifyou do not select a tab, your tab is added at the end of all tabs.

» Ifanitem is already selected, your tab is added below the parent tab of the
selected item.

3. Click New Tab.

A tab is added below the selected tab. In addition, a group is automatically
added to the tab.

4. Select the tab, click Rename, and specify a name for the tab.
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i Tip
You can also use the context menu to add a tab.

Adding a Group

You can add a group to the Creo Elements/Direct 2D Access ribbon.
To add a group:

1. Click File » Options.

The Options dialog box opens. The Customize Ribbon pane is selected by
default.

2. In the Customize the Ribbon list, select a tab or group.
Ensure that you select a tab or group below which you need to add the group.

The selected tab or group is highlighted.

~ Note

If you do not select a tab or group, your group is added at the end of all
groups of the first tab.

3. Click New Group.
A group is added below the selected tab or group.

4. Click Rename and specify a name for the group.

1 Note
You can add groups to user-defined tabs only.

¢ Tip

You can also use the context menu to add a new group.

Customizing the Creo Elements/Direct 2D Access Ribbon 23



Adding an Element to the Ribbon

You can add the following elements to the user-defined groups in the Creo
Elements/Direct 2D Access ribbon:

* A button with an arrow not separated by a line (Menu)
* A button with an icon and an arrow, and separated by a line (Split Menu)
For details about different types of buttons, see Ribbon on page 13.

* A separator

~ Note

You can also add the default buttons similar to the buttons (created by using
Menu or Split Menu) in the user-defined groups.

To add a new element:
1. Click File » Options.

The Options dialog box opens. The Customize Ribbon pane is selected by
default.

2. In the Customize the Ribbon list, select a group to which you want to add a
new element.

3. Click New Element.

Select one of the following:

* Menu to add a button with an arrow not separated by a line.

For example, .

The button is added at the end of the selected group.

* Split Menu to add a button with an icon and an arrow separated by a line.

Hidden
Mode~

For example,

For details about different types of buttons, see Ribbon on page 13.
The button is added at the end of the selected group.

* Seperator to add a separator.

A separator is added below the selected group.
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> Note
You can also add a separator between two buttons.

5. Click Rename and specify a name for the button (created by using Menu or
Split Menu).

6. To add a command (button) to the button (created by using Menu or Split
Menu), see Adding a Button (Command) to the Ribbon on page 21.

Renaming a Tab, Group, or Button
To rename a tab, group, or button:
1. Click File » Options.

The Options dialog box opens. The Customize Ribbon pane is selected by
default.

2. In the Customize the Ribbon list, click the tab, group, or button.
The selected item is highlighted.

3. Click Rename and specify a name for the tab, group, or button.

The new name is displayed in the Customize the Ribbon list and on the ribbon

after you click OK.

1 Note
You can rename user-defined tabs and groups only.

¢ Tip
You can also use the context menu for renaming elements on the ribbon.

Hiding or Showing a Tab or a Group
You can select the tabs or groups that you want to hide or view on the ribbon.

To hide or show a tab or a group:

1. Click File » Options.

Customizing the Creo Elements/Direct 2D Access Ribbon
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The Options dialog box opens. The Customize Ribbon pane is selected by
default.

2. In the Customize the Ribbon list, clear or click the check box of the tab or
group to hide or show the tab or group, respectively.

Modifying the Button Style

You can modify the appearance of a button on the ribbon.
To modify the appearance of a button:
1. Click File » Options.

The Options dialog box opens. The Customize Ribbon pane is selected by
default.

2. In the Customize the Ribbon list, select a button.

The Modify button is activated.

o Tip
To select multiple buttons in the Customize the Ribbon list:

*  Press SHIFT+[button] for range selection of buttons. Buttons that are
within a group are selected only if the group buttons are expanded.

*  Press CTRL+[button] for individual selection of buttons.

3. Click Modify.
The Modify Button dialog box opens.

4. In the Icon area, click Browse to replace the current icon with a different icon.

~ Note
* Creo Elements/Direct 2D Access supports PNG, and BMP images for
icons.

* Creo Elements/Direct 2D Access partially supports JPG and JPEG images
for icons. Creo Elements/Direct 2D Access converts these images to BMP
images internally.

To reset the icon, click Reset.
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-~ Note

You can change or reset the icon of the following:

* A user-defined button created by using Menu.

* A default button with an icon and an arrow, and not separated by a line.

5. In the Button Layout area, select one of the following:
* Small to display the button as a small button.
* Small - No Icon to display the button as a small button without the icon.
* Large to display the button as a large button.

6. Optionally, click or clear the Hide check box to hide or display the label of the
button, respectively, on the ribbon.

Changing the Order of a Tab, Group, or
Button

You can change the order of a tab, group, or button on the ribbon in Creo
Elements/Direct 2D Access.

To change the order of a tab, group, or button:
1. Click File » Options.

The Options dialog box opens. The Customize Ribbon pane is selected by
default.

2. In the Customize the Ribbon list, select the button, group, or tab.

3. Click E to move up or E to move down.

o Tlp
You can also use the context menu to change the order of a tab, group, or
button on the ribbon.
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Exporting and Re-using a User-Defined
Tab

You can export a user-defined tab and import it to a module. You can export a
single user-defined tab at a time. You can also import a single user-defined tab or
multiple user-defined tabs to a module at a time.

To export a user-defined tab:
1. Click File » Options.

The Options dialog box opens. The Customize Ribbon pane opens by default.
In the Customize the Ribbon list, select the user-defined tab.
Right-click and select Export Tab.

The user-defined tab is exported as an XML file to the Modules subdirectory
of the installation directory. The XML file carries the name of the user-defined

tab and contains information about the commands or buttons on the user-
defined tab.

-~ Note

The Modules subdirectory of the installation directory is the default
directory in which Creo Elements/Direct 2D Access saves the exported
XML file. To change the default directory, use the ME SET MODULE
SEARCH PATH command in the user input line. See ME_SET MODULE
SEARCH_PATH in the Creo Elements/Direct Drafting / Creo Elements/
Direct 2D Access Programming Reference Guide for details.

To import a single user-defined tab or multiple user-defined tabs to a module, use
the REGISTER MODULE command in the user input line to import the XML file
in the Creo Elements/Direct 2D Access user interface. See REGISTER MODULE
in the Creo Elements/Direct Drafting / Creo Elements/Direct 2D Access
Programming Reference Guide for details.

To start or stop the module:

1. Click File » Modules.
2. Select the module.

~ Note

The modules (consisting of user-defined tabs) are removed when you exit
Creo Elements/Direct 2D Access.
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Tip
You can create macro files to perform activities like licensing-related tasks, if
required, when you start or stop the module.

* You can create a macro file in the Modules subdirectory (default) or in the
path specified using the ME_SET MODULE SEARCH PATH command and
the file name must be identical to the name of the user-defined module. For
example, you can create a macro file IBS . m for the user-defined module IBS
and include the load-specific macros in the file. Creo Elements/Direct 2D
Access uses this macro file during the start of the module. Ensure that you
have included the commands required to activate the buttons on the imported
tabs in the macro file. You can also add licensing-related commands to the
macro file.

*  When you stop a user-defined module, Creo Elements/Direct 2D Access
removes the tab of the corresponding module. You can create a macro file in
the Modules subdirectory (default) or in the path specified using the ME
SET MODULE SEARCH PATH command and the file name must be
identical to the name of the user-defined module appended by unload. For
example, you can create a macro file IBS unload.m for the user-defined
module IBS and include the unload-specific macros in the file. You can add
commands to release any licenses acquired for the module or perform the
desired cleanup actions using this macro file.

To import a user-defined tab to the Creo Elements/Direct 2D Access ribbon, use
the IMPORT TAB command in the user input line and import the XML file. See
IMPORT TABand ME SET MODULE SEARCH PATH in the Creo Elements/
Direct Drafting / Creo Elements/Direct 2D Access Programming Reference Guide
for details.
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~ Note

You can specify the name of an existing tab for an imported tab. Importing a
tab with a name similar to an existing tab does not affect the existing tab.
Consequently Creo Elements/Direct 2D Access adds another tab with a similar
name in the Creo Elements/Direct 2D Access ribbon.

The import of user-defined tabs is independent to the registration of user-
defined modules.

The imported tabs are removed when you exit Creo Elements/Direct 2D
Access. Consequently, they are unavailable when you start Creo Elements/
Direct 2D Access next time.

You can modify (add elements to, move the elements, and so on) the imported
user-defined tab or module by starting Creo Elements/Direct 2D Access with the
moduleadmin option:

AN I S

Click Start » All Programs » PTC » Creo Elements Direct 2D Access [version].
Right-click Creo Elements Direct 2D Access [version].

Select Properties.

In the Target box, append -moduleadmin at the end of the existing string.
Click OK.

Note

If you start Creo Elements/Direct 2D Access without using -moduleadmin,
the user-defined tabs are considered as system tabs and you cannot modify
them.

The imported tabs are available in the Creo Elements/Direct 2D Access ribbon
even after you use Reset in the Options dialog box to restore default ribbon
settings.

Exporting Ribbon Customization Settings

You can export the existing customization settings of the Creo Elements/Direct 2D
Access ribbon to a XML file. The same customization settings can be used on
other computers by importing the XML file in Creo Elements/Direct 2D Access.

To export the ribbon customization settings:
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1. Click File » Options.

The Options dialog box opens. The Customize Ribbon pane is selected by
default.

Click Import/Export.

Click Export Customization.

The Choose exported Creo Ul file dialog box opens.
4. Specify the path and the file name for the XML file.

Importing Ribbon Customization Settings

You can import the XML file generated by Export Customization to replace the
existing ribbon customization settings.

To import the ribbon customization settings:
1. Click File » Options.

The Options dialog box opens. The Customize Ribbon pane is selected by
default.

2. Click Import/Export.
3. Click Import Customization.

The Choose exported Creo Ul file dialog box opens.
4. Select the XML file.

~ Note

The imported ribbon customization settings override the existing ribbon
customization settings. It is recommended to export the existing ribbon
customization settings before using Import Customization. You can then use
the exported file to revert to the existing ribbon customization settings, if
required.

Restoring the Default Ribbon Settings

You can reject the changes that you have made for customizing the ribbon. The
default ribbon settings are restored after rejecting the ribbon customization
changes.

To restore the default ribbon settings:

1. Click File » Options.
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The Options dialog box opens. The Customize Ribbon pane is selected by
default.

2. Click Reset.

32 Inspection with Creo Elements/Direct 2D Access Fluent User Interface



Getting Started with Creo
Elements/Direct 2D Access

About Creo Elements/Dir€Ct 2D ACCESS .......uieiiiiiiieeiiii e e e e e e eeeees 34
Starting Creo Elements/DireCt 2D ACCESS ......ccvvuniiiiiieiiiieeee e e e 34
SWItChING LANQUAGES .. ..ouniiiiiiiie ettt e e e e e e e e e e e et e e e e eeen 34
Switching the Beeper On or Off ... oo e 35
Basic WOorking MethOds .........uiiiii e e 35
Exiting Creo Elements/DireCt 2D ACCESS .....ccvuuiiiiieiiie ettt e e e 43
Customizing Creo Elements/DireCt 2D ACCESS......ccceuuuiiiiiiiiieeeeeiie e 43

33



About Creo Elements/Direct 2D Access

Creo Elements/Direct 2D Access provides a full set of commands for viewing,
measuring, and plotting any MI format drawings created in the Creo Elements/
Direct Drafting 2D CAD system. In Creo Elements/Direct 2D Access, you cannot
damage or alter such drawings in any way.

The functionality of Creo Elements/Direct 2D Access is a subset of the Creo
Elements/Direct Drafting functionality. For further details and illustrated examples
of this functionality, refer to the Creo Elements/Direct Drafting User's Guide:
Fluent User Interface in the Creo Elements/Direct Drafting Help Center.

Starting Creo Elements/Direct 2D Access
To start Creo Elements/Direct 2D Access with the standard Fluent UI:

* Click start » All Programs » PTC » Creo Elements Direct 2D Access [version] >
Creo Elements Direct 2D Access [version].

To start Creo Elements/Direct 2D Access with alternative Ul:
e Classic Ul

©  Click Start » All Programs » PTC » Creo Elements Direct 2D Access
[version] » Alternative Ul » Creo Elements Direct 2D Access [version]
(Classic Ul).

*  Windows Ul

O Click Start » All Programs » PTC » Creo Elements Direct 2D Access
[version] > Alternative Ul » Creo Elements Direct 2D Access [version]
(Windows 9x).

Switching Languages

By default, the Creo Elements/Direct 2D Access user interface is displayed in
English. To switch to the language of your choice, type the appropriate command
in the user input line and press ENTER:

Language Command

English change locale 'en'
French change locale '"fr'
German change locale 'de’
Italian change locale 'it'
Spanish change locale 'es'
Japanese change locale 'ja'
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Alternatively, specify this command above the Startup menus string in the
startup.m file contained in the Creo Elements/Direct 2D Access installation
directory.

~ Note

If you installed Creo Elements/Direct 2D Access in Custom mode, any
languages that you did not select during installation will not be available at
Creo Elements/Direct 2D Access runtime.

Switching the Beeper On or Off

Optionally, you can enable or disable the "beeper" in Creo Elements/Direct 2D
Access. Simply type BEEPER ON or BEEPER OFF in the user input line and press
ENTER.

Basic Working Methods

You can quickly and easily delete elements or entire classes of elements from your

k

drawing for visual clarity. The Select buttons help you to select or unselect

given classes of elements.

Deleting Elements

Click %] Delete to delete drawing elements or pieces of text.

For example, to delete everything in the active part:

1. Click < Delete.

2. Click 2D Access and then, in the Utilities group, click R | select » i All.

3. Click ¢ Confirm.

Highlighting Elements Before Deletion

The L™ | Select buttons enable you to select the elements that you want to delete
(or modify).
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1. Click < Delete.

2. Click 2D Access and then in the Utilities group, click R | select and then click
the required button.

Depending upon the selected button, the elements selected for delete are

All. All the

-

highlighted. For example, click R | select and then click b
elements in the drawing get highlighted.

Alternatively, press F2 to open the Select window. Then click Select and All.
All the elements in the drawing get highlighted
3. When you are satisfied that the elements to be deleted have been correctly

selected, click c Confirm.

Global Selection

Each time you select components, you can decide whether you want to select from
the current part or from the whole parts tree. Global selection allows you to select
components from the whole parts tree:

* In the Select window, click Select, Global, and All.
If you do not click Global, Creo Elements/Direct 2D Access defaults to the

current part.

Example

€

1. Click 2D Access and then, in the Utilities group, click Delete.

2. In the Utilities group, click k Select » Advanced.
The Select window opens.
Alternatively, press F2 to open the Select window.

3. Click Select, Global, All, Confirm and OK.

This command string deletes all components of the parts tree even if the active
part is not the top part.

It should, however, be noted that even though all components (geometry,
construction geometry, and text) contained within the parts tree will be deleted, it
is not possible to delete the complete parts tree. The current part is never deleted
and a path linkage to the top part is always maintained.
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Selecting Drawing Elements

Click Select to let Creo Elements/Direct 2D Access know you are about to make a
selection. Then press any option or combination of options from the selection
block.

All options on the selection block can be chosen directly without clicking Select.
However, if you do not click Select first:

* The elements you choose will not be highlighted on the screen for you to view
before the operation of your choice. For example, deleting will be performed
immediately.

* You will not be able to use the options Add, Subtract, Not, and so forth.

~ Note

If you want to select elements drawn in a particular color or linetype, you must
first click Select and then specify the respective color or linetype.

Example

€

1. Click 2D Access and then, in the Utilities group, click Delete.

e[k
2. In the Utilities group, click Select » LMl Advanced.

The Select window opens.

Alternatively, press F2 to open the Select window.
3. Click Select and then click Color.

The Color dialog box opens.
4. In the Color box, select Green and then click OK.
5. Click Confirm and then click OK.

This deletes all elements drawn in green in the current part.

Adding Elements to Your Selection

This option allows you to add elements, either selected individually or enclosed in
a box, to your current selection. For example:

1. Click %] Delete.
2. Press F2 to open the Select window.
3. Click Select.
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4. Select several elements to be deleted.

5. Click Add.

6. Click Box.

7. Enclose further elements to be deleted in a box.
8. Click Confirm.

9. Click OK.

Subtracting Elements from Your Selection

To subtract elements from your current selection, click Subtract in the Select
window.

Removing Elements from Your Selection

Click Not in the Select window to make the previous selection result unselected,
and all previously unselected elements to be treated as selected.

~ Note
Not always works globally on all parts.

Enclosing Elements in a Box

To select a group of drawing elements by enclosing them in a box:
1. Click Box in the Select window.

2. Enclose the required elements in a box.

The elements are shown in a different linetype and Creo Elements/Direct 2D
Access prompts you to confirm that you want to delete them. Before you click
Confirm, you may want to alter your selection by, for example, subtracting or
adding some elements.

3. Click confirm.
4. Click OK.

Enclosing Elements with a Polyline

If you need greater flexibility when selecting elements, use Polygon to
enclose elements within a polyline. This is particularly useful when elements are
not symmetrically grouped horizontally and vertically.
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Figure 2. Selecting Elements with Polyline
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Suppose you want to delete the elements 1, 2, and 3:

Click & Delete.

Click 2D Access and then, in the Utilities group, click Select »

Polygon.

Alternatively, press F2 to open the Select window and then click Poly.

Click a succession of points to define the enclosing polygon around elements
1,2, and 3.

Close the polygon by clicking the start point again or type CLOSE in the user
input line and press ENTER.

Selecting All Elements

To select everything contained in the current part (and subparts):

Click & Delete.

1
2. Press F2 to open the Select window.
3.
4

Click All.
Click OK.

Creo Elements/Direct 2D Access prompts you to click Confirm if you really

want to delete all elements selected. If not, click 9 Cancel and select again.

Click c Confirm.

Click OK.

Selecting a Vertex

Click Vertex in the Select window if you want to delete all elements that share a
specified point.

Getting Started with Creo Elements/Direct 2D Access
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Selecting Elements by Type

The Select window facilitates the selection of specific element types in your Creo
Elements/Direct Drafting drawing.

Selecting Elements Using Information Strings

Click Info in the Select window to select all elements that have a particular
information string associated with them. You are prompted to type the information
concerned.

Selecting Layers

Click Layer in the Select window to select all elements assigned to a specified
layer. When you choose this option, Creo Elements/Direct 2D Access prompts
you for the layer information.

Selecting Text

Click Text in the Select window to select the required text. Creo Elements/Direct
2D Access prompts you to identify the text to be selected.

Selecting Reference Lines

Click Ref Line in the Select window to select reference lines.

Selecting Construction Geometry

Click CGeo in the Select window to select and highlight construction geometry.
Alternatively, click CCircle to select construction circles only or click CLine to
select construction lines only.

Selecting Drawing Geometry

Click Geo in the Select window to select and highlight drawing geometry.
Alternatively, you can:

* Click Line to select lines.

» Click Circle to select circles.
* Click Arc to select arcs.

* Click Spline to select splines.
» Click Fillet to select fillets.

* Click Point to select points.

» Click Poly El to select polyline elements.
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To make a selection on pensize or linesize

1. Click Line Size or Pen Size in the Select window.
2. Type a value (for example, 2).

3. Click Confirm.

4. Click OK.

Selecting Parts

Click Part in the Select window to select elements in a particular part. Also, you
can click Subtree to select a subtree of a part or assembly.

Example

To delete a selected part from anywhere in the parts tree:

Click © Delete.

1

2. Press F2 to open the Select window.

3. Click Select, Global, Part, and OK.

4. Type the part name in the user input line and press ENTER.

5. Click c Confirm.

6. Click OK.

~ Note
When deleting a part, you automatically delete all associated subparts.

Selecting Dimensions

Click Dim in the Select window to select and highlight dimensions. Alternatively,
click Edit Dim in the Select window to select edited dimensions only.

Selecting URLs
Click URL in the Select window to select and highlight URLs.

Confirming Commands

C

Click Confirm to confirm that the deletion or modification you have defined
should be implemented.
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Pasting Elements from Other Applications

When you have cut or copied an item, you can paste this item such that it is owned
by the current part using the As Subpart button.

To use As Subpart:

1. Click 2D Access and then, in the Clipboard group, click the arrow next to -
Paste.

2. Click As Subpart.

Refer to Linking and Embedding OLE Objects on page 113 for instructions on
linking and embedding OLE objects in Creo Elements/Direct 2D Access.

Undo and Redo

In Creo Elements/Direct 2D Access, you can undo mistakes with Undo or
]

Redo:

*  On the Quick Access Toolbar, click
+Z.

to undo an operation or press CTRL

*  On the Quick Access Toolbar, click I to redo an operation (after you have
-.l!:I

clicked Undo) or press CTRL+Y.

Each time you click | undo or L™ Redo, you undo or redo all the changes that

were created by the last button you clicked.

You can set a limit on the number of steps to keep in the K Undo history in the
System dialog box.
—

1. Click File » Settings » |—Q System.

The System dialog box opens.

Click Environment.
3. In the Undo area, click one of the following:

*  Click Unlimited to allow unlimited number of steps for | undo.

* Click Max steps and type the maximum number of steps allowed in the
)

Undo history.
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Limitations:

*  You can undo or redo complete macros, but you cannot use g, Undo or L
Redo inside macros.
. 2 Undo or | Redo cannot undo or redo:

O Commands related to parametric design or hidden lines.
Once you have executed one of these commands, you can no longer undo
or redo any of your previous commands.

© The RESET SYSTEM command.

© Commands for default settings (although these commands do not affect the

2 Undo or i

Redo history).

Undo and Redo with state history
Each time you enter a command and change your drawing, Creo Elements/Direct

2D Access adds a new state to the L | Undo or || Redo history. Creo Elements/

Direct 2D Access marks the new state with a unique ID. You can use several
commands to work with these unique IDs. For further information, see the Creo
Elements/Direct Drafting / Creo Elements/Direct 2D Access Programming
Reference Guide.

Exiting Creo Elements/Direct 2D Access
To exit Creo Elements/Direct 2D Access, click File and then click Exit.

Creo Elements/Direct 2D Access prompts you to save changes, if any, before
exiting.

Customizing Creo Elements/Direct 2D
Access

You can quickly and easily customize Creo Elements/Direct 2D Access for your
personal requirements. Detailed instructions are provided in the Customizing Creo
Elements/Direct 2D Access on page 147 chapter.
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This chapter assumes that you are familiar with the directory structure and general
file handling methods of your computer.
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Using the File Browser

You can open a drawing file quickly and easily by means of the Creo Elements/
Direct 2D Access File Browser. This File Browser adheres to standard MS
Windows conventions. You do not need to remember long filenames and
subdirectories as these are displayed. (You can still enter the file name in the
command line if you wish.)

You can close the File Browser once the drawing has been opened or saved.
Optionally, you can leave the File Browser open for further selections.

In the File related dialog boxes, the File Browser provides the following icons:

¥ Moves up one level in the directory hierarchy.

Creates a new folder (directory) on the current directory level.

Displays files and directories in various views. You can choose
the following views:
*  Thumbnails

* Tiles

* lcons

* List

* Details

In the dialog boxes associated with the File Browser, you can move, copy and
delete files and directory using standard MS-Windows techniques.

Opening a Drawing File Using the File Browser

To open a drawing file by means of the Creo Elements/Direct 2D Access File
Browser:

1. Click File » =1 Open to display the File Browser.

=]

Alternatively, click .| Open on the Quick Access Toolbar or press CTRL+O.

2. If the file you want to open is not listed in the File pane of the File Browser,
select the directory that contains the file in the Directory box.

If this directory is specified in the File pane, double-click the directory name
to list the files contained in it.

3. Click the filename.

If a file is in a format other than MI (the default), then in the Filter box, click
the applicable format:
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Model Interface Standard (*.mi)
Compressed MI (*.bi)
Bundle (*.bdl) (Creo Elements/Direct Modeling Bundle files)

~ Note

Only the 2D portions of such files are extracted, while any 3D portions
are ignored.

Autodesk Drawing Interchange (*.dxf)
Initial Graphics Exchange Format (*.igs)
AutoCAD File Specification (*.dwg)
JPEG - JFIF Compliant (*.jpg)

Portable Network Graphics (*.png)
Tagged Image File Format (*.tif)
Windows or OS/2 Bitmap (*.bmp)

All files (*.%)

A preview image of the drawing file is displayed in the preview pane of the
File Browser.

Optionally, click the following check box:

Check 2D Creo Elements/Direct 2D Access checks this file

for invalid elements (such as extremely short lines)
and removes such elements.

Check 2D Retain Creo Elements/Direct 2D Access reallocates
Dependency dependent elements (such as dimensions or

hatches) of removed invalid elements to plausible
valid elements.
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Overwrite fonts In some cases, a font may have been saved with an
MI file. Creo Elements/Direct 2D Access
automatically loads this font when you load the
file. However, if the font in the file matches a font
name already in your system, you can instruct Creo
Elements/Direct 2D Access to overwrite your
system font with the file font by clicking this box.

Discard fonts In some cases, a font may have been saved with an
MI file. Creo Elements/Direct 2D Access
automatically loads this font when you load the
file. If you do not want new fonts loaded, click this
check box.

5. Click Open to open this file in Creo Elements/Direct 2D Access.
Alternatively, type the filename in the Name box and press ENTER.

6. Once the drawing is displayed in Creo Elements/Direct 2D Access, you can
view and measure it.

~ Note
The preview image is pixel-based. It cannot be modified.

Opening a Drawing File by Means of the Navigator

The Creo Elements/Direct 2D Access Navigator provides a scrollable sequence of
preview images of the drawing files in the current directory. The Navigator thus
facilitates the selection of drawings.

To open a drawing file by means of the Creo Elements/Direct 2D Access
Navigator:

1. Click File » |~ | Open to display the File Browser.

Za

Alternatively, click 1 Open on the Quick Access Toolbar or press CTRL+O.
2. Click Navigator to display the Creo Elements/Direct 2D Access Navigator.

The Navigator displays a preview image for each file provided in the formats
listed above.
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3. In the left pane of the Navigator, click the directory whose drawing files you
want to view.

4. In the right pane of the Navigator, double-click the preview image to open its
associated drawing file in Creo Elements/Direct 2D Access.

Once the drawing is displayed in Creo Elements/Direct 2D Access, you can view
and measure it.

~ Note

To return to the File Browser, simply close the Navigator.

Opening Most Recently Used Drawing Files

By default, the four most recently used drawing files are listed (complete with
filetype extension) in the Creo Elements/Direct 2D Access File menu. To load one
of these files:

1. Click File.
2. Under Recent Documents, click the name of the drawing file you want to
open.

Creating a New Creo Elements/Direct 2D
Access Instance

Optionally, you can run multiple instances of Creo Elements/Direct 2D Access at
the same time.

To create a new Creo Elements/Direct 2D Access instance:

* Click Start » All Programs » PTC » Creo Elements Direct 2D Access [version] »
Creo Elements Direct 2D Access [version].

~ Note
* Each instance runs in a separate window.

» All Creo Elements/Direct 2D Access instances are independent of each other.
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Importing Macros, Fonts and HPGL Files

You can import the following files into your current Creo Elements/Direct
Drafting drawing:

Parts and Subparts

Creo Elements/Direct Drafting Macros
Fonts

HPGL Files

Importing a Part
To load a part:

1.

=

Click File » Import/Export » L= Import Part.

The Load File dialog box opens.

If the file that you want to import is not listed in the File pane of the File
Browser:

a. In the Directory box, select the directory that contains the drawing file that
you want to import.

b. Double-click the directory.

If the directory is specified in the File pane, double-click the directory name to
list the files contained in it.

Click or specify the filename.

4. Ifafile is provided in a format other than MI (the default), then in the Filter

50

box, select the applicable file format. Refer to Opening a Drawing File Using
the File Browser on page 46 for a list of supported formats.

Optionally, you can click any or all of the following check box:

As Subpart Loads a drawing as a subpart of the active part.

Keep Scale The original drawing scale is retained when the
drawing file is loaded.
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5.

Check 2D Creo Elements/Direct Drafting checks this file
for invalid elements (such as extremely short
lines) and removes such elements.

Check 2D Retain Creo Elements/Direct Drafting reallocates
Dependency dependent elements (such as dimensions or
hatches) of removed invalid elements to plausible

valid elements.

Click Open to add the file as a part to the current drawing in Creo Elements/
Direct 2D Access.

Creo Elements/Direct 2D Access automatically loads the part into the position,

relative to the origin, in which it was originally created.

~! Note

Creo Elements/Direct 2D Access loads the file immediately below the top

part.

Importing a Subpart

You can import a part file as a subpart under the active part.

To import a subpart:

1.

Finding, Loading, and Handling Files

S

Click File » Import/Export » = | Import Part.

The Load File dialog box opens.

If the file that you want to import is not listed in the File pane of the File
Browser:

a. In the Directory box, select the directory that contains the drawing file that
you want to import.

b. Double-click the directory.

If the directory is specified in the File pane, double-click the directory name to
list the files contained in it.

Click the As Subpart check box.
Click or specify the filename.
If a file is provided in a format other than MI (the default), then in the Filter
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box, select the applicable file format. Refer to Opening a Drawing File Using
the File Browser on page 46 for a list of supported formats.

6. Click Open to add the file as a subpart to the current drawing in Creo
Elements/Direct 2D Access.

Creo Elements/Direct Drafting automatically loads the part into the position,
relative to the origin, in which it was originally created.

~ Note

Creo Elements/Direct 2D Access loads the file as a part. The part belongs to
the active part and is placed under it in the parts hierarchy.

Importing a Creo Elements/Direct Drafting Macro

To import a Creo Elements/Direct Drafting macro:

i
Click File » Import/Export » Import Macro.
2. Click Macro.

3. Click one of the following:
*  Click Input Macro to import a macro provided in the ASCII format.
The Input Macro dialog box opens.
* Click Load Macro to import a macro provided in the binary format.
The Load Macro dialog box opens.
4. Select the macro.

Click Open to open the macro in Creo Elements/Direct 2D Access.

Importing a Font

To import a font:

hd>
Click File » Import/Export » Import Font.

2. Click Load Font to import a font provided in the binary format.
The Load Font dialog box opens.

3. Select a font and then click Open to load the font for use in Creo Elements/
Direct 2D Access.
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Importing an HPGL File

Creo Elements/Direct Drafting enables you to load HP-GL and HP-GL2 files.
To import a HP-GL (Hewlett-Packard Graphics Language) or HP-GL2 file:

1.

Exporting Macro, Pictures, and Images

Click File » Import/Export » [‘;} Import HPGL.

The Load HPGL/2 file dialog box opens.

Select the HPGL/2 file.

Click Open to open the file in Creo Elements/Direct 2D Access.
Specify the position for the imported HPGL/2 file.

You can export the following from your current Creo Elements/Direct 2D Access
session:

Creo Elements/Direct 2D Access Macros
Pictures

Images

Exporting a Macro

To export a Creo Elements/Direct Drafting macro:

Click File » Import/Export » |—: Export Macro.
Click one of the following:

* Click Save Macro to export and save a macro in the ASCII format.

* Click Store Macro to export and save a macro in the binary format.

The Select Macro dialog box opens.

. In the Name box, select a macro.

Optionally, click the All check box to select all macros.
Click OK.

The Save Macro dialog box opens.

5. In the Name box, type or select a macro file name (* . m).

Click Save to save the macro file.

Finding, Loading, and Handling Files
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Exporting a Picture

Creo Elements/Direct 2D Access allows you to export pictures in various image
formats.

To export a picture:

Click File » Import/Export » s Export Picture.
Select a single picture for export.

Type the name of the destination file with the desired file format (JPG, PNG,
TIF, or BMP) and press ENTER.

Exporting as Image

Creo Elements/Direct 2D Access allows you to export a drawing as an image in
high resolution pixel format.

To export a drawing as an image:

Click File » Import/Export » s Export as Image.
2. Click one of the following:

* Export as BMP
* Export as JPEG
¢ Export as PNG
* Export as TIFF

3. To specify input, type PORT, BOX, or DEL_OLD in the user input line and
press ENTER.

Alternatively, type the name and the destination path for the drawing image
file in the user input line and press ENTER to directly obtain the drawing
image at the specified destination path.

4. Ifyou type PORT in the user input line and press ENTER:

a. Click a point, or type CURRENT or the viewport number in the user input
line and press ENTER.

b. Type RESOLUTION or destination for the drawing image file in the user
input line and press ENTER.

To specify the resolution for the drawing image, type RESOLUTION in the
user input line and press ENTER. Then perform the following steps:

* Type PAPER TO PIXELS in the user input line and press ENTER.
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Creo Elements/Direct Drafting recalculates paper format and dpi to X,
Y resolution. You are then prompted for a paper format (A-E, A4-A0)
or size, and then for the dpi.

* Type the width and height of the pixels. Type -1 for either width or
height to retain the ratio of the current viewport and specify the other
dimension in pixels.

5. If you type BOX in the user input line and press ENTER:
a. Enclose the required drawing area in a box and press ENTER.

b. Type the name and the destination path for the drawing image file in the
user input line and press ENTER.

Possible error messages are:

* Not enough memory available to perform the operation.

« ***The output image size is limited to a maximum of 4/3 billion pixels.

Finding, Loading, and Handling Files
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Viewing Drawings in Creo
Elements/Direct 2D Access

UsIiNg VIEW FUNCHONS ... .o e 58
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Selecting What is Displayed on YOUr SCre€n ............coooiviiiiiiiiiiiiiceie e 65

This chapter describes how to view a drawing in Creo Elements/Direct 2D
Access.
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Using View Functions

This section describes how to control the area of the drawing shown in the current
viewport using the buttons in the Viewing group on the View tab.

Viewing a Drawing in the Full Screen Mode

To view your drawing in the Full Screen mode:

=]

Alternatively, press F11 to toggle between the Full Screen mode and the
normal mode.

» Click View and then, in the Viewing group, click Full Screen.

Redrawing

To redraw the drawing in the chosen viewport:

K|

This is sometimes necessary if you have deleted several elements and traces are
still visible on the screen. The contents of other viewports are not redrawn.

* Click View and then, in the Viewing group, click Redraw.

Fitting a Drawing

To fit the current drawing in the selected viewport:

* Click View and then, in the Viewing group, click |:| Fit.

Panning Across a Drawing

Panning is a very useful function enabling you to move across the drawing to see
those areas not currently displayed.

To pan in any direction:

[+

1. Click View and then, in the Viewing group, click L= Pan.

2. Click a point in your drawing.
3. Specify the new screen position for this point.

Alternatively, middle-click and drag to pan to the new position.

Creating a New View in a Window

To create a new window:
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1. Click View and then, in the Viewing group, click = Window.

2. Specify the two points (corners) of the area you want to enlarge.

Restoring the Last View

To return to the previous view:

* Click View and then, in the Viewing group, click (<] Last.

Zooming In or Out
A window is always zoomed about its center point.

To zoom your window:

e g

=,

Zoom.

1. Click View and then, in the Viewing group, click
2. Type a zoom factor in the user input line and press ENTER.

A number greater than 1 results in a window that covers a smaller area
(zooming in). A number less than 1 (>0) or negative (<-1) gives a larger
coverage (zooming out).

Alternatively, move the mouse towards the screen to zoom-in or move the mouse
away from the screen to zoom-out and click a point in the viewport.

Storing and Recalling Windows

If you are likely to need the same view again, you can store it and recall it as
required

To store the current window coordinates:
» Right-click the viewport and click Store.
To recall the window that was stored last:

» Right-click the viewport and click Recall.

Creating a New Center Point for Your Drawing
To specify the new center point for the display:

[+]

Your drawing is repositioned so that this point is in the center of the chosen
viewport.

Center.

* Click View and then, in the Viewing group, click
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~ Note

[+] Center uses the current catch mode to identify the specified point.

Using Viewports to Display Several Views

You can divide the drawing area of the screen so that more than one view can be
displayed. This is a very useful feature when you want to work on a detail
drawing. The changes made to the detail are automatically repeated in the main
drawing. Each division of the screen is called a viewport.

Viewports can be overlapped with other viewports. All viewports are continuously
updated.

In the following example, the view in viewport 1 can be imagined as the view you
would see if you were examining your drawing with a magnifying glass. To
achieve this effect, simply zoom in to the drawing displayed in viewport 1 until
you can see the required level of detail.

* Viewport | — contains a magnified view showing the required level of detail.

* Viewport 2 — contains the entire drawing and is used as a positional reference
for the magnifying glass.

Examine the zoomed drawing in viewport 1 while moving the cursor (as a
positional reference) in viewport 2. See Figure 3. Using Viewport 2 as a Reference
on page 61 and Figure 4. Viewing Piston Assembly Detail in Viewport 1 on page
62.
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Figure 3. Using Viewport 2 as a Reference
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Figure 4. Viewing Piston Assembly Detail in Viewport 1
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Creating a Viewport

To create a new viewport:

1. Click View and then, in the Window group, click - New.

2. Specify the new corner points for the new viewport.

The new viewport is marked by a sequential number in the top-right corner.

Making a Viewport Current

If a viewport is partially or totally covered by other viewports, it is made inactive.
Its visual contents are not updated by any subsequent operations unless it is made
the current viewport.

The current viewport is the one that is currently active, fully visible and up-to-
date. The viewport number is displayed in inverse video in the top-right corner.

To change the current viewport:

1. Click View and then, in the Window group, click Current.
2. Click the viewport required.
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Alternatively, type the viewport number in the user input line and press
ENTER.

Changing the Size of a Viewport
To change the size of a viewport:

1. Click View and then, in the Window group, click Change.
2. Click the required viewport.

3. Specify the new corner points of the viewport.

Moving a Viewport

To move a viewport:

1. Click View and then, in the Window group, click Move.
2. Click the viewport.

3. Drag the cursor to the new position in the viewport.

The contents of the viewport follow the viewport.

Redrawing a Viewport

To redraw a viewport:

1. Click View and then, in the Window group, click = Redraw.
2. Click the viewport.

The contents of the viewport are redrawn.

Maximizing the Size of a Viewport

You can maximize the size of any viewport such that the viewport occupies the
entire Creo Elements/Direct 2D Access drawing area.

To maximize the size of the viewport:
1. Click View and then, in the Window group, click Large.
2. Click the viewport.

Any other viewport are now hidden behind the maximized viewport. To bring any
of these hidden viewport to the foreground, make it current. To change the size of
the maximized viewport, use Change.
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Deleting a Viewport

To delete a viewport:

Click View and then, in the Window group, click Delete.

2. Click the viewport.

Alternatively, type the viewport number in the user input line and press
ENTER.

Deleting All Viewports

To delete all viewports:

|

1. Click View and then, in the Window group, click Delete.

2. Type ALL in the user input line and press ENTER.

~ Note

To view your current drawing in Creo Elements/Direct 2D Access after you
have deleted all viewports, you need to create at least one new viewport.

Viewport Settings
The viewport settings are defined in the Viewport Settings dialog box.
To define the viewport settings:
1. Click File » Settings > Viewport.
The Viewport Settings dialog box opens.
2. In the Border area:
a. In the Color box, select a color for the viewport border.
b. In the Width box, type the viewport border width.
3. In the Color of area:
a. In the Background box, select the background color.
b. In the Text box, select the color of the text.
c. In the Cursor box, select the color of the cursor.

4. In the Invert area, select one of the following in the Invert Color box to invert
display colors in a viewport:

*  White elements
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If you select White elements, the elements that are white (or almost white)
are displayed in black. This is the default for the Creo Colors color
scheme.

* Black elements

If you select Black elements, the elements that are black (or almost black)
are displayed in white. This is the default for the CoCreate Colors color
scheme.

e Off

If you select Off, element colors are not inverted in the viewport.
5. Click OK.

~ Note
The viewport colors are defined by the selected color scheme.

Selecting What is Displayed on Your
Screen

This section describes how to use the Show dialog box to control exactly what is
displayed on your screen.

To open the Show dialog box:
* Click File » Settings » Show.
Alternatively, click 2D Access and then, in the Utilities group, click Show.

>~ Note

Before you plot your complete drawing, you are recommended to check what
is included by clicking Show All in the General tab of the Show dialog box.

You can selectively display or hide:

+ Construction geometry

*  Geometry

* Dimensions
* Hatch

o Text
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e Vertex

* Info

* Layers
« URLs
~ Note

» The Show settings apply to the current viewport.

* Any new viewports created automatically adopts the settings of the viewport
that was active when they were created.

Showing All Features

To display all the features of your drawing:

1. Click File » Settings » Show.
Alternatively, click 2D Access and then, in the Utilities group, click Show.
The Show dialog box opens.

2. On the General tab, click Show All.

It is useful to start with everything displayed, and then clear the check box of
items that are not required.

Showing Points

To display all existing points on the drawing:

1. Click File » Settings » Show.
Alternatively, click 2D Access and then, in the Utilities group, click Show.
The Show dialog box opens.

2. On the General tab, click the Vertex check box.

This is useful if you want to identify a point more accurately, or to check if two
lines overlap. Points are displayed in the following colors (by default):

*  GREEN — end points

* YELLOW — common end points

* BLUE — single center points

*  MAGENTA — multiple center points
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Showing Dimensions

To display all dimensions on a drawing:

1.

Click File » Settings » Show.

Alternatively, click 2D Access and then, in the Utilities group, click Show.

The Show dialog box opens.

On the General tab, click the Dimension check box to display all the
dimensions.

Changing the Layer Color

To change the color of a specified layer:

1.

A

Click File » Settings » Show.

Alternatively, click 2D Access and then, in the Utilities group, click Show.

The Show dialog box opens.
Click the Layer tab.

Select the layer number.

In the Color box, select a color.
Click Color.

Displaying Infos

To display elements that contain attached infos:

1.

Click File » Settings » Show.

Alternatively, click 2D Access and then, in the Utilities group, click Show.

The Show dialog box opens.
Click the Info Elem. tab.
Select the info to be displayed.

Click On to display elements that have information attached.

Setting the Redraw Mode

When working with large or complex drawings, you may want to change the
redraw mode in order to enhance the graphics performance.

To define settings for the redraw mode:

1.

=)
Click File » Settings » System.

Viewing Drawings in Creo Elements/Direct 2D Access
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The System dialog box opens.
Click Redraw Mode.

In the Parts as Box area:

a. Inthe Smaller than box, type a size threshold (in pixels) below which parts
are only shown as boxes.

b. Optionally, in the Box Color box, select a color.
In the Draw Dynamic area:
a. Click the check box of the items that you want to include in the redraw.

b. Clear the check box of the items that you want to exclude from the redraw
to enhance performance.

Click OK.
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Measuring in Creo Elements/Direct
2D Access
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This chapter describes how to measure in Creo Elements/Direct 2D Access. The
combination of Catch and Measure functions provides a powerful tool for fast and
accurate measurements.
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Changing the Catch Mode

The Catch box enables you to select a point on the screen without putting the
cursor directly on that point. The cursor automatically "snaps" to this point. The
current catch mode is always displayed in the status bar. The system will catch to
a given point only if the point lies within the (imaginary) circle around the edges
of the cursor.

By default, the catch mode is set to All. You can change the catch mode to any of
the following:

Setting Catches to
VERTEX Vertex

ELEM Element
INTERSECTION Intersection
CENTER Center point

GRID Ruler/grid point
OFF Switches Catch off

Select the catch mode in the Catch box on the status bar.

When Catch is set to All, Creo Elements/Direct 2D Access catches using the
following order of priority:

1. VERTEX

2. INTERSECTION
3. RULER/GRID
4. ELEM

If the system finds a vertex within the catch range it catches to the closest such
vertex; otherwise it searches for intersections and so on. If the system can't find
any of these, it uses the given input point.

Measuring Distances

Creo Elements/Direct 2D Access allows you to obtain values for arc lengths,

distances, point coordinates, angles, and areas using 7 H Measure buttons. These
buttons are useful if you need to enter a value measured from existing features on
the drawing. To illustrate this, consider the following example:

Example

Suppose you want to draw a vertical line starting at 100,100 and of the same
length as an existing line drawn at an angle of 40 degrees:
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A

1. Click 2D Access and then, in the Utilities group, click Measure.

2. Click I—EEI Length.
3. Click the existing line.

The measured length of this line is displayed in the user input line.

~ Note

A

* The Follow function is not active while Measure is active.

Measuring Distance

To measure distance between any two points:

A

Measure.

1. Click 2D Access and then, in the Utilities group, click

2. Click Distance.

3. Click the begin point and the end point in the drawing to measure the required
distance.

The distance between the two points is displayed in the user input line.

Measuring a Radius

To measure the radius of a curved element:

A

Measure.

1. Click 2D Access and then, in the Utilities group, click

Click @ Radius.

3. Click the curved element whose radius you want to measure.

The radius of the curved element is displayed in the user input line.

Measuring Lengths

To measure the length of any element (line, circle, arc, fillet, chamfer or spline):

A

Measure.

1. Click 2D Access and then, in the Utilities group, click

2. Click I—EEI Length.
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The length of the element is displayed in the user input line.

Measuring Horizontal Distances

To measure horizontal distance between two points:

A

1. Click 2D Access and then, in the Utilities group, click Measure.

2. Click |—:'=| Horizontal.

3. Click two points in the drawing to identify the horizontal distance you want to
measure.

The horizontal distance between the two points is displayed in the user input
line.

~ Note
This option is dependent on the current catch mode.

Measuring Vertical Distances

To measure vertical distance between two points:

A

1. Click 2D Access and then, in the Utilities group, click Measure.

2. Click Ii_EI Vertical.

3. Click two points in the drawing to identify the vertical distance you want to
measure.

The vertical distance between the two points is displayed in the user input line.

~ Note
This option is dependent on the current catch mode.

Displaying Point Coordinates

To display the exact coordinates of any existing point:
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A

1. Click 2D Access and then, in the Utilities group, click Measure.

2. Click Point.
3. Click the point.

The exact coordinates of this point are shown in the user input line.

~ Note
This option is dependent on the current catch mode.

Measuring Angles

To measure the angle between two lines:

A

Measure.

1. Click 2D Access and then, in the Utilities group, click

2. Click Angle.
3. Click a point on the first line.

4. Click a point on the second line.
Similarly, to measure an arc segment angle, click the arc start and end points.

The angle between two tangents drawn at an intersection point of two circles can
be measured by clicking a point on the first circle and then a point on the second
circle.

Measuring Area Properties

A Single Face

To calculate the area and area properties of a selected face, the face must be
completely bounded by elements.

Creo Elements/Direct 2D Access calculates and displays the following area
properties for a single face:

* Number of holes in the face.

» Density of the face.

» Perimeter length of the face (outer perimeter).
* Area.

* Center of Area (= Center of Mass).
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* Principal Axes (of Inertia through the Center of Area).

* Second Moments of Area about principal axes.

* Second Moments of Area about coordinate system axes.

* Product of Second Moment of Area about coordinate system axes.
* Moments of Inertia about principal axes.

*  Moments of Inertia about coordinate system axes.

* Product of Moment of Inertia about coordinate system axes.
* Section Moduli (about principal axes).

» Distance from first neutral axis to extreme fiber.

» Distance from second neutral axis to extreme fiber.

* Radii of Gyration.

* Angle between coordinate system and principal axes.

Multiple Faces

If you identify multiple faces, Creo Elements/Direct 2D Access uses the density
values to calculate the Common Center of Mass. The density must be specified
before a face is identified, otherwise the default value (1) or the previous density
value is used.

Creo Elements/Direct 2D Access calculates and displays the following total values
for multiple faces:

» Total Area.

* Center of Area (common).

* Center of Mass (common).

» Principal Axes through the (common) Center of Area.

* Second Moments of Area about (common) Principal Axes.

* Second Moments of Area about Coordinate System Axes.

* Product of Second Moment of Area about Coordinate System Axes.
* Moments of Inertia about (common) Principal Axes.

*  Moments of Inertia about Coordinate System Axes.

* Product of Moment of Inertia about Coordinate System Axes.

* Radii of Gyration with respect to the (common) Center of Area.

* Angle between Coordinate System and (common) Principal Axes.

To display face area properties:
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1. Click 2D Access and then, in the Utilities group, click a Properties.

2. Click Area.

Type the density value in the user input line and press ENTER.

The default density value is 1.

Alternatively, select a face or faces.

4. Click

C

Confirm.

The area properties are displayed in a standard text editor.

Optionally, you can save the list of area properties in a file.

Setting the Units of Measurement

£

You can select angular and linear units using the buttons under Angle Units

and L1 Length Units, respectively. The current units are displayed in the Format
group on the 2D Access tab.

To set the angular unit:

1. Click 2D Access and then, in the Format group, click Angle Units.

2. Click the required angular unit from the following:

£

Degree

L5

Gradian

i

Radian

P

User

To set the linear unit:

1. Click 2D Access and then, in the Format group, click || Length Units.

2. Click the required linear unit from the following:

(=] 1]

_lcm

mi

| meters

Em

‘I km
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Defining Your Own Units
é usr

The User and L] user buttons in the Format group on the 2D Access tab
allow you to define your own units in Creo Elements/Direct Drafting. For
example, an input of 5 mm allows you to work in 5 mm units, and an input of 5
degrees allows you to work in 5 degree units.

Using the Calculator

Creo Elements/Direct 2D Access provides a standard MS Windows calculator.

To use the scientific calculator:

1. Click 2D Access and then, in the Utilities group, click Calculator.

The Calculator application opens.

2. On the View menu of the Calculator, click Scientific.

Using the Ruler or Grid

The ruler simulates the T-square traditionally used with manual drafting methods.
When used together with the grid point catch mode, the ruler allows you to draw
with the help of a grid.

The grid is a useful drawing aid for alignment purposes.
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Displaying a Ruler and/or a Grid
To display the ruler and/or the grid:

1.

Click File » Settings »> Grid.

The Grid Settings dialog box opens.

In the Grid area, click Dot or Line to display a dot or line grid, respectively.
In the Ruler area, click Ruler to display the ruler.

Click OK.

Displaying the Origin

To display the coordinate origin:

1.

Click File » Settings »> Grid.

The Grid Settings dialog box opens.

In the Ruler area, click Origin.

The coordinate origin is indicated in the chosen viewport by an axes symbol.

If the ruler is active in the chosen viewport, it becomes unavailable.
Click OK.

Setting the Cursor Size

You can use either a small cursor or a full screen cursor. A full screen cursor is
particularly recommended for use with the ruler.

To change the cursor size:

Click File » Settings » [;3 System.

1.

2. Click Environment.

3. In the Cursor area, click the Large check box to use the large (full screen)
CUrsor.

4. In the Cursor Size box, type the size for the cursor.

~ Note

The catch range is not affected by the cursor size.
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Using Follow On/Off

The ruler is always located at the origin. The origin always tracks the ruler, and
the ruler always tracks the origin. Optionally, you can use the Follow function to
move the coordinate system origin with the origin of the ruler.

To make the origin follow the ruler:

1. Click View and then, in the Viewing group, click | Grid.
2. Click Follow.

The ruler automatically moves to each new point you create.

Moving the Ruler

To move the ruler:

1. Click View and then, in the Viewing group, click | Grid.
2. Click Move.
3. Specify the new origin.

The orientation of the ruler axes remains the same.

Rotating the Ruler/Grid

With Respect to the X-Axis

To rotate the ruler (or grid) so that the x-axis is at a given angle to the horizontal:

1. Click View and then, in the Viewing group, click fH Grid.

2. Click Turn.

3. Click Absolute.

4. Type the required angle in the user input line and press ENTER.

Through a Given Angle

To rotate the ruler (or grid) through a given angle:

1. Click View and then, in the Viewing group, click | Grid.
2. Click Turn.

3. Click Relative.
4

. Type the required rotation angle in the user input line and press ENTER.
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A positive value results in counterclockwise rotation.

Setting the Ruler or Grid Spacing

To change the spacing between the tick marks of the ruler or between the grid
lines or dots:

1. Click File » Settings > Grid.

The Grid Settings dialog box opens.

2. In the Options area, type the required distance (for example: 0. 5) in the
Spacing box.

This entry is interpreted in terms of the current length unit.

If the spacing is very small, it may not be shown on the screen but it will still be
used for catch when in ruler or grid catch mode. Use the buttons on the View tab if
you want an enlarged view.

Drawing an Isometric Ruler or Grid

To redraw the ruler or grid according to the isometric grid required for drawing
top, front, or side views:

1. Click View and then, in the Viewing group, click | Grid.

2. Click Isometric and then click any of the following:

*  Click Front to draw a front view.
* Click Top to draw a top view.

¢ Click Side to draw a side view.

Hiding the Ruler or Grid
To hide the ruler/grid:

1. Click View and then, in the Viewing group, click | Grid.
2. Click Hide.

Hide disables the ruler and/or grid. Alternatively, you can click None in the Ruler
area of the Grid Settings dialog box.

Placing the Ruler or Grid

To change the orientation of the axes:
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Click View and then, in the Viewing group, click | Grid.
Click Place.

Specify the new origin and two more points that define the new axis
orientation.

Figure 5. Ruler Axes on page 80 shows the ruler axes.

Figure 5. Ruler Axes

80
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To understand how to use the buttons in the Parts group on the 2D Access tab, it is
necessary for you to have a basic understanding of parts.

A complex drawing is likely to contain several parts. Design Engineers use parts
to simplify the drawing into clearly defined groups of elements. Each part has a
part name. It is possible to view or highlight only one part of a complex drawing
at a time. This provides a clearer visual representation of the part in relation to the
entire drawing.
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Parts Structure

The use of parts in a drawing results in a parts structure. A parts structure can be
thought of as a family-tree showing the relationships between all the parts. The
structure is hierarchical and has many levels, each level containing information
about the relationship between each part and its subparts. The highest level of the
parts structure is called Top. The lowest level contains parts that cannot be
subdivided any further.

If a part has subparts then it is called a parent part.

Summary

* Complex drawings are likely to contain parts.

+ Parts are groups of elements.

* Each part has a name (part name).

» Parts containing subparts are called parent parts.

* You can selectively view, or highlight any part or group of parts, either by
means of the Part Browser on page 85, or by means of the following buttons.

Editing Parts

=1
Creo Elements/Direct 2D Access allows you to edit the parts using the % Edit
buttons in the Parts group on the 2D Access tab.

] ST g
You can use | = Part, 5581 Top, and | &l Parent to edit parts. Creo Elements/
Direct 2D Access displays the active part in normal linetypes and colors while all

the other parts are shown in magenta dotted lines.

Editing a Part

To set a part as active:

=1
1. Click 2D Access and then, in the Parts group, click % Edit.
]

&

2. Click Part.

3. Select the part you want to make active.

Creo Elements/Direct 2D Access sets the clicked part as the active part.

Editing a Top Part

To set the highest part in the parts structure as active:
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=
1. Click 2D Access and then, in the Parts group, click % Edit.

2. Click |=&| Top.

Editing the Parent Part

Parts can contain subparts.

To set the parent of the active subpart as the new active part:

=1
1. Click 2D Access and then, in the Parts group, click % Edit.

2. Click =& Parent.

Viewing Parts
This section describes how to view individual parts of your drawing.
Use the . View buttons in the Parts group on the 2D Access tab to look at

individual parts of your drawing. The . View buttons work only in the active
viewport.

Viewing a Part
To look at an isolated part:

1. Click 2D Access and then, in the Parts group, click View.

2. Click Part.

3. Type the part name in the user input line and press ENTER or click an element
of the part.

Creo Elements/Direct 2D Access draws only this part. Creo Elements/Direct 2D
Access displays the part name in the top left-hand corner of the active viewport.

Viewing All Parts

To view all parts of a drawing in the current viewport:

1. Click 2D Access and then, in the Parts group, click View.

2. Click Top.
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Creo Elements/Direct 2D Access redraws all the parts making up the drawing.
Creo Elements/Direct 2D Access redraws the part name in the top left-hand corner
of the active viewport. This is useful if you have been viewing a lower level and
want to quickly redraw the drawing.

Viewing Parent Part
To view the parent of the currently viewed part:

1. Click 2D Access and then, in the Parts group, click View.

'{}q
Click Parent.

3. Type the part name in the user input line and press ENTER or click an element
of the part.

Showing Unselected Parts as Boxes

This section describes how to look at selected groups of parts using the [2..] Show
buttons in the Parts group on the 2D Access tab. Creo Elements/Direct 2D Access

replaces each part not selected by a box. The [..] Show buttons operate only in
the active viewport. Using boxes is useful when parts overlap.

With Part

To draw a part as a box representation:

1. Click 2D Access and then, in the Parts group, click [£..1 Show.

2. Click L= | part.
3. Click the required part.

Creo Elements/Direct 2D Access redraws the part as a box. Also, use Part to
draw a boxed part as a normal part.

With Part Boxed

To change a part and all its subparts to a box representation:
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1. Click 2D Access and then, in the Parts group, click [~ Show.

2. Click = Boxed.

. Select the part to be boxed or type its name in the user input line and press
ENTER.

Creo Elements/Direct 2D Access redraws the parent part and all the subparts
displayed as a box.

With All

You can restore all parts in the chosen viewport to their normal appearance:

1. Click 2D Access and then, in the Parts group, click [~ Show.

—

2. Click it AL

Creo Elements/Direct 2D Access redraws the chosen viewport with all parts
visible.

Part Browser

To display the Part Browser, press F12.

To perform an action on a given part, right-click the part in the Part Browser and
click the required button.

~ Note

The Part Browser can be docked anywhere in the Creo Elements/Direct 2D
Access window.

What is Shown in the Part Browser?

The Part Browser provides a graphical overview of the current parts structure in
your drawing.

+ Starting at the top part, this tree-like structure includes a separate branch for
each part. Subparts of a part are shown as sub-branches of that part.

* Click the + (plus) sign icon to expand the tree.

* Click the - (minus) sign icon to collapse the tree.
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* Click the check box to the left of any part icon to view the associated part (and
any parts hierarchically below this part).

* Clear the check box to the left of any part icon to hide the associated part (and
any parts hierarchically below this part).

The individual columns of the Part Browser provide the following information:

Column Description
Name Specifies the name of the part. The following icons are used to
indicate the nature of the part:

) The currently active part. Note that the
currently active part is represented by a red
icon.

[ Normal part or assembly. Any non-active parts
and/or parts hierarchically below the active
part are indicated by a green icon.

'“‘ Shared part.

“ Detail.

53 The associated part is hidden. This is because
you have applied the View command to
another part.

Unique Specifies a unique sequential number associated with the part.

Share A "hash" (#) character in this colums indicates that the part is
shared.

Scale Indicates the drawing scale of the part.

Symbol A small "x" indicates that the part is symbolic.

The Part Browser Tree Context Menu

To display the Part Browser tree context menu, right-click any part icon in the Part
Browser. This context menu provides the following commands (some of which are
also available in the Parts group on the 2D Access tab):

View

Shows only the selected part. Creo Elements/Direct 2D Access
fits this part into the current viewport. All other parts are
hidden, and their icons are marked by a yellow X (see list of
Part Browser icons above).

Symbol

Changes the part to a symbol.

Show

This command provides the following options:

Show

Shows the selected part (if it is presently
shown as a box or if it is hidden).

ShowFlat

Shows the selected part but not its subparts
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(if any).

ShowAll Shows the entire selected part complete
with all of its subparts.

ShowBox Shows the selected part as a box.

Hide

This command provides the following options:

Hide Hides the selected part.

HideFlat Hides the selected part but not its
subparts (if any).

HideAll Hides the entire selected part complete

with all of its subparts.

Options

The Icons option enables you to display the Part Browser with
or without icons. The State Icons option enables you to show
or hide the (checkbox-like) state icons that indicate whether or
not a part is visible.

Save

You can click Save to save an ASCII representation of the
current parts tree structure in a Creo Elements/Direct 2D
Access list file.

Delete

Deletes the selected part.

Spotlighting Parts

You can distinguish between the active part and all other parts by using a
spotlight. The button works as an on or off switch. The Spotlight is on when you
first load Creo Elements/Direct 2D Access.

1. To disable Spotlight, click & Spotlight in the status bar.

2. To enable Spotlight, click ™ | Spotlight again in the status bar.

Parts
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Introduction to Hidden Lines

This chapter shows how to display hidden lines in assembly drawings.

The 2D hidden line module is used with assembly drawings to automatically
display lines that indicate hidden drawing features. In an assembly drawing, these
lines are normally shown dashed.

Creo Elements/Direct 2D Access allows you to use the buttons in the Hidden
group on the 2D Access tab for commands associated with hidden lines.

Before you can display an assembly drawing using the hidden lines mode, you
must check to see that the faces of your drawing have been assigned z-values.

What are Faces?

Faces can be thought of as freely definable, infinitely thin, shaped areas that form
part of an assembly. Faces can partially obscure or completely cover other faces
and geometry lines (depending upon their z-values).

In simple terms, you could imagine faces as pieces of paper, laid one on top of
another, thus obscuring elements with a lower z-value.

Figure 6. Faces - With Z-Values 0 and 1 on page 90 shows the faces of two
components (one with z-value 0 and the other with z-value 1).

Figure 6. Faces - With Z-Values 0 and 1
Foces

! T

ez

What are Z-Values?

A z-value is the numerical value assigned to an element to position it in the
drawing at the appropriate logical level in the z-direction.

See Figure 7. Visualizing Z-Values on page 91.
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Figure 7. Visualizing Z-Values

T
a
I

A face or line with a higher z-value covers a face or line with a lower z-value.
Figure 8. Z-Values 0, 1 and 2 on page 91 shows 3 faces assigned the z-values 0, 1
and 2.

Figure 8. Z-Values 0, 1 and 2

Z-volue 2

Z-oua D

Hatches are treated as faces, this means hatched areas can cover geometry and
faces. Hatches that are partially covered are displayed partially obscured.

Construction geometry, texts, leader lines and dimensions are always visible.

~ Note

A face does not necessarily need to have the same z-value as its boundary
lines. In this case the boundary lines of the face may be partially covered by
the face itself (solid lines may appear dashed in some cases). The linetype of
the boundary lines is not changed.

Checking Z-Values
You can check the z-values of:

* Elements

* Shared parts

* Elements in shared parts

The z-value will be displayed on the User Prompt Line.
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Checking the Z-Value of an Individual Element

To check the z-value of an individual element:

1. Click 2D Access and then, in the Hidden group, click

2. Click

FZ

—_—

z)

Inquire Z Value.

Absolute.

3. Select the element.

Creo Elements/Direct 2D Access displays the absolute z-value of the element
in the user input line.

Checking the Minimum or Maximum Z-Value in an
Assembly Drawing

To check the minimum z-value:

z)

1. Click 2D Access and then, in the Hidden group, click k= Inquire Z Value.

2. Click

Minimum.

Creo Elements/Direct 2D Access displays the minimum z-value in the
assembly drawing in the user input line.

To check the maximum z-value:

1. Click 2D Access and then, in the Hidden group, click

2. Click

+Z

z)

Inquire Z Value.

Maximum.

Creo Elements/Direct 2D Access displays the maximum z-value in the
assembly drawing in the user input line.

Checking the Z-Value of a Shared Part

To find the computed z-value of a shared part:

1. Click 2D Access and then, in the Hidden group, click

2. Click ICH

[Zh

z)

Inquire Z Value.

Shared Part Offset.

Select the shared part.

Creo Elements/Direct 2D Access computes the z-value as the sum of the
shared part's z-value and that of the shared parent part.
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Checking the Z-Value of an Element in a Shared Part

To find the z-value of an element in a shared part:

z)

1. Click 2D Access and then, in the Hidden group, click Inquire Z Value.

=

2. Click 3 Shared Part Element.

3. Select the element in the shared part.

Creo Elements/Direct 2D Access displays the element’s z-value in the user
input line.

Generating Hidden Lines

To generate hidden lines:
* Click 2D Access and then, in the Hidden group, click 2| Generate.

-
When you click Generate to generate hidden lines, Creo Elements/Direct 2D
Access does the following:

* Geometry is modified by splitting geometric components if they are covered
by faces with a higher z-value.

» Splines are converted.
* Shared parts are unshared.

* The parts tree, starting from the current part, will be smashed.

Showing Hidden Lines On or Off

After you generate hidden lines, you can show or hide them in the drawing.

To display the hidden lines in the drawing:

1. Click 2D Access and then, in the Hidden group, click the arrow next to
Hidden Mode.

2. Click On to display the hidden lines in the drawing.

3. Click E Off to hide the hidden lines in the drawing.

Showing Hidden Lines as Dashed Lines

To view hidden lines as dashed lines:
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1. Click 2D Access and then, in the Hidden group, click the arrow next to
Hidden Mode.

2. Click On to display the hidden lines in the drawing.

%

3. Click B4 Show Hidden.

Plotting Hidden Lines

If you are plotting your drawing, note that it is not possible to plot face colors.

In order to suppress plotting of hidden lines you must set the hidden line linetype
and color appropriately. For more information, see the PLOT
TRANSFORMATION command in the online help.
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Using Construction Geometry

Drawing ConstruCtioN LINES .......cocuuuiiiiiiiiii e e e e e e s 96
Drawing Construction Circles

This section shows how to add construction lines and circles to a drawing
displayed in Creo Elements/Direct 2D Access. Construction geometry can be used
to check the alignment of existing geometry.

Construction lines differ from real lines in that they are considered to be of infinite
length. Only full construction circles can be drawn.

When creating construction lines you can either click positional points in the Creo
Elements/Direct 2D Access drawing area, or you can enter the coordinates
(separated by a comma) in the user input line.
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Drawing Construction Lines

To draw construction lines:

1. Click 2D Access and then, in the Draw group, click the arrow next to 2
Points.

2. Click the required Construction Line button and perform the associated
procedure.

Construction Line Purpose Procedure
Button

Draw construction lines
2 Points using two points.

a. Type the angle for
the construction line
in the user input line
and press ENTER.

b. Specify the second
point.

Alternatively, click the
two points for the
construction line.

Draw horizontal a. Typethey
Horizontal construction lines. . :
coordinate of the
horizontal

construction line in
the user input line
and press ENTER.

or

Click a point through
which the horizontal
construction line
must pass.

b. To draw several
horizontal
construction lines,
type their y
coordinates,
separated by spaces,
in the user input line
and press ENTER.

Draw vertical

. ) ) a. Type the x
Vertical construction lines. P
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Construction Line
Button

Purpose

Procedure

coordinate of the
vertical construction
line in the user input
line and press
ENTER.

or

Click a point through
which the vertical
construction line
must pass.

b. To draw several
vertical construction
lines, type their x
coordinates,
separated by spaces,
in the user input line
and press ENTER.

Parallel

Draw construction lines
parallel to an existing
line.

a. Type the separation
distance of the line
in the user input line
and press ENTER.

b. Click any existing
line and then click
the side on which the
parallel construction

line should be
drawn.

Multiple lines can be
drawn at the
previously set
separation distance
by clicking the
original lines and the
desired sides.

Alternatively:

a. Click any existing
line.

Using Construction Geometry
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Construction Line
Button

Purpose

Procedure

b. Specify a point for
the parallel
construction line to
pass through.

You can draw
multiple parallel
construction lines by
specifying further
points for the lines to
pass through.

Alternatively, draw a set
of parallel lines from an
original line.

For example, if you
enter line separations as
1020 30 40, four
parallel lines are drawn
at the given distances
from the indicated line.

Perpendicular

Draw a construction line
perpendicular to an
existing line.

a. Click any existing
line.

b. Specify a point
through which the
perpendicular
construction line
must pass.

L Point & Angle

Draw a construction line
at an angle.

a. Specify a point
through which the
construction line
must pass.

b. Specify a second
point for the
construction line.

or

Type the angle of the
line with respect to
the x axis in the user
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Construction Line
Button

Purpose

Procedure

input line and press
ENTER.

A positive angle is
measured in a
counterclockwise arc
from the horizontal. You
can set the angle units in
your Creo Elements/

Direct 2D Access
environment.
Tancent Draw a constmctlon line a. Click the
9 tangent to a circle or a approximate point of
spline and passing tangency.

through a given point or
at a set angle.

b. Type the angle of the
construction line in
the user input line
and press ENTER.

>~ Note

The angle is
measured in a
counterclockwise
arc from the
horizontal.

Alternatively, click the
approximate point of
tangency on the circle or
spline and then specify a
point through which the
construction line must
pass.

66 Tangent by 2

Draw a construction line
as a tangent to two
circles or splines.

Click the approximate
point of tangency on
each of the two circles
or splines.

Using Construction Geometry
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Construction Line Purpose Procedure
Button

The construction line is
drawn through the points
of tangency that are
closest to the points you

indicated.
Draw a bisecting Specify the two end
Bisector construction line. points of the line.

A construction line is
drawn perpendicular to
the line at the
appropriate position.

To divide the line in two
unequal parts:

a. Type the bisector
factor (value for the
ratio of division) in
the user input line
and press ENTER.

b. Specify first point on
the line.

c. Specify second point

on the line.
Draw a construction line . .
. Specify the first line.
Bisector Angle bisecting an angle. P _ Y
Specify the second
line.

A construction line,
defining the bisector
angle, is drawn.

Drawing Construction Circles

To draw a construction circle:

1. Click 2D Access and then, in the Draw group, click the arrow next to @
Center & Radius.

2. Click the required Construction Circle button and perform the associated
procedure.
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Construction
Circle Button

Purpose

Procedure

(o3

Center &

Radius

Draw a construction circle
by center and
circumference point.

Specify the center of
the construction line.

Type the radius of the
construction circle in
the user input line and
press ENTER.

Alternatively, specify a
point on the
circumference.

If multiple concentric
circles are required,
type the desired radii in
the user input line and
press ENTER or specify
multiple peripheral
points.

3 Points

Draw a construction circle
by three points on the
circumference.

Specify two circumference
points.

The construction circle
drawn varies with the
movement of your cursor
till you specify the third
point.

©

Tangent &

Center

Draw a construction circle
by a center and element.

a.

Click the approximate
point of tangency on the
existing element.

Specify the center of
the construction circle
to be drawn.

Concentric

Draw concentric circles.

Click the existing
circle.

Type the radial offset of
the new construction
circle from the existing
one, that is, the
difference between the
two radii, in the user

Using Construction Geometry
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Construction
Circle Button

Purpose

Procedure

input line and press
ENTER.

c. To draw several
concentric construction
circles, type the
appropriate radial
offsets separated by
spaces in the user input
line and press ENTER.

or

Click existing points

through which the
construction circles
must pass.
— Draw a construction circle |Specify two points as the
~="| Diameter by diameter. two ends of the diameter
for the required circle.
O Tangent & 2 ]lj)raw da.l constmctlon circle a. Click the approximate
Points y radius, point (or two point of tangency of the

points) and element.

construction circle on
the existing element
(which must not be a
spline).

b. Specify a point on the
circumference.

c. Type the required radius
in the user input line
and press ENTER or
specify another point
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Construction
Circle Button

Purpose

Procedure

Q Tangent by 2

Draw a construction circle
by radius or point and

tangential to two elements.

b. Type the desired radius

a. Click the approximate
points of tangency
(either lines or circles
but no splines).

in the user input line
and press ENTER.

or

Specify a peripheral
point on the
construction circle.

Creo Elements/Direct
2D Access calculates
the best solution, or
informs you that no
solution is possible.

Q Tangent by 3

Draw a construction circle
by three elements.

Click the approximate point
of tangency of the
construction circle on each
of the three existing
elements (none of which
must be a spline).

Using Construction Geometry
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Revision Checking

Using ReViSion CheCKING .........iiiiiiiiii e 106

This chapter describes how to use the buttons and options that allow you to
compare similar drawings. This facility is particularly useful in design offices
where successive drawings are revised and you need to identify the differences
between revisions.

The differences between the original and revised drawings are shown in color.
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Using Revision Checking

To use the revision checking facility:

1.

106

Click Compare and then, in the Setup group, click il | | oad Files.

The Load dialog box opens.

In the Original box, type the name of the original drawing file.
For example, dt cs rev06.

Alternatively, click Browse to select the original drawing file.

In the Revised box, type the name of the revised drawing file.
For example, dt cs rev1O0.

Alternatively, click Browse to select to select the revised drawing file.
Click OK.

Creo Elements/Direct 2D Access displays the two drawings overlapping.

T
Click Compare and then, in the Compare group, click Geometry.

Creo Elements/Direct 2D Access compares the location of the geometry and
texts (without comparing the parts structure) in the two drawings and shows
the result of the comparison in different colors according to the following
defaults:

Blue Identical geometry elements in both drawings
Green Differences in the original drawing
Red Differences in the modified drawing

Click Compare and then, in the Compare group, click Annotation.

(S
In addition to Geometry, Annotation also compares the properties of
the geometry and texts — linetype, color, text attributes, info texts — and the

dimensions and hatches in both drawings.

Click Compare and then, in the Compare group, click Parts.

In addition to 2271 Annotation, Parts compares the parts structure in both
drawings.
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~ Note
If you modify a drawing solely by a scaling factor, clicking Parts
displays all elements in red (indicating a difference). However, uf

Geometry and Annotation display elements and annotation in blue
(indicating identical elements).

~ Note

Both drawings must have the same location compared to the drawing origin to
get meaningful results from the comparison.

Viewing Single Drawings

When both drawings are loaded, you can toggle between them using the buttons in
the Show group of the Compare tab.

To view the original drawing only:

* Click Compare and then, in the Show group, click Original.

To view the revised drawing only:

* Click Compare and then, in the Show group, click Revised.

To view both the drawings:

* Click Compare and then, in the Show group, click E

Resetting Colors and Showing Differences

The colors generated after selecting a button in the Compare group can be reset to
their original colors.

To view the drawings in the original colors:

* Click Compare and then, in the Show group, click ﬁ Reset.

To view the drawing elements in different colors depending on the result of the
last comparison:
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* Click Compare and then, in the Show group, click Differences.

Changing the Color Scheme

To change the color scheme for changes in the original drawing:

1. Click Compare and then, in the Setup group, click the arrow next to
Original.

2. Click a color.

To change the color scheme for changes in the revised drawing:

1. Click Compare and then, in the Setup group, click the arrow next to ]
Revised.

2. Click a color.

To change the color scheme for identical elements:

1. Click Compare and then, in the Setup group, click the arrow next to
Identical.

2. Click a color.

The color changes take effect with the next redraw.
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Using URLs with Creo Elements/
Direct 2D Access

IS g T | U 110
Highlighting the Element or Part to which a Given URL is Attached ..................c.......... 110
ACCESSING @ URL ... e 110
Using URL Elem. in Show Dialog BOX ........cccuuiiiiiiiiiiii e 111
Switching URLS On & Off ......ii e 111
AssigNINg @ Color t0 @ URL ....cvuniii e 112
Further INformation ............ooiiii e 112

Creo Elements/Direct Drafting enables you to attach any industrial standard Web
page to drawings, parts and elements. All URLs used by Creo Elements/Direct
Drafting drawings, parts and elements are handled using the buttons in the URL
group on the 2D Access tab.
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Listing URLs

To display a list of the URLSs attached to the current drawing or to a part or to an
element in the drawing:

1. Click 2D Access and then, in the URL group, click the arrow next to @ URL.
2. Click any of the following:

*  Click Element to list the URLs for an element or a group of elements.
Then, select the element or group of elements.

The Element URLs dialog box opens. It lists all the URLs associated with
the element or group of elements.

* Click Part to list the URLs for a part other than the current part. Then
select the part.

The Part URLs dialog box opens. It lists all the URLs associated with the
part.

Highlighting the Element or Part to which
a Given URL is Attached

To highlight the element or part to which a URL is attached:

1. Click 2D Access and then, in the URL group, click , Show.

The Global URLs dialog box opens.
2. Select the URL.
3. Click Show Elem. to highlight the element associated with the URL.
4. Click Show Parts to highlight the part associated with the URL.

Accessing a URL

To access a URL attached to a part or element in a drawing:

1. Click 2D Access and then, in the URL group, click the arrow next to @ URL.
2. Click any of the following:

* Click Element to list the URLs for an element or a group of elements.
Then, select the element or group of elements.
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The Element URLs dialog box opens.

* Click Part to list the URLs for a part other than the current part. Then
select the part.

The Part URLs dialog box opens.
3. Select the URL you want to access.

4. Click Browse to access this URL by means of your default Web browser or
navigator.

You can also click Browse in the Global URLs dialog box to access the selected
URL by means of your default Web browser or navigator.

Using URL Elem. in Show Dialog Box

To open the URL Elem. tab of the Show dialog box:

1. Click File » Settings » Show.
Alternatively, click 2D Access and then, in the Utilities group, click Show.
The Show dialog box opens.

2. Click the URL Elem. tab.

In the URL Elem. tab, you can:

* Switch URLs on and off.

* Box an area to show its URLs.
» Select a color for each URL.

Switching URLs On & Off

To switch URLs on or off:

1. Click File » Settings » Show.
Alternatively, click 2D Access and then, in the Utilities group, click Show.
The Show dialog box opens.
Click the URL Elem. tab.

3. Select the URL you want to switch on or off.

4. Click On or Off to display or hide all the elements associated with the selected
URL, respectively.
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Assigning a Color to a URL
You can color a URL to aid visualization.
To color a URL:
1. Click File » Settings » Show.
Alternatively, click 2D Access and then, in the Utilities group, click Show.
The Show dialog box opens.
Click the URL Elem. tab.
Select a URL.
Select a color from the selection list and click Color.

Creo Elements/Direct 2D Access indicates the element in the selected color
that contains the URL.

Further Information

For further technical information about layers and infos, refer to the Creo
Elements/Direct 2D Access help system.

Type help layer or help info or help url in the Creo Elements/Direct 2D
Access user input line and press ENTER.

Creo Elements/Direct 2D Access displays further information about using layers
or infos or URLs with Creo Elements/Direct Drafting.
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Linking and Embedding OLE
Objects

Inserting @n OLE ODJEC.......coiuiiiiiei e 114
Editing an OLE Object in Creo Elements/Direct 2D ACCESS .......cceuvvuiieiiiiiiieiiiiiiieeeeennns 115
USING the OLE BrOWSET ... ..ceiiiiieeeei ettt eeeaaas 116

Files (such as spreadsheets, graphics or text pages) created in external applications
can be included in Creo Elements/Direct 2D Access by inserting associated Object
Linking and Embedding (OLE) objects.
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Inserting an OLE Object

To insert an OLE object in a drawing using Creo Elements/Direct 2D Access:

T =
1. Click File » Lo Import/Export » Lo Import OLE.

The Insert Object dialog box opens. It lists all applications on your system that
provide OLE capability.

In the Object Type box, select an application.
3. Select one of the following:
* Create New

* Create from File

Create New
Create New inserts a new OLE object of the selected application in your drawing.
To create a new OLE object:

1. In the Object Type box, select an object type.

2. Click the Display As Icon check box to represent the OLE object by the
associated application icon in Creo Elements/Direct 2D Access.

Optionally, click Change Icon to select a different icon for the OLE object.
3. Click OK.

The Open dialog box opens.
4. Using the File Browser, select the OLE object.

The default OLE object name is displayed in the user input line.

5. Retain the default OLE object name or type a name for the OLE object in the
user input line and press ENTER.

6. Specify the insertion position for the OLE object in Creo Elements/Direct 2D
Access.

The OLE object is displayed in the Creo Elements/Direct 2D Access drawing.

Create from File

Create from File inserts the contents of a file as an object in your document so that
you can activate the object using the application in which it was created.

To create an OLE object from an existing file:
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1. Click Browse and browse to the file you want to link using the File Browser.

Click Open.

Optionally, click the Link check box to link the OLE object to its source
application such that changes in the original file are reflected in the OLE
object in Creo Elements/Direct 2D Access.

Click the Display As Icon check box to represent the OLE object by the
associated application icon in Creo Elements/Direct 2D Access. Optionally,
click Change Icon to select a different icon for the OLE object.

Click OK.
The default OLE object name is displayed in the user input line.

Retain the default OLE object name or specify a name for the OLE object in
the user input line.

Specify the insertion position for the OLE object in Creo Elements/Direct 2D
Access.

The OLE object is displayed in the Creo Elements/Direct 2D Access drawing.

Editing an OLE Object in Creo Elements/
Direct 2D Access

Once the OLE object is inserted in the drawing, you can edit it as described in the
following sections.

Arranging OLE Objects

To arrange OLE objects:

1. Click 2D Access and then, in the OLE group, click the arrow next to -J Level.

2. Click IE‘ To Front, IE‘ To Back, IE Forward or |E| Backward, or W In
Front Of or - Behind.

3. Select the OLE object you want to arrange.

Activating an OLE Object

By activating an OLE object, you open the underlying file in its source application
for editing. The OLE objects created by using Create from File reflects the changes
in the underlying file.

To activate an OLE object:
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1. Click 2D Access and then, in the OLE group, click Activate.
2. Click the OLE object you want to activate.

You can also use the OLE Browser to activate an OLE object.

Renaming an OLE Object
You can rename an existing OLE object in a drawing.

To rename an OLE object:

1. Click 2D Access and then, in the OLE group, click L=2| Rename.

2. Select the OLE object to be renamed.
3. Type the new name of the OLE object in the user input line and press ENTER.

You can also use the OLE Browser to rename an OLE object.

Deleting an OLE Object

To delete an OLE object from your drawing:

1. Click 2D Access and then, in the OLE group, click Browser.

The OLE Browser opens.
Select the OLE in the OLE Browser.
3. Click Delete.

Hiding and Showing OLE Objects

To improve system performance or to reduce screen clutter, OLE objects can be
hidden or displayed using Show or Hide in the OLE Browser. If the drawing
includes several OLE objects, you can choose to hide individual or all OLE
objects. In the OLE Browser, select the OLE object and click the following:

Show Unhides a hidden OLE object.
Hide Hides an OLE object.
Box Hides an OLE object but places a reference frame

around the hidden image.

Icon Displays an icon that represents the OLE object.

Using the OLE Browser

To open the OLE Browser:
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The OLE Browser displays the following information about the OLE objects

Click 2D Access and then, in the OLE group, click

Browser.

currently included in your drawing:

Name The name you specified for the OLE object

Z-level Numerical value for the "hidden" level assigned to an image in
the drawing

Show Status of the SHOW command; ON, OFF, or ICON

X-Scale Scaling factor in the x-direction

Y-Scale Scaling factor in the y-direction

OLE Type OLE object type

Program ID Application object type

Class ID OLE object class ID

Using the OLE Browser, you can perform the following actions on the OLE

objects:

* Activate

* Delete

* Show

* Hide

* Box

Convert to icon
Rename

Save

Linking and Embedding OLE Objects

117







13

Printing and Plotting

Using the Print Manager .......c.oieii it e e een 120
Creating a Print Configuration ..............cooiiiiiiii e 120
Defining the Print or Plot Settings ........ooivuiiiiii e 123
Previewing a Print Or PIOt ... ... 133
Starting @ Print or POt JOD.......oooi e 134
Printing or Plotting Multiple Drawing Files..........c..ooiiiiiii e 134
Dumping the Creo Elements/Direct 2D ACCESS SCreeN..........uvvvevnveiiiieiiiieeeiiieeeieeeaenns 134
Further INformation ............oo i e 134

This chapter describes how to print and plot drawings and how to produce screen
dumps.
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Using the Print Manager

Creo Elements/Direct 2D Access spools all plots and screendumps either to the
Print Manager or to the Clipboard, and not directly to an output device.

The Print Manager controls device selection, configuration, and spooling for the
printers and plotters on your system. Once you send a plot from Creo Elements/
Direct 2D Access to the Print Manager, the Print Manager takes over the process
of producing the final output. By setting REQUEST PRINT SETUP, you can
directly access the Print Manager's setup dialogs each time you plot or
screendump.

The Clipboard temporarily stores a plot or screendump so that it can be
electronically transferred or "pasted" into another application.

~ Note

Depending on the output device or devices on your system, the Print Manager
may allow you to set several printer or plotter options in addition to those
offered by Creo Elements/Direct 2D Access. Refer to your Windows
documentation and hardware manuals for information on configuring your
printer or plotter to work with Windows.

Creating a Print Configuration

To facilitate the creation of consistent print or plot output, Creo Elements/Direct
2D Access enables you to create any number of print configurations.

To create a print configuration:

b E
1. Click File » "==| Print » Print Setup.

by

L

Alternatively, click Print Preview and Print on the Quick Access Toolbar

or press CTRLAP.

The Print dialog box opens.
2. Define the settings for the new print configuration.

These settings are discussed in the following sections of this chapter.
3. In the Print configuration area, click Settings.

The Print Configurations dialog box opens.

4. Type a name for the print configuration in the text box and click Add to add
this new print configuration name to the list of print configurations.
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Creo Elements/Direct 2D Access prompts for confirmation to add the print
configuration to the list.

Click OK.

To save the print configuration for future use, select it and then, click Store.

The Store Print Configurations dialog box opens.

7. In the Name box, type a name for the print configuration file (for example,
my print.m) for your print configuration file.

~ Note

This filename does not have to be the same as the print configuration
name. However, ensure that the filename is readily identified.

Click Save.
Click Close.

Example of a Print Configuration

An example of a Creo Elements/Direct Drafting or Creo Elements/Direct 2D

Access print configuration follows:
{ User specific customization }

WIN PRT MGR PAPER 'a3' ORIENTATION LANDSCAPE COPIES 1 END
PLOT_SCALE AUTO

PLOTTER TYPE ADD MSWINDOW GDI PRINTER PRT DRIVER 'HP LaserJet 1100' 'department 1
WIN PRT MGR PAPER 'a4' ORIENTATION PORTRAIT COPIES 1 END
PLOT SCALE AUTO

PLOTTER TYPE ADD MSWINDOW GDI PRINTER PRT DRIVER 'HP DeskJet' 'department 2' END

WIN PRT MGR PAPER 'a4' ORIENTATION LANDSCAPE COPIES 1 END

PLOT_SCALE AUTO
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PLOTTER TYPE ADD MSWINDOW GDI PRINTER PRT DRIVER 'HP LaserJet 1100’

PLOTTER TYPE 'department 3'

{ plot it }

PLOT 0,0 O all BW_IMG NORM VIDEO

The settings in this customize p.m print configuration file imply the
following:

*  One copy of the drawing is printed to A4 paper in landscape orientation.
* The drawing is scaled to fit.

* The PLOTTER TYPE variable is set to department 3. This is the printer
that will be used as the output device.

* The entire drawing is printed in normal (as opposed to inverse) video.

Reusing a Saved Print Configuration

When you quit Creo Elements/Direct 2D Access, the system automatically saves
your current print settings. These settings are used when you start Creo Elements/
Direct 2D Access again.

You can see and modify your current configuration file by opening
<application data path>\PTC\Creo Elements Direct Drafting
[version]\ [version]\print configurations\current print
cfg.m.

You can also use existing or create your own configuration files. If you use the
name convention (print cfg <configuration name>.m) for your own
configuration files and place them in the print configurations
subdirectory, these files appear in the Print dialog box as a Print configuration.
Configurations that you create with the Print dialog box are automatically stored
in this subdirectory when you store your configuration.

To re-use binary legacy print configuration files (with file name <print
configuration>.cfqg) from a CoCreate Drafting version < 13.00:

b E
1. Click File » L"=| Print » Print Setup.

The Print dialog box opens.
Alternatively, press CTRL+P to open the Print dialog box.

2. In the Print configuration area, click Settings.
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The Print Configurations dialog box opens.
3. Click Load.
The Load Print Configurations dialog box opens.
4. Select the print configuration file and click Open.
The print configurations appears in the Print Configurations list.

Select the print configuration.
6. Click Close.

The Print dialog box settings change to the settings defined for the loaded print

configuration.

Defining the Print or Plot Settings

Before printing or plotting a drawing, you should define exactly what will be
printed or plotted and how the drawing will be printed or plotted.

Setting the Plot or Print Destination

Creo Elements/Direct 2D Access can send plots and screen dumps either to the
Windows Print Manager or to the Clipboard. You usually send plots to the Print
Manager for output on the system's default printer or plotter. Send a plot to the

Clipboard if you want to insert it in another Windows application. You can also

define the output destination of a file by clicking Browse in the Print dialog box.

~ Note

Creo Elements/Direct 2D Access automatically derives the extension for the
output file according to the selected printer or plotter.

Selecting a Printer or Plotter

To set a printer or plotter:

= o
1. Click File » "==| Print » Print Setup.

The Print dialog box opens. The Printer tabbed page opens by default.
Alternatively, press CTRL+P to open the Print dialog box.

2. Inthe Printer area, select the printer or plotter in the Name box.

Note the boxed plus sign beside some generic options.
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Expand the plus sign and select the model number, if required.

3. Click Properties and set the properties (such as the paper size and the
resolution) of this printer or plotter.

If the printer or plotter you want to use is not included in this list, use standard
Microsoft Windows techniques to install, set up and configure this printer or
plotter.

>~ Note

Refer to your Windows documentation and hardware manuals for information
on configuring your printer or plotter to work with Windows.

Routing the Print or Plot Output to a File
To send the print or plot output to a file:

b E
1. Click File » L"=| Print » Print Setup.

The Print dialog box opens. The Printer tabbed page opens by default.
Alternatively, press CTRL+P to open the Print dialog box.

2. In the Printer area, click the Print to File check box.

3. In the Destination box, type the file path and file name.

Ensure that you match the printer or plotter with the format of the output file. For
example:

* Ifyou want to create an HP-GL file, select an HP-GL compatible plotter.
« Ifyou want to create a PostScript file, select a PostScript printer.
+ Ifyou want to create a PDF file, select the PDF Generic option.

After you click Print, the file is saved at the destination path with the specified
name.

Setting the Paper Size and Number of Copies

To set the paper size and number of copies for printing or plotting:

I. Click Fite » = print » | print setup.
The Print dialog box opens. The Printer tabbed page opens by default.
Alternatively, press CTRLAP to open the Print dialog box.

2. In the Paper area, select the paper size in the Format box.
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To set a custom paper size, select Custom size in the Format box and define
the size of the paper.

3. Ifyou have a multi-sheet drawing, click the Use sheet format check box to
automatically set the format and orientation of each sheet based on the sheet
size.

4. To set the number of copies, type or select the number of copies in the Copies
box.

Setting Orientation

To set the paper orientation:

b Q
1. Click File » ™=®]Print » Print Setup.

The Print dialog box opens. The Printer tabbed page opens by default.
Alternatively, press CTRL+P to open the Print dialog box.

2. In the Orientation area, click Portrait or Landscape.

~ Note

If you set the paper size such that the height and width are equal, the
orientation is set to landscape by default.

Positioning Your Drawing

To position your drawing:

b Q
1. Click File » L"=%| Print » Print Setup.

The Print dialog box opens.
Alternatively, press CTRL+P to open the Print dialog box.

2. Click the Drawing tab and then, in the Position area, click any of the following:
* Center (default setting) to position your drawing at the center of the paper.

Creo Elements/Direct 2D Access places the bounding box centered on the
paper.

* Left to position your drawing at the lower left corner prior to printing or
plotting.

Creo Elements/Direct 2D Access places the bounding box in the lower left
corner of the paper.
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Specifying Linear Offsets

To specify linear offsets for Center and Left:

= i
1. Click File » "==| Print » Print Setup.

The Print dialog box opens.

Alternatively, press CTRLAP to open the Print dialog box.

2. Click the Drawing tab and then, in the Position area, type an offset in the X
direction and in the Y direction in the X Offset box and Y Offset box,
respectively, for Center and Left. The print or plot output is moved accordingly
in the X direction and/or Y direction.

These offsets are interpreted in terms of the current length unit (such as mm) set
up for your Creo Elements/Direct 2D Access environment.

Setting a Rotation Angle

To rotate the drawing output to the printer or plotter:

- a
1. Click File » .=%|Print » Print Setup.

The Print dialog box opens.

Alternatively, press CTRL+P to open the Print dialog box.

2. Click the Drawing tab and then, in the Position area, type the angle of rotation
in the Rotation box.

The angle of rotation is interpreted in terms of the current angular units set up for
your Creo Elements/Direct 2D Access environment.

Selecting the Drawing Range for Printing or Plotting
You can print/plot the complete drawing, the current viewport, or a boxed area.

To select the drawing range for a print or plot:

- B
1. Click File » L"®| Print » Print Setup.

The Print dialog box opens.
Alternatively, press CTRL+P to open the Print dialog box.
2. Click the Drawing tab and then, in the Range area, click any of the following:

* Al (default setting) to print or plot the entire drawing — irrespective of the
current viewport contents.

* Sheet to print each Annotation sheet on a separate page.
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Viewport to print or plot the contents of the current viewport.

For example, if you are currently viewing a part, only the elements of that
part contained within the window of the current viewport will be printed or
plotted.

Box to print or plot a specific area of a viewport.

Click Pick and then use your cursor in the drawing viewport to specify two
opposite corners of a box. Only the contents of the boxed area will be
printed or plotted. For example, suppose you are currently viewing a part,
and the other parts or elements exist in the same area, but are not
displayed. If you click Box, all the drawing elements existing in the boxed
area (both displayed and hidden), are plotted.

Setting the Plot Scale

This section describes how to set the scale to be used for the subsequent print/plot

output.

You can set a scale factor or automatically scale the drawing as large as possible
within the limits of your paper.

To set the print or plot scale factor:

1.

b g
Click File » L] Print » Print Setup.

The Print dialog box opens.

Alternatively, press CTRL+P to open the Print dialog box.

Click the Drawing tab and then, in the Scale area, click any of the following:

L]

Click Fit to scale the print or plot output (as large as possible) within the
limits of the defined paper size.

Click Factor (default setting) and type the required scaling factor in the
Factor box.

The entire print or plot output is scaled, but dimension values are not
affected.

Figure 9. Operation of Print/Plot Scale on page 128 shows the operation of
print/plot scale.
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Figure 9. Operation of Print/Plot Scale
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If you set the plotting scale such that the drawing is too large for the paper,
Creo Elements/Direct 2D Access warns you at the start of a plot by
displaying the maximum scale possible. Pressing ESC aborts the plot and
allows you to reset the plot scale. Otherwise, press SPACE BAR and the
plot will continue, cutting off elements outside the paper format.

Setting the Content of the Print or Plot Output

Creo Elements/Direct 2D Access enables you to specify what will be included in
the print/plot output:

To set the content of the print or plot output:

b E
1. Click File » L"=| Print » Print Setup.

The Print dialog box opens.

Alternatively, press CTRL+P to open the Print dialog box.

2. Click the Drawing tab and then, in the Content area, click any of the following:

L]

128

Drawing to print or plot the drawing using standard drawing conventions.

Drawing lines, dimensions, text and hatching will be included in the print/
plot output. Construction lines, spotlights for parts and so on are omitted.
The drawing appears as a normal drawing irrespective of the screen status
(that is, the plot is unaffected by the Show functions).

Current Show to print or plot the drawing as shown in the viewport.

a. Select a viewport in which you can set your own drawing conventions.
b. Use the Show functions to set the desired attributes.

c. Click Current Show.

The subsequent plots will contain whatever drawing conventions you have
selected in the current viewport.

Inspection with Creo Elements/Direct 2D Access Fluent User Interface



~ Note

Drawing and Current Show only determine how the plot appears. The plotting
area is unaffected.

Defining Color Settings

Creo Elements/Direct 2D Access allows you to define the True Color, Plot
Transformations and True Color & Screen Trans settings for your printer or plotter
environment.

To define the color settings of you drawing:

Lk
1. Click File » =] Print » g‘ Print Setup.

The Print dialog box opens.

Alternatively, press CTRL+P to open the Print dialog box.
2. On the Drawing tab, in the Colors area, click Pens.

The Plot Transformation dialog box opens.

3. In the Plot Transformation list, click True Color, or Plot Transformations, or
True Color & Screen Trans.

True Color

In the Plot Transformations list, select True Color to create a color plot of your
drawing that is suitable for output to color output devices capable of producing
color rastering.

This feature is available on PostScript Level 2 printers and HP-GL/2 printers. This
means, for example, if you have access to an HP DesignJet 650C color printer you
can print any number of colors up to the capability of the printer.

- Note
If you have a drawing that contains elements in white, and specify truecolor
plotting, the elements are drawn in white. Normally, when sending drawings to
a pen-plotter, the white elements on the screen are converted to black

Plot Transformation

In the Plot Transformation list, select Plot Transformations.
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The following settings are available:

Edit Displays a separate Pen Format dialog box to set a
custom plot transformation map.

Reset Restores the default Plot Transformations settings.

Default Color Applies a default color-to-pen assignment map.

Default B/W Applies a monochrome color-to-pen assignment map.

Default GDI Applies a 125 — color plot pen color-to-pen assignment
map.

The Plot Transformation map enables you to map the colors and pensizes of
elements in your drawing for output to a printer or plotter.

To set up the Plot Transformations map:

1.

130

In the Plot Transformations map, click the row you want to change.

The selected row is highlighted.
Click Edit.

The Pen Format dialog box opens.

In the Drawing area of the Pen Format dialog box:

a.

In the Linetype box, select a "from" linetype and then, in the To box, select
a "to" linetype to which you want to map the "from" linetype. For
example, if you want all dashed lines in the drawing to be plotted as dotted
lines, map "from" dashed "to" dotted.

If you want to map all linetypes in the drawing to the associated linetypes
on the plotter, click the All Linetypes check box.

Click the Color Range check box and then, in the From (RGB) box, type the
RGB value for a "from" color. In addition, in the To (RGB) box, type the
RGB value for a "to" color to which you want to map the "from" color.

If you want to map all colors in the drawing to the associated colors on the
plotter, click the All Colors check box.

In the Pen Size box, type a "from" pensize and then, in the To box, type a
"to" pensize to which you want to map the "from" pensize. For example, if
you want pensize 0.3 in the drawing to be plotted by a 0.45 pen on the
plotter, type 0 . 3 in the Pen Size box and 0. 45 in the To box.

If you want to map all pensizes in the drawing to the associated pensizes
on the plotter, click the All Pen Sizes check box.
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Assigning a Specific Pen to a Given Linetype or Color
Combination

To assign a specific plotter pen to a given linetype or color combination in the Plot
Transformations map:

1. In the Color box of the Drawing area, select the color.
2. In the Linetype box of the Drawing area, select the linetype.
3. In the Linetype box of the Plotted As area, select the linetype to be plotted.

If you want to print or plot using the linetype that is used in the drawing, click
the Same Linetype check box.

4. In the Pen box, type or select the pen number.
In the Pen Width box, type a pen width.

If you want to print or plot using the pen width that is used in the drawing,
click the Same Pen Width check box.

6. Click OK to add the changed row to the Plot Transformations map.

For example, assume that you want to use a 0.3 mm blue pen to plot all dashed
blue lines of the drawing. This pen is pen # 5 in your plotter.

1. In the Linetype box, select the dashed linetype and in the Color box, select
Blue in the Drawing area of the Plot Transformations map.

2. In the Plotted As areca, click the Same Linetype check box.
3. In the Pen Width box, type 0. 3.
4. In the Pen box, type or select the pen number 5.

Repeat this procedure till the Plot Transformations map contains the required map
of colors, linetypes, and associated plotter pens.

To restore the Plot Transformations default settings, click Reset.

To restore the default color settings, click Default Color.

Setting the Linetype Length

You can set the pattern length for any of the seven broken linetypes. Each broken
linetype is a pattern repeated many times to produce a line. Using the Plot
Linetype Length dialog box, you can specity the length of each pattern and thus
alter the fineness of the line. Figure 10. Different Linetype Lengths on page 132
shows two DASH CENTER lines drawn with different linetype lengths. The
linetype length is shown arrowed.
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Figure 10. Different Linetype Lengths

The seven broken linetypes that you can set are:

. DASHED
- LONG DASHED
- DOT CENTER

- DASH_CENTER

« PHANTOM
« CENTER DASH DASH
« DOTTED

To set the linetype length and minimum space for individual broken linetypes:

1. Click File » = Print » 5 Print Setup.
The Print dialog box opens.

Alternatively, press CTRL+P to open the Print dialog box.
2. Click the Drawing tab and then, in the Colors area, click Pattern Length.

The Plot Linetype Length dialog box opens.
3. In the Linetype name column, click the required linetype.
4. In the Length box, type or select a segment length for each broken linetype.

In the Min. Dist. box, type or select the minimum distance (the gap) between
the broken line segments.

6. Click Apply.
7. Click OK.

Alternatively, to set all broken linetypes to the same segment length and the same
minimum distance, specify the segment length and minimum distance and click
Apply to All in the Plot Linetype Length dialog box.
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Setting the Pixmap Color

When printing or plotting a drawing that includes embedded pixmaps, you can set
the output of the image to be either Color or Black & White.

To set the pixmap color:

b

1. Click File » L"%]Print » I Print Setup.

Alternatively, press CTRL+P.
2. On the Pixmap tab, in the Pixmap area, click Color or Black & White.

Retaining or Inverting Black and White Pixmaps

To reverse the black and white pictures:

— o
1. Click File » L"=| Print » Print Setup.

The Print dialog box opens.

Alternatively, press CTRL+P to open the Print dialog box.
2. Click the Pixmap tab and then, in the B&W Pixmap area, click Reverse.

Previewing a Print or Plot

Creo Elements/Direct 2D Access allows you to view print or plot output on your
screen using the Plot Preview system viewport. You can open the viewport after
you select all the necessary print settings (as a last step before printing), or open it
to view while working on your drawing.

b

1. Click File » "==| Print » El Print Setup.

The Print dialog box opens.

Alternatively, press CTRL+P to open the Print dialog box.
2. Click the Show Preview check box.

The Plot Preview system viewport appears.
3. Select a color setting for the Plot Preview viewport:

* Original to preview color printer or plotter output.

* Grayscale to preview black and white printer or plotter with dithering
capability output.
* B&W to preview black and white printer or plotter output.

The Plot Preview viewport is visible till you clear the Show Preview check box.
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Starting a Print or Plot Job

When you have selected or specified all of the required print or plot output
settings, click Print to send your drawing to either the Print Manager or to the
Clipboard or to a file.

The Print Manager queues the drawing to the current default output device. The
Clipboard temporarily stores the drawing so that it can be electronically pasted
into another application.

Printing or Plotting Multiple Drawing Files

To plot or print multiple Creo Elements/Direct 2D Access drawing files from the
File Browser:

1. Inthe Windows file browser, select the drawing file or files to be printed or
plotted and right-click.

2. Click Print.

Dumping the Creo Elements/Direct 2D
Access Screen

To copy the entire Creo Elements/Direct 2D Access screen to the Clipboard, press
ALT & PRINT.

Then paste the screen dump in a graphics application of your choice for further
processing. For example, in Microsoft® Paint, click Edit » Paste to paste the Creo
Elements/Direct 2D Access screen dump to the drawing area.

Writing a Creo Elements/Direct 2D Access
Screendump to an Output File

Optionally, you can write a screen dump of the current Creo Elements/Direct 2D
Access window directly to an output file.

See Exporting as Image on page 54 for instructions.

Further Information

For further technical information about plotting or dumping, refer to the Creo
Elements/Direct 2D Access help system.

Type help plot orhelpbitmap to file inthe Creo Elements/Direct 2D
Access command line and press ENTER.
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Creo Elements/Direct 2D Access displays further information about plotting or
dumping.
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Toolbar and Classical Menu
Support

Displaying and Hiding TOOIDArS. ..........cooouiuiiiiii e 139
EXCIUAING TOOIDAIS ...t et 139
Customizing Toolbars and Toolbar emMS ...........oiiiiiiiii e 139

From Creo Elements/Direct 2D Access Rev. 18.1 onwards, MFC-based toolbar
and menu customizations (ASCII Format Layouts) created and saved in earlier
versions can be loaded in the Creo Elements/Direct 2D Access Fluent user
interface.

To load the customizations:

1. Click File » Import/Export » Import Macro » Input Macro.
The Input Macro dialog box opens.

2. Select the macro and click Open.

Alternatively, you can use the INPUT command to load the customizations.

~ Note

After you load the customized toolbars and menus in Creo Elements/Direct 2D
Access, you cannot modify or customize them.

You can also use the emulated “classical” menus and tables. You can load them by
specifying their macro name.

Emulated "classical" menus and tables (referencing the MENU and TABLE
commands) cannot be scaled to wrap to a changing number of rows and columns.
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The number of rows and columns always remain fixed as defined in the
underlying macro. Note that these menus are not saved for subsequent relaunch
when you exit Creo Elements/Direct 2D Access.
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Displaying and Hiding Toolbars

To display or hide a toolbar:

1. Click View and then, in the Viewing group, click L*_ | Toolbars.
Click 2D Access.

3. Click or clear the check box of a toolbar to show or hide the toolbar,
respectively.

Excluding Toolbars

You can exclude a toolbar from loading in Creo Elements/Direct 2D Access by
specifying the name of the toolbar in a text file.

To exclude a toolbar, add the name of the toolbar in the
FilterToolBars. txt file, which is available in the following path:

<Creo Elements/Direct 2D Access Installation Folder>/
fluent ui

~ Note

Creo Elements/Direct 2D Access creates a copy of the
FilterToolBars.txt file in the AppData (Application Data) folder
after every session. If you make any changes to the FilterToolBars.txt
file, you have to remove its copy from the AppData (Application Data)
folder to implement the changes.

To avoid redundancy, toolbars like Command Line, Status Bar, and Main Toolbar
are excluded by default.

Customizing Toolbars and Toolbar Items

You can add, edit, or delete toolbars and toolbar items using the Customize dialog
box.

To open the Customize dialog box:
* Click File » Customize.

The Customize dialog box displays a list of toolbars and toolbar items in Creo
Elements/Direct 2D Access. When you start Creo Elements/Direct 2D Access, all
pre-defined toolbars are loaded by default, but are hidden. You can display a
toolbar by clicking its check box in the Toolbars list of the Customize dialog box.
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You can also display or hide toolbars using | Toolbars in the Viewing group on
the View tab. For more information, see Displaying and Hiding Toolbars on page
139.

=

Note

You retain a toolbar layout across Creo Elements/Direct 2D Access sessions.
When you exit Creo Elements/Direct 2D Access, the toolbar layout
information is stored in the 1ayout fv.m file in the AppData (Application
Data) folder. Creo Elements/Direct 2D Access loads this file (if available)
when you start a new session.

Creating a Custom Toolbar

To create a custom toolbar:

1.
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Click File » Customize.
The Customize dialog box opens. The Toolbars pane opens by default.

Click Add.

The Add Toolbar dialog box opens.

In the Caption Key box, type a label for the toolbar.

Creo Elements/Direct 2D Access displays this label in the user interface.

Click or clear the Locked check box to lock or unlock the toolbar, respectively.

~ Note
You cannot delete a locked toolbar.

In the Unique Name box, type a unique name for the toolbar.

This name is internal to Creo Elements/Direct 2D Access.

In the On Right Click box, type a command, function, or macro name.

This command, function, or macro is executed when you right-click the
toolbar.

In the Domain box, type the name of the message file (if any).

Creo Elements/Direct 2D Access refers to the message file for the localized
version (if applicable) of this toolbar.
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-~ Note

Every toolbar and toolbar item in the Creo Elements/Direct 2D Access
user interface is associated with a specific domain file. The domain file
contains the strings associated with the toolbar or toolbar items, which you
can edit. The strings include:

» Caption
* Category
* Tooltip

¢ List Items
8. Click OK.
Tip

* You can place the toolbar anywhere in the Creo Elements/Direct 2D Access
user interface using a drag-and-drop operation.

(=

» To display tooltips of the toolbar items, click the Show Tooltips check box in
the Toolbars pane of the Customize dialog box.

Selecting a Toolbar Menu Style

You can select the look and feel of the toolbar menus. You can view the toolbar
menus as icons, text, or both.

To select a toolbar menu style:
1. Click File » Customize.

The Customize dialog box opens. The Toolbars pane opens by default.
2. In the Text Options box, select one of the following:

¢ Text below

* Texton right

* Textonly

* lcononly
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Editing a Toolbar

To edit a toolbar:

1.

Click File » Customize.

The Customize dialog box opens. The Toolbars pane opens by default.

2. In the Toolbars list, select a toolbar.

Click Edit.
The Edit Toolbar dialog box opens.

4. Edit the settings.

Click OK.

Deleting a Toolbar

To delete a toolbar:

1.

Click File » Customize.
The Customize dialog box opens. The Toolbars pane opens by default.
In the Toolbars list, select a toolbar.

Click Destroy.

Creating a Custom Toolbar ltem

To create a custom toolbar item:

1.
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Click File » Customize.

The Customize dialog box opens. The Toolbars pane opens by default.
Click Toolbar Items.

Click Add.

The Add Toolbar Item dialog box opens.

Define the following parameters in the Add Toolbar Item dialog box:

Parameter Description
Caption Key Type a label for the toolbar item.

Creo Elements/Direct 2D Access displays this label
in the user interface.

Enabled Click or clear the check box to enable or disable
the toolbar item, respectively.

Unique Name Type a unique name for the toolbar.
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Parameter

Description

This name is internal to Creo Elements/Direct 2D
Access.

Item Type

Select a standard MS Windows item type.
- Note

The item types in the Item Type list are context-
sensitive. For example, you can select items
from a context menu when you right-click a
button that is created by using Popup Button.

Submenu

Select a submenu.

~! Note

The Submenu list is available only if you select
Popup Button in the Item Type list.

ToolTip Key

Type a brief description of the toolbar item.

On Action

Type a command, function, or macro name (for
example, change color).
Creo Elements/Direct 2D Access executes this

command, function, or macro when you click the
toolbar item.

On Right Click

Type a command, function, or macro name.

Creo Elements/Direct 2D Access executes this
command, function, or macro when you right-click
the toolbar item.

Category Key

Define a category for the toolbar item.

Domain

Type the name of the message file (if any).

Creo Elements/Direct 2D Access refers to the
message file for the localized version of this
toolbar item (if applicable).

~! Note

Multiple toolbars may share the same domain
file. Optionally, you can create a separate
domain file for each toolbar.

Toolbar and Classical Menu Support
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Parameter Description
Image Define an icon for the toolbar item:

a. Inthe Image area, click Edit.

The Image Editor dialog box opens.

b. Use the drawing tools to design the icon.

c. Click OK.
» To save the icon, click Store in the Image Editor
dialog box.

» To use an existing image as an icon, click Load
in the Image Editor dialog box.

List Keys Define an action string:

Click || to add an item to the list.

* Click X to remove an item from the list.

Click * +

or to scroll within the list of

keys.
~! Note

An action string requires an associated action
definition in a separate macro.

5. Click OK.

~ Note

Combo boxes, radio buttons, and check boxes require a separate macro. For
details about the Creo Elements/Direct 2D Access user interface customization
capabilities, see TOOLBAR ITEM in the Creo Elements/Direct Drafting /
Creo Elements/Direct 2D Access Programming Reference Guide.

Adding an Icon to the Toolbar
You can add icons (as buttons) to the Creo Elements/Direct 2D Access toolbars.
To add an icon to a toolbar:

1. Click File » Customize.
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The Customize dialog box opens. The Toolbars pane opens by default.
Click Toolbar Items.

In the Categories list, select a category.

Select a toolbar item.

Click Edit.

The Edit Toolbar Item dialog box opens.

In the Image area, click Edit.

The Image Editor dialog box opens.

Create an icon.

To add an existing icon, click Load in the Image Editor dialog box.

Click OK.
The icon is associated with the toolbar item.

Drag the toolbar item to the toolbar.

Tip

To remove a button from a toolbar, drag the toolbar button to the Customize
dialog box.

You can copy or move toolbar buttons to other toolbars.

Press CTRL and place a toolbar button on the destination toolbar (with a drag-
and-drop operation) to copy the toolbar button.

If the Customize dialog box is not open, you can use ALT to move toolbar
buttons or use ALT+CTRL to copy toolbar buttons to other toolbars.

Editing a Toolbar Item

To edit a toolbar item:

I.

Click File » Customize.

The Customize dialog box opens. The Toolbars pane opens by default.
Click Toolbar Items.

In the Categories list, select a category.
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Select a toolbar item.
Click Edit.

The Edit Toolbar Item dialog box opens.
Edit the parameter values.
Click OK.

Deleting a Toolbar item
To delete a toolbar item:
1. Click File » Customize.

The Customize dialog box opens. The Toolbars pane opens by default.

2. Click Toolbar Items.

3. In the Categories list, select a category.
4. Sclect a toolbar item.

5. Click Destroy.

~ Note

* Destroy removes items from the Toolbar Items pane of the Customize dialog
box and deletes the associated files.

* You cannot undo Destroy.
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Customizing Creo Elements/Direct
2D Access

Customizing the Creo Elements/Direct 2D Access Environment...............ccooovviiiien. 148
Changing the Creo Elements/Direct 2D Access Environment..............cccccooiiiiiieiinnnno. 148
Customizing the Keyboard ... e 149
=0 ] o] = 149
Loading and Listing TEXt FONTS .....couiiii e 150
The SYStemM FONES ....ueiii e e e e e 151
Customizing the Startup File ..........oi e 152
Creo Elements/Direct 2D Access KEYWOIdS .........couuiiiiiiiiiiiieiieeeeeeee e 153

Creo Elements/Direct 2D Access can be customized to suit your individual
requirements.

~ Note

You need to be fully conversant with Creo Elements/Direct 2D Access before
you start customizing Creo Elements/Direct 2D Access.

When Creo Elements/Direct 2D Access is started up, it reads and executes a
number of files which define a variety of functions such as the screen menus and
Creo Elements/Direct 2D Access environment. These files are executable
programs called macros which you can edit and store under your own filenames to
be reloaded and used as required. It is therefore possible to create your own
alternative definitions for the screen menus and Creo Elements/Direct 2D Access
environment. This process is known as customizing.

147



Customizing the Creo Elements/Direct 2D
Access Environment

The Creo Elements/Direct 2D Access environment consists of such things as the
size and color of text, the plot scale, the drawing scale, and units.

All these are controlled by the settings of the environment functions, of which
there are more than 70 in the system. An example of an environment function is
DIM COLOR. This can be set to produce dimensions with any of the colors
available.

The current settings of the environment functions can be stored in a file. An
extract of a Creo Elements/Direct 2D Access environment file is as follows:
MAX_ FEEDBACK 100
CONFIGURE EDITOR '$' 1 79
UNITS 1 MM

UNITS 1 DEG

CS_REF PT 0,0

CS_AXIS 1,0 0,1

FOLLOW OFF

GRID FACTOR 10

CURRENT FONT 'hp block v'
TEXT FRAME OFF

TEXT ANGLE 0

TEXT ADJUST 1

TEXT LINESPACE 2.2

TEXT FILL OFF

TEXT SIZE 1

TEXT RATIO 1

TEXT SLANT 0

LINE WHITE SOLID END
C_LINE RED DOTTED END
TEXT WHITE END

At startup, the functions are set as shown in the listing to provide a standard
environment. During normal use, the settings are changed from the screen menu.

It is also possible to change the function settings by editing the Creo Elements/
Direct 2D Access environment. This method is useful because it gives an
overview of the status of all environment functions at once. It also gives access to
those functions that are inaccessible from File » Settings.

A customized environment can be stored in a named file. This file can then be
used to restore the same environment whenever it is required.

Changing the Creo Elements/Direct 2D Access
Environment

To display the environment file:
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1. Enteredit environment.

The environment will be displayed and the function settings can be changed as
required. When you have finished changing the environment, save the file and exit
the text editor to implement all the changes to Creo Elements/Direct 2D Access.

The current environment can be stored for future use in a named file as follows:
I. Enter save environment.

2. Enter 'env filename' (the name of your own choice).

To execute the stored file and redefine the system environment:

1. Enter INPUT 'env filename'.

Customizing the Keyboard

When working with Creo Elements/Direct 2D Access, you may carry out some
operations more frequently than others. This section describes how you can
customize the keyboard to reduce the time you spend on these operations.

At the top of your keyboard there are normally eight function keys labeled F1 to
F8 that you can customize.

For example, you may set several directories as current during a Creo Elements/
Direct 2D Access session. To save time, you can customize the function keys to
set each directory as current. Once you have done this, you only need to press this
key, then press ENTER and the named directory will be set to current.

Any command can be implemented in this way and eight examples are given in
this section.

You use the DEFINE KEY command to customize the function keys.
The syntax for this command is described below.

DEFINE KEY key number 'command name'

The key number defines which function key you are customizing (1 to 8).

The command name is the command name.

Example
The following example describes how to customize the eight function keys:

1. Enter EDIT FILE. The system will prompt for a filename.

2. Enter "customize".

Unless you have previously stored some customized files or macros in the file,
the screen will now go blank (because the file is empty at the moment). Type
your first command line. An example could be:

Customizing Creo Elements/Direct 2D Access 149



e DEFINE KEY 1 "CURRENT DIRECTORY 'c:/users/alan/
proj l rm

In the above line, 1 1s the defined function key and CURRENT DIRECTORY
'c:/users/alan/projl'is the text to be displayed in the user input line.

You can define the other function keys in exactly the same way. An example
of all eight defined keys is shown below.

DEFINE KEY 1 "CURRENT DIRECTORY 'c:/users/alan/projl'"
DEFINE KEY 2 "CURRENT DIRECTORY 'd:/users/larry/proj2'"
DEFINE KEY 3 "CURRENT DIRECTORY 'd:/users/mary/proj3'"
DEFINE KEY 4 "CURRENT DIRECTORY 'k:/users/geoff/proj4'"
DEFINE KEY 5 "CURRENT DIRECTORY 'i:/users/steve/proj5'"
DEFINE KEY 6 "CHANGE VIEWPORT SIZE"

DEFINE KEY 7 "CHANGE VIEWPORT COLOR"

DEFINE KEY 8 "EDIT PART POINT"

The first five function keys set the named directories as current. Function keys
6 and 7 are used for altering the viewports. Function key 8 is used, in a
drawing that contains parts, to make a picked part active.

3. After entering the command lines, press CTRL+D to store your changes in the
file.

4. Input the file customize by entering INPUT customize.

The function keys will be defined and ready for your use.

Loading and Listing Text Fonts

A text font is a group of pre-defined geometrical patterns that can be placed on a
drawing. Each pattern in a font is made up of straight lines joining points on a
grid, and is associated with a keyboard character so that it can be easily called.

Although normally used for text (the standard system annotation and
dimensioning texts are produced this way), text fonts can also produce special
symbols. Because there can be many points in the grid, highly detailed symbols
can be defined.

If you need special text or symbols, you can create them with your own
customized text fonts and store them on disk ready for use. A good example of
text font use is for producing company trademarks, logos, etc.

Text fonts are very versatile - these are some of the main features:
* Characters can be filled or unfilled.

» The character width-to-height ratio can be set.

» The character slant angle can be set (forwards or backwards).

* The line angle can be set (0 to 360 degrees).
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The System Fonts

When the system is started up, a number of font files are loaded into memory.
However, only one of them is the current font and available for immediate use.

Creo Elements/Direct Drafting’s different internal and external encoding schemes
were Unicode incorporated for version 2007.

You can find out which fonts are in memory by entering LIST FONTS. If no new
fonts have been defined since system startup, the display will become as follows,
and then you can return to the menu using ESC.

Fonts loaded:
osd default2
osd _default3
osd default

hp def font

Font used:

osd default

Current font:

osd default

This table gives the names of fonts that are in memory and has nothing to do with
the files from which they are created. The fonts hp Y 14.5 and hp 13098 v are
loaded from files with the same names, but hp def font is created within the
system and displays a box on the screen to represent the space that will be
occupied by characters before they are drawn.

There are files available on the disk that create fonts when they are loaded. The
complete list is:

osd_default |Default Creo Elements/Direct Drafting font containing hp
13098 v and hp kanji2 c characters with variable character
spacing

osd default2 |Default Creo Elements/Direct Drafting font containing hp
13098 c and hp kanji2 c with fixed characters spacing
osd default3 |Default Creo Elements/Direct Drafting font containing hp
d17 v and hp kanji2 c with variable characters spacing

hp Y14.5 Used for symbols only
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hp 13098 v ISO 3098 font with variable character spacing

hp 13098 c ISO 3098 font with constant character spacing

hp block v Filled font with variable character spacing

hp block c Filled font with constant character spacing

hp d17 v DIN17 font with variable character spacing

hp d17 c DIN17 font with constant character spacing

hp jasc v Kanji Japanese and Greek font with variable character
spacing

hp jasc c Kanji Japanese and Greek font with constant character
spacing

hp symbols Special characters for dimensioning: °, +, minutes, seconds

To increase the speed of access, all the files listed above are stored as binary files
on the disk and cannot be input. They have to be loaded using:
LOAD FONT 'bin filename'

bin filename is the name of the binary file. It is possible for a binary file to
contain more than one font, in which case they will all be loaded. Each of the
system files contains only one font that has the same name as the filename. The
LOAD FONT command will not change the current font.

Customizing the Startup File

~ Note

To edit the Creo Elements/Direct 2D Access startup file, you need to be
logged in as an administrator.

If you exit Creo Elements/Direct 2D Access, any customized features that you
have entered, although stored in files, are not defined when you start Creo
Elements/Direct 2D Access. To redefine the customization, the files containing the
customization must be input again.

If you want your customization automatically defined whenever you start Creo
Elements/Direct 2D Access, you should edit the Creo Elements/Direct 2D Access
startup file. The startup file contains the commands that load the system
files when you start Creo Elements/Direct 2D Access. To edit the startup file :

1. Type EDIT FILE 'startup' and press ENTER.

A listing of the startup file will be displayed on the screen. The listing of the

file 1s shown below.

INPUT 'passwords'

LOAD MODULE 'VIEW'
LOAD FONT 'hp 13098 v'
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LOAD_FONT 'hp Y14.5'

LOAD FONT 'hp symbols'

CURRENT FONT 'hp 13098 v'

LET Menu_slot border distance y 0
LET Fill up menu 0

LET Menu position LOWER

LOAD MACRO 'hp macro'

INPUT 'defaults'

Configure system

LOAD MACRO Sys macro_ filename
LOAD MACRO Sys tmacro_filename
LOAD MACRO Sys menu_filename
INPUT Sys tmenu_ filename
{Enable data management}
{Enable dm classification}
{Enable dm bom}

Startup menus

{INPUT 'customize'}

2. Remove the braces {} from around {INPUT 'customize'} so that it reads:
* INPUT 'customize'
3. Press CTRLAD to store your changes.

Check that all your files containing customized features are in the file called
customize. If they are not, INPUT the filenames as described below.

For example, if you had two customized files: Custm_ fk, and Sm_menu_1 you
would include the following lines at the end of the customize file:

* INPUT 'Custm fk'
* INPUT 'Sm menu 1'

During startup, the startup file automatically loads customize which in turn
will load the customized files: Custm_ fk and Sm menu_1.

Creo Elements/Direct 2D Access
Keywords

Keywords are reserved words within Creo Elements/Direct 2D Access used to
access relevant technical information from the he1p file.

Each keyword in the list is followed by an abbreviation indicating which type of
keyword it is. (Enter help 1ist keywords to display the list.)

There are four types of keywords:

* COMMANDS and FUNCTIONS (Cmd) or (Fnc): Command and function
keywords such as DOT GRID and REDRAW will start their corresponding
action routine when typed by the user.
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Keep in mind that functions can interrupt a command (or another function)
without terminating it. Once a function has been executed, control is
automatically returned to the previously unfinished command in which you
were working.

QUALIFIERS (Qua): Qualifiers such as DEL._OLD and THREE POINTS do
not have an action routine of their own. They are used by other commands and
functions to select one of the many options available to that command or
function.

PSEUDO COMMANDS (Psc): Pseudo commands such as IF and END LOOP
are only used internally. They control the execution of macros.

ARITHMETIC FUNCTIONS (Afn): Arithmetic functions such as STN and
SQRT are used within expressions. Their associated C function has to pick up
the necessary parameters and calculate the function result.
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angles
measuring, 73
area
measuring, 73
properties, 73
arithmetic functions, 154

B

beeper

switching on or off, 35
bisect

angle, 100

lines, 100
boxes, parts as, 84
boxing

elements, 38
button, 13

C

calculator, 76
CATCH commands, 70
catch mode, 70
center point

creating, 59
centering

the drawing, 125
Change to Hidden, 93
changing

Creo Elements/Direct 2D Access,

147

classical menu

support, 137
Clipboard, 120

Index

coloring
URLs, 112
command groups
CATCH, 70
command line, 15
commands
confirming, 41
commands vs functions, 153
Confirm command, 41
confirming
commands, 41
delete operation, 41
modify operation, 41
construction circles
by center and circumference point,
101
by center and element, 101
by diameter, 102
by radius or point and two elements,
103
by radius, point, and element, 102
by three elements, 103
by three points, 101
concentric, 101
drawing, 100
construction geometry
selecting for deletion, 40
construction lines
a tangent to two circles, 99
at an angle, 98
bisecting a line, 100
bisecting an angle, 100
by two points, 96
drawing, 96
horizontal, 96
parallel, 97
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perpendicular, 98
tangent from a point to a circle, 99
vertical, 96
context menu, 15
creating
a new center point, 59
a new window, 58
viewport, 62
Creo Elements/Direct 2D Access
basic working methods, 35
Creo Elements/Direct 2D Access
instance, 49
current
viewport, 58, 62, 65-66
cursor
setting the size, 77
customizing
Creo Elements/Direct 2D Access,
147
environment, 148
startup file, 152
the keyboard, 149
customizing Creo Elements/Direct 2D
Access, 43

D

DEFINE KEY command, 149
defining
printing/plotting parameters, 122
your own units, 76
delete command, 35
deleting
all viewports, 64
clements, 35
general, 35
OLE object, 116
viewports, 64
dimensions
selecting, 41
showing, 67
displaying

infos, 67
point coordinates, 72
the origin, 77
distance
measuring, 70
dot grid, 77
drawing
an isometric Ruler/Grid, 79
centering, 125
fitting a, 58
justifying, 125
panning across, 58
plotting, 119
positioning, 125
printing, 119
drawing area, 15
drawing geometry
selecting, 40

E

EDIT PART
Parent option, 83
Top option, 82
elements
adding to your selection, 37
boxing, 38
deleting, 35
enclosing within a polyline, 38
removing them from your selection,
38
selecting, 37
selecting all, 39
enclosing
customizing the, 148
elements, 38
environment
changing the, 148
exiting Creo Elements/Direct 2D
Access, 43
exporting
macro, 53
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picture file, 54 introduction, 90
plotting, 94

F Hidden Mode
On or Off, 93
face hiding
measuring the area, 73 ruler/grid, 79
faces, what are they?, 90 horizontal
features measuring distances, 72
showing all, 66 HP-GL file
File Browser importing, 53
opening a drawing, 46
file tab, 12 |
files
how to find, 45 icons
filing in Part Browser, 85
introduction, 45 importing
fitting, 58 font, 52
Follow on/off HP-GL file, 53
using, 78 macro, 52
font infos
importing, 45 displaying, 67
fonts selecting, 40
system, 151 isometric ruler/grid
text, 150 drawing, 79
G J
generating justifying
hidden lines, 93 the drawing, 125
Geo command, 40
global
selection, 36 K
graphics performance keyboard
enhancing, 67 customizing, 149
grids keywords
displaying, 77 commands and functions, 153
group, 13
L
H language
hidden lines switching, 34
displaying as dashed lines, 93 layer
generating, 93 changing the color, 67
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layers

selecting, 40

using the Show functions, 111
learning

Creo Elements/Direct 2D Access, 35
lengths

measuring, 71
line grid, 77
linesize

selecting, 41
linetype length, 131

Load File
As Subpart, 50
Check 2D, 51

Check 2D Retain Dependency, 51

Keep Scale, 50
Load Files command, 106
loading

a subpart, 51

introduction, 45

recently used drawing files, 49
loading and listing

text fonts, 150
loading drawings

File Browser, 46

Navigator, 48

macro
exporting, 53
importing, 52
macros
z-value in assembly, 92
Measure
calculator, 76
Measure function, 70
measurement units, 75
measuring
angles, 73
area properties, 73
distances, 70

horizontal distances, 72
lengths, 71
radius, 71
vertical distances, 72
minimum
z-value in assembly, 92
more, 13
most recently used drawing files, 49
moving
the ruler, 78
multiple Creo Elements/Direct 2D
Access instances, 49

N

Navigator
opening a drawing, 48

(0

OLE Browser, 116
OLE object

activating, 115

deleting, 116

hiding and showing, 116

to back, 115

to front, 115
OLE objects

linking and embedding, 113
Open, 46

Check 2D, 47

Check 2D Retain Dependency, 47
origin

displaying, 77

P

panning

across a drawing, 58
parallel

construction lines, 97
parameters

printing/plotting, 123
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parent part, 82

part browser, 15

Part Browser
description, 85
icons, 85

part, parent, 82

parts, 81
editing, 82
Part Browser, 85
selecting, 41
tree, 36
viewing, 83

Parts
structure, 82

parts as boxes, 84

Paste, 42

pensize
selecting, 41

pixmap color
printing, plotting, 133

placing
the ruler/grid, 79

plot
fitting, 127

plot transformation map, 129

plotter
selecting, 123

plotting
boxed area, 127
complete drawing, 126
current show attributes, 128
current viewport, 127
drawing, 128
drawings, 119
hidden lines, 93
linetype length, 131
multiple drawings, 134
pixmap color, 133
preview plot output, 133
Range, 126
scale, 127
scale factor, 127

Index

starting output, 134
to a file, 124
truecolor, 129
point coordinates
displaying, 72
points
showing, 66
port (viewports), 60
positioning
drawing in print/plot, 125
Preview Print/Plot Output, 133
print configuration
example, 121
Print Manager, 120
printer
selecting, 123
printing
boxed area, 127
complete drawing, 126
current show attributes, 128
current viewport, 127
drawing, 128
drawings, 119
linetype length, 131
multiple drawing files, 134
pixmap color, 133
preview plot/print output, 133
range, 126
scale, 127
scale factor, 127
starting output, 134
to a file, 124
truecolor, 129
printing/plotting
settings, 123
prompt line, 15
pseudo commands, 154

Q

qualifiers, 154
quick access toolbar, 13
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R

radius
measuring, 71
Range, 126
recalling
a window, 59
Redo, 42
redraw mode, 67
redrawing, 58
reference line
selecting, 40
Reset Show command, 107
restoring
last view, 59
revision checking, 105
loading files, 106
Reset Show, 107
Set Color, 107
Show Difference, 108
ribbon, 13
rotating
the ruler/grid, 78
rotation
print/plot output, 126
ruler
displaying, 77
moving, 78
ruler/grid
drawing an isometric, 79
hiding, 79
placing, 79
rotating, 78
setting the spacing, 79
using, 76

S

scale
factor for plot, 127
setting, 127
screendump, 134
Select command, 37

160

Select mechanism, 35
selecting
what is displayed, 65
selection
a vertex, 39
boxing elements, 38
confirming, 41
construction geometry, 40
dimensions, 41
drawing elements, 37
drawing geometry, 40
elements within a polyline, 38
general, 35
global, 36
infos, 40
layers, 40
linesize, 41
parts, 41
pensize, 41
reference lines, 40
removing elements, 38
subtracting elements, 38
subtree, 41
text, 40
URLs, 41
Set Color command (revision
checking), 107
setting the units of measurement, 75
Show
functions with layers, 111
SHOW
All option, 85
Boxed option, 84
function, 65
Part option, 84
Show Difference command, 107
Show Hidden, 93
showing
all features, 66
dimensions, 67
points, 66
SPOTLIGHT ON/OFF command, 87
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spotlighting, 87

starting Creo Elements/Direct 2D

Access, 34
startup file
customizing, 152
editing, 152
status bar, 14-15
storing
a window, 59
subtree
selecting, 41
switching
URLs on and off, 111
system fonts, 151

T

tab, 13
tangent
constructing, 99
tangent constructing, 99
text
selecting, 40
text fonts
loading and listing, 150
toolbar
creating, 140
editing, 142
support, 137
toolbar item
creating, 142
deleting, 146
editing, 145
toolbar items
customizing, 139
toolbar menu style
selecting, 141
toolbars
customizing, 139
deleting, 142

displaying or hiding, 139

excluding, 139

Index

truecolor plotting, 129

truecolor printing, 129

TrueType font
importing, 52

U

Undo, 42
units of measurement, 75
URL
color, 112
URLs
selecting, 41
user input line, 15
user interface, 11

\'

values
Z,90

vertex
selecting a, 39
show, 66

vertical
measuring distances, 72

vertices
show, 66

View command
Parent option, 84
Top option, 83

View commands
parts, 83

VIEW commands, 83

viewport
changing size, 63
creating, 62
deleting, 64
making it current, 62
maximizing, 63
moving, 63
redrawing, 63
settings, 64



w

window
creating, 58
recalling, 59
restoring last view, 59
storing, 59
using normal functions, 58
zooming, 59
windows
multiple Creo Elements/Direct 2D
Access instances, 49
working
basic methods, 35

V4

z-value
checking, 91
checking maximum, 92
checking minimum, 92
of a shared part, 92
what is it?, 90
zooming
in or out, 59
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