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Preface

Creo Elements/Direct Drafting is a versatile 2D design and drafting system for
optimizing each stage of the design process. Using Creo Elements/Direct Drafting
you can quickly and easily create and modify 2D drawings.
Creo Elements/Direct Drafting has a full set of commands for constructing,
modifying, annotating, viewing, measuring, and plotting a 2D drawing.
Using a mouse or other supported digitizer, you have the facility to:

• Perform real time zoom-in and zoom-out.
• Pan in real time, across the entire drawing or a zoomed-in portion.
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Who Should Use This Manual
Read this manual if you are a:

• Design engineer
• Industrial designer
The Creo Elements/Direct Drafting documentation set is designed to help you
learn to use Creo Elements/Direct Drafting quickly and easily. It consists of:

• Creo Elements/Direct Drafting User’s Guide
• Installing and Configuring Creo Elements/Direct Drafting
• Writing Macros with Creo Elements/Direct Drafting
• Creo Elements/Direct Drafting Interfacing
This manual is written for users who have limited experience with CAD software.
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Purpose of this Manual
This manual gives information on:

• Setting up Creo Elements/Direct Drafting for your particular environment.
• The Creo Elements/Direct Drafting user interface.
• Using the Creo Elements/Direct Drafting commands and functions.
• Using the dynamic graphic facilities.
• Working with parts and assemblies.
• How to generate hidden lines.
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How to Use This Manual
Use this manual for both day-to-day use and reference. Each section contains:

• A description of the command or function.
• The procedure used to perform the given task.
• A tutorial example (when required).
• Any reference material required.

13



How This Manual is Organized
This manual is organized in the same order as the way you are likely to use Creo
Elements/Direct Drafting:

Chapter 1 Getting Started with Creo Elements/Direct Drafting — a brief
overview of the system and supplies you with hints to help in
getting started.

Chapter 2 Preparing the Drawing Environment — how to set up the
environment and store it as a file.

Chapter 3 Commonly Used Commands — how to escape from a current
activity.

Chapter 4 Changing the Environment and Making Measurements — how to
change the environment in which the drawing is produced and
how to measure distances on your drawing.

Chapter 5 Using Creo Elements/Direct Drafting's Copilot Functionality —
how to create a design drawing with the minimum of
construction geometry.

Chapter 6 Drawing Methods — how to create a drawing with or without the
aid of construction geometry.

Chapter 7 Modifying a Drawing — how to modify your drawing.
Chapter 8 Dimensioning a Drawing — how to automatically dimension a

drawing.
Chapter 9 Hatching a Drawing — how to hatch drawing sections.
Chapter 10 Adding Text To a Drawing — how to add text to a drawing.
Chapter 11 Adding Symbols to a Drawing — how to add geometric tolerance

symbols and other special annotation to your drawing.
Chapter 12 Handling Parts and Assemblies — how to use parts and

assemblies when creating drawings.
Chapter 13 Generating Hidden Lines — how to generate hidden lines in

assembly drawings.
Chapter 14 Using Layers and Infos — how to use layers and how to add

textual information (infos) to elements in your drawing.
Chapter 15 Storing, Loading, and Filing — how to load and save your Creo

Elements/Direct Drafting drawing files.
Chapter 16 Revision Checking — how to compare revised drawings.
Chapter 17 Editing Imported Bitmap Files — how to handle imported bitmap

files in Creo Elements/Direct Drafting.
Chapter 18 Linking and Embedding OLE Objects — how to insert OLE

objects into a Creo Elements/Direct Drafting drawing.
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Chapter 19 Creo Elements/Direct Annotation — how to visualize, annotate,
and edit MI files created by means of Creo Elements/Direct
Annotation.

Chapter 20 Plotting Drawings and Dumping Screens — how to plot your
finished drawing and how to dump screens.

Chapter 22 Customizing the Creo Elements/Direct Drafting User Interface
— how to add custom icons to the toolbar, how to create custom
menus, how to define custom key commands, and how to display
menus and dialog boxes via mouse buttons.

Appendix A Using Filetran — how to convert file formats between UNIX and
Microsoft Windows systems.
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The Creo Elements/Direct Drafting User
Interface
The Creo Elements/Direct Drafting user interface is designed to ensure a short
learning curve and to provide maximum efficiency in 2D CAD projects.
All of the menus, dialog boxes, commands, functions and tools specified in this
manual are accessible via the Creo Elements/Direct Drafting user interface. The
following figure illustrates the general (default) layout of the Creo Elements/
Direct Drafting user interface.
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Figure 1. The Creo Elements/Direct Drafting User Interface

1 The top menu bar. This menu bar provides access to menus such as File and Setup.
Optionally, you can use hotkeys to select menu items.

2 The toolbar. Move the cursor to each of these icons to display the associated tooltips.
3 The design and drafting related menus.
4 The drawing area. This is the area where you will create and modify drawings. Additional
viewports can be created in this area.

5 The bottom menu bar (which includes the Status Line). The first two items in this menu bar
reflect the current cursor position. The other items enable you to select or specify settings
such as the current linetype, color, catch range, dimensioning standard, layer, scale, angular
unit, length unit and current part.

6 The prompt line. This line tells you how to proceed to complete the current operation.
7 The user input line. When prompted, enter the required input (such as a numerical value or
a name) into this line.

Optionally, you can run multiple Creo Elements/Direct Drafting instances
(separate Creo Elements/Direct Drafting windows) at the same time. Refer to
Creating a New Creo Elements/Direct Drafting Instance on page 422 for further
information.

Basic Working Methods
It will not take you very long to become familiar with Creo Elements/Direct
Drafting, but a few hints may help you to get started.
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The best way to learn is to practice, and we recommend you try the examples
given in this manual. If you need further explanation of any of the 2D functions or
commands, refer to this manual. It contains a description of how to use each
command or function.
An index is included at the back of the manual; this contains not only the
command and function names but also a task reference.

Cut, Copy and Paste
Creo Elements/Direct Drafting provides Cut, Copy and Paste functions which
operate via the Clipboard. The Select functions (including Poly; see Selecting
Drawing Elements on page 34) can be used to facilitate the selection of elements
to be cut or copied.

Enables you to cut elements.

Enables you to copy elements.
Enables you to paste elements.

The handling of elements via the Clipboard can be manipulated via the Clipboard
tab. Click Setup, Edit Environment, System, Clipboard to display this tab. Via this
tab, you can change the following settings:
Inverse Black and White White changes to black, while black changes to

white.
Global Selection Like the Global selection function (see Selecting

Drawing Elements on page 34), this setting
selects the entire parts tree rather than just the
current part. If you paste to Creo Elements/
Direct Drafting, this parts tree is retained. If you
copy to another application, the parts tree will
be smashed.

Paste As Subpart
When you have cut or copied an item, you can use Paste As Subpart to paste this
item such that it is owned by the current part. Refer to Hierarchical Parts Structure
on page 326 for details on the Creo Elements/Direct Drafting parts structure
concept.

Undo and Redo
In Creo Elements/Direct Drafting, you can undo mistakes with Undo / Redo.
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Click to undo an operation (before you click Confirm).

Click to redo an operation (after you have clicked Undo).

Each time you click Undo/Redo, you will undo or redo all the changes that were
created by the last command you entered.
You can set a limit on the number of steps to keep in the Undo/Redo history in the
System Setting dialog.

1. In the main menu, click Setup ▶ Edit Environment ▶ System.
2. You can select:

• -1: no limit.
• 0: disable the Undo/Redo option.
• +[number]: the maximum number of steps you can undo or redo when no

command is active. If you already have more steps in your history than the
number you selected as the limit, Creo Elements/Direct Drafting will
automatically delete the extra steps.

Limitations:
• You can undo or redo complete macros, but you cannot use Undo/Redo inside

macros.
• Undo/Redo cannot undo or redo:

○ Commands related to parametric design, hidden lines, PIXMAPs, or
OLEs. Once you have executed one of these commands, you can no longer
undo or redo any of your previous commands.

○ The RESET_SYSTEM command.
○ Commands for default settings (although these commands do not affect the

undo/redo history).

Undo and Redo with state history
Each time you enter a command and change your drawing, Creo Elements/Direct
Drafting adds a new state to the undo/redo history. Creo Elements/Direct Drafting
marks the new state with a unique ID. With this information, you can:

• Use UR_GET_CURRENT_ID to see the ID of the current undo/redo state.
• Use UR_ID_EXISTS to see if a specified ID exists in the undo/redo history.
• Use UR_GET_FIRST_ID to see the ID of the first state in the undo/redo

history.
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• Use UR_GET_LAST_ID to see the ID of the last state in the undo/redo
history.

• Use UR_MOVE to undo/redo the drawing to a specified state.

Select, Click, Specify, and Enter
Many operations require similar user interaction, For example, you will often be
prompted to select an element, enter a value, enter a filename, or specify a point.
Some of the most commonly used terms are listed below:

• Select — Use the left mouse button (or a supported digitizer) to select or draw
a selection box around items in the drawing.

• Click — Briefly press the left mouse button (or a supported digitizer) to select
items such as a menu option or an element in the drawing.

• Enter — Send information to the computer. You send information to the
computer from the User Input Line. Normally, you enter information on the
User Input Line and then press [Enter]. For certain commands and
functions you must enter a numerical value, and for others a string enclosed in
quotes (' ' or ""). Additionally, values to be entered can be first calculated
by typing the appropriate mathematical expression in parentheses:

○ (15 * tan 30)

• Specify — Press the cursor at the appropriate position or enter the coordinates
separated by a comma.

Viewports
Aviewport is a rectangular area on the screen whose position and size you can
define. Specific parts of your drawing can be displayed in the viewports. This then
enables you to study the drawing or add information with greater ease and
accuracy. You can create up to 16 viewports but usually between 2 and 6 are
sufficient.
The viewports are identified by a number in the top right hand corner. You will
notice one is in inverse video – this is the current viewport. All window functions
operate on the current viewport, for example, if you click New and make a box in
any viewport, the new view will be drawn in the current viewport. Any viewport
can be made current by clicking its identification number on the screen.
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Positioning Menus
Menus can be repositioned anywhere around the screen so that you can display
several menus at a time. The menus can be overlapped and closed as needed for
your current work.
Additionally, menus and submenus can be "pinned" at a certain position. Pinned
menus always open at the position where they were pinned.
By opening and pinning menus or submenus, you can quickly and easily create a
custom menu layout. Note that this menu layout is automatically retained by Creo
Elements/Direct Drafting (for future sessions) until you change it or until you
click Tools, Customize and Reset Layout to restore the initial (default) Creo
Elements/Direct Drafting user interface.

How to Delete Elements
As you learn to work with the system you are sure to make mistakes. To delete an
element or piece of text:

1. Click Delete.
2. Select the element or text to be deleted.

Getting Help
The Programmer's Reference file contains technical reference information about
all the commands and functions that you can use within Creo Elements/Direct
Drafting.
To use the help system:

1. Click Help ▶ Program Ref. Guide.
2. Input the command or function on which you require help by either:

• Clicking on a command or function from the screen menu.
• Entering the command or function name.

Creo Elements/Direct Drafting responds by displaying the required help
information.

3. Close the Help window to return to the normal Creo Elements/Direct Drafting
display.
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Switching Languages
By default, the Creo Elements/Direct Drafting user interface is displayed in
English. To switch to the language of your choice, enter the appropriate command
in the user input line:

Language Command
English change_locale 'en'

French change_locale 'fr'

German change_locale 'de'

Italian change_locale 'it'

Spanish change_locale 'es'

Japanese change_locale 'ja'

Alternatively, specify this command above the Startup_menus string in the
startup.m file contained in the Creo Elements/Direct Drafting installation
directory.

Note
The Japanese version of Creo Elements/Direct Drafting requires a Japanese
operating environment. If you installed Creo Elements/Direct Drafting in Custom
mode, any languages you deselected during installation will not be available at
Creo Elements/Direct Drafting runtime.

Switching to the Classic User Interface
Optionally, you can run Creo Elements/Direct Drafting using the Classic User
Interface. Note that a separate User's Guide is available for this user interface.
To run the Creo Elements/Direct Drafting Classic User Interface, you need to set
the following variable in the me10.ini file (located in the Creo Elements/Direct
Drafting installation directory):
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MEPELOOK=2 Creo Elements/Direct Drafting uses the standard
Windows style user interface.

MEPELOOK=3 Creo Elements/Direct Drafting displays any top-
level menus in the usual Windows style (without
the arrow indicating cascading), whereas menus
cascaded from the right-hand menu bar are
displayed in the "classic" style. Optionally, you
can enter the WUI_CLASSIC command into the
user input line to remove the separator lines from
the "classic" style menus in this display mode.

Switching the Beeper On or Off
Optionally, you can switch the "beeper" on or off in Creo Elements/Direct
Drafting. Simply enter BEEPER ON or BEEPER OFF into the user input line.

Further Reading
You can now begin to use Creo Elements/Direct Drafting to produce high quality
2D drawings.
When you are ready to learn more about the system and its command structure
refer to “Writing Macros with Creo Elements/Direct Drafting”, which contains
advice on macro writing and command syntax.
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Editing the Creo Elements/Direct Drafting
Environment
The Creo Elements/Direct Drafting environment specifies various settings, which
determine, for example:

• Line color.
• Dimension appearance.
• Text appearance.
The Edit Environment command in the Setup menu provides access to a number of
dialog boxes which can be used to define settings for your design and drafting
environment. For example, you can use Construction Settings to select the color
and linetype in which construction geometry will be displayed in your drawing.
Some of the settings can be set in a particular menu, such as Text Size in the Text
menu, while many of the dimension settings can be set using the commands
contained in the Creo Elements/Direct Drafting environment.

Setting the Environment
The Edit Environment command options are:
Construction Edit the construction geometry settings, for example,

line color.
Geometry Edit the geometry settings, for example, line color.
Dimension Edit the dimension settings, for example, dimension

offset.
Hatch Edit the hatch settings, for example, hatch distance.
Text Edit the text settings, for example, text size.
Parts Edit the part representation settings, for example,

spotlight color.
Line Patterns Add/edit user-defined line patterns.
Projected Reference
Points

Edit the settings (such as color or linetype) for
projected reference points and their associated lines
and circle.

Refline Edit the reference line settings, for example, line
color.

Symmetry Line Edit the symmetry line settings, for example, line
color.
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Center Line Edit the center line settings, for example, line color.
System Edit general settings for the Parametric module, for

the Copilot functionality, for the Clipboard, Handles,
FlyBy, for the autosave mechanism, for the menu
cascade timeout and for the redraw mode.

Saving the Environment Settings
Creo Elements/Direct Drafting saves your environment settings when you exit.
The settings are saved to <application data path>\PTC\Creo
Elements Direct Drafting [version]\[version]\.

Saving the Creo Elements/Direct Drafting
Environment to a File
When you type SAVE_ENVIRONMENT in the User Input Line, Creo Elements/
Direct Drafting prompts you to enter one of the following options:
Screen Outputs the environment to the screen.
Printer Outputs the environment to a printer.
Append Appends the environment to an existing environment.
Delete Old Overwrites the existing environment file.
'file name' Enables you to specify the name of a file in which the

current environment settings will be stored.

• If you wish to save a particular Creo Elements/Direct Drafting environment,
enter the applicable filename (such as 'Company_environment') into the
User Input Line.

• To apply the settings of a saved environment file, you can input the file at the
start of a drawing session (Enter INPUT 'filename').

Further details of using the environment file are contained in the manual “Writing
Macros with Creo Elements/Direct Drafting”.

Setting Linear and Angular Units
You can select linear and angular units from the bottom menu bar. The current
units are displayed in the System Status Line. Normally, you will set the current
units before starting to draw. However, if you reset the current units after you have
started to draw, Creo Elements/Direct Drafting will automatically convert all
existing elements without changing the lengths.
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For example, if you set the current units to meters and draw a line one unit long,
when you change the current units to millimeters the line will measure 1000 units.
The following options are available:
Linear units:

• mm
• um (micrometer)
• inches
• feet
• yards
• miles
• mils
• uinches
• usr
Angular units:

• deg
• grd
• rad
• usr

Defining Your Own Units
The usr option in the selection lists for angular and linear units allows you to
define your own units. For example, an input of 5 mm allows you to work in 5
mm units, and an input of 5 degrees allows you to work in 5 degree units.

Loading a Drawing Frame
A number of standard drawing frames are supplied with Creo Elements/Direct
Drafting. To load one of these frames:

1. Pull down the File menu.
2. Click Open to display the Creo Elements/Direct Drafting File Browser.
3. Click Navigator to display the Creo Elements/Direct Drafting Navigator.
4. In the left pane of the Navigator, change to the Creo Elements/Direct Drafting

installation directory.
5. Double-click the preview image of a drawing frame.
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The frame is a symbol part which is always loaded below the Top part (refer to
Handling Parts and Assemblies on page 323). Each frame consists of two
concentric rectangles: the outer one the size of the respective paper size, the inner
one between 10 to 50 mm smaller per side.
The frames are drawn in magenta with the dotted linetype and therefore will not
normally be plotted out.
Drawing frame part names have the form:
frame_A4[symbol], frame_A3[symbol], and so on.
The ten frame options are:
A A4
B A3
C A2
D A1
E A0

Setting the Drawing Scale
The drawing scale will affect only the physical size of construction and drawing
lines during plotting. Dimensions, text, and symbols are not affected by this
setting. The current drawing scale is displayed in the System Status Line. The
default drawing scale is 1. The maximum drawing scale is 99999.
For example, when the drawing scale is set to 2, a line drawn 100 mm long will be
plotted 200 mm long.
To set the drawing scale:

1. Pull down the Setup menu.
2. Click the Environment tab.
3. Enter the drawing scale in the Scale field.
The result can be checked by looking at the System Status Line.

Further Information
For further technical information about the Creo Elements/Direct Drafting
environment, refer to the Creo Elements/Direct Drafting help system:
Enter help environment at the Creo Elements/Direct Drafting command line.
The screen will clear and Creo Elements/Direct Drafting will display further
information about the environment.
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Most of these commands have a similar purpose — they allow you to escape from
whatever activity is currently being performed. The knowledge that you can easily
delete or cancel any mistakes should help you gain confidence in using Creo
Elements/Direct Drafting.
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Deleting Elements
Use the Delete key on your keyboard or the Delete command from the menu to
delete elements.

To use Delete on the keyboard,
1. Click an element in the drawing area. The handles appear.
2. Press the Delete key on your keyboard.
Delete multiple elements:

1. Hold the Shift key and click all the elements in the drawing area. The handles
appear.

2. Press the Delete key on your keyboard.

To use the Delete button,
Press Delete to delete drawing elements or pieces of text.
For example, to delete everything in the active part:

1. Click Delete.
2. Click All.
3. Click Confirm.
To delete an element or text:

1. Press Delete.
2. Select the element or text to be deleted (you can also enclose the elements to

be deleted in a box).

Deleting Hatching
To delete hatching, use the Delete command in the Hatch menu, then select the
hatching to be deleted individually. See Hatching a Drawing on page 267 for.
more information.

Highlighting Elements Before Deletion
The Select mechanism enables you to select the elements that you want to delete
(or modify).

1. Click Delete.
2. Click Select followed by any option or combination of options described

below.
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3. When you are satisfied that the elements to be deleted have been correctly
selected, click Confirm.

Global Selection
Each time you select components, you can decide whether you want to select from
the current part or from the whole parts tree. Global selection allows you to select
components from the whole parts tree:

1. Click Select.
2. Click Global.
If you do not click Global, Creo Elements/Direct Drafting defaults to the current
part.
Example

Click Delete, Select, Global, All, Confirm, OK.
This command string deletes all components of the parts tree even if the active
part is not the top part.
It should, however, be noted that even though all components (geometry,
construction geometry, and text) contained within the parts tree will be deleted, it
is not possible to delete the complete parts tree. The current part is never deleted
and a path linkage to the top part is always maintained.
Several examples using the parts structure in Figure 2. Example of a Parts
Structure on page 32 show the power of Select.

Figure 2. Example of a Parts Structure

If you delete globally with 'B' as the active part, the Top part and 'B' will remain.
See Figure 3. Top Part and 'B'. on page 33.
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Figure 3. Top Part and 'B'.

If you delete globally with 'A' as the active part, the Top part and 'A' will remain.
See Figure 4. Top Part and 'A'. on page 33.

Figure 4. Top Part and 'A'.

If you delete globally with 'D' as the active part, the Top part, 'D', and its parent,
'A', will remain. See Figure 5. Top Part + D + A. on page 33.

Figure 5. Top Part + D + A.
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Selecting Drawing Elements
Click Select to let Creo Elements/Direct Drafting know you are about to make a
selection (for example, to move or to delete elements). Then click any option or
combination of options from the selection block.

Option Description
All Selects all elements in the active part.
Box Selects all elements you enclose in a box.
Poly Selects all elements you enclose in a polygon.
Global The selection applies to the entire parts tree.
Global Perm The selection, and all subsequent selections in this

command, applies to the entire parts tree.
Subtree Selects a subtree of a part or an assembly.
PreSelected Selects the current preselection. See Preselecting Elements

on page 43.
Advanced Displays a separate Select dialog box which provides

functions and options for complex selections. These are
discussed in the following section.

Advanced Selection Functions
Click Select and then Advanced to display the Select dialog box. The functions
and options included in this dialog box enable you to define complex selections.
These include the All, Poly, Box, Subtree, PreSelected, Global and Global_Perm
selection functions described above.
Select Initiates a selection.
Confirm Confirms a selection.
Add Adds the next elements you select to the current result.
Subtract Subtracts the next elements you select from the current

result.
And Results in a logical AND (set intersection) of the current

result and the elements selected next.
Or Results in a logical OR (set union) of the current result and

the elements selected next.
Exor Results in a logical EXOR (exclusive OR) of the current

result and the elements selected next.
Not Unselects the current result. All other elements become the

current result.
Vertex Selects vertices.
Color Selects colors.
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Line Type Selects linetypes.
Line Size Selects linesizes.
Pen Size Selects pensizes.
Font Selects fonts.
Contours Selects contours (see Selecting Contours on page 40).
Geo Selects geometry.
Point Selects points (singularities) but not vertices.
Line Selects geometry lines.
Circle Selects geometry circles.
Arc Selects arcs.
Fillet Selects fillets.
Spline Selects splines.
Poly El Selects polyelements.
PRPs Selects projected reference points.
Hatch Selects hatches.
Text Selects text.
Dim Selects dimensions.
Edit Dim Selects edited dimensions.
Sym Line Selects symmetry lines.
Center Line Selects center lines.
Ref Line Selects reference lines.
Leader Line Selects leader lines.
CGeo Selects construction geometry.
CLine Selects construction lines.
CCircle Selects construction circles.
Part Selects parts.
Info Selects infos.
URL Selects URLs.
Layer Selects layers.
Back Removes the last change to the selection.
Load Enables you to load a (previously stored) selection file.
Store Enables you to store the selection definition to a selection

file.
Execute Immediately applies the current selection.
OK Immediately applies the current selection and closes the

Select dialog box. This button has the combined effect of
the Execute and Close buttons.

Close Closes the Select dialog box.
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Note
All Select options can be chosen directly without clicking Select. However, if
you do not click Select first:

• The elements you choose will not be highlighted on the screen for you to view
before the operation of your choice. For example, deleting will be performed
immediately.

• You will not be able to use the options Add, Subtract, Not, and so forth.

Example: Deleting All Green Elements
If you want to select elements drawn in a particular color or linetype you must
first press Select and then specify the respective color or linetype.

1. Click Delete, Select, Advanced to display the Select dialog box.
2. In the Select dialog box, click Select and Color.
3. Select Green and click OK in Select Color.
4. In the Select dialog box, click Confirm and OK.
This will delete all elements drawn in green in the current part.
Further examples are provided in the following sections.

Adding Elements to Your Selection
This option allows you to add elements, either selected individually or enclosed in
a box, to your current selection. For example:

1. Click Delete.
2. Click Select.
3. Select several elements to be deleted.
4. Click Add.
5. Click Box.
6. Enclose further elements to be deleted in a box.
7. Click Confirm.
8. Click OK.

Subtracting Elements from Your Selection
To subtract elements from your current selection, click Subtract.

36 Creo Elements/Direct Drafting User's Guide: Windows User Interface



Removing Elements from Your Selection
Click Not to make the previous selection result unselected, and all previously
unselected elements to be treated as selected.

Note
Not always works globally on all parts.

Enclosing Elements in a Box
To select a group of drawing elements by enclosing them in a box:

1. Click Box.
2. Enclose the required elements in a box.
They will then be shown in a different linetype and Creo Elements/Direct Drafting
prompts you to Confirm that you want to delete them. Before you click Confirm,
you may want to alter your selection by, for example, subtracting or adding some
elements.

1. Click Confirm.
2. Click OK.

Enclosing Elements in a Polygon
If you need greater flexibility when selecting elements, use Polygon to enclose
elements within a polyline. This is particularly useful when elements are not
symmetrically grouped horizontally and vertically.

Figure 6. Selecting Elements with a Polygon

Suppose you want to delete the elements 1, 2, and 3:

1. Click Delete.
2. Click Select, Advanced, Poly.
3. Click a succession of points to define the enclosing polygon around elements

1, 2, and 3.
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4. Close the polygon by clicking the start point again or enter CLOSE.

Selecting All Elements
To select everything contained in the current part (and subparts):

1. Click Delete.
2. Click All.
Creo Elements/Direct Drafting prompts you to click Confirm if you really want to
delete all elements selected. If not, click Cancel and select again.

1. Click Confirm.
2. Click OK.

Selecting a Vertex
Click Vertex in Select if you want to delete all elements that share a specified
point.

Selecting Elements by Type
The Select functionality facilitates the selection of specific element types in your
Creo Elements/Direct Drafting drawing.

Selecting Elements Using Information Strings
Click Info in Select to select all elements that have a particular information string
associated with them. You will be prompted to type in the information concerned.

Selecting Layers
Click Layer in Select to select all elements assigned to a specified layer. When you
choose this option, the system prompts you for the layer information.

Selecting Text
Click Text in Select to select the required text. Creo Elements/Direct Drafting
prompts you to identify the text to be selected.

Selecting Reference Lines
Click Ref Line in Select to select reference lines.
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Selecting Construction Geometry
Click CGeo in Select to select and highlight construction geometry. Alternatively,
click CCircle to select construction circles only or click CLine to select
construction lines only.

Selecting Drawing Geometry
Click Geo in Select to select and highlight drawing geometry. Alternatively, you
can:

• Click Line to select lines.
• Click Circle to select circles.
• Click Arc to select arcs.
• Click Spline to select splines.
• Click Fillet to select fillets.
• Click Point to select points.
• Click Poly El to select polyline elements (see Creating a Polyline on page 113).
To make a selection on pensize or linesize:

1. Click Line Size or Pen Size in Select.
2. Enter a value (for example, 2).
3. Click Confirm.
4. Click OK.

Selecting Parts
Click Part in Select to select elements in a particular part. Also, you can click
Subtree to select a subtree of a part or assembly.

Example
To delete a selected part from anywhere in the parts tree:

1. Click Delete, Select, Global, Part.
2. Enter the part name.
3. Click Confirm.
4. Click OK.

Note
When deleting a part, you automatically delete all associated subparts.
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Selecting Dimensions
Click Dim in Select to select and highlight dimensions. Alternatively, click on Edit
Dim to select edited dimensions only.

Selecting Contours
The Contours option in Select enables you to select contours (closed loops of
connected elements).

Note
To account for the fact that contours may be nested (closed loops of elements
within other closed loops of elements), Creo Elements/Direct Drafting allows
you to specify a contour level. See Specifying the Contour Level on page 41
for details.

The general procedure is as follows:

1. Select a given subset (such as an area enclosed in a selection polygon) of your
drawing.

2. Apply further selection criteria to refine your selection.
3. Click Contours to scan this refined selection for contours.
For example:

• To move all contours in your drawing by a given distance:

1. Display the Modify menu and click Move.
2. Click two points to define the distance and direction of the move.
3. Click Select, Advanced.
4. In the Select dialog box, click Select, All, Contours, OK.
5. Click Confirm to move the selected contours.

• To delete all elements other than contours:

1. Click Delete.
2. Click Select, Advanced.
3. In the Select dialog box, click Select, All, Contours, Not, OK.
4. Click Confirm to delete all non-contour elements.

• To change the color of all contours to green:

1. Click Geometry, Change, Color.
2. Set the color to Green and click OK.
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3. Click Select, Advanced.
4. In the Select dialog box, click Select, All, Contours, OK.
5. Click Confirm to change the color of all contours to green.

Specifying the Contour Level
To facilitate the selection of nested contours, Creo Elements/Direct Drafting
enables you to specify a selection level by typing contour_level followed by
an integer.
contour_level 0 This is the default. Only the "outer" contours in

the selection polygon are selected. See the part
labeled 0 in Figure 7. Contour Levels on page
42.

contour_level 1 In addition to the outer contours, the first
contours encountered within the outer contours
are selected. See the part labeled 1 in Figure 7.
Contour Levels on page 42.

contour_level 2 In addition to the contours in contour level 1
(including all level 0 contours), the first
contours encountered within level 1 contours
are selected. See the part labeled 2 in Figure 7.
Contour Levels on page 42.

contour_level 3 In addition to the contours in contour level 2
(including all level 1 and level 0 contours), the
first contours encountered within level 2
contours are selected. See the part labeled 3 in
Figure 7. Contour Levels on page 42.
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Figure 7. Contour Levels
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Copying Contours to the Clipboard
The Copy Contour command in the Edit menu enables you to select contours
(closed loops of connected elements) to the Clipboard. Copy Contour does not
modify the drawing. From the Clipboard, the copied contours can be pasted to
another place in the same Creo Elements/Direct Drafting drawing, to another Creo
Elements/Direct Drafting drawing, or to Creo Elements/Direct Modeling.
Proceed as follows to copy a set of contours:

1. Specify the Specifying the Contour Level on page 41 for the selection you are
about to make.

2. Click Edit, Copy Contour.
3. Click on points in your drawing to define a selection polygon around the area

from which you want to select contours. Note that contours fully enclosed in
this polygon are highlighted.

4. In the user input line, enter contours.
5. Click End.

Selecting URLs
Click URL in Select to select and highlight URLs.

Preselecting Elements
By preselecting elements, you can keep these available for subsequent operations.
Creo Elements/Direct Drafting will "remember" your preselection until you
replace it by another preselection.

Defining a Preselection
To preselect elements:

1. Click the Preselection icon in the Creo Elements/Direct Drafting toolbar:

1. Select the elements you want to include in your preselection.
2. Click Confirm.

Retrieving a Preselection
To retrieve your preselection:

Commonly Used Commands 43



1. Click PreSelected or Advanced in the Select menu
2. Click Confirm.

Automatic Preselection
With automatic preselection enabled, you can add elements to the preselect list
and use them in Modify commands without using the Select menu or Preselect
command. To enable this option, click Setup ▶ Edit Environment ▶ System ▶
Preselect ▶ Automatically use preselection.

Confirming Commands
Click Confirm to confirm that the deletion or modification you have defined
should be implemented.

Undoing Commands
Click Undo when you have just deleted or modified something but realize you
have made a mistake. This will return you to the previous display.

Ending a Command
Click End to terminate the active command or function, whether or not you have
completed it. You can also terminate any command or function by selecting
another command.
In the case of functions, clicking End will terminate the currently active function,
but the previously selected command will remain active.

Canceling Commands
It may happen that you select a series of commands and functions but do not
complete any of them. Although selecting a new command will terminate
whatever command or function is active and allow you to continue working, it is
advisable to click Cancel and then start again. Otherwise the response time may be
slightly slower than normal.

Getting Help
The Programmer's Reference file contains general technical information about all
the commands and functions that you can use in Creo Elements/Direct Drafting.
To use the help system:
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1. Click Help ▶ Program Ref. Guide.
2. Enter the name of the command or function about which you require help.

Creo Elements/Direct Drafting responds by displaying the required help
information.

3. Exit the browser to return to the normal display.

Commonly Used Commands 45



4
Changing the Drawing

Environment and Making
Measurements

Setting Linetype, Line Color and Line Width or Line Size ..............................................48
Mapping Pen Color, Linetype and Pen Width ...............................................................52
Changing the Linetype, Color, Line Width or Line Size of Existing Elements...................53
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Setting the Color for Parts Spotlight and Vertices .........................................................55
Viewing and Converting Colors...................................................................................56
Changing the Catch Mode..........................................................................................62
Measuring Distances .................................................................................................63
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Selecting What is Displayed on Your Screen ...............................................................72
Viewing A Drawing ....................................................................................................73
Using Viewports to Display Several Views...................................................................76
Using Properties to Change Elements and Text ...........................................................82
Setting the Auto Save Time for Drawings.....................................................................84
Setting the Delay Time for Cascaded Menus ...............................................................85
Setting the Redraw Mode...........................................................................................85
Saving the Current Drawing Environment ....................................................................85

Use the functions shown in this chapter as an aid to make designing and drafting
easier. These functions are arranged in groups of functions and are available for
use at all times.
Functions are essentially different from commands in that a function can interrupt
a command (or another function) without terminating it.
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For example, while using the Fillet command to draw a fillet radius, you may want
zoom in on the corner or change the current linetype. Both Linetype and View are
interrupt function groups.
Once a function has been executed, control is automatically returned to the
previously unfinished command in which you were working.
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Setting Linetype, Line Color and Line
Width or Line Size
To set the linetype, line color and line width (pen size) or line size for geometry,
construction geometry, or hatching:

1. Pull down the Setup menu and click Edit Environment.
2. Click the item for which you want to set the linetype, line color and line width

or line size:

• Construction

• Geometry

• Hatch

• Refline

• Symmetry Line

• Center Line

3. Select the linetype from the Type list.

Figure 8. Linetypes and Corresponding Symbolic Representation on page 48
shows the built-in linetypes available in Creo Elements/Direct Drafting and
their corresponding symbolic representation. If you want to define your own
linetypes, follow the instructions in Creating User-Defined Linetypes on page
49.

Figure 8. Linetypes and Corresponding Symbolic Representation

Item Description
1 Solid
2 Dashed
3 Long Dashed
4 Dot Center
5 Dash Center
6 Phantom
7 Center Dash Dash
8 Dotted
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4. Select the line color from the Color list. Refer to Defining Custom Colors on
page 54 for instructions on defining custom colors.

5. Specify the line width (pen size) or line size:

• To specify the line width (pen size), press the Width radio button and enter
the required value.

• To specify the line size, press the Size radio button and enter the required
value.

Note that line width and line size are mutually exclusive; you can only specify
one of these two settings. The difference between line width (pen size) and
line size is explained in Line Width vs. Line Size on page 51.

The last line setting you defined is displayed at the bottom of the Creo Elements/
Direct Drafting display. By default, the line settings for geometry are shown. Note
that this information is context sensitive. For example, when you draw
construction geometry, the line settings for construction geometry are shown.
To select a linetype, line color, line width or line size, simply select the required
setting(s) from the list box(es) at the bottom of the Creo Elements/Direct Drafting
display.

Creating User-Defined Linetypes
In addition to the standard linetypes supplied with Creo Elements/Direct Drafting
(see Figure 8. Linetypes and Corresponding Symbolic Representation on page 48),
you can quickly and easily create your own linetypes through a repeated sequence
of dot and dash patterns.
To create a user-defined (custom) linetype:

1. Pull down the Setup menu and click Edit Environment, Line Patterns.
2. Click Add in Line Pattern. Alternatively, display the linetype menu from the

bottom menu bar and click on the questionmark item.
3. In the Name field in Add Line Pattern, specify a name for the line pattern you

are about to create.
4. In the Pattern field in Add Line Pattern, enter one of the following:

• A sequence of 1s and 0s, in which each 1 denotes a dot and each 0 denotes
a gap. Note that the first number of this sequence must not be a 0. For
example:

•
1111011110000

• A sequence of comma-separated natural numbers, in which the first (third,
fifth, ...) number denotes the number of dots and the second (forth, sixth,
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...) number denotes the number of gaps. (Creo Elements/Direct Drafting
will convert any sequence of 1s and 0s to this notation.) For example:

•
4,1,4,4

Note that both of these examples produce the same linetype.
5. Click OK to save the new linetype.
The following figure gives you a visual impression of the new linetype defined in
the two examples above. Note that the newly defined linetype pattern is appended
to the list of built-in linetypes.

Figure 9. Eight Built-In Linetypes Plus a User-Defined Linetype

To apply your new linetype, follow the instructions in Setting Linetype, Line
Color and Line Width or Line Size on page 48.

Exporting User-Defined Linetypes
Any user-defined linetypes are saved to your current MI file. By sending this MI
file to another Creo Elements/Direct Drafting user, you can make your user-
defined linetypes available to this user.
These additional linetypes will be listed as "imported" linetypes in the linetype
menu.

Editing User-Defined Linetypes
To edit a user-defined (custom) linetype:

1. Pull down the Setup menu and click Edit Environment ▶ Line Pattern.
Alternatively, display the linetype menu from the bottom menu bar and click
on the questionmark item.

2. In Line Pattern, select the user-defined linetype to be edited.
3. Click Edit and edit the linetype as appropriate. Refer to Creating User-Defined

Linetypes on page 49 for guidance.
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Deleting User-Defined Linetypes
To delete a user-defined (custom) linetype:

1. Pull down the Setup menu and click Edit Environment ▶ Line Pattern.
Alternatively, display the linetype menu from the bottom menu bar and click
on the questionmark item.

2. In Line Pattern, select the user-defined linetype to be deleted.
3. Click Delete.

Line Width vs. Line Size
The thickness of elements can be set by setting the line width or line size
properties.
Note that line width differs from line size:

• Line width (pen size) and line size are mutually exclusive: Specifying linesize
resets pensize to 0, and specifying pensize resets linesize to 0.

• When you scale (increase or decrease the size of) an element drawn in a given
line size, this line size will change with the size of the element.

• When you scale an element drawn in a given line width, the line width
remains unchanged even if you scale the element. This behavior reflects the
pen width concept of a conventional drawing board: an enlarged detail of a
part is drawn with the same pen as the part.

• Line size supports HP-GL/2 and PostScript.

Figure 10. Scaling with Pensize and Linesize

Item Description
1 Line Width (Pen Size): The line is non-scalable. This means

that if you create a line having a pensize of 1mm, and then scale
it by a factor of 2, the thickness of the line remains 1mm.

2 Line Size: The line is scalable. In this case, if you create a line
having a linesize of 1mm, and then scale it by a factor of 2, the
new thickness of the line is 2mm.

Figure 11. Difference between Pensize and Linesize on page 52 shows one benefit
of specifying pensize and linesize for specific elements.
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Figure 11. Difference between Pensize and Linesize

1 All geometry elements are drawn with the property pensize. When scaled, all lines remain
the same size (thickness).

2 The outline of the building is drawn with the property linesize. All other elements are drawn
with the property pensize. When scaled, the thickness of the outline increases but the other
elements remain the same thickness.

Figure 12. Lines Drawn with Different Sizes on page 52 shows some sample sizes.
The ends of lines are rounded so that when more than one line intersects, a
rounded end is formed. Otherwise, the line end would appear stepped.

Figure 12. Lines Drawn with Different Sizes

Mapping Pen Color, Linetype and Pen
Width
The Pens map is based on eight pens. This map enables you to map pen color,
linetype, and pen width. The Pens map is available for:

• Geometry

• Refline

• Symmetry Line
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• Center Line

Proceed as follows to set up the Pens map:

1. Display the Settings dialog box of one of the entity types listed above. For
example, pull down the Setup menu, click Edit Environment and select
Dimensions to display the Geometry Settings dialog box.

2. Click Pens to display the Pens map.
3. In the Pens map, click the row you want to change. This row will be

highlighted.
4. Click Change to display the Pen Settings dialog box.
5. In the Pen Settings dialog box, select a linetype and a line color, then enter the

line width (pen size) you want to associate with this color and linetype
combination. The difference between line width (pen size) and line size is
explained in Line Width vs. Line Size on page 51.

6. Click OK to return to the Pens map.
7. Repeat this procedure until the Pens map contains the required combinations

of pen color, linetype and pen width.
Optionally, you can click Save to save your current Pens map in a file. Click Input
to load a previously saved Pens map for re-use or editing.

Changing the Linetype, Color, Line Width
or Line Size of Existing Elements
To change the linetype, color, line width and/or pen width of existing geometry:

1. Click Change in Geometry.
2. Select the appliable item:

• Linetype

• Color

• Pen Width

• Line Width

3. Select or specify the new setting. Note that you can change all four settings
before you select the element(s) to which these changed settings will be
applied.

4. Select the elements to be changed.
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Note
• The linetypes you choose on the screen will be plotted unless plot

transformation has been altered (see PLOT_TRANSFORMATION and
SCREEN_TRANSFORMATION in the online Help.

• Note that when plotted, PHANTOM and CENTER_DASH_DASH
linetypes look the same.

• You can use the LINEPATTERN function to define your own linetype.
Refer to Writing Macros with Creo Elements/Direct Drafting. If the
linetype you have defined cannot be displayed or plotted, Creo Elements/
Direct Drafting defaults to the nearest standard linetype shown in Figure 8.
Linetypes and Corresponding Symbolic Representation on page 48.

• The spacing of all broken linetypes is set using the plot default option
Ltype Len in PLOT.

Changing Color
Colors can be selected or changed for geometry, construction geometry, text,
hatching and dimensioning.
The colors available for you to use are as follows:

• Black and White.
• The six basic colors:

Red, Yellow, Green, Cyan, Magenta and Blue.
• Custom (user-defined) colors.

Note
The colors you choose are linked to the pen transformation so that you can
allocate plotter pens to the colors displayed on the screen. (See PLOT_
TRANSFORMATION in the online Help.)

Defining Custom Colors
Proceed as follows to define custom colors for use in Creo Elements/Direct
Drafting:
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1. In any of the Color drop-down list boxes, select Custom to display the Color
menu.

2. A number of basic colors are shown in the upper section of this menu. Click
on the basic color(s) you want to add to your color selection list.

3. If you want to create colors other than these basic colors, click Define Custom
Colors to display the Creo Elements/Direct Drafting Color dialog box.

4. In the Color dialog box, move the color selection recticule to change the
associated hue, saturation, luminosity, red, green and blue values. Note that
these values are indicated in separate fields. Optionally, you can replace these
values to create a custom color.

5. When the required color is shown in the Color|Solid field, click Add to Custom
Colors. The newly added custom color is shown in the Custom colors section
of the Color dialog box.

6. Optionally, repeat the last two steps to create additional custom colors.
7. Click OK.
Note that the last custom color you defined becomes the current (active) color in
the Color selection list. To access your other custom colors (if any), select Custom
from the Color selection list.

The Dithering Effect
The ability to display the various RGB and HSL colors is dependent on your
hardware. The number of colors that can be displayed typically ranges from 16 to
256 (or a much larger number) according to your graphics hardware.
However, since not all hardware has the ability to display the range of colors the
RGB and HSL color system offers, a dithering effect is used to increase the
number of shades available. This creates the impression of a larger range of colors
than the hardware actually supports.
This dithering effect creates patterns of dots in the available colors. The eye then
combines them into a perceived color different from the actual colors used to
produce the patterns.
Although dithering can create a larger range of colors for surfaces, the drawing
lines and the System Status Line can be displayed only in the range of colors
supported by the hardware.

Setting the Color for Parts Spotlight and
Vertices
To set the color of the parts spotlight and of vertices in your Creo Elements/Direct
Drafting drawings:
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1. Pull down the Setup menu.
2. Click Edit Environment and System.
3. In the System dialog box, click on the Geometry tab.
4. Select the required colors for the parts spotlight and for vertices from the

associated Color selection lists.

Refer to Defining Custom Colors on page 54 for instructions on defining
custom colors.

5. Select the required line type for the parts spotlight.

Viewing and Converting Colors
You can view information about the colors of all elements in a part and its
subparts using the Color Conversion dialog box. You can also convert the colors of
existing elements in a part and its subparts, to other colors.
To open the Color Conversion dialog box:

• Type WUI_CREATE_COLOR_MAP in the user input line and press ENTER.
You can use the Color Conversion dialog box for:

• Viewing color information of all elements in a part and its subparts.
• Converting colors of elements in a drawing.
• Storing the color conversion map file.
• Loading the color conversion map file.

Viewing Color Information
The Color Conversion dialog box provides information about :

• Color information table
• Preview viewport
• Parts list
• Preview colors
• Background colors

Color Information Table
The color information table of the Color Conversion dialog box consists of the
following columns:

• Seq Num: Sequence number of a color in the table.
• Source Color: Color present in the drawing.
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• Target Color: A color to map the source color to, if required.
• Count: Number of elements in the drawing that have the source color.
The standard colors in a drawing are represented by their names in the color
information table. For other colors, Creo Elements/Direct Drafting displays the
RGB value in the color information table.

Note
You can only edit the Target column of the color information table.

Preview Viewport
The preview viewport of the Color Conversion dialog box displays the preview of
the drawing.

Note
For big drawings, Creo Elements/Direct Drafting displays parts that are
smaller than a certain limit as magenta boxes (instead of entire parts) during
the redraw process, by default. Creo Elements/Direct Drafting enables
REDRAW_MODE PARTS_AS_BOX during the redraw process. As a result,
many of magenta-colored elements are visible in the preview viewport (even
though the magenta color may not be present in the drawing). To avoid this
situation, Creo Elements/Direct Drafting disables REDRAW_MODE PARTS_
AS_BOX by setting its value to zero when you open the Color Conversion
dialog box. When you close the Color Conversion dialog box, the value of
REDRAW_MODE PARTS_AS_BOX is restored.

Parts List
The Part Id box of the Color Conversion dialog box displays the list of parts in the
drawing.
In the Part Id box, select a part ID to view the color map associated with the part
ID.

Note
Creo Elements/Direct Drafting selects the part ID of the top-level part of a
drawing by default.

Changing the Drawing Environment and Making Measurements 57



Preview Colors
The Preview box of the Color Conversion dialog box displays the original colors,
target colors, or a single user-defined color of drawing elements in the preview
viewport.
In the Preview box, select one of the following:

• Source to view the drawing elements in their original colors.
• Target to view the drawing elements in the target colors that you have defined.

This is the default.
• One Source Color to view the drawing elements in a single color.

Creo Elements/Direct Drafting prompts you to select a source color.

Click the cell which contains the color to define the single color.

Creo Elements/Direct Drafting displays the drawing elements that contain the
single source color.

Note
• You can view a single source color of the part which you select in the Part Id

box.
• OK is disabled when Source One Color preview is active.

Background Colors
The Background box of the Color Conversion dialog box displays the elements of
the drawing in the preview viewport according to the color scheme.
In the Background box, select any of the following:

• Neutral to view all the elements against a neutral-grey color background.

This is the default.

Note
Elements having a color which is similar to the neutral background color
are not visible in the preview viewport. When you open the Color
Conversion dialog box, Creo Elements/Direct Drafting displays a warning
if a drawing contains elements that have the same color as the neutral
background color.
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• Creo to view the elements against the default background color of Creo Colors
scheme.

• CoCreate to view the elements against the default background color of
CoCreate scheme.

Converting Colors
To convert the color of existing elements in a drawing to another color:

1. Click File ▶ Settings ▶ Color ▶ Convert Colors.

The Color Conversion dialog box opens.
2. In the Part Id box, select the required part.

The color scheme of the part is displayed in the color information table.
3. In the color information table, click the Target Color cell for the Source Color

cell which you want to change.

The Color dialog box opens.
4. Select the required color in the Color dialog box.

The selected color is displayed in the Target Color cell of the color information
table.

Tip
• To remove a target color, right-click the required Target Color row in the

color information table and select Clear.
• To remove all target colors, right-click the color information table and

select Clear All.
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Note
If there are duplicate source or target colors in the source-to-target color
mapping, Creo Elements/Direct Drafting displays a warning if any of the
following situations occur:

• If you define the same color as a source and a target color and the source
color instance has no target color mapped to it. For example, if blue is the
source color (not mapped to a target color), and the same blue color is
defined as the target color for the green source color.

• If you define the same color as a target color more than once.

In addition, Creo Elements/Direct Drafting displays the sequence number
of the duplicate colors in a bold orange color (RGB 255 128 0) in the color
information table.

5. Click OK in the Color Conversion dialog box.

Note
• If you click Clear All, Creo Elements/Direct Drafting removes the target colors

in the Target Color column of the color information table. Also, Creo
Elements/Direct Drafting removes rows that contain color count as 0 (zero).

• Creo Elements/Direct Drafting supports Undo and Redo for color
conversion.

Storing the Color Conversion Map File
You can save your source-to-target color preferences in a map file after you have
defined the target colors in the Color Conversion dialog box. The source-to-target
color mapping is stored in a text file. The colors are stored as RGB values. Each
source-to-target color pair is stored on a new line. For example, the source-to-
target color mapping for black-to-white color conversion and red-to-yellow color
conversion is saved as:
0,0,0;255,255,255; (black-to-white color conversion)
255,0,0;255,255,0; (red-to-yellow color conversion)
To store the source-to-target color mapping:

1. Click File ▶ Settings ▶ Color ▶ Convert Colors.

The Color Conversion dialog box opens.
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2. Define the target colors in the Target Color column of the color information
table.

3. Click Store.

The Save As dialog box opens.
4. Specify the path and the file name, and save the file.

Loading Color Conversion Map File
Creo Elements/Direct Drafting allows you to load a map file which contains
predefined or user-defined source-to-target mapping of colors to convert the
colors of a drawing.
To load a color map file:

1. Click File ▶ Settings ▶ Color ▶ Convert Colors.

The Color Conversion dialog box opens.
2. In the Preset box, select one of the following:

• None

This is the default. No color map is loaded.
• CoCreate to Creo (predefined color map)
• Creo to CoCreate (predefined color map)

3. To load a user-defined source-to-target color map file, select User defined in
the Preset box and select the map file in the Open dialog box.

Note
• If a source color which is defined in the map file is present in the drawing, the

corresponding target color is set in the Target Color column of the color
information table.

• If a source color which is defined in the map file is absent in the drawing, a
row (containing the color information) is added to the color information table
and the count is set to 0 (zero). You can view the information when you select
Source in the Preview box.

• If there are duplicate source or target colors in the source-to-target color
mapping, Creo Elements/Direct Drafting displays a warning. See Converting
Colors on page 59 for more information.
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Changing the Catch Mode
The Catch function enables you to select a point on the screen without putting the
cursor directly on that point. The cursor will automatically "snap" to this point.
The current catch mode is always displayed in the System Status Line. The system
will catch to a given point only if the point lies within the (imaginary) circle
around the edges of the cursor.
By default, the Catch mode is set to All. You can change the Catch mode to any of
the following:

Setting Catches to
VERTEX Vertex
ELEM Element
INTERSECTION Intersection
CENTER Center point
GRID Ruler/grid point
OFF Switches Catch off

Simply click on the Catch arrow in the bottom menu bar to list these options for
selection.
When Catch is set to All, Creo Elements/Direct Drafting will catch using the
following order of priority:

1. VERTEX

2. INTERS

3. RULER/GRID

4. ELEM

If the system finds a vertex within the catch range it catches to the closest such
vertex; otherwise it searches for intersections and so on. If the system can't find
any of these, it uses the given input point.

Note
By default, Catch mode ELEM is used, when moving elements like geometry
or parts via handles. To use a different Catch mode than ELEM, type MH_
USE_CATCH_MODE ON in the User Input line. Now, the current Catch mode
is used to move the elements via handles.

Setting the Catch Range
To alter the catch range:
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1. Pull down the Setup menu.
2. Click Edit Environment and select System.
3. In the Cursor section of Environment, specify the new catch range.
4. Click OK.

Measuring Distances
The Measure functions allow you to obtain values for arc lengths, distances, point
coordinates, angles, and areas. These functions are useful if you need to enter a
value measured from existing features on the drawing. To illustrate this, consider
the following example.

Example
Suppose you want to draw a vertical line starting at 100,100 and of the same
length as an existing line drawn at an angle of 40 degrees:

1. Pull down the Tools menu.
2. Click Measure and Length.
3. Click the existing line. The measured length of this line is displayed in the

User Input Line.
4. Click Line in Geometry.
5. Click Vertical in Line.
6. Specify the begin point of the vertical line you want to create.
7. When prompted for the end point or the length of this vertical line, simply

display the measured length in the User Input Line and press [Enter]. Creo
Elements/Direct Drafting draws the vertical line as specified. The length of
this line is the same as that of the line you measured.

Measure in a loop
In older versions of Creo Elements/Direct Drafting, the MEASURE function
ended after one execution. You can measure continuously instead, or keep the
traditional behavior.
Use the MULTIPLE_MEASURE switch to measure in a loop.
MULTIPLE_MEASURE does not terminate other commands or functions. In the
user input line, each new measurement overwrites the last. MULTIPLE_
MEASURE works with MEASURE_ANGLE, MEASURE_COORDINATE,
MEASURE_DISTANCE, MEASURE_LENGTH, and MEASURE_RADIUS.
MULTIPLE_MEASURE does not work with MEASURE_AREA or MEASURE_
TANG_ANG_AT_PNT.
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Enter MULTIPLE_MEASURE ON in the user input line. When you're finished
making measurements, type END to exit the loop.
Restore traditional measurement behavior with MULTIPLE_MEASURE OFF.

Note
• The ruler Follow function, described later in this section, is not active during

the Measure function.
• If any of the Measure functions are used within macros, the resultant

measurement will be stored and can be obtained by using the INQ function.

Measuring Lengths
Click Tools, Measure and Length to measure the length of any element (line,
circle, arc, fillet, chamfer or spline).

Measuring Distances (Horizontal and Vertical)

Note
This option is dependent on the current catch mode.

1. Click Tools, Measure and Horizontal or Vertical.
2. Click two points in the drawing to identify the horizontal or vertical distance

to be measured.

Displaying Point Coordinates

Note
This option is dependent on the current catch mode.

To display the exact coordinates of any existing point:

1. Click Tools, Measure and Point.
2. Click the point. The exact coordinates of this point are shown in the User

Input Line.
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Measuring Angles
To measure the angle between two lines:

1. Click Tools, Measure and Angle.
2. Click a point on the first line.
3. Click a point on the second line.
Similarly, to measure an arc segment angle, click the arc start and end points.
The angle between two tangents drawn at an intersection point of two circles can
be measured by clicking a point on the first circle and then a point on the second
circle.

Measuring a Radius
To measure the radius of a curved element:

1. Click Tools, Measure and Radius.
2. Click the curved element whose radius you want to measure.

Measuring Area Properties

A Single Face
To calculate the area and area properties of a selected face, the face must be
completely bounded by elements.
Creo Elements/Direct Drafting calculates and displays the following area
properties for a single face:

• Number of holes in the face.
• Density of the face.
• Perimeter length of the face (outer perimeter).
• Area.
• Center of Area (= Center of Mass).
• Principal Axes (of Inertia through the Center of Area).
• Second Moments of Area about principal axes.
• Second Moments of Area about coordinate system axes.
• Product of Second Moment of Area about coordinate system axes.
• Moments of Inertia about principal axes.
• Moments of Inertia about coordinate system axes.
• Product of Moment of Inertia about coordinate system axes.
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• Section Moduli (about principal axes).
• Distance from first neutral axis to extreme fiber.
• Distance from second neutral axis to extreme fiber.
• Radii of Gyration.
• Angle between coordinate system and principal axes.

Multiple Faces
If you identify multiple faces, Creo Elements/Direct Drafting uses the density
values to calculate the Common Center of Mass. The density must be specified
before a face is identified, otherwise the default value (1) or the previous density
value is used.
Creo Elements/Direct Drafting calculates and displays the following total values
for multiple faces:

• Total Area.
• Center of Area (common).
• Center of Mass (common).
• Principal Axes through the (common) Center of Area.
• Second Moments of Area about (common) Principal Axes.
• Second Moments of Area about Coordinate System Axes.
• Product of Second Moment of Area about Coordinate System Axes.
• Moments of Inertia about (common) Principal Axes.
• Moments of Inertia about Coordinate System Axes.
• Product of Moment of Inertia about Coordinate System Axes.
• Radii of Gyration with respect to the (common) Center of Area.
• Angle between Coordinate System and (common) Principal Axes.
To display face area properties:

1. Click Tools and Area Properties. Creo Elements/Direct Drafting prompts you
to enter a density (default 1) or to select a face.

2. Enter the density value if known, otherwise select the face(s).
3. Click Confirm. The area properties are listed in a text box.
4. Optionally, you can save the list of area properties in a file.
5. Close the text box to return to Creo Elements/Direct Drafting.
Example

Figure 13. I-Section Face on page 67 shows an I-section face.
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Figure 13. I-Section Face

Figure 14. Resultant Diagram for I-Section Face on page 67 is a resultant diagram
for the I-section face.

Figure 14. Resultant Diagram for I-Section Face

A listing of the Creo Elements/Direct Drafting output for this single face is given
below:
ALL VALUES REFER TO THE FOLLOWING UNITS :
LENGTH = 1 MM
ANGLE = 1 DEG
FACE 1:
NUMBER OF HOLES
noh = 0
DENSITY
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rho = 1
PERIMETER LENGTH
P = 334
AREA
A = 1470
CENTER OF AREA = CENTER OF MASS
(Cx,Cy) = (289.2011071614633,344.1233317074434)
PRINCIPAL AXES OF INERTIA THROUGH THE CENTER OF AREA (DIRECTIONS)
u = (0.8191520442890209,0.5735764363510046)
v = (-0.5735764363510046,0.8191520442890209)

SECOND MOMENTS OF AREA (ABOUT PRINCIPAL AXES)
Icu = 761433.6734694783
Icv = 334727.5
SECOND MOMENTS OF AREA (ABOUT COORDINATE SYSTEM AXES)
Ix = 174699726.7554225
Iy = 123421911.6970526
PRODUCT OF SECOND MOMENT OF AREA (ABOUT COORDINATE SYSTEM AXES)
Ixy = 146095161.0177031
MOMENTS OF INERTIA (ABOUT PRINCIPAL AXES)
Jcu = 761433.673469478
Jcv = 334727.5
MOMENTS OF INERTIA (ABOUT COORDINATE SYSTEM AXES)
Jx = 174699726.755422
Jy = 123421911.697053
PRODUCT OF MOMENT OF INERTIA (ABOUT COORDINATE SYSTEM AXES)
Jxy = 146095161.017703
SECTION MODULI ABOUT PRINCIPAL AXES
Zcu = 23392.00626959447
Zcv = 10299.30769231674
DISTANCE FROM NEUTRAL AXIS u TO EXTREME FIBER
Du = 32.55102040816436
DISTANCE FROM NEUTRAL AXIS v TO EXTREME FIBER
Dv = 32.5
RADII OF GYRATION WITH RESPECT TO THE CENTER OF AREA
Rcu = 22.7592199074477
Rcv = 15.08992320434836
ANGLE BETWEEN COORDINATE SYSTEM AND PRINCIPLE AXES
phi = 35

Using the Calculator
Creo Elements/Direct Drafting provides a standard MS-Windows calculator. To
switch to scientific calculator mode, pull down the View menu in the top menu bar
of the calculator and select Scientific.
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Using the Ruler/Grid
The ruler simulates the T-square traditionally used with manual drafting methods.
When used together with the grid point catch mode, the ruler allows you to draw
with the help of a grid.
The grid is a useful drawing aid for alignment purposes.

Displaying a Ruler and/or a Grid
To display the ruler and/or the grid:

1. Pull down the Setup menu.
2. Click Grid and Settings to display the Grid Settings dialog box.
3. Press the Dot or Line radio button below Grid to display a dot or line grid.
4. Press the Ruler radio button below Ruler to display a ruler.

Displaying the Origin
Press the Origin radio button in the Grid Settings dialog box. The coordinate origin
is indicated in the chosen viewport by an axes symbol. If the ruler is active in the
chosen viewport, it is switched off.

Setting Cursor Size
You can use either a small cursor or a full screen cursor. A full screen cursor is
particularly recommended for use with the ruler.
To change the cursor size:

1. Pull down the Setup menu.
2. Click Edit Environment and System.
3. In the Cursor section of the System dialog box, tick the Large check box to

switch to the large (full screen) cursor.
Note that the catch range is not affected by the cursor size. Optionally, you can
specify a catch range in the Catch Range field.

Using Follow On/Off
The ruler is always located at the origin. The origin always tracks the ruler, and
the ruler always tracks the origin. Optionally, you can use the Follow function to
move the coordinate system origin with the origin of the ruler.
To make the origin follow the ruler:

1. Pull down the Setup menu.
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2. Click Grid and Follow.
The ruler will now automatically move to each new point you create.

Moving the Ruler
To move the ruler:

1. Pull down the Setup menu.
2. Click Grid and Move.
3. Specify the new origin. The orientation of the ruler axes will remain the same.

Rotating the Ruler/Grid

With Respect to the X-Axis
To rotate the ruler (or grid) so that the x-axis is at a given angle to the horizontal:

1. Pull down the Setup menu.
2. Click Grid ▶ Turn ▶ Absolute.
3. Enter the angle required.

Through a Given Angle
To rotate the ruler (or grid) through a given angle:

1. Pull down the Setup menu.
2. Click Grid ▶ Turn ▶ Relative.
3. Enter the rotation angle required.
A positive value results in counterclockwise rotation.

Setting the Ruler/Grid Spacing
To change the spacing between the tick marks of the ruler or between the grid
lines or dots:

1. Display the Grid Settings dialog box.
2. Enter the required distance (for example: 0.5) into the Spacing field. Note

that this entry is interpreted in terms of the current length unit.
If the spacing is very small, it may not be shown on the screen but it will still be
used for catch when in ruler or grid catch mode. Use the View functions if you
want an enlarged view.
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Drawing an Isometric Ruler/Grid
To redraw the ruler or grid according to the isometric grid required for drawing
top, front, or side views:

1. Pull down the Setup menu.
2. Click Grid ▶ Isometric.
3. Select the applicable option:

• Top

• Front

• Side

Hiding the Ruler/Grid
To hide the ruler/grid:

1. Pull down the Setup menu.
2. Click Grid and Hide.
The Hide function switches the ruler and/or grid off. Alternatively, you can press
the None radio button in the Grid Settings dialog box.

Placing the Ruler/Grid
To change the orientation of the axes:

1. Pull down the Setup menu.
2. Click Grid ▶ Place.
3. Specify the new origin and two more points that define the new axis

orientation.
Figure 15. Ruler Axes on page 71 shows the ruler axes.

Figure 15. Ruler Axes
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Selecting What is Displayed on Your
Screen
This section describes how to use the Show dialog box to control exactly what is
displayed on your screen. The Show dialog box is accessible via the Setup menu.
Show operates in the current viewport.
Before you plot your complete drawing, you are recommended to check what is
included by clicking Show All in Show.
You can selectively display:

• Construction geometry
• Geometry
• Dimensions
• Hatch
• Text
• Vertex
• Info
• Layers
• URLs

Note
• The Show settings apply to the current viewport.
• Any new viewports created will automatically adopt the settings of the

viewport that was active when they were created.

Showing All Features
Click Show All in the Show dialog box to display all features of your drawing. It is
useful to start with everything displayed, then switch off what is not required.

Showing Points
Tick the Vertex check box in SHOW to display all existing points on the drawing.
This is useful if you want to identify a point more accurately, or to check if two
lines overlap. Points are displayed in the following colors (by default):

• GREEN – end points
• YELLOW – common end points
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• BLUE – single center points
• MAGENTA – multiple center points

Showing Dimensions
The Dimensions check box in Show enables you to turn dimensions on and off as
a group. Any dimensions created after the dimensions have been turned off will
not be displayed on the screen until the dimensions are turned on again.

Changing the Layer Color
To change the color of a specified layer.

1. Click the Layer tab in SHOW.
2. Select the layer number.
3. Select a color from the Color list.

Displaying Infos
1. Click the Info tab in SHOW.
2. Select the info to be displayed.
3. Click On to display elements that have information attached.

Viewing A Drawing
This section shows how to use the normal and dynamic View functions to see
details in your drawing more clearly. You can zoom in on the area concerned, or
reposition the drawing on the screen.
Click View to display the View menu. The View functions operate on either the
current viewport (default) or on a viewport you selected.

Selecting a Viewport
You can select the viewport in which the View functions operate.

Current Viewport
If you want the View functions to operate in the current viewport:

1. Pull down the Setup menu.
2. Click Viewport and Current.
3. Click in the viewport or enter the viewport number.
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Creo Elements/Direct Drafting will use the current viewport for any View
functions.

Select Viewport
1. Pull down the Setup menu.
2. Click Viewport and Select.
3. Click in the viewport to select it.

Using View Functions
This section shows how to control the area of the drawing shown in the current
viewport using the View functions.

Redrawing
Click Redraw in View to redraw the drawing in the chosen viewport. This is
sometimes necessary if you have deleted several elements and traces can still be
seen on the screen. The contents of other viewports will not be redrawn.

Fitting a Drawing
Click Fit in View to fit the current drawing into the chosen viewport.

Panning Across a Drawing
Panning is a very useful function enabling you to move across the drawing to see
those areas not currently displayed.
Figure 16. Panning Across a Drawing on page 74 illustrates the use of panning.

Figure 16. Panning Across a Drawing

To pan in any direction:

1. Click Pan in View.
2. Click a point in your drawing.
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3. Specify the new screen position for this point.
Alternatively, press the [Ctrl] key, press the left mouse button, and drag the
cursor to pan to the new position.

Creating a New View in a Window
To create a new window:

1. Click New in View.
2. Specify the bottom left and top right corners of the area you want to enlarge.

Restoring the Last View
Click Last in View to return to the previous view.

Zooming In or Out
Awindow is always zoomed about its center point.
To zoom your window:

1. Click Zoom in View.
2. Enter the zoom factor required.

A number greater than 1 results in a window that covers a smaller area
(zooming in). A number less than 1 (>0) or negative (<-1) gives a larger
coverage (zooming out).

3. Press [Enter].
Alternatively, press the [Ctrl] key and press the right mouse button. Move the
mouse towards the screen to zoom in, move the mouse away from the screen to
zoom out.

Storing and Recalling Windows
If you are likely to need the same view again, you can store it and recall it as
required:
Click Store in View to store the current window coordinates.
Click Recall in View to recall the window that was stored last.

Creating a New Center Point for Your Drawing
Click Center in View and specify the new center point for the display. Your
drawing is then repositioned so that this point is in the center of the chosen
viewport.
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Note
This option uses the current catch mode to identify the specified point.

Redrawing
1. Click Redraw in View to rapidly redraw your drawing in the current or selected

viewport.

Fitting a Drawing
1. Click Fit in View to rapidly fit your drawing in the current or selected

viewport.

Using Viewports to Display Several Views
You can divide the drawing area of the screen so that more than one view can be
displayed. This is a very useful feature when you want to work on a detail
drawing. The changes made to the detail are automatically repeated in the main
drawing. Each division of the screen is called a viewport.
Viewports can be overlapped with other viewports, menus, and programmable
tables. All overlapping viewports are continuously updated during your drawing
session.
In the following example, the view in viewport 1 can be imagined as the view you
would see if you were examining your drawing with a magnifying glass. To
achieve this effect, simply zoom in to the drawing displayed in viewport 1 until
you can see the required level of detail.

• Viewport 1 – contains a magnified view showing the required level of detail.
• Viewport 2 – contains the entire drawing and is used as a positional reference

for the magnifying glass.
Examine the zoomed drawing in viewport 1 while moving the cursor (as a
positional reference) in viewport 2. See Figure 17. Using Viewport 2 as a
Reference on page 77 and Figure 18. Viewing Piston Assembly Detail in Viewport
1 on page 78.
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Figure 17. Using Viewport 2 as a Reference
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Figure 18. Viewing Piston Assembly Detail in Viewport 1

Creating a Viewport
To create a new viewport:

1. Pull down the Setup menu.
2. Click Viewport and Create.
3. Specify a point for the top left corner and another point for the bottom right

corner of the new viewport.
The newly created viewport is marked by a sequential number in the top right
corner.

Making a Viewport Current
If a viewport is partially or totally covered by other viewports, it is made inactive.
Its visual contents will not be updated by any subsequent operations unless it is
made the current viewport.
The current viewport is the one that is currently active, fully visible and up-to-
date. The viewport number is displayed in inverse video in the top right corner.
To change the current viewport:

1. Pull down the Setup menu.
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2. Click Viewport and Current.
3. Click the viewport required. Alternatively, enter the viewport number and

press [Enter].

Changing the Size of a Viewport
To change the size of a viewport:

1. Pull down the Setup menu.
2. Click Viewport and Change.
3. Click the viewport.
4. Indicate the new corner points of the viewport.

Moving a Viewport
To move a viewport:

1. Pull down the Setup menu.
2. Click Viewport and Move.
3. Click the viewport.
4. Drag the cursor to the new position of the bottom left corner of the viewport.
The contents of the viewport follows the viewport.

Redrawing a Viewport
To redraw a viewport:

1. Pull down the Setup menu.
2. Click Viewport and Redraw.
3. Click the viewport.
The contents of the viewport will be redrawn.

Maximizing the Size of a Viewport
You can maximize the size of any viewport such that the viewport occupies the
entire Creo Elements/Direct Drafting drawing area.

1. Pull down the Setup menu.
2. Click Viewport and Large.
3. Click the viewport.
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Any other viewport are now hidden behind the maximized viewport. To bring any
of these hidden viewport to the foreground, make it current. To change the size of
the maximized viewport, use Change.

Deleting a Viewport
To delete a viewport:

1. Pull down the Setup menu.
2. Click Viewport and Delete.
3. Click the viewport. Alternatively, enter the viewport number and press

[Enter].

Deleting All Viewports
To delete all viewports:

1. Pull down the Setup menu.
2. Click Viewport and Delete.
3. Click Select, All, Confirm, OK.
All viewports will be removed from the Creo Elements/Direct Drafting drawing
area.
To continue drawing or to view your current Creo Elements/Direct Drafting
drawing after you have deleted all viewports, you need to create at least one new
viewport.

Defining Viewport Settings
The viewport settings are defined in the Viewport Settings dialog box.
To define the viewport settings:

1. Click Setup ▶ Viewport ▶ Settings.

The Viewport Settings dialog box opens.
2. In the Border area:

a. In the Color box, select a color for the viewport border.
b. In the Width box, type the viewport border width.

3. In the Color of area:

a. In the Background box, select the background color.
b. In the Text box, select the color of the text.
c. In the Cursor box, select the color of the cursor.
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Refer to Defining Custom Colors on page 54 for instructions on defining
custom colors.

4. In the Invert area, select one of the following in the Invert Color box to invert
display colors in a viewport:

• White elements

If you select White elements, the elements that are white (or almost white)
are displayed in black. This is the default for the Creo Colors color
scheme.

• Black elements

If you select Black elements, the elements that are black (or almost black)
are displayed in white. This is the default for the CoCreate Colors color
scheme.

• Off

If you select Off, element colors are not inverted in the viewport.
5. Click OK.

Note
The viewport colors are defined by the color scheme. The internal viewports
(for example, the viewport in the Symbols dialog box) also display the default
colors for the selected color scheme.

Viewport Example
A common application using viewports is identifying two (or more) widely
separated points on a large and complex drawing. Refer to Figure 19. Joining Two
Widely Spaced Points Using Viewports on page 82.
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Figure 19. Joining Two Widely Spaced Points Using Viewports

To draw a line between points 1 and 2 in Figure 19. Joining Two Widely Spaced
Points Using Viewports on page 82:

1. Create the three viewports (V1, V2 and V3).
2. Make V1 the active viewport.
3. Window into point 1 in V1.
4. Make V2 active.
5. Window into point 2 in V2.
6. Click Line in Geometry.
7. Click 2 Pts in Line.
8. Specify point 1 in V1 and point 2 in V2.
Creo Elements/Direct Drafting will now draw a line between points 1 and 2.

Using Properties to Change Elements and
Text
Line geometry, text and hatch have associated properties.
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Geometry Properties
Geometry properties are:

• Color
• Linetype
• Line width (pen size) and line size
These can be predefined via the Geometry Settings dialog box.

Text Properties
Text properties are:

• Font
• Origin vertex
• Angle
• Fill
• Frame
• Linespace
• Ratio
• Size
• Slant
These can be predefined via the Text Settings dialog box.

Hatch Properties
Hatch properties are:

• Pattern
• Angle
• Distance
• Reference Point
These can be predefined via the Hatch Settings dialog box.

Getting and Putting Properties
It is possible to retrieve properties (of Text, for example) and use them either in
subsequent work or to change existing properties.
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Note
You cannot change Dimension properties using Get and Put.

For example:

1. Click Tools ▶ Properties ▶ Get.
2. Select a block of text.
All properties of that text will be retrieved. Any further text entered will now have
these properties.
To change the properties of an existing text block to those of another:

1. Click Tools ▶ Properties ▶ Get.
2. Select the text whose properties are to be retrieved.
3. Click Tools ▶ Properties ▶ Put.
4. Select the text whose properties are to be changed.

Setting the Auto Save Time for Drawings
In addition to the File functionality described in Storing, Loading and Filing on
page 409, Creo Elements/Direct Drafting provides an autosave feature to
automatically save a drawing at routine intervals.

• The name of the autosaved file is me_backup.mi. This file is put in the
working directory as specified by ME_WORKING_DIR.

• If ME_WORKING_DIR is not defined, the file is stored in \temp on
Windows-based systems.

• The autosave interval is a time interval in minutes. Possible values are 10 and
0 (0 means off; this is the default).

• While the autosave is running, a message pops up and the blue store bar
displays the progress.

To set a time interval (in minutes) at which your drawing will be automatically
saved to a file named me_backup.mi:

1. Click Setup ▶ Edit Environment ▶ System.
2. In System, click on the Save tab.
3. Tick the Auto Save Drawing checkbox.
4. Specify a time interval.
5. Click OK.
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Setting the Delay Time for Cascaded
Menus
If you find that cascaded menus are displayed too quickly or too slowly, proceed
as follows to change the time delay for such menus:

1. Click Setup ▶ Edit Environment ▶ System.
2. In System, click on the UI tab.
3. In the Cascade Timeout field, specify the time delay (in milliseconds).
4. Click OK to save these settings.

Setting the Redraw Mode
When dealing with large or complex drawings, you may want to change the
redraw mode in order to enhance the graphics performance.

1. Click Setup ▶ Edit Environment ▶ System.
2. In System, click on the Redraw tab.
3. Select one or any of the following settings:

• In the Parts as Box section, you can specify a size threshold (in pixels)
below which parts are only shown as boxes. This box representation helps
to unclutter your drawing display. Optionally, select a color from the Box
Color menu.

• In the Draw Dynamic section, check any items that you want to include in
the redraw. Uncheck any items you want to exclude from the redraw to
enhance performance.

4. Click OK to save these settings.

Saving the Current Drawing Environment
The current setup of your drawing environment can be saved to a file for re-use.
To save the current drawing environment:

1. Click Setup ▶ Edit Environment ▶ System.
2. In System, click on the Save tab.
3. Tick the settings you want to save.
4. Click OK to save these settings.
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Introduction
The Creo Elements/Direct Drafting copilot functionality provides dynamic visual
feedback on an element's attributes (angles and dimensions) before you fix the
position. This dynamic feedback lets you create designs quickly and minimizes
the need for construction geometry.
You can also enter values using the keyboard as usual if you need greater
precision in size and positioning.
The following figure shows an example of the on-screen feedback provided by the
copilot functionality when you create geometry.

Figure 20. Copilot Functionality: Typical Feedback

The snap marker (magenta box) over the cursor indicates that you are in copilot
mode and about to click a start-point.

Enabling/Disabling the Copilot
Functionality
To enable or disable the copilot functionality:

1. Pull down the Setup menu.
2. Click Edit Environment and System.
3. In the System dialog box, click on the Copilot tab.
4. Tick the Enable Copilot check box to switch on the copilot functionality. To

switch off the copilot functionality, click on the ticked check box.

Copilot Settings
To define the settings for the copilot functionality:
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1. Pull down the Setup menu.
2. Click Edit Environment and System.
3. In the System dialog box, click on the Copilot tab.
4. Define the following settings for the copilot functionality:

• Snap settings
• Catch range settings
• Text settings

Snap Settings
Distance Sets the distance that the cursor snaps to.
Angle Sets the angle that the cursor snaps to.

For example, if the snap distance is set to 1 mm and the snap angle to 15°,
specifying lengths is restricted to multiples of 1 mm and angles to multiples of
15°. This means that movement of the cursor over empty areas occurs in
increments rather than as a smooth action.

Catch Range Settings
Perpendicular Sets the catch distance from perpendicular elements.
Tangent Sets the catch distance from tangent elements.
Center Sets the catch distance from center points.

Text Settings
Color Sets the color of the text in the text box.
Long Prefixes Displays a full description of the circular element in

the text box. Use Long Prefixes on = Radius. Use
Long Prefixes off = R

To define other settings,
1. In the System dialog box, click the Snapping tab.
2. Define the following settings for snapping functionality:

• Snap points
• Snap marker
• Snap line

88 Creo Elements/Direct Drafting User's Guide: Windows User Interface



• Constraint signs

Snap Points Settings
Count Sets the maximum number of points simultaneously present in

the drawing.
Delay Sets the delay (in seconds) for how long a cursor is caught on

an element before a snap point for a snap line appears.
Color Sets the color of the last visited snap point.

Snap marker Settings
Color Sets the color of the snap marker.

Snap Line Settings
Color Sets the color of the snap line.
Linetype Sets the line type of the snap line.

Constraint Signs Settings
Enable Displays a sign when the element you are creating is

horizontal, vertical, tangent, or perpendicular to
another element.

Color Sets the color of the constraint sign.

CoPilot Features
To improve your speed and accuracy when working with geometry, use the
following features:

• Incremental movement
• Size indication
• Snap lines

Incremental movement
You can specify a length increment to restrict the length of a line or the radius of a
circle using the CoPilot. The length and angle increments are defined by the Snap
Distance and Snap Angle (Setup ▶ Edit Environment ▶ System ▶ CoPilot tab).
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Increment = 1 mm Increment = 0.1 mm

Size indication
When you create or modify elements, a text box with coordinates shows the
element's size or modification distance.

Snap lines
Snap lines are similar to temporary auxiliary lines; they appear when you move
the cursor close enough to catch them.

Snap line base points
When you hold the cursor at a vertex for .5 seconds (the default setting), a small
plus sign appears. This is the snap point for snap lines.
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On geometry elements, you can have snap points at the start point, the end point,
the midpoint (of lines), and the intersection between two elements.

There is a limit to the number of snap points that can exist at one time; when it is
reached, the snap point that hasn't been visited for the longest time disappears.
Change this number in the System menu: Setup ▶ Edit Environment ▶ System ▶
Snapping tab.

Snap line orientation
Snap lines may be horizontal, vertical, parallel, tangent, or perpendicular to an
element. You can catch the cursor to a snap line, to the intersection of two snap
lines, or the intersection of a snap line and a geometry element.

Snap lines on text
The snap point for text is on the attachment point of the text.

Snap lines on dimensions
The snap line snap points for dimensions appear on the center of the dimension
text, and the snap line appears on and is parallel to the dimension line.

To align a new dimension with an existing dimension, the text and lines of the two
dimensions must be parallel.
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Snap lines on reference lines
On reference lines, the snap points appear on the vertices. You can snap the cursor
to the refline on any of the 9 text adjust points.

Example — Creating a Slotted Plate
Suppose you want to create an engineering drawing from a sketch made at a
design meeting. With the copilot functionality, you can quickly turn a sketch into
an engineering design without the need for unnecessary construction geometry.

Figure 21. Design Sketch

Figure 22. Design Reality

The following example illustrates how to construct the plate with the minimum of
construction geometry. As you draw, you will notice that line colors may change
as you intersect with existing geometry and the status line gives feedback on your
current activity. During certain actions, Creo Elements/Direct Drafting displays
negative values. Ignore these for this example.

1. Click Line in Geometry.
2. Click Horizontal and draw a horizontal line of length 50 mm (line 1 in Figure

23. Slotted Plate - 1 on page 93)
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3. Click Vertical and draw a vertical line of length 20 mm (line 2)
4. Click Angle & Length and click point A
5. Move the cursor in an arc and specify an angle of 135°
6. Drag the cursor and specify a length of 18 mm
7. Click the parallel construction line icon and click line 1
8. Drag the cursor vertically and click a point at 45
9. Click Vertical and draw line 4 to meet the construction line
10. Click Horizontal and draw a horizontal line of length 95 mm
11. Click Vertical and draw a vertical line of length 15 (line 6)
12. Click 2 Pts and draw line 7
The next step is to construct the holes. The hole at H1 is to be offset at 10 and 8
with diameter 6 mm. Holes H2 and H3 constructed on arcs 32 and 70 mm from
H1.

1. Click Circle in Geometry.
2. Click Center & Point or Radius (Figure 24. Slotted Plate - 2 on page 94)
3. Click Offset
4. Click line 1 and then line 2
5. Click the center point at 8 (x-axis) and 10 (y-axis)
6. Drag the cursor and specify a radius of 3
7. Draw construction circles at 32 and 70 with H1 as the center (center and radius

in Construct)
8. Click Center & Point or Radius and construct holes H2 and H3 having radius 5

(precise position is not important)
9. Delete the circular construction geometry.

Figure 23. Slotted Plate - 1
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Figure 24. Slotted Plate - 2

The slot can be drawn in freehand mode using the Polygon command. The only
criteria is that the inside edge is parallel to line 7.

1. Click the parallel construction line icon in Construct and draw the parallel
lines at a distance of 7 from lines 1, 5, and 7.

2. Click Polygon in Line and draw the slot starting at point B moving
anticlockwise.

Finally, to cleanup the drawing, delete the construction geometry and add some
fillets to the corners (Fillet in Geometry, size 5 mm).

Figure 25. Slotted Plate - 3
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This chapter shows how to produce a drawing using construction geometry and
"real" geometry.
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Creating Construction Geometry
Construction geometry is used for positioning and as an aid to drawing.
This section shows how to draw using construction lines and circles, just as you
would normally do when working on a drawing board.
Construction lines differ from real lines in that they are considered to be of infinite
length. Only full construction circles can be drawn.
When creating construction lines you can indicate a point for the line or enter the
exact coordinates via the keyboard.
Enter coordinates using the following format:
2.5,3
12,4.8
5.35,6.1

The x and y coordinates are separated by a comma. When you have typed in the
coordinates, press [Enter].

Creating Construction Lines
The following commands allow you to draw construction lines.

Horizontal Construction Line
Enter the y coordinate of the line required, or click a point
through which the line must pass. To create several
horizontal construction lines, simply enter the appropriate
y coordinates separated by spaces.

Vertical Construction Line
Enter the x coordinate of the line required, or click an existing
point through which the line must pass. To create several
vertical construction lines, simply enter the appropriate x
coordinates separated by spaces.

Construction Line by Two Points
Click this option, then click two points for the construction line
required or enter the coordinates of two points.

96 Creo Elements/Direct Drafting User's Guide: Windows User Interface



Parallel Construction Line
You can create construction lines parallel to any existing line in
the following ways:
• Click any existing line. Specify a point for the parallel

construction line to pass through. You can draw multiple
parallel construction lines by specifying further points for
the lines to pass through.

• Enter the required separation of the line. Then click any
existing line. Finally, click the side on which the parallel
construction line should be drawn. Multiple lines can be
drawn at the previously set separation by clicking the
original lines and the desired sides.

• A set of parallel lines can be drawn from an original line.
For example, if you enter line separations in the form: 10
20 30 40, four parallel lines will be drawn at the given
distances from the indicated line.

Perpendicular Construction Line
You can create a construction line perpendicular to any existing
line. Click the option, click the existing line, and then specify a
point through which the perpendicular construction line must
pass.

Bisecting Construction Line
If you do not want the line concerned divided into two equal
parts, enter a value for the ratio of the division. Then specify
the two end points of the line. A construction line will be
drawn perpendicular to the line at the appropriate position.

Construction Line Bisecting an Angle
You have the option of entering a value for the ratio of the
division, otherwise the angle will be bisected. Specify the apex,
and then specify two points (usually on existing lines) to define
the angle.
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Construction Line at an Angle
When you select this option, Creo Elements/Direct Drafting
will prompt you to specify a point through which the
construction line must pass. Next enter the angle of the line
with respect to the x axis. Note that a positive input will result
in a line drawn counterclockwise from the x axis. The angle
units will be those currently defined for your Creo Elements/
Direct Drafting environment.

Construction Line Tangent to Two Circles
You can create a construction line as a tangent to two circles or
splines. Click this option and click the approximate point of
tangency on each of the two circles or splines. The construction
line created will be the one with points of tangency closest to
those you indicated.

Construction Line Tangent from Point to Circle
This option enables you to create a construction line tangent to
a circle or a spline and passing through a given point or at a set
angle.
Click the approximate point of tangency on the circle or spline
and then specify a point through which the construction line
must pass. Or, click the approximate point of tangency, then
enter the desired angle of the construction line. Note that the
angle is measured in a counterclockwise arc from the
horizontal.

Drawing Construction Circles
Eight commands allow you to draw construction circles.

Construction Circle by Three Points
You can create a construction circle by specifying three points
on the circumference. Click this option and specify two
circumference points. The construction circle created will vary
with the movement of your cursor until you specify the third
point.
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Construction Circle by Center and Circumference
Point

Specify the center of the construction circle and either specify a
point on the circumference, or enter the radius required. If
multiple concentric circles are required, specify multiple
peripheral points or enter the desired radii.

Construction Circle by Diameter
Specify two points as the two ends of the diameter for the
required circle.

Concentric Construction Circle
To create concentric construction circles, click this option and
click the existing circle. Enter the radial offset of the new
construction circle from the existing one, that is the difference
between the two radii. To create several concentric
construction circles, simply type in the appropriate radial
offsets separated by spaces. Alternatively you can click
existing points through which the construction circles must
pass.

Construction Circle by Center and Element
Click the approximate point of tangency on the existing
element. Next specify the center of the construction circle to be
drawn.

Construction Circle by Radius, Point (or Two Points)
and Element

Click the approximate point of tangency of the construction
circle on the existing element (which must not be a spline).
Next specify a point on the circumference, then either specify
another point or enter the required radius.
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Construction Circle by Radius or Point and Two
Elements

This option draws a construction circle of given radius
tangential to two existing elements. Click the approximate
points of tangency (either lines or circles but no splines). Next
specify a peripheral point on the construction circle or enter the
desired radius. Creo Elements/Direct Drafting calculates the
best solution, or informs you that no solution is possible.

Construction Circle by Three Elements
Click the approximate point of tangency of the construction
circle on each of the three existing elements (none of which
must be a spline).

Note
If the third tangency point you click for a construction circle is located such
that no circle is tangent to all three points, the first two points will move along
the projection (notional extension) of the associated elements.

Drawing a Lever Using Construction
Geometry
Use the following tutorial example to familiarize yourself with the various
techniques used when producing a drawing with the aid of construction geometry.
Figure 26. Lever on page 101 shows the finished drawing of the lever.
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Figure 26. Lever

First draw horizontal and vertical construction lines. See Figure 27. Horizontal
and Vertical Construction Lines on page 101.

Figure 27. Horizontal and Vertical Construction Lines

1. Pull down the Setup menu and click Show.
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2. Make sure that the Construction Geometry and Geometry options are switched
on (ticked) in the Show option box.

3. Make sure that the Vertex option is switched off (not ticked) in the Show
option box.

4. Select All in the Catch menu at the bottom of the Creo Elements/Direct
Drafting window.

5. Click the following icon in Construct to draw a horizontal construction line:

6. Enter 0,0.
7. Click the following icon in Construct to draw a vertical construction line:

8. Enter 0,0.
9. Click Fit in View.
10. Click End.
Now draw some parallel horizontal construction lines. See Figure 28. Parallel
Construction Lines on page 102.

Figure 28. Parallel Construction Lines

1. Click the following icon in Construct to draw parallel construction lines:
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2. Enter -8 3 40 45.
3. Click the horizontal construction line and then click a point above it.
4. Click Fit in View.
Draw some parallel vertical construction lines. See Figure 29. Parallel Vertical
Lines on page 103.

Figure 29. Parallel Vertical Lines

1. Enter 11 25 130 151 (the option for parallel construction lines is still active).
2. Click the vertical construction line and click a point to the left of it.
3. Click Fit in View.
Create three viewports in the drawing area. See Figure 30. Three Viewports on
page 104.
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Figure 30. Three Viewports

1. Pull down the Setup menu.
2. Click Viewport and then Delete.
3. Click All.
4. Pull down the Setup menu.
5. Click Viewport and then Create.
6. Create viewport 1 as shown above by clicking two corner points of the

viewport.
7. Repeat the previous three steps to create viewports 2 and 3.

Viewports 1 and 2 give you a closer look at certain areas of your drawing
where you will do more complex work. Viewport 3 displays the entire
drawing.

8. Pull down the Setup menu.
9. Click Viewport and then Current.
10. Click viewport 1.
11. Click New in View and click two points in viewport 3 as defined by the left

hand rectangle.
12. Pull down the Setup menu.
13. Click Viewport and then Current.
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14. Click viewport 2.
15. Click New in View and click two points in viewport 3 as defined by the right

hand rectangle.
Now create some construction circles. See Figure 31. Construction Circles on
page 105.

Figure 31. Construction Circles

1. Click ALL in the Catch menu.
2. C1 — Click the following icon in Construct:

Then click the center point and lower circumference point (in viewport 3).
3. C2 — Click the following icon in Construct:

Then click the center point and enter 12 (in viewport 2).
4. C3 — Click the following icon in Construct:

Then click the center point and enter 17 (in viewport 2).
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5. C4 — Click the following icon in Construct:

Then click the center point and enter 8 (in viewport 1).
6. C5 — Click the following icon in Construct:

Then click the two tangent points and enter the radius 3 (in viewport 1).
7. C6 — Click the two tangent points and enter the radius 43 (in viewport 1).
8. C7 — Click the two tangent points and enter the radius 10.5 (in viewport 2).
9. C8 – Click the following icon in Construct:

Then click the tangent point to C7 and the center point of C4. Enter the radius
246 (in viewport 3).

10. C9 — Click the following icon in Construct:

Then click the two tangent points and enter the radius 8 (in viewport 3).
Draw a construction line tangent to C1 and C3. See Figure 32. Construction Line
Tangent on page 107.
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Figure 32. Construction Line Tangent

1. Click the following icon in Construct:

2. Click the tangent points on C1 and C3 (in viewport 3).
Click Overdraw in Geometry to draw the lever itself. See Figure 33. Drawing the
Lever on page 108.
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Figure 33. Drawing the Lever

1. Click Overdraw in Geometry.
2. Click point 11/1 as the start point.
3. Click a point on element 1 and click point 1/2.
4. Click a point on element 2 and click point 2/3.
5. Click a point on element 3 and click point 3/4.
6. Click a point on element 4 and click point 4/5.
7. Click a point on element 5 and click point 5/6.

Note
When drawing the arc on C9, ensure that the cursor is nearer to C9 than to
any other line. If you make a mistake, click Overdraw in Geometry and
window in on the area by clicking New in View.

8. Continue with this procedure for elements 6, 7, 8, 9, 10, and 11.
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Creating Geometry
To create geometry, click Geometry. The Geometry menu contains the following
commands:

• Point

• Line

• Circle

• Arc

• Fillet

• Chamfer

• Equidist

• Overdraw

• CenterLine

• SymLine

• Ellipse

• Hyperbola

• Parabola

• Interpolation Spline

• Control Spline

• Title Block

• Change

Creating Points
Points can be created anywhere on your drawing. Simply click Point in the
Geometry menu and then click the position in a viewport, or entering the required
coordinates.
If you have difficulty deleting points, try enclosing them in a box for deletion.

Creating Lines
The Line menu provides the following commands:

• Offset

• 2 Points

• Horizontal

• Vertical
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• Parallel

• Perpendicular

• Angle & Length

• Tangential Arc & Point

• Tangential Arc & Arc

• Rectangle

• Polygon

• Poly Element

Specifying an Offset for Linear Elements
The Offset command enables you to specify an offset for the points defining a new
line, arc, rectangle, polygon or polyline. This offset is defined by the distance
from an existing element and the distance from another existing element.
To define an offset for a linear element:

1. Click Line in Geometry.
2. Enter the following into the user input line:

OFFSET

3. Click on a linear element type (such as Horizontal) in Line.
4. Select the first existing element. Specify the required distance from this

element. Click a point on one side of this element.
5. Select the second existing element. Specify the required distance from this

element. Click a point on one side of this element.
6. The offset point thus defines serves as the current definition point (such as the

begin point or end point) of the linear element you are creating. Complete this
linear element. Note that you can use the Offset command multiple times when
creating the new linear element.

Alternatively:

1. Select the first element.
2. Select the second element.
3. Specify the offset point between the two elements.

Line by Two Points
To draw a line by two points:

1. Click Line in Geometry.
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2. Click 2 Points in Line.
3. Specify the start and end points of the line.

Horizontal Line
This option is similar to line by two points but only draws a horizontal line.
To draw a horizontal line:

1. Click Line in Geometry.
2. Click Horizontal in Line.
3. Specify the start point of the line.
4. Specify the end point of the line, or enter the length of the line.

If you specify an end point, the line is drawn through that point.

Vertical Line
This option is similar to line by two points but only draws a vertical line.
To draw a vertical line:

1. Click Line in Geometry.
2. Click Vertical in Line.
3. Specify the start point of the line.
4. Specify the end point of the line, or enter the length of the line.

If you specify an end point, the line is drawn through that point.

Parallel Line
To draw a line parallel to an existing line:

1. Click Line in Geometry.
2. Click Parallel in Line.
3. Click the existing line.
4. Specify a point on the new line.

You can use the ruler to ensure that the line is drawn at a given distance (refer
to Using the Ruler/Grid on page 69).

Alternatively:

1. Click Parallel.
2. Enter the distance required.
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3. Click the existing line.
4. Specify the side on which the parallel line should be drawn.

Perpendicular Line
To draw a perpendicular line:

1. Click Line in Geometry.
2. Click Perpend in Line.
3. Click the existing line.
4. Specify the point from which the perpendicular line should be dropped.
Alternatively:

1. Click Perpend.
2. Click the existing line.
3. Specify a point on the existing line.
4. Enter the length of the perpendicular line. If the perpendicular line appears on

the wrong side of the line, repeat the operation using the opposite sign for the
entered value.

Tangent from Point to Arc or Circle
This option enables you to draw a tangent to a circular element from any given
point.

1. Click Line in Geometry.
2. Click Tangential Arc & Point in Line.
3. Specify the approximate point of tangency on the arc or circle.
4. Specify the point from which the tangent should be drawn.

The system will inform you if such a tangent cannot be created.

Tangent to Two Arcs or Circles
To draw a tangent from one circular element to another:

1. Click Line in Geometry.
2. Click Tangential Arc & Arc in Line.
3. Specify the approximate point of tangency on each of the two arcs or circles.

The tangent drawn will be the one with points of tangency closest to those
indicated.
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Line with Given Length and Angle
To draw a line with a given length and angle:

1. Click Line in Geometry.
2. Click Angle & Length in Line.
3. Specify the start point of the line.
4. Enter the angle of the line with respect to the x-axis.
5. Enter the length of the line.

The line will be drawn accordingly.

Rectangle
Rectangles can be created as whole entities, but the system treats them as four
individual line elements. This means the sides of a rectangle can be deleted or
manipulated individually.
To draw a rectangle:

1. Click Line in Geometry.
2. Click Rectangle in Line.
3. Specify two diagonal corner points.

The rectangle size will vary with the movement of the cursor until the second
point is defined.

Polygon
To draw a polygon:

1. Click Line in Geometry.
2. Click Polygon in Line.
3. Specify the start point, and then a sequence of end points.
Note that the result does not have to be a closed polygon. The lines are treated as
individual elements and must therefore be deleted individually or enclosed in a
box for deletion.
Once you have closed a polygon, you can continue by indicating the first point of
a new polygon.

Creating a Polyline
Polylines can be created with Poly Element.
Polylines facilitate design modifications.
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The following example shows some of the differences of working with polyline
elements and non-polyline elements. Drawing A is a standard polygon created
with Polygon in Line. To modify the pensizes of drawing A to produce drawing
A1, you need to click points 1, 2, and 3 (for the purpose of this example, it is
assumed that only individual elements can be clicked).
Drawing B is similar to drawing A but has been converted into a polyline.
Because drawing B is a polyline, it acts like a single element and you need only
click point 4 to modify the complete shape (drawing B1).

Figure 34. Modifying Polyline and Non-Polyline Elements

The following procedure describes how to create a polyline from a polygon and
then modify the polyline by changing its pensize and shape.
To create a polyline:

1. Create a polygon.
2. Click Poly Element in Line.
3. Click a vertex of the existing polygon.
4. Click a polygon element that ends at the vertex.
5. Click adjacent elements or click the last element.
6. Click End when the desired shape is defined.
The polygon is now a polyline. To test it, change the pensize:

1. Click Change in Geometry.
2. Click Pen Width in Change.
3. Enter a value (for example, 0.5).
4. Select one element of the polyline.

Note that the complete shape changes–not just the selected element.
Similarly, you can modify the shape of the polyline:
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1. Switch off Keep in Modify.
2. Click Stretch in Modify.
3. Click a Stretch option (such as Horizontal).
4. Click a vertex (or enclose it in a box).
5. Specify the new position of the vertex.

Smashing a Polyline
Use the Smash option to smash the polyline into individual elements.

Drawing Circles
The commands used for drawing circles are:

• Offset

• Center & Point or Radius

• 3 Points

• Tangential

• Concentric

• Diameter

Specifying an Offset for Circles
The Offset command enables you to specify an offset for a new circle. This offset
is defined by the distance from two existing linear elements.
To define an offset for a circle:

1. Click Circle in Geometry.
2. Click on a circle option (such as 3 Points) in Circle.
3. Click Offset in Circle.
4. Select the first linear element. Specify the required distance from this element.

Click a point on one side of this element.
5. Select the second linear element. Specify the required distance from this

element. Click a point on one side of this element.
6. The offset point thus defines a point of the circle you are creating. Complete

the circle. Note that you can use the Offset command multiple times when
creating the circle.

Alternatively:

1. Select the first element.
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2. Select the second element.
3. Specify the offset point between the two elements.

Circle by Center and Circumference Point
To draw a circle by indicating the center and point:

1. Click Circle in Geometry.
2. Click Center & Point or Radius in Circle.
3. Specify the center of the circle.
4. Specify a point on the circumference, or enter the length of the radius. The

circle moves with the cursor until the circumference point is defined.

You can create additional concentric circles by indicating additional points or
radii.

Circle by Three Points
To draw the circle by indicating three points on the circumference:

1. Click Circle in Geometry.
2. Click 3 Points in Circle.
3. Specify three circumference points.

The circle drawn will vary with the movement of the cursor until the third
point is defined.

Circle by Radius and Two Elements
To draw a circle of given radius tangential to two existing elements:

1. Click Circle in Geometry.
2. Click Tangent in Circle.
3. Specify the approximate tangent points on the two elements.
4. Enter the radius required.

The elements can be either lines, arcs or circles. Creo Elements/Direct
Drafting will calculate the best solution or, if no solution is possible, it will
suggest a valid radius.

Concentric Circles
To draw concentric circles:
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1. Click Circle in Geometry.
2. Click Concentric in Circle.
3. Click the existing circle.
4. Specify the desired circumference point and the circle will be drawn.

To draw further concentric circles, simply specify further circumference
points.

Alternatively:

1. Click Concentric.
2. Click the existing circle.
3. Enter the radial offset.

Circle by Diameter
To draw a circle by diameter:

1. Click Circle in Geometry.
2. Click Diameter in Circle.
3. Specify the two diameter end points for the circle required.

Drawing Arcs
This section shows how to use the commands for drawing arcs. Arcs are normally
drawn in the counterclockwise direction. The options are:

• Offset

• 3 Points

• Center & Radius & Angle

• Center & Radius & Ends

• Concentric

• Point & Radius & Angles

• Diameter

• Smooth

Figure 35. Arc Geometry on page 118 shows arc geometry.
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Figure 35. Arc Geometry

Specifying an Offset for Arcs
The Offset command enables you to specify an offset for a new arc. This offset is
defined by the distance from two existing linear elements.
To define an offset for an arc:

1. Click Arc in Geometry.
2. Click on an arc option (such as 3 Points) in Arc.
3. Click Offset in Arc.
4. Select the first linear element. Specify the required distance from this element.

Click a point on one side of this element.
5. Select the second linear element. Specify the required distance from this

element. Click a point on one side of this element.
6. The offset point thus defines a point of the arc you are creating. Complete the

arc. Note that you can use the Offset command multiple times when creating
the arc.

Alternatively:

1. Select the first element.
2. Select the second element.
3. Specify the offset point.

Arc by Three Points
To draw an arc through three points:

1. Click Arc in Geometry.
2. Click 3 Points in Arc.
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3. Specify the two end points of the required arc.
4. Specify a third point on the arc.

The arc drawn will vary with the movement of the cursor until the third point
is defined.

Arc by Center and Radius
To draw an arc with a given center and radius:

1. Click Arc in Geometry.
2. Click Center & Radius & Angle in Arc.
3. Specify the center point.
4. Enter the radius.
5. Enter the start angle and the end angle of the arc. Alternatively, you can define

the angles by specifying two points.

Arc by Center and End Points
1. Click Arc in Geometry.
2. Click Center & Radius & Ends in Arc.
3. Specify the center of the arc.
4. Specify the radius (arc start point).
5. Specify a third point. It does not need to lie on the arc plane, but its line

defines the end of the arc.

Concentric Arcs
To draw concentric arcs:

1. Click Arc in Geometry.
2. Click Concentric in Arc.
3. Click the existing arc.
4. Specify a point on the required arc.

Simply specify further points to draw further concentric arcs.

Arc by Center and Radius and Angle
To draw an arc by specifying the arc center and radius:

1. Click Arc in Geometry.
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2. Click Point & Radius & Angles in Arc.
3. Specify the center of the arc.
4. Enter the arc radius.
5. Enter the arc begin (or end) angle (angles are measured counterclockwise from

the horizontal).
6. Enter the arc angle.

Arc by Diameter
1. Click Arc in Geometry.
2. Click Diameter in Arc.
3. Specify the diameter end points and an arc will be drawn between them.

The resulting position of the arc will depend upon which diameter point is
specified first.

Smoothly Connecting Arc
To draw a smoothly connecting arc:

1. Click Arc in Geometry.
2. Click Smooth.
3. Click an element end point (line, circle, and so on).
4. Specify the end point of the arc.

The arc is drawn tangential to the element you have clicked. With each further
point indicated, another arc is drawn tangential to the previous one. In Figure
36. Smoothly Connecting Arcs on page 120, points 1 to 4 have been specified
in sequence.

Figure 36. Smoothly Connecting Arcs

Drawing Fillets
To draw a fillet:
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1. Click Fillet in Geometry.
2. Enter the radius.
3. Click the two elements between which the fillet should be drawn, or click the

vertex.

The fillet radius will be drawn and by default the corner point will be deleted.
If you do not want the corner to be deleted, switch on Keep Corner before
clicking the elements or vertex.

Changing Fillets
To change fillet radii you have already created:

1. Click Fillet in Geometry.
2. Enter the new fillet radius.
3. Click the individual fillets to be changed or enclose them in a box.

You also can change all existing fillets by clicking Fillet and All in the Select
menu. Then click Confirm. To remove all fillets, enter a radius of zero.

Drawing Chamfers
Four methods of drawing a chamfer are described in this section. By default the
corner will be deleted after the chamfer is drawn. If you do not want the corner to
be deleted, switch on Keep Corner before you choose a chamfer option.

Chamfer at Distance from Vertex
To draw a chamfer at a given distance from the vertex along each line:

1. Click Chamfer in Geometry.
2. Click Vertex in Chamfer.
3. Enter the chamfer distance.
4. Click the vertex (the point where the two lines intersect).

Chamfer by Two Points
To draw a chamfer by two points:

1. Click Chamfer in Geometry.
2. Click 2 Points in Chamfer.
3. Click the start point and end point of the required chamfer.
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Chamfer by Two Distances
To draw a chamfer by specifying two different distances:

1. Click Chamfer in Geometry.
2. Click Dist. Dist. in Chamfer.
3. Enter the distance for chamfer along the first element.
4. Enter the distance for chamfer along the second element.
5. Click the first element.
6. Click the second element.

Chamfer at Distance and Angle
To draw a chamfer at a given angle to the first line and at a given distance from
the vertex:

1. Click Chamfer in Geometry.
2. Click Dist. Ang. in Chamfer.
3. Enter the angle between the chamfer and the first element.
4. Enter the chamfer distance.
5. Click the first element.
6. Click the second element.

Drawing Equidistant (Parallel) Contours
To create a contour equidistant to an existing contour:

1. Click Equidist in Geometry.
2. Enter the separation required for the equidistant/parallel contour.
3. Click the start point of the existing contour.
4. Select the elements to be copied (Creo Elements/Direct Drafting will allow

you to skip to the final element, provided you do not pass more than one
branch element that is not to be copied).

5. Indicate the side on which the equidistant contour is to be drawn.
If you require a particular section of a contour to be copied:

1. Follow steps 1 to 4 above.
2. When you have indicated the desired section, click End.
3. Specify the side on which the equidistant contour is to be drawn.
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Using Overdraw
Use Overdraw to draw a contour between intersection points in the construction
geometry. The lines will be drawn over the existing construction lines and circles
just as you would line in a contour by hand.
Additionally, it is not necessary to click each construction geometry intersection
point before clicking the line or arc you want to draw over. You simply click the
next construction geometry element and Creo Elements/Direct Drafting calculates
the intersection point. This saves one click for every overdraw action.
To use the Overdraw command:

1. Draw the construction geometry as shown in Figure 37. Using the Overdraw
Command on page 123.

2. Click Overdraw.
3. Specify the start point (1).
4. Specify points 2 to 14 (end point).

Figure 37. Using the Overdraw Command

The Overdraw command also supports multiple Undo operations.

Creating a Centerline
This command lets you create a centerline for a circular element. The centerline
becomes part of the circular element and is moved or deleted if the associated
circular element is moved or deleted.
To create a centerline, click Centerline in the Geometry menu and click the circle.
Figure 38. Creating a Centerline on page 124 shows the top circles before and
after adding a centerline. The different appearance of the centerlines is done by
changing absolute and relative values. Refer to the online help on how to do this
(help centerline).
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Figure 38. Creating a Centerline

When you dimension centerlines and then make a modification, the dimension is
automatically updated. When asked to click the first element, click the center
point of the circle (use Catch Center).

Figure 39. Effect of Changing the Position

Click Change in the Centerline menu to change the position of the centerline.

To create a single slot centerline,
1. Go to Geometry ▶ Centerline ▶ Slot Single.
2. Specify a circular element of a slot. Creo Elements/Direct Drafting draws the

single slot centerlines.

To create double slot centerlines,
1. Go to Geometry ▶ Centerline ▶ Slot Double.
2. Specify a circular element of a slot. Creo Elements/Direct Drafting draws the

double slot centerlines.
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Limitations of slot centerlines:
• Slot centerlines can be created only between two 180 degree arcs.
• The start and end points of the two arcs must be on a line that is perpendicular

to the line connecting the center points of the arcs. After the center lines are
created, you can modify the slot element.

Creating Symmetric Elements
Use the SymLine command to create elements that are:

• Symmetric with existing elements
• Associated (or anchored) to the defining elements.
When you modify the defining elements, the associated element is modified
accordingly.
To draw an associated element:

1. Draw a polygon similar to that shown in Figure 40. Associated Symmetric
Elements on page 126.

2. Create circle 1 having diameter 1 mm.
3. Create circle 2 having diameter 3 mm.
4. Click SymLine in the Geometry menu.
5. Click circle at point 1.
6. Click circle at point 2.
Creo Elements/Direct Drafting draws the associated circle (point 3) that is:

• Midway between circles 1 and 2.
• 2 mm in diameter (half the sum of the defining diameters).
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Figure 40. Associated Symmetric Elements

Click Change in the SymLine menu to change the position of the symmetry line.
Now try moving the circle at position 2 and notice how the associated element
also moves.

Figure 41. Effect of Moving the Defining Circle

Figure 42. Finding Lines of Symmetry on page 126 shows another example of
where to use the SymLine command.

Figure 42. Finding Lines of Symmetry

Indicating the
The "projected reference point" is the point at which the extended traces of two
existing elements (line-line, line-arc, and arc-arc) would meet. To indicate this
point in your drawing:

1. Click Projected Reference Point in Geometry.
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2. Click the first element.
3. Click the second element.
The point where the traces of the two elements meet is now shown in your
drawing.
When one or both the elements are arcs, the intersection point that is closest to
both the elements is the projected reference point.
Note that this reference point (plus the associated traces) are fully associative:

• These items can be included in dimensions.
• These items are preserved even when you perform Modify operations.

Note
You cannot have projected reference points across parts.

Figure 43. Projected Reference Point on page 127 shows an example of a
projected reference point.

Figure 43. Projected Reference Point

Changing the Settings of the Projected Reference
Point
To change the settings of the projected reference point and its associated elements:

1. Click Setup ▶ Edit Environment ▶ Projected Reference Points.
2. In Projected Reference Point Settings, select the linetype, color, width, size

and show option for the individual elements associated with the projected
reference point.
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Drawing Ellipses
The commands used for drawing an ellipse are:

• Axis Ends & Peripheral Point

• Center & Angle & Radius

• Center & 2 Peripheral Points

• 2 Focal Points & Circumference Point

• Focal Point & Angle & Ex_value & Radius

Ellipse by Axis End Points and Peripheral Point
To draw an ellipse by axis end points and peripheral point:

1. Click Ellipse in Geometry.
2. Click Axis Ends & Peripheral Point in Ellipse.
3. Specify the two vertices of the major axis of the required ellipse.
4. Specify a point on the circumference.

Ellipse by Center, Angle and Radii
To draw an ellipse by center, angle and radii:

1. Click Ellipse in Geometry.
2. Click Center & Angle & Radius in Ellipse.

See Figure 44. Ellipse by Center, Angle and Radii on page 128.

Figure 44. Ellipse by Center, Angle and Radii

3. Specify the center of the required ellipse.
4. Enter the angle of the major axis with respect to the x axis (30° in Figure 44

on page 95).
5. Enter the major radius (30mm) in Figure 44. Ellipse by Center, Angle and

Radii on page 128).
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6. Enter the minor radius (15mm) in Figure 44. Ellipse by Center, Angle and
Radii on page 128).

Ellipse by Center and Two Points
To draw an ellipse using the center and two points:

1. Click Ellipse in Geometry.
2. Click Center & 2 Peripheral Points in Ellipse.
3. Specify the center point of the ellipse.
4. Specify the first point on the circumference.
5. Specify the second point on the circumference.

Ellipse by Focus and Points
Use the Ellipse command options 2 Focal Points & Circumference Point and Focal
Point & Angle & Ex_value & Radius to create elliptical shapes by means of the focal
points and the major radius.

Figure 45. Ellipses by Focus, Point, Angle

To create an ellipse by specifying the focus (drawing A):

1. Click Ellipse in Geometry.
2. Click 2 Focal Points & Circumference Point in Ellipse.
3. Specify the first focal point (1).
4. Specify the second focal point (2).
5. Specify a point on the circumference (3).
To create an ellipse by specifying the focal points and a direction (drawing B):

1. Click Focal Point & Angle & Ex_value & Radius in Ellipse.
2. Specify the first focal point (point 1).
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3. Specify the direction of the major axis (point 2)
4. Enter an Ex-value (for example, 0.8)
5. Enter a value for the major radius (for example, 15)

Drawing Hyperbolas
The commands used for drawing a hyperbola are:

• Center & Focus & End Point

• Center & Tangential & Focus Point

Hyperbola by Center, Focus and End Points
To draw a hyperbola using the center, focus and end points:

1. Click Hyperbola in Geometry.
2. Click Center & Focus & End Point in Hyperbola.
3. Specify the center of the hyperbola (point 1).
4. Specify the focus of the hyperbola (point 2).
5. Specify one end of the hyperbola (point 3). Note that the other end point of the

hyperbola is computed by symmetry.

Figure 46. Hyperbola by Center, Focus, and End Point

Hyperbola by Center, Tangent and Focus
To draw a hyperbola tangential to existing geometry:

1. Click Hyperbola in Geometry.
2. Click Center & Tangential & Focus Point in Hyperbola.
3. Specify the center of the hyperbola (point 1).
4. Click a tangential point (point 2).
5. Specify the focus of the hyperbola (point 3).
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Figure 47. Hyperbola by Center, Tangent, and Focus

Creo Elements/Direct Drafting automatically adds the tangential construction
geometry.

Drawing Parabolas
The commands used for drawing a parabola are:

• Center & Focus

• Focus & Direction & End Point

Parabola by Center and Focus
To draw a parabola using its center and focus:

1. Click Parabola in Geometry.
2. Click Center & Focus in Parabola.
3. Specify the center of the parabola (point 1)
4. Specify the focus of the parabola (point 2)

Figure 48. Parabola by Center and Focus

Parabola by Focus, Direction and End Points
To draw a parabola in a specific direction:

1. Click Parabola in Geometry.
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2. Click Focus & Direction & End Point in Parabola.
3. Specify the focus of the parabola (point 1).
4. Specify the direction of the parabola (point 2).
5. Specify the end of the parabola (point 3). Note that the other end point of the

parabola is computed by symmetry.

Figure 49. Parabola by Focus, Direction and End Points

Drawing Splines
Spline curves are special types of smooth curves that pass through given data
points. When you have specified the data points, Creo Elements/Direct Drafting
uses a powerful technique (B-spline mathematics) to produce the spline shape.
The following diagram shows examples of uses of spline curves.

Figure 50. Typical Spline Curves: Engine Manifold, Pipe Tree, Racquet
Head

Spline Components
Figure 51. Spline Components on page 133 shows a simple spline with its control
polygon visible. The control polygon can be thought of as a convex hull
containing the spline. Note that both interpolation and control splines have a
control polygon. Points on the interpolation spline curve are called interpolation
points. Points on the control polygon are called control points.
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Figure 51. Spline Components

Interpolation Spline vs. Control Spline
You can create splines based on interpolation points or control points. If you want
a spline to pass through defined points, use interpolation points. If the spline does
not need to pass through defined points, you can use interpolation-point created
splines or control-point created splines. Control-point created splines are more
appropriate for creative design work where curved molded surfaces are required.

Open Spline vs. Closed Spline
By default, the interpolation or control splines you create in Creo Elements/Direct
Drafting are open. The Closed option provided in Interpolation Spline and Control
Spline enables you to create closed splines.

Figure 52. Open Spline vs. Closed Spline

Specifying the Order of a Spline
The spline order controls the smoothness of the curve. The higher the order, the
smoother the spline. Figure 53. Spline Order on page 134 shows two splines
drawn through the same control points.
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Figure 53. Spline Order

Be sure to specify the order of the spline before you specify the last interpolation
point (for interpolation splines) or control point (for control splines) for the spline.

Interpolation Splines
Points on an interpolation spline (I spline) are called interpolation points. A spline
created with interpolation points will pass exactly through the interpolation points
used to define it.

Note
To display the control polygon of an interpolation spline, switch on Vertex in
the Show menu.

In this section:

• Drawing Interpolation Splines on page 134
• Modifying Interpolation Points on page 137
• Changing the Slope of an Interpolation Spline on page 139

Drawing Interpolation Splines
In this section:

• Spline by Interpolation Points on page 134
• Appending an Interpolation Spline on page 135
• Specifying the Slope of an Interpolation Spline on page 135

Spline by Interpolation Points
To draw an interpolation spline:

1. Click Interpolation Spline in Geometry.
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2. Click Create in Interpolation Spline.
3. Specify a sequence of interpolation points.
4. Click End.
Creo Elements/Direct Drafting draws a spline curve through the points you
specified.

Appending an Interpolation Spline
To append an interpolation spline to existing geometry:

1. Click Interpolation Spline in Geometry.
2. Click Append in Interpolation Spline.
3. Click the end-point of the line to which you want to append an interpolation

spline.
4. Specify a sequence of points.
5. Click End.
To append the begin-point and end-point of an interpolation spline:

1. Click Interpolation Spline in Geometry.
2. Click Append in Interpolation Spline.
3. Specify point A and a series of points B1, B2, B3, ..., Bn.
4. Click Append in Interpolation Spline.
5. Specify point C.
6. Click End.

Figure 54. Appending an Interpolation Spline

Specifying the Slope of an Interpolation Spline
When using Create to draw a new interpolation spline, you can use the Tangent
option to specify the slope angle at which the interpolation spline leaves or
approaches the current interpolation point. For example, to specify a slope of 70°:

1. Click Interpolation Spline in Geometry.
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2. Use Create or Append in Interpolation Spline to define the first interpolation
points (such as point A in Figure 55. Specifying the Slope of an Interpolation
Spline on page 136).

3. Click Tangent in Interpolation Spline.
4. Type in the slope angle (such as 70) and press [Enter]. Alternatively, you can

specify a point at the required angle, for example, point C.
5. Specify the second point (B in Figure 55. Specifying the Slope of an

Interpolation Spline on page 136).
6. Click End.

Figure 55. Specifying the Slope of an Interpolation Spline

By specifying a slope at a given interpolation point, you add a tangency condition
to the spline. This tangency condition can be modified (see Changing the Slope of
an Interpolation Spline on page 139) or deleted (see Deleting a Tangency
Condition of an Interpolation Spline on page 140).
Figure 56. Effects of Different Slope Angles on page 136 shows the effects of
specifying different slope angles:

Figure 56. Effects of Different Slope Angles

Being able to specify the slope of a spline is useful when joining unequal
diameters. The following diagram shows the difference between curves created
with the Append option (curve CD) and the Tangent option (curve AB).
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Figure 57. Slope of Interpolation Splines

To draw curve C to D, do the following:

1. Click Interpolation Spline in Geometry.
2. Click Append in Interpolation Spline.
3. Click point C.
4. Click Append in Interpolation Spline.
5. Click point D.
6. Click End.
To draw the lower curve A to B, do the following:

1. Click Interpolation Spline in Geometry.
2. Click Create in Interpolation Spline.
3. Click point A.
4. Click Tangent in Interpolation Spline.
5. Enter 5.
6. Click point B.
7. Click Tangent in Interpolation Spline.
8. Enter 20.
9. Click End.

Modifying Interpolation Points
In this section:

• Adding an Interpolation Point on page 138
• Moving an Interpolation Point on page 138
• Deleting an Interpolation Point on page 138
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Adding an Interpolation Point
To add an interpolation point to an interpolation spline:

1. Click Interpolation Spline in Geometry.
2. Click Modify Point in Interpolation Spline.
3. Click Add in Modify Point.
4. Click the spline to which you want to add an interpolation point.
5. Click the position on the spline where you want to add the interpolation point.
When you add an interpolation point, the shape of the spline changes accordingly.

Moving an Interpolation Point
To change the position of an interpolation point of a spline:

1. Click Interpolation Spline in Geometry.
2. Click Modify Point in Interpolation Spline.
3. Click Change in Modify Point.
4. Click the spline you want to modify.
5. Click the interpolation point you want to move.
6. Click the new position of the interpolation point.
When you move an interpolation point, other interpolation points will also be
moved. The shape of the spline changes accordingly.

Deleting an Interpolation Point
To delete an interpolation point of a spline:

1. Click Interpolation Spline in Geometry.
2. Click Modify Point in Interpolation Spline.
3. Click Delete in Modify Point.
4. Click the spline you want to modify.
5. Click the interpolation point you want to delete.
When you delete an interpolation point, the shape of the spline adjusts to the
positions of the remaining interpolation points.

Changing the Spline Shape by Moving an Interpolation
Point
To change the shape of an interpolation spline by moving one of its interpolation
points:
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1. Click Interpolation Spline in Geometry.
2. Click Modify Point in Interpolation Spline.
3. Click Shape in Modify Point.
4. Click the spline you want to modify.
5. Click the interpolation point you want to move.
6. Specify the new position of this interpolation point.
When you move an interpolation point, the shape of the spline changes
accordingly.

Changing the Slope of an Interpolation Spline
In this section:

• Changing the Slope at an Interpolation Point on page 139
• Changing the Slope at Any Point on an Interpolation Spline on page 140
• Deleting a Tangency Condition of an Interpolation Spline on page 140
• Changing the Shape of an Interpolation Spline on page 141

Changing the Slope at an Interpolation Point
You can change the spline slope at any interpolation point without moving
interpolation points. The spline slope defines the angle at which a spline
approaches an interpolation point. This is useful if you are merging a spline with
another line. Figure 58. Effect of Changing the Slope at an Interpolation Point on
page 139 shows a simple spline and the same spline with the tangent of
interpolation point A changed.

Figure 58. Effect of Changing the Slope at an Interpolation Point

To change the spline slope at an interpolation point:

1. Make sure that the Vertex option is switched on (ticked) in the Show option
box so that the interpolation points are displayed.

2. Click Interpolation Spline in Geometry.
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3. Click Modify Tangent in Interpolation Spline.
4. Click Add in Modify Tangent.
5. Click the interpolation spline.
6. Click an interpolation point of the spline. Creo Elements/Direct Drafting

displays an arrow to indicate the spline slope at that point.
7. Type in the required slope angle (such as 70) and press [Enter]. Alternatively,

you can specify a point at the required angle.
The spline slope at other interpolation points changes accordingly. However, the
interpolation points do not move.

Changing the Slope at Any Point on an Interpolation Spline
You can change the spline slope at any point on the interpolation spline. This
operation will move the interpolation points of the spline.
To change the spline slope at any point on the spline:

1. Click Interpolation Spline in Geometry.
2. Click Modify Tangent in Interpolation Spline.
3. Click Change in Modify Tangent.
4. Click the interpolation spline.
5. Click an interpolation point of the spline. Creo Elements/Direct Drafting

displays an arrow to indicate the spline slope at that point.
6. Type in the required slope angle (such as 70) and press [Enter]. Alternatively,

you can specify a point at the required angle.
The interpolation points of the spline move to new positions. The spline slope at
the interpolation points changes accordingly.

Deleting a Tangency Condition of an Interpolation Spline
You can undo any spline slope change (see Specifying the Slope of an
Interpolation Spline on page 135, Changing the Slope at an Interpolation Point on
page 139, and Changing the Slope at Any Point on an Interpolation Spline on page
140) by deleting the associated tangency condition.
To delete a tangency condition:

1. Make sure that the Vertex option is switched on (ticked) in the Show option
box so that the interpolation points and any points where you changed the
spline slope are displayed.

2. Click Interpolation Spline in Geometry.
3. Click Modify Tangent in Interpolation Spline.
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4. Click Delete in Modify Tangent.
5. Click the spline.
6. Click the point where you defined or changed the slope angle.
The spline will return to the shape it had before you defined or specified a slope
angle at a given point on the spline.

Changing the Shape of an Interpolation Spline
You can change the shape of an interpolation spline without moving any of its
interpolation points.
To change the shape of an interpolation spline:

1. Click Interpolation Spline in Geometry.
2. Click Modify Tangent in Interpolation Spline.
3. Click Shape in Modify Tangent.
4. Click the spline.
5. Click the interpolation at which you want to change the spline slope in order to

change the shape of the spline.
Note that the shape of the spline changes but none of its interpolation points are
moved.

Control Splines
When you create a spline using a control polygon, the shape of the spline is
influenced by the control polygon formed by the control points.
In this section:

• Drawing Control Splines on page 141
• Modifying Control Points on page 142
• Changing the Slope at a Point on the Control Spline on page 143

Drawing Control Splines
To draw a control spline:

1. Click Control Spline in Geometry.
2. Click Create in Control Spline.
3. Specify a sequence of control points. Note that these points make up a control

polygon which "controls" the shape and size of the resulting control spline.
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The first control point serves as the begin point of the control spline. The last
control point serves as the end point of the control spline.

4. Click End.
Creo Elements/Direct Drafting draws a spline curve based on the control points
you specified.

Modifying Control Points
You can modify the size and shape of a control spline by modifying its control
points.
In this section:

• Adding a Control Point on page 142
• Moving a Control Point on page 142
• Deleting a Control Point on page 143
• Changing the Shape of a Control Spline on page 143

Adding a Control Point
To add a control point to a control spline:

1. Click Control Spline in Geometry.
2. Click Modify Point in Control Spline.
3. Click Add in Modify Point.
4. Click the spline you want to modify.
5. Click a position between two existing control points.
6. Move the cursor to the position where you want to add the new control point.
7. Click to add the new control point.
When you add a control point, the shape of the spline changes accordingly.

Moving a Control Point
To change the position of a control point of a spline:

1. Click Control Spline in Geometry.
2. Click Modify Point in Control Spline.
3. Click Change in Modify Point.
4. Click the spline you want to modify.
5. Click the control point you want to move.
6. Click the new position of the control point.
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When you move a control point, the shape of the spline changes accordingly.

Deleting a Control Point
To delete a control point of a control spline:

1. Click Control Spline in Geometry.
2. Click Modify Point in Control Spline.
3. Click Delete in Modify Point.
4. Click the spline you want to modify.
5. Click the control point you want to delete.
When you delete a control point, the shape of the spline changes accordingly.

Changing the Shape of a Control Spline
You can change the shape of a control spline by moving one or multiple control
points.
To change the shape of a control spline:

1. Click Control Spline in Geometry.
2. Click Modify Point in Control Spline.
3. Click Shape in Modify Point.
4. Click the spline.
5. Click the control point you want to move in order to change the shape of the

spline.
Note that the shape of the spline changes when you move one of its control points.

Changing the Slope at a Point on the Control Spline
You can change the spline slope at any point on the control spline. This operation
will move the control points of the spline.
To change the spline slope at any point on the spline:

1. Click Control Spline in Geometry.
2. Click Modify Tangent in Control Spline.
3. Click the control spline.
4. Click any point on the spline. Creo Elements/Direct Drafting displays an

arrow to indicate the spline slope at that point.
5. Type in the required slope angle (such as 70) and press [Enter]. Alternatively,

you can specify a point at the required angle.
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The spline slope changes accordingly. The control points of the spline move to
new positions.

Modifying Splines
Splines can be converted to lines and arcs or subdivided (split) into individual
spline segments.

Converting Splines
Splines need to be co-converted only if you want to export them to devices (such
as numerical control machines) that do not recognize spline curves.
The Convert command converts splines to arcs and lines by approximation. This
command provides the following options:
Arcs & Lines Use this option to convert splines to

arcs and lines.
Lines Use this option to convert splines to

lines.

Using the Trimming Function
Splines can be split in the same way as other line elements. However, you can set
a Trimming function that affects the way in which a spline is split. The Trimming
function has the options:
On Two new (independent) splines are

created, each with their own
mathematical behavior.

Off A given section of the spline is hidden
following the split. This means that the
spline is drawn from the start (or end)
point to the split point. Curve points
beyond the visibility range are kept but
are hidden.

Figure 59. Splitting Splines on page 145 shows the effects of splitting a spline
with Trimming:
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On Splines 2A and 2B
The spline is split in two — with each
spline having a new end-point, a new
start-point, and individual control
polygons.

Off Splines 3A and 3B
The spline is split but the control
polygon retains its shape. When the left
part of the spline is deleted, the curve
points are retained (but hidden).

Figure 59. Splitting Splines

In drawings 2B and 3B, the left spline has been deleted. Notice in drawing 3B
how the control polygon thinks that the spline starts at its original point (drawing
1).
To split and trim a spline:

1. Click Interpolation Spline or Control Spline in Geometry.
2. Switch on the Trimming option in Interpolation Spline or Control Spline.
3. Click Subdivide in Interpolation Spline or Control Spline.
4. Divide the spline. Proceed as described in Subdividing a Spline on page 145.

Subdividing a Spline
The Subdivide command either divides a spline into section of equal length (spline
1 in Figure 60. Dividing a Spline on page 146) or splits a spline at points along its
length (spline 2 in Figure 60. Dividing a Spline on page 146).
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Figure 60. Dividing a Spline

Dividing a Spline into Segments of Equal Length
Dividing splines into sections of equal lengths is useful, for example, when
designing the shape of a ship's hull and you need to divide the ribs (rib-cage) into
equal lengths.
To divide a spline into segments of equal length:

1. Click Interpolation Spline or Control Spline in Geometry.
2. Click Subdivide.
3. Click the spline you want to split.
4. Enter an integer for the number of segments you want to produce (for

example, 4).
Creo Elements/Direct Drafting divides the spline into the specified number of
segments.

Dividing a Spline by Specifying a Split Point
You can define a split point by specifying a length value. The spline will be split
at the end point of the spline segment defined by this length.
To divide a spline by specifying a split point:

1. Click Interpolation Spline or Control Spline in Geometry.
2. Click Subdivide.
3. Click the spline you want to split.
4. Click any point on the spline you want to split.
5. Specify a length. A split point is created at the end point of the spline segment

defined by this length.
If Trimming is switched on (see Using the Trimming Function on page 144), the
spline segment "beyond" this split point will be hidden.
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Example – Cam Profile
This example describes how to create a cam profile and then modify it.
Construct the following geometry (see Figure 61. Cam Profile - 1 on page 147):

• Horizontal and vertical lines at 0 0
• Circles at 35 40 45
• Lines at angles 30 60 120 150

Figure 61. Cam Profile - 1

To create the initial profile:

1. Click Interpolation Spline in Geometry.
2. Click Create in Interpolation Spline.
3. Switch on Closed.
4. Specify points A, B, ... J.
5. Click End.
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Figure 62. Cam Profile - 2

You now want to add an interpolation point at K:

1. Click Add in Modify Point.
2. Click the spline.
3. Click a point on the spline that is close to point K.
4. Click the intersection point at K.

Figure 63. Cam Profile - 3

To delete and interpolation point:

1. Click Delete in Modify Point.
2. Click the spline.
3. Click point C.
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The system deletes the point.
To change the position of an interpolation point:

1. Click Change in Modify Point.
2. Click the spline.
3. Click point F.
4. Move the point and click point F1.
To change the angle at point F1:

1. Click Change in Modify Tangent.
2. Click the spline.
3. Click point F1.

The system displays an arrow indicating the slope direction. You can now
either click a point to indicate the direction or enter a value. (This example
uses an angle of 10°.)

4. Enter 10

Figure 64. Cam Profile - Final Shape
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This chapter shows you how to use the commands and options that allow you to
reposition or alter your drawing.
You can modify single drawing elements (for example, lines and circles) or
enclose the elements you want to modify in a box.
For a description of the Picture command, see Importing a Picture File on page
424.
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Keeping or Removing the Original
Elements
For all modification commands/options (except Isometric) you can switch Keep on
or off in the Modify menu. This determines whether the original drawing elements
will be kept or deleted after the modification. For example, clicking Move with
Keep copies the drawing elements concerned rather than just moving them. By
default, Keep is switched off.

Repeating a Modification
You can use the Repeat function to repeat a modification a given number of times.
For example, by switching on Repeat and specifying a repeat factor of 5, you can
perform the same Move operation five times.

Modifying Using Selection
The Selection mechanism described in Commonly Used Commands on page 30
can also be used with all the Modify commands/options (except Isometric and
Stretch).
Using Select gives you various ways to select elements to be modified and to see
them highlighted on the screen before the modification is made.
To use Select with Modify:

1. Click the appropriate modification option (such as Move and Horizontal) in
Modify.

2. Select the elements to be modified using the options available in the Select
menu. For example, you can click Circle and All in the Select menu to perform
the same modification on all circles.

3. Click Confirm to perform the modification on the selected elements.
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Note
Each time you select elements for modification, you can decide whether you
want to select:

• From the current part only (this is the default)
or

• From the entire parts tree (by clicking Global in Select).

Refer to Handling Parts and Assemblies on page 323 for details on handling
parts and assemblies.

Changing the Number of Elements in the
Visual Feedback
You can change the number of elements displayed in the visual feedback during a
Modify operation. For example, you may want to unclutter the screen during a
Move of a complex assembly.

1. Click Setup ▶ Edit Environment ▶ System.
2. Enter the appropriate number of elements in the Max feedback field in the

Environment tab.

Moving Elements
Use the Handles or the Move command to move or copy elements to another
position.
To move an element with the handles,

1. Click an element in the drawing area. The handles appear.
2. Click the element again and drag it to the new position.
3. Click End.
To move multiple elements with handles,

1. Hold the Shift key and click all the elements in the drawing area. The handles
appear.

2. Release the Shift key and click one of the elements again.
3. Drag the elements to a new location.
4. Click End.
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Click Move to move or copy drawing elements to another position.
Click Move with Keep switched on to produce a copy. The original remains
unchanged.
With Keep switched on or off, switch on Repeat and enter a repeat factor. This
will repeat the next operation the specified number of times.

By Two Points
You can click any two points to define a move vector.
To move or copy a drawing element(s) using a reference point:

1. Click Move in Modify.
2. Click 2 Points in Move.
3. Select the element(s) to be moved.
4. To define the move vector, specify a reference point and then a destination

point.

Creo Elements/Direct Drafting moves the element(s) to the new position.

Horizontal Move/Copy
To move or copy a drawing element(s) to a new position in the horizontal
direction:

1. Click Move in Modify.
2. Click Horizontal in Move.
3. Select the element(s) to be moved.
4. Enter the required horizontal distance. Alternatively, specify a reference point

and then a destination point to define the horizontal distance.

If a repeat factor has been specified, the same horizontal distance will be taken
for each move or copy.

Note
You can interrupt the command with the Measure Length or Measure Distance
function if the distance you need can be measured from existing features on
the drawing. Alternatively, you can specify two points defining the horizontal
distance required.
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Vertical Move/Copy
To move or copy a drawing element(s) to a new position in the vertical direction:

1. Click Move in Modify.
2. Click Vertical in Move.
3. Select the element(s) to be moved.
4. Enter the required vertical distance. Alternatively, specify a reference point

and then a destination point to define the vertical distance.

If a repeat factor has been specified, the same vertical distance will be taken
for each move or copy.

Multiple Move/Copy
To interactively move or copy a drawing element(s) to any number of new
position required:

1. Click Move in Modify.
2. Switch on the Keep option in Modify.
3. Click Multiple in Move.
4. Select the element(s) to be moved.
5. Specify a reference point for the move.
6. Specify the destination point for the move.

The selected element(s) will move to the new position defined by these two
points.

7. Specify as many further destination points as required.
8. Terminate the move or copy by clicking another command, another option, or

End.

Rotating Drawings
Elements can be rotated:

• About a Center on page 154
• By Reference Point on page 155
Both of these methods can be used with Keep switched on or off in Modify.

About a Center
To rotate a drawing or drawing element about a center:
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1. Click Rotate in Modify.
2. Click Center in Rotate.
3. Specify the center of rotation.
4. Enter the angle of rotation. Alternatively, you can define the angle by

specifying two points. A positive angle results in a counterclockwise rotation.
5. Select the element(s) to be rotated.
The Center option is especially useful when combined with a Repeat factor for
repeated rotation. The flywheel shown in Figure 65. Flywheel on page 155 was
drawn by rotating the holes with a repeat factor of 5.

Figure 65. Flywheel

By Reference Point
To rotate a drawing or drawing element using a reference point:

1. Click Rotate in Modify.
2. Click 2 Points in Rotate.
3. Specify a rotation reference point on the drawing or element.
4. Specify the destination for the rotation reference point.
5. Enter the angle of rotation. Alternatively, you can define the angle by

specifying two points. A positive angle results in a counterclockwise rotation.
6. Select the element(s) to be rotated.

Mirroring
To save time when drawing symmetrical shapes you can mirror them about a line
of symmetry.
Mirror is usually used with Keep in Modify. The repeat factor is set to 1. Wait until
your drawing is nearly complete before mirroring, otherwise you may miss a
feature and have to draw it in both halves.
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About Two Points
To mirror a drawing about two points:

1. Click Mirror in Modify.
2. Click 2 Points in Mirror.
3. Specify two points to define the line of symmetry.
4. Select the elements to be mirrored.

The line of symmetry in Figure 66. Line of Symmetry on page 156 is the
dashed line.

Figure 66. Line of Symmetry

About a Horizontal Line
To mirror a drawing about a horizontal line:

1. Click Mirror in Modify.
2. Click Horizontal in Mirror.
3. Specify a point on the horizontal line of symmetry.
4. Select the elements to be mirrored.

About a Vertical Line
To mirror a drawing about a vertical line:

1. Click Mirror in Modify.
2. Click Vertical in Mirror.
3. Specify a point on the vertical line of symmetry.
4. Select the elements to be mirrored.

About a Center Point
To rotate a drawing through 180 degrees:
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1. Click Mirror in Modify.
2. Click Center in Mirror.
3. Specify the center point of rotation.
4. Select the elements to be mirrored.

The elements will be rotated 180 degrees in a clockwise direction.

Making Elements Larger or Smaller
Use Scale to make drawing elements and text larger or smaller. Note that
dimensions will be changed accordingly. If you want to keep the original drawing
elements, switch on Keep in Modify.

By Center
When drawing elements are scaled using the Center option, one point on the
drawing remains fixed.
To scale your drawing using Center:

1. Click Scale in Modify.
2. Click Center in Scale.
3. Specify the center for the scaling operation.
4. Enter a scale factor or specify two points to define the scale factor.
5. Select the elements to be scaled.

By Reference Point
To scale your drawing using a reference point:

1. Click Scale in Modify.
2. Click 2 Points in Scale.
3. Specify a reference point. Then specify the new position for this point.
4. Enter a scale factor or specify two points to define the scale factor.
5. Select the elements to be scaled. The selected elements will be moved and

scaled.

Drawing Similar Elements
The Similar option is a combination of the Move, Rotate and Scale options. It
allows you to fit specified drawing elements between two given points. This
involves rescaling.
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To fit a specified drawing element between two given points:

1. Click Similar in Modify.
2. Click 2 Points in Scale.
3. Specify two reference points on the drawing.
4. Specify two destination points for those reference points.
5. Select the elements of which you want to create a similar copy. These drawing

elements will then be scaled to fit the new position. Figure 67. Fitting Drawing
Elements Between Two Points on page 158 shows an example.

Figure 67. Fitting Drawing Elements Between Two Points

Creating a Parallel Perspective (Oblique)
View
Use Transform to create a parallel perspective view.
Parallel perspective means that three view points for the perspective view are
taken to be at infinity, and parallel lines will therefore remain parallel.

Example
Figure 68. Creating an Oblique View on page 159 shows an oblique view created
by copying the end elevation, then using Transform command to create the side
and top.
Points used for the first Transform operation are shown.
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Figure 68. Creating an Oblique View

Position the End View

1. Click Move in Modify.
2. Click 2 Points in Move.
3. Specify a reference point on the drawing (end view).
4. Specify a destination point.
5. Select the end view (marked by an upside-down L in Figure 68. Creating an

Oblique View on page 159).
Position the Side View

1. Click Transform in Modify.
2. Click three reference points on the drawing (1, 2, and 3).
3. Click three destination points (1', 2', and 3') to which the three reference points

will be mapped in the parallel perspective view.
4. Select the side view (marked by a circle in Figure 68. Creating an Oblique

View on page 159).
Position the Top View

1. Click Transform in Modify.
2. Click three reference points on the drawing.
3. Click three destination points to which the three reference points will be

mapped in the parallel perspective view.
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4. Select the top view (marked by a rectangle in Figure 68. Creating an Oblique
View on page 159).

Stretching a Drawing
Alter the shape of your drawing by stretching it in a certain direction. All the
dimensioning, hatching, and finishing information will be modified to fit the new
stretched shape.

Example
The following example shows how to use the Stretch command. Refer to Figure
69. Stretching a Drawing on page 160.

Figure 69. Stretching a Drawing

1. Switch off Keep in Modify.
2. Click Stretch in Modify.
3. Specify a reference point on the drawing.
4. Specify a destination point.
5. Select the elements to be stretched. You can select the elements by clicking a

single vertex or boxing several (the vertex is moved and the element is
stretched accordingly).

You can combine stretching with any of the other modify commands (except
Isometric).

In Any Direction
To stretch drawing elements in an arbitrary direction:

1. Click Stretch in Modify.
2. Click Free in Stretch.
3. Select the drawing elements to be stretched.
4. Specify a reference point and a destination point for the stretch operation.
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Horizontally
To stretch your drawing horizontally:

1. Click Stretch in Modify.
2. Click Horizontal in Stretch.
3. Select the drawing elements to be stretched.
4. Enter a horizontal distance. Alternatively, specify a reference point and a

destination point for the horizontal distance.

Vertically
To stretch your drawing vertically:

1. Click Stretch in Modify.
2. Click Vertical in Stretch.
3. Select the drawing elements to be stretched.
4. Enter a vertical distance. Alternatively, specify a reference point and a

destination point for the vertical distance.

Note
You can interrupt the command by clicking Length in Measure, if the distance
you need can be measured from existing features on the drawing.

Creating an Isometric View
To draw an approximate isometric view of a three-dimensional object, you must
have drawn the front, side, and top views already.
The following example shows how to create an isometric view. Refer to Figure 70.
Creating an Isometric View on page 162.
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Figure 70. Creating an Isometric View

1. Click Isometric in Modify.
2. Select the front view by enclosing it in a box.
3. Click a reference point on the front view.
4. Specify the destination for the front view reference point.
5. Select the side view by enclosing it in a box.
6. Click a reference point on the side view.
7. Specify the destination for the side view reference point.
8. Select the top view by enclosing it in a box.
9. Click a reference point on the top view.
10. Specify the destination for the top view reference point.

Trimming Elements
Overlapping elements can easily be trimmed or extended with the Trim/Expand
command. This is useful when you want to clean up a drawing. Note that
construction geometry can be used as reference elements (indicating where an
element is to be trimmed).

Trimming One Element
The Trim One Element option trims one overlapping element.
To trim one overlapping element:

1. Click Trim/Expand in Modify.
2. Click Trim One Element in Trim/Expand.
3. Click the first element (point 1).
4. Click the intersecting element (point 2).
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Figure 71. Trimming One Element

Trimming Two Elements
The Trim Two Elements option trims two overlapping elements.
To trim two overlapping elements:

1. Click Trim/Expand in Modify.
2. Click Trim Two Elements in Trim/Expand.
3. Click the first element (point 1).
4. Click the intersecting element (point 2).

Figure 72. Trimming Two Elements

Chain Trimming
Use the option Chain if you are trimming a series of elements. After you click the
second element, Creo Elements/Direct Drafting trims the line(s) and tells you to
click the next element:

1. Click Trim/Expand in Modify.
2. Click Chain in Trim/Expand.
3. Click point 1.
4. Click point 2.
5. Click points 3, 4, 5, 6.

Figure 73. Using the Chain Option
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Note
You cannot trim elements such as closed splines, circles, and closed polygons
because split points are not defined.

Cutting Out the Middle Section
The Cut Middle option cuts the middle section out of intersecting elements.
To cut out the middle of an element:

1. Click Trim/Expand in Modify.
2. Click Cut Middle in Trim/Expand.
3. Click element (point 1).
4. Click element (point 2).
5. Click element (point 3).
The option Chain takes the last intersecting elements as the new intersecting
elements.

Figure 74. Cutting Out the Middle Section

Creating a Contour
The Contour command creates a smooth contour by deleting overlapping
elements.
To create a contour from a number of overlapping lines:

1. Click Contour in Modify.
2. Enclose the elements in a box.
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Figure 75. Creating a Contour

Splitting Elements
It is often useful to split an element (line, circle, and so on) into two or more parts.
Following the split operation, the segments of lines that intersect can be treated as
separate elements and deleted individually.

Splitting Elements Automatically
Before you begin to draw, switch on Splitting in the Setup menu to automatically
split elements at their intersection points. This technique keeps contours clean,
which is important for automatic hatching.
When a new element is created, Creo Elements/Direct Drafting checks to see if
one of the end points of the new element lies on other elements. If so, it splits the
other element at that point if possible. When the new element crosses the old
element, the old element will not be split.
Figure 76. Splitting Elements on page 165 shows the principle of splitting
elements.

Figure 76. Splitting Elements
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Note
If you are deleting an element whose end point lies on other elements and
Splitting is active, Creo Elements/Direct Drafting will attempt to merge the
remaining elements automatically into one.

Splitting Single Element/Elements in a Box
To split a single element:

1. Click Split in Modify.
2. Click the element to be split. Creo Elements/Direct Drafting highlights the

chosen element.
3. Click the point where the element should be split.
Alternatively, to split several elements automatically at their intersection points:

1. Click Split in Modify.
2. Box the elements to be split (be sure to fully enclose the elements in the box).
To verify that all elements have been split, switch on Vertex in the Show menu. All
existing points will be highlighted.

Merging Elements
To merge elements that have been split:

1. Click Merge in Modify.
2. Click the elements to be merged.

The elements will then be returned to their original state. Intersection points
will no longer be marked when you switch on Vertex in the Show menu.

Cleaning a Drawing
Inconsistencies in a part (for example, lines not quite parallel, small gaps between
tangent objects, duplicate elements) are relatively common, but can cause
problems for applications (like Parametric Design) that scan the part to extract
information. To help eliminate drawing inconsistencies, Creo Elements/Direct
Drafting provides several tools that can do limited cleaning of parts. The Clean
commands are:

• Points
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• Duplicate

• Stacked

• Staggered

• Gaps

• Show Gaps

Points
Model points within a given distance of each other are merged, and the elements
attached to the merged points are adjusted (moved, stretched, or rotated) as
necessary to reflect the new positions of the points. For each set of points to be
merged, Points chooses a location within the given tolerance and moves the points
there. In general, there is no way to accurately predict or control which elements
will be adjusted as a result of the merge. This should not be a limitation in most
cases, however, because the tolerance used is likely to be small. Points is most
useful for removing small gaps between elements. To use Points:

1. Click Modify ▶ Clean ▶ Points.
2. Enter a distance tolerance (current length units).
3. Points within the given tolerance are marked with a *, and will be merged.

Elements that will be modified as a result of the merge are highlighted.
4. Click Confirm to merge the marked points and modify the highlighted

elements.

Duplicate
Duplicate scans the part for duplicate elements and deletes them. The command
selects which element of a duplicate pair to delete. Elements are considered to be
duplicates if their model points are identical. An exception is made for concentric
circles (only): if the radii of concentric circles are within a given tolerance, they
are treated as duplicates. Normally, Duplicate should be used after Points to clean
up duplicate elements that may result from merging model points. To use
Duplicate:

1. Click Modify ▶ Clean ▶ Duplicate.
2. Enter a distance tolerance (current length units) for the removal of duplicate

elements.
3. Elements that will be deleted are highlighted.
4. Click Confirm to remove duplicate elements.
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Stacked
Stacked finds stacked lines and arcs in the current part and calls Split to split them.
To use Stacked:

1. Click Modify ▶ Clean ▶ Stacked.
2. Elements to be split are highlighted and the points to be used for the splits are

marked with a *.
3. Click Confirm to split elements.

Staggered
Staggered finds staggered (partially overlapping) lines and arcs in the current part
and merges these to form a single "new" line or arc. The "old" lines or arcs are
removed by this operation. To use Staggered:

1. Click Modify ▶ Clean ▶ Staggered.
2. Enter a distance tolerance (current length units).
3. Elements that will be deleted are highlighted.
4. Click Confirm to delete superfluous elements following the merge.

Gaps
Gaps uses the Creo Elements/Direct Drafting Trim/Expand functionality to close
"trivial" gaps between two or more elements, even between circular and linear
elements.

• "Trivial" gaps are small gaps that can be closed automatically without any
major impact on the drawing. These can be closed automatically.

• "Non-trivial" gaps cannot be eliminated automatically because their
elimination may lead to unpredictable results. Therefore, "non-trivial" gaps
cannot be closed automatically. "Non-trivial" gaps are typically characterized
by distances and/or complexities greater than those found in "trivial" gaps.

To automatically close "trivial" gaps:

1. Click Modify ▶ Clean ▶ Gaps.
2. Draw a selection box around the elements between which there are gaps that

you want to close. Note that, if you use the Global selection mode, you may
unintentionally close "correct" gaps between elements.

3. Enter a distance tolerance (in current length units). Note that this distance
tolerance needs to be a "realistic" (small) value in order to prevent the
elimination of required spacing between elements. If the distance tolerance is
too big, a very large number of gaps may be shown. If all gaps are shown in
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the drawing, your drawing may be cluttered with color rectangles indicating
"non-trivial" gaps.

The number of "trivial" and "non-trivial" gaps found in your selection is
indicated in the prompt line. However, note that "non-trivial" gaps are not
indicated in the drawing.

4. Be sure to check the "trivial gaps" preview for plausibility.
5. Click Confirm to close any "trivial" gap(s).
Figure 77. Closing Trivial Gaps on page 169 shows an example of a set of
elements separated by "trivial" gaps. These gaps are highlighted in the drawing
and are then closed. Note that the gap sizes are exaggerated for visual clarity.

Figure 77. Closing Trivial Gaps

Show Gaps
Show Gaps can be used to box "non-trivial" gaps between two or more elements.
To mark "non-trivial" gaps:

1. Click Modify ▶ Clean ▶ Show Gaps.
2. Select a box color for "trivial" gaps.
3. Select a box color for "non-trivial" gaps.
4. Draw a selection box around the elements between which there are or may be

gaps.
5. Enter a distance tolerance (current length units). Note that this distance

tolerance needs to be a "realistic" (small) value in order to prevent the
elimination of required spacing between elements. If the distance tolerance is
too big, a very large number of gaps may be shown. If all gaps are shown in
the drawing, your drawing may be cluttered with color rectangles indicating
"non-trivial" gaps.

The number of "trivial" and "non-trivial" gaps found in your selection is
indicated in the prompt line.

6. Enter the number of "non-trivial" gaps.
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Optionally, by incrementing this number, you can display one "non-trivial"
gaps after the other for further examination. For example, you may want to
enter 1 to box only a single "non-trivial" gap. Then enter 2 to box the next one,
and so forth.

Optionally, enter the total number of "non-trivial" gaps to box all of these gaps
at the same time.

7. If the Show Gaps command also indicates "trivial" gaps, you can optionally
close these by clicking Confirm.

Figure 78. Showing Non-Trivial Gaps on page 170 shows an example of a
geometry that includes three "non-trivial" gaps.

Figure 78. Showing Non-Trivial Gaps

Tip
Tip: To clean up most common problems in a part, run the Clean commands in
the following sequence:

Points Merge disconnected points.
Gaps Close gaps between adjoining elements.
Duplicate Remove existing duplicates and those caused by

merging points.
Stacked Split overlapping elements.
Duplicate Remove duplicates caused by splitting.
Staggered Merge partially overlapping elements.

Further Information
For further technical information about modifying, refer to the Creo Elements/
Direct Drafting help system:
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Enter help modify at the Creo Elements/Direct Drafting command line.
The screen will clear and Creo Elements/Direct Drafting will display further
information about modifying your drawing.
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This chapter shows how to dimension your drawings.
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Dimensioning Fundamentals
To clarify how the dimensioning commands work, it is necessary to define the
terminology used when discussing dimensioning. Generally, a dimension consists
of two parts:

• Dimension Text.
• Dimension Geometry.

What is Dimension Text?
Dimension text describes the geometry feature that is marked by the dimension
geometry. Dimension text is divided into the following fields:

• Prefix
• Dimension Value
• Tolerance
• Postfix
• Subfix
• Superfix
Figure 79. Dimension Text Examples on page 173 shows several examples of
dimension text with the fields indicated.

Figure 79. Dimension Text Examples

The fields prefix, tolerance, postfix, subfix and superfix are optional.

What is a Prefix?
Use a prefix to include additional information before the dimension value.
Examples of prefixes are: DIA (diameter), TRUE R (true radius), and R (radius).
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What is a Dimension Value?
A dimension value is the numerical value assigned to the geometry feature you are
dimensioning. The value can be imperial, metric or angular depending on the
geometry feature and the standard units you use.

What is a Tolerance?
A tolerance is used to include information about the tolerance allowed in the
dimension value. Tolerance is the total amount by which a specific dimension is
permitted to vary. Types of tolerances are:

• Limit tolerances
• Plus and minus tolerances
• Upper and lower tolerances

Limit Tolerances
Limit tolerancing is used to give the maximum and the minimum dimension
values. The high limit (maximum value) is placed over the low limit (minimum
value).
Figure 80. Limit Tolerancing on page 174 shows an example of limit tolerancing.

Figure 80. Limit Tolerancing

Plus and Minus Tolerances
Plus and minus tolerancing is used to place the tolerance to the right of the
dimension value as a plus and minus expression of the tolerance.
Figure 81. Plus and Minus Tolerancing on page 174 shows an example of plus and
minus tolerancing.

Figure 81. Plus and Minus Tolerancing
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Upper and Lower Tolerances
Upper and lower tolerancing is used to place the tolerances to the right of the
specific dimension value. They appear as upper and lower values of the
permissible variation of the size of the feature.
Figure 82. Upper and Lower Tolerancing on page 175 shows an example of upper
and lower tolerancing.

Figure 82. Upper and Lower Tolerancing

What is a Postfix?
Use a postfix to include additional information after the dimension value.
Examples of postfix information are: 3 HOLES, EQUALLY SPACED, and CONC
(concentric).

What are Subfixes and Superfixes?
You can use subfixes (text below the dimension text) and superfixes (text above
the dimension text) to add information such as manufacturing-related
specifications to the actual dimension text.
Figure 83. Dimension Text plus Subfix plus Superfix on page 175 shows an
example of a dimensioned part complete with dimension text, subfix and superfix.

Figure 83. Dimension Text plus Subfix plus Superfix

What is a Dimension?
Dimension marks the geometry feature corresponding to the dimension text.
Dimension consists of:

• Dimension lines
• Extension lines

Dimensioning a Drawing 175



• A dimension text frame
Figure 84. Dimension on page 176 shows the three components of a dimension.

Figure 84. Dimension

Dimension Lines
Dimension lines show the direction and extent of a dimension. The dimension line
may be broken and the dimension text inserted (referred to as on the dimension
line), or the line may be a full unbroken line with the dimension text above or
below the dimension line. The dimension line will normally end with a terminator.
Figure 85. Dimension Line Terminators on page 176 shows dimension line
terminators.

Figure 85. Dimension Line Terminators

Extension Lines
Extension lines show the extension of a surface or point to a location outside the
part outline. In most technical drawings, you draw them perpendicular to the
dimension line with a visible gap from the geometry feature.

Dimension Text Frames
The dimension text frame surrounds all dimension text relating to the dimension
geometry. Normally, the frame is switched off. You can make the frame appear as
a box-shaped frame or a balloon-shaped frame or a flag-shaped frame by selecting
the appropriate option (see Figure 120. Dimension Text Frame – Options on page
231).
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Dimension Settings and Dimension Text Distances
As previously described, a dimension is made up of several parts:

• Dimension text
• Dimension lines
• Extension lines
You can set the distance between some of the parts making up a dimension.
Figure 86. Setting Dimension Distances on page 177 shows the most common
distances that you can set. Each distance is identified by a letter. Refer to Table 1
on page for an explanation of the letters.

Figure 86. Setting Dimension Distances

Table 1 on page gives the distance, the corresponding Creo Elements/Direct
Drafting function that sets the distance, and a typical value.

Table 1. Setting Dimension Distances

Distance Description
A The minimum distance between the dimension line and the

geometry feature. Define with the Minimum Space function (in
Lines under Dimension Settings). The default minimum
distance is 0 mm.

B The distance between the extension line and the geometry
feature. Define with the Offset Point function (in Lines under
Dimension Settings). The default distance is 0 mm.

C The distance between the dimension line and the top of the
extension line. Define with the Offset Line function (in Lines
under Dimension Settings). The default distance is 2 mm.
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Distance Description
D The vertical distance between the dimension line and the

dimension text. This only works if the location of the
dimension text is above or below the dimension line. Define
with the Offset Line function (in Text under Dimension
Settings). The default distance is 2 mm.

E The gap between the dimension line and the dimension text.
This only works if the location of the dimension text is on the
dimension line. Define with the Space function (in Line under
Dimension Settings). The default gap is 2 mm.

Dimensioning With Creo Elements/Direct
Drafting
The dimensioning module has the following features to make dimensioning your
drawing quick and easy:

• A full-featured user interface that includes:

○ An efficient screen menu system.
○ Combination of dimensioning commands and functions.
○ Integration with Creo Elements/Direct Drafting common and selection

commands.
• Powerful dimension assignment features:

○ A range of dimensioning assignment methods.
○ Multiple elements can be dimensioned at once.
○ Selection aids speed the assignment process.
○ Dimensioning between parts and on layers.

• Tools for dimension style setting and modification:

○ Standards-based dimensioning styles.
○ Style saving and re-assignment via the Style table.
○ Simultaneous modification of dimensioning geometry and text.

The dimensioning module is sometimes referred to as the Dimension Advisor
(DA).

Dimensioning Interface Features
Dimensioning commands and functions can be executed via a screen menu
interface as well as from the command line.
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Dimensioning Commands and Functions
The dimensioning interface provides both commands and functions. Commands
and functions can be combined to perform complex operations in a short amount
of time.

Dimensioning Commands
Generally, a command remains active until:

• You click End to end the command.
• You end the command by starting another command.
This means you can repeat the command without having to click the command
again.
For example:

1. Click Dimension.
2. Click Linear.
3. Click Single.
4. Click and dimension more than one geometry feature.
5. When you have finished using Single, click End to end the command.

Dimensioning Functions
Use functions to interrupt commands. Once you have completed the function,
Creo Elements/Direct Drafting will return to the active command. You can cancel
the function and leave the dimensioning command active by clicking Cancel.

Combining the Dimensioning Commands and Functions
A powerful feature of the Creo Elements/Direct Drafting dimensioning module is
the ability to combine dimensioning commands and functions to perform complex
operations efficiently.
The following procedure illustrates the importance of this feature.

Figure 87. Combining Dimensioning Commands and Functions
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To create the dimension shown in Figure 87. Combining Dimensioning
Commands and Functions on page 179:

1. Click Dimension.
2. Click Circular.
3. Click Diameter.
4. Click Centerline.
5. Click Settings in Dimension.
6. In Dimension Settings, click the Text Ext tab.
7. Select Prefix, then enter DIA into the Text Ext input field.
8. Enter an arbitrary name for the prefix (such as p1) into the entry field above

the (originally empty) prefix list and click Add.
9. Select Postfix, then enter GRIND into the Text Ext input field.
10. Click Upper/Lower in Tolerance, then:

a. Enter the upper tolerance value, +0.004.
b. Enter the lower tolerance value, -0.000.

Use the same procedure as above to add the tolerance values to your
dimension text extensions.

11. Click the circle.
12. Click the desired location for the dimension text.
Remember that Diameter and the tolerancing values remain active. This means
that you can continue to apply diameter dimensions to other circular geometry
features simply by clicking them.
Suppose that you do not want the GRIND postfix to appear in subsequent
dimensions. You can remove this postfix without ending the current command by
using the Clear function:

1. Click Clear.
2. Click another circular element (circle, arc, fillet).
3. Specify the desired location for the dimension text.
As you can see, combining dimensioning commands and functions reduces the
amount of time needed to dimension your drawing.
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Note
All the examples in this chapter assume that the current linear units are
millimeters and the angular units are degrees. Check the System Status Bar for
the entries mm and deg.

Using the Common and Selection Commands
You can use Creo Elements/Direct Drafting common and selection commands
with the dimensioning commands. For more information, refer to Commonly
Used Commands on page 30.

Dimension Assignment Features

Multiple Assignment Methods
The dimensioning module provides several methods for assigning dimensions to
drawing elements.

• With direct assignment, you manually select the type of dimension you wish to
assign (single, chain, datum, angle, etc.) and then identify one or more
drawing elements to receive the selected dimension. For example:

1. Click Linear in Dimension.
2. Click Single in Linear.
3. Click the dimension points. To dimension a single geometric feature, click

two dimension points to identify the feature. To dimension several drawing
elements at the same time, enclose them in a box.

4. Move the dimension trace around your drawing until the extension lines
and dimension text are at the desired location.

5. Specify the point where you want to place the dimension text and Creo
Elements/Direct Drafting draws the dimension(s).

Direct dimensioning gives you the greatest control over the dimensioning
process, but is likely to take the most time.

• Geometry-sensing assignment is provided by the commands DA_DIM_GEO_
SENSE and DA_DIM_PD_SCAN. DA_DIM_GEO_SENSE asks you to
identify a group of drawing elements and then generates a basic set of
dimensions for those elements based on their geometry type and position. DA_
DIM_PD_SCAN also generates dimensions for a selected set of elements, but
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it scans the parametric design constraints on the selected elements to
determine what type of dimensions to generate.

Geometry-sensing assignment is not intended to provide "automatic"
dimensioning, but it does provide a basic dimensioning framework that you
can modify to suit your requirements.

To quickly see how geometry-sensing assignment works, try the following:

1. Create a drawing with several different drawing elements.
2. Enter DA_DIM_GEO_SENSE ALL at the command line.

Creo Elements/Direct Drafting creates dimensioning for all elements in the
drawing.

3. To manually adjust the positions of the newly-created dimensions, you can
use the DA_MOVE_DIMENSION command.

• Database-matching assignment transfers dimensioning from a "dimensioning
database" of pre-dimensioned parts to similar drawing elements in your
drawing. Once you create this database, you can use the entries in it as
dimensioning templates to quickly generate complete dimensioning for similar
parts or features in you drawings.

Database-matching assignment can greatly improve dimensioning speed and
accuracy for commonly used drawing details.

Dimension Single or Multiple Elements
You can assign dimensions to one or several elements at a time. You assign single
dimensions by indicating the individual dimension points you wish to dimension.
To assign multiple dimensions, you select whole elements, either with Select or by
enclosing them in a box.

Selection Aids
Several selection aids are available to help you assign dimensions:

• When dimensioning single elements, you do not have to precisely identify the
end points of each element. You can click two points on the element that are
close to each end point and the cursor will catch to the end points
automatically.

• When selecting multiple elements for dimensioning, a filter can be applied to
the selection process to selectively exclude items from being considered.
Geometry can be filtered based on geometry type, line slope, linetype, pensize,
color, and/or linesize. You set up the filter using the Filter options in
Dimension. The current filter can be enabled or disabled via the On check box
in Filter under Dimension Settings.

182 Creo Elements/Direct Drafting User's Guide: Windows User Interface



• A dimension trace appears after you have identified the dimension points of
the geometry features you want to dimension. Creo Elements/Direct Drafting
then displays a movable dimension trace which shows:

○ The orientation and location of the dimension(s).
○ The location of the dimension line terminators.
○ The length of extension lines.
○ The dimension text represented by a box.

When multiple elements are selected, the dimensioning trace shows the
proposed dimensioning for all the selected elements, allowing you to place the
dimensioning text for all of them with a single click.

Dimensioning Between Parts
To dimension between parts, ensure that the parent part is active. You can then
dimension between the parent part and one of its subparts, or between pairs of
subparts.

Dimensioning Detail Parts
If you are dimensioning a detail part, you must make it the active part. Otherwise,
Creo Elements/Direct Drafting produces incorrect dimensions.
If you attempt to dimension a detail part that is not also the active part, Creo
Elements/Direct Drafting will display the following message in the System
Prompt Line:
Warning; Detail part is not active. Dimension value reflects the drawing scale.
To make a detail part active:

1. Click Parts.
2. Click Edit.
3. Click the detail part.

Dimensioning on Layers
Dimensioning on layers is the same as normal dimensioning.
For more information about layers, refer to Using Layers and Infos on page 393.

Style Features
Creo Elements/Direct Drafting provides several methods for setting and changing
dimensioning styles. In addition to specific commands that allow you to set and
change dimension text attributes (size, font, orientation, spacing, etc.) and line
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attributes (color, width, spacing, offsets, terminators, etc.), Creo Elements/Direct
Drafting also provides tools for emulating dimensioning standards and for storing
and recovering often-used styles.

Standards
Dimensioning standards allow you to quickly set the Creo Elements/Direct
Drafting dimension style features to emulate popular dimensioning standards,
such as ANSI, DIN, JIS, and ISO. A generic "company" standard may also be
defined. Standards are easily selected from the Standard menu at the bottom of the
Creo Elements/Direct Drafting window. Creo Elements/Direct Drafting displays
the current dimensioning standard in the Standard display field.

Style Table
The Dimension Style table allows you to store the current dimensioning style
attributes into a table entry. These attributes can later be recovered simply by
clicking the table entry. Once recovered, these settings become the current
dimensioning style and will be used for subsequent dimensions.

Modification Features
Dimension modification features allow you to change the layout of existing
dimensioning lines and text. Dimension modification commands are provided in
the Modify menu in Dimension.

Preparing to Dimension
Before you assign dimensions to your drawing, you may want to set up the basic
dimensioning style that will be used for your dimensions.
You can manually set dimensioning attributes via Dimension Settings. In addition,
you can set up dimensioning to emulate a particular standard.

Selecting a Dimensioning Standard
Creo Elements/Direct Drafting can emulate the dimensioning styles specified in
various drawing standards as well as allow you to define your own company or
site-wide standard. The standards available are:

• ANSI
• DIN
• ISO
• JIS
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• Company (Creo Elements/Direct Drafting default)
To select a dimensioning standard:

1. Click on the selection arrow of the Dimension Standard list box at the bottom
of the Creo Elements/Direct Drafting window to list the dimension standards
available for selection.

2. Select the dimensioning standard you want to use.

Note
To emulate a given dimensioning standard, Creo Elements/Direct Drafting
simply executes a macro that calls dimensioning style commands with the
appropriate options. If a given dimensioning standard has features that are not
supported by Creo Elements/Direct Drafting dimensioning commands, that
feature will not be supported.

The dimensioning standards are all defined in the macro file da_std.mac.
This macro file can be edited by hand in order to set the Company
dimensioning style, but the other standards defined in this file should generally
not be changed.

Please ensure automatic dimension placement by clicking Automatic check box in
Options under Dimension Settings or clear Automatic for manual placement.
You may also want to select or specify your own dimension settings before you
begin to dimension. For details see:

• Dimension Line Settings on page 218
• Dimension Text Settings on page 228
• Predefining Prefixes, Postfixes, Superfixes, Subfixes, and Tolerances on page

233
• Dimension Unit Settings on page 238
• Selection Filtering on page 242
• Dimension Options on page 247

Single Dimensioning
This section shows how to dimension single linear geometry features.
The following options are available to define the orientation of the single
dimension relative to a geometry feature:
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Parallel Parallel to a line drawn between two dimension points.
Horizontal In a horizontal plane.
Vertical In a vertical plane.
Perpend to Perpendicular to a reference line on your drawing.
Parallel to Parallel to a reference line on your drawing.

To dimension single linear geometry features:

1. Click Linear in Dimensions.
2. Click Single in Linear.
3. Click an orientation option; the default is Parallel.
4. Complete the selection sequence required by the option. All options enable

you to apply dimensioning to a single linear drawing element or to a group of
elements depending on your selection. You can:

• Click any two dimension points. The line between the two points is
dimensioned.

• Click a single linear drawing element. The starting point of the selected
element becomes the first dimension point. Select a second dimension
point on this or any other linear drawing element to complete the
dimension.

• Select multiple linear drawing elements with Select or by enclosing them
in a box. The end points of each selected element become dimension
points, and each element is dimensioned.

5. If you switched Automatic dimension placement off in Dimension Settings,
position the dimensions on your drawing manually. A dimension trace appears
when you select elements. Move the trace around your drawing until the
dimension text is in the desired location. Click the desired text location and
Creo Elements/Direct Drafting draws the dimension(s). When multiple
elements are selected, the trace shows the proposed dimensions for all of them
at the same time.

If you switched Automatic dimension placement on in Options under
Dimension Settings, Creo Elements/Direct Drafting positions the new
dimensions automatically. Automatic placement only applies when you have
selected multiple elements for dimensioning.

6. Click End to end this command.

Example
Figure 88. Single Dimensioning – Options on page 187 shows the result of using
each single dimensioning option.
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Figure 88. Single Dimensioning – Options

Parallel Dimensions
This is the default option. To dimension along an inclined plane:

1. Click Linear in Dimensions.
2. Click Single in Linear.
3. Click Parallel in Single.
4. Click the dimension points or elements to be dimensioned.
5. If you switched Automatic dimension placement off in Options under

Dimension Settings,, click the desired location for the dimension text(s), using
the dimension trace for guidance.

Horizontal Dimensions
To produce dimensions in the horizontal plane:

1. Click Linear in Dimensions.
2. Click Single in Linear.
3. Click Horizontal in Single.
4. Click the dimension points or elements to be dimensioned.
5. If you switched Automatic dimension placement off in Options under

Dimension Settings, specify the desired location for the dimension text(s),
using the dimension trace for guidance.
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Vertical Dimensions
To produce dimensions in the vertical plane:

1. Click Linear in Dimensions.
2. Click Single in Linear.
3. Click Vertical in Single.
4. Click the dimension points or elements to be dimensioned.
5. If you switched Automatic dimension placement off in Options under

Dimension Settings, click the desired location for the dimension text(s), using
the dimension trace for guidance.

Perpendicular Dimensions
To produce dimensions perpendicular to a reference line:

1. Click Linear in Dimensions.
2. Click Single in Linear.
3. Click Perpend to in Single.
4. Click a reference line. You can identify any line on the drawing as the

reference line.
5. Click the dimension points or elements to be dimensioned.
6. If you switched Automatic dimension placement off in Options under

Dimension Settings, click the desired location for the dimension text(s), using
the dimension trace for guidance.

Parallel to a Reference Line
To produce dimensions Parallel to a reference line:

1. Click Linear in Dimensions.
2. Click Single in Linear.
3. Click Parallel to in Single.
4. Click a reference line. You can identify any line on the drawing as the

reference line.
5. Click the dimension points or elements to be dimensioned.
6. If you switched Automatic dimension placement off in Options under

Dimension Settings, click the desired location for the dimension text(s), using
the dimension trace for guidance.
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Symmetry-Style Dimensions
The commands Symmetry Single and Symmetry Long let you specify symmetry-
style dimensions. Figure 89. Symmetry-Style Dimensioning on page 189 shows an
example of symmetric dimensioning. In drawing 2, the first dimension point is
assumed to be on a symmetry line. No extension line or line terminator is drawn
for that element, and the dimension text value is doubled to indicate that the
dimension represents both sides of the symmetry line. Drawing 1 shows the
unseen half of the geometry.

Figure 89. Symmetry-Style Dimensioning

To produce a (single) symmetric dimension:

1. Click Linear in Dimensions.
2. Click Symmetry Single in Linear.
3. Click the first dimension point.
4. Click the second dimension point.
To produce a (datum) symmetric dimension:

1. Click Linear in Dimensions.
2. Click Symmetry Long in Linear.
3. Click the first dimension point.
4. Click the second dimension point.
5. Continue clicking dimension points as required.

Centerline Dimensions
When dimensioning geometry contains centerlines, the dimension extension line
is attached to the model point (center point) of the centerline. This is true even if
the centerlines are not perpendicular to the measured direction of the dimensions.
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Figure 90. Dimensions and Centerlines

Modify a symmetry or center line
Use the handles of a symmetry or center line to modify the line.

Extend the symmetry/center line Click the handle and drag.
Rotate the center line Click the center line (not on the

handles) and drag.

Change the Handle Settings in Setup ▶ Edit Environment ▶ System ▶ Handles tab.

Chain Dimensioning
This section shows how to dimension groups of linear geometry features.
The following options are available to define the orientation of chain dimensions
relative to geometry features:
Parallel Parallel to a line drawn between two dimension points.
Horizontal In a horizontal plane.
Vertical In a vertical plane.
Perpend to Perpendicular to a reference line on your drawing.
Parallel to Parallel to a reference line on your drawing.

Creo Elements/Direct Drafting draws the chain dimensions parallel to the first
dimension and chained to the same axis. Locate your first chain dimension so that
subsequent chain dimensions do not overwrite the drawing or dimensions. You
can correct mistakes by repeatedly clicking Undo, which removes preceding
dimensions. You can then click the correct points.
To draw chained dimensions:

1. Click Linear in Dimensions.
2. Click Chain in Linear.
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3. Click an orientation option (the default is Parallel).
4. Complete the selection sequence required by the option.

All options allow you apply dimensioning to a single linear drawing element
or to a group of elements. Depending on your selection, you can:

• Click any two dimension points. The line between the two points is
dimensioned.

• Click a single linear drawing element. The starting point of the selected
element becomes the first dimension point. Click a second dimension point
on this or any other linear drawing element to complete the dimension.

• Select multiple linear drawing elements with Select or by enclosing them
in a box. The end points of each selected element become dimension
points, and each element is dimensioned.

5. If you switched Automatic dimension placement off in Options under
Dimension Settings, position the dimensions on your drawing. A dimension
trace appears when you select elements. Move the trace around your drawing
until the dimension text is in the desired location. Click the desired text
location and Creo Elements/Direct Drafting draws the dimension(s). When
multiple elements are selected, they become the first members of the chain and
the trace shows the proposed dimensions for all of them at the same time.

If you switched Automatic dimension placement on in Options under
Dimension Settings, Creo Elements/Direct Drafting automatically positions the
dimensions. Automatic dimension placement only applies when you have
selected multiple elements for dimensioning.

6. To continue chain dimensioning, click the next point in the dimension
sequence.

7. Click End to end this command.
Figure 91. Chain Dimensioning on page 192 shows examples of chain
dimensioning using each option.
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Figure 91. Chain Dimensioning

Parallel Dimensions
To chain dimensions along an inclined plane:

1. Click Linear in Dimensions.
2. Click Chain in Linear.
3. Click Parallel in Chain.
4. Click the first two dimension points. These define the angle for this and

subsequent chain dimensions.
5. If your initial selection contains multiple drawing elements, you are prompted

to identify one of them to provide the reference angle for the chain.
6. If you switched Automatic dimension placement off in Options under

Dimension Settings, in Dimension Settings, click the desired location for the
dimension text(s), using the dimension trace for guidance.

7. To continue the chain along the inclined plane, select additional linear
elements.

Horizontal Dimensions
To chain dimensions in the horizontal plane:

1. Click Linear in Dimensions.
2. Click Chain in Linear.
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3. Click Horizontal in Chain.
4. Click the dimension points or elements to be dimensioned. If your selection

contains multiple drawing elements, they become the first members in the
chain.

5. If you switched Automatic dimension placement off in Options under
Dimension Settings, in Dimension Settings, click the desired location for the
dimension text(s), using the dimension trace for guidance.

6. To continue the chain, select additional linear elements.

Vertical Dimensions
To chain dimensions in the vertical plane:

1. Click Linear in Dimensions.
2. Click Chain in Linear.
3. Click Vertical in Chain.
4. Click the dimension points or elements to be dimensioned. If your selection

contains multiple drawing elements, they become the first members in the
chain.

5. If you switched Automatic dimension placement off in Options under
Dimension Settings, click the desired location for the dimension text(s), using
the dimension trace for guidance.

6. To continue the chain, select additional linear elements.

Perpendicular Dimensions
To create a dimension chain perpendicular to a given line:

1. Click Linear in Dimensions.
2. Click Chain in Linear.
3. Click Perpend to in Chain.
4. Click a reference line. You can use any line on the drawing as the reference

line.
5. Click the dimension points or elements to be dimensioned. If your selection

contains multiple drawing elements, they become the first members in the
chain.

6. If Manual placement was selected, click the desired location for the dimension
text(s), using the dimension trace for guidance.

7. To continue the chain, select additional linear elements.
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Parallel to a Reference Line
To create a dimension chain parallel to a reference line:

1. Click Linear in Dimensions.
2. Click Chain in Linear.
3. Click Parallel to in Chain.
4. Identify a reference line. You can identify any line on the drawing as the

reference line.
5. Click the dimension points or elements to be dimensioned. If your selection

contains multiple drawing elements, they become the first members in the
chain.

6. If Manual placement was selected, click the desired location for the dimension
text(s), using the dimension trace for guidance.

7. To continue the chain, select additional linear elements.

Datum Dimensioning
Datum dimensioning is useful for marking holes and other features on a part. The
dimensions are parallel to each other (like chain dimensioning), and have a
common datum point. Normally, design engineers use this type of dimensioning
for parts that will be NC machined.
The three datum dimension commands are:

• Datum Long – creates dimensions using long base lines.
• Datum Short – creates dimensions using short base lines.
• Coordinate – creates dimensions without dimension lines. Useful if the

geometry of the part will cause the dimension lines to be too close together.

Creating Datum Dimensions
To create a datum dimension:

1. Click Linear in Dimensions.
2. In Linear, click the applicable datum dimension command (Datum Long or

Datum Short or Coordinate).
3. Click an orientation option (the default is Parallel).
4. Complete the selection sequence required by the option. All options allow you

apply dimensioning to a single drawing element or to a group of elements.
5. If you selected Manual placement, move the dimension trace around your

drawing until the dimension text is in the desired location.
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6. If multiple drawing elements are selected, the trace shows all proposed
dimensions at the same time. Click the desired text location and Creo
Elements/Direct Drafting draws the dimension(s).

If you switched Automatic dimension placement on in Options under
Dimension Settings, all the dimensions are positioned automatically and the
trace is not used. Automatic dimension placement only applies when you have
selected multiple elements for dimensioning.

7. To continue datum dimensioning, click the next dimension point.
8. Click End to end this command.
The orientation options are:
Parallel Parallel to a line drawn between two dimension points.
Horizontal In a horizontal plane.
Vertical In a vertical plane.
Perpend to Perpendicular to a reference line on your drawing.
Parallel to Parallel to a reference line on your drawing.

Datum Dimension Examples
Example
Figure 92. Rectangular Plate – Dimensioned with Datum Long on page 195 shows
a rectangular plate dimensioned using Datum Long and the Parallel to orientation
option.

Figure 92. Rectangular Plate – Dimensioned with Datum Long

Example
Figure 93. Rectangular Plate – Dimensioned with Datum Short on page 196 shows
a rectangular plate dimensioned using Datum Short with Parallel and Vertical
orientation options.
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Figure 93. Rectangular Plate – Dimensioned with Datum Short

Example
The following example shows how to use Coordinate to dimension a simple
rectangular plate with three holes. Assume that the common datum point is the
lower left hand corner of the plate.
Figure 94. Rectangular Plate – Dimensioned with Coordinate on page 196 shows
the rectangular plate:

Figure 94. Rectangular Plate – Dimensioned with Coordinate

To add the dimensions measured along the vertical (from datum point):

1. Make sure that the Vertex option is switched on in the Show menu.
2. Click Linear in Dimensions.
3. Click Coordinate in Linear.
4. Click Vertical in Coordinate.
5. Click the lower left hand corner of the plate.
6. Click the center of one of the circles.
7. Click the position for the dimension text.
8. Repeat step 6 for the other two circles.

To add the dimensions measured along the horizontal (from datum point):
9. Click Coordinate in Linear.
10. Click Horizontal in Coordinate.
11. Click the lower left hand corner of the plate.
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12. Click the center of one of the circles.
13. Click the position for the dimension text.
14. Repeat step 12 for the other two circles.

Note
The dimension text may be preceded by a leading zero. For details see
Coordinate Dimension Leading zero on page in this chapter.

Parallel Dimensions
To datum dimension along an inclined plane:

1. Click Linear in Dimensions.
2. In Linear, click the applicable datum dimension command (Datum Long or

Datum Short or Coordinate).
3. Click Parallel.
4. Click a single dimension point. This becomes the common datum point.
5. Click one or more additional dimensioning points.
6. If Manual placement was selected, click the desired location for the dimension

text(s), using the dimension trace for guidance.
7. To add more dimensions relative to the common datum point, select additional

drawing elements.

Horizontal Dimensions
You can dimension in the horizontal plane irrespective of the position of the
dimension points.
To dimension in the horizontal plane:

1. Click Linear in Dimensions.
2. In Linear, click the applicable datum dimension command (Datum Long or

Datum Short or Coordinate).
3. Click Horizontal.
4. Click a single dimension point. This becomes the common datum point.
5. Click one or more additional dimensioning points.
6. If you switched Automatic dimension placement off in Options under

Dimension Settings, click the desired location for the dimension text(s), using
the dimension trace for guidance.
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7. To add more dimensions relative to the common datum point, select additional
drawing elements.

Vertical Dimensions
To dimension in the vertical plane:

1. Click Linear in Dimensions.
2. In Linear, click the applicable datum dimension command (Datum Long or

Datum Short or Coordinate).
3. Click Vertical.
4. Click a single dimension point. This becomes the common datum point.
5. Select one or more additional dimensioning points.
6. If you switched Automatic dimension placement off in Options under

Dimension Settings, click the desired location for the dimension text(s), using
the dimension trace for guidance.

7. To add more dimensions relative to the common datum point, select additional
drawing elements.

Perpendicular Dimensions
To create a perpendicular datum dimension:

1. Click Linear in Dimensions.
2. In Linear, click the applicable datum dimension command (Datum Long or

Datum Short or Coordinate).
3. Click Perpend to.
4. Click a reference line. You can use any line on the drawing as the reference

line.
5. Click a single dimension point. This becomes the common datum point.
6. Select one or more additional dimensioning points.
7. If you switched Automatic dimension placement off in Options under

Dimension Settings, click the desired location for the dimension text(s), using
the dimension trace for guidance.

8. To add more dimensions relative to the common datum point, select additional
drawing elements.

Parallel to a Reference Line
To create a datum dimension parallel to a reference line:
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1. Click Linear in Dimensions.
2. In Linear, click the applicable datum dimension command (Datum Long or

Datum Short or Coordinate).
3. Click Parall to.
4. Click a reference line. You can use any line on the drawing as the reference

line.
5. Click a single dimension point. This becomes the common datum point.
6. Select one or more additional dimensioning points.
7. If you switched Automatic dimension placement off in Options under

Dimension Settings, click the desired location for the dimension text(s), using
the dimension trace for guidance.

8. To add more dimensions relative to the common datum point, select additional
drawing elements.

Radius, Diameter, Tangential and Arc
Dimensioning

Dimensioning Radii
This section shows how to dimension the radius of an arc, circle, BSpline or fillet
feature.

• Radius dimension text includes the prefix R (radius).
• You can locate the dimension text either inside or outside the feature.
• When the radius dimension is placed at a position where the dimension line

does not hit the dimensioned geometry then the system automatically creates
an arc extension for the dimension.

To dimension a radius:

1. Click Circular in Dimension.
2. Click Radius in Circular.
3. Click Centerline or No Centerline in Radius.

• Use Centerline to dimension the radius of a feature with the dimension line
drawn from the feature center.

• Use No Centerline to dimension the radius of a feature with the dimension
line drawn towards the center of the feature but not connecting with the
center.

Dimensioning a Drawing 199



Figure 95. Dimensioning Radii with and without a Centerline

4. Select one or more arc, circle, or fillet features.
5. If you switched Automatic dimension placement off in Options under

Dimension Settings, click the desired location for the dimension text(s), using
the dimension trace for guidance.

6. Click End to end this command.

Note
To dimension a BSpline, you must select a point on the BSpline. The radius
dimension value is valid at the selected point; the dimension value may be
different at different points.

Dimensioning using Tangents
Tangential dimensions are useful for dimensioning geometry where vertices are
not available. This section shows how to create tangential dimensions on the
following elements:

• Circle
• Arc
• Fillet
• Ellipse
• B-spline (closed, both interpolation and control)

Note
Tangential dimensions are not possible for open B-splines.

The following options are available to define the orientation of the tangential
dimensions relative to geometry features:
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Inclined In an inclined plane.
Horizontal In a horizontal plane.
Vertical In a vertical plane.
Perpend to Perpendicular to a reference line on your drawing.
Parallel to Parallel to a reference line on your drawing.
Parallel Parallel to an imaginary line which passes through the

selected extreme points on the geometry.

Creo Elements/Direct Drafting always chooses the extreme tangent points of a
closed B-spline for dimensioning, for the B-spline with more than two tangent
points at the given angle. If you select the points on a closed B-spline and a circle,
arc, line, fillet or an ellipse, Creo Elements/Direct Drafting automatically chooses
the tangent point of the B-spline which is closest to the selected point on that
bspline.
The following figure shows examples of tangential dimensioning on a closed B-
spline using each option.

Figure. Tangential Dimensioning

Inclined Dimensions
To create tangential dimensions in an inclined plane:

1. Click Circular in Dimension.
2. Click Tangential in Circular.
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3. Click Inclined in Tangential.
4. Select the two elements to be dimensioned. The dimension appears at the

cursor.
5. Type the inclination angle of the dimension in the User Input Line or

move the cursor to define the angle.
6. If you switched Automatic dimension placement off in Options under

Dimension Settings, select the desired location for the dimension text(s), using
the dimension trace for guidance.

7. Click End to end this command.

Note
You can specify any value of the inclination angle, Creo Elements/Direct
Drafting converts the angle between 360 and -360 degrees.

Horizontal Dimensions
To create tangential dimensions in the horizontal plane:

1. Click Circular in Dimension.
2. Click Tangential in Circular.
3. Click Horizontal in Tangential.
4. Select the two elements to be dimensioned. The dimension appears at the

cursor.
5. If you switched Automatic dimension placement off in Options under

Dimension Settings, select the desired location for the dimension text(s), using
the dimension trace for guidance.

6. Click End to end this command.

Vertical Dimensions
To create tangential dimensions in the vertical plane:

1. Click Circular in Dimension.
2. Click Tangential in Circular.
3. Click Vertical in Tangential.
4. Select the two elements to be dimensioned. The dimension appears at the

cursor.
5. If you switched Automatic dimension placement off in Options under

Dimension Settings, select the desired location for the dimension text(s), using
the dimension trace for guidance.
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6. Click End to end this command.

Perpendicular Dimensions
To create a tangential dimension perpendicular to a given line:

1. Click Circular in Dimension.
2. Click Tangential in Circular.
3. Click Perpend to in Circular.
4. Select a reference line in the viewport. You can select any line on the drawing

as the reference line.
5. Select the two elements to be dimensioned. The dimension appears at the

cursor.
6. If you switched Automatic dimension placement off in Options under

Dimension Settings, select the desired location for the dimension text(s), using
the dimension trace for guidance.

7. Click End to end this command.

Parallel to a Reference Line
To create a tangential dimension parallel to a reference line:

1. Click Circular in Dimension.
2. Click Tangential in Circular.
3. Click Parallel to in Tangential.
4. Select a reference line in the viewport. You can select any line on the drawing

as the reference line.
5. Select the two elements to be dimensioned. The dimension appears at the

cursor.
6. If you switched Automatic dimension placement off in Options under

Dimension Settings, select the desired location for the dimension text(s), using
the dimension trace for guidance.

7. Click End to end this command.

Parallel Dimensions
To create a tangential dimension that is parallel to a line through the tangent
points:

1. Click Circular in Dimension.
2. Click Tangential in Circular.
3. Click Parallel in Tangential.
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4. Select the two elements to be dimensioned. The dimension appears at the
cursor.

5. If you switched Automatic dimension placement off in Options under
Dimension Settings, select the desired location for the dimension text(s), using
the dimension trace for guidance.

6. Click End to end this command.

Dimensioning a Diameter
This section shows how to dimension the diameter of a:

• Circle
• Arc
• Fillet feature
You can locate the dimension text either inside or outside the diameter.
To dimension a circle, arc or fillet:

1. Click Circular in Dimension.
2. Click Diameter in Circular.
3. Click Centerline or No Centerline in Diameter.

• Use Centerline to dimension the diameter of a feature with the dimension
line drawn from the feature center.

• Use No Centerline to dimension the diameter of a feature with the
dimension line drawn towards the center of the feature but not connecting
with the center.

Figure 96. Dimensioning Circles with and without a Centerline

4. Select one or more circle, arc, or fillet features.
5. If you switched Automatic dimension placement off in Options under

Dimension Settings, click the desired location for the dimension text(s), using
the dimension trace for guidance.

6. Click End to end this command.
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Dimensioning Arcs
Creo Elements/Direct Drafting can measure the length or angle of the major or
minor arc. When dimensioning arcs singly, you determine which measurement is
used by selecting either the start or end point of the arc first. When dimensioning
multiple arcs at once, the length or angle of the major arc will be measured Creo
Elements/Direct Drafting measures arcs in a counterclockwise direction.
Dimensioning the length or angle between two arcs is also possible, but only for
arcs with the same radius and center.
You can locate the dimension either inside or outside the arc.
To dimension an arc:

1. Click Circular in Dimension.
2. Click Arc in Circular.
3. Select the arc features to be dimensioned. You can either:

• Identify the first and second end points on individual arcs. The order in
which you select the endpoints determines whether the major or minor arc
is dimensioned.

• Identify one or more arc elements with Select or by enclosing them in a
box. The major arc will be dimensioned for all selected arcs.

4. If you switched Automatic dimension placement off in Options under
Dimension Settings, click the desired location for the dimension text(s), using
the dimension trace for guidance.

5. Click End to end this command.
Figure 97. Dimensioning Arcs – Two Results on page 206 shows two possible
results of length and angle dimensions obtained using the Arc Dimension UI. Each
arc end point is marked in the order in which it has been identified.
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Figure 97. Dimensioning Arcs – Two Results

Angle and Chamfer Dimensioning

Dimensioning Angles
During your work you will need to dimension angles between lines. Creo
Elements/Direct Drafting measures an angle depending on the order in which you
identify the lines making up the angle. Therefore, there are two possible results for
each Angle option. Creo Elements/Direct Drafting measures angles in a
counterclockwise direction.
To dimension an angle:

1. Click Angular in Dimension.
2. Click the applicable Angular option.
3. Click the two lines that make up the angle.
4. If you switched Automatic dimension placement off in Options under

Dimension Settings, click the desired location for the dimension text(s), using
the dimension trace for guidance.

5. Click End to end this command.
The Angle options are:

• Direct

• Opposite

• Adjacent -

• Adjacent +

For each of the above options you can achieve two results.
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Figure 98. Identifying Angle Lines on page 207 shows how you identify the angle
lines in the opposite order to achieve a different result.

Figure 98. Identifying Angle Lines

Between Two Lines
Figure 99. Angle Between Two Lines – Two Results on page 207 shows the two
possible results.

Figure 99. Angle Between Two Lines – Two Results

To dimension the angle between two lines:

1. Click Angular in Dimension.
2. Click Direct in Angular.
3. Identify the two lines making up the angle (the angle dimensioned depends

upon which of the two lines you identify first).
4. If you switched Automatic dimension placement off in Options under

Dimension Settings, click the desired location for the dimension text(s), using
the dimension trace for guidance.

Between Intersections
Figure 100. Angle Between Intersections – Two Results on page 208 shows the
two possible results.
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Figure 100. Angle Between Intersections – Two Results

To dimension the angle between the projected intersection of two lines:

1. Click Angular in Dimension.
2. Click Opposite in Angular.
3. Click the two lines making up the angle (the angle dimensioned will depend

upon which of the two lines you identify first).
4. If you switched Automatic dimension placement off in Options under

Dimension Settings, click the desired location for the dimension text(s), using
the dimension trace for guidance.

Between First and Second Line
Figure 101. Angle Between First and Second Line – Two Results on page 208
shows the two possible results.

Figure 101. Angle Between First and Second Line – Two Results

To dimension the angle between the first line you clicked and the projection of the
second line:

1. Click Angular in Dimension.
2. Click Adjacent - in Angular.
3. Click the two lines making up the angle (the angle dimensioned depends upon

which of the two lines you identify first).
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4. If you switched Automatic dimension placement off in Options under
Dimension Settings, click the desired location for the dimension text(s), using
the dimension trace for guidance.

Between Second and First Line
Figure 102. Angle Between Second and First Line – Two Results on page 209
shows the two possible results.

Figure 102. Angle Between Second and First Line – Two Results

To dimension the angle between the second line you clicked and the projection of
the first line:

1. Click Angular in Dimension.
2. Click Adjacent + in Angular.
3. Click the two lines making up the angle (the angle dimensioned depends upon

which of the two lines you identify first).
4. If you switched Automatic dimension placement off in Options under

Dimension Settings, click the desired location for the dimension text(s), using
the dimension trace for guidance.

Dimensioning a Chamfer
Chamfered surfaces can be dimensioned using the Chamfer command in the
Dimension menu. (This feature is required in certain countries to meet recognized
design standards.)
By default the chamfer dimension is preceded by the character C. Only chamfered
surfaces created with the chamfer option Vertex or set at an angle of 45° can be
dimensioned.
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Figure 103. Dimensioning a Chamfer

To dimension a chamfer:

1. Click Linear in Dimension.
2. Click Chamfer in Linear.
3. Click the chamfer you want to dimension.
4. If you switched Automatic dimension placement off in Options under

Dimension Settings, click the desired location for the dimension text(s), using
the dimension trace for guidance.

5. Click End to end this command.

Note
• You can use DIM_CHAMFER_TEXT_CONTROL and DIM_CHAMFER_

PREFIX_STRING to change the default chamfer prefix string.
• If you stretch a chamfer or its reference geometry, the chamfer reference

geometry is updated. However, the chamfer dimensions are not updated. The
chamfer dimensions may not be visible after you stretch the chamfer.

Geometry-Sensing Assignment
The Geo Sense and Scan commands in the Dimension menu quickly generate
basic dimensioning for a selected set of drawing elements based on their geometry
types, positions, and parametric constraints, if any.
Geometry-sensing assignment is not intended to provide "automatic"
dimensioning. It is best used to provide a basic dimensioning framework that you
can then modify as needed to generate the final dimensioning.
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Dimensioning with Geo Sense
Geo Sense assigns dimensions to preselected types (see Geo Sense Settings on
page 249) of geometric elements. The type and location of the dimensions is
determined automatically by the system, based on the geometry type and the
location of the selected elements. The following dimension types can be
generated:
DIM_LINE for lines
DIM_RADIUS for arcs, fillets and circles (by default)
DIM_DIAMETER for arcs, fillets and circles (optional)
DIM_CHAMFER for 45-degree chamfers (optional)
DIM_ARC for arcs and fillets (optional)

To assign dimensions with Geo Sense:

1. Click Geo Sense in Dimension.
2. Click any needed option.
3. Select a group of drawing elements, either with Select or by boxing them.

Creo Elements/Direct Drafting generates and positions dimensions for the
selected elements.

4. Click End to end this command.

Dimensioning with Scan
Scan assigns dimensions to preselected types (see Scan Settings on page 250) of
geometric elements. The type and location of the dimensions are determined from
parametric constraints currently assigned to the selected elements. Generally, the
constraint information allows Creo Elements/Direct Drafting to generate more
accurate dimensioning than is possible with Geo Sense. If no constraints are
present in the selected geometry, however, dimensions will not be generated.
Scan generates the following dimension types for selected elements:
DIM_LINE for lines and splines
DIM_ANGLE for angle elements
DIM_RADIUS for arcs, fillets and circles (by default)
DIM_DIAMETER for arcs, fillets and circles (optional)

To assign dimensions with Scan:

1. Click Scan in Dimension.
2. Click any needed option.
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3. Select a group of drawing elements, which must have been previously given
parametric constraints, either with Select or by boxing them.

Creo Elements/Direct Drafting generates dimensions for the selected elements.
4. Click End to end this command.

Database-Matching Assignment
Database-matching commands allow you to create a database of common
drawings, parts, or features that have already been dimensioned to company
standards. You can then use the entries in this database as templates for assigning
dimensions to similar (but not necessarily identical) features and parts in the
future, ensuring consistent dimensioning.
All database-matching commands are found in the Match menu which you can
access via the Dimension menu.

Database Matching Example
1. Draw and dimension the flange shown in Figure 104. Initial Part for Database

Matching on page 212.

Figure 104. Initial Part for Database Matching

2. Add the flange to the dimension database:

a. Delete the construction lines from the drawing.
b. Click Match in Dimension.
c. Click Add in Match.
d. Enter the name 'Flange 001' when prompted.
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e. Select the entire drawing by boxing it.

Creo Elements/Direct Drafting adds your drawing to the dimension
database.

3. Delete all dimensions from your drawing, and using Modify, make two or three
copies of it. You can further modify each copy by scaling the whole part or
resizing the holes (Figure 105. New Parts Needing Dimensions on page 213).
Do not make modifications that alter the basic topology of the part.

Figure 105. New Parts Needing Dimensions

4. Return to Match and click the 'Flange 001' entry from the database table.

Creo Elements/Direct Drafting shows the 'Flange 001' entry in the style
display window.

5. Identify a reference element on the 'Flange 001' entry by clicking directly in
the style display window. For this example, start by clicking the line element
on the lower left edge of the flange.

6. Identify the corresponding target element on one of the flanges in your
drawing.

Creo Elements/Direct Drafting transfers the dimensioning from the database
entry to the target drawing (Figure 106. Assigning Dimensions from the
Database on page 214). You may need to repeat the previous two steps in
order to transfer the dimensioning for the flange holes.

Note that each time you transfer dimensions from the database to the target, a
portion of the database entry is highlighted. Once a database element is
highlighted, it cannot be used for further matching during this iteration of the
command. You can start a new iteration of the command by clicking the name
of the entry from the database table.
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7. Repeat the previous three steps as needed until all the flanges in your drawing
are dimensioned.

Figure 106. Assigning Dimensions from the Database

Adding Entries to the Dimension Database
1. Click Match in Dimension.
2. Click Add in Match.
3. Enter the name that will identify this entry ("flange 002", for example).
4. Select the geometry to be added to the database by boxing.
Creo Elements/Direct Drafting creates a new entry in the database and adds the
selected geometry under that entry.

Deleting Entries from the Dimension Database
1. Click Match in Dimension.
2. Click Delete in Match.
3. Enter the name of the entry to be deleted, either by clicking its entry in the

dimension database table or by typing it on the command line.
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Creo Elements/Direct Drafting deletes the selected entry from the dimension
database.

Assigning Dimensions from the Database
1. Click Match in Dimension.
2. Select a database entry by clicking its entry in the database table.

Creo Elements/Direct Drafting draws the database entry in the style display
window.

3. Click one end of a reference element on the database entry. Do this by clicking
in the style display window.

4. Click the corresponding end of a target element in your drawing.

Creo Elements/Direct Drafting dimensions your drawing to match the
database entry.

5. Click End to end this command.

Note
If you find that a template image in the style display window is too small or
not detailed enough for you to easily select a reference element, you can use
View commands in this window to make your job easier. To make the style
display window active so that these commands will work on it, click on the
mark at the top right corner of the window.

Working Methods and Limitations
When assigning dimensions from the database, you should follow the guidelines
below for the best results.

• Make sure that the geometry of the dimensioned part does not contain any
duplicate or stacked contours. Optionally, use the Parametric Design module to
remove such contours.

• Make sure that the dimensioned geometry does not contain any unwanted
gaps. Use Vertex in Show to check for green vertices (which indicate gaps).

• To identify an element, it is best to click it near its center. Then click a point
on the element (such as a vertex) away from its center.

• The topology of the database entry and your drawing must be the same. You
cannot, for example, use a circular template to assign dimensions to a
rectangle. The assignment tool can compensate for minor topological
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differences such as line splits, but major differences will lead to unsatisfactory
results.

The topological differences between a database entry and your drawing may
be subtle. If dimension assignments don't appear to be working correctly, you
can switch on Vertex in the Show menu in your drawing window to try to track
down the differences.

• The part structure (if any) of the database entry and your drawing should be
similar. Results can be unsatisfactory if you try to match a multi-part database
entry to a single-part drawing.

• The reference element on the database entry and the target element on your
drawing must be in the same relative location, or the resulting dimensioning
will be unpredictable.

• A reference element can only be matched once in a single iteration of the DA_
DB_MATCH command. Once you have matched one or more reference
elements to your drawing, they are highlighted in the style display to indicate
that they cannot be used for further matching.

Exporting a Database Entry
The Export option copies a selected entry from the dimensioning database into the
current drawing. The copied entry becomes a new part in the current drawing.
A common application for Export is to edit an entry in the dimensioning database.
To edit a database entry, export it into the current drawing, edit the exported
geometry, then Add it back into the database.

Saving and Loading Dimension Databases
You can use the Save and Open commands to save the current dimension database
to a file and later reload it into Creo Elements/Direct Drafting. Note that when you
load a database into Creo Elements/Direct Drafting, its entries are appended to the
current database.
To save the current database:

1. Click Match in Dimension.
2. Click Save in Match.
3. Enter a filename ("Flange_DB", for example).

Creo Elements/Direct Drafting will store the current database under the given
filename.

To load a dimension database from a file, appending to the current database:

1. Click Match in Dimension.
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2. Click Open in Match.
3. Enter a filename ("Flange2_DB", for example).

Creo Elements/Direct Drafting will load the entries from the named database
file at the end of the current database.

Unloading the Dimension Database From Memory
To unload the current dimension database from memory and clear the current
database table, use the Unload command:

1. Click Match in Dimension.
2. Click Unload in Match.

Creo Elements/Direct Drafting unloads the current database from memory.

Common Interrupt Functions
You can interrupt any direct assignment command to change the prefix, postfix,
and/or tolerance values for the dimension text. To find out how to predefine these
values, see Predefining Prefixes, Postfixes, Superfixes, Subfixes, and Tolerances
on page 233 in this chapter.

Adding a New Prefix
You can interrupt a dimensioning command to add a new prefix to the dimension
text. Examples of prefixes are:

• DIA (diameter)
• R (radius)
• CHAMFER
• BC (base circle)
After entering the prefix, complete the dimensioning command and Creo
Elements/Direct Drafting will draw the dimension including the prefix.
The new prefix will also be included in all subsequently assigned dimensions.
This avoids having to enter the same prefix every time you are dimensioning a
similar geometry feature.
To add a new prefix:

1. Click Text Ext in Dimension.
2. Click Prefix in Text Ext.
3. Define the prefix.
4. Complete the dimensioning command.
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Creo Elements/Direct Drafting draws the dimension including the prefix text.
To cancel the function and leave the dimensioning command active, click Clear.

Adding Special Characters
You can include special characters such as ° and Phi in your prefix:

1. Select and copy the special character from any character table or from an
existing text document in your Windows environment.

2. Move the cursor to the prefix entry field.
3. Press the right mouse button and select Paste from the pop-up menu to add the

special character to the prefix.
Also, you can add any special character defined in the hp_symbols and hp_
symbols2 fonts. See Special Characters in Dimension Text Extensions on page
237 for instructions.

Dimension Line Settings
The Line dialog box under Dimension Settings enables you to set attributes of
dimension lines:

• Line Settings
• Terminator (Arrow) Settings
These settings will be applied to all subsequent dimensioning that you assign via
the Dimension menu.

Line Settings
In the Line section of the Line dialog box under Dimension Settings, you can set
the following dimension line attributes:
Width Sets the width for all subsequent dimension lines.
Offset Line Sets the distance between the top end of the extension

line and the dimension line.
Space Sets the distance between the dimension text and the

dimension line.
Datum Step Sets the vertical distance (or step) that is automatically

placed between datum dimension lines drawn with the
dimension placement set to Automatic.

Color Sets the color for extension lines, dimension lines, and
text frames.

Offset Point Sets the offset distance between a geometry feature and
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the dimensioning extension lines.
Minimum Space Sets the minimum distance allowed between a geometry

feature and its dimension line.
Catch Line Sets whether or not a dimension may be selected by

clicking its dimension line, extension line, or text.
Broken Sets whether or not a line is drawn between the extension

lines of a dimension when the dimension text is placed
outside of the extension lines.

Catch Range Sets the size of the catch range used to automatically
center dimensioning text between extension lines.

Dimension Line Width
1. Click the Line tab in Dimension Settings.
2. Enter the required value (such as .25) into the Width field.
Dimension a drawing element to see the effect of the changed dimension line
width.

Figure 107. Dimension Line Width

Offset Line
Various national standards are used for dimensioning (American Standards,
British Standards, and so on). You can set the distance (or offset) between the top
end of the extension line and the dimension line to conform to the standards you
use. The Creo Elements/Direct Drafting default for this distance is 2 mm.
To set the dimension offset:

1. Click the Line tab in Dimension Settings.
2. Enter a positive value (such as `3) into the Offset Line field.

Creo Elements/Direct Drafting sets this distance for all subsequent
dimensions.

Dimensioning a Drawing 219



Figure 108. Dimension Offset Line Distance on page 220 shows the dimension
offset line distance.

Figure 108. Dimension Offset Line Distance

Space
The Space field enables you to specify a gap between the dimension text and its
associated dimension line.

Note
This gap is shown only if the dimension text location is set to On. See
Dimension Text Location on page 231.

To set this space:

1. Click the Line tab in Dimension Settings.
2. Enter a positive value (such as 2.3) into the Space field.
Figure 109. Distance between Dimension Lines and Text on page 220 shows the
distance between the inner ends of the dimension lines and the dimension text.
The Creo Elements/Direct Drafting default for this distance is 2 mm.

Figure 109. Distance between Dimension Lines and Text
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Datum Step
You may find that your datum dimensions are positioned too close together. This
section shows how to specify a vertical distance (or step) between each
subsequent datum dimension line.
The Creo Elements/Direct Drafting default for this distance is 8 mm. The distance
is active for the Datum Long and Datum Short commands.
To specify a datum step:

1. Click the Line tab in Dimension Settings.
2. Enter a new distance value into the Datum Step field.

Creo Elements/Direct Drafting sets the vertical distance to the new value.
3. Complete, or start the dimensioning command.

Creo Elements/Direct Drafting steps the dimension line for each dimension.

Example
Figure 110. Datum Stepping on page 221 shows the difference between:

• Datum dimensioning without using Datum Step (datum step distance is 0).
This produces a poor quality dimension where the dimension text has been
overwritten by the dimension lines.

• Datum dimensioning using Datum Step (datum step distance is 10).

Figure 110. Datum Stepping
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Dimension Line Color
To set the color of dimension lines and dimension extension lines:

1. Click the Line tab in Dimension Settings.
2. Select a color from the Color list. Refer to Defining Custom Colors on page 54

for instructions on defining custom colors.

Dimension Offset Point
Various national standards are used for dimensioning (American Standards,
British Standards, and so on). You can set the distance (or offset) between the
geometry feature and the dimension extension lines to conform to the standards
you use. The Creo Elements/Direct Drafting default for this distance is 0 mm.
To set the dimension offset point distance:

1. Click the Line tab in Dimension Settings.
2. Enter a positive value (such as 1.5) into the Offset Point field.
Figure 111. Dimension Offset Point on page 222 shows the dimension offset
point.

Figure 111. Dimension Offset Point

Minimum Space
This section shows how to avoid crowding dimensions by setting a minimum
distance (or space) between the geometry feature you are dimensioning and the
dimension line. If you try to locate the dimension trace closer than the minimum
distance, the trace will skip to the opposite side of the geometry feature. The Creo
Elements/Direct Drafting default for this distance is 0 mm.
To set the minimum space:

1. Click the Line tab in Dimension Settings.
2. Enter a positive value (such as 10) into the Minimum Space field.
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Refer to Figure 112. Locating a Dimension – Closer Than the Minimum Distance
on page 223. If you try to locate the dimension text closer than the minimum
distance (10 mm), the dimension skips to the opposite side of the geometry
feature.

Figure 112. Locating a Dimension – Closer Than the Minimum
Distance

Catch Line
When you want to select a dimension, you can specify which components of the
dimension can be selected. This is done by switching the Catch Line check box
option on or off in Line under Dimension Settings.
On A dimension may be selected by clicking one of the dimension

components:
• Dimension line
• Extension line
• Dimension text
This is the default.

Off A dimension may be selected by clicking the dimension text
only.

Broken/Unbroken Dimension Lines

Drawing Dimension Lines Inside Extension Lines
Because of space limitations when dimensioning, you may want to place
dimension text outside the extension lines, but still want the dimension lines to be
drawn inside the extension lines.
To draw an unbroken dimension line inside the extension lines, switch the Broken
check box option off in Line under Dimension Settings.
Figure 113. Dimension Lines Inside Extension Lines on page 224 shows
dimension lines drawn inside the extension lines and dimension text outside.
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Figure 113. Dimension Lines Inside Extension Lines

Drawing Dimension Lines Outside Extension Lines
Because of space limitations you might want to place dimension lines and text
outside the extension lines.
To draw an unbroken dimension line outside the extension lines, switch the
Broken check box option on in Line under Dimension Settings.
Figure 114. Dimension Lines and Text Outside Extension Lines on page 224
shows how dimension lines and text are drawn outside the extension lines.

Figure 114. Dimension Lines and Text Outside Extension Lines

Catch Range
This section shows how to center dimension text whenever you indicate a point
within the catch range. The catch range is governed by two catch lines parallel to
the extension lines. The origin is the bisection of the distance between the two
extension lines and the catch range is the horizontal distance from the origin to the
catch lines. If you indicate any point within the catch range, Creo Elements/Direct
Drafting will center the dimension text exactly between the two extension lines.
Figure 115. Dimension Catch Range on page 225 shows the catch range. Any
point you indicate within the catch range results in Creo Elements/Direct Drafting
centering the dimension text.
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Figure 115. Dimension Catch Range

Terminator Settings
In the Arrow section of the Line dialog box under Dimension Settings, you can set
the type, size, and fill attributes for all subsequent dimension line terminators.
Normally, the terminator is an arrowhead.
Figure 116. Dimension Line Terminators on page 225 shows the five possible
dimension line terminators:

Figure 116. Dimension Line Terminators

To set the dimension line terminator:

1. Click the Line tab in Dimension Settings.
2. Select the required terminator settings in the Arrow section.

Creo Elements/Direct Drafting uses these settings for all subsequent
dimensions.

You can set the first, the second or both terminators using the following options:

• Both

• First

• Second
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Both
Both is the default option. Click Both and then select the required settings. The
settings you select will apply to both dimension line terminators.

First
Click First to apply the chosen terminator settings to the first point you click when
identifying the dimension start-point.

Second
Click Second to apply the chosen terminator settings to the second point you click
when identifying the dimension end-point.

Figure 117. Dimension Terminators – First and Second

A Both (arrow type)
B First (dot type)
C Second (dot type)
D First (dot type – notice which is the first point)

Because you specify a first point and a second point, it makes no difference if the
dimensions are horizontal or vertical.

Terminator Position
By default, the position of terminators with respect to the extension lines is
determined automatically. If there is enough room between the dimension's
extension lines for the terminators and dimension text, the terminators are placed
between the extension lines. Otherwise, terminators are placed outside of the
extension lines. The terminator position can also be set manually.
To set the terminator position:

1. Click the Line tab in Dimension Settings.
2. Select Auto or Inside or Outside from the Position list.
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Note
You cannot change the direction of arrows in Broken on page 218 dimension
lines.

Absolute Terminator Size
The Creo Elements/Direct Drafting default terminator size is 3.5 mm. To set the
absolute size of the terminator:

1. Click the Line tab in Dimension Settings.
2. Enter a value for the terminator size into the Size field.

Relative Terminator Size
You can set the size of the dimension line terminator by entering a scale factor
relative to the main dimension text size.
The Creo Elements/Direct Drafting default scale factor is 1 and the default main
dimension text size is 3.5 mm.
To set the relative size of the dimension line terminator:

1. Click the Line tab in Dimension Settings.
2. Switch on the Relative check box option.

Terminator Fill On/Off
By default, dimension line terminators are filled. Simply click on the Fill check
box to switch the fill mode on or off in Line under Dimension Settings.

Example
Figure 118. Unfilled Dot Type Terminators on page 227 shows unfilled dot type
terminators.

Figure 118. Unfilled Dot Type Terminators
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Dimension Text Settings
The Text dialog box under Dimension Settings enables you to set the attributes of
all dimension text or of specific dimension text components. These settings will
be applied to all subsequent dimensioning that you assign via the Dimension
menu.
Set Enables you to select the dimension text components to

which the dimension text settings will apply.
Font Sets the font in which these dimension text components

will be displayed.
Color Sets the color for the selected dimension text

components.
Orientation Sets the orientation for the selected dimension text

components.
Frame Determines what kind of box (if any) is drawn around

subsequent dimensioning text.
Location Sets the location of the dimension text relative to the

dimension line.
Size Sets the size of dimension text.
Offset Line Sets the offset distance between dimension text and the

dimension line.
Slant Sets the dimension text slant.
Ratio Sets the character height-to-width ratio of dimension

text. Sets text appearance attributes such as size, font,
slant, and aspect ratio.

Brackets Encloses primary and secondary dimension text in
brackets.

Fill Fills characters of block fonts.

Dimension Text Components
Dimension text is comprised of several components:

• Prefix
• Dimension value
• Tolerance
• Postfix
To select the dimension text component(s) to which you want to apply the
dimension text settings:

1. Click the Text tab in Dimension Settings.
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2. Select a dimension text component from the Set list. You can choose any of
the following:

• All (prefix, value, tolerance and postfix)
• Lower

• Upper

By default, the dimension text settings apply to all dimension text components.
3. Select or specify the required dimension text settings.

Creo Elements/Direct Drafting uses these settings for all subsequent
dimensions.

Dimension Text Font
To select a dimension text font:

1. Click the Text tab in Dimension Settings.
2. Select a font from the Font list. The font names in this selection list include:

• Fonts supplied with Creo Elements/Direct Drafting
• Fonts already installed on your PC.

To load additional fonts for selection, follow the instructions in Importing a Font
on page 423.

Dimension Text Color
To set the color of dimension text:

1. Click the Text tab in Dimension Settings.
2. Select a color from the Color list. Refer to Defining Custom Colors on page 54

for instructions on defining custom colors.

Dimension Text Orientation
The orientation of the dimension text can be one of the following:
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Figure 119. Dimension Orientation

1 Parallel to the dimension line. This is the default.
2 Horizontal (2).
3 Vertical (3).
4 Perpendicular to the dimension line.

To set the orientation of dimension text:

1. Click the Text tab in Dimension Settings.
2. Select one of the following settings from the Orientation list:

• Parallel

• Horizontal

• Vertical

• Perpend

Dimension Text Frame
To set the dimension text frame:

1. Click the Text tab in Dimension Settings.
2. Select one of the following settings from the Frame list:

• None

• Box

• Balloon

• Flag

• Basic

The basic dimension text frame allows you to have a frame just around the
dimension main text; by that you can mark all basic dimensions in your drawing.
In addition to that Creo Elements/Direct Drafting enables you to include a user-
defined portion of the prefix and postfix text into the basic frame in addition to the
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normal prefix and postfix text outside the frame. You can add and edit both, the
basic and normal prefix and postfix text. You can also convert an existing
dimension text frame to a basic dimension text frame.
Figure 120. Dimension Text Frame – Options on page 231 shows the dimension
text frame options.

Figure 120. Dimension Text Frame – Options

Dimension Text Location
The location of dimension can be in one of three positions:

Figure 121. Dimension Location

1 On the dimension line.
2 Above the dimension line. This is the default.
3 Below the dimension line.

To set the location of dimension text:

1. Click the Text tab in Dimension Settings.
2. Select one of the following settings from the Location list:

• On

• Above

• Below

Absolute Dimension Text Size
The Creo Elements/Direct Drafting default dimension text size (character height)
is 3.5 mm. To set the absolute size of dimension text:

1. Click the Text tab in Dimension Settings.
2. Make sure that the Relative check box option is switched off.
3. Specify the absolute dimension text size.
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Relative Dimension Text Size
Creo Elements/Direct Drafting multiplies the relative factor by the current main
dimension text size. This gives a new text size for all selected dimension text.
To set a relative text size:

1. Click the Text tab in Dimension Settings.
2. Make sure that the Relative check box option is switched on.
3. Enter the relative dimension text size.

Dimension Text Offset

Note
This function only works if you have previously selected either Above or
Below from the Location list.

Figure 122. Dimension Text Offset on page 232 shows the distance (or offset)
between the dimension line and dimension text. The Creo Elements/Direct
Drafting default for this distance is 2 mm.

Figure 122. Dimension Text Offset

To set the dimension text offset:

1. Click the Text tab in Dimension Settings.
2. Enter a positive offset into the Offset Line field.

Dimension Text Slant
The Creo Elements/Direct Drafting default slant of dimension text characters is 0
degrees.
To set the dimension text slant:

1. Click the Text tab in Dimension Settings.
2. Enter a new slant angle into the Slant field.
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Dimension Text Ratio
The Creo Elements/Direct Drafting default for the width-to-height ratio of
dimension text characters is 1. A number smaller than one narrows dimension text
characters, a number greater than one widens dimension characters.
To change the dimension text character width-to-height ratio:

1. Click the Text tab in Dimension Settings.
2. Enter the new value into the Ratio field.

Dimension Text Brackets
Primary and secondary dimension text can be enclosed in brackets [ ] or not. By
default, brackets are not on.
To switch dimension text brackets on or off:

1. Click the Text tab in Dimension Settings.
2. Select either Upper or Lower in the Set list.
3. Click on the Brackets check box to toggle this option on or off.
Coordinate Dimension Leading Zero
The leading zero in coordinate dimensions can be shown or hidden. By default,
the leading zero is shown.
To show or hide the leading zero:

1. Click the Text tab in Dimension Settings.
2. Under Specific Texts, click or clear Coordinate Dimension - Leading Zero.

Predefining Prefixes, Postfixes,
Superfixes, Subfixes, and Tolerances
If you frequently add dimension text extensions (such as postfixes) to a
dimension, it is useful to first predefine these via Dimension Settings. Once
defined, they can easily be selected from a table. Apart from making the process
quicker, this method also improves consistency.
The Text Ext dialog box under Dimension Settings enables you to add, delete,
save, open and clear the following:

• Prefix

• Postfix

• Superfix

• Subfix

• Tolerance
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See What is Dimension Text? on page 173 for a definition of these terms.

Adding a Dimension Text Extension
Although the following example is for a prefix, the procedure is the same for a
postfix, a superfix, a subfix, and a tolerance.

1. Click the Text Ext tab in Dimension Settings.
2. Select Prefix from the Set list in the Extension section.
3. Enter a name for the prefix (such as p1) into the entry field above the

(originally empty) prefix list.
4. Enter the prefix text (such as the following example) into the Ext Text field.

Examples of prefixes are:

• DIA (diameter)
• R (radius)
• CHAMFER
• BC (base circle)

Optionally, you can select a special character to serve as the dimension text
extension:

5. Click Spec Char to display a graphics list of special text characters. Note that
these are based on the hp_symbols and hp_symbols2 fonts.

6. In Special Characters, select the special character you want to use as a
dimension text extension. A graphical representation of each character is
provided in the Meta Name column.

7. Click Insert to copy the selected special character to the dimension text
extension. Note that the meta name of this special character is added to the
Text field in Set Text Extension.

8. In the Ext Text box, type the basic dimension prefix text string in the Extension
Text section.

9. Click Add to add this prefix to your list of prefixes. Each time you click a
dimension, you can select the desired prefix from the list.

Which Dimension Text Extension(s) Will be Used in the
Drawing?
When the prefix list contains multiple prefix names, the prefix named in the name
entry field (above the prefix list) will be used in any dimension you add to your
drawing. This rule also applies to the other dimension text extension types
(postfix, superfix, subfix, and tolerance). The dimension text extension specified
in the name entry field is active and will be included in subsequent dimensions.
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To add a dimension plus prefix to a drawing:

1. Click Single in Dimension.
2. Click Prefix.
3. Click the prefix you want from the list.
4. Click the begin and end points of the dimension.

Deleting a Predefined Dimension Text Extension
Although the following example is for a prefix, the procedure is the same for a
postfix, a superfix, a subfix, and a tolerance.

1. Click the Text Ext tab in Dimension Settings.
2. Select Prefix from the Set list in the Extension section.
3. Select the name of the prefix to be deleted from the prefix list.
4. Click Delete to delete this prefix.

Saving Predefined Dimension Text Extensions
Although the following example is for a prefix, the procedure is the same for a
postfix, a superfix, a subfix, and a tolerance.

1. Click the Text Ext tab in Dimension Settings.
2. Select Prefix from the Set list in the Extension section.
3. Click Save to display the Save as dialog.
4. Specify a filename and select a file type.
5. Click OK to save the dimension text extension(s).

Opening Predefined Dimension Text Extensions
Although the following example is for a prefix, the procedure is the same for a
postfix, a superfix, a subfix, and a tolerance.

1. Click the Text Ext tab in Dimension Settings.
2. Select Prefix from the Set list in the Extension section.
3. Click Open to display the Open dialog.
4. Select or specify a filename under which you saved predefined dimension text

extensions.
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Clearing a Predefined Dimension Text Extension
Although the following example is for a prefix, the procedure is the same for a
postfix, a superfix, a subfix, and a tolerance.

1. Click the Text Ext tab in Dimension Settings.
2. Select Prefix from the Set list in the Extension section.
3. Click Clear to remove the prefix name (if any) from the name entry field

above the prefix list. Note that the Clear command merely deactivates the
prefix. It remains in the prefix list for further use unless you Delete it.

Dimension Text Extension Settings
The Extension Text section of the Text Ext dialog box under Dimension Settings
enables you to define the following attributes of prefixes, postfixes, superfixes,
subfixes and tolerances:

• Font
• Color
• Ratio
• Size
• Slant
• Special Characters
• Basic Dimension Text Extensions

Dimension Text Extension Font
To select a dimension text extension font:

1. Click the Text Ext tab in Dimension Settings.
2. Select a font from the Font list. The font names in this selection list include:

• Fonts supplied with Creo Elements/Direct Drafting
• Fonts already installed on your PC.

To load additional fonts for selection, follow the instructions in Importing a Font
on page 423.

Dimension Text Extension Color
To set the color of dimension text extensions:

1. Click the Text Ext tab in Dimension Settings.
2. Select a color from the Color list. Refer to Defining Custom Colors on page 54

for instructions on defining custom colors.
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Dimension Text Extension Ratio
The Creo Elements/Direct Drafting default for the width-to-height ratio of
dimension text characters is 1. A number smaller than one narrows dimension text
characters, a number greater than one widens dimension characters.
To change the dimension text character width-to-height ratio:

1. Click the Text Ext tab in Dimension Settings.
2. Enter the new value into the Ratio field.

Absolute Dimension Text Extension Size
The Creo Elements/Direct Drafting default dimension text extension size
(character height) is 3.5 mm. To set the absolute size of dimension text extensions:

1. Click the Text Ext tab in Dimension Settings.
2. Make sure that the Relative check box option is switched off.
3. Specify the absolute dimension text extension size.

Relative Dimension Text Extension Size
Creo Elements/Direct Drafting multiplies the relative factor by the current main
dimension text size. This gives a new text size for dimension text extensions.
To set a relative text extension size:

1. Click the Text Ext tab in Dimension Settings.
2. Make sure that the Relative check box option is switched on.
3. Enter the relative dimension text extension size.

Dimension Text Extension Slant
The Creo Elements/Direct Drafting default slant of dimension text extension
characters is 0 degrees.
To set the dimension text extension slant:

1. Click the Text Ext tab in Dimension Settings.
2. Enter a new slant angle into the Slant field.

Special Characters in Dimension Text Extensions
To add a special character to a dimension text extension:

1. Click the Text Ext tab in Dimension Settings.
2. Under Extension, select the type of extension to which you want to add a

special character.
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3. Click Spec Char to display a graphical list of special text characters.

These special characters are included in the hp_symbols and hp_
symbols2 fonts. You can create additional special characters by editing these
fonts. See Editing a Font on page 295 for further information.

4. In Special Characters, select the special character you want to add to the
dimension text extension. A graphical representation of each character is
provided in the Meta Name column.

5. Click Insert to copy the selected special character to the dimension text
extension.

Basic Dimension Text Extensions
To add a basic dimension text extension to a normal dimension text extension:

1. Click the Text Ext tab in Dimension Settings.
2. Under Extension Text, in the Basic Ext Text box, type the basic dimension

extension text.
3. Click Ok to save the basic dimension text extension.
All the dimensions created after setting the basic dimension text extension inherit
the text extension.

Note
To change the basic dimension text extension, in the Basic Dimensions
Extensions area, click the Change box adjacent to the Prefix or Postfix boxes.

Dimension Unit Settings
The Units dialog box under Dimension Settings enables you to set the units of all
dimension text or of specific dimension text components. These settings will be
applied to all subsequent dimensioning that you assign via the Dimension menu.
To select the dimension text component(s) to which you want to apply the unit
settings:

1. Click the Units tab in Dimension Settings.
2. Select a dimension text component from the Set list. You can choose any of

the following:

• Upper

• Lower
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Upper Dimension
This is the default option. Select Upper from the Set list in Units to set the units for
the main dimension text.

Lower Dimension
Select Lower from the Set list in Units to set the units for the lower dimension text
(if applicable).

Linear Units
First select the Upper or Lower dimension text component from the Set list in
Units, then select the linear units for that component from the options available:

• Micrometers

• Millimeters

• Centimeters

• Meters

• Kilometers

• Inches

• Fractional Inches

• Feet and Fractional Inches

• Feet and Fractional Inches with Sign

• Feet and Fractional Inches with Text

Micrometers
Select Micrometers (um) to set the dimension units to micrometers.

Millimeters
This is the default option. Select Millimeters to set the dimension units to
millimeters.

Centimeters
Select Centimeters to set the dimension units to centimeters.

Meters
Select Meters to set the dimension units to meters.
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Kilometers
Select Kilometers to set the dimension units to kilometers.

Inch
Select Inches to set the dimension units to inches.

Fractional Inches
Select Fractional Inches to set the dimension units to fractional inches. For
example, 12" and 6 1/2 ".

Feet and Fractional Inches
Select Feet and Fractional Inches to set the dimension units to feet and fractional
inches. For example, 1 - 0 and 0 - 6 1/2.

Feet and Fractional Inches with Sign
Select Feet and Fractional Inches with Sign to set the dimension units to feet and
fractional inches. Creo Elements/Direct Drafting displays the dimension value
with feet and inches signs. For example, 1' - 0" and 0' - 6 1/2".

Feet and Fractional Inches with Text
Select Feet and Fractional Inches with Text to set the dimension units to feet and
fractional inches. Creo Elements/Direct Drafting displays the dimension value
with feet and inches indicated by text. For example, 1 FT 0 IN and 0 FT 6 1/2 IN.

Angular Units
First select the Upper or Lower dimension text component from the Set list in
Units, then select the angular units for that component from the options available:

• Degrees

• Degrees Minutes Seconds

• Radians

• Gradian

Degrees
Select Degrees to set the angle dimension units to degrees.
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Degrees Minutes Seconds
Select Degrees Minutes Seconds to set the angle dimension units to degrees,
minutes, and seconds.

Radians
Select Radians to set the angle dimension units to radians.

Gradian
Select Gradian to set the angle dimension units to gradian.

Decimal Places
First select a dimension unit from the Unit list in Display, then enter an associated
number format into the Decimal Places field to specify the number of decimal
places for that unit.
For example, to specify that dimensions displayed in mm are shown with two
decimal places, enter:
0.01

The format string in the Decimal Places field defines:

• The type of decimal period: a comma (,) or point (.).
• The suppression of zeroes before the decimal period (left zero suppression).
• The suppression of zeroes after the decimal period (right zero suppression).
• The number of decimal places.
Creo Elements/Direct Drafting has a default format string which defines:

• The decimal period as a point (.).
• No left zero suppression. For example, 0.21 appears as 0.21.
• Right zero suppression. For example, 2.100 appears as 2.1.
• The dimension value to be displayed to two decimal places.
For example, 2.2354 appears as 2.24 and 12.299 appears as 12.3 (notice the right
zero suppression).
This format is general and may not suit certain types of dimensioning. For
example: large scale dimensions, precision dimensions, and so on. You can use the
Decimal Places field to specify your own format string.
Table 2 on page explains the format string using six examples of how Creo
Elements/Direct Drafting would display 10.000, 3.142, and 0.090.

Table 2. Format Strings
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Format
String

Represents

1, Dimension values with a decimal comma, left zeroes not suppressed,
right zeroes suppressed, and no decimal places quoted. Creo
Elements/Direct Drafting displays the values 10, 3, and 0.

0.1 Dimension values with a decimal point, left zeroes not suppressed,
right zeroes suppressed, and one decimal place quoted. Creo
Elements/Direct Drafting displays the values 10, 3.1, and 0.1.

1,1 Dimension values with a decimal comma, both left and right zeroes
suppressed, and one decimal place quoted. Creo Elements/Direct
Drafting displays the values 10, 3,1, and ,1.

1.000 Dimension values with a decimal point, with left zero suppression,
right zeroes not suppressed, three decimal places quoted. Creo
Elements/Direct Drafting displays the values 10.000, 3.142, and
.090.

0,001 Dimension values with a decimal comma, left zeroes not suppressed,
right zeroes suppressed, three decimal places quoted. Creo
Elements/Direct Drafting displays the values 10, 3,142, and 0,09.

+1,001 Dimension values with a decimal comma, with left and right zero
suppression, three decimal places quoted, plus included in value.
Creo Elements/Direct Drafting displays the values +10, +3,142, and
+,09.

Selection Filtering
When you assign dimensions to multiple drawing elements at one time, you can
also apply a selection filter. The selection filter prevents elements that meet
certain criteria from receiving dimensions. Selection filtering commands are
located under Filter in Dimension Settings.
Drawing elements can be filtered on the basis of any combination of the following
types of criteria:

• Geometry Type
• Line Slope
• Linetype
• Pensize
• Color
• Linesize
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Enabling and Disabling Selection Filtering
The selection filter can be turned on or off at any time via the Filter On check box
under Filter in Dimension Settings.

Setting up the Selection Filter
Before you can use the selection filter, you must specify the filter criteria. You can
combine options from any of the categories below to come up with a filter that
meets your needs.

1. Click the Filter tab in Dimension Settings.
2. Switch on Filter On in Filter.
3. Select a filter type:

• Geometry Type
• Line Slope
• Linetype
• Pensize
• Color
• Linesize

4. Select the desired options for this filter type.
5. If needed, select other filter type and options until the selection filter is

complete.

Geometry-Type Filter
This filter excludes elements based on their geometry type. For example, if the Arc
and Circle options are set, all circular elements will be excluded by this filter.
To set the geometry-type filter:

1. Click the Filter tab in Dimension Settings.
2. Switch on Filter On under Filter in Dimension Settings.
3. Select the Geometry Type filter.
4. Select one or more geometry types to add these to the filter. The Geometry

Type options are:

• Point

• Line

• Arc

• Fillet

• Circle

Dimensioning a Drawing 243



• Text

• Spline

• BSpline

You can click Reset to quickly remove all geometry types from the filter.

The Line Slope Filter
The line-slope filter is a list of angle ranges. Each entry in the table has a lower
bound and an upper bound, given in the current angular units. Linear elements
with orientations that fall within the angle range of any entry in the table are
excluded by this filter.
For example, if the orientation filter contains one entry with a lower bound of 30
degrees and an upper bound of 40 degrees, all lines with 33 degree elevations will
be filtered, but lines with 45 degree elevations will remain.

Adding To The Line-Slope Filter
1. Click the Filter tab in Dimension Settings.
2. Switch on Filter On under Filter in Dimension Settings.
3. Select the Line Slope filter.
4. Switch on Horizontal under Exclude.
5. Enter the lower bound (in current angular units).
6. Enter the upper bound (in current angular units).
7. Click Add to create a new entry in the filter table.
To quickly add an entry for horizontal or for vertical lines, you can switch on
Horizontal or Vertical under Include.

Saving from The Line-Slope Filter
1. Click the Filter tab in Dimension Settings.
2. Select the Line Slope filter under Filter in Dimension Settings.
3. Select the line slope filter row you want to delete from the list.
4. Click Delete.

Creo Elements/Direct Drafting deletes the entry from the filter table.

The Linetype Filter
This filter excludes elements based on their linetype. For example, if the Dashed
option is set, all elements with a dashed linetype will be excluded by this filter.
To set the linetype filter:
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1. Click the Filter tab in Dimension Settings.
2. Select the Line Slope filter under Filter in Dimension Settings.
3. Select one or more linetypes to add them to the filter. Types currently in the

filter are highlighted. Click Reset to quickly remove all linetypes from the
filter.

The Linetype options are:

• Solid

• Dashed

• Long Dashed

• Dot Center

• Dash Center

• Phantom

• Center Dash Dash

• Dotted

The Pensize and Linesize Filter
The pensize and linesize filters are tables of size ranges. Each entry in the table
has a lower bound and an upper bound, given in the current distance units.
Elements with sizes that fall within the range of any entry in the table are
excluded by this filter.
For example, if the pensize filter contains one entry with a lower bound of .5 mm
and an upper bound of 1.0 mm, and a second entry with bounds of 1.1 mm and 3.0
mm, all lines with sizes between .5 mm and 3.0 mm will be filtered except for
lines with sizes between 1.0 mm and 1.1 mm.

Adding to the Pensize or Linesize Filter
1. Click the Filter tab in Dimension Settings.
2. Select the Pensize or Linesize filter under Filter in Dimension Settings.
3. Enter the lower bound.
4. Enter the upper bound.
5. Click Add.

Creo Elements/Direct Drafting creates a new entry in the filter table.

Deleting from the Pensize or Linesize Filter
1. Click the Filter tab in Dimension Settings.
2. Select the Pensize or Linesize filter under Filter in Dimension Settings.
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3. Select the row you want to delete from the table.
4. Click Delete.

Creo Elements/Direct Drafting deletes the entry from the filter table.

The Color Filter
The color filter is a table of colors. Elements with colors that match any entry in
the table are excluded by this filter.

Adding to the Color Filter
1. Click the Filter tab in Dimension Settings.
2. Select the Color filter under Filter in Dimension Settings.
3. Select a color from the Add Color list. Refer to Defining Custom Colors on

page 54 for instructions on defining custom colors.
4. Click Add.

Creo Elements/Direct Drafting creates a new entry in the filter table.
5. Click End to finish the operation.

Deleting from the Color Filter
1. Click the Filter tab in Dimension Settings.
2. Select the Color filter under Filter in Dimension Settings.
3. Select the color you want to delete from the list.
4. Click Delete.

Creo Elements/Direct Drafting deletes the entry from the filter list.

Clearing the Selection Filter
To clear all filter criteria from the selection filter:

1. Click the Filter tab under Dimension Settings.
2. Click Reset.

Saving and Loading Selection Filters
You can use the Save and Load commands to save selection filters to files and
later reload them into Creo Elements/Direct Drafting.
To save the current selection filter:

1. Click the Filter tab in Dimension Settings.
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2. Click Save.
3. Enter a filename ("Select_filter.1", for example).

Creo Elements/Direct Drafting will store the selection filter under the given
filename.

To load a new selection filter from a file (overwriting any current filter):

1. Click the Filter tab in Dimension Settings.
2. Click Load.
3. Select a filename ("Select_filter.1", for example) from the list.

Creo Elements/Direct Drafting will load the named selection filter, replacing
any current filter.

Dimension Options
The Options dialog box in Dimension Settings enables you to set dimension
location options as well as well as automatic dimensioning settings. These settings
will be applied to all subsequent dimensioning that you assign via the Dimension
menu.

Dimension Location Settings
In the Dimension Location section of the Options dialog box, you can set the
following:

• Automatic Dimension Positioning
• Auto-Placement Position
• Dimension Strategy

Automatic Dimension Positioning
You can switch on the Automatic check box option to automatically place
dimensions rather than use the dimension trace (Automatic switched off).

Dimension Position Settings
By default, Creo Elements/Direct Drafting attempts to auto-place dimensions
above or to the right of their associated (linear) drawing elements. Using the
Position list in Options under Dimension Settings, you can ask Creo Elements/
Direct Drafting to place dimensions either above and to the right or below and to
the left (see Figure 123. Automatic Dimension Positioning — Above (a.) and
Below (b.) on page 248).
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Figure 123. Automatic Dimension Positioning — Above (a.) and Below
(b.)

To set the auto-placement position:

1. Click the Options tab in Dimension Settings.
2. Tick the Automatic check box under Dimension Location.
3. Select Above or Below from the Position list.

Dimensioning Strategy - Interference Check
By default, Creo Elements/Direct Drafting attempts to auto-place new dimensions
so that the new dimension text does not intersect existing geometry or
dimensioning. This process is called interference check. Full interference
checking can slow down a busy system, so you are given the option of reducing or
disabling this check. Doing this may improve system performance, but will also
increase the likelihood that auto-placed dimensions will need to be re-located
later. Note that even full interference checking cannot always prevent overlaps
from occurring.
To change the level of interference checking:

1. Click Options in Dimension Settings.
2. Tick the Automatic check box under Dimension Location.
3. Select Off, Geo, or Geo+Dim from the Strategy list box.

• Off disables all interference checking.
• Geo checks for interference with geometry elements only.
• Geo + Dim checks for interference with geometry elements and with

existing dimensioning.
There are two check boxes at the bottom of the Options dialog box in Dimension
Settings:

• Delete Dimension Check

Sets the check option for the Dimension - Delete command.
• Insert Dimension Check

Sets the check option for the Dimension - Modify - Insert command.
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Automatic Dimensioning Settings
In the Automatic Dimensioning Settings section of the Options dialog box, you can
set the following:

• Settings for Automatic Dimensioning using Geo Sense
• Settings for Automatic Dimension using Scan

Geo Sense Settings
To preselect the geometry items to be included in automatic dimensioning with
Geo Sense:

1. Click Options in Dimension Settings.
2. Select Geo Sense from the Type list under Automatic Dimensioning Settings.
3. Select the geometric element types for Geo Sense:

Radius Radius dimensions are generated for all circular
elements in the selection set.

Diameter Diameter dimensions are generated for all circular
elements in the selection set.

Chamfer Chamfer dimensions are generated for any valid
chamfers in the selection set.

Arc Arc dimensions are generated for any arc elements,
including fillets, found in the selection set.

Figure 124. Geo Sense Options on page 250 illustrates the effects of these options
on the resulting dimensions.
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Figure 124. Geo Sense Options

1 Defaults
2 Diameter and Chamfer On
3 Diameter, Chamfer, and Arc On

Scan Settings
To preselect the geometry items to be included in automatic dimensioning with
Scan:

1. Click Options in Dimension Settings.
2. Select Scan from the Type list under Automatic Dimension Settings.
3. Select the geometric element types for Scan:

Radius Radius dimensions are generated for all circular elements
in the selection set.

Diameter Diameter dimensions are generated for all circular
elements in the selection set.
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Setting Dimension Attributes in the
Dimension Style Table
The Dimension Style table enables you to store your current dimensioning style
settings (font, size, units, line styles, etc.) as table entries. You can later recover
the stored style settings and make them the current dimensioning style simply by
selecting the table entry. The currently active settings are always previewed in the
style display window, so you always know what you will be assigning.
If you often dimension particular features or details in a given style, the
Dimension Style table frees you from having to manually set up that style each
time you need it.
By default, the Style radio button is depressed to indicate that you are using your
own dimensioning styles. Optionally, you can press the Standard radio button to
select one of the preconfigured industrial standards (DIN, ANSI, JIS, ISO) for
dimensioning.

Adding a Style Table Entry
Before you can take advantage of the Dimension Style table, you need to add one
or more entries to hold the style settings you want to apply later. To create an
entry in this table:

1. Set up the dimensioning style that you want to save to the table. You can use
the Dimension Settings to do this. The style display window shows the current
settings.

2. Click Style in Dimension.
3. Enter a name for the new table entry in the name entry field above the

(originally empty) style table.
4. Click Add in Dimension Style.

Creo Elements/Direct Drafting adds the new entry to the Dimension Style
table.

Setting the Current Dimension Style with the
Dimension Style Table
1. Click Style in Dimension.
2. Click an entry in the Dimension Style table to move this entry to the name

entry field above the (originally empty) style list.

The dimensioning style settings associated with this entry become the current
settings. These settings will be used for subsequent dimensioning.
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Assigning Dimension Styles
You can assign a new dimensioning style to an existing dimension via the Style
menu.

1. Set up the desired dimensioning style, using either Dimension Settings or the
Dimension Style table.

2. Click Style in Dimension.

The style display window should reflect the settings you want to apply.
3. Click Apply in Style.
4. Select dimensions in your drawing to receive the new settings.

Creo Elements/Direct Drafting updates the style of the selected dimensions to
match the current style.

Setting the Current Dimension Style from An
Existing Dimension
The Grab command queries the style settings of a selected dimension and then
makes them the current settings. You can use these settings for new dimensions or
store them as an entry in the Style table.

1. Click Style in Dimension.
2. Click Grab in Style.
3. Select the text of a dimension in your drawing.

Creo Elements/Direct Drafting makes the style settings of the selected
dimension the current settings.

4. Click End.

Editing a Dimension Style Table Entry
Each entry in the Dimension Style table is a macro that contains the dimension
style commands needed to define the entry's style. The entry can be modified by
editing this macro.

1. Click Style in Dimension.
2. Select the table entry you wish to change.
3. Click Edit in Dimension Style. Creo Elements/Direct Drafting displays the

entry's macro in a screen editor window.
4. Edit the text, then save and exit the file.
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Deleting an Entry
1. Click Style in Dimension.
2. Click the table entry you wish to delete.
3. Click Delete in Dimension Style.

Saving the Dimension Style Table to a File
The Dimension Style table can be stored in a file for later use.

1. Click Style in Dimension.
2. Click Store in Dimension Style.
3. In the Store dialog, Specify a filename and select a file type.
4. Click OK to save the dimension text extension(s).

Creo Elements/Direct Drafting stores the table macros in the given file.

Loading Table Entries from a File
New table entries can be appended to the Dimension Style table by loading them
from a file.

1. Click Style in Dimension.
2. Click Open in Dimension Style to display the Open dialog.
3. Select or specify a filename under which you saved predefined dimension text

extensions.

Creo Elements/Direct Drafting loads the table macros from the given file into
the STYLE table. These entries are appended to the end of the table.

Changing Dimension Settings
To change the settings of existing dimensions:

1. Click Change... in Dimension.
2. Select the dimension(s) to be changed. Either click on a single dimension or

box multiple dimensions or use Select.
3. In Change Dimension, click the tab of the dimension items you want to

change:

• Line
• Text
• Units
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Note that the settings in Dimension Settings apply to all dimensions to be
added to the drawing, while the settings in Change Dimension apply to
existing dimensions you selected.

Changing Dimension Line Attributes
The Change Dimension dialog box enables you to change the attributes of
dimension lines:

• Line Settings
• Terminator (Arrow) Settings

Changing Dimension Line Settings
In the Line section of the Line dialog box under Change Dimension, you can
change the following dimension line attributes:
Width Changes the width of dimension lines.
Offset Line Changes the distance between the top end of the

extension line and the dimension line.
Color Changes the color of extension lines, dimension lines,

and text frames.
Offset Point Changes the offset distance between a geometry feature

and the dimensioning extension lines.

See Dimension Line Settings on page 218 for an explanation of these dimension
line attributes.

Changing Dimension Line Terminator Settings
In the Arrow section of the Line dialog box under Change Dimension, you can
change the type, size, and fill attributes of dimension line terminators. See
Terminator Settings on page 225 for an explanation of these terminator attributes.

Changing Dimension Text Settings
In the Text dialog box under Change Dimension, you can change the attributes of
dimension text.

1. Begin by selecting the dimension text component(s) whose attributes you want
to change:

• If you click the All check box under Set, the attribute changes apply to all
dimension text components.

• Alternatively, you can pull down the Set list to select any of the following:
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○ Upper

○ Lower

○ Prefix

○ Postfix

○ Superfix

○ Subfix

Then select Value or Tolerance from the Subset list or tick the All Subsets
check box to select both Value and Tolerance (if applicable).

2. Change the attributes for the selected dimension text components. See
Dimension Text Settings on page 228 for an explanation of these attributes.

Changing Dimension Unit Settings
In the Units dialog box under Change Dimension, you can change the settings of
dimension units. See Dimension Unit Settings on page 238 for an explanation of
dimension unit settings.

Example
The example below shows how to change dimension units from millimeters to
fractional inches.
Figure 125. Changing Millimeters to Fractional Inches on page 255 shows the
dimension before and after the change:

Figure 125. Changing Millimeters to Fractional Inches

Modifying Dimensions
The following sections describe how to modify the layout of existing dimensions.

Modifying Dimension Lines
If dimension and extension lines are crowded or overlapped, you can:

• Break an extension or dimension line.
• Slant an extension line.
• Stagger an extension line.
• Reset an extension or dimension line.
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Any breaks and staggers you make to a dimension line are retained until either:

• The dimension line is reset with the Reset command.
• The location of the dimension is moved to within the range of the break or

stagger.
Use the handles of a dimension to quickly modify it:

Move the dimension and text Click anywhere on the dimension and drag.
Move the dimension text Hold the Shift key and drag the text.
Reattach the dimension Click the square-shaped handle where the

dimension is attached to the element and drag.
Change the direction of the
arrows

Click the diamond-shaped handle.

Modify the stagger line Click the square-shaped handle and drag.

Change the Handle settings in Setup ▶ Edit Environment ▶ System ▶ Handles tab.
To modify a dimension line:

1. Click Modify in Dimension.
2. Click Line in Modify.
3. Click one of the following options in Line:

• Break

• Stagger

• Change Vertex

• Reset

Breaking Dimension Lines
To break a dimension extension line around obstructing features:

1. Click Modify in Dimension.
2. Click Line in Modify.
3. Click Break in Modify. Refer to Figure 126. Broken Extension Line on page

257.
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Figure 126. Broken Extension Line

4. Click the dimension text for the dimension (1).
5. Specify the start point for the break (2).
6. Specify the end point for the break (3).

Note
The break will be lost after any modification of the geometry to which the
dimension is attached.

Slanting Dimension Extension Lines
To slant dimension extension lines:

1. Click Modify in Dimension.
2. Click Line in Modify.
3. Click Slant in Modify. Refer to the following figure.

Slanted Extension Lines

4. Type the slant angle in the User Input Line.
5. Select the dimension to slant.
The dimension extension lines are slanted by the specified angle.
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Note
Slant angles must be between 0 and 60 degrees, or 0 and -60 degrees. You can
only slant the extension lines of single dimensions with a parallel dimension
orientation. Broken or staggered dimensions can be slanted and slanted
dimensions can be broken or staggered. A slanted dimension cannot be further
slanted.

Staggering Dimension Extension Lines
To stagger dimension extension lines:

1. Click Modify in Dimension.
2. Click Line in Modify.
3. Click Stagger in Modify. Refer to Figure 127. Staggered Extension Lines on

page 258.

Figure 127. Staggered Extension Lines

4. Click the dimension text for the dimension.
5. Specify the start point for the stagger on the extension line (1).
6. Specify the end point for the stagger on the extension line (2).
7. Specify the point where you want the stagger to go (3).

Figure 128. Effect of Moving Staggered Extension Lines
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Note
If a dimension contains several staggers, only the first is retained following a
move. The staggers will be lost after any modification of the geometry to
which the dimension is attached.

Figure 129. Multiple Staggered Extension Lines

Modifying a Dimension Vertex
The dimension vertex can be relocated to a new position without the need to click
the first point again.

Figure 130. Relocating a Dimension Vertex

To modify a dimension vertex:

1. Click Modify in Dimension.
2. Click Line in Modify.
3. Click Change Vertex in Modify.
4. Click Keep Text in Change Vertex.
5. Click the dimension (point 1).
6. Click the old reference element (point 2).
7. Click the new reference element (point 3).
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Creo Elements/Direct Drafting relocates the dimension but leaves the
dimension text in its original position. If you click Move Text in Change Vertex,
you can also relocate the dimension text.

Resetting Dimension Lines
To reset a broken or staggered dimension line:

1. Click Modify in Dimension.
2. Click Line in Modify.
3. Click Reset in Modify.
4. Identify the dimension for the dimension line reset.

Note
If you reset a dimension with broken, staggered, or slanted dimension
extension lines, Creo Elements/Direct Drafting straightens the extension lines
and removes breaks or staggers, if any.

Modifying Dimension Text
This section shows how to move or rotate existing dimension text, with or without
the associated dimension lines.
To move or rotate dimension text:

1. Click Modify in Dimension.
2. Click Text in Modify.
3. Click one of the following options in Text:

• Move Text

• Move Text & Line

• Rotate Text

Moving Dimension Text
To move dimension text without moving the dimension or extension lines:

1. Click Modify in Dimension.
2. Click Text in Modify.
3. Click Move Text in Text.
4. Select the dimension text items you want to move.
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Creo Elements/Direct Drafting replaces each selected dimension text item
with a trace box.

5. Click the desired location for the dimension text.

Creo Elements/Direct Drafting relocates the selected dimension text items.

Moving Complete Dimensions
To move one or more complete dimensions:

1. Click Modify in Dimension.
2. Click Text in Modify.
3. Click Move Text + Line.
4. Click the dimension text of the dimension(s) you want to move.

Creo Elements/Direct Drafting draws a trace of the dimensions.
5. Click the desired location for the dimension text.

Creo Elements/Direct Drafting relocates the selected dimensions.

Moving Dimension Text and Leader Line
To move a dimension text and its associated leader line:

1. Click Modify in Dimension.
2. Click Text in Modify.
3. Click Move Text + Leader.
4. Click the dimension whose text and leader lines you want to move. Creo

Elements/Direct Drafting draws a trace of the dimension text and its leader
line.

5. Click the desired location for the dimension text. Creo Elements/Direct
Drafting relocates the selected dimension text and its leader line.

Figure 131. Moving a Dimension Text and Its Leader Line

Rotating Dimension Text
Horizontal is the zero angle and positive rotation is counterclockwise.
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To rotate dimension text:

1. Click Modify in Dimension.
2. Click Text in Modify.
3. Click Rotate Text in Text.
4. Enter an absolute angle of rotation. A positive angle causes a

counterclockwise rotation.
5. Select the dimension text(s) you want to rotate.

Creo Elements/Direct Drafting rotates the selected dimension text.

Aligning Dimensions
Dimensions can be aligned with other dimensions. First, you identify an existing
dimension and align the new dimension above, below, or adjacent to it.

Figure 132. Aligning Dimensions to Other Dimensions

To align a dimension:

1. Click Modify in Dimension.
2. Click Text in Modify.
3. Click Move Text & Line.
4. Click the dimension you want to move (point 1).
5. Click the reference dimension (point 2).
6. Drag the cursor to the new location.
7. Release the mouse button.
8. Repeat for other dimensions (point 3).
Aligning of dimensions applies to single dimensions and not group dimensions (a
group of dimensions cannot be boxed because each dimension needs a specific
shift-vector). Additionally, aligning dimensions does not apply to non-linear
dimensions such as:

• Diameters
• Radii
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• Arcs

Inclining Dimensions
The dimension attributes Horizontal and Vertical can be overridden such that when
an element is inclined, the dimension is also inclined. What you are doing is
freezing the dimension to the describing element. This helps speed up the
modification process for dimensioned geometry. Dimension attributes such as text
size and font are not changed.

Figure 133. Effects of Freezing a Dimension

1 Dimension created by Single, Horizontal. When the part is rotated 20°, the dimensions
remain horizontal giving a correct but meaningless result.

2 Same as item 1 but the dimensions were frozen with Freeze before the part was modified.

To freeze a dimension:

1. Click Modify in Dimension.
2. Click Freeze in Modify.
3. Click the dimension you want to incline.
Note the following:

• If you use the select Box option when selecting dimensions, only those
dimensions with the attribute Horizontal or Vertical are affected.

• There is no Undo for this command.

Editing Text
This section shows how to edit existing dimension text. Identified dimension text
is displayed in the User Input Line. After editing the text, make sure that quotes (' '
or " ") surround the text, then press [Enter].
Creo Elements/Direct Drafting will redraw the edited dimension text.
To edit existing dimension text:

1. Click Modify in Dimension.
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2. Click Edit Dim Text in Modify.
3. Click the dimension text to edit.

Creo Elements/Direct Drafting displays the dimension text in the User Input
Line.

4. Edit the text, then press [Enter].
5. Click End to end this command.

Dimension Text Underlining
Creo Elements/Direct Drafting provides the possibility to underline dimension
text. This is particularly useful when you want to flag a dimension that has been
manually changed (or edited). This underlining feature is a requirement of DIN
dimensioning standards. The default setting depends on the selected dimension
standard:
DIN Standard Default is on.
ANSI, ISO, JIS, or
COMPANY Standard

Default is off.

If the selected dimension standard is DIN, dimension text that is edited is
automatically underlined. Otherwise, edited dimension text is not underlined but
can be underlined selectively. Dimension underlines have the following
properties:

• The length is the same length as the dimension text.
• Prefixes, postfixes, and tolerances are not underlined.
• The color is the same as dimension lines.
• The space between the dimension text and underline is fixed.
• The pensize is the same as that of the dimension lines.
To underline a dimension:

1. Click Modify in Dimension.
2. Click Edit Dim Text in Modify.
3. Click the dimension to be underlined.
4. Press [Enter] to accept the current value. Optionally, you can edit this value.
Creo Elements/Direct Drafting displays the edited dimension value with an
underline.
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Figure 134. Dimension Underlining

To remove an underline:

1. Click Modify in Dimension.
2. Click Cancel Edit in Modify.
3. Click the underlined dimension you want to reset.
Creo Elements/Direct Drafting displays the edited dimension value without an
underline.

Canceling a Dimension Text Edit
This section shows how to cancel an edit and display the dimension text in its
original form. This means that if you edit the dimension text twice and then use
Cancel Edit, the original dimension text will appear and not your first edited
version of the text.
To cancel an edit:

1. Click Modify in Dimension.
2. Click Cancel Edit in Modify.
3. Click the dimension text you want to reset to its original version.

Creo Elements/Direct Drafting displays the original dimension text.
4. Click End to end this command.

Modifying Chain and Datum Dimensions
Individual segments can be inserted or deleted within chain and datum dimension
groups. Creo Elements/Direct Drafting automatically adjusts other segments
within the chain or datum group to account for the new/deleted segment.
Optionally, Creo Elements/Direct Drafting can check to ensure that the modified
chain or datum group will not intersect existing geometry.
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Deleting a Segment from a Chain or Datum
Dimension Group
To delete a segment from an existing chain or datum dimension group:

1. Click Delete in Dimension.
2. Click the dimension text of the segment to be deleted.
3. If the segment you are deleting is part of a dimension chain, click the

dimension text of the next segment in the chain. This segment will grow to fill
the space created by the segment you delete.

4. When you have finished deleting dimensions, click End to end this command.

Inserting a New Chain or Datum Dimension Segment
To insert a new segment into an existing chain or datum dimension group:

1. Click Modify in Dimension.
2. Click Insert in Modify.
3. Click the chain or datum group you want to modify by clicking on the

dimension text of any segment within the group.
4. Click the new dimension point.
5. When you have finished inserting segments, Click End to end this command.

Grouping
You can group annotations together. Groups on page 490 may consists of a single
dimension, multiple text elements and multiple symbols.

Further Information
For further technical information about dimensions, refer to the Creo Elements/
Direct Drafting help system:
Enter help da_dimension at the Creo Elements/Direct Drafting command
line.
The screen will clear and Creo Elements/Direct Drafting will display further
information about dimensioning.
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This chapter shows how to hatch your drawing and how to set and change the
hatch parameters.
If you wish to cross-hatch an area or build up a custom hatch pattern, simply use
any number of Enter commands on the same area but with different hatch angles,
distances, hatch points, colors, and linetypes.
Alternatively, you can define your own hatch patterns for use in multiple areas.
See Creating a Hatch Pattern on page 273 for details.
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Hatching a Drawing Area
You have a choice of two hatch methods:

• Automatic Hatching on page 268
• Manual Hatching on page 269

Automatic Hatching
You can hatch any area fully enclosed by drawing lines or already hatched.
To automatically hatch a drawing area:

1. Click Enter in Hatch.
2. Specify a point inside the area to be hatched.

The cursor will automatically track around the enclosing polygon and then
search for any inner holes. Having established the inner and outer contours,
Drafting will hatch the bounded area. If Drafting finds any gaps or incorrectly
split lines in the enclosing polygon, the command is aborted and Drafting
marks the gap or split line.

Match Point
You can set a match point to be used for all subsequent hatching. One hatch line
will be aligned to pass through the match point. The match point need not
necessarily lie inside an area to be hatched; in this case an imaginary extension of
the hatch lines would pass through the hatch point.
Figure 135. Hatch Pattern Aligned with Match Point on page 268 shows the hatch
pattern aligned with an external match point.

Figure 135. Hatch Pattern Aligned with Match Point

To set the hatch match point:

1. Click Enter in Hatch.
2. Click Enter Point in Hatch. Then specify a point with you want to align the

hatch to be created.
3. Specify a point inside the area to be hatched.
One hatch line of all subsequent hatching will pass through the new match point.
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Manual Hatching
Manual hatching is used to hatch any area not fully enclosed by drawing lines.
To manually hatch a drawing area:

1. Click Hatch ▶ Enter ▶ Manual.
2. Click the start point on the existing outer contour of the area to be hatched.

See Automatic Splitting on page 270 for further contour creation options.
3. Continue by clicking successive points around the outer contour.
4. Click the start point again to close the contour.

When you have closed the contour, use the same method to indicate any inner
holes that are not to be hatched.

5. Click End and Drafting will hatch the area.

To abort the command click Cancel. Use Undo to undo erroneous points.
If a side consists of a complete drawing line, simply indicate a mid-point on the
line using the element (ELEM) catching mode. Drafting will accept the line. If you
wish to identify only part of a line, mark the desired end point with a construction
line, use the intersection (INTERSECTION) catching mode, and indicate the desired
end point. Drafting will then accept only part of the line.
A series of connected drawing lines can be indicated by the end of one line and
the mid-point of the last line. Drafting will not accept a series of successive lines
if there is a branch at one of the vertices.
Figure 136. Indicating the Area for Hatch on page 269 illustrates the above
techniques.

Figure 136. Indicating the Area for Hatch

Not all the sides have to be drawing lines. An imaginary line can be used to
separate free space or existing points. See Figure 137. Hatching — Leaving an
Unhatched Area on page 270.
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Figure 137. Hatching — Leaving an Unhatched Area

Automatic Splitting
You can use automatic splitting options for extended contour creation
functionality. To enable these options, Hatch ▶ Settings ▶ Automatic Split for
Hatch Manual click. Use these options to automatically detect element
intersections and add only parts of elements to contours.

• Use ANY_POINT to automatically create a split point at the pick point on a
selected element and use that element as the contour element if it is connected
to previously selected element. All elements connecting currently picked and
previously picked elements are included in the contour. This option remains
active until you select another option (INTERSECTION, ANY_POINT).

• Use INTERSECTION to automatically find the next intersection of elements
on the contour and splits them both at that point. Drafting starts searching for
an intersection along the contour in the same direction as between the previous
and current pick points. All elements connecting the previously picked
element and the intersection are included in the hatch contour. If Drafting
doesn’t find an intersection, this option behaves the same as the NO_
SPLITTING option. This option remains active until you select another option
(INTERSECTION, ANY_POINT).

• Use NO_SPLITTING to restore default behavior. The command behaves as if
the Automatic Split for Hatch Manual setting is off. This option remains active
until you select another option (INTERSECTION, ANY_POINT).

• Use VERTEX to automatically split element at the pick point, and directly
connect it to your previous pick point without following the contour. This
option remains active only for one pick.
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Hatch Settings
The Hatch Settings dialog box enables you to define:

• Simple Hatch Settings on page 271
• Setting Hatch Patterns on page 272
• Standard Hatch Patterns on page 278
To display the Hatch Settings dialog box:

• Click Settings in Hatch.
Or:

• Pull down the Setup menu. Click Edit Environment and then click Hatch.
When you have defined your hatch settings, either click Hatch to apply these
settings to the next face(s) you click, or click OK to apply these settings to
subsequent hatching (via Enter).

Simple Hatch Settings
Press the Hatch radio button in the Hatch Settings dialog box to switch to Hatch
mode. In this mode, you can select or change the following hatch settings:

• Distance

• Angle

• Linetype

• Color

The settings you specify or select in the Hatch Settings dialog box are applied to
all subsequent hatching. These settings remain active until you change them.

Hatch Distance
To set the distance between hatch lines, enter the required value into the Distance
field in Hatch Settings. This value is interpreted in terms of the length unit (such
as mm) currently set up for your Drafting environment. Figure 138. Hatch Line
Distance on page 271 shows an example of a hatch line distance.

Figure 138. Hatch Line Distance
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Hatch Angle
To set the hatch angle, enter the required value into the Angle field in Hatch
Settings. The angular units will be those currently defined for your Drafting
environment. A zero value implies horizontal hatch lines and a positive angle
results in counterclockwise rotation.
Figure 139. Positive Hatch Angle on page 272 shows a positive hatch angle.

Figure 139. Positive Hatch Angle

Hatch Linetype
To set the hatch linetype, select a linetype from the drop-down list box next to the
Linetype field in Hatch Settings.

Hatch Color
To set the hatch color, select a color from the drop-down list box next to the Color
field in Hatch Settings. Refer to Defining Custom Colors on page 54 for
instructions on defining custom colors.

Setting Hatch Patterns
Patterns consist of any number of simple hatch lines built up in layers. When you
have created a pattern, it will be active every time you click Enter in Hatch. The
pattern will be used to hatch all subsequent areas.
The five hatch pattern settings are described in Table 3 on page .

Table 3. Hatch Pattern Parameters

Name Allowed Value Description
Offset 0 to 1 The offset is used to align the hatch lines of

the layer to the match point (set using Enter
Point in Hatch). The perpendicular offset is
the entered value multiplied by the distance.
See Figure 140. Hatch Perpendicular Offset
on page 273.

Distance Any Number The distance between each of the layer's
hatch lines will be the entered value
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Name Allowed Value Description
multiplied by the distance value specified in
Hatch mode.

Angle 0 to ± 360 The entered angle will be added to the angle
specified in Hatch mode to determine the
actual angle at which the layer's hatch lines
will be drawn.

Color Any of predefined colors in the drop-down
list box or a custom color. Refer to Defining
Custom Colors on page 54 for instructions on
defining custom colors.

Linetype Any of the eight Drafting standard linetypes
can be selected from a drop-down list box.

Figure 140. Hatch Perpendicular Offset

Creating a Hatch Pattern
To create a hatch pattern:

1. Press the Pattern radio button in the Hatch Settings dialog box to switch to
Pattern mode.

2. Specify the first layer's values for Offset, Distance, Angle, Color and Linetype.
3. Enter the next layer's values or finish the pattern by clicking Add To.

There is no limit to the number of layers in a pattern. For examples of patterns,
refer to the section Standard Hatch Patterns on page 278. The exact values
required for each standard pattern are listed there.

Canceling a Hatch Pattern
You can cancel any previously created hatch pattern. After canceling the hatch
pattern all future Enter commands in Hatch will revert to the hatch parameters set
using the linetype and color specified in the Hatch mode (see Simple Hatch
Settings on page 271).
To cancel a hatch pattern:

1. Press the Pattern radio button in the Hatch Settings dialog box to switch to
Pattern mode.
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2. Click Cancel.

The previously created hatch pattern will be canceled.

Changing Hatch Settings
This section shows how to change existing hatching.

• Changing Individual Hatch Settings on page 274
• Changing Multiple Hatch Settings on page 276
• Changing a Hatch Pattern on page 276

Changing Individual Hatch Settings
Via the Change menu in Hatch, you can change individual hatches in your
drawing.

• Changing the Hatch Angle on page 274
• Changing the Hatch Line Distance on page 274
• Changing the Hatch Color on page 275
• Changing the Hatch Linetype on page 275
• Changing the Match Point on page 275
• Changing a Hatch Pattern on page 276
• Automatic Splitting on page 270

Changing the Hatch Angle
To change the hatch angle:

1. Click Change in Hatch.
2. Click Angle in Change.
3. Enter the required hatch angle.
4. Click the hatching to be changed. You can click individual areas of hatch or

box several hatch areas or click All. Drafting will change the selected hatching.

Alternatively, use the Selection block as you would for a Delete command, and
finish by clicking Confirm.

Changing the Hatch Line Distance
To change the line distance of an existing hatch:

1. Click Change in Hatch.
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2. Click Distance in Change.
3. Enter the required line distance.
4. Identify the hatching to be changed. You can click individual areas of hatch or

box several hatch areas or click All. Drafting will change the selected hatching.

Alternatively, use the Selection block as you would for a Delete command, and
finish by clicking Confirm.

Changing the Hatch Color
To change the color of an existing hatch:

1. Click Change in Hatch.
2. Click Color in Change.
3. Select a color from the Color list box. Refer to Defining Custom Colors on

page 54 for instructions on defining custom colors.
4. Identify the hatching to be changed.

You can only identify individual areas of hatch to be changed. When there are
two hatch patterns superimposed on each other, the pattern nearest to the
cursor will be changed.

Alternatively, use the Selection block as you would for a Delete command, and
finish by clicking Confirm.

Changing the Hatch Linetype
To change the hatch linetype:

1. Click Change in Hatch.
2. Click Linetype in Change.
3. Select a linetype from the Linetype list box.
4. Identify the hatching to be changed.

You can only identify individual areas of hatch to be changed. When there are
two hatch patterns superimposed on each other, the pattern nearest to the
cursor will be changed.

Alternatively, use the Selection block as you would for a Delete command, and
finish by clicking Confirm.

Changing the Match Point
To change the hatch match point:

1. Click Change in Hatch.
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2. Click Match Point in Change.
3. Enter the required point for the hatch lines to match.
4. Identify the hatching to be changed. You can click individual areas of hatch or

box several hatch areas or click All. Drafting will change the selected hatching.

Alternatively, use the Selection block as you would for a Delete command, and
finish by clicking Confirm.

Automatic Splitting
Read about Automatic splitting in the Manual Hatching on page 270 section.

Changing Multiple Hatch Settings
Instead of changing individual settings of a hatch, you can change multiple hatch
settings at the same time.
To change multiple settings of a hatch:

1. Click Change in Hatch.
2. Click Multiple in Change. Drafting returns the Change Hatch dialog box.
3. Change the hatch settings as required. The method is the same as described in

Simple Hatch Settings on page 271.
4. Click the hatch to which you want to apply these changes.

Alternatively, use the Selection block as you would for a Delete command, and
finish by clicking Confirm.

Changing a Hatch Pattern
To change a hatched area to a new pattern:

1. Click Change in Hatch.
2. Click Pattern in Change.
3. Specify or select the settings for the first layer of the pattern (see Setting Hatch

Patterns on page 272 for details).
4. If there are further layers, continue by defining the next layer(s) in the same

way.
5. Finish defining the pattern by clicking OK in Hatch Settings.
6. Identify any hatched areas and Drafting will change them to the new pattern.
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Hatching Around Text and Dimension
Text
When text lies in a hatched area, Drafting automatically creates a window around
the text. The result is the same whether you hatch first and then add text, or add
text first. If you modify the drawing by moving the text, the hatching is
automatically updated.
The Text Window command creates a hole around text and dimension text when
the text runs through a hatched area (as in overlapping parts). The following figure
shows three parts in a parts structure (part 1 is the top part and part 3 is the lowest
part). In a real assembly, the parts overlap and the hatching on parts 1 and 2
appears to run through the dimension text on part 1. You use the Text Window
command to punch a window through the overlapping hatching.

Figure 141. Text and Dimension Text: Hatched Area

1. Hatch the required area in automatic or manual mode.
2. Click Change in Hatch.
3. Click Text Window in Change.
4. Click the dimension text around which you want to hatch.

Figure 142. Hatching Around Dimension Text

To move dimension text when you have used the Text Window command to create
the hole around the text:

1. Move the dimension text to its new position.
2. Delete the old hole in the hatching (Drafting deletes the hole and regenerates

the hatch).
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3. Use the Text Window command to create a new hole around the dimension
text.

Standard Hatch Patterns
This section shows how to set up standard hatch patterns which will be used by all
subsequent Enter commands in Hatch.
To set up a standard hatch pattern:

1. Display the Hatch Settings dialog box:

• Click Settings in Hatch.

Or:

• Pull down the Setup menu. Click Edit Environment and then click Hatch.
2. Press the Standard radio button in the Hatch Settings dialog box to switch to

Standard mode.
3. Select the desired option (Iron, Steel, Copper).

The selected standard hatch pattern will become active.
The three standard options are shown below together with the values of offset,
distance, angle, color, and linetype used (refer to Setting Hatch Patterns on page
272). All the examples shown are drawn with the following hatch parameters:
hatch angle 45, hatch distance 5, and match point 0,0.

Standard Hatching — Iron
This option sets the following Hatch Pattern values:
Offset: 0
Distance: 1
Angle: 0
Color: Cyan
Linetype: Solid

Figure 143. Iron
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Standard Hatching — Steel
This option sets the following Hatch Pattern values:
Offset: 0.33 & 0
Distance: 1 & 1
Angle: 0 & 0
Color: Cyan & Cyan
Linetype: Solid & Solid

Figure 144. Steel

Standard Hatching — Copper
This option sets the following Hatch Pattern values:
Offset: 0.5 & 0
Distance: 1 & 1
Angle: 0 & 0
Color: Cyan & Cyan
Linetype: Dashed & Solid

Figure 145. Copper

Converting Hatch to Geometry
Hatches are handled differently by different applications. In some cases, hatch that
is passed from Creo Elements/Direct Drafting to Autocad can change appearance.
To make sure your hatch does not change appearance, convert it to geometry.

1. Click Hatch.
2. Click Hatch to Geometry.
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3. "Identify hatch to convert it to the geometry" prompt appears. Click in your
viewport window or use the Select function to select hatches in the current
part. Global selection is not available.

4. Click Confirm.
5. Click End.
The appearance of your hatching does not change. You can see, however, that it is
now geometry. For example, you can now delete a single line of the hatch.
Completely filled hatches will not convert. In this case, you will see the error
message, "Completely filled hatches will not be converted to geometry" or "Some
hatches will not be converted to geometry."
You can use Undo and Redo in combination with Hatch to Geometry.

Deleting Hatching
This section shows how to delete areas of hatching.
To delete an area of hatching:

1. Click Delete in Hatch.
2. Click individual areas of hatching to be deleted, (or enclose a group of hatched

areas in a box). Alternatively:

• Use the Selection block as you would for a normal deletion.
• Finish by clicking Confirm to delete the selected groups of hatching.

3. If you delete an area by mistake, click Undo to undo the last delete operation.
4. Click End to end the command.
Delete hatch that has been converted to geometry the same way you would delete
geometry, using the Delete command.

Further Information
For further technical information about hatching, refer to the Drafting help
system:
Enter help hatching at the Drafting command line.
The screen will clear and Drafting will display further information about hatching.
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Entering Text
Creo Elements/Direct Drafting provides the following options for entering text:

• Entering Text Via a Text Box on page 282
• Entering Text Directly in the Drawing on page 283

Note
If Creo Elements/Direct Drafting draws boxes instead of the text, you must
input a text font. Refer to Text Font on page 288. To load additional fonts for
selection, follow the instructions in Importing a Font on page 423.

Entering Text Via a Text Box
To add text to your drawing via a text box:

1. Click Enter Text in Text. Creo Elements/Direct Drafting returns the Text box.
2. Enter the required text into the Text box.
3. Click OK to add the text to the drawing.
4. Click the position for the text.
Creo Elements/Direct Drafting draws the text. The newly added text reflects the
text settings defined via Text Settings on page 286.
If you require the same text at several locations on the drawing, simply continue
to click locations and the text will be repeated.
In addition to entering text, you can use the Text box for:

• Entering Special Characters on page 282
• Text Settings on page 286
• Loading an Existing Text File on page 283
• Storing Text in a Text File on page 283

Entering Special Characters
To add a special character to your Creo Elements/Direct Drafting drawing:

1. In Text, click Enter Text.
2. In the Text box, click Spec Char to display a graphical list of special text

characters.
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These special characters are included in the hp_symbols and hp_
symbols2 fonts. You can create additional special characters by editing these
fonts. See Editing a Font on page 295 for further information.

3. In Special Characters, select the special character you want to add as text to
your drawing. A graphical representation of each character is provided in the
Meta Name column.

4. Click Insert to copy the selected special character to the Text box. Note that
you can insert the special character(s) into existing text in the Text box.

5. When the Text box contains the required special character(s), click OK to add
the text to your drawing.

6. Click the position for the text.

Loading an Existing Text File
To load an existing text file for use in your Creo Elements/Direct Drafting
drawing:

1. In Text, click Enter Text.
2. In the Text box, click Load.
3. Use the Load browser to find and load a text file.
4. In the Text box, edit the text file as required.
5. Click OK to add the text to your drawing.
6. Click the position for the text.

Storing Text in a Text File
To store text in a text file:

1. Click Text, Enter Text to display the Text box. Either type in the text to be
saved or load an existing text file (see Loading an Existing Text File on page
283) and edit it.

2. In the Text box, click Store.
3. In the Store browser, select a directory and enter the name of the text file in

which you want to store the text.
4. Click OK to store your text in this file.

Entering Text Directly in the Drawing
To enter text directly in your drawing:

1. In Text, click Inplace, Enter.
2. Click the position for the text.
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3. Enter the required text. Creo Elements/Direct Drafting adds the text directly at
the cursor position. By default, the newly added text reflects the text settings
defined via Text Settings on page 286.

4. Click End.
When you have entered text in your Creo Elements/Direct Drafting drawing, you
can:

• Edit and/or delete this text (see Editing and Deleting Text on page 284)
• Change the settings of this text (see Changing Text Settings on page 290)
• Modify this text just like any geometric element (see Modifying a Drawing on

page 150)
• Add a reference line to this text (see Creating a Reference Line on page 290)
• Convert the text to normal geometry (see Converting Text to Geometry (DXF/

DWG and IGES 2D Translation) on page 290)

Editing and Deleting Text
Creo Elements/Direct Drafting provides the following options for editing and
deleting text:

• Editing Text Via a Text Box on page 284
• Editing Text Directly in the Drawing on page 285
• Moving Text on page 285
• Deleting Text on page 285

Note
If Creo Elements/Direct Drafting draws boxes instead of the text, you must input a
text font. Refer to Text Font on page 288. To load additional fonts for selection,
follow the instructions in Importing a Font on page 423.

Editing Text Via a Text Box
To edit existing text via a text box:

1. Click Edit Text in Text.
2. In the Creo Elements/Direct Drafting drawing, click the text to be edited. Creo

Elements/Direct Drafting displays this text in the Edit Text box.
3. Use the keyboard and edit keys to make the required changes to the text.

284 Creo Elements/Direct Drafting User's Guide: Windows User Interface



4. Click OK. The normal display will reappear and the changed text is displayed
in the drawing.

Editing Text Directly in the Drawing
To edit text directly in your drawing:

1. In Text, click Inplace, Edit.
2. Click the text to be edited.
3. Edit the text as required. Any changes are performed at the cursor location. If

you add text while editing, the newly added text will reflect the settings of the
existing text (see Text Settings on page 286).

4. Click End.

Moving Text
Quickly move text by moving the text box.

1. Hover over the text. Creo Elements/Direct Drafting highlights a box around
the text (if Enable Fly-By Highlighting is on).

2. Drag the text to a new location.

Deleting Text
There are several ways to delete text from your drawing.
Use the Delete key on your keyboard:

1. Click the text. A frame appears around the text.
2. Press the Delete key on your keyboard.
Creo Elements/Direct Drafting deletes text in the same way as normal drawing
lines. To delete text without using the selection block:

1. Click Delete.
2. Box the text to be deleted, or click a single text to be deleted. Creo Elements/

Direct Drafting will now delete the selected text.
If you use the Text option in Select, the text blocks you select for deletion are
highlighted. Click Confirm to delete the highlighted text.
Click Undo to correct mistakes and then repeat the operation or end the command.
To delete text using the selection block:

1. Click Delete.
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2. Select text for deletion using the Selection block options just as you would for
a normal Delete command. You can click Undo to correct any mistakes.

3. Click Confirm to delete the selected text block(s).

Text Settings
You can display the Text Settings dialog box in the following ways:

• Click Enter Text in Text. Then click Settings in the Text box.
• Click Settings in Text.
• Pull down the Setup menu. Click Edit Environment and then click Text.
The settings you specify or select in the Text Settings dialog box are applied to all
subsequent text. These settings remain active until you change them.
The Text Settings dialog box enables you to define:

• Text Parameters on page 286
• Text Font on page 288
• Text Options on page 288

Text Parameters
Use the items in the Parameters section of the Text Settings dialog box to set the
following text parameters:

• Size

• Angle

• Ratio

• Linespace

• Slant

• Fill

Text Character Size
To set the text size, enter the required value into the Size field in Text Settings.
This value is interpreted in terms of the length unit (such as mm) currently set up
for your Creo Elements/Direct Drafting environment. The Creo Elements/Direct
Drafting default text size is 3.5 mm.
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Text Angle
To set the text angle, enter the required value into the Angle field in Text Settings.
The angular units will be those currently defined for your Creo Elements/Direct
Drafting environment. A zero value implies horizontal text and a positive angle
results in counterclockwise rotation. Figure 146. Setting the Text Angle on page
287 illustrates the text angle concept.

Figure 146. Setting the Text Angle

Text Character Ratio
To set the width-to-height ratio of text characters, enter the required value into the
Ratio field in Text Settings. The default text ratio is 1.0.

Linespace
To set the line spacing of text lines, enter the required value into the Linespace
field in Text Settings. The default linespace in Creo Elements/Direct Drafting is
2.2 mm. The distance between lines of text in a block is computed as follows:
Actual line spacing = Linespace * Text Size

Text Character Slant
To set the slant angle of text characters, enter the required value into the Slant
field in Text Settings. The angular units will be those currently defined for your
Creo Elements/Direct Drafting environment. A zero value implies no slant and a
positive angle results in clockwise rotation. The default slant in Creo Elements/
Direct Drafting is 0. Figure 147. Text with a 15° Slant on page 287 shows text
with a 15° slant.

Figure 147. Text with a 15° Slant
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Text Character Fill On/Off
Creo Elements/Direct Drafting provides a number of text fonts (such as " hp_
block_c ") that can be displayed in filled or unfilled mode. Simply click on the Fill
check box to switch the fill mode on or off. Figure 148. Unfilled and Filled Text
on page 288 shows an example (unfilled and filled).

Figure 148. Unfilled and Filled Text

Text Font
To select a font for text, simply select that font from the Font list in Text Settings.
The font names in this selection list include:

• Fonts supplied with Creo Elements/Direct Drafting.
• Fonts already installed on your PC.
To load additional fonts for selection, follow the instructions in Importing a Font
on page 423.
OSD’s different internal and external encoding schemes were Unicode on page
497 incorporated for version 2007.

Note
The font selection list also includes all TrueType® fonts installed on your PC. If
you select one of these fonts, it will be converted during the load process. The
converted font will be stored in the fontssubdirectory below the Creo Elements/
Direct Drafting installation directory.

Text Options
Use the items in the Options section of the Text Settings dialog box to set the
following text options:

• Color
• Frame
• Origin Vertex
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Text Color
To set the text color, select a color from the Color list in Text Settings. Refer to
Defining Custom Colors on page 54 for instructions on defining custom colors.

Text Frame
By default, text in Creo Elements/Direct Drafting is displayed without a frame.
Optionally, you can select the following frame forms from the Frame list in Text
Settings:

• Balloon

Figure 149. Text with a Balloon Frame on page 289 shows text with a balloon
frame.

Figure 149. Text with a Balloon Frame

• Box

Figure 150. Text with a Box Frame on page 289 shows text with a box frame.

Figure 150. Text with a Box Frame

• Flag

Figure 151. Text with a Flag Frame on page 289 shows text with a flag frame.

Figure 151. Text with a Flag Frame

Text Origin Vertex
To set the position of the origin of any subsequent text, click Origin Vertex and
specify the associated position number (an integer between 1 and 9). Figure 152.
Cursor Positions in the Text Box on page 290 shows you the relative position
associated with each of these adjust values.
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Figure 152. Cursor Positions in the Text Box

Changing Text Settings
To change the settings of existing text:

1. Click Change Text in Text.
2. Select the text to be changed. Either click on a single text block or box

multiple text blocks or use Select.
3. In the Text Change dialog box, change the settings as required. See the Text

Settings on page 286 section for an explanation of these settings. Note that the
settings in Text Settings apply to all text to be added to the drawing, while the
settings in Change Text apply to existing text you selected.

Converting Text to Geometry (DXF/DWG
and IGES 2D Translation)
The Text to Geometry command converts text entities to geometry entities. This is
necessary for translation to DXF/DWG and IGES 2D format when customized
fonts have been used (the MI file stores the font name but does not contain the
customized font information).
Note the following:

• Only text entities can be converted, not dimension texts.
• Any text-windows inside hatched areas are retained.

Creating a Reference Line
The Enter Refline command lets you create a reference line between a source
element and its associated target element. Creating reference lines helps to speed-
up the modification phase as it saves you time repositioning individual elements.
When you move the target element of a reference line, the reference line will
remain attached to the target element like a "rubber band" (see Figure 153. Effect
of Moving the Target Element on page 291).
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To draw a reference between two existing elements:

1. Click Enter Refline in Text.
2. Click the required option (if any) in Enter Refline. See Reference Line Options

on page 294 for further information.
3. Click the associated source element (such as an existing text block).
4. Optionally, click a number of points through which you want the reference line

to pass.
5. Click the target element (the element to which the source element refers).
Creo Elements/Direct Drafting draws a reference line between the two elements.
The newly added reference line reflects the settings defined via Reference Line
Settings on page 292.

Figure 153. Effect of Moving the Target Element

For deletion purposes, even a multi-segment reference line is considered as a
single element and can be deleted in one operation.

Reference Line Options
When you create a reference line between two elements, you can choose any (or
none) of the following options.

Reference Line
Option

Result

Parallel The reference line is drawn parallel to the orientation
direction of the source element.

Horizontal A horizontal reference line is drawn from the source
element.

Vertical Avertical reference line is drawn from the source
element.

Perpendicular The reference line is drawn perpendicular to the
orientation direction of the source element.

Reference Angle This options prompts you for an angle. Enter the
required angle into the command input line. The
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Reference Line
Option

Result

angular units will be those currently defined for your
Creo Elements/Direct Drafting environment. A zero
value implies horizontal text and a positive angle
results in counterclockwise rotation.

Attach Source This option enables you to attach the reference line to
its source element. When you move the source
element, the reference line will remain attached to this
element like a "rubber band".

Underline The source element is underlined.
Invisible An invisible reference line is drawn.

When you draw a multi-segment reference line (by clicking points between the
source element and its target element), note that these options apply to the first
reference line segment (between the source element and the first reference line
point you click) only.

Modify a Reference Line
Use the handles of a reference line to quickly modify it:

Reattach the reference line Click the handle on the start or end of the refline
and drag.

Stretch reference line
segments

Click inside the refline handles and drag.

Change the Handle Settings in Setup ▶ Edit Environment ▶ System ▶ Handles.

Delete a Reference Line
Click the reference line. Press Delete on your keyboard.

Reference Line Settings
To display the Reference Line Settings dialog box:

• Click RefLine Settings in Text.
Or:

• Pull down the Setup menu. Click Edit Environment and then click Refline.
The Reference Line Settings dialog box enables you to define:

• Line Settings on page 293
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• Reference Line Terminator on page 293
• Reference Line Options on page 291

Line Settings
Use the items in the Line section of the Reference Line Settings dialog box to set
the following:

• Type

• Color

• Width

Type
To set the linetype of reference lines, Select a linetype from the Type list in the
Line section of Reference Line Settings.

Color
To set the reference line color, select a color from the Color list in the Line section
of Reference Line Settings. Refer to Defining Custom Colors on page 54 for
instructions on defining custom colors.

Width
To set the reference line width, enter the required width into the field next to
Width in the Line section of Reference Line Settings. Refer to Line Width vs. Line
Size on page 51 for further information on line width.

Reference Line Terminator
Use the items in the Terminator section of the Reference Line Settings dialog box
to set the following:

• Type

• Size

Type
To set the reference line terminator type, select one of the following options from
the Type list in the Terminator section of Reference Line Settings:

• None

• Arrow

• Dot
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• Slash

• Triangle

• Jis

Size
To set the reference terminator size width, enter the required value into the field
next to Size in the Terminator section of Reference Line Settings. This value is
interpreted in terms of the length unit (such as mm) currently set up for your Creo
Elements/Direct Drafting environment.

Reference Line Options
Use the items in the Options section of the Reference Line Settings dialog box to
set the following:

• Source Gap

• Destination Gap

• Offset

All three values are interpreted in terms of the length unit (such as mm) currently
set up for your Creo Elements/Direct Drafting environment.

Source Gap
To set a distance between the begin point of the reference line and its source
element, enter the required value into the Source Gap field in the Options section
of Reference Line Settings.

Destination Gap
To set a distance between the end point of the reference line and its target element,
enter the required value into the Destination Gap field in the Options section of
Reference Line Settings.

Offset
To set a distance between the begin point of the reference line and its source
element as well as between its end point and its target element, enter the required
value into Offset field in the Options section of Reference Line Settings.

Getting and Putting Text Properties
Any properties you assigned to a text block (see Text Settings on page 286 and
Changing Text Settings on page 290) can be assigned to another text block.
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To assign the properties of a text block to another text block:

1. Click Get in Tools ▶ Properties.
2. Click the text block whose properties you want to get.
3. Click Put in Tools ▶ Properties.
4. Click the text block to which you want to assign these properties.

Font Editor
The Creo Elements/Direct Drafting Font Editor enables you modify existing Creo
Elements/Direct Drafting fonts and create new fonts. This special module is
particularly useful in design environments where company-specific characters or
logos are required and for Japanese Kanji character-sets.
When working with the Font Editor, note the following:

• Although you can use the View menu to do such things as a redraw, do not
change to another menu until you are finished.

• Store the current drawing (MI file).
• When you have finished creating or modifying the font, you must save it.
• All loaded fonts are listed in a selection table.
• The font you are editing becomes the current font.

Caution
Before calling the Font Editor, save the current drawing. This is because the font
editor uses the current drawing area to display the font table and deletes anything
in the current workspace.

Editing a Font
To edit a font:

1. Pull down the Tools menu, click Font Editor and Font.
2. In the Select Font dialog box, select a font and click Edit.
3. Pull down the Tools menu, click Font Editor and Show Font to display all of

the characters included in this font in the Creo Elements/Direct Drafting
drawing area.

4. Pull down the Tools menu, click Font Editor and Edit Character.
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5. Enter the character number (for example: 174) of the character you want to
edit in the User Input Line. Press [Enter] to display this character.

Note
If you use this method to add further special characters to the hp_
symbols or hp_symbols2 font, be sure to edit an empty character
(indicated by a blank square). These special characters are available for
use in text, dimensions, and symbols.

Creo Elements/Direct Drafting displays the character and a yellow character-
frame.

6. Modify or delete existing character geometry.
7. Pull down the Tools menu, click Font Editor and Draw.
8. Select the Draw option you want to use to create the new character. Note that

the maximum number of unconcatenated elements in a character is 84.

Figure 154. Character Frame

9. Pull down the Tools menu, click Font Editor and Update Character.
10. Enter the character number (you can either keep this number or assign a new

number).
11. Repeat this procedure for other characters if/as required.
12. To save the modified font, pull down the Tools menu, click Font Editor and

Store Font.

Note
If you use this method to create additional special characters in the hp_symbols
or hp_symbols2 font, be sure to save the edited version under a unique name in
a separate directory so it can be re-used following an Creo Elements/Direct
Drafting update.
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Changing the Character Spacing
To change the spacing between characters:

1. Pull down the Tools menu, click Font Editor and Change.
2. Select one of the following options:
Normal Distance to change the distance between constant-spaced

characters.
Constant Width to change the distance between variable-spaced

characters.

The next time you enter text, Creo Elements/Direct Drafting draws the text block
with the new character spacing.

Figure 155. Characters with Constant Spacing

Figure 156. Characters with Variable Spacing

Grouping
You can group annotations together. Group on page 490 may consists of a single
dimension, multiple text elements and multiple symbols.

Further Information
For further technical information about text, refer to the Creo Elements/Direct
Drafting help system:
Enter: help text at the Creo Elements/Direct Drafting command line.
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Geometric Tolerancing Symbols
This section shows how to add geometric tolerancing symbols to your drawing.
The symbols are based on the hp_symbols2 font. When you add symbols to a
drawing, Creo Elements/Direct Drafting uses this font.
Click Symbols to display the Symbols menu.

Setting Symbol Size
The size of symbols and associated text is determined by the Size in Text Settings.
Therefore, before you start adding symbols to your drawing, set the desired text
size as described in Adding Text to a Drawing on page 281.
To change the size of symbols and associated text, use Change Text as described in
Adding Text to a Drawing on page 281.

Deleting and Moving Symbols

Deleting Symbols
There are two ways to delete a symbol:

1. Click the symbol. A frame appears around the symbol. Press the Delete key on
your keyboard.

2. Click Delete in the menu and identify the symbol to be deleted.

Moving Symbols
There are two ways to move a symbol:

1. Move the symbol box.

• Hover over the symbol. Creo Elements/Direct Drafting highlights a box
around the symbol (if Enable Fly-By Highlighting is on).

• Drag the symbol to a new location.
2. Click Move in Modify and proceed as you would for a normal element such as

text, a line, or an arc.

Building a Geometric Tolerance Group
Click Create in Symbols to display the Symbols dialog box. The items in this
dialog box allow you to quickly build up the desired geometric tolerance group.
The main items are:
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Item Description
Tolerance Sets Normal or Composite symbol mode.
Type Enables you to select a symbol type.
Symbol This rectangular area provides a preview of the

current symbol definition.
Symbol Browser Bar This bar displays predefined symbols of the selected

Type.
Add Text Displays a text box for adding text to a symbol.
| Appends a short vertical line to the symbol.
– Adds a new line to the symbol.
] Appends the ] character to the symbol
Undo The Undo arrow button undoes the last addition to

the symbol.
Apply This button applies the current symbol definition.

Simply position the symbol in the drawing.
Cancel Cancels the current symbol definition.

To draw a geometric tolerance group:

1. Click Symbols.
2. In the Symbols dialog box, select a symbol mode from the Tolerance list:

• Normal

• Composite

3. Select a symbol type from the Type list:

• Geometric Symbols

• Modifying Symbols

• Draws Datum Target and Revision Symbols

Symbols of the selected type are displayed on the Symbol Browser Bar for
selection.

4. Click on a symbol on the Symbol Browser Bar. This symbol is displayed in
the Symbol preview area.

5. Optionally, click Add Text to display a text box in which you can enter text to
be added to the symbol. By convention, only UPPER CASE characters should
be entered. Click OK to close the text box and to append the text to the
symbol.

6. Click the appropriate button(s) to append vertical and/or horizontal lines and/
or ] characters to the symbol.
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7. When the symbol displayed in the preview area is complete, click Apply. Then
position the symbol in the Creo Elements/Direct Drafting drawing. Note that
another copy of the same symbol is added to the drawing every time you click
a point in the drawing.

8. Click End to terminate the positioning of the symbol.
9. Indicate the symbol location.
10. Optionally, attach a reference line that connects the symbol to the associated

feature in the Creo Elements/Direct Drafting drawing. See Creating a
Reference Line on page 290 for instructions.

Normal or Composite Symbols
Figure 157. Position Geometric Symbol on page 301 shows an example of a
Position geometric symbol. Both the Normal and Composite options are shown.

Figure 157. Position Geometric Symbol

Drawing a Geometric Symbol
Select Geometric Symbols from the Type list in Symbols to draw geometric
symbols.

Form Symbols
Figure 158. Symbol Type and Form Geometric Symbols on page 302 shows the
four form symbols.
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Figure 158. Symbol Type and Form Geometric Symbols

1 Straight
2 Flat
3 Round
4 Cylinder

Profile Symbol
Figure 159. Profile Geometric Symbols on page 302 shows the two profile
symbols.

Figure 159. Profile Geometric Symbols

Location Symbols
Figure 160. Location Geometric Symbol on page 302 shows the three location
symbols.

Figure 160. Location Geometric Symbol

1 Position
2 Symmetry
3 Concentric

Alignment Symbols
Figure 161. Alignment Geometric Symbols on page 303 shows the three
alignment symbols.
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Figure 161. Alignment Geometric Symbols

1 Angular
2 Perpendicular
3 Parallel

Runout Symbols
Figure 162. Runout Geometric Symbols on page 303 shows the two runout
symbols.

Figure 162. Runout Geometric Symbols

1 Circular
2 Total

Appending Text
Text can be added to symbols with the Add Text command. Use this command to
interrupt the symbol group, add text, and then proceed with the symbols. By
convention, only UPPER CASE characters should be entered. The two examples
in Symbol Examples on page 304 show you the correct sequence of steps.

Figure 163. Adding Symbol Text

Adding Symbols to a Drawing 303



Drawing Modifiers
Select Modifying Symbols from the Type list in Symbols to draw any of the
symbols shown in Figure 164. Modifier Geometric Symbols on page 304.

Figure 164. Modifier Geometric Symbols

Drawing Datum Target and Revision Symbols
Select Draws Datum Target and Revision Symbols from the Type list in Symbols to
draw any of the symbols shown in Figure 165. Target and Revision Symbols on
page 304.

Figure 165. Target and Revision Symbols

1 Symbol
2 Point
3 Revision

Symbol Examples
Drawing symbols is a simple task and can quickly be mastered by following
specified steps.
Before starting, set the text size to 5 mm, the text adjust to 1 (refer to Adding Text
to a Drawing on page 281 for details).
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Example 1: Single Line Symbol Group

Figure 166. Symbol Group – Example 1

To add symbol text:

1. Select Normal from the Tolerance list in Symbol.
2. Select Geometric Symbols from the Type list.
3. Click the Total Runout symbol on the Symbol Browser Bar.
4. Select Modifying Symbols from the Type list.
5. Click the (S) symbol on the Symbol Browser Bar.
6. Click Add Text. Enter 0.02 into the text box.
7. Click OK in the text box.
8. Click |.
9. Click Add Text. Enter A into the text box.
10. Click OK in the text box.
11. Click |.
12. Click Add Text. Enter 5R into the text box.
13. Click OK in the text box.
14. Click ].
15. Click Apply.
16. In the Creo Elements/Direct Drafting drawing, specify a point where you want

to position the symbol.

Example 2: Multiline Symbol Group

Figure 167. Symbol Group – Example 2

To add symbol text:
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1. Select Composite from the Tolerance list in Symbol.
2. Select Geometric Symbols from the Type list.
3. Click the Concentric location symbol on the Symbol Browser Bar.
4. Select Modifying Symbols from the Type list.
5. Click the diameter symbol on the Symbol Browser Bar.
6. Click Add Text. Enter 0.01 into the text box.
7. Click OK in the text box.
8. Click |.
9. Click Add Text. Enter A into the text box.
10. Click OK in the text box.
11. Click ].
12. Click – to initiate a second line in the symbol.
13. Click the diameter symbol on the Symbol Browser Bar.
14. Click Add Text. Enter 0.02 into the text box.
15. Click OK in the text box.
16. Click |.
17. Click Add Text. Enter B into the text box.
18. Click OK in the text box.
19. Click ].
20. Click Apply.
21. In the Creo Elements/Direct Drafting drawing, specify a point where you want

to position the symbol.

Example 3: Editing a Symbol Group
Symbol groups can be edited using the Edit command. This command converts the
symbol into a readable text-string and displays it in a text box for editing. This
text-string also contains control characters (\030) that should not be edited. If
they are modified, the conversion link back to the symbols font is lost and the
symbol appears as normal text.
To edit the symbol text:

1. Click Edit in Symbol.
2. Click the symbol you want to edit.

Creo Elements/Direct Drafting displays the text in screen mode, similar to the
following:
\030\151e0.01|A}
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\030fe0.02|B}

3. Edit the text and select Save from the File menu in the text box to save your
changes.

Note
Use the font list for special characters created by FONT EDITOR.

Surface Symbols

Note
The Surface Symbols and Welding Symbols menus are available in the Classical
User Interface of Creo Elements/Direct Drafting only. To run Creo Elements/
Direct Drafting with this user interface, set MEPELOOK to 1 or 3 in the
me10.inifile.

To display the Surface Symbols menu, click Menu 2 in the SYMBOLS menu.

Symbol Set
Click this icon to load or save a symbol
set.

Symbols
Click this icon to handle (e.g. load, save
or delete) individual symbols in the
current symbol set.

Positioning
Click this icon to display the positioning menu for
the current symbols.
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Option Description
The symbol is drawn horizontally from the
positioning point to the right.

The symbol is drawn vertically upwards from the
positioning point.

The symbol is drawn vertically downwards from
the positioning point.

The symbol is drawn from the positioning point
(first point) towards the second point.

The symbol is drawn from the positioning point
(first point) at the specified angle.

Note
The positioning point marks the foot point of the symbol.

Modifying
Click this icon to remove, read or
replace existing symbols in the
drawing.

Setting Up Surface Symbols
Click this icon to display the setup
menus for surface symbols.
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Symbol Setup
Menu Item Description
File Filename of the currently loaded symbol set or, following

changes, the name of the symbol set to be loaded.
Font Click Font to display a submenu for selecting the font size

for surface symbols. If you prefer to use your own font size,
specify the applicable number. Note that italic fonts are
marked by the letter i preceding the fnt extension. For
example, the italic version of the hp_symbols2 font is
named hp_symbols2_i.fnt.

Color Click Color to display a submenu for selecting the color for
surface symbols. Optionally, you can select RGB values.

Text Angle Click Text Angle and then specify the text character slant
angle.

Reference Lines
Menu Item Description
Color Click Color to display a submenu for

selecting the color for reference lines.
Optionally, you can select RGB values.

Width Click Width to display a submenu for
selecting the reference line width.
Optionally, you can specify a numerical
value for the reference line width.

Note
The Width applies to both reference
lines and symbols.

Automatic Click Automatic if you want reference
lines to be added automatically (YES)
or not (NO).
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Reference Line Terminator
Menu Item Description
Shape Click Shape in Reference Lines Symbol

to select a dot, an arrow, a triangle or a
slash as the terminator for reference
lines.

Size Click Size in Reference Lines Symbol to
display a submenu from which you can
select the reference line terminator size.
Optionally, you can specify a numerical
value for this size.

Angle Correction
Menu Item Description
Angle Correction Click Angle Correction. Then specify

the maximum deviation angle (in
degrees) at which the reference line will
still snap to the horizontal or vertical
direction. The default value of 45
degrees implies that the reference line
is always drawn horizontally or
vertically. If you want to draw
reference lines at arbitrary angles, set
the Angle Correction to 0.

The "surf_sym" Symbol Set Supplied with Creo
Elements/Direct Drafting
The surf_sym symbol set supplied with Creo Elements/Direct Drafting includes
the following preconfigured surface symbols:

coated

milled
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mat_remov

no_mat_remov

smooth

raw

Use Load to load this symbol set.

Illustrated Examples of Surface Symbols
To create your own surface symbols, either modify one of the preconfigured
symbols supplied with Creo Elements/Direct Drafting or create symbols "from
scratch". Both methods are illustrated in the following section.
In the following example, four surface symbols are added to the drawing of a
casting.

Figure 174. Casting plus Surface Symbols

Adding Symbols to a Drawing 311



The following exercise illustrated the procedure for creating the surface symbols
((A)), ((B)), ((C)) and ((D)). This exercise assumes that the Surface Symbols menu
is displayed.

Symbol ((A))
Proceed as follows:

1. Click S in the first column of the Compose Menu to display the current symbol
definitions. Then click the following symbol shape icon:

Note
The extension line running to the right is drawn only if you specify additional
symbol-related data.

2. Click a2 in the first column of the Compose Menu. Then click Ra 3.2 in the
associated submenu.

3. Click c in the first column of the Compose Menu. Then click 5 in the
associated submenu.

4. Click d in the first column of the Compose Menu. Then click = in the
associated submenu.

5. Click the following icon:

You do not need to specify any positioning options because you want to draw
the symbol in the default direction (from left to right).

6. Specify the positioning point (the foot point) for symbol ((A)) in your
drawing.

Symbol ((B))
Proceed as follows:

1. Load the smooth surface symbol.
2. Set d to EMPTY.
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3. Set a2 to Ra 0,8.
4. Remove the entry for c by specifying a blank in apostrophes: ' '
5. Specify Rz 2,5 (in apostrophes) for f1.
6. Position symbol ((B)) in your drawing.

Symbol ((C))
Proceed as follows:

1. Click the following icon:

Note
When you select a different symbol type, the existing settings are
preserved in the Compose menu. Therefore, any settings for a different
symbol type require explicit changes. To leave any symbol element blank,
you either specify a space character (in apostrophes) or you click BLANK.

2. Set d to EMPTY.
3. Specify Ra 100 for a2.
4. Specify grind for b.
5. Set e to 3.
6. Set f1 to Rz 25.
7. Position the symbol at a suitable point to the left of and below the area to

marked for grinding.
8. To select the begin point of the reference line, click on a point to the left of the

symbol foot point.
9. To select the flexion point of the reference line, click on a point close to a line

perpendicular to the area to be marked for grinding.
10. To select the begin point of the reference line arrow, click on a point on the

area to be marked for grinding.
11. Click CONFIRM.

Symbol ((D))
Proceed as follows:
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1. Load the milled surface symbol.
2. Set a1 to Ra 50.
3. Click on the "vertically upwards" positioning arrow icon to position symbol

((D)) in your drawing.

Welding Symbols

Note
The Surface Symbols and Welding Symbols menus are available in the
Classical User Interface of Creo Elements/Direct Drafting only. To run Creo
Elements/Direct Drafting with this user interface, set MEPELOOK to 1 in the
me10 startup file.

To display the Welding Symbols menu, click MENU 3 in the SYMBOLS menu.

Composing a Welding Symbol
To compose a welding symbol, click on the applicable field(s) in the first column
of the Compose Menu or select the associated items of the symbol (indicated
graphically in the menu).

Note
To familiarize yourself with the symbol composition method, load one of the
welding symbols supplied with Creo Elements/Direct Drafting and check the
resulting welding symbol in your drawing with its associated items in the
Compose menu.

Text
Click Text in the Welding Symbols menu to display the associated Text menu. You
can specify the individual text strings for your welding symbols either as default
strings in submenus, or you can specify text strings (in apostrophes).
Please note that the following applies to fillet weld offsets:

• Specify the following if you want the Z to cross the reference line:
\V

• If you do not want the Z to cross the reference line, specify the following:
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\v

Symbol Elements
The following welding symbol elements are provided to facilitate the creation of
welding symbols:

Item Description
Sy 1 Welding symbol
Sy 2 Welding symbol
Sy 3 Welding symbol
Sy 4 Supplementary symbol
Sy 5 Supplementary symbol
Ring Ring weld ("weld all around")
Assembly Assembly weld
Fork Fork
- - Relative position of the reference extension line. The

following options are available:

above: the reference extension line is located above the
reference line.
below: the reference extension line is located below the
reference line.
none: no reference extension line.

Positioning Welding Symbols
Proceed as follows to position a welding symbol:

1. Click the following icon:

2. Select the applicable positioning option.

Note
Unless you explicitly select a positioning option, the symbol will be drawn
from left to right. This default is associated with the following icon:
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3. Click a point in your drawing where you want to add the welding symbol.
4. Draw the reference line for your welding symbol. Follow the instructions in

the following section.

Menu 2
Menu 2 for welding symbols provides a number of functions similar to those for
surface symbols plus a number of welding-related functions.

Welds

This icon selects fillet weld symbols.

Use this function to indicated weld surfaces in your drawing.

Text Functions
Use the functions of this menu section to add text in the font size of the current
drawing. Click the applicable icon and then enter the text (in apostrophes) into the
user input line.

Adds text without a frame.

Adds text in a rectangular box.
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Adds text in a balloon.

Enables you to move text added by one
of these three text frame options.

Reference Line
This function enables you to manually create a reference line for the current
symbol.
The reference line always runs from the object to the symbol. Proceed as follows:

1. Click the following icon in Menu 2:

2. The begin point of the reference line is automatically attached to the symbol.
Click any points along the reference line as well as any bend points.

3. Click the end point of the reference line.
4. To complete the reference line, either:

• Double-click on its end point, or
• Click CONFIRM.

Note
If you want to break (interrupt) the reference line, click Free.
The Back option enables you to delete the last point on the reference line.

Stretching Symbols
Stretches symbols vertically.

Stretches symbols horizontally.
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Construction Lines
Creates a construction line at an angle.

Creates a horizontal construction line.

Creates a vertical construction line.

Setting Up Welding Symbols
The text, color, and reference line Setup options for welding symbols are similar
to those for surface symbols. See Setting Up Surface Symbols on page 308.

Weld
Menu Item Description
Color Click Color to display a submenu from which you can

select the color of fillet weld and weld surface symbols.
Optionally, you can specify RGB values.

Hatch Dist Click Hatch Dist to display a submenu from which you
can select the hatch distance for fillet weld symbols. If
you want to draw fillet weldÇ symbols "filled", set this
distance to 0.

Linetype Linetype for fillet welds and weld surfaces.

The "weld_sym" Symbol Set Supplied with Creo
Elements/Direct Drafting
The weld_sym symbol set supplied with Creo Elements/Direct Drafting includes
the following preconfigured welding symbols:

• V-U-weld

• V_back
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• fillet_back

• fillet_ring

Use Load to load this symbol set.

Illustrated Examples of Welding Symbols
To create your own symbols, either modify one of the preconfigured symbols
supplied with Creo Elements/Direct Drafting or create symbols "from scratch".
Both methods are illustrated in the following section.
In the following example, a number of welding symbols are added to a simple
sheet metal design.

Figure 179. Sheet Metal Design plus Welding Symbols
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The following exercise illustrated the procedure for creating the welding symbols
((A)), ((B)), ((C)), ((D)), ((E)), ((F)) and ((G)). This exercise assumes that the
Welding Symbols menu is displayed.

Symbol ((A))
Proceed as follows:

1. Load the kehl_gegen welding symbol.
2. Click the following icon:

3. Click the following positioning icon:

4. Click the positioning point for the symbol.
5. Click a point vertically above the symbol positioning point.
6. Click the reference line end point.

Symbol ((B))
1. Load the V_back welding symbol.
2. Position this welding symbol and its reference line in your drawing.

Symbol ((C))
1. In the SETUP menu for welding symbols, set the hatch distance to 0.
2. Display Menu 2 for welding symbols.
3. Click the following icon:

4. Specify the fillet weld width: 4
5. Click the vertex for the "left" leg of the fillet weld.
6. Click the first leg.
7. Click the second leg.
8. Repeat these four steps to define the "right" fillet weld.
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Symbol ((D))
1. Specify 3 for T 1.

Set Sy 2 to:

delta

2. Set R Sm to:

3. Set M Sm to:

4. Position this symbol and its reference line.

Note
The SETUP menu enables you to select defaults for the size of the symbol
elements.

Symbol ((E))
1. Load the zwr_pnt_n welding symbol.
2. Click Text.
3. Replace the entry for T 1 by: 5
4. Replace the entry for T 2 by:

10(30) \v (20)

5. Click the following positioning icon:
6. Click the positioning points for the symbol.
7. To define the reference line direction, click on a point horizontally above and

to the left of the symbol positioning points.

8. Click the reference line end point.
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Symbol ((F))
1. Click Menu 2 in Welding Symbols.
2. Click the following icon:

3. Click the begin point of the weld.
4. Specify the weld contour width: 5
5. Specify a weld contour spacing factor: 4
6. Click the end point of the weld.

Symbol ((G))
1. Specify 3 for T 1.
2. Set Sy 2 to:

delta

3. Set - - to above.
4. Position the symbol such that its reference line runs to the left.

Grouping
You can group annotations together. Groups on page 490 may consists of a single
dimension, multiple text elements and multiple symbols.
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This chapter shows how to use parts in your drawing.
The Parts menu contains the following items:

• Edit
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• New

• Create

• Gather

• Show

• Smash

• Share

• Unshare

• Symbol

• View

• Set Ref Point

• Scale

• Part List

• Spotlight
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Introduction to Parts
Parts are most useful in large complex drawings. Therefore, in your first few
weeks using ME10 you may not want to complicate the drawing process by using
parts. However, as you become a proficient user, you will begin to see how the use
of parts will simplify complex drawings and increase your productivity. Using
parts in a drawing is a matter of personal choice; different users will use a
different parts structure on the same drawing.
With these points in mind, now consider some ideas and definitions of parts.

What is a Part?
A part is a logical grouping of elements, for example, a group of elements that
make up a component in a sub-assembly.
A drawing created without the use of parts consists of a number of lines, circles,
arcs, pieces of text, and so on. Each line, circle, arc, and so on, is known as an
element.
If you use parts in a drawing, each part is a collection of elements. Thus, without
parts, a drawing consists of a collection of elements, but with parts a drawing
consists of several parts, each part being a collection of elements.

The Top Part
Remember that without parts a drawing is a collection of elements. You could also
say that a drawing without parts is in effect a drawing containing one part; the part
and the drawing are one and the same. Each part has a name (more details are
given later in this section), and the name of the part you are using is displayed in
the System Status Line. In a drawing without parts you will see the name
associated with the top part (default name Top) displayed in the System Status
Line; all the elements of the drawing are in this single part.
In an assembly drawing certain parts will contain drawing elements, a name, and
possible subparts. Other parts contain only a name and possible subparts, these
parts are used as pointers to assemblies.

Parts Structure Explained
A parts structure can be thought of as a family tree showing the hierarchical
relationships of all the parts. Because of this hierarchical nature, we talk about the
different levels of the structure. At the highest level a single part exists; this is the
Top part already discussed. For your first few drawings using parts, it is best to
use a parts structure with only one level; more experienced users will use a multi-
level structure. The two types of parts structure are shown below:
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Figure 180. Single-Level Parts Structure

Figure 181. Multi-Level Parts Structure

Hierarchical Parts Structure
The hierarchical structure of parts means that one part can own other parts. Refer
to the CYLINDER ASSEMBLY hierarchy shown in Figure 181. Multi-Level
Parts Structure on page 326. The parts structure is as follows:
PISTON ASSEMBLY can be thought of as the owner of PISTON, PISTON RING
# 1, PISTON RING # 2, and WRISTASSEMBLY.
We refer to the owning part (PISTON ASSEMBLY) as the parent and the owned
parts (PISTON, PISTON RING # 1, PISTON RING # 2, and WRIST
ASSEMBLY) as subparts.
Note that the hierarchical level of the current part is indicated through an integer
in the Status Line.

Note
This ownership mechanism implies that deleting a parent part will also result
in the deletion of all its subparts.
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Setting the Active Part
Except for a few special cases, all newly created elements (lines, arcs, text, and so
on) are placed in the active part. Also, most of the commands using the Select
menu (for example, Delete and Change) only operate on the active part. The Edit
command in the Parts menu allows you to set the active part. Thus by using the
Edit command to make different parts active, you can place elements in different
parts.

Note
The name of the active part is displayed in the System Status Line.

Rules for Part Names
Follow these rules when entering part names:

• Part names are limited to 255 characters in length.
• Any characters may be used in a part name with the exception of:

○ / (Only allowed as the name of the top part when not used together with
other characters.)

○ ~

○ . (Invalid part name when used alone, but may be used together with other
characters.)

Examples of impossible names are:

○ .

○ ..

○ /hello
○ hello~

Examples of possible names are:

○ hello
○ / (Can be used only for the top part.)

• Whenever possible, give your parts meaningful names. This will help
recognize the part.
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Note
ME10 can assign a default name to a part. The ME10 default name will be in
the series .1, .2 , .3 and so on. See Initiating a Part on page 335.

The Advantages of Parts
Using parts has the following advantages:

• You can arrange a complex drawing into a convenient logical structure.
• Modify, Delete and most of the commands using the Select menu can be used

on complete parts, thus you need only identify the part and not every element.
• Parts can be stored in or loaded from a file. This allows you to build up

libraries of standard parts.
• By making a master drawing into parts, two or more people can work on

individual parts of the master drawing. You can also quickly build up a final
master drawing.

• Special Parts commands (such as Symbol) allow you to create custom
symbols.

Creating an Assembly Drawing
To make full use of the ME10 parts functionality you should create and maintain a
parts and assemblies structure for your drawing files.
This approach to drawing facilitates the link between your ME10 design data and
a relational database management system.
The following example shows one way to create the assembly drawing WRIST
ASSEMBLY from the following component drawings:

• RETAINING CLIP # 1
• RETAINING CLIP #2
• WRIST PIN
Figure 182. WRISTASSEMBLY Structure on page 329 shows the WRIST
ASSEMBLY structure.
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Figure 182. WRISTASSEMBLY Structure

Initial Stages
For the purposes of this example, assume that each component drawing has not
yet been given a part name.

Note
Drawings have two names associated with them:

1. The drawing storefile name – indicated in lower case.
2. The drawing partname – indicated in CAPITALS.

First load each individual component drawing, give it a part name and set a
reference point to enable accurate positioning in the final assembly drawing.
Load the drawing file retain_clip1_d.mi.

1. Click Open in File.
2. Select retain_clip1_d.mi.

ME10 displays the drawing of RETAINING CLIP #1.

You must now set a reference point on the drawing to enable accurate
positioning in the final assembly drawing.

3. Click Set Ref Point in Parts.
4. Specify a reference point.

Delete all unnecessary construction lines.
5. Click Delete.
6. Click C-Geo and All in Select.

Give the drawing the part name you wish to see in the Part Browser.
7. Click Part Browser in Parts.
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8. In the Part Browser, click on the part you want to rename.
9. Press the right mouse button to display a popup menu.
10. Select Rename from the popup menu.
11. Replace the current part name by RETAINING CLIP # 1.

Store the new drawing (without construction lines).
12. Click Save in File.
13. Enter the new storefile name (for example retainclip1). Note that the mi

suffix is appended automatically.
14. Click Delete, All and Confirm.
15. Repeat these steps for the component drawings:

• retain_clip2_d.mi.
• wrist_pin_d.mi.

Creating WRISTASSEMBLY
Next create the assembly drawing WRISTASSEMBLY:

1. Switch on (tick) the Spotlight check box option in Parts. This command causes
the active part to have a normal appearance and all non-active parts to be
shown in magenta dotted lines.

Make sure that the ME10 top part is empty.
2. Click Edit in Parts.
3. Click Top in Edit.
4. Click Delete, All and Confirm.

Rename the top part with the assembly drawing name you wish to see in the
parts list.

5. Click Part Browser in Parts.
6. In the Part Browser, click on the Top part.
7. Press the right mouse button to display a popup menu.
8. Select Rename from the popup menu.
9. Replace the current name of the Top part to WRISTASSEMBLY.

The name of the active part in the status line changes to WRISTASSEMBLY.
Note that this part contains only the assembly name WRISTASSEMBLY but
no drawing elements.

Now load the first part of the assembly, for example the wrist pin.
10. Click Open in File.
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11. Select or specify the filename of the drawing to be loaded: wristpin.

ME10 asks you to indicate a reference point to position the drawing.
12. Specify a reference point.
13. Repeat steps 3 to 6 for the drawings:

• retainclip1.mi
• retainclip2.mi

14. Store the final assembly drawing as wrist_assy.

Creating Further Assemblies
The next stage in your assembly would be to create the PISTON ASSEMBLY
drawing. The procedure is the same as previously described:

1. Create an empty top part in ME10.
2. Rename the top part PISTON ASSEMBLY.
3. Construct PISTON ASSEMBLY from the following parts:

• PISTON RING # 1 — a single component part.
• PISTON RING # 2 — a single component part.
• WRISTASSEMBLY— an assembly.
• PISTON — a single component part.

Creating a Final Engine Assembly Drawing
The ultimate industrial requirement would normally involve the creation of
several assembly and sub-assembly drawings. In the case of our example, the
following drawings would be incorporated into a final assembly drawing at the
highest level of detail, for example ENGINE ASSEMBLY:

• CRANKCASE ASSEMBLY
• CRANK ASSEMBLY
• HEAD ASSEMBLY
• CYLINDER ASSEMBLY (which contains the PISTON and WRIST

assemblies)
Figure 183. Completed Cylinder Assembly Drawing on page 332 shows how the
completed cylinder assembly drawing might appear:
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Figure 183. Completed Cylinder Assembly Drawing

Deleting Parts
Consider the CYLINDER ASSEMBLY hierarchy with PISTON ASSEMBLY
active. Figure 184. Deleting Parts on page 332 shows three examples of the
deletion mechanism. The star shows the active part; the D shows that an element
in the part was identified for deletion.

Figure 184. Deleting Parts

Note that in the third case:
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• The entire WRISTASSEMBLY would be deleted if any element of RETAIN
CLIP 1, RETAIN CLIP 2, or WRIST PIN were identified.

• If WRISTASSEMBLY was made active and an element in RETAIN CLIP # 1
identified for deletion, only RETAIN CLIP # 1 would be deleted.

Note
You cannot delete the current active part or the Top part. A link is always
maintained to the Top part.

To delete parts:

1. Click Edit in Parts.
2. Click Part in Edit.
3. In the parts hierarchy, select the appropriate part you want to make active.

Note that selection of the active part will control what is actually deleted.
4. Click Delete.
5. Click the part(s) you wish to delete.

Modifying Parts
Use the Modify menu to modify your parts.
Consider the CYLINDER ASSEMBLY hierarchy again. Suppose you wish to
move the entire piston assembly, that is the piston, rings, wrist pin, and so on. The
simplest way to identify all these is to first set a part above PISTON ASSEMBLY
active, in this case CYLINDER ASSEMBLY:

1. Click Edit in Parts.
2. Click Part in Edit.
3. Select the CYLINDER ASSEMBLY.

With CYLINDER ASSEMBLYactive, you only have to identify an element in
PISTON ASSEMBLY. ME10 will accept the assembly and all its subparts.

4. Complete the required move commands in Modify.

Note
To modify parts or elements above the active part you must click Global in
Select.
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Editing Parts
This section shows how to set a part as active so that you can then change it. All
new drawing elements created from then on belong to the active part.
Similarly, whichever part is active affects the results of the Modify and Delete
commands. If you have the Spotlight turned on (refer to Spotlighting Parts on page
354), the active part is shown in normal linetypes and colors, while all other parts
are shown in magenta dotted lines. The name of the active part is displayed in the
System Status Line.
The three Edit options are:

• Part

• Top

• Parent

Editing a Part
This is the default option.
To edit a part (make a part active):

1. Click Edit in Parts.
2. Click Part in Edit.

ME10 will prompt for the name of a part.
3. Enter the name of a part, or select an element of the part in any viewport.

ME10 then sets the named, or selected, part as the active part.

Editing Top
To edit the top part (set the highest part of the parts structure as the active part):

1. Click Edit in Parts.
2. Click Top in Edit.

ME10 sets the Top part as the active part.

Editing the Parent
You can move the active part status to the parent of the currently active part. In
relation to a given part, the parent is always one level higher in the parts structure.
To edit the parent part:

1. Click Edit in Parts.
2. Click Parent in Edit.
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ME10 sets the parent of the currently active part as the active part.

Initiating a New Empty Part
This section shows how to create a new empty part. The active-part status will be
altered after the command has been executed so that the new part is active. The
New command options are:

• Part

• Subpart

Initiating a Part
This is the default option. Create a new empty part under the Top part and make
this new part the active part so you are ready to draw in it.

Note
It is not necessary to make the Top part active before you use the Part option.
Every new part you create is automatically positioned immediately below the
Top part.

To create a new empty part immediately below Top:

1. Click New in Parts.
2. Click Part in New.
3. Enter a name for the new part or allow ME10 to assign a default name.

If you wish ME10 to assign a default name to the new part, click End. ME10
will generate a default name based on incremental numbers (.1, .2, .3 and so
forth).

ME10 creates the new empty part below the Top part and sets it as the active
part. You can now begin adding drawing lines, text, and so on to the part.

4. Place at least one element (or subpart) in the new part otherwise it will be
deleted when you change the active part status.

Initiating a Subpart
You can create a new empty part under the active part and set the new part as the
active part so you are ready to draw in it. This means that a subpart can be created
below an existing part, or below an existing subpart.
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Before clicking Subpart, make sure you have the correct part active as the new
part will belong to it and be one level below.
To create a new empty subpart:

1. Click New in Parts.
2. Click Subpart in New.
3. Enter a name for the new subpart.

ME10 creates the new empty part and sets it as the active part. You can now
begin adding drawing lines, text, and so on, to the part.

Place at least one element in the new part, otherwise it will be deleted when
you change the active part status.

Creating Parts
This section shows how to make a new part from existing elements in the active
part. The active part status will be unaffected after the command has been
executed.
The two Create options are:

• Subpart

• Detail

Creating a Subpart
This is the default option. You can create a new part by transferring elements from
the active part into the newly created one. The new part will be placed below the
active part.
Before selecting the command make sure you have the correct part active as the
new part will belong to it and be one level below.
To create a subpart:

1. Click Create in Parts.
2. Click Subpart in Create.
3. Enter the name for the new part.

Having entered the part name, select the elements in the active part you wish
to transfer to the new one.
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Note
If you incorrectly select an element for transfer, click Undo to cancel the
transfer.

4. When you have selected all of the elements you want to include in the subpart,
click End (or any other command except Cancel) to complete the command.

ME10 transfers all the selected elements to the new part.

Creating Detail Drawings
You can create detail drawings in your drawing. Each detail is a magnified copy of
an area of the active part.

Note
Dimensions are not affected by the magnifying factor; thus the dimensions on
your detail will agree with the part from which it was taken.

Figure 185. Creating a Detail Part on page 337 shows how to create a detail
drawing within your main drawing:

Figure 185. Creating a Detail Part
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Finish drawing the part to be detailed and make it the active part.
This technique of finishing the part before creating a detail differs from traditional
drafting methods. However, using View functions, you can just as easily draw
intricate features on the main drawing as on the detail drawing.
The Detail option is used to produce a magnified copy for dimensioning purposes.
To produce a detail drawing:

1. Click Create in Parts.
2. Click Detail in Create.
3. Enter the required magnifying factor for the detail.
4. Box the area of the active part from which you wish to form the detail. The

edges of the box will determine where elements are cut, so specify the corners
carefully (in the detail drawing, the dashed lines indicate where the box was
placed).

5. Specify a reference point for the copy operation, then specify the desired
location for the reference point.

ME10 now creates the detail part.

Notes on Detail Parts
• The detail part is automatically placed in level 1 of the parts structure (that is,

below the Top part).
• The detail part is assigned the next default name generated by ME10 in the

sequence .1,.2,.3, and so on. (Note that a postfix [shared #1] [detail] is
displayed in the parts tree; this is for information only and is not part of the
name).

• The detail part will be a unique shared part (refer to Sharing Parts on page
323). However, it is not shared with the part from which it was detailed. Thus,
if you modify the original part, its detail will not be changed automatically.

Note
To dimension a detail part you must make it the active part.

Gathering Elements Into Other Parts
During the drawing process, it may prove useful to transfer the ownership of
existing elements in a part to the active part. Click Element in Gather to transfer
elements.
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If you click the Keep Scale check box in Element, the element is moved or copied
to the active part, and it is drawn to the scale of the active part.

Note
• If the element to be transferred is the master element of a group, the group

is ungrouped before gathering.
• If the element to be transferred is a normal element of a group, the element

is removed from the group before gathering.

Delete Old
The old element is deleted and the transferred elements only exist in the active
part.

Note
• Take care to identify the correct elements as mistakes can only be rectified

by changing the active part and gathering the element back.
• Switch on the Spotlight check box option to see the changes made in your

drawing.

To transfer elements from one part to the active part:

1. Click Gather in Parts.
2. Click Element in Gather.
3. Click Delete Old in Element.
4. Select the elements (in non-active parts) that you wish to transfer to the active

part.

As you select each element, it will be deleted from its original part and it
appears in the active part.

Copy
The elements indicated will be duplicated in the active part.
To copy elements from any part to the active part:

1. Switch on the Spotlight check box option in Parts.
2. Click Gather in Parts.
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3. Click Element in Gather.
4. Click Copy in Element.
5. Select an element (in any non-active part) that you wish to copy to the active

part.
6. Specify a reference point for the copy operation.
7. Specify the desired location for the reference point.

Example
Refer to Figure 186. Including Elements on page 340. You have incorrectly added
drawing elements to PISTON RING # 1. Use Element in Gather to transfer these
elements to RETAINING CLIP # 1.

Figure 186. Including Elements

To transfer elements from PISTON RING # 1 to RETAINING CLIP # 1:

1. Click Edit in Parts.
2. Click Part in Edit.
3. Click RETAINING CLIP # 1.

ME10 makes RETAINING CLIP # 1 the active part.
4. Click Element in Gather.
5. Click Delete Old in Element.
6. Select elements in PISTON RING # 1 you wish to transfer to the active part.

As you select each element, it will be deleted from its original part and appear
in the active part.
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Including Dimensions in Other Parts
This section shows how to transfer the ownership of existing dimensions.
The Gather ▶ Dimension options are:

• Move

• Move All Below

• Move All Above

Move
If the reference geometry of the selected dimension is in or below the active part
then the selected dimension is moved to the active part.

Move All Below
All dimensions in parts hierarchically below the active part are moved to the
active part.

Move All Above
All dimensions in parts hierarchically above the active part with reference
geometry in or below the active part are moved to the active part.

Including Parts into Other Parts
This section shows how to transfer the ownership of existing parts to the active
part. The gathered part belongs to the active part and it is placed one level below
the active part in the parts structure.

Note
• If the part to be transferred is the master element of a group, the group is

ungrouped before gathering.
• If the part to be transferred is a normal element of a group, the part is

removed from the group before gathering.

The Gather ▶ Part options are:

• Move

• Copy
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Move
This is the default option.
To transfer the ownership of a part to the active part:

1. Click Gather in Parts.
2. Click Part in Gather.
3. Click Move in Part.
4. Select the part to be gathered or enter its name. You cannot gather a part from

above the level of the active part.

ME10 then transfers the part to the ownership of the active part and deletes the
original.

Copy
To copy a part to the active part:

1. Click Gather in Parts.
2. Click Part in Gather.
3. Click Copy in Part.
4. Select the part to be included or enter its name.
5. Specify a reference point for the copy operation.
6. Specify the location for the reference point.

ME10 copies the part such that the new part is owned by the active part.

Example
Refer to Figure 187. Including a Part on page 343. You have incorrectly created
the part RETAINING CLIP # 1 as a subpart of PISTON ASSEMBLY. Use Part in
Include to transfer RETAINING CLIP # 1 to its correct position as a subpart of
WRISTASSEMBLY.
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Figure 187. Including a Part

To transfer RETAINING CLIP # 1 to its correct position as a subpart of WRIST
ASSEMBLY:

1. Click Edit in Parts.
2. Click Part in Edit.
3. Click WRISTASSEMBLY.

ME10 makes WRISTASSEMBLY the active part.
4. Click Move in Part.
5. Click RETAINING CLIP # 1.

ME10 transfers the part so that it becomes a subpart of WRISTASSEMBLY.

Showing Parts
This section shows how to examine a selected groups of parts. Those you do not
want to see are replaced by representative boxes. This can be useful where parts
overlap.
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The three Show options are:

• Part

• Part Boxed

• All

Part
This is the default option. You can either restore a part presently represented by a
box, or look at certain levels in the parts structure.
If you want to restore a boxed part:

1. Click Show in Part.
2. Click Part in Show.
3. Click the part.

ME10 will redraw it normally.
However, if you wish to look down to a certain parts level and no further:

1. Enter the level number.
2. Press [Enter].

ME10 redraws the chosen viewport with all parts in the entered level and
below shown as boxes.

For example, if you enter 3 , the chosen viewport will be redrawn to show all
parts in levels 1 and 2 with those in lower levels indicated by boxes. If a boxed
part belongs directly to the active part, this is indicated by a yellow box.

Part Boxed
You can change a part and all its subparts to a box representation in the chosen
viewport. The box will enclose all elements of the part.

1. Click Show in Part.
2. Click Part Boxed in Show.
3. Identify the part to be boxed or enter its name.

ME10 will redraw the chosen viewport with the desired part shown as a box.

All
You can restore all parts in the chosen viewport to their normal appearance:

1. Click Show in Part.
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2. Click All in Show.

ME10 immediately redraws the chosen viewport with all parts visible.

Hiding Parts
You can hide specific parts or all parts in your drawing.

Part
To hide a specific part in your drawing:

1. Click Parts ▶ Hide ▶ Part.
2. Click the part.

All
To hide all parts in your drawing:

1. Click Parts ▶ Hide ▶ All.
You can use the Show command to unhide any or all parts.

Smashing Subparts
When you smash a subpart, the elements that comprise the identified part will be
merged into the active part and the subpart will no longer exist.
To merge a subpart into the active part:

1. Make sure that the correct part is active.
2. Click Smash in Parts.
3. Click the required Smash option:

Move The subpart is merged with the active part.
Move KeepData The subpart is merged with the active part, and it is

drawn to the scale of the top part (scaling is
maintained – drawing A).

Move Keep Display The subpart is merged with the active part, and it is
brought into the top part as it is displayed on the
screen (scaling may be lost) – drawing B.

4. Select the part to be smashed or enter the part name. The part to be smashed
must belong to the active part.
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ME10 will now transfer the elements of the identified part to the active part
and delete the subpart.

Example
Refer to Figure 188. Smashing Parts on page 346. You want to make a single part
drawing (WRIST UNIT) from the assembly drawing WRISTASSEMBLY.

Figure 188. Smashing Parts

To create WRIST UNIT from WRISTASSEMBLY:

1. Click Edit in Parts.
2. Click Part in Edit.
3. Click WRISTASSEMBLY.

ME10 makes WRISTASSEMBLY the active part.
4. Click Smash in Parts.
5. Click RETAINING CLIP # 1, RETAINING CLIP # 2 and WRIST PIN.
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ME10 transfers all drawing elements to the active part and then deletes the
subparts.

6. In the Part Browser, press the right mouse button, select Rename and rename
the part to WRIST UNIT.

Figure 189. Effects of Smashing Scaled Parts

Note
• If the part to be selected is the master element of a group, the group is

ungrouped before smashing.
• If the part to be selected is a normal element of a group, the part is

removed from the group before smashing.

Sharing Parts
This section shows how to make a shared part. Shared parts are useful if you
require a particular part to appear several times in a drawing.
Examples of parts suitable for sharing are nuts, bolts, rivets, and other standard
parts.
The geometry of a shared part always remains the same as the original part.
However, the location of each shared part can be different and the overall size of
each shared part can be altered by using the Scale command.
You can also determine the plane in which the shared part lies by using the
Isometric command from the Modify menu. If you place a shared part in a different
plane, make it active and then turn on the Ruler or Grid, so that they will also be
displayed in the same plane.
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The advantages of shared parts:

• Although you have several copies of the shared part displayed on your
drawing, in memory you have only one. This saves you memory and allows
you to carry out certain commands faster.

• If you change any geometry of a shared part, the changes will automatically
appear in all other occurrences of that shared part in their respective planes.
For example, if you add a horizontal line to a shared part, it will be displayed
on the respective horizontal axis of each occurrence of that shared part.

To share a part:

1. Click Share in Parts.
2. Select the part to be shared.
The part must be non-active and may not be at a level above the active part or at
the same level. In the Share column of the Part Browser, a shared part is identified
by one or multiple hash characters followed by the appropriate number (such as:
#3).

Copying Shared Parts
To create copies of a shared part:

1. Click Modify.
2. Click Move in Modify.
3. Click Multiple in Move.
4. Select the shared part to be copied.
5. Specify a reference point for the move.
6. Specify the destination point for the move.
The following naming conventions apply to copies of shared parts:

• When you copy a shared part as described above, note that each copy will
reflect the name of the original shared part. Each of these copies automatically
receives a unique identifier. For example, when you copy a shared part named
rim3, its copies will also be named rim3; however, each of these copies will
have its own unique identifier. (~2, ~3, etc).

The following example shows the parts structure of an assembly containing a
shared part named RIM and a copy of this shared part.
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Uniq Share Scale Symbol
WHEEL
ASSEMBLY

~1 1:1

RIM ~2 #3 1:1
RIM ~3 #3 1:1

• When you copy a shared part which owns another shared part (i.e. a shared
subpart of a shared part), the copies of these shared subparts retain the same
common name and identifier. However, each of the "owning" shared parts has
its own unique identifier.

The following example shows the parts structure of an assembly containing a
shared part named RIM which in turn owns a shared part named LINER.

Uniq Share Scale Symbol
WHEEL
ASSEMBLY

~1 1:1

RIM ~2 #3 1:1
LINER ~3 ##4 1:1

When you copy the RIM, the resulting parts structure will look like this:

Uniq Share Scale Symbol
WHEEL
ASSEMBLY

~1 1:1

RIM ~4 #3 1:1
LINER ~3 ##4 1:1
RIM ~2 #3 1:1
LINER ~3 ##4 1:1

Refer to Unique Partnames on page 357 for further information.

Note
Any changes made to a shared part will automatically appear in all other
occurrences of that shared part.

You cannot share a part above the active part or at the same level. Therefore
you cannot share the Top Part.

All subparts of a shared part have their status set to shared.

When you rename a shared part, all occurrences of that shared part will be
given the new name.
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Unsharing Parts
This section shows how to change a shared part back into a normal part.
This can be useful if you want to alter one occurrence of your shared part in
isolation, as otherwise all occurrences will be altered simultaneously.

Note
You cannot unshare a part above the active part or at the same level.

To unshare a part:

1. Click Unshare in Parts.
2. Select the part to be unshared. The active status does not affect the command

except that the part you wish to unshare cannot be active.

ME10 alters the parts structure so that the identified part is a normal part
positioned alongside the shared parts and with the same parent. All other
occurrences of the shared part stay shared.

Part Browser
To display the Part Browser, click Part Browser in Parts. To perform an action on
a given part, click on that part in the Part Browser, then press the right mouse
button to display a popup menu, and select an option from this menu. Note that
the Part Browser can be docked anywhere in the ME10 window.

What is Shown in the Part Browser?
The Part Browser provides a graphical overview of the current parts structure in
your ME10 drawing.

• Starting at the top part, this tree-like structure includes a separate branch for
each part. Subparts of a part are shown as sub-branches of that part.

• Click on the + (plus) sign icon to expand the tree.
• Click on the - (minus) sign icon to collapse the tree.
• Tick the (checkbox-like) state icon to the left of any part icon to view the

associated part (and any parts hierarchically below this part).
• Untick the (checkbox-like) state icon to the left of any part icon to hide the

associated part (and any parts hierarchically below this part).
The individual columns of the Part Browser provide the following information:
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Column Description
Name Specifies the name of the part. The following icons are used to

indicate the nature of the part:

The currently active part. Note that the
currently active part is represented by a
red icon.
Normal part or assembly. Any non-active
parts and/or parts hierarchically below the
active part are indicated by a green icon.
Shared part.

Detail.

The associated part is hidden. This is
because you have applied the View
command to another part.

Unique Specifies a unique sequential number associated with the part.
Share A "hash" (#) character in this colums indicates that the part is

shared.
Scale Indicates the drawing scale of the part.
Symbol A small "x" indicates that the part is symbolic.

The Part Browser Tree Popup Menu
To display the Part Browser tree popup menu, press the right mouse button on any
part icon in the Part Browser. This popup menu provides the following commands
(some of which are also available via the Parts menu):
View Shows only the selected part. ME10 fits this part into the

current viewport. All other parts are hidden, and their icons
are marked by a yellow X (see list of Part Browser icons
above).

Rename Enables you to change the name of the selected part.
Smash Smashes a subpart. See Smashing Subparts on page 345 for

further information.
Share Creates a shared part. See Sharing Parts on page 347 for

further information.
UnShare Unshares the selected (shared) part. See Unsharing Parts on

page 350 for further information.
Symbol Changes the part to a symbol. See Changing Parts into

Symbols on page 354 for further information.
Show In addition to the options explained in Showing Parts on page
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343, this command provides the ShowFlat option which
shows the selected part but not its subparts (if any).

Hide In addition to the options explained in Hiding Parts on page
345, this command provides the HideFlat option which hides
the selected part but not its subparts (if any).

Options The Icons option enables you to display the Part Browser
with or without icons. The State Icons option enables you to
show or hide the (checkbox-like) state icons that indicate
whether or not a part is visible.

Save You can click Save to save an ASCII representation of the
current parts tree structure in an ME10 list file.

Delete Deletes the selected part.

Changing the Ownership of Parts
The Part Browser provides drag-and-drop functionality to facilitate changes in
part ownership. For example, if you want a subpart to be owned by another part,
simply drag the subpart away from its present owner part and drag it to the new
owner part.

Renaming a Part in the Part Browser
To rename a part:

1. In the Part Browser, click on the part you want to rename.
2. Press the right mouse button to display a popup menu.
3. Select Rename from the popup menu.
4. Replace the current part name by the new name.

Note
When you rename a shared part, all occurrences of that shared part will be
given the new name.

Viewing Parts
This section shows how to view individual parts of your drawing.
You can only view drawings in the current viewport.
Use viewing in the following cases:
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• During the design stage if parts overlap one another in a confusing way.
• To quickly inspect a finished part and check that it is complete.
• To reduce redraw time by viewing only the part(s) you are currently working

on.
The three View options are:

• Part

• Parent

• Top

Part
To look at an individual part:

1. Click View in Parts.
2. Click Part in View.
3. Enter the name of the part to be viewed, or click an element of the part in any

viewport.

ME10 then redraws the chosen viewport containing only the desired part and
any subparts belonging to it. The name of the part being viewed will be
displayed in the top left corner of the viewport.

Parent
You can view the parent of the presently viewed part. Parent allows you to view
the next level up in the parts hierarchy:

1. Click View in Parts.
2. Click Parent in View.

The current viewport will be redrawn displaying the parent of the active part
and all parts belonging to the active part.

Top
You can view your complete drawing in the current viewport.
This is useful if you have been viewing a lower level and want to quickly restore
the complete drawing to the viewport:

1. Click View in Parts.
2. Click Top in View.
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The chosen viewport will be redrawn to show all the parts of your drawing.
The name of the top part will be displayed in the top left corner of the
viewport.

Spotlighting Parts
Spotlighting allows you to distinguish between the active part and all other parts.
The function works as an on/off switch. We recommend you switch on Spotlight
(by ticking its check box) box when you are creating and modifying parts.

1. Switch off the Spotlight check box option in Parts.

All parts appear in their normal linetype and color, this makes it difficult to
distinguish between the active part and all other parts.

2. Alternatively, switch on the Spotlight check box option in Parts.

Only the active part has its normal appearance. All non-active parts are shown
in magenta dotted lines.

Changing Parts into Symbols
This section shows how to change existing parts into symbols.
The only difference between a symbol and a normal part is that a symbol's size
relative to the plotter paper does not change if you alter the draw scale (refer to
Preparing the Drawing Environment on page 25).
An example of a symbol part could be a border to fit a particular paper size or any
standard symbol. Once you've made a symbol part, it is best to store it so that it is
ready to be loaded whenever you require it.
To make a symbol part:

1. Create the required shape as a part. This is best done with the draw scale set to
1.

2. When the part is finished, click Symbol in Parts, then click On in Symbol.
3. Select the part or enter its name.

ME10 now defines the part as a symbol part. Check this by viewing the Part
Browser. clicking Part List. You will see a small "x" in the Symbol column.

You can also change a symbol part back into a normal part:

1. Click Symbol in Parts.
2. Click Off in Symbol.
3. Select the symbol part or enter its name.

ME10 will now change the symbol part back into a normal part.
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Setting the Part Reference Point
This section shows how to set a reference point in the active part.
The reference point is used:

• To locate other parts when loading from files.
• For symbols.
• For some Include commands.
The ME10 default reference point is the lower left corner of an imaginary box
placed around the elements of the part.
To set a reference point:

1. Click Set Ref Point in Parts.

The present reference point for the active part will be shown by a line joined
to the cursor.

2. Specify the new reference point.

Multiple Drawing Scales
ME10 supports multiple drawing scales on one drawing. This lets you place small
and large parts on the same drawing for manufacturing and documentation
purposes.
The scale associated with a part can be seen in the parts tree. To change the
drawing scale:

1. Create a top part and a subpart.

2. Look at the Part Browser. It should look similar to the following:
Top ~1 1:1

SUBPART ~2 1:1

3. Click Scale in Parts.
4. Click Prt + Subprt in Scale.
5. Select the top part (both parts are highlighted).
6. Enter 2.

ME10 scales both the top part and subpart by the scaling factor 2.
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Now look at the parts tree again to see how the scaling factors change:
Top ~1 2:1
SUBPART ~2 2:1

1. Click Scale in Parts.
2. Click Prt Only in Scale.
3. Select the subpart (it does not need to be active).
4. Enter 3.

ME10 scales the subpart only.

Now look at the parts tree again to see how the scaling factors change:
Top ~1 2:1
SUBPART ~2 3:1

Notice that the subpart is scaled according to its original value. In others words, it
is scaled by a factor 3 — not 2 and then 3.
Text, dimensioning text, and symbols are not changed.
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Scaling Parts about a Reference Point
The Set Ref Point option of the Scale command in Parts scales parts and subparts
about one of the following:

• Ref Pnt

• Origin

• Center

Unique Partnames
ME10 automatically generates names for parts when you create them. These
names are shown in the parts tree and are represented by numbers: ~1,~2, ...
This feature is useful when handling parts by macros. For example, a typical parts
tree may look like this:

Unique parts naming has the following functionality:

• Each part is specified by a number.
• Shared parts within shared parts are identified with the same unique partname

because they exist once only in the data structure.

Shared parts within shared parts are marked with [shared in shared #n]
• Parts can be made active by entering EDIT-PART followed by the name of

the part. Two examples are provided below.
EDIT_PART 'bracket'
EDIT_PART '~2'

If you enter EDIT_PART and the parts structure has more than one part with
the same partname, ME10 prompts you to specify the part number.

With INQ 900 and INQ 901, you get a string list of unique partnames (~2, ~3).
• INQ_ENV 8 INQ 5 for inquiry of the offset. For loading several drawings, the

maximum used unique partname can be inquired (useful when running
macros).

• You can click Delete, All and Confirm to reset the parts numbering.
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• Refreshing partnames can be done by entering the command:
RESET_PART_NUMBER

Further Information
For further technical information about parts, the parts structure and so on, refer to
the ME10 help system:
Enter help parts at the ME10 command line.
The screen will clear and ME10 will display further information about parts.
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Introduction to Hidden Lines
The 2D hidden line module is used during the creation of an assembly drawing to
automatically generate lines that indicate hidden drawing features. In an assembly
drawing, these lines are normally shown dashed.
To create an assembly drawing that includes hidden lines, you must:

• Load parts.
• Generate faces (without faces you cannot generate hidden lines).
• Assign each face a logical level in the z direction (a z-value).
• Use the z-value information to generate the appropriate hidden lines.
During the drawing process you can selectively view faces for clarity (ensure that
each face is correctly positioned in relation to the others).
Use one of the following methods to redraw your assembly drawing with hidden
lines:

• Click Hidden Mode and On— this mode effectively redraws your assembly
drawing, hiding any hidden lines and faces.

• Click Hidden Mode and Off— this is the normal Creo Elements/Direct
Drafting redraw mode.

On completion of your assembly drawing you can generate hidden lines in the
dashed linetype (default).

Caution
Click Backup in Change to Hidden to store your assembly drawing (in
workfile.hid) before generating hidden lines. The Change to Hidden
command smashes the parts structure and creates the hidden line geometry.

Two tutorial examples have been included:

• A simple example using a Frame Assembly will clarify the general procedure.
• A realistic example creates a component assembly drawing (CRANK_

ASSEMBLY).

What are Faces?
Faces can be thought of as freely definable, infinitely thin, shaped areas that form
part of an assembly. Faces can partially obscure or completely cover other faces
(depending upon their z-values). You can delete any covering face by clicking
Delete Face in Edit and then clicking the face. Note that the face to be deleted must
be in the active part.
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In simple terms, you could imagine faces as pieces of paper, laid one on top of
another, thus obscuring elements with a lower z-value.
Figure 194. Faces — With Z-Values 0 and 1 on page 361 shows the faces of two
components (one with z-value 0 and the other with z-value 1).

Figure 194. Faces —With Z-Values 0 and 1

Note
A face does not necessarily need to have the same z-value as its boundary
lines. In this case the boundary lines of the face may be partially covered by
the face itself (solid lines may appear dashed in some cases). Note, the
linetype of the boundary lines is not changed.

Faces are defined in one of the following ways:

• Automatic face search for an entire part (Creo Elements/Direct Drafting tries
to find a maximum number of faces contained within a part. All faces are
assigned the same z-value).

• Automatic face search for an entire part (with hole recognition).
• Automatic face search by clicking (similar to automatic hatching).
• Manual face specification (similar to manual hatching).

What are Z-Values?
A z-value is the numerical value assigned to an element to position it in the
drawing at the appropriate logical level in the z-direction.
Newly created elements are assigned the current z-value. The current z-value is
always displayed in the System Status Line.
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See Figure 195. Visualizing Z-Values on page 362.

Figure 195. Visualizing Z-Values

For example, three faces could be given the z-values 0, 1, 2. The face with z-value
1 would be positioned above that with z-value 0. The face with z-value 2 would be
positioned above those with z-values 1 and 0. Depending on where these faces
were positioned with respect to each other, certain areas would be obscured.
Figure 196. Z-Values 0, 1 and 2 on page 362 shows 3 faces assigned the z-values
0, 1 and 2.

Figure 196. Z-Values 0, 1 and 2

Hatches are treated as faces. This means hatched areas can cover geometry and
faces. Hatches that are partially covered are displayed partially obscured.
Construction geometry, texts, leader lines and dimensions are always visible.
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Parts cannot be given a z-value, with the exception of shared parts (see Z-Values
and Shared Parts on page 363).
You can specify z-values in three ways:

• Automatically — if you have clicked Hidden and thus loaded the hidden line
module. Future elements you create are assigned the current z-value.

• By defining "element-to-element" relations (Above, Below, Same, Between,
None).

• By entering a z-value (real number) for the specified elements.
Elements and geometry without a z-value are automatically positioned below the
element(s) with the lowest z-value. Construction geometry, text, dimensions and
leader lines are always at the top.
Figure 197. Z-Value Structure within a Drawing on page 363 shows how the z-
value structure relates to your drawing:

Figure 197. Z-Value Structure within a Drawing

Z-Values and Shared Parts
You can assign z-values to shared parts to enable them to be placed on different
logical levels.
The z-values of elements within a shared part are calculated as the sum of their
own z-value and the z-values of all their shared parent parts.

Hidden Line Modes
The two hidden line modes are:

• View Mode — produces a hidden line display, does not compute hidden lines,
does not change geometry.
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• Hidden Line Generation Mode — used to finish the assembly drawing before
plotting, changes geometry.

View Mode
This mode produces a hidden line display of the assembly on the screen without
computing the hidden lines. It does not change the geometry or the parts structure.
Therefore you can assign z-values to elements during construction. Changes in z-
value are possible at any time and are displayed immediately.

Generation Mode
Hidden Line Generation Mode is used to finish an assembly drawing before
plotting.
In contrast to the view mode, geometry is modified:

• Elements are split.
• Shared parts will be unshared.
• The parts structure is completely smashed.
The hidden lines can be switched on and off by clicking Hidden Mode ▶ On or
Hidden Mode ▶ Off in Hidden.

Hidden Line — Tutorial Example 1
This tutorial shows how to make a simple assembly drawing (Frame_Assy) and
use it to create:

• An assembly view with the hidden lines to be generated as yet invisible (View
Mode).

• An assembly view showing dashed hidden lines (Generation Mode).

Creating Frame Assembly
First create the assembly drawing Frame Assembly by creating two parts, Frame 1
and Frame 2.

Initial Steps
1. Click Delete ▶ All ▶ Confirm to clear the screen.
2. In the Part Browser, click on the Top part, press the right mouse button, select

Rename and rename the top part to:
Frame Assembly
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Drawing Frame 1
1. Click New in Part.
2. Click Part in New.
3. Enter `Frame 1' as the part name.
4. Click Generate Element in Hidden.
5. Click Current Z Value in Generate Element and enter 1
6. Click Line in Geometry.
7. Click Rectangle in Line.
8. Draw two rectangles as shown in Figure 198. Frame 1 on page 365.

Figure 198. Frame 1

Generating Face 1
1. Click Generate Face in Hidden.
2. Click Single Automatic in Generate Face.
3. Click Face 1 (see Figure 198. Frame 1 on page 365).

Creo Elements/Direct Drafting creates Face 1.
4. Click End.

Drawing Frame 2
1. Click New in Part.
2. Click Part in New.
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3. Enter `Frame 2' as the part name.
4. Click Generate Element in Hidden.
5. Click Current Z Value in Generate Element and enter 2
6. Click Line in Geometry.
7. Click Rectangle in Line.
8. Draw two more rectangles as shown in Figure 199. Frame 1 and Frame 2 on

page 366.

Figure 199. Frame 1 and Frame 2

Generating Face 2
1. Click Generate Face in Hidden.
2. Click Single Automatic in Generate Face.
3. Click Face 2.
4. Click End.

Positioning Frame 2 Above Frame 1
1. Switch off Keep in Modify.
2. Select Frame 2 by enclosing it in a box.
3. Click 2 Points in Move.
4. Specify a reference point for the move.
5. Reposition Frame 2 above Frame 1 as shown in Figure 200. Frame 2 Above

Frame 1 on page 367.
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Figure 200. Frame 2 Above Frame 1

Assembly — Hidden Lines Invisible
You can display your assembly drawing so that the lines that will be generated as
hidden are removed from the view. This is useful as a check to see exactly which
lines in your assembly will be generated as hidden lines.

1. Click Hidden Mode On in Hidden.
2. Click the current viewport.

To confirm hidden mode, Creo Elements/Direct Drafting displays -H- in the
top left hand corner of the viewport (after the part name of the viewport top
part).

Creo Elements/Direct Drafting redraws the assembly. The hidden lines are
now invisible. See Figure 201. Assembly View with Hidden Lines Invisible on
page 367.

Figure 201. Assembly View with Hidden Lines Invisible
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Assembly — Hidden Lines Shown Dashed
At this point you will generate the actual hidden lines.

Caution
Click Backup in Change to Hidden to save your assembly drawing before
generating hidden lines. The Change to Hidden command smashes the parts
structure and creates the hidden line geometry.

1. Click Edit in Parts.
2. Click Top in Edit.
3. Click Backup in Change to Hidden.
4. Click Confirm.

Creo Elements/Direct Drafting stores your original drawing (in your current
directory) and generates hidden lines in the version displayed on the screen.

Creo Elements/Direct Drafting redraws the assembly with the hidden lines
shown dashed; see Figure 202. Assembly with Hidden Lines Shown Dashed
on page 368.

Figure 202. Assembly with Hidden Lines Shown Dashed

Setting the Current Offset
The current offset in the z-direction is used to calculate the z-value used in the
above/below/between relationship with another element. The current offset z-
value is added to/subtracted from the z-value of a reference element.
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To set the current offset:

1. Click Generate Element in Hidden.
2. Click Current Offset in Generate Element.
3. Enter the current offset z-value.

Setting Z-Values
This section shows how to assign and change element z-values.
The Generate Element options for assigning z-values are:

• Element

• Shared Part

Use the normal Creo Elements/Direct Drafting selection techniques to select the
elements to which you want to assign z-values.
If you select a part and you have clicked Element in Generate Element, all
elements in that part are assigned the specified z-value. This works recursively
down to all subparts.
Additional options for the above command can be selected from Options in
Hidden:

• Above

• Below

• Same

• Between

• None

You can set a z-value by clicking Current Z Value in Generate Element and
entering a numerical value; this is assigned to each drawing element in your
selection.
The Creo Elements/Direct Drafting default is that any existing z-values will be
overwritten. If you don't want to overwrite z-values that have already been
assigned:

1. Click Element in Generate Element.
2. Select the elements to which you wish to assign z-values.
3. Enter KEEP via the keyboard.
4. Enter a numerical value.
You can also click one of the options Above, Below, Same, or Between. This will
result in a computed z-value.
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Note
These options only influence elements that already have a z-value assigned to
them.

If you select a group of elements for a z-value change that have a range of z-
values (lower limit — upper limit) already associated with them, the range
relationship will be maintained.
To understand the effect of using the options Above, Below, Same, or Between,
refer to the following four examples:
Example 1
Suppose you have a group of elements with computed z-values 1 to 9 and you
then specify that they are placed at the same (click Same) z-value as a reference
element with a computed z-value of 20.
The result of this operation is that the z-values of all nine elements are computed
and set in the range 20 to 28.
Example 2
Suppose you have a group of elements with computed z-values 1 to 9 and you
then specify that they are placed above (click Above in Options, Current Offset =
1) a reference element with a computed z-value of 20.
The result of this operation is that the z-values of all nine elements are computed
and set in the range 21 to 29.
Example 3
Suppose you have a group of elements with computed z-values 1 to 9 and you
then specify that they are placed below (click Below in Options, Current Offset =
1) a reference element with a computed z-value of 20.
The result of this operation is that the z-values of all nine elements are computed
and set in the range 11 to 19.
Example 4
Suppose you have a group of elements with computed z-values 1 to 9 and you
then specify that they are placed between (click Between in Options, Current
Offset = 1) a reference element with a computed z-value of 20 and another
reference element with a computed z-value of 40.
The result of this operation is that the z-values of all nine elements are computed
and set in the range 21 to 29.
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Assigning a Z-Value to an Element
To assign a z-value to an element:

1. Click Generate Element in Hidden.
2. Click Element in Generate Element.
3. Select the element to which you want to assign a z-value.
4. Enter the z-value.

Assigning a Z-Value to a Shared Part
To assign a z-value to a shared part:

1. Click Generate Element in Hidden.
2. Click Shared Part in Generate Element.
3. Select the shared part to which you want to assign a z-value.
4. Enter the z-value.

Deleting a Z-Value
To delete a z-value of an element or a shared part:

1. Click Generate Element in Hidden.
2. Click Element or Shared Part in Generate Element.
3. Select the element(s) or the shared part.
4. Click None in Options.

Positioning an Element at a Z-Value Above Another
Element
To position an element at a z-value above another element:

1. Click Generate Element in Hidden.
2. Click Element in Generate Element.
3. Select the elements to be set above the reference element.
4. Click Above in Options.
5. Select the reference element.
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Positioning an Element at a Z-Value Below Another
Element
To position an element at a z-value below another element:

1. Click Generate Element in Hidden.
2. Click Element in Generate Element.
3. Select the elements to be set below the reference element.
4. Click Below in Options.
5. Select the reference element.

Assigning an Element's Z-Value to Another Element
To set the same z-value:

1. Click Generate Element in Hidden.
2. Click Element in Generate Element.
3. Select the elements to be set to the same level as the reference element.
4. Click Same in Options.
5. Select the reference element.

Positioning an Element at a Z-Value Between Two
Other Elements
To insert an element at a z-value between two other elements:

1. Click Generate Element in Hidden.
2. Click Element in Generate Element.
3. Select the elements to be set to a level between two existing elements.
4. Click Between in Options.
5. Select the lower reference element.
6. Select the upper reference element.

Generating Faces and Setting Z-Values in
a Complete Part
This section shows you how to easily generate faces and set z-values in a
complete part. Using the With Holes option, you can detect the presence of holes
to prevent them being generated as faces.
The Generate Part options are:
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• Elements & Faces

• With Holes

Generating All Faces and Setting All Z-Values
To automatically generate all faces and set all z-values for all elements in a
complete part:

1. Click Generate Part in Hidden.
2. Click Elements & Faces in Generate Part.
3. Select the part.
4. Enter the z-value or click Above, Same, or Below in Options.
5. Click End.

Creo Elements/Direct Drafting generates all faces and assigns z-values to all
elements in your part.

Generating All Faces - Ignoring Holes and Setting
All Z-Values
To automatically generate all faces ignoring any holes and set all z-values for all
elements in a complete part:

1. Click Generate Part in Hidden.
2. Click With Holes in Generate Part.
3. Select the part.
4. Enter the z-value or click Above, Same, or Below in Options.
5. Click End.

Creo Elements/Direct Drafting generates all faces ignoring any holes and
assigns z-values to all elements.

Checking Z-Values
This section shows how to check z-values.

An Element's Z-Value
To check the z-value of an individual element:

1. Click Generate Element in Hidden.
2. Click Inquire Z Value in Generate Element.
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3. Click Absolute in Inquire Z Value.
4. Select the element.

Creo Elements/Direct Drafting displays the element's z-value in the User Input
Line (if the specified element has no assigned z-value, an error beep is given).
The value is also written into the System Inquiry Array.

An Element Belonging to a Shared Part
If the element whose z-value you wish to know belongs to a shared part, the z-
value is computed as the z-value of the element itself plus the z-values of all
parent shared parts.

Example
Refer to Figure 203. Z-Values for Shared Parts on page 375.
To check the computed z-value of an individual element with z-value 2 in Shared_
part1:

1. Click Generate Element in Hidden.
2. Click Inquire Z Value in Generate Element.
3. Click Absolute in Inquire Z Value.
4. Select an element with z-value 2.

Creo Elements/Direct Drafting calculates the element's z-value as follows:

Element at z-value 2 + z-value of Shared_part1.

2 + -5 = -3.
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Figure 203. Z-Values for Shared Parts

The Minimum Z-Value in an Assembly Drawing
To check the minimum z-value:

1. Click Generate Element in Hidden.
2. Click Inquire Z Value in Generate Element.
3. Click Minimum in Inquire Z Value.

Creo Elements/Direct Drafting displays the minimum z-value in the assembly
drawing on the User Input Line (if the drawing has no z-values assigned, an
error beep is given). The value is also written into the System Inquiry Array.

The Maximum Z-Value in an Assembly Drawing
To find the maximum z-value:

1. Click Generate Element in Hidden.
2. Click Inquire Z Value in Generate Element.
3. Click Maximum in Inquire Z Value.

Creo Elements/Direct Drafting displays the maximum z-value in the assembly
drawing in the User Input Line (if the drawing has no z-values assigned, an
error beep is given). The value is also written into the System Inquiry Array.
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The Z-Value of a Shared Part
To find the computed z-value of a shared part:

1. Click Generate Element in Hidden.
2. Click Inquire Z Value in Generate Element.
3. Click ShPrtOffset in Inquire Z Value.
4. Select the shared part.

Creo Elements/Direct Drafting computes the z-value as the sum of the shared
part's z-value and that of the shared parent part and displays it in the User
Input Line. The value is also written into the System Inquiry Array.

Example

Refer to Figure 203. Z-Values for Shared Parts on page 375.
To check the z-value of Shared_part2:

1. Click Generate Element in Hidden.
2. Click Inquire Z Value in Generate Element.
3. Click ShPrtOffset in Inquire Z Value.
4. Click Shared_part2.

Creo Elements/Direct Drafting calculates the shared part's z-value as follows:

Z-value of Shared_part2 + z_value of parent. In this case,

-5 + 6 = 1.

The Z-Value of an Element in a Shared Part
To find the z-value of an element in a shared part:

1. Click Generate Element in Hidden.
2. Click Inquire Z Value in Generate Element.
3. Click ShPrt Elem in Inquire Z Value.
4. Select the element in the shared part.

Creo Elements/Direct Drafting displays the element's z-value in the User Input
Line. The value is also written into the System Inquiry Array.

The Current Z-Value
To check the default current z-value assigned to each newly created drawing
element:

1. Click Generate Element in Hidden.
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2. Click Inquire Z Value in Generate Element.
3. Click Curr Z-Val in Inquire Z Value.

Creo Elements/Direct Drafting displays the current z-value in the User Input
Line. If required, it can be used as input without retyping. The current z-value
is also written into the System Inquiry Array.

The Load Value
To check the current load z-value:

1. Click Generate Element in Hidden.
2. Click Inquire Z Value in Generate Element.
3. Click Load Z-Val in Inquire Z Value.

Creo Elements/Direct Drafting displays the current load mode and load z-
value on the User Input Line. If required, it can be used as input without
retyping. Both these values are written into the System Inquiry Array.

Setting the Default Z-Value
This section shows how to define a specific z-value which is assigned to each
newly created element (the default current z-value is 0).
To set the current z-value:

1. Click Generate Element in Hidden.
2. Click Current Z Value in Generate Element.
3. Enter the new z-value into the User Input Line or click Above, Same, or Below

in Options.

Creo Elements/Direct Drafting assigns this value as the current z-value,
assigned by default to each newly created element.

Setting the Load Value
This section shows how to define a loading offset in the z-direction for elements
that are loaded in the future.
The default load z-value is None. If you load elements with the load z-value set to
None, their z-value (if any) remains unchanged.
To set a load offset z-value:

1. Click Generate Element in Hidden.
2. Click Load Z Value in Generate Element.
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3. Enter the required load offset z-value into the User Input Line. Alternatively,
click a reference element set to a given z-value and then click Above, Same, or
Below in Options.

Creo Elements/Direct Drafting assigns the required load z-value to any
elements loaded in the future.

Example
To load drawing elements with a load z-value of 2:

1. Click Generate Element in Hidden.
2. Click Load Z Value in Generate Element.
3. Enter 2.
4. Load an existing drawing file.

Creo Elements/Direct Drafting loads the drawing elements as shown in Figure
204. Loading Drawing Elements with a Load Z-Value of >=2 on page 378.

Figure 204. Loading Drawing Elements with a Load Z-Value of >=2

Generating Faces
This section shows how to specify covering faces. A covering face will effectively
cover all geometry (or faces) with a lower z-value. Newly created faces are
assigned the current z-value by default. The covering face will adopt the default
face color (note that you can set a default color for faces).
The Generate Face options are:

• Single Automatic

• Single Manual

• All in Part
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• With Holes

Automatically
You can automatically generate faces if:

• All elements of the contour are in the active part.
• The contour has no gaps.
• Each vertex of the contour is a vertex of all elements there.
To automatically generate faces:

1. Click Generate Face in Hidden.
2. Click Single Automatic in Generate Face.
3. Specify a point inside the face.
4. Enter a z-value or click Above, Same or Below in Options.

Creo Elements/Direct Drafting generates the face automatically and assigns
the required z-value.

Manually
Note that in order to build up a contour with elements, a vertex of an element must
be specified first. Thereafter, the elements which make up the contour can be
selected by a simple click.
Creo Elements/Direct Drafting will allow you to skip elements along a contour as
long as not more than one element after any branch point is skipped. All elements
must be in the active part.
To manually generate a face:

1. Click Generate Face in Hidden.
2. Click Single Manual in Generate Face.
3. First specify points along the outer contour (the points selected do not have to

lie on any geometric element).
4. Specify points along the inner contour.
5. Click End.
6. Enter a z-value or click Above, Same or Below in Options.

All Faces in a Part Excluding Holes
To automatically generate all faces in a part and exclude any holes:

1. Click Generate Face in Hidden.
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2. Click With Holes in Generate Face.
3. Enter a z-value or click Above, Same or Below in Options.

Creo Elements/Direct Drafting generates the faces automatically and assigns
the required z-values. Note that any holes that are present are excluded from
face generation.

Automatically Generating All Faces in a Part
You can generate faces automatically in the active part. Creo Elements/Direct
Drafting tries to find the maximum number of faces.
To automatically generate faces in the active part:

1. Click Generate Face in Hidden.
2. Click All in Part in Generate Face.
3. Enter a z-value or click Above, Same or Below in Options.

Example
Refer to Figure 205. Automatically Generating Faces In a Part on page 380. In this
example Creo Elements/Direct Drafting would generate the four faces shown.

Figure 205. Automatically Generating Faces In a Part

Undoing a Face
You may want to undo a face you have just generated (before specifying the z-
value).
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The effect of clicking Undo when using the following Generate Face options is:
Single Automatic The last face specified will be removed.
Single Manual During creation of a contour, points will be removed. If

you have finished defining a face and have clicked End,
pressing Undo results in the removal of the entire face.

All in Part All faces generated automatically will be removed.
With Holes All faces generated automatically will be removed.

Deleting Covering Faces
This section shows how to delete covering faces. You can delete a single face or
all faces in a part. The faces identified must be in the current part and they should
not contain any hatching.

A Single Face
To delete a single face:

1. Click Edit in Hidden.
2. Click Delete Face in Edit.
3. Select the face you wish to delete.

Creo Elements/Direct Drafting deletes the face.

All Faces in a Part
To delete all the faces in the current part:

1. Click Edit in Hidden.
2. Click Delete Face in Edit.
3. Click All, Confirm and Apply in Options.

Creo Elements/Direct Drafting deletes all faces in the current part.

Redrawing in Hidden or Normal Mode
This section shows how to switch between the normal Creo Elements/Direct
Drafting redraw function and the hidden line redraw function.
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Note
Hidden Mode affects all View functions as each takes the z-value information
into account.

Hidden Mode
To redraw in hidden mode:

1. Click Hidden Mode and On in Hidden.
2. Specify the appropriate viewport to use the z-value information when

redrawing.

Creo Elements/Direct Drafting displays the drawing partially covered
(depending on the z-values associated with the assembly drawing).

Note that Creo Elements/Direct Drafting displays "-H-" in the upper left-hand
corner to indicate hidden mode.

Normal Mode
This is the default mode. To redraw normally:

1. Click Hidden Mode and Off in Hidden.
2. Specify the appropriate viewport.

Hidden Settings
Proceed as follows to define the required hidden line type, line color and face
color settings:

1. Click Settings in Hidden.
2. In the Hidden Settings dialog box, pull down the selection list for each of the

following settings:
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Line Type Select the line type for hidden lines in your drawing.
Line Color Select the color for hidden lines in your drawing. When

the Default check box is ticked, the default hidden line
color will be applied. Refer to Defining Custom Colors on
page 54 for instructions on defining custom colors.

Color Select the color for faces in hidden mode. When the
Default check box is ticked, the default face color will be
applied. Refer to Defining Custom Colors on page 54 for
instructions on defining custom colors.

3. Click OK.

Changing the Linetype and Color of
Hidden Lines
The Change Hidden Line dialog box enables you to change hidden lines (see
Generating Hidden Lines on page 359 for instructions on generating hidden lines).
To change the linetype and/or color of existing hidden lines:

1. Click Edit in Hidden.
2. Click Change Line in Edit.
3. In the Change Hidden Line dialog box, select a linetype from the Type selection

list.
4. Select a line color from the Color selection list. Refer to Defining Custom

Colors on page 54 for instructions on defining custom colors.
5. Click OK.

All existing hidden lines in the drawing will be redrawn in the linetype and
line color you selected.

Changing Face Color
The Change Hidden Face dialog box enables you to change the color of faces you
created to generate hidden lines.

1. Click Edit in Hidden.
2. Click Change Face in Edit.
3. In the Change Hidden Face dialog box, select a color from the Color selection

list. If you tick the None check box, the face color is set to none (i.e. faces will
be transparent). Refer to Defining Custom Colors on page 54 for instructions
on defining custom colors.

4. Click OK.
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5. Select the face(s) to be changed.

The selected face(s) will be redrawn in the color you selected.

Viewing Z-Values
The ShowRange dialog box enables you to view all or a range of z-values in your
drawing. You can display all elements or only faces (in a color of your choice) that
are in a specified range of z-values.
The ShowRange options are:

• Elements in Drawing

• Faces in Drawing

• Elements in Part

• Faces in Part

To display the Show Range dialog box:

1. Click Show in Hidden.
2. Click Range in Show.

Setting a Range of Z-Values
By default, all z-values are shown. In the Show Range dialog box, you can limit
the visible range of z-values as follows:

1. Click the Limit radio button in the Range section of the ShowRange dialog
box.

2. Specify the "from" z-value in the Lower field.
3. Specify the "to" z-value in the Upper field. For example, to limit the visible

range to z-levels 3 through 8, you would enter 3 into the Lower field and 8 in
the Upper field.

This range is used in the following way:

• In connection with the options Elements in Drawing and Elements in Part, this
range specifies the range of z-values belonging to elements that are visible.

• In connection with the options Faces in Drawing and Faces in Part, this range
specifies the range of z-values belonging to faces that are visible and colored.

Elements in All Parts
Click the Elements in Drawing radio button to select all elements:

• In a selected range of z-values.
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• In all parts (default).

Elements in Current Part
Click the Elements in Part radio button to select elements:

• In a selected range of z-values.
• In the current part.

Faces in all Parts
Click Faces in Drawing to select faces:

• In a selected range of z-values.
• In all parts.

Faces in Current Part
Click Faces in Part to select faces:

• In a selected range of z-values.
• In the current part.

Applying a Color to Facilitate Visualization
To color faces in a particular range of z-values as an aid to visualization:

1. In the ShowRange dialog box, click the appropriate radio button for the items
to be displayed.

2. In the Range section, specify a the range of z-values to be displayed in the
same color (see Setting a Range of Z-Values on page 384).

3. In the Show section of the Show Range dialog box, click the Color radio button
and select a color from the Color list. Refer to Defining Custom Colors on
page 54 for instructions on defining custom colors.

4. Click OK.

Creo Elements/Direct Drafting displays the selected faces in the required color
and does not display those faces with a z-value outside of the desired range.
See Figure 206. Viewing Selected Elements on page 386.
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Figure 206. Viewing Selected Elements

Resetting the Viewport after Viewing
Having used the Show Range dialog box to display selected elements/geometry,
you will need to reset the viewport so that you can see all elements/geometry
again. To reset the viewport:

1. Click Show in Hidden.
2. Click Reset Show in Show.

Generating Hidden Lines
This section shows how to generate hidden lines and load the backup drawing
(workfile.hid) produced just before generating hidden lines.
When generating hidden lines, Creo Elements/Direct Drafting does the following:

• Geometry is modified by splitting geometric components if they are covered
by faces with a higher z-value.

• Shared parts are unshared.
• The parts tree, starting from the current part, will be smashed.

Caution
You are recommended to click Backup in Change to Hidden to store your
assembly (in workfile.hid) before generating hidden lines as this
command smashes the parts structure and creates the hidden line geometry.

To generate hidden lines:
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1. Click Change to Hidden in Hidden.
2. Click Backup or No Backup in Change to Hidden.

Loading the Backup Drawing
If you wish to recover the backup drawing (workfile.hid) produced by
clicking Backup in Change to Hidden:

1. Store your hidden line view.
2. Click Change to Hidden in Hidden.
3. Click Load Backup in Change to Hidden.

Creo Elements/Direct Drafting will load the original drawing
(workfile.hid) produced before you generated hidden lines.

Plotting Hidden Lines
It is not possible to plot face colors.
To suppress plotting of hidden lines, you must set the hidden line linetype and
color appropriately. Refer to the PLOT_TRANSFORMATION command in
Writing Macros with Creo Elements/Direct Drafting.

Dumping Hidden Lines
You can use the screen dumping commands to produce a copy of your drawing
that includes face colors (if you have a color printer). Screen dumps can be made
at any stage in the drawing process. Refer to Printing and Plotting on page 456.

Hidden Line - Tutorial Example 2
This tutorial example shows one way to create an assembly drawing (CRANK_
ASSEMBLY) from five individual part drawings. The assembly drawing is then
used to demonstrate the various features of the Creo Elements/Direct Drafting 2D
Hidden Line Module.

Creating the Crank Assembly
This tutorial is based on the crank assembly shown in Figure 207. CRANK_
ASSEMBLY on page 388.
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Figure 207. CRANK_ASSEMBLY

This crank assembly consists of the top part named CRANK_ASSEMBLY and five
subparts. The parts tree is indicated in the following list.
CRANK_ASSEMBLY

Nut
Lever
Crank
Joint
Shaft assembly

Draw a Cutaway Hole in the Joint
1. Click Parts ▶ Edit ▶ Part.
2. Click the Joint to make it the active part.
3. Click Interpolation Spline in Geometry.
4. Switch on the Closed check box option in Interpolation Spline.
5. Click points for the spline to create the cutaway hole shown in Figure 208.

CRANK_ASSEMBLY With Cutaway Hole on page 389.
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Figure 208. CRANK_ASSEMBLY With Cutaway Hole

6. Click End.

Create Face 1
1. Click Hidden Mode and On in Hidden.
2. Click the current viewport to get visual feedback while creating faces (the face

is highlighted).
3. Click Generate Element in Hidden.
4. Click Element in Generate Element.
5. Box the Joint.
6. When prompted for the z-value, enter 1

Creo Elements/Direct Drafting assigns a z-value of 1 to all elements in the
box.

7. Click End.

Generate Face 1
1. Click Generate Face in Hidden.
2. Click Single Automatic in Generate Face.
3. Click a point on Face 1.
4. When prompted for the z-value, enter 2
5. Click End.
6. Pull down the View menu and click Redraw.
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Generate Faces in the Nut
1. Click Parts ▶ Edit ▶ Part.
2. Click the Nut to make it the active part.
3. Click Generate Element in Hidden.
4. Click Element in Generate Element.
5. Box the Nut.
6. When prompted for the z-value, enter 1

Creo Elements/Direct Drafting assigns a z-value of 1 to all elements in the
box.

7. Click End.
8. Click Generate Face in Hidden.
9. Click All in Part in Generate Face.
10. Pull down the View menu and click Redraw.

Generate a Face in the Lever
1. Click Parts ▶ Edit ▶ Part.
2. Click the Lever to make it the active part.
3. Click Generate Element in Hidden.
4. Click Element in Generate Element.
5. Box the Lever.
6. When prompted for the z-value, enter 1

Creo Elements/Direct Drafting assigns a z-value of 1 to all elements in the
box.

7. Click End.
8. Click Generate Face in Hidden.
9. Click All in Part in Generate Face.
10. Pull down the View menu and click Redraw.
At this point you would check for any errors you may have made when assigning
z-values and generating faces. See Figure 209. CRANK_ASSEMBLY with
Hidden Mode On on page 391.
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Figure 209. CRANK_ASSEMBLY with Hidden Mode On

Generate Hidden Lines
1. Click Change to Hidden in Hidden.
2. Click Backup in Change to Hidden.

Caution
We recommend that you use Backup in Change to Hidden to store your
assembly (in workfile.hid) before generating hidden lines, as this
command smashes the parts structure and creates the hidden line geometry.

Creo Elements/Direct Drafting would generate hidden lines as shown in
Figure 210. Cutaway Hole and Hidden Lines on page 392, Figure 211. Nut —
Showing Hidden Lines on page 392 and Figure 212. Lever — Showing
Hidden Lines on page 392.
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Figure 210. Cutaway Hole and Hidden Lines

Figure 211. Nut — Showing Hidden Lines

Figure 212. Lever — Showing Hidden Lines

3. Click Hidden Mode and On or Off in Hidden to toggle the hidden lines on or
off.
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Drawing Using Layers
The layers commands in the Info menu allow you to split up your drawing into a
number of layers. Thus you can place individual elements in a particular layer, or
in a number of layers.
The advantage of working this way is mainly in visualization. By switching layers
on and off you can simplify what you see on the screen.
For example, suppose you wish to create an assembly drawing of a cap bearing
consisting of four components. Each component was stored as a drawing, and you
must load each one to create a four part drawing.
Figure 213. Cap Bearing Parts Structure on page 394 shows the parts structure.

Figure 213. Cap Bearing Parts Structure

Irrespective of the parts structure, you want to be able to see the assembly in three
different ways:

• Each of the components individually.
• With the cap removed.
• Fully assembled.
To do this we can use the three layer commands and place the various elements
into layers; some elements would be contained in more than one layer.
Finally, via the Layer tab in the Show dialog box, you can switch the various
layers on and off to produce the required views. The layers would be as follows:
Layer 1 contains all the HOUSING elements.

Figure 214. Layer 1 — Housing Elements

Layer 2 contains all the BEARING elements.
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Figure 215. Layer 2 — Bearing Elements

Layer 3 contains all the SHAFT elements.

Figure 216. Layer 3 — Shaft Elements

Layer 4 contains all the CAP elements.

Figure 217. Layer 4 — CAP Elements

Layer 5 contains most of the HOUSING elements, all the BEARING elements
and some of the SHAFT elements.

Figure 218. Layer 5 — Housing, Bearing and Shaft Elements
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Layer 6 contains some of the HOUSING and SHAFT elements, plus all the CAP
ones.

Figure 219. Layer 6 — Housing, Shaft and CAP Elements

Adding a New Layer
To add a new layer to your drawing:

1. Click Add Layer in Info.
2. Specify a unique number for this new layer.

Setting the Active Layer
When a particular layer is active, all subsequently drawn elements will be placed
in it.
To set a layer active:

1. In the status toolbar, use the layer field pull-down menu and select the active
layer.

2. Click the desired number and you are ready to start drawing in the layer.
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Duplicating Elements in Other Layers
This section shows how to duplicate elements contained in one layer in another.
After using the function the selected elements will be in both layers. The function
can be used irrespective of which layer is current.
To duplicate elements contained in one layer in another:

1. Click Add Layer in Info.
2. Creo Elements/Direct Drafting will prompt for the number of the layer to

which elements are to be added.
3. Select the elements to be added. This can be done in one of two ways:

• Click or box the elements to be added. This method is most suitable for
simple selections of one or two elements.

• Alternatively, click Select and Advanced to use the various Select options.
When your selection is complete, click Confirm and OK. Creo Elements/
Direct Drafting will add the elements to the selected layer. This method is
most suitable for large selections as you can see which elements have been
identified so far.

Moving Elements Between Layers
This section shows how to transfer elements from one layer to another. The
function can be used irrespective of which layer is current.
To transfer elements from one layer to another:

1. Click Change Layer in Info.
2. Enter the number of the layer to which elements are to be transferred.
3. Identify elements to transfer. This can be done in one of two ways:

a. Click or box the elements to be transferred. This method is most suitable
for simple selections of one or two elements.

b. Alternatively, click Select and Advanced to use the various Select options.
When your selection is complete, click Confirm and OK. Creo Elements/
Direct Drafting will transfer the elements to the specified layer. This
method is most suitable for large selections as you can see which elements
have been identified so far.

Using the Layer Dialog in Show
Click on the Layer tab in Show to display the Layer dialog box.
In this dialog box, you can:
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• Switch layers on and off
• Box an area to define a layer
• Select a color for each layer

Switching Layers On & Off
To switch layers on or off:

1. Click Show in Setup.
2. Click the Layer tab.
3. In the Layer dialog box, select the layer(s) you want to switch on or off.
4. Click On or Off.
5. Enter the number of the layer.

Creo Elements/Direct Drafting will now switch the specified layer on or off.

Showing Layer Color
You can color a layer to aid visualization. This will not affect plotter pen
numbering.
To color a layer:

1. In the Layer dialog box in Show, select a layer number.
2. Select a color from the Color selection list.
3. Click OK to apply the layer color change.

Creo Elements/Direct Drafting will redraw the elements in the specified layer
in the new color.

To restore the original color of the layer, switch the layer on again in Layer.

Modifying and Deleting Layers
There may be occasions when you wish to modify or delete complete layers. In
such cases use the Layer option in the Select menu.
To modify or delete complete layers:

1. Click Delete or click a Modify option;.
2. Click Layer in Select.
3. When prompted, specify the layer you want to delete or modify.
4. Click Confirm and OK.
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What are Infos?
The major components of a drawing are drawing elements such as lines, circles,
arcs, and so on. Each element is stored in memory together with information to
describe it. These pieces of information attached to each element are known as
attributes.
Examples of attributes are an element's linetype and color. In addition to these,
Creo Elements/Direct Drafting allows you to enter your own attributes, called
Infos.
An info is simply a piece of text attached to an element. The info is not visible on
the screen, but is attached to the element in memory. The use of infos is a matter
of personal or company preference. They can be used to:

• Store information concerning a design update. The revised elements could all
have the following infos added to them:
Revision number:003
Nature of revision: Dimensional changes to accommodate
uprated bearings

• Store information concerning dates and names:
Designer: Bill G
Date: 03.03.93
Job No: 147/2

In addition to whatever use you make of infos, Creo Elements/Direct Drafting
uses them during the Layers commands. Thus if you place an element in layer 1,
Creo Elements/Direct Drafting will attach the info LAYER: 1 to it.
The Info menu contains the following info commands:

• Add

• Edit

• Change

• List

• Delete

Adding Infos
This section shows how to add infos to drawing elements. The Add options are:

• Current Element

• Select Element

• Screen
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To a Selected Element
To add infos to existing drawing elements:

1. Click Add in Info.
2. Click Select Element in Add.
3. Enter the info text.

This can be done in one of two ways:

• Enter the required text enclosed in quotes (' ' or " ") into the command line.
This is the best method to use for infos of up to one line in length.

• Alternatively, click Screen to display a text box (based on a standard text
editor) in which you can enter the info text. Don't enclose the text in
quotes. When you have finished typing the info, close this text box to
return to the normal Creo Elements/Direct Drafting display.

Once the info text has been entered, you can add it to any existing elements.
4. Identify the required elements and the system will add the info to them.

Alternatively, you can use the Select menu in the normal way to identify
elements.

Adding the Current Info
You can create infos as current such that they are attached to all subsequently
drawn elements:

1. Click Add in Info.
2. Click Current Element in Add.
3. Enter the info text.

This can be done in one of two ways:

• Enter the required text enclosed in quotes (' ' or " ") into the command line.
This is the best method to use for infos of up to one line in length.

• Alternatively, click Screen to display a text box (based on a standard text
editor) in which you can enter the info text. Don't enclose the text in
quotes. When you have finished typing the info, close this text box to
return to the normal Creo Elements/Direct Drafting display.

Once the current info has been set, you can continue drawing. All new elements
will automatically contain the current infos.

Editing an Info
This section shows how to edit any existing info.
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The command options are:

• Current Element

• Select Element

An Existing Element
To edit the info for any existing element:

1. Click Edit in Infos.
2. Click Select Element in Edit.
3. Select the drawing element to be edited.

The display will clear and be replaced by the infos belonging to the element.
4. Edit the text using the edit keys and keyboard.
5. When you have finished editing, close the text box to return to the normal

Creo Elements/Direct Drafting display.

The Current Info
To edit the current info:

1. Click Edit in Infos.
2. Click Current Element in Edit.

The normal display will clear and be replaced by the current infos.
3. Edit the text using the edit keys and keyboard.
4. When you have finished editing, close the text box to return to the normal

Creo Elements/Direct Drafting display. All newly drawn elements will contain
the revised current infos.

Deleting an Info
This section shows how to delete existing infos or the current info.
The command options are:

• Current Element

• Select Element

An Existing Info
To delete the infos belonging to any existing drawing elements:

1. Click Delete in Infos.
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2. Click Select Element in Delete.
3. Select elements. This can be done in one of two ways:

a. Click individual elements or use a box to select several. The system will
now delete the infos.

b. Alternatively, use the Select menu options. When selection is complete,
click Confirm and OK to delete the infos.

The Current Info
Click Current Element in Delete and Creo Elements/Direct Drafting will delete the
current info. If you now continue drawing, all new elements will be without infos.

Changing Infos
This section shows how to change infos.
The command options are:

• Current Element

• Select Element

• Global

For each option, enter the line of info text to be changed, and the new text. You
can use wildcards (that is, *, ?, [..], ! and \) in either the info text to be changed, or
the new text.
For further information about wildcards, refer to Storing, Loading and Filing on
page 409.

An Existing Info
To change any existing info:

1. Click Change in Infos.
2. Click Select Element in Change.
3. Enter the line of info text to be changed.

For example, "DRAWN ON 28.02.93".
4. Enter the replacement text.

For example, "DRAWN ON 03.03.93".
5. Select the elements to be changed. This can be done in one of two ways:

• Click individual elements, or box several elements.
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Creo Elements/Direct Drafting changes the info text for the identified
elements.

• Alternatively, use the Select menu options. When selection is complete,
click Confirm and OK to change the elements.

The Current Info
To change the current info:

1. Click Change in Infos.
2. Click Current Element in Change.
3. Enter the line of the current info to be changed.
4. Enter the replacement line and the system will change the current info.

Once the change is made, you are ready to continue drawing. The revised
current info will be added to all new drawing elements.

All Occurrences
To perform changes to all occurrences of an info:

1. Click Change in Infos.
2. Click Global in Change.
3. Enter the line of info text to be changed.
4. Enter the replacement line and the system will change every such occurrence

without you having to identify elements.

Listing Infos
This section shows how to produce a list of all infos used in your drawing.

1. Click List in Infos. All infos used in your drawing are displayed in a text box.
2. Close this text box to return to the normal Creo Elements/Direct Drafting

display.

Listing Namespaces
Namespaces are used for structuring infos. The use of namespaces in Creo
Elements/Direct Drafting enhanced performance through targeted inquiries. For
further details, refer to Infotext namespace in the Creo Elements/Direct Drafting
Help.
To list all of the namespaces currently in use:
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1. Click Namespaces in Infos. All namespaces used in your drawing (for
example, SYS:HL_SCOPE includes Z-LEVELS) are displayed in an Info
Browser.

2. Close the Info Browser to return to the normal Creo Elements/Direct Drafting
display.

Using the Info Dialog in Show
Click on the Info tab in Show to display the Info dialog box.
In this dialog box, you can:

• Switch infos on a off
• Box an area to define an info
• Select a color for each info

Switching Infos On & Off
To switch infos on or off:

1. Click Show in Setup.
2. Click the Info tab.
3. In the Info dialog box, select the info you want to switch on or off.
4. Click On or Off.

All elements containing this info text will be switched on (displayed) or off
(hidden).

URLs
Creo Elements/Direct Drafting enables you to attach any industrial standard Web
page to drawings, parts and elements. All URLs used by Creo Elements/Direct
Drafting drawings, parts and elements are handled via the URL dialog box
accessible from the Infos menu.

Adding URLs
To add a URL to the current Creo Elements/Direct Drafting drawing or to a part or
to an element in the drawing:

1. Click URL in Infos.
2. In the URL dialog box, click Add.
3. In the Add dialog box, select the area to which you want to add a URL:
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Current to add a URL to the current part
Element to add a URL to an element or a group of elements.
Part to add a URL to a part other than the current part

4. Specify the URL in the Info field of the Add dialog box.
5. Click OK.
6. Unless you selected Current (the default area) in the Add dialog box, select the

part or element to which you want to attach the URL.
7. Click End.

Changing URLs
To change the URL attached to a part or element:

1. Click URL in Infos.
2. In the URL dialog box, click Change.
3. In the Change dialog box, select the area in which you want to change a URL:

Current to change a URL of the current part
Element to change a URL of an element or a group of elements.
Part to change a URL of a part other than the current part

4. Unless you selected Current (the default area) in the Change dialog box, select
the part or element whose URL you want to change.

5. Select the URL to be replaced from the old selection list.
6. Specify the URL you want to use instead.
7. Click OK.
8. Unless you selected Current (the default area) in the Change dialog box, select

the part or element whose URL you want to change.

Deleting URLs
To remove a URL attachment from a part or element:

1. Click URL in Infos.
2. In the URL dialog box, click Delete.
3. In the Delete dialog box, select the area from which you want to delete a URL

attachment:
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Current to remove a URL attachment from the current part
Element to remove a URL attachment from an element or a group

of elements.
Part to remove a URL attachment from a part other than the

current part

4. Select the URL attachment to be removed from the Info selection list.
5. Click OK.

Listing URLs
To display a list of the URLs attached to the current Creo Elements/Direct
Drafting drawing or to a part or to an element in the drawing:

1. Click URL in Infos.
2. Display the List selection list at the top of the URL dialog box.
3. Select the area whose URLs you want to list:

Global to list all URLs attached to any items in the current
drawing

Current to list all URLs attached to the current part
Element to list all URLs attached to an element or group of

elements.
Part to list all URLs attached to a part other than the

current part

4. Unless you selected Global or Current, click Select in URL and select the part
or element(s) whose URLs you want to list.

The associated URL list is displayed in the URL dialog box.

Highlighting the Element or Part to which a Given
URL is Attached
To highlight the element or part to which a URL is attached:

1. Click URL in Infos.
2. List the URLs attached to your drawing. See Listing URLs on page 406 for

instructions.
3. Select a URL from the list.
4. Click Show to highlight the element or part to which this URL is attached.
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Accessing a URL
To access a URL attached to a part or element in a drawing:

1. Click URL in Infos.
2. List the URLs attached to your drawing. See Listing URLs on page 406 for

instructions.
3. Select the URL you want to access.
4. Click Browse to access this URL by means of your default Web browser or

navigator.

Using the URL Dialog in Show
Click on the URL tab in Show to display the URL dialog box.
In this dialog box, you can:

• Switch URLs on and off
• Box an area to show its URLs
• Select a color for each URL

Switching URLs On & Off
To switch URLs on or off:

1. Click Show in Setup.
2. Click the URL tab.
3. In the URL dialog box, select the URL you want to switch on or off.
4. Click On or Off.

Creo Elements/Direct Drafting will now switch the specified URL on or off.

Assigning a Color to a URL
You can color a URL to aid visualization.
To color a URL:

1. In the URL dialog box in Show, select a URL.
2. Select a color from the Color selection list.

Creo Elements/Direct Drafting will indicate the URL in the newly selected
color.
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Further Information
For further technical information about layers and infos, refer to the Creo
Elements/Direct Drafting help system:
Enter help layer or help info or help url at the Creo Elements/Direct
Drafting command line. The screen will clear and Creo Elements/Direct Drafting
will display further information about using layers or infos or URLs with Creo
Elements/Direct Drafting.
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File Organization and Names
This section gives a brief overview of file handling terminology, sufficient to use
the File functions and commands.
All file access operations can easily be performed using Creo Elements/Direct
Drafting filing commands.

File Organization
A file is simply a container into which you can put data. The most important
aspect of a file is that it has a name which you have allocated to it. The contents of
a file can be displayed, copied, and removed from the system.
A directory is a file containing information about other files and directories. A
directory contained within another directory is called a subdirectory, and each
subdirectory can itself contain files and more subdirectories. Figure 220. File
System Hierarchy on page 410 shows file system hierarchy.

Figure 220. File System Hierarchy

Filenames
In theory, a filename can consist of any characters available on the keyboard. In
practice however, many characters are of special significance to the MS-DOS or
Windows NT operating systems and these should not be used in filenames and
directory names.
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Table 4 on page gives the characters with special significance to the operating
system.

Table 4. Characters With Special Significance

asterisk *
question mark ?
less than <
greater than >
bar |
forward slash /
backslash \
quote '
colon :

As a general rule, it is best to restrict yourself to names consisting of letters, digits,
and underscore characters.

Note
You can use upper or lower-case letters for filenames, however, do not mix
cases when entering commands. For example, File01 is valid for a filename,
but Create_Directory is not valid for a command.

Identifying Files
This section shows how to identify files to ensure the correct file is loaded, stored,
and so on.
You can identify files three ways:

• By entering the file path name.
• By using the SEARCH command.
• By using the File Browser (see Opening and Saving Drawings by Means of

the Creo Elements/Direct Drafting File Browser on page 413 later in this
chapter).

• By using the Navigator.
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Using the File Path Name
The file path consists of the volume/drive identifier, a directory path and a
filename, all separated by a backslash ("\") or a colon (":"). Suppose you wish to
perform a file command on the following:

Filename: nvb_drw_101.mi
In directory: larry
In volume/drive: D:

To identify the file you would enter the following string:
'D:\larry\nvb_drw_101.mi'

Note
Creo Elements/Direct Drafting recognizes both the slash ("/") and the
backslash ("\") as valid separators of the components of a file path. The
following string also correctly identifies the file given in the example above:
'D:/larry/nvb_drw_101.mi'

Backslashes are generally used in this manual because this most closely matches
the MS-DOS file system convention.

Using the Search Command
The SEARCH command allows you to specify further directories, other than the
current directory, to be searched during the LOAD and INPUT commands. Use
this command to quickly load macros, standard parts and so on contained in other
directories.
For example, suppose that the volume and directory D:\users\eng_constr
is to be searched for the file geom_1.mi. Then if the following had been entered
into the search command:
SEARCH

'd:\users\eng_constr'
END

all you would have to enter is:
LOAD 'geom_1.mi'
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Opening and Saving Drawings by Means
of the Creo Elements/Direct Drafting File
Browser
You can open and save drawings quickly and easily by means of the Creo
Elements/Direct Drafting File Browser. This File Browser adheres to standard
MS-Windows conventions. You do not need to remember long filenames and
subdirectories as these are displayed. (You can still enter the filename on the
command line if you wish.)
You can close the File Browser once the drawing has been opened or saved.
Optionally, you can leave the File Browser open for further selections.
In the File related dialog boxes, the File Browser provides the following icons:

Moves up one level in the directory hierarchy.

Creates a new folder (directory) on the current
directory level.
Displays columns of files and directories.

Displays files and directories in report mode. In
this mode, you can sort the listed files and
directories by type, size, last modification date/
time and attributes.

In the dialog boxes associated with the Creo Elements/Direct Drafting File
Browser, you can move, copy and delete files and directory using standard MS-
Windows techniques.

Opening a Drawing File via the Creo Elements/Direct
Drafting File Browser
When you use Open, the drawing file you select or specify will replace any
drawing already loaded in the Creo Elements/Direct Drafting workspace.
The name of the currently loaded drawing file is displayed in the Creo Elements/
Direct Drafting title bar (at the top of the Creo Elements/Direct Drafting window).
To open a drawing file by means of the Creo Elements/Direct Drafting File
Browser:

1. In Creo Elements/Direct Drafting, pull down the File menu. Note that the last
four drawing files you used are listed by default. If the file you want to open is
included in this list, simply select the associated filename.

2. Click Open to display the File Browser.
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3. Unless the file you want to open is listed in the file pane of the File Browser,
pull down the Directory selection list and change to the directory where the file
is stored. If this directory is specified in the file pane, double-click on the
directory name to list the files contained in it.

4. The system defaults to the most recent file type extension opened (startup
default is .mi). This is convenient if you open several files of the same type in
your work session. Thumbnail views are an exception; if you open a
Thumbnail, the extension of the file opened before the Thumbnail is kept as
most recent.

5. Click on the filename. If the file you want has a format different from the most
recent opened, pull down the Filter selection list and select the applicable
format:

• Model Interface Standard (*.mi)

• Compressed MI (*.bi) (compressed by means of the Z-lib mechanism)
• Bundle (*.bdl) (Note that only the 2D portions of such files are extracted,

while any 3D portions are ignored.)
• Autodesk Drawing Interchange (*.dxf)

• Initial Graphics Exchange Format (*.igs)

• AutoCAD File Specification (*.dwg)

• All files (*.*)

Refer to Handling External File Formats on page 427 for further information
on external file format translators used by Creo Elements/Direct Drafting.

A preview image of the drawing file is displayed in the preview pane of the
File Browser.

Optionally, tick the following checkboxes:
Check 2D Creo Elements/Direct Drafting will check this file

for invalid elements (such as extremely short lines)
and will remove such elements.

Check 2D Retain
Dependency

Creo Elements/Direct Drafting will re-allocate
dependent elements (such as dimensions or
hatches) of removed invalid elements to plausible
valid elements.
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Overwrite fonts In some cases, a font may have been saved with an
MI file. Creo Elements/Direct Drafting will
automatically load this font when you load the file.
However, if the font in the file matches a font name
already in your system, you can instruct Creo
Elements/Direct Drafting to overwrite your system
font with the file font by checking this box.

Discard fonts In some cases, a font may have been saved with an
MI file. Creo Elements/Direct Drafting will
automatically load this font when you load the file.
If you do not want new fonts loaded, check this
box.

6. Click Open to open this file in Creo Elements/Direct Drafting. Alternatively,
enter the filename and press [Enter].

7. If Creo Elements/Direct Drafting contains a drawing, you are prompted to
save this drawing before the selected file is loaded. Refer to Saving a Drawing
File via the Creo Elements/Direct Drafting File Browser on page 416 for
instructions.

8. Once the drawing is displayed in Creo Elements/Direct Drafting, you can edit
it as required.

Note
The preview image is pixel-based. It cannot be modified.

Opening a Drawing File by Means of the Navigator
The Creo Elements/Direct Drafting Navigator provides a scrollable sequence of
preview images of the drawing files in the current directory. The Navigator thus
facilitates the selection of drawings.
To open a drawing file by means of the Creo Elements/Direct Drafting Navigator:

1. In Creo Elements/Direct Drafting, pull down the File menu and click Open to
display the File Browser. Alternatively, click the following button in the Creo
Elements/Direct Drafting toolbar:

2. Click Navigator to display the Creo Elements/Direct Drafting Navigator. By
default, the Navigator points to the Creo Elements/Direct Drafting installation
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directory. The preview images in the right pane of the Navigator show a
number of drawing frames supplied with Creo Elements/Direct Drafting.

3. In the left pane of the Navigator, switch to the directory whose drawing files
you want to view.

4. In the right pane of the Navigator, scroll down until you see the preview image
of the drawing file you want to open. Note that the Navigator displays a
preview image for each file provided in the formats listed above.

5. Double-click on the preview image to open its associated drawing file in Creo
Elements/Direct Drafting.

6. If Creo Elements/Direct Drafting contains a drawing, you are prompted to
save this drawing before the selected file is loaded. Refer to Saving a Drawing
File via the Creo Elements/Direct Drafting File Browser on page 416 for
instructions.

7. Once the drawing is displayed in Creo Elements/Direct Drafting, you can edit
it as required.

Note
To return to the File Browser, simply close the Navigator.

Opening Most Recently Used Drawing Files
By default, the four most recently used drawing files are listed (complete with
filetype extension) in the Creo Elements/Direct Drafting File menu. To load one of
these files:

1. Pull down the Creo Elements/Direct Drafting File menu.
2. Click on the name of the drawing file you want to load.

Saving a Drawing File via the Creo Elements/Direct
Drafting File Browser
To save a drawing by means of the Creo Elements/Direct Drafting File Browser:

1. In Creo Elements/Direct Drafting, pull down the File menu and click Save to
display the File Browser. Alternatively, click the following button in the Creo
Elements/Direct Drafting toolbar:

2. Unless the filename you want to use is listed in the file pane of the File
Browser, pull down the Directory selection list and change to the directory
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where you want to store the drawing file. If this directory is specified in the
file pane, double-click on the directory name to list the files contained in it.

3. Click on an existing filename (to overwrite an existing file) or enter a new
filename (to create a new drawing file).

4. The system defaults to the most recent file type extension saved (startup
default is .mi). This is convenient if you save several files of the same type in
your work session. Thumbnail views are an exception; if you open a
Thumbnail, the extension of the file saved before the Thumbnail is kept as
most recent.

5. If you want to save the drawing in a format different from the most recent
saved, pull down the Filter selection list and select the applicable format:

• Model Interface Standard (*.mi)

• Model Interface Standard (*) (save MI format files without an extension or
with a custom extension)

• Compressed MI (*.bi) (compressed by means of the Z-lib mechanism)
• AutoCAD [version] DXF (*.dxf) (version 2013, 2010, 2007, and so on)
• Initial Graphics Exchange Format (*.igs)

• AutoCAD [version] Drawing (*.dwg)

• Virtual Reality Modeling Language (*.wrl)

• Drawing Web Format (*.dwf)

• Scalable Vector Graphics (*.svg)

• Text file (*.txt)

• ME10 [version] - MI [version] (*.mi)

• AutoCAD [version] Drawing (*.dwg) (version 2013, 2010, 2007, and so on)

Refer to Handling External File Formats on page 427 for further information
on external file format translators used by Creo Elements/Direct Drafting.

6. Click Add fonts if you have want to ensure that the fonts you used with this
drawing can be seen by others. This adds to the size of the file, but will ensure
that others who do not have the same fonts on their systems can read your
drawing text. Available for MI format only.

7. Click Save to save the drawing file.

Once you have completed this procedure, you can save the current drawing in
the same file by simply clicking Save in the File Browser.

Saving a Drawing File under a Different Name
To save a drawing under a different name:
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1. In Creo Elements/Direct Drafting, pull down the File menu.
2. Click Save As.
3. Unless the filename you want to use is listed in the file pane of the File

Browser, pull down the Directory selection list and change to the directory
where you want to store the drawing file.

4. Enter the name of the file in which you want to save the current drawing.
5. If you want to save the drawing in a format other than the most recent saved,

pull down the Filter selection list and select the applicable format. Note that
for DWF, VRML, and SVG, the file filter will be set back to the previous
choice. Refer to Saving a Drawing File via the Creo Elements/Direct Drafting
File Browser on page 416 for a list of supported formats.

6. Click Save to save the drawing file.

Saving a Drawing File in HPGL formats
To save an entire drawing, or the content of a viewport, or the content of a box in
an HPGL format:

1. Click File.
2. Click Print.
3. Click the drop-down menu in the Name field to see options:

• HPGL_GENERIC - Hewelett-Packard plotter language
• HPGL_GENERIC - improved version with text defined
• HPGL2_RTL_GENERIC - improved version with text and images

4. Select a generic option or click a boxed plus sign to select a model number
suboption.

5. Note that the Print to file box is automatically selected.
6. Click OK in the Print dialog box.
7. The Print to File save box appears. Browse to select an output location.
8. Click SAVE in the Print to File save box.
Note that these formats are based on generic printer drivers. For further
information on setting up a print configuration, refer to Creating a Print
Configuration on page 457.

Saving a Drawing File in PDF format
To save an entire drawing, the content of a viewport, or the content of a box in a
generic PDF format:
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1. Click File.
2. Click Print.
3. Click the drop-down menu in the Name field.
4. Note that the Print to file box is automatically checked.
5. Click OK in the Print dialog box.
6. The Print to File save box appears. Browse to select an output location.
7. Click SAVE in the Print to File save box.
For further information on setting up a print configuration, refer to Creating a
Print Configuration on page 457.

Saving Selected Elements
To save a selection of elements in your drawing:

1. Enter the following command into the user input line:
STORE

2. Select the element(s) you want to store.
3. Specify the name of the file (in apostrophes) in which you want to store this

selection.

Saving a Part
To save the active (current) part in the current Creo Elements/Direct Drafting
drawing:

1. In Creo Elements/Direct Drafting, pull down the File menu.
2. Click Store Part to display the Store Part dialog box.
3. Unless the filename you want to use is listed in the file pane of the File

Browser, pull down the Directory selection list and change to the directory
where you want to store the drawing file.

4. Enter the name of the file in which you want to save the current part.
5. If you want to save the part in a format other than MI (the default), pull down

the Filter selection list and select the applicable format. Refer to Saving a
Drawing File via the Creo Elements/Direct Drafting File Browser on page 416
for a list of supported formats.

6. Click Save to save the part in the specified drawing file.
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Loading a Part
When you use Load File, the drawing file you select or specify will be added to
any drawing already loaded in the Creo Elements/Direct Drafting workspace. In
the case of an assembly drawing, a part is loaded below the top part. This means
that there is no need to clear the memory as the top part has now been renamed,
for example to: EXAMPLE_ASSY.
To load a part:

1. In Creo Elements/Direct Drafting, pull down the File menu.
2. Click Load File.
3. Unless the file you want to add as a part is listed in the file pane of the Load

File dialog box, pull down the Directory selection list and change to the
directory where the file is stored. If this directory is specified in the file pane,
double-click on the directory name to list the files contained in it.

4. Switch on the Part check box option in the Load File dialog box.
5. Click or specify the filename.
6. If a file is provided in a format other than MI (the default), pull down the Filter

selection list and select the applicable format. Refer to Opening a Drawing
File via the Creo Elements/Direct Drafting File Browser on page 413 for a list
of supported formats.

Optionally, you can tick any or all of the following checkboxes:
As Subpart Loads a drawing as a subpart of the active part.
Absolute Loads the drawing back into the same position,

relative to the origin, from which it was
originally stored.

Keep Scale The original drawing scale is retained when the
drawing file is loaded.

Check 2D Creo Elements/Direct Drafting will check this
file for invalid elements (such as extremely short
lines) and will remove such elements.

Check 2D Retain
Dependency

Creo Elements/Direct Drafting will re-allocate
dependent elements (such as dimensions or
hatches) of removed invalid elements to plausible
valid elements.

7. Click Open to add the file as a part to the current drawing in Creo Elements/
Direct Drafting.

Creo Elements/Direct Drafting will automatically load the part into the
position, relative to the origin, in which it was originally created.
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Note
Creo Elements/Direct Drafting loads the file immediately below the top part.

Loading a Subpart
You can load a part file as a subpart under the active part.
To load a subpart:

1. In Creo Elements/Direct Drafting, pull down the File menu.
2. Click Load File.
3. Unless the file you want to add as a part is listed in the file pane of the Load

File dialog box, pull down the Directory selection list and change to the
directory where the file is stored. If this directory is specified in the file pane,
double-click on the directory name to list the files contained in it.

4. Switch on the As Subpart check box option in the Load File dialog box.
5. Click or specify the filename.
6. If a file is provided in a format other than MI (the default), pull down the Filter

selection list and select the applicable format. Refer to Opening a Drawing
File via the Creo Elements/Direct Drafting File Browser on page 413 for a list
of supported formats.

7. Click Open to add the file as a part to the current drawing in Creo Elements/
Direct Drafting.

Creo Elements/Direct Drafting automatically loads the part into the position,
relative to the origin, in which it was originally created.

Note
Creo Elements/Direct Drafting loads the file as a part. The part belongs to the
active part and is placed under it in the parts hierarchy.

Creating a New Drawing
To create a new drawing:

1. In Creo Elements/Direct Drafting, pull down the File menu and click New ▶
Drawing. Alternatively, click the following button in the Creo Elements/Direct
Drafting toolbar:
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2. If Creo Elements/Direct Drafting already contains a current drawing, you will
be prompted to save the drawing in a file before a new drawing is initiated.
Proceed as described in Saving a Drawing File under a Different Name on
page 417.

3. Create the drawing in the usual way.

Creating a New Creo Elements/Direct
Drafting Instance
Optionally, you can run multiple instances of Creo Elements/Direct Drafting at the
same time.
To create a new Creo Elements/Direct Drafting instance:

1. In Creo Elements/Direct Drafting, pull down the File menu and click New ▶
Window. Alternatively, click the following button in the Creo Elements/Direct
Drafting toolbar:

Note
• Each instance will run in a separate window.
• All Creo Elements/Direct Drafting instances are independent of each

other; there is no master or slave instance.
• Only a single Creo Elements/Direct Drafting license is required for any

number of Creo Elements/Direct Drafting instances run by the same user
on the same machine/display.

• Newly created Creo Elements/Direct Drafting instances are initiated
without the input_customize command. Consequently, any additional
applications associated with a given Creo Elements/Direct Drafting
instance are available in that instance only. For example, if you run a
licensed third-party standard parts library in a Creo Elements/Direct
Drafting instance, this library is not automatically available in another
Creo Elements/Direct Drafting instance.
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Opening an Existing Drawing File in a
New Creo Elements/Direct Drafting
Instance
To open an existing drawing file in a new Creo Elements/Direct Drafting instance:

1. In Creo Elements/Direct Drafting, pull down the File menu and click New ▶
Dwg in New Window.

2. In the file browser, switch to the appropriate directory.
3. Select the drawing file you want to load.
4. Click Open to load this drawing file in a new Creo Elements/Direct Drafting

instance.

Importing Macros, Fonts, Pictures, and
HPGL Files
You can import the following files into your current Creo Elements/Direct
Drafting drawing:

• Creo Elements/Direct Drafting Macros
• Fonts
• Pictures
• HPGL Files

Importing a Creo Elements/Direct Drafting Macro
To import a Creo Elements/Direct Drafting macro:

1. In Creo Elements/Direct Drafting, pull down the File menu and click Import.
2. Click Macro.
3. Click one of the following options:

Input to import a macro provided in ASCII format.
Load to import a macro provided in binary format.

4. Select the macro from the dialog box.
5. Click Open to open the macro.

Importing a Font
To import a font:
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1. In Creo Elements/Direct Drafting, pull down the File menu and click Import.
2. Click Font.
3. Click one of the following options:

Convert From TT/T1 to import a TrueType font provided in ASCII
format. Select a font from the dialog box and click
Convert to convert and load the font for use in Creo
Elements/Direct Drafting.

Load to import a font provided in binary format. Select a
font from the dialog box and click Open to load the
font for use in Creo Elements/Direct Drafting.

Specifying the Resolution of an Imported TrueType Font
To specify the resolution of a TrueType font you want to convert to a Creo
Elements/Direct Drafting font:

1. Enter the following command into the user input line:
CONVERT_TO_ME10_FONT

2. Enter the desired resolution. Note that the maximum value is 255.
3. Enter the font name.

Importing a Picture File
Creo Elements/Direct Drafting lets you import picture files in TIFF (*.tif,
compressed and uncompressed), BMP (*.bmp), JPEG (jpg) and PNG formats.
The following TIFF compression methods are supported:

• Packbits
• CCITT Group 3 1-Dimensional (modified Huffman encoding)
• CCITT Group 4
Being able to import images is particularly useful when you want to place a
scanned image onto your drawing or include a 3D model for better visualization.
To import a picture:

1. In Creo Elements/Direct Drafting, pull down the File menu and click Import.
2. Click Picture.
3. Select a bitmap file from the Import Raster Image dialog box.
4. Click Open to open the bitmap file in Creo Elements/Direct Drafting.
5. Give the picture a name.
6. In Creo Elements/Direct Drafting, specify the position for the imported bitmap

file.
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Refer to Editing Imported Pictures on page 432 for further details on handling
imported TIFF files in Creo Elements/Direct Drafting.

Importing an HPGL File
Creo Elements/Direct Drafting enables you to load HP-GL and HP-GL2 files. To
import an HP-GL (Hewlett-Packard Graphics Language) or HP-GL2 file:

1. In Creo Elements/Direct Drafting, pull down the File menu and click Import.
2. Click Load HPGL.
3. Specify the name (complete with path) of the HP-GL file you want to import.
4. In Creo Elements/Direct Drafting, specify the position for the imported HP-

GL file.

Exporting Macros, Fonts, and Pictures
You can export the following from your current Creo Elements/Direct Drafting
session:

• Creo Elements/Direct Drafting Macros
• Fonts
• Pictures

Exporting a Creo Elements/Direct Drafting Macro
To export a Creo Elements/Direct Drafting macro:

1. In Creo Elements/Direct Drafting, pull down the File menu and click Export.
2. Click Macro.
3. Click one of the following options:

Save to export and save a macro in ASCII format.
Store to export and save a macro in binary format.

4. Select a macro from the Select Macro dialog box. Optionally, click All to select
all macros.

5. Click OK to display the Save Macro dialog box.
6. Select or specify a macro file name (*.mac).
7. Click Save to save the macro file.
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Exporting a Font
When you have edited a font (or any character(s) included in a given font) by
means of the Font Editor (see Font Editor on page 295), you need to export this
font for further use.
To export a font:

1. In Creo Elements/Direct Drafting, pull down the File menu and click Export.
2. Click Font.
3. Click one of the following options:

Save to export and save a font in ASCII format.
Store to export and save a font in binary format.

4. Select a font from the Select Font dialog box. Optionally, click All to select all
fonts.

5. Click OK to display the Save Font dialog box.
6. Select or specify a font file name (*.fnt).
7. Click Save to save the font file.

Exporting a Picture
You can output your drawings in high-resolution pixel format:

1. Click File
2. Click Export
3. Select a picture for export.
Prompts are:
Enter PORT, BOX, DEL_OLD or "destination" - to select input

• Enter point, CURRENT or viewport number - to further select after
PORT

• Enter lower left and upper right corner of box which is to
be dumped - to select after BOX

Enter RESOLUTION or "destination"

• Enter PAPER_TO_PIXELS or output image width, height - if
you select RESOLUTION

○ PAPER_TO_PIXELS - recalculates paper format and dpi to your X,Y
resolution. You will be prompted for a paper format (A-E, A4-A0) or size,
and then you will be prompted for dpi.
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○ Enter output image width, height - enter width and height in
pixels. Enter -1 for either width or height to retain the ratio of the current
viewport and specify the other dimension in pixels.

Possible error messages are:

• Not enough memory available to perform the operation.
• ***The output image size is limited to a maximum of 4/3 billion pixels.

Handling External File Formats
Creo Elements/Direct Drafting provides the following translators for external file
formats:

• DWF Translator
• DXF Translator
• IGES Translator
• VRMLTranslator
To run one of these translators, double-click on the associated icon in the Creo
Elements/Direct Drafting program group. Each of these translators is controlled
via a DOS window.

Exiting Creo Elements/Direct Drafting
To exit Creo Elements/Direct Drafting:

1. In Creo Elements/Direct Drafting, pull down the File menu and click Close.
2. If there were any changes to your current drawing, you are prompted to save

these changes.
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16
Revision Checking

Using Revision Checking ......................................................................................... 430

This chapter tells you how to use the commands and options that allow you to
compare similar drawings. This facility is particularly useful in design offices
where successive drawings are revised and you need to identify the differences
between revisions. For example, suppose you create a drawing of a plate early on
in the development stage. A few weeks later you revise this drawing by stretching
it, adding fillets, and adding holes. You can now compare the original drawing
with the revised drawing to see where changes have been made. The differences
between the original and revised drawings are shown in color.

Note
Revision checking is possible on drawings stored in MI-format 2.10 or higher.
Incorrect results may occur if you attempt to compare drawings saved in MI-
formats earlier than 2.10. For OLE objects, the revision checking facility
compares the name of the native application, the class ID and the type of the
OLE object.

Figure 221. Original Drawing and Revised Drawing on page 429 shows the
original drawing (A) and the revised drawing (B). Figure 222. Both Files Loaded
on page 429 shows A and B superimposed so that you can easily identify the
modified elements.
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Figure 221. Original Drawing and Revised Drawing

Figure 222. Both Files Loaded
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Using Revision Checking
To use the revision checking facility, click Rev Check.

1. Click Load Files in Rev Check.
2. In the Load dialog box, specify the name of the original drawing file (for

example: dt_cs_rev06) and the name of the revised drawing file (for example:
dt_cs_rev10).

3. Enter `dt_cs_rev10'

Creo Elements/Direct Drafting displays the two drawings overlapping.
4. Click Geometry in Compare.

Creo Elements/Direct Drafting compares the location of the geometry and
texts (without comparing the parts structure) in the two drawings and shows
the result of the comparison in different colors according to the following
defaults:
Blue Identical geometry elements in both drawings
Green Differences in the original drawing
Red Differences in the modified drawing

The other options in the Compare menu do the following:
Annotation In addition to Geometry, this option also compares the

properties of the geometry and texts — linetype, color, text
attributes, info texts — and the dimensions and hatches in
both drawings.

Parts In addition to Annotation, this option compares the parts
structure in both drawings.
If you modify a drawing solely by a scaling factor, clicking
Parts displays all elements in red (indicating a difference).
However, the options Geometry and Annotation displays
elements and annotation in blue (indicating identical
elements).

Note
Both drawings must have the same location compared to the drawing origin to
get meaningful results from the comparison.

Be careful when working with scaling factors (Parts ▶ Scale).
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Viewing Single Drawings
When both drawings are loaded, you can toggle between them using View in Rev
Check. To display the original drawing only, click Original in View. To display the
revised drawing only, click Revised in View. To display both drawings, click Both
in View.

Continuing with the Drawing
When you are ready to continue with your drawing, click Original or Revised in
Continue. Creo Elements/Direct Drafting displays the selected drawing and
deletes the other drawing. You can now continue working on this drawing in the
usual manner.
Unlike the View command, the Continue command does not let you toggle
between the two drawings as it deletes the one you do not select.

Resetting Colors and Showing Differences
The colors generated after selecting an option in the Compare menu can be reset to
their original colors.
Reset Show Use this command to show the drawings in their

original colors.
Show Difference Use this command to show the drawing elements

in different colors, corresponding to the result of
the last comparison.

Changing the Color Scheme
To change the color scheme:

1. Click Set Color in Rev Check.
2. Select the color for changes in the original drawing.
3. Select the color for changes in the revised drawing.
4. Select the color for identical elements.
Refer to Defining Custom Colors on page 54 for instructions on defining custom
colors.
The color changes take effect with the next redraw.
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Show - Image Options
Show commands allow you to control the tradeoff between image quality and
processing speed for redraw.

Show/Hide
Images can be hidden to speed up processing. If the drawing includes several
images, you can choose to hide individual images or all images.
Use the SHOW PICTURES function to show or hide pictures.
Tip:When zooming with the dynamic mouse ([Ctrl] + right mouse button), hide
the images with the Box option.

Quality
When large drawings are placed on a small screen, some pixels from the original
drawing cannot be shown. Two or more pixels from the large drawing must be
mapped into one destination pixel on the screen. Traditionally, this operation
meant that small lines and details could disappear.
Creo Elements/Direct Drafting provides aliasing to let you control quality vs time
trade-offs of large drawing displays. Aliasing algorithms establish an area of
investigation in the large drawing; formulas compute an average color tone for
that area; and the system maps that color result to the destination pixel. Areas of
investigation are based on one pixel and a pattern of its neighbors. Color tone
result is grey-scale, an average of the original black and white pixels.
To control display quality using aliasing:

1. Click Picture.
2. Click Anti-alias Factor in Show.

• Specify picture quality number. Enter a number between -2 and
+2.

• Select pictures for which to apply the change.

Positive input between 0 and 2 tells the system to use a block of converging
pixels in the aliasing formula. Input 2 to use the largest possible block of
neighboring pixels. This results in the slowest possible operation.
Input 0 to produce the fastest operation. No aliasing.
Negative input between 0 and -2 tells the system to use pixels on a diagonal in
the aliasing formula. This option is much faster than using blocks, and often
produces a picture of good quality. Input -2 to use the largest number of
neighboring diagonal pixels in the aliasing formula.
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Editing Pictures
When you have imported a bitmap (BMP or TIFF or JPEG or PNG) file as
described in Importing a Picture File on page 424, you can edit it as an image in
Creo Elements/Direct Drafting.

Moving an Image
To move an image, click Modify ▶Move, and select a method.

Rotating an Image
To rotate an image, click Modify ▶ Rotate, and select a method.

Scaling an Image by X and Y Factors
To scale an image, click Modify ▶ Scale, and select a method.

Arranging Images
To arrange images:

1. Click Change Level in Picture.
2. Choose among these options:

• To Front to move an image in front of all other objects.
• Forward to move one level forward.
• In Front of [selection] to move in front of a reference object.
• To Back to move an image in back of all other objects.
• Backward to move one level backward.
• Behind [selection] to move behind a reference object.

3. Select the image you want to move to the foreground or background.
When two pictures overlap, only one picture is shown on the screen or printed. All
the pictures within the same part are ordered according to level. Similarly,
subparts are ordered according to level. In other words, the level is the position of
an object (picture or part) in the sequence of all the objects within the same part
(without subparts).
The picture that is in front of another is shown when two pictures overlap.
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Note
The command CHANGE_LEVEL changes the level of a single part or subpart
as well as a picture.

Restriction: If you have multiple subparts, you cannot have some pictures in one
subpart in front of pictures in another subpart, and some behind. You can only
have all pictures from one subpart in front of all pictures in another subpart.

Using an external editor
1. Click External Edit in Picture.
2. Click the picture to be edited. The external editor will open a new window.
3. Edit the picture and close the external editor.
The default external editor is MS Paint. To specify a different external editor, set
the environment variable MEPICEDITOR (first choice) or
SDTOOLBARICONEDIOR (second choice).

Updating a picture
To update a single picture with the contents of the new bitmap picture file:

1. Click Update in Picture.
2. Click the picture to be updated.
3. Enter:

• the file name of the new picture, or
• an empty string (two single quote marks - '' ) to use the remembered, or

default, file.

Changing the Color of Pixels
After you have imported an image, you probably want to clear unwanted
information or simply clean it of the debris usually associated with scanned
images. This is done by changing the color of the pixel data. If the image is black
and white, you can only reverse the color (black to white or white to black).
Changing the color of individual pixels to the background color of the image
appears to delete the pixel. However, you have only colored the pixel. It is not
possible to delete pixels in order to see through to an underlying image.
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Figure 223. Cleaning an Imported Image

You can clean up or edit an image with the following Change Color options:

Item Description
1 Box option
2 Poly option
3 Brush option

To change the color of pixels:

1. Click Picture ▶ Change Color ▶ Change.
2. Select the image.
3. Select one of the following options:

a. Box - and enclose the required pixels in a box
b. Poly - and enclose the required pixels in a polygon
c. Brush - press and hold down the [Shift] key while dragging the cursor over

the pixels to be colored (the cursor changes shape)
4. Click End to end the command.
Additional Information:

• If the Brush color is different from the background color, you can add or red-
line information on the image.

• The image is always described by a rectangular frame. If you rotate the image,
the frame increases/decreases according to the horizontal and vertical lines
passing through the corners; see Figure 224. Rotating an Imported Image on
page 437. The swept area is only temporary — it disappears along with any
pixel editing you may have done.
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Figure 224. Rotating an Imported Image

Modify
Relocate allows you to move a picture:

1. Click Picture ▶ Modify ▶ ReLocate.
2. Select an image to move.
3. Select a reference point.
4. Select a destination point.
BW Invert allows you to change between white-on-black and black-on-white
displays:

1. Click Picture.
2. Click Modify.
3. Click BW Invert - prompts you to select a picture to invert.
4. Click End.

Note
BW Invert only works on true black and white displays, not grey or color.

Transparency
You can select one color in your picture to become transparent when that picture
overlays another picture. The color you select for transparency becomes invisible,
allowing you to see through those pixels to the lower picture.
To set transparency attributes:

1. Click Picture.
2. Click Transparency.

Editing Imported Pictures 437



• On - Prompts you to select a picture. If that picture has a transparency
color, the color will become invisible during overlay.

• Off - Prompts you to select a picture. If that picture has a transparency
color, the color will not become invisible (default setting).

• Color - To select a picture and apply the transparency color you have
chosen from the color menu to it.

Note
Transparent picture attributes must be set by Creo Elements/Direct Drafting.
Attributes from other programs such as those written in jpg, tiff, etc. will not
be supported. All imported files will be opened as not transparent.

Using the Picture Browser
When you click Picture Browser in Picture, Creo Elements/Direct Drafting
displays the Picture Browser. This browser displays information about the
currently loaded images:
Name Filename and path of the image
Z-level Numerical value for the "hidden" level assigned to an

image in the drawing
Show Status of the SHOW command; ON, OFF, or BOX
X-Scale Scaling factor in the x-direction
Y-Scale Scaling factor in the y-direction
Angle Angle of rotation

Deleting an Image
To delete an image, use the Delete command in the main menu.

Additional Information
• The imported figure is embedded in the MI file format. In the MI file, the

pixel data will be handled in a special section as ASCII characters.
• The imported image maintains its aspect ratio.
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• If two images overlap each other, the options in Picture ▶ Change Level can be
used to move the image forwards or backwards. Click in a non-overlapping
area to select the image. Alternatively, enter the name on the user input line.

• If drawing geometry overlaps an image, it is placed at the front of the image
(s).

Tip
Change the color of the overlapping geometry.

• Plotting of images is supported by raster-based plotters only (for example,
plotters supporting PostScript or HP-GL/2 plus RTL). Images are ignored on
non-supported plotters.

• IGES and DXF/DWG translators do not translate pictures by default and
report a warning message in the log file when pictures are skipped.

• The Store Pixel Data switch in the IGESo.conf file allows storage of picture to
separate files.

• When a picture is loaded, the size of the picture (in current units) is
determined by the factor (current_viewport->factor which is number of current
units per pixel). Hence the actual size of the image depends on the current
value of the zoom factor.

• When an image with more colors than supported by the hardware is loaded
and subsequently saved, loss of color occurs. For example, if an image
containing 1500 colors is loaded on a machine which can display only 256
colors and saved, only 256 out of the 1500 colors are saved in the MI file.
(The pixels with the lost colors are mapped to the nearest available color in the
color table.) This changes the size of the MI file once a load and save is done
across different platforms (with different number of bitplanes) without any
deletion of data (image contents) in the file.
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Linking and Embedding OLE

Objects
Inserting an OLE Object........................................................................................... 441
Editing an OLE Object in Creo Elements/Direct Drafting ............................................. 442
Using the OLE Browser............................................................................................ 443

Files (such as spreadsheets, graphics or text pages) created in external applications
can be included in Creo Elements/Direct Drafting by inserting associated OLE
objects. Drawings containing OLE objects can be printed as PDF and PS files.
Please note the following:

• OLE functionality is only supported in the Windows user interface.
• An Creo Elements/Direct Drafting file containing OLE objects added in the

Windows user interface can be loaded in the Classic User Interface but the
OLE information will not be displayed. However, the existing OLE
information is retained, even if the Creo Elements/Direct Drafting file is saved
in the Classic User Interface.

Note
Creo Elements/Direct Drafting can also be inserted as an OLE object in other
applications that support OLE.
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Inserting an OLE Object
To insert an OLE object into an Creo Elements/Direct Drafting drawing:

1. In Creo Elements/Direct Drafting, pull down the Insert menu and click Object.
2. The Insert Object dialog box lists all applications on your system that provide

OLE capability.
3. Scroll down the list and select an application.
4. Select one of the following options by clicking the associated radio button:

• Create New

• Create from File

Create New
This option inserts a new OLE object of the selected application into your Creo
Elements/Direct Drafting drawing.
To create a new OLE object:

1. Select an object type from the Object Type list and click OK.
2. If you use the Display As Icon option, the OLE object will be represented by

the associated application icon in Creo Elements/Direct Drafting. Optionally,
click Change Icon to select a different icon for the OLE object.

3. Retain the default OLE object name or specify a name for the OLE object in
the User Input Line.

4. Specify the insertion position for the OLE object in Creo Elements/Direct
Drafting.

The OLE object is displayed in the Creo Elements/Direct Drafting drawing.

Create From File
This option inserts the contents of a file as an object into your document so that
you can activate the object by means of the application in which it was created.
To create an OLE object from an existing file:

1. Click Browse. Select the file you want to link from the File Browser.
2. Click Open to open this file.
3. Optionally, switch on Link to link the OLE object to its source application such

that changes in the original file are reflected in the OLE object in Creo
Elements/Direct Drafting.
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4. If you use the Display As Icon option, the OLE object will be represented by
the associated application icon in Creo Elements/Direct Drafting. Optionally,
click Change Icon to select a different icon for the OLE object.

5. Click OK.
6. Retain the default OLE object name or specify a name for the OLE object in

the User Input Line.
7. Specify the insertion position for the OLE object in Creo Elements/Direct

Drafting.

The OLE object is displayed in the Creo Elements/Direct Drafting drawing.

Editing an OLE Object in Creo Elements/
Direct Drafting
Once the OLE object is inserted in the Creo Elements/Direct Drafting drawing,
you can edit it as described in the following sections.

Arranging OLE Objects
To arrange OLE objects:

1. Pull down the Insert menu.
2. Click OLE, Change Level and To Front or To Back, Forward or Backward, In

Front of or Behind.
3. Select the OLE object you want to arrange.

Activating an OLE Object
By activating an OLE object, you open the underlying file in its source application
for editing. OLE objects you created by means of the Create from File option will
reflect changes in the underlying file.
To activate an OLE object:

1. Pull down the Insert menu.
2. Click OLE and Activate.
3. Select the OLE object to be activated.

Renaming an OLE Object
You can rename an existing OLE object in a drawing.
To rename an OLE object:
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1. Pull down the Insert menu.
2. Click OLE and Rename.
3. Select the OLE object to be renamed.
4. Type the new name of OLE object in the User Input Line.
5. Press Enter.

Using the OLE Browser
To display the OLE Browser:

1. Pull down the Insert menu.
2. Click OLE and then OLE Browser.
The OLE Browser displays information about the OLE objects currently included
in your Creo Elements/Direct Drafting drawing:
Name The name you specified for the OLE object
Z-level Numerical value for the "hidden" level assigned to an

image in the drawing
Show Status of the SHOW command; ON, OFF, or ICON
X-Scale Scaling factor in the x-direction
Y-Scale Scaling factor in the y-direction
OLE Type OLE object type
Program ID Application object type
Class ID OLE object class ID

The OLE objects can be activated, deleted, renamed, saved, converted to icons
and hidden or shown using the OLE Browser.
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Loading an Annotation Drawing................................................................................ 448
Using the Sheet Browser to Navigate among Sheets and Views.................................. 448
Views ..................................................................................................................... 448
Showing Differences in a View Following a 3D Change .............................................. 450
Handling Annotation Elements ................................................................................. 450
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Hiding, Deleting, Unhiding........................................................................................ 452
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Storing the Drawing for Further Use in Annotation...................................................... 455

This chapter discusses the Creo Elements/Direct Drafting Annotation module.
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Introduction
The Annotation module included in Creo Elements/Direct Drafting enables you to
visualize, annotate and edit MI format 2D drawings generated by Creo Elements/
Direct Annotation.

General Procedure
The general Creo Elements/Direct Drafting Annotation procedure comprises the
following steps:

• Prepare the Creo Elements/Direct Drafting drawing environment for
Annotation.

• Load an MI file generated in Creo Elements/Direct Annotation.
• View, annotate and edit this file as appropriate. For example, you can

manipulate views and you can hide or delete elements. Also, you can modify
and/or add geometry by means of regular Creo Elements/Direct Drafting
commands. Note that a warning message is displayed for any "structurally
dangerous" operations that would impair 3D/2D associativity.

• After making changes to the underlying 3D model in Creo Elements/Direct
Drafting, update the relevant view(s) to visualize and review the resulting
changes in 2D.

• Edit the 2D views as appropriate.
• Check the part structure of the Annotation MI file by means of the Creo

Elements/Direct Drafting Part Browser.
• Save the 2D drawing for further use in Creo Elements/Direct Drafting or in

Creo Elements/Direct Annotation.

Annotation Rules
To ensure that the Annotation MI drawing file retains its 3D/2D associativity for
further use in Creo Elements/Direct Annotation, you must observe the following
rules when using the Creo Elements/Direct Drafting Annotation module:

• Do not copy one drawing into another drawing.
• Do not manually insert one or more sheets into another drawing.
• Do not manually insert views into a sheet (using the view definition

commands of Creo Elements/Direct Annotation). Only use the Sheet
commands provided by the Creo Elements/Direct Drafting Annotation module.

• Do not change or delete info texts beginning with "SD_" or "DOCU" or "AM_
".

Annotation 445



• Do not modify view parts or 3D parts below view parts with the commands in
the Modify menu of Creo Elements/Direct Drafting. Only use the View
commands provided by the Creo Elements/Direct Drafting Annotation module.

• Do not scale view parts or 3D parts below view parts with the command in the
Parts menu of Creo Elements/Direct Drafting. Only use the Scale command
provided by the Creo Elements/Direct Drafting Annotation module.

• Do not change the scale of the TOP part or the parts below the TOP part with
the Creo Elements/Direct Drafting Parts ▶ Scale commands.

• Do not change the owner of a part or subassembly (which belong to the
drawing) in Creo Elements/Direct Drafting.

• Do not use Creo Elements/Direct Drafting to smash or gather any part created
by Creo Elements/Direct Annotation (sheets, frames, view parts, parts below
view parts, sketches).

• Do not create detail parts in Creo Elements/Direct Drafting — these would not
be associative to the 3D model. Use the Detail command in Creo Elements/
Direct Annotation to create detail views.

Preservation of Modifications
The following modifications in the Creo Elements/Direct Drafting Annotation
module are preserved when an update is performed in Creo Elements/Direct
Annotation:

• Attribute changes such as line type or line color, info text added to geometry
elements derived from the 3D model.

• Centerlines created in Creo Elements/Direct Drafting.
• Dimensions, texts, symbols and additional 2D geometry created in the

appropriate view parts. (Note that symbols, text and additional 2D geometry
can be added to each part except the TOP part).

• Geometry belonging to subparts which are not owned by the TOP part named
"SD_drawing".

• Hatches added in Creo Elements/Direct Drafting.

Limitations
Some operations performed in the Creo Elements/Direct Drafting Annotation
module will not deliver the expected results after reloading and updating in Creo
Elements/Direct Annotation.

• Parts created in Creo Elements/Direct Drafting as sub-parts of the TOP part
named "SD_drawing" will not be loaded into Creo Elements/Direct
Annotation.
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• Geometry or any other additional elements created in the TOP part named
"SD_drawing" will not be loaded into Creo Elements/Direct Annotation.

• Subparts created in Creo Elements/Direct Drafting (and which are not owned
by the TOP part) will not be displayed in the Drawing Browser of Creo
Elements/Direct Annotation. However, their geometry is displayed in the
viewport.

• Leader lines (or text with leaderlines) created in Creo Elements/Direct
Drafting will not behave associatively in Creo Elements/Direct Annotation.

• Hatch holes automatically created in Creo Elements/Direct Drafting (forced by
dimensions or texts when Creo Elements/Direct Drafting option TEXT_
HOLE_INSERTION is set to ON by default) do not update associatively in
Creo Elements/Direct Annotation.

• Hatch holes automatically created in Creo Elements/Direct Annotation for text
do not update associatively in Creo Elements/Direct Drafting when the text is
changed in Creo Elements/Direct Drafting.

• Hatches that were automatically created in Creo Elements/Direct Annotation
but deleted in Creo Elements/Direct Drafting will re-appear after the next
update in Creo Elements/Direct Annotation.

• 2D view parts created in Creo Elements/Direct Annotation that are renamed in
Creo Elements/Direct Drafting get their original name during the next update
in Creo Elements/Direct Annotation.

• If you split or merge 2D geometry in Creo Elements/Direct Drafting which
was derived from the 3D geometry during an update in Creo Elements/Direct
Annotation, the geometry will look like the original one after the next update
in Creo Elements/Direct Annotation.

Preparing the Creo Elements/Direct Drafting
Drawing Environment
Before you load an MI file generated in Creo Elements/Direct Annotation, be sure
to complete the following steps:

1. To make sure that the top part is empty, enter the following into the user input
line:
RESET_SYSTEM
CONFIRM

2. Activate the Creo Elements/Direct Drafting Annotation module by clicking
Modules ▶ Annotation.
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Loading an Annotation Drawing
Load an MI file generated in Creo Elements/Direct Annotation as follows:

1. Go to File ▶ Open.
2. Select the MI file you want to load from the Creo Elements/Direct Drafting

file browser.

Using the Sheet Browser to Navigate
among Sheets and Views
The Sheet Browser enables you to quickly and easily select a sheet or a view
included in a sheet.

Displaying the Sheet Browser
To display the Sheet Browser:

1. In Annotation, click Drawing ▶ Sheet ▶ Sheet Browser.
2. Drag the Sheet Browser to where you want to display it.

Selecting a Sheet or View from the Sheet Browser
To select a sheet from the Sheet Browser:

1. In the Sheet Browser, click Curr Sheet.
2. Click on the associated sheet number in the right-hand column of the Sheet

Browser.
To select a view from the Sheet Browser:

1. In the Sheet Browser, select the sheet in which this view is included.
2. Click Curr View.
3. Click on the associated view number in the right-hand column of the Sheet

Browser.

Views
The Creo Elements/Direct Drafting Annotation module provides a number of
commands for selecting, changing and manipulating views.
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Selecting the Current View
In addition to the method described in Selecting a Sheet or View from the Sheet
Browser on page 448, you can proceed as follows to select the current view in the
current sheet:

1. In Annotation, click Drawing ▶ View ▶ Current View.
2. Click on the view you want to make current.

Modifying Views
You can change the position of views on a sheet. Also, you can move views
between sheets. Note that a warning message is displayed for any "structurally
dangerous" operations that would impair 3D/2D associativity.
To change the position of one or multiple views:

1. In Annotation, click Drawing ▶ View ▶Modify View.
2. Select the option for the view change you want to perform:

Move 2Pts Moves the selected view(s) from the first point to
the second point.

Move Horizontal Moves the selected view(s) by the specified
horizontal distance.

Move Vertical Moves the selected view(s) by the specified
vertical distance.

Move Sht to Sht Moves the selected view(s) to another sheet.
Rotate Rotates the selected view(s) by the specified angle

about the specified center.
Scale Scales the selected view(s).

Hiding Hidden Lines
To hide hidden lines in the Annotation MI file:

1. In Annotation, click Drawing ▶ View ▶ Hide ▶ Hidden Line.
2. Select the view(s) in which you want to hide hidden lines.

Hiding Tangent Lines
To hide tangent lines in the Annotation MI file:

1. In Annotation, click Drawing ▶ View ▶ Hide ▶ Tangent Line.
2. Select the view(s) in which you want to hide tangent lines.
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Showing Hidden Lines
To show (previously hidden) hidden lines in the Annotation MI file:

1. In Annotation, click Drawing ▶ View ▶ Show ▶ Hidden Line.
2. Select the view(s) in which you want to show hidden lines.

Showing Tangent Lines
To show (previously hidden) tangent lines in the Annotation MI file:

1. In Drawing ▶ View ▶ Show ▶ Tangent Line.
2. Select the view(s) in which you want to show tangent lines.

Showing Differences in a View Following
a 3D Change
Any view you see in the Creo Elements/Direct Drafting Annotation module is a
2D derivative of a 3D model view in Creo Elements/Direct Drafting. When the
underlying 3D model changes in Creo Elements/Direct Drafting, you can update
the associated view in Creo Elements/Direct Drafting Annotation and check for
differences in the view before and after this update.

Showing Differences
In Annotation, click Drawing ▶ View ▶ Show Difference.

• By default, the Creo Elements/Direct Annotation update colors are used to
mark differences as well as unchanged elements.

• Any unchanged elements are marked by the equal info text flag.
• Any changed elements are marked by the non-equal info text flag.

Hiding Differences
To hide the differences in a view before and after the update of the underlying 3D
model, click Drawing ▶ View ▶ Reset Show. Note that Reset returns the view to
the state prior to Show Difference.

Handling Annotation Elements
Optionally, you can change or accept annotation elements.
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Changing an Annotation
You can change an annotation, e.g. by selecting a different reference element.
To change an annotation:

1. In Annotation, click Drawing ▶ View ▶ Annotation ▶ Change.
2. Click on the annotation you want to change.
3. Follow the prompts displayed in the prompt line.

Accepting All Annotation Elements
To accept all (current or changed) annotation elements, click Drawing ▶ View ▶
Annotation ▶ Accept.

Dimensions

Moving a Dimension
To move a dimension:

1. In Annotation, click Drawing ▶ View ▶ Dimension ▶Move.
2. Click on the dimension you want to change.
3. Drag the dimension text to its new position.

Returning a Moved Dimension to Its Original
Position
To move a dimension back to its original position:

1. In Drawing ▶ View ▶ Dimension ▶ Reset.
2. Click on the dimension you want to restore.

Sheets
You can create, select, change, and modify sheets.

Creating a Sheet
To create a new sheet:

1. In Annotation, click Drawing ▶ Sheet ▶ Create Sheet.
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2. Enter a number for the new sheet. Check the Sheet Browser for existing sheet
numbers.

3. In the Load Frame browser, select a frame for the new sheet.
You can now add new views to this sheet, e.g. by moving from an existing sheet
or by loading a view from Creo Elements/Direct Drafting.

Selecting the Current Sheet
To make a sheet current:

1. In Annotation, click Drawing ▶ Sheet ▶ Current Sheet.
2. Click on the sheet you want to make current.
Alternatively, select the current sheet from the Sheet Browser (see Selecting a
Sheet or View from the Sheet Browser on page 448).

Modifying a Sheet
You can change the position of the frame of a sheet. Also, you can replace the
current frame of a sheet by a different sheet, or you can delete a sheet. Note that a
warning message is displayed for any "structurally dangerous" operations that
would impair 3D/2D associativity.
To modify a sheet:

1. In Annotation, click Drawing ▶ Sheet ▶Modify Sheet.
2. Select the option for the change you want to perform:

Frame Type to select a different frame from the Load Frame
browser, thus replacing the existing frame by the
newly selected one.

Frame Position to move the frame to the desired position.
Delete to delete the sheet.

Hiding, Deleting, Unhiding
The Creo Elements/Direct Drafting Annotation module provides a number of
commands for selectively hiding, deleting or unhiding elements in the drawing.
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Hiding or Deleting Elements
Any elements you hide are simply "invisible" in the drawing. Any elements you
delete are physically removed from the drawing. Note that a warning message is
displayed for any "structurally dangerous" operations that would impair 3D/2D
associativity.
To hide or delete elements:

1. In Annotation, click Hide Geometry.
2. Select the option for the operation you want to perform:

No Delete Hides element but does not delete them. Elements
hidden in this way can be restored through an Unhide
operation.

Prev Delete Deletes any elements you have previously marked as No
Delete. Elements deleted in this way cannot be restored
through an Unhide operation.

Final Delete Deletes (removes) elements. Elements deleted in this
way cannot be restored through an Unhide operation.

3. Click Hide (the menu field above these three options).
4. Click or box the elements you want to hide or delete.

Unhiding Elements
Any elements that you have hidden by means of the No Delete Option can be
unhidden.

Unhiding Selected Elements
Elements that have been hidden (but not deleted) can be selectively unhidden.

1. In Annotation, click Unhide Geometry ▶ Selected. Any elements previously
hidden by means of the No Delete option are now shown in a special highlight
color for selection.

2. Click or frame the element(s) you want to unhide.

Sequentially Unhiding Elements
Optionally, you can sequentially unhide elements that have been hidden (but not
deleted).

1. In Annotation, click Unhide Geometry ▶ Sequential. Any hidden elements are
shown in a special highlight color.
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2. Select the direction for your sequential Unhide operation:
Backward Undoes your Hide operations in reverse order; i.e. the last

Hide operation is undone first. Optionally, enter the
number of backward Unhide Geometry steps.

Forward Undoes your Hide operations in the order in which they
were performed; i.e. the first Hide operation is undone
first. Optionally, enter the number of forward Unhide
Geometry steps.

Next Undoes the next Hide operation in the current direction
(Backward or Forward).

3. Any unhidden elements are now shown in a special highlight color.

Changing Colors, Linetypes and Hatches
In the Annotation module, you can change the color and linetype of hidden lines
and tangent lines. Also, you can change the color, angle, and distance of hatches.

1. In Annotation, click Drawing, View, Change.
2. Select the change you want to perform:

Hidden Line to change the color and/or linetype of hidden lines.
Tangent Line to change the color and/or linetype of tangent lines.
Hatch to change the color and/or angle and/or distance of

hatches.

3. To change these settings, follow the general instructions provided in Changing
the Drawing Environment and Making Measurements on page 46.

Showing and Storing
When you have completed your work on the Annotation MI drawing file, you may
want to see what this drawing would look like in Annotation or in Creo Elements/
Direct Drafting.

Showing the Drawing in Annotation Mode
To show the drawing in annotation mode, click Show as Annotation in Annotation.
This mode reflects your Hide operations.
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Showing the Drawing in Creo Elements/Direct
Drafting Mode
To show the drawing in Creo Elements/Direct Drafting mode, click Show as
AnnotationCreo Elements/Direct Drafting in Annotation. This mode ignores any
Hide operations but reflects any Prev Delete and Final Delete operations.

Storing the Drawing for Further Use in
Annotation
To store the drawing for further use in Creo Elements/Direct Annotation:

1. Go to File ▶ Save.
2. Enter the name of the file in which you want to store the current Annotation

MI drawing.

Annotation 455



20
Printing and Plotting

Using the Print Manager .......................................................................................... 457
Creating a Print Configuration .................................................................................. 457
Defining the Print/Plot Settings ................................................................................. 459
Previewing a Print/Plot............................................................................................. 469
Starting a Print or Plot Job........................................................................................ 469
Printing or Plotting Multiple Drawing Files.................................................................. 469
Dumping the Creo Elements/Direct Drafting Screen ................................................... 470
Further Information.................................................................................................. 470

This chapter shows you how to print and plot drawings and how to produce screen
dumps.
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Using the Print Manager
In a Windows environment, Creo Elements/Direct Drafting spools all plots and
screen dumps either to the Print Manager or to the Clipboard, and not directly to
an output device.
The Print Manager controls device selection, configuration, and spooling for the
printers and plotters on your system. Once you send a plot from Creo Elements/
Direct Drafting to the Print Manager, the Print Manager takes over the process of
producing the final output. By setting REQUEST_PRINT_SETUP, you can
directly access the Print Manager's setup dialogs each time you plot or screen
dump.
The Clipboard temporarily stores a plot or screen dump so that it can be
electronically transferred or "pasted" into another application.

Note
Depending on the output device(s) on your system, the Print Manager may
allow you to set several printer/plotter options in addition to those offered by
Creo Elements/Direct Drafting. Refer to your Windows documentation and
hardware manuals for information on configuring your printer/plotter to work
with Windows.

Creating a Print Configuration
To facilitate the creation of consistent print/plot output, Creo Elements/Direct
Drafting enables you to create any number of print configurations.
To create a print configuration:

1. Pull down the File menu and click Print. Alternatively, click the following
button in the Creo Elements/Direct Drafting toolbar:

2. In the Print menu, select and/or specify the settings you want to save in the
new print configuration. These settings are discussed in the following sections
of this chapter.

3. In the Print configuration section of the Print menu, click Settings.
4. At the top of the Print Configurations dialog box, specify a name for the print

configuration you want to create.
5. Click Add to add this new print configuration name to the list of print

configurations.
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6. If you want to save the print configuration for future use, select it and click
Store.

7. In the Store Print Configurations dialog box, select or specify a name (such as
my_print.m) for your print configuration file. Note that this filename does
not have to be the same as the print configuration name. However, be sure to
specify a name that is readily identified.

8. Click Save to save this file.

Example of a Print Configuration
The following is an example of a Creo Elements/Direct Drafting print
configuration.
{ User specific customization }
WIN_PRT_MGR PAPER 'a3' ORIENTATION LANDSCAPE COPIES 1 END
PLOT_SCALE AUTO
PLOTTER_TYPE ADD MSWINDOW_GDI_PRINTER PRT_DRIVER 'HP LaserJet
1100' 'department_1' END

WIN_PRT_MGR PAPER 'a4' ORIENTATION PORTRAIT COPIES 1 END
PLOT_SCALE AUTO
PLOTTER_TYPE ADD MSWINDOW_GDI_PRINTER PRT_DRIVER 'HP DeskJet'
'department_2' END

WIN_PRT_MGR PAPER 'a4' ORIENTATION LANDSCAPE COPIES 1 END
PLOT_SCALE AUTO
PLOTTER_TYPE ADD MSWINDOW_GDI_PRINTER PRT_DRIVER 'HP LaserJet
1100' 'department_3' END

PLOTTER_TYPE 'department_3'

{ plot it }
PLOT 0,0 0 all BW_IMG NORM_VIDEO

The settings in this customize_p.m print configuration file imply the
following:

• One copy of the drawing is printed to A4 paper in landscape orientation.
• The drawing is scaled to fit.
• The PLOTTER_TYPE variable is set to department_3. This is the printer

that will be used as the output device.
• The entire drawing is printed in normal (as opposed to inverse) video.
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Re-Using a Saved Print Configuration
When you quit Creo Elements/Direct Drafting, the system automatically saves
your current print settings. This will be the setting used when you start Creo
Elements/Direct Drafting again.
You can see and modify your current configuration file by opening
<application data path>\PTC\Creo Elements Direct Drafting
[version]\[version]\print_configurations\current_print_
cfg.m.
You can also use existing or create your own configuration files. If you use the
name convention (print_cfg_<configuration name>.m) for your own
configuration files and place them in the print_configurations
subdirectory then these files appear in the Print menu as a Print configuration.
Configurations that you create with the Print dialog are automatically stored in
this subdirectory when you store your configuration.
To re-use binary legacy print configuration files (with file name <print
configuration>.cfg) from a CoCreate Drafting version < 13.00:

1. Click File ▶ Print from the main menu. The Print dialog box opens.
2. Under Print Configuration, click Settings. The Print Configurations dialog box

opens.
3. In the Print Configurations dialog box, click Load. The Load Print

Configurations dialog box opens.
4. In the Load Print Configurations dialog box, select the print configuration file.
5. Click Open. The print configuration appears in the Name list.
6. In the Print Configurations list, selects the print configuration.
7. Click Close to close the Print Configurations dialog box.

The Print menu settings change to the settings contained in the newly loaded
print configuration.

Defining the Print/Plot Settings
Before printing or plotting a drawing, you should define exactly what will be
printed/plotted and how the drawing will be printed/plotted.

Setting the Plot/Print Destination
Creo Elements/Direct Drafting provides a wide range of printer/plotter output
options. After you select an option, you can send plots and screendumps either to
the Windows Print Manager or to the Clipboard. You usually send plots to the
Print Manager for output on the system's default printer or plotter. Send a plot to
the Clipboard if you want to insert it into another Windows application.
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Note
Creo Elements/Direct Drafting automatically derives the extension for the
output file according to the selected printer/plotter.

Selecting a Printer or Plotter
To set a printer or plotter:

1. Click File ▶ Print from the main menu.
2. Click the tab labeled Printer.
3. Pull down the Name selection list in the Printer section of the Print menu.
4. Select the printer or plotter from this list.
5. Note the boxed plus sign beside some generic options. Click the plus sign to

see and select model number suboptions.
6. Click Properties to set the properties (such as the paper size and the

resolution) of this printer or plotter.
If the printer or plotter you want to use is not included in this list, use standard
Microsoft Windows techniques to install, set up and configure this printer or
plotter.

Note
Refer to your Windows documentation and hardware manuals for information
on configuring your printer/plotter to work with Windows.

Stop on Error
Check this box if you want a warning message when drawings do not fit on the
selected paper size. The system will check:

• whether the size of the drawing will fit on the selected paper format
• when printing Annotation drawings, whether the largest one matches the

chosen plot configuration. If not, you will see the warning, "Plot doesn't fit on
paper" and you can stop the process.

Routing the Print/Plot Output to a File
If you want to send the print/plot output to a file, click on the Print to file check
box.
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Be sure to select the printer or plotter in whose format you want to create this
output file. For example:

• If you want to create an HP-GL file, select an HP-GL compatible plotter.
• If you want to create a PostScript file, select a PostScript printer.
• If you want to create a PDF file, select the PDF Generic option.
When you click OK to start the print/plot job, you are prompted for a filename.

Setting the Paper Size and Number of Copies
Select the applicable paper size from the Format selection list in the Paper section
of the Print menu.
If you have a multi-sheet drawing, click Use sheet format to automatically set the
format and orientation of each sheet based on the sheet size.
To set the number of copies, either click the up or down arrow in the spin box to
change the number, or enter the number in the Copies field.

Setting Orientation
Select:

• Portrait
• Landscape

Note
If you set the paper size such that the height and width are equal, the
orientation is set to landscape by default.

Positioning Your Drawing
To position your drawing

1. Click File ▶ Print from the main menu.
2. Click the Drawing tab.
3. Select a Position.

• Center: the default option. Creo Elements/Direct Drafting places the
bounding box centered on the paper.
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• Left: to position your drawing at the lower left corner prior to printing/
plotting. Creo Elements/Direct Drafting will place the bounding box in the
lower left corner of the paper.

For both Center and Left, you can specify an offset in the X direction and in
the Y direction. The print/plot output will be moved accordingly in the X
direction and/or Y direction.

Note that these offsets are interpreted in terms of the current length unit (such
as mm) set up for your Creo Elements/Direct Drafting environment.

Setting a Rotation Angle
If you want to rotate the drawing output to the printer/plotter,

1. Click File ▶ Print from the main menu.
2. Click the Drawing tab.
3. Type the angle of rotation in the Rotate field.
The angle of rotation is interpreted in terms of the current angular units set up for
your Creo Elements/Direct Drafting environment.

Selecting the Drawing Range for Printing/Plotting
1. Click File ▶ Print from the main menu.
2. Click the Drawing tab.
The Print menu Range options are:

• All: to print/plot the entire drawing - irrespective of the current viewport
contents. This is the default option.

○ Sheet. When printing an Annotation drawing, you can select Sheet to print
each Annotation sheet on a separate page. See Stop on Error on page 460
for information on a possible warning.

• Viewport: to print/plot the contents of the current viewport.

For example, if you are currently viewing a part, only the elements of that part
contained within the window of the current viewport will be printed/plotted.

• Box: to print/plot a specific area of a viewport. Click Pick and then use your
cursor in the drawing viewport to specify two opposite corners of a box. Only
the contents of the boxed area will be printed/plotted.

For example, suppose you are currently viewing a part, and the other parts/
elements exist in the same area but are not displayed. If you click Box, all the
drawing elements existing in the boxed area, both displayed and not displayed,
will be plotted.

462 Creo Elements/Direct Drafting User's Guide: Windows User Interface



Setting the Plot Scale
You can set a scale factor for output or automatically scale the drawing as large as
possible within the limits of your paper. To reach this setting

1. Click File ▶ Print from the main menu.
2. Click the Drawing tab.

Entering a Scale Factor
This is the default option. The entire print/plot output will be scaled, but
dimension values are not affected.
Figure 225. Operation of Print/Plot Scale on page 463 shows the operation of
print/plot scale.

Figure 225. Operation of Print/Plot Scale

To set the print/plot scale factor:

1. Click the Factor radio button in the Scale section of the Print menu.
2. Enter the required scaling factor.
If you set the plotting scale such that the drawing is too large for the paper, Creo
Elements/Direct Drafting will warn you at the start of a plot by displaying the
maximum scale possible. Pressing ESC will abort the plot and allow you to reset
the plot scale. Otherwise, press the space bar and the plot will continue, cutting off
elements outside the paper format.

Fitting a Drawing
Click the Fit radio button in the Scale section of the Print menu. The print/plot
output of your drawing will be scaled as large as possible within the limits of the
paper size you specified.
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Setting the Content of the Print/Plot Output
Creo Elements/Direct Drafting enables you to specify what will be included in the
print/plot output. To reach this setting:

1. Click File ▶ Print from the main menu.
2. Click the Drawing tab.

• Drawing: all entities will be included in the print/plot output expect
Construction lines. Spotlights for the current part are omitted. The drawing
will appear as a normal drawing irrespective of the screen status (that is, the
plot is unaffected by the Show functions).

• Current Show: to print/plot the drawing as shown in the viewport.

1. Select a viewport in which you want to set up your own drawing
conventions.

2. Use the Show functions to set up the desired attributes.
3. Click Current Show in the Content section of the Print menu to print/plot

what is currently shown in the drawing.
The subsequent plots will contain whatever drawing conventions you have
selected in the current viewport.

Note
Drawing and Current Show only determine how the plot will appear. The
plotting area is unaffected.

Colors
This section of the Print menu enables you to set the True Color option, a linetype,
and a Plot Transformation map for your printer/plotter environment. To reach this
setting:

1. Click File ▶ Print from the main menu.
2. Click the Drawing tab.
3. In the Colors box, click Pens. The Plot Transformations dialog appears.

True Color
From the Plot Transformations pull-down menu, click True Color to create a color
plot of your drawing that is suitable for output to color output devices capable of
producing color rastering.
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This feature is available on PostScript Level 2 printers and HP-GL/2 printers. This
means, for example, if you have access to an HP DesignJet 650C color printer you
can print any number of colors up to the capability of the printer.

Note
If you have a drawing that contains elements in the color white and specify
truecolor plotting, the elements are drawn in white. Normally, when sending
drawings to a pen-plotter, the white elements on the screen are converted to
black

Setting the Linetype Length
To reach this setting:

1. Click File ▶ Print from the main menu.
2. Click the Drawing tab.
3. In the Colors box, click Pattern Length. The Plot Linetype Length dialog

appears.
You can set the pattern length for any of the seven broken linetypes. Each broken
linetype is a pattern repeated many times to produce a line. Via the Plot Linetype
Length map, you can specify the length of each pattern and thus alter the fineness
of the line. Figure 226. Different Linetype Lengths on page 465 shows two
DASH_CENTER lines drawn with different linetype lengths. The linetype length
is shown arrowed.

Figure 226. Different Linetype Lengths

The seven broken linetypes that you can set are:

• DASHED
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• LONG_DASHED
• DOT_CENTER
• DASH_CENTER
• PHANTOM
• CENTER_DASH_DASH
• DOTTED
To set the linetype length and minimum space for individual broken linetypes:

1. Click Pattern Length at the bottom of the Print menu to display the Plot
Linetype Length map.

2. In the Length field, specify a segment length for each broken linetype.
3. In the Min. Dist. field, specify the minimum distance (the gap) between the

broken line segments.
Alternatively, if you want to set all broken linetypes to the same segment length
and the same minimum distance, click All Linetypes. Then specify a single length
and a single minimum distance.

Plot Transformation
To reach this setting:

1. Click File ▶ Print from the main menu.
2. Click the Drawing tab.
3. In the Colors box, click Pens. The Plot Transformations dialog appears.
4. From the Plot Transformations pull-down menu, click Plot Transformations.

• The Edit button displays a separate Pen Format dialog in which you can set
up a custom plot transformation map.

• The Reset button restores the default settings that you see the first time
you display the Plot Transformation dialog box.

• The Default Color button applies a default color-to-pen assignment map.
• The Default B/W button applies a monochrome color-to-pen assignment

map.
• The Default GDI button applies a 125-color plot pen color to pen

assignment map.
Proceed as follows to set up the Plot Transformation map:

1. In the Plot Transformation map, click the row you want to change. This row
will be highlighted.

2. Click Edit to display the Pen Format dialog box.
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3. In the Pen Format dialog box:

• Select a "from" linetype and then a "to" linetype to which you want to map
the "from" linetype. For example, if you want all dashed lines in the
drawing to be plotted as dotted lines, map "from" dashed "to" dotted.

If you want to map all linetypes in the drawing to the associated linetypes
on the plotter, click All Linetypes.

• Select a "from" color and then a "to" color to which you want to map the
"from" color. For example, if you want all cyan lines in the drawing to be
plotted in a custom pen color, select Cyan from the Color selection list and
then select Custom from the To selection list to define that custom color.

If you want to map all colors in the drawing to the associated colors on the
plotter, click All Colors.

• Select a "from" pensize and then a "to" pensize to which you want to map
the "from" pensize. For example, if you want pensize 0.3 in the drawing to
be plotted by a 0.45 pen on the plotter, enter 0.3 in the Pen Size field and
0.45 in the To field.

If you want to map all pensizes in the drawing to the associated pensizes
on the plotter, click All Pen Sizes.

Assigning a Specific Pen to a Given Linetype/Color
Combination
In the Plot Transformation map, proceed as follows to assign a specific plotter pen
to a given linetype/color combination:

1. Select the color from the Color selection list.
2. Select the linetype from the Linetype selection list.
3. In the Plotted As section, select the linetype to be plotted. If you want to plot

the same linetype that is used in the drawing, select Same Linetype.
4. Use the spin box to select the associated pen number.
5. Specify a pen width.
6. Click OK to add the changed row to the Plot Transformation map.
For example, let us assume that you want to use a 0.3 mm blue pen to plot all
dashed blue lines of the drawing. This pen is pen # 5 in your plotter.

1. Select the dashed linetype and the color blue in the Drawing section of the Plot
Transformation map.

2. In the Plotted As section, click Same Linetype.
3. Specify a pen width of 0.3.
4. In the Pen spin box, set the pen number to 5.
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Note
The difference between line width (pen size) and line size is explained in Line
Width vs. Line Size on page 51.

Repeat this procedure until the Plot Transformation map contains the required map
of colors, linetypes, and associated plotter pens.
To restore the Plot Transformation default settings, click Reset. To restore the
default color settings, click Default Color.

Setting the Picture Color
When printing or plotting a drawing that includes embedded pictures, you can set
the output of the image to be either Black & White or Color.
To reach this setting,

1. Click File ▶ Print from the main menu.
2. Click the tab labeled Pixmap.

Retaining or Inverting Black and White Pictures
The Reverse radio button in the B&W Pixmap section of the Print menu enables
you to reverse black and white pictures in the print/plot output.
To reach this setting,

1. Click File ▶ Print from the main menu.
2. Click the tab labeled Pixmap.

Picture Quality
To reach this setting,

1. Click File ▶ Print from the main menu.
2. Click the tab labeled Pixmap.
Select:

• Best: high quality
• Low: draft quality
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Previewing a Print/Plot
Open the Plot Preview system viewport to see print/plot output on your screen.
You can open the viewport after you select all the necessary print settings (as a
last step before printing), or open it to watch while working on your drawing.

1. Click File.
2. Click Print.
3. Click Show Preview.
4. Select a color setting for the Plot Preview viewport only.

• Original: to preview color printer/plotter output.
• Grayscale: to preview black and white printer/plotter with dithering

capability output.
• BW: to preview black and white printer/plotter output.

5. The Plot Preview viewport appears or is updated.
The Plot Preview viewport remains open until you uncheck it in the Print dialog
box.

Starting a Print or Plot Job
When you have selected or specified all of the required print/plot output settings,
click OK at the bottom of the Print menu to send your drawing to either the Print
Manager or to the Clipboard or to a file.
The Print Manager queues the drawing to the current default output device. The
Clipboard temporarily stores the drawing so that it can be electronically pasted
into another application.

Printing or Plotting Multiple Drawing Files
To plot or print multiple Creo Elements/Direct Drafting drawing files from the
Creo Elements/Direct Drafting File Browser:

1. In the Windows file browser, select the drawing file(s) to be printed or plotted.
2. Press the right mouse button on this selection.
3. Click Print.
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Dumping the Creo Elements/Direct
Drafting Screen
To copy the entire Creo Elements/Direct Drafting screen to the Clipboard, press
[Alt] & [Print].
Then paste the screendump into a graphics application of your choice for further
processing.
For example, in Microsoft® Paint, pull down the Edit menu and click Paste to
paste the Creo Elements/Direct Drafting screen dump to the drawing area.

Writing a Creo Elements/Direct Drafting Screen
dump to an Output File
Optionally, you can write a screen dump of your current Creo Elements/Direct
Drafting window directly to an output file.
See Exporting a Picture on page 426 for instructions.

Further Information
For further technical information about plotting or dumping, refer to the Creo
Elements/Direct Drafting help system:
Enter help plot or help bitmap_to_file at the Creo Elements/Direct
Drafting command line.
The screen will clear and Creo Elements/Direct Drafting will display further
information about plotting or dumping.
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Drafting are written to macros.
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Displaying and Hiding Menus
To display or hide menus in the Creo Elements/Direct Drafting user interface:

1. Press the right mouse button on any menu item.
2. Check the applicable checkbox to display a menu or set of menus.

Alternatively, uncheck any items you want to hide.

Selecting Menu Look and Feel
Menus can be displayed as icons, text, or both. To select a menu style:

1. Click Setup ▶ Customize ▶ Customize Layout. The Customize window
appears.

2. From the Customize window, select your preferred view from the Text Options
field.

Editing Toolbar Items
To change the name, type, action or other property of a menu item in the Creo
Elements/Direct Drafting user interface:

1. Display the menu item you want to change.
2. Press the right mouse button on that menu item. This brings up the Edit

Toolbar Item dialog box.
Caption Key The string in this field is the label displayed for the

current menu item.
Enabled Tick this box to enable the menu item or untick this box

to gray out the menu item.
Unique Name The Creo Elements/Direct Drafting internal name for

this menu item. Note that this name must be unique.
Item Type This combo box enables you to pull down a selection

list of standard Microsoft Windows item types. The
item types in this list are context sensitive. For
example, a popup button enables you to select a
submenu (discussed below) which will be displayable
via this popup button.

Submenu Enables you to branch to a submenu.
Tooltip Key A brief description of the current menu item.
On Action A command or function or macro name (e.g.:

change_color
) to be triggered via this menu item. Note that any
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macro specified here must be created separately.
On Right Click Command, function or macro name to be triggered by

pressing the right mouse key on this menu item.
Category This string allocates the menu item to a category for

selection in the Toolbar Items tab.
Domain Name of the file where Creo Elements/Direct Drafting

will look for your localized version (if any) of this
menu item. Note that multiple toolbars may share the
same domain file. Optionally, a separate domain file
may be created for each toolbar.

Image Brings up an icon editor. Refer to Creating Icons on
page 477 for details.

List Keys Click New (Insert) to add an entry to the list of items.
Click Delete to remove an item from this list. Click the
up or down arrow to scroll within the list of keys. Note
that any action string you define here requires an
associated action definition in a separate macro.

Note
Combo boxes, radio buttons and checkboxes require the creation of a separate
macro. For more detailed background information on the user interface
customization capabilities of Creo Elements/Direct Drafting, refer to the
TOOLBAR_ITEM section in the Creo Elements/Direct Drafting Help. Destroy
not only removes items from the Toolbar Items tab but actually deletes the
associated files. Note that Destroy cannot be undone.

Creating Custom Menus
To create a custom menu:

1. Pull down the Tools menu, click Customize and Customize Layout.
Alternatively, press the right mouse button on any existing menu item and
click Customize Layout.

2. In the Customize dialog box, click Add.
3. In the Add Toolbar dialog box, specify the following:

Caption Key The string in this field is the label displayed for the
current menu item.

Locked Locks the menu so it cannot be destroyed.
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Unique Name The Creo Elements/Direct Drafting internal name for
this menu item. Note that this name must be unique.

On Right Click Command, function or macro name to be triggered by
pressing the right mouse key on this menu item.

Domain Name of the message file (if any) where Creo
Elements/Direct Drafting will look for your localized
version (if any) of this menu item. Each toolbar and
toolbar item in the Creo Elements/Direct Drafting user
interface is associated with a specific "domain" file.
This domain file contains all of the strings associated
with your toolbar or toolbar items. These strings
include:
• Caption
• Category
• Tooltip
• List Items
In the domain file, you can edit (e.g. localize) these
strings.

4. Click OK.
5. Drag and drop the menu to any location in the Creo Elements/Direct Drafting

user interface

Example: Creating a Background Menu
This example illustrates the procedure for creating a cascaded menu that enables
you to change the background color of the current viewport in Creo Elements/
Direct Drafting. The newly created Background menu will contain a submenu
with two buttons:

• Black
• White
The first task is to create two empty toolbars. The first of these will receive a
popup button that displays the second toolbar. The second toolbar will then
receive two "action" buttons that change the background color.

Stage 1: Defining Two Empty Toolbars
To define the first (initially empty) toolbar:

1. Click Tools ▶ Customize ▶ Customize Layout ▶ Add.
2. Specify the following in the Add Toolbar dialog box:
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Caption Key Background
Unique Name tlb_backg
On Right Click Retain the default.
Domain cust_menus

3. Click OK to return to the Customize dialog box.
To define the second (initially empty) toolbar:

1. Click Tools ▶ Customize ▶ Customize Layout ▶ Add.
2. Specify the following in the Add Toolbar dialog box:

Caption Key Background_2
Unique Name tlb_backg_2
On Right Click Retain the default.
Domain cust_menus

3. Click OK to return to the Customize dialog box.
Result of this exercise:
You have just created two empty toolbars. Both of these are named Background.

Stage 2: Creating a Cascaded Submenu
Next, you will make one of these toolbars a "cascaded submenu" of the other:

1. In Customize, click on the Toolbar Items tab.
2. Click Add to display Add Toolbar Item.
3. In Add Toolbar Item, select or specify the following:

Caption Key Black or White
Item Type Popup Button
Unique Name pob_black_white
Submenu tlb_backg_2

4. Retain the defaults for the remaining fields.
5. Click OK.
6. Drag the newly created pob_black_white item to the Background menu you

created in Stage 1.
Result of this exercise:
You have just created a first menu label in the toolbar named Background. The
black arrow pointing to the right suggests cascading.
You can now click on the Black or White label to display the (still empty)
toolbar you just defined as its submenu.
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Stage 3: Adding Two Action Buttons to the Cascaded
Submenu
Next, you need to define the two menu items for this newly created submenu.
To create the Black menu button:

1. In Toolbar Items, click Add.
2. Select or specify the following in the Add Toolbar Item dialog box:

Caption Key Black
Unique Name btn_background_black
Item Type Push Button
ToolTip Key Changes the background color to black
On Action change_viewport_color black end

3. Retain the defaults for the remaining fields.
4. Click OK.
To create the White menu button:

1. In Toolbar Items, click Add.
2. To define the White menu button, select or specify the following in the Add

Toolbar Item dialog box:
Caption Key White
Unique Name btn_background_white
Item Type Push Button
ToolTip Key Changes the background color to white
On Action change_viewport_color white end

3. Retain the defaults for the remaining fields.
4. Click OK.
Next, you need to drag these two buttons to the cascaded submenu:

1. Drag the Black pushbutton definition from Toolbar Items to the cascaded
submenu.

2. Drag the White pushbutton definition from Toolbar Items to the cascaded
submenu.

Stage 4: Test
To test your newly created cascaded menu:

1. Drag the Background menu to any position in the Creo Elements/Direct
Drafting user interface.
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2. Click on the Black or White menu label.
3. Click White to change the viewport background color to white.
4. Click Black to change the viewport background color to black.

Creating Icons
To create an icon:

1. In the Edit Toolbar Item dialog box, click Edit under Image to bring up the
Image Editor.

2. Use the Creo Elements/Direct Drafting Image Editor drawing tools to draw the
geometry of your icon. Select colors as appropriate.

3. When you have completed the geometry, pull down the Image Editor File
menu and click Save.

4. Specify a filename for the new image.
5. Click Save to save the file.

Adding Icons to the Toolbar
To add an icon (as a button) to the Creo Elements/Direct Drafting toolbar:

1. Pull down the Tools menu, click Customize and Customize Layout.
2. In the Toolbar Items tab, select the item for which you want to add or change

an icon.
3. Click Edit to bring up the Icon Editor.
4. Create the icon.
5. Click OK to return to the Edit Toolbar dialog box. Check whether or not the

icon meets your requirements.
6. Click Edit to edit the icon or click OK to accept the icon.
7. The menu item now has the icon associated with it. Drag and drop the menu

item (complete with its icon) to the menu where you want to use it.

Defining Key Commands
To define a custom key command:

1. Pull down the Setup menu and click Keys.
2. In the Key Definitions dialog box, click a key (such as [1]).
3. Specify any or all of the following commands:
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Plain Enter the command to be executed when the key is
pressed.

Control Enter the command to be executed when the key is
pressed in combination with the CTRL key.

Alt Enter the command to be executed when the key is
pressed in combination with the ALT key.

Alt-Control Enter the command to be executed when the key is
pressed in combination with the ALT + CTRL keys.

4. Check the Execute box if you want the command to execute when the
associated key (or key combination) is pressed.

If you leave this box unchecked, the command will simply be written to the
User Input Line in Creo Elements/Direct Drafting when you press the key (or
key combination). To execute the command, press [Enter].

Note
Some keys (such as F1) are disabled because they serve a predefined function
in the Windows environment.

Displaying Menus and Dialog Boxes via
Mouse Buttons
You can allocate any Creo Elements/Direct Drafting menu or dialog box to a
mouse button so the menu or dialog box pops up when that mouse button is
pressed. The allocation procedure uses the following syntax:
define_mouse_key <key number> <mode> "show_popup_menu '<action
text>'"#M

where:
define_mouse_
key

is the macro command that allocates a command to a mouse
button.

key number is either 1 (left mouse button), 2 (middle mouse button), or 3
(right mouse button).

mode is one of the following:
Plain: The command is to be executed when the mouse button
is pressed. Note that you should not use plain combined with
the left mouse button because this button is used for menu
selection and drawing work in Creo Elements/Direct Drafting.
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Shift: The command is to be executed when the mouse button
is pressed in combination with the [Shift] key.
Alt: The command is to be executed when the mouse button is
pressed in combination with the [Alt] key.
Shift Alt: The command is to be executed when the mouse
button is pressed in combination with the [Shift]+[Alt] keys.

show_popup_
menu

is the macro command that brings up the menu or dialog box
specified through the command.

action text is the name of a Creo Elements/Direct Drafting menu or
dialog box. Note that this string is case sensitive.

#M causes the command to be executed immediately when the
mouse button is pressed. If you decide to leave out #m, the
command will be written to the command line.

For example, to display the Arc menu by pressing the right mouse button
combined with the [Shift] key, enter the following command string into the User
Input Line:
define_mouse_key 3 shift "TOOLBAR 'tlb_Arc' SHOW_AS_POPUP END"#M

Note
The Creo Elements/Direct Drafting menu names are case sensitive.

Displaying Dialog Boxes Directly
The Creo Elements/Direct Drafting dialog boxes can be displayed directly. Simply
enter the associated WUI command string in the User Input Line. To find out these
command strings, enter:
LIST_KEYWORDS SCREEN

into the User Input Line. The resulting Creo Elements/Direct Drafting keyword
list is displayed in a separate text editor window. Scroll to the section of keywords
beginning with WUI_ to see the keywords that will display dialog boxes.
For example, to display the Construction menu, enter:
WUI_CONSTRUCTION

Managing Layouts
Via Tools, Customize, Creo Elements/Direct Drafting provides the following
layout management options:
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Save Layout Saves the entire layout to a file.
Save Toolbars Saves one or multiple user-selected toolbars to a file.
Load Layout Loads an entire layout.
Load Toolbars Loads one or multiple user-selected toolbars.

Converting Existing Multi-Column Menus
The mcm2lcassic.m macro supplied with this release of Creo Elements/Direct
Drafting enables you to convert multi-column menus created with earlier Creo
Elements/Direct Drafting releases.

Resetting the Layout
To return your Creo Elements/Direct Drafting layout to its original
(uncustomized) state, simply click Tools ▶ Customize ▶ Reset Layout.
If you have inadvertently removed the Reset Layout button or if you have lost the
Customize submenu or the entire Tools menu, enter the following command in the
user input line to restore the original Creo Elements/Direct Drafting layout:
toolbar_layout reset confirm

Windows User Interface Customization
History
As of CoCreate Drafting rev. 11.0, all user interface customization is handled
through the Creo Elements/Direct Drafting macro language. Any existing user
interface customization files from previous releases of Creo Elements/Direct
Drafting could be converted.
The following sections provide a brief overview of the Creo Elements/Direct
Drafting GUI customization technological history.

CoCreate Drafting Rev. 8.7 or Earlier
All "classical" UI menus were handled through the Creo Elements/Direct Drafting
macro language. These were loaded by means of the LOAD_MACRO command
and activated by means of the INPUT command.
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Figure 228. User Interface Customization in CoCreate Drafting Rev.
8.7 or Earlier

In the "classical" user interface:

• Fonts were defined via the MEFONT or -font command.
• The font color and background color were defined in macros via the MENU,

TABLE_TITLE and/or TABLE_COLUMN command, etc.
• Menus could only be moved within the Creo Elements/Direct Drafting

window.

CoCreate Drafting Rev. 9.0 and Rev. 10.0
In addition to the classical menus (see previous section), customized Windows
style menus were created and managed as .lt format files by the Customization
Toolkit.
Multi-column and multi-row menus created by the user were managed as ASCII
format files. These were loaded by means of the LOAD_MULTICOL_MENU
command.
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Figure 229. User Interface Customization in CoCreate Drafting Rev.
9.0 and 10.0

CoCreate Drafting Rev. 10.5 or Higher
The mcm2lclassic.m macro enabled users to convert existing multi-column
menus for re-use in the current and future Creo Elements/Direct Drafting releases.
Any *.lt files were automatically converted by the TOOLBAR_LOAD
command.
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Figure 230. User Interface Customization in CoCreate Drafting Rev.
10.5 or Higher

Note the following:

• Fonts are defined (by default) via Control Panel ▶ Display ▶ Appearance but
can be overridden via the MEFONT and -font commands.

• The Bcol0 and Colo0 macros (which control the background and text colors
in menus) can also be defined via Control Panel ▶ Display ▶ Appearance. All
other colors will be retained as before.

• All menus can be docked or moved outside of the Creo Elements/Direct
Drafting window by clicking on the menu frame and dragging it to its new
position.

• Buttons are mouse sensitive. Moving the cursor over a button will raise the
button.

• Emulated "classical" menus and tables (referencing the MENU and TABLE
commands) cannot be scaled to wrap to a changing number of rows and
columns. The number of rows and columns will always remain fixed as
defined in the underlying macro. Note that these menus will not be saved for
subsequent relaunch when you exit Creo Elements/Direct Drafting.
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Using Fly By Highlighting and

Handles
Fly By Highlighting................................................................................................... 485
Handles.................................................................................................................. 486
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Fly By Highlighting
When you pass over an element with your cursor, Fly By highlighting indicates
which elements are available for work. Fly By highlighting is available in three
modes:

No commands are active
When you pass over an element with your cursor, Creo Elements/Direct Drafting
highlights the elements that you can drag (A) or that have handles (when you click
on the element) (B).

A command is active
When you pass over an element with your cursor, the highlighted elements can be
used for the command. In the image, the arrow points to the highlighted element
where the text box will be placed.
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Selection of parts
When you hover over an element belonging to a part or the rounding box of the
part, Creo Elements/Direct Drafting highlights the part.

Fly By Highlighting Settings
Enable and disable FlyBy highlighting and change the color of the highlight in the
System menu: Setup ▶ Edit Environment ▶ System ▶ FlyBy tab.

Handles
Use handles to quickly and easily modify geometry elements, dimensions, text
and symbols, symmetry and center lines, references lines, and parts. Handles
appear as

• squares and diamonds for geometry elements, dimensions, symmetry and
center lines, and reference lines.

• a frame around text, symbols, and parts.
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Modify with handles
There are two ways to modify an element using the mouse:

• Drag: Available for dimensions, text, symbols, and parts.

○ Click the element and drag it to a new location.
○ Release.

• Click and Drag: Available for all elements.

○ Click the element to display the handles.
○ Click the element again and drag a the new location.
○ Release.

To show the handles on more than one element at a time, hold the Shift key and
pick the elements.
To remove the handles, press the ESC key or type MH_CLEAR.
Dimensions:Move and reattach dimensions, change the direction of the arrows,
and modify the stagger line.

• Move the dimension and text: Click anywhere on the dimension and drag.
• Change the direction of the arrows: Click the diamond-shaped handle. You

cannot change the direction of arrows for broken on page 218 dimension lines.
• Reattach the dimension: Click the square-shaped handle where the dimension

is attached to the element and drag.
• Modify the stagger line: Click the square-shaped handle and drag.
• Move the dimension text only: Hold the Shift button and drag the text.
Text/Symbols: Move the text or symbol box.
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1. Hover over the text or symbol. Creo Elements/Direct Drafting highlights a box
around the text or symbol (if Fly By Highlighting is on).

2. Drag the text or symbol to a new location.
Symmetry/Center lines: Extend a symmetry or center line or rotate a center line.

• Extend the symmetry/center line: Click the handle and drag.
• Rotate the center line: Click the center line (not on the handles) and drag.
Reference lines: Move the reference line or stretch reference line segments.

• Move the reference line: Click the handle on the start or end of the refline and
drag.

• Stretch reference line segments: Click inside the refline handles and drag.

Delete with handles
1. Click on the item to be deleted. Creo Elements/Direct Drafting highlights the

item or displays handles.
2. Press Delete on your keyboard.

Handles Settings
Enable and disable the handles and change handle settings in Setup ▶ Edit
Environment ▶ System ▶ Handles tab.

Handles
Fill Color Change the color of the square and diamond-shaped

handles.
Box Color Change the color of the frame around text, symbols, and

parts.
Size Change the size of the square handle in pixels.

Selection
You must click the element to show the handles.
Local Show the handles of the current part.
Subtree Show the handles of the current part and its subpart. If you

click on an element in another part, the entire part is selected.
Global Show the handles of all parts. Select the entire part when you

hover over the rounding box of the part.
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Allowed types
Select which elements will display handles when they are clicked.
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Grouping

Create a group ........................................................................................................ 491
Add elements to an existing group ............................................................................ 491
Remove elements from an existing group.................................................................. 491
Ungroup all elements of a group ............................................................................... 491
Limitations .............................................................................................................. 491

You can group annotations or parts together. Groups may consists of a single
dimension, multiple text elements, parts, and multiple symbols. Each group has
one of its elements as the master element.
Creo Elements/Direct Drafting creates one invisible refline between each element
in a group and its master element. These reflines can be shown with either the
SHOW_INV_RTL or SHOW_INV_GEO command. Deleting an invisible refline
deletes the group. You can change the flyby highlight color of the group box and
of the group master element with the FLYBY_GROUP_MASTER_COLOR
function.
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Create a group
To create a group:

1. Click Modify ▶ Groups ▶ Group.
2. Enter GLOBAL if you wish to group elements from different parts.
3. Select the master element for the group.
4. Select additional elements to add them to the group.
5. Click End.

Add elements to an existing group
To add elements to an existing group:

1. Click Modify ▶ Groups ▶ Add Group.
2. Select an element belonging to the group to which you wish to add.
3. Select elements to add them to the group.
4. Click End.

Remove elements from an existing group
To remove elements from an existing group:

1. Click Modify ▶ Groups ▶ Del Group.
2. Select an element belonging to the group to which you wish to add.
3. Select elements to remove them from the group.
4. Click End.

Ungroup all elements of a group
To ungroup all elements in an existing group:

1. Click Modify ▶ Groups ▶ Ungroup.
2. Select an element belonging to the group you wish to ungroup.
3. Click End.

Limitations
• A group may contain only one master element.
• If a group contains a dimension, it automatically becomes the master element.
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• Each element can belong to only one group.
• You cannot add an active part to a group.
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Managing drawings with Windchill

The Creo Elements/Direct Drafting and Windchill integration allows you to load,
save, and manage data created by Creo Elements/Direct Drafting in Windchill.

Activating the Windchill PDM Actions from Creo Elements/Direct
Drafting
1. Register Creo Elements/Direct Drafting with the Windchill Workgroup

Manager. To do this, install and start the Windchill Unified Workgroup
Manager (UWGM) and set the UWGM server as the primary server.

2. Click Modules ▶Windchill WGM in Creo Elements/Direct Drafting to activate
the Windchill Workgroup Manager. The Windchillmenu is now available in
Creo Elements/Direct Drafting.

Windchill PDM commands
The following table explains the PDM commands that are inserted into Creo
Elements/Direct Drafting when connected to the Windchill Workgroup Manager.

Action Menu Location in
Windows and Mixed User
Interface

Description

Open from
Windchill

Windchill ▶ Open from
Windchill
[Also]
File ▶ Open from Windchill

Presents the Open from
Windchill window. By default,
the contents of your active
workspace are displayed. You
can also navigate to the server
common space to select an
object to open.

Save to
Workspace

Windchill ▶ Save to Workspace
[Also]
File ▶ Save to Workspace

Presents the Save to
Workspace window. Upon
execution of the save, the
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Action Menu Location in
Windows and Mixed User
Interface

Description

document is uploaded to the
server-side workspace.

Check out Windchill ▶ Check out Checks that the current
drawing is not already checked
out. If not, checks out the
current document to the
workspace.

Revise and
Check out

Windchill ▶ Revise and Check
out

Checks that the current
drawing is not already checked
out. If not, creates a new
revision of the current file and
checks the new revision out to
the workspace, replacing the
earlier revision in the
workspace and in Creo
Elements/Direct session.

Undo Check out Windchill ▶ Undo Check out Cancels the check out of the
current document.

Note
If the document was
checked out via the Revise
and Check out action, the
higher revision label is
maintained.

Custom Check
In

Windchill ▶ Custom Check In
[Also]
File ▶ Custom Check In

Accesses the Check In page
and allows you to change
check in options.

Auto Check In Windchill ▶ Auto Check In Automatically checks in the
current file to the
commonspace.

Load File from
Windchill

Windchill ▶ Load File from
Windchill

Presents the Open from
Windchill window, allowing
you to navigate to another
document with drawing
geometry to load into the
current drawing.

Load Frame
from Windchill

Windchill ▶ Load Frame from
Windchill

Presents the Open from
Windchill window, allowing
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Action Menu Location in
Windows and Mixed User
Interface

Description

you to navigate to a library
containing frames and select a
frame to load into the current
drawing. The default location
shown can be defined by the
Windchill server preference,
Default Drawing Frame
Location.

Save Frame to
Windchill

Windchill ▶ Save Frame to
Windchill

Presents the Save to
Workspace window, allowing
an administrator to save a new
drawing recognized as a frame
to an appropriate library
workspace.

Text Reference Windchill ▶ Text Reference Calls or displays a submenu for
text references enabling a user
to assign, unassign, or update
text references to document
attributes. In addition, actions
are available to display
references, values, or a table of
name-value pairs.

Workgroup
Manager

Windchill ▶Managers ▶
Workgroup Manager

Opens the Windchill Workgroup
Manager (if closed); accesses
the Workgroup Manager (if
open).

Server
Management

Windchill ▶Managers ▶ Server
Manager

Opens the Server Manager
window, where you can view
or change Windchill servers
and server active workspaces.

Event
Management

Windchill ▶Managers ▶ Event
Manager

Opens the Event Manager on
the current server.

Update Windchill ▶ Update Checks the server for a later
iteration. If one is found,
replaces the drawing in session
and in the workspace with the
latest server iteration. An
Update action also updates all
drawing text references.
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Action Menu Location in
Windows and Mixed User
Interface

Description

View Drawing
Information

Windchill ▶ View Drawing
Information

Opens the server information
page (workspace view) for the
drawing in session.

Windchill
Workgroup
Manager Help

Windchill ▶Windchill
Workgroup Manager Help
[also]
Help ▶Windchill Workgroup
Manager Help

Opens the Windchill
Workgroup Manager Help
Center.

For more information on the Windchill PDM commands, see the Windchill WGM
help from the Creo Elements/Direct Drafting user interface.
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Unicode
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Introduction
Creo Elements/Direct Drafting’s different internal and external encoding schemes
were Unicode incorporated for version 2007. Unicode allows text and symbols
from all languages to be consistently represented and manipulated by computers.
All textual and string data processed by Creo Elements/Direct Drafting is held
internally in Unicode (UTF-8) encoding. That means most of Drafting's
functionality processes user input from almost any language, and string data from
different languages can be mixed. For example, it is now possible to have
German, Japanese, and Russian characters within a single string, such as a part
name.
Drafting's font list contains all the Creo Elements/Direct true type fonts that are
dynamically converted to internal font format when referenced. An appropriate
font that contains all desired characters must be selected to display texts and
dimension texts correctly. Fonts containing characters from the whole Unicode
range are relatively rare, and they usually contain the word Unicode in their name
(for example, Arial Unicode MS).
Symbols are a special Creo Elements/Direct Drafting feature and display with hp_
symbols and hp_symbols2 fonts. They can still be composed in old-style escape
sequences (#15#XY#16) but for compatibility with Unicode are mapped to a
private-use Unicode area [E000-E1FF]:

• 15#XY#16 — 0xE000 + XY
• 30#XY#31 — 0xE100 + XY

MI file format
Version 3.20 MI files are encoded in Unicode (UTF-8). Files stored to older MI
versions are encoded as before, depending on the current locale. When loading
older MI formats, the Creo Elements/Direct Drafting loader uses the information
recorded in the info section (~1) of the MI file. MI formats without encoding
information in their info sections are treated as if encoded in ROMAN8 or SJIS
(Japanese locale).

Macro file encoding
Old macro files did not contain any encoding information. They were assumed to
be encoded for current locales (e.g. ROMAN8 for English and SJIS for Japanese
locales). However, this causes problems when using the same macros in different
locales.
Version 2007 supports macro Unicode but maintains backward compatibility.
We recommend you change old macro files such that their encoding is explicitly
specified with the DEFINE_ENCODING directive.
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Text macro files containing Unicode UTF-8 or UTF-16 BOMs (Byte Order
Markers), supported by most popular Windows text editors, are read as Unicode.
Files containing the DEFINE_ENCODING directive are always read in the
specified encoding. Otherwise they are treated as old macro files and encodings
are locale dependent:

• SJIS for Japanese
• BIG5 for traditional Chinese
• GB2312 for simplified Chinese
• ROMAN8 for all else

Limitations
The displaying of Unicode texts is limited. Features such as combining characters,
Arabic cursive connection, and bidirectional algorithm are not fully implemented.
CHR, NUM and # still work in old locale-dependent internal encodings
(ROMAN8 & SJIS). They return different results in different locales. They are
obsolete; their use is only for maintaining backward compatibility. For example,
((CHR 154)+(CHR 223)) or its equivalent (#154#223) displays a Japanese
character with Unicode code 22756 (hex 58E4) on a Japanese locale and two
Latin characters on other locales. To avoid problems and to display the same
character regardless of locale, use Unicode versions of these functions: (UCHR
22756), (UCHR '58E4'), #u22756, or #ux58E4.
Combinations of # and CHR to compose 2-byte characters and symbols are not
allowed. For example, ((CHR 154)+#223) does not work.
Strings that begin with (CHR 255) are icons and are not encoded in UTF-8. Pre-
2007 CoCreate Drafting versions let you compose icons using a large variety of
combinations (for example #255'abc'#212+CHR 12). In version 2007, only CHRs
can be used to compose icons.
MI files of versions prior to 2.90 that do not contain encoding information in their
info section (~1) load correctly only if loaded in the same locale as they were
drawn. For example, you have 2 options to correctly load a Japanese MI file of
version 2.80 in English Creo Elements/Direct Drafting:
1. Load the file in Japanese locale and store it back in new format:

a. CHANGE_LOCALE 'ja'
b. LOAD 'japanese.mi'
c. STORE MI ALL DEL_OLD 'japanese.mi'
d. CHANGE_LOCALE 'en'

2. Load the MI file in a text editor and manually add section ~1 at the beginning
of MI file:
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a. #~1
b. ENCODING:SJIS
c. Such files load correctly in any locale.

AIl modules call internal Creo Elements/Direct Drafting functions and use strings
in internal encoding. Before CoCreate Drafting 15.00 (2007) these strings were
encoded in ROMAN8 or SJIS, depending on locale. Compatibility is maintained
only for characters in range [0, 127]. If AI modules use characters in a different
range, they must be changed and recompiled to support UTF-8.

File names encoding
In CoCreate Drafting 2007, file names display in the same fashion as other
Windows applications. Prior to 2007 they were shown in the internal encoding,
which was different and dependant on locale. Files names were consequently
shown differently if extended characters were used.
You can set the MEEXTFN option in the .ini file to zero to keep the old
behavior.

Changed font concept
CoCreate Drafting 2007 does not distinguish between 1-byte and 2-byte fonts (in
terms of default settings or text properties). Because Creo Elements/Direct
Drafting now has Unicode support, there is just one current font at a time and each
text and dimension text has just one assigned font.
CoCreate Drafting 2007 includes new default fonts which have been combined
from the old 1- and 2-byte definitions:

• osd_default combines hp_i3098_v and hp_kanj2_c
• osd_default2 combines hp_i3098_c and hp_kanj2_c
• osd_default3 combines hp_d17_v and hp_kanj2_c
When loading old 2D files with texts or dimension texts using characters from 1-
and 2-byte fonts (fonts that are not already included in any of the osd_default
fonts), Creo Elements/Direct Drafting automatically combines the 2 fonts into a
single font containing the character definitions from both fonts. It names them "1-
byte=font name"#"1-byte=font name".
You can combine those fonts (1- and 2-byte fonts) into a single font using a new
command MERGE_TWO_FONTS.
TrueType fonts converted to Creo Elements/Direct Drafting fonts contain all
defined characters. Separate symbol fonts are used.
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Index

A
active
part, 327

Add Layer function, 396-397
Add Text
symbol command, 303

aligning dimensions, 262
alignment symbols, 302
angle
changing the hatch, 274
dimensioning, 206
hatching, 272
text, 287

Angle command, 206
angles
measuring, 65

angular units
dimension, 240

arc
by center and end points, 119
by center and radius, 119
by diameter, 120
by point and radius, 119
by three points, 118
concentric, 119
dimensioning, 199, 205
drawing, 117
smooth connecting, 120

Arc command, 117, 205
area
changing a hatched, 274
measuring, 65
properties, 65

arrow
changing dimension line terminator
settings, 254

dimension line terminator settings,
225

assigning
a z-value, 371

associated
properties, 82

associated data types, 123, 125
automatic
hatching, 268
snapping to end points of lines
(dimensioning), 182
stepping when datum dimensioning,
221

autosave
time interval, 84

B
B-Splines, 132
background colors, 56, 58
backup
loading, 387

balloon
frame, 289

beeper
switching on or off, 24

bisect
angle, 97
lines, 97

BMP file
importing, 424

box
frame, 289

boxing
elements, 37

Broken function, 223

501



C
calculator, 68
Cancel command, 44
canceling
a dimension text edit, 265
a hatch pattern, 273

cancelling
a command or function, 44

cascade timeout, 85
cascaded menus
delay time, 85

Catch Line function, 223
catch mode
changing, 62

catch range
setting, 62

Catch Range function, 224
center point
creating, 75

centering
the drawing, 461

Centerline command, 123
centerline dimensions, 189
chain
dimensioning, 190

Chain command, 190
chain dimension
deleting a segment, 266
inserting a segment, 266

chamfer
dimensioning, 209

Chamfer command, 121
chamfers
angle to first line, 122
by two distances, 122
by two points, 121
drawing, 121
given distance from a vertex, 121

Change Dim command, 253
Change Fillet command, 121
Change Hidden Face, 383
Change Hidden Line, 383

Change Layer layer function, 397
Change Text command, 290
character spacing, 297
circle
by center and point on
circumference, 116
dimensioning, 199

Circle command, 115
circles
by diameter, 117
by radius and two elements, 116
by three points, 116
concentric circles, 116

Clean command, 166
click
what does it mean?, 21

Clipboard, 457
closed spline, 133
closing Drafting, 427
color
changing, 53
dimension geometry, 222
dimension text, 229
dimension text extension, 236
hatching, 272, 275
hidden face, 383
hidden line, 383
of geometry, text, hatching and
dimensions, 54
reference line, 293
surface symbols, 309
text, 289

color conversion, 59
color conversion map file
loading, 61
storing, 60

color information table, 56
coloring
layers, 398
URLs, 407

colors
converting, 56, 59
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custom, 54
viewing, 56

commands
canceling, 44
commonly used, 30
confirming, 44
dimensioning, 179
ending, 44
undoing, 44

commonly
used commands, 30

composite
symbols, 301

concentric
arcs, 119
circles, 116

confirming
commands, 44
delete operation, 44
modify operation, 44

construction
geometry, 96

construction circles
by center and circumference point,
99
by center and element, 99
by diameter, 99
by radius or point and two elements,
100
by radius, point, and element, 99
by three elements, 100
by three points, 98
concentric, 99
drawing, 98

construction geometry
selecting for deletion, 39

construction lines
a tangent to two circles, 98
at an angle, 98
bisecting a line, 97
bisecting an angle, 97
by two points, 96

drawing, 96
horizontal, 96
parallel, 97
perpendicular, 97
tangent from a point to a circle, 98
vertical, 96

Contour command, 164
contour level, 41
Contour level, 41
contours
drawing, 123
selecting, 40

control points, splines, 132-133
control spline
splitting into segments of equal
length, 146

Control Spline command, 141
control splines
adding a control point, 142
changing the shape, 143
changing the slope, 143
drawing, 141
moving a control point, 142-143

convert
colors, 59

convert colors, 56
convert text to geometry, 290
Coordinate command, 194
coordinates
datum dimensioning, 194

Copilot functionality, 86
example, 92

Copy, 19
Copy Contour, 43
Create command, 336
creating
a centerline, 123
a new center point, 75
a new window, 75
a part, 336
a polyline, 113
a viewport, 78
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contours, 164
ellipses, 129
hyperbolas, 130
parabolas, 131
points, 109
reference line, 290
splines, 132
symmetric elements, 125

Creo Elements/Direct Annotation
changing colors, linetypes and
hatches, 454
dimensions, 451
elements, 450
hidden lines, 449
hiding or deleting, 453
introduction, 445
limitations, 446
loading a drawing, 448
preparing, 447
rules, 445
selecting a sheet or view, 448
sheet, 451
Sheet Browser, 448
showing, 454
showing differences, 450
storing, 454
tangent lines, 449
unhiding, 453
view, 448

Creo Elements/Direct Drafting
basic working methods, 18
common definitions, 21
exiting, 427
getting started with, 16
user interface, 17
what is it, 10

Creo Elements/Direct Drafting
instance, 422
current
viewport, 72, 74, 78

Current Layer function, 396
current offset

setting, 368
Current Offset command, 368
Current Z Value command, 377
cursor
setting the size, 69

custom colors, 54
Cut, 19
Cut Middle option, 164

D
DA DB MATCH command, 212
DA DIM GEO SENSE command, 211
DA DIM PD SCAN command, 211
datum
dimensioning using coordinates, 194
dimensioning using long base lines,
194
dimensioning using short base lines,
194
dimensioning with automatic
stepping of dimension text, 221

datum dimension
deleting a segment, 266
inserting a segment, 266

Datum Long command, 194
Datum Short command, 194
Datum Step function, 221
datum target
symbols, 304

decimal places
dimension units, 241

default
z-value, 377

defining
load value, 377
printing/plotting parameters, 459
your own units, 28

delete
elements, 22

delete command, 31
Delete Face command, 381
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deleting
a covering face, 381
a part, 332
all viewports, 80
an info, 401
elements, 31
general, 31
hatch, 280
hatching, 280
images, 438
OLE object, 440
OLEs, 30
pictures, 30
symbols, 299
text, 285
viewports, 80
z-values, 371

destination gap
reference line, 294

detail
dimensioning a detail part, 183
parts, 337

dialog boxes
displaying directly, 479

diameter
dimensioning, 204

Diameter command, 204
dimension database, 212
dimension extension lines
breaking, 256
resetting, 260
slanting, 256
staggering, 258

dimension leader line
moving, 261

dimension lines
breaking, 256
catch line, 223
catch range, 224
changing line settings, 254
changing terminator settings, 254
color, 222

datum step, 221
inside the extension lines, 223
line settings, 218
minimum space, 222
offset line, 219
offset point, 222
resetting, 260
slanting, 256
space, 220
staggering, 258
terminator settings, 225
width, 219

Dimension Style table
dimensioning, 251

dimension text
absolute size, 231
brackets, 233
character width-to-height ratio, 233
color, 229
editing dimension, 263
font, 229
frame, 230
location, 231
moving, 260
orientation, 229
relative size, 232
rotating, 261
settings, 228
slant, 232

dimension text extensions
absolute size, 237
adding, 234
character width-to-height ratio, 237
clearing, 236
color, 236
deleting, 235
font, 236
opening, 235
predefining, 233
relative size, 237
saving, 235
slant, 237
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special character, 237
dimension units
changing settings, 255
decimal places, 241
settings, 238

dimensioning
a drawing, 172
assignment features, 181
automatic dimension positioning
option, 247
automatic location, 247
canceling a dimension text edit, 265
changing settings, 253
changing vertex, 259
cm, 239
database matching, 212
database-matching assignment, 181
degrees, 240
degrees minutes seconds, 241
Delete command, 266
Dimension Style table, 251
direct assignment, 181
features, 178
feet and fractional inches, 240
fractional inches, 240
fractional inches with sign, 240
fractional inches with text, 240
Geo Sense settings, 249
geometry sensing assignment, 181
gradian, 241
inch, 240
interrupt functions, 217
km, 240
meters, 239
mm, 239
most used table, 184
multiple elements, 182
position settings, 247
preparation, 184
radians, 241
Scan settings, 250
scanning constraints, 211

selection aids, 182
selection filtering, 242
single geometry features, 185
standards, 184
Strategy option, 248
style setting features, 183
um, 239
using the common commands, 181
using the selection commands, 181

dimensioningGeo Sense command
Geo Sense settings, 211

dimensions
aligning, 262
centerline, 189
chamfer, 209
freeze, 263
geometry sensing, 210
moving, 261
selecting, 40
showing, 73
underlining, 264

displaying
infos, 73
point coordinates, 64
the origin, 69

distance
hatching, 271

distances
measuring, 63

dithering
the effect, 55

dot grid, 69
drawing
an isometric ruler/grid, 71
auto save time interval, 84
centering, 461
creating a new file, 421
fitting a, 74, 76
justifying, 462
panning across, 74
plotting, 456
positioning, 461
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printing, 456
scales, 355
viewing a, 73

drawing file
opening in a new Drafting instance,
423

drawing geometry
selecting, 39

drawing scale
setting the, 29

Duplicate command, 167
DWF translator, 427
DXF translator, 427
dynamic feedback, 87

E
Edit command, 334
Edit Environment command, 26
Edit Part command, 327
Edit Text command, 284
Edit Text Inplace command, 285
Edit Toolbar Item, 472
editing
a part, 334
an info, 400
dimension text, 263
fonts, 295
text via text box, 284-285
the parent part, 334
the top part, 334

element
merging, 166
splitting, 165

elements
adding to your selection, 36
boxing, 37
changing the linetype, 53
deleting, 31
enclosing within a polygon, 37
moving to a layer, 397
preselecting, 43

removing them from your selection,
37
selecting, 34, 38

ellipse
by axis end points and peripheral
point, 128
by center and two points, 129
by center, angle and radii, 128

Ellipse command, 128
enclosing
elements, 37

End command, 44
ending
a command or function, 44

enter
what does it mean?, 21

Enter Refline command, 290
Enter Text command, 282
entering
special characters, 282
text directly in the drawing, 283
text via text box, 282

environment
changing, 46
editing, 26
saving, 85
saving settings, 27

environment file
setting, 27
setting a drawing frame, 28
setting the current units, 27

Equidist command, 122
exiting Drafting, 427
exporting
font, 426
macro, 425
picture file, 426

extension lines
dimension geometry, 176

external file formats
handling, 427
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F
face
automatically generating, 379
automatically generating in a part,
380
definition of term, 360
deleting, 381
generating a, 378
generating in a part ignoring holes,
379
manually generating, 379
measuring the area, 65
undoing, 380

features
dimensioning single features, 185
showing all, 72

file
identifying, 411
identifying using the file path name,
412
identifying using the search
command, 412
names, 410
organization, 410

File, 409
File Browser
opening a drawing, 413
saving a drawing, 416
saving a drawing under a different
name, 417

filename
MS-DOS, 410

filenames, 410
filing, 409
fill on
text, 288

fillet
dimensioning, 199

Fillet command, 120
fillet weld, 316
fillets
changing radius, 121

drawing, 120
Filter command, 242
fitting, 74
a drawing, 76

flag
frame, 289

Fly By highlighting, 484
Follow on/off
using, 69

font
dimension text, 229
dimension text extension, 236
editing, 295
exporting, 426
importing, 423
text, 288

font editor, 295
Font Editor, 295
font size
surface symbols, 309

form
symbols, 301

format
changing dimension text, 254

frame
balloon, 289
box, 289
dimension text, 230
flag, 289
loading a drawing frame, 28
options, 28
text, 289

Freeze command, 263
functions
dimensioning, 179

fundamentals
of dimensioning, 173

G
gaps
trivial vs non-trivial, 168
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Gaps command, 168
Generate Face command, 378
Generate Hidden command, 386
Generate Part command, 372
generating
a face, 378
hidden lines, 359, 386

generation
mode, 364

Geo command, 39
Geo Sense
settings, 249
using, 211

geometric tolerancing symbols, 299
geometry
construction, 96
creating, 109
dimension geometry, 175

Get Text command, 294
getting
properties, 83

global
selection, 32

Global
selection option combined with
Modify command, 151

Global Selection, 19
graphics performance
enhancing, 85

grid
displaying, 69

grouping, 490

H
handles, 484
hatch distance
fillet weld symbols, 318

hatch settings, 271
hatching
angle, 272
automatically, 268

canceling patterns, 273
Change command, 274
changing the angle, 274
changing the hatch color, 275
changing the hatch distance, 274
changing the hatch match point, 275
changing the hatch pattern, 276
changing the linetype, 275
changing to geometry, 279
deleting, 31, 280
manually, 269
setting patterns, 272
setting the hatch color, 272
setting the hatch distance, 271
setting the linetype, 272
setting the match point, 268
settings, 271
standard patterns, 278
your drawing, 267

hatching around text, 277
help
general, 22, 44

Help command, 22, 44
hidden
redrawing, 381

hidden face
color, 383

hidden line
color, 383
generating, 359, 386
introduction, 360
modes, 363

hidden lines
plotting, 387

Hidden Mode Off command, 381
Hidden Mode On command, 381
Hidden Settings, 382
hiding
ruler/grid, 71

hierarchy
parts, 326

highlighting, fly by, 485
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horizontal
dimensions, 187
measuring distances, 64

horizontal lines
drawing, 111

Horizontal move, 153
HP-GL
saving drawings, 418

HP-GL file
importing, 425

hyperbola
by center, focus and end points, 130
by center, tangent and focus, 130
tangential to existing geometry, 130

Hyperbola command, 130

I
icon
adding to toolbar, 477
creating, 477

icons
in Part Browser, 350

IGES translator, 427
images
changing pixel color, 435
deleting, 438
hiding and showing, 433
importing, 424
inverting black and white, 437
moving, 434
quality for redraw, 433
relocate, 437
rotating, 434
scaling, 434, 438
to back, 434
to front, 434
transparency for overlay, 437

importing
font, 423
HP-GL file, 425
image, 424

macro, 423
Include Dimension command, 341
Include Element command, 338
Include Part command, 341
including
a dimension, 341
a part, 341
an element in another part, 338

infos
adding infos to elements, 399
changing an info, 402
deleting an info, 401
displaying, 73
editing an info, 400
listing all infos, 403
listing namespaces, 403
selecting, 38
setting a current info, 400
what are they?, 399

initiating
a part, 335

Inplace command, 283
Inquire Z Value command, 373
interpolation points, splines, 132-133
interpolation spline
splitting into segments of equal
length, 146

Interpolation Spline command, 134
interpolation splines
adding an interpolation point, 138
appending, 135
changing the shape, 141
changing the shape by moving an
interpolation point, 138
changing the slope at an
interpolation point, 139
changing the slope at any spline
point, 140
creating, 134
deleting a tangency condition, 140
deleting an interpolation point, 138
moving an interpolation point, 138
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specifying the slope, 135
Inverse Black and White, 19
isometric
views, 161

Isometric command, 161
isometric ruler/grid
drawing, 71

italic fonts for symbols, 309

J
JPEG file
importing, 424

justifying
the drawing, 461

K
Keep command, 151
KeepData option, 345
KeepDisply option, 345
key commands
customizing, 477

L
language
switching, 23

layer
changing the color, 73

layers
adding, 396
adding elements to a layer, 397
coloring a layer, 398
dimensioning on, 183
moving elements to a layer, 397
selecting, 38
setting a layer active, 396
using, 394
using the Select block, 398
using the Show functions, 397, 404,
407

layout

loading, 479
resetting, 480
saving, 479

learning
Drafting, 18

lengths
measuring, 64

line
spacing text, 287

line color
setting, 48

Line command, 109
line grid, 69
line size
setting, 48

line size vs line width, 51
line width
changing, 53
dimension lines, 219
reference line, 293
setting, 48

line width vs line size, 51
linear units
dimension, 239

lines
a perpendicular line, 112
by two points, 110
dimension lines, 176
drawing a rectangle, 113
given length and angle, 113
horizontal, 111
polygon, 113
tangent from point to arc or circle,
112
tangent to two arcs or circles, 112
vertical lines, 111

linesize
selecting, 39

linetype
changing, 53
creating a user-defined pattern, 49
deleting user-defined linetype, 51
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editing user-defined linetype, 50
exporting user-defined linetype, 50
hatching, 272, 275
setting, 48

linetype length, 465
listing
all infos, 403

load, 61
Load Backup command, 387
Load File
Absolute, 420
As Subpart, 420
Check 2D, 420
Check 2D Retain Dependency, 420
Keep Scale, 420
Part, 420

Load Files command, 430
load value, 377
defining, 377

Load Z Value command, 377
loading, 409
a part, 420
a standard drawing frame, 28
a subpart, 421
recently used drawing files, 416
the backup drawing, 387

loading drawings
File Browser, 413
in a new Drafting instance, 423
Navigator, 415

location
symbols, 302

long base lines
datum dimensioning, 194

M
macro
exporting, 425
importing, 423

manual
hatching, 269

manually
generating a face, 379

match point
changing the hatch, 275
setting hatching, 268

Max. feedback, 152
maximum
z-value, 375

Measure
calculator, 68

Measure function, 63
measuring
angles, 65
area properties, 65
distances, 63
horizontal distances, 64
lengths, 64
radius, 65
vertical distances, 64

menu items
customizing, 472

menus
custom, 473
displaying or hiding, 472

menus, positioning, 22
Merge command, 166
merging
a subpart, 345
an element, 166

methods
drawing, 95

minimum
z-value in assembly, 375

Minimum Space function, 222
Mirror command, 155
mirroring
about a center point, 156
about a horizontal line, 156
about a vertical line, 156
about two points, 156
elements, 155

mode
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generation, 364
view, 364

modes
hidden line, 363

modifier
symbols, 304

Modify
number of elements in visual
feedback, 152

modify command, 150
modifying
a part, 333
chain and datum dimensions, 265
dimension lines, 255
existing dimension text, 260
general, 150
keeping or removing original
elements, 151
mirroring, 155
moving by reference point, 153
moving horizontally, 153
moving multiple times, 154
moving vertically, 154
rotating, 154
scaling, 157
stretching, 160
using selection, 151

most recently used drawing files, 416
mouse buttons
customizing, 478

Move command, 152
moving
dimension, 261
dimension leader line, 261
dimension text, 260
images, 434
OLE object, 440
symbols, 299
the ruler, 70
using the reference point, 153

moving multiple Drafting instances,
422

MS-DOS filenames, 410
Multiple move, 154

N
names
file, 410

namespaces
listing, 403

naming
parts, 327

Navigator
opening a drawing, 415

New command, 335
normal
redrawing, 381
symbols, 301

O
oblique
parallel perspective views, 158

offset
reference line, 294
setting the distance between the top
of extension lines and dimension
lines, 219

Offset
arc, 118
circle, 115
line, 110

offset point
setting the distance between the
geometry feature and the
dimension extension lines, 222

Offset Point function, 222
OLE Browser, 443
OLE object
activating, 442
deleting, 440
hiding and showing, 442
linking and embedding, 440
moving, 440
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scaling, 440
to back, 442
to front, 442

OLEs
deleting, 31

Open, 413
Check 2D, 414
Check 2D Retain Dependency, 414

open spline, 133
options
text, 288

organization
file, 410

orientation
dimension text, 229
of existing dimension text, 260

origin
displaying, 69

origin vertex
text, 289

overdraw, 123
Overdraw command, 123

P
panning
across a drawing, 74

parabola
by center, tangent and focus, 131
by focus, direction and end points,
131

Parabola command, 131
parallel
construction lines, 97
contours, 122
dimensions, 187-188
lines, 111
perspective views, 158

parameters
printing/plotting, 459
text, 286

part

saving, 419
setting z-values and generating faces
in, 372

Part Browser
description, 350
icons, 350

partname
unique, 357

parts
advantages of, 328
automatically generating all faces in,
380
changing ownership by drag and
drop, 352
changing to a symbol, 354
creating, 336
deleting, 332
detail parts, 337
dimensioning between, 183
dimensioning detail, 183
editing, 334
including a dimension, 341
including a part, 341
including an element, 338
initiating, 335
introduction, 325
modifying, 333
naming, 327
Part Browser, 350
part names, 327
renaming, 352
selecting, 39
setting a reference point, 355
sharing parts, 347
showing a part, 343
smashing, 345
spotlighting, 354
the active part, 327
the part structure, 325
the top part, 325
tree, 32, 357
unique partnames, 357
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viewing, 352
Parts, 323
parts list, 56-57
parts scaling, Set Ref Point command,
357
Paste, 19
Paste As Subpart, 19
path name
identifying files, 412

pattern
changing the hatch, 276
hatching, 272

Pattern command, 272
Pen Settings, 52
pen width
changing, 53

Pens map, 52
pensize
selecting, 39

perpendicular
dimensions, 188
lines, 112

Picture, 432
inverting black and white, 437

Picture Browser, 438
picture color
printing, plotting, 468

pictures
deleting, 30
importing, 424

placing
the ruler/grid, 71

plot
fitting, 463

plot transformation map, 466
plotter
selecting, 459

plotting
boxed area, 462
complete drawing, 462
current show attributes, 464
current viewport, 462

drawing, 464
drawings, 456
hidden lines, 387
linetype length, 465
multiple drawing files, 469
picture color, 468
preview a print/plot, 469
Range, 462
scale, 463
scale factor, 463
starting output, 469
to a file, 460
truecolor, 464

Point command, 109
point coordinates
displaying, 64

points
creating, 109
showing, 72

Points command, 167
Poly Element command, 113
polygons
drawing, 113

polyline, 113
smashing, 115

port (viewports), 76
position
dimensioning option, 247

positioning
drawing in print/plot, 461
welding symbols, 315

postfix
absolute size, 237
adding, 234
clearing, 236
color, 236
deleting, 235
dimension text, 175
font, 236
predefining, 233
ratio, 237
relative size, 237
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saving, 235
slant, 237
special character, 237

prefix
absolute size, 237
adding, 234
adding a new prefix to a dimension,
217
clearing, 236
color, 236
deleting, 235
dimension, 173
font, 236
predefining, 233
ratio, 237
relative size, 237
saving, 235
slant, 237
special character, 237

Prefix function, 217
PreSelected, 43
preset, 61
preview, 56
Preview a Print/Plot, 469
preview colors, 56, 58
preview viewport, 57
print configuration
creating, 457
example, 458

Print Manager, 457
printer
selecting, 459

printing
boxed area, 462
complete drawing, 462
current show attributes, 464
current viewport, 462
drawing, 464
drawings, 456
linetype length, 465
multiple drawing files, 469
picture color, 468

preview a print/plot, 469
range, 462
scale, 463
scale factor, 463
starting output, 469
to a file, 460
truecolor, 464

printing/plotting
preview a print/plot, 469
settings, 459

profile
symbols, 302

projected reference point
creating, 126
settings, 127

properties
associated, 82
getting, 83
putting, 83

Put Text command, 294
putting
properties, 83

R
radius
creating a fillet, 120
dimensioning, 199
measuring, 65

Radius command, 199
range, 62
Range, 462
recalling
a window, 75

rectangle
drawing, 113

Redo, 19
redraw mode, 85
redrawing, 74, 76
hidden, 381
normal, 381

reference
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point for a part, 355
reference line
adding manually, 317
color, 293
creating, 290
destination gap, 294
linetype, 293
offset, 294
selecting, 38
settings, 292
source gap, 294
terminator, 293
width, 293

reference line color
surface symbols, 309

reference lines for symbols
snap angle, 310

renaming parts, 352
Repeat command, 151
repositioning menus, 22
Reset Show, 386
Reset Show command, 431
restoring
last view, 75

revision
symbols, 304

revision checking
loading files, 430
Reset Show, 431
Set Color, 431
Set Color command (revision
checking), 431
Show Difference, 431
supported MI formats, 428

RGB color, 55
rotate
elements, 154

Rotate command, 154
rotating
about a center, 154
dimension text, 261
images, 434

the ruler/grid, 70
using a reference point, 155

rotation
print/plot output, 462

ruler
displaying, 69
moving, 70

ruler/grid
drawing an isometric, 71
hiding, 71
placing, 71
rotating, 70
setting the spacing, 70
using, 69

runout
symbols, 303

S
Save, 416
Save As, 417
Save Part, 419
saving drawings
File Browser, 416
in HPGL format, 418
under a different name, 417

scale
factor for plot, 463
multiple drawing, 355
setting, 463

Scale command, 157, 355
Scale Set Ref Point command, 357
scaling
by center, 157
elements, 157
images, 434, 437
OLE object, 440
using a reference point, 157

scaling parts
center or reference point, 357

Scan
settings, 250
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screendump, 470
select
what does it mean?, 21

Select command, 34
Select command combined with
Modify command, 151
Select mechanism, 31
selecting
a viewport, 73
elements for modification, 151
what is displayed, 72

selection
a vertex, 38
boxing elements, 37
confirming, 44
construction geometry, 39
contours, 40
dimensions, 40
drawing elements, 34
drawing geometry, 39
elements within a polygon, 37
general, 31
global, 32
infos, 38
layers, 38
linesize, 39
parts, 39
pensize, 39
reference lines, 38
removing elements, 37
saving, 419
subtracting elements, 36
subtree, 39
text, 38
URLs, 43

selection filtering, 242
color filter, 246
geometry-type filter, 243
line-slope filter, 244
linesize filter, 245
linetype filter, 244
pensize filter, 245

Set Ref Point command, 355
settings
copilot, 87
saving, 85
text, 286

Share command, 347
shared
parts, 347

shared parts
and z-values, 363, 371

Sheet Browser, 448
short base lines
datum dimensioning, 194

show
functions with layers, 404

Show
functions with layers, 397, 407

Show command, 343
Show Difference command, 431
SHOW function, 72
Show Gaps command, 169
Show Range, 384
showing
a part, 343
all features, 72
dimensions, 73
points, 72

similar
elements, 157

Similar command, 157
single
geometry features dimensioning,
185

size
text, 286

slant angle
text, 287

slot
centerlines, 123

Smash Subpart command, 345
smashing
subparts, 345
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snapping
using the automatic snap feature,
182

source gap
reference line, 294

space
dimension line option, 220
setting the minimum distance
between dimension lines and
geometry features, 222

special character
adding to dimension text extension,
234
entering, 282

special characters
adding, 218

specify
what does it mean?, 21

splines, 132
control points, 132-133
converting, 144
interpolation points, 132-133
modifying, 144
open vs closed, 133
order, 133
splitting, 144

Split command, 165-166
splitting
an element, 165
an element or elements in a box, 166
elements automatically, 165

Spotlight command, 354
spotlighting
a part, 354

Stacked command, 168
Staggered command, 168
standards
copper hatch, 279
dimensioning standards, 184
for hatch patterns, 278
iron hatch, 278
steel hatch, 279

stepping
dimension text automatically, 221

store, 60
storing, 409
a window, 75

Strategy
dimensioning option, 248

Stretch command, 160
stretching elements, 160
structure
of parts, 325
parts, 326

subfix
absolute size, 237
adding, 234
clearing, 236
color, 236
deleting, 235
dimension text, 175
font, 236
predefining, 233
ratio, 237
relative size, 237
saving, 235
slant, 237
special character, 237

subpart
merging, 345

subtree
selecting, 39

superfix
absolute size, 237
adding, 234
clearing, 236
color, 236
deleting, 235
dimension text, 175
font, 236
predefining, 233
ratio, 237
relative size, 237
saving, 235
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slant, 237
special character, 237

surface symbols, 307
color, 309
examples, 311
font size, 309
preconfigured symbols, 310
reference line color, 309
text character slant, 309

switching
infos on and off, 404
layers on & off, 398
URLs on & off, 407

Symbol command, 354
symbols, 298
alignment, 302
changing a part to a symbol, 354
composite, 301
datum target, 304
deleting, 299
form symbols, 301
geometric tolerancing, 299
italic fonts, 309
location, 302
modifiers, 304
moving, 299
normal, 301
profile, 302
revision, 304
runout, 303
setting size, 299
stretching, 317
surface, 307
symbol text, 303
welding, 307

SymLine command, 125
symmetric
dimensions, 189

Symmetry Long
command, 189

Symmetry Single
command, 189

T
tangent
constructing, 98

tangent constructing, 98
terminator
both, 226
changing dimension line settings,
254
dimension line settings, 225
filling on or off, 227
first, 226
position, 226
reference line, 293
relative size, 227
second, 226
size absolute, 227

text
angle, 287
changing dimension text settings,
254
changing settings, 290
character width-to-height ratio, 287
color, 289
copying properties, 294
deleting, 285
dimension, 173
editing via text box, 284-285
entering, 282
entering directly in the drawing, 283
entering via text box, 282
fill on, 288
font, 288
frame, 289
general, 281
line spacing, 287
modifying dimension, 260
options, 288
origin, 289
parameters, 286
selecting, 38
settings, 286
size, 286
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text slant angle, 287
text character slant
surface symbols, 309

text file
loading, 283
storing, 283

text frame
dimension, the different types, 176

text functions
welding symbols, 316

Text to Geometry command, 290
Text Window command, 277
TIFF file
importing, 424

tolerance
dimension text, 174
geometric tolerance group, 299
limit tolerancing, 174
plus and minus tolerancing, 174
upper and lower tolerancing, 175

tolerances
absolute size, 237
adding, 234
clearing, 236
color, 236
deleting, 235
font, 236
predefining, 233
ratio, 237
relative size, 237
saving, 235
slant, 237
special character, 237

toolbar
adding a button, 477
adding items, 473
creating, 473
loading, 479
saving, 479

toolbar items
editing, 472

top part

what is it?, 325
trace
using the dimension trace, 182

Transform command, 158
Trim Expand command, 162
trimming
elements, 162
one element, 162
two elements, 163

Trimming command, 144
truecolor
plotting, 464
printing, 464

TrueType font
importing, 423
resolution, 424

U
underlining
dimensions, 264

Undo, 19
Undo command, 44
UNDO command, 30
undoing
a face, 380
commands, 44

Unicode, 497
units
angular dimension, 239
dimensioning, 238, 255
linear dimension, 239
setting, 27

Unshare command, 350
unsharing
a part, 350

unsharing parts, 350
URL
color, 407
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