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Preface

Creo Elements/Direct Drafting is a versatile 2D design and drafting system for
optimizing each stage of the design process. Using Creo Elements/Direct Drafting,
you can quickly and easily create and modify 2D drawings.
Creo Elements/Direct Drafting has a full set of commands for constructing,
modifying, viewing, measuring, and plotting a 2D drawing.
Using a mouse or other supported digitizer, you have the facility to:

• Perform real time zoom-in and zoom-out.
• Pan in real time, across the entire drawing or a zoomed-in portion.
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Who Should Use This Guide
Read this guide if you are a:

• Design engineer
• Industrial designer
The Creo Elements/Direct Drafting documentation set is designed to help you
learn to use Creo Elements/Direct Drafting quickly and easily. It consists of:

• Creo Elements/Direct Drafting User’s Guide
• Installing and Configuring Creo Elements/Direct Drafting
• Writing Macros with Creo Elements/Direct Drafting
• Creo Elements/Direct Drafting Interfacing
This guide is written for users who have limited experience with CAD software.
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Purpose of This Guide
This guide provides information about:

• Setting up Creo Elements/Direct Drafting for your particular environment.
• The Creo Elements/Direct Drafting user interface.
• Using the Creo Elements/Direct Drafting commands and functions.
• Using the dynamic graphic facilities.
• Working with parts and assemblies.
• How to generate hidden lines.
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How to Use This Guide
Use this guide for both day-to-day use and reference. Each section contains:

• A description of the command or function.
• The procedure used to perform the given task.
• A tutorial example (when required).
• Any reference material required.
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How This Guide is Organized
This guide is organized in the same order as the way you are likely to use Creo
Elements/Direct Drafting:

Chapter 1 The Drafting User Interface — provides a brief overview of the
system and describes how to use fly by highlighting and handles.

Chapter 2 Customizing the Creo Elements/Direct Drafting Ribbon — how to
customize the ribbon to quickly access frequently-used commands.

Chapter 3 Getting Started with Creo Elements/Direct Drafting — supplies you
with hints to help in getting started.

Chapter 4 Preparing the Drawing Environment — how to set up the
environment and store it as a file.

Chapter 5 Commonly Used Commands — how to escape from a current
activity.

Chapter 6 Changing the Environment and Making Measurements — how to
change the environment in which the drawing is produced and how
to measure distances on your drawing.

Chapter 7 Using the Creo Elements/Direct Drafting's Copilot Functionality —
how to create a design drawing with the minimum of construction
geometry.

Chapter 8 Drawing Methods — how to create a drawing with or without the
aid of construction geometry.

Chapter 9 Modifying a Drawing — how to modify your drawing.
Chapter 10 Dimensioning a Drawing — how to automatically dimension a

drawing.
Chapter 11 Hatching a Drawing — how to hatch drawing sections.
Chapter 12 Adding Text to a Drawing — how to add text to a drawing.
Chapter 13 Adding Symbols to a Drawing — how to add geometric tolerance

symbols and other special annotation to your drawing.
Chapter 14 Handling Parts and Assemblies — how to use parts and assemblies

when creating drawings.
Chapter 15 Generating Hidden Lines — how to generate hidden lines in

assembly drawings.
Chapter 16 Using Layers and Infos — how to use layers and how to add textual

information (infos) to elements in your drawing.
Chapter 17 Storing, Loading, and Filing — how to load and save your Creo

Elements/Direct Drafting drawing files.
Chapter 18 Revision Checking — how to compare revised drawings.
Chapter 19 Associative Documentation Update — how to update 3D design
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modifications in the 2D layout.
Chapter 20 Editing Imported Pictures — how to handle imported bitmap files in

Creo Elements/Direct Drafting.
Chapter 21 Linking and Embedding OLE Objects — how to insert OLE objects

into a Creo Elements/Direct Drafting drawing.
Chapter 22 Annotation — how to visualize, annotate and edit MI format 2D

drawings generated by Creo Elements/Direct Annotation.
Chapter 23 Printing and Plotting — how to plot your finished drawing and how

to dump screens.
Chapter 24 Parametric Design with Creo Elements/Direct Drafting Fluent User

Interface — how to use the Parametric Design module in Creo
Elements/Direct Drafting

Chapter 25 Toolbar and Classical Menu Support in Creo Elements/Direct
Drafting Fluent User Interface — how to load toolbars and classical
menus in Creo Elements/Direct Drafting.

Chapter 26 Managing drawings with Windchill — how to activate Windchill
PDM actions and the various Windchill PDM commands.
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1
The Drafting User Interface

Fly By Highlighting.....................................................................................................26
Handles....................................................................................................................28

With Creo Elements/Direct 18.0, a Fluent user interface has been introduced for
Drafting. The Fluent user interface facilitates faster access to commands by
grouping the commands according to their functionality.
The Creo Elements/Direct Drafting consists of the following elements:

• File Tab on page 19
• Quick Access Toolbar on page 21
• Ribbon on page 21
• Status Bar on page 23
• Drawing Area on page 24
• Part Browser on page 24
• Command Mini Toolbar on page 24
• Context Menu on page 24
• Command Line on page 24
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Figure 1: The Drafting User Interface

1 File tab
2 Quick Access Toolbar
3 Ribbon
4 Part Browser
5 Command Mini Toolbar
6 Context menu
7 Drawing area
8 Command line
9 Status bar

You can middle-click to perform the following operations:

• Middle-click to end a command.
• Middle-click and rotate to zoom.
• Middle-click and drag to pan.
Refer to Creo Elements/Direct Drafting Quick Reference Card for more
information.

File Tab
The File button in the upper-left corner of the Creo Elements/Direct Drafting
window opens the File menu. The File menu contains the following commands:
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• New Session: Opens a new drafting window.
• Open: Opens a drawing from the file system.
• Open From Database: Opens a drawing from the database which is connected

to the Drafting current session. If no database is activated, this command is not
available.

• Save or Save As: Saves a drawing to the file system.
• Save To Database: Saves a drawing to the database which is connected to the

Drafting current session. If no database is activated, this command is not
available.

• Database: Offers commands that are specific to the database which is
connected to the current Drafting session. The name of this command changes
depending on the database. For example, if you activate Drawing Manager,
Database changes to Drawing Manager. If no database is activated, this
command is not available.

• Print: Prints or plots a drawing. For more information, see Printing and
Plotting on page 606.

• Import/Export: Imports or exports files. For more information, see Storing,
Loading, and Filing on page 528.

• Modules: Activates or deactivates one of the following database modules:

○ Design Data Management

○ Drawing Manager

○ Windchill Workgroup Manager

○ Integration for SAP ERP

You can also activate the Hidden and Parametric modules.
• Settings: Changes the draw and system settings. For more information, see

Preparing the Drawing Environment on page 61.
• Keys: Customizes the keys. For more information, see Defining Key

Commands on page 57.
• Options: Opens the Quick Access Toolbar settings for adding or removing

commands in the Quick Access toolbar.
• Exit: Exits Creo Element/Direct Drafting.
• Search for Command: Type the name of the command and then select the

relevant command from the list to start the command.
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Quick Access Toolbar
The Quick Access toolbar is by default at the top of the Creo Elements/Direct
Drafting window. It provides quick access to frequently-used commands. You can
customize the Quick Access toolbar by adding commands (buttons and menus) to
it.

Ribbon
The ribbon contains commands organized as a set of tabs. On each tab, related
commands are grouped. The following figure shows the different elements of a
ribbon.

Figure 1A: Ribbon

1 Tab
2 Group
3 Button
4 More button

1. Tab: The tabs available on the ribbon are:

• Drafting

• Modify

• Structure

• Compare

• View

• Hidden

• Parametric

• Annotation

• ADU

• Miscellaneous

To activate the Hidden module, the Parametric module in Creo Elements/
Direct Drafting:

a. Click File ▶ Module.
b. Click one of the following:
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• Hidden to activate the Hidden module.

• Parametric to activate the Parametric module.

You can customize the ribbon to display the following additional tabs:

• Annotation

• ADU

• Miscellaneous

For more information about customizing the Creo Elements/Direct Drafting
ribbon, see Customizing the Creo Elements/Direct Drafting Ribbon on page
32.

2. Group: Commands are placed within groups according to their functionality.

Note
The Utilities group is available on all the tabs except the following tabs:

• View

• Annotation

• ADU

• Miscellaneous

3. Button: Each button on the ribbon represents a command and consists of an
icon and a label. Some buttons also contain an arrow along with an icon and
label.

The ribbon has the following types of buttons:

• or (Large or small button with an icon and a label):
Click this button to execute an operation.

• or (Large or small button with an icon and an arrow not
separated by a line): An arrow indicates the existence of a list. Click this
button to open a list of related commands. When no line separates a
button, the icon and arrow perform the same action.
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• or (Large or small button with an icon and an arrow
separated by a line): A line, or separation, between the icon and arrow
indicates that the icon and arrow perform different actions. Click the icon
on this button to execute an operation. Click the arrow to open a list of
related commands. The icon of the last-selected command in the current
session is displayed on the button.

Note
○ The label remains unchanged irrespective of the last selection.
○ The tooltip displays the name of the command that the icon

represents.
○ The procedural topics assume that the icon of the default command

in a list is displayed on a button though you may see the icon of
your last-selected command.

4. More: The rarely-used commands are listed at the end of each group under the
More button to optimize the user interface.

Status Bar
The status bar is at the bottom of the Drafting window and has the following
buttons:

• : Confirms a command or selection.

• : Ends the current command.

• : Cancels the current command.

• : Highlights the active part in the graphics area.

• : Switches the full screen mode on and off (alternatively, you can press
F11). For more information, see Viewing a Drawing in the Full Screen Mode
on page 122.

• : Defines a new viewing window.

• : Displays the last view.

• : Fits the content into the viewport.
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The status bar also displays the coordinates at which the cursor is placed in the
drawing area, the name of the current part, and the catch range. For more
information on catch, see Changing the Drawing Environment and Making
Measurements on page 90.

Drawing Area
The drawing is displayed in the drawing area. The drawing area is in between the
ribbon and the status bar.

Part Browser
The part browser displays the assembly structure with the parts and subparts, the
unique ID, part-sharing information, scale, and symbol for the part or the subpart.

Click Structure and then, in the Parts group, click Browser (alternatively,
press F12) to show or hide the part browser.

Command Mini Toolbar
Creo Elements/Direct Drafting opens the Command Mini Toolbar (CMT) when
you select any element in the drawing area in the preselection mode. Depending
on the current context and the selected object, the elements on the CMT change.
The CMT helps you to quickly execute a command from the viewport. The first
command on the CMT is the command executed upon Drag and Drop of the
element. For more information, see Command Mini Toolbar on page 52.

Context Menu
The context menu opens when you right-click an element in the drawing area in
the preselection mode. Depending on the current context and the selected object,
the commands on the context menu change. The first command on the context
menu is the View command. If you right-click the drawing area without selecting
any element, the context menu contains only the View buttons. For more
information, see Context Menu Commands on page 55.

Prompt Line
The Prompt Line tells you how to proceed to complete the current operation. In the
absence of the Prompt Line, Creo Elements/Direct Drafting displays the prompt in
the status bar.
You can enable or disable Prompt Line by clicking or clearing the Prompt Line

check box under Toolbars in the Viewing group on the View tab, respectively.

Command Line
In the Command Line (user input line) you can type the required values, when
prompted.
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You can enable or disable Command Line by clicking or clearing the Command

Line check box under Toolbars in the Viewing group on the View tab,
respectively.
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Fly By Highlighting
When you pass over an element with your cursor, fly by highlighting indicates
which elements are available for work. Fly By highlighting is available in three
modes:

• No commands are active.

When you pass over an element with your cursor, Creo Elements/Direct
Drafting highlights the elements that you can drag (A) or that have handles
(when you click the element) (B).

• A command is active.

When you pass over an element with your cursor, the highlighted elements can
be used for the command. In the image, the arrow points to the highlighted
element where the text box will be placed.
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• Selection of parts.

When you hover over an element belonging to a part or the rounding box of
the part, Creo Elements/Direct Drafting highlights the part.

Fly By Highlighting Settings
Creo Elements/Direct Drafting allows you to enable or disable fly-by highlighting
and change the color of the highlight using the System dialog box.
To define the settings for fly-by highlighting:

1. Click File ▶ Settings ▶ System.
2. Click FlyBy.
3. Click or clear the Enable Fly-By Highlighting check box to enable or disable

fly-by highlighting, respectively.
4. In the Color box, select the required color for highlighting.
5. Click OK.
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Handles
Use handles to quickly and easily modify geometry elements, dimensions, text
and symbols, symmetry and center lines, references lines, and parts. Handles
appear as:

• Squares and diamonds for geometry elements, dimensions, symmetry and
center lines, and reference lines.

• Frame around text, symbols, and parts.

Modify with handles
There are two ways to modify an element using the mouse:

• Drag: Available for dimensions, text, symbols, and parts.

○ Click the element and drag it to a new location.
○ Release.

• Click and Drag: Available for all elements.

○ Click the element to display the handles.
○ Click the element again and drag it to a new location.
○ Release.

To show the handles on more than one element at a time, press SHIFT and select
the elements.
To remove the handles, press ESC or type MH_CLEAR in the user input line and
press ENTER.
Dimensions: Move and reattach dimensions, change the direction of the arrows,
and modify the stagger line.

• Move the dimension and text: Click anywhere on the dimension and drag.
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• Change the direction of the arrows: Click the diamond-shaped handle. You
cannot change the direction of arrows for broken dimension lines (see broken
on page 308).

• Reattach the dimension: Click the square-shaped handle where the dimension
is attached to the element and drag.

• Modify the stagger line: Click the square-shaped handle and drag.
• Move the dimension text only: Press SHIFT and drag the text.
Text or Symbols: Move the text or symbol box.

1. Hover the cursor over the text or symbol. Creo Elements/Direct Drafting
highlights a box around the text or symbol (if you have enabled fly-by
highlighting).

2. Drag the text or symbol to a new location.
Symmetry or Center lines: Extend a symmetry or center line or rotate a center
line.

• Extend the symmetry or center line: Click the handle and drag.
• Rotate the center line: Click the center line (not on the handles) and drag.
Reference lines: Move the reference line or stretch reference line segments.

• Move the reference line: Click the handle on the start or end of the refline and
drag.

• Stretch reference line segments: Click inside the refline handles and drag.

Delete with handles
1. Click the item to be deleted.

Creo Elements/Direct Drafting highlights the item or displays handles.
2. Press DELETE.

Handles Settings
Creo Elements/Direct Drafting allows you to enable or disable the handles and
change handle settings using the System dialog box.
To enable or disable the modification handles:

1. Click File ▶ Settings ▶ System.

The System dialog box opens.
2. Click Handles.
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3. Click or clear the Enable Modification Handles check box to enable or disable
handles, respectively.

4. Click OK.
You can also define the following settings for handles using the Handles pane in
the System dialog box:

• Handles

• Selection

• Allowed Types

Handles
In the Handles area, set the following:
Fill Color Select a color for the square and diamond-shaped

handles.
Box Color Select a color for the frame around text, symbols, and

parts.
Size Type the size of the square handle in pixels.

Selection
In the Selection area, click any of the following:
Local Show the handles of the current part.
Subtree Show the handles of the current part and its subpart. If you

click an element in another part, the entire part is selected.
Global Show the handles of all parts. Select the entire part when your

cursor hovers over the rounding box of the part.

Note
You must click the element to view the handles.

Allowed Types
In the Allowed Types area, specify which elements will display handles when they
are clicked.
Click the check box of the required element types from the following:

• Geometry

30 Creo Elements/Direct Drafting User's Guide: Fluent User Interface



• Dimensions

• Construction Geo

• Associative Geo

• Texts

• Parts

To specify all element types, click the ALL check box.

Further Information
For further technical information about FlyBy, refer to the Creo Elements/Direct
Drafting help system.
Type help flyby in the Creo Elements/Direct Drafting user input line and press
ENTER.
Creo Elements/Direct Drafting displays further information about FlyBy.
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You can customize the Creo Elements/Direct Drafting ribbon to quickly access
frequently-used commands.
You can customize the ribbon by:

• Creating a User-Defined Command on page 34
• Modifying a User-Defined Command on page 35
• Adding a Button (Command) to the Ribbon on page 36
• Removing a Tab, Group, or Button from the Ribbon on page 36
• Adding a Tab on page 37
• Adding a Group on page 38
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• Adding an Element to the Ribbon on page 39
• Renaming a Tab, Group, or Button on page 40
• Hiding or Showing a Tab or a Group on page 40
• Modifying the Button Style on page 41
• Changing the Order of a Tab, Group, or Button on page 42
• Exporting and Re-using a User-Defined Tab on page 43
• Exporting Ribbon Customization Settings on page 45
• Importing Ribbon Customization Settings on page 46
You can customize the ribbon using the Options dialog box.
To open the Options dialog box:

• Click File ▶ Options.

Alternatively, right-click the ribbon and select Customize Quick Access
Toolbar.

The Options dialog box opens. The Customize Ribbon pane is selected by
default.

To apply and view the customized settings, click OK in the Options dialog box.
To cancel the modified settings, click Cancel in the Options dialog box.
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Creating a User-Defined Command
You can create your commands and add them to the Creo Elements/Direct
Drafting ribbon.
To create a command:

1. Click File ▶ Options.

The Options dialog box opens. The Customize Ribbon pane is selected by
default.

2. Click New.

The Create New Command dialog box opens.
3. In the Command ID area, type a name for the command in the Name box.

Note
Creo Elements/Direct Drafting displays the specified name as the label for
the button (command) on the ribbon.

4. Optionally, type a tooltip for the command (button) in the Tool Tip box.
5. Optionally, type a category for the command in the Category box.

The default category is User-Defined.

If you type a new category name, a category is created with the specified
name, and the command is added to the category.

6. Optionally, in the Icon area, click Browse to select an image for the button.

Note
• Creo Elements/Direct Drafting supports PNG and BMP images for

buttons.
• Creo Elements/Direct Drafting partially supports JPG and JPEG images

for buttons. Creo Elements/Direct Drafting converts these images to BMP
images internally.

7. In the Command Action box, provide the action (function) details.

See the Creo Elements/Direct Drafting / Creo Elements/Direct 2D Access
Programming Reference Guide for details about functions and commands.
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Note
Creo Elements/Direct Drafting executes the specified function when you
click the button.

8. Click Add.

The command is now available in the User-Defined list of the Choose
commands from box.

Note
You must provide at least a name and an action to create a command.

Modifying a User-Defined Command
You can modify the user-defined commands in Creo Elements/Direct Drafting.
To modify a user-defined command:

1. Click File ▶ Options.

The Options dialog box opens. The Customize Ribbon pane is selected by
default.

2. In the Choose commands from box, select User-Defined.

The user-defined commands are listed.
3. Select the command.
4. Click Modify.

The Create New Command dialog box opens.

Note
Modify is activated only after you select a user-defined command.

5. Edit the settings.
6. Click Modify to save the edited settings.
If you want to delete the user-defined command, click Delete in the Create New
Command dialog box.
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Adding a Button (Command) to the
Ribbon
You can add the default Creo Elements/Direct Drafting buttons as well as user-
defined buttons to the Creo Elements/Direct Drafting ribbon.
To add a button to the ribbon:

1. Click File ▶ Options.

The Options dialog box opens. The Customize Ribbon pane is selected by
default.

2. In the Customize the Ribbon list, select the group to which you want to add a
button.

3. In the Choose commands from box, select the tab name.

The commands on the selected tab are listed.

Tip
To view the list of user-defined commands, select User-Defined.

4. Select a command and click Add.

The button for the selected command is added to the group on the ribbon.

Note
• You can add buttons to user-defined groups only.
• You cannot add buttons directly to a tab.

Removing a Tab, Group, or Button from
the Ribbon
To remove a tab, group, or a button from the ribbon:

1. Click File ▶ Options.

The Options dialog box opens. The Customize Ribbon pane is selected by
default.

2. In the Customize the Ribbon list, select the tab, group, or button (command).
3. Click Remove.
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The selected tab, group, or button is removed from the ribbon.

Note
• You can remove the user-defined tabs and groups only.
• You cannot remove buttons of the default groups.

Tip
You can also use the context menu to remove tabs, groups, or buttons.

Adding a Tab
You can add a tab to the Creo Elements/Direct Drafting ribbon.
To add a tab:

1. Click File ▶ Options.

The Options dialog box opens. The Customize Ribbon pane is selected by
default.

2. In the Customize the Ribbon list, select a tab below which your tab should be
added.

The selected tab is highlighted.

Note
• If you do not select a tab, your tab is added at the end of all tabs.
• If an item is already selected, your tab is added below the parent tab of the

selected item.

3. Click New Tab.

A tab is added below the selected tab. In addition, a group is automatically
added to the tab.

4. Select the tab, click Rename, and specify a name for the tab.

Customizing the Creo Elements/Direct Drafting Ribbon 37



Tip
You can also use the context menu to add a tab.

Adding a Group
You can add a group to the Creo Elements/Direct Drafting ribbon.
To add a group:

1. Click File ▶ Options.

The Options dialog box opens. The Customize Ribbon pane is selected by
default.

2. In the Customize the Ribbon list, select a tab or group.

Ensure that you select a tab or group below which you need to add the group.

The selected tab or group is highlighted.

Note
If you do not select a tab or group, your group is added at the end of all
groups of the first tab.

3. Click New Group.

A group is added below the selected tab or group.
4. Click Rename and specify a name for the group.

Note
You can add groups to user-defined tabs only.

Tip
You can also use the context menu to add a new group.
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Adding an Element to the Ribbon
You can add the following elements to the user-defined groups in the Creo
Elements/Direct Drafting ribbon:

• A button with an arrow not separated by a line (Menu)
• A button with an icon and an arrow separated by a line (Split Menu)

For details about different types of buttons, see Ribbon on page 21.
• A separator

Note
You can also add the default buttons similar to the buttons (created by using
Menu or Split Menu) in the user-defined groups.

To add a new element:

1. Click File ▶ Options.

The Options dialog box opens. The Customize Ribbon pane is selected by
default.

2. In the Customize the Ribbon list, select a user-defined group to which you
want to add a new element.

3. Click New Element.
4. Select one of the following:

• Menu to add a button with an arrow not separated by a line.

For example, .

The button is added at the end of the selected group.
• Split Menu to add a button with an icon and an arrow separated by a line.

For example, .

For details about different types of buttons, see Ribbon on page 21.

The button is added at the end of the selected group.
• Seperator to add a separator.

A separator is added below the selected group.
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Note
You can also add a separator between two buttons.

5. Click Rename and specify a name for the button (created by using Menu or
Split Menu).

6. To add a command (button) to the button (created by using Menu or Split
Menu), see Adding a Button (Command) to the Ribbon on page 36.

Renaming a Tab, Group, or Button
To rename a tab, group, or button:

1. Click File ▶ Options.

The Options dialog box opens. The Customize Ribbon pane is selected by
default.

2. In the Customize the Ribbon list, click the tab, group, or button.

The selected item is highlighted.
3. Click Rename and specify a name for the tab, group, or button.

The new name is displayed in the Customize the Ribbon list and on the ribbon
after you click OK.

Note
You can rename user-defined tabs and groups only.

Tip
You can also use the context menu for renaming elements on the ribbon.

Hiding or Showing a Tab or a Group
You can select the tabs or groups that you want to hide or view on the ribbon.
To hide or show a tab or a group:

1. Click File ▶ Options.
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The Options dialog box opens. The Customize Ribbon pane is selected by
default.

2. In the Customize the Ribbon list, clear or click the check box of the tab or
group to hide or show the tab or group, respectively.

Modifying the Button Style
You can modify the appearance of a button on the ribbon.
To modify the appearance of a button:

1. Click File ▶ Options.

The Options dialog box opens. The Customize Ribbon pane is selected by
default.

2. In the Customize the Ribbon list, select a button.

The Modify button is activated.

Tip
To select multiple buttons in the Customize the Ribbon list:

• Press SHIFT+[button] for range selection of buttons. Buttons that are
within a group are selected only if the group buttons are expanded.

• Press CTRL+[button] for individual selection of buttons.

3. Click Modify.

The Modify Button dialog box opens.
4. In the Icon area, click Browse to replace the current icon with a different icon.

Note
• Creo Elements/Direct Drafting supports PNG and BMP images for icons.
• Creo Elements/Direct Drafting partially supports JPG and JPEG images

for icons. Creo Elements/Direct Drafting converts these images to BMP
images internally.

To reset the icon, click Reset.
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Note
You can change or reset the icon of the following:

• A user-defined button created by using Menu.
• A default button with an icon and an arrow, and not separated by a line.

5. In the Button Layout area, select one of the following:

• Small to display the button as a small button.
• Small - No Icon to display the button as a small button without the icon.
• Large to display the button as a large button.

6. Optionally, click or clear the Hide check box to hide or display the label of the
button, respectively, on the ribbon.

Changing the Order of a Tab, Group, or
Button
You can change the order of a tab, group, or button on the ribbon in Creo
Elements/Direct Drafting.
To change the order of a tab, group, or button:

1. Click File ▶ Options.

The Options dialog box opens. The Customize Ribbon pane is selected by
default.

2. In the Customize the Ribbon list, select the button, group, or tab.

3. Click to move up or to move down.

Tip
You can also use the context menu to change the order of a tab, group, or
button on the ribbon.
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Exporting and Re-using a User-Defined
Tab
You can export a user-defined tab and import it to a module. You can export a
single user-defined tab at a time. You can also import a single user-defined tab or
multiple user-defined tabs to a module at a time.
To export a user-defined tab:

1. Click File ▶ Options.

The Options dialog box opens. The Customize Ribbon pane is selected by
default.

2. In the Customize the Ribbon list, select the user-defined tab.
3. Right-click and select Export Tab.

The user-defined tab is exported as an XML file to the Modules subdirectory
of the installation directory. The XML file carries the name of the user-defined
tab and contains information about the commands or buttons on the user-
defined tab.

Note
The Modules subdirectory of the installation directory is the default
directory in which Creo Elements/Direct Drafting saves the exported XML
file. To change the default directory, use the ME_SET_MODULE_
SEARCH_PATH command in the user input line. See ME_SET_MODULE_
SEARCH_PATH in the Creo Elements/Direct Drafting / Creo Elements/
Direct 2D Access Programming Reference Guide for details.

To import a single user-defined tab or multiple user-defined tabs to a module, use
the REGISTER_MODULE command in the user input line to import the XML file
in the Creo Elements/Direct Drafting user interface. See REGISTER_MODULE in
the Creo Elements/Direct Drafting / Creo Elements/Direct 2D Access
Programming Reference Guide for details.
To start or stop the module:

1. Click File ▶ Modules.
2. Select the module.
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Note
The modules (consisting of user-defined tabs) are removed when you exit
Creo Elements/Direct Drafting.

Tip
You can create macro files to perform activities like licensing-related tasks, if
required, when you start or stop the module.

• You can create a macro file in the Modules subdirectory (default) or in the
path specified using the ME_SET_MODULE_SEARCH_PATH command and
the file name must be identical to the name of the user-defined module. For
example, you can create a macro file IBS.m for the user-defined module IBS
and include the load-specific macros in the file. Creo Elements/Direct Drafting
uses this macro file during the start of the module. Ensure that you have
included the commands required to activate the buttons on the imported tabs in
the macro file. You can also add licensing-related commands to the macro file.

• When you stop a user-defined module, Creo Elements/Direct Drafting
removes the tab of the corresponding module. You can create a macro file in
the Modules subdirectory (default) or in the path specified using the ME_
SET_MODULE_SEARCH_PATH command and the file name must be
identical to the name of the user-defined module appended by _unload. For
example, you can create a macro file IBS_unload.m for the user-defined
module IBS and include the unload-specific macros in the file. You can add
commands to release any licenses acquired for the module or perform the
desired cleanup actions using this macro file.

To import a user-defined tab to the Creo Elements/Direct Drafting ribbon, use the
IMPORT_TAB command in the user input line and import the XML file. See
IMPORT_TAB and ME_SET_MODULE_SEARCH_PATH in the Creo Elements/
Direct Drafting / Creo Elements/Direct 2D Access Programming Reference Guide
for details.
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Note
• You can specify the name of an existing tab for an imported tab. Importing a

tab with a name similar to an existing tab does not affect the existing tab.
Consequently, Creo Elements/Direct Drafting adds another tab with a similar
name in the Creo Elements/Direct Drafting ribbon.

• The import of user-defined tabs is independent to the registration of user-
defined modules.

• The imported tabs are removed when you exit Creo Elements/Direct Drafting.
Consequently, they are unavailable when you start Creo Elements/Direct
Drafting next time.

You can modify (add elements to, move the elements, and so on) the imported
user-defined tab or module by starting Creo Elements/Direct Drafting with the
moduleadmin option:

1. Click Start ▶ All Programs ▶ PTC ▶ Creo Elements Direct Drafting [version].
2. Right-click Creo Elements Direct Drafting [version].
3. Select Properties.
4. In the Target box, append –moduleadmin at the end of the existing string.
5. Click OK.

Note
• If you start Creo Elements/Direct Drafting without using -moduleadmin,

the user-defined tabs are considered as system tabs and you cannot modify
them.

• The imported tabs are available in the Creo Elements/Direct Drafting ribbon
even after you use Reset in the Options dialog box to restore default ribbon
settings.

Exporting Ribbon Customization Settings
You can export the existing customization settings of the Creo Elements/Direct
Drafting ribbon to a XML file. The same customization settings can be used on
other computers by importing the XML file in Creo Elements/Direct Drafting.
To export the ribbon customization settings:
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1. Click File ▶ Options.

The Options dialog box opens. The Customize Ribbon pane is selected by
default.

2. Click Import/Export.
3. Click Export Customization.

The Choose exported Creo UI file dialog box opens.
4. Specify the path and the file name for the XML file.

Importing Ribbon Customization Settings
You can import the XML file generated by Export Customization to replace the
existing ribbon customization settings.
To import the ribbon customization settings:

1. Click File ▶ Options.

The Options dialog box opens. The Customize Ribbon pane is selected by
default.

2. Click Import/Export.
3. Click Import Customization.

The Choose exported Creo UI file dialog box opens.
4. Select the XML file.

Note
The imported ribbon customization settings override the existing ribbon
customization settings. It is recommended to export the existing ribbon
customization settings before using Import Customization. You can then use
the exported file to revert to the existing ribbon customization settings, if
required.

Restoring the Default Ribbon Settings
You can reject the changes that you have made for customizing the ribbon. The
default ribbon settings are restored after rejecting the ribbon customization
changes.
To restore the default ribbon settings:

1. Click File ▶ Options.
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The Options dialog box opens. The Customize Ribbon pane is selected by
default.

2. Click Reset.
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Starting Creo Elements/Direct Drafting
To start Creo Elements/Direct Drafting with the standard Fluent UI:

• Click Start ▶ All Programs ▶ PTC ▶ Creo Elements Direct Drafting [version] ▶
Creo Elements Direct Drafting [version].

To start Creo Elements/Direct Drafting with alternative UI:

• Classic UI

○ Click Start ▶ All Programs ▶ PTC ▶ Creo Elements Direct Drafting [version]
▶ Alternative UI ▶ Creo Elements Direct Drafting [version] (Classic UI).

• Mixed UI

○ Click Start ▶ All Programs ▶ PTC ▶ Creo Elements Direct Drafting [version]
▶ Alternative UI ▶ Creo Elements Direct Drafting [version] (Mixed UI).

• Windows UI

○ Click Start ▶ All Programs ▶ PTC ▶ Creo Elements Direct Drafting [version]
▶ Alternative UI ▶ Creo Elements Direct Drafting [version] (Windows 9x).

Basic Working Methods
This section informs you about few hints that may help you to get started with
Creo Elements/Direct Drafting.
The best way to learn is to practice, and we recommend you try the examples
given in this guide. If you need further explanation of any of the 2D functions or
buttons, refer to this guide. It contains a description of how to use each button or
function.
An index is included at the back of the guide. It contains not only the command
and function names but also a task reference.

Cut, Copy, and Paste

Creo Elements/Direct Drafting provides Cut, Copy and Paste which
operate via the Clipboard.
To use them, click Drafting and then, in the Clipboard group, click the following
buttons:

• Click Cut to cut elements.

• Click Copy to copy elements.

• Click Paste to paste elements.
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The Select buttons (including Polygon; see Selecting Drawing Elements
on page 77) can be used to facilitate the selection of elements to be cut or copied.
The handling of elements via the Clipboard can be manipulated via the Clipboard
settings.
To view the Clipboard settings:

1. Click File ▶ Settings ▶ System.

The System dialog box opens.
2. Click Clipboard.
You can change the following settings:
Inverse Black and
White

Click the Inverse Black and White check box.
White changes to black, while black changes to white.

Global Selection Click the Global Selection check box.
Like the Global selection function (see Selecting Drawing
Elements on page 77), this setting selects the entire parts
tree rather than just the current part. If you paste to Creo
Elements/Direct Drafting, this parts tree is retained. If
you copy to another application, the parts tree is
smashed.

Paste As Subpart
When you have cut or copied an item, you can paste this item such that it is owned
by the current part using the As Subpart button. Refer to Hierarchical Parts
Structure on page 431 for details on the Creo Elements/Direct Drafting parts
structure concept.
To use As Subpart:

1. Click Drafting and then, in the Clipboard group, click the arrow next to
Paste.

2. Click As Subpart.

Undo and Redo
In Creo Elements/Direct Drafting, you can undo mistakes with Undo or
Redo:

• On the Quick Access Toolbar, click to undo an operation or press CTRL
+Z.
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• On the Quick Access Toolbar, click to redo an operation (after you have

clicked Undo) or press CTRL+Y.

Each time you click Undo or Redo, you will undo or redo all the changes
that were created by the last button you clicked.

You can set a limit on the number of steps to keep in the Undo history in the
System dialog box.

1. Click File ▶ Settings ▶ System.

The System dialog box opens.
2. Click Environment.
3. In the Undo area, click one of the following:

• Click Unlimited to allow unlimited number of steps for Undo.
• Click Max steps and type the maximum number of steps allowed in the

Undo history.

Limitations:

• You can undo or redo complete macros, but you cannot use Undo or
Redo inside macros.

• Undo or Redo cannot undo or redo:

○ Commands related to parametric design or hidden lines.

Once you have executed one of these commands, you can no longer undo
or redo any of your previous commands.

○ The RESET_SYSTEM command.
○ Commands for default settings (although these commands do not affect the

Undo or Redo history).

Undo and Redo with state history
Each time you enter a command and change your drawing, Creo Elements/Direct

Drafting adds a new state to the Undo or Redo history. Creo Elements/
Direct Drafting marks the new state with a unique ID. You can use several

Getting Started with Creo Elements/Direct Drafting 51



commands to work with these unique IDs. For further information, see the Creo
Elements/Direct Drafting / Creo Elements/Direct 2D Access Programming
Reference Guide.

Select, Click, Specify, and Enter
Many operations require similar user interaction, For example, you are often
prompted to select an element, enter a value, enter a filename, or specify a point.
Some of the most commonly used terms are listed below:

• Select — Use the left mouse button (or a supported digitizer) to select or draw
a selection box around items in the drawing.

• Click — Briefly press the left mouse button (or a supported digitizer) to select
items such as a menu option or an element in the drawing.

• Enter — Send information to the computer. You send information to the
computer from the user input line. Normally, you enter information in the user
input line and then press ENTER. For certain commands and functions you
must enter a numerical value, and for others a string enclosed in quotes (' ' or
""). Additionally, values to be entered can be first calculated by typing the
appropriate mathematical expression in parentheses:

(15 * tan 30)

• Specify — Press the cursor at the appropriate position or enter the coordinates
separated by a comma.

Command Mini Toolbar
The Command Mini Toolbar (CMT) helps you to quickly execute a command
from the viewport. The CMT appears when you preselect elements. The following
table lists the buttons in the CMT for different element types:
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Element Type CMT Buttons
Geometry

• Move

• Copy

• Change Geometry Color

• Change Line Type

• Element Line Width

• Element Pen Width

• Delete
Dimension

• Modify Move Text & Line

• Properties

• Break

• Slant

• Stagger

• Delete
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Element Type CMT Buttons
Text

• Move

• Copy

• Text Modify

• Text In Place

• Delete
Part

• Move

• Edit Part

• Edit Top

• View Part

• View Top

• New Subpart (&Edit)

• Delete

The CMT includes element-specific commands according to your selection. For
example, if you select a dimension, geometry, and text as the element-types, the
CMT displays the following buttons:

• Move

• Copy

• Modify Move Text & Line

• Change Geometry Color

• Change Line Type

• Change Line Width

• Properties

• Text Modify

• Delete
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Note
If you preselect parts with other element-types, only the parts-specific buttons
are displayed on the CMT.

Context Menu Commands
The context menu appears when you right-click elements in the drawing area in
the preselection mode. Depending on the current context and the selected object,
the commands on the context menu change.
If you do not preselect any elements, the context menu displays the following
commands (also present in the Viewing group on the View tab):

• Redraw

• Fit

• New

• Last

• Zoom

• Pan

• Center

• Store

• Recall

The context menu displays element-specific commands if you preselect any
elements. The following table lists the commands on the context menu for
different element-types and preselection modes:
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Element Type Context Menu Preselection
Mode

Geometry
• Change Geo Linetype

• Change Geo Color

• Change Geo Penwidth

• Change Geo Linewidth

Single or Multiple

Part
• Edit Part

• Initialize New Subpart

• Create New Subpart

• Gather Into Part

• View Part

• Rename Part

• Smash Part

• Share/Unshare Part

• Symbol Part

Single

Dimension
• Change Dim

• Modify Dim

Single

• Change Dim
Multiple

Text
• Change Text

• Edit Text

Single

• Change Text
Multiple

Additionally, the context menu also contains the following for element
transformations (except when dimensions are preselected):

• Move

• Rotate

• Mirror

• Scale
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• Similar

• Transform

The context menu also contains the Keep command, which you can use to retain
the original element after the element is transformed. The last command on the

context menu is Delete.

Note
• The context menu includes element-specific commands according to your

selection. For example, if you preselect a single text and a single part, the
context menu displays the part-specific commands, text-specific commands,

the element transformation commands, and Delete.
• For other element types (for example, pictures and OLE objects), the context

menu only displays the element transformation commands and Delete.

Viewports
Aviewport is a rectangular area on the screen whose position and size you can
define. Specific parts of your drawing can be displayed in the viewports. This
enables you to study the drawing or add information with greater ease and
accuracy. You can create up to 16 viewports but usually between 2 and 6 are
sufficient.
The viewports are identified by a number in the top right hand corner. You will
notice one is in inverse video – this is the current viewport. All window functions
operate on the current viewport. For example, if you click View and then in the

Window group, click New and make a box in any viewport, the new view is
drawn in the current viewport. Any viewport can be made current by clicking its
identification number on the screen.

Defining Key Commands
To define a custom key command:

1. Click File ▶ Keys.

The Key Definitions dialog box opens.
2. Click the required key (for example, 1).
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3. Specify any or all of the following commands:
Plain In the Plain box, type the command to be executed when

the key is pressed.
Shift In the Shift box, type the command to be executed when

the key is pressed in combination with SHIFT.
Control In the Control box, type the command to be executed

when the key is pressed in combination with CTRL.
Alt In the Alt box, type the command to be executed when

the key is pressed in combination with ALT.

4. Click the Execute check box if you want the command to execute when the
associated key (or key combination) is pressed.

If you clear the Execute check box, the command is written to the user input
line in Creo Elements/Direct Drafting when you press the key (or key
combination). To execute the command, press ENTER.

Note
Some keys (such as F1) are disabled because they serve a predefined function
in the Windows environment.

How to Delete Elements
As you learn to work with the system you may make mistakes. To delete an
element or piece of text:

1. Select the element or text you want to delete.

2. In the Utilities group, click Delete.

Getting Help
The Creo Elements/Direct Drafting / Creo Elements/Direct 2D Access
Programming Reference Guide contains technical reference information about all
the commands and functions that you can use within Creo Elements/Direct
Drafting.
To use the help system:

1. On the top-right of Creo Elements/Direct Drafting window, click .
2. Enter the command or function on which you require help by either:
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• Clicking on a command or function on the screen menu.
• Typing the command or function name in Creo Elements/Direct Drafting

user input line.

Creo Elements/Direct Drafting responds by displaying the required help
information.

3. Close the Help window to return to the normal Creo Elements/Direct Drafting
user interface.

Switching Languages
By default, the Creo Elements/Direct Drafting user interface is displayed in
English language. To switch to the language of your choice, type the appropriate
command in the user input line and press ENTER:

Language Command
English change_locale 'en'

French change_locale 'fr'

German change_locale 'de'

Italian change_locale 'it'

Spanish change_locale 'es'

Japanese change_locale 'ja'

Alternatively, specify this command above the Startup_menus string in the
startup.m file located in the Creo Elements/Direct Drafting installation
directory.

Note
If you installed Creo Elements/Direct Drafting in Custom mode, any languages
that you did not select during installation are not available at Creo Elements/
Direct Drafting runtime.

Switching the Beeper On or Off
Optionally, you can enable or disable the "beeper" in Creo Elements/Direct
Drafting. Simply type BEEPER ON or BEEPER OFF in the user input line and
press ENTER.
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Exiting Creo Elements/Direct Drafting
To exit Creo Elements/Direct Drafting:

• Click File and then click Exit.

Creo Elements/Direct Drafting prompts you to save changes, if any, before
exiting.

Further Reading
You can now use Creo Elements/Direct Drafting to produce high quality 2D
drawings.
When you are ready to learn more about the system and its command structure
refer to Writing Macros with Creo Elements/Direct Drafting, which contains
information on macro writing and command syntax.
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Editing the Creo Elements/Direct Drafting
Environment
The Creo Elements/Direct Drafting environment specifies various settings, which
determine, for example:

• Line color.
• Dimension appearance.
• Text appearance.
Click File ▶ Settings to access various dialog boxes for defining settings related to

your design and drafting environment. For example, you can use
Construction to select the color and linetype, which is used to display construction
geometry in your drawing.
Many of the dimension settings can be set using the commands contained in the
Creo Elements/Direct Drafting environment.

Setting the Environment
You can define the following settings for the drawing environment using File ▶
Settings.

Construction
Edit the construction geometry settings, for
example, line color.

Geometry
Edit the geometry settings, for example, line color.

Line Patterns
Add or edit user-defined line patterns.

Dimension
Edit the dimension settings, for example,
dimension offset.

Hatch
Edit the hatch settings, for example, hatch distance.

Text
Edit the text settings, for example, text size.

Projected Reference
Points

Edit the settings (such as color or linetype) for
projected reference points and their associated lines
and circle.

Refline
Edit the reference line settings, for example, line
color.

Symmetry Line
Edit the symmetry line settings, for example, line
color.

Center Line
Edit the center line settings, for example, line color.
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Parts
Edit the part representation settings, for example,
spotlight color.

System
Edit general settings for the following:
• Parametric Design
• Copilot functions
• Clipboard
• Handles
• Flyby highlighting
• Auto save mechanism
• Menu cascade timeout
• Redraw

Viewport Edit the viewport settings, for example, viewport
background color.

Grid Edit the grid settings.
Show Edit the general show settings and the show

settings for infos, layers, and urls.
Color Define the color scheme for Creo Elements/Direct

Drafting from the following:
• Creo Colors

• CoCreate Colors

Hidden
Edit the settings for hidden lines, for example, line
type.

Parametric
Edit the settings for parametric display and icons.

Import DXF/DWG Analyze the data, and after reading the drawing
file, set its properties.

Saving the Environment Settings
Creo Elements/Direct Drafting saves your environment settings when you exit.
The settings are saved to <application data path>\PTC\Creo
Elements Direct Drafting [version]\[version]\.

Setting the Default Color Scheme
You can set a default color scheme for Creo Elements/Direct Drafting.
When you set the default color scheme, the default colors of the following are
defined:
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• Geometry
• Text
• Hatches
• Dimensions
• Highlight color
• Constraint color
• Centerline color
• Symmetry line color
• Reference line color
• Viewport colors
To set the default color scheme:

1. Click File ▶ Settings ▶ Color.
2. Click a color scheme:

• Creo Colors

• CoCreate Colors

The Creo Colors scheme is the default color scheme for Creo Elements/Direct
Drafting. The default colors in the Creo Colors scheme are:

• Element Types

Element Type Default Color RGB Value
Geometry Black (0 0 0)
Dimensions Blue (0 0 1)
Text Black (0 0 0)
Hatches Black (0 0 0)

• Viewport Color

Viewport Default Color RGB Value
Background White (Almost) (251 251 252)
Cursor Black (0 0 0)
Text Black (0 0 0)
Border Custom (238 240 241)

The Viewport Settings dialog box (see Viewport Settings on page 129) displays the
default colors for the selected color scheme.

64 Creo Elements/Direct Drafting User's Guide: Fluent User Interface



Setting Angular and Linear Units
You can select angular and linear units using Angle Units and Length
Units, respectively.
To set the angular unit:

1. Click Drafting and then, in the Format group, click Angle Units.
2. Click the required angular unit from the following:

• Degree

• Gradian

• Radian

• User

To set the linear unit:

1. Click Drafting and then, in the Format group, click Length Units.
2. Click the required linear unit from the following:

• cm

• meters

• km

• mm

• µm

• inches

• feet

• yards

• miles

• mils/thou

• µinches

• user
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Normally, you set the current units before initiating drawing. However, if you
reset the current units after you have started to draw, Creo Elements/Direct
Drafting automatically converts all existing elements without changing the
lengths.
For example, if you set the current units to meters and draw a line one unit long,
and when you change the current units to millimeters, the line measures 1000
units.

Defining Your Own Units

The User and user buttons in the Format group on the Drafting tab allow
you to define your own units in Creo Elements/Direct Drafting. For example, an
input of 5 mm allows you to work in 5 mm units, and an input of 5 degrees
allows you to work in 5 degree units.

Loading a Drawing Frame
A number of standard drawing frames are supplied with Creo Elements/Direct
Drafting. To load one of these frames:

1. Click File ▶ Open to display the Creo Elements/Direct Drafting File
Browser.

The Open dialog box opens.
2. Click Navigator.

The Creo Elements/Direct Drafting Navigator opens.
3. In the left pane of the Navigator, navigate to the Creo Elements/Direct

Drafting installation directory.

The thumbnails of drawing frames are displayed for preview.
4. Double-click the thumbnail of the required drawing frame.
The frame is a symbol part which is always loaded below the Top part (refer to
Handling Parts and Assemblies on page 429). Each frame consists of two
concentric rectangles: the outer one the size of the respective paper size, the inner
one between 10 to 50 mm smaller per side.
The frames are drawn in magenta with the dotted linetype and therefore usually
are not plotted.
Drawing frame part names have the following format:
format_A.mi, format_A0.mi, format_B.mi and so on.
The ten frame options are:
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• A

• A0

• A1

• A2

• A3

• A4

• B

• C

• D

• E

Setting the Drawing Scale
The drawing scale affects only the physical size of construction and drawing lines
during plotting. Dimensions, text, and symbols are not affected by this setting.
The current drawing scale is displayed in the Part Browser (see Part Browser on
page 459). The default drawing scale is 1. The maximum drawing scale is 99999.
For example, when the drawing scale is set to 2, a line drawn 100 mm long is
plotted 200 mm long.
To set the drawing scale:

1. Click File ▶ Settings ▶ System.

The Environment pane of the System dialog box opens by default.
2. In the Drawing area, type the drawing scale in the Scale box.
You can check the result by viewing the Part Browser.

Using the Import Configurator
The Import Configurator controls the translation process and mapping of
configurable entities in the DWG/DXF Translator. You can change the default
settings using the Import Configurator.
To use the Import Configurator:

1. Click File ▶ Settings ▶ Import DXF/DWG.

The Import Configurator dialog box opens. This dialog box has two tabs;
Advanced and Configure.

2. Click theAdvanced tab in the Import Configurator dialog box.
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3. Under Model & Layouts Selection, click the Read all layout data check box to
enable DXF/DWG >MI translation.

a. Click the Model Space or Translate paper space check boxes for Model
space or Paper space translation.

b. Click layouts under the Model & Layouts section, to create files with more
than one Paper space.

c. Click the Side by side layout view check box for better visualization. It
controls whether to show overlapping or side-by-side layouts.

4. Under Units, the DXF/DWG box shows the units of the selected DXF/DWG
file. The following table lists the scenarios for the Custom Units check box.

Custom Units Multiplier Result
Cleared—The
Multiplier box is
not visible.

Not applicable. The units of the imported DXF/DWG
file are translated to the MI file as
follows:
• Imperial units are translated using

UnitsScale as 25.4 and units as
inches.

• Metric units are translated using
UnitsScale as 1 and units as mm.

Selected—The
Multiplier box is
visible.

No—The Scale
Factor box is
not visible.

The DXF/DWG file is imported with the
same geometrical units.
For example, a DXF/DWG file that
contains a line measuring 5m is
imported as 5000 mm.
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Custom Units Multiplier Result
Yes—The Scale
Factor box is
visible.

The DXF/DWG file is imported with the
geometrical units multiplied by a user-
defined scale factor.
For example:
• If a DXF/DWG file contains a line

measuring 5mm, and the scale factor
is 10, the line is imported as 50mm.

• If a DXF/DWG file contains a line
measuring 5ft, and the scale factor is
10, the line is imported as 50ft.

The general rule for importing a file is:
source dimension x scale
factor = measured dimension

Where, source dimension is the
dimension of the geometry in the source
DXF/DWG file, and measured
dimension is the final dimension after
importing the file.

5. Under Mapping, map the elements.

a. Click the Font tab in the Mapping section to view or edit the font settings
such as source font name, destination font name, width ratio, line spacing,
and vertical line spacing.

b. Click the Arrow Head tab to view and edit the arrow settings such as names
of the arrows, arrow scale, and arrow fill.

c. Click the Line Type tab to define the mapping of AutoCAD linetypes to MI
linetypes. The first parameter is the AutoCAD linetype name and the
second parameter is the corresponding Creo Elements/Direct Drafting
linetype name.

6. Click the Configure tab in the Import Configurator dialog box.
7. Under General Settings, do the following:

a. In theStart section, DXF to MI Translator is displayed by default.
b. Click the Kanji translate check box to translate kanji characters.
c. Click the Keep attributes with part check box to create additional subparts

for each block containing attributes. The attributes are kept with the part to
which they belong.

d. Click the Translate DXF invisible entities check box to translate invisible
entities to DXF visible entities.
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e. Click the Record by layer info check box to add special informational text
to every entity for color, line types, each layer, layer’s color, and status
(visible, frozen and locked).

f. Click the Translate invisible layers check box to translate AutoCAD layers
that are “Frozen” and “Off” to an MI file.

8. Under Hatch, do the following:

a. Type a value in the Minimum hatch spacing box. Typical values should be
greater than 0.001mm or 0.0001 inches. The default value is 0.0.

b. Type a value in the Contour snap gap box, which specifies the maximum
distance between two entities in a hatch contour. The default value is 1E-
12.

c. Click the Hatch close contours check box to close the hatch contour. Clear
the check box to close the hatch contour depending on the Contour snap
gap value.

d. Click the Hatch to contours check box to convert DXF/DWG hatches to
contours. Clear the check box to translate DXF/DWG hatches to MI
hatches.

e. Click the Create manual hatch check box to create manual hatches. Clear
the check box for automatic hatches.

9. Under Dimensions, do the following:

a. Click the Recompute dim block check box to re-compute the dimension
data structure and update it to latest dimension data structure for correct
translation.

b. Click the Explode DXF dimensions check box to translate dimensions to
geometric elements, Clear the check box to translate dimensions to
dimension elements.

10. Under Lines and Curves, do the following:

a. In the Translate DXF pen line size box, select a value to define the DXF/
DWG linesize conversions.

b. In the Polymarker type box, select a value to define the default polymaker
for DXF/DWG/SVG points. The default value is 2.

c. Click the Spline control point translation check box to convert a spline
using its control points and knots. Clear the check box to convert a spline
using its fit points.

11. Click Reset to revert to the default settings.
12. Click OK to save and apply your changes.
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13. Click Cancel to close the import configurator dialog box without applying
your changes.

Further Information
For further technical information about the Creo Elements/Direct Drafting
environment, refer to the Creo Elements/Direct Drafting help system.
Type help save_environment in the Creo Elements/Direct Drafting user
input line and press ENTER.
Creo Elements/Direct Drafting displays further information about the
environment.
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5
Commonly Used Commands
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Selecting Drawing Elements.......................................................................................77
Confirming Commands ..............................................................................................88
Undoing Commands..................................................................................................88
Ending a Command...................................................................................................88
Canceling Commands ...............................................................................................88
Further Information....................................................................................................89

Most of these commands have a similar purpose — they allow you to escape from
whatever activity is currently being performed. The knowledge that you can easily
delete or cancel any mistakes should help you gain confidence in using Creo
Elements/Direct Drafting.
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Deleting Elements
To delete elements, press DELETE or click Delete.

Using Delete Key
1. Click an element in the drawing area.

The handles appear.
2. Press DELETE.
To delete multiple elements:

1. Hold SHIFT and click all the elements in the drawing area.

The handles appear.
2. Press DELETE.

Using Delete

Click Delete to delete drawing elements or pieces of text.
For example, to delete everything in the active part:

1. In the Utilities group, click Delete.

2. In the Utilities group, click Select ▶ All.

3. Click Confirm.
To delete an element or text:

1. Click Delete.
2. Select the element or text to be deleted.

You can also enclose the elements to be deleted in a box
Alternatively, you can also use preselection to delete elements.
To delete an element or text:

1. Click the text or element.

The Command Mini Toolbar appears.

2. Click Delete on the Command Mini Toolbar.

Alternatively, press DELETE.
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The selected text or element is deleted.

Deleting Hatching
To delete a hatch:

1. Click Modify and then, in the Annotate group, click the arrow next to
Hatch.

2. Click Delete.
3. Select the hatching to be deleted.

See Hatching a Drawing on page 366 for more information.

Highlighting Elements Before Deletion

The Select buttons enable you to select the elements that you want to delete
(or modify).

1. Click Delete.

2. In the Utilities group, click Select and then select the required button.

Depending upon the selected button, the elements selected for delete are

highlighted. For example, click Select and then click All. All the
elements in the drawing get highlighted.

Alternatively, press F2 to open the Select window. Then click Select and All.
All the elements in the drawing get highlighted

3. When you are satisfied that the elements to be deleted have been correctly

selected, click Confirm.
Alternatively, enclose the elements to be deleted in a box. The elements are

preselected and the Command Mini Toolbar appears. Click Delete on the
Command Mini Toolbar to delete the elements.

Global Selection
Each time you select components, you can decide whether you want to select from
the current part or from the whole parts tree. Global selection allows you to select
components from the whole parts tree:

• In the Select window, click Select, Global, and All.
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If you do not click Global, Creo Elements/Direct Drafting defaults to the current
part.

Example

1. In the Utilities group, click Delete.

2. In the Utilities group, click Select ▶ Advanced.

The Select window opens.

Alternatively, press F2 to open the Select window.
3. Click Select, Global, All, Confirm and OK.

This command string deletes all components of the parts tree even if the active
part is not the top part.

It should, however, be noted that even though all components (geometry,
construction geometry, and text) contained within the parts tree will be deleted, it
is not possible to delete the complete parts tree. The current part is never deleted
and a path linkage to the top part is always maintained.
Several examples using the parts structure in Figure 2 on page 75 show the power
of Select.

Figure 2. Example of a Parts Structure

If you delete globally with 'B' as the active part, the Top part and 'B' will remain.
See Figure 3 on page 76.
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Figure 3. Top Part and 'B'

If you delete globally with 'A' as the active part, the Top part and 'A' will remain.
See Figure 4 on page 76.

Figure 4. Top Part and 'A'

If you delete globally with 'D' as the active part, the Top part, 'D', and its parent,
'A', will remain. See Figure 5 on page 76.

Figure 5. Top Part + D + A
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Selecting Drawing Elements
Use Select to let Creo Elements/Direct Drafting know you are about to make
a selection

Click Select (for example, to move or to delete elements). Then click any
option or combination of options from the selection block.
To make a selection (for example, to move or delete elements):

• In the Utilities group, click Select and then, select the required button:

Select Button Purpose

All
Selects all elements in the active part.

Box
Selects all elements you enclose in a box.

Polygon
Selects all elements you enclose in a polygon.

Global
The selection applies to the entire parts tree.

Global Perm
The selection, and all subsequent selections in this
command, applies to the entire parts tree.

Subtree
Selects a subtree of a part or an assembly.

PreSelected
Selects the current preselection. See Preselecting Elements
on page 87.

Advanced
Displays a separate Select window, which provides
functions and options for complex selections.

Advanced Selection Functions
To use Advanced selection functions:

• In the Utilities group, click Select ▶ Advanced.

The Select window opens.

Alternatively, press F2 to open the Select window.
The functions and options included in the Select window enable you to define

complex selections. These include the All, Box, Polygon,

Global, Global Perm, Subtree, and PreSelected selection buttons
described above.

Commonly Used Commands 77



Function Description
Select Initiates a selection.
Confirm Confirms a selection.
Add Adds the next elements you select to the current result.
Subtract Subtracts the next elements you select from the current

result.
And Results in a logical AND (set intersection) of the current

result and the elements selected next.
Or Results in a logical OR (set union) of the current result and

the elements selected next.
Exor Results in a logical EXOR (exclusive OR) of the current

result and the elements selected next.
Not Unselects the current result. All other elements become the

current result.
Vertex Selects vertices.
Color Selects colors.
Line Type Selects linetypes.
Line Size Selects linesizes.
Pen Size Selects pensizes.
Font Selects fonts.
Groups Selects groups.
Contours Selects contours (see Selecting Contours on page 84).
Geo Selects geometry.
Point Selects points (singularities) but not vertices.
Line Selects geometry lines.
Circle Selects geometry circles.
Arc Selects arcs.
Fillet Selects fillets.
Spline Selects splines.
Poly El Selects polyelements.
PRPs Selects projected reference points.
Text Selects text.
Hatch Selects hatches.
Dim Selects dimensions.
Edit Dim Selects edited dimensions.
Sym Line Selects symmetry lines.
Center Line Selects center lines.
Ref Line Selects reference lines.
Leader Line Selects leader lines.
CGeo Selects construction geometry.
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Function Description
CLine Selects construction lines.
CCircle Selects construction circles.
Part Selects parts.
Namespace Select namespaces.
Info Selects infos.
URL Selects URLs.
Layer Selects layers.
Back Removes the last change to the selection.
Load Enables you to load a (previously stored) selection file.
Store Enables you to store the selection definition to a selection

file.
Execute Immediately applies the current selection.
OK Immediately applies the current selection and closes the

Select dialog box. This button has the combined effect of
the Execute and Close.

Close Closes the Select window.

Note
All the Select options can be chosen directly without clicking Select.
However, if you do not click Select first:

• The elements you choose will not be highlighted on the screen for you to view
before the operation of your choice. For example, deleting will be performed
immediately.

• You will not be able to use the options Add, Subtract, Not, and so forth.

Example: Deleting All Green Elements
If you want to select elements drawn in a particular color or linetype you must
first click Select and then specify the respective color or linetype.

1. In the Utilities group, click Delete.

2. In the Utilities group, click Select ▶ Advanced.

The Select window opens.

Alternatively, press F2 to open the Select window.
3. Click Select and then click Color.
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The Color dialog box opens.
4. In the Color box, select Green and click OK.
5. Click Confirm and then click OK.
This deletes all elements drawn in green in the current part.
Further examples are provided in the following sections.

Adding Elements to Your Selection
This option allows you to add elements, either selected individually or enclosed in
a box, to your current selection. For example:

1. Click Delete.
2. Press F2 to open the Select window.
3. Click Select.
4. Select several elements to be deleted.
5. Click Add.
6. Click Box.
7. Enclose further elements to be deleted in a box.
8. Click Confirm.
9. Click OK.

Subtracting Elements from Your Selection
To subtract elements from your current selection, click Subtract in the Select
window.

Removing Elements from Your Selection
Click Not in the Select window to make the previous selection result unselected,
and all previously unselected elements to be treated as selected.

Note
Not always works globally on all parts.

Enclosing Elements in a Box
To select a group of drawing elements by enclosing them in a box:
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1. Click Box in the Select window.
2. Enclose the required elements in a box.

The elements are then shown in a different linetype and Creo Elements/Direct
Drafting prompts you to Confirm that you want to delete them. Before you
click Confirm, you may want to alter your selection by, for example,
subtracting or adding some elements.

3. Click Confirm.
4. Click OK.

Enclosing Elements in a Polygon
If you need greater flexibility when selecting elements, use Poly to enclose
elements within a polyline. This is particularly useful when elements are not
symmetrically grouped horizontally and vertically.

Figure 6. Selecting Elements with a Polygon

Suppose you want to delete the elements 1, 2, and 3:

1. Click Delete.

2. In the Utilities group, click Select ▶ Polygon.

Alternatively, press F2 to open the Select window and then click Poly.
3. Click a succession of points to define the enclosing polygon around elements

1, 2, and 3.
4. Close the polygon by clicking the start point again or type CLOSE in the user

input line and press ENTER.

Selecting All Elements
To select everything contained in the current part (and subparts):

1. Click Delete.
2. Press F2 to open the Select window.
3. Click All.
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4. Click OK.

Creo Elements/Direct Drafting prompts you to click Confirm if you really want

to delete all elements selected. If not, click Cancel and select again.

5. Click Confirm

6. Click OK.

Selecting a Vertex
Click Vertex in the Select window if you want to delete all elements that share a
specified point.

Selecting Elements by Type
The Select window facilitates the selection of specific element types in your Creo
Elements/Direct Drafting drawing.

Selecting Elements Using Information Strings
Click Info in the Select window to select all elements that have a particular
information string associated with them. You will be prompted to type in the
information concerned.

Selecting Layers
Click Layer in the Select window to select all elements assigned to a specified
layer. When you choose this option, the system prompts you for the layer
information.

Selecting Text
Click Text in the Select window to select the required text. Creo Elements/Direct
Drafting prompts you to identify the text to be selected.

Selecting Reference Lines
Click Ref Line in the Select window to select reference lines.

Selecting Construction Geometry
Click CGeo in the Select window to select and highlight construction geometry.
Alternatively, click CCircle to select construction circles only or click CLine to
select construction lines only.
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Selecting Drawing Geometry
Click Geo in the Select window to select and highlight drawing geometry.
Alternatively, you can:

• Click Line to select lines.
• Click Circle to select circles.
• Click Arc to select arcs.
• Click Spline to select splines.
• Click Fillet to select fillets.
• Click Point to select points.
• Click Poly El to select polyline elements (see Drawing Polylines on page 172).
To make a selection on pensize or linesize:

1. Click Line Size or Pen Size in the Select window.
2. Type a value (for example, 2).
3. Click Confirm.
4. Click OK.

Selecting Parts
Click Part in the Select window to select elements in a particular part. Also, you
can click Subtree to select a subtree of a part or assembly.

Example
To delete a selected part from anywhere in the parts tree:

1. Click Delete.
2. Press F2 to open the Select window.
3. Click Select, Global, Part, and OK.
4. Type the part name in the user input line and press ENTER.

5. Click Confirm.

6. Click OK.

Note
When deleting a part, you automatically delete all associated subparts.
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Selecting Dimensions
Click Dim in the Select window to select and highlight dimensions. Alternatively,
click Edit Dim in the Select window to select edited dimensions only.

Selecting Contours
Click Contours in the Select window to select contours (closed loops of connected
elements).

Note
To account for the fact that contours may be nested (closed loops of elements
within other closed loops of elements), Creo Elements/Direct Drafting allows
you to specify a contour level. See Specifying the Contour Level on page 85
for details.

The general procedure is as follows:

1. Select a given subset (such as an area enclosed in a selection polygon) of your
drawing.

2. Apply further selection criteria to refine your selection.
3. Click Contours to scan this refined selection for contours.
For example:

• To move all contours in your drawing by a given distance:

1. Click Modify and then, in the General group, click the arrow next to
Move.

2. Click 2 Pnts and define the distance and direction of the move.

3. In the Utilities group, click Select ▶ Advanced.

Alternatively, press F2 to open the Select window.
4. Click Select, All, Contours, OK.

5. Click Confirm to move the selected contours.
• To delete all elements other than contours:

1. Click Delete.

2. In the Utilities group, click Select ▶ Advanced.

Alternatively, press F2 to open the Select window.
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3. Click Select, All, Contours, Not, OK.

4. Click Confirm to delete all non-contour elements.
• To change the color of all contours to green:

1. Click Drafting and then, in the Format group, click Colors.
2. Select the Green color.

3. In the Utilities group, click Select ▶ Advanced.

Alternatively, press F2 to open the Select window.
4. Click Select, All, Contours, OK.

5. Click Confirm to change the color of all contours to green.

Specifying the Contour Level
To facilitate the selection of nested contours, Creo Elements/Direct Drafting
enables you to specify a selection level by typing contour_level followed by
an integer.
contour_level 0 This is the default. Only the "outer" contours in the

selection polygon are selected. See the part labeled 0
in Figure 7 on page 86.

contour_level 1 In addition to the outer contours, the first contours
encountered within the outer contours are selected.
See the part labeled 1 in Figure 7 on page 86.

contour_level 2 In addition to the contours in contour level 1
(including all level 0 contours), the first contours
encountered within level 1 contours are selected. See
the part labeled 2 in Figure 7 on page 86.

contour_level 3 In addition to the contours in contour level 2
(including all level 1 and level 0 contours), the first
contours encountered within level 2 contours are
selected. See the part labeled 3 in Figure 7 on page
86.
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Figure 7. Contour Levels
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Copying Contours to the Clipboard
The Copy Contour button in the Clipboard group on the Drafting tab enables you to
select contours (closed loops of connected elements) to the Clipboard. Copy
Contour does not modify the drawing. From the Clipboard, the copied contours
can be pasted to another place in the same Creo Elements/Direct Drafting
drawing, to another Creo Elements/Direct Drafting drawing, or to Creo Elements/
Direct Modeling.
To copy a set of contours:

1. Specify the contour level (see Specifying the Contour Level on page 85) for
the selection you are about to make.

2. Click Drafting and then, in the Clipboard group, click Copy Contour.
3. Click points in your drawing to define a selection polygon around the area

from which you want to select contours.

Note
Contours fully enclosed in this polygon are highlighted.

4. Type contours in the user input line and press ENTER.

5. Click OK.

Selecting URLs
Click URL in the Select window to select and highlight URLs.

Preselecting Elements

Automatic Preselection
With automatic preselection enabled, you can add elements to the preselect list

and use them for Modify operations without using the Select buttons.
To enable automatic preselection:

1. Click File ▶ Settings ▶ System.

The System dialog box opens.
2. Click Preselect.
3. Click the Automatically use preselection check box.
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Note
Automatic preselection is enabled by default in Creo Elements/Direct Drafting
Fluent UI.

The active preselection ends after you start a new command or middle-click to end

the current command. The active preselection also ends when you click
Cancel or press ESC.

Confirming Commands
Click Confirm to confirm that the deletion or modification you have defined
should be implemented.

Undoing Commands
Click Undo when you have just deleted or modified something but realize you
have made a mistake. This will return you to the previous display.

Ending a Command
Click OK to terminate the active command or function, whether or not you
have completed it. You can also terminate any command or function by selecting
another command.

In the case of functions, clicking OK will terminate the currently active
function, but the previously selected command will remain active.

Canceling Commands
It may happen that you select a series of commands and functions but do not
complete any of them. Although selecting a new command will terminate
whatever command or function is active and allow you to continue working, it is

advisable to click Cancel and then start again. Otherwise the response time
may be slightly slower than normal.
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Further Information
For further technical information about the commonly-used commands in Creo
Elements/Direct Drafting, refer to the Creo Elements/Direct Drafting help system.
Type the following in the Creo Elements/Direct Drafting user input line and press
ENTER:

• help delete

• help wui_select

• help select

• help undo_redo

Creo Elements/Direct Drafting displays further information about the commonly-
used commands.
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6
Changing the Drawing

Environment and Making
Measurements

Setting Linetype, Line Color, and Line Width or Line Size..............................................92
Mapping Pen Color, Linetype and Pen Width ...............................................................97
Changing the Linetype, Color, Line Width or Line Size of Existing Elements...................98
Changing Color ....................................................................................................... 100
Setting the Color for Vertices .................................................................................... 101
Viewing and Converting Colors................................................................................. 101
Changing the Catch Mode........................................................................................ 107
Measuring Distances ............................................................................................... 108
Using the Calculator ................................................................................................ 115
Using the Standard Text Editor ................................................................................. 115
Using the Ruler or Grid ............................................................................................ 115
Selecting What is Displayed on Your Screen ............................................................. 119
Viewing a Drawing................................................................................................... 121
Searching for Text and Dimensions in the Viewport .................................................... 125
Using Viewports to Display Several Views................................................................. 125
Using Properties to Change Elements and Text ......................................................... 131
Using the Toolbox.................................................................................................... 133
Setting the Auto Save Time for Drawings................................................................... 136
Setting the Delay Time for Cascaded Menus ............................................................. 136
Setting the Redraw Mode......................................................................................... 137
Saving the Current Drawing Environment .................................................................. 137
Further Information.................................................................................................. 137

Use the functions shown in this chapter as an aid to make designing and drafting
easier. These functions are arranged in groups of functions and are available for
use at all times.
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Functions are essentially different from commands in that a function can interrupt
a command (or another function) without terminating it.

For example, while using the Fillet button to draw a fillet radius, you may
want to zoom in on the corner or change the current linetype. Both Linetype and
View are interrupt function groups.
Once a function has been executed, control is automatically returned to the
previously unfinished command in which you were working.
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Setting Linetype, Line Color, and Line
Width or Line Size
To set the linetype, line color and line width (pen size) or line size for geometry,
construction geometry, or hatching:

1. Click File ▶ Settings.
2. Click the settings for which you want to set the linetype, line color and line

width or line size:

• Construction

• Geometry

• Hatch

• Refline

• Symmetry Line

• Center Line

3. In the Type box or Linetype box, select the linetype.

Figure 8 on page 92 shows the built-in linetypes available in Creo Elements/
Direct Drafting and their corresponding symbolic representation. If you want
to define your own linetypes, follow the instructions in Creating User-Defined
Linetypes on page 93.

Figure 8. Linetypes and Corresponding Symbolic Representation

Item Description
1 Solid
2 Dashed
3 Long Dashed
4 Dot Center
5 Dash Center
6 Phantom
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Item Description
7 Center Dash Dash
8 Dotted

4. In the Color box, select the line color. See Defining Custom Colors on page
100 for instructions on defining custom colors.

5. Specify the line width (pen size) or line size using Width and Size.

Note
Line width and line size are mutually exclusive; you can only specify one
of these two settings. The difference between line width (pen size) and line
size is explained in Line Width vs. Line Size on page 95.

The last line setting you defined is displayed in the Format group on the Drafting
tab. By default, the line settings for geometry are shown. Note that this
information is context sensitive. For example, when you draw construction
geometry, the line settings for construction geometry are shown.
To select a linetype, line color, line width or line size, simply select the required
setting in the Format group on the Drafting tab:

• Click Drafting and then, in the Format group, click the arrow next to Line Type
and select the required linetype.

• Click Drafting and then, in the Format group, click Select Color and select
the required color.

Creating User-Defined Linetypes
In addition to the standard linetypes supplied with Creo Elements/Direct Drafting
(see Figure 8 on page 92), you can quickly and easily create your own linetypes
through a repeated sequence of dot and dash patterns.
To create a user-defined (custom) linetype:

1. Click File ▶ Settings ▶ Line Patterns.

The Line Pattern dialog box opens.

Alternatively, click Drafting and then, in the Format group, click the arrow
next to Line Type. Select the last option to open the Line Pattern dialog box.

2. Click Add.

The Add Line Pattern dialog box opens.
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3. In the Name box, type a name for the new line pattern.
4. In the Pattern box, type one of the following:

• A sequence of 1s and 0s, in which each 1 denotes a dot and each 0 denotes
a gap. Note that the first number of this sequence must not be a 0. For
example:
1111011110000

• A sequence of comma-separated natural numbers, in which the first (third,
fifth, and so on) number denotes the number of dots and the second (forth,
sixth, and so on) number denotes the number of gaps. (Creo Elements/
Direct Drafting will convert any sequence of 1s and 0s to this notation.)
For example:
4,1,4,4

Note
Both of these examples produce the same linetype.

5. Click OK.
The following figure gives you a visual impression of the new linetype defined in
the two examples above.

Figure 9. Eight Built-In Linetypes Plus a User-Defined Linetype

Note
The newly defined linetype pattern is appended to the list of built-in linetypes.

To apply your new linetype, follow the instructions in Setting Linetype, Line
Color and Line Width or Line Size on page 92.
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Exporting User-Defined Linetypes
Any user-defined linetypes are saved to your current MI file. By sending this MI
file to another Creo Elements/Direct Drafting user, you can make your user-
defined linetypes available to this user.
These additional linetypes will be listed as "imported" linetypes in the linetype
menu.

Editing User-Defined Linetypes
To edit a user-defined (custom) linetype:

1. Click File ▶ Settings ▶ Line Patterns.

The Line Pattern dialog box opens.

Alternatively, click Drafting and then, in the Format group, click the arrow
next to Line Type. Select the last option to open the Line Pattern dialog box.

2. In the Name column, select the user-defined linetype you want to edit.
3. Click Edit and edit the linetype as per your requirements. Refer to Creating

User-Defined Linetypes on page 93 for guidance.

Deleting User-Defined Linetypes
To delete a user-defined (custom) linetype:

1. Click File ▶ Settings ▶ Line Patterns.

The Line Pattern dialog box opens.

Alternatively, click Drafting and then, in the Format group, click the arrow
next to Line Type. Select the last option to open the Line Pattern dialog box.

2. In the Name column, select the user-defined linetype you want to delete.
3. Click Delete.

A message prompting for confirmation of the linetype deletion appears.
4. Click Yes.

Line Width vs. Line Size
The thickness of elements can be set by setting the line width or line size
properties.
Note that line width differs from line size:

• Line width (pen size) and line size are mutually exclusive: Specifying linesize
resets pensize to 0, and specifying pensize resets linesize to 0.
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• When you scale (increase or decrease the size of) an element drawn in a given
line size, this line size will change with the size of the element.

• When you scale an element drawn in a given line width, the line width
remains unchanged even if you scale the element. This behavior reflects the
pen width concept of a conventional drawing board: an enlarged detail of a
part is drawn with the same pen as the part.

• Line size supports HP-GL/2 and PostScript.

Figure 10. Scaling with Pensize and Linesize

Item Description
1 Line Width (Pen Size): The line is non-scalable. This means that if

you create a line having a pensize of 1mm, and then scale it by a
factor of 2, the thickness of the line remains 1mm.

2 Line Size: The line is scalable. In this case, if you create a line
having a linesize of 1mm, and then scale it by a factor of 2, the new
thickness of the line is 2mm.

Figure 11 on page 97 shows one benefit of specifying pensize and linesize for
specific elements.
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Figure 11. Difference between Pensize and Linesize

1 All geometry elements are drawn with the property pensize. When scaled, all lines remain
the same size (thickness).

2 The outline of the building is drawn with the property linesize. All other elements are drawn
with the property pensize. When scaled, the thickness of the outline increases but the other
elements remain the same thickness.

Figure 12 on page 97 shows some sample sizes. The ends of lines are rounded so
that when more than one line intersects, a rounded end is formed. Otherwise, the
line end would appear stepped.

Figure 12. Lines Drawn with Different Sizes

Mapping Pen Color, Linetype and Pen
Width
The Pens map is based on eight pens. This map enables you to map pen color,
linetype, and pen width. The Pens map is available for:

• Geometry

• Refline
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• Symmetry Line

• Center Line

To set up the Pens map:

1. Click File ▶ Settings and open the settings dialog box of any of the entity types
listed above.

For example, click File ▶ Settings ▶ Geometry.

The Geometry Settings dialog box opens.
2. In the Line area, click Pens to display the Pens map.
3. Click the click the row that you want to change.

The selected row gets highlighted.
4. Click Change.

The Pen Settings dialog box opens.
5. In the Type box, select a linetype.
6. In the Color box, select a color.
7. In the Width box, type the line width (pen size) that you want to associate with

this color and linetype combination.

The difference between line width (pen size) and line size is explained in Line
Width vs. Line Size on page 95.

8. Click OK to return to the Pens map.
9. Repeat this procedure till the Pens map contains the required combinations of

pen color, linetype, and pen width.
Optionally to save your current Pens map in a file, click Save. To load a saved
Pens map for re-use or editing, click Input.

Changing the Linetype, Color, Line Width
or Line Size of Existing Elements
To change the linetype, color, line width or pen width of existing geometrical
element:

1. Click Modify and then, in the Draw group, click More.
2. To change the linetype:

a. Under Modify, click Line Type.
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The Change Line Type dialog box opens.
b. In the Type box, select the required linetype.
c. Click OK.

3. To change the color:

a. Under Modify, click Color.

The Select Color dialog box opens.
b. In the Color box, select the required color.
c. Click OK.

4. To change the pen width:

a. Under Modify, click Pen Width.
b. Type the new pen size in the user input line and press ENTER.

5. To change the line width:

a. Under Modify, click Line Width.
b. Type the new line size in the user input line and press ENTER.

6. Select the elements that you want to modify.

You can change the settings before selecting the required elements.

Alternatively, you can use the CMT to change the linetype, color, pen width,
or line width of existing geometrical elements.

Note
• The linetypes you choose on the screen will be plotted unless plot

transformation has been altered (see PLOT_TRANSFORMATION and
SCREEN_TRANSFORMATION in the online Help).

• When plotted, PHANTOM and CENTER_DASH_DASH linetypes look
the same.

• You can use the LINEPATTERN function to define your own linetype.
Refer to Writing Macros with Creo Elements/Direct Drafting. If the
linetype you have defined cannot be displayed or plotted, Creo Elements/
Direct Drafting defaults to the nearest standard linetype shown in Figure 8
on page 92.

• The spacing of all broken linetypes is set using the plot default option
Ltype Len in PLOT.
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Changing Color
You can select or change colors for geometry, construction geometry, text,
hatching and dimensioning.
The colors available for you to use are as follows:

• Black and White.
• The six basic colors:

Red, Yellow, Green, Cyan, Magenta, and Blue.
• Custom (user-defined) colors.

Note
The colors you choose are linked to the pen transformation so that you can
allocate plotter pens to the colors displayed on the screen. (See PLOT_
TRANSFORMATION in the online Help.)

Defining Custom Colors
To define custom colors for use in Creo Elements/Direct Drafting:

1. In any of the Color box, select Custom.

The Color dialog box opens.

The Basic colors area displays a number of basic color.
2. Click the basic color you want to add to your color selection list.
3. To create colors other than the basic colors, click Define Custom Colors.
4. Move the color selection recticule to change the associated hue, saturation,

luminosity, red, green and blue values.

These values are indicated in Hue, Sat, Lum, Red, Green, and Blue box
respectively. Optionally, you can replace these values to create a custom color.

5. When the required color appears in the Color|Solid box, click Add to Custom
Colors.

The added custom color appears in the Custom colors area of the Color dialog
box.

6. Optionally, repeat the last two steps to create additional custom colors.
7. Click OK.
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Note
The last custom color you defined becomes the current (active) color in the
Color box.

To access your other custom colors (if any), select Custom in the Color box.

The Dithering Effect
The ability to display the various RGB and HSL colors is dependent on your
hardware. The number of colors that can be displayed typically ranges from 16 to
256 (or a much larger number) according to your graphics hardware.
However, since not all hardware has the ability to display the range of colors the
RGB and HSL color system offers, a dithering effect is used to increase the
number of shades available. This creates the impression of a larger range of colors
than the hardware actually supports.
This dithering effect creates patterns of dots in the available colors. The eye then
combines them into a perceived color different from the actual colors used to
produce the patterns.
Although dithering can create a larger range of colors for surfaces, the drawing
lines and the status bar can be displayed only in the range of colors supported by
the hardware.

Setting the Color for Vertices
To set the color of vertices in your Creo Elements/Direct Drafting drawings:

1. Click File ▶ Settings ▶ Geometry.

The Geometry Settings dialog box opens.
2. In the Vertex Color area, select the required colors for the vertex.

Refer to Defining Custom Colors on page 100 for instructions on defining
custom colors.

3. Select the required line type for the parts spotlight.

Viewing and Converting Colors
You can view information about the colors of all elements in a part and its
subparts using the Color Conversion dialog box. You can also convert the colors of
existing elements in a part and its subparts, to other colors.

Changing the Drawing Environment and Making Measurements 101



To open the Color Conversion dialog box:

• Click File ▶ Settings ▶ Color ▶ Convert Colors.
You can use the Color Conversion dialog box for:

• Viewing color information of all elements in a part and its subparts.
• Converting colors of elements in a drawing.
• Storing the color conversion map file.
• Loading the color conversion map file.

Viewing Color Information
The Color Conversion dialog box provides information about :

• Color information table
• Preview viewport
• Parts list
• Preview colors
• Background colors

Color Information Table
The color information table of the Color Conversion dialog box consists of the
following columns:

• Seq Num: Sequence number of a color in the table.
• Source Color: Color present in the drawing.
• Target Color: A color to map the source color to, if required.
• Count: Number of elements in the drawing that have the source color.
The standard colors in a drawing are represented by their names in the color
information table. For other colors, Creo Elements/Direct Drafting displays the
RGB value in the color information table.

Note
You can only edit the Target column of the color information table.

Preview Viewport
The preview viewport of the Color Conversion dialog box displays the preview of
the drawing.
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Note
For big drawings, Creo Elements/Direct Drafting displays parts that are
smaller than a certain limit as magenta boxes (instead of entire parts) during
the redraw process, by default. Creo Elements/Direct Drafting enables
REDRAW_MODE PARTS_AS_BOX during the redraw process. As a result,
many of magenta-colored elements are visible in the preview viewport (even
though the magenta color may not be present in the drawing). To avoid this
situation, Creo Elements/Direct Drafting disables REDRAW_MODE PARTS_
AS_BOX by setting its value to zero when you open the Color Conversion
dialog box. When you close the Color Conversion dialog box, the value of
REDRAW_MODE PARTS_AS_BOX is restored.

Parts List
The Part Id box of the Color Conversion dialog box displays the list of parts in the
drawing.
In the Part Id box, select a part ID to view the color map associated with the part
ID.

Note
Creo Elements/Direct Drafting selects the part ID of the top-level part of a
drawing by default.

Preview Colors
The Preview box of the Color Conversion dialog box displays the original colors,
target colors, or a single user-defined color of drawing elements in the preview
viewport.
In the Preview box, select one of the following:

• Source to view the drawing elements in their original colors.
• Target to view the drawing elements in the target colors that you have defined.

This is the default.
• One Source Color to view the drawing elements in a single color.

Creo Elements/Direct Drafting prompts you to select a source color.

Click the cell which contains the color to define the single color.
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Creo Elements/Direct Drafting displays the drawing elements that contain the
single source color.

Note
• You can view a single source color of the part which you select in the Part Id

box.
• OK is disabled when One Source Color preview is active.

Background Colors
The Background box of the Color Conversion dialog box displays the elements of
the drawing in the preview viewport according to the color scheme.
In the Background box, select any of the following:

• Neutral to view all the elements against a neutral-grey color background.

This is the default.

Note
Elements having a color which is similar to the neutral background color
are not visible in the preview viewport. When you open the Color
Conversion dialog box, Creo Elements/Direct Drafting displays a warning
if a drawing contains elements that have the same color as the neutral
background color.

• Creo to view the elements against the default background color of Creo Colors
scheme.

• CoCreate to view the elements against the default background color of
CoCreate scheme.

Note
For information about the color schemes, see Setting the Default Color
Scheme on page 63.
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Converting Colors
To convert the color of existing elements in a drawing to another color:

1. Click File ▶ Settings ▶ Color ▶ Convert Colors.

The Color Conversion dialog box opens.
2. In the Part Id box, select the required part.

The color scheme of the part is displayed in the color information table.
3. In the color information table, click the Target Color cell for the Source Color

cell which you want to change.

The Color dialog box opens.
4. Select the required color in the Color dialog box.

The selected color is displayed in the Target Color cell of the color information
table.

Tip
• To remove a target color, right-click the required Target Color row in the

color information table and select Clear.
• To remove all target colors, right-click the color information table and

select Clear All.

Note
If there are duplicate source or target colors in the source-to-target color
mapping, Creo Elements/Direct Drafting displays a warning if any of the
following situations occur:

• If you define the same color as a source and a target color and the source
color instance has no target color mapped to it. For example, if blue is the
source color (not mapped to a target color), and the same blue color is
defined as the target color for the green source color.

• If you define the same color as a target color more than once.

In addition, Creo Elements/Direct Drafting displays the sequence number
of the duplicate colors in a bold orange color (RGB 255 128 0) in the color
information table.

5. Click OK in the Color Conversion dialog box.
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Note
• If you click Clear All, Creo Elements/Direct Drafting removes the target colors

in the Target Color column of the color information table. Also, Creo
Elements/Direct Drafting removes rows that contain color count as 0 (zero).

• Creo Elements/Direct Drafting supports Undo and Redo for color
conversion.

Storing the Color Conversion Map File
You can save your source-to-target color preferences in a map file after you have
defined the target colors in the Color Conversion dialog box. The source-to-target
color mapping is stored in a text file. The colors are stored as RGB values. Each
source-to-target color pair is stored on a new line. For example, the source-to-
target color mapping for black-to-white color conversion and red-to-yellow color
conversion is saved as:
0,0,0;255,255,255; (black-to-white color conversion)
255,0,0;255,255,0; (red-to-yellow color conversion)
To store the source-to-target color mapping:

1. Click File ▶ Settings ▶ Color ▶ Convert Colors.

The Color Conversion dialog box opens.
2. Define the target colors in the Target Color column of the color information

table.
3. Click Store.

The Save As dialog box opens.
4. Specify the path and the file name, and save the file.

Loading Color Conversion Map File
Creo Elements/Direct Drafting allows you to load a map file which contains
predefined or user-defined source-to-target mapping of colors to convert the
colors of a drawing.
To load a color map file:

1. Click File ▶ Settings ▶ Color ▶ Convert Colors.

The Color Conversion dialog box opens.
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2. In the Preset box, select one of the following:

• None

This is the default. No color map is loaded.
• CoCreate to Creo (predefined color map)
• Creo to CoCreate (predefined color map)

3. To load a user-defined source-to-target color map file, select User defined in
the Preset box and select the map file in the Open dialog box.

If there are duplicate source or target colors in the source-to-target color
mapping, Creo Elements/Direct Drafting displays a warning. See Converting
Colors on page 105 for more information.

4. Click OK.

Note
• If a source color which is defined in the map file is present in the drawing, the

corresponding target color is set in the Target Color column of the color
information table.

• If a source color which is defined in the map file is absent in the drawing, a
row (containing the color information) is added to the color information table
and the count is set to 0 (zero). You can view the information when you select
Source in the Preview box.

Changing the Catch Mode
The Catch box enables you to select a point on the screen without putting the
cursor directly on that point. The cursor will automatically "snap" to this point.
The current catch mode is always displayed in the status bar. The system will
catch to a given point only if the point lies within the (imaginary) circle around
the edges of the cursor.
By default, the catch mode is set to ALL. You can change the catch mode to any of
the following:

Setting Catches to
VERTEX Vertex
ELEM Element
INTERSECTION Intersection
CENTER Center point
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Setting Catches to
GRID Ruler/grid point
OFF Disables Catch

Select the catch mode in the Catch box on the status bar.
When you select ALL in the Catch box, Creo Elements/Direct Drafting catches
using the following order of priority:

1. VERTEX

2. INTERSECTION

3. GRID

4. ELEM

If the system finds a vertex within the catch range it catches to the closest such
vertex; otherwise it searches for intersections and so on. If the system can't find
any of these, it uses the given input point.

Note
By default, catch mode ELEM is used, when moving elements like geometry
or parts via handles. To use a different catch mode than ELEM, type MH_
USE_CATCH_MODE ON in the user input line. Now, the current catch mode is
used to move the elements via handles.

Measuring Distances
Creo Elements/Direct Drafting allows you to obtain values for arc lengths,

distances, point coordinates, angles, and areas using the Measure buttons.
These buttons are useful if you need to specify a value measured from existing
features on the drawing. To illustrate this, consider the following example.

Example
Suppose you want to draw a vertical line starting at 100,100 and of the same
length as an existing line drawn at an angle of 40 degrees:

1. In the Utilities group, click Measure.

2. Click Length.
3. Click the existing line.

The measured length of this line is displayed in the user input line.
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4. Click Drafting and then, in the Draw group, click the arrow next to Line.

5. Click Vertical.
6. Specify the begin point of the vertical line you want to create.
7. When prompted for the end point or the length of this vertical line, type the

measured length in the user input line and press ENTER.

Creo Elements/Direct Drafting draws the vertical line as specified. The length
of this line is the same as that of the line you measured.

Note

• Follow (described later in this section) is not active while Measure is
active.

Measuring Distance
To measure distance between any two points:

1. In the Utilities group, click Measure.

2. Click Distance.
3. Click the begin point and the end point in the drawing to measure the required

distance.

The distance between the two points is displayed in the user input line.

Measuring a Radius
To measure the radius of a curved element:

1. In the Utilities group, click Measure.

2. Click Radius.
3. Click the curved element whose radius you want to measure.

The radius of the curved element is displayed in the user input line.

Measuring Lengths
To measure the length of any element (line, circle, arc, fillet, chamfer or spline):
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1. In the Utilities group, click Measure.

2. Click Length.
3. Select the element.

The length of the element is displayed in the user input line.

Measuring Horizontal Distance
To measure horizontal distance between two points:

1. In the Utilities group, click Measure.

2. Click Horizontal.
3. Click two points in the drawing to identify the horizontal distance you want to

measure.

The horizontal distance between the two points is displayed in the user input
line.

Note
This option is dependent on the current catch mode.

Measuring Vertical Distance
To measure vertical distance between two points:

1. In the Utilities group, click Measure.

2. Click Vertical.
3. Click two points in the drawing to identify the vertical distance you want to

measure.

The vertical distance between the two points is displayed in the user input line.

Note
This option is dependent on the current catch mode.
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Displaying Point Coordinates
To display the exact coordinates of any existing point:

1. In the Utilities group, click Measure.

2. Click Point.
3. Click the point.

The exact coordinates of this point are shown in the user input line.

Note
This option is dependent on the current catch mode.

Measuring Angles
To measure the angle between two lines:

1. In the Utilities group, click Measure.

2. Click Angle.
3. Click a point on the first line.
4. Click a point on the second line.
Similarly, to measure an arc segment angle, click the arc start and end points.
The angle between two tangents drawn at an intersection point of two circles can
be measured by clicking a point on the first circle and then a point on the second
circle.

Measuring Area Properties

A Single Face
To calculate the area and area properties of a selected face, the face must be
completely bounded by elements.
Creo Elements/Direct Drafting calculates and displays the following area
properties for a single face:

• Number of holes in the face.
• Density of the face.
• Perimeter length of the face (outer perimeter).
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• Area.
• Center of Area (= Center of Mass).
• Principal Axes (of Inertia through the Center of Area).
• Second Moments of Area about principal axes.
• Second Moments of Area about coordinate system axes.
• Product of Second Moment of Area about coordinate system axes.
• Moments of Inertia about principal axes.
• Moments of Inertia about coordinate system axes.
• Product of Moment of Inertia about coordinate system axes.
• Section Moduli (about principal axes).
• Distance from first neutral axis to extreme fiber.
• Distance from second neutral axis to extreme fiber.
• Radii of Gyration.
• Angle between coordinate system and principal axes.

Multiple Faces
If you identify multiple faces, Creo Elements/Direct Drafting uses the density
values to calculate the Common Center of Mass. The density must be specified
before a face is identified, otherwise the default value (1) or the previous density
value is used.
Creo Elements/Direct Drafting calculates and displays the following total values
for multiple faces:

• Total Area.
• Center of Area (common).
• Center of Mass (common).
• Principal Axes through the (common) Center of Area.
• Second Moments of Area about (common) Principal Axes.
• Second Moments of Area about Coordinate System Axes.
• Product of Second Moment of Area about Coordinate System Axes.
• Moments of Inertia about (common) Principal Axes.
• Moments of Inertia about Coordinate System Axes.
• Product of Moment of Inertia about Coordinate System Axes.
• Radii of Gyration with respect to the (common) Center of Area.
• Angle between Coordinate System and (common) Principal Axes.
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To display face area properties:

1. In the Utilities group, click Properties.

2. Click Area.
3. Type the density value in the user input line and press ENTER.

The default density value is 1.

Alternatively, select a face or faces.

4. Click Confirm.

The area properties are displayed in a standard text editor.

Optionally, you can save the list of area properties in a file.
5. Exit the standard text editor to return to Creo Elements/Direct Drafting.

Example
Figure 13. I-Section Face on page 113 shows an I-section face.

Figure 13. I-Section Face

Figure 14. Resultant Diagram for I-Section Face on page 114 is a resultant
diagram for the I-section face.
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Figure 14. Resultant Diagram for I-Section Face

A listing of the Creo Elements/Direct Drafting output for this single face is given
below:
ALL VALUES REFER TO THE FOLLOWING UNITS:
LENGTH = 1 MM
ANGLE = 1 DEG

FACE 1:
NUMBER OF HOLES

noh = 0
DENSITY

rho = 1
PERIMETER LENGTH

P = 334
AREA

A = 1470
CENTER OF AREA = CENTER OF MASS

(Cx,Cy) = (289.2011071614633,344.1233317074434)
PRINCIPAL AXES OF INERTIA THROUGH THE CENTER OF AREA

(DIRECTIONS)
u = (0.8191520442890209,0.5735764363510046)
v = (-0.5735764363510046,0.8191520442890209)

SECOND MOMENTS OF AREA (ABOUT PRINCIPAL AXES)
Icu = 761433.6734694783
Icv = 334727.5

SECOND MOMENTS OF AREA (ABOUT COORDINATE SYSTEM AXES)
Ix = 174699726.7554225
Iy = 123421911.6970526

PRODUCT OF SECOND MOMENT OF AREA (ABOUT COORDINATE SYSTEM AXES)
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Ixy = 146095161.0177031
MOMENTS OF INERTIA (ABOUT PRINCIPAL AXES)

Jcu = 761433.673469478
Jcv = 334727.5

MOMENTS OF INERTIA (ABOUT COORDINATE SYSTEM AXES)
Jx = 174699726.755422
Jy = 123421911.697053

PRODUCT OF MOMENT OF INERTIA (ABOUT COORDINATE SYSTEM AXES)
Jxy = 146095161.017703

SECTION MODULI ABOUT PRINCIPAL AXES
Zcu = 23392.00626959447
Zcv = 10299.30769231674

DISTANCE FROM NEUTRAL AXIS u TO EXTREME FIBER
Du = 32.55102040816436

DISTANCE FROM NEUTRAL AXIS v TO EXTREME FIBER
Dv = 32.5

RADII OF GYRATION WITH RESPECT TO THE CENTER OF AREA
Rcu = 22.7592199074477
Rcv = 15.08992320434836

ANGLE BETWEEN COORDINATE SYSTEM AND PRINCIPLE AXES
phi = 35

Using the Calculator
Creo Elements/Direct Drafting provides a standard MS Windows calculator.
To use the scientific calculator:

1. In the Utilities group, click Calculator.

The Calculator application opens.
2. On the View menu of the Calculator, click Scientific.

Using the Standard Text Editor
Creo Elements/Direct Drafting provides a standard text editor.
To use the standard text editor:

• Click Miscellaneous and then, in the System group, click Edit File.

A blank text file opens.

Using the Ruler or Grid
The ruler simulates the T-square traditionally used with manual drafting methods.
When used together with the grid point catch mode, the ruler allows you to draw
with the help of a grid.
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The grid is a useful drawing aid for alignment purposes.

Displaying a Ruler and/or a Grid
To display the ruler and/or the grid:

1. Click File ▶ Settings ▶ Grid.

The Grid Settings dialog box opens.
2. In the Grid area, click Dot or Line to display a dot or line grid, respectively.
3. In the Ruler area, click Ruler to display the ruler.
4. Click OK.

Displaying the Origin
To display the coordinate origin:

1. Click File ▶ Settings ▶ Grid.

The Grid Settings dialog box opens.
2. In the Ruler area, click Origin.

The coordinate origin is indicated in the chosen viewport by an axes symbol.

If the ruler is active in the chosen viewport, it becomes unavailable.
3. Click OK.

Setting the Ruler or Grid Spacing
To change the spacing between the tick marks of the ruler or between the grid
lines or dots:

1. Click File ▶ Settings ▶ Grid.

The Grid Settings dialog box opens.
2. In the Options area, type the required distance (for example, 0.5) in the

Spacing box.

Note that this entry is interpreted in terms of the current length unit.
If the spacing is very small, it may not be shown on the screen but it will still be
used for catch when in ruler or grid catch mode. Use the buttons on the View tab if
you want an enlarged view.
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Setting Cursor Size
You can use either a small cursor or a full screen cursor. A full screen cursor is
particularly recommended for use with the ruler.
To change the cursor size:

1. Click File ▶ Settings ▶ System.

The System dialog box opens.
2. Click Environment.
3. In the Cursor area, click the Large check box to use the large (full screen)

cursor.
4. In the Cursor Size box, type the size for the cursor.
The catch range is not affected by the cursor size. Optionally, you can specify a
catch range in the Catch Range box.

Using Follow
The ruler is always located at the origin. The origin always tracks the ruler, and
the ruler always tracks the origin. Optionally, you can use the Follow check box to
move the coordinate system origin with the origin of the ruler.
To make the origin follow the ruler:

1. Click View and then, in the Viewing group, click Grid.
2. Click the Follow check box.

The ruler automatically moves to each new point you create.

Moving the Ruler
To move the ruler:

1. Click View and then, in the Viewing group, click Grid.
2. Click Move.
3. Specify the new origin.

The orientation of the ruler axes remains the same.

Placing the Ruler or Grid
To change the orientation of the axes:

1. Click View and then, in the Viewing group, click Grid.
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2. Click Place.
3. Specify the new origin and two more points that define the new axis

orientation.
Figure 15 on page 118 shows the ruler axes.

Figure 15. Ruler Axes

Rotating the Ruler or Grid

With Respect to the X-Axis
To rotate the ruler (or grid) so that the x-axis is at a given angle to the horizontal:

1. Click View and then, in the Viewing group, click Grid.
2. Click Turn.
3. Click Absolute.
4. Type the required angle in the user input line and press ENTER.

Through a Given Angle
To rotate the ruler (or grid) through a given angle:

1. Click View and then, in the Viewing group, click Grid.
2. Click Turn.
3. Click Relative.
4. Type the required rotation angle in the user input line and press ENTER.
A positive value results in counterclockwise rotation.
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Hiding the Ruler or Grid
To hide the ruler or grid:

1. Click View and then, in the Viewing group, click Grid.
2. Click Hide.
Hide disables the ruler and/or grid. Alternatively, you can click None in the Ruler
area of the Grid Settings dialog box.

Drawing an Isometric Ruler or Grid
To redraw the ruler or grid according to the isometric grid required for drawing
top, front, or side views:

1. Click View and then, in the Viewing group, click Grid.
2. Click Isometric and then click any of the following:

• Click Front to draw a front view.
• Click Top to draw a top view.
• Click Side to draw a side view.

Selecting What is Displayed on Your
Screen
This section describes how to use the Show dialog box to control exactly what is
displayed on your screen.
To open the Show dialog box:

• Click File ▶ Settings ▶ Show.

Alternatively, in the Utilities group, click Show.
Show operates in the current viewport.
Before you plot your complete drawing, you are recommended to check what is
included by clicking Show All in the General tab of the Show dialog box.
You can selectively display:

• Construction geometry
• Hatch
• Dimension
• Text
• Geometry

Changing the Drawing Environment and Making Measurements 119



• Vertex
• Info
• Layers
• URLs

Note
• The Show settings apply to the current viewport.
• Any new viewports created automatically adopts the settings of the viewport

that was active when they were created.

Showing All Features
To display all the features of your drawing:

1. Click File ▶ Settings ▶ Show.

Alternatively, in the Utilities group, click Show.

The Show dialog box opens.
2. On the General tab, click Show All.
It is useful to start with everything displayed, and then clear the check box of
items that are not required.

Showing Points
To display all existing points on the drawing:

1. Click File ▶ Settings ▶ Show.

Alternatively, in the Utilities group, click Show.

The Show dialog box opens.
2. On the General tab, click the Vertex check box.
This is useful if you want to identify a point more accurately, or to check if two
lines overlap. Points are displayed in the following colors (by default):

• GREEN – end points
• YELLOW – common end points
• BLUE – single center points
• MAGENTA – multiple center points
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Showing Dimensions
To display all dimensions on a drawing:

1. Click File ▶ Settings ▶ Show.

Alternatively, in the Utilities group, click Show.

The Show dialog box opens.
2. On the General tab, click the Dimension check box to display dimensions as a

group.
Any dimensions created after you clear the Dimension check box are not displayed
on the screen till the Dimension check box is clicked.

Changing the Layer Color
To change the color of a specified layer:

1. Click File ▶ Settings ▶ Show.

Alternatively, in the Utilities group, click Show.

The Show dialog box opens.
2. Click the Layer tab.
3. Select the layer number.
4. Select a color from the Color box.
5. Click Color.

Displaying Infos
To display elements that contain attached infos:

1. Click File ▶ Settings ▶ Show.

Alternatively, in the Utilities group, click Show.

The Show dialog box opens.
2. Click the Info Elem. tab.
3. Select the info to be displayed.
4. Click On to display elements that have information attached.

Viewing a Drawing
This section describes how to use the normal and dynamic View functions to see
details in your drawing more clearly. You can zoom-in on the area concerned, or
reposition the drawing on the screen.
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The buttons in the Viewing group on the View tab operate on either the current
viewport (default) or on a viewport that you select.

Selecting a Viewport
You can select the viewport in which the Viewing group buttons operate.

Current Viewport
If you want to use buttons in the Viewing group on the View tab for operating in
the current viewport:

1. Click View and then, in the Window group, click Current.
2. Click in the viewport or type the viewport number in the user input line and

press ENTER.

Creo Elements/Direct Drafting uses the current viewport for any buttons in the
Viewing group on the View tab.

Select Viewport
To select a viewport:

1. Click View and then, in the Window group, click Select.
2. Click in the viewport to select it.

Using View Functions
This section describes how to control the area of the drawing shown in the current
viewport using the buttons in the Viewing group on the View tab.

Viewing a Drawing in the Full Screen Mode
To view your drawing in the Full Screen mode:

• Click View and then, in the Viewing group, click Full Screen.

Alternatively, press F11 to toggle between the Full Screen mode and the
normal mode.

In the Full Screen mode, you can view the maximized drafting window. In
addition, the ribbon is minimized and the Part Browser is hidden during the Full
Screen mode.

Fitting a Drawing
To fit the current drawing in the selected viewport:
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• Click View and then, in the Viewing group, click Fit.

Restoring the Last View
To return to the previous view:

• Click View and then, in the Viewing group, click Last.

Redrawing
To redraw the drawing in the chosen viewport:

• Click View and then, in the Viewing group, click Redraw.
This is sometimes necessary if you have deleted several elements and traces are
still visible on the screen. The contents of other viewports will not be redrawn.

Panning Across a Drawing
Panning is a very useful function that enables you to move across the drawing to
view those areas not currently displayed.
Figure 16 on page 123 illustrates the use of panning.

Figure 16. Panning Across a Drawing

To pan in any direction:

1. Click View and then, in the Viewing group, click Pan.
2. Click a point in your drawing.
3. Specify the new screen position for this point.
Alternatively, press the middle mouse button to pan to the new position.

Creating a New Center Point for Your Drawing
To specify the new center point for the display:
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• Click View and then, in the Viewing group, click Center.
Your drawing is repositioned so that this point is in the center of the chosen
viewport.

Note

Center uses the current catch mode to identify the specified point.

Zooming In or Out
Awindow is always zoomed about its center point.
To zoom your window:

1. Click View and then, in the Viewing group, click Zoom.
2. Type a zoom factor in the user input line and press ENTER.

A number greater than 1 results in a window that covers a smaller area
(zooming in). A number less than 1 (>0) or negative (<-1) gives a larger
coverage (zooming out).

Alternatively, move the mouse towards the screen to zoom in or move the mouse
away from the screen to zoom out and click a point in the viewport.

Creating a New View in a Window
To create a new window:

1. Click View and then, in the Viewing group, click Window.
2. Specify the two points (corners) of the area you want to enlarge.

Storing and Recalling Windows
If you are likely to need the same view again, you can store it and recall it as
required
To store the current window coordinates:

• Click View and then, in the Viewing group, click Store.
To recall the window that was stored last:

• Click View and then, in the Viewing group, click Recall.
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Searching for Text and Dimensions in the
Viewport
You can search for text and dimensions in a drawing in the viewport using the
buttons in the Search group on the View tab.

Searching for text in the viewport
1. Click View and then, in the Search group, click Text.

The Search Text dialog box opens.
2. In the Text box, type the text to be searched for.

Select the Match case and Match whole word check boxes as required.
3. The Index box indicates the current occurrence of the text.
4. Click Next or Previous to search for the next or previous occurrence of the

text, respectively.

Searching for dimensions in the viewport
1. Click View and then, in the Search group, click Dimension.

The Search Dimension dialog box opens.
2. In the Dimension box, type the dimension to be searched for.
3. In the Dim Type box, select the dimension type.
4. In the Search In box, select the scope of the search, that is, the main dimension

or a dimension text extension.
5. The Index box indicates the current occurrence of the dimension.
6. Select the Match case and Match whole word check boxes as required.
7. Click Next or Previous to search for the next or previous occurrence of the

dimension, respectively.

Using Viewports to Display Several Views
You can divide the drawing area of the screen so that more than one view can be
displayed. This is a very useful feature when you want to work on a detail
drawing. The changes made to the detail are automatically repeated in the main
drawing. Each division of the screen is called a viewport.
Viewports can be overlapped with other viewports, menus, and programmable
tables. All overlapping viewports are continuously updated during your drawing
session.
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In the following example, the view in viewport 1 can be imagined as the view you
would see if you were examining your drawing with a magnifying glass. To
achieve this effect, simply zoom in to the drawing displayed in viewport 1 until
you can see the required level of detail.

• Viewport 1 — contains a magnified view showing the required level of detail.
• Viewport 2 — contains the entire drawing and is used as a positional reference

for the magnifying glass.
Examine the zoomed drawing in viewport 1 while moving the cursor (as a
positional reference) in viewport 2. See Figure 17 on page 126 and Figure 18 on
page 127.

Figure 17. Using Viewport 2 as a Reference
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Figure 18. Viewing Piston Assembly Detail in Viewport 1

Creating a Viewport
To create a new viewport:

1. Click View and then, in the Window group, click New.
2. Specify the new corner points for the new viewport.
The new viewport is marked by a sequential number in the top-right corner.

Making a Viewport Current
If a viewport is partially or totally covered by other viewports, it is made inactive.
Its visual contents are not updated by any subsequent operations unless it is made
the current viewport.
The current viewport is the one that is currently active, fully visible and up-to-
date. The viewport number is displayed in inverse video in the top right corner.
To change the current viewport:

1. Click View and then, in the Window group, click Current.
2. Click the viewport required.
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Alternatively, type the viewport number in the user input line and press
ENTER.

Changing the Size of a Viewport
To change the size of a viewport:

1. Click View and then, in the Window group, click Change.
2. Click the required viewport.
3. Specify the new corner points of the viewport.

Moving a Viewport
To move a viewport:

1. Click View and then, in the Window group, click Move.
2. Click the viewport.
3. Drag the cursor to the new position in the viewport.

The contents of the viewport follow the viewport.

Maximizing the Size of a Viewport
You can maximize the size of any viewport such that the viewport occupies the
entire Creo Elements/Direct Drafting drawing area.
To maximize the size of the viewport:

1. Click View and then, in the Window group, click Large.
2. Click the viewport.
Any other viewport are now hidden behind the maximized viewport. To bring any
of these hidden viewport to the foreground, make it current. To change the size of
the maximized viewport, use Change.

Redrawing a Viewport
To redraw a viewport:

1. Click View and then, in the Window group, click Redraw.
2. Click the viewport.
The contents of the viewport will be redrawn.
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Deleting a Viewport
To delete a viewport:

1. Click View and then, in the Window group, click Delete.
2. Click the viewport.

Alternatively, type the viewport number in the user input line and press
ENTER.

Deleting All Viewports
To delete all viewports:

1. Click View and then, in the Window group, click Delete.
2. Type ALL in the user input line and press ENTER.
All viewports are removed from the Creo Elements/Direct Drafting drawing area.

Note
To continue drawing or to view your current Creo Elements/Direct Drafting
drawing after you have deleted all viewports, you need to create at least one
new viewport.

Viewport Settings
The viewport settings are defined in the Viewport Settings dialog box.
To define the viewport settings:

1. Click File ▶ Settings ▶ Viewport.

The Viewport Settings dialog box opens.
2. In the Border area:

a. In the Color box, select a color for the viewport border.
b. In the Width box, type the viewport border width.

3. In the Color of area:

a. In the Background box, select the background color.
b. In the Text box, select the color of the text.
c. In the Cursor box, select the color of the cursor.
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Refer to Defining Custom Colors on page 100 for instructions on defining
custom colors.

4. In the Invert area, select one of the following in the Invert Color box to invert
display colors in a viewport:

• White elements

If you select White elements, the elements that are white (or almost white)
are displayed in black. This is the default for the Creo Colors color
scheme.

• Black elements

If you select Black elements, the elements that are black (or almost black)
are displayed in white. This is the default for the CoCreate Colors color
scheme.

• Off

If you select Off, element colors are not inverted in the viewport.
5. In the Print Preview area:

a. In the Width box, type the preview width.
b. In the Height box, type the preview height.
c. In the Background box, select the background color.
d. Select the Show Ruler check box, to display the ruler.

6. Select the Smooth Window Update check box, to provide more visual guidance
when zooming into a selected area or when defining the window view.

The time duration for window update is ranged from 30ms to 3000ms.
7. Click OK.

Note
• The viewport colors are defined by the color scheme. The internal viewports

(for example, the viewport in the Symbols dialog box) also display the default
colors for the selected color scheme.

• The smart zoom feature for files with large size takes longer than the specified
time.

Viewport Example
A common application using viewports is identifying two (or more) widely
separated points on a large and complex drawing. Refer to Figure 19 on page 131.
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Figure 19. Joining Two Widely Spaced Points Using Viewports

To draw a line between points 1 and 2 in Figure 19 on page 131:

1. Create viewport V3.
2. Then create viewport V1 and V2.

3. Click Drafting and then, in the Draw group, click the arrow next to Line.

4. Click 2 Points.
5. Specify point 1 in V1 and point 2 in V2.
Creo Elements/Direct Drafting draws a line between points 1 and 2.

Using Properties to Change Elements and
Text
Line geometry, text and hatch have associated properties.

Geometry Properties
Geometry properties are:

• Color
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• Linetype
• Line width (pen size) and line size
These can be predefined using the Geometry Settings dialog box.

Text Properties
Text properties are:

• Font
• Origin vertex
• Angle
• Fill
• Frame
• Linespace
• Ratio
• Size
• Slant
These can be predefined using the Text Settings dialog box.

Hatch Properties
Hatch properties are:

• Pattern
• Angle
• Distance
• Reference Point
These can be predefined using the Hatch Settings dialog box.

Getting and Putting Properties

It is possible to retrieve properties (of Text, for example) and use them either
in subsequent work or to change existing properties.

Note

You cannot change dimension properties using Get and Put.
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For example:

1. In the Utilities group, click Properties.

2. Click Get.
3. Select a block of text.
All properties of that text are retrieved. Any further text will now have these
properties.
To change the properties of an existing text block to those of another:

1. In the Utilities group, click Properties.

2. Click Get.
3. Select the text whose properties you want to retrieve.

4. In the Utilities group, click Properties.

5. Click Put.
6. Select the text whose properties are to be changed.

Using the Toolbox
Creo Elements/Direct Drafting provides a special dialog box from which you can
run, view, and administer macros. Up to 24 macros can be assigned to the
TOOLBOX dialog box and you can define any number of macro-sets that can be
called in the TOOLBOX dialog box.
To open the TOOLBOX dialog box:

• Click Miscellaneous and then, in the System group, click Toolbox.

The TOOLBOX dialog box opens.

Recording a Macro
To record a macro using the TOOLBOX dialog box:

1. Click ADD.

Numbers appear in the boxes to help you identify the correct box. If macros
are already assigned, their names are shortened to make space for the box
numbers.

2. Click one of the 24 macro boxes.
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3. Type a title for the macro between single quotes (‘ ’) in the user input line and
press ENTER.

The macro title can be up to six characters long.
4. Perform the required operations in Creo Elements/Direct Drafting.

Creo Elements/Direct Drafting records all your operations.
5. After you finish your operations, click END.

Creo Elements/Direct Drafting stops recording the macro and displays the
macro name in the box you assigned to it.

Example
This example shows you how to record a macro named RT4020 that draws a
rectangle and dimensions it (rectangle size is 40x20mm). The macro is assigned to
box number 3.
To record the RT4020 macro using the TOOLBOX dialog box:

1. Click ADD.
2. Click box number 3.
3. Type `RT4020' in the user input line and press ENTER.
4. Click Drafting and then, in the Draw group, click Rectangle.
5. Type 0,0 in the user input line and press ENTER.
6. Type 40,20 in the user input line and press ENTER.
7. Click OK.
8. Click END.
The macro is now defined.

Running a Macro
To run a macro:

• In the TOOLBOX dialog box, click the macro name.

Renaming Macros
To rename a macro:

1. In the TOOLBOX dialog box, click RENAME.
2. Select the macro.
3. Type a new name for the macro in the user input line and press ENTER.

134 Creo Elements/Direct Drafting User's Guide: Fluent User Interface



Deleting Macros
To delete a macro:

1. In the TOOLBOX dialog box, click DELETE.
2. Select the macro.

Editing Macros
After you have recorded a macro, you can modify its contents using EDIT in the
TOOLBOX dialog box. For example, suppose you want to change the size of the
rectangle you created in Recording a Macro on page 133 to measure 38x22
instead of 40x20.
To edit the RT4020 macro:

1. In the TOOLBOX dialog box, click EDIT.
2. Select RT4020.

Creo Elements/Direct Drafting displays the macro string in the user input line.
3. Modify the old values and press ENTER.
The next time you use the RT4020 macro, the new rectangle is drawn. You may
change the macro's name to reflect the new size.

Loading Macro-Sets
Although the TOOLBOX dialog box lets you display a maximum of 24 macros, you
can group macros together into a file. Each file can contain up to 24 macros that
can be loaded by the TOOLBOX dialog box. For example, if you have a file called
tb_rectangle containing the macros:
RT4020
RT4025
.
.
.
RT5020

you can tell TOOLBOX to use this file by clicking INPUT and then specifying
the filename tb_rectangle.

Note
The TOOLBOX dialog box is a fixed size. Although you can reposition it
around the screen, you cannot change its size.
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Setting the Auto Save Time for Drawings
In addition to the File functionality described in Storing, Loading and Filing on
page 528, Creo Elements/Direct Drafting provides an autosave feature to
automatically save a drawing at routine intervals.

• The name of the autosaved file is me_backup.mi. This file is put in the
working directory as specified by ME_WORKING_DIR.

• If ME_WORKING_DIR is not defined, the file is stored in \temp on
Windows-based systems.

• The autosave interval is a time interval in minutes. Possible values are 10 and
0 (0 means off; this is the default).

• While the autosave is running, a message pops up and the blue store bar
displays the progress.

To set a time interval (in minutes) at which your drawing will be automatically
saved to a file named me_backup.mi:

1. Click File ▶ Settings ▶ System.

The System dialog box opens.
2. Click Save.
3. In the Auto Save area, click the Auto Save Drawing check box.
4. In the Type box, type a time interval (in minutes).
5. Click OK.

Setting the Delay Time for Cascaded
Menus
If you find that cascaded menus are displayed too quickly or too slowly, proceed
as follows to change the time delay for such menus:

1. Click File ▶ Settings ▶ System.

The System dialog box opens.
2. Click UI.
3. In the Menus area, type the time delay (in milliseconds) in the Cascade

Timeout box.
4. Click OK.
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Setting the Redraw Mode
When dealing with large or complex drawings, you may want to change the
redraw mode in order to enhance the graphics performance.
To define settings for the redraw mode:

1. Click File ▶ Settings ▶ System.

The System dialog box opens.
2. Click Redraw Mode.
3. In the Parts as Box area:

a. In the Smaller than box, type a size threshold (in pixels) below which parts
are only shown as boxes.

b. Optionally, in the Box Color box, select a color.
4. In the Draw Dynamic area:

a. Click the check box of the items that you want to include in the redraw.
b. Clear the check box of the items that you want to exclude from the redraw

to enhance performance.
5. Click OK.

Saving the Current Drawing Environment
The current setup of your drawing environment can be saved to a file for re-use.
To save the current drawing environment:

1. Click File ▶ Settings ▶ System.

The System dialog box opens.
2. Click Save.
3. In the Save Settings area, click the check box of the settings you want to save.
4. Click OK.

Further Information
For further technical information about the drawing environment and making
measurements in Creo Elements/Direct Drafting, refer to the Creo Elements/
Direct Drafting help system.
Type the following in the Creo Elements/Direct Drafting user input line and press
ENTER:
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• help edit_environment

• help wui_construction_settings

• help wui_geometry_settings

• help wui_dimension_settings

• help wui_hatch_settings

• help wui_text_settings

• help wui_prp_settings

• help wui_refline_settings

• help wui_symmetry_line_settings

• help wui_center_line_settings

• help wui_viewport_settings

• help wui_grid_settings

• help wui_show

• help wui_hidden_settings

• help measure_angle

• help measure_area

• help measure_coordinate

• help measure_distance

• help measure_length

• help measure_radius

• help measure_tang_ang_at_pnt

• help multiple_measure

• help calculator

• help catch

• help window

• help line_grid

• help dot_grid

• help cs_set

Creo Elements/Direct Drafting displays further information about the drawing
environment and making measurements.
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Introduction
The Creo Elements/Direct Drafting copilot functionality provides dynamic visual
feedback on an element's attributes (angles and dimensions) before you fix the
position. This dynamic feedback lets you create designs quickly and minimizes
the need for construction geometry.
You can also enter values using the keyboard as usual if you need greater
precision in size and positioning.
The following figure shows an example of the on-screen feedback provided by the
copilot functionality when you create geometry.

Figure 20. Copilot Functionality: Typical Feedback

The snap marker (magenta box) over the cursor indicates that you are in copilot
mode and about to click a start-point.

Enabling or Disabling the Copilot
Functionality
To enable or disable the copilot functionality:

1. Click File ▶ Settings ▶ System.

The System dialog box opens.
2. Click Copilot.
3. Click or clear the Enable Copilot check box to enable or disable the copilot,

respectively.
4. Click OK.
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Copilot Settings
You can also define the following settings for the copilot using the Copilot pane in
the System dialog box:

• Snap settings
• Catch range settings
• Text settings

Snap Settings
In the Snap area, define the following snap settings:
Angle In the Angle box, type the angle that the cursor snaps to.
Distance In the Distance box, type the distance that the cursor snaps

to.

For example, if the snap angle is set to 15° and the snap distance is set to 1 mm,
specifying lengths is restricted to multiples of 1 mm and angles to multiples of
15°. This means that movement of the cursor over empty areas occurs in
increments rather than as a smooth action.

Catch Range Settings
In the Catch Range area, define the catch distance:
Perpendicular Type the catch distance from perpendicular

elements.
Tangent Type the catch distance from tangent elements.
Center Type the catch distance from center points.

Text Settings
In the Text Box area, click the Long Prefixes check box to display a full description
of the circular element in the text box. For example:

• Long Prefixes on = Radius
• Long Prefixes off = R

Defining other settings related to Copilot
To define other settings related to copilot:

1. Click File ▶ Settings ▶ System.
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The System dialog box opens.
2. Click Snapping.
3. Define the following settings for snapping functionality:

• Snap points
• Snap marker
• Snap line
• Constraint signs

Snap Points Settings
In the Snap Points area, define the following:
Count In the Count box, type the count value.

This value sets the maximum number of points simultaneously
present in the drawing.

Delay In the Delay box, type the delay (in seconds).
This value sets the delay for how long a cursor is caught on an
element before a snap point for a snap line appears.

Color In the Color box, select a color for the last visited snap point.

Snap marker Settings
In the Snap marker area, select a color for the snap marker.

Snap Line Settings
In the Snap Line area, define the following

• Color

• Line type

Color In the Color box, select a color for the snap line.
Linetype In the Line type box, select a line type for the snap

line.

Constraint Signs Settings
In the Constraint Signs area, define the following:
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Enable Click the Enable check box to enable constraint signs.
A constraint sign is displayed when the element you are
creating is horizontal, vertical, tangent, or perpendicular to
another element.

Color In the Color box, select a color for the constraint sign.

Copilot Features
To improve your speed and accuracy when working with geometry, use the
following features:

• Incremental movement
• Size indication
• Snap lines

Incremental movement
You can specify a length increment to restrict the length of a line or the radius of a
circle using the copilot. The length and angle increments are defined by the snap
angle and the snap distance settings available in the Snap area of the Copilot pane
in the System dialog box.

Increment = 1 mm Increment = 0.1 mm

Size indication
When you create or modify elements, a text box with coordinates shows the
element's size or modification distance.
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Snap lines
Snap lines are similar to temporary auxiliary lines; they appear when you move
the cursor close enough to catch them.

Snap line base points
When you hold the cursor at a vertex for 0.5 seconds (the default setting), a small
plus sign appears. This is the snap point for snap lines.

On geometry elements, you can have snap points at the start point, the end point,
the midpoint (of lines), and the intersection between two elements.

There is a limit to the number of snap points that can exist at one time; when it is
reached, the snap point that hasn't been visited for the longest time disappears.
You can change this number in the Snapping pane of the System dialog box.

Snap line orientation
Snap lines may be horizontal, vertical, parallel, tangent, or perpendicular to an
element. You can catch the cursor to a snap line, to the intersection of two snap
lines, or the intersection of a snap line and a geometry element.
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Snap lines on text
The snap point for text is on the attachment point of the text.

Snap lines on dimensions
The snap line snap points for dimensions appear on the center of the dimension
text, and the snap line appears on and is parallel to the dimension line.

To align a new dimension with an existing dimension, the text and lines of the two
dimensions must be parallel.

Snap lines on reference lines
On reference lines, the snap points appear on the vertices. You can snap the cursor
to the refline on any of the 9 text adjust points.

Example — Creating a Slotted Plate
Suppose you want to create an engineering drawing from a sketch made at a
design meeting. With the copilot functionality, you can quickly turn a sketch in an
engineering design without the need for unnecessary construction geometry.
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Figure 21. Design Sketch

Figure 22. Design Reality

An example of constructing the plate with the minimum of construction geometry
follows. As you draw, you will notice that line colors may change as you intersect
with existing geometry and the status line gives feedback on your current activity.
During certain actions, Creo Elements/Direct Drafting displays negative values.
Ignore these for this example.

1. Click Drafting and then, in the Draw group, click the arrow next to Line.

2. Click Horizontal and draw a horizontal line of length 50 mm (line 1 in
Figure 23 on page 148).

3. Click Drafting and then, in the Draw group, click the arrow next to Line.

4. Click Vertical and draw a vertical line of length 20 mm (line 2).

5. Click Drafting and then, in the Draw group, click the arrow next to Line.

6. Click Angle & Length and click point A.
7. Move the cursor in an arc and specify an angle of 135°.
8. Drag the cursor and specify a length of 18 mm.
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9. Click Drafting and then, in the Draw group, click the arrow next to 2
Points.

10. Click Parallel and then click line 1.
11. Drag the cursor vertically and click a point at 45.

12. Click Drafting and then, in the Draw group, click the arrow next to Line.

13. Click Vertical and draw line 4 to meet the construction line.

14. Click Drafting and then, in the Draw group, click the arrow next to Line.

15. Click Horizontal and draw a horizontal line of length 95 mm.

16. Click Drafting and then, in the Draw group, click the arrow next to Line.

17. Click Vertical and draw a vertical line of length 15 (line 6).

18. Click Drafting and then, in the Draw group, click the arrow next to Line.

19. Click 2 Points and draw line 7.
The next step is to construct the holes. The hole at H1 is to be offset at 10 and 8
with diameter 6 mm. Holes H2 and H3 constructed on arcs 32 and 70 mm from
H1.

1. Click Drafting and then, in the Draw group, click the arrow next to Circle.

2. Click Center & Radius (see Figure 23 on page 148).
3. Type OFFSET or offset in the user input line and press ENTER.
4. Click line 1 and then line 2.
5. Click the center point at 8 (x-axis) and 10 (y-axis).
6. Drag the cursor and specify a radius of 3.

7. In the Draw group, click the arrow next to Center & Radius.

8. Click Center & Radius and draw a construction circle at 32 with H1 as the
center.

9. Similarly, draw a construction circle at 70 with H1 as the center (see Figure
24. Slotted Plate - 2 on page 148).

10. In the Draw group, click the arrow next to Circle.
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11. Click Center & Radius.
12. Draw hole H2 having radius 5.
13. Similarly, draw hole H3 also having radius 5.

Note
The precise position for holes H2 and H3 is not important.

14. Delete the circular construction geometry.

Figure 23. Slotted Plate - 1

Figure 24. Slotted Plate - 2

The slot can be drawn in freehand mode using Polygon. The only criteria is
that the inside edge is parallel to line 7.
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1. Click Drafting and then, in the Draw group, click the arrow next to 2
Points.

2. Click Parallel and draw parallel construction lines at a distance of 7 from
lines 1, 5, and 7.

3. Click Drafting and then, in the Draw group, click the arrow next to Line.

4. Click Polygon and draw the slot starting at point B moving anticlockwise.
5. Delete the construction geometry to clean up the drawing.

6. Click Drafting and then, in the Engineering group, click the arrow next to
Fillet.

7. Click Radius, type 5 in the user input line, and press ENTER.
8. Click the corners of the plate to add fillets.

Figure 25. Slotted Plate - 3

Further Information
For further technical information about the copilot, refer to the Creo Elements/
Direct Drafting help system.
Type help copilot in the Creo Elements/Direct Drafting user input line and
press ENTER.
Creo Elements/Direct Drafting displays further information about the copilot.
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This chapter describes how to create a drawing using construction geometry and
"real" geometry.
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Drawing Geometry
On the Drafting tab, the following groups contain the buttons to draw geometry:

• Draw

• Engineering

• Annotate

Drawing Lines
Creo Elements/Direct Drafting allows you to draw linear elements in your

drawing using Line.
To draw a linear element:

1. Click Drafting and then, in the Draw group, click the arrow next to Line.
2. Click the required Line button and perform the associated procedure.

Line Button Purpose Procedure

Polygon
Draw a polygon. Specify the start point,

and then a sequence of
end points.
The result does not have
to be a closed polygon.
Creo Elements Direct/
Drafting treats the lines
as individual elements
and hence you must
delete them individually
or enclose them in a box
for deletion.
Once you close a
polygon, you can
continue by indicating
the first point of a new
polygon.

2 Points
Draw a line with two
points.

Specify the start and end
points of the line.

Horizontal
Draw a horizontal line. a. Specify the start

point of the line.
b. Type the length of

the line in the user
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Line Button Purpose Procedure
input line and press
ENTER.

or

Specify the end point
of the line.

If you specify an end
point, the line is
drawn through that
point.

This operation is similar
to line by two points but
only draws a horizontal
line.

Vertical
Draw a vertical line. a. Specify the start

point of the line.
b. Type the length of

the line in the user
input line and press
ENTER.

or

Specify the end point
of the line.

If you specify an end
point, the line is
drawn through that
point.

This operation is similar
to line by two points but
only draws a vertical
line.

Parallel
Draw a line parallel to
an existing line.

a. Click an existing
line.

b. Specify a point on
the parallel line.

Alternatively:

a. Type the distance in
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Line Button Purpose Procedure
the user input line
and press ENTER.

b. Click an existing
line.

c. Specify the side on
which you want to
draw the parallel
line.

You can use the ruler to
ensure that the line is
drawn at a given
distance (see Using the
Ruler or Grid on page
115).

Perpendicular
Draw a perpendicular
line to an existing line.

a. Click the existing
line.

b. Click a point on the
perpendicular line.

Alternatively, to use
a point on the
existing line as the
starting point of the
perpendicular line:

i. Specify the point
on the existing
line.

ii. Specify the end
point of the
perpendicular
line or type the
length of the
perpendicular
line in the user
input line and
press ENTER.

If the
perpendicular
line appears on
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Line Button Purpose Procedure
the wrong side of
the line, repeat
the operation
using the
opposite sign for
the specified
value.

Angle & Length
Draw a line with a given
length and angle.

a. Specify the start
point of the line.

b. Type the angle of the
line with respect to
the x-axis in the user
input line and press
ENTER.

c. Type the length of
the line in the user
input line and press
ENTER.

The line is drawn
accordingly.
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Line Button Purpose Procedure

Tangent
Draw a tangent to a
circular element (arc or
circle) from any given
point.

a. Specify the
approximate point of
tangency on the arc
or circle.

b. Specify the point
from which the
tangent should be
drawn.
Note
Creo Elements/
Direct Drafting
informs you if such a
tangent is not
possible.

Tangent by 2
Draw a tangent to two
arcs or circles (from one
circular element to
another).

Specify the approximate
point of tangency on
each of the two arcs or
circles.
The tangent drawn is the
one with points of
tangency closest to those
indicated.

Drawing Rectangles
You can draw rectangles as whole entities. However, Creo Elements/Direct
Drafting treats them as four individual line elements. The sides of a rectangle can
be deleted or manipulated individually.
To draw a rectangle:

1. Click Drafting and then, in the Draw group, click Rectangle.
2. Specify two diagonal corner points.

The rectangle size varies with the movement of the cursor until the second
point is defined.
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Drawing Circles
Creo Elements/Direct Drafting allows you to draw circular elements in your

drawing using Circle.
To draw a circular element:

1. Click Drafting and then, in the Draw group, click the arrow next to Circle.
2. Click the required Circle button and perform the associated procedure.

Circle Button Purpose Procedure

Center &
Radius

Draw a circle by indicating
the center and
circumference point.

a. Specify the center of
the circle.

b. Specify a point on the
circumference

or

Type the length of the
radius in the user input
line and press ENTER.

The circle moves with
the cursor till you
define the
circumference point.

You can draw additional
concentric circles by
indicating additional points
or radii.

3 Points
Draw a circle by indicating
three points on the
circumference.

Specify three
circumference points.
The circle drawn varies
with the movement of the
cursor till you define the
third point.

Concentric
Draw concentric circles. a. Click the existing

circle.
b. Specify the desired

circumference point.

or

Type the radial offset
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Circle Button Purpose Procedure
in the user input line
and press ENTER.

To draw further concentric
circles, simply specify
further circumference
points.

Diameter
Draw a circle by diameter. Specify the two diameter

end points for the circle.

Tangent
Draw a circle of given
radius tangential to two
existing elements.

a. Specify the
approximate tangent
points on the two
elements.

The elements can be
lines, arcs, or circles.

b. Type the required
radius in the user input
line and press ENTER.

Creo Elements/Direct
Drafting calculates the best
solution, or suggests a
valid radius, if no solution
is possible.

Drawing Arcs
Creo Elements/Direct Drafting allows you to draw arcs in your drawing using
Arc. Arcs are normally drawn in the counterclockwise direction.
Figure 26 on page 158 shows arc geometry.
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Figure 26. Arc Geometry

To draw an arc:

1. Click Drafting and then, in the Draw group, click the arrow next to Arc.
2. Click the required Arc button and perform the associated procedure.

Arc Button Purpose Procedure

3 Points
Draw an arc through
three points.

a. Specify the two end
points of the
required arc.

b. Specify a third point
on the arc.

The arc drawn varies
with the movement
of the cursor till you
define the third
point.

Center & 2 Points
Draw an arc with a
given center and radius.

a. Specify the center
point.

b. Type the arc radius
in the user input line
and press ENTER.

c. Type the start angle
of the arc in the user
input line and press
ENTER.

d. Type the end angle
of the arc in the user
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Arc Button Purpose Procedure
input line and press
ENTER.

Alternatively, you
can define the angles
by specifying two
points.

Center, Radius & 2
Points

Draw an arc by center
and end points.

a. Specify the center of
the arc.

b. Specify the arc start
point (radius).

c. Specify the arc end
point (third point).

The third point may
not lie on the arc
plane, but its line
defines the end of
the arc.

Concentric
Draw concentric arcs. a. Click an existing arc.

b. Specify a point on
the required arc.

c. Specify further
points to draw
further concentric
arcs.

Point, Radius &
Angle

Draw an arc by
specifying a point,
radius, and angle.

a. Specify a peripheral
arc point.

b. Type the arc radius
in the user input line
and press ENTER.

c. Type the start or end
angle of the arc in
the user input line
and press ENTER.
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Arc Button Purpose Procedure
Note
Angles are
measured
counterclockwise
from the
horizontal.

d. Type the opening arc
angle in the user
input line and press
ENTER.

Diameter
Draw an arc by
specifying diameter.

Specify the diameter end
points. An arc is drawn
between the end points.
The resulting position of
the arc depends upon
which diameter point
you specify first.

Smooth
Draw a smoothly
connecting arc.

a. Click an element end
point (line, circle,
and so on).

b. Specify the end point
of the arc.

The arc is drawn
tangential to the
element you have
clicked.

With each further
point indicated,
another arc is drawn
tangential to the
previous one.

In Figure 27 on page
161, points 1 to 4 have
been specified in
sequence.
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Figure 27. Smoothly Connecting Arcs

Drawing Splines
Spline curves are special types of smooth curves that pass through given data
points. When you have specified the data points, Creo Elements/Direct Drafting
uses a powerful technique (B-spline mathematics) to produce the spline shape.
The following diagram shows examples of uses of spline curves.

Figure 28. Typical Spline Curves: Engine Manifold, Pipe Tree, Racquet
Head

Spline Components
Figure 51 on page 162 shows a simple spline with its control polygon visible. The
control polygon can be thought of as a convex hull containing the spline. Note that
both interpolation and control splines have a control polygon. Points on the
interpolation spline curve are called interpolation points. Points on the control
polygon are called control points.
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Figure 29. Spline Components

Interpolation Spline vs. Control Spline
You can create splines based on interpolation points or control points. If you want
a spline to pass through defined points, use interpolation points. If the spline does
not need to pass through defined points, you can use interpolation-point created
splines or control-point created splines. Control-point created splines are more
appropriate for creative design work where curved molded surfaces are required.

Open Spline vs. Closed Spline
By default, the interpolation or control splines you create in Creo Elements/Direct

Drafting are open. The Closed check box under Spline enables you to create
closed splines.

Figure 30. Open Spline vs. Closed Spline

Drawing a Spline
Creo Elements/Direct Drafting allows you to draw splines in your drawing using
Spline.
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To draw a spline:

1. Click Drafting and then, in the Draw group, click the arrow next to Spline.
2. Click the required Spline button and perform the associated procedure.
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Spline Button Purpose Procedure

Interpolation
Draw an interpolation
spline using
interpolation points.
Points on an
interpolation spline (I
spline) are called
interpolation points. A
spline created with
interpolation points
passes exactly through
the interpolation points
used to define it.

a. Specify a sequence
of interpolation
points.

b. Click OK.
While creating an
interpolation spline, you
can also change the
order of spline, append
the spline to an existing
geometry, and specify
the slope of an
interpolation spline. See
Modifying Splines on
page 223 for more
information.

Control
Draw a control spline.
When you draw a spline
using a control polygon,
the shape of the spline is
influenced by the
control polygon formed
by the control points.

a. Specify a sequence
of control points.

Note
These points
make up a
control polygon
which "controls"
the shape and
size of the
resulting control
spline. The first
control point
serves as the
begin point of the
control spline.
The last control
point serves as
the end point of
the control
spline.

b. Click OK.
Creo Elements/Direct
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Spline Button Purpose Procedure
Drafting draws a spline
curve based on the
control points you
specified.
While creating a control
spline, you can also
change the order of the
spline. See Modifying
Splines on page 223 for
more information.

Note
• To display the control polygon of an interpolation spline, click File ▶ Settings

▶ Show and then click the Vertex check box.
• To display or hide the spline control points, click Drafting and then, in the

Draw group, click the arrow next to Spline. Click Display On or
Display Off to display or hide the spline control points, respectively, and then
select the spline.

Drawing Ellipses
Creo Elements/Direct Drafting allows you to draw ellipses in your drawing using

the Ellipse buttons under Spline in the Draw group on the Drafting tab.
To draw an ellipse:

1. Click Drafting and then, in the Draw group, click the arrow next to Spline.
2. Click the required Ellipse button and perform the associated procedure.
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Ellipse Button Purpose Procedure

Axis & Point
Draw an ellipse by axis
end points and a
peripheral point.

a. Specify the two
vertices of the major
axis of the required
ellipse.

b. Specify a point on
the circumference.

Center, Angle &
Radius

Draw an ellipse by
center, angle and radii.

a. Specify the center of
the required ellipse.

b. Type the angle of
the major axis with
respect to the x axis
(30° in Figure 31 on
page 150) in the
user input line and
press ENTER.

c. Type the major
radius (30 mm in
Figure 31 on page
167) in the user
input line and press
ENTER.

d. Type the minor
radius (15 mm in
Figure 31 on page
167) in the user
input line and press
ENTER.

Center & 2 Points
Draw an ellipse using the
center and two points.

a. Specify the center
point of the ellipse.

b. Specify the first
point on the
circumference.

c. Specify the second
point on the
circumference.
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Ellipse Button Purpose Procedure

2 Focal &
Circumference

Draw an ellipse by
specifying the focus.
See Figure 32 on page
168 (drawing A).

a. Specify the first
focal point (1).

b. Specify the second
focal point (2).

c. Specify a point on
the circumference
(3).

Focal, Angle &
Radius

Draw an ellipse by
specifying the focal
points and a direction.
See Figure 32 on page
168 (drawing B).

a. Specify the first
focal point (point 1).

b. Specify the
direction of the
major axis (point 2)

c. Type a numerical
eccentricity value
for the ellipse (for
example, 0.8) in
the user input line
and press ENTER.

Note
The eccentricity
of ellipse is
greater than 0
but less than 1.

d. Type a value for the
major radius (for
example, 15) in the
user input line and
press ENTER.

Figure 31. Ellipse by Center, Angle and Radii
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Figure 32. Ellipses by Focus, Point, Angle

Drawing Hyperbolas
Creo Elements/Direct Drafting allows you to draw hyperbolas in your drawing

using the Hyperbola buttons under Spline in the Draw group on the Drafting
tab.
To draw a hyperbola:

1. Click Drafting and then, in the Draw group, click the arrow next to Spline.
2. Click the required Hyperbola button and perform the associated procedure:
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Hyperbola Button Purpose Procedure

Center, Focus &
Point

Draw a hyperbola using
center, focus, and point.

a. Specify the center of
the hyperbola (point
1).

b. Specify the focus of
the hyperbola (point
2).

c. Specify one end of
the hyperbola (point
3).

The other end point
of the hyperbola is
computed by
symmetry.

See Figure 33 on page
169.

Center, Tangent &
Focus

Draw a hyperbola
tangential to existing
geometry.

a. Specify the center of
the hyperbola (point
1).

b. Click a tangential
point (point 2).

c. Specify the focus of
the hyperbola (point
3).

See Figure 34 on page
170.

Figure 33. Hyperbola by Center, Focus, and End Point
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Figure 34. Hyperbola by Center, Tangent, and Focus

Drawing Parabolas
Creo Elements/Direct Drafting allows you to draw parabolas in your drawing

using the Parabola buttons under Spline in the Draw group on the Drafting tab.
To draw a parabola:

1. Click Drafting and then, in the Draw group, click the arrow next to Spline.
2. Click the required Parabola button and perform the associated procedure:
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Parabola Button Purpose Procedure

Center & Focus
Draw a parabola using
its center and focus.

a. Specify the center of
the parabola (point
1)

b. Specify the focus of
the parabola (point
2)

See Figure 35 on page
171.

Center, Direction &
Point

Draw a parabola in
specific direction.

a. Specify the focus of
the parabola (point
1).

b. Specify the direction
of the parabola
(point 2).

c. Specify the end of
the parabola (point
3). Note that the
other end point of
the parabola is
computed by
symmetry.

See Figure 36 on page
172.

Figure 35. Parabola by Center and Focus
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Figure 36. Parabola by Focus, Direction and End Points

Drawing Points
Creo Elements/Direct Drafting allows you to draw points anywhere on your
drawing.
To draw a point:

1. Click Drafting and then, in the Draw group, click Point.
2. Click the position in a viewport.

or

Type the required coordinates in the user input line and press ENTER.
If you have difficulty deleting points, try enclosing them in a box for deletion.

Drawing Polylines
Creo Elements/Direct Drafting allows you to draw polylines from polygons using

Polyelement.
Polylines facilitate design modifications.
The following example shows some of the differences of working with polyline
elements and non-polyline elements. Drawing A is a standard polygon created by

clicking Polygon under Line in the Draw group on the Drafting tab. To
modify the pensizes of drawing A to produce drawing A1, you need to click
points 1, 2, and 3 (for the purpose of this example, it is assumed that only
individual elements can be clicked).
Drawing B is similar to drawing A but has been converted into a polyline.
Because drawing B is a polyline, it acts like a single element and you need only
click point 4 to modify the complete shape (drawing B1).
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Figure 37. Modifying Polyline and Non-Polyline Elements

The following procedure describes how to draw a polyline from a polygon and
then modify the polyline by changing its pensize and shape.
To draw a polyline:

1. Draw a polygon.

2. Click Drafting and then, in the Draw group, click the arrow next to
Polyelement.

3. Click Create.
4. Click a vertex of the existing polygon.
5. Click a polygon element that ends at the vertex.
6. Click adjacent elements or click the last element.

7. Click OK when the desired shape is defined.
The polygon is now a polyline. To test the polyline, change the pensize.
To change the pensize of the polyline:

1. Select the polyline and right-click.

2. Click Change Geo Penwidth.
3. Type a value (for example, 0.5) in the user input line and press ENTER.
4. Select one element of the polyline.

Note that the complete shape changes except the selected element.
Similarly, you can modify the shape of the polyline.
To change the shape of the polyline:

1. Click Modify and then, in the General group, clear the Keep check box.
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2. In the General group, click More.

3. Click Stretch.

4. Click Free, Horizontal, or Vertical.
5. Click a vertex (or enclose it in a box).
6. Specify the new position of the vertex.

Smashing a Polyline

You can smash the polyline to individual elements using Smash.
To smash the polyline:

1. Click Drafting and then, in the Draw group, click the arrow next to
Polyelement.

2. Click Smash.
3. Select the polyelement.

4. Click OK.

Drawing Equidistant (Parallel) Contours
To draw a contour equidistant to an existing contour:

1. Click Drafting and then, in the Draw group, click Equidistance.
2. Type the separation distance required for the equidistant or parallel contour in

the user input line and press ENTER.
3. Click the start point of the existing contour.
4. Select the elements to be copied (Creo Elements/Direct Drafting allows you to

skip to the final element, provided you do not pass more than one branch
element that is not to be copied).

5. Specify the side on which the equidistant contour is to be drawn.
If you require a particular section of a contour to be copied:

1. Follow steps 1 to 4 above.

2. When you have indicated the desired section, click OK.
3. Specify the side on which the equidistant contour is to be drawn.
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Using Overdraw
Creo Elements/Direct Drafting allows you to draw a contour between intersection

points in the construction geometry using Overdraw. The lines are drawn over
the existing construction lines and circles just as you would line in a contour by
hand.
Additionally, it is not necessary to click each construction geometry intersection
point before clicking the line or arc you want to draw over. You simply click the
next construction geometry element and Creo Elements/Direct Drafting calculates
the intersection point. This saves one click for every overdraw action.

To use Overdraw:

1. Draw the construction geometry as shown in Figure 37 on page 175.

2. Click Drafting and then, in the Draw group, click Overdraw.
3. Specify the start point (1).
4. Specify points 2 to 14 (end point).

Figure 38. Using the Overdraw Command

Overdraw supports multiple Undo operations within the command.

Drawing Construction Geometry
Construction geometry is used for positioning and as an aid to drawing.
This section describes how to draw construction lines and circles, just as you
would normally do when working on a drawing board.
Unlike real lines, construction lines are considered to be of infinite length. Only
full construction circles can be drawn.
When drawing construction lines, you can indicate a point for the line or enter the
exact coordinates via the keyboard.
Enter coordinates using the following format:
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2.5,3

12,4.8

5.35,6.1

The x and y coordinates are separated by a comma. After you type the coordinates
in the user input line, press ENTER.

Drawing Construction Lines
Creo Elements/Direct Drafting allows you to draw construction lines using
Construction Line buttons in the Draw group on the Drafting tab.
To draw construction lines:

1. Click Drafting and then in the Draw group, click the arrow next to 2
Points.

2. Click the required Construction Line button and perform the associated
procedure.

Construction Line
Button

Purpose Procedure

2 Points
Draw construction lines
using two points.

a. Type the angle for
the construction line
in the user input line
and press ENTER.

b. Specify the second
point.

Alternatively, click the
two points for the
construction line.

Horizontal
Draw horizontal
construction lines.

a. Type the y
coordinate of the
horizontal
construction line in
the user input line
and press ENTER.

or

Click a point through
which the horizontal
construction line
must pass.
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Construction Line
Button

Purpose Procedure

b. To draw several
horizontal
construction lines,
type their y
coordinates,
separated by spaces,
in the user input line
and press ENTER.

Vertical
Draw vertical
construction lines.

a. Type the x
coordinate of the
vertical construction
line in the user input
line and press
ENTER.

or

Click a point through
which the vertical
construction line
must pass.

b. To draw several
vertical construction
lines, type their x
coordinates,
separated by spaces,
in the user input line
and press ENTER.

Parallel
Draw construction lines
parallel to an existing
line.

a. Type the separation
distance of the line
in the user input line
and press ENTER.

b. Click any existing
line and then click
the side on which the
parallel construction
line should be
drawn.

Multiple lines can be
drawn at the
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Construction Line
Button

Purpose Procedure

previously set
separation distance
by clicking the
original lines and the
desired sides.

Alternatively:

a. Click any existing
line.

b. Specify a point for
the parallel
construction line to
pass through.

You can draw
multiple parallel
construction lines by
specifying further
points for the lines to
pass through.

Alternatively, draw a set
of parallel lines from an
original line.
For example, if you
specify line separations
as 10 20 30 40, four
parallel lines are drawn
at the given distances
from the indicated line.

Perpendicular
Draw a construction line
perpendicular to an
existing line.

a. Click any existing
line.

b. Specify a point
through which the
perpendicular
construction line
must pass.

Point & Angle
Draw a construction line
at an angle.

a. Specify a point
through which the
construction line
must pass.
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Construction Line
Button

Purpose Procedure

b. Specify a second
point for the
construction line.

or

Type the angle of the
line with respect to
the x axis in the user
input line and press
ENTER.

A positive angle is
measured in a
counterclockwise arc
from the horizontal. You
can set the angle units in
your Creo Elements/
Direct Drafting
environment.

Tangent
Draw a construction line
tangent to a circle or a
spline and passing
through a given point or
at a set angle.

a. Click the
approximate point of
tangency.

b. Type the angle of the
construction line in
the user input line
and press ENTER.

Note
The angle is
measured in a
counterclockwise
arc from the
horizontal.

Alternatively, click the
approximate point of
tangency on the circle or
spline and then specify a
point through which the
construction line must
pass.
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Construction Line
Button

Purpose Procedure

Tangent by 2
Draw a construction line
as a tangent to two
circles or splines.

Click the approximate
point of tangency on
each of the two circles
or splines.
The construction line is
drawn through the points
of tangency that are
closest to the points you
indicated.

Bisector
Draw a bisecting
construction line.

Specify the two end
points of the line.
A construction line is
drawn perpendicular to
the line at the
appropriate position.
To divide the line in two
unequal parts:

a. Type the bisector
factor (value for the
ratio of division) in
the user input line
and press ENTER.

b. Specify first point on
the line.

c. Specify second point
on the line.

Bisector Angle
Draw a construction line
bisecting an angle.

a. Specify the first line.
b. Specify the second

line.

A construction line,
defining the bisector
angle, is drawn.

Drawing Construction Circles
Creo Elements/Direct Drafting allows you to draw construction circles using
Construction Circle buttons in the Draw group on the Drafting tab.
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To draw a construction circle:

1. Click Drafting and then, in the Draw group, click the arrow next to Center
& Radius.

2. Click the required Construction Circle button and perform the associated
procedure.

Construction
Circle Button

Purpose Procedure

Center &
Radius

Draw a construction circle
by center and
circumference point.

a. Specify the center of
the construction line.

b. Type the radius of the
construction circle in
the user input line and
press ENTER.

Alternatively, specify a
point on the
circumference.

If multiple concentric
circles are required,
type the desired radii in
the user input line and
press ENTER or specify
multiple peripheral
points.

3 Points
Draw a construction circle
by three points on the
circumference.

Specify two circumference
points.
The construction circle
drawn varies with the
movement of your cursor
till you specify the third
point.

Tangent &
Center

Draw a construction circle
by a center and element.

a. Click the approximate
point of tangency on the
existing element.

b. Specify the center of
the construction circle
to be drawn.

Concentric
Draw concentric circles. a. Click the existing

circle.
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Construction
Circle Button

Purpose Procedure

b. Type the radial offset of
the new construction
circle from the existing
one, that is, the
difference between the
two radii, in the user
input line and press
ENTER.

c. To draw several
concentric construction
circles, type the
appropriate radial
offsets separated by
spaces in the user input
line and press ENTER.

or

Click existing points
through which the
construction circles
must pass.

Diameter
Draw a construction circle
by diameter.

Specify two points as the
two ends of the diameter
for the required circle.

Tangent & 2
Points

Draw a construction circle
by radius, point (or two
points) and element.

a. Click the approximate
point of tangency of the
construction circle on
the existing element
(which must not be a
spline).

b. Specify a point on the
circumference.

c. Type the required radius
in the user input line
and press ENTER.

or

Specify another point.
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Construction
Circle Button

Purpose Procedure

Tangent by 2
Draw a construction circle
by radius or point and
tangential to two elements.

a. Click the approximate
points of tangency
(either lines or circles
but no splines).

b. Type the desired radius
in the user input line
and press ENTER.

or

Specify a peripheral
point on the
construction circle.

Creo Elements/Direct
Drafting calculates the
best solution, or
informs you that no
solution is possible.

Tangent by 3
Draw a construction circle
by three elements.

Click the approximate point
of tangency of the
construction circle on each
of the three existing
elements (none of which
must be a spline).

Note
If the third tangency
point for a construction
circle is located such
that no circle is tangent
to all the three points,
the first two points
moves along the
projection (notional
extension) of the
associated elements.
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Drawing a Lever Using Construction
Geometry
A tutorial example to familiarize you with the various techniques for creating a
drawing using construction geometry follows.
Figure 39. Lever on page 184 shows the finished drawing of the lever.

Figure 39. Lever

1. Draw horizontal and vertical construction lines. See Figure 40. Horizontal and
Vertical Construction Lines on page 185.

184 Creo Elements/Direct Drafting User's Guide: Fluent User Interface



Figure 40. Horizontal and Vertical Construction Lines

a. In the Utilities group, click Show.

or

Click File ▶ Settings ▶ Show.

The Show dialog box opens.
b. Click the Construction Geometry check box and the Geometry check box.
c. Clear the Vertex check box.
d. Click Close.
e. In the Catch box located at the bottom of Creo Elements/Direct Drafting

window, select ALL.

f. Click Drafting and then, in the Draw group, click the arrow next to 2
Points.

g. Click Horizontal.
h. Type 0,0 in the user input line and press ENTER.

i. Click Drafting and then, in the Draw group, click the arrow next to
Horizontal.

j. Click Vertical.
k. Type 0,0 in the user input line and press ENTER.
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l. Click View and then, in the Viewing group, click Fit.

m. Click OK.
2. Draw some parallel horizontal construction lines. See Figure 41. Parallel

Construction Lines on page 186.

Figure 41. Parallel Construction Lines

a. Click Drafting and then, in the Draw group, click the arrow next to
Vertical.

b. Click Parallel.
c. Type -8 3 40 45 in the user input line and press ENTER.
d. Select the horizontal construction line and then click somewhere above it.

e. Click View and then, in the Viewing group, click Fit.
3. Draw some parallel vertical construction lines. See Figure 42. Parallel Vertical

Lines on page 187.
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Figure 42. Parallel Vertical Lines

a. Type 11 25 130 151 in the user input line and press ENTER.

Note
The command for the parallel construction line is still active.

b. Click the vertical construction line and click a point to the left of it.

c. Click View and then, in the Viewing group, click Fit.
4. Create three viewports in the drawing area. See Figure 43. Three Viewports on

page 188.
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Figure 43. Three Viewports

a. Click View and then, in the Window group, click Delete.
b. Type ALL in the user input line and press ENTER.
c. Click the viewport to delete it.

d. Click View and then, in the Window group, click New.
e. Create viewport 1 as shown above by clicking two opposite corner points

of the viewport.
f. Repeat the earlier two steps to create viewports 2 and 3.

Viewports 1 and 2 give you a closer look at certain areas of your drawing
where you do more complex work. Viewport 3 displays the entire drawing.

g. Click View and then, in the Window group, click Current.
h. Click viewport 1.

i. Click View and then, in the Window group, click New and click two
points in viewport 3 as defined by the rectangle on the left.

j. Click View and then, in the Window group, click Current.
k. Click viewport 2.
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l. Click View and then, in the Window group, click New and click two
points in viewport 3 as defined by the rectangle on the right.

5. Now create some construction circles. See Figure 44. Construction Circles on
page 189.

Figure 44. Construction Circles

a. In the Catch box located at the bottom of Creo Elements/Direct Drafting
window, select ALL.

b. Draw construction circle C1.

i. Click Drafting and then, in the Draw group, click the arrow next to
Center & Radius.

ii. Click Center & Radius.
iii. Click the center point and lower circumference point (in viewport 3).

c. Draw construction circle C2.

i. Click Drafting and then, in the Draw group, click the arrow next to
Center & Radius.

ii. Click Center & Radius.
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iii. Click the center point, type 12 in the user input line, and press ENTER
(in viewport 2).

d. Draw construction circle C3.

i. Click Drafting and then, in the Draw group, click the arrow next to
Center & Radius.

ii. Click Center & Radius.
iii. Click the center point, type 17 in the user input line, and press ENTER

(in viewport 2).
e. Draw construction circle C4.

i. Click Drafting and then, in the Draw group, click the arrow next to
Center & Radius.

ii. Click Center & Radius.
iii. Click the center point, type 8in the user input line, and press ENTER

(in viewport 1).
f. Draw construction circle C5.

i. Click Drafting and then, in the Draw group, click the arrow next to
Center & Radius.

ii. Click Tangent by 2.
iii. Click the two tangent points, type 3 in the user input line, and press

ENTER (in viewport 1).
g. Draw construction circle C6.

i. Click Drafting and then, in the Draw group, click the arrow next to
Tangent by 2.

ii. Click Tangent by 2.
iii. Click the two tangent points, type 43 in the user input line, and press

ENTER (in viewport 1).
h. Draw construction circle C7.

i. Click Drafting and then, in the Draw group, click the arrow next to
Tangent by 2.

ii. Click Tangent by 2.
iii. Click the two tangent points, type 10.5 in the user input line, and

press ENTER (in viewport 2).
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i. Draw construction circle C8.

i. Click Drafting and then, in the Draw group, click the arrow next to
Tangent by 2.

ii. Click Tangent & 2 Points.
iii. Click the tangent point on C7 and the center point of C4.
iv. Type 246 in the user input line and press ENTER (in viewport 3).

j. Draw construction circle C9.

i. Click Drafting and then, in the Draw group, click the arrow next to
Tangent & 2 Points.

ii. Click Tangent by 2.
iii. Click the two tangent points, type 8 in the user input line, and press

ENTER (in viewport 3).
6. Draw a construction line tangent to C1 and C3. See Figure 45. Construction

Line Tangent on page 191.

Figure 45. Construction Line Tangent

a. Click Drafting and then in the Draw group, click the arrow next to 2
Points.
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b. Click Tangent by 2.
c. Click the tangent points on C1 and C3 (in viewport 3).

7. Click Overdraw to draw the lever itself. See Figure 46. Drawing the Lever
on page 192.

Figure 46. Drawing the Lever

a. Click Drafting and then, in the Draw group, click Overdraw.
b. Click point 11/1 as the start point.
c. Click a point on element 1 and click point 1/2.
d. Click a point on element 2 and click point 2/3.
e. Click a point on element 3 and click point 3/4.
f. Click a point on element 4 and click point 4/5.
g. Click a point on element 5 and click point 5/6.
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Note
When drawing the arc on C9, ensure that the cursor is nearer to C9
than to any other line. If you make a mistake, click Drafting and then,

in the Draw group, click Overdraw and zoom-in on the area by

clicking New in the Windows group on the View tab.

h. Continue the same procedure for elements 6, 7, 8, 9, 10, and 11.

Specifying an Offset
Creo Elements/Direct Drafting allows you to specify an offset distance for the
following geometrical elements:

• Lines
• Rectangles
• Circles
• Arcs
• Points
• Construction lines
• Construction circles
You can also specify an offset while modifying the geometrical elements. The
offset distance is defined as the distance of the geometrical element from two
existing linear elements.

You can use (Offset) on the status bar to define the offset. is disabled by
default. It is active when you use following buttons:

• Line buttons ( Polygon, 2 Points, Horizontal, Vertical,

Parallel, Perpendicular, Angle & Length, Tangent, or Tangent
by 2)

• Rectangle

• Circle buttons ( Center & Radius, 3 Points, Concentric,

Diameter, or Tangent)
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• Arc buttons ( 3 Points, Center & 2 Points, Center, Radius & 2

Points, Concentric, Point, Radius & Angle, Diameter, or
Smooth)

• Point

• Construction Line buttons ( 2 Points, Horizontal, Vertical,

Parallel, Perpendicular, Point & Angle, Tangent, Tangent by

2, Bisector, or Bisector Angle)

• Construction Circle buttons ( Center & Radius, 3 Points, Tangent

& Center, Concentric, Diameter, Tangent & 2 Points, Tangent

by 2, or Tangent by 3)

• Move buttons ( 2 Pnts, Horizontal, Vertical, or Multiple)

is disabled after you finish the above operations.

Note

To use , you must enable Copilot in Creo Elements/Direct Drafting. See
Enabling or Disabling the Copilot Functionality on page 140 for more
information.

To define an offset for geometrical elements in Creo Elements/Direct Drafting:

1. Click the required button (for example, 2 Points in the Draw group on the
Drafting tab).

2. In the status bar, click .
3. Select the first offset element.
4. Type the distance from the first offset element in the user input line and press

ENTER.
5. Click a point on one side of the first offset element to indicate the positive

side.
6. Select the second offset element.
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7. Type the distance from the second offset element in the user input line and
press ENTER.

8. Click a point on one side of the second offset element to indicate the positive
side.

The offset point thus defined serves as the current definition point (such as the
begin point or end point) of the geometrical element.

9. Complete the operation.

10. Click OK.
Alternatively:

1. Click the required button (for example, 2 Points in the Draw group on the
Drafting tab).

2. In the status bar, click .
3. Select the first offset element.
4. Select the second offset element.
5. Click between the two elements to specify the offset point.
6. Complete the operation.

7. Click OK.

After you click OK, Creo Elements/Direct Drafting ends and it is no

longer active in the status bar. also ends if you click Cancel.

Drawing Fillets
Creo Elements/Direct Drafting allows you to draw fillets in your drawing using

Fillet.
To draw a fillet:

1. Click Drafting and then, in the Engineering group, click the arrow next to
Fillet.

2. Click Radius.
3. Type the radius in the user input line and press ENTER.
4. Click the two elements between which the fillet should be drawn, or click the

vertex.
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The fillet radius is drawn and by default the corner point is deleted. If you do
not want the corner to be deleted, click the Keep Corner check box before
clicking the elements or vertex.

Changing Fillets
To change fillet radii:

1. Click Drafting and then, in the Engineering group, click the arrow next to
Fillet.

2. Click Modify.
3. Type the fillet radius in the user input line and press ENTER.

Note
To remove all fillets, type 0 in the user input line and press ENTER.

4. Select the fillet or enclose it in a box.

To select all fillets, click Select ▶ All in the Utilities group. Then click

Confirm.

Tip
If fly-by highlighting is enabled, Creo Elements/Direct Drafting highlights the
fillets when you hover over them. You can use the CMT and the context menu
to modify the general properties of a fillet (for example, to change the color, to
change the line type, or to move the fillet) after you select it.

For more information about fly-by highlighting, CMT, and the context menu,
see Fly By Highlighting on page 26, Command Mini Toolbar on page 52, and
Context MenuContext Menu Commands on page 55.

Drawing Chamfers
Creo Elements/Direct Drafting allows you to draw and modify chamfers in your

drawing using Chamfer.
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By default, the corner is deleted after the chamfer is drawn. If you do not want the
corner to be deleted, click the Keep Corner check box in the Engineering group on

the Drafting tab before you choose a Chamfer button.
To draw a chamfer:

1. Click Drafting and then, in the Engineering group, click the arrow next to
Chamfer.

2. Click the required Chamfer button and perform the associated procedure.

Chamfer Button Purpose Procedure

Vertex
Draw a chamfer at a
given distance from the
vertex along each line.

a. Type the distance of
the chamfer from the
vertex in the user
input line and press
ENTER.

b. Click the vertex (the
point where the two
lines intersect).

2 Points
Draw a chamfer by two
points.

Click the start point and
end point of the chamfer.
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Chamfer Button Purpose Procedure

Dist. Dist.
Draw a chamfer by
specifying two different
distances.

a. Type the distance to
chamfer along the
first element in the
user input line and
press ENTER.

b. Type the distance to
chamfer along the
second element in
the user input line
and press ENTER.

c. Click the first
element.

d. Click the second
element.

Dist. Ang.
Draw a chamfer at a
given angle to the first
line and at a given
distance from the vertex.

a. Type the distance to
chamfer along the
first element in the
user input line and
press ENTER.

b. Type the angle
between the chamfer
and the first element
in the user input line
and press ENTER.

c. Click the first
element.

d. Click the second
element.

Changing Chamfers
To change a chamfer:

1. Click Drafting and then, in the Engineering group, click the arrow next to
Chamfer.

2. Click Modify.
3. Type the revised chamfer distance in the user input line and press ENTER.
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4. Select the chamfer.

Drawing a Centerline
Creo Elements/Direct Drafting allows you to draw a centerline for a circular

element using Center Line.
The centerline becomes part of the circular element and is moved or deleted if the
associated circular element is moved or deleted.
Figure 47 on page 199 shows the top circles before and after adding a centerline.
The different appearance of the centerlines is done by changing absolute and
relative values. Refer to the online help on how to do this (help centerline).

Figure 47. Creating a Centerline

When you dimension centerlines and then make a modification, the dimension is
automatically updated. When asked to click the first element, click the center
point of the circle (use Catch Center).
To draw a centerline:

1. Click Drafting and then, in the Annotate group, click the arrow next to
Center Line.

2. Click the required Center Line button and perform the associated procedure.
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Center Line
Button

Purpose Procedure

Create
Create a centerline. Click the circle.

See Figure 47 on page 199.

Slot Single
Create single slot
centerlines.

Specify a circular element of a
slot.
Creo Elements/Direct Drafting
draws the single slot centerlines.

Slot Double
Create double slot
centerlines.

Specify a circular element of a
slot.
Creo Elements/Direct Drafting
draws the double slot
centerlines.

Limitations of slot centerlines:
• Slot centerlines can be created only between two 180 degree arcs.
• The start and end points of the two arcs must be on a line that is perpendicular

to the line connecting the center points of the arcs. After the center lines are
created, you can modify the slot element.

Changing Position of Centerlines
To change the position of centerline:

1. Click Modify and then, in the Annotate group, click the arrow next to Cen
Line.

2. Click Modify.
3. Select an end of the centerline.
4. Specify the new position of the centerline.
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Figure 48. Effect of Changing the Position

Creating Symmetric Elements
Creo Elements/Direct Drafting allows you to use Symmetry Line for creating
elements that are:

• Symmetric with existing elements
• Associated (or anchored) to the defining elements.
When you modify the defining elements, the associated element is modified
accordingly.
To draw an associated element:

1. Draw a polygon similar to that shown in Figure 49 on page 202.
2. Create circle 1 having diameter 1 mm.
3. Create circle 2 having diameter 3 mm.

4. Click Drafting and then, in the Annotate group, click Symmetry Line.
5. Click circle at point 1.
6. Click circle at point 2.
Creo Elements/Direct Drafting draws the associated circle (point 3) that is:

• Midway between circles 1 and 2.
• 2 mm in diameter (half the sum of the defining diameters).
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Figure 49. Associated Symmetric Elements

To change the extension of the symmetry line:

1. Click Modify and then, in the Annotate group, click Sym Line.
2. Select the end of the symmetry line and then select the new end position of the

symmetry line.
To change the position of the symmetry line, move the circular or linear elements
to which the symmetry line is associative. So try moving the circle at position 2
and notice how the associated element also moves.

Figure 50. Effect of Moving the Defining Circle

Figure 51. Finding Lines of Symmetry on page 202 shows another example of

where to use Symmetry Line.

Figure 51. Finding Lines of Symmetry
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Drawing the Projected Reference Point
The "projected reference point" is the point at which the extended traces of two
existing elements (line-line, line-arc, and arc-arc) would meet. To draw this point
in your drawing:

1. Click Drafting and then, in the Annotate group, click More.

2. Under Projected Reference Point, click New.
3. Click the first element.
4. Click the second element.
The point where the traces of the two elements meet is now visible in your
drawing.
When one or both the elements are arcs, the intersection point that is closest to
both the elements is the projected reference point.
Note that this reference point (plus the associated traces) are fully associative:

• These items can be included in dimensions.
• These items are preserved even when you perform Modify operations.

Note
You cannot have projected reference points across parts.

Figure 43 on page 203 shows an example of a projected reference point.

Figure 52. Projected Reference Point

Changing the Settings of the Projected Reference
Point
To change the settings of the projected reference point and its associated elements:
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1. Click File ▶ Settings ▶ Projected Reference Points.

The Projected Reference Point Settings dialog box opens.
2. Specify the type, color, width, length, radius, and Show options for the

projected reference point.

Further Information
For further technical information about drawing methods, refer to the Creo
Elements/Direct Drafting help system.
Type the following in the Creo Elements/Direct Drafting user input line and press
ENTER:

• help line

• help circle

• help arc

• help ellipse

• help hyperbola

• help parabola

• help point

• help polyelem

• help equidistance

• help overdraw

• help c_line

• help c_circle

• help fillet

• help chamfer

• help centerline

• help symline

• help prp

Creo Elements/Direct Drafting displays further information about drawing
methods.
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This chapter describes how to use the buttons and options that allow you to
reposition or alter your drawing.
You can modify single drawing elements (for example, lines and circles) or
enclose the elements you want to modify in a box.

205



For a description of the Picture command, see Importing a Picture File on page
544.
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Keeping or Removing the Original
Elements
For all the buttons in the General group on the Modify tab, (except Isometric),
you can click or clear the Keep check box on the Modify tab. This determines
whether the original drawing elements are kept or deleted after the modification.

For example, using Move (with the Keep check box clicked) copies the
drawing elements rather than just moving them. By default, the Keep check box is
cleared.

Note
You can also click or clear the Keep check box when any button in the General
group on the Modify tab is active.

Repeating a Modification
You can use the Repeat check box to repeat a modification a given number of
times. For example, by clicking the Repeat check box and specifying a repeat
factor of 5, you can perform the same Move operation five times.

Note
You can also click or clear the Repeat check box when any button in the
General group on the Modify tab is active.

Modifying Using Selection
The Selection mechanism described in Commonly Used Commands on page 72

can also be used with all the buttons on the Modify tab (except Isometric and

Stretch).

Using Select provides various ways to select elements to be modified and
view them highlighted on the screen before the modification is made.

To use Select with Modify tab:
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1. Click the required modification button (for example, in the General group,

click Move ▶ Horizontal) on the Modify tab.

2. In the Utilities group, click Select.
3. Click Advanced.

The Select dialog box opens.

Alternatively, press F2 to open the Select dialog box.
4. Select the elements to be modified using the buttons available in the Select

dialog box. For example, you can click Circle, then All, and then OK in the
Select dialog box to perform the same modification on all circles.

Note
Each time you select elements for modification, you can decide whether you
want to select:

• From the current part only (this is the default)
or

• From the entire parts tree (by clicking Select ▶ Global ).

Refer to Handling Parts and Assemblies on page 429 for details on handling
parts and assemblies.

Changing the Number of Elements in the
Visual Feedback
You can change the number of elements displayed in the visual feedback during a
Modify operation. For example, you may want to unclutter the screen during a
Move of a complex assembly.

1. Click File ▶ Settings ▶ System.

The System dialog box opens.
2. In the Environment settings, type the required number of elements in the Max

feedback box.
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Moving Elements
Creo Elements/Direct Drafting allows you to move or copy elements to another

position using the Handles or the various Move buttons.
To move an element with the handles:

1. Click an element in the drawing area.

The handles appear.
2. Click the element again and drag it to the new position.
To move multiple elements with handles:

1. Press SHIFT and click all the elements in the drawing area.

The handles appear.
2. Release SHIFT and click one of the elements again.
3. Drag the elements to a new location.

Click the Move buttons to move or copy drawing elements to another
position.

Note
Creo Elements/Direct Drafting shows a visual feedback that realistically
changes when you drag a geometry.

Click the Move buttons with the Keep check box clicked to produce a copy.
The original remains unchanged.
Click the Repeat check box, type a repeat factor in the user input line and press
ENTER. This repeats the next operation the specified number of times.

To move an element using Move:

1. Click Modify and then, in the General group, click the arrow next to Move.
2. Click the required Move button and perform the associated procedure.
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Move Button Purpose Procedure

2 Points
Move or copy a drawing
element or elements
using a reference point

a. Select the element or
elements to be
moved.

b. To define the move
vector, specify a
reference point and
then a destination
point.

You can click any
two points to define
a move vector.

Creo Elements/
Direct Drafting
moves the element
or elements to the
new position.

Horizontal
Move or copy a drawing
element or elements to a
new position in the
horizontal direction.

a. Select the element or
elements to be
moved.

b. Type the required
horizontal distance
in the user input line
and press ENTER.

or

Specify a reference
point and then a
destination point to
define the horizontal
distance.

If a repeat factor has
been specified, the
same horizontal
distance will be
taken for each move
or copy.
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Move Button Purpose Procedure

Note
You can interrupt the
command with the

Length or
Distance button if
the required distance
can be measured
from existing
features on the
drawing.
Alternatively, you
can specify two
points defining the
horizontal distance
required.

Vertical
Move or copy a drawing
element or elements to a
new position in the
vertical direction.

a. Select the element or
elements to be
moved.

b. Type the required
vertical distance in
the user input line
and press ENTER.

or

Specify a reference
point and then a
destination point to
define the vertical
distance.

If a repeat factor has
been specified, the
same vertical
distance will be
taken for each move
or copy.
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Move Button Purpose Procedure

Multiple
Interactively move or
copy a drawing element
or elements to any
number of new
positions.

a. Select the element or
elements to be
moved.

b. Specify a reference
point for the move.

c. Specify the
destination point for
the move.

The selected element
or elements moves o
the new position
defined by these two
points.

d. Specify as many
further destination
points as required.

e. Terminate the move
or copy by clicking
another button,
another option, or

OK.

Rotating Drawings
Creo Elements/Direct Drafting allows you to rotate elements using Rotate.
Elements can be rotated:

• About a Center

Center is especially useful when combined with a Repeat factor for
repeated rotation. The flywheel shown in Figure 57. Flywheel on page 213
was drawn by rotating the holes with a repeat factor of 5.
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Figure 57. Flywheel

• By Reference point ( 2 Points)
Both of these methods can be used with the Keep check box clicked or cleared on
the Modify tab.
To rotate a drawing:

1. Click Modify and then, in the General group, click Rotate.
2. Click the required Rotate button and perform the associated procedure.
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Rotate Button Purpose Procedure

Center
Rotate a drawing or
drawing element about a
center.

a. Specify the center of
rotation.

b. Type the angle of
rotation in the user
input line and press
ENTER.

or

Define the angle by
specifying two
points.

A positive angle
results in a
counterclockwise
rotation.

c. Select the element or
elements to be
rotated.

2 Points
Rotate a drawing or
drawing element using a
reference point.

a. Specify a rotation
reference point on
the drawing or
element.

b. Specify the
destination for the
rotation reference
point.

c. Type the angle of
rotation in the user
input line and press
ENTER.

or

Define the angle by
specifying two
points.
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Rotate Button Purpose Procedure
A positive angle
results in a
counterclockwise
rotation.

d. Select the element or
elements to be
rotated.

Mirroring
Creo Elements/Direct allows you to mirror a drawing using Mirror.
To save time when drawing symmetrical shapes, you can mirror them about a line
of symmetry.

On the Modify tab, Mirror is usually used with the Keep check box clicked.
The repeat factor is set to 1. Wait until your drawing is nearly complete before
mirroring, otherwise you may miss a feature and have to draw it in both halves.
To mirror a drawing:

1. Click Modify and then, in the General group, click Mirror.
2. Click the required Mirror button and perform the associated procedure.

Mirror Button Purpose Procedure

2 Points
Mirror a drawing about
two points.

a. Specify two points to
define the line of
symmetry.

b. Select the elements
to be mirrored.

The line of symmetry in
Figure 58 on page 216 is
the dashed line.

Horizontal
Mirror a drawing about
a horizontal line.

a. Specify a point on
the horizontal line of
symmetry.

b. Select the elements
to be mirrored.
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Mirror Button Purpose Procedure

Vertical
Mirror a drawing about
a vertical drawing.

a. Specify a point on
the vertical line of
symmetry.

b. Select the elements
to be mirrored.

Center
Rotate a drawing
through 180 degrees.

a. Specify the center
point of rotation.

b. Select the elements
to be mirrored.

The elements are
rotated 180 degrees
in a clockwise
direction.

Figure 58. Line of Symmetry

Making Elements Larger or Smaller
Creo Elements/Direct Drafting allows you to make drawing elements and text

larger or smaller using Scale. Note that dimensions will be changed
accordingly. If you want to keep the original drawing elements, click the Keep
check box on the Modify tab.
To scale your drawing:

1. Click Modify and then, in the General group, click the arrow next to Scale.
2. Click the required Scale button and perform the associated procedure.
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Scale Button Purpose Procedure

Center
Scale a drawing by
center.

a. Specify the center
for the scaling
operation.

b. Type a scale factor.

or

Specify two points to
define the scale
factor.

c. Select the elements
to be scaled.

When drawing elements
are scaled using Center,
one point on the drawing
remains fixed.

2 Points
Scale your drawing
using a reference point.

a. Specify a reference
point and then
specify the new
position for this
point.

b. Type a scale factor.

or

Specify two points to
define the scale
factor.

c. Select the elements
to be scaled.

The selected
elements are moved
and scaled.

Drawing Similar Elements
Similar is a combination of Move, Rotate and Scale. It allows

you to fit specified drawing elements between two given points. This involves
rescaling.

Modifying a Drawing 217



To fit a specified drawing element between two given points:

1. Click Modify and then, in the General group, click More.

2. Click Similar.
3. Specify two reference points on the drawing.
4. Specify two destination points for those reference points.
5. Select the elements of which you want to create a similar copy. These drawing

elements will then be scaled to fit the new position. Figure 59 on page 218
shows an example.

Figure 59. Fitting Drawing Elements Between Two Points

Creating a Parallel Perspective (Oblique)
View
Creo Elements/Direct Drafting allows you to create a parallel perspective view

using Transform.
Parallel perspective means that three view points for the perspective view are
taken to be at infinity, and parallel lines will therefore remain parallel.

Example
Figure 60 on page 219 shows an oblique view created by copying the end

elevation, then the side and top created by Transform.

Points used for the first Transform operation are shown.
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Figure 60. Creating an Oblique View

Position the End View

1. Click Modify and then, in the General group, click the arrow next to Move.

2. Click 2 Points.
3. Specify a reference point on the drawing (end view).
4. Specify a destination point.
5. Select the end view (marked by an upside-down L in Figure 60 on page 219).

Position the Side View
1. Click Modify and then, in the General group, click More.

2. Click Transform.
3. Click three reference points on the drawing (1, 2, and 3).
4. Click three destination points (1', 2', and 3') to which the three reference points

will be mapped in the parallel perspective view.
5. Select the side view (marked by a circle in Figure 60 on page 219).

Position the Top View
1. Click Modify and then, in the General group, click More.

2. Click Transform.
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3. Click three reference points on the drawing.
4. Click three destination points to which the three reference points will be

mapped in the parallel perspective view.
5. Select the top view (marked by a rectangle in Figure 60 on page 219).

Stretching a Drawing
Creo Elements/Direct Drafting allows you to alter the shape of your drawing by

stretching it in a certain direction using Stretch. All the dimensioning,
hatching, and finishing information will be modified to fit the new stretched
shape.

Example

The following example demonstrates the use of Stretch. See Figure 61 on
page 220.

Figure 61. Stretching a Drawing

1. Click Modify and then, in the General group, clear the Keep check box.
2. In the General group, click More.

3. Click Stretch and then click the required button.
4. Specify a reference point on the drawing.
5. Specify a destination point.
6. Select the elements to be stretched.

You can select the elements by clicking a single vertex or enclosing several
elements in a box (the vertex is moved and the element is stretched
accordingly).

Alternatively, you can preselect the elements that you want to stretch. In the
preselection mode, the elements are stretched after you specify a reference
point and a destination point.
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You can combine stretching with any of the other Modify buttons (except
Isometric).
To stretch a drawing:

1. Click Modify and then, in the General group, clear the Keep check box.
2. In the General group, click More.

3. Click Stretch.

4. Click the required Stretch button and perform the associated procedure.

Stretch Button Purpose Procedure

Free
Stretch drawing
elements in an arbitrary
direction.

a. Select the drawing
elements to be
stretched.

b. Specify a reference
point and a
destination point for
the stretch operation.

Horizontal
Stretch the drawing
horizontally.

a. Select the drawing
elements to be
stretched.

b. Type a horizontal
distance in the user
input line and press
ENTER.

or

Specify a reference
point and a
destination point for
the horizontal
distance.

Vertical
Stretch the drawing
vertically.

a. Select the drawing
elements to be
stretched.

b. Type a vertical
distance in the user
input line and press
ENTER.
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Stretch Button Purpose Procedure
or

Specify a reference
point and a
destination point for
the vertical distance.
Note
You can interrupt the
command by

clicking the
Length button, if the
distance you need
can be measured
from existing
features on the
drawing.

Creating an Isometric View
To draw an approximate isometric view of a three-dimensional object, you must
have drawn the front, side, and top views already.
The following example shows how to create an isometric view. Refer to Figure 62.
Creating an Isometric View on page 222.

Figure 62. Creating an Isometric View

1. Click Modify and then, in the General group, click More.

2. Click Isometric.
3. Select the front view by enclosing it in a box.
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4. Click a reference point on the front view.
5. Specify the destination for the front view reference point.
6. Select the side view by enclosing it in a box.
7. Click a reference point on the side view.
8. Specify the destination for the side view reference point.
9. Select the top view by enclosing it in a box.
10. Click a reference point on the top view.
11. Specify the destination for the top view reference point.

Modifying Splines
Creo Elements/Direct Drafting allows you to specify the order of spline and
modify the interpolation and control splines.

Specifying the Order of a Spline
The spline order controls the smoothness of the curve. The higher the order, the
smoother the spline. Figure 63. Spline Order on page 223 shows two splines
drawn through the same control points.

Figure 63. Spline Order

Be sure to specify the order of the spline before you specify the last interpolation
point (for interpolation splines) or control point (for control splines) for the spline.
Creo Elements/Direct Drafting allows you to change the order of the splines using

Order while creating splines (see Drawing Splines on page 161).
To change the order of the interpolation spline:

1. Click Modify and then, in the Draw group, click the arrow next to Interpol.

2. Under Modify General click Order.
3. Type the order of the spline in the user input line and press ENTER.
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To change the order of the control spline:

1. Click Modify and then, in the Draw group, click the arrow next to Control.

2. Under Modify General, click Order.
3. Type the order of the spline in the user input line and press ENTER.

Appending an Interpolation Spline
To append an interpolation spline to existing geometry:

1. Click Modify and then, in the Draw group, click the arrow next to Interpol.

2. Under Modify General, click Append.
3. Click the end point of the line to which you want to append an interpolation

spline.
4. Specify a sequence of points.

5. Click OK.
To append the begin-point and end-point of an interpolation spline:

1. Click Modify and then, in the Draw group, click the arrow next to Interpol.

2. Under Modify General, click Append.
3. Specify point A and a series of points B1, B2, B3, till Bn.

4. Click Append.
5. Specify point C.

6. Click OK.

Figure 64. Appending an Interpolation Spline
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Specifying the Slope of an Interpolation Spline

While drawing an interpolation spline using Interpolation (see Drawing a
Spline on page 162), you can specify the slope angle at which the interpolation

spline leaves or approaches the current interpolation point using Tangent.
To specify the slope angle at which the interpolation spline leaves or approaches
the current interpolation point:

1. Define the first interpolation points (such as point A in Figure 65. Specifying
the Slope of an Interpolation Spline on page 225) when creating or appending
an interpolation spline.

2. Click Modify and then, in the Draw group, click the arrow next to Interpol.

3. Under Modify General, click Tangent

4. Type in the slope angle (for example 70) and press ENTER.

Alternatively, you can specify a point at the required angle, for example, point
C.

5. Specify the second point (B in Figure 65. Specifying the Slope of an
Interpolation Spline on page 225).

6. Click OK.

Figure 65. Specifying the Slope of an Interpolation Spline

By specifying a slope at a given interpolation point, you add a tangency condition
to the spline. This tangency condition can be modified or deleted
Figure 66. Effects of Different Slope Angles on page 226 shows the effects of
specifying different slope angles:
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Figure 66. Effects of Different Slope Angles

Being able to specify the slope of a spline is useful when joining unequal
diameters. The following diagram shows the difference between curves created

with Append (curve CD) and Tangent (curve AB).

Figure 67. Slope of Interpolation Splines

To draw curve C to D, do the following:

1. Click Modify and then, in the Draw group, click the arrow next to Interpol.

2. Under Modify General, click Append.
3. Click point C.

4. Click the arrow next to Interpol.
5. Click point D.

6. Click OK.
To draw the lower curve A to B, do the following:

1. Click Drafting and then, in the Draw group, click the arrow next to Spline.

2. Click Interpolation.
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3. Click point A.

4. Click Modify and then, in the Draw group, click the arrow next to Interpol.

5. Under Modify General, click Tangent.
6. Type 5 in the user input line and press ENTER.
7. Click point B.

8. Click Modify and then, in the Draw group, click the arrow next to Interpol.

9. Under Modify General, click Tangent.
10. Type 20 in the user input line and press ENTER.

11. Click OK.

Modifying Interpolation Points
Creo Elements/Direct Drafting allows you to modify the interpolation points using

Modify Point buttons under Interpol in the Draw group on the Modify tab.

Adding an Interpolation Point
To add an interpolation point to an interpolation spline:

1. Click Modify and then, in the Draw group, click the arrow next to Interpol.

2. Under Modify Point, click Add.
3. Click the spline to which you want to add an interpolation point.
4. Click the position on the spline where you want to add the interpolation point.
When you add an interpolation point, the shape of the spline changes accordingly.

Moving an Interpolation Point
To change the position of an interpolation point of a spline:

1. Click Modify and then, in the Draw group, click the arrow next to Interpol.

2. Under Modify Point, click Change.
3. Click the spline you want to modify.
4. Click the interpolation point you want to move.
5. Click the new position of the interpolation point.
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When you move an interpolation point, other interpolation points also move. The
shape of the spline changes accordingly.

Deleting an Interpolation Point
To delete an interpolation point of a spline:

1. Click Modify and then, in the Draw group, click the arrow next to Interpol.

2. Under Modify Point, click Delete.
3. Click the spline you want to modify.
4. Click the interpolation point you want to delete.
When you delete an interpolation point, the shape of the spline adjusts to the
positions of the remaining interpolation points.

Changing the Spline Shape by Moving an Interpolation
Point
To change the shape of an interpolation spline by moving one of its interpolation
points:

1. Click Modify and then, in the Draw group, click the arrow next to Interpol.

2. Under Modify Point, click Shape.
3. Click the spline you want to modify.
4. Click the interpolation point you want to move.
5. Specify the new position of this interpolation point.
When you move an interpolation point, the shape of the spline changes
accordingly.

Changing the Slope of an Interpolation Spline
Creo Elements/Direct Drafting allows you to change the slope of an interpolation

spline using Modify Tangential buttons under Interpol in the Draw group on the
Modify tab.

Changing the Slope at an Interpolation Point
You can change the spline slope at any interpolation point without moving
interpolation points. The spline slope defines the angle at which a spline
approaches an interpolation point. This is useful if you are merging a spline with
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another line. Figure 68. Effect of Changing the Slope at an Interpolation Point on
page 229 shows a simple spline and the same spline with the tangent of
interpolation point A changed.

Figure 68. Effect of Changing the Slope at an Interpolation Point

To change the spline slope at an interpolation point:

1. Click the Vertex check box in the Show dialog box.

The interpolation points and any points where you changed the spline slope
are displayed.

2. Click Modify and then, in the Draw group, click the arrow next to Interpol.

3. Under Modify Tangential, click Add.
4. Click the interpolation spline.
5. Click an interpolation point of the spline.

Creo Elements/Direct Drafting displays an arrow to indicate the spline slope at
that point.

6. Type the required slope angle (for example, 70) and press ENTER.

Alternatively, you can specify a point at the required angle.
The spline slope at other interpolation points changes accordingly. However, the
interpolation points do not move.

Changing the Slope at Any Point on an Interpolation Spline
You can change the spline slope at any point on the interpolation spline. This
operation will move the interpolation points of the spline.
To change the spline slope at any point on the spline:

1. Click Modify and then, in the Draw group, click the arrow next to Interpol.

2. Under Modify Tangential, click Change.
3. Click the interpolation spline.
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4. Click an interpolation point of the spline.

Creo Elements/Direct Drafting displays an arrow to indicate the spline slope at
that point.

5. Type the required slope angle (for example, 70) and press ENTER.

Alternatively, you can specify a point at the required angle.
The interpolation points of the spline move to new positions. The spline slope at
the interpolation points changes accordingly.

Deleting a Tangency Condition of an Interpolation Spline
You can undo any spline slope change (see Specifying the Slope of an
Interpolation Spline on page 225, Changing the Slope at an Interpolation Point on
page 228, and Changing the Slope at Any Point on an Interpolation Spline on page
229) by deleting the associated tangency condition.
To delete a tangency condition:

1. Click the Vertex check box in the Show dialog box.

The interpolation points and any points where you changed the spline slope
are displayed.

2. Click Modify and then, in the Draw group, click the arrow next to Interpol.

3. Under Modify Tangential, click Delete.
4. Click the spline.
5. Click the point where you defined or changed the slope angle.
The spline returns to the shape it had before you defined or specified a slope angle
at a given point on the spline.

Changing the Shape of an Interpolation Spline
You can change the shape of an interpolation spline without moving any of its
interpolation points.
To change the shape of an interpolation spline:

1. Click Modify and then, in the Draw group, click the arrow next to Interpol.

2. Under Modify Tangential, click Shape.
3. Click the spline.
4. Click the interpolation at which you want to change the spline slope in order to

change the shape of the spline.
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Note that the shape of the spline changes but none of its interpolation points are
moved.

Modifying Control Points
Creo Elements/Direct Drafting allows you to modify the size and shape of control

spines by modifying its control points using Modify Point buttons under
Control on the Draw group of Modify tab.

Adding a Control Point
To add a control point to a control spline:

1. Click Modify and then in the Draw group, click the arrow next to Control.

2. Under Modify Point, click Add.
3. Click the spline you want to modify.
4. Click a position between two existing control points.
5. Move the cursor to the position where you want to add the new control point.
6. Click to add the new control point.
When you add a control point, the shape of the spline changes accordingly.

Moving a Control Point
To change the position of a control point of a spline:

1. Click Modify and then in the Draw group, click the arrow next to Control.

2. Under Modify Point, click Change.
3. Click the spline you want to modify.
4. Click the control point you want to move.
5. Click the new position of the control point.
When you move a control point, the shape of the spline changes accordingly.

Deleting a Control Point
To delete a control point of a control spline:

1. Click Modify and then in the Draw group, click the arrow next to Control.

2. Under Modify Point, click Delete.
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3. Click the spline you want to modify.
4. Click the control point you want to delete.
When you delete a control point, the shape of the spline changes accordingly.

Changing the Shape of a Control Spline
You can change the shape of a control spline by moving one or multiple control
points.
To change the shape of a control spline:

1. Click Modify and then in the Draw group, click the arrow next to Control.

2. Under Modify Point, click Shape.
3. Click the spline.
4. Click the control point you want to move in order to change the shape of the

spline.
Note that the shape of the spline changes when you move one of its control points.

Changing the Slope at a Point on the Control Spline
Creo Elements/Direct Drafting allows you to change the spline slope at any point

on the control spline using Modify Tangential button under Control in the Draw
group on the Modify tab. This operation moves the control points of the spline.
To change the spline slope at any point on the spline:

1. Click Modify and then, in the Draw group, click the arrow next to Control.

2. Under Modify Tangential click Change.
3. Click the control spline.
4. Click any point on the spline. Creo Elements/Direct Drafting displays an

arrow to indicate the spline slope at that point.
5. Type in the required slope angle (for example 70) in the user input line and

press ENTER.

Alternatively, you can specify a point at the required angle.
The spline slope changes accordingly. The control points of the spline move to
new positions.
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Example — Cam Profile
An example describing how to create a cam profile and then modify it follows:
Construct the following geometry (see Figure 69. Cam Profile - 1 on page 233):

• Horizontal and vertical lines at 0 0
• Circles at 35 40 45
• Lines at angles 30 60 120 150

Figure 69. Cam Profile - 1

To create the initial profile:

1. Click Drafting and then, in the Draw group, click the arrow next to Spline.

2. Click Interpolation.
3. Click the Closed check box.
4. Specify points A, B, till J.

5. Click OK.
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Figure 70. Cam Profile - 2

You now want to add an interpolation point at K:

1. Click Modify and then, in the Draw group, click the arrow next to Interpol.

2. Under Modify Point, click Add.
3. Click the spline.
4. Click a point on the spline that is close to point K.
5. Click the intersection point at K.

Figure 71. Cam Profile - 3

To delete an interpolation point:

1. Click Modify and then, in the Draw group, click the arrow next to Interpol.
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2. Under Modify Point, click Delete.
3. Click the spline.
4. Click point C.

The point is deleted.
To change the position of an interpolation point:

1. Click Modify and then, in the Draw group, click the arrow next to Interpol.

2. Under Modify Point, click Change.
3. Click the spline.
4. Click point F.
5. Move the point and click point F1.
To change the angle at point F1:

1. Click Modify and then, in the Draw group, click the arrow next to Interpol.

2. Under Modify Tangential, click Change.
3. Click the spline.
4. Click point F1.

The system displays an arrow indicating the slope direction. You can now
either click a point to indicate the direction or type a value in the user input
line. (This example uses an angle of 10°.)

5. Type 10 in the user input line and press ENTER.

Figure 72. Cam Profile - Final Shape
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Subdividing a Spline
Subdivide either divides a spline into section of equal length (spline 1 in

Figure 73. Dividing a Spline on page 236) or splits a spline at points along its
length (spline 2 in Figure 73. Dividing a Spline on page 236).

Figure 73. Dividing a Spline

Dividing a Spline in Segments of Equal Length
Dividing splines into sections of equal lengths is useful, for example, when
designing the shape of a ship's hull and you need to divide the ribs (rib-cage) into
equal lengths.
To divide a spline into segments of equal length:

1. Click Modify and then, in the Draw group, click Subdivide.
2. Click the spline you want to split.
3. Type an integer for the number of segments you want to produce (for example

4) in the user input line and press ENTER.
Creo Elements/Direct Drafting divides the spline into the specified number of
segments.

Dividing a Spline by Specifying a Split Point
You can define a split point by specifying a length value. The spline splits at the
end point of the spline segment defined by this length.
To divide a spline by specifying a split point:

1. Click Modify and then, in the Draw group, click Subdivide.
2. Click the spline you want to split.
3. Click any point on the spline you want to split.
4. Specify a length.
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A split point is created at the end point of the spline segment defined by this
length.

If the Trim check box is clicked (see Using the Trim Function on page 237), the
spline segment "beyond" this split point is hidden.

Converting Splines
Splines need to be converted only if you want to export them to devices (such as
numerical control machines) that do not recognize spline curves.
Creo Elements/Direct Drafting allows you to convert splines to arcs and lines by

approximation using Convert.
To convert splines:

1. Click Modify and then, in the Draw group, click the arrow next to Convert.
2. Click the required Convert button and perform the associated procedure.

Convert Button Purpose Procedure

Lines
Convert splines to
lines.

Select the spline for
converting it to a line.

Arcs & Lines
Convert splines to
arcs and lines.

Select the spline for
converting it to arcs and
lines.

Using the Trim Function
Splines can be split in the same way as other line elements. However, you can
click or clear the Trim check box, which affects the way in which a spline is split
as follows:
Click Two new (independent) splines are created, each with their own

mathematical behavior.
Clear A given section of the spline is hidden following the split. This means

that the spline is drawn from the start (or end) point to the split point.
Curve points beyond the visibility range are kept but are hidden.

Figure 74. Splitting Splines on page 238 shows the effects of splitting a spline
with the Trim check box:
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Click Splines 2A and 2B
The spline is split in two — with each spline having a new end-point, a
new start-point, and individual control polygons.

Clear Splines 3A and 3B
The spline is split but the control polygon retains its shape. When the
left part of the spline is deleted, the curve points are retained (but
hidden).

Figure 74. Splitting Splines

In drawings 2B and 3B, the left spline has been deleted. Notice in drawing 3B
how the control polygon thinks that the spline starts at its original point (drawing
1).
Creo Elements/Direct Drafting allows you to split and trim a spline using the Trim

check box and Subdivide in the Draw group on the Modify tab.
To split and trim a spline:

1. Click Modify and then, in the Draw group, click the Trim check box.

2. Click Subdivide.
3. Divide the spline.

Proceed as described in Subdividing a Spline on page 236.
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Trimming or Extending Elements
Creo Elements/Direct Drafting allows you to trim or extend overlapping elements

using Trim/Extend. This is useful when you want to clean up a drawing. Note
that construction geometry can be used as reference elements (indicating where an
element is to be trimmed).
To trim overlapping elements:

1. Click Modify and then, in the Draw group, click Trim/Extend.
2. Click the required Trim/Extend button and perform the associated procedure.

Trim/Extend Button Purpose Procedure

1 Element
Trim one overlapping
element.

a. Click the first
element (point 1).

b. Click the
intersecting element
(point 2).

See Figure 75 on page
241.

2 Elements
Trim two overlapping
elements.

a. Click the first
element (point 1).

b. Click the
intersecting element
(point 2).

See Figure 76 on page
241.
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Trim/Extend Button Purpose Procedure

Cut Middle
Cut out the middle of an
element.

a. Click element (point
1).

b. Click element (point
2).

c. Click element (point
3).

See Figure 77 on page
241.

Chain
Trim a series of
elements.

After you click the
second element, Creo
Elements/Direct
Drafting trims the line or
lines and prompts you to
click the next element:

a. Click point 1.
b. Click point 2.
c. Click points 3, 4, 5,

6.
See Figure 78 on page
241.

Note

Use Chain only

after clicking 1

Element or 2
Elements.
Note
You cannot trim
elements such as
closed splines,
circles, and closed
polygons because
split points are not
defined.
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Figure 75. Trimming One Element

Figure 76. Trimming Two Elements

Figure 77. Cutting Out the Middle Section

Chain takes the last intersecting elements as the new intersecting elements.

Figure 78. Using the Chain Option

Grouping
You can group annotations or parts together.

• Single Dimension
• Multiple Text Elements
• Parts
• Multiple Symbols
Each group has one of its elements as the master element.
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Creo Elements/Direct Drafting creates one invisible refline between each element
in a group and its master element. These reflines can be shown with either the
SHOW_INV_RTL or SHOW_INV_GEO command. Deleting an invisible refline
deletes the group. You can change the flyby highlight color of the group box and
of the group master element with the FLYBY_GROUP_MASTER_COLOR
function.

Create a group
To create a group:

1. Click Modify and then, in the Draw group, click the arrow next to Groups.

2. Click Create.
3. Type GLOBAL in the user input line and press ENTER if you want to group

elements from different parts.
4. Select the master element for the group.
5. Select additional elements to add them to the group.

6. Click OK.

Ungroup all elements of a group
To ungroup all elements in an existing group:

1. Click Modify and then, in the Draw group, click the arrow next to Groups.

2. Click Remove

3. Select an element belonging to the group you wish to ungroup.

4. Click OK.

Add elements to an existing group
To add elements to an existing group:

1. Click Modify and then, in the Draw group, click the arrow next to Groups.

2. Click Add.
3. Select an element belonging to the group to which you wish to add.
4. Select elements to add them to the group.

5. Click OK.
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Remove elements from an existing group
To remove elements from an existing group:

1. Click Modify and then, in the Draw group, click the arrow next to Groups.

2. Click Delete.
3. Select an element from the group that contains the elements, which you want

to delete.
4. Select elements to remove them from the group.

5. Click OK.

Limitations
• A group may contain only one master element.
• If a group contains a dimension, it automatically becomes the master element.
• Each element can belong to only one group.
• You cannot add an active part to a group.

Creating a Contour
Creo Elements/Direct Drafting allows you to draw a smooth contour by deleting

overlapping elements using Contour

To create a contour from a number of overlapping lines:

1. Click Modify and then, in the Draw group, click More.

2. Under Modify, click Contour

3. Enclose the elements in a box.

Figure 79. Creating a Contour
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Splitting Elements
It is often useful to split an element (line, circle, and so on) in two or more parts.
Following the split operation, the segments of lines that intersect can be treated as
separate elements and deleted individually.

Splitting Elements Automatically
Before you begin to draw, you must click the Splitting check box to automatically
split elements at their intersection points. This technique keeps contours clean,
which is important for automatic hatching.
To click the Splitting check box:

1. Click File ▶ Settings ▶ Geometry.

The Geometry Settings dialog box opens.
2. In the Geometry area, click the Splitting check box.
When a new element is created, Creo Elements/Direct Drafting checks to see if
one of the end points of the new element lies on other elements. If so, it splits the
other element at that point if possible. When the new element crosses the old
element, the old element will not be split.
Figure 80. Splitting Elements on page 244 shows the principle of splitting
elements.

Figure 80. Splitting Elements

Note
If you are deleting an element whose end point lies on other elements and the
Splitting check box is clicked, Creo Elements/Direct Drafting attempts to
merge the remaining elements automatically into one.
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Splitting Single Element or Elements in a Box
To split a single element:

1. Click Modify and then, in the Draw group, click More.

2. Under Modify, click Split.
3. Click the element to be split. Creo Elements/Direct Drafting highlights the

chosen element.
4. Click the point where the element should be split.
Alternatively, to split several elements automatically at their intersection points:

1. Click Modify and then, in the Draw group, click More.

2. Under Modify, click Split.
3. Box the elements to be split.

Ensure that you fully enclose the elements in the box.
To verify that all elements have been split, click the Vertex check box in the Show
dialog box. All existing points are highlighted.

Merging Elements
To merge elements that have been split:

1. Click Modify and then, in the Draw group, click More.

2. Under Modify, click Merge.
3. Click the elements to be merged.

The elements will then be returned to their original state. Intersection points
will no longer be marked when you click the Vertex check box in the Show
dialog box.

Cleaning a Drawing
Inconsistencies in a part (for example, lines not quite parallel, small gaps between
tangent objects, duplicate elements) are relatively common, but can cause
problems for applications (like Parametric Design) that scan the part to extract
information. To help eliminate drawing inconsistencies, Creo Elements/Direct
Drafting provides the following several tools that can do limited cleaning of parts
under Clean:

• Pnt
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• Duplicate

• Stacked

• Staggered

• Gaps

Points
Model points within a given distance of each other are merged, and the elements
attached to the merged points are adjusted (moved, stretched, or rotated) as
necessary to reflect the new positions of the points. For each set of points to be

merged, Pnt chooses a location within the given tolerance and moves the
points there. In general, there is no way to accurately predict or control which
elements will be adjusted as a result of the merge. This should not be a limitation

in most cases, however, because the tolerance used is likely to be small. Pnt is
most useful for removing small gaps between elements.

To use Pnt:

1. Click Modify and then, in the Draw group, click More.

2. Under Clean, click Pnt.
3. Type a distance tolerance (current length units) in the user input line and press

ENTER.

Points within the given tolerance are marked with a *, and will be merged.
Elements that will be modified as a result of the merge are highlighted.

4. Click Confirm to merge the marked points and modify the highlighted
elements.

Duplicate

Duplicate scans the part for duplicate elements and deletes them. It selects the
element of a duplicate pair to delete. Elements are considered to be duplicates if
their model points are identical. An exception is made for concentric circles
(only); if the radii of concentric circles are within a given tolerance, they are

treated as duplicates. Normally, Duplicate should be used after Pnt to
clean up duplicate elements that may result from merging model points.
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To use Duplicate:

1. Click Modify and then, in the Draw group, click More.

2. Under Clean, click Duplicate.
3. Type a distance tolerance (current length units) for the removal of duplicate

elements in the user input line and press ENTER.

Elements that will be deleted are highlighted.

4. Click Confirm to remove duplicate elements.

Stacked
Stacked finds stacked lines and arcs in the current part and calls Split to

split them.

To use Stacked:

1. Click Modify and then, in the Draw group, click More.

2. Under Clean, click Stacked.

Elements to be split are highlighted and the points to be used for the splits are
marked with a *.

3. Click Confirm to split elements.

Staggered

Staggered finds staggered (partially overlapping) lines and arcs in the current
part and merges these to form a single "new" line or arc. The "old" lines or arcs
are removed by this operation.

To use Staggered:

1. Click Modify and then, in the Draw group, click More.

2. Under Clean, click Staggered.
3. Type a distance tolerance (current length units) in the user input line and press

ENTER.

Elements that will be deleted are highlighted.

4. Click Confirm to delete superfluous elements following the merge.
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Gaps

Gaps uses the Creo Elements/Direct Drafting Trim/Extend button to close
"trivial" gaps between two or more elements, even between circular and linear
elements.

• "Trivial" gaps are small gaps that can be closed automatically without any
major impact on the drawing. These can be closed automatically.

• "Non-trivial" gaps cannot be eliminated automatically because their
elimination may lead to unpredictable results. Therefore, "non-trivial" gaps
cannot be closed automatically. "Non-trivial" gaps are typically characterized
by distances and/or complexities greater than those found in "trivial" gaps.

To automatically close "trivial" gaps:

1. Click Modify and then, in the Draw group, click More.

2. Under Clean, click Gaps.
3. Draw a selection box around the elements between which there are gaps that

you want to close.

Note

If you use the Global selection mode, you may unintentionally close
"correct" gaps between elements

4. Type a distance tolerance (in current length units) in the user input line and
press ENTER.

Note that this distance tolerance needs to be a "realistic" (small) value in order
to prevent the elimination of required spacing between elements. If the
distance tolerance is too big, a very large number of gaps may be shown. If all
gaps are shown in the drawing, your drawing may be cluttered with color
rectangles indicating "non-trivial" gaps.

The number of "trivial" and "non-trivial" gaps found in your selection is
indicated in the prompt line. However, note that "non-trivial" gaps are not
indicated in the drawing.

5. Check the "trivial gaps" preview for plausibility.

6. Click Confirm to close any "trivial" gap or gaps.
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Figure 81. Closing Trivial Gaps on page 249 shows an example of a set of
elements separated by "trivial" gaps. These gaps are highlighted in the drawing
and are then closed. Note that the gap sizes are exaggerated for visual clarity.

Figure 81. Closing Trivial Gaps

Show Gaps
Creo Elements/Direct Drafting allows you to box "non-trivial" gaps between two

or more elements using Show Gaps.
To mark "non-trivial" gaps:

1. Click Modify and then, in the Draw group, click Show Gaps.
2. Type a box color for "trivial" gaps in the user input line and press ENTER.
3. Type a box color for "non-trivial" gaps in the user input line and press

ENTER.
4. Draw a selection box around the elements between which there are or may be

gaps.
5. Type a distance tolerance (current length units) in the use input line and press

ENTER.

Note
This distance tolerance needs to be a "realistic" (small) value in order to
prevent the elimination of required spacing between elements. If the
distance tolerance is too big, a very large number of gaps may be shown. If
all gaps are shown in the drawing, your drawing may be cluttered with
color rectangles indicating "non-trivial" gaps.

The number of "trivial" and "non-trivial" gaps found in your selection is
indicated in the prompt line.

6. Type the number of "non-trivial" gaps in the user input line and press ENTER.

Modifying a Drawing 249



Optionally, by incrementing this number, you can display one "non-trivial"
gaps after the other for further examination. For example, you may want to
type 1 to box only a single "non-trivial" gap. Then type 2 to box the next one,
and so forth.

Optionally, type the total number of "non-trivial" gaps to box all of these gaps
at the same time.

7. Optionally, close the "trivial" gaps indicated by Show Gaps by clicking

Confirm.
Figure 82. Showing Non-Trivial Gaps on page 250 shows an example of a
geometry that includes three "non-trivial" gaps.

Figure 82. Showing Non-Trivial Gaps

Tip
To clean up most common problems in a part, click the Clean buttons in the
following sequence:

Pnt
Merge disconnected points.

Gaps
Close gaps between adjoining elements.

Duplicate
Remove existing duplicates and those caused by
merging points.

Stacked
Split overlapping elements.

Duplicate
Remove duplicates caused by splitting.

Staggered
Merge partially overlapping elements.
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Further Information
For further technical information about modifying, refer to the Creo Elements/
Direct Drafting help system.
Type the following in the Creo Elements/Direct Drafting user input line and press
ENTER:

• help modify

• help move

• help rotate

• help mirror

• help scale

• help similar

• help stretch

• help isometric

• help convert_spline

• help bspl_point_length

• help trim

• help contour

• help split

• help merge

• help clean_drawing

• help group

• help ungroup

• help group_add

• help group_remove

Creo Elements/Direct Drafting displays further information about modifying your
drawing.
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This chapter describes how to dimension your drawings.
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Dimensioning Fundamentals
To clarify how the dimensioning commands work, it is necessary to define the
terminology used when discussing dimensioning. Generally, a dimension consists
of two parts:

• Dimension Text.
• Dimension Geometry.

What is Dimension Text?
Dimension text describes the geometry feature that is marked by the dimension
geometry. Dimension text is divided into the following fields:

• Prefix
• Dimension Value
• Tolerance
• Postfix
• Subfix
• Superfix
Figure 83 on page 253 shows several examples of dimension text with the fields
indicated.

Figure 83. Dimension Text Examples

The fields prefix, tolerance, postfix, subfix and superfix are optional.

What is a Prefix?
Use a prefix to include additional information before the dimension value.
Examples of prefixes are: DIA (diameter), TRUE R (true radius), and R (radius).
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What is a Dimension Value?
A dimension value is the numerical value assigned to the geometry feature you are
dimensioning. The value can be imperial, metric or angular depending on the
geometry feature and the standard units you use.

What is a Tolerance?
A tolerance is used to include information about the tolerance allowed in the
dimension value. Tolerance is the total amount by which a specific dimension is
permitted to vary. Types of tolerances are:

• Limit tolerances
• Plus and minus tolerances
• Upper and lower tolerances

Limit Tolerances
Limit tolerancing is used to give the maximum and the minimum dimension
values. The high limit (maximum value) is placed over the low limit (minimum
value).
Figure 84 on page 254 shows an example of limit tolerancing.

Figure 84. Limit Tolerancing

Plus and Minus Tolerances
Plus and minus tolerancing is used to place the tolerance to the right of the
dimension value as a plus and minus expression of the tolerance.
Figure 85 on page 254 shows an example of plus and minus tolerancing.

Figure 85. Plus and Minus Tolerancing
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Upper and Lower Tolerances
Upper and lower tolerancing is used to place the tolerances to the right of the
specific dimension value. They appear as upper and lower values of the
permissible variation of the size of the feature.
Figure 86 on page 255 shows an example of upper and lower tolerancing.

Figure 86. Upper and Lower Tolerancing

What is a Postfix?
Use a postfix to include additional information after the dimension value.
Examples of postfix information are: 3 HOLES, EQUALLY SPACED, and CONC
(concentric).

What are Subfixes and Superfixes?
You can use subfixes (text below the dimension text) and superfixes (text above
the dimension text) to add information such as manufacturing-related
specifications to the actual dimension text.
Figure 87 on page 255 shows an example of a dimensioned part complete with
dimension text, subfix and superfix.

Figure 87. Dimension Text plus Subfix plus Superfix

What is a Dimension?
Dimension marks the geometry feature corresponding to the dimension text.
Dimension consists of:

• Dimension lines
• Extension lines
• A dimension text frame
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Figure 88 on page 256 shows the three components of a dimension.

Figure 88. Dimension

Dimension Lines
Dimension lines show the direction and extent of a dimension. The dimension line
may be broken and the dimension text inserted (referred to as on the dimension
line), or the line may be a full unbroken line with the dimension text above or
below the dimension line. The dimension line will normally end with a terminator.
Figure 89 on page 256 shows dimension line terminators.

Figure 89. Dimension Line Terminators

Extension Lines
Extension lines show the extension of a surface or point to a location outside the
part outline. In most technical drawings, you draw them perpendicular to the
dimension line with a visible gap from the geometry feature.

Dimension Text Frames
The dimension text frame surrounds all dimension text relating to the dimension
geometry. Normally, the frame is switched off. You can make the frame appear as
a box-shaped frame or a balloon-shaped frame or a flag-shaped frame by selecting
the appropriate option (see Figure 125 on page 321).
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Dimension Settings and Dimension Text Distances
As previously described, a dimension is made up of several parts:

• Dimension text
• Dimension lines
• Extension lines
You can set the distance between some of the parts making up a dimension.
Figure 90 on page 257 shows the most common distances that you can set. Each
distance is identified by a letter. Refer to Table 1 on page for an explanation of the
letters.

Figure 90. Setting Dimension Distances

Table 1 on page gives the distance, the corresponding Creo Elements/Direct
Drafting function that sets the distance, and a typical value.

Table 1. Setting Dimension Distances

Distance Description
A The minimum distance between the dimension line and the

geometry feature. Define with the Minimum Space box (in the
Line settings of the Dimension Settings dialog box). The default
minimum distance is 0 mm.

B The distance between the extension line and the geometry
feature. Define with the Offset Point box (in the Line settings of
the Dimension Settings dialog box). The default distance is 0
mm.

C The distance between the dimension line and the top of the
extension line. Define with the Offset Line box (in the Line
settings of the Dimension Settings dialog box). The default
distance is 2 mm.
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Distance Description
D The vertical distance between the dimension line and the

dimension text. This only works if the location of the
dimension text is above or below the dimension line. Define
with the Offset Line box (in the Text settings of the Dimension
Settings dialog box). The default distance is 2 mm.

E The gap between the dimension line and the dimension text.
This only works if the location of the dimension text is on the
dimension line. Define with the Space box (in the Line settings
of the Dimension Settings dialog box). The default gap is 2 mm.

Dimensioning With Creo Elements/Direct
Drafting
The dimensioning module has the following features to make dimensioning your
drawing quick and easy:

• A full-featured user interface that includes:

○ An efficient screen menu system.
○ Combination of dimensioning commands and functions.
○ Integration with Creo Elements/Direct Drafting common and selection

commands.
• Powerful dimension assignment features:

○ A range of dimensioning assignment methods.
○ Multiple elements can be dimensioned at once.
○ Selection aids speed the assignment process.
○ Dimensioning between parts and on layers.

• Tools for dimension style setting and modification:

○ Standards-based dimensioning styles.
○ Style saving and re-assignment via the Style table.
○ Simultaneous modification of dimensioning geometry and text.

The dimensioning module is sometimes referred to as the Dimension Advisor
(DA).

Dimensioning Interface Features
Dimensioning commands and functions can be executed using the ribbon user
interface as well as from the command line.
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Dimensioning Commands and Functions
The dimensioning interface provides both commands and functions. Commands
and functions can be combined to perform complex operations in a short amount
of time.

Dimensioning Commands
Generally, a command remains active until:

• You click OK to end the command.
• You end the command by starting another command.
This means you can repeat the command without having to click the command
again.
For example:

1. Click Drafting and then, in the Annotate group, click the arrow next to
Linear.

2. Click Single.
3. Enclose more than one geometry feature in a box and specify the position in

the drawing.

4. When you have finished using Single, click OK to end the command.

Dimensioning Functions
Use functions to interrupt commands. Once you have completed the function,
Creo Elements/Direct Drafting will return to the active command. You can cancel

the function and leave the dimensioning command active by clicking Cancel.

Combining the Dimensioning Commands and Functions
A powerful feature of the Creo Elements/Direct Drafting dimensioning module is
the ability to combine dimensioning commands and functions to perform complex
operations efficiently.
The following procedure illustrates the importance of this feature.
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Figure 91. Combining Dimensioning Commands and Functions

To create the dimension shown in Figure 91 on page 260:

1. Click Drafting and then, in the Annotate group, click the arrow next to
Circular.

2. Click Diameter.

3. In the Orient gallery, select Center Line.

4. Click File ▶ Settings ▶ Dimension.

The Dimension Settings dialog box opens.
5. Click Text Ext.
6. In the Set box, select Prefix.
7. Type DIA in the Ext Text box.
8. Type an arbitrary name for the prefix (such as p1) in the entry field above the

(originally empty) prefix list and click Add.
9. In the Set box, select Postfix.
10. Type GRIND in the Ext Text box.
11. In the Set box, select Tolerance.
12. In the Display box, select Upper/Lower.
13. In the Upper box, type +0.004 as the upper tolerance value.
14. In the Lower box, type –0.000 as the lower tolerance value.

Use the same procedure as above to add the tolerance values to your
dimension text extensions.

15. Click the circle.
16. Click the desired location for the dimension text.

Remember that Diameter and the tolerancing values remain active. This
means that you can continue to apply diameter dimensions to other circular
geometry features simply by clicking them.
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Suppose that you do not want the GRIND postfix to appear in subsequent
dimensions. You can remove this postfix without ending the current command by
using the Clear function:

1. Click Clear.
2. Click another circular element (circle, arc, fillet).
3. Specify the desired location for the dimension text.
As you can see, combining dimensioning commands and functions reduces the
amount of time needed to dimension your drawing.

Note
All the examples in this chapter assume that the current linear units are

millimeters and the angular units are degrees. Check the Format tab for

mm and Degree.

Using the Common and Selection Commands
You can use Creo Elements/Direct Drafting common and selection commands
with the dimensioning commands. For more information, refer to Commonly
Used Commands on page 72.

Dimension Assignment Features

Multiple Assignment Methods
The dimensioning module provides several methods for assigning dimensions to
drawing elements.

• With direct assignment, you manually select the type of dimension you wish to
assign (single, chain, datum, angle, etc.) and then identify one or more
drawing elements to receive the selected dimension. For example:

1. Click Drafting and then, in the Annotate group, click the arrow next to
Linear.

2. Click Single.
3. Click the dimension points. To dimension a single geometric feature, click

two dimension points to identify the feature. To dimension several drawing
elements at the same time, enclose them in a box.
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4. Move the dimension trace around your drawing until the extension lines
and dimension text are at the desired location.

5. Specify the point where you want to place the dimension text and Creo
Elements/Direct Drafting draws the dimension or dimensions.

Direct dimensioning gives you the greatest control over the dimensioning
process, but is likely to take the most time.

• Geometry-sensing assignment is provided by the commands DA_DIM_GEO_
SENSE and DA_DIM_PD_SCAN. DA_DIM_GEO_SENSE prompts you to
identify a group of drawing elements and then generates a basic set of
dimensions for those elements based on their geometry type and position. DA_
DIM_PD_SCAN also generates dimensions for a selected set of elements, but
it scans the parametric design constraints on the selected elements to
determine what type of dimensions to generate.

Geometry-sensing assignment is not intended to provide "automatic"
dimensioning, but it does provide a basic dimensioning framework that you
can modify to suit your requirements.

To quickly understand the operation of geometry-sensing assignment, try the
following:

1. Create a drawing with several different drawing elements.
2. Type DA_DIM_GEO_SENSE ALL in the user input line and press ENTER.

Creo Elements/Direct Drafting creates dimensioning for all elements in the
drawing.

3. Type DA_MOVE_DIMENSION in the user input line and press ENTER.

You can now manually adjust the positions of the newly-created
dimensions.

• Database-matching assignment transfers dimensioning from a "dimensioning
database" of pre-dimensioned parts to similar drawing elements in your
drawing. Once you create this database, you can use the entries in it as
dimensioning templates to quickly generate complete dimensioning for similar
parts or features in you drawings.

Database-matching assignment can greatly improve dimensioning speed and
accuracy for commonly used drawing details.
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Dimension Single or Multiple Elements
You can assign dimensions to one or several elements at a time. You assign single
dimensions by indicating the individual dimension points you wish to dimension.

To assign multiple dimensions, you select whole elements, either with Select
or by enclosing them in a box.

Selection Aids
Several selection aids are available to help you assign dimensions:

• When dimensioning single elements, you do not have to precisely identify the
end points of each element. You can click two points on the element that are
close to each end point and the cursor will catch to the end points
automatically.

• When selecting multiple elements for dimensioning, a filter can be applied to
the selection process to selectively exclude items from being considered.
Geometry can be filtered based on geometry type, line slope, linetype, pensize,
color, and/or linesize. You set up the filter using the Filter options in the
Dimension Settings dialog box. The current filter can be enabled or disabled
by clicking or clearing the On check box in the Filter settings in the Dimension
Settings dialog box.

• A dimension trace appears after you have identified the dimension points of
the geometry features you want to dimension. Creo Elements/Direct Drafting
then displays a movable dimension trace which shows:

○ The orientation and location of the dimension(s).
○ The location of the dimension line terminators.
○ The length of extension lines.
○ The dimension text represented by a box.

When multiple elements are selected, the dimensioning trace shows the
proposed dimensioning for all the selected elements, allowing you to place the
dimensioning text for all of them with a single click.

Dimensioning Between Parts
To dimension between parts, ensure that the parent part is active. You can then
dimension between the parent part and one of its subparts, or between pairs of
subparts.

Dimensioning Detail Parts
If you are dimensioning a detail part, you must make it the active part. Otherwise,
Creo Elements/Direct Drafting produces incorrect dimensions.
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If you attempt to dimension a detail part that is not also the active part, Creo
Elements/Direct Drafting will display the following message in the prompt line:
Warning; Detail part is not active. Dimension value reflects the
drawing scale.

To make a detail part active:

1. Click Structure and then, in the Parts group, click Edit.

2. Click Part.
3. Click the detail part.

Dimensioning on Layers
Dimensioning on layers is the same as normal dimensioning.
For more information about layers, refer to Using Layers and Infos on page 510.

Style Features
Creo Elements/Direct Drafting provides several methods for setting and changing
dimensioning styles. In addition to specific commands that allow you to set and
change dimension text attributes (size, font, orientation, spacing, etc.) and line
attributes (color, width, spacing, offsets, terminators, etc.), Creo Elements/Direct
Drafting also provides tools for emulating dimensioning standards and for storing
and recovering often-used styles.

Standards
Dimensioning standards allow you to quickly set the Creo Elements/Direct
Drafting dimension style features to emulate popular dimensioning standards,
such as ANSI, DIN, JIS, and ISO. A generic "company" standard may also be

defined. Standards are easily selected using Dimension Standards in the
Format group on the Drafting tab. Creo Elements/Direct Drafting displays the
current dimensioning standard in the Format group.

Style Table
The Dimension Style table allows you to store the current dimensioning style
attributes into a table entry. These attributes can later be recovered simply by
clicking the table entry. Once recovered, these settings become the current
dimensioning style and will be used for subsequent dimensions.
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Modification Features
Dimension modification features allow you to change the layout of existing
dimensioning lines and text. Dimension modification buttons are provided in the
Annotate group on the Modify tab.

Preparing to Dimension
Before you assign dimensions to your drawing, you may want to set up the basic
dimensioning style that will be used for your dimensions.
You can manually set dimensioning attributes using the Dimension Settings dialog
box. In addition, you can set up dimensioning to emulate a particular standard.

Selecting a Dimensioning Standard
Creo Elements/Direct Drafting can emulate the dimensioning styles specified in
various drawing standards as well as allow you to define your own company or
site-wide standard. The standards available are:

• ANSI

• ISO

• DIN

• JIS

• Company (Creo Elements/Direct Drafting default)
To select a dimensioning standard:

1. Click Drafting and then, in the Format group, click Dimension Standards.
2. Click the dimensioning standard you want to use.
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Note
To emulate a given dimensioning standard, Creo Elements/Direct Drafting
simply executes a macro that calls dimensioning style commands with the
appropriate options. If a given dimensioning standard has features that are not
supported by Creo Elements/Direct Drafting dimensioning commands, that
feature will not be supported.

The dimensioning standards are all defined in the macro file da_std.mac.
This macro file can be edited by hand in order to set the Company
dimensioning style, but the other standards defined in this file should generally
not be changed.

Please ensure automatic dimension placement by clicking the Automatic check
box in the Options settings of the Dimension Settings dialog box. Clear the
Automatic check box for manual placement.
You may also want to select or specify your own dimension settings before you
begin to dimension. For details see:

• Dimension Line Settings on page 308
• Dimension Text Settings on page 318
• Predefining Prefixes, Postfixes, Superfixes, Subfixes, and Tolerances on page

324
• Dimension Unit Settings on page 329
• Selection Filtering on page 332
• Dimension Options on page 337

Single Dimensioning
This section describes how to dimension single linear geometry features.
Creo Elements/Direct Drafting allows you to define the orientation of the single
dimension relative to a geometry feature using the buttons of the Orient gallery.
All buttons enable you to apply dimensioning to a single linear drawing element
or to a group of elements depending on your selection. You can:

• Click any two dimension points. The line between the two points is
dimensioned.

• Click a single linear drawing element. The starting point of the selected
element becomes the first dimension point. Select a second dimension point on
this or any other linear drawing element to complete the dimension.
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• Select multiple linear drawing elements with Select or by enclosing them
in a box. The end points of each selected element become dimension points,
and each element is dimensioned.

If you clicked the Automatic check box (automatic dimension displacement) in the
Options settings of the Dimension Settings dialog box, Creo Elements/Direct
Drafting positions the new dimensions automatically. Automatic placement only
applies when you have selected multiple elements for dimensioning.
If you cleared the Automatic check box (automatic dimension displacement) in the
Options settings of the Dimension Settings dialog box, position the dimensions on
your drawing manually. A dimension trace appears when you select elements.
Move the trace around your drawing until the dimension text is in the desired
location. Click the desired text location and Creo Elements/Direct Drafting draws
the dimension or dimesions. When multiple elements are selected, the trace shows
the proposed dimensions for all of them at the same time.

Example
Figure 92 on page 267 shows the result of using each single dimensioning option.

Figure 92. Single Dimensioning – Options

To dimension single linear geometry features:

1. Click Drafting and then, in the Annotate group, click the arrow next to
Linear.

2. Click Single and then, click the required Orient button in the gallery and
perform the associated procedure:
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Orient Button Purpose Procedure

Parallel
Draw a dimension
parallel to a line drawn
between two dimension
points (along an inclined
plane).

a. Click the dimension
points or elements to
be dimensioned.

b. Specify the location
of the dimension.

c. If you have cleared
the Automatic check
box (automatic
dimension
placement) in the
Options settings of
the Dimension
Settings dialog box,
position the
dimension on your
drawing manually.

d. Click OK.

Horizontal
Draw a dimension in the
horizontal plane.

a. Click the dimension
points or elements to
be dimensioned.

b. Specify the location
of the dimension.

c. If you have cleared
the Automatic check
box (automatic
dimension
placement) in the
Options settings of
the Dimension
Settings dialog box,
position the
dimension on your
drawing manually.

d. Click OK.

Vertical
Draw a dimension in the
vertical plane.

a. Click the dimension
points or elements to
be dimensioned.
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Orient Button Purpose Procedure
b. Specify the location

of the dimension.
c. If you have cleared

the Automatic check
box (automatic
dimension
placement) in the
Options settings of
the Dimension
Settings dialog box,
position the
dimension on your
drawing manually.

d. Click OK.

Perpendicular to
Line

Draw a dimension
perpendicular to a
reference line.

a. Click a reference
line.

b. Click the dimension
points or elements to
be dimensioned.

c. Specify the location
of the dimension.

d. If you have cleared
the Automatic check
box (automatic
dimension
placement) in the
Options settings of
the Dimension
Settings dialog box,
position the
dimension on your
drawing manually.

e. Click OK.
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Orient Button Purpose Procedure

Parallel to Line
Draw a dimension
parallel to a reference
line.

a. Click a reference
line.

b. Click the dimension
points or elements to
be dimensioned.

c. Specify the location
of the dimension.

d. If you have cleared
the Automatic check
box (automatic
dimension
placement) in the
Options settings of
the Dimension
Settings dialog box,
position the
dimension on your
drawing manually.

e. Click OK.

Symmetry-Style Dimensions
Creo Elements/Direct Drafting allows you to specify symmetry-style dimensions

using Symmetric Single and Symmetric Long. Figure 93 on page 270
shows an example of symmetric dimensioning. In drawing 2, the first dimension
point is assumed to be on a symmetry line. No extension line or line terminator is
drawn for that element, and the dimension text value is doubled to indicate that
the dimension represents both sides of the symmetry line. Drawing 1 shows the
unseen half of the geometry.

Figure 93. Symmetry-Style Dimensioning
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To create a symmetry-style dimension:

1. Click Drafting and then in the Annotate group, click the arrow next to
Linear.

2. Click the required Linear button and perform the associated procedure.

Linear Button Purpose Procedure

Symmetric Single
Draw a (single)
symmetric
dimension.

a. Click the first dimension
point.

b. Click the second
dimension point.

Symmetric Long
Draw a (datum)
symmetric
dimension.

a. Click the first dimension
point.

b. Click the second
dimension point.

c. Continue clicking
dimension points as
required.

Centerline Dimensions
When dimensioning geometry contains centerlines, the dimension extension line
is attached to the model point (center point) of the centerline. This is true even if
the centerlines are not perpendicular to the measured direction of the dimensions.

Figure 94. Dimensions and Centerlines

Modify a symmetry or center line
Use the handles of a symmetry or center line to modify the line.
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Extend the symmetry/center line Click the handle and drag.
Rotate the center line Click the center line (not on the handles) and

drag.

To change the Handles settings:

1. Click File ▶ Settings ▶ System.

The System dialog box opens.
2. Click Handles.

Chain Dimensioning
This section describes how to dimension groups of linear geometry features.
Creo Elements/Direct Drafting draws the chain dimensions parallel to the first
dimension and chained to the same axis. Locate your first chain dimension so that
subsequent chain dimensions do not overwrite the drawing or dimensions. You

can correct mistakes by repeatedly clicking Undo, which removes preceding
dimensions. You can then click the correct points.
Creo Elements/Direct Drafting allows you to define the orientation of chain
dimensions relative to geometry features using the buttons of the Orient gallery.
All buttons enable you to apply dimensioning to a single linear drawing element
or to a group of elements depending on your selection. You can:

• Click any two dimension points. The line between the two points is
dimensioned.

• Click a single linear drawing element. The starting point of the selected
element becomes the first dimension point. Select a second dimension point on
this or any other linear drawing element to complete the dimension.

• Select multiple linear drawing elements with Select or by enclosing them
in a box. The end points of each selected element become dimension points,
and each element is dimensioned.

If you clicked the Automatic check box (automatic dimension displacement) in the
Options settings of the Dimension Settings dialog box, Creo Elements/Direct
Drafting positions the new dimensions automatically. Automatic placement only
applies when you have selected multiple elements for dimensioning.
If you cleared the Automatic check box (automatic dimension displacement) in the
Options settings of the Dimension Settings dialog box, position the dimensions on
your drawing manually. A dimension trace appears when you select elements.
Move the trace around your drawing until the dimension text is in the desired
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location. Click the desired text location and Creo Elements/Direct Drafting draws
the dimension or dimensions. When multiple elements are selected, the trace
shows the proposed dimensions for all of them at the same time.
Figure 95 on page 273 shows examples of chain dimensioning using each option.

Figure 95. Chain Dimensioning

To draw chained dimensions:

1. Click Drafting and then, in the Annotate group, click the arrow next to
Linear.

2. Click Chain and then, click the required Orient button in the gallery and
perform the associated procedure.
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Orient Button Purpose Procedure

Parallel
Draw chain dimensions
along an inclined plane.

a. Click the first two
dimension points.
These define the
angle for this and
subsequent chain
dimensions.

b. If your initial
selection contains
multiple drawing
elements, you are
prompted to identify
one of them to
provide the reference
angle for the chain.

c. If you have cleared
the Automatic check
box (automatic
dimension
placement) in the
Options settings of
the Dimension
Settings dialog box,
click the desired
location for the
dimension text or
texts, using the
dimension trace for
guidance.

d. To continue the
chain along the
inclined plane, select
additional linear
elements.

e. Click OK.

Horizontal
Draw chain dimensions
in the horizontal plane.

a. Click the dimension
points or elements to
be dimensioned. If
your selection
contains multiple
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Orient Button Purpose Procedure
drawing elements,
they become the first
members in the
chain.

b. If you have cleared
the Automatic check
box (automatic
dimension
placement) in the
Options settings of
the Dimension
Settings dialog box,
click the desired
location for the
dimension text or
texts, using the
dimension trace for
guidance.

c. To continue the
chain, select
additional linear
elements.

d. Click OK.

Vertical
Draw chain dimensions
in the vertical plane.

a. Click the dimension
points or elements to
be dimensioned. If
your selection
contains multiple
drawing elements,
they become the first
members in the
chain.

b. If you have cleared
the Automatic check
box (automatic
dimension
placement) in the
Options settings of
the Dimension
Settings dialog box,
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Orient Button Purpose Procedure
click the desired
location for the
dimension text or
texts, using the
dimension trace for
guidance.

c. To continue the
chain, select
additional linear
elements.

d. Click OK.

Perpendicular to
Line

Draw a dimension chain
perpendicular to a given
line.

a. Click a reference
line. You can use
any line on the
drawing as the
reference line.

b. Click the dimension
points or elements to
be dimensioned. If
your selection
contains multiple
drawing elements,
they become the first
members in the
chain.

c. If you have cleared
the Automatic check
box (automatic
dimension
placement) in the
Options settings of
the Dimension
Settings dialog box,
click the desired
location for the
dimension text or
texts, using the
dimension trace for
guidance.
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Orient Button Purpose Procedure
d. To continue the

chain, select
additional linear
elements.

e. Click OK.

Parallel to Line
Draw a dimension chain
parallel to a reference
line.

a. Select a reference
line. You can
identify any line on
the drawing as the
reference line.

b. Click the dimension
points or elements to
be dimensioned. If
your selection
contains multiple
drawing elements,
they become the first
members in the
chain.

c. If you have cleared
the Automatic check
box (automatic
dimension
placement) in the
Options settings of
the Dimension
Settings dialog box,
click the desired
location for the
dimension text or
texts, using the
dimension trace for
guidance.

d. To continue the
chain, select
additional linear
elements.

e. Click OK.
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Datum Dimensioning
Datum dimensioning is useful for marking holes and other features on a part. The
dimensions are parallel to each other (like chain dimensioning), and have a
common datum point. Normally, design engineers use this type of dimensioning
for parts that will be NC machined.
Creo Elements/Direct Drafting allows you to define the orientation of datum
dimensions relative to geometry features using the buttons of the Orient gallery.
All buttons enable you to apply dimensioning to a single linear drawing element
or to a group of elements.
If you clicked the Automatic check box (automatic dimension displacement) in the
Options settings of the Dimension Settings dialog box, Creo Elements/Direct
Drafting positions the new dimensions automatically. Automatic placement only
applies when you have selected multiple elements for dimensioning.
If you cleared the Automatic check box (automatic dimension displacement) in the
Options settings of the Dimension Settings dialog box, position the dimensions on
your drawing manually. A dimension trace appears when you select elements.
Move the trace around your drawing until the dimension text is in the desired
location. Click the desired text location and Creo Elements/Direct Drafting draws
the dimension or dimensions. When multiple elements are selected, the trace
shows the proposed dimensions for all of them at the same time.

Creating Datum Dimensions
To create a datum dimension:

1. Click Drafting and then, in the Annotate group, click the arrow next to
Linear.

2. Click the required Linear button:

• Datum Long to draw dimension using long base lines.

• Datum Short to draw dimensions using short base lines.

• Coordinate to draw dimensions without dimension lines. This is useful
if the geometry of the part will cause the dimension lines to be too close
together.

3. Click the required Orient button in the gallery and perform the associated
procedure.
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Parallel
Draw datum dimension
along an inclined plane.

a. Click a single
dimension point.
This becomes the
common datum
point.

b. Click one or more
additional
dimensioning points.

c. If you have cleared
the Automatic check
box (automatic
dimension
placement) in the
Options settings of
the Dimension
Settings dialog box,
click the desired
location for the
dimension text or
texts, using the
dimension trace for
guidance.

d. To add more
dimensions relative
to the common
datum point, select
additional drawing
elements.

e. Click OK.

Horizontal
Dimension in the
horizontal plane.
You can dimension in
the horizontal plane
irrespective of the
position of the
dimension points.

a. Click a single
dimension point.
This becomes the
common datum
point.

b. Click one or more
additional
dimensioning points.

c. If you have cleared
the Automatic check
box (automatic
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dimension
placement) in the
Options settings of
the Dimension
Settings dialog box,
click the desired
location for the
dimension text or
texts, using the
dimension trace for
guidance.

d. To add more
dimensions relative
to the common
datum point, select
additional drawing
elements.

e. Click OK.

Vertical
Dimension in the
vertical plane.

a. Click a single
dimension point.
This becomes the
common datum
point.

b. Click one or more
additional
dimensioning points.

c. If you have cleared
the Automatic check
box (automatic
dimension
placement) in the
Options settings of
the Dimension
Settings dialog box,
click the desired
location for the
dimension text or
texts, using the
dimension trace for
guidance.

d. To add more
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dimensions relative
to the common
datum point, select
additional drawing
elements.

e. Click OK.

Perpendicular to
Line

Draw a perpendicular
datum dimension.

a. Click a reference
line. You can use
any line on the
drawing as the
reference line.

b. Click a single
dimension point.
This becomes the
common datum
point.

c. Select one or more
additional
dimensioning points.

d. If you have cleared
the Automatic check
box (automatic
dimension
placement) in the
Options settings of
the Dimension
Settings dialog box,
click the desired
location for the
dimension text or
texts, using the
dimension trace for
guidance.

e. To add more
dimensions relative
to the common
datum point, select
additional drawing
elements.

f. Click OK.
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Parallel to Line
Draw a datum
dimension parallel to a
reference line.

a. Click a reference
line. You can use
any line on the
drawing as the
reference line.

b. Click a single
dimension point.
This becomes the
common datum
point.

c. Select one or more
additional
dimensioning points.

d. If you have cleared
the Automatic check
box (automatic
dimension
placement) in the
Options settings of
the Dimension
Settings dialog box,
click the desired
location for the
dimension text or
texts, using the
dimension trace for
guidance.

e. To add more
dimensions relative
to the common
datum point, select
additional drawing
elements.

f. Click OK.

282 Creo Elements/Direct Drafting User's Guide: Fluent User Interface



Datum Dimension Examples
Example 1

Figure 96 on page 283 shows a rectangular plate dimensioned using the

Datum Long and the Parallel to Line orientation button.

Figure 96. Rectangular Plate — Dimensioned with Datum Long

Example 2

Figure 97 on page 283 shows a rectangular plate dimensioned using Datum

Short with the Parallel and Vertical orientation button.

Figure 97. Rectangular Plate — Dimensioned with Datum Short

Example 3

The following example shows how to use Coordinate to dimension a simple
rectangular plate with three holes. Assume that the common datum point is the
lower left hand corner of the plate.
Figure 98 on page 284 shows the rectangular plate:
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Figure 98. Rectangular Plate — Dimensioned with Coordinate

To add the dimensions measured along the vertical (from datum point):

1. Ensure that the Vertex check box is clicked in the Show dialog box.

2. Click Drafting and then, in the Annotate group, click the arrow next to
Linear.

3. Click Coordinate.

4. In the Orient gallery, click Vertical.
5. Click the lower left hand corner of the plate.
6. Click the center of one of the circles.
7. Click the position for the dimension text.
8. Repeat step 6 for the other two circles.

To add the dimensions measured along the horizontal (from datum point):

9. Click Coordinate.

10. In the Orient gallery, click Horizontal.
11. Click the lower left hand corner of the plate.
12. Click the center of one of the circles.
13. Click the position for the dimension text.
14. Repeat step 12 for the other two circles.

Note
The dimension text may be preceded by a leading zero. For details see
Coordinate Dimension Leading Zero on page 323 in this chapter.
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Radius, Diameter, Tangential and Arc
Dimensioning

Dimensioning Radii
This section shows how to dimension the radius of an arc, circle, BSpline or fillet
feature.

• Radius dimension text includes the prefix R (radius).
• You can locate the dimension text either inside or outside the feature.
• When the radius dimension is placed at a position where the dimension line

does not hit the dimensioned geometry then the system automatically creates
an arc extension for the dimension.

To dimension a radius:

1. Click Drafting and then, in the Annotate group, click the arrow next to
Circular.

2. Click Radius and then click the required Orient button in the gallery:

• Center Line to dimension the radius of a feature with the dimension
line drawn from the feature center.

• No Center Line to dimension the radius of a feature with the
dimension line drawn towards the center of the feature but not connecting
with the center.

Figure 99. Dimensioning Radii with and without a Centerline

3. Select one or more arc, circle, or fillet features.
4. If you have cleared the Automatic check box (automatic dimension placement)

in the Options settings of the Dimension Settings dialog box, click the desired
location for the dimension text or texts, using the dimension trace for
guidance.

5. Click OK.

Dimensioning a Drawing 285



Note
To dimension a BSpline, you must select a point on the BSpline. The radius
dimension value is valid at the selected point; the dimension value may be
different at different points.

Dimensioning using Tangents
Tangential dimensions are useful for dimensioning geometry where vertices are
not available. This section shows how to create tangential dimensions on the
following elements:

• Circle
• Arc
• Fillet
• Ellipse
• B-spline (closed, both interpolation and control)

Note
Tangential dimensions are not possible for open B-splines.

Creo Elements/Direct Drafting always chooses the extreme tangent points of a
closed B-spline for dimensioning, for the B-spline with more than two tangent
points at the given angle. If you select the points on a closed B-spline and a circle,
arc, line, fillet or an ellipse, Creo Elements/Direct Drafting automatically chooses
the tangent point of the B-spline which is closest to the selected point on that
bspline.
The following figure shows examples of tangential dimensioning on a closed B-
spline using each option.
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Figure 100. Tangential Dimensioning

To create tangential dimensions:

1. Click Drafting and then, in the Annotate group, click the arrow next to
Circular.

2. Click Tangential and then, click the required Orient button in the gallery
and perform the associated procedure.
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Orient Button Purpose Procedure

Inclined
Draw tangential
dimensions in an
inclined plane.

a. Select the two
elements to be
dimensioned. The
dimension appears at
the cursor.

b. Type the inclination
angle of the
dimension in the
user input line and
press ENTER or
move the cursor to
define the angle.

c. If you have cleared
the Automatic check
box (automatic
dimension
placement) in the
Options settings of
the Dimension
Settings dialog box,
click the desired
location for the
dimension text or
texts, using the
dimension trace for
guidance.

d. Click OK.
Note
You can specify any
value of the
inclination angle,
Creo Elements/
Direct Drafting
converts the angle
between 360 and
-360 degrees.

Parallel
Draw a tangential
dimension that is
parallel to a line through

a. Select the two
elements to be
dimensioned. The
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Orient Button Purpose Procedure
the tangent points. dimension appears at

the cursor.

b. Click OK.

Horizontal
Draw tangential
dimensions in the
horizontal plane.

a. Select the two
elements to be
dimensioned. The
dimension appears at
the cursor.

b. If you have cleared
the Automatic check
box (automatic
dimension
placement) in the
Options settings of
the Dimension
Settings dialog box,
click the desired
location for the
dimension text or
texts, using the
dimension trace for
guidance.

c. Click OK.

Vertical
Draw tangential
dimensions in the
vertical plane.

a. Select the two
elements to be
dimensioned. The
dimension appears at
the cursor.

b. If you have cleared
the Automatic check
box (automatic
dimension
placement) in the
Options settings of
the Dimension
Settings dialog box,
click the desired
location for the
dimension text or
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Orient Button Purpose Procedure
texts, using the
dimension trace for
guidance.

c. Click OK.

Perpendicular to
Line

Draw a tangential
dimension perpendicular
to a given line.

a. Select a reference
line in the viewport.
You can select any
line on the drawing
as the reference line.

b. Select the two
elements to be
dimensioned. The
dimension appears at
the cursor.

c. If you have cleared
the Automatic check
box (automatic
dimension
placement) in the
Options settings of
the Dimension
Settings dialog box,
click the desired
location for the
dimension text or
texts, using the
dimension trace for
guidance.

d. Click OK.
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Orient Button Purpose Procedure

Parallel to Line
Draw a tangential
dimension parallel to a
reference line.

a. Select a reference
line in the viewport.
You can select any
line on the drawing
as the reference line.

b. Select the two
elements to be
dimensioned. The
dimension appears at
the cursor.

c. If you have cleared
the Automatic check
box (automatic
dimension
placement) in the
Options settings of
the Dimension
Settings dialog box,
click the desired
location for the
dimension text or
texts, using the
dimension trace for
guidance.

d. Click OK.

Dimensioning a Diameter
This section shows how to dimension the diameter of a:

• Circle
• Arc
• Fillet feature
You can locate the dimension text either inside or outside the diameter.
To dimension a circle, arc or fillet:

1. Click Drafting and then, in the Annotate group, click the arrow next to
Circular.
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2. Click Diameter and then click the required Orient button in the gallery:

• Click Center Line to dimension the diameter of a feature with the
dimension line drawn from the feature center.

• Click No Center Line to dimension the diameter of a feature with the
dimension line drawn towards the center of the feature but not connecting
with the center.

Figure 101. Dimensioning Circles with and without a Centerline

3. Select one or more circle, arc, or fillet features.
4. If you have cleared the Automatic check box (automatic dimension placement)

in the Options settings of the Dimension Settings dialog box, click the desired
location for the dimension text or texts, using the dimension trace for
guidance.

5. Click OK.

Dimensioning Arcs
Creo Elements/Direct Drafting can measure the length or angle of the major or
minor arc. When dimensioning arcs singly, you determine which measurement is
used by selecting either the start or end point of the arc first. When dimensioning
multiple arcs at once, the length or angle of the major arc will be measured Creo
Elements/Direct Drafting measures arcs in a counterclockwise direction.
Dimensioning the length or angle between two arcs is also possible, but only for
arcs with the same radius and center.
You can locate the dimension either inside or outside the arc.

To dimension an arc using Arc Length:

1. Click Drafting and then, in the Annotate group, click the arrow next to
Circular.

2. Click Arc Length.
3. Select the arc features to be dimensioned. You can either:
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• Identify the first and second end points on individual arcs. The order in
which you select the endpoints determines whether the major or minor arc
is dimensioned.

• Identify one or more arc elements using the Select window or by enclosing
them in a box. The major arc will be dimensioned for all selected arcs.

4. If you have cleared the Automatic check box (automatic dimension placement)
in the Options settings of the Dimension Settings dialog box, click the desired
location for the dimension text or texts, using the dimension trace for
guidance.

5. Click OK.

To dimension an arc using Arc Angle:

1. Click Drafting and then, in the Annotate group, click the arrow next to
Angular.

2. Click Arc Angle.
3. Select the arc features to be dimensioned. You can either:

• Identify the first and second end points on individual arcs. The order in
which you select the endpoints determines whether the major or minor arc
is dimensioned.

• Identify one or more arc elements using the Select window or by enclosing
them in a box. The major arc will be dimensioned for all selected arcs.

4. If you have cleared the Automatic check box (automatic dimension placement)
in the Options settings of the Dimension Settings dialog box, click the desired
location for the dimension text or texts, using the dimension trace for
guidance.

5. Click OK.
Figure 102 on page 294 shows two possible results of length and angle
dimensions obtained using Arc Dimension UI. Each arc end point is marked in the
order in which it has been identified.
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Figure 102. Dimensioning Arcs — Two Results

Angle and Chamfer Dimensioning

Dimensioning Angles
During your work you will need to dimension angles between lines. Creo
Elements/Direct Drafting measures an angle depending on the order in which you
identify the lines making up the angle. Therefore, there are two possible results for
each Angle button. Creo Elements/Direct Drafting measures angles in a
counterclockwise direction.
To dimension an angle:

1. Click Drafting and then, in the Annotate group, click the arrow next to
Angular.

2. Click Angle.
3. In the Orient gallery, select the required button.
4. Click the two lines that make up the angle.
5. If you have cleared the Automatic check box (automatic dimension placement)

in the Options settings of the Dimension Settings dialog box, click the desired
location for the dimension text or texts, using the dimension trace for
guidance.

6. Click OK.
The buttons in the Orient gallery are:
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• Direct

• Opposite

• Adjacent Negative

• Adjacent Positive
For each of the above button you can achieve two results.
Figure 103 on page 295 shows how you identify the angle lines in the opposite
order to achieve a different result.

Figure 103. Identifying Angle Lines

Between Two Lines
Figure 104 on page 295 shows the two possible results.

Figure 104. Angle Between Two Lines —Two Results

To dimension the angle between two lines:

1. Click Drafting and then, in the Annotate group, click the arrow next to
Angular.

2. Click Angle.

3. In the Orient gallery, select Direct.
4. Select the two lines making up the angle (the angle dimensioned depends upon

which of the two lines you identify first).
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5. If you have cleared the Automatic check box (automatic dimension placement)
in the Options settings of the Dimension Settings dialog box, click the desired
location for the dimension text or texts, using the dimension trace for
guidance.

Between Intersections
Figure 105 on page 296 shows the two possible results.

Figure 105. Angle Between Intersections — Two Results

To dimension the angle between the projected intersection of two lines:

1. Click Drafting and then, in the Annotate group, click the arrow next to
Angular.

2. Click Angle.

3. In the Orient gallery, select Opposite.
4. Click the two lines making up the angle (the angle dimensioned will depend

upon which of the two lines you identify first).
5. If you have cleared the Automatic check box (automatic dimension placement)

in the Options settings of the Dimension Settings dialog box, click the desired
location for the dimension text or texts, using the dimension trace for
guidance.

Between First and Second Line
Figure 106 on page 297 shows the two possible results.
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Figure 106. Angle Between First and Second Line — Two Results

To dimension the angle between the first line you clicked and the projection of the
second line:

1. Click Drafting and then, in the Annotate group, click the arrow next to
Angular.

2. Click Angle.

3. In the Orient gallery, select Adjacent Negative.
4. Click the two lines making up the angle (the angle dimensioned depends upon

which of the two lines you identify first).
5. If you have cleared the Automatic check box (automatic dimension placement)

in the Options settings of the Dimension Settings dialog box, click the desired
location for the dimension text or texts, using the dimension trace for
guidance.

Between Second and First Line
Figure 107 on page 297 shows the two possible results.

Figure 107. Angle Between Second and First Line — Two Results

To dimension the angle between the second line you clicked and the projection of
the first line:

1. Click Drafting and then, in the Annotate group, click the arrow next to
Angular.

Dimensioning a Drawing 297



2. Click Angle.

3. In the Orient gallery, select Adjacent Positive.
4. Click the two lines making up the angle (the angle dimensioned depends upon

which of the two lines you identify first).
5. If you have cleared the Automatic check box (automatic dimension placement)

in the Options settings of the Dimension Settings dialog box, click the desired
location for the dimension text or texts, using the dimension trace for
guidance.

Dimensioning a Chamfer

Chamfered surfaces can be dimensioned using Chamfer under Line in the
Annotate group on the Drafting tab. (This feature is required in certain countries to
meet recognized design standards.)
By default, the chamfer dimension is preceded by the character C. Only
chamfered surfaces created with the chamfer option Vertex or set at an angle of
45° can be dimensioned.

Figure 108. Dimensioning a Chamfer

To dimension a chamfer:

1. Click Drafting and then, in the Annotate group, click the arrow next to
Linear.

2. Click Chamfer.
3. Click the chamfer you want to dimension.
4. If you have cleared the Automatic check box (automatic dimension placement)

in the Options settings of the Dimension Settings dialog box, click the desired
location for the dimension text or texts, using the dimension trace for
guidance.

5. Click OK.
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Note
• You can use DIM_CHAMFER_TEXT_CONTROL and DIM_CHAMFER_

PREFIX_STRING to change the default chamfer prefix string.
• If you stretch a chamfer or its reference geometry, the chamfer reference

geometry is updated. However, the chamfer dimensions are not updated. The
chamfer dimensions are not visible after you stretch the chamfer.

Geometry-Sensing Assignment
The Geo Sense and Scan buttons in the Annotate group on the Drafting
tab quickly generate basic dimensioning for a selected set of drawing elements
based on their geometry types, positions, and parametric constraints, if any.
Geometry-sensing assignment is not intended to provide "automatic"
dimensioning. It is best used to provide a basic dimensioning framework that you
can then modify as needed to generate the final dimensioning.

Dimensioning with Geo Sense

Geo Sense assigns dimensions to preselected types (see Geo Sense Settings
on page 339) of geometric elements. The type and location of the dimensions is
determined automatically by the system, based on the geometry type and the
location of the selected elements. The following dimension types can be
generated:
DIM_LINE for lines
DIM_RADIUS for arcs, fillets and circles (by default)
DIM_DIAMETER for arcs, fillets and circles (optional)
DIM_CHAMFER for 45-degree chamfers (optional)
DIM_ARC for arcs and fillets (optional)

To assign dimensions with Geo Sense:

1. Click Drafting and then, in the Annotate group, click More.

2. Under Automatic Dimensioning, click Geo Sense.
3. Click the required line, arc, fillet, chamfers or circle.
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4. Select a group of drawing elements, either with the Select buttons or by
enclosing them in a box.

Creo Elements/Direct Drafting generates and positions dimensions for the
selected elements.

5. Click OK.

Dimensioning with Scan

Scan assigns dimensions to preselected types (see Scan Settings on page 340)
of geometric elements. The type and location of the dimensions are determined
from parametric constraints currently assigned to the selected elements. Generally,
the constraint information allows Creo Elements/Direct Drafting to generate more

accurate dimensioning than is possible with Geo Sense. If no constraints are
present in the selected geometry, however, dimensions will not be generated.

Scan generates the following dimension types for selected elements:
DIM_LINE for lines and splines
DIM_ANGLE for angle elements
DIM_RADIUS for arcs, fillets and circles (by default)
DIM_DIAMETER for arcs, fillets and circles (optional)

To assign dimensions with Scan:

1. Click Drafting and then, in the Annotate group, click More.

2. Under Automatic Dimensioning, click Scan.
3. Click the required line, arc, fillet, chamfers or circle.
4. Select a group of drawing elements, which must have been previously given

parametric constraints, either with the Select buttons or by enclosing them
in a box.

Creo Elements/Direct Drafting generates dimensions for the selected elements.

5. Click OK.
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Database-Matching Assignment
Database-matching commands allow you to create a database of common
drawings, parts, or features that have already been dimensioned to company
standards. You can then use the entries in this database as templates for assigning
dimensions to similar (but not necessarily identical) features and parts in the
future, ensuring consistent dimensioning.
All database-matching commands are found in the Dimension Match dialog box

which you can access using the Match button in the Annotate group on the
Drafting tab.

Database Matching Example
1. Draw and dimension the flange shown in Figure 109 on page 301.

Figure 109. Initial Part for Database Matching

2. Add the flange to the dimension database:

a. Delete the construction lines from the drawing.
b. Click Drafting and then, in the Annotate group, click More.

c. Under Automatic Dimensioning, click Match.

The Dimension Match dialog box opens.
d. Click Add.
e. Type the name 'Flange 001' when prompted.
f. Select the entire drawing by boxing it.
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Creo Elements/Direct Drafting adds your drawing to the dimension
database.

3. Delete all dimensions from your drawing, and using the buttons on the Modify
tab, make two or three copies of it. You can further modify each copy by
scaling the whole part or resizing the holes (Figure 110 on page 302). Do not
make modifications that alter the basic topology of the part.

Figure 110. New Parts Needing Dimensions

4. Return to the Dimension Match dialog box and click the Flange 001 entry
from the database table.

Creo Elements/Direct Drafting shows the Flange 001 entry in the style
display window.

5. Identify a reference element on the Flange 001 entry by clicking directly in
the style display window. For this example, start by clicking the line element
on the lower left edge of the flange.

6. Identify the corresponding target element on one of the flanges in your
drawing.

Creo Elements/Direct Drafting transfers the dimensioning from the database
entry to the target drawing (Figure 111 on page 303). You may need to repeat
the previous two steps in order to transfer the dimensioning for the flange
holes.

Note that each time you transfer dimensions from the database to the target, a
portion of the database entry is highlighted. Once a database element is
highlighted, it cannot be used for further matching during this iteration of the
command. You can start a new iteration of the command by clicking the name
of the entry from the database table.
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7. Repeat the previous three steps as needed until all the flanges in your drawing
are dimensioned.

Figure 111. Assigning Dimensions from the Database

Adding Entries to the Dimension Database
1. Click Drafting and then, in the Annotate group, click More.

2. Under Automatic Dimensioning, click Match.

The Dimension Match dialog box opens.
3. Click Add.
4. Type the name that will identify this entry (‘flange 002’, for example).
5. Select the geometry to be added to the database by boxing.
Creo Elements/Direct Drafting creates a new entry in the database and adds the
selected geometry under that entry.

Deleting Entries from the Dimension Database
1. Click Drafting and then, in the Annotate group, click More.

2. Under Automatic Dimensioning, click Match.
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The Dimension Match dialog box opens.
3. Click Delete.
4. Enter the name of the entry to be deleted, either by clicking its entry in the

dimension database table or by typing it in the user input line.
Creo Elements/Direct Drafting deletes the selected entry from the dimension
database.

Assigning Dimensions from the Database
1. Click Drafting and then, in the Annotate group, click More.

2. Under Automatic Dimensioning, click Match.

The Dimension Match dialog box opens.
3. Select a database entry by clicking its entry in the database table.

Creo Elements/Direct Drafting draws the database entry in the style display
window.

4. Click one end of a reference element on the database entry. Do this by clicking
in the style display window.

5. Click the corresponding end of a target element in your drawing.

Creo Elements/Direct Drafting dimensions your drawing to match the
database entry.

6. Click OK.

Note
If you find that a template image in the style display window is too small or
not detailed enough for you to easily select a reference element, you can use
the View buttons in this window to make your job easier. To make the style
display window active so that these commands will work on it, click on the
mark at the top right corner of the window.

Working Methods and Limitations
When assigning dimensions from the database, you should follow the guidelines
below for the best results.
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• Make sure that the geometry of the dimensioned part does not contain any
duplicate or stacked contours. Optionally, use the Parametric Design module to
remove such contours.

• Make sure that the dimensioned geometry does not contain any unwanted
gaps. Click the Vertex check box in the Show dialog box to check for green
vertices (which indicate gaps).

• To identify an element, it is best to click it near its center. Then click a point
on the element (such as a vertex) away from its center.

• The topology of the database entry and your drawing must be the same. You
cannot, for example, use a circular template to assign dimensions to a
rectangle. The assignment tool can compensate for minor topological
differences such as line splits, but major differences will lead to unsatisfactory
results.

The topological differences between a database entry and your drawing may
be subtle. If dimension assignments don't appear to be working correctly, you
can click the Vertex check box in the Show dialog box in your drawing
window to try to track down the differences.

• The part structure (if any) of the database entry and your drawing should be
similar. Results can be unsatisfactory if you try to match a multi-part database
entry to a single-part drawing.

• The reference element on the database entry and the target element on your
drawing must be in the same relative location, or the resulting dimensioning
will be unpredictable.

• A reference element can only be matched once in a single iteration of
Match. Once you have matched one or more reference elements to your
drawing, they are highlighted in the style display to indicate that they cannot
be used for further matching.

Exporting a Database Entry
The Export option copies a selected entry from the dimensioning database into the
current drawing. The copied entry becomes a new part in the current drawing.
A common application for Export is to edit an entry in the dimensioning database.
To edit a database entry, export it into the current drawing, edit the exported
geometry, and then Add it back into the database.
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Saving and Loading Dimension Databases
You can use the Store and Load options to save the current dimension database to
a file and later reload it into Creo Elements/Direct Drafting. Note that when you
load a database into Creo Elements/Direct Drafting, its entries are appended to the
current database.
To save the current database:

1. Click Drafting and then, in the Annotate group, click More.

2. Under Automatic Dimensioning, click Match.

The Dimension Match dialog box opens.
3. Click Store.
4. Type a filename (Flange_DB, for example).

Creo Elements/Direct Drafting stores the current database under the given
filename.

To load a dimension database from a file, appending to the current database:

1. Click Drafting and then, in the Annotate group, click More.

2. Under Automatic Dimensioning, click Match.

The Dimension Match dialog box opens.
3. Click Load.
4. Type or select a filename (for example, Flange2_DB).

Creo Elements/Direct Drafting loads the entries from the named database file
at the end of the current database.

Unloading the Dimension Database From Memory
To unload the current dimension database from memory and clear the current
database table, use the Unload command:

1. Click Drafting and then, in the Annotate group, click More.

2. Under Automatic Dimensioning, click Match.

The Dimension Match dialog box opens.
3. Click Unload.

Creo Elements/Direct Drafting unloads the current database from memory.
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Common Interrupt Functions
You can interrupt any direct assignment command to change the prefix, postfix,
and/or tolerance values for the dimension text. To find out how to predefine these
values, see Predefining Prefixes, Postfixes, Superfixes, Subfixes, and Tolerances
on page 324 in this chapter.

Adding a New Prefix
You can interrupt a dimensioning command to add a new prefix to the dimension
text. Examples of prefixes are:

• DIA (diameter)
• R (radius)
• CHAMFER
• BC (base circle)
After entering the prefix, complete the dimensioning command and Creo
Elements/Direct Drafting will draw the dimension including the prefix.
The new prefix will also be included in all subsequently assigned dimensions.
This avoids having to enter the same prefix every time you are dimensioning a
similar geometry feature.
To add a new prefix:

1. Click Modify and then, in the Annotate group, click Style.

2. Click Text Extension.

The Set Text Extension dialog box opens.
3. Click the button next to Text.

The Edit Text dialog box opens.
4. Define the prefix.
5. Complete the dimensioning command.

Creo Elements/Direct Drafting draws the dimension including the prefix text.
To cancel the function and leave the dimensioning command active, click Clear.

Adding Special Characters
You can include special characters such as ° and Phi in your prefix:

1. Select and copy the special character from any character table or from an
existing text document in your Windows environment.

2. Click the Edit Text box.
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3. Right-click and select Paste to add the special character to the prefix.
Also, you can add any special character defined in the hp_symbols and hp_
symbols2 fonts. See Special Characters in Dimension Text Extensions on page
328 for instructions.

Dimension Line Settings
You can set the attributes of dimension lines using the Dimension Settings dialog
box.
To open the Dimension Settings dialog box:

• Click File ▶ Settings ▶ Dimension.
The Line settings of the Dimension Settings dialog box enable you to set attributes
of dimension lines:

• Line Settings
• Terminator (Arrow) Settings
These settings are applied to all subsequent dimensioning that you assign using
the Annotate group.

Line Settings
In the Line area of the Line settings in the Dimension Settings dialog box, you can
set the following dimension line attributes:
Width Sets the width for all subsequent dimension lines.
Offset Line Sets the distance between the top end of the extension

line and the dimension line.
Space Sets the distance between the dimension text and the

dimension line.
Datum Step Sets the vertical distance (or step) that is automatically

placed between datum dimension lines drawn with the
dimension placement set to Automatic.

Color Sets the color for extension lines, dimension lines, and
text frames.

Offset Point Sets the offset distance between a geometry feature and
the dimensioning extension lines.

Minimum Space Sets the minimum distance allowed between a geometry
feature and its dimension line.

Catch Line Sets whether or not a dimension may be selected by
clicking its dimension line, extension line, or text.
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Broken Sets whether or not a line is drawn between the extension
lines of a dimension when the dimension text is placed
outside of the extension lines.

Catch Range Sets the size of the catch range used to automatically
center dimensioning text between extension lines.

Dimension Line Width
To set the width of the dimension line:

1. Click Line in the Dimension Settings dialog box.
2. In the Width box, type the required value (such as .25).
Dimension a drawing element to see the effect of the changed dimension line
width.

Figure 112. Dimension Line Width

Offset Line
Various national standards are used for dimensioning (American Standards,
British Standards, and so on). You can set the distance (or offset) between the top
end of the extension line and the dimension line to conform to the standards you
use. The Creo Elements/Direct Drafting default for this distance is 2 mm.
To set the dimension offset:

1. Click Line in the Dimension Settings dialog box.
2. In the Offset Line box, type a positive value (for example 3).

Creo Elements/Direct Drafting sets this distance for all subsequent
dimensions.

Figure 113. Dimension Offset Line Distance on page 310 shows the dimension
offset line distance.
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Figure 113. Dimension Offset Line Distance

Space
The Space box enables you to specify a gap between the dimension text and its
associated dimension line.

Note
This gap is shown only if the dimension text location is set to On. See
Dimension Text Location on page 321.

To set this space:

1. Click Line in the Dimension Settings dialog box.
2. In the Space box, type a positive value (for example 2.3).
Figure 114. Distance between Dimension Lines and Text on page 310 shows the
distance between the inner ends of the dimension lines and the dimension text.
The Creo Elements/Direct Drafting default for this distance is 2 mm.

Figure 114. Distance between Dimension Lines and Text

Datum Step
You may find that your datum dimensions are positioned too close together. This
section shows how to specify a vertical distance (or step) between each
subsequent datum dimension line.
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The Creo Elements/Direct Drafting default for this distance is 8 mm. The distance

is active for the Datum Long and Datum Short buttons.
To specify a datum step:

1. Click Line in the Dimension Settings dialog box.
2. In the Datum Step box, type a new distance value.

Creo Elements/Direct Drafting sets the vertical distance to the new value.
3. Complete, or start the dimensioning command.

Creo Elements/Direct Drafting steps the dimension line for each dimension.

Example
Figure 115 on page 311 shows the difference between:

• Datum dimensioning without using Datum Step (datum step distance is 0).
This produces a poor quality dimension where the dimension text has been
overwritten by the dimension lines.

• Datum dimensioning using Datum Step (datum step distance is 10).

Figure 115. Datum Stepping

Dimension Line Color
To set the color of dimension lines and dimension extension lines:

1. Click Line in the Dimension Settings dialog box.
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2. Select a color from the Color box. Refer to Defining Custom Colors on page
100 for instructions on defining custom colors.

Tip
To set a single color for dimension lines and dimension texts while

defining a dimension (when dimension buttons are active), use in the
Format group on the Drafting tab.

Dimension Offset Point
Various national standards are used for dimensioning (American Standards,
British Standards, and so on). You can set the distance (or offset) between the
geometry feature and the dimension extension lines to conform to the standards
you use. The Creo Elements/Direct Drafting default for this distance is 0 mm.
To set the dimension offset point distance:

1. Click Line in the Dimension Settings dialog box.
2. In the Offset Point box, type a positive value (such as 1.5).
Figure 116 on page 312 shows the dimension offset point.

Figure 116. Dimension Offset Point

Minimum Space
This section shows how to avoid crowding dimensions by setting a minimum
distance (or space) between the geometry feature you are dimensioning and the
dimension line. If you try to locate the dimension trace closer than the minimum
distance, the trace will skip to the opposite side of the geometry feature. The Creo
Elements/Direct Drafting default for this distance is 0 mm.
To set the minimum space:

1. Click Line in the Dimension Settings dialog box.

312 Creo Elements/Direct Drafting User's Guide: Fluent User Interface



2. In the Minimum Space box, type a positive value (such as 10).
Refer to Figure 117 on page 313. If you try to locate the dimension text closer
than the minimum distance (10 mm), the dimension skips to the opposite side of
the geometry feature.

Figure 117. Locating a Dimension – Closer Than the Minimum
Distance

Catch Line
When you want to select a dimension, you can specify which components of the
dimension can be selected. This is done by clicking or clearing the Catch Line
check box in Line settings of the Dimension Settings dialog box.

Click A dimension may be selected by clicking one of the
dimension components:
• Dimension line
• Extension line
• Dimension text
This is the default.

Clear A dimension may be selected by clicking the dimension
text only.

Broken or Unbroken Dimension Lines

Drawing Dimension Lines Inside Extension Lines
Because of space limitations when dimensioning, you may want to place
dimension text outside the extension lines, but still want the dimension lines to be
drawn inside the extension lines.
To draw an unbroken dimension line inside the extension lines:

1. Click Line in the Dimension Settings dialog box.
2. Clear the Broken check box.
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Figure 118. Dimension Lines Inside Extension Lines on page 314 shows
dimension lines drawn inside the extension lines and dimension text outside.

Figure 118. Dimension Lines Inside Extension Lines

Drawing Dimension Lines Outside Extension Lines
Because of space limitations you might want to place dimension lines and text
outside the extension lines.
To draw an unbroken dimension line outside the extension lines:

1. Click Line in the Dimension Settings dialog box.
2. Click the Broken check box.
Figure 119. Dimension Lines and Text Outside Extension Lines on page 314
shows how dimension lines and text are drawn outside the extension lines.

Figure 119. Dimension Lines and Text Outside Extension Lines

Catch Range
This section shows how to center dimension text whenever you indicate a point
within the catch range. The catch range is governed by two catch lines parallel to
the extension lines. The origin is the bisection of the distance between the two
extension lines and the catch range is the horizontal distance from the origin to the
catch lines. If you indicate any point within the catch range, Creo Elements/Direct
Drafting will center the dimension text exactly between the two extension lines.
Figure 120 on page 315 shows the catch range. Any point you indicate within the
catch range results in Creo Elements/Direct Drafting centering the dimension text.
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To specify the catch range:

1. Click Line in the Dimension Settings dialog box.
2. In the Catch Range box, type the catch range value.

Figure 120. Dimension Catch Range

Terminator Settings
Creo Elements/Direct Drafting allows you to set the type, size, and fill attributes
for all subsequent dimension line terminators in the Arrow area of the Line
settings.
Normally, the terminator is an arrowhead.
Figure 121 on page 315 shows the five possible dimension line terminators:

Figure 121. Dimension Line Terminators

To set the dimension line terminator:

1. Click Line in the Dimension Settings dialog box.
2. Select the required terminator settings in the Arrow area.

Creo Elements/Direct Drafting uses these settings for all subsequent
dimensions.

You can set the first, the second or both terminators using the following options:
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• Both Identical

• First Arrow

• Second Arrow

Both
Click the Both Identical check box and then select the required settings. The
settings you select applies to both the dimension line terminators.

First Arrow
In the First Arrow area, define the settings for applying the chosen terminator
settings to the first point you click when identifying the dimension start-point.

Second Arrow
In the Second Arrow area, define the settings for applying the chosen terminator
settings to the second point you click when identifying the dimension end-point.

Figure 122. Dimension Terminators — First and Second

A Both (arrow type)
B First (dot type)
C Second (dot type)
D First (dot type — notice which is the first point)

Because you specify a first point and a second point, it makes no difference if the
dimensions are horizontal or vertical.

Terminator Position
By default, the position of terminators with respect to the extension lines is
determined automatically. If there is enough room between the dimension's
extension lines for the terminators and dimension text, the terminators are placed
between the extension lines. Otherwise, terminators are placed outside of the
extension lines. The terminator position can also be set manually.
To set the terminator position:

1. Click Line in the Dimension Settings dialog box.
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2. In the Position box, select Auto or Inside or Outside.

Note
You cannot change the direction of arrows in Broken on page 308 dimension
lines.

Absolute Terminator Size
The Creo Elements/Direct Drafting default terminator size is 3.5 mm. To set the
absolute size of the terminator:

1. Click Line in the Dimension Settings dialog box.
2. In the Size box, type a value for the terminator size.

Relative Terminator Size
You can set the size of the dimension line terminator by entering a scale factor
relative to the main dimension text size.
The Creo Elements/Direct Drafting default scale factor is 1 and the default main
dimension text size is 3.5 mm.
To set the relative size of the dimension line terminator:

1. Click Line in the Dimension Settings dialog box.
2. Click the Relative check box.

Terminator Fill On or Off
By default, dimension line terminators are filled.
To enable or disable the filling of dimension line terminators:

1. Click Line in the Dimension Settings dialog box.
2. Click or clear the Fill check box to enable or disable the fill mode.

Example
Figure 123 on page 318 shows unfilled dot type terminators.
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Figure 123. Unfilled Dot Type Terminators

Dimension Text Settings
The Text settings on the Dimension Settings dialog box enable you to set the
attributes of all dimension text or of specific dimension text components. These
settings will be applied to all subsequent dimensioning that you assign via the
Annotate tab.
Set Enables you to select the dimension text components to

which the dimension text settings will apply.
Font Sets the font in which these dimension text components

will be displayed.
Color Sets the color for the selected dimension text

components.
Orientation Sets the orientation for the selected dimension text

components.
Frame Determines what kind of box (if any) is drawn around

subsequent dimensioning text.
Location Sets the location of the dimension text relative to the

dimension line.
Size Sets the size of dimension text.
Offset Line Sets the offset distance between dimension text and the

dimension line.
Slant Sets the dimension text slant.
Ratio Sets the character height-to-width ratio of dimension

text. Sets text appearance attributes such as size, font,
slant, and aspect ratio.

Brackets Encloses primary and secondary dimension text in
brackets.

Fill Fills characters of block fonts.
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Dimension Text Components
Dimension text is comprised of several components:

• Prefix
• Dimension value
• Tolerance
• Postfix
To select the dimension text component(s) to which you want to apply the
dimension text settings:

1. Click Text in the Dimension Settings dialog box.
2. In the Set box, select a dimension text component from the following:

• Upper

• Lower

By default, the dimension text settings apply to all dimension text components.
3. Click the All check box to apply the dimension settings to dimension text

components.
4. Select or specify the required dimension text settings.

Creo Elements/Direct Drafting uses these settings for all subsequent
dimensions.

Dimension Text Font
To select a dimension text font:

1. Click Text in the Dimension Settings dialog box.
2. In the Font box, select a font. The font names in this selection list include:

• Fonts supplied with Creo Elements/Direct Drafting
• Fonts already installed on your PC.

To load additional fonts for selection, follow the instructions in Importing a Font
on page 543.

Dimension Text Color
To set the color of dimension text:

1. Click Text in the Dimension Settings dialog box.
2. In the Color box, select a color. Refer to Defining Custom Colors on page 100

for instructions on defining custom colors.
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Tip
To set a single color for dimension texts and dimension lines while

defining a dimension (when dimension buttons are active), use in the
Format group on the Drafting tab.

Dimension Text Orientation
The orientation of the dimension text can be one of the following:

Figure 124. Dimension Orientation

1 Parallel to the dimension line. This is the default.
2 Horizontal (2).
3 Vertical (3).
4 Perpendicular to the dimension line.

To set the orientation of dimension text:

1. Click Text in the Dimension Settings dialog box.
2. In the All Texts area, select one of the following in the Orientation box:

• Parallel

• Perpendicular

• Horizontal

• Vertical

Dimension Text Frame
To set the dimension text frame:

1. Click Text in the Dimension Settings dialog box.
2. In the All Texts area, select one of the following in the Frame box:
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• None

• Box

• Balloon

• Flag

• Basic

The basic dimension text frame allows you to have a frame just around the
dimension main text; by that you can mark all basic dimensions in your drawing.
In addition to that Creo Elements/Direct Drafting enables you to include a user-
defined portion of the prefix and postfix text into the basic frame in addition to the
normal prefix and postfix text outside the frame. You can add and edit both, the
basic and normal prefix and postfix text. You can also convert an existing
dimension text frame to a basic dimension text frame.
Figure 125 on page 321 shows the dimension text frame options.

Figure 125. Dimension Text Frame – Options

Dimension Text Location
The location of dimension can be in one of three positions:

Figure 126. Dimension Location

1 On the dimension line.
2 Above the dimension line. This is the default.
3 Below the dimension line.

To set the location of dimension text:

1. Click Text in the Dimension Settings dialog box.
2. In the All Texts area, select one of the following in the Location box:

• On

• Above
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• Below

Absolute Dimension Text Size
The Creo Elements/Direct Drafting default dimension text size (character height)
is 3.5 mm. To set the absolute size of dimension text:

1. Click Text in the Dimension Settings dialog box.
2. Ensure that you clear the Relative check box.
3. In the Size box, type the absolute dimension text size.

Relative Dimension Text Size
Creo Elements/Direct Drafting multiplies the relative factor by the current main
dimension text size. This gives a new text size for all selected dimension text.
To set a relative text size:

1. Click Text in the Dimension Settings dialog box.
2. Ensure that you click the Relative check box.
3. In the Size box, type the relative dimension text size.

Dimension Text Offset

Note
This function only works if you have previously selected either Above or
Below in the Location box.

Figure 127 on page 322 shows the distance (or offset) between the dimension line
and dimension text. The Creo Elements/Direct Drafting default for this distance is
2 mm.

Figure 127. Dimension Text Offset

To set the dimension text offset:
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1. Click Text in the Dimension Settings dialog box.
2. In the Offset Line box, type a positive offset.

Dimension Text Slant
The Creo Elements/Direct Drafting default slant of dimension text characters is 0
degrees.
To set the dimension text slant:

1. Click Text in the Dimension Settings dialog box.
2. In the Slant box, type a new slant angle.

Dimension Text Ratio
The Creo Elements/Direct Drafting default for the width-to-height ratio of
dimension text characters is 1. A number smaller than one narrows dimension text
characters, a number greater than one widens dimension characters.
To change the dimension text character width-to-height ratio:

1. Click Text in the Dimension Settings dialog box.
2. In the Ratio box, type the new value.

Dimension Text Brackets
Primary and secondary dimension text can be enclosed in brackets. By default,
brackets are not enabled for enclosing the primary and secondary dimension text.
To enable or disable dimension text brackets:

1. Click Text in the Dimension Settings dialog box.
2. In the Set box, select Upper or Lower.
3. Click or clear the Brackets check box to enable or disable brackets,

respectively.

Coordinate Dimension Leading Zero
The leading zero in coordinate dimensions can be shown or hidden. By default,
the leading zero is shown.
To show or hide the leading zero:

1. Click Text in the Dimension Settings dialog box.
2. In the Specific Texts area, click or clear the Coordinate Dimension - Leading

Zero check box to show or hide the leading zero, respectively.
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Predefining Prefixes, Postfixes,
Superfixes, Subfixes, and Tolerances
If you frequently add dimension text extensions (such as postfixes) to a
dimension, it is useful to first predefine these via the Dimension Settings dialog
box. Once defined, they can easily be selected from a table. Apart from making
the process quicker, this method also improves consistency.
The Text Ext settings of the Dimension Settings dialog box enable you to add,
delete, save, open and clear the following:

• Prefix

• Postfix

• Superfix

• Subfix

See What is Dimension Text? on page 253 for a definition of these terms.

Adding a Dimension Text Extension
Although the following example is for a prefix, the procedure is the same for a
postfix, a superfix, a subfix, and a tolerance.

1. Click Text Ext in the Dimension Settings dialog box.
2. In the Extension area, select Prefix in the Set box.
3. Type a name for the prefix (such as p1) into the entry field above the

(originally empty) prefix list.
4. Type the prefix text (such as the following example) in the Ext Text box.

Examples of prefixes are:

• DIA (diameter)
• R (radius)
• CHAMFER

• BC (base circle)
5. Optionally, you can select a special character to serve as the dimension text

extension:

Click Spec Char to display a graphical list of special text characters. The
Special Characters window opens.
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Note
The special characters are based on the hp_symbols and hp_
symbols2 fonts.

6. Select the special character you want to use as a dimension text extension. A
graphical representation of each character is provided in the Meta Name
column.

7. Click Insert to copy the selected special character to the dimension text
extension. Note that the meta name of this special character is added to the Ext
Text box.

8. In the Extension area, type the basic dimension prefix text string in the Ext
Text box.

9. Click Add to add this prefix to your list of prefixes. Each time you click a
dimension, you can select the desired prefix from the list.

Which Dimension Text Extension or Extensions Will be
Used in the Drawing?
When the prefix list contains multiple prefix names, the prefix named in the name
entry field (above the prefix list) will be used in any dimension you add to your
drawing. This rule also applies to the other dimension text extension types
(postfix, superfix, subfix, and tolerance). The dimension text extension specified
in the name entry field is active and will be included in subsequent dimensions.
To add a dimension plus prefix to a drawing:

1. Click Text Ext in the Dimension Settings dialog box.
2. In the Extension area, select Prefix in the Set box.
3. Click the prefix you want from the list.
4. Click the begin and end points of the dimension.

Deleting a Predefined Dimension Text Extension
Although the following example is for a prefix, the procedure is the same for a
postfix, a superfix, a subfix, and a tolerance.

1. Click Text Ext in the Dimension Settings dialog box.
2. In the Extension area, select Prefix in the Set box.
3. Select the name of the prefix to be deleted from the prefix list.
4. Click Delete to delete this prefix.
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Saving Predefined Dimension Text Extensions
Although the following example is for a prefix, the procedure is the same for a
postfix, a superfix, a subfix, and a tolerance.

1. Click Text Ext in the Dimension Settings dialog box.
2. In the Extension area, select Prefix in the Set box.
3. Click Store to display the Store dialog box.
4. Specify a filename and select a file type.
5. Click Save to save the dimension text extension or extensions.

Opening Predefined Dimension Text Extensions
Although the following example is for a prefix, the procedure is the same for a
postfix, a superfix, a subfix, and a tolerance.

1. Click Text Ext in the Dimension Settings dialog box.
2. In the Extension area, select Prefix in the Set box.
3. Click Load to display the Load dialog box.
4. Select or specify a filename under which you saved predefined dimension text

extensions.

Clearing a Predefined Dimension Text Extension
Although the following example is for a prefix, the procedure is the same for a
postfix, a superfix, a subfix, and a tolerance.

1. Click the Text Ext tab in Dimension Settings.
2. In the Extension area, select Prefix in the Set box.
3. Click Clear to remove the prefix name (if any) from the name entry field

above the prefix list. Note that the Clear command merely deactivates the
prefix. It remains in the prefix list for further use unless you Delete it.

Dimension Text Extension Settings
The Extension Text area of Text Ext settings of the Dimension Settings dialog box
enables you to define the following attributes of prefixes, postfixes, superfixes,
subfixes and tolerances:

• Font
• Color
• Ratio
• Size
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• Slant
• Special Characters
• Basic Dimension Text Extensions

Dimension Text Extension Font
To select a dimension text extension font:

1. Click Text Ext in the Dimension Settings dialog box.
2. In the Extension Text area, select a font in the Font box. The font names in this

selection list include:

• Fonts supplied with Creo Elements/Direct Drafting.
• Fonts already installed on your PC.

To load additional fonts for selection, follow the instructions in Importing a Font
on page 543.

Dimension Text Extension Color
To set the color of dimension text extensions:

1. Click Text Ext in the Dimension Settings dialog box.
2. In the Extension Text area, select a color in the Color box. Refer to Defining

Custom Colors on page 100 for instructions on defining custom colors.

Dimension Text Extension Ratio
The Creo Elements/Direct Drafting default for the width-to-height ratio of
dimension text characters is 1. A number smaller than one narrows dimension text
characters, a number greater than one widens dimension characters.
To change the dimension text character width-to-height ratio:

1. Click Text Ext in the Dimension Settings dialog box.
2. In the Extension Text area, type the new value in the Ratio box.

Absolute Dimension Text Extension Size
The Creo Elements/Direct Drafting default dimension text extension size
(character height) is 3.5 mm. To set the absolute size of dimension text extensions:

1. Click Text Ext in the Dimension Settings dialog box.
2. In the Extension Text area, ensure that you clear the Relative check box.
3. Type the absolute dimension text extension size in the Scale/Size box.
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Relative Dimension Text Extension Size
Creo Elements/Direct Drafting multiplies the relative factor by the current main
dimension text size. This gives a new text size for dimension text extensions.
To set a relative text extension size:

1. Click Text Ext in the Dimension Settings dialog box.
2. In the Extension Text area, ensure that you click the Relative check box.
3. Type the relative dimension text extension size in the Scale/Size box.

Dimension Text Extension Slant
The Creo Elements/Direct Drafting default slant of dimension text extension
characters is 0 degrees.
To set the dimension text extension slant:

1. Click Text Ext in the Dimension Settings dialog box.
2. In the Extension Text area, type a new slant angle in the Slant box.

Special Characters in Dimension Text Extensions
To add a special character to a dimension text extension:

1. Click Text Ext in the Dimension Settings dialog box.
2. In the Extension Text area, select the type of extension to which you want to

add a special character.
3. Click Spec Char to display a graphical list of special text characters.

These special characters are included in the hp_symbols and hp_
symbols2 fonts. You can create additional special characters by editing these
fonts.

4. Select the special character you want to add to the dimension text extension. A
graphical representation of each character is provided in the Meta Name
column.

5. Click Insert to copy the selected special character to the dimension text
extension.

Basic Dimension Text Extensions
To add a basic dimension text extension to a normal dimension text extension:

1. Click Text Ext in the Dimension Settings dialog box.
2. In the Extension Text area, click the button next to the Ext Text box.

The Edit Text dialog box opens.
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3. Type the basic dimension extension text in the Edit Text box.
4. Click OK to save the basic dimension text extension.
All the dimensions created after setting the basic dimension text extension inherit
the text extension.

Dimension Unit Settings
The Units settings of the Dimension Settings dialog box enable you to set the units
of all dimension text or of specific dimension text components. These settings will
be applied to all subsequent dimensioning that you assign using the dimension
buttons in the Annotate group on the Drafting and Modify tabs.
To select the dimension text component or components to which you want to
apply the unit settings:

1. Click Units in the Dimension Settings dialog box.
2. In the Units area, select a dimension text component in the Set box from the

following:

• Select Upper to set the units for the main dimension text.

This is the default setting.
• Select Lower to set the units for the lower dimension text (if applicable).

Linear Units
After you select the Upper or Lower dimension text component in the Set box,
select the linear units for that component from the following:

• Micrometers

• Millimeters

• Centimeters

• Meters

• Kilometers

• Inches

• Fractional Inches

• Feet and Fractional Inches

• Feet and Fractional Inches with Sign

• Feet and Fractional Inches with Text
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Micrometers
Select Micrometers (um) to set the dimension units to micrometers.

Millimeters
Select Millimeters to set the dimension units to millimeters. This is the default
option.

Centimeters
Select Centimeters to set the dimension units to centimeters.

Meters
Select Meters to set the dimension units to meters.

Kilometers
Select Kilometers to set the dimension units to kilometers.

Inch
Select Inches to set the dimension units to inches.

Fractional Inches
Select Fractional Inches to set the dimension units to fractional inches. For
example, 12" and 6 1/2 ".

Feet and Fractional Inches
Select Feet and Fractional Inches to set the dimension units to feet and fractional
inches. For example, 1 - 0 and 0 - 6 1/2.

Feet and Fractional Inches with Sign
Select Feet and Fractional Inches with Sign to set the dimension units to feet and
fractional inches. Creo Elements/Direct Drafting displays the dimension value
with feet and inches signs. For example, 1' - 0" and 0' - 6 1/2".

Feet and Fractional Inches with Text
Select Feet and Fractional Inches with Text to set the dimension units to feet and
fractional inches. Creo Elements/Direct Drafting displays the dimension value
with feet and inches indicated by text. For example, 1 FT 0 IN and 0 FT 6 1/2 IN.
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Angular Units
After you select the Upper or Lower dimension text component in the Set box,
select the angular units for that component from the following:

• Degrees

• Degrees Minutes Seconds

• Radians

• Gradian

Degrees
Select Degrees to set the angle dimension units to degrees.

Degrees Minutes Seconds
Select Degrees Minutes Seconds to set the angle dimension units to degrees,
minutes, and seconds.

Radians
Select Radians to set the angle dimension units to radians.

Gradian
Select Gradian to set the angle dimension units to gradian.

Decimal Places
After you select a dimension unit in the Set box of the Display area, type an
associated number format in the Decimal Places box to specify the number of
decimal places for that unit.
For example, to specify that dimensions displayed in mm are shown with two
decimal places, type 0.01:
The format string in the Decimal Places box defines:

• The type of decimal period: a comma (,) or point (.).
• The suppression of zeroes before the decimal period (left zero suppression).
• The suppression of zeroes after the decimal period (right zero suppression).
• The number of decimal places.
Creo Elements/Direct Drafting has a default format string which defines:

• The decimal period as a point (.).
• No left zero suppression. For example, 0.21 appears as 0.21.
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• Right zero suppression. For example, 2.100 appears as 2.1.
• The dimension value to be displayed to two decimal places.
For example, 2.2354 appears as 2.24 and 12.299 appears as 12.3 (notice the right
zero suppression).
This format is general and may not suit certain types of dimensioning. For
example: large scale dimensions, precision dimensions, and so on. You can use the
Decimal Places field to specify your own format string.
Table 2 on page explains the format string using six examples of how Creo
Elements/Direct Drafting would display 10.000, 3.142, and 0.090.

Table 2. Format Strings

Format
String

Represents

1, Dimension values with a decimal comma, left zeroes not suppressed,
right zeroes suppressed, and no decimal places quoted. Creo
Elements/Direct Drafting displays the values 10, 3, and 0.

0.1 Dimension values with a decimal point, left zeroes not suppressed,
right zeroes suppressed, and one decimal place quoted. Creo
Elements/Direct Drafting displays the values 10, 3.1, and 0.1.

1,1 Dimension values with a decimal comma, both left and right zeroes
suppressed, and one decimal place quoted. Creo Elements/Direct
Drafting displays the values 10, 3,1, and ,1.

1.000 Dimension values with a decimal point, with left zero suppression,
right zeroes not suppressed, three decimal places quoted. Creo
Elements/Direct Drafting displays the values 10.000, 3.142, and
.090.

0,001 Dimension values with a decimal comma, left zeroes not suppressed,
right zeroes suppressed, three decimal places quoted. Creo
Elements/Direct Drafting displays the values 10, 3,142, and 0,09.

+1,001 Dimension values with a decimal comma, with left and right zero
suppression, three decimal places quoted, plus included in value.
Creo Elements/Direct Drafting displays the values +10, +3,142, and
+,09.

Selection Filtering
When you assign dimensions to multiple drawing elements at one time, you can
also apply a selection filter. The selection filter prevents elements that meet
certain criteria from receiving dimensions. The Filter settings in the Dimension
Settings dialog box enable you to apply selection filtering.
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Drawing elements can be filtered on the basis of any combination of the following
types of criteria:

• Geometry Type
• Line Slope
• Linetype
• Pensize
• Color
• Linesize

Enabling and Disabling Selection Filtering
The selection filter can be enabled or disabled at any time by clicking or clearing
the Filter On check box, respectively, in the Filter settings of the Dimension
Settings dialog box.

Setting up the Selection Filter
Before you can use the selection filter, you must specify the filter criteria. You can
combine options from any of the categories below to come up with a filter that
meets your needs.

1. Click Filter in the Dimension Settings dialog box.
2. In the Filter area, click the On check box.
3. In the Attributes area, select a filter type from the following in the Type box:

• Geometry Type

• Line Slope

• Linetype

• Pensize

• Color

• Linesize

4. Select the required options for this filter type.
5. If needed, select other filter type and options until the selection filter is

complete.

Geometry-Type Filter
This filter excludes elements based on their geometry type. For example, if the Arc
and Circle options are set, all circular elements are excluded by this filter.
To set the geometry-type filter:
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1. Click Filter in the Dimension Settings dialog box.
2. In the Filter area, click the On check box.
3. In the Attributes area, select the Geometry Type filter type in the Type box.
4. Select one or more geometry types to add these to the filter. The Geometry

Type options are:

• Point

• Line

• Arc

• Fillet

• Circle

• Text

• Spline

• BSpline

You can click Reset to quickly remove all geometry types from the filter.

The Line Slope Filter
The line-slope filter is a list of angle ranges. Each entry in the table has a lower
bound and an upper bound, given in the current angular units. Linear elements
with orientations that fall within the angle range of any entry in the table are
excluded by this filter.
For example, if the orientation filter contains one entry with a lower bound of 30
degrees and an upper bound of 40 degrees, all lines with 33 degree elevations will
be filtered, but lines with 45 degree elevations will remain.

Adding To The Line-Slope Filter
1. Click Filter in the Dimension Settings dialog box.
2. In the Filter area, click the On check box.
3. In the Attributes area, select the Line Slope filter type in the Type box.
4. Click the Horizontal check box related to Exclude.
5. In the Lower box, type the lower bound (in current angular units).
6. In the Upper box, type the upper bound (in current angular units).
7. Click Add to create a new entry in the filter table.
To quickly add an entry for horizontal or for vertical lines, you can click the
Horizontal check box or the Vertical check box of Exclude.
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Deleting from The Line-Slope Filter
1. Click Filter in the Dimension Settings dialog box.
2. In the Attributes area, select the Line Slope filter type in the Type box.
3. Select the line slope filter row you want to delete from the list.
4. Click Delete.

Creo Elements/Direct Drafting deletes the entry from the filter table.

The Linetype Filter
This filter excludes elements based on their linetype. For example, if the Dashed
option is set, all elements with a dashed linetype will be excluded by this filter.
To set the linetype filter:

1. Click Filter in the Dimension Settings dialog box.
2. In the Attributes area, select the Linetype filter type in the Type box.
3. Click the check box of one or more linetypes to add them to the filter. Types

currently in the filter are highlighted. Click Reset to quickly remove all
linetypes from the filter.

The Linetype options are:

• Solid

• Dashed

• Long Dashed

• Dot Center

• Dash Center

• Phantom

• Center Dash Dash

• Dotted

The Pensize and Linesize Filter
The pensize and linesize filters are tables of size ranges. Each entry in the table
has a lower bound and an upper bound, given in the current distance units.
Elements with sizes that fall within the range of any entry in the table are
excluded by this filter.
For example, if the pensize filter contains one entry with a lower bound of .5 mm
and an upper bound of 1.0 mm, and a second entry with bounds of 1.1 mm and 3.0
mm, all lines with sizes between .5 mm and 3.0 mm will be filtered except for
lines with sizes between 1.0 mm and 1.1 mm.
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Adding to the Pensize or Linesize Filter
1. Click Filter in the Dimension Settings dialog box.
2. In the Attributes area, select the Pensize filter type in the Type box.
3. In the Lower box, type the lower bound.
4. In the Upper box, type the upper bound.
5. Click Add.

Creo Elements/Direct Drafting creates a new entry in the filter table.

Deleting from the Pensize or Linesize Filter
1. Click Filter in the Dimension Settings dialog box.
2. In the Attributes area, select the Pensize filter type in the Type box.
3. Select the row you want to delete from the table.
4. Click Delete.

Creo Elements/Direct Drafting deletes the entry from the filter table.

The Color Filter
The color filter is a table of colors. Elements with colors that match any entry in
the table are excluded by this filter.

Adding to the Color Filter
1. Click Filter in the Dimension Settings dialog box.
2. In the Attributes area, select the Color filter type in the Type box.
3. In the Add Color box, select a color. Refer to Defining Custom Colors on page

100 for instructions on defining custom colors.
4. Click Add.

Creo Elements/Direct Drafting creates a new entry in the filter table.
5. Click OK.

Deleting from the Color Filter
1. Click Filter in the Dimension Settings dialog box.
2. In the Attributes area, select the Color filter type in the Type box.
3. Select the color you want to delete from the list.
4. Click Delete.

Creo Elements/Direct Drafting deletes the entry from the filter list.
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Clearing the Selection Filter
To clear all filter criteria from the selection filter:

1. Click Filter in the Dimension Settings dialog box.
2. Click Reset.

Saving and Loading Selection Filters
You can use the Store and Load to save selection filters to files and later reload
them into Creo Elements/Direct Drafting, respectively.
To save the current selection filter:

1. Click Filter in the Dimension Settings dialog box.
2. Click Save.
3. Type a filename (for example, Select_filter.1) in the Name box.
4. Click Save.

Creo Elements/Direct Drafting stores the selection filter as per the specified
filename.

To load a new selection filter from a file (overwriting any current filter):

1. Click Filter in the Dimension Settings dialog box.
2. Click Load.
3. Select a filename (for example, Select_filter.1).

Creo Elements/Direct Drafting loads the specified selection filter, replacing
any current filter.

Dimension Options
The Options settings in the Dimension Settings dialog box enable you to set
dimension location options as well as well as automatic dimensioning settings.
These settings will be applied to all subsequent dimensioning that you assign
using the dimension buttons in the Annotate group on the Drafting and Modify tabs.

Dimension Location Settings
In the Dimension Location area of the Options settings, you can set the following:

• Automatic Dimension Positioning
• Auto-Placement Position
• Dimension Strategy
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Automatic Dimension Positioning
You can click the Automatic check box option to automatically place dimensions
rather than use the dimension trace (if the Automatic check box is clear).

Dimension Position Settings
By default, Creo Elements/Direct Drafting attempts to auto-place dimensions
above or to the right of their associated (linear) drawing elements. Using the
Position box in the Options settings of the Dimension Settings dialog box, you can
configure Creo Elements/Direct Drafting to place dimensions either above and to
the right or below and to the left (see Figure 128 on page 338).

Figure 128. Automatic Dimension Positioning — Above (a.) and Below
(b.)

To set the auto-placement position:

1. Click Options in the Dimension Settings dialog box.
2. In the Dimension Location area, click the Automatic check box.
3. In the Position box, select Above or Below.

Dimensioning Strategy - Interference Check
By default, Creo Elements/Direct Drafting attempts to auto-place new dimensions
so that the new dimension text does not intersect existing geometry or
dimensioning. This process is called interference check. Full interference
checking can slow down a busy system, so you are given the option of reducing or
disabling this check. Doing this may improve system performance, but will also
increase the likelihood that auto-placed dimensions will need to be re-located
later. Note that even full interference checking cannot always prevent overlaps
from occurring.
To change the level of interference checking:

1. Click Options in the Dimension Settings dialog box.
2. In the Dimension Location area, click the Automatic check box.
3. In the Strategy box, select Off, Geo, or Geo+Dim.

• Off disables all interference checking.
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• Geo checks for interference with geometry elements only.
• Geo + Dim checks for interference with geometry elements and with

existing dimensioning.
There are two check box at the bottom of the Options settings in the Dimension
Settings dialog box:

• Click the Delete Dimension Check check box to set the check option for
deleting the dimension.

• Click the Insert Dimension Check check box to set the check option for Insert.

Automatic Dimensioning Settings
In the Automatic Dimensioning Settings area of the Options dialog box, you can
set the following:

• Settings for Automatic Dimensioning using Geo Sense.
• Settings for Automatic Dimension using Scan.

Geo Sense Settings
To preselect the geometry items to be included in automatic dimensioning with
Geo Sense:

1. Click Options in the Dimension Settings dialog box.
2. In the Automatic Dimensioning Settings area, select the geometric element

types for Geo Sense:
Radius Radius dimensions are generated for all circular

elements in the selection set.
Diameter Diameter dimensions are generated for all circular

elements in the selection set.
Chamfer Chamfer dimensions are generated for any valid

chamfers in the selection set.
Arc Arc dimensions are generated for any arc elements,

including fillets, found in the selection set.

Figure 129 on page 340 illustrates the effects of these options on the resulting
dimensions.
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Figure 129. Geo Sense Options

1 Defaults
2 Diameter and Chamfer On
3 Diameter, Chamfer, and Arc On

Scan Settings
To preselect the geometry items to be included in automatic dimensioning with
Scan:

1. Click Options in the Dimension Settings dialog box.
2. In the Automatic Dimensioning Settings area, select the geometric element

types for Scan:
Radius Radius dimensions are generated for all circular

elements in the selection set.
Diameter Diameter dimensions are generated for all circular

elements in the selection set.
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Setting Dimension Attributes in the
Dimension Style Table
The Dimension Style table enables you to store your current dimensioning style
settings (font, size, units, line styles, etc.) as table entries. You can later recover
the stored style settings and make them the current dimensioning style simply by
selecting the table entry. The currently active settings are always previewed in the
style display window, so you always know what you will be assigning.
If you often dimension particular features or details in a given style, the
Dimension Style table frees you from having to manually set up that style each
time you need it.
By default, Style is clicked to indicate that you are using your own dimensioning
styles. Optionally, you can click Standard to select one of the preconfigured
industrial standards (DIN, ANSI, JIS, ISO) for dimensioning.

Adding a Style Table Entry
Before you can take advantage of the Dimension Style table, you need to add one
or more entries to hold the style settings you want to apply later. To create an
entry in this table:

1. Set up the dimensioning style that you want to save to the table. You can use
the Dimension Settings dialog box to do this. The style display window shows
the current settings.

2. Click Style in the Dimension Settings dialog box.
3. In the Style area, type a name for the new table entry in the name entry field

above the (originally empty) style table.
4. Click Add.

Creo Elements/Direct Drafting adds the new entry to the Dimension Style
table.

Setting the Current Dimension Style with the
Dimension Style Table
1. Click Style in the Dimension Settings dialog box.
2. Click an entry in the Dimension Style table to move this entry to the name

entry field above the (originally empty) style list.

The dimensioning style settings associated with this entry become the current
settings. These settings will be used for subsequent dimensioning.
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Assigning Dimension Styles

You can assign a new dimensioning style to an existing dimension using Style
.

1. Set up the desired dimensioning style, using either the Dimension Settings
dialog box or the Dimension Style table.

2. Click Modify and then, in the Annotate group, click Style.

3. Click Apply.
4. Select dimensions in your drawing to receive the new settings.

Creo Elements/Direct Drafting updates the style of the selected dimensions to
match the current style.

Setting the Current Dimension Style from An
Existing Dimension

Grab queries the style settings of a selected dimension and then makes them
the current settings. You can use these settings for new dimensions or store them
as an entry in the Style table.

1. Click Modify and then, in the Annotate group, click Style.

2. Click Grab.
3. Select the text of a dimension in your drawing.

Creo Elements/Direct Drafting makes the style settings of the selected
dimension the current settings.

4. Click OK.

Editing a Dimension Style Table Entry
Each entry in the Dimension Style table is a macro that contains the dimension
style commands needed to define the entry's style. The entry can be modified by
editing this macro.

1. Click Style in the Dimension Settings dialog box.
2. Select the table entry you wish to change.
3. Click Edit. Creo Elements/Direct Drafting displays the entry's macro in a

screen editor window.
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4. Edit the text, then save and exit the file.

Deleting an Entry
1. Click Style in the Dimension Settings dialog box.
2. Click the table entry you wish to delete.
3. Click Delete.

Saving the Dimension Style Table to a File
The Dimension Style table can be stored in a file for later use.

1. Click Style in the Dimension Settings dialog box.
2. Select a dimension style.
3. Click Store.
4. In the Name box, specify a filename and select a file type.
5. Click OK to save the dimension text extension or extensions.

Creo Elements/Direct Drafting stores the table macros in the given file.

Loading Table Entries from a File
New table entries can be appended to the Dimension Style table by loading them
from a file.

1. In the Dimension Settings dialog box, click Style.
2. Click Load.
3. In the Name box, select or specify a filename under which you saved

predefined dimension text extensions.

Creo Elements/Direct Drafting loads the table macros from the given file into
the STYLE table. These entries are appended to the end of the table.

Changing Dimension Settings
To change the settings of existing dimensions:

1. Click Modify and then, in the Annotate group, click Properties.
2. Select the dimension or dimensions to be changed.

You can click a single dimension or enclose multiple dimensions in a box or
use the Select window.
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The Annotation Properties dialog box opens.

Alternatively, you can preselect single or multiple dimensions to open the
Annotation Properties dialog box.

Note
In the preselection mode, the Annotation Properties dialog box opens after

you click Properties.

3. Click the following settings of the dimension items you want to change:

• Line

• Text

• Units

Note
The settings in the Dimension Settings dialog box apply to all dimensions
to be added to the drawing, while the settings in the Annotation Properties
dialog box apply to existing dimensions you selected.

Changing Dimension Line Attributes
The Annotation Properties dialog box enables you to change the following
attributes of the dimension lines:

• Line Settings
• Terminator (Arrow) Settings

Changing Dimension Line Settings
In the Line area on the Line settings of the Annotation Properties dialog box, you
can change the following dimension line attributes:
Width Changes the width of dimension lines.
Offset Line Changes the distance between the top end of the

extension line and the dimension line.
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Color Changes the color of extension lines, dimension lines,
and text frames.

Note
To use the same dimension line color for dimension
texts, click the Connected To Text check box (default).
If you change the color of dimension lines
subsequently, similar color is also used for dimension
texts.

To use separate colors for dimension lines and
dimension texts, clear the Connected To Text check
box.

Offset Point Changes the offset distance between a geometry feature
and the dimensioning extension lines.

See Dimension Line Settings on page 308 for an explanation of these dimension
line attributes.

Changing Dimension Line Terminator Settings
In the Arrow area on the Line settings of the Annotation Properties dialog box, you
can change the type, size, and fill attributes of dimension line terminators. See
Terminator Settings on page 315 for an explanation of these terminator attributes.

Changing Dimension Text Settings
In the Text settings of the Annotation Properties dialog box, you can change the
attributes of dimension text.

1. Begin by selecting the dimension text component or components whose
attributes you want to change:

• If you click the All check box under Set, the attribute changes apply to all
dimension text components.

• Alternatively, you can select any of the following in the Set list:

○ Upper

○ Lower

○ Prefix

○ Postfix

○ Superfix

○ Subfix
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Then select Value or Tolerance in the Subset box or click the All Subsets
check box to select both Value and Tolerance (if applicable).

2. Change the attributes for the selected dimension text components. See
Dimension Text Settings on page 318 for an explanation of these attributes.

Note
To use the same dimension text color for dimension lines, click the
Connected To Line check box (default). If you change the color of
dimension texts subsequently, similar color is also used for dimension
lines.

To use separate colors for dimension texts and dimension lines, clear the
Connected To Line check box.

Changing Dimension Unit Settings
In the Units settings of the Annotation Properties dialog box, you can change the
settings of dimension units. See Dimension Unit Settings on page 329 for an
explanation of dimension unit settings.

Example
The example below shows how to change dimension units from millimeters to
fractional inches.
Figure 130 on page 346 shows the dimension before and after the change:

Figure 130. Changing Millimeters to Fractional Inches

Changing Dimension Text Ext Settings
In the Text Ext settings of the Annotation Properties dialog box, you can change
the text extension settings of the dimension text.

1. In the Extensions area, click the Change check box for the required text
extension from the following:

• Prefix

• Postfix

• Superfix
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• Subfix

2. In the Tolerance area, click the Change check box, and specify the revised
settings for tolerance.

Modifying Dimensions
The following sections describe how to modify the layout of existing dimensions.

Modifying Dimension Lines
If dimension and extension lines are crowded or overlapped, you can:

• Break an extension or dimension line.
• Slant an extension line.
• Stagger an extension line.
• Reset an extension or dimension line.
Any breaks and staggers you make to a dimension line are retained until either:

• The dimension line is reset using Line Reset under Modify in the
Annotate group on the Modify tab.

• The location of the dimension is moved to within the range of the break or
stagger.

Use the handles of a dimension to quickly modify it:

Move the dimension and
text

Click anywhere on the dimension and drag.

Move the dimension text Hold SHIFT and drag the text.
Reattach the dimension Click the square-shaped handle where the dimension

is attached to the element and drag.
Change the direction of
the arrows

Click the diamond-shaped handle.

Modify the stagger line Click the square-shaped handle and drag.

To change the Handles settings:

1. Click File ▶ Settings ▶ System.

The System dialog box opens.
2. Click Handles.
To modify a dimension line:

• Click Modify and then, in the Annotate group, click one of the following:
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○ Break

○ Stagger

○ Line Keep Text under Modify

○ Line Move Text under Modify

○ Line Reset under Modify

Breaking Dimension Lines
To break a dimension extension line around obstructing features:

1. Click Modify and then, in the Annotate group, click Break.

Refer to Figure 131 on page 348.

Figure 131. Broken Extension Line

2. Click the dimension text for the dimension (1).

Alternatively, you can preselect the dimension text.
3. Specify the start point for the break (2).
4. Specify the end point for the break (3).
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Note
• In the preselection mode, you can directly specify the start point of the break

after you click Break.
• If preselection is active for the dimension, you can select another dimension to

break.

• If you specify a different option in the user input line after clicking Break
(for example, STAGGERED, BREAK, RESET, CHG_STAGGER), the
preselected dimension is modified accordingly.

Note
The break is lost after any modification of the geometry to which the
dimension is attached.

Slanting Dimension Extension Lines
To slant dimension extension lines:

1. Click Modify and then, in the Annotate group, click Slant. See the
following figure:

Figure 132. Slanted Extension Lines

2. Type the slant angle in the user input line and press ENTER.
3. Select the dimension to slant.

Alternatively, you can preselect the dimension.

The dimension extension lines are slanted by the specified angle.
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Note
• In the preselection mode, Creo Elements/Direct slants the dimension extension

lines after you specify the slant angle.
• If preselection is active for the dimension, you can select another dimension to

slant.

• If you specify a different option in the user input line after clicking Slant
(for example, STAGGERED, BREAK, RESET, CHG_STAGGER), the
preselected dimension is modified accordingly.

Note
Slant angles must be between 0 and 60 degrees, or 0 and -60 degrees. You can
only slant the extension lines of single dimensions with a parallel dimension
orientation. Broken or staggered dimensions can be slanted and slanted
dimensions can be broken or staggered. A slanted dimension cannot be further
slanted.

Staggering Dimension Extension Lines
To stagger dimension extension lines:

1. Click Modify and then, in the Annotate group, click Stagger.

Refer to Figure 133 on page 350.

Figure 133. Staggered Extension Lines

2. Select the dimension.

Alternatively, you can preselect the dimension.
3. Specify the start point for the stagger on the extension line (1).
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4. Specify the end point for the stagger on the extension line (2).
5. Specify the point where you want the stagger to go (3).

Figure 134. Effect of Moving Staggered Extension Lines

Note
• In the preselection mode, Creo Elements/Direct prompts you to specify the

start point for the stagger after you click Stagger.
• If preselection is active for the dimension, you can select another dimension to

stagger.

• If you specify a different option in the user input line after clicking
Stagger (for example, BREAK, SLANT, RESET), the preselected dimension
is modified accordingly.

Note
If a dimension contains several staggers, only the first is retained following a
move. The staggers is lost after any modification of the geometry to which the
dimension is attached.

Figure 135. Multiple Staggered Extension Lines
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Modifying Dimension Orientation
You can modify the orientation of dimensions in a drawing.
To modify the orientation of a dimension:

1. Click Modify and then, in the Annotate group, click the arrow next to
Modify.

2. Click one of the following:

• Orientation Parallel to orient the dimension parallel to an element.

• Orientation Horizontal to orient the dimension in the horizontal
direction.

• Orientation Vertical to orient the dimension in the vertical direction.

• Orientation Inclined to orient the dimension at the specified inclination
angle.

• Orientation Perp to line to orient the dimension perpendicular to a
selected reference line.

• Orientation Par to line to orient the dimension parallel to a selected
reference line.

3. Select the dimension.

Modifying a Dimension Vertex
The dimension vertex can be relocated to a new position without the need to click
the first point again.

Figure 136. Relocating a Dimension Vertex

To modify a dimension vertex:

1. Click Modify and then, in the Annotate group, click the arrow next to
Modify.

2. Click Line Keep Text.
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3. Click the dimension (point 1).

Alternatively, you can preselect the dimension.
4. Click the old reference element (point 2).
5. Click the new reference element (point 3).

Creo Elements/Direct Drafting relocates the dimension but leaves the
dimension text in its original position.

Note
• If the dimension is preselected, you only need to specify the old and new

reference points after you click Line Keep Text.
• You can use the preselected dimension only once. At the next prompt, you

must select another dimension or click Cancel to end the command.

If you click Line Move Text under Modify, you can also relocate the
dimension text:

1. Click Modify and then, in the Annotate group, click the arrow next to
Modify.

2. Click Line Move Text.
3. Click the dimension (point 1).

Alternatively, you can preselect the dimension.
4. Click the old reference element (point 2).
5. Click the new reference element (point 3).

Creo Elements/Direct Drafting relocates the dimension with the dimension
text.

Note
• If the dimension is preselected, you only need to specify the old and new

reference points after you click Line Move Text.
• You can use the preselected dimension only once. At the next prompt, you

must select another dimension or click Cancel to end the command.
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Resetting Dimension Lines
To reset a broken or staggered dimension line:

1. Click Modify and then, in the Annotate group, click the arrow next to
Modify.

2. Click Line Reset.
3. Select the dimension for the dimension line reset.

Alternatively, you can preselect the dimension.

Creo Elements/Direct Drafting resets the broken or staggered dimension line.

Note
In the preselection mode, Creo Elements/Direct Drafting resets the broken or

staggered dimension line after you click Line Reset.

Note
If you reset a dimension with broken, staggered, or slanted dimension
extension lines, Creo Elements/Direct Drafting straightens the extension lines
and removes breaks or staggers, if any.

Modifying Dimension Text
This section shows how to move or rotate existing dimension text, with or without
the associated dimension lines.

Moving Dimension Text
To move dimension text without moving the dimension or extension lines:

1. Click Modify and then, in the Annotate group, click the arrow next to
Modify.

2. Click Move Text.
3. Select the dimension text items you want to move.

Alternatively, you can preselect the dimension text.
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Creo Elements/Direct Drafting replaces each selected dimension text item
with a trace box.

4. Click the desired location for the dimension text.

Creo Elements/Direct Drafting relocates the selected dimension text items.

Note
In the preselection mode, Creo Elements/Direct Drafting replaces each

selected dimension text item with a trace box after you click Move Text.

Moving Complete Dimensions
To move one or more complete dimensions:

1. Click Modify and then, in the Annotate group, click the arrow next to
Modify.

2. Click Move Text & Line.
3. Click the dimension text of the dimension or dimensions you want to move.

Creo Elements/Direct Drafting draws a trace of the dimensions.

Alternatively, you can preselect the text of the dimension that you want to
move.

4. Click the desired location for the dimension text.

Creo Elements/Direct Drafting relocates the selected dimensions.

Note
In the preselection mode, Creo Elements/Direct Drafting draws a trace of the

dimension after you click Move Text & Line.

Moving Dimension Text and Leader Line
To move a dimension text and its associated leader line:

1. Click Modify and then, in the Annotate group, click the arrow next to
Modify.
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2. Click Move Text & Leader.
3. Click the dimension whose text and leader lines you want to move. Creo

Elements/Direct Drafting draws a trace of the dimension text and its leader
line.

Alternatively, you can preselect the dimension text.
4. Click the desired location for the dimension text.

Creo Elements/Direct Drafting relocates the selected dimension text and its
leader line.

Note
In the preselection mode, Creo Elements/Direct Drafting draws a trace of the

dimension text and its leader line after you click Move Text & Leader.

Figure 137. Moving a Dimension Text and Its Leader Line

Rotating Dimension Text
Horizontal is the zero angle and positive rotation is counterclockwise.
To rotate dimension text:

1. Click Modify and then, in the Annotate group, click the arrow next to
Modify.

2. Click Rotate Text.
3. Type an absolute angle of rotation in the user input line and press ENTER.

A positive angle causes a counterclockwise rotation.
4. Select the dimension text or texts you want to rotate.

Alternatively, you can preselect the dimension text.

Creo Elements/Direct Drafting rotates the selected dimension text.
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Note
In the preselection mode, Creo Elements/Direct Drafting rotates the dimension
text after you specify the rotation angle.

Aligning Dimensions
Dimensions can be aligned with other dimensions. First, you identify an existing
dimension and align the new dimension above, below, or adjacent to it.

Figure 138. Aligning Dimensions to Other Dimensions

To align a dimension:

1. Click Modify and then, in the Annotate group, click the arrow next to
Modify.

2. Click Move Text & Line.
3. Click the dimension you want to move (point 1).
4. Click the reference dimension (point 2).
5. Drag the cursor to the new location.
6. Release the mouse button.
7. Repeat for other dimensions (point 3).
Aligning of dimensions applies to single dimensions and not group dimensions (a
group of dimensions cannot be boxed because each dimension needs a specific
shift-vector). Additionally, aligning dimensions does not apply to non-linear
dimensions such as:

• Diameters
• Radii
• Arcs
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Inclining Dimensions

The dimension attributes Horizontal and Vertical can be overridden such
that when an element is inclined, the dimension is also inclined. What you are
doing is freezing the dimension to the describing element. This helps speed up the
modification process for dimensioned geometry. Dimension attributes such as text
size and font are not changed.

Figure 139. Effects of Freezing a Dimension

1 Dimension created by Single, Horizontal. When the part is rotated 20°, the
dimensions remain horizontal giving a correct but meaningless result.

2 Same as item 1 but the dimensions were frozen with Freeze before the part was
modified.

To freeze a dimension:

1. Click Modify and then, in the Annotate group, click the arrow next to
Modify.

2. Click Freeze.
3. Click the dimension you want to incline.

Alternatively, you can preselect a single dimension. You can use Freeze
for a single preselected dimension.

Note
• If you select the dimensions by enclosing them in a box, only those

dimensions with the attribute Horizontal or Vertical are affected.

• There is no Undo for this command.
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Editing Dimension Text
This section shows how to edit existing dimension text. Identified dimension text
is displayed in the user input line. After editing the text, make sure that quotes (' '
or " ") surround the text, and then press ENTER.
Creo Elements/Direct Drafting redraws the edited dimension text.
To edit existing dimension text:

1. Click Modify and then, in the Annotate group, click the arrow next to
Modify.

2. Click Edit Dim Text.
3. Click the dimension text to edit.

Alternatively, you can preselect the dimension text.

Creo Elements/Direct Drafting displays the dimension text in the user input
line.

4. Edit the text and press ENTER.

5. Click OK.

Note
• In the preselection mode, Creo Elements/Direct Drafting displays the

dimension text in the user input line after you click Edit Dim Text.
• You can preselect only a single dimension.

Dimension Text Underlining
Creo Elements/Direct Drafting provides the possibility to underline dimension
text. This is particularly useful when you want to flag a dimension that has been
manually changed (or edited). This underlining feature is a requirement of DIN
dimensioning standards. The default setting depends on the selected dimension
standard:
DIN Standard Default is on.
ANSI, ISO, JIS, or COMPANY Standard Default is off.

If the selected dimension standard is DIN, dimension text that is edited is
automatically underlined. Otherwise, edited dimension text is not underlined but
can be underlined selectively. Dimension underlines have the following
properties:
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• The length is the same length as the dimension text.
• Prefixes, postfixes, and tolerances are not underlined.
• The color is the same as dimension lines.
• The space between the dimension text and underline is fixed.
• The pensize is the same as that of the dimension lines.
To underline a dimension:

1. Click Modify and then, in the Annotate group, click the arrow next to
Modify.

2. Click Edit Dim Text.

3. Click Modify and then, in the Annotate group, click the arrow next to
Modify.

4. Click Underline.
5. Click the dimension to be underlined.
6. Press ENTER to accept the current value displayed in the user input line.

Optionally, you can edit this value.
Creo Elements/Direct Drafting displays the edited dimension value with an
underline.

Figure 140. Dimension Underlining

To remove an underline:

1. Click Modify and then, in the Annotate group, click the arrow next to
Modify.

2. Click Cancel Edit.
3. Click the underlined dimension you want to reset.
Creo Elements/Direct Drafting displays the edited dimension value without an
underline.
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Canceling a Dimension Text Edit
This section shows how to cancel an edit and display the dimension text in its
original form. This means that if you edit the dimension text twice and then use

Cancel Edit, the original dimension text will appear and not your first edited
version of the text.
To cancel an edit:

1. Click Modify and then, in the Annotate group, click the arrow next to
Modify.

2. Click Cancel Edit.
3. Click the dimension text you want to reset to its original version.

Creo Elements/Direct Drafting displays the original dimension text.

Alternatively, you can preselect the edited dimension text.

Note
In the preselection mode, Creo Elements/Direct Drafting displays the

original dimension text after you click Cancel Edit.

4. Click OK.

Modifying the Color of Dimension Lines and
Dimension Texts
Creo Elements/Direct Drafting allows you to change the color of dimension lines
and dimension texts in a single operation. You can also separately change the
color of the dimension lines and dimension texts.
To change the color of dimension lines and dimension texts in a single operation:

1. Click Modify and then, in the Annotate group, click the arrow next to
Modify.

2. Click Dim Text and Line Color.

The Select Color dialog box opens.
3. In the Color box, select the required color for dimension texts and dimension

lines.
4. Click OK.
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5. Select the dimensions to apply the color.

Alternatively, you can use the Select dialog box to select the elements that
contain dimensions.

Creo Elements/Direct Drafting applies the specified color to the dimension
lines and dimension texts of the selected dimensions.

Note
After you select the elements, you can change the color of the dimension

lines and dimension texts again, using Dim Text and Line Color.

6. Click OK.
To change the color of dimension lines only:

1. Click Modify and then, in the Annotate group, click the arrow next to
Modify.

2. Click Dim Line Color.

The Select Color dialog box opens.
3. In the Color box, select the required dimension color.
4. Click OK.
5. Select the dimension lines to apply the dimension line color.

Creo Elements/Direct Drafting applies the specified color to the selected
dimension.

Alternatively, you can use the Select dialog box to select the elements that
contain dimension lines.

Creo Elements/Direct Drafting applies the specified color to the selected
dimension lines.

Note
After you select the elements, you can change the dimension line color

again using Dim Line Color.

6. Click OK.
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To change the color of dimension texts only:

1. Click Modify and then, in the Annotate group, click the arrow next to
Modify.

2. Click Dim Text Color.

The Select Color dialog box opens.
3. In the Color box, select the required dimension text color.
4. Click OK.
5. Select the dimension to apply the color to the dimension text.

Alternatively, you can use the Select dialog box to select the elements that
contain dimension texts.

Creo Elements/Direct Drafting applies the new color to the selected dimension
texts.

Note
After you select the elements, you can change the dimension text color

again using Dim Text Color.

6. Click OK.

Modifying Chain and Datum Dimensions
Individual segments can be inserted or deleted within chain and datum dimension
groups. Creo Elements/Direct Drafting automatically adjusts other segments
within the chain or datum group to account for the new/deleted segment.
Optionally, Creo Elements/Direct Drafting can check to ensure that the modified
chain or datum group will not intersect existing geometry.

Inserting a New Chain or Datum Dimension Segment
To insert a new segment into an existing chain or datum dimension group:

1. Click Modify and then, in the Annotate group, click the arrow next to
Modify.

2. Click Insert.
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3. Click the chain or datum group you want to modify by clicking on the
dimension text of any segment within the group.

4. Click the new dimension point.

5. When you have finished inserting segments, click OK.

Deleting a Segment from a Chain or Datum
Dimension Group
To delete a segment from an existing chain or datum dimension group:

1. Click Modify and then, in the Annotate group, click the arrow next to
Modify.

2. Click Delete Member.
3. Click the dimension text of the segment which you want to delete.
4. If the dimension text segment is a part of a dimension chain, click the

neighboring dimension text in the chain.

This segment grows to fill the space created by the deleted segment.

5. Click OK after you finish deleting dimensions.

Grouping
You can group annotations together. Groups on page 241 may consist of a single
dimension, multiple text elements and multiple symbols.

Further Information
For further technical information about dimensions, refer to the Creo Elements/
Direct Drafting help system.
Type the following in the Creo Elements/Direct Drafting user input line and press
ENTER:

• help da_dimension

• help da_dim_line

• help da_dim_line_sym

• help da_dim_datum_long

• help da_dim_datum_short

• help da_dim_chain
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• help da_dim_coord

• help da_dim_chamfer

• help da_dim_radius

• help da_dim_diameter

• help da_dim_dtan

• help da_dim_arc

• help da_dim_angle

• help wui_dim_set_text_ext

• help da_style_get

• help da_style_apply

• help da_dim_geo_sense

• help da_dim_pd_scan

• help wui_da_db_match

• help wui_change_dim

• help modify_dim_lines

• help change_dim_vertex

• help da_move_dimension

• help rotate_dim_text

• help da_dim_insert

• help da_dim_incline

• help edit_dim_text

• help cancel_edit_dim_text

• help wui_dimension_settings

• help da_dim_delete

Creo Elements/Direct Drafting displays further information about dimensioning.
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This chapter describes how to hatch your drawing and how to set and change the
hatch parameters.
If you wish to cross-hatch an area or build up a custom hatch pattern, simply use

any number of Hatch buttons on the same area but with different hatch angles,
distances, hatch points, colors, and linetypes.
Alternatively, you can define your own hatch patterns for use in multiple areas.
See Creating a Hatch Pattern on page 372 for details.
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Hatching a Drawing Area
You have a choice of two hatch methods:

• Automatic Hatching on page 367
• Manual Hatching on page 368

Automatic Hatching
You can hatch any area fully enclosed by drawing lines or already hatched.
To automatically hatch a drawing area:

1. Click Drafting and then, in the Annotate group, click the arrow next to
Hatch.

2. Click Automatic.
3. Specify a point inside the area to be hatched.

The cursor automatically tracks around the enclosing polygon and then
searches for any inner holes. Having established the inner and outer contours,
Creo Elements/Direct Drafting hatches the bounded area. If Creo Elements/
Direct Drafting finds any gaps or incorrectly split lines in the enclosing
polygon, the command is aborted and Creo Elements/Direct Drafting marks
the gap or split line.

Match Point
You can set a match point to be used for all subsequent hatching. One hatch line
will be aligned to pass through the match point. The match point need not
necessarily lie inside an area to be hatched; in this case an imaginary extension of
the hatch lines would pass through the hatch point.
Figure 141. Hatch Pattern Aligned with Match Point on page 367 shows the hatch
pattern aligned with an external match point.

Figure 141. Hatch Pattern Aligned with Match Point

To set the hatch match point:

1. Click Drafting and then, in the Annotate group, click the arrow next to
Hatch.
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2. Click Match Point.
3. Specify a point for the hatch line to pass through.
One hatch line of all subsequent hatching passes through the new match point.

Manual Hatching
Manual hatching is used to hatch any area not fully enclosed by drawing lines.
To manually hatch a drawing area:

1. Click Drafting and then, in the Annotate group, click the arrow next to
Hatch.

2. Click Manual.
3. Click the start point on the existing outer contour of the area to be hatched.

See Automatic Splitting on page 369 for further contour creation options.
4. Continue by clicking successive points around the outer contour.
5. Click the start point again to close the contour.

When you have closed the contour, use the same method to indicate any inner
holes that are not to be hatched.

6. Click OK.

The area is hatched.

To abort the command click Cancel. Use Undo to undo erroneous
points.

If a side consists of a complete drawing line, simply indicate a mid-point on the
line using the element (ELEM) catching mode. Drafting will accept the line. If you
wish to identify only part of a line, mark the desired end point with a construction
line, use the intersection (INTERSECTION) catching mode, and indicate the desired
end point. Drafting will then accept only part of the line.
A series of connected drawing lines can be indicated by the end of one line and
the mid-point of the last line. Drafting will not accept a series of successive lines
if there is a branch at one of the vertices.
Figure 142. Indicating the Area for Hatch on page 369 illustrates the above
techniques.
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Figure 142. Indicating the Area for Hatch

Not all the sides have to be drawing lines. An imaginary line can be used to
separate free space or existing points. See Figure 143. Hatching — Leaving an
Unhatched Area on page 369.

Figure 143. Hatching — Leaving an Unhatched Area

Automatic Splitting
You can use automatic splitting options for extended contour creation
functionality.
To enable automatic splitting options:

1. Click File ▶ Settings ▶ Hatch.

The Hatch Settings dialog box opens.
2. Click the Automatic Split for Hatch Manual check box.
Use these options to automatically detect element intersections and add only parts
of elements to contours.

• Use ANY_POINT to automatically create a split point at the pick point on a
selected element and use that element as the contour element if it is connected
to previously selected element. All elements connecting currently picked and
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previously picked elements are included in the contour. This option remains
active until you select another option (INTERSECTION, ANY_POINT).

• Use INTERSECTION to automatically find the next intersection of elements
on the contour and splits them both at that point. Drafting starts searching for
an intersection along the contour in the same direction as between the previous
and current pick points. All elements connecting the previously picked
element and the intersection are included in the hatch contour. If Drafting
doesn’t find an intersection, this option behaves the same as the NO_
SPLITTING option. This option remains active until you select another option
(INTERSECTION, ANY_POINT).

• Use NO_SPLITTING to restore default behavior. The command behaves as if
the Automatic Split for Hatch Manual setting is off. This option remains active
until you select another option (INTERSECTION, ANY_POINT).

• Use VERTEX to automatically split element at the pick point, and directly
connect it to your previous pick point without following the contour. This
option remains active only for one pick.

Hatch Settings
The Hatch Settings dialog box enables you to define:

• Simple Hatch Settings on page 370
• Setting Hatch Patterns on page 372
• Standard Hatch Patterns on page 378
To open the Hatch Settings dialog box:

• Click File ▶ Settings ▶ Hatch.
After you define your hatch settings, either click Hatch to apply these settings to
the next face or faces you click, or click OK to apply these settings to subsequent

hatching (while using the Hatch buttons).

Simple Hatch Settings
Click Hatch in the Hatch Settings dialog box to enable the Hatch area for editing.
In the Hatch area, you can select or change the following hatch settings:

• Distance

• Angle

• Linetype

• Color
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• Ref. Point

The settings you specify or select in the Hatch Settings dialog box are applied to
all subsequent hatching. These settings remain active until you change them.

Hatch Distance
To set the distance between hatch lines, type the required value in the Distance
box in the Hatch area. This value is interpreted in terms of the length unit (such as
mm) currently set up for your Creo Elements/Direct Drafting environment. Figure
144. Hatch Line Distance on page 371 shows an example of a hatch line distance.

Figure 144. Hatch Line Distance

Hatch Angle
To set the hatch angle, type the required value in the Angle box in the Hatch area.
The angular units are those currently defined for your Creo Elements/Direct
Drafting environment. A zero value implies horizontal hatch lines and a positive
angle results in counterclockwise rotation.
Figure 145. Positive Hatch Angle on page 371 shows a positive hatch angle.

Figure 145. Positive Hatch Angle

Hatch Linetype
To set the hatch linetype, select a linetype in the Linetype box in the Hatch area.

Hatch Color
To set the hatch color, select a color in the Color box in the Hatch area. Refer to
Defining Custom Colors on page 100 for instructions on defining custom colors.
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Setting Hatch Patterns
Patterns consist of any number of simple hatch lines built up in layers. After you

create a pattern, it is active every time you click the Hatch buttons in the
Annotate group on the Drafting tab. The pattern is used to hatch all subsequent
areas.
The five hatch pattern settings are described in Table 3 on page .

Table 3. Hatch Pattern Parameters

Name Allowed Value Description
Offset 0 to 1 The offset is used to align the hatch lines of

the layer to the match point (set using Match
Point). The perpendicular offset is the entered
value multiplied by the distance (see Figure
146. Hatch Perpendicular Offset on page
372).

Distance Any Number The distance between each of the layer's
hatch lines will be the entered value
multiplied by the distance value specified in
the Distance box in the Hatch area.

Angle 0 to ± 360 The angle is added to the angle specified in
Angle box in the Hatch area to determine the
actual angle at which the layer's hatch lines
will be drawn.

Color - Any of predefined colors in the drop-down
list box or a custom color. Refer to Defining
Custom Colors on page 100 for instructions
on defining custom colors.

Linetype - Any of the eight Drafting standard linetypes
can be selected from a drop-down list box.

Figure 146. Hatch Perpendicular Offset

Creating a Hatch Pattern
To create a hatch pattern:
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1. Click Pattern in the Hatch Settings dialog box to enable the Pattern area for
editing.

2. In the Pattern area, define the first layer's values for Offset, Distance, Angle,
Color and Linetype.

3. Define the next layer's values or finish the pattern by clicking Add To.

There is no limit to the number of layers in a pattern. For examples of patterns,
refer to the section Standard Hatch Patterns on page 378. The exact values
required for each standard pattern are listed there.

Canceling a Hatch Pattern
You can cancel any previously created hatch pattern. After canceling the hatch

pattern, all future Hatch buttons in the Annotate group on the Drafting tab
revert to the hatch parameters set using the linetype and color specified in the
Hatch area (see Simple Hatch Settings on page 370).
To cancel a hatch pattern:

1. Click Pattern in the Hatch Settings dialog box to enable the Pattern area for
editing.

2. Click Cancel.

The previously created hatch pattern is canceled.

Changing Hatch Settings
Creo Elements/Direct Drafting allows you to change existing hatching in your

drawing using the Hatch buttons in the Annotate group on the Modify tab:

• Changing Individual Hatch Settings on page 373
• Changing a Hatch Pattern on page 376

Changing Individual Hatch Settings

Use the Hatch buttons in the Annotate group on the Modify tab to change
individual hatch settings.

• Changing the Hatch Angle on page 374
• Changing the Hatch Line Distance on page 374
• Changing the Hatch Color on page 374
• Changing the Match Point on page 375
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• Changing a Hatch Pattern on page 376
• Automatic Splitting on page 369

Changing the Hatch Angle
To change the hatch angle:

1. Click Modify and then, in the Annotate group, click the arrow next to
Hatch.

2. Click Angle.
3. Type the required hatch angle in the user input line and press ENTER.
4. Click the hatch you want to change.

Creo Elements/Direct Drafting changes the selected hatching.

You can click individual areas of hatch or box several hatch areas. To change
all the hatches, type ALL in the user input line and press ENTER.

Alternatively, use the Selection buttons (as you would for a Delete

operation), and finish by clicking Confirm.

Changing the Hatch Line Distance
To change the line distance of an existing hatch:

1. Click Modify and then, in the Annotate group, click the arrow next to
Hatch.

2. Click Distance.
3. Type the required line distance in the user input line and press ENTER.
4. Select the hatching to be changed.

Creo Elements/Direct Drafting changes the selected hatching.

You can click individual areas of hatch or box several hatch areas. To change
all the hatches, type ALL in the user input line and press ENTER.

Alternatively, use the Selection buttons (as you would for a Delete

operation), and finish by clicking Confirm.

Changing the Hatch Color
To change the color of an existing hatch:
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1. Click Modify and then, in the Annotate group, click the arrow next to
Hatch.

2. Click Color.

The Select Color dialog box opens.
3. In the Color box, select a color.

Refer to Defining Custom Colors on page 100 for instructions on defining
custom colors.

4. Select the hatching to be changed.

You can only select individual areas of hatch. When there are two hatch
patterns superimposed on each other, the pattern nearest to the cursor is
changed.

Alternatively, use the Selection buttons (as you would for a Delete

operation), and finish by clicking Confirm.

Changing the Match Point
To change the hatch match point:

1. Click Modify and then, in the Annotate group, click the arrow next to
Hatch.

2. Click Match Point.
3. Type the required point for the hatch lines to match in the user input line and

press ENTER.
4. Select the hatching to be changed.

Creo Elements/Direct Drafting changes the selected hatching.

You can click individual areas of hatch or box several hatch areas. To change
all the hatches, type ALL in the user input line and press ENTER.

Alternatively, use the Selection buttons as you would for a Delete

command, and finish by clicking Confirm.

Automatic Splitting
See Automatic splitting in the Manual Hatching on page 369 section.
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Changing Multiple Hatch Settings
Instead of changing individual settings of a hatch, you can change multiple hatch
settings at the same time.
To change multiple settings of a hatch:

1. Click Modify and then, in the Annotate group, click the arrow next to
Hatch.

2. Click Multiple.

The Change Hatch dialog box opens.
3. Change the required hatch settings. (SeeSimple Hatch Settings on page 370.)
4. Select the hatch.

Alternatively, use the Select buttons to select the hatch and click Confirm
to finish.

Changing a Hatch Pattern
To change a hatched area to a new pattern:

1. Click Modify and then, in the Annotate group, click the arrow next to
Hatch.

2. Click Pattern.
3. Specify or select the settings for the first layer of the pattern (see Setting Hatch

Patterns on page 372 for details).
4. If there are further layers, continue by defining the next layer or layers in the

same way.
5. Click OK in the Hatch Settings dialog box to finish defining the pattern.
6. Select the required hatched areas.

Creo Elements/Direct Drafting changes them to the new pattern.

Hatching Around Text and Dimension
Text
When text lies in a hatched area, Creo Elements/Direct Drafting automatically
creates a window around the text. The result is the same whether you hatch first
and then add text, or add text first. If you modify the drawing by moving the text,
the hatching is automatically updated.
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Text Window creates a hole around text and dimension text when the text runs
through a hatched area (as in overlapping parts). The following figure shows three
parts in a parts structure (part 1 is the top part and part 3 is the lowest part). In a
real assembly, the parts overlap and the hatching on parts 1 and 2 appears to run

through the dimension text on part 1. Use Text Window to punch a window
through the overlapping hatching.

Figure 147. Text and Dimension Text: Hatched Area

1. Click Drafting and then, in the Annotate group, click the arrow next to
Hatch.

2. Hatch the required area using Automatic or Manual.

3. Click Modify and then, in the Annotate group, click the arrow next to
Hatch.

4. Click Text Window.
5. Click the dimension text around which you want to hatch.

Figure 148. Hatching Around Dimension Text

To move dimension text after using Text Window to create the hole around the
text:

1. Move the dimension text to its new position.
2. Delete the old hole in the hatching (Creo Elements/Direct Drafting deletes the

hole and regenerates the hatch).
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3. Use Text Window to create a new hole around the dimension text.

Standard Hatch Patterns
This section describes how to set up standard hatch patterns which are used by all

subsequent Hatch buttons in the Annotate group on the Drafting tab.
To set up a standard hatch pattern:

1. Click File ▶ Settings ▶ Hatch.

The Hatch Settings dialog box opens.
2. Click Standard to enable the Standard area for editing.
3. Click the required standard hatch pattern from the following:

• Iron

• Steel

• Copper

The selected standard hatch pattern becomes active.
The three standard options are displayed below along with the values of Offset,
Distance, Angle, Color, and Linetype used (refer to Setting Hatch Patterns on page
372). All the examples shown are drawn with the following hatch parameters:

• Hatch Angle: 45
• Hatch Distance: 5
• Match Point: 0,0

Standard Hatching — Iron
This option sets the following Hatch Pattern values:
Offset: 0
Distance: 1
Angle: 0
Color: Cyan
Linetype: Solid
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Figure 149. Iron

Standard Hatching — Steel
This option sets the following Hatch Pattern values:
Offset: 0.33 & 0
Distance: 1 & 1
Angle: 0 & 0
Color: Cyan & Cyan
Linetype: Solid & Solid

Figure 150. Steel

Standard Hatching — Copper
This option sets the following Hatch Pattern values:
Offset: 0.5 & 0
Distance: 1 & 1
Angle: 0 & 0
Color: Cyan & Cyan
Linetype: Dashed & Solid

Figure 151. Copper
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Converting Hatch to Geometry
Hatches are handled differently by different applications. In some cases, hatch that
is passed from Creo Elements/Direct Drafting to AutoCAD can change
appearance. To ensure your hatch does not change appearance, convert it to
geometry.
To convert a hatch to geometry:

1. Click Modify and then, in the Annotate group, click the arrow next to
Hatch.

2. Click Text To Geo.
3. Select the required hatch to convert it to geometry.

Click in your viewport or use the Select window to select hatches in the
current part. Global selection is not available.

4. Click Confirm.

5. Click OK.
The appearance of your hatching does not change. You can see, however, that it is
now geometry. For example, you can now delete a single line of the hatch.

Note
Completely filled hatches are not converted. In this case, you will see the error
message, "Completely filled hatches will not be converted to geometry" or
"Some hatches will not be converted to geometry".

You can use Undo or Redo in combination with Text To Geo.

Deleting Hatching
To delete an area of hatching:

1. Click Modify and then, in the Annotate group, click the arrow next to
Hatch.

2. Click Delete.
3. Click individual areas of hatching to be deleted, (or enclose a group of hatched

areas in a box). Alternatively:
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• Use the Selection buttons as you would for a normal deletion.

• Finish by clicking Confirm to delete the selected groups of hatching.

4. If you delete an area by mistake, click Undo to undo the last delete
operation.

5. Click OK.
Delete hatch that has been converted to geometry the same way you would delete

geometry by using Delete.

Further Information
For further technical information about hatching, refer to the Creo Elements/
Direct Drafting help system.
Type the following in the user input line and press ENTER:

• help hatching

• help hatch

• help hatch_ref_pt

• help change_hatch_angle

• help change_hatch_dist

• help change_hatch_ref_pt

• help change_hatch_pattern

• help wui_hatch_settings

• help hatch_to_geo

• help delete_hatch

Creo Elements/Direct Drafting displays further information about hatching.
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Entering Text
Creo Elements/Direct Drafting provides the following options for entering text:

• Entering Text Directly in the Drawing on page 383
• Entering Text Using a Text Box on page 384

Note
If Creo Elements/Direct Drafting draws boxes instead of the text, you must input a
text font. Refer to Text Font on page 391. To load additional fonts for selection,
follow the instructions in Importing a Font on page 543.

Entering Text Directly in the Drawing
To enter text directly in your drawing:

1. Click Drafting and then, in the Annotate group, click the arrow next to
Text.

2. Click In Place.
3. Click the position for the text in the viewport.
4. Type the required text.

Creo Elements/Direct Drafting adds the text directly at the cursor position. By
default, the newly added text reflects the text settings defined using the Text
Settings on page 388 dialog box.

5. Press CTRL+D.
6. Insert further text in the drawing, if required.

7. Click OK.
When you have entered text in your Creo Elements/Direct Drafting drawing, you
can:

• Edit and/or delete this text (see Editing and Deleting Text on page 386)
• Change the settings of this text (see Changing Text Settings on page 393)
• Modify this text just like any geometric element (see Modifying a Drawing on

page 205)
• Add a reference line to this text (see Creating a Reference Line on page 394)
• Convert the text to normal geometry (see Converting Text to Geometry (DXF/

DWG and IGES 2D Translation) on page 394)
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Entering Text Using a Text Box
To add text to your drawing via a text box:

1. Click Drafting and then, in the Annotate group, click the arrow next to
Text.

2. Click Editor.

The Text dialog box opens.
3. Type the required text in the Text box.
4. Click OK to add the text to the drawing.
5. Click the position for the text.
Creo Elements/Direct Drafting draws the text. The newly added text reflects the
text settings defined via Text Settings on page 388.
If you require the same text at several locations on the drawing, simply continue
to click locations and the text will be repeated.
In addition to entering text, you can use the Text box for:

• Entering Special Characters on page 384
• Text Settings on page 388
• Loading an Existing Text File on page 385
• Storing Text in a Text File on page 385

Entering Special Characters
To add a special character to your Creo Elements/Direct Drafting drawing:

1. Click Drafting and then, in the Annotate group, click the arrow next to
Text.

2. Click Editor

The Text dialog box opens.
3. Click Special Characters.

The Special Characters dialog box opens. It displays a graphical list of special
text characters.

These special characters are included in the hp_symbols and hp_
symbols2 fonts. You can create additional special characters by editing these
fonts.
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4. Select the special character you want to add as text to your drawing. A
graphical representation of each character is provided in the Meta Name
column.

5. Click Insert to copy the selected special character to the Text box.

Note
You can insert the special character or characters to the existing text in the
Text box.

6. When the Text box contains the required special character or characters, click
OK.

7. Click the position for the text in the drawing.

Loading an Existing Text File
To load an existing text file for use in your Creo Elements/Direct Drafting
drawing:

1. Click Drafting and then, in the Annotate group, click the arrow next to
Text.

2. Click Editor

The Text dialog box opens.
3. Click Load.

The Load dialog box opens
4. Use the Load browser to browse to the path of the required text file and select

it.
5. In the Text box, edit the text as required.
6. Click OK.
7. Click the position for the text in the drawing.

Storing Text in a Text File
To store text in a text file:

1. Click Drafting and then, in the Annotate group, click the arrow next to
Text.

2. Click Editor
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The Text dialog box opens.
3. Type the text in the Text box or load an existing text file (see Loading an

Existing Text File on page 385) and edit it.
4. Click Store.

The Store dialog box opens.
5. Using the Store browser, browse to the required directory and type the name

of the text file in which you want to store the text.
6. Click OK to store your text in this file.

The text is saved in the specified file

Editing and Deleting Text
Creo Elements/Direct Drafting provides the following options for editing and
deleting text in a drawing:

• Editing Text Using a Text Box on page 387
• Editing Text Directly in the Drawing on page 386
• Moving Text on page 387
• Deleting Text on page 388

Note
If Creo Elements/Direct Drafting draws boxes instead of the text, you must
input a text font. Refer to Text Font on page 391. To load additional fonts for
selection, follow the instructions in Importing a Font on page 543.

Editing Text Directly in the Drawing
To edit text directly or by using a text box in your drawing:

1. Click Modify and then, in the Annotate group, click the arrow next to Text.

2. Click In Place.
3. Click the text that you want to edit.

Alternatively, you can preselect the text block to edit the text.

To edit the preselected text using the context menu:

a. Right-click the preselected text.
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b. Click Edit Text.
4. Edit the text as required.

Any changes are performed at the cursor location. If you add text while
editing, the newly added text will reflect the settings of the existing text (see
Text Settings on page 388).

5. Press CTRL+D.

Editing Text Using a Text Box
To edit existing text using a text box:

1. Click Modify and then, in the Annotate group, click the arrow next to Text.

2. Click Editor.
3. Select the text in the drawing.

Alternatively, you can preselect the text block or blocks to edit the text.

The Edit Text dialog box opens. It contains the text that you have selected.
4. Make the required changes to the text and click OK.

5. Click OK.

Note

In the preselection mode, the Edit Text dialog box opens after you click
Editor.

Moving Text
To quickly move text by moving the text box:

1. Hover the cursor over the text.

Creo Elements/Direct Drafting highlights a box around the text (if you have
enabled fly-by highlighting).

2. Drag the text to a new location.
Alternatively:
1. Select the required text.

The Command Mini Toolbar appears.
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2. Click 2 Points.
3. Specify the reference point and then a destination point.

Creo Elements/Direct Drafting moves the text to the new position.

Deleting Text
There are several ways to delete text from your drawing.
To delete the text using the keyboard:

1. Click the text.

A frame appears around the text.
2. Press DELETE.
Creo Elements/Direct Drafting deletes text in the same way as normal drawing
lines. To delete text without using the selection block:

1. Click Delete.
2. Box the text to be deleted, or click a single text to be deleted. Creo Elements/

Direct Drafting deletes the selected text.
If you use the Text option in the Select window, the text blocks you select for
deletion are highlighted. Click Confirm to delete the highlighted text.

Click Undo to correct mistakes and then repeat the operation or end the
command.

To delete text using the Selection buttons:

1. Click Delete.

2. Select text for deletion using Select buttons (similar to operation of

Delete). You can click Undo to correct any mistakes.

3. Click Confirm to delete the selected text block or blocks.

Text Settings
To open the Text Settings dialog box:

1. Click Drafting and then, in the Annotate group, click the arrow next to
Text.
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2. Click Editor.

The Text dialog box opens.
3. Click Settings.

The Text Settings dialog box opens.

Alternatively, click File ▶ Settings ▶ Text to open the Text Settings dialog box.
The settings you specify or select in the Text Settings dialog box are applied to all
subsequent text. These settings remain active until you change them.
The Text Settings dialog box enables you to define:

• Text Parameters on page 389
• Text Font on page 391
• Text Options on page 391

Text Parameters
In the Parameters area of the Text Settings dialog box, set the following text
parameters:

• Size

• Angle

• Ratio

• Linespace

• Slant

• Fill

Text Character Size
In the Size box, type the required value to set the text character size.
This value is interpreted in terms of the length unit (such as mm) currently set up
for your CoCreate Drafting environment.
The Creo Elements/Direct Drafting default text size is 3.5 mm.

Text Angle
In the Angle box, type the required value to set the text angle.
The angular units are interpreted in terms of the angle units currently defined for
your Creo Elements/Direct Drafting environment. A zero value implies horizontal
text and a positive angle results in counterclockwise rotation.
Figure 152. Setting the Text Angle on page 390 illustrates the text angle concept.
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Figure 152. Setting the Text Angle

Text Character Ratio
In the Ratio box, type the required value to set the width-to-height ratio of text
characters.
The default text ratio is 1.0.

Linespace
In the Linespace box, type the required value to set the line spacing of text lines.
The distance between lines of text in a block is computed as follows:
Actual line spacing = Linespace * Text Size
The default linespace in Creo Elements/Direct Drafting is 2.2 mm.

Text Character Slant
In the Slant box, type the required value to set the slant angle of text characters.
The angular units are interpreted in terms of the angle units currently defined for
your Creo Elements/Direct Drafting environment. A zero value implies no slant
and a positive angle results in clockwise rotation.
The default slant in Creo Elements/Direct Drafting is 0.
Figure 153. Text with a 15° Slant on page 390 shows text with a 15° slant.

Figure 153. Text with a 15° Slant

Text Character Fill On/Off
Creo Elements/Direct Drafting provides a number of text fonts (such as " hp_
block_c ") that can be displayed in filled or unfilled mode.
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Click or clear the Fill check box to enable or disable the fill mode, respectively.
Figure 154. Unfilled and Filled Text on page 391 shows an example (unfilled and
filled).

Figure 154. Unfilled and Filled Text

Text Font
In the Text Settings dialog box, select the required font in the Name box.
The font names in this selection list include:

• Fonts supplied with Creo Elements/Direct Drafting.
• Fonts already installed on your PC.
To load additional fonts for selection, follow the instructions in Importing a Font
on page 543.
OSD’s different internal and external encoding schemes were Unicode on page
782 incorporated for version 2007.

Note
The font selection list also includes all TrueType® fonts installed on your PC. If
you select one of these fonts, it will be converted during the load process. The
converted font will be stored in the fonts subdirectory below the Creo Elements/
Direct Drafting installation directory.

Text Options
In the Options area of the Text Settings dialog box, set the following text options:

• Color

• Frame

• Origin Vertex

Text Color
To set the text color, in the Color box, select the required color.
Refer to Defining Custom Colors on page 100 for instructions on defining custom
colors.
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Text Frame
By default, text in Creo Elements/Direct Drafting is displayed without a frame.
Optionally, In the Frame box, select a frame from the following:
• Box

Figure 155. Text with a Box Frame on page 392 shows text with a box frame.

Figure 155. Text with a Box Frame

• Balloon

Figure 156. Text with a Balloon Frame on page 392 shows text with a balloon
frame.

Figure 156. Text with a Balloon Frame

• Flag

Figure 157. Text with a Flag Frame on page 392 shows text with a flag frame.

Figure 157. Text with a Flag Frame

Text Origin Vertex
To set the position of the origin of any subsequent text, select the associated
position number (an integer between 1 and 9) in the Origin Vertex box.
Figure 158. Cursor Positions in the Text Box on page 393 shows you the relative
position associated with each of these adjust values.
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Figure 158. Cursor Positions in the Text Box

Changing Text Settings
To change the settings of existing text:

1. Click Modify and then, in the Annotate group, click the arrow next to Text.

2. Click Modify.
3. Select the text that you want to change.

You can click a single text block or enclose multiple text blocks in a box or
use the Select window.

The Text Change dialog box opens.

Alternatively, you can preselect the text to open the Text Change dialog box.

Note
In the preselection mode, the Text Change dialog box opens after you click

Modify.

4. Change the settings as required.

See the Text Settings on page 388 section for an explanation of these settings.

Note
The settings in the Text Settings dialog box apply to all text to be added to the
drawing, while the settings in the Text Change dialog box apply to the selected
existing text.
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Converting Text to Geometry (DXF/DWG
and IGES 2D Translation)
Creo Elements/Direct Drafting allows you to convert text entities to geometry

entities using Text To Geo. This is necessary for translation to DXF/DWG and
IGES 2D format when customized fonts have been used (the MI file stores the
font name but does not contain the customized font information).
To convert text entities to geometry entities:

1. Click Modify and then, in the Annotate group, click the arrow next to Text.

2. Click Text To Geo.

Note
• Only text entities can be converted, except dimension texts.
• Any text-windows inside hatched areas are retained.

Creating a Reference Line
Creo Elements/Direct Drafting allows you to create a reference line between a
source element and its associated target element using the Reference Line buttons.
The Reference Line buttons let you create a reference line between a source
element and its associated target element. Creating reference lines helps to speed-
up the modification phase as it saves you time repositioning individual elements.
When you move the target element of a reference line, the reference line remains
attached to the target element like a "rubber band" (see Figure 159. Effect of
Moving the Target Element on page 396).
To draw a reference between two existing elements:

1. Click Drafting and then, in the Annotate group, click More.
2. Under Reference Line, click the required button.

Reference Line Button Description

Parallel
The reference line is drawn parallel to the
orientation direction of the source element.

Horizontal
A horizontal reference line is drawn from the
source element.

Vertical
Avertical reference line is drawn from the source
element.
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Reference Line Button Description

Perpendicular
The reference line is drawn perpendicular to the
orientation direction of the source element.

Reference Angle
This button prompts you for an angle. Type the
required angle into the user input line and press
ENTER. The angular units are interpreted in
terms of the angle units currently defined for
your Creo Elements/Direct Drafting
environment. A zero value implies horizontal
text and a positive angle results in
counterclockwise rotation.

Attach Source
This button enables you to attach the reference
line to its source element. When you move the
source element, the reference line remains
attached to this element like a "rubber band".

Underline
The source element is underlined.

Invisible
An invisible reference line is drawn.

Note
When you draw a multi-segment reference line (by clicking points
between the source element and its target element), note that these buttons
apply to the first reference line segment (between the source element and
the first reference line point you click) only.

3. Click the associated source element (such as an existing text block).
4. Optionally, click a number of points through which you want the reference line

to pass.
5. Click the target element (the element to which the source element refers).
Creo Elements/Direct Drafting draws a reference line between the two elements.
The newly added reference line reflects the settings defined via Reference Line
Settings on page 396.
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Figure 159. Effect of Moving the Target Element

For deletion purposes, even a multi-segment reference line is considered as a
single element and can be deleted in one operation.

Modify a Reference Line
To quickly modify the reference line, use the handles as follows:
To reattach the reference line, click the handle on the start or end of the reference
line and drag.
To stretch reference line segments, click the reference line handles and drag.

To change the handle settings click File ▶ Settings ▶ System and then click
Handles.

Delete a Reference Line
To delete a reference line:
1. Click the reference line.
2. Press DELETE.

Reference Line Settings
To open the Reference Line Settings dialog box:

• Click File ▶ Settings ▶ Refline.
The Reference Line Settings dialog box enables you to define:

• Line Settings on page 396
• Reference Line Terminator on page 397

Line Settings
In the Line area of the Reference Line Settings dialog box, set the following:
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• Type

• Color

• Width

Type
To set the linetype of reference lines, select a linetype in the Type box in the Line
area of the Reference Line Settings dialog box.

Color
To set the reference line color, select a color in the Color box in the Line area of
the Reference Line Settings dialog box. Refer to Defining Custom Colors on page
100 for instructions on defining custom colors.

Width
To set the reference line width, type the required width in the Width box in the
Line area of the Reference Line Settings dialog box. Refer to Line Width vs. Line
Size on page 95 for further information on line width.

Reference Line Terminator
In the Terminator area of the Reference Line Settings dialog box, set the following:

• Type

• Size

Type
To set the reference line terminator type, select one of the following options in the
Type box in the Terminator area of the Reference Line Settings dialog box:

• None

• Arrow

• Dot

• Slash

• Triangle

• Jis
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Size
To set the reference terminator size width, type the required value in the Size box
in the Terminator area of the Reference Line Settings dialog box. This value is
interpreted in terms of the length unit (such as mm) currently set up for your Creo
Elements/Direct Drafting environment.

Reference Line Options
In the Options area of the Reference Line Settings dialog box, set the following:

• Source Gap

• Destination Gap

• Offset

All three values are interpreted in terms of the length unit (such as mm) currently
set up for your Creo Elements/Direct Drafting environment.

Source Gap
To set a distance between the begin point of the reference line and its source
element, type the required value in the Source Gap box in the Options area of the
Reference Line Settings dialog box.

Destination Gap
To set a distance between the end point of the reference line and its target element,
type the required value in the Destination Gap box in the Options area of the
Reference Line Settings dialog box.

Offset
To set a distance between the begin point of the reference line and its source
element as well as between its end point and its target element, type the required
value in the Offset box in the Options section of Reference Line Settings.

Getting and Putting Text Properties
Any properties you assigned to a text block (see Text Settings on page 388 and
Changing Text Settings on page 393) can be assigned to another text block.
To assign the properties of a text block to another text block:

1. In the Utilities group, click Properties.

2. Click Get.
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3. Click the text block whose properties you want to assign.

4. In the Utilities group, click Properties.

5. Click Put.
6. Click the text block to which you want to assign these properties.

Font Editor
The Creo Elements/Direct Drafting Font Editor enables you to modify existing
Creo Elements/Direct Drafting fonts and create new fonts. The Creo Elements/
Direct Drafting Font Editor is particularly useful in design environments where
company-specific characters or logos are required and for Japanese Kanji
character-sets.
When working with the Font Editor, note the following:

• Although you can use the buttons in the View group to do such things as a
redraw, do not change to another menu until you are finished.

• Store the current drawing (MI file).
• When you have finished creating or modifying the font, you must save it.
• All loaded fonts are listed in a selection table.
• The font you are editing becomes the current font.

Caution

Before using Font in the Font Editor group on the Miscellaneous tab, save
the current drawing. This is because the font editor uses the current drawing
area to display the font table and deletes anything in the current workspace.

Editing a Font
To edit a font:

1. Click Miscellaneous and then, in the Font Editor group, click Font.

The Select Font dialog box opens.
2. In the List box, select a font and click Edit.

Details of the selected font appear in the viewport.

3. Click Miscellaneous and then, in the Font Editor group, click Show Font.
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All the characters of the selected font are displayed in the Creo Elements/
Direct Drafting drawing area.

4. Click Drafting and then, in the Font Editor group, click the arrow next to
Character.

5. Click Edit.
6. Type the character number (for example 174) which you want to edit in the

user input line and press ENTER.

Creo Elements/Direct Drafting displays the character and a yellow character
frame.

Character Frame

Note
• If you use this method to add special characters to the hp_symbols or

hp_symbols2 font, be sure to edit an empty character (indicated by a
blank square).

• These special characters are available for use in text, dimensions, and
symbols.

7. Modify or delete the geometry of the character.
8. Click Miscellaneous and then, in the Font Editor group, click the arrow next to

Draw.

9. Use the Draw buttons ( Line, Rectangle, Polygon, Circle,

Arc, or Point) to create a new character.
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Note
The maximum number of unconcatenated elements in a character is 84.

10. Click Miscellaneous and then, in the Font Editor group, click the arrow next to

Character.

11. Click Update.
12. Type the character number in the user input line and press ENTER.

You can retain the same character number or assign a new character number.

You can repeat the procedure for other characters, if required.

Note
If you use this method to create additional special characters in the hp_
symbols or hp_symbols2 font, be sure to save the edited version under a
unique name in a separate directory so that it can be reused following a Creo
Elements/Direct Drafting update.

Changing the Character Spacing
To change the spacing between characters:

1. Click Miscellaneous and then, in the Font Editor group, click the arrow next to

Change.
2. Click one of the following:

• Normal Distance to change the distance between constant-spaced
characters.

• Constant Width to change the distance between variable-spaced
characters.

After you change the character spacing, Creo Elements/Direct Drafting draws
subsequent text blocks with the new character spacing.
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Characters with Constant Spacing

Characters with Variable Spacing

Grouping
You can group annotations together. Groups on page 241 may consist of a single
dimension, multiple text elements and multiple symbols.

Further Information
For further technical information about text, refer to the Creo Elements/Direct
Drafting help system.
Type the following in the Creo Elements/Direct Drafting user input line and press
ENTER:

• help text

• help help wui_enter_text

• help wui_change_text

• help wui_text_settings

• help text_to_geo

• help text_split

• help refline

• help wui_refline_settings

• help leader_line

Creo Elements/Direct Drafting displays further information about text.
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Geometric Tolerancing Symbols
This section describes how to add geometric tolerancing symbols to your drawing.
The symbols are based on the hp_symbols2 font. When you add symbols to a
drawing, Creo Elements/Direct Drafting uses this font.

Setting Symbol Size
The size of symbols and associated text is determined by the Size setting in the
Parameters area of the Text Settings dialog box. Therefore, before you start adding
symbols to your drawing, set the desired text size as described in Adding Text to a
Drawing on page 382.
To change the size of symbols and associated text, use the Text Change dialog box
settings as described in Adding Text to a Drawing on page 382.

Deleting and Moving Symbols

Deleting Symbols
There are two ways to delete a symbol:

1. Click the symbol.

A frame appears around the symbol.
2. Press DELETE.
Alternatively:

1. In the Utilities group, click Delete.
2. Select the element that you want to delete.

Moving Symbols
There are two ways to move a symbol:

1. Move the symbol box.

• Hover the cursor over the symbol. Creo Elements/Direct Drafting
highlights a box around the symbol (if the Enable Fly-By Highlighting
check box is clicked in the System dialog box).

• Drag the symbol to a new location.

2. Click Modify and then, in the General group, click the required Move
buttons.
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Move the symbol just as you would move a text, a line, or an arc (see Moving
Elements on page 209).

Building a Geometric Tolerance Group
Click Drafting and then in the Annotate group, click Symbol

The Symbols dialog box opens. The settings in this dialog box allow you to
quickly build up the desired geometric tolerance group.
The main settings are:

Setting Description
Tolerance Sets the Normal or Composite symbol mode.
Type Enables you to select a symbol type.
Symbol Provides a preview of the current symbol

definition in a rectangular area.
Symbol Browser Bar Displays predefined symbols of the selected

Type.
Add Text Displays the Add Text dialog box for adding text

to a symbol.
Appends a short vertical line to the symbol.

Adds a new line to the symbol.

Appends the ] character to the symbol.

Undoes the last addition to the symbol.

Apply Applies the current symbol definition. Simply
position the symbol in the drawing.

Cancel Cancels the current symbol definition.

To draw a geometric tolerance group:

1. Click Drafting and then in the Annotate group, click Symbol.

The Symbols dialog box opens.
2. In the Tolerance box, select a symbol mode:

• Normal

• Composite

3. In the Type box, select a symbol type:
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• Geometric Symbols

• Modifying Symbols

• Draws Datum Target and Revision Symbols

Symbols of the selected type are displayed on the Symbol Browser bar.
4. Click a symbol on the Symbol Browser bar.

This symbol is displayed in the Symbol preview area.
5. Optionally, click Add Text and type the text to be added to the symbol in the

Add Text box. Use all upper case letters. Click OK to close the text box and
append the text to the symbol.

6. Click , or , or to append vertical and/or horizontal lines and/or ]
characters to the symbol.

7. Click Apply when the symbol displayed in the preview area is complete.
8. Position the symbol in the Creo Elements/Direct Drafting drawing.

Note
A copy of the same symbol is added to the drawing every time you click a
point in the drawing.

9. Click OK to terminate the positioning of the symbol.
10. Optionally, attach a reference line which connects the symbol to the associated

feature in the Creo Elements/Direct Drafting drawing. See Creating a
Reference Line on page 394 for instructions.

Normal or Composite Symbols
Figure 160. Position Geometric Symbol on page 406 shows an example of a
Position geometric symbol. Both the Normal and Composite options are shown.

Figure 160. Position Geometric Symbol
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Drawing a Geometric Symbol
In the Symbols dialog box, select Geometric Symbols in the Type box to draw
geometric symbols.

Form Symbols
Figure 161. Symbol Type and Form Geometric Symbols on page 407 shows the
four form symbols.

Figure 161. Symbol Type and Form Geometric Symbols

1 Straight
2 Flat
3 Round
4 Cylinder

Profile Symbol
Figure 162. Profile Geometric Symbols on page 407 shows the two profile
symbols.

Figure 162. Profile Geometric Symbols

Location Symbols
Figure 163. Location Geometric Symbol on page 408 shows the three location
symbols.
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Figure 163. Location Geometric Symbol

1 Position
2 Symmetry
3 Concentric

Alignment Symbols
Figure 164. Alignment Geometric Symbols on page 408 shows the three
alignment symbols.

Figure 164. Alignment Geometric Symbols

1 Angular
2 Perpendicular
3 Parallel

Runout Symbols
Figure 165. Runout Geometric Symbols on page 408 shows the two runout
symbols.

Figure 165. Runout Geometric Symbols

1 Circular
2 Total
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Appending Text
Text can be added to symbols with Add Text. Use this command to interrupt the
symbol group, add text, and then proceed with the symbols. Use all upper case
letters. The two examples in Symbol Examples on page 410 show you the correct
sequence of steps.

Figure 166. Adding Symbol Text

Drawing Modifiers
In the Symbols dialog box, select Modifying Symbols in the Type box to draw any
of the symbols shown in Figure 167. Modifier Geometric Symbols on page 409.

Figure 167. Modifier Geometric Symbols

Drawing Datum Target and Revision Symbols
In the Symbols dialog box, select Draws Datum Target and Revision Symbols in the
Type box to draw any of the symbols shown in Figure 168. Target and Revision
Symbols on page 410.
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Figure 168. Target and Revision Symbols

1 Symbol
2 Point
3 Revision

Symbol Examples
Drawing symbols is a simple task and can quickly be mastered by following
specified steps.
Before starting, set the text size to 5 mm, the text adjust to 1 (refer to Adding Text
to a Drawing on page 382 for details).

Example 1: Single Line Symbol Group

Figure 169. Symbol Group – Example 1

To add symbol text:

1. Click Drafting and then , in the Annotate group, click Symbol.

The Symbols dialog box opens.
2. In the Tolerance box, select Normal.
3. In the Type box. select Geometric Symbols.

4. Click the (Total Runout) symbol on the Symbol Browser bar.
5. In the Type box, select Modifying Symbols.

6. Click the symbol on the Symbol Browser bar.
7. Click Add Text and type 0.02 in the box.
8. Click OK.

9. Click .
10. Click Add Text and type A in the box.
11. Click OK.
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12. Click .
13. Click Add Text and type 5R in the box.
14. Click OK.

15. Click .
16. Click Apply.
17. Specify a point to position the symbol in the Creo Elements/Direct Drafting

drawing.

Example 2: Multiline Symbol Group

Figure 170. Symbol Group – Example 2

To add symbol text:

1. Click Drafting and then in the Annotate group, click Symbol.

The Symbols dialog box opens.
2. In the Tolerance box, select Composite.
3. In the Type box, select Geometric Symbols.

4. Click (Concentric) symbol on the Symbol Browser bar.
5. In the Type box, select Modifying Symbols.

6. Click (Diameter) symbol on the Symbol Browser bar.
7. Click Add Text and type 0.01 in the box.
8. Click OK.

9. Click .
10. Click Add Text and type A in the box.
11. Click OK.

12. Click .

13. Click to initiate a second line in the symbol.

Adding Symbols to a Drawing 411



14. Click (Diameter) symbol on the Symbol Browser bar.
15. Click Add Text and type 0.02 in the box.
16. Click OK.

17. Click .
18. Click Add Text and type B in the box.
19. Click OK.

20. Click .
21. Click Apply.
22. Specify a point to position the symbol in the Creo Elements/Direct Drafting

drawing.

Example 3: Editing a Symbol Group

Creo Elements/Direct Drafting allows you to edit Symbol groups using Edit.
It converts the symbol into a readable text-string and displays it in a text box for
editing. This text-string also contains control characters (\030) that should not be
edited. If they are modified, the conversion link back to the symbols font is lost
and the symbol appears as normal text.
To edit the symbol text:

1. Click Modify and then, in the Annotate group, click the arrow next to
Symbols.

2. Click Edit.
3. Click the symbol you want to edit.

Creo Elements/Direct Drafting displays the text in a standard text editor,
similar to the following:
\030\151e0.01|A}
\030fe0.02|B}

4. Edit the text and click File ▶ Save in the standard text editor to save your
changes.

Surface Symbols
To open the Surface Symbols dialog box:

1. Click Drafting and then, in the Annotate group, click the arrow next to
Symbol.
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2. Click Tolerance.

The TOLERANCE SYMBOLS dialog box opens.
3. Click Menu 2.

The Surface Symbols dialog box opens.
In the TOLERANCE SYMBOLS dialog box, under Functional Areas, the following
buttons are available:
Button Description

Load or save a symbol set.

Load, save, or delete individual symbols in the
current symbol set.
Display the positioning menu for the current
symbols.

After you click , the following Positioning
buttons are available:

Note
The positioning point marks the foot point of
the symbol.

The symbol is drawn
horizontally from the
positioning point to the
right.
The symbol is drawn
vertically upwards from the
positioning point.
The symbol is drawn
vertically downwards from
the positioning point.
The symbol is drawn from
the positioning point (first
point) towards the second
point.
The symbol is drawn from
the positioning point (first
point) at the specified
angle.
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Button Description
Remove, read or replace existing symbols in the
drawing.
Display the setup menus for surface symbols.

Setting Up Surface Symbols
To define the settings for surface symbols:

• In the TOLERANCE SYMBOLS dialog box, under Functional Areas, click

.

The SETUP 1 SURFACE dialog box opens.
You can define the following settings in the SETUP 1 SURFACE dialog box:

• Surface Symbols

File Filename of the currently loaded symbol set or,
following changes, the name of the symbol set to be
loaded.

Font Select the font size in the Font Size box for surface
symbols. If you prefer to use your own font size,
specify the applicable number in the user input line and
press ENTER. Note that italic fonts are marked by the
letter i preceding the fnt extension. For example, the
italic version of the hp_symbols2 font is named hp_
symbols2_i.fnt.

Color Select the color in the Symbol Color box for surface
symbols.
Optionally, you can type RGB values in the user input
line and press ENTER

Text Angle Select a text character slant angle in the Text Slant box.

• Reference Lines
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Color Select the color for reference lines in the RefLinColor box.
Optionally, you can type RGB values in the user input
line and press ENTER.

Width Select the reference line width in the Line Size box.
Optionally, you can specify a numerical value for the
reference line width in the user input line and press
ENTER.

Note
The Width setting applies to both, reference lines and
symbols.

Automatic Toggle to enable or disable the automatic addition of
reference lines.

• Reference Lines Symbol

Shape Select a point, an arrow, a triangle or a dash as the
terminator for reference lines in the Shape box.

Size Select the reference line terminator size in the Size box.
Optionally, you can type a numerical value for the
reference line terminator size in the user input line and
press ENTER.

• Angle Correction

Ref Line Select the maximum deviation angle (in degrees) at which
the reference line snaps to the horizontal or vertical
direction in the Correction box. The default value of 45
degrees implies that the reference line is always drawn
horizontally or vertically. If you want to draw reference
lines at arbitrary angles, select 0.

The "surf_sym" Symbol Set Supplied with Creo
Elements/Direct Drafting
The surf_sym symbol set supplied with Creo Elements/Direct Drafting includes
the following preconfigured surface symbols:
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coated

milled

mat_remov

no_mat_remov

smooth

raw

Use Load to load this symbol set.

Illustrated Examples of Surface Symbols
To create your own surface symbols, either modify one of the preconfigured
symbols supplied with Creo Elements/Direct Drafting or create symbols "from
scratch". Both methods are illustrated in the following section.
In the following example, four surface symbols are added to the drawing of a
casting.
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Casting plus Surface Symbols

The following exercise illustrated the procedure for creating the surface symbols
((A)), ((B)), ((C)) and ((D)).

Symbol ((A))

1. Click Drafting and then, in the Annotate group, click the arrow next to
Symbol.

2. Click Tolerance.

The TOLERANCE SYMBOLS dialog box opens.
3. Under Compose Menu, click S to display the current symbol definitions.

The Symbol Form box opens.

4. Click .

Note
The extension line running to the right is drawn only if you specify additional
symbol-related data.

5. Under Compose Menu, click a2.

The Roughness box opens.
6. Select Ra 3.2.
7. Under Compose Menu, click c.
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The Reference Distance box opens.
8. Select 5.
9. Under Compose Menu, click d.

The Lay Direction box opens.
10. Select =.

11. Under Functional Areas, click .

You do not need to specify any positioning options because the symbol is in
the default direction (from left to right).

12. Specify the positioning point (the foot point) for symbol ((A)) in your
drawing.

Symbol ((B))
1. Load the smooth surface symbol.
2. Under Compose Menu, click d.

The Lay Direction box opens.
3. Select EMPTY.
4. Under Compose Menu, click a2.

The Roughness box opens.
5. Type ‘Ra 0,8’ in the user input line and press ENTER.
6. Under Compose Menu, click c.
7. Type ‘’ (a blank space) in the user input line and press ENTER.
8. Under the Compose Menu, click f1.
9. Type ‘Rz 2,5’ in the user input line and press ENTER.
10. Position symbol ((B)) in your drawing.

Symbol ((C))

1. Click :
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Note
When you select a different symbol type, the existing settings are
preserved in the Compose Menu. Therefore, any settings for a different
symbol type require explicit changes. To leave any symbol element blank,
you either specify a space character (in apostrophes) or you can click
EMPTY.

2. Under Compose Menu, click d.

The Lay Direction box opens.
3. Select EMPTY.
4. Under Compose Menu, click a2.
5. Type ‘Ra 100’ in the user input line and press ENTER.
6. Under Compose Menu, click b.

The Manuf Process Surface Treat box opens.
7. Select grinded.
8. Under Compose Menu, click e.

The Manuf Allowance box opens.
9. Select 3.
10. Under Compose Menu, click f1.
11. Select Rz 25.
12. Position the symbol at a suitable point to the left of and below the area to

marked for grinding.
13. To select the start point of the reference line, click a point to the left of the

symbol foot point.
14. To select the flexion point of the reference line, click a point close to a line

which is perpendicular to the area to be marked for grinding.
15. To select the start point of the reference line arrow, click a point on the area to

be marked for grinding.

16. Click Confirm.

Symbol ((D))
1. Load the milled surface symbol.
2. Under Compose Menu, click a1.
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The Roughness box opens.
3. Select Ra 50.

4. Click to position symbol ((D)) in your drawing.

Welding Symbols
To open the Welding Symbols dialog box:

1. Click Drafting and then, in the Annotate tab, click the arrow next to
Symbol.

2. Click Welding.

Composing a Welding Symbol
To compose a welding symbol, click the applicable button under the Compose
Menu or select the associated items of the symbol (indicated graphically in the
menu).

Note
To familiarize yourself with the symbol composition method, load one of the
welding symbols supplied with Creo Elements/Direct Drafting and check the
resulting welding symbol in your drawing with its associated items in the
Compose Menu.

Text
To view the associated Text Menu:

• In the Welding Symbols dialog box, under Welding Symbols, click Text.
You can specify the individual text strings for your welding symbols either as
default strings in submenus, or you can specify text strings (in apostrophes).
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Note
The following applies to fillet weld offsets:

• Specify the following if you want the Z to cross the reference line:
\V

• Specify the following if you do not want the Z to cross the reference line:
\v

Symbol Elements
The following welding symbol elements are provided to facilitate the creation of
welding symbols:

Item Description
Sy 1 Welding symbol
Sy 2 Welding symbol
Sy 3 Welding symbol
Sy 4 Supplementary symbol
Sy 5 Supplementary symbol
R Sm Opens the Ring Seam box.
M Sm Opens the Mounting Seam box.
Fork Opens the Fork box.
- - Relative position of the reference extension line. The

following options are available:
up: The reference extension line is located above the
reference line.
down: The reference extension line is located below the
reference line.
without: No reference extension line.

Positioning Welding Symbols

1. Click .
2. Select the applicable positioning icon.
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Note
Unless you explicitly select a positioning icon, the symbol is drawn from

left to right. This default is associated with the icon.

3. Click a point in your drawing to add the welding symbol.
4. Draw the reference line for your welding symbol. Follow the instructions in

the following section.

Menu 2
Menu 2 for welding symbols provides a number of functions similar to those for
surface symbols plus a number of welding-related functions.

Welding Seams

• : selects fillet weld symbols.

• : indicates weld surfaces in your drawing.

Text Functions
Use Text Functions to add text in the font size of the current drawing. Click a
button, type the text (in single quotes or double quotes) in the user input line and
press ENTER.

Adds text without a frame.

Adds text in a rectangular box.

Adds text in a balloon.

Enables you to move text added by one of these
three text frame options.
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Reference Line
The Reference Line function enables you to manually create a reference line for
the current symbol.
The reference line always runs from the object to the symbol.
To use the Reference Line function:

1. On Menu 2, under Reference Line, click .

The begin point of the reference line is automatically attached to the symbol.
2. Click any points along the reference line and any bend points.
3. Click the end point of the reference line.

4. To complete the reference line, click Confirm.

Note
To break (interrupt) the reference line, click Free.

To delete the last point on the reference line, click Back.

Stretch Symbols
Stretches symbols vertically.

Stretches symbols horizontally.

Construction Lines
Creates a construction line at an
angle.

Creates a horizontal construction
line.

Creates a vertical construction line.
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Setting Up Welding Symbols
The text, color, and reference line setup options for welding symbols are similar to
those for surface symbols. See Setting Up Surface Symbols on page 414.
Additionally, you can also define the following settings:

• Welding Seams

Color Select the color of fillet weld and weld surface symbols
in the Symbol Color box.
Optionally, you can type RGB values in the user input
line and press ENTER.

Hatch Dist Select the hatch distance for fillet weld symbols in the
LinDist box.
If you want to draw fillet weldÇ symbols "filled", select
this distance as 0.

Line Type Select the linetype for fillet welds and weld surfaces in
the Line Type box.

The "weld_sym" Symbol Set Supplied with Creo
Elements/Direct Drafting
The weld_sym symbol set supplied with Creo Elements/Direct Drafting includes
the following preconfigured welding symbols:

• V-U-weld

• V_back

• fillet_back

• fillet_ring
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Use Load to load this symbol set.

Illustrated Examples of Welding Symbols
To create your own symbols, either modify one of the preconfigured symbols
supplied with Creo Elements/Direct Drafting or create symbols "from scratch".
Both methods are illustrated in the following section.
In the following example, a number of welding symbols are added to a simple
sheet metal design.

Sheet Metal Design plus Welding Symbols

The following exercise illustrated the procedure for creating the welding symbols
((A)), ((B)), ((C)), ((D)), ((E)), ((F)) and ((G)). This exercise assumes that the
Welding Symbols dialog box is open.

Symbol ((A))
1. Load the kehl_gegen welding symbol.

2. Under Functional Areas, click .
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The Positioning box opens.

3. Click .
4. Click the positioning point for the symbol.
5. Click a point vertically above the symbol positioning point.
6. Click the reference line end point.

Symbol ((B))
1. Load the V_back welding symbol.
2. Position this welding symbol and its reference line in your drawing.

Symbol ((C))
1. In the WELDING SYMBOLS dialog box, click Menu 2 ▶ SETUP.
2. Under Welding Seam, click Hatch Dist.

The LinDist box opens.
3. Select 0.

4. On Menu 2, under Welding Seams, click .
5. Type 4as the fillet weld width in the user input line and press ENTER.
6. Click the vertex for the "left" leg of the fillet weld.
7. Click the first leg.
8. Click the second leg.
9. Repeat the earlier four steps to define the "right" fillet weld.

Symbol ((D))
1. In the Welding Symbols dialog box, under Welding Symbols, click Text.
2. Under Compose Menu, click T 1.
3. Type 3 in the user input line and press ENTER.
4. Under Text Menu, click Sym.
5. Under Compose Menu, click Sy 2.
6. Select the delta symbol.
7. Under Compose Menu, click R Sm.

The Ring Seam box opens.
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8. Select .
9. Under Compose Menu, click M Sm.

The Mounting Seam box opens.

10. Select .
11. Position the symbol and its reference line.

Note
The SETUP Weld Symb dialog box enables you to select defaults for the size of the
symbol elements.

Symbol ((E))
1. Load the zwr_pnt_n welding symbol.
2. In the Welding Symbols dialog box, under Welding Symbols, click Text.
3. Under Compose Menu, click T 1.
4. Type ‘5’ in the user input line and press ENTER.
5. Under Compose Menu, click T 2.
6. Type ‘10(30) \v (20)’ in the user input line and press ENTER.

7. Click .
8. Click the positioning points for the symbol.
9. To define the reference line direction, click a point horizontally above and to

the left of the symbol positioning points.
10. Click the reference line end point.

Symbol ((F))
1. In the Welding Symbols dialog box, click Menu 2.

2. Under Welding Seams, click .
3. Type 5 as the weld contour width in the user input line and press ENTER.
4. Type 4 as the weld contour spacing factor in the user input line and press

ENTER.
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5. Click the start point of the weld.
6. Click the end point of the weld.

Symbol ((G))
1. In the Welding Symbols dialog box, under Welding Symbols, click Text.
2. Under Compose Menu, click T 1.
3. Type ‘3’ in the user input line and press ENTER.
4. Under Text Menu, click Sym.
5. Under Compose Menu, click Sy 2.

The Weld Symbol box opens.
6. Select the delta symbol.
7. Under Compose Menu, click - -.

The Position box opens.
8. Select up.
9. Position the symbol such that its reference line points to the left.

Grouping
You can group annotations together. Groups on page 241 may consist of a single
dimension, multiple text elements and multiple symbols.

Further Information
For further technical information about symbols, refer to the Creo Elements/Direct
Drafting help system.
Type the following in the user input line and press ENTER:

• help edit_text

• help wui_spec_char_browser

Creo Elements/Direct Drafting displays further information about symbols.
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Introduction to Parts
Parts are most useful in large complex drawings. Therefore, in your first few
weeks of using Creo Elements/Direct Drafting you may not want to complicate
the drawing process by using parts. However, as you become a proficient user,
you will begin to see how the use of parts will simplify complex drawings and
increase your productivity. Using parts in a drawing is a matter of personal choice;
different users will use a different parts structure on the same drawing.
With these points in mind, now consider some ideas and definitions of parts.

What is a Part?
A part is a logical grouping of elements, for example, a group of elements that
make up a component in a sub-assembly.
A drawing created without the use of parts consists of a number of lines, circles,
arcs, pieces of text, and so on. Each line, circle, arc, and so on, is known as an
element.
If you use parts in a drawing, each part is a collection of elements. Thus, without
parts, a drawing consists of a collection of elements, but with parts a drawing
consists of several parts, each part being a collection of elements.

The Top Part
Remember that without parts a drawing is a collection of elements. You could also
say that a drawing without parts is in effect a drawing containing one part; the part
and the drawing are one and the same. Each part has a name (more details are
given later in this section), and the name of the part you are using is displayed in
the status bar. In a drawing without parts you will see the name associated with the
top part (default name Top) displayed in the status bar; all the elements of the
drawing are in this single part.
In an assembly drawing certain parts will contain drawing elements, a name, and
possible subparts. Other parts contain only a name and possible subparts, these
parts are used as pointers to assemblies.

Parts Structure Explained
A parts structure can be thought of as a family tree showing the hierarchical
relationships of all the parts. Because of this hierarchical nature, we talk about the
different levels of the structure. At the highest level a single part exists; this is the
Top part already discussed. For your first few drawings using parts, it is best to
use a parts structure with only one level; more experienced users will use a multi-
level structure. The two types of parts structure are shown below:
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Figure 171. Single-Level Parts Structure

Figure 172. Multi-Level Parts Structure

Hierarchical Parts Structure
The hierarchical structure of parts means that one part can own other parts. Refer
to the CYLINDER ASSEMBLY hierarchy shown in Figure 181 on page 431. The
parts structure is as follows:
PISTON ASSEMBLY can be thought of as the owner of PISTON, PISTON RING
# 1, PISTON RING # 2, and WRISTASSEMBLY.
We refer to the owning part (PISTON ASSEMBLY) as the parent and the owned
parts (PISTON, PISTON RING # 1, PISTON RING # 2, and WRIST
ASSEMBLY) as subparts.
Note that the hierarchical level of the current part is indicated through an integer
in the status bar.

Note
This ownership mechanism implies that deleting a parent part will also result
in the deletion of all its subparts.
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Setting the Active Part
Except for a few special cases, all newly created elements (lines, arcs, text, and so

on) are placed in the active part. Also, most of the commands using the Select

buttons (for example, Delete and Change) only operate on the active part. The

Part button under Edit in the Parts group on the Structure tab allows you

to set the active part. Thus, by using the Edit buttons to make different parts
active, you can place elements in different parts.

Note
The name of the active part is displayed in the status bar.

Rules for Part Names
Follow these rules when entering part names:

• Part names are limited to 255 characters in length.
• Any characters may be used in a part name with the exception of:

○ / (Only allowed as the name of the top part when not used together with
other characters.)

○ ~

○ . (Invalid part name when used alone, but may be used together with other
characters.)

Examples of impossible names are:

○ .

○ ..

○ /hello

○ hello~

Examples of possible names are:

○ hello

○ / (Can be used only for the top part.)
• Whenever possible, give your parts meaningful names. This helps to recognize

the part.
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Note
Creo Elements/Direct Drafting can assign a default name to a part. The Creo
Elements/Direct Drafting default name will be in the series .1, .2 , .3 and so
on. See Initiating a Part on page 441.

The Advantages of Parts
Using parts has the following advantages:

• You can arrange a complex drawing into a convenient logical structure.

• Modify, Delete and most of the commands using the Select
buttons can be used on complete parts, thus you need only identify the part
and not every element.

• Parts can be stored in or loaded from a file. This allows you to build up
libraries of standard parts.

• By making a master drawing into parts, two or more people can work on
individual parts of the master drawing. You can also quickly build up a final
master drawing.

• Special Parts buttons (such as the Symbol check box) allow you to create
custom symbols.

Creating an Assembly Drawing
To make full use of the Creo Elements/Direct Drafting parts functionality you
should create and maintain a parts and assemblies structure for your drawing files.
This approach to drawing facilitates the link between your Creo Elements/Direct
Drafting design data and a relational database management system.
The following example shows one way to create the assembly drawing WRIST
ASSEMBLY from the following component drawings:

• RETAINING CLIP # 1
• RETAINING CLIP #2
• WRIST PIN
Figure 173 on page 434 shows the WRISTASSEMBLY structure.
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Figure 173. WRISTASSEMBLY Structure

Initial Stages
For the purposes of this example, assume that each component drawing has not
yet been given a part name.

Note
Drawings have two names associated with them:

1. The drawing storefile name — indicated in lower case.
2. The drawing partname — indicated in CAPITALS.

First load each individual component drawing, give it a part name and set a
reference point to enable accurate positioning in the final assembly drawing.

1. Load the drawing file retain_clip1_d.mi.

a. Click File ▶ Open.

The Open dialog box opens.
b. Click retain_clip1_d.mi.

Creo Elements/Direct Drafting displays the drawing of RETAINING
CLIP #1.

2. Set a reference point on the drawing to enable accurate positioning in the final
assembly drawing.

a. Click Structure and then, in the Parts group, click Set Ref Pnt.
b. Specify a reference point.

3. Delete all unnecessary construction lines.

a. In the Utilities group, click Delete.
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b. In the Utilities group, click Select ▶ Advanced.

The Select window opens.

Alternatively, press F2 to directly open the Select window.
c. Click CGeo and then click All.
d. Click OK.

4. Provide a part name to the drawing.

This part name is displayed in the Part Browser.

a. Click Structure and then, in the Parts group, click Browser.

The Part Browser opens.

Alternatively, press F12 to open the Part Browser.
b. In the Part Browser, right-click the part name you want to rename and

click Rename.
c. Rename the current part name as RETAINING CLIP # 1.

5. Store the new drawing (without construction lines).

a. Click File ▶ Save.
b. Type the new file name (for example retainclip1) and then click

Save.

Note
The mi suffix is appended automatically.

c. In the Utilities group, click Delete.

d. In the Utilities group, click Select ▶ All.

e. Click Confirm.
6. Repeat these steps for the component drawings:

• retain_clip2_d.mi

• wrist_pin_d.mi
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Creating WRISTASSEMBLY
Next create the assembly drawing WRISTASSEMBLY:

1. Click Spotlight in the status bar.

As a result, the active part has a normal appearance and all non-active parts are
shown in magenta dotted lines.

2. Ensure that the Creo Elements/Direct Drafting top part is empty.

a. Click Structure and then in the Parts group, click Edit.

b. Click Top.

c. In the Utilities group, click Delete.

d. In the Utilities group, click Select ▶ All.

e. Click Confirm.
3. Rename the top part with the assembly drawing name you wish to see in the

parts list.

a. Click Structure and then in the Parts group, click Browser.

The Part Browser opens.

b. In the Part Browser, right-click Top and click Rename.
c. Rename Top as WRIST ASSEMBLY.

The name of the active part in the status bar changes to WRIST ASSEMBLY.
This part contains only the assembly name WRIST ASSEMBLY but no
drawing elements.

4. Now load the first part of the assembly, for example the wrist pin.

a. Click File ▶ Open .
b. Select wristpin as the filename of the drawing to be loaded.

Creo Elements/Direct Drafting prompts you to indicate a reference point to
position the drawing.

c. Specify a reference point.
5. Repeat steps 2 to 4 for the drawings:

• retainclip1.mi

• retainclip2.mi
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6. Store the final assembly drawing as wrist_assy.

Creating Further Assemblies
The next stage in your assembly would be to create the PISTON ASSEMBLY
drawing. The procedure is the same as previously described:

1. Create an empty top part in Creo Elements/Direct Drafting.
2. Rename the top part PISTON ASSEMBLY.
3. Construct PISTON ASSEMBLY from the following parts:

• PISTON RING # 1— a single component part.
• PISTON RING # 2— a single component part.
• WRIST ASSEMBLY— an assembly.
• PISTON— a single component part.

Creating a Final Engine Assembly Drawing
The ultimate industrial requirement would normally involve the creation of
several assembly and sub-assembly drawings. In the case of our example, the
following drawings would be incorporated into a final assembly drawing at the
highest level of detail, for example ENGINE ASSEMBLY:

• CRANKCASE ASSEMBLY
• CRANK ASSEMBLY
• HEAD ASSEMBLY
• CYLINDER ASSEMBLY (which contains the PISTON and WRIST

assemblies)
Figure 174 on page 438 shows how the completed cylinder assembly drawing
might appear:
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Figure 174. Completed Cylinder Assembly Drawing

Deleting Parts
Consider the CYLINDER ASSEMBLY hierarchy with PISTON ASSEMBLY
active. Figure 175 on page 438 shows three examples of the deletion mechanism.
The star shows the active part; the D shows that an element in the part was
identified for deletion.

Figure 175. Deleting Parts

Note that in the third case:
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• The entire WRISTASSEMBLY would be deleted if any element of RETAIN
CLIP 1, RETAIN CLIP 2, or WRIST PIN were identified.

• If WRISTASSEMBLY was made active and an element in RETAIN CLIP # 1
identified for deletion, only RETAIN CLIP # 1 would be deleted.

Note
You cannot delete the current active part or the Top part. A link is always
maintained to the Top part.

To delete parts:

1. Click Structure and then, in the Parts group, click Edit.

2. Click Part.
3. In the parts hierarchy, select the appropriate part you want to make active.

The selection of the active part controls what is actually deleted.

4. Click Delete.
5. Click the part or parts you wish to delete.

Modifying Parts
Creo Elements/Direct Drafting allows you to modify your parts using the buttons
on the Modify tab.
Consider the CYLINDER ASSEMBLY hierarchy again. Suppose you wish to
move the entire piston assembly, that is the piston, rings, wrist pin, and so on. The
simplest way to identify all these is to first set a part above PISTON ASSEMBLY
active, in this case CYLINDER ASSEMBLY:

1. Click Structure and then, in the Parts group, click Edit.

2. Click Part.
3. Select the CYLINDER ASSEMBLY.

With CYLINDER ASSEMBLYactive, you only have to identify an element in
PISTON ASSEMBLY. Creo Elements/Direct Drafting accepts the assembly
and all its subparts.

4. Complete the required move operation using the buttons on the Modify tab.
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Note

To modify parts or elements above the active part you must click Select ▶

Global.

Editing Parts
This section describes how to set a part as active so that you can then change it.
All new drawing elements created from then on belong to the active part.
Similarly, whichever part is active affects the results of the Modify operations and

Delete. If you have used Spotlight (refer to Spotlighting Parts on page
464), the active part is shown in normal linetypes and colors, while all other parts
are shown in magenta dotted lines. The name of the active part is displayed in the
status bar.

Editing a Part
To edit a part (make a part active):

1. Click Structure and then, in the Parts group, click Edit.

2. Click Part.

Creo Elements/Direct Drafting prompts for the name of a part.
3. Type the name of a part in the user input line and press ENTER.

Alternatively, select an element of the part in any viewport.

Creo Elements/Direct Drafting sets the named, or selected, part as the active
part.

Editing Top
To edit the top part (set the highest part of the parts structure as the active part):

1. Click Structure and then, in the Parts group, click Edit.

2. Click Top.

Creo Elements/Direct Drafting sets the Top part as the active part.
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Editing the Parent
You can move the active part status to the parent of the currently active part. In
relation to a given part, the parent is always one level higher in the parts structure.
To edit the parent part:

1. Click Structure and then, in the Parts group, click Edit.

2. Click Parent.
Creo Elements/Direct Drafting sets the parent of the currently active part as the
active part.

Initiating a New Empty Part
This section describes how to create a new empty part. The active-part status will
be altered after the command has been executed so that the new part is active.

Initiating a Part
Create a new empty part under the Top part and make this new part the active part
so you are ready to draw in it.

Note

It is not necessary to make the Top part active before you use the Part.
Every new part you create is automatically positioned immediately below the
Top part.

To create a new empty part immediately below Top:

1. Click Structure and then, in the Parts group, click the arrow next to New.

2. Click Part

3. Type a name for the new part in the user input line and press ENTER.
Alternatively, allow Creo Elements/Direct Drafting to assign a default name.

If you want Creo Elements/Direct Drafting to assign a default name to the new

part, click OK. Creo Elements/Direct Drafting generates a default name
based on incremental numbers (.1, .2, .3 and so forth).
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Creo Elements/Direct Drafting creates the new empty part below the Top part
and sets it as the active part. You can now begin adding drawing lines, text,
and so on to the part.

Note
Place at least one element (or subpart) in the new part otherwise it is deleted
when you change the active part status.

Initiating a Subpart
You can create a new empty part under the active part and set the new part as the
active part so you are ready to draw in it. This means that a subpart can be created
below an existing part, or below an existing subpart.

Before clicking Subpart, ensure you have the correct part active as the new
part will belong to it and be one level below.
To create a new empty subpart:

1. Click Structure and then, in the Parts group, click the arrow next to New.

2. Click Subpart.
3. Type a name for the new subpart in the user input line and press ENTER.

Creo Elements/Direct Drafting creates the new empty part and sets it as the
active part. You can now begin adding drawing lines, text, and so on, to the
part.

Place at least one element in the new part, otherwise it is deleted when you
change the active part status.

Creating Parts
This section describes how to make a new part from existing elements in the
active part. The active part status is unaffected after the command has been
executed.

Creating a Subpart
You can create a new part by transferring elements from the active part into the
newly created one. The new part is placed below the active part.
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Before selecting Subpart, ensure you have the correct part active as the new
part will belong to it and be one level below.
To create a subpart:

1. Click Structure and then, in the Parts group, click the arrow next to New.

2. Click Subpart.
3. Type a name for the new part in the user input line and press ENTER.
4. Select the elements in the active part you wish to transfer to the new part.

Note

If you incorrectly select an element for transfer, click Undo to cancel
the transfer.

5. When you have selected all of the elements you want to include in the subpart,

click OK (or any other button except Cancel) to complete the
command.

Creo Elements/Direct Drafting transfers all the selected elements to the new
part.

Creating Detail Drawings
You can create detail drawings in your drawing. Each detail is a magnified copy of
an area of the active part.

Note
Dimensions are not affected by the magnifying factor; thus the dimensions on
your detail will agree with the part from which it was taken.

Figure 176 on page 444 shows how to create a detail drawing within your main
drawing:
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Figure 176. Creating a Detail Part

Finish drawing the part to be detailed and make it the active part.
This technique of finishing the part before creating a detail differs from traditional
drafting methods. However, using the buttons on the View tab, you can just as
easily draw intricate features on the main drawing as on the detail drawing.
Creo Elements/Direct Drafting allows you to create a magnified copy for

dimensioning purposes using Detail.
To produce a detail drawing:

1. Click Structure and then in the Parts group, click the arrow next to New.

2. Click Detail.
3. Type the required magnifying factor for the detail in the user input line and

press ENTER.
4. Enclose the area of the active part from which you wish to form the detail in a

box.
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Note
The edges of the box determine where elements are cut, so specify the
corners carefully (in the detail drawing, the dashed lines indicate where the
box was placed).

5. Specify a reference point for the movement of detail part and then specify the
desired end point.

Creo Elements/Direct Drafting creates the detail part.

Note
• The detail part is automatically placed in level 1 of the parts structure (that is,

below the Top part).
• The detail part is assigned the next default name generated by Creo Elements/

Direct Drafting in the sequence .1, .2, .3, and so on. (Note that a postfix
[shared #1] [detail] is displayed in the parts tree; this is for information only
and is not part of the name).

• The detail part will be a unique shared part (refer to Sharing Parts on page
456). However, it is not shared with the part from which it was detailed. Thus,
if you modify the original part, its detail will not be changed automatically.

• To dimension a detail part, you must make it the active part.

Gathering Elements in Other Parts
During the drawing process, it may prove useful to transfer the ownership of
existing elements in a part to the active part.
To transfer elements:

1. Click Structure and then, in the Parts group, click Gather.

2. Click Element.
3. Click one of the following:

• Click Delete Old Keep Scale if you want to move the element to the
active part. It is drawn to the scale in the active part.
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• Click Copy Keep Scale if you want to copy the element to the active
part. It is drawn to the scale in the active part.

Note
• If the element to be transferred is the master element of a group, the group is

ungrouped before gathering.
• If the element to be transferred is a normal element of a group, the element is

removed from the group before gathering.

Delete Old
The old element is deleted and the transferred elements only exist in the active
part.

Note
• Identify the correct elements as mistakes can only be rectified by changing the

active part and gathering the element back.

• Click Spotlight in the status bar to see the changes made in your drawing.

To transfer elements from one part to the active part:

1. Click Structure and then, in the Parts group, click Gather.

2. Click Element.

3. Click Delete Old.
4. Select the elements (in non-active parts) that you wish to transfer to the active

part.

As you select each element, it gets deleted from its original part and appears in
the active part.

Copy
The elements indicated are duplicated in the active part.
To copy elements from any part to the active part:
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1. In the status bar, click Spotlight.

2. Click Structure and then, in the Parts group, click Gather.

3. Click Element.

4. Click Copy.
5. Select an element (in any non-active part) that you wish to copy to the active

part.
6. Specify a reference point for the copy operation.
7. Specify the desired location for the reference point.

Example
Refer to Figure 177 on page 447. You have incorrectly added drawing elements to

PISTON RING # 1. Use Element buttons in Gather in the Parts group on
the Structure tab to transfer these elements to RETAINING CLIP # 1.

Figure 177. Including Elements

To transfer elements from PISTON RING # 1 to RETAINING CLIP # 1:

1. Click Structure and then, in the Parts group, click Edit.

2. Click Part.
3. Click RETAINING CLIP # 1.
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Creo Elements/Direct Drafting makes RETAINING CLIP # 1 the active part.

4. Click Structure and then, in the Parts group, click Gather.

5. Click Element.

6. Click Delete Old.
7. Select elements in PISTON RING # 1 you wish to transfer to the active part.

As you select each element, it is deleted from its original part and appears in
the active part.

Including Dimensions in Other Parts
Creo Elements/Direct Drafting allows you to transfer the ownership of existing

dimensions using Dimension buttons of Gather in the Parts group on the
Structure tab.

Move
To move the dimension to the active part when the reference geometry of the
selected dimension is in the active part or below the active part:

1. Click Structure and then, in the Parts group, click Gather.

2. Click Dimension.

3. Click Move.
4. Select the dimension you want to move to the active part.

Move All Below
To move all dimensions in parts hierarchically below the active part to the active
part:

1. Click Structure and then, in the Parts group, click Gather.

2. Click Dimension.

3. Click Move All Below.
4. Select the dimension you want to move to the active part.
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Move All Above
To move all dimensions in parts hierarchically above the active part with reference
geometry in the active part or below the active part to the active part:

1. Click Structure and then, in the Parts group, click Gather.

2. Click Dimension.

3. Click Move All Above.
4. Select the dimension you want to move to the active part.

Including Parts in Other Parts
This section describes how to transfer the ownership of existing parts to the active
part. The gathered part belongs to the active part and it is placed one level below
the active part in the parts structure.

Note
• If the part to be transferred is the master element of a group, the group is

ungrouped before gathering.
• If the part to be transferred is a normal element of a group, the part is removed

from the group before gathering.

Move
To transfer the ownership of a part to the active part:

1. Click Structure and then, in the Parts group, click Gather.

2. Click Part.

3. Click Move.
4. Select the part to be gathered or type the name of the part in the user input line

and press ENTER. You cannot gather a part from above the level of the active
part.

Creo Elements/Direct Drafting transfers the part to the ownership of the active
part and deletes the original.
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Copy
To copy a part to the active part:

1. Click Structure and then, in the Parts group, click Gather.

2. Click Part.

3. Click Copy.
4. Select the part to be included or type the name of the part in the user input line

and press ENTER.
5. Specify a reference point for the copy operation.
6. Specify the location for the reference point.

Creo Elements/Direct Drafting copies the part such that the new part is owned
by the active part.

Example
Refer to Figure 178 on page 451. You have incorrectly created the part

RETAINING CLIP # 1 as a subpart of PISTON ASSEMBLY. Use the Part

buttons of Gather in the Parts group on the Structure tab to transfer
RETAINING CLIP # 1 to its correct position as a subpart of WRISTASSEMBLY.

450 Creo Elements/Direct Drafting User's Guide: Fluent User Interface



Figure 178. Including a Part

To transfer RETAINING CLIP # 1 to its correct position as a subpart of WRIST
ASSEMBLY:

1. Click Structure and then, in the Parts group, click Edit.

2. Click Part.
3. Click WRISTASSEMBLY.

Creo Elements/Direct Drafting makes WRISTASSEMBLY the active part.

4. Click Structure and then, in the Parts group, click Gather.

5. Click Part and then click Move.
6. Click RETAINING CLIP # 1.

Creo Elements/Direct Drafting transfers the part so that it becomes a subpart
of WRISTASSEMBLY.
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Showing Parts
This section describes how to examine a selected groups of parts. Those you do
not want to see are replaced by representative boxes. This can be useful where
parts overlap.

Part
You can either restore a part presently represented by a box, or look at certain
levels in the parts structure.
If you want to restore a boxed part:

1. Click Structure and then, in the Parts group, click Show.

2. Click Part.
3. Click the part.

Creo Elements/Direct Drafting redraws it normally.
However, if you wish to look down to a certain part level and no further:

1. Click Structure and then, in the Parts group, click Show.

2. Click Part.
3. Type the level number in the user input line and press ENTER.

Creo Elements/Direct Drafting redraws the chosen viewport with all parts in
the entered level and below, shown as boxes.

4. For example, if you type 3, the chosen viewport is redrawn to show all parts in
levels 1 and 2 with those in lower levels indicated by boxes. If a boxed part
belongs directly to the active part, this is indicated by a yellow box.

Boxed
You can change a part and all its subparts to a box representation in the chosen
viewport. The box encloses all elements of the part.

1. Click Structure and then, in the Parts group, click Show.

2. Click Boxed.
3. Select the part to be boxed or type its name in the user input line and press

ENTER.
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Creo Elements/Direct Drafting redraws the chosen viewport with the desired
part shown as a box.

All
You can restore all parts in the chosen viewport to their normal appearance:

1. Click Structure and then, in the Parts group, click Show.

2. Click All.

Creo Elements/Direct Drafting redraws the chosen viewport with all parts
visible.

Hiding Parts
You can hide specific parts or all parts in your drawing.

Part
To hide a specific part in your drawing:

1. Click Structure and then, in the Parts group, click Hide.

2. Click Part.
3. Click the part.

All
To hide all parts in your drawing:

1. Click Structure and then, in the Parts group, click Hide.

2. Click All.
You can use the Show buttons to unhide any or all parts.

Smashing Subparts
When you smash a subpart, the elements that comprise the identified part will be
merged into the active part and the subpart will no longer exist.
To merge a subpart into the active part:

1. Ensure that the correct part is active.
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2. Click Structure and then, in the Parts group, click Smash.
3. Click any of the following:

• Subpart

The subpart is merged with the active part.

• Subpart Keep Scale

The subpart is merged with the active part, and it is drawn to the scale of
the top part (scaling is maintained – drawing A).

• Subpart Keep Display

The subpart is merged with the active part, and it is brought into the top
part as it is displayed on the screen (scaling may be lost) – drawing B.

4. Select the part to be smashed or specify the part name. The part to be smashed
must belong to the active part.

Creo Elements/Direct Drafting transfers the elements of the identified part to
the active part and deletes the subpart.

Example
Refer to Figure 179 on page 455. You want to make a single part drawing (WRIST
UNIT) from the assembly drawing WRISTASSEMBLY.
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Figure 179. Smashing Parts

To create WRIST UNIT from WRISTASSEMBLY:

1. Click Structure and then, in the Parts group, click Edit.

2. Click Part.
3. Click WRISTASSEMBLY.

Creo Elements/Direct Drafting makes WRISTASSEMBLY the active part.

4. Click Structure and then, in the Parts group, click Smash.
5. Click RETAINING CLIP # 1, RETAINING CLIP # 2 and WRIST PIN.

Creo Elements/Direct Drafting transfers all drawing elements to the active part
and then deletes the subparts.

6. In the Part Browser, right-click the active part and click Rename.
7. Rename the part to WRIST UNIT.
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Figure 180. Effects of Smashing Scaled Parts

Note
• If the part to be selected is the master element of a group, the group is

ungrouped before smashing.
• If the part to be selected is a normal element of a group, the part is removed

from the group before smashing.

Sharing Parts
This section shows how to make a shared part. Shared parts are useful if you
require a particular part to appear several times in a drawing.
Examples of parts suitable for sharing are nuts, bolts, rivets, and other standard
parts.
The geometry of a shared part always remains the same as the original part.
However, the location of each shared part can be different and the overall size of

each shared part can be altered by using the Scale buttons.

You can also determine the plane in which the shared part lies by using
Isometric in the General group on the Modify tab. If you place a shared part in a
different plane, make it active and then enable the Ruler or Grid, so that they will
also be displayed in the same plane.
The advantages of shared parts:

• Although you have several copies of the shared part displayed on your
drawing, in memory you have only one. This saves you memory and allows
you to carry out certain commands faster.

456 Creo Elements/Direct Drafting User's Guide: Fluent User Interface



• If you change any geometry of a shared part, the changes will automatically
appear in all other occurrences of that shared part in their respective planes.
For example, if you add a horizontal line to a shared part, it will be displayed
on the respective horizontal axis of each occurrence of that shared part.

To share a part:

1. Click Structure and then, in the Parts group, click Share.
2. Select the part to be shared.
The part must be non-active and may not be at a level above the active part or at
the same level. In the Share column of the Part Browser, a shared part is identified
by one or multiple hash characters followed by the appropriate number (such as:
#3).

Copying Shared Parts
To create copies of a shared part:

1. Click Modify and then, in the General group, click the arrow next to Move.

2. Click Multiple.
3. Select the shared part to be copied.
4. Specify a reference point for the move.
5. Specify the destination point for the move.
The following naming conventions apply to copies of shared parts:

• When you copy a shared part as described above, note that each copy will
reflect the name of the original shared part. Each of these copies automatically
receives a unique identifier. For example, when you copy a shared part named
rim3, its copies will also be named rim3; however, each of these copies will
have its own unique identifier. (~2, ~3, etc).

The following example shows the parts structure of an assembly containing a
shared part named RIM and a copy of this shared part.

Uniq Share Scale Symbol

WHEEL ASSEMBLY ~1 1:1

RIM ~2 #3 1:1

RIM ~3 #3 1:1
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• When you copy a shared part which owns another shared part (i.e. a shared
subpart of a shared part), the copies of these shared subparts retain the same
common name and identifier. However, each of the "owning" shared parts has
its own unique identifier.

The following example shows the parts structure of an assembly containing a
shared part named RIM which in turn owns a shared part named LINER.

Unique Share Scale Symbol

WHEEL ASSEMBLY ~1 1:1

RIM ~2 #3 1:1

LINER ~3 ##4 1:1

When you copy the RIM, the resulting parts structure will look like this:
Unique Share Scale Symbol

WHEEL ASSEMBLY ~1 1:1

RIM ~4 #3 1:1

LINER ~3 ##4 1:1

RIM ~2 #3 1:1

LINER ~3 ##4 1:1

Refer to Unique Partnames on page 468 for further information.

Note
• Any changes made to a shared part automatically appear in all other

occurrences of that shared part.
• You cannot share a part above the active part or at the same level. Therefore

you cannot share the Top Part.
• All subparts of a shared part have their status set to shared.
• When you rename a shared part, all occurrences of that shared part are given

the new name.
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Unsharing Parts
This section describes how to change a shared part back into a normal part.
This can be useful if you want to alter one occurrence of your shared part in
isolation, as otherwise all occurrences are altered simultaneously.

Note
You cannot unshare a part above the active part or at the same level.

To unshare a part:

1. Click Structure and then, in the Parts group, click Unshare.
2. Select the part to be unshared.

Creo Elements/Direct Drafting alters the parts structure so that the identified
part is a normal part positioned alongside the shared parts and with the same
parent. All other occurrences of the shared part stay shared.

The active status does not affect Unshare except that the part you wish to
unshare cannot be active.

Part Browser
To display the Part Browser:

• Click Structure and then, in the Parts group, click Part Browser.

Alternatively, press F12 to display the Part Browser.
To perform an action on a given part:

• Right-click the part in the Part Browser and click the required button.

Note
The Part Browser can be docked anywhere in the Creo Elements/Direct
Drafting window.
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What is Shown in the Part Browser?
The Part Browser provides a graphical overview of the current parts structure in
your Creo Elements/Direct Drafting drawing.

• Starting at the top part, this tree-like structure includes a separate branch for
each part. Subparts of a part are shown as sub-branches of that part.

• Click the + (plus) sign icon to expand the tree.
• Click the - (minus) sign icon to collapse the tree.
• Click the check box to the left of any part icon to view the associated part (and

any parts hierarchically below this part).
• Clear the check box to the left of any part icon to hide the associated part (and

any parts hierarchically below this part).
The individual columns of the Part Browser provide the following information:

Column Description
Name Specifies the name of the part. The following icons are used to

indicate the nature of the part:
The currently active part. Note that the
currently active part is represented by a red
icon.
Normal part or assembly. Any non-active
parts and/or parts hierarchically below the
active part are indicated by a green icon.
Shared part.
Detail.
The associated part is hidden. This is because
you have applied the View command to
another part.

Unique Specifies a unique sequential number associated with the part.
Share A "hash" (#) character in this colums indicates that the part is

shared.
Scale Indicates the drawing scale of the part.
Symbol A small "x" indicates that the part is symbolic.

The Part Browser Tree Context Menu
To display the Part Browser context menu, right-click any part icon in the Part
Browser. The context menu provides the following buttons (some of which are
also available in the Parts group on the Structure tab):
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View Shows only the selected part. Creo Elements/Direct Drafting
fits this part into the current viewport. All other parts are
hidden, and their icons are marked by a yellow X (see list of
Part Browser icons above).

Rename Enables you to change the name of the selected part.
Smash Smashes a subpart. See Smashing Subparts on page 453 for

further information.
Share Creates a shared part. See Sharing Parts on page 456 for

further information.
Symbol Changes the part to a symbol. See Changing Parts to Symbols

on page 464 for further information.
Show In addition to the options explained in Showing Parts on page

452, this command provides the ShowFlat option which
shows the selected part but not its subparts (if any).

Hide In addition to the options explained in Hiding Parts on page
453, this command provides the HideFlat option which hides
the selected part but not its subparts (if any).

Options The Icons option enables you to display the Part Browser
with or without icons. The State Icons option enables you to
show or hide the (checkbox-like) state icons that indicate
whether or not a part is visible.

Save You can click Save to save an ASCII representation of the
current parts tree structure in a Creo Elements/Direct Drafting
list file.

Delete Deletes the selected part.

Changing the Ownership of Parts
The Part Browser provides drag-and-drop functionality to facilitate changes in part
ownership. For example, if you want a subpart to be owned by another part,
simply drag the subpart away from its present owner part and drag it to the new
owner part.

Renaming a Part in the Part Browser
To rename a part:

1. In the Part Browser, right-click the part you want to rename and click
Rename.

2. Replace the current part name by the new name.
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Note
When you rename a shared part, all occurrences of that shared part are given
the new name.

Viewing Parts
This section describes how to view individual parts of your drawing. You can only
view drawings in the current viewport.

Use the View buttons in the Parts group on the Structure tab in the following
cases:

• During the design stage if parts overlap one another in a confusing way.
• To quickly inspect a finished part and check that it is complete.
• To reduce redraw time by viewing only the part or parts you are currently

working on.

Top
You can view your complete drawing in the current viewport.
This is useful if you have been viewing a lower level and want to quickly restore
the complete drawing to the viewport
To view the complete drawing in the current viewport:

1. Click Structure and then, in the Parts group, click View.

2. Click Top.

The chosen viewport is redrawn to show all the parts of your drawing. The
name of the top part is displayed in the top-left corner of the viewport.

Part
To look at an individual part:

1. Click Structure and then, in the Parts group, click View.

2. Click Part.

462 Creo Elements/Direct Drafting User's Guide: Fluent User Interface



3. Type the name of the part to be viewed, or click an element of the part in any
viewport.

Creo Elements/Direct Drafting redraws the chosen viewport containing only
the desired part and any subparts belonging to it. The name of the part being
viewed is displayed in the top left corner of the viewport.

Parent
You can view the parent of the presently viewed part. Parent allows you to
view the next level up in the parts hierarchy:

1. Click Structure and then, in the Parts group, click View.

2. Click Parent.

The current viewport is redrawn displaying the parent of the active part and all
parts belonging to the active part.

Creating a Parts List
Creo Elements/Direct Drafting allows you to create a list of parts in your drawing.
The parts list indicates the relationship between the active part and all other parts.
You can view the list of parts that are under an active part (parent part). You can
also create a list of all parts in your drawing. Creo Elements/Direct Drafting can
display the parts list in a standard text editor or print the list on a local printer.

Counting Parts
You can create a list of all the parts owned by the active part (parent part) and the
parts under the active part.
To list the parts:

1. In the Part Browser, select the part.
2. Click Structure and then, in the Parts group, click More.
3. Under Part List, click Count.

Creo Elements/Direct Drafting displays the list of parts in a standard text
editor.
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Creating a Parts Tree
You can create a list of all parts in your drawing. The active part is indicated by a
* next to it in the list. Part names in the list are indented to indicate the
hierarchical relationship between each part. The relationship is indicated by
indentation of the part name.
To create a full parts list:

1. Click Structure and then, in the Parts group, click More.
2. Under Part List, click Tree.

Creo Elements/Direct Drafting displays the list of parts in a standard text
editor.

Spotlighting Parts
Spotlighting allows you to distinguish between the active part and all other parts.
The button works as an on or off switch. We recommend you enable Spotlight (by
clicking it) when you are creating and modifying parts.

1. To enable Spotlight, click Spotlight in the status bar.

Only the active part has its normal appearance. All non-active parts are shown
in magenta dotted lines.

2. To disable Spotlight, click Spotlight in the status bar again.

All parts appear in their normal linetype and color. This makes it difficult to
distinguish between the active part and all other parts.

Changing Parts to Symbols
This section describes how to change existing parts into symbols.
The only difference between a symbol and a normal part is that a symbol's size
relative to the plotter paper does not change if you alter the drawing scale (refer to
Setting the Drawing Scale on page 67).
An example of a symbol part could be a border to fit a particular paper size or any
standard symbol. Once you've made a symbol part, it is best to store it so that it is
ready to be loaded whenever you require it.
To make a symbol part:

1. Create the required shape as a part with the drawing scale set to 1.
2. When the part is finished, click Structure and then, in the Parts group, click

the Symbols check box.
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3. Select the part or type the name of the part in the user input line and press
ENTER.

Creo Elements/Direct Drafting now defines the part as a symbol part. Check
this by viewing the Symbol column of the Part Browser. Note a small "x" in
the Symbol column.

You can also change a symbol part back into a normal part
To change a symbol to normal part:

1. Click Structure and then, in the Parts group, clear the Symbols check box.
2. Select the symbol part or type the name of the part in the user input line and

press ENTER.

Creo Elements/Direct Drafting changes the symbol part back to a normal part.

Setting the Part Reference Point
This section shows how to set a reference point in the active part.
The reference point is used:

• To locate other parts when loading from files.
• For symbols.

• For some Gather buttons.
The Creo Elements/Direct Drafting default reference point is the lower left corner
of an imaginary box placed around the elements of the part.
To set a reference point:

1. Click Structure and then, in the Parts group, click Set Ref Point.

The present reference point for the active part is shown by a line joined to the
cursor.

2. Specify the new reference point.

Multiple Drawing Scales
Creo Elements/Direct Drafting supports multiple drawing scales on one drawing.
This lets you place small and large parts on the same drawing for manufacturing
and documentation purposes.
The scale associated with a part can be seen in the parts tree.
To change the drawing scale:

1. Create a top part and a subpart.
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The parts tree in the Part Browser should look similar to the following:
Top ~1 1:1

SUBPART ~2 1:1

2. Click Structure and then, in the Parts group, click Scale.

3. Click Part & Subpart.
4. Select the top part (both parts are highlighted).
5. Type 2 in the user input line and press ENTER.

Creo Elements/Direct Drafting scales both the top part and subpart by the
scaling factor 2.

Now look at the parts tree again to see how the scaling factors change:
Top ~1 2:1

SUBPART ~2 2:1

1. Click Structure and then, in the Parts group, click Scale.

2. Click Part Only.
3. Select the subpart (it does not need to be active).
4. Type 3 in the user input line and press ENTER.

Creo Elements/Direct Drafting scales the subpart only.
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Now look at the parts tree again to see how the scaling factors change:
Top ~1 2:1

SUBPART ~2 3:1

Note that the subpart is scaled according to its original value. In others words, it is
scaled by a factor 3 — and not 2 and then 3.
Text, dimensioning text, and symbols are not changed.

Scaling Parts about a Reference Point
To scale parts and subparts about reference point, origin, or center:

1. Click Structure and then, in the Parts group, click Scale.
2. Click one of the following:

• By Reference Point to scale parts and subparts about the reference
point.

• By Origin to scale parts and subparts about the origin.

• By Center to scale parts and subparts about the center.

Renaming Parts
To change the name of the active part:

1. Click Structure and then, in the Parts group, click More.
2. Under Modify, click Rename.
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Creo Elements/Direct Drafting displays the name of the active part and
prompts you for a new name.

3. Type a new name enclosed by quotes (single or double) in the user input line
and press ENTER.

Creo Elements/Direct Drafting renames the active part to the new name.

You can use the Part Browser to check the new name of the active part.

Unique Partnames
Creo Elements/Direct Drafting automatically generates names for parts when you
create them. These names are shown in the parts tree and are represented by
numbers: ~1,~2, and so on.
This feature is useful when handling parts by macros. For example, a typical parts
tree may look like this:

Unique parts naming has the following functionality:

• Each part is specified by a number.
• Shared parts within shared parts are identified with the same unique partname

because they exist once only in the data structure.

Shared parts within shared parts are marked with [shared in shared #n]
• Parts can be made active by entering EDIT_PART followed by the name of

the part. Two examples are provided below.
EDIT_PART 'bracket'
EDIT_PART '~2'

If you enter EDIT_PART and the parts structure has more than one part with
the same partname, Creo Elements/Direct Drafting prompts you to specify the
part number.

With INQ 900 and INQ 901, you get a string list of unique partnames (~2, ~3).
• INQ_ENV 8 INQ 5 for inquiry of the offset. For loading several drawings, the

maximum used unique partname can be inquired (useful when running
macros).

468 Creo Elements/Direct Drafting User's Guide: Fluent User Interface



• You can click Delete, All and Confirm to reset the parts
numbering.

• Refreshing partnames can be done by typing the following command in the
user input line:
RESET_PART_NUMBER

Further Information
For further technical information about parts, the parts structure and so on, refer to
the Creo Elements/Direct Drafting help system.
Type the following in the Creo Elements/Direct Drafting user input line and press
ENTER:

• help parts

• help edit_part

• help init_part

• help init_subpart

• help create_subpart

• help create_detail

• help gather_dim

• help gather

• help smash_subpart

• help share_part

• help unshare_part

• help symbol_part

• help view

• help show_part

• help hide_part

• help change_part_ref_pt

• help scale

• help part_drw_scale

• help wui_part_browser

Creo Elements/Direct Drafting displays further information about parts.
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Introduction to Hidden Lines
The 2D hidden line module is used during the creation of an assembly drawing to
automatically generate lines that indicate hidden drawing features. In an assembly
drawing, these lines are normally shown dashed.
To activate the Hidden module:

1. Click File ▶ Modules ▶ Hidden.

The Hidden tab appears.
To create an assembly drawing that includes hidden lines, you must:

• Load parts.
• Generate faces (without faces you cannot generate hidden lines).
• Assign each face a logical level in the z direction (a z-value).
• Use the z-value information to generate the appropriate hidden lines.
During the drawing process you can selectively view faces for clarity (ensure that
each face is correctly positioned in relation to the others).
Use one of the following methods to redraw your assembly drawing with hidden
lines:

• Click Hidden and then, in the Modify group, click the Hidden Mode check box.

This mode effectively redraws your assembly drawing, hiding any hidden lines
and faces.

• Click Hidden and then, in the Modify group, clear the Hidden Mode check box.

This is the normal Creo Elements/Direct Drafting redraw mode.
On completion of your assembly drawing you can generate hidden lines in the
dashed linetype (default).

Caution
It is recommended to store your assembly drawing (in workfile.hid)
before generating hidden lines:

1. Click Hidden and then, in the Modify group, click the arrow next to
Generate.

2. Click with Backup.

The Generate buttons smash the part structure and create the hidden line
geometry.
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Two tutorial examples have been included:

• A simple example using a Frame Assembly will clarify the general procedure.
• A realistic example creates a component assembly drawing (CRANK_

ASSEMBLY).

What are Faces?
Faces can be thought of as freely definable, infinitely thin, shaped areas that form
part of an assembly. Faces can partially obscure or completely cover other faces
(depending upon their z-values).
To delete any covering face:

1. Click Hidden and then, in the Modify group, click Delete Face.
2. Select the face.

Note
The face to be deleted must be in the active part.

In simple terms, you could imagine faces as pieces of paper, laid one on top of
another, thus obscuring elements with a lower z-value.
Figure 181. Faces — With Z-Values 0 and 1 on page 472 shows the faces of two
components (one with z-value 0 and the other with z-value 1).

Figure 181. Faces —With Z-Values 0 and 1
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Note
A face does not necessarily need to have the same z-value as its boundary
lines. In this case, the boundary lines of the face may be partially covered by
the face itself (solid lines may appear dashed in some cases). The linetype of
the boundary lines is not changed.

Faces are defined in one of the following ways:

• Automatic face search for an entire part (Creo Elements/Direct Drafting tries
to find a maximum number of faces contained within a part. All faces are
assigned the same z-value).

• Automatic face search for an entire part (with hole recognition).
• Automatic face search by clicking (similar to automatic hatching).
• Manual face specification (similar to manual hatching).

What are Z-Values?
A z-value is the numerical value assigned to an element to position it in the
drawing at the appropriate logical level in the z-direction.
Newly created elements are assigned the current z-value. The current z-value is
always displayed in the prompt line.
See Figure 182. Visualizing Z-Values on page 473.

Figure 182. Visualizing Z-Values
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For example, three faces could be given the z-values 0, 1, 2. The face with z-value
1 would be positioned above that with z-value 0. The face with z-value 2 would be
positioned above those with z-values 1 and 0. Depending on where these faces
were positioned with respect to each other, certain areas would be obscured.
Figure 183. Z-Values 0, 1 and 2 on page 474 shows 3 faces assigned the z-values
0, 1 and 2.

Figure 183. Z-Values 0, 1 and 2

Hatches are treated as faces. This means hatched areas can cover geometry and
faces. Hatches that are partially covered are displayed partially obscured.
Construction geometry, texts, leader lines and dimensions are always visible.
Parts cannot be given a z-value, with the exception of shared parts (see Z-Values
and Shared Parts on page 475).
You can specify z-values in three ways:

• Automatically – if you have clicked File ▶Modules ▶ Hidden and thus loaded
the hidden line module. Future elements you create are assigned the current z-
value.

• By defining "element-to-element" relations ( Above, Below,

Same, Between, None).
• By entering a z-value (real number) for the specified elements.
Elements and geometry without a z-value are automatically positioned below the
element(s) with the lowest z-value. Construction geometry, text, dimensions and
leader lines are always at the top.
Figure 184. Z-Value Structure within a Drawing on page 475 shows how the z-
value structure relates to your drawing:
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Figure 184. Z-Value Structure within a Drawing

Z-Values and Shared Parts
You can assign z-values to shared parts to enable them to be placed on different
logical levels.
The z-values of elements within a shared part are calculated as the sum of their
own z-value and the z-values of all their shared parent parts.

Hidden Line Modes
The two hidden line modes are:

• View Mode – produces a hidden line display, does not compute hidden lines,
does not change geometry.

• Hidden Line Generation Mode – used to finish the assembly drawing before
plotting, changes geometry.

View Mode
This mode produces a hidden line display of the assembly on the screen without
computing the hidden lines. It does not change the geometry or the parts structure.
Therefore you can assign z-values to elements during construction. Changes in z-
value are possible at any time and are displayed immediately.

Generation Mode
Hidden Line Generation Mode is used to finish an assembly drawing before
plotting.
In contrast to the view mode, geometry is modified:
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• Elements are split.
• Shared parts will be unshared.
• The parts structure is completely smashed.
You can enable or disable the hidden lines by clicking or clearing the Hidden Mode
check box in the Modify group on the Hidden tab, respectively.

Hidden Line – Tutorial Example 1
This tutorial shows how to make a simple assembly drawing (Frame_Assy) and
use it to create:

• An assembly view with the hidden lines to be generated as yet invisible (View
Mode).

• An assembly view showing dashed hidden lines (Generation Mode).

Creating Frame Assembly
First create the assembly drawing Frame Assembly by creating two parts, Frame 1
and Frame 2.

Initial Steps

1. Click Drafting and then in the Utilities group, click Delete.

2. In the Utilities group, click Select.

3. Click All.

4. Click Confirm.

5. Click Structure and then, in the Parts group, click Browser.

The Part Browser opens.

6. In the Part Browser, right-click Top and click Rename.

7. Rename Top to Frame Assembly.

Drawing Frame 1

1. Click Structure and then, in the Parts group, click the arrow next to New.

2. Click Part.
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3. Type the part name Frame 1 in the user input line and press ENTER.
4. Click Hidden and then, in the Create Element group, click the arrow next to

Inquire Z Value.

5. Click Current Z Value.
6. Type 1 in the user input line and press ENTER.

7. Click Drafting and then, in the Draw group, click Rectangle.
8. Draw two rectangles as shown in Figure 185. Frame 1 on page 477.

Figure 185. Frame 1

Generating Face 1

1. Click Hidden and then, in the Create Face group, click Single Automatic.
2. Click inside Face 1 (see Figure 185. Frame 1 on page 477).

Creo Elements/Direct Drafting creates Face 1.

3. Click OK.

Drawing Frame 2

1. Click Structure and then, in the Parts group, click the arrow next to New.

2. Click Part.
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3. Type Frame 2 as the part name in the user input line and press ENTER.
4. Click Hidden and then, in the Create Element group, click the arrow next to

Inquire Z Value.

5. Click Current Z Value.
6. Type 2 in the user input line and press ENTER.

7. Click Drafting and then, in the Draw group, click Rectangle.
8. Draw two more rectangles as shown in Figure 186. Frame 1 and Frame 2 on

page 478.

Figure 186. Frame 1 and Frame 2

Generating Face 2

1. Click Hidden and then, in the Create Face group, click Single Automatic.
2. Click inside Face 2.

3. Click OK.

Positioning Frame 2 Above Frame 1
1. Click Modify and then, in the General group, ensure that the Keep check box is

clear.
2. Select Frame 2 by enclosing it in a box.

3. In the General group, click the arrow next to Move.

4. Click 2 Points.
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5. Specify a reference point for the move.
6. Reposition Frame 2 above Frame 1 as shown in Figure 187. Frame 2 Above

Frame 1 on page 479.

Figure 187. Frame 2 Above Frame 1

Assembly – Hidden Lines Invisible
You can display your assembly drawing so that the lines that will be generated as
hidden are removed from the view. This is useful as a check to see exactly which
lines in your assembly will be generated as hidden lines.

1. Click Hidden and then, in the Modify group, click the Hidden Mode check box.
2. Click the current viewport.

To confirm hidden mode, Creo Elements/Direct Drafting displays - H - in the
top-left corner of the viewport (after the part name of the viewport top part).

Creo Elements/Direct Drafting redraws the assembly. The hidden lines are
now invisible. See Figure 188. Assembly View with Hidden Lines Invisible on
page 480.
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Figure 188. Assembly View with Hidden Lines Invisible

Assembly – Hidden Lines Shown Dashed
At this point you will generate the actual hidden lines.

Caution
It is recommended to store your assembly drawing (in workfile.hid)
before generating hidden lines:

1. Click Hidden and then, in the Modify group, click the arrow next to
Generate.

2. Click with Backup.

The Generate buttons smash the part structure and create the hidden line
geometry.

To generate hidden lines:

1. Click Structure and then, in the Parts group, click the arrow next to Edit.

2. Click Top.

3. Click Hidden and then, in the Modify group, click the arrow next to
Generate.

4. Click with Backup.

5. Click Confirm.
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Creo Elements/Direct Drafting stores your original drawing (in your current
directory) and generates hidden lines in the version displayed on the screen.

Creo Elements/Direct Drafting redraws the assembly with the hidden lines
shown dashed; see Figure 189. Assembly with Hidden Lines Shown Dashed
on page 481.

Figure 189. Assembly with Hidden Lines Shown Dashed

Setting the Current Offset
The current offset in the z-direction is used to calculate the z-value used in the
above or below or between relationship with another element. The current offset
z-value is added to or subtracted from the z-value of a reference element.
To set the current offset:

1. Click Hidden and then, in the Create Element group, click Set Z Values.

The HL Z Values dialog box opens.
2. In the Current Offset box, type the current offset z-value.
3. Click OK.

Setting Z-Values
This section provides information about assigning and changing element z-values.

Use Element to assign z-values.
Use the normal Creo Elements/Direct Drafting selection techniques to select the
elements to which you want to assign z-values.
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To assign the specified z-value to all elements of a part and its subparts:

1. Select the part.
2. Click Hidden and then, in the Create Element group, click the arrow next to

New.

3. Click Element.

All elements in the part and are assigned the specified z-value. This works
recursively down to all subparts.

4. To select additional options for Element:

a. Click Hidden and then, in the Modify group, click the arrow next to
Options.

b. Click the required Options button:

• Above

• Below

• Same

• Between

• None

To set a z-value:

1. Click Hidden and then, in the Create Element group, click Inquire Z Value.

2. Click Current Z Value.
3. Type a numerical value in the user input line and press ENTER.

The z-value is assigned to each drawing element in your selection.
The Creo Elements/Direct Drafting default is that any existing z-values will be
overwritten. If you don't want to overwrite z-values that have already been
assigned:

1. Click Hidden and then, in the Create Element group, click the arrow next to

New.

2. Click Element.
3. Select the elements to which you wish to assign z-values.
4. Type KEEP in the user input line and press ENTER.
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5. Type a numerical value in the user input line and press ENTER.

You can also click one of the following Options button in the Modify group on
the Hidden tab:

• Above

• Below

• Same

• Between

This results in a computed z-value.

Note

These Options buttons only influence elements that already have a z-
value assigned to them.

If you select a group of elements for a z-value change that have a range of z-
values (lower limit — upper limit) already associated with them, the range
relationship will be maintained.

To understand the effect of using Above, Below, Same, or
Between, refer to the following four examples:

Example 1
Suppose you have a group of elements with computed z-values 1 to 9 and you

then specify that they are placed at the same (click Same under Options)
z-value as a reference element with a computed z-value of 20.
The result of this operation is that the z-values of all nine elements are computed
and set in the range 20 to 28.

Example 2
Suppose you have a group of elements with computed z-values 1 to 9 and you

then specify that they are placed above (click Above under Options,
specify Current Offset as 1) a reference element with a computed z-value of 20.
The result of this operation is that the z-values of all nine elements are computed
and set in the range 21 to 29.
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Example 3
Suppose you have a group of elements with computed z-values 1 to 9 and you

then specify that they are placed below (click Below under Options,
specify Current Offset as 1) a reference element with a computed z-value of 20.
The result of this operation is that the z-values of all nine elements are computed
and set in the range 11 to 19.

Example 4
Suppose you have a group of elements with computed z-values 1 to 9 and you

then specify that they are placed between (click Between under Options,
specify Current Offset as 1) a reference element with a computed z-value of 20
and another reference element with a computed z-value of 40.
The result of this operation is that the z-values of all nine elements are computed
and set in the range 21 to 29.

Assigning a Z-Value to an Element
To assign a z-value to an element:

1. Click Hidden and then, in the Create Element group, click the arrow next to

New.

2. Click Element.
3. Select the element to which you want to assign a z-value.
4. Type the z-value in the user input line and press ENTER.

Assigning a Z-Value to a Shared Part
To assign a z-value to a shared part:

1. Click Hidden and then, in the Create Element group, click the arrow next to

New.

2. Click Shared Part.
3. Select the shared part to which you want to assign a z-value.
4. Type the z-value in the user input line and press ENTER.

Deleting a Z-Value
To delete a z-value of an element or a shared part:
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1. Click Hidden and then, in the Create Element group, click the arrow next to

New.

2. Click Element.
3. Select the element or elements.

4. In the Modify group of the Hidden tab, click the arrow next to Options.

5. Click None.

Positioning an Element at a Z-Value Above Another
Element
To position an element at a z-value above another element:

1. Click Hidden and then, in the Create Element group, click the arrow next to

New.

2. Click Element.
3. Select the elements to be set above the reference element.

4. Click Hidden and then, in the Modify group, click the arrow next to
Options.

5. Click Above.
6. Select the reference element.

Positioning an Element at a Z-Value Below Another
Element
To position an element at a z-value below another element:

1. Click Hidden and then, in the Create Element group, click the arrow next to

New.

2. Click Element.
3. Select the elements to be set below the reference element.

4. Click Hidden and then, in the Modify group, click the arrow next to
Options.

5. Click Below.
6. Select the reference element.

Generating Hidden Lines 485



Assigning an Element's Z-Value to Another Element
To set the same z-value:

1. Click Hidden and then, in the Create Element group, click the arrow next to

New.

2. Click Element.
3. Select the elements to be set to the same level as the reference element.

4. Click Hidden and then, in the Modify group, click the arrow next to
Options.

5. Click Same.
6. Select the reference element.

Positioning an Element at a Z-Value Between Two
Other Elements
To insert an element at a z-value between two other elements:

1. Click Hidden and then, in the Create Element group, click the arrow next to

New.

2. Click Element.
3. Select the elements to be set to a level between two existing elements.

4. Click Hidden and then, in the Modify group, click the arrow next to
Options

5. Click Between.
6. Select the lower reference element.
7. Select the upper reference element.

Generating Faces and Setting Z-Values in
a Complete Part
This section provides information about generating faces and setting z-values in a

complete part using Elements & Faces. Using With Holes, you can detect
the presence of holes to prevent them being generated as faces.
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Generating All Faces and Setting All Z-Values
To automatically generate all faces and set all z-values for all elements in a
complete part:

1. Click Hidden and then, in the Create Part group, click Elements & Faces.
2. Select the part.
3. Type the z-value in the user input line and press ENTER.

or

Click Hidden and then, in the Modify group, click the arrow next to
Options.

Click Above or Same or Below and then click the reference
element.

4. Click OK.

Creo Elements/Direct Drafting generates all faces and assigns z-values to all
elements in your part.

Generating All Faces - Ignoring Holes and Setting
All Z-Values
To automatically generate all faces ignoring any holes and set all z-values for all
elements in a complete part:

1. Click Hidden and then, in the Create Part group, click With Holes.
2. Select the part.
3. Type the z-value in the user input line and press ENTER.

or

Click Hidden and then, in the Modify group, click the arrow next to
Options.

Click Above or Same or Below and then click the reference
element.

4. Click OK.

Creo Elements/Direct Drafting generates all faces ignoring any holes and
assigns z-values to all elements.
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Checking Z-Values
This section provides information about how to check z-values.

An Element's Z-Value
To check the z-value of an individual element:

1. Click Hidden and then, in the Create Element group, click Inquire Z Value.

2. Click Absolute.
3. Select the element.

Creo Elements/Direct Drafting displays the element's z-value in the user input
line (if the specified element has no assigned z-value, an error beep is given).
The value is also written in the System Inquiry Array.

An Element Belonging to a Shared Part
If the element whose z-value you wish to know belongs to a shared part, the z-
value is computed as the z-value of the element itself plus the z-values of all
parent shared parts.

Example
See Figure 190 on page 489.
To check the computed z-value of an individual element with z-value 2 in Shared_
part1:

1. Click Hidden and then, in the Create Element group, click Inquire Z Value.

2. Click Absolute.
3. Select an element with z-value 2.

Creo Elements/Direct Drafting calculates the element's z-value as follows:

Element at z-value 2 + z-value of Shared_part1.

2 + -5 = -3.
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Figure 190. Z-Values for Shared Parts

The Minimum Z-Value in an Assembly Drawing
To check the minimum z-value:

1. Click Hidden and then, in the Create Element group, click Inquire Z Value.

2. Click Minimum.

Creo Elements/Direct Drafting displays the minimum z-value in the assembly
drawing in the user input line (if the drawing has no z-values assigned, an
error beep is given). The value is also written in the System Inquiry Array.

The Maximum Z-Value in an Assembly Drawing
To find the maximum z-value:

1. Click Hidden and then, in the Create Element group, click Inquire Z Value.

2. Click Maximum.

Creo Elements/Direct Drafting displays the maximum z-value in the assembly
drawing in the user input line (if the drawing has no z-values assigned, an
error beep is given). The value is also written in the System Inquiry Array.
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The Z-Value of a Shared Part
To find the computed z-value of a shared part:

1. Click Hidden and then, in the Create Element group, click Inquire Z Value.

2. Click Shared Part Offset.
3. Select the shared part.

Creo Elements/Direct Drafting computes the z-value as the sum of the shared
part's z-value and that of the shared parent part and displays it in the user input
line. The value is also written in the System Inquiry Array.

Example
Refer to Figure 203 on page 489.
To check the z-value of Shared_part2:

1. Click Hidden and then, in the Create Element group, click Inquire Z Value.

2. Click Shared Part Offset.
3. Click Shared_part2.

Creo Elements/Direct Drafting calculates the shared part's z-value as follows:

Z-value of Shared_part2 + z_value of parent. In this case, -5 + 6 = 1.

The Z-Value of an Element in a Shared Part
To find the z-value of an element in a shared part:

1. Click Hidden and then, in the Create Element group, click Inquire Z Value.

2. Click Shared Part Element.
3. Select the element in the shared part.

Creo Elements/Direct Drafting displays the element's z-value in the user input
line. The value is also written in the System Inquiry Array.

The Current Z-Value
To check the default current z-value assigned to each newly created drawing
element:

• Click Hidden and then, in the Create Element group, click Set Z Values.
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The HL Z Values dialog box opens.
The Current Value box in the HL Z Values dialog box displays the current z-value.
The current z-value is also written in the System Inquiry Array.

The Load Value
To check the current load z-value:

• Click Hidden and then, in the Create Element group, click Set Z Values.

The HL Z Values dialog box opens.
The Load Value box in the HL Z Values dialog box displays the current load z-
value. The current load z-value is also written in the System Inquiry Array.

Setting the Default Z-Value
This section provides information about defining a specific z-value which is
assigned to each newly created element (the default current z-value is 0).
To set the current z-value:

1. Click Hidden and then, in the Create Element group, click Inquire Z Value.

2. Click Current Z Value.
3. Type the default z-value in the user input line and press ENTER.

Alternatively, click Hidden and then, in the Modify group, click the arrow next

to Options.

Click Above or Same or Below and then click the reference
element.

Creo Elements/Direct Drafting assigns this value as the current z-value,
assigned by default to each newly created element.

Setting the Load Value
This section provides information about defining a loading offset in the z-direction
for elements that are loaded in the future.
The default load z-value is None. If you load elements with the load z-value set to
None, their z-value (if any) remains unchanged.
To set a load offset z-value:

1. Click Hidden and then, in the Create Element group, click Inquire Z Value.
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2. Click Load Z Value.
3. Type the relative load z-value in the user input line and press ENTER.

Alternatively, click Hidden and then, in the Modify group, click the arrow next

to Options.

Click Above or Same or Below and then click the reference
element.

Creo Elements/Direct Drafting assigns the required load z-value to any
elements loaded in the future.

Example
To load drawing elements with a load z-value of 2:

1. Click Hidden and then, in the Create Element group, click Inquire Z Value.

2. Click Load Z Value.
3. Type 2 in the user input line and press ENTER.
4. Load an existing drawing file.

Creo Elements/Direct Drafting loads the drawing elements as shown in Figure
191 on page 492.

Figure 191. Loading Drawing Elements with a Load Z-Value of >=2
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Generating Faces
This section describes how to specify covering faces. A covering face will
effectively cover all geometry (or faces) with a lower z-value. Newly created faces
are assigned the current z-value by default. The covering face will adopt the
default face color (note that you can set a default color for faces).

Automatically
You can automatically generate faces if:

• All elements of the contour are in the active part.
• The contour has no gaps.
• Each vertex of the contour is a vertex of all elements there.
To automatically generate faces:

1. Click Hidden and then, in the Create Face group, click Single Automatic.
2. Specify a point inside the face.
3. Type a z-value in the user input line and press ENTER.

or

Click Hidden and then, in the Modify group, click the arrow next to
Options.

Click Above or Same or Below and then click the reference
element.

Creo Elements/Direct Drafting generates the face automatically and assigns
the required z-value.

Manually
In order to build up a contour with elements, a vertex of an element must be
specified first. Thereafter, the elements which make up the contour can be selected
by a simple click.
Creo Elements/Direct Drafting will allow you to skip elements along a contour as
long as not more than one element after any branch point is skipped. All elements
must be in the active part.
To manually generate a face:

1. Click Hidden and then, in the Create Face group, click Single Manual.
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2. Specify points along the outer contour (the points selected do not have to lie
on any geometric element).

3. Specify points along the inner contour.

4. Click OK.
5. Type a z-value in the user input line and press ENTER.

or

Click Hidden and then, in the Modify group, click the arrow next to
Options.

Click Above or Same or Below and then click the reference
element.

All Faces in a Part Excluding Holes
To automatically generate all faces in a part and exclude any holes:

1. Click Hidden and then, in the Create Face group, click With Holes.
2. Type a z-value in the user input line and press ENTER.

or

Click Hidden and then, in the Modify group, click the arrow next to
Options.

Click Above or Same or Below and then click the reference
element.

Creo Elements/Direct Drafting generates the faces automatically and assigns
the required z-values. Any holes that are present are excluded from face
generation.

Automatically Generating All Faces in a Part
You can generate faces automatically in the active part. Creo Elements/Direct
Drafting tries to find the maximum number of faces.
To automatically generate faces in the active part:

1. Click Hidden and then, in the Create Face group, click All in Part.
2. Type a z-value in the user input line and press ENTER.

or
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Click Hidden and then, in the Modify group, click the arrow next to
Options.

Click Above or Same or Below and then click the reference
element.

Example
Refer to Figure 192 on page 495. In this example, Creo Elements/Direct Drafting
would generate the four faces shown.

Figure 192. Automatically Generating Faces In a Part

Undoing a Face
You may want to undo a face you have just generated (before specifying the z-
value).

The effect of clicking Undo when using the following buttons in the Create
Face group on the Hidden tab is as follows:

Single Automatic
The last face specified is removed.

Single Manual
During creation of a contour, points are removed. If you

have finished defining a face and have clicked OK,

clicking Undo results in the removal of the entire
face.
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All in Part
All faces generated automatically are removed.

With Holes
All faces generated automatically are removed.

Deleting Covering Faces
This section shows how to delete covering faces. You can delete a single face or
all faces in a part. The faces identified must be in the current part and they should
not contain any hatching.

A Single Face
To delete a single face:

1. Click Hidden and then, in the Modify group, click Delete Face.
2. Select the face you wish to delete.

Creo Elements/Direct Drafting deletes the face.

All Faces in a Part
To delete all the faces in the current part:

1. Click Hidden and then, in the Modify group, click Delete Face.
2. Type ALL in the user input line and press ENTER.

Creo Elements/Direct Drafting deletes all faces in the current part.

Redrawing in Hidden or Normal Mode
This section shows how to switch between the normal Creo Elements/Direct
Drafting redraw function and the hidden line redraw function.

Note
Hidden Mode affects all View functions as each takes the z-value information
into account.

Hidden Mode
To redraw in hidden mode:
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1. Click Hidden and then in the Modify group, click the Hidden Mode check box.
2. Specify the required viewport to use the z-value information when redrawing.

Creo Elements/Direct Drafting displays the drawing partially covered
(depending on the z-values associated with the assembly drawing).

Note
Creo Elements/Direct Drafting displays - H - in the upper left-hand corner of
the Creo Elements/Direct Drafting window to indicate hidden mode.

Normal Mode
This is the default mode. To redraw normally:

1. Click Hidden and then in the Modify group, clear the Hidden Mode check box.
2. Specify the appropriate viewport.

Hidden Settings
The Hidden Settings dialog box allows you to define the required hidden line type,
line color and face color settings,
To open the Hidden Settings dialog box:

• Click File ▶ Settings ▶ Hidden.
The Hidden Settings dialog box enables you to define:

• Line settings
• Face settings

Line Settings
In the Line area of the Hidden Settings dialog box, define the following settings:
Type Select the line type for hidden lines in your drawing.
Color Select the color for hidden lines in your drawing.

If you click the Default check box, the default hidden line color
is applied. Refer to Defining Custom Colors on page 100 for
instructions on defining custom colors.

Width Type the width of the hidden line.
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Face Settings
In the Face area of the Hidden Settings dialog box, select the color for faces in the
hidden mode. If you click the Default check box, the default face color is applied.
Refer to Defining Custom Colors on page 100 for instructions on defining custom
colors.

Changing the Linetype and Color of
Hidden Lines
The Change Hidden Line dialog box enables you to change hidden lines (see
Generating Hidden Lines on page 470 for instructions on generating hidden lines).
To change the linetype and/or color of existing hidden lines:

1. Click Hidden and then, in the Modify group, click the arrow next to Edit.

2. Click Line.

The Change Hidden Line dialog box opens.
3. In the Type box, select a linetype.
4. In the Color box, select a color.

Refer to Defining Custom Colors on page 100 for instructions on defining
custom colors.

5. Click OK.

All existing hidden lines in the drawing are redrawn in the linetype and line
color you selected.

Changing Face Color
The Change Hidden Face dialog box enables you to change the color of faces you
created to generate hidden lines.
To change the color of faces:

1. Click Hidden and then, in the Modify group, click the arrow next to Edit.

2. Click Face.

The Change Hidden Face dialog box opens.
3. In the Color box, select a color.
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4. If you click the None check box, the face color is set to none (that is, faces will
be transparent). Refer to Defining Custom Colors on page 100 for instructions
on defining custom colors.

5. Click OK.
6. Select the face or faces to be changed.

The selected face or faces are redrawn in the color you selected.

Viewing Z-Values
The Show Range dialog box enables you to view all or a range of z-values in your
drawing. You can display all elements or only faces (in a color of your choice) that
are in a specified range of z-values.
To open the Show Range dialog box:

1. Click Hidden and then, in the Modify group, click the arrow next to Show.

2. Click Range.
The Items area of the Show Range dialog box enables you to select one of the
following:

• Elements in Drawing

• Faces in Drawing

• Elements in Part

• Faces in Part

Elements in All Parts
Click Elements in Drawing in the Items area of the Show Range dialog box to
select all elements:

• In a selected range of z-values.
• In all parts (default).

Elements in Current Part
Click Elements in Part in the Items area of the Show Range dialog box to select
elements:

• In a selected range of z-values.
• In the current part.
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Faces in All Parts
Click Faces in Drawing in the Items area of the Show Range dialog box to select
faces:

• In a selected range of z-values.
• In all parts.

Faces in Current Part
Click Faces in Part in the Items area of the Show Range dialog box to select faces:

• In a selected range of z-values.
• In the current part.

Setting a Range of Z-Values
By default, all z-values are shown. In the Show Range dialog box, you can limit
the visible range of z-values as follows:

1. In the Range area of Show Range dialog box, click Limit.
2. In the Lower box, type the "from" z-value.
3. In the Upper box, type the "to" z-value.
For example, to limit the visible range to z-levels 3 through 8, you would type 3
in the Lower box and 8 in the Upper box.
This range is used in the following way:

• In connection with Elements in Drawing and Elements in Part, this range
specifies the range of z-values belonging to elements that are visible.

• In connection with Faces in Drawing and Faces in Part, this range specifies the
range of z-values belonging to faces that are visible and colored.

Applying a Color to Facilitate Visualization
To color faces in a particular range of z-values as an aid to visualization:

1. In the Items area of the Show dialog box, click the required item for the items
to be displayed.

2. In the Range area of the Show dialog box, specify the range of z-values to be
displayed in the same color (see Setting a Range of Z-Values on page 500).

3. In the Show area of the Show Range dialog box, click Color and select a color.
Refer to Defining Custom Colors on page 100 for instructions on defining
custom colors.
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4. Click OK.

Creo Elements/Direct Drafting displays the selected faces in the required color
and does not display those faces with a z-value outside of the desired range.
See Figure 193 on page 501.

Figure 193. Viewing Selected Elements

Resetting the Viewport after Viewing
After using the Show Range dialog box to display selected elements or geometry,
you need to reset the viewport so that you can see all elements or geometry again.
To reset the viewport:

1. Click Hidden and then, in the Modify group, click the arrow next to Show.

2. Click Show Reset.

Generating Hidden Lines
This section shows how to generate hidden lines and load the backup drawing
(workfile.hid) produced just before generating hidden lines.
When generating hidden lines, Creo Elements/Direct Drafting does the following:

• Geometry is modified by splitting geometric components if they are covered
by faces with a higher z-value.

• Shared parts are unshared.
• The parts tree, starting from the current part, will be smashed.
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Caution
It is recommended to store your assembly drawing (in workfile.hid)
before generating hidden lines:

1. Click Hidden and then, in the Modify group, click the arrow next to
Generate.

2. Click with Backup.

The Generate buttons smash the part structure and create the hidden line
geometry.

To generate hidden lines:

1. Click Hidden and then, in the Modify group, click the arrow next to
Generate.

2. Click with Backup or without Backup.

Loading the Backup Drawing
If you wish to recover the backup drawing (workfile.hid) produced by

clicking with Backup:

1. Store your hidden line view.

2. Click Hidden and then, in the Modify group, click Load Backup.

Creo Elements/Direct Drafting will load the original drawing
(workfile.hid) created before you generated hidden lines.

Plotting Hidden Lines
It is not possible to plot face colors.
To suppress plotting of hidden lines, you must set the hidden line linetype and
color appropriately. Refer to the PLOT_TRANSFORMATION command in
Writing Macros with Creo Elements/Direct Drafting.
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Dumping Hidden Lines
You can use the screen dumping commands to produce a copy of your drawing
that includes face colors (if you have a color printer). Screen dumps can be made
at any stage in the drawing process. Refer to Printing and Plotting on page 606.

Hidden Line - Tutorial Example 2
This tutorial example shows one way to create an assembly drawing (CRANK_
ASSEMBLY) from five individual part drawings. The assembly drawing is then
used to demonstrate the various features of the Creo Elements/Direct Drafting 2D
Hidden Line Module.

Creating the Crank Assembly
This tutorial is based on the crank assembly shown in Figure 194 on page 503.

Figure 194. CRANK_ASSEMBLY

This crank assembly consists of the top part named CRANK_ASSEMBLY and five
subparts. The parts tree is indicated in the following list:
CRANK_ASSEMBLY

Nut

Lever

Crank

Joint

Shaft assembly
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Draw a Cutaway Hole in the Joint

1. Click Structure and then, in the Parts group, click the arrow next to Edit.

2. Click Part.
3. Click the Joint to make it the active part.

4. Click Drafting and then, in the Draw group, click the arrow next to Spline.

5. Click Interpolation Spline.
6. Click the Closed check box.
7. Click points for the spline to create the cutaway hole shown in Figure 195 on

page 504.

Figure 195. CRANK_ASSEMBLY With Cutaway Hole

8. Click OK.

Create Face 1
1. Click Hidden and then in the Modify group, click the Hidden Mode check box.
2. Click the current viewport to get visual feedback while creating faces (the face

is highlighted).
3. Click Hidden and then, in the Create Element group, click the arrow next to

New.

4. Click Element.
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5. Enclose the Joint in a box.
6. When prompted for the z-value, type 1 in the user input line and press

ENTER.

Creo Elements/Direct Drafting assigns a z-value of 1 to all elements in the
box.

7. Click OK.

Generate Face 1

1. Click Hidden and then, in the Create Face group, click Single Automatic.
2. Click a point inside Face 1.
3. When prompted for the z-value, type 2 in the user input line and press

ENTER.

4. Click OK.

5. Click View and then, in the Windows group, click Redraw.

Generate Faces in the Nut
1. Click Structure and then, in the Parts group, click the arrow next to Edit.

2. Click Part.
3. Click the Nut to make it the active part.
4. Click Hidden and then, in the Create Element group, click the arrow next to

New.

5. Click Element.
6. Enclose the Nut in a box.
7. When prompted for the z-value, type 1 in the user input line and press

ENTER.

Creo Elements/Direct Drafting assigns a z-value of 1 to all elements in the
box.

8. Click OK.

9. In the Create Face group of the Hidden tab, click All in Part.

10. Click View and then, in the Viewing group, click Redraw.
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Generate a Face in the Lever
1. Click Structure and then, in the Parts group, click the arrow next to Edit.

2. Click Part.
3. Click the Lever to make it the active part.
4. Click Hidden and then, in the Create Element group, click the arrow next to

New.

5. Click Element.
6. Enclose the Lever in a box.
7. When prompted for the z-value, type 1 in the user input line and press

ENTER.

Creo Elements/Direct Drafting assigns a z-value of 1 to all elements in the
box.

8. Click OK.

9. Click Hidden and then, in the Create Face group, click All in Part.

10. Click View and then, in the Viewing group, click Redraw.
At this point you would check for any errors you may have made when assigning
z-values and generating faces. See Figure 196 on page 506.

Figure 196. CRANK_ASSEMBLY with Hidden Mode On
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Generate Hidden Lines
1. Click Hidden and then, in the Modify group, click the arrow next to

Generate.

2. Click with Backup.

Caution
It is recommended to store your assembly drawing (in workfile.hid)
before generating hidden lines:

a. Click Hidden and then, in the Modify group, click the arrow next to
Generate.

b. Click with Backup.

The Generate buttons smash the part structure and create the hidden
line geometry.

Creo Elements/Direct Drafting generates hidden lines as shown in Figure 197
on page 507, Figure 198 on page 508, and Figure 199 on page 508.

Figure 197. Cutaway Hole and Hidden Lines
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Figure 198. Nut — Showing Hidden Lines

Figure 199. Lever — Showing Hidden Lines

3. Click Hidden and then, in the Modify group, click or clear the Hidden Mode
check box to toggle the hidden lines on or off, respectively.

Further Information
For further technical information about hidden lines, refer to the Creo Elements/
Direct Drafting help system.
Type the following commands in the user input line and press ENTER:

• help hl_set_z_value

• help hl_inq_z_value

• help wui_hl_z_values

• help hl_set_curr_z_value

• help hl_set_load_value
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• help hl_set_relation_offset

• help hl_gen_all_part

• help hl_generate_face

• help wui_change_hidden_line

• help wui_change_hidden_face

• help hl_delete_face

• help hl_generate_hidden

• help hl_redraw_mode

• help wui_hidden_show_range

• help wui_hidden_settings

Creo Elements/Direct Drafting displays further information about hidden lines.
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Drawing Using Layers
Creo Elements/Direct Drafting allows you to split up your drawing into a number
of layers using the buttons in the following groups on the Structure tab:

• Info

• Layer

• URL

The advantage of working this way is mainly in visualization. By switching layers
on and off you can simplify what you see on the screen.

Example
Suppose you wish to create an assembly drawing of a cap bearing consisting of
four components. Each component was stored as a drawing, and you must load
each one to create a four part drawing.
Figure 190. Cap Bearing Parts Structure on page 511 shows the parts structure.

Figure 190. Cap Bearing Parts Structure

Irrespective of the parts structure, you want to be able to see the assembly in three
different ways:

• Each of the components individually.
• With the cap removed.
• Fully assembled.
To do this we can use the three layer commands and place the various elements
into layers; some elements would be contained in more than one layer.
Finally, via the Layer tab in the Show dialog box, you can switch the various
layers on and off to produce the required views. The layers would be as follows:

• Layer: 1

Contains all the HOUSING elements.
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Figure 191. Layer 1 — Housing Elements

• Layer: 2

Contains all the BEARING elements.

Figure 192. Layer 2 — Bearing Elements

• Layer: 3

Contains all the SHAFT elements.

Figure 193. Layer 3 — Shaft Elements

• Layer: 4

Contains all the CAP elements.
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Figure 194. Layer 4 — CAP Elements

• Layer: 5

Contains most of the HOUSING elements, all the BEARING elements and
some of the SHAFT elements.

Figure 195. Layer 5 — Housing, Bearing and Shaft Elements

• Layer: 6

Contains some of the HOUSING and SHAFT elements, plus all the CAP ones.

Figure 196. Layer 6 — Housing, Shaft and CAP Elements
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Adding a New Layer
To add a new layer to your drawing:

1. Click Structure and then, in the Layer group, click Add.
2. Type a unique number or name for this new layer in the user input line and

press ENTER.
3. Select the elements to be added to the new layer by using one of the following

methods:

• Click or box the elements to be added. This method is most suitable for
simple selections of one or two elements.

• Alternatively, click Utilities and then, click Select ▶ Advanced to
use the various Select options. When your selection is complete, click
Confirm and OK. Creo Elements/Direct Drafting adds the elements to the
selected layer. This method is most suitable for large selections as you can
see which elements have been identified so far.

Setting the Active Layer
When a particular layer is active, all subsequently drawn elements will be placed
in it.
To set a layer active:

1. Click Structure and then, in the Layer group, click Current.
2. Type the unique number or layer name in the user input line and press

ENTER.

Duplicating Elements in Other Layers
This section describes how to duplicate elements contained in one layer in
another. After using the function the selected elements will be in both layers. The
function can be used irrespective of which layer is current.
To duplicate elements contained in one layer in another:

1. Click Structure and then, in the Layer group, click Add.

Creo Elements/Direct Drafting prompts for the layer number or layer name to
which elements are to be added.

2. Type the required layer number or layer name in the user input line and press
ENTER.
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3. Select the elements to be duplicated to the new layer by using one of the
following methods:

• Click or box the elements to be added. This method is most suitable for
simple selections of one or two elements.

• Alternatively, click Utilities and then click Select ▶ Advanced to
use the various Select options. When your selection is complete, click
Confirm and OK. Creo Elements/Direct Drafting adds the elements to the
selected layer. This method is most suitable for large selections as you can
see which elements have been identified so far.

Moving Elements Between Layers
This section describes how to transfer elements from one layer to another. The
function can be used irrespective of which layer is current.
To transfer elements from one layer to another:

1. Click Structure and then, in the Layer group, click Change.
2. Type the layer number or layer name to which elements are to be transferred.
3. Select the elements to transfer by using one of the following methods:

• Click or box the elements to be added. This method is most suitable for
simple selections of one or two elements.

• Alternatively, click Utilities and then click Select ▶ Advanced to
use the various Select options. When your selection is complete, click
Confirm and OK. Creo Elements/Direct Drafting adds the elements to the
selected layer. This method is most suitable for large selections as you can
see which elements have been identified so far.

Using Layer in Show Dialog Box
To use the Layer tab on the Show dialog box:

1. Click File ▶ Settings ▶ Show.

Alternatively, click Show in the Utilities group.

The Show dialog box opens.
2. Click the Layer tab.
In the Layer tab, you can:

• Switch layers on and off.
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• Box an area to define a layer.
• Select a color for each layer.

Switching Layers On & Off
To switch layers on or off:

1. Click File ▶ Settings ▶ Show.

Alternatively, click Show in the Utilities group.

The Show dialog box opens.
2. Click the Layer tab.
3. Select the layer or layers you want to switch on or off.
4. Click On or Off to switch on (displayed) or off (hidden), respectively.

Showing Layer Color
You can color a layer to aid visualization. This does not affect plotter pen
numbering.
To color a layer:

1. Click File ▶ Settings ▶ Show.

Alternatively, click Show in the Utilities group.

The Show dialog box opens.
2. Click the Layer tab.
3. Select the required layer or layers.
4. In the Color box, select a color.
5. Click Color to apply the layer color change.

Creo Elements/Direct Drafting redraws the elements of the specified layer in
the selected color.

To restore the original color of the layer, select the layer and then click On in the
Layer tab.

Modifying and Deleting Layers
There may be occasions when you wish to modify or delete complete layers. In
such cases use the Layer option in the Select window.
To modify or delete complete layers:
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1. Click Delete or click the required Modify button.

2. In the Utilities group, click Select ▶ Advanced.

The Select window opens.

Alternatively, press F2 to open the Select window.
3. Click Layer.

The Layer dialog box opens.
4. Type the layer number or layer name that you want to delete or modify.
5. Click Confirm and then click OK.

What are Infos?
The major components of a drawing are drawing elements such as lines, circles,
arcs, and so on. Each element is stored in memory together with information to
describe it. These pieces of information attached to each element are known as
attributes.
Examples of attributes are an element's linetype and color. In addition to these,
Creo Elements/Direct Drafting allows you to enter your own attributes, called
Infos.
An info is simply a piece of text attached to an element. The info is not visible on
the screen, but is attached to the element in memory. The use of infos is a matter
of personal or company preference. They can be used to:

• Store information concerning a design update. The revised elements could all
have the following infos added to them:
· Revision number:003

· Nature of revision: Dimensional changes to
accommodate

· uprated bearings

• Store information concerning dates and names:
· Designer: Bill G

· Date: 03.03.93

· Job No: 147/2

In addition to whatever use you make of infos, Creo Elements/Direct Drafting
uses them when you use the Layer buttons. Thus if you place an element in layer
1, Creo Elements/Direct Drafting will attach the info LAYER: 1 to it.
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Adding Infos
This section describes how to add infos to drawing elements.

Adding the Current Info
You can create infos as current to attach them to all subsequently drawn elements.
To add the current info:

1. Click Structure and then, in the Info group, click the arrow next to Add.

2. Click Current Element.
3. Enter the info text using one of the following methods:

• Type the required text enclosed in quotes (' ' or " ") in the user input line.
This is the best method to use for infos having length of one line.

• Alternatively, click the arrow next to Add and click Editor to
display a text box (based on a standard text editor) in which you can type
the info text. Avoid enclosing the text in quotes. When you have finished
typing the info, close this text box to return to the normal Creo Elements/
Direct Drafting display.

Once the current info has been set, you can continue drawing. All new elements
will automatically contain the current infos.

To a Selected Element
To add infos to existing drawing elements:

1. Click Structure and then, in the Info group, click the arrow next to Add.

2. Click Element.
3. Enter the info text using one of the following methods:

• Type the required text enclosed in quotes (' ' or " ") in the user input line.
This is the best method to use for infos having length of one line.

• Alternatively, click the arrow next to Add and click Editor to display a
text box (based on a standard text editor) in which you can type the info
text. Avoid enclosing the text in quotes. When you have finished typing
the info, close this text box to return to the normal Creo Elements/Direct
Drafting display.

Once the info text has been entered, you can add it to any existing elements.
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4. Select the required elements. Creo Elements/Direct Drafting adds the info to
them. Alternatively, you can use the Select window to select the elements.

Editing an Info
This section describes how to edit any existing info.

The Current Info
To edit the current info:

1. Click Structure and then, in the Info group, click Edit.

2. Click Current.

A text box (based on a standard text editor) opens using which you can edit
the info text

3. Edit the info text.
4. When you have finished editing, close the text box to return to the normal

Creo Elements/Direct Drafting display. All newly drawn elements contain the
revised current infos.

An Existing Element
To edit the info for any existing element:

1. Click Structure and then, in the Info group, click Edit.

2. Click Element.
3. Select the drawing element to be edited.

A text box (based on a standard text editor) opens using which you can edit
the info text

4. Edit the info text.
5. When you have finished editing, close the text box to return to the normal

Creo Elements/Direct Drafting display.

Deleting an Info
This section describes how to delete the current info or the element info.
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Deleting the Current Info
To delete the current info:

1. Click Structure and then, in the Info group, click Delete.

2. Click Current.
Creo Elements/Direct Drafting deletes the current info. If you continue drawing,
all new elements are without infos.

Deleting Element Info
To delete the infos belonging to any existing drawing elements:

1. Click Structure and then, in the Info group, click Delete.

2. Click Element.
3. Select the required elements by using one of the following methods:

• Click or box the elements to be deleted. This method is most suitable for
simple selections of one or two elements.

• Alternatively, click Utilities and then click Select ▶ Advanced to
use the various Select options. When your selection is complete, click
Confirm and OK. Creo Elements/Direct Drafting adds the elements to the
selected layer. This method is most suitable for large selections as you can
see which elements have been identified so far.

Creo Elements/Direct Drafting deletes the infos of the selected elements.

Changing Infos
This section describes how to change infos.
For each option, enter the line of info text to be changed, and the new text. You
can use wildcards (that is, *, ?, [..], ! and \) in either the info text to be changed, or
the new text.
For further information about wildcards, refer to Storing, Loading and Filing on
page 528.

Changing the Current Info
To change the current info:

1. Click Structure and then, in the Info group, click Replace.
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2. Click Current.
3. Type the line of the current info to be changed in the user input line and press

ENTER.
4. Type the replacement text in the user input line and press ENTER.

Creo Elements/Direct Drafting changes the current info

Once the change is made, you are ready to continue drawing. The revised
current info is added to all new drawing elements.

Changing Element Info
To change any existing info:

1. Click Structure and then, in the Info group, click Replace.

2. Click Element.
3. Type the line of info text to be changed in the user input line and press

ENTER.

For example, "DRAWN ON 28.02.93".
4. Type the replacement text in the user input line and press ENTER.

For example, "DRAWN ON 03.03.93".
5. Select the elements to be changed using one of the following methods:

• Click or box the elements to be deleted. This method is most suitable for
simple selections of one or two elements.

• Alternatively, click Utilities and then click Select ▶ Advanced to
use the various Select options. When your selection is complete, click
Confirm and OK. Creo Elements/Direct Drafting adds the elements to the
selected layer. This method is most suitable for large selections as you can
see which elements have been identified so far.

Creo Elements/Direct Drafting modifies the infos of the selected elements.

Changing All Occurrences
To perform changes to all occurrences of an info:

1. Click Structure and then, in the Info group, click Replace.

2. Click Global.
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3. Type the line of info text to be changed in the user input line and press
ENTER.

4. Type the replacement line in the user input line and press ENTER.

Creo Elements/Direct Drafting changes every such occurrence without the
need for identifying elements.

Listing Infos
This section describes how to produce a list of all infos used in your drawing.

1. Click Structure and then, in the Info group, click List.

All infos used in your drawing are displayed in a standard text editor.
2. Close the standard text editor to return to the normal Creo Elements/Direct

Drafting display.

Listing Namespaces
Namespaces are used for structuring infos. The use of namespaces in Creo
Elements/Direct Drafting enhanced performance through targeted inquiries. For
further details, refer to Infotext namespace in the Creo Elements/Direct Drafting
Help.
To list all of the namespaces currently in use:

1. Click Structure and then, in the Info group, click Namespaces.

All namespaces used in your drawing (for example, SYS:HL_SCOPE includes
Z-LEVELS) are displayed in the Info Browser.

2. Close the Info Browser to return to the normal Creo Elements/Direct Drafting
display.

Using Info Elem. in Show Dialog Box
To open the Info Elem. tab on the Show dialog box:

1. Click File ▶ Settings ▶ Show.

Alternatively, in the Utilities group, click Show.
2. Click the Info Elem. tab.
In the Info Elem. tab, you can:

• Switch infos on or off.
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• Box an area to define an info.
• Select a color for each info.

Switching Infos On & Off
To switch infos on or off:

1. Click File ▶ Settings ▶ Show.

Alternatively, in the Utilities group, click Show.
2. Click the Info Elem. tab.
3. Select the info you want to switch on or off.
4. Click On or Off to display or hide the elements containing this info text,

respectively.

URLs
Creo Elements/Direct Drafting enables you to attach any industrial standard Web
page to drawings, parts and elements. All URLs used by Creo Elements/Direct

Drafting drawings, parts and elements are handled using the URL buttons in
the URL group on the Structure tab.

Adding URLs
To add a URL to the current Creo Elements/Direct Drafting drawing:

1. Click Structure and then, in the URL group, click the arrow next to URL.
2. Click any of the following:

• Click Current to add a URL to the current part.

The Current URLs dialog box opens.

• Click Element to add a URL to an element or a group of elements.
Then, select the element or group of elements.

The Element URLs dialog box opens.

• Click Part to add a URL to a part other than the current part. Then
select the part.

The Part URLs dialog box opens.
3. In the dialog box, type the url you want to add in the text box and click Add.
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4. Click OK.

Changing URLs
To change the URL attached to a part or element:

1. Click Structure and then, in the URL group, click the arrow next to URL.
2. Click any of the following:

• Click Current to change the URL of the current part.

The Current URLs dialog box opens.

• Click Element to change the URL of an element or a group of
elements. Then, select the required element or group of elements.

The Element URLs dialog box opens.

• Click Part to change the URL of a part other than the current part.
Then select the part.

The Part URLs dialog box opens.
3. In the dialog box, select the URL you want to change.
4. Type the revised URL in the text box and click Change.
5. Click OK.

Deleting URLs
To remove a URL attachment from a part or element:

1. Click Structure and then, in the URL group, click the arrow next to URL.
2. Click any of the following:

• Click Current to delete the URL of the current part.

The Current URLs dialog box opens.

• Click Element to delete the URL of an element or a group of elements.
Then, select the required element or group of elements.

The Element URLs dialog box opens.

• Click Part to delete the URL of a part other than the current part. Then
select the part.
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The Part URLs dialog box opens.
3. In the dialog box, select the url you want to delete.
4. Click Delete.
5. Click OK.

Listing URLs
To display a list of the URLs attached to the current Creo Elements/Direct
Drafting drawing or to a part or to an element in the drawing:

• Click Structure and then, in the URL group, click Show.

The Global URLs dialog box opens. You can view the list of the attached
URLs.

Highlighting the Element or Part to which a Given
URL is Attached
To highlight the element or part to which a URL is attached:

1. Click Structure and then, in the URL group, click Show.

The Global URLs dialog box opens.
2. Select a url from the list.
3. Click Show Elem. to highlight the element associated with the URL.
4. Click Show Parts to highlight the part associated with the URL.

Accessing a URL
To access a URL attached to a part or element in a drawing:

1. Click Structure and then, in the URL group, click the arrow next to URL.
2. Click any of the following:

• Click Current to access the URL of the current part. The Current URLs
dialog box opens.

The Current URLs dialog box opens.

• Click Element to access the URL of an element or a group of
elements. Then, select the required element or group of elements.

The Element URLs dialog box opens.
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• Click Part to access the URL of a part other than the current part.
Then select the part.

The Part URLs dialog box opens.
3. In the dialog box, select a URL and then click Browse to access this URL by

means of your default Web browser or navigator.

Using URL Elem. in Show Dialog Box
To use the URL Elem. tab on the Show dialog box:

1. Click File ▶ Settings ▶ Show.

Alternatively, click Show in the Utilities group.

The Show dialog box opens.
2. Click the URL Elem. tab.
In URL Elem. tab, you can:

• Switch URLs on and off.
• Box an area to show its URLs.
• Select a color for each URL.

Switching URLs On & Off
To switch URLs on or off:

1. Click File ▶ Settings ▶ Show.

Alternatively, click Show in the Utilities group.

The Show dialog box opens.
2. Click the URL Elem. tab.
3. Select the URL you want to switch on or off.
4. Click On or Off to display or hide all the elements associated with the selected

URL, respectively.

Assigning a Color to a URL
You can color a URL to aid visualization.
To color a URL:

1. Click File ▶ Settings ▶ Show.

Alternatively, click Show in the Utilities group.

526 Creo Elements/Direct Drafting User's Guide: Fluent User Interface



The Show dialog box opens.
2. Click the URL Elem. tab.
3. Select a URL.
4. In the Color box, select a color.
5. Click Color.

Creo Elements/Direct Drafting indicates the element in the selected color that
contains the URL.

Further Information
For further technical information about layers and infos, refer to the Creo
Elements/Direct Drafting help system.
Type the following in the user input line and press ENTER:

• help infotexts

• help add_current_info

• help add_elem_info

• help screen

• help edit_current_info

• help edit_elem_info

• help change_current_info

• help change_elem_info

• help change_global_info

• help delete_current_info

• help delete_elem_info

• help url

• help wui_edit_global_url

• help wui_edit_current_url

• help wui_edit_elem_url

• help wui_edit_part_url

Creo Elements/Direct Drafting displays further information about using layers or
infos or URLs.
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File Organization and Names
This section gives a brief overview of file handling terminology, sufficient to use
the File functions and commands.
All file access operations can easily be performed using Creo Elements/Direct
Drafting filing commands.

File Organization
A file is simply a container into which you can put data. The most important
aspect of a file is that it has a name which you have allocated to it. The contents of
a file can be displayed, copied, and removed from the system.
A directory is a file containing information about other files and directories. A
directory contained within another directory is called a subdirectory, and each
subdirectory can itself contain files and more subdirectories. Figure 197. File
System Hierarchy on page 529 shows file system hierarchy.

Figure 197. File System Hierarchy

Filenames
In theory, a filename can consist of any characters available on the keyboard. In
practice however, many characters are of special significance to the MS-DOS or
Windows NT operating systems and these should not be used in filenames and
directory names.
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Table 4 on page 530 gives the characters with special significance to the operating
system.

Table 4. Characters With Special Significance

asterisk *
question mark ?
less than <
greater than >
bar |
forward slash /
backslash \
quote '
colon :

As a general rule, it is best to restrict yourself to names consisting of letters, digits,
and underscore characters.

Note
You can use upper or lower-case letters for filenames, however, do not mix
cases when entering commands. For example, File01 is valid for a filename,
but Create_Directory is not valid for a command.

Identifying Files
This section provides information about identifying files to ensure the correct file
is loaded, stored, and so on.
You can identify files three ways:

• By entering the file path name.
• By using the SEARCH command.
• By using the File Browser (see Opening and Saving Drawings by Using Creo

Elements/Direct Drafting File Browser on page 531 later in this chapter).
• By using the Navigator.

Using the File Path Name
The file path consists of the volume or drive identifier, a directory path, and a
filename, all separated by a backslash ("\") or a colon (":").
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For example, consider the following string:
'D:\larry\nvb_drw_101.mi'

The string can be identified as following:

Filename nvb_drw_101.mi

Directory larry

Volume/Drive: D:

Note
Creo Elements/Direct Drafting recognizes both the slash ("/") and the
backslash ("\") as valid separators of the components of a file path. The
following string also correctly identifies the file given in the example above.
'D:/larry/nvb_drw_101.mi'

In this guide, backslashes are used in general.

Opening and Saving Drawings by Using
Creo Elements/Direct Drafting File
Browser
You can open and save drawings quickly and easily by means of the Creo
Elements/Direct Drafting File Browser. This File Browser adheres to standard
MS-Windows conventions. You do not need to remember long filenames and
subdirectories as these are displayed. (You can still type the filename in the user
input line if you wish.)
You can close the File Browser once the drawing has been opened or saved.
Optionally, you can leave the File Browser open for further selections.
In the File related dialog boxes, the File Browser provides the following icons:
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Moves up one level in the directory hierarchy.

Creates a new folder (directory) on the current directory level.

Displays files and directories in various views. You can choose
the following views:
• Thumbnails

• Tiles

• Icons

• List

• Details

In the dialog boxes associated with the Creo Elements/Direct Drafting File
Browser, you can move, copy and delete files and directory using standard MS-
Windows techniques.

Opening a Drawing File Using the Creo Elements/
Direct Drafting File Browser

When you use Open, the drawing file you select or specify replaces any
drawing already loaded in the Creo Elements/Direct Drafting workspace.
The name of the currently loaded drawing file is displayed in the Creo Elements/
Direct Drafting title bar (at the top of the Creo Elements/Direct Drafting window).
To open a drawing file by using the Creo Elements/Direct Drafting File Browser:

1. Click File ▶ Open to display the File Browser.

Alternatively, click Open on the Quick Access Toolbar or press CTRL+O.
2. If the file you want to open is not listed in the File pane of the File Browser,

select the directory that contains the file in the Directory box.

If this required directory is specified in the File pane, double-click the
directory name to list the files contained in it.

The system defaults to the most recent file type extension opened (startup
default is *.mi). This is convenient if you open several files of the same type
in your work session. Thumbnail views are an exception; if you open a
Thumbnail, the extension of the file opened before the Thumbnail is kept as
most recent.

3. Click the filename.
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If the file that you want to open has a format different from the most recent
opened, then in the Filter box, click the applicable file format:

• Model Interface Standard (*.mi)

• Compressed MI (*.bi) (compressed by means of the Z-lib mechanism)
• Bundle (*.bdl) (Creo Elements/Direct Drafting bundle files)

Note
Only the 2D portions of such files are extracted, while any 3D portions
are ignored.

• Autodesk Drawing Interchange (*.dxf)

• Initial Graphics Exchange Format (*.igs)

• AutoCAD File Specification (*.dwg)

• JPEG - JFIF Compliant (*.jpg)

• Portable Network Graphics (*.png)

• Tagged Image File Format (*.tif)

• Windows or OS/2 Bitmap (*.bmp)

• All files (*.*)

Refer to Handling External File Formats on page 557 for further information
on external file format translators used by Creo Elements/Direct Drafting.

A preview image of the drawing file is displayed in the preview pane of the
File Browser.

4. Optionally, click the following:
Remember extension
filter

Applicable to DXF and DWG files. A dialog box
opens for DXF and DWG only.

Configure Enabled for DXF or DWG files. The Import
Configurator dialog box opens.

Check 2D Creo Elements/Direct Drafting checks this file for
invalid elements (such as extremely short lines)
and will remove such elements.

Check 2D Retain
Dependency

Creo Elements/Direct Drafting re-allocates
dependent elements (such as dimensions or
hatches) of removed invalid elements to plausible
valid elements.
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Overwrite fonts In some cases, a font may have been saved with an
MI file. Creo Elements/Direct Drafting will
automatically load this font when you load the file.
However, if the font in the file matches a font name
already in your system, you can instruct Creo
Elements/Direct Drafting to overwrite your system
font with the file font by checking this box.

Discard fonts In some cases, a font may have been saved with an
MI file. Creo Elements/Direct Drafting will
automatically load this font when you load the file.
If you do not want new fonts loaded, check this
box.

5. Click Open to open this file in Creo Elements/Direct Drafting.

Alternatively, type the filename in the Name box and press ENTER.
6. If Creo Elements/Direct Drafting contains a drawing, you are prompted to

save this drawing before the selected file is loaded. Refer to Saving a Drawing
File via the Creo Elements/Direct Drafting File Browser on page 536 for
instructions.

7. Once the drawing is displayed in Creo Elements/Direct Drafting, you can edit
it as required.

Note
The preview image is pixel-based. It cannot be modified.

Opening a Drawing File by Means of the Navigator
The Creo Elements/Direct Drafting Navigator provides a scrollable sequence of
preview images of the drawing files in the current directory. The Navigator thus
facilitates the selection of drawings.
To open a drawing file by using the Creo Elements/Direct Drafting Navigator:

1. Click File ▶ Open to display the File Browser.

Alternatively, click Open on the Quick Access Toolbar or press CTRL+O.
2. Click Navigator to open the Creo Elements/Direct Drafting Navigator. By

default, the Navigator points to the Creo Elements/Direct Drafting installation
directory. The preview images in the right pane of the Navigator show a
number of drawing frames supplied with Creo Elements/Direct Drafting.
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The Navigator displays a preview image for each file provided in the formats
listed above.

3. In the left pane of the Navigator, click the directory whose drawing files you
want to view.

4. In the right pane of the Navigator, double-click the preview image to open its
associated drawing file in Creo Elements/Direct Drafting.

5. If Creo Elements/Direct Drafting contains a drawing, you are prompted to
save this drawing before the selected file is loaded. Refer to Saving a Drawing
File via the Creo Elements/Direct Drafting File Browser on page 536 for
instructions.

6. Once the drawing is displayed in Creo Elements/Direct Drafting, edit the
drawing as required.

Note
To return to the File Browser, close the Navigator.

Opening a Drawing File Using Configure
Configure allows you to open DXF or DWG files.
To open a drawing file using Configure:

1. Click File ▶ Open to display the File Browser.

Alternatively, click Open on the Quick Access Toolbar or press CTRL+O.
2. Browse to and select the DWG or DXF file.
3. Click Configure to open the Import Configurator dialog box.

The Import Configurator dialog box has two tabs; Advanced and Configure.
4. Edit the options on Advanced and Configure tabs.

See Preparing the Drawing Environment on page 61 for details about the
Advanced and Configure tabs.

5. Click Open in the File Browser to load the drawing.
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Note
On the Advanced tab of the Import Configurator dialog box, options such as
Read all layout, Model space, and Translate paper space are not available for
existing files. The Advanced tab also displays information in the file such as
layout names, font, line types, and unit.

Opening Most Recently Used Drawing Files
By default, the four most recently used drawing files are listed (complete with
filetype extension) in the Creo Elements/Direct Drafting File menu. To load one of
these files:
To load a recently used drawing file:

1. Click File.
2. Under Recent Documents, click the name of the drawing file.

Saving a Drawing File via the Creo Elements/Direct
Drafting File Browser
To save a drawing by using the Creo Elements/Direct Drafting File Browser:

1. In Creo Elements/Direct Drafting, click File ▶ Save to display the File
Browser.

Alternatively, click Save on the Quick Access Toolbar or press CTRL+S.
2. If the filename that you want to use for saving the file is not listed in the File

pane of the File Browser, select the directory that contains the file in the
Directory box.

If the required directory is specified in the File pane, double-click the
directory to list the files contained in it.

The system defaults to the most recent file type extension saved (startup
default is .mi). This is convenient if you save several files of the same type in
your work session. Thumbnail views are an exception. If you open a
thumbnail, the extension of the file saved before the thumbnail is kept as most
recent.

3. Click an existing filename (to overwrite an existing file) or type a new
filename (to create a new drawing file) in the Name box.
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4. If the file (containing the drawing that you want to save) is in a format
different from the most recent saved, then in the Filter box, click the applicable
format:

• Model Interface Standard (*.mi)

• Model Interface Standard (*) (save MI format files without an extension or
with a custom extension)

• Compressed MI (*.bi) (compressed by means of the Z-lib mechanism)
• Initial Graphics Exchange Format (*.igs)

• Virtual Reality Modeling Language (*.wrl)

• Drawing Web Format (*.dwf)

• Scalable Vector Graphics (*.svg)

• Text file (*.txt)

• Drafting [version] – MI [version] (*.mi) (MI version 3.40, 3.30, 3.20, and so
on)

• ME 10 [version] – MI [version] (*.mi)

• AutoCAD [version] DXF (*.dxf) (version 2013, 2010, 2007, and so on)
• AutoCAD [version] Drawing (*.dwg) (version 2013, 2010, 2007, and so on)

Refer to Handling External File Formats on page 557 for further information
on external file format translators used by Creo Elements/Direct Drafting.

5. Click Add fonts if you want to ensure that the fonts you used with this drawing
is visible for others. This adds to the file size, but ensures that others who do
not have the same fonts on their systems can read your drawing text (available
for MI format only).

6. Click Save to save the drawing file.

Once you have completed this procedure, you can save the current drawing in
the same file by simply clicking Save in the File Browser.

Saving a Drawing File under a Different Name
To save a drawing under a different name:

1. In Creo Elements/Direct Drafting, click File ▶ Save As.
2. If the filename that you want to use for saving the file is not listed in the File

pane of the File Browser, select the directory that contains the file in the
Directory box.

If the required directory is specified in the File pane, double-click the
directory to list the files contained in it.
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3. In the Name box, type a name for the file.
4. If you want to save the drawing in a format other than the most recently saved,

then in the Filter box, select the applicable file format.

Note that for DWF, VRML, and SVG, the file filter will be set back to the
previous choice. Refer to Saving a Drawing File via the Creo Elements/Direct
Drafting File Browser on page 536 for a list of supported formats.

5. Click Save to save the drawing file.

Saving a Drawing File in HPGL formats
To save an entire drawing, or the content of a viewport, or the content of a box in
a HPGL format:

1. Click File ▶ Print ▶ Print Setup.

Alternatively, click Print Preview and Print on the Quick Access Toolbar.

The Print dialog box opens.
2. On the Print tab, in the Printer area, select a generic option in the Name box

from the following:

• HPGL_GENERIC - Hewelett-Packard plotter language
• HPGL2_GENERIC - Improved version with text defined
• HPGL2_RTL_GENERIC - Improved version with text and images

Note
These formats are based on generic printer drivers. For further information
on setting up a print configuration, refer to Creating a Print Configuration
on page 607.

Note the boxed plus sign beside the generic options. Expand the plus sign and
select the model number, if required.

3. In the Destination box, type the destination file path and file name.
4. Click Print.

Saving a Drawing File in PDF format
To save an entire drawing, the content of a viewport, or the content of a box in a
generic PDF format:
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1. Click File ▶ Print ▶ Print Setup.

Alternatively, click Print Preview and Print on the Quick Access toolbar.

The Print dialog box opens.
2. On the Print tab, in the Printer area, select PDF_GENERIC in the Name box.
3. In the Destination box, type the destination file path and file name.

Alternatively, click Browse to select the destination path and file name.
4. Click Print.
For further information on setting up a print configuration, refer to Creating a
Print Configuration on page 607.

Saving Selected Elements
To save a selection of elements in your drawing:

1. Type STORE in the user input line and press ENTER.
2. Select the element or elements you want to save.
3. Type a name for the file (in apostrophes) in the user input line for saving the

selection.
4. Press ENTER.

Creating a New Drawing
To create a new drawing:

1. Click File ▶ New Session

Alternatively, click Window on the Quick Access Toolbar or press CTRL
+N.

2. If Creo Elements/Direct Drafting already contains a current drawing, you are
prompted to save the drawing in a file before a new drawing is initiated.
Proceed as described in Saving a Drawing File under a Different Name on
page 537.

3. Create the drawing in the usual way.
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Creating a New Creo Elements/Direct
Drafting Instance
Optionally, you can run multiple instances of Creo Elements/Direct Drafting at the
same time.
To create a new Creo Elements/Direct Drafting instance:

• Click Miscellaneous and then, in the System group, click New Drafting.

Alternatively, click Start ▶ All Programs ▶ PTC ▶ Creo Elements Direct
Drafting [version] ▶ Creo Elements Direct Drafting [version].

Note
• Each instance will run in a separate window.
• All Creo Elements/Direct Drafting instances are independent of each other.
• Only a single Creo Elements/Direct Drafting license is required for any

number of Creo Elements/Direct Drafting instances run by the same user on
the same machine/display.

Opening an Existing Drawing File in a
New Creo Elements/Direct Drafting
Instance
To open an existing drawing file in a new Creo Elements/Direct Drafting instance:

1. Click File ▶ Open Dwg in New Drafting.

The Open dialog box opens.
2. Select the file.

If the file is not listed, select the directory which contains the file in the
Directory box and then select the required file.

3. Click Open.
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Importing Macros, Fonts, Pictures, and
HPGL Files
You can import the following files into your current Creo Elements/Direct
Drafting drawing:

• Parts and Subparts
• Creo Elements/Direct Drafting Macros
• Fonts
• Pictures
• HPGL Files

Importing a Part

When you use Import Part, the drawing file you select or specify is added to
any drawing already loaded in the Creo Elements/Direct Drafting workspace. In
the case of an assembly drawing, a part is loaded below the top part. This means
that there is no need to clear the memory as the top part has now been renamed,
for example, to: EXAMPLE_ASSY.
To load a part:

1. Click File ▶ Import/Export ▶ Import Part.

The Load File dialog box opens.
2. If the file that you want to import is not listed in the File pane of the File

Browser:

a. In the Directory box, select the directory that contains the drawing file that
you want to import.

b. Double-click the directory.

If the directory is specified in the File pane, double-click the directory name to
list the files contained in it.

3. Click or specify the filename.
4. If a file is provided in a format other than MI (the default), then in the Filter

box, select the applicable file format. Refer to Opening a Drawing File Using
the Creo Elements/Direct Drafting File Browser on page 532 for a list of
supported formats.

Optionally, you can click any or all of the following check box:
As Subpart Loads a drawing as a subpart of the active part.
Absolute Loads the drawing back to the same position,
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relative to the origin, from which it was
originally stored.

Keep Scale The original drawing scale is retained when the
drawing file is loaded.

Check 2D Creo Elements/Direct Drafting checks this file
for invalid elements (such as extremely short
lines) and removes such elements.

Check 2D Retain
Dependency

Creo Elements/Direct Drafting reallocates
dependent elements (such as dimensions or
hatches) of removed invalid elements to plausible
valid elements.

5. Click Open to add the file as a part to the current drawing in Creo Elements/
Direct Drafting.

Creo Elements/Direct Drafting will automatically load the part into the
position, relative to the origin, in which it was originally created.

Note
Creo Elements/Direct Drafting loads the file immediately below the top part.

Importing a Subpart
You can import a part file as a subpart under the active part.
To import a subpart:

1. Click File ▶ Import/Export ▶ Import Part.

The Load File dialog box opens.
2. If the file that you want to import is not listed in the File pane of the File

Browser:

a. In the Directory box, select the directory that contains the drawing file that
you want to import.

b. Double-click the directory.

If the directory is specified in the File pane, double-click the directory name to
list the files contained in it.

3. Click the As Subpart check box.
4. Click or specify the filename.
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5. If a file is provided in a format other than MI (the default), then in the Filter
box, select the applicable file format. Refer to Opening a Drawing File Using
the Creo Elements/Direct Drafting File Browser on page 532 for a list of
supported formats.

6. Click Open to add the file as a subpart to the current drawing in Creo
Elements/Direct Drafting.

Creo Elements/Direct Drafting automatically loads the part into the position,
relative to the origin, in which it was originally created.

Note
Creo Elements/Direct Drafting loads the file as a part. The part belongs to the
active part and is placed under it in the parts hierarchy.

Importing a Creo Elements/Direct Drafting Macro
To import a Creo Elements/Direct Drafting macro:

1. Click File ▶ Import/Export ▶ Import Macro.
2. Click Macro.
3. Click one of the following:

• Click Input Macro to import a macro provided in the ASCII format.

The Input Macro dialog box opens.
• Click Load Macro to import a macro provided in the binary format.

The Load Macro dialog box opens.
4. Select the macro from the dialog box.
5. Click Open to open the macro in Creo Elements/Direct Drafting.

Importing a Font
To import a font provided in the binary format:

1. Click File ▶ Import/Export ▶ Import Font.
2. Click Font.
3. Click Load Font to import a font provided in the binary format.

The Load Font dialog box opens.
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4. Select a font and then click Open to load the font for use in Creo Elements/
Direct Drafting.

To import a TrueType font provided in the ASCII format:

1. Click File ▶ Import/Export ▶ Import Font.
2. Click Font.
3. Click Convert From TT/T1 to import a TrueType font provided in the ASCII

format.

The Convert Font dialog box opens.
4. In the Name box, select a font or fonts. Optionally, click the All check box to

select all fonts.
5. Click Convert to convert and load the font for use in Creo Elements/Direct

Drafting.

Specifying the Resolution of an Imported TrueType Font
To specify the resolution for a TrueType font that you want to convert to a Creo
Elements/Direct Drafting font:

1. Type CONVERT_TO_ME10_FONT in the user input line and press ENTER.
2. Type the desired resolution in the user input line and press ENTER. Note that

the maximum value is 255.
3. Type the font name in quotes and press ENTER.

Importing a Picture File
Creo Elements/Direct Drafting lets you import picture files in TIFF (*.tif,
compressed and uncompressed), BMP (*.bmp), JPEG (*.jpg) and PNG
(*.png) formats. The following TIFF compression methods are supported:

• Packbits
• CCITT Group 3 1-Dimensional (modified Huffman encoding)
• CCITT Group 4
Being able to import images is particularly useful when you want to place a
scanned image onto your drawing or include a 3D model for better visualization.
To import a picture:

1. Click File ▶ Import/Export ▶ Import Picture.

The Import Raster Image dialog box opens.
2. Select an image.
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3. Click Open to open the image file in Creo Elements/Direct Drafting.
4. Type a name for the picture in the user input line and press ENTER.
5. Specify the position for the imported image file.
Refer to Editing Imported Pictures on page 577 for further details on handling
imported TIFF files in Creo Elements/Direct Drafting.

Importing an HPGL File
Creo Elements/Direct Drafting enables you to load HP-GL and HP-GL2 files.
To import a HP-GL (Hewlett-Packard Graphics Language) or HP-GL2 file:

1. Click File ▶ Import/Export ▶ Import HPGL.

The Load HPGL/2 file dialog box opens.
2. Select the HPGL/2 file.
3. Click Open to open the file in Creo Elements/Direct Drafting.
4. Specify the position for the imported HPGL/2 file.

Exporting Macros, Fonts, and Pictures
You can export the following from your current Creo Elements/Direct Drafting
session:

• Parts
• Creo Elements/Direct Drafting Macros
• Fonts
• Pictures

Exporting a Part
To export the active (current) part in the current Creo Elements/Direct Drafting
drawing:

1. Click File ▶ Import/Export ▶ Export Part.

The Store Part dialog box opens.
2. If the filename that you want to use for saving the file is not listed in the File

pane of the File Browser:

a. In the Directory box, select the directory for saving the file.
b. Double-click the directory.
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3. In the Name box, type the name of the file in which you want to save the
current part.

4. If you want to save the part in a format other than MI (the default), then in the
Filter box, select the applicable format. Refer to Saving a Drawing File via the
Creo Elements/Direct Drafting File Browser on page 536 for a list of
supported formats.

5. Click Save to save the part in the specified drawing file.

Exporting a Creo Elements/Direct Drafting Macro
To export a Creo Elements/Direct Drafting macro:

1. Click File ▶ Import/Export ▶ Export Macro.
2. Click one of the following:

• Click Save Macro to export and save a macro in the ASCII format.
• Click Store Macro to export and save a macro in the binary format.

The Select Macro dialog box opens.
3. In the Name box, select a macro.

Optionally, click the All check box to select all macros.
4. Click OK.

The Save Macro dialog box opens.
5. In the Name box, type or select a macro file name (*.m).
6. Click Save to save the macro file.

Exporting a Font
When you have edited a font (or any character or characters included in a given
font), you need to export this font for further use.
To export a font:

1. Click File ▶ Import/Export ▶ Export Font .
2. Click one of the following:

• Click Save Font to export and save a font in the ASCII format.
• Click Store Font to export and save a font in the binary format.

The Select Font dialog box opens.
3. In the Name box, select a font.
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Optionally, click the All check box to select all fonts.
4. Click OK.

The Save Font dialog box opens.
5. In the Name box, type or select a font file name (*.fnt).
6. Click Save to save the font file.

Exporting a Picture
Creo Elements/Direct Drafting allows you to export pictures in various formats.
To export your picture:

1. Click File ▶ Import/Export ▶ Export Picture.
2. Select a single picture for export.
3. Type the name of the destination file with the desired file format (JPG, PNG,

TIF, or PNG) and press ENTER.

Exporting as Image
Creo Elements/Direct Drafting allows you to export a drawing as an image in high
resolution pixel format.
To export a drawing as an image:

1. Click File ▶ Import/Export ▶ Export as Image.
2. Click one of the following:

• Export as BMP

• Export as JPEG

• Export as PNG

• Export as TIFF

3. To specify input, type PORT, BOX, or DEL_OLD in the user input line and
press ENTER.

Alternatively, type the name and the destination path for the drawing image
file in the user input line and press ENTER to directly obtain the drawing
image at the specified destination path.

4. If you type PORT in the user input line and press ENTER:

a. Click a point, or type CURRENT or the viewport number in the user input
line and press ENTER.
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b. Type RESOLUTION or destination for the drawing image file in the user
input line and press ENTER.

To specify the resolution for the drawing image, type RESOLUTION in the
user input line and press ENTER. Then perform the following steps:

• Type PAPER_TO_PIXELS in the user input line and press ENTER.

Creo Elements/Direct Drafting recalculates paper format and dpi to X,
Y resolution. You are then prompted for a paper format (A-E, A4-A0)
or size, and then for the dpi.

• Type the width and height of the pixels. Type -1 for either width or
height to retain the ratio of the current viewport and specify the other
dimension in pixels.

5. If you type BOX in the user input line and press ENTER:

a. Enclose the required drawing area in a box and press ENTER.
b. Type the name and the destination path for the drawing image file in the

user input line and press ENTER.
Possible error messages are:

• Not enough memory available to perform the operation.
• ***The output image size is limited to a maximum of 4/3 billion pixels.

Copying Files and Directories
You can use Creo Elements/Direct Drafting to copy files and directories. You can
select files, directories, and subdirectories by using the Open dialog box or by
specifying their names in the user input line.

Copying Files
To copy a file:

1. Click Miscellaneous and then, in the System group, click Copy.
2. Type the filename (between single quotes) in the user input line and press

ENTER.

You can use the following four wildcard characters in the file name:

• *
• […]
• ?
• \
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3. Type one of the following in the user input line:

• SELECT and then press ENTER to select the specified file. You can
further narrow the selection using catalog sorting and one of the following
relational operators:

○ =
○ <>
○ >
○ <
○ >=
○ <=

• DEL_OLD and then press ENTER to delete the earlier version of the
specified file.

• SCREEN and then press ENTER to view the source file name in a standard
text editor.

4. Type the destination path for the file in the user input line and press ENTER.

Copying a File Using the Selection Mechanism
The following example shows how to:

• Find files in the current directory (users) with a filename beginning with f.
• Select files greater than 250 bytes in size.
• Copy those files to the mary directory.

The following figure shows the file structure before using Copy:
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File Structure Before Copy

1. Click Miscellaneous and then, in the System group, click Copy.
2. Type 'f*' in the user input line and press ENTER.

Creo Elements/Direct Drafting identifies the file_1 and file_2 files.
3. Type SELECT in the user input line and press ENTER.
4. Type ‘SORT FILE_SIZE’ in the user input line and press ENTER.
5. Type '>250' in the user input line and press ENTER.

Creo Elements/Direct Drafting searches for files that are larger than 250 bytes
and identifies the file_2 file.

6. Type mary in the user input line and press ENTER.

Creo Elements/Direct Drafting copies the file_2 file to the mary directory.

The following figure shows the file structure after using Copy:
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File Structure After Copy

Copying Directories
You must use the RECURSIVE option to copy directories.
To copy directories you must specify the name of the directory as the source name
(include a directory path if required). The entire directory with its files and
subdirectories will then be copied to the directory specified as the destination file.

Note

• While using COPY, you can copy directories using the RECURSIVE
option only.

Copying a Directory Using Recursive
The following example shows how to copy the /users/peter directory to the
/john/drawings directory.

The following figure shows the directory structure before using Copy:
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Directory Structure Before Copy

1. Click Miscellaneous and then, in the System group, click Copy.
2. Type '/users/peter' in the user input line and press ENTER.

Creo Elements/Direct Drafting identifies the peter directory.
3. Type RECURSIVE in the user input line and press ENTER.
4. Type '/john/drawings' in the user input line and press ENTER.

Creo Elements/Direct Drafting copies the peter directory to the drawings
directory.

The following figure shows the directory structure after using Copy:

Directory Structure After Copy
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Copying Options
When you are copying files or directories, you can specify the following options
in the user input line before specifying the destination filename or directory name:

• Use Delete Old to overwrite an existing file.
• Use Screen to view the files and directories to be copied in the standard text

editor.

Note
• If you have specified more than one file as the source name, you must specify

a directory as the destination name. Else, the command does not operate.
• You cannot specify more than one file or directory as the destination name.
• You cannot copy device files, block special files, or char special files.

Purging Files or Directories
You can use Creo Elements/Direct Drafting to purge files or directories.
To purge a file or directory:

1. Click Miscellaneous and then, in the System group, click Purge.
2. Type the name of the file or directory (between single quotes) in the user input

line and press ENTER.

You can use the following wildcard characters in the directory path:

• *
• […]
• ?
• \

3. Type one of the following in the user input line and press ENTER:

• SCREEN to view the files or directories for deletion in a standard text
editor.

• SELECT to use the catalog selection mechanism on the specified files or
directories.

• CONFIRM to directly purge the file.
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Purging Examples
For the purpose of the following examples, assume the current directory is
/users.
The following figure shows the file structure before purging:

File Structure Before Purging

Example 1
To purge the file_1 and file_2 files:

1. Click Miscellaneous and then, in the System group, click Purge.
2. Type '*' in the user input line and press ENTER.

Creo Elements/Direct Drafting identifies the john and peter directories, the
file_1 and file_2 files, and the mary directory.

3. Type SELECT in the user input line and press ENTER.
4. Type “FILE_TYPE” in the user input line and press ENTER.
5. Type < > ‘DIR’ in the user input line and press ENTER.

Creo Elements/Direct Drafting sorts through the three directories and two files
and identifies the file_1 and file_2 files.

6. Click Confirm.

The file_1 and file_2 files are purged.
The following figure shows the file structure after purging:
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File Structure After Purging

Example 2
The following figure shows the directory structure before purging:

Directory Structure Before Purging

To purge the john, peter and mary directories:

1. Click Miscellaneous and then, in the System group, click Purge.
2. Type '*' in the user input line and press ENTER.

Creo Elements/Direct Drafting identifies the john and peter directories, the
file_1 and file_2 files, and finally the mary directory.

3. Type SELECT in the user input line and press ENTER.
4. Type ‘FILE_TYPE’ in the user input line and press ENTER.
5. Type ‘DIR’ in the user input line and press ENTER.
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Creo Elements/Direct Drafting now sorts through the three directories and two
files and identifies the john, peter and mary directories.

In the last case (example 2) nothing is purged. Creo Elements/Direct Drafting tries
to purge the john directory. However, since this directory is not empty, an error
message is displayed and the operation is terminated. If however, the empty mary
directory had been the first directory to be found by Creo Elements/Direct
Drafting, it would have been purged and Creo Elements/Direct Drafting would
then have given an error message, since it would have then found either the john
or peter directory, neither of which are empty.
To successfully delete john, peter and mary directories, you must use the
RECURSIVE option.
Using the RECURSIVE option, you can purge files, non-empty directories and
empty directories. The RECURSIVE option operates on the whole directory path
tree of the directory you have already specified.

Note
RECURSIVE is the only option that allows you to purge directories.

Example 3
The following example shows how to delete the john directory using the
RECURSIVE option. The following figure shows the john directory before
purging:

Directory Structure Before Purging

1. Click Miscellaneous and then, in the System group, click Purge.
2. Type 'john' in the user input line and press ENTER.
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Creo Elements/Direct Drafting identifies the john directory.
3. Type RECURSIVE in the user input line and press ENTER.
4. To view the files and directories before purging, type SCREEN in the user

input line and press ENTER.

The contents of the john directory are displayed in a standard text editor. The
john directory and its contents are deleted after you exit the standard text
editor.

5. To delete the john directory without viewing the directory contents, type
CONFIRM in the user input line and press ENTER.

The following figure shows the directory structure after purging:

Directory Structure After Purging

Handling External File Formats
Creo Elements/Direct Drafting provides the following translators for external file
formats:

• DWF Translator
• DXF DWG Translator
• IGES Translator
• VRMLTranslator
To run one of these translators, double-click the associated icon in the Creo
Elements/Direct Drafting program group. Each of these translators is controlled
via a DOS window.
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Further Information
For further technical information about loading files, refer to the Creo Elements/
Direct Drafting help system.
Type the following in the user input line and press ENTER:

• help load

• help load_font

• help load_hpgl

• help load_macro

• help store

• help store_330

Creo Elements/Direct Drafting displays further information about loading files.
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18
Revision Checking

Using Revision Checking ......................................................................................... 561
Further Information.................................................................................................. 564

This chapter describes how to use the buttons and options that allow you to
compare similar drawings. This facility is particularly useful in design offices
where successive drawings are revised and you need to identify the differences
between revisions. For example, suppose you create a drawing of a plate early on
in the development stage. A few weeks later you revise this drawing by stretching
it, adding fillets, and adding holes. You can now compare the original drawing
with the revised drawing to see where changes have been made. The differences
between the original and revised drawings are shown in color.

Note
Revision checking is possible on drawings stored in MI-format 2.10 or higher.
Incorrect results may occur if you attempt to compare drawings saved in MI-
formats earlier than 2.10. For OLE objects, the revision checking facility
compares the name of the native application, the class ID and the type of the
OLE object.

Figure 198. Original Drawing and Revised Drawing on page 560 shows the
original drawing (A) and the revised drawing (B). Figure 199. Both Files Loaded
on page 560 shows A and B superimposed so that you can easily identify the
modified elements.
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Figure 198. Original Drawing and Revised Drawing

Figure 199. Both Files Loaded

560 Creo Elements/Direct Drafting User's Guide: Fluent User Interface



Using Revision Checking
To use the revision checking facility:

1. Click Compare and then, in the Setup group, click Load Files.

The Load dialog box opens.
2. In the Original box, type the name of the original drawing file.

For example, dt_cs_rev06.

Alternatively, click Browse to select the original drawing file.
3. In the Revised box, type the name of the revised drawing file.

For example, dt_cs_rev10.

Alternatively, click Browse to select to select the revised drawing file.
4. Click OK.

Creo Elements/Direct Drafting displays the two drawings overlapping.

5. Click Compare and then, in the Compare group, click Geometry.

Creo Elements/Direct Drafting compares the location of the geometry and
texts (without comparing the parts structure) in the two drawings and shows
the result of the comparison in different colors according to the following
defaults:
Blue Identical geometry elements in both drawings
Green Differences in the original drawing
Red Differences in the modified drawing

6. Click Compare and then, in the Compare group, click Annotation.

In addition to Geometry, Annotation also compares the properties of
the geometry and texts — linetype, color, text attributes, info texts — and the
dimensions and hatches in both drawings.

7. Click Compare and then, in the Compare group, click Parts.

In addition to Annotation, Parts compares the parts structure in both
drawings.

Revision Checking 561



Note

If you modify a drawing solely by a scaling factor, clicking Parts

displays all elements in red (indicating a difference). However,

Geometry and Annotation display elements and annotation in blue
(indicating identical elements).

Note
Both drawings must have the same location compared to the drawing origin to
get meaningful results from the comparison.

Be careful when working with scaling factors (Part Scale).

Viewing Single Drawings
When both drawings are loaded, you can toggle between them using the buttons in
the Show group on the Compare tab.
To view the original drawing only:

• Click Compare and then, in the Show group, click Original.
To view the revised drawing only:

• Click Compare and then, in the Show group, click Revised.
To view both the drawings:

• Click Compare and then, in the Show group, click Both.

Viewing and Logging Differences
When both the drawings are loaded and compared using the buttons in the
Compare group, you can view the differences between them. You can also view
the generated logs of both the drawing files in a standard text file.
To view the identical elements in the drawing:

1. Click Miscellaneous and then, in the Rev Check group, click Log Diff.
2. Click Identical.
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To view the original drawing:

1. Click Miscellaneous and then, in the Rev Check group, click Log Diff.
2. Click Drawing 1.

Creo Elements/Direct Drafting shows the original drawing and generates a log
of the original drawing in a standard text file.

To view the differences in the modified drawing:

1. Click Miscellaneous and then, in the Rev Check group, click Log Diff.
2. Click Drawing 2.

Creo Elements/Direct Drafting shows the differences in the modified drawing
and generates a log of the modified drawing in a standard text file.

Note
If you click the Arrow check box in the Rev Check group on the
Miscellaneous tab, Creo Elements/Direct Drafting indicates the differences
in the drawing with arrows.

Continuing with the Drawing
When you are ready to continue with your drawing:

• Click Compare and then, in the Continue group, click Original or
Revised.

Creo Elements/Direct Drafting displays the selected drawing and deletes the
other drawing. You can now continue working on this drawing in the usual
manner.

Unlike the Show group buttons, the Continue group buttons do not let you toggle
between the two drawings as it deletes the one you do not select.

Resetting Colors and Showing Differences
The colors generated after selecting a button in the Compare group can be reset to
their original colors.
To view the drawings in the original colors:

• Click Compare and then, in the Show group, click Reset.
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To view the drawing elements in different colors depending on the result of the
last comparison:

• Click Compare and then, in the Show group, click Differences.

Changing the Color Scheme
To change the color scheme for changes in the original drawing:

1. Click Compare and then, in the Setup group, click the arrow next to
Original.

2. Click a color.
To change the color scheme for changes in the revised drawing:

1. Click Compare and then, in the Setup group, click the arrow next to
Revised.

2. Click a color.
To change the color scheme for identical elements:

1. Click Compare and then, in the Setup group, click the arrow next to
Identical.

2. Click a color.
Refer to Defining Custom Colors on page 100 for instructions on defining custom
colors.
The color changes take effect with the next redraw.

Further Information
For further technical information about revision checking, refer to the Creo
Elements/Direct Drafting help system.
Type the following in the Creo Elements/Direct Drafting user input line and press
ENTER:

• help wui_rc_load_files

• help rc_view

• help rc_show_diff

• help rc_clean_up

• help wui_rc_color_settings

Creo Elements/Direct Drafting displays further information about revision
checking.
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Update
Using Associative Documentation............................................................................. 567
Example ................................................................................................................. 573

This chapter tells you how to use the Associative Documentation Update (ADU)
functionality.
ADU provides a way of reflecting 3D design modifications from Creo Elements/
Direct Modeling in related 2D technical drawings (layouts) in Creo Elements/
Direct Drafting.
Elements of existing technical drawings (text, symbols, and hatches) are
automatically transferred to the new 2D technical drawing after a change in a 3D
design. 2D dimensions associated to 3D geometry are updated automatically.
Geometry and annotation changes are highlighted in user-definable colors.
The following figure shows a 3D design (1) done with Creo Elements/Direct
Modeling and its 2D layout (2) in Creo Elements/Direct Drafting. Modifications
made to the 3D design are highlighted in color in the 2D layout. (Drawing 2 is the
undocumented layout and drawing 3 is the documented layout.)
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3D Model and 2D Layout

When modifications are made to a 3D drawing, ADU remembers identifiers and
tries to relocate them in the new layout. Elements with identifiers that are found
again in the new layout are shown in green and identifiers that are not found are
shown in red at their original position.
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Using Associative Documentation
To work with associative documentation in Creo Elements/Direct Drafting, you
need to activate the ADU tab.
To activate the ADU tab:

1. Click File ▶ Options.

The Options dialog box opens. The Customize Ribbon pane is selected by
default.

2. In the Customize the Ribbon list, click the ADU check box.

The ADU tab is displayed on the ribbon.

Loading Drawings
Before you begin, you must have two versions of a drawing available that were
created by Creo Elements/Direct Modeling and passed to Creo Elements/Direct
Drafting as 2D layouts. For example:
layout_1: Drawing that belongs to the original 3D model and that was
completely documented in Creo Elements/Direct Drafting in an earlier session.
layout_2: Layout that belongs to the modified 3D model and that is
undocumented.

1. Click ADU and then, in the Setup group, click Load & Update.

The Load dialog box opens.
2. In the Drawing box, type the name of the drawing file (for example, layout_

1).

Alternatively, click Browse to select the drawing file.
3. In the Layout box, type the name of the layout file (for example, layout_2).

Alternatively, click Browse to select the layout file.
4. Click OK.
Creo Elements/Direct Drafting updates layout_2 with the 2D documentation
that had been added to layout_1. The result of the ADU update is shown in
colors according to the following color defaults:

• Annotations
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Green Transfered 2D All elements of the existing technical drawing as
texts, symbols and drawing frames without a
reference to geometry coming from 3D. They are
transferred to the new 2D technical drawing that is
the result of the Associative Documentation Update
(ADU). Additionally, all dimensions and hatches
associated to geometry that comes from 3D and that
was not changed during the 3D modification are
transferred.

Blue Updated 2D All dimensions and hatches associated to geometry
that was modified during the 3D modification but
that could be unambiguously determined in the
layout file. For example, if the radius of a bore-hole
is changed in the 3D model with a local
modification then the radius dimension associated to
the bore-hole in the existing technical drawing will
be updated to the new bore-hole as the modified
bore-hole could be unambiguously determined in the
layout file.

Red Regenerated
2D

This means dimensions and hatches that referred to
geometry coming from the old drawing that is no
longer in the new layout. For example, if a bore-hole
was deleted in the 3D model, the radius dimension
associated to the bore-hole in the existing technical
drawing will be regenerated.

• 3D Geometry
Magenta Equal 3D The same geometrical location and same unique

name in both versions of the drawing.
Yellow Updated

3D
The same unique name but not the same geometrical
location in both versions of the drawing.

Cyan New 3D New geometry that has been added to the original
design.

The second use of Load & Update loads a Creo Elements/Direct Drafting
drawing and a Creo Elements/Direct Modeling layout but updates the specified
view only.
If no view is given, Creo Elements/Direct Drafting prompts you to specify a view
to update. You can identify a view by entering the string (for example front1)
or select a view by calling the file browser FBROWSER.
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The STORE CURR command stores the currently loaded drawing to the file
system.

Setting Colors
To change the color scheme for transferred 2D elements:

1. Click ADU and then, in the Setup group, click Transfered 2D.
2. Select a color.
To change the color scheme for updated 2D elements:

1. Click ADU and then, in the Setup group, click Updated 2D.
2. Select a color.
To change the color scheme for regenerated 2D elements:

1. Click ADU and then, in the Setup group, click Regenerated 2D.
2. Select a color.
To change the color scheme for equal 3D drawing:

1. Click ADU and then, in the Setup group, click Equal 3D.
2. Select a color.
To change the color scheme for updated 3D drawing:

1. Click ADU and then, in the Setup group, click Updated 3D.
2. Select a color.
To change the color scheme for new 3D drawing:

1. Click ADU and then, in the Setup group, click New 3D.
2. Select a color.
The color changes take effect with the next redraw.

Showing Drawing Differences
To temporarily view the results of the ADU in different colors (with specific
colors for elements that are only in layout_1 or layout_2):

• Click ADU and then, in the Show group, click Diff.
To view the updated drawing in the original colors:

• Click ADU and then, in the Show group, click Reset.
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Note
• All texts and geometry that was added to complete the original 2D drawing is

transferred to the new layout at its original position.
• Associated geometry (center lines and symmetry lines) are treated in the same

way as annotations. For example, a center line follows a moved hole.
• Detail parts are not updated but are also transferred to the new layout at their

original position and with their original geometry.

Accepting and Changing Dimensions
When ADU has finished processing, you must decide whether to accept or change
the updated annotations. You do this by using Accept and Change in the Continue

group on the ADU tab. You can also use Accept in conjunction with Select to
accept, for example, 100 dimensions in one step.
To accept a blue dimension:

1. Click ADU and then, in the Continue group, click Accept.
2. Select a blue dimension.

Once accepted, the dimension is shown in its original color (yellow if the
default has not been changed) and cannot be undone. If you refresh the
drawing, the original dimensioning color remains.

To accept a red dimension:

1. Click ADU and then, in the Continue group, click Accept.
2. Select a red dimension.

Once accepted, the dimension is deleted together with any regenerated
reference elements.

There may be instances where you want to relocate a dimension that ADU
proposes. You can do this using Change in the Continue group on the ADU tab.
To change a dimension vertex:

1. Click ADU and then in the Continue group, click Change.
2. Select the dimension.
3. Select the new reference element.
4. Click the point where you want to locate the dimension.
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Creo Elements/Direct Drafting redraws the dimension and deletes the old vertex
point.
You can also use Change to reposition dimensions and to regenerate hatches
(keeping original attributes).
The following table summarizes the differences between the Accept and Change
when combined with the different annotation colors.

Differences between Accept and Change

Button Description
Accept Tells the system to accept a proposal of ADU.

• Blue: Leave annotation as it is. After you accept the
annotation, it appears in its original color.

• Red: Delete annotation together with regenerated
reference points (also red).

Change Tells the system to exchange the elements to which
annotations refer. For example, you can exchange a
dimension reference-element without deleting the
dimension. When changing recreated (red) reference
points against valid reference elements, the red reference
points are removed after a successful exchange.
Exchanging the reference elements (the contour) of a
hatched face means removing the old hatch and
specifying a new contour by retaining the hatch
attributes.
After you change the annotation, it appears in its original
color.

Accept can be used on blue and red annotations only. Change can be used on all
annotations, regardless of the color. It can also be used on annotations that are not
related to the ADU process.

Associative Elements
When working with associative elements (symmetry lines, reference lines, and
center lines), please note the following:

• If the associative elements have been moved but not modified (means, for

example, not stretched), they will be displayed in green ( Transfered 2D).
• If the associative elements have been modified (like the circle radius having

been increased) the center lines will be displayed in blue ( Updated 2D).
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• If associative elements have been deleted (for example, the circle), the center

lines will be displayed in red ( Regenerated 2D).
Accept and Change also work with associative elements. The following table
shows the effects of combining the buttons with the different colors.

Color Button Effects and Actions
Red Accept Element is deleted.
Blue Accept Element will change color.
Red Change The old elements are deleted and you must

select pick new associated elements.
Blue Change The old elements are deleted and you must

select pick new associated elements.

Modifying Dimensions
To move a dimension:

1. Click ADU and then, in the Modify group, click Move Dim.
2. Select the dimension.
3. Click the location where you want to move the dimension.

1. Click ADU and then, in the Modify group, click Reset Dim.
2. Select the dimension.

Modifying Views
Once you have accepted or changed ADU proposals, you modify the position and
scale of individual views.
When working with ADU, you should not use the buttons on the Modify tab
because association may be lost.

By Reference Point
To move a view using a reference point:

1. Click ADU and then, in the Modify group, click Move View.
2. Click 2 Points.
3. Click a source point.
4. Click a destination point for the view.
5. Select the view.

572 Creo Elements/Direct Drafting User's Guide: Fluent User Interface



Horizontal Move
To move view to a new position in the horizontal direction:

1. Click ADU and then, in the Modify group, click Move View.
2. Click Horizontal.
3. Type the horizontal distance in the user input line and press ENTER.
4. Select the view.

Vertical Move
To move a view to a new position in the vertical direction:

1. Click ADU and then, in the Modify group, click Move View.
2. Click Vertical.
3. Type the vertical distance in the user input line and press ENTER.
4. Select the view.

Rotate a View
To rotate a view about a center:

1. Click ADU and then, in the Modify group, click Rotate View.
2. Type the angle of rotation in the user input line and press ENTER.
3. Select the view.

Scale a View
To scale a view about a center:

1. Click ADU and then, in the Modify group, click Scale View.
2. Type a scale factor in the user input line and press ENTER.
3. Select the view.

Example
The following example shows the steps that you must follow when working with
ADU. For reasons of clarity only one view is considered and it is assumed that
both layouts are available. Before you begin however, it may be helpful to think of
the complete process as 9 steps:

1. Create the first design with Creo Elements/Direct Modeling.
2. Create the first undocumented layout with Creo Elements/Direct Modeling.
3. Document this first layout with Creo Elements/Direct Drafting.
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4. Make changes to the first design in Creo Elements/Direct Modeling and create
the second design.

5. Create the second undocumented layout with Creo Elements/Direct Modeling.
6. Load the first layout which is documented into Creo Elements/Direct Drafting

with ADU.
7. Load the second, undocumented layout into Creo Elements/Direct Drafting

with ADU
8. Accept, reject, or modify the proposals from ADU.
9. Save the new, resulting layout to a file.
The example is a two-pin electrical socket designed using Creo Elements/Direct
Modeling with layout-filename socket_ly1. This design is then modified
according to the following:

• Added: Center hole for the retaining screw.
• Deleted: Punched slot.
• Moved: Left and right recesses.
The following figure shows the first 3D design, the undocumented first layout,
and the documented first layout.

First Design

1 3D Design
2 Undocumented first layout
3 Documented first layout

The following figure shows the first layout and the second layout side-by-side.
Layout 2 contains the new and modified geometry but is not documented. The
numbered items referred to are:
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First Layout

1 Center hole added
2 Left and right recesses modified
3 Punched slot deleted

The filename for the new layout is socket_ly2. You are now ready to use
ADU.

1. Click ADU and then, in the Setup group, click Load & Update.
2. In the Drawing box, type socket_ly1.
3. In the Layout box, type socket_ly2.
Creo Elements/Direct Drafting superimposes the second layout on the first layout
and assigns colors to elements and geometry.
In the following examples, colors are indicated by the following texts and
dimension prefixes:

Layouts Superimposed

• G: Green
• R: Red
• M: Magenta
• C: Cyan
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• B: Blue
You must now decide which of the proposals from ADU to accept or change.

1. Click ADU and then, in the Continue group, click Accept.
2. Select the R-10 dimension.
3. Select the R-12 dimension.
The following figure shows the cleaned-up drawing.

Updated Layout
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Show - Image Options
Show commands allow you to control the tradeoff between image quality and
processing speed for redraw.

Show or Hide
Images can be hidden to speed up processing. If the drawing includes several
images, you can choose to hide individual images or all images.
Use Show or Hide to show or hide pictures.
To show or hide pictures:

1. Click Modify, and then in the Picture group, click Picture Browser.

The Picture Browser opens.
2. Click the required picture name in the Name column.
3. Click Show to show the picture in the drawing.

Click Hide to hide the picture in the drawing.

Tip
While zooming, click the Show Box in the Picture Browser to hide the images.

Quality
When large drawings are placed on a small screen, some pixels from the original
drawing cannot be shown. Two or more pixels from the large drawing must be
mapped into one destination pixel on the screen. Traditionally, this operation
meant that small lines and details could disappear.
Creo Elements/Direct Drafting provides aliasing to let you control quality vs time
trade-offs of large drawing displays. Aliasing algorithms establish an area of
investigation in the large drawing; formulas compute an average color tone for
that area; and the system maps that color result to the destination pixel. Areas of
investigation are based on one pixel and a pattern of its neighbors. Color tone
result is grey-scale, an average of the original black and white pixels.
To control display quality using aliasing:

1. Click Modify and then, in the Picture group, click More.

2. Click Anti-alias Factor.
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3. Type the picture quality number (between -2 and +2 ) in the user input line and
press ENTER.

4. Select the picture.
Positive input between 0 and 2 indicates the system to use a block of
converging pixels in the aliasing formula. Input 2 to use the largest possible block
of neighboring pixels. This results in the slowest possible operation.
Input 0 to produce the fastest operation. No aliasing.
Negative input between 0 and -2 tells the system to use pixels on a diagonal
in the aliasing formula. This option is much faster than using blocks, and often
produces a picture of good quality. Input -2 to use the largest number of
neighboring diagonal pixels in the aliasing formula.

Editing Pictures
When you have imported a bitmap (BMP or TIFF or JPEG or PNG) file as
described in Importing a Picture File on page 544, you can edit it as an image in
Creo Elements/Direct Drafting.

Arranging Images
To arrange images:

1. Click Modify and then, in the Picture group, click the arrow next to Level.

2. Click the required Level button:

Level Button Purpose

To Front
Move an image in front of all other
objects.

To Back
Move an image at back of all other
objects.

Forward
Move one level forward.

Backward
Move one level backward.

In Front Of
Move in front of a reference object.

Behind
Move behind a reference object.

3. Select the image you want to move to the foreground or background.

Editing Imported Pictures 579



When two pictures overlap, only one picture is shown on the screen or printed. All
the pictures within the same part are ordered according to level. Similarly,
subparts are ordered according to level. In other words, the level is the position of
an object (picture or part) in the sequence of all the objects within the same part
(without subparts).
The picture that is in front of another is shown when two pictures overlap.

Note

• Level changes the level of a single part or subpart as well as a picture.
• If you have multiple subparts, you cannot have some pictures in one subpart in

front of pictures in another subpart, and some behind. You can only have all
pictures from one subpart in front of all pictures in another subpart.

Using an external editor
1. Click Modify and then, in the Picture group, click More.

2. Click External Edit.
3. Click the picture to be edited.

An external editor opens the picture in a new window.
4. Edit the picture and close the external editor.
The default external editor is MS Paint. To specify a different external editor, set
the environment variable MEPICEDITOR (first choice) or
SDTOOLBARICONEDIOR (second choice).

Updating a picture
To update a single picture with the contents of the new bitmap picture file:

1. Click Modify and then in the Picture group, click More.

2. Click Update.
3. Click the picture you want to update.
4. Type the file path and file name of the new picture file in the user input line.

To update the earlier uploaded file, type an empty string (two single quote
marks - '') in the user input line.

5. Press ENTER.
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Renaming a picture
To rename a picture in Creo Elements/Direct Drafting:

1. Click Modify and then, in the Picture group, click More.

2. Click Rename.
3. Select the picture.
4. Type the new name for the picture (in quotes) in the user input line and press

ENTER.
You can verify the change in name of the picture using the Part Browser.

Changing the Color of Pixels
After you have imported an image, you probably want to clear unwanted
information or simply clean it of the debris usually associated with scanned
images. This is done by changing the color of the pixel data. If the image is black
and white, you can only reverse the color (black to white or white to black).
Changing the color of individual pixels to the background color of the image
appears to delete the pixel. However, you have only colored the pixel. It is not
possible to delete pixels in order to see through to an underlying image.

Figure 200. Cleaning an Imported Image

1 Box
2 Poly
3 Brush

Creo Elements/Direct Drafting allows you to clean or edit an image using
Color.
To change the color of pixels:

1. Click Modify and then, in the Picture group, click Color.

2. Click Change.
3. Select a single picture.
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4. Click any of the following Color button:

• Click Box and enclose the required pixels in a box.

• Click Poly and enclose the required pixels in a polygon.

• Click Brush and press SHIFTwhile dragging the cursor over the
pixels to be colored.

5. Click OK.

Additional Information:
• If the Brush color is different from the background color, you can add or red-

line information on the image.
• The image is always described by a rectangular frame. If you rotate the image,

the frame increases or decreases according to the horizontal and vertical lines
passing through the corners; see Figure 201. Rotating an Imported Image on
page 582. The swept area is only temporary — it disappears along with any
pixel editing you may have done.

Figure 201. Rotating an Imported Image

Inverting Pictures on Black and White
Displays
Creo Elements/Direct Drafting allows you to change between white-on-black and

black-on-white displays using BW Invert:

1. Click Modify and then, in the Picture group, click More.

2. Click BW Invert.
3. Select the picture to invert.
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4. Click OK.

Note

BW Invert only works on true black and white displays, not grey or color.

Transparency
You can select one color in your picture to become transparent when that picture
overlays another picture. The color you select for transparency becomes invisible,
allowing you to see through those pixels to the lower picture.
To set transparency attributes:

1. Click Modify and then, in the Picture group, click the arrow next to Color.
2. Click Transparency.
3. Click any of the following:

• Click On and select the picture.

If the picture has a transparency color, the color becomes invisible during
overlay.

• Click Off and select the picture.

If that picture has a transparency color, the color does not become invisible
(default setting).

• Click Color.

The Select Color dialog box opens. In the Color box, select a color and
click OK. Select the picture to apply the selected transparency color to it.

Note
Transparent picture attributes must be set by Creo Elements/Direct Drafting.
Attributes from other programs such as those written in jpg, tiff, etc. are not
supported. All imported files are opened as non transparent.

Using the Picture Browser
To use the Picture Browser:

Editing Imported Pictures 583



• Click Modify and then, in the Picture group, click Browser.

Creo Elements/Direct Drafting displays the Picture Browser.
The Picture Browser displays the following information about the currently loaded
images:
Name Filename of the image
Z-level Numerical value for the "hidden" level assigned to an

image in the drawing
Show Status of the SHOW command: On, OFF, or BOX
X-Scale Scaling factor in the x-direction
Y-Scale Scaling factor in the y-direction
Angle Angle of rotation
Anti-A Anti-alias factor of the image
Trans On Image transparency on
Trans Off Image transparency off

Additional Information
• The imported figure is embedded in the MI file format. In the MI file, the

pixel data will be handled in a special section as ASCII characters.
• The imported image maintains its aspect ratio.

• If two images overlap each other, you can use Level in the Picture group
on the Modify tab to move the image forwards or backwards. Click a non-
overlapping area to select the image. Alternatively, type the name in the user
input line and press ENTER.

• If drawing geometry overlaps an image, it is placed at the front of the image or
images.

Tip
Change the color of the overlapping geometry.

• Plotting of images is supported by raster-based plotters only (for example,
plotters supporting PostScript or HP-GL/2 plus RTL). Images are ignored on
non-supported plotters.

• IGES and DXF/DWG translators do not translate pictures by default and
report a warning message in the log file when pictures are skipped.
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• The Store Pixel Data switch in the IGESo.conf file allows storage of
picture to separate files.

• When a picture is loaded, the size of the picture (in current units) is
determined by the factor (current_viewport->factor which is number of current
units per pixel). Hence the actual size of the image depends on the current
value of the zoom factor.

• When an image with more colors than supported by the hardware is loaded
and subsequently saved, loss of color occurs. For example, if an image
containing 1500 colors is loaded on a machine which can display only 256
colors and saved, only 256 out of the 1500 colors are saved in the MI file.
(The pixels with the lost colors are mapped to the nearest available color in the
color table.) This changes the size of the MI file once a load and save is done
across different platforms (with different number of bitplanes) without any
deletion of data (image contents) in the file.

Further Information
For further technical information about pictures, refer to the Creo Elements/Direct
Drafting help system.
Type the following in the Creo Elements/Direct Drafting user input line and press
ENTER:

• help picture

• help change_level

• help chg_pixel_color

• help resample_picture

• help change_picture_aa_factor

• help rename_picture

• help change_picture_transparency

• help wui_inq_picture_color

Creo Elements/Direct Drafting displays further information about pictures.
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Files (such as spreadsheets, graphics or text pages) created in external applications
can be included in Creo Elements/Direct Drafting by inserting associated Object
Linking and Embedding (OLE) objects. Drawings containing OLE objects can be
printed as PDF and PS files.
Please note the following:

• OLE functionality is supported in the Fluent user interface and Windows user
interface only.

• A Creo Elements/Direct Drafting file containing OLE objects added in the
Windows user interface can be loaded in the Classic user interface but the
OLE information is not displayed. However, the existing OLE information is
retained, even if the Creo Elements/Direct Drafting file is saved in the Classic
user interface.

Note
Creo Elements/Direct Drafting can also be inserted as an OLE object in other
applications that support OLE.
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Inserting an OLE Object
To insert an OLE object in a Creo Elements/Direct Drafting drawing:

1. Click File ▶ Import/Export ▶ Import OLE.

The Insert Object dialog box opens. It lists all applications on your system that
provide OLE capability.

2. In the Object Type box, select an application.
3. Select one of the following:

• Create New

• Create from File

Create New
Create New inserts a new OLE object of the selected application in your Creo
Elements/Direct Drafting drawing.
To create a new OLE object:

1. In the Object Type box, select an object type.
2. Click the Display As Icon check box to represent the OLE object by the

associated application icon in Creo Elements/Direct Drafting.
3. Optionally, click Change Icon to select a different icon for the OLE object.
4. Click OK.

The Open dialog box opens.
5. Using the File browser, select the OLE object.

The default OLE object name is displayed in the user input line.
6. Retain the default OLE object name or type a name for the OLE object in the

user input line and press ENTER.
7. Specify the insertion position for the OLE object in Creo Elements/Direct

Drafting.

The OLE object is displayed in the Creo Elements/Direct Drafting drawing.

Create from File
Create from File inserts the contents of a file as an object in your document so that
you can activate the object using the application in which it was created.
To create an OLE object from an existing file:

1. Click Browse and browse to the file you want to link using the file browser.
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2. Click Open.
3. Optionally, click the Link check box to link the OLE object to its source

application such that changes in the original file are reflected in the OLE
object in Creo Elements/Direct Drafting.

4. Optionally, click the Display As Icon check box to represent the OLE object by
the associated application icon in Creo Elements/Direct Drafting.

5. Optionally, click Change Icon to select a different icon for the OLE object.
6. Click OK.
7. Retain the default OLE object name or specify a name for the OLE object in

the user input line and press ENTER.
8. Specify the insertion position for the OLE object in Creo Elements/Direct

Drafting.

The OLE object is displayed in the Creo Elements/Direct Drafting drawing.

Note
If the inserted OLE Object is a Microsoft Excel sheet, the contents displayed
may differ from the actual sheet depending on the font size, the row height,
and the number of rows and columns used in the actual sheet. The size of the
inserted OLE object remains the same even after you add rows or columns to
the actual sheet. However, there is no loss of information in the Microsoft
Excel sheet even if all the rows and columns are not displayed.

Editing an OLE Object in Creo Elements/
Direct Drafting
Once the OLE object is inserted in the Creo Elements/Direct Drafting drawing,
you can edit it as described in the following sections.

Arranging OLE Objects
To arrange OLE objects:

1. Click Modify and then, in the OLE group, click the arrow next to Level.

2. Click To Front, To Back, Forward or Backward, or In

Front Of or Behind.
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3. Select the OLE object you want to arrange.

Activating an OLE Object
By activating an OLE object, you open the underlying file in its source application
for editing. The OLE objects created by using Create from File reflect the changes
made to the underlying file.
To activate an OLE object:

1. Click Modify and then, in the OLE group, click Activate.
2. Click the OLE object you want to activate.

Renaming an OLE Object
You can rename an existing OLE object in a drawing.
To rename an OLE object:

1. Click Modify and then in the OLE group, click Rename.
2. Select the OLE object to be renamed.
3. Type the new name of the OLE object in the user input line and press ENTER.

Using the OLE Browser
To open the OLE Browser:

• Click Modify and then, in the OLE group, click Browser.
The OLE Browser displays the following information about the OLE objects
currently included in your Creo Elements/Direct Drafting drawing:
Name The name you specified for the OLE object
Z-level Numerical value for the "hidden" level assigned to an

image in the drawing
Show Status of the SHOW command: ON, OFF, or ICON
X-Scale Scaling factor in the x-direction
Y-Scale Scaling factor in the y-direction
OLE Type OLE object type
Program ID Application object type
Class ID OLE object class ID

Using the OLE Browser, you can perform the following actions on the OLE
objects:
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• Activate
• Delete
• Show
• Hide
• Box
• Convert to icon
• Rename
• Save

Further Information
For further technical information about OLE objects, refer to the Creo Elements/
Direct Drafting help system.
Type the following in the Creo Elements/Direct Drafting user input line and press
ENTER:

• help ole_list

• help activate_ole

• help rename_ole

Creo Elements/Direct Drafting displays further information about OLE objects.

590 Creo Elements/Direct Drafting User's Guide: Fluent User Interface



22
Annotation

Introduction............................................................................................................. 592
Loading an Annotation Drawing................................................................................ 595
Using the Sheet Browser to Navigate among Sheets and Views.................................. 595
Views ..................................................................................................................... 596
Showing Differences in a View Following a 3D Change .............................................. 598
Handling Annotation Elements ................................................................................. 599
Dimensions............................................................................................................. 599
Sheets.................................................................................................................... 600
Hiding, Deleting, Unhiding........................................................................................ 601
Unhiding Elements .................................................................................................. 602
Changing Colors, Linetypes and Hatches.................................................................. 603
Showing and Storing ............................................................................................... 604
Storing the Drawing for Further Use in Annotation...................................................... 605

This chapter discusses the functionality from the Creo Elements/Direct Drafting
Annotation tab.
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Introduction
The functionality from the Annotation tab in Creo Elements/Direct Drafting
enables you to visualize, annotate and edit MI format 2D drawings generated by
Creo Elements/Direct Annotation.

General Procedure
The functionality from the Annotation tab in Creo Elements/Direct Drafting
Annotation comprises the following steps:

• Prepare the Creo Elements/Direct Drafting drawing environment for
Annotation drawings.

• Load an MI file generated by Creo Elements/Direct Annotation in Creo
Elements/Direct Drafting.

• View, annotate and edit this file as appropriate. For example, you can
manipulate views and you can hide or delete elements. Also, you can modify
and/or add geometry by means of regular Creo Elements/Direct Drafting
commands.

Note
Awarning message is displayed for any "structurally dangerous"
operations that would impair association between 3D model or 2D
drawing.

• After making changes to the underlying 3D model in Creo Elements/Direct
Modeling, update the relevant views in Creo Elements/Direct Modeling and
then review the resulting changes in 2D (Creo Elements/Direct Drafting).

• Edit the information in the 2D views as appropriate (for example,
dimensioning elements coming from 3D, adding text, and so on).

• Check the part structure of the Annotation MI file by means of the Creo
Elements/Direct Drafting Part Browser.

• Save the 2D drawing for further use in Creo Elements/Direct Drafting or in
Creo Elements/Direct Annotation.

Annotation Rules
To ensure that the Annotation MI drawing file retains its 3D or 2D association for
further use in Creo Elements/Direct Modeling, you must observe the following
rules when using the functionality on the Annotation tab in Creo Elements/Direct
Drafting:
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• Do not copy one drawing in another drawing.
• Do not manually insert one or more sheets into another drawing.
• Do not manually insert one or more sheets in another drawing and do no

manually insert views into a sheet (using the part definition commands of Creo
Elements/Direct Drafting). Only use the buttons in the General group and the
Sheet group provided by the Creo Elements/Direct Drafting Annotation tab.

• Do not change or delete info texts beginning with "SD_" or "DOCU" or "AM_".
• Do not modify view parts or parts below view parts with the buttons on the

Modify tab of Creo Elements/Direct Drafting. Only use the buttons in the View
group provided by the Creo Elements/Direct Drafting Annotation tab.

• Do not scale view parts or parts below view parts using the buttons in the
Parts group on the Structure tab of Creo Elements/Direct Drafting. Only use
Scale View in the View group on the Annotation tab of Creo Elements/Direct
Drafting.

• Do not change the scale of the TOP part or the parts below the TOP part with

the Scale buttons in the Parts group on the Structure tab of Creo
Elements/Direct Drafting.

• Do not change the owner of a part or subassembly which belongs to the
drawing in Creo Elements/Direct Drafting.

• Do not use Creo Elements/Direct Drafting to smash or gather any part created
by Creo Elements/Direct Annotation (sheets, frames, view parts, parts below
view parts, sketches).

• Do not create detail parts in Creo Elements/Direct Drafting — these would not
be associative to the 3D model. Use the Detail commands on the Annotation
tab of Creo Elements/Direct Modeling to create detail views.

Preservation of Modifications
The following modifications done with the Annotation functionality in Creo
Elements/Direct Drafting are preserved when an update is performed in Creo
Elements/Direct Annotation:

• Attribute changes such as line type or line color, or addition of info texts to the
geometrical elements coming from the 3D model.

• Center lines created in Creo Elements/Direct Drafting.
• Dimensions, texts, symbols and additional 2D geometry created in the

appropriate view parts.
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Note
Symbols, text and additional 2D geometry can be added to each part
except the TOP part.

• Geometrical elements belonging to subparts which are not owned by the TOP
part named "SD_drawing".

• Hatches added in Creo Elements/Direct Drafting.

Limitations
Some operations performed with the Annotation functionality in Creo Elements/
Direct Drafting will not deliver the expected results after reloading and updating
in Creo Elements/Direct Annotation.

• Parts created in Creo Elements/Direct Drafting as sub-parts of the TOP part
named "SD_drawing" will not be loaded into Creo Elements/Direct
Annotation.

• Geometry or any other additional elements created in the TOP part named
"SD_drawing" will not be loaded into Creo Elements/Direct Annotation.

• Subparts created in Creo Elements/Direct Drafting that are not owned by the
TOP part are not displayed in the Drawing Browser of Creo Elements/Direct
Annotation. However, their geometry is displayed in the viewport.

• Leader lines (or text with leaderlines) created in Creo Elements/Direct
Drafting do not behave associatively in Creo Elements/Direct Annotation.

• Hatch holes automatically created in Creo Elements/Direct Drafting which
have been forced by creation of dimensions or texts with Creo Elements/
Direct Drafting option TEXT_HOLE_INSERTION being set to ON by default
do not update associatively in Creo Elements/Direct Annotation.

• Hatch holes automatically created in Creo Elements/Direct Annotation for
texts do not update associatively in Creo Elements/Direct Drafting when the
text is modified in Creo Elements/Direct Drafting.

• Hatches that were automatically created in Creo Elements/Direct Annotation
but deleted in Creo Elements/Direct Drafting reappear after the next update in
Creo Elements/Direct Annotation.

• 2D view parts created in Creo Elements/Direct Annotation that are renamed in
Creo Elements/Direct Drafting get their original name during the next view
update in Creo Elements/Direct Annotation.
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• If you split or merge 2D geometrical elements in Creo Elements/Direct
Drafting which were derived from 3D geometrical elements during a view
update in Creo Elements/Direct Annotation, then the geometrical elements
look like the original ones after the next view update in Creo Elements/Direct
Annotation.

Preparing the Creo Elements/Direct Drafting
Drawing Environment
Before you load a MI file generated in Creo Elements/Direct Annotation, ensure
you complete the following steps:

1. To ensure that the top part is empty:

a. Click Miscellaneous and then, in the System group, click Reset System.

b. Click Confirm.

Creo Elements/Direct Drafting changes the active part to the top of the
drawing and deletes the entire drawing. The top part of the drawing is
renamed to Top.

2. Activate the Creo Elements/Direct Drafting Annotation tab:

a. Click File ▶ Options.

The Options dialog box opens. The Customize Ribbon pane is selected by
default.

b. In Customize the Ribbon list, click the Annotation check box.

Loading an Annotation Drawing
To load a MI file generated in Creo Elements/Direct Annotation:

1. Click File ▶ Open.
2. Select the MI file from the Creo Elements/Direct Drafting file browser.

Using the Sheet Browser to Navigate
among Sheets and Views
The Sheet Browser enables you to quickly and easily select a sheet or a view
included in a sheet.
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Displaying the Sheet Browser
To display the sheet browser:

1. Click Annotation and then, in the General group, click Sheet Browser.

The SHEETS browser opens.
2. Click the sheet browser and position it in the drawing area.

Selecting a Sheet or View from the Sheet Browser
To select a sheet from the sheet browser:

1. In the sheet browser, click Curr Sheet.
2. Select the sheet name in the sheet browser.

The selected sheet becomes the current sheet.
To select a view from the sheet browser:

1. In the sheet browser, select the sheet that contains the view.
2. Click Curr View.
3. Select the view in the sheet.

The selected view becomes the current view.

Views
The Creo Elements/Direct Drafting Annotation tab provides a number of buttons
for selecting, changing and manipulating views.

Selecting the Current View
To select the current view in the current sheet:

1. Click Annotation and then, in the General group, click Current.
2. Click View.
3. Select the view.
You can also use the sheet browser to select the current view. See Selecting a
Sheet or View from the Sheet Browser on page 596,

Modifying Views
You can change the position of views on a sheet. You can also move views
between sheets.
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Note
Awarning message is displayed for any "structurally dangerous" operations
that would impair 3D or 2D association.

To change the position of one or multiple views:

1. Click Annotation and then, in the View group, click Move.
2. Click one of the following:

• 2 Points to move the selected view or views from the first point to the
second point.

• Horizontal to move the selected view or views by the specified horizontal
distance.

• Vertical to move the selected view or views by the specified vertical
distance.

• Sheet to sheet to move the selected view or views to another sheet.
To rotate a view or views by an angle:

1. Click Annotation and then, in the View group, click Rotate View.
2. Type the angle of rotation in the user input line and press ENTER.
3. Select the view.
To scale a view:

1. Click Annotation and then, in the View group, click Scale View.
2. Type the view scale in the user input line and press ENTER.
3. Select the view.

Showing Hidden Lines
To show hidden lines in the Annotation MI file:

1. Click Annotation and then, in the Show group, click the Hidden Line check
box.

2. Select the view that contains the hidden lines.

Showing Tangent Lines
To show tangent lines in the Annotation MI file:

1. Click Annotation and then, in the Show group, click the Tangent Line check
box.
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2. Select the view that contains the tangent lines.

Hiding Hidden Lines
To hide hidden lines in the Annotation MI file:

1. Click Annotation and then, in the Show group, clear the Hidden Line check
box.

2. Select the view that contains the hidden lines.

Hiding Tangent Lines
To hide tangent lines in the Annotation MI file:

1. Click Annotation and then, in the Show group, clear the Tangent Line check
box.

2. Select the view that contains the tangent lines.

Showing Differences in a View Following
a 3D Change
Any view you see using the Creo Elements/Direct Drafting Annotation tab is a 2D
derivative of a 3D model view in Creo Elements/Direct Drafting. When the
underlying 3D model changes in Creo Elements/Direct Modeling, you can update
the associated view with the Annotation module in Creo Elements/Direct
Modeling and check with the Annotation functionality in Creo Elements/Direct
Drafting for differences in the view before and after the update.

Showing Differences
To show differences in a view:

• Click Annotation and then, in the Show group, click Difference.

Note
• By default, the Creo Elements/Direct Annotation update colors are used to

mark differences as well as unchanged elements.
• Any unchanged elements are marked by the equal info text flag.
• Any changed elements are marked by the non-equal info text flag.
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Hiding Differences
To hide the differences in a view before and after an update to the underlying 3D
model:

• Click Annotation and then, in the Show group, click Reset.

Note
Reset returns the view to the state before Difference.

Handling Annotation Elements
Optionally, you can change or accept annotation elements.

Changing an Annotation
You can change an annotation, for example, by selecting a different reference
element.
To change an annotation:

1. Click Annotation and then, in the Modify group, click Annotation.
2. Click Change.
3. Select the annotation.
4. Perform the steps displayed in the user input line.

Accepting All Annotation Elements
To accept all (current or changed) annotation elements:

1. Click Annotation and then, in the Modify group, click Annotation.
2. Click Accept.

Dimensions

Moving a Dimension
To move a dimension:

1. Click Annotation and then, in the Modify group, click Dimension.
2. Click Move.
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3. Select the dimension and drag it to the new position.

Returning a Dimension to the Original Position
To move a dimension back to its original position:

1. Click Annotation and then, in the Modify group, click Dimension.
2. Click Reset.
3. Select the dimension.

Sheets
You can create, select, change, and modify sheets.

Creating a Sheet
To create a new sheet:

1. Click Annotation and then, in the Sheet group, click New.
2. Click one of the following:

• Frame from File

• Frame from Database

3. Type the number of the new sheet in the user input line and press ENTER.

The Load Frame dialog box opens.

Note
You can see the existing sheet numbers in the sheet browser.

4. Select a frame for the new sheet.
You can then add new views to this sheet, for example, by moving from an
existing sheet or by loading a view from Creo Elements/Direct Drafting. See
Modifying Views on page 596 for more information.

Selecting the Current Sheet
To make a sheet current:

1. Click Annotation and then, in the General group, click Current.
2. Click Sheet.
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3. Select the sheet in the Part Browser.
Alternatively, select the current sheet from the sheet browser (see Selecting a
Sheet or View from the Sheet Browser on page 596).

Modifying a Sheet
You can change the position of the frame of a sheet. Also, you can replace the
current frame of a sheet by a different sheet, or you can delete a sheet.

Note
Awarning message is displayed for any "structurally dangerous" operations
that would impair 3D or 2D association.

To modify a sheet:

• Click Annotation and then, in the Sheet group, click one of the following:

○ Frame Type to select a different frame from the Load Frame dialog box.

The existing frame is replaced by the new frame.
○ Frame Position to move a frame to a new position.
○ Renumber to renumber a sheet.
○ Delete to delete a sheet.

Hiding, Deleting, Unhiding
The Creo Elements/Direct Drafting Annotation tab provides a number of
commands for selectively hiding, deleting or unhiding elements in the drawing.

Hiding or Deleting Elements
Any elements you hide are simply "invisible" in the drawing. Any elements you
delete are physically removed from the drawing.

Note
Awarning message is displayed for any "structurally dangerous" operations
that would impair 3D or 2D association.

To hide or delete elements:
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1. Click Annotation and then, in the Modify group, click Hide Geometry.
2. Click one of the following:

• No Delete to hide elements without deleting them.

Note
You can restore the hidden elements using the buttons in the Unhide
Geometry group.

• Previous Delete to delete the elements that you have selected using No
Delete.

Note
You cannot restore the elements that you delete with Previous Delete
using the buttons in the Unhide Geometry group.

• Final Delete to delete (remove) the elements.

Note
You cannot restore the elements that you delete with Final Delete using
the buttons in the Unhide Geometry group.

3. Select the elements or enclose the elements in a box to hide or delete them.

Unhiding Elements
You can unhide any elements that you have hidden using No Delete.

Unhiding Selected Elements
To selectively unhide the elements that are hidden (but not deleted):

1. Click Annotation and then, in the Modify group, click Unhide Geometry.
2. Click Selected.

The elements that you have hidden using No Delete are displayed in a special
highlight color.

3. Select the elements that you want to unhide or enclose the elements in a box
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4. Click Confirm.

Sequentially Unhiding Elements
Optionally, you can sequentially unhide elements that have been hidden (but not
deleted).
To sequentially unhide the elements:

1. Click Annotation and then, in the Modify group, click Unhide Geometry.
2. Click one of the following:

• Backward to undo your Hide Geometry operations in reverse order (the last
Hide Geometry operation is undone first).

Optionally, click Backward, type the number of backward steps in the user
input line, and press ENTER.

• Forward to undo your Hide Geometry operations in the order in which they
were performed (the first Hide Geometry operation is undone first).

Optionally, click Forward, type the number of forward steps in the user
input line, and press ENTER.

Any unhidden elements are now shown in a special highlight color.

Changing Colors, Linetypes and Hatches
On the Annotation tab, you can change the color and linetype of hidden lines and
tangent lines. Also, you can change the color, angle, and distance of hatches.

Changing the Color and Linetype of Hidden Lines
To change the color of hidden lines:

1. Click Annotation and then, in the View group, click Hidden Line.
2. Click Color and select the view.

The Select Color dialog box opens.
3. In the Color box, select a color.
4. Click OK.
To change the linetype of hidden lines

1. Click Annotation and then, in the View group, click Hidden Line.
2. Click Line Type and select the view.

The Change Line Type dialog box opens.
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3. In the Type box, select a linetype.
4. Click OK.

Changing the Color and Linetype of Tangent Lines
To change the color of tangent lines:

1. Click Annotation and then, in the View group, click Tangent Line.
2. Click Color and select the view.

The Select Color dialog box opens.
3. In the Color box, select a color.
4. Click OK.
To change the linetype of tangent lines:

1. Click Annotation and then, in the View group, click Tangent Line.
2. Click Line Type and select the view.

The Change Line Type dialog box opens.
3. In the Type box, select a linetype.
4. Click OK.

Changing the Color, Angle, and Distance of Hatches
To change the color, angle, and distance of hatches:

1. Click Annotation and then, in the View group, click Hatch.
2. Click Color to change the color of hatches.
3. Click Annotation and then, in the View group, click Hatch.
4. Click Angle to change the angle of hatches.
5. Click Annotation and then, in the View group, click Hatch.
6. Click Distance to change the distance of hatches.
Refer the general instructions provided in Changing the Drawing Environment
and Making Measurements on page 90 to change the color angle, and distance of
hatches.

Showing and Storing
When you have completed your work on the Annotation MI drawing file, you may
want to see what this drawing would look like in Annotation or in Creo Elements/
Direct Drafting.
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Showing the Drawing in Annotation Mode
To show the drawing in Annotation mode:

• Click Annotation and then, in the Show group, click the As Annotation check
box.

This mode displays your Hide Geometry operations.

Showing the Drawing in Creo Elements/Direct
Drafting Mode
To show the drawing in Creo Elements/Direct Drafting mode:

• Click Annotation and then, in the Show group, clear the As Annotation check
box.

This mode ignores any Hide Geometry operations but displays any Prev Delete and
Final Delete operations.

Storing the Drawing for Further Use in
Annotation
To store the drawing for further use in Creo Elements/Direct Annotation:

1. Click File ▶ Save.
2. Specify the path and the file name to save the current Annotation MI drawing.
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This chapter describes how to print and plot drawings and create screen dumps.
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Using the Print Manager
Creo Elements/Direct Drafting spools all plots and screen dumps either to the
Print Manager or to the Clipboard, and not directly to an output device.
The Print Manager controls device selection, configuration, and spooling for the
printers and plotters on your system. Once you send a plot from Creo Elements/
Direct Drafting to the Print Manager, the Print Manager takes over the process of
producing the final output. By setting REQUEST_PRINT_SETUP, you can
directly access the Print Manager's setup dialogs each time you plot or screen
dump.
The Clipboard temporarily stores a plot or screen dump so that it can be
electronically transferred or "pasted" in another application.

Note
Depending on the output device or devices on your system, the Print Manager
may allow you to set several printer or plotter options in addition to those
offered by Creo Elements/Direct Drafting. Refer to your Windows
documentation and hardware manuals for information on configuring your
printer or plotter to work with Windows.

Creating a Print Configuration
To facilitate the creation of consistent print or plot output, Creo Elements/Direct
Drafting enables you to create any number of print configurations.
To create a print configuration:

1. Click File ▶ Print ▶ Print Setup.

Alternatively, click Print Preview and Print on the Quick Access Toolbar
or press CTRL+P.

The Print dialog box opens.
2. Define the settings for the new print configuration.

These settings are discussed in the following sections of this chapter.
3. In the Print configuration area, click Settings.

The Print Configurations dialog box opens.
4. Type a name for the print configuration in the text box and click Add to add

this new print configuration name to the list of print configurations.
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Creo Elements/Direct Drafting prompts for confirmation to add the print
configuration to the list.

5. Click OK.
6. To save the print configuration for future use, select it and then, click Store.

The Store Print Configurations dialog box opens.
7. In the Name box, type a name for the print configuration file (For example,

my_print.m) for your print configuration file.

Note
This filename does not have to be the same as the print configuration
name. However, ensure that the filename is readily identified.

8. Click Save.
9. Click Close.

Example of a Print Configuration
An example of a Creo Elements/Direct Drafting print configuration follows:
{ User specific customization }

WIN_PRT_MGR PAPER 'a3' ORIENTATION LANDSCAPE COPIES 1 END

PLOT_SCALE AUTO

PLOTTER_TYPE ADD MSWINDOW_GDI_PRINTER PRT_DRIVER 'HP LaserJet
1100' 'department_1' END

WIN_PRT_MGR PAPER 'a4' ORIENTATION PORTRAIT COPIES 1 END

PLOT_SCALE AUTO

PLOTTER_TYPE ADD MSWINDOW_GDI_PRINTER PRT_DRIVER 'HP DeskJet'
'department_2' END

WIN_PRT_MGR PAPER 'a4' ORIENTATION LANDSCAPE COPIES 1 END

PLOT_SCALE AUTO
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PLOTTER_TYPE ADD MSWINDOW_GDI_PRINTER PRT_DRIVER 'HP LaserJet
1100' 'department_3' END

PLOTTER_TYPE 'department_3'

{ plot it }

PLOT 0,0 0 all BW_IMG NORM_VIDEO

The settings in this customize_p.m print configuration file imply the
following:

• One copy of the drawing is printed to A4 paper in landscape orientation.
• The drawing is scaled to fit.
• The PLOTTER_TYPE variable is set to department_3. This is the printer

that will be used as the output device.
• The entire drawing is printed in normal (as opposed to inverse) video.

Reusing a Saved Print Configuration
When you quit Creo Elements/Direct Drafting, the system automatically saves
your current print settings. These settings are used when you start Creo Elements/
Direct Drafting again.
You can see and modify your current configuration file by opening
<application data path>\PTC\Creo Elements Direct Drafting
[version]\[version]\print_configurations\current_print_
cfg.m.
You can also use existing or create your own configuration files. If you use the
name convention (print_cfg_<configuration name>.m) for your own
configuration files and place them in the print_configurations
subdirectory, these files appear in the Print dialog box as a Print configuration. The
configurations that you create with the Print dialog box are automatically stored in
this subdirectory when you store your configuration.
To reuse binary legacy print configuration files (with file name <print
configuration>.cfg) from a CoCreate Drafting version < 13.00:

1. Click File ▶ Print ▶ Print Setup.

The Print dialog box opens.

Alternatively, press CTRL+P to open the Print dialog box.
2. In the Print configuration area, click Settings.
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The Print Configurations dialog box opens.
3. Click Load.

The Load Print Configurations dialog box opens.
4. Select the print configuration file and click Open.

The print configurations appear in the Print Configurations list.
5. Select the required print configuration.
6. Click Close.

The Print dialog box settings change to the settings defined for the loaded print
configuration.

Defining the Print or Plot Settings
Before printing or plotting a drawing, you should define exactly what you want to
print or plot and how the drawing will be printed or plotted.

Setting the Plot or Print Destination
Creo Elements/Direct Drafting provides a wide range of printer or plotter output
options. After you select an option, you can send plots and screen dumps either to
the Windows Print Manager or to the Clipboard. Send plots to the Print Manager
for output on the system's default printer or plotter. Send a plot to the Clipboard if
you want to insert it in another Windows application.

Note
Creo Elements/Direct Drafting automatically derives the extension for the
output file according to the selected printer or plotter.

Selecting a Printer or Plotter
To set a printer or plotter:

1. Click File ▶ Print ▶ Print Setup.

The Print dialog box opens. The Printer tabbed page opens by default.

Alternatively, press CTRL+P to open the Print dialog box.
2. In the Printer area, select the printer or plotter in the Name box.

Note the boxed plus sign beside some generic options.
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Expand the plus sign and select the model number, if required.
3. Click Properties and set the properties (such as the paper size and the

resolution) of this printer or plotter.
If the printer or plotter you want to use is not included in this list, use standard
Microsoft Windows techniques to install, set up, and configure this printer or
plotter.

Note
Refer to your Windows documentation and hardware manuals for information
on configuring your printer or plotter to work with Windows.

Routing the Print or Plot Output to a File
To send the print or plot output to a file:

1. Click File ▶ Print ▶ Print Setup.

The Print dialog box opens. The Printer tabbed page opens by default.

Alternatively, press CTRL+P to open the Print dialog box.
2. In the Printer area, click the Print to File check box.
3. In the Destination box, type the file path and file name.
Ensure that you match the printer or plotter with the format of the output file. For
example:

• If you want to create an HP-GL file, select an HP-GL compatible plotter.
• If you want to create a PostScript file, select a PostScript printer.
• If you want to create a PDF file, select the PDF Generic option.
After you click Print, the file is saved at the destination path with the specified
name.

Stop on Error
If you want Creo Elements/Direct Drafting to warn you when drawings do not fit
on the selected paper size, click the Stop On Error check box on the Printer tab of
the Print dialog box. Creo Elements/Direct Drafting checks:

• Whether the size of the drawing fits on the selected paper format.
• When printing Annotation drawings, whether the largest one matches the

chosen plot configuration. If not, Creo Elements/Direct Drafting warns you
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with the Plot doesn't fit on paper message and you can stop the
process.

Setting the Paper Size and Number of Copies
To set the paper size and number of copies for printing or plotting:

1. Click File ▶ Print ▶ Print Setup.

The Print dialog box opens. The Printer tabbed page opens by default.

Alternatively, press CTRL+P to open the Print dialog box.
2. In the Paper area, select the paper size in the Format box.

To set a custom paper size, select Custom size in the Format box and define
the size of the paper.

3. If you have a multi-sheet drawing, click the Use sheet format check box to
automatically set the format and orientation of each sheet based on the sheet
size.

4. To set the number of copies, type or select the number of copies in the Copies
box.

Setting Orientation
To set the paper orientation:

1. Click File ▶ Print ▶ Print Setup.

The Print dialog box opens. The Printer tabbed page opens by default.

Alternatively, press CTRL+P to open the Print dialog box.
2. In the Orientation area, click Portrait or Landscape.

Note
If you set the paper size such that the height and width are equal, the
orientation is set to landscape by default.

Positioning Your Drawing
To position your drawing:

1. Click File ▶ Print ▶ Print Setup.
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Alternatively, press CTRL+P to open the Print dialog box.
2. On the Drawing tab, in the Position area, click any of the following:

• Center (default setting) to position your drawing at the center of the paper.

Creo Elements/Direct Drafting places the bounding box centered on the
paper.

• Left to position your drawing at the lower left corner prior to printing or
plotting.

Creo Elements/Direct Drafting places the bounding box in the lower left
corner of the paper.

You can specify an offset in the X direction and in the Y direction in the X Offset
box and Y Offset box, respectively, for Center and Left. The print or plot output is
moved accordingly in the X direction and/or Y direction.
These offsets are interpreted in terms of the current length unit (such as mm) set
up for your Creo Elements/Direct Drafting environment.

Setting a Rotation Angle
To rotate the drawing output to the printer or plotter:

1. Click File ▶ Print ▶ Print Setup.

Alternatively, press CTRL+P to open the Print dialog box.
2. On the Drawing tab, in the Position area, type the angle of rotation in the

Rotation box.
The angle of rotation is interpreted in terms of the current angular units set up for
your Creo Elements/Direct Drafting environment.

Selecting the Drawing Range for Printing or Plotting
To select the drawing range for a print or plot:

1. Click File ▶ Print ▶ Print Setup.

Alternatively, press CTRL+P to open the Print dialog box.
2. On the Drawing tab, in the Range area, click any of the following:

• All (default setting) to print or plot the entire drawing - irrespective of the
current viewport contents.

• Click Sheet to print each Annotation sheet on a separate page. See Stop on
Error on page 611 for information on a possible warning.

• Click Viewport to print or plot the contents of the current viewport.
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For example, if you are currently viewing a part, only the elements of that
part contained within the window of the current viewport will be printed or
plotted.

• Click Box to print or plot a specific area of a viewport.

Click Pick and then use your cursor in the drawing viewport to specify two
opposite corners of a box. Only the contents of the boxed area will be
printed or plotted. For example, suppose you are currently viewing a part,
and the other parts or elements exist in the same area, but are not
displayed. If you click Box, all the drawing elements existing in the boxed
area (both displayed and hidden), are plotted.

Setting the Plot Scale
You can set a scale factor for output or automatically scale the drawing as large as
possible within the limits of your paper.
To set the print or plot scale factor:

1. Click File ▶ Print ▶ Print Setup.

Alternatively, press CTRL+P to open the Print dialog box.
2. On the Drawing tab, in the Scale area, click any of the following:

• Click Fit to scale the print or plot output (as large as possible) within the
limits of the defined paper size.

• Click Factor (default setting) and type the required scaling factor in the
Factor box.

The entire print or plot output is scaled, but dimension values are not
affected. Figure 202. Operation of Print/Plot Scale on page 614 shows the
operation of print or plot scale.

Figure 202. Operation of Print/Plot Scale
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If you set the plotting scale such that the drawing is too large for the paper,
Creo Elements/Direct Drafting warns you at the start of a plot by
displaying the maximum scale possible. Pressing ESC aborts the plot and
allows you to reset the plot scale. Otherwise, press SPACE BAR and the
plot will continue, cutting off elements outside the paper format.

Setting the Content of the Print or Plot Output
Creo Elements/Direct Drafting enables you to specify what will be included in the
print or plot output.
To set the content of the print or plot output:

1. Click File ▶ Print ▶ Print Setup.

Alternatively, press CTRL+P to open the Print dialog box.
2. On the Drawing tab, in the Content area, click any of the following:

• Drawing to include all entities except construction lines in the print or plot
output.

Note
Spotlights for the current part are omitted. The drawing appears as a
normal drawing irrespective of the screen status (that is, the plot is
unaffected by the Show functions).

• Current Show to print or plot the drawing as shown in the viewport.

a. Select a viewport in which you can set your own drawing conventions.
b. Use the Show functions to set the desired attributes.
c. Click Current Show.

The subsequent plots will contain whatever drawing conventions you have
selected in the current viewport.

Note
Drawing and Current Show only determine how the plot appears. The plotting
area is unaffected.
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Defining Color Settings
Creo Elements/Direct Drafting allows you to define the True Color, Plot
Transformations and True Color & Screen Trans settings for your printer or plotter
environment.
To define the color settings of you drawing:

1. Click File ▶ Print ▶ Print Setup.

Alternatively, press CTRL+P to open the Print dialog box.
2. On the Drawing tab, in the Colors area, click Pens.

The Plot Transformation dialog box opens.
3. In the Plot Transformation list, click True Color, or Plot Transformations, or

True Color & Screen Trans.

True Color
In the Plot Transformations list, select True Color to create a color plot of your
drawing that is suitable for output to color output devices capable of producing
color rastering.
This feature is available on PostScript Level 2 printers and HP-GL/2 printers. This
means, for example, if you have access to an HP DesignJet 650C color printer you
can print any number of colors up to the capability of the printer.

Note
If you have a drawing that contains elements in the color white and specify
truecolor plotting, the elements are drawn in white. Normally, when sending
drawings to a pen-plotter, the white elements on the screen are converted to
black.

Plot Transformation
In the Plot Transformation list, select Plot Transformations.
The following settings are available:
Edit Displays a separate Pen Format dialog box to set a

custom plot transformation map.
Reset Restores the default Plot Transformations settings.
Default Color Applies a default color-to-pen assignment map.
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Default B/W Applies a monochrome color-to-pen assignment map.
Default GDI Applies a 125 – color plot pen color-to-pen assignment

map.

To set up the Plot Transformations map:

1. In the Plot Transformations map, click the row you want to change.

The selected row is highlighted.
2. Click Edit.

The Pen Format dialog box opens.
3. In the Drawing area of the Pen Format dialog box:

a. In the Linetype box, select a "from" linetype and then, in the To box, select
a "to" linetype to which you want to map the "from" linetype. For
example, if you want all dashed lines in the drawing to be plotted as dotted
lines, map "from" dashed "to" dotted.

If you want to map all linetypes in the drawing to the associated linetypes
on the plotter, click the All Linetypes check box.

b. Click the Color Range check box and then, in the From (RGB) box, type the
RGB value for a "from" color. In addition, in the To (RGB) box, type the
RGB value for a "to" color to which you want to map the "from" color.

If you want to map all colors in the drawing to the associated colors on the
plotter, click the All Colors check box.

c. In the Pen Size box, type a "from" pensize and then, in the To box, type a
"to" pensize to which you want to map the "from" pensize. For example, if
you want pensize 0.3 in the drawing to be plotted by a 0.45 pen on the
plotter, type 0.3 in the Pen Size box and 0.45 in the To box.

If you want to map all pensizes in the drawing to the associated pensizes
on the plotter, click the All Pen Sizes check box.

Assigning a Specific Pen to a Given Linetype or Color
Combination
To assign a specific plotter pen to a given linetype or color combination in the Plot
Transformations map:

1. In the Color box of the Drawing area, select the color.
2. In the Linetype box of the Drawing area, select the linetype.
3. In the Linetype box of the Plotted As area, select the linetype to be plotted.
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If you want to print or plot using the linetype that is used in the drawing, click
the Same Linetype check box.

4. In the Pen box, type or select the pen number.
5. In the Pen Width box, type a pen width.

If you want to print or plot using the pen width that is used in the drawing,
click the Same Pen Width check box.

6. Click OK to add the changed row to the Plot Transformations map.
For example, assume that you want to use a 0.3 mm blue pen to plot all dashed
blue lines of the drawing. This pen is pen # 5 in your plotter.

1. In the Linetype box, select the dashed linetype and in the Color box, select
Blue in the Drawing area of the Plot Transformations map.

2. In the Plotted As area, click the Same Linetype check box.
3. In the Pen Width box, type 0.3.
4. In the Pen box, type or select the pen number 5.

Note
The difference between line width (pen size) and line size is explained in Line
Width vs. Line Size on page 95.

Repeat this procedure till the Plot Transformations map contains the required map
of colors, linetypes, and associated plotter pens.
To restore the Plot Transformations default settings, click Reset.
To restore the default color settings, click Default Color.

Setting the Linetype Length
Creo Elements/Direct Drafting allows you to set the pattern length of the linetype
for the plot or print using the Plot Linetype Length dialog box.
To open the Plot Linetype Length dialog box:

1. Click File ▶ Print ▶ Print Setup.

Alternatively, press CTRL+P to open the Print dialog box.
2. On the Drawing tab, in the Colors area, click Pattern Length.

The Plot Linetype Length dialog box opens.
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You can set the pattern length for any of the seven broken linetypes. Each broken
linetype is a pattern repeated many times to produce a line. You can specify the
length of each pattern and thus alter the fineness of the line. Figure 203. Different
Linetype Lengths on page 619 shows two DASH_CENTER lines drawn with
different linetype lengths. The arrow displays the linetype length.

Figure 203. Different Linetype Lengths

The seven broken linetypes that you can set are:

• DASHED
• LONG_DASHED
• DOT_CENTER
• DASH_CENTER
• PHANTOM
• CENTER_DASH_DASH
• DOTTED
To set the linetype length and minimum space for individual broken linetypes in
the Plot Linetype Length dialog box:

1. In the Linetype name column, click the required linetype.
2. In the Length box, type or select a segment length for each broken linetype.
3. In the Min. Dist. box, type or select the minimum distance (the gap) between

the broken line segments.
4. Click Apply.
5. Click OK.
Alternatively, to set all broken linetypes to the same segment length and the same
minimum distance, specify the segment length and minimum distance and click
Apply to All in the Plot Linetype Length dialog box.

Printing and Plotting 619



Setting the Picture Color
Creo Elements/Direct Drafting allows you to set the output of the image to be
either Color or Black & White when printing or plotting a drawing that includes
embedded pictures.
To set the picture color:

1. Click File ▶ Print ▶ Print Setup.

Alternatively, press CTRL+P to open the Print dialog box.
2. On the Pixmap tab, in the Pixmap area, click Color or Black & White.

Retaining or Inverting Black and White Pictures
To reverse the black and white pictures:

1. Click File ▶ Print ▶ Print Setup.

Alternatively, press CTRL+P.
2. On the Pixmap tab, in the B&W Pixmap area, click Reverse.

Setting Picture Quality
To set the picture quality:

1. Click File ▶ Print ▶ Print Setup.

Alternatively, press CTRL+P.
2. On the Pixmap, in the Pixmap Quality area, click any of the following:

• Best for high quality.
• Low for draft quality.

Previewing a Print or Plot
Creo Elements/Direct Drafting allows you to view print or plot output on your
screen using the Plot Preview system viewport. You can open the viewport after
you select all the necessary print settings (as a last step before printing), or open it
to view while working on your drawing.

1. Click File ▶ Print ▶ Print Setup.

The Print dialog box opens.

Alternatively, press CTRL+P to open the Print dialog box.
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2. Click the Show Preview check box.

The Plot Preview system viewport appears.
3. Select a color setting for the Plot Preview viewport:

• Original to preview color printer or plotter output.
• Grayscale to preview black and white printer or plotter with dithering

capability output.
• B&W to preview black and white printer or plotter output.

The Plot Preview viewport is visible till you clear the Show Preview check box.

Starting a Print or Plot Job
When you have selected or specified all of the required print or plot output
settings, click Print to send your drawing to either the Print Manager or to the
Clipboard or to a file.
The Print Manager queues the drawing to the current default output device. The
Clipboard temporarily stores the drawing so that it can be electronically pasted in
another application.

Printing or Plotting Multiple Drawing Files
To plot or print multiple Creo Elements/Direct Drafting drawing files from the
Creo Elements/Direct Drafting File Browser:

1. In the Windows file browser, select the drawing file to be printed or plotted
and right-click.

2. Click Print.

Dumping the Creo Elements/Direct
Drafting Screen
Creo Elements/Direct
To copy the entire Creo Elements/Direct Drafting screen to the Clipboard, press
ALT & Print.
Then paste the screen dump in a graphics application of your choice for further
processing. For example, in Microsoft® Paint, click Edit ▶ Paste to paste the Creo
Elements/Direct Drafting screen dump to the drawing area.
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Writing a Creo Elements/Direct Drafting Screen
dump to an Output File
Optionally, you can write a screen dump of your current Creo Elements/Direct
Drafting window directly to an output file.
See Exporting a Picture on page 547 for instructions.

Further Information
For further technical information about plotting or dumping, refer to the Creo
Elements/Direct Drafting help system.
Type help plot, or help bitmap_to_file in the Creo Elements/Direct
Drafting user input line and press ENTER.
Creo Elements/Direct Drafting displays further information about plotting or
dumping.
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Introduction

Roadmap
Read this chapter first. It provides an overview of the Parametric Design software,
introduces several important terms, and directs you to the sections that describe
how to start and use Parametric Design.

What is Parametric Design?
The Creo Elements/Direct Drafting Parametric Design module adds powerful
parametric and constraint-based modeling capabilities to Creo Elements/Direct
Drafting.
Parametric modeling allows you to attach "names" or parameters to drawing
dimensions, such as radii or lengths, and then to change the drawing by changing
the numerical values or expressions associated with these parameters.
Constraint-based modeling allows you to specify geometric properties and
relationships. The software then modifies the part so that these constraints are
satisfied. For example, you can say "these two elements should be tangent," or
"this line should be horizontal," or "this dimension should have such-and-such a
value."
Parametric Design combines both types of modeling into a module that allows you
to quickly and easily perform modifications that are beyond the scope of the basic
Creo Elements/Direct Drafting Modify toolset.
With Parametric Design module you can use any existing part as a template for
generating variations or a family of parts that otherwise would have to be drawn
from scratch. Figure 204. Master Part & Three Variations on page 625 below
shows a "master" part and three variations that were generated with Parametric
Design. Once constraints and parameters were defined for the master part with
Parametric Design, each variation was generated by modifying only one
dimension on the master.
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Figure 204. Master Part & Three Variations

Parametric Design provides these capabilities without changing existing Creo
Elements/Direct Drafting functionality or procedures. Loading the Parametric
Design module does not change any existing Creo Elements/Direct Drafting
menus or commands, so your drawing methods need not change to use it. You can
use any existing Creo Elements/Direct Drafting part with Parametric Design, and
parts generated by Parametric Design will be fully compatible with Creo
Elements/Direct Drafting. The constraint and parametric information generated by
the software is added directly to the master part (as info text), and is automatically
stored/recovered along with the part.

Starting Parametric Design Module
To enable the Parametric Design module in Creo Elements/Direct Drafting:

• Click File ▶ Modules ▶ Parametric.
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Basic Working Methods

For the Draftsperson
Parametric Design gives the Draftsperson a simple, efficient interface for
generating variations from pre-constrained parts. When a pre-constrained part is
loaded in Creo Elements/Direct Drafting, all parameters that can accept value
input appear in a table on this menu along with their current values. To generate
variations of the part, the Draftsperson sets the appropriate values for any or all of
these parameters and then uses the Solve group buttons on the Parametric tab.
Parametric Design then generates the variation, which can be saved, copied, or
modified further.

For the Designer
The Designer or Engineer uses Parametric Design to assign, evaluate, and modify
constraints and parameters on that part. Once the constraints and parameters are in
place, the Solve group buttons on the Parametric tab can be used to generate
variations. The typical steps needed to constrain a part are as follows:

Preparation
Model inconsistencies can cause unexpected results in Parametric Design and
should usually be resolved before assigning constraints to a part. The following
buttons in the Modify group on the Parametric tab check parts for inconsistencies
such as extra points and duplicated or stacked geometry; and optionally adjusts or
removes the offending elements:

• Clean Pnt

• Clean Duplicate

• Clean Stacked

Parametric Design operates on drawing elements within its zone. The zone may

contain an entire part or selected elements of a part. The buttons under Zone
in the Modify group on the Parametric tab select elements for the zone.

Assign Constraints
Before you can use Parametric Design to generate variations from a part,
constraints must be assigned to the part. These constraints must be sufficient to
tell the parametric solver exactly what to do with each element in the zone to
generate the variation. If elements are not constrained or are incorrectly
constrained, the solver is not able to generate the variation.
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Constraints may be assigned manually or automatically. Typically, the designer
uses a combination of methods as follows:

1. Assign a full set of constraints that completely define the part's current
configuration:

a. Manually assign a few reference constraints and perhaps symmetry line
constraints to important elements in the part.

b. If large sections of the part's geometry can move together as a single unit,

collect these sections into rigid bodies using Rigid in the Create group
on the Parametric tab. This can greatly reduce the number of constraints
needed on the part.

c. Use Complete to automatically assign a reasonable set of constraints to the
remaining elements.

2. If you used the Solve group buttons on the Parametric tab to generate

variations, check the potential result or results by means of Preview. You
may need to modify certain constraints to better reflect your design intentions.

3. Modify constraints as needed to generate the desired variation from the current
configuration. You may add or delete constraints or change the values
associated with existing constraints to come up with the variation you want.

To manually assign or modify constraints:

1. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
2. In the Action area, click Assign.
3. In the Type box, select a constraint type (for example, Angle, Dimension, Size).
4. Click Apply.
5. Select the drawing elements to receive the constraint.

Iconic call-outs are used to label constraints as they are assigned.
Angle, distance, and dimensional constraints, among others, may be given
parametric as well as numerical values when you assign them. A parametric value
may be a text label, a Creo Elements/Direct Drafting expression, or a macro name
which is resolved at solve time to generate a numeric value for the constraint.
Parameters can perform math functions and can reference other parameters when
they are resolved. You are not required to use parametric constraints, but they are
an especially powerful feature of the software.
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Solve for the Variation
After you have constrained your part, use the Solve group buttons on the
Parametric tab to solve the set of constraints and generate the variation. Parametric
Design attempts to create new geometry that fits the constraints by adjusting sizes,
locations, and relationships of elements in the part. If the current set of constraints
is inconsistent or incomplete, the solver can selectively highlight the offending
areas. A variation can be previewed before actually being generated, and it can be
generated either as a copy of or as a replacement for the original geometry.

Learning to Use Parametric Design
The best way to learn Parametric Design is to work with the software and consult
this guide as needed for clarification. The Examples on page 715 chapter provides
several work-along examples that we recommend you to try. To encourage you in
this, we have included the parts used in the examples along with the Parametric
Design software. You need only load the parts into Creo Elements/Direct Drafting
to begin working with the examples.

Generating Variations

Roadmap
Read this chapter to learn how to generate variations from parts that have already
been constrained and parameterized with Parametric Design. To learn how to
assign constraints and parameters, go on to Working with Parametric Design on
page 633 after you read this chapter.
Parametric Design provides an efficient interface for generating new parts
(variations) from a master part that has already been processed through Parametric
Design. Once you load a master part into Creo Elements/Direct Drafting, you need
only supply a few parameter values and use the Solve group buttons on the
Parametric tab to generate a particular variation. Again, the basic working method
for generating a variation of a pre-processed master part is:

1. Load the master part.
2. Click Parametric and then, in the Show group, click Current.

The Current Constraints window opens.
3. Change parameter values as required in the parameter value table.
4. Use the Solve group buttons on the Parametric tab to generate the variation.
The following sections describe each step.
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Load the Master Part
A master part can be any Creo Elements/Direct Drafting part that has Parametric
Design constraint and parameter data associated with it. This data is generated by
the Designer using Parametric Design and is automatically stored along with the
part when it is saved to a file. Parametric Design data is loaded back into Creo
Elements/Direct Drafting whenever you load the master part with the standard
Creo Elements/Direct Drafting Load functions.
Parametric Design operates only on the current Creo Elements/Direct Drafting
part. If you load a drawing that contains several parts, ensure that the part you
wish to use as the master is the current Creo Elements/Direct Drafting part. Use

the Creo Elements/Direct Drafting Part button under Edit in the Parts
group on the Structure tab to select a particular part to be current.
To confirm that the part you have loaded has the necessary Parametric Design data
associated with it to be a master part, check the parameter value table in the
Current Constraints dialog box. If no entries appear in the table after you load a
part or make it the current part, it cannot be used as a Parametric Design master
from this menu.

List the Current Constraints
To create variations from a master part, open the Current Constraints dialog box

by clicking Current in the Show group on the Parametric tab. Then click
Advanced to open the Advanced window that displays the parameter value table.
When you load a master part into Creo Elements/Direct Drafting, one or more
entries appear in this table. Each entry contains a parameter name and a value. The
parameter names correspond to elements in the master part that you can modify.
The value entries represent the values that will be assigned to the corresponding
drawing elements when you next use the Solve group buttons on the Parametric
tab.

Change Parameter Values
Use the parameter value table to specify how variations of the master part should
be generated. When you change the value for a parameter listed in the table, you
indicate Parametric Design to modify all elements in the master part that are
constrained to depend on this parameter. The constraints on the part determine
exactly what modifications will occur. The changes are not actually made until
you click the required button in the Solve group on the Parametric tab.
To change the value for a parameter, simply select its entry from the table and
enter the new value from the keyboard. If there are too many entries to view at
once, use the scroll bar beside the table. The type of value you give (linear,
angular, or point) depends on the type of the parameter. Usually, the parameter
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name is descriptive enough to indicate what type of value is expected. It is easy to
tell if a point value is expected, because point parameters take up two slots in the
table. The upper slot contains the x coordinate of the point and the lower slot
contains the y coordinate. Note that you still enter point values using the standard
Creo Elements/Direct Drafting x,y format.
If you need more specific information about the correspondence between
parameter entries in the table and the elements in the master part, click Show in
the Current Constraints dialog box. When you click Show, elements in the master
that have parameters assigned to them are highlighted or marked with icons as
described below.
If a parameter is associated with a dimension in the part, the parameter name is
appended to the corresponding dimension text and both are highlighted (in CYAN
by default). By examining the dimension, you can tell whether the parameter
requires linear or angular input.
Parameter names may also be associated with several kinds of geometric
constraints that have been assigned to the master part by a designer. If any of the
parameters in the value table are associated with geometric constraints and you
click Show, these constraints are marked with icons as well as with the parameter
name. Each type of geometric constraint has a unique icon to identify it. Icons and
parameter labels are drawn in CYAN by default. Your current text font is used to
display the parameter names. Consult Constraint Types on page 655 for complete
information on geometric constraints, their icons, and the types of values to be
supplied to each.
The Show highlighting is removed whenever you click the Solve group buttons to
generate a variation.
Alternatively, to remove the highlighting:

1. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
2. Click Clear.
3. In the Type box, select All Types.

Note
If the icons produced by Show are too large or too small, you can resize them
using the Icon Setting dialog box.
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Solve for the Variation
Once you have filled the parameter value table, use Preview, Keep, or

No Keep in the Solve group on the Parametric tab to create a variation with
the desired values.

Preview

By default, the solver works in Preview mode. The variation is computed, but
is not actually created. Instead, an outline of the variation is superimposed over
the current part. This gives you a good idea of what the new variation will look
like without creating any new geometry or overwriting any existing geometry. If
the preview indicates that the new variation is acceptable, you can actually create

the new variation by re-solving with Keep or No Keep. The preview lines

drawn by Preview are removed when you click OK.

Keep

Keep generates the variation and inserts it into the current part as a modified

copy of the original part. When you click Keep, the solver computes the
variation and temporarily overlays it onto the current part so that you can see what

it looks like. If the variation is not what you want, click OK or Undo
immediately to restore the original part. If the variation is OK, click a reference
point for moving the new part, and then drag it to the desired location. After

you've inserted as many copies as you want, click OK. The overlaid variation
is removed, and your original part is now restored.
Depending on how the master part was originally constrained, elements of the
master such as construction geometry and dimensioning may not appear in copies

made with No Keep. Also, the copies are not normally affected by subsequent
use of the Solve group buttons on the Parametric tab. To change any of these
behaviors, you will most likely need to modify the zone memberships and/or
constraints in the master part. See Working with Parametric Design on page 633
for details.
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No Keep

Use No Keep if you want the solver to replace your current part with the

variation. If the result of the solve is not what you expect, click Undo
immediately to restore your original part. You can continue to modify the part by
entering new values into the parameter table and re-solving.

Saving and Restoring the Parameter Value Table
In the Current Constraints dialog box, click Save and Input to write out the current
parameter value table to a file and later restore it. This feature lets you build a
"library" of value tables that can be used to drive the master part. The advantage
of this is that a series of standard parts based on a single master part can be stored
as a single MI file (the constrained master part) and a collection of parameter
value files. This arrangement takes up much less disk space than if an individual
MI file were stored for each part in the series. To recreate any member of the
series, you need only load the master part, Input the desired parameter value table,
and Solve.

Note
When the parameter value table is written out, all Parametric Design
parameters for the master part are written to the file. A number of these
parameters may be expressions, which are used by the software, but do not
appear in the table. Don't modify or remove these parameters from the output
file!

Save the Parameter Value Table
To save the current parameter value table to a file:

1. Click Save in the Current Constraints dialog box.

The Store dialog box opens.
2. In the Name box, type the name of the file to write out at the prompt.
3. Click Save.

Restore a Parameter Value Table
To input a parameter value table:

1. If necessary, Load the master part that the value table file refers to.

To ensure that the master is the current part:
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a. Click Structure and then, in the Parts group, click Edit.

b. Click Part.
2. Click Input in the Current Constraints dialog box.

The Load dialog box opens.
3. In the Name box, type or select the name of the parameter value file to input.
4. Click Open.
5. To apply the values from this table to the part, click Solve.

Creating a Parameter Value Table by Hand
When you save a parameter value table, the file generated is an ASCII macro file
that contains one PD_PARAM_FIX command for each entry in the table, e.g.,
PD_PARAM_FIX 'Width' 37.5. It is relatively easy, therefore, to build your
own parameter value tables outside of Creo Elements/Direct Drafting using an
ordinary text editor. When writing a value table file by hand, keep the following
points in mind:

• It may be very helpful later on if you include comment lines in your file that
identify the master part this file applies to!

• Make sure that each PD_PARAM_FIX command in your file corresponds to a
value parameter in the master part. If in doubt, save a parameter value table
with Parametric Design and use this file as a template for your own files.

• When Parametric Design saves a parameter value table, it includes several
macros in the output file which ensure that the values are restored in the
correct units. When you create this file by hand, you are responsible for
ensuring that the units used in the file correspond to the current Creo
Elements/Direct Drafting units when you restore it. One way to do this is to
include the macros used by Parametric Design in your own files (use any
system-created value table file as a template).

Working with Parametric Design

Roadmap
Read this chapter to learn how to assign constraints to a Creo Elements/Direct
Drafting part so that you or others can generate variations from it. If you only
need to know how to generate variations from a pre-constrained part, skip this
chapter and read Generating Variations on page 628 instead.
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This chapter is for Designers or Engineers who wants to incorporate Parametric
Design capabilities in their Creo Elements/Direct Drafting design environment.
We begin by describing the Parametric Design tools that the Designer should be
familiar with:

• Part preparation tools
• Constraint assignment tools
• Solving tools
The chapter concludes with several sections that cover the major applications for
these tools: developing master parts for repeated use by yourself or others, and
using Parametric Design as an extension of the Creo Elements/Direct Drafting
Modify commands to do one-time adjustments of complex parts.

Part Preparation
Before you assign constraints to a part, two preparation steps should be
considered. The first is to check the part for inconsistencies that can interfere with
constraint generation. The second is to select or restrict the portions of the part to
work with.
The following buttons on the Parametric tab handle preparation tasks:

• Clean Pnt (in the Modify group)

• Clean Duplicate (in the Modify group)

• Clean Stacked (in the Modify group)

• Rigid (in the Create group)
• Zone group buttons

• Zone (in the Show group)

Cleanup
Inconsistencies in a part (lines not quite parallel, small gaps between "tangent"
objects, duplicate elements, etc.) are relatively common, but can cause problems
for any program that must scan the part to extract information. To help eliminate
drawing inconsistencies, Parametric Design provides several tools that can do

limited "cleaning" of parts. Use Clean Pnt, Clean Duplicate, or Clean
Stacked to clean the parts.
These buttons are functionally independent from the remainder of the Parametric
Design software, and should be thought of as a "preprocess" for parts that are
submitted for parametric design. The Complete command and the Solve group
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buttons have additional part cleaning capabilities which are described in detail in
Advanced Topics and Tips on page 698. Each of the buttons described below
affects all geometry in the current part.

Points
Model points within a given distance of each other are merged, and the elements
attached to the merged points are adjusted (moved, stretched, or rotated) as
necessary to reflect the new positions of the points. For each set of points to be

merged, Clean Pnt chooses a location within the given tolerance and moves
the points there. In general, there is no way to accurately predict or control which
elements will be adjusted as a result of the merge. This should not be a limitation

in most cases, however, because the tolerance used is likely to be small. Clean
Pnt is most useful for removing small gaps between elements.

To use Clean Pnt:

1. Click Parametric and then, in the Modify group, click Clean Pnt.
2. Type a distance tolerance (current length units) in the user input line and press

ENTER.

Points within the given tolerance are marked with a *, and will be merged.
Elements that will be modified as a result of the merge are highlighted.

3. Click Confirm to merge the marked points and modify the highlighted
elements.

Duplicate

Clean Duplicate scans the part for duplicate elements and deletes them. The
button selects which element of a duplicate pair to delete. Elements are considered
to be duplicates if their model points are identical. An exception is made for
concentric circles (only): if the radii of concentric circles are within a given

tolerance, they are treated as duplicates. Normally, Clean Duplicate should be

used after Clean Pnt to clean up duplicate elements that may result from
merging model points.

To use Clean Duplicate:

1. Click Parametric and then, in the Modify group, click Clean Duplicate.
2. Type a distance tolerance (current length units) for concentric circles in the

user input line and press ENTER.
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Elements that will be deleted are highlighted.

3. Click Confirm to remove duplicate elements.

Stacked

Clean Stacked finds stacked lines and arcs in the current part and calls
Split to split them.

To use Clean Stacked:

1. Click Parametric and then, in the Modify group, click Clean Stacked.

Elements to be split are highlighted and the points to be used for the splits are
marked with a *.

2. Click Confirm to split elements.

Note
To clean up most common problems in a part, click Clean buttons in the
following sequence:

Clean Pnt
Merge disconnected points.

Clean Duplicate
Remove existing duplicates and those
caused by merging points.

Clean Stacked
Split overlapping elements.

Clean Duplicate
Remove duplicates caused by splitting.

Setting the Zone

The Parametric Design Solve commands and Automatic operate only on the
current Creo Elements/Direct Drafting part, and only on the portion of that part
which is included in a zone that you define. The zone mechanism allows you to
apply parametric design to sections of a part, leaving the remainder untouched. By
including only those sections that require parametric design in the zone, you can
often significantly reduce the number of constraints you need to assign as well as
shorten Solve times.
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The zone is implemented via Creo Elements/Direct Drafting info text. The buttons

under Zone in the Modify group on the Parametric tab are used to add or
remove the info text PD_ZONE to geometry elements in a part. Parametric Design
will only operate on elements that have the PD_ZONE info text. Sections of the
part that do not have this info fall outside the zone and are never modified by the
Solve group buttons, remaining fixed in place.
When you start Creo Elements/Direct Drafting, the zone is empty. By default,
elements you Create during an Creo Elements/Direct Drafting session are
automatically added to the zone, but geometry you Load from unconstrained files

is not included. The buttons under Zone in the Modify group on the Parametric
tab add and remove elements in the zone.

Adding Elements to the Zone
To add elements to the zone:

1. Click Parametric and then, in the Modify group, click Zone.

2. Click Add Single or Add Multiple.
3. Select the geometry to be included in the zone.

Add Multiple extends your selection to include all elements that share
model points with the elements you select. The Creo Elements/Direct Drafting
Select mechanism can be used with either button.

4. Click OK to conclude.
Elements are highlighted as you add them to the zone.

Note

Add Multiple and Add Single do not add dimensioning or subparts in
the master part to the zone. See Zone Gymnastics on page 703 for additional
information on adding to the zone.

Showing Contents of the Zone
To display the current contents of the zone:

1. Click Parametric and then, in the Show group, click Zone.
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Zone redraws all elements in the zone with the current highlight color and
linetype.

2. Click OK to remove the highlighting.

Removing Elements from the Zone
To remove elements from the zone:

1. Click Parametric and then, in the Modify group, click Zone.

2. Click Delete.
3. Select the elements that you want to remove.
If the elements have constraints attached to them, the constraints are not removed,
but the elements will not be modified by subsequent use of the Solve group
buttons on the Parametric tab.

Note

Delete only removes the elements from the zone that you click directly
and not elements that share model points with those you select. In other words,

Delete is analogous to Add Single rather than Add Multiple.

Defining Rigid Bodies
A final preparation step that can often help simplify the design process is to
identify areas of the part in which the geometry will not change in size or relative
position, but which should be able to move (translate, rotate) as a unit. By
defining these areas as rigid bodies, you can significantly reduce the number of
constraints needed, and make the design process more predictable.
A rigid body is a named collection of geometry that acts as if it is sufficiently
constrained to prohibit any relative change of size or position among the elements
collected into it. The geometry collected into a rigid body can only be translated
and/or rotated as a whole. To link a rigid body with other elements in a part, you
can assign constraints between these elements and any element inside the rigid
body.
Most Creo Elements/Direct Drafting geometry elements as well as hatching and
subparts can be included in a rigid body. Like zones, rigid bodies are implemented
via Creo Elements/Direct Drafting infos; entities with the info text PD_RIGID are
linked into rigid bodies. For more in-depth information on rigid body applications
see Advanced Topics and Tips on page 698.
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Rigid allows you to define and manipulate an unlimited number of rigid
bodies inside a given part. The options in the Generate Rigids dialog box are:

• Assign

• Show

• Clear

Creating a Rigid Body
To create a new rigid body:

1. Click Parametric and then, in the Create group, click Rigid.

The Generate Rigids dialog box opens.
2. Type a name for the new rigid body in the text box.

Ensure that you select a name that is not already in the rigid body list in the
Generate Rigids dialog box if you want to create a new rigid body.

3. Click Assign.
4. Select the geometry to be included in the rigid body.

Elements are highlighted as you add them to the rigid body. When you make
the first selection, the name of the new rigid body is added to the table.

5. Type the name of another rigid body in the user input line and press ENTER

or click OK to conclude.

Showing and Clearing Rigid Bodies
To show or clear an existing rigid body:

1. In the Generate Rigids dialog box, select the rigid body you want to show or
clear.

If there are too many entries in this table to view at once, scroll the table to
bring the correct entry into view.

2. Click Show or Clear to highlight or remove the rigid body from the list,
respectively.

3. Click OK.

Assigning Constraints
Constraints can be assigned manually or automatically to elements in the zone.
The constraint assignment tools include:
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• Commands:
Command Function
Assign Manually assign constraints to geometric elements.
Free Remove constraints from geometric elements.
Show Show existing constraints by displaying their icons.
Clear Remove selected constraint icons (but not the constraints

themselves) from the display.
Ban Remove selected constraints and prevent them from being

re-assigned by Complete.
Complete Automatically generates a reasonable set of constraints to

all remaining elements in the zone.

• Options:

Options limit the actions of Show, Clear, Free and Ban. Available options are:

Option Limiting Action
New Act only on constraints added by the most recent

Complete command. New must be used immediately after
Complete. Any intervening command converts new
constraints to "system" constraints. New only modifies the
actions of Show and Clear.

User Act only on constraints assigned manually by the user. If
the user modifies a system-generated constraint, it
converts to a "user" constraint.

System Act only on constraints generated by Complete and
unchanged by the user.

Used Act only on constraints actually used by the solver during
the most recent Complete or Solve command.

Unused Act only on constraints that were not used by the solver
during the most recent Solve command.

Banned Act only on constraints that have been banned by the
user; i.e., constraints that cannot be assigned by Complete.

Violated Act only on constraints marked "violated" by the most
recent Solve.

• Types:

These blocks specify the available constraint types. You must always specify a
type for Assign, Show and Clear. Types can also be used to limit the actions of
Free and Ban. A generic type, All Types, refers to all the available constraint
types. See Constraint Types on page 655 for a complete description of each
type.
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The following sections describe each of the constraint assignment commands.

Note
The default size and positioning of constraint icons may not be ideal. You can
resize or change the color of icons via the Icon Setting dialog box and

reposition them with Move Icon. To update the icon display after changing

their size or position, you can use the Creo Elements/Direct Drafting
Redraw button. The text labels that appear on some icons are drawn in the
current Creo Elements/Direct Drafting text font.

Assign
Use Assign to manually assign constraints to elements.
To assign a constraint:

1. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
2. In the Action area, click Assign.
3. In the Type box, select a constraint type (for example, Angle).
4. Click Apply.
5. Select the required geometry for the constraint type.
6. If applicable, type a value or parameter name for the constraint in the user

input line and press ENTER.

7. Continue to select geometry, select a new constraint type, or click OK.
When you successfully assign a constraint, one or more icons appear on the part to
identify the type and identification number of that constraint. The leader line of
the icon is drawn in the same linestyle as the element it references.

Note
When you use Assign to assign a constraint to a piece of geometry, the
constraint is bound to that element and goes with it whenever it is moved.
Thus, you can move elements in a part after assigning constraints without
invalidating the constraints. On the other hand, if you delete a constrained
element, all constraints on that element are removed along with it.
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Some constraint types can be given numeric or parametric values when they are
assigned. If you give a numeric value, the constraint will resolve to that value at
solve time. If you give a parameter name or expression, the constraint resolves to
the output of that parameter or expression at solve time. If you choose not to
supply either a value or parameter, the constraint resolves to the corresponding
value that is currently on the element at solve time. If a value or parameter name
is assigned to a constraint, that data will appear along with the constraint's icon
whenever it is displayed. See Parameters on page 679 for a full discussion of how
numeric values and parameters affect constraints.

Show and Clear
To assign and free constraints efficiently, it is important to know what constraints
are currently assigned. Show and Clear work with the limit-options and constraint-
type settings to selectively display and hide the icons and parameter labels of
constraints currently on the part. Neither function affects the constraints
themselves, just the display of their icons. Icons and parameter labels are
displayed in the current show color (PD_PREVIEW_COLOR) and size. Parameter
labels will use each dimension's text font for dimensional constraints and the
current text font for geometric constraints.
Show and Clear operate identically. To use either:

1. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
2. In the Action area, click Show or Clear.
3. In the Act On box, select an option to limit the function's effect, if desired.
4. In the Type box, select the constraint type to show or clear.
Show options are additive; subsequent calls to Show do not erase the icons that are
already on the screen, allowing you to build up the display. From time to time, as
the display gets crowded, you can erase some or all of the icons with Clear.
The following table provides some Show examples:

Show all constraints: Show, All Types
Show constraints set by
Complete:

Show, System, All Types

Show reference elements
set by the user:

Show, User, Refelem

Show angle and distance
constraints:

Show, Angle, Show, Distance

Erase all constraint icons: Clear, All Types
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Free
Free removes constraints from elements. To remove constraints:

1. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
2. In the Action area, click Free.
3. Use one of these methods to select constraints to free:

• Click the icon of the constraint to be freed.
• In the Type box, select a constraint type and then click the element itself.
• Select a limiting option in the Act On box and then a constraint type in the

Type box to remove the selected constraint from all elements in the zone.
For example, Free, User and Dimension removes all user-assigned
dimensional constraints.

4. Click OK or continue to select constraints for removal.
Whenever you free a constraint, the corresponding constraint icon is removed

from the display. If you free a constraint by accident, an immediate Undo
restores it.
Freeing a constraint does not prevent it from being re-assigned to the master by
Complete. If you want to prevent a constraint from being re-assigned by Complete,
use Ban instead.
To remove all constraints generated by Complete, click Free, select System, and
select All Types in the Action area, Act On box and Type, respectively.
To quickly remove all constraint and parametric data from the current part, use
click Free in the Action area and select All Types in the Type box. This command

requires a Confirm.

Complete
In order for the Solve group buttons to be able to generate a variation of a part,
every element in the part must be completely constrained. To manually assign a
complete set of constraints to a part of even moderate complexity would be time
consuming and prone to error. The Complete command provides an efficient
alternative. Complete scans the geometry currently in the zone and generates a
reasonable set of constraints that is sufficient to completely constrain the geometry
in its current configuration. In many situations, only a few constraints need be set
manually before running Complete, and a few more changed after Complete is run
to generate the variation. The Strategy for Assigning Constraints on page 644
section below explains how to best integrate the automatic and manual options.
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To use Complete:

1. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
2. In the Action area, click Complete.
3. Click Apply.

Parametric Design generates constraints. A series of messages is displayed to
inform you about the command's progress.

While generating constraints, Complete may add a number of point elements to
your part. These are needed to fix point-on or reference-point constraints, and
should not be removed from the part. By default, these points are drawn as green
×s, but you can easily change this to make them nearly invisible. See Parametric
Design Defaults on page 761 for details.
Complete takes into account any constraints that you may have manually assigned
to the part. If these constraints are inconsistent with one another, Complete may
not be able to successfully generate a complete set of valid constraints. In this
case, error messages and highlighting warn you about the problem and help you
track the cause. The error-trapping mechanism used by Complete is also used by
the buttons in the Solve group. See the Solver Errors on page 648 section later in
this Chapter for more information.

Ban
Ban works exactly like Free except that in addition to removing a constraint, Ban
prevents that constraint from being re-assigned by subsequent Complete
commands. Essentially, Ban forces a constraint to remain unset. To re-assign a
banned constraint, you must assign it manually with Assign.

Strategy for Assigning Constraints
Complete and the manual constraint tools are designed to be used together to
efficiently generate a workable set of constraints that lends itself to modification.
The following strategy will produce the best results in most situations:

1. Before running Complete, manually assign sufficient constraints to:

• "Anchor" the part. Do this by assigning Refelem or Refpoint constraints to
one or more elements that you know should not change position in the
variation. Anchoring helps to give Complete a frame of reference for
generating new constraints.

• Identify symmetry lines. Assign Symmline constraints to any elements that
serve as symmetry lines in the part. Complete uses these lines to generate
mirrored-element constraints. Parametric Design can also be configured to
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automatically recognize all lines with a particular color and linetype as
symmetry lines. You enable this capability by modifying the pd_
def.mac file. See Parametric Design Defaults on page 761 for details.

• If the part has several distinct components or views, make sure to anchor
each view sufficiently to prevent them from interfering with each other in
subsequent operations. You can do this either by assigning absolute
constraints (Refelem, Refpoint) to each view, or by constraining the relative
distance and/or orientation among all views with Distance or Angle
constraints.

• Collect suitable elements into rigid bodies whenever possible.
• Manually constrain any elements whose position or orientation is critical

in subsequent variations. For example, you should fix in place any
elements that definitely should not move in the variation. Alternately, you
could remove these elements from the zone before running Complete.

• In general, the more constraints you can assign by hand, the better for
Complete. This is especially true if the part is not fully dimensioned.

Note
Do not manually assign constraints designed to move elements away
from their current location before running Complete. For example,
don't assign a Vertical constraint to horizontal lines in the part before
you use Complete. Such constraints make the extraction process much
more difficult.

2. Run Complete to generate the remaining constraints needed to fully constrain
the master part in its current configuration.

3. When Complete finishes, examine the constraints on the part to make sure that
Complete hasn't made any poor decisions about assigning constraints. In
particular:

• Check dimensions. Make sure that constraints were actually assigned to
any dimensions that you might have to change. If not, add new constraints.
Also, be aware that different types of dimensions can cause Complete to
behave in different ways. For example, a horizontal dimension between
two points is quite different from a parallel dimension between the same
two points, even if both have the same value. The first case implies that the
second point is on a vertical line a given distance away from the first point.
The second case implies that the second point is on a circle of a given
radius centered at the first point. Complete takes these distinctions into
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account when generating constraints. When in doubt about the type of
linear dimension, redefine it.

• Check distance and size constraints. Distance constraints are usually
assigned as a last resort to position disconnected geometry that is
insufficiently dimensioned. The elements that receive distance constraints
may not be the ones you would normally choose to receive them.
Similarly, size constraints are normally only assigned to geometry that is
connected to other elements, but is still under-dimensioned. Again, a size
constraint may not be an appropriate choice.

• Check angle and slope constraints. Are elements with these constraints
supposed to be fixed at the given angle?

• Check the constraints on rigid bodies. Ensure that Complete hasn't over-
constrained each rigid body with regard to the rest of the part.

Inq Elem and Inq Icon in the Show group on the Parametric tab are
especially useful for examining constraints generated by Complete.

Inq Elem shows how the most recent Complete command or the buttons in
the Solve group determined the size and position of an element that you select.

When you click Inq Elem and then click an element, the icons for all the
constraints that determined the size and position of that element are displayed.
In addition, all geometry on which those constraints rely have their geometry
highlighted.

Inq Icon identifies the element or elements associated with a given
constraint by highlighting the element or elements. You identify the constraint
by clicking its icon.

4. If you make changes to geometry or constraints at this stage, re-run Complete.
Check the following points any time you re-run:

• If you removed any constraints, did you Free or Ban them? Complete is
likely to re-assign the same constraints unless you used Ban.

• If you added dimensioning to your part to eliminate the need for size or
distance or angle constraints, did you Free the old system constraints?
Complete will not automatically free existing system constraints and use
the dimensioning to generate new constraints. If you Free the system
constraints first, then the new dimensioning is taken into account.

5. Once you are satisfied that the part is completely and correctly constrained in
its current configuration, start to modify those constraints that will be used to
generate the variation or variation to ensure that the part responds as you
intend.
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Solve
All access to the Parametric Design solver is through the Preview, Keep,

and No Keep buttons in the Solve group on the Parametric tab.
When you click a button in the Solve group, the solver finds all the geometry
currently in the zone, and evaluates all constraints on that geometry. If all the
constraints can be successfully evaluated, the solver generates the variation
specified by the constraints. Depending on the option selected, the solver can
either create geometry for a new variation or simply preview it. The sections
below describe the buttons in the Solve group.

Preview

By default, Solve works in Preview mode. The variation is computed, but is
not actually created. Instead, an outline of the variation is superimposed over the
current part. This gives you a good idea of what the new variation will look like
without creating any new geometry or overwriting any existing geometry. If the
preview indicates that the new variation is acceptable, you can actually create the

new variation by re-solving with the Keep or No Keep buttons. The
preview lines are drawn in the current PD_PREVIEW_COLOR color (MAGENTA
by default). Preview lines are removed from the viewport when you use the next

instance by clicking the buttons in the Solve group or when you click OK.

Keep

Keep generates the variation and inserts it in the current part as a modified

copy of the original part. When you click Keep, the solver computes the
variation, temporarily overlays it on the current part, and executes an operation as

conducted by Multiple (under Move in the General group on the Modify
tab) to allow you to copy the variation.

To use Keep:

• Click Parametric and then, in the Solve group, click Keep.
When the solver generates the variation and overlays it on the current part,

evaluate the results. If the variation is not what you want, click OK or
Undo immediately to restore the original part. If the variation is OK, click or
specify a reference point for moving the new part, and then drag it to the desired
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location. Repeat this step until you have inserted as many copies as you want.

Finally, click OK. The overlaid variation is removed, and your original part is
restored.
Only elements in the zone (that is, elements with the PD_ZONE info text) at solve

time are copied by Keep. Dimensioning and hatching elements are never put
into the zone by Parametric Design commands. Therefore, these elements are not

normally included in the copies you make with Keep.

Copies made with Keep are not put in the current zone and do not have
constraints assigned to them. The original part from which copies are generated is

unaffected by Keep.

No Keep

Use No Keep if you want the solver to replace your current part with the
variation.

To use No Keep:

• Click Parametric and then, in the Solve group, click No Keep.

If the result of the solve is not what you expect, click Undo immediately to
restore your original part. You can continue to modify the part after solving with

No Keep by assigning new values to the constraints and re-solving.

Solver Errors
The solver or automatic constraint generator will fail without generating a
complete solution if incomplete or inconsistent constraints exist on a part. Solver
errors can result from any of the following conditions:

• The solver has successfully evaluated all the constraints it could find, but
some elements cannot be resolved. More constraints are needed in order to
completely constrain the part and generate a variation.

• A constraint has been violated while determining the new geometry. This is
usually due to contradictory constraints on one or more elements in the part.
For example, if two lines are constrained with different Slope constraints and
are also constrained to be parallel, one of these constraints cannot be satisfied.
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• An expression has been violated while determining new geometry. As with a
violated constraint, a violated expression occurs when the result of a
parametric expression contradicts an existing constraint.

When the solver or automatic constraint generator fails due to one of the above
problems, a descriptive message is written to the prompt line and the solver goes
into preview mode to show the status of the solution at the time the error was
encountered. Elements that were successfully solved are displayed in their new

positions using the Preview color (MAGENTA by default). Elements that
were still unsolved when the solver exited are displayed in their original position,
color and linetype. This often gives a good indication of the elements that caused
the failure.
The Display dialog box options usually provide the clearest indication of problem
sources. After every solve or constraint-extraction command, one or more info
strings are always written to each drawing element that was affected by the
command. These info strings give the current solve status of each element. Show
All and Hide All allow you to selectively display or hide elements based on their
solve status. These status displays are very effective for pointing out problem
areas, especially in complex drawings, where highlighting may not clearly identify
problem elements.
To open the Display dialog box:

• Click File ▶ Settings ▶ Parametric ▶ Parametric Display.
The Display options are described below.

Display Option Function
Show All Display all elements in the model.
Hide All Hide all elements in the model.
Solved Display or hide elements that were completely

determined by the last solve or constraint extraction
command. These elements have the PD_STATUS
SOLVED info text.

Unsolved Display or hide elements that were completely
undetermined by the last solve or constraint extraction
command. Unsolved elements either had no constraints
on them or the solver exited before reaching them.
These elements have the PD_STATUS UNSOLVED info
text.
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Display Option Function
Partialy Determined Display or hide elements that were partially determined

by the last solve or constraint extraction command.
Some, but not all degrees of freedom have been
determined for these elements. These elements have the
PD_STATUS PARTIAL info text.

Inconsistent Display or hide elements whose constraints have caused
an inconsistency in the most recent solve or constraint-
extraction process. These elements have the PD_
STATUS INCONSISTENT info text. Inconsistent
elements always fall into one of the three previous
categories as well.

Debugging Solver Errors
When you're confronted with a solver error, first look at the error message posted
to the prompt line. It will usually tell you whether the problem occurred because
of too few constraints or because of conflicting constraints.
If the error message is something like:
Not enough constraints to solve for all elements

your drawing does not have sufficient constraints for the solver to generate a
variation.
To quickly correct this situation, use Complete in the Generate Constraints dialog
box to extract the missing constraints. If for some reason Complete is not
applicable to your situation, use the Display options to highlight the problem areas
and manually assign additional constraints to the offending elements. Start by
highlighting all partially solved elements (click Hide All and Show All and then
click the Partialy Determined check box in the Display dialog box), and then use

Inq Elem to see what constraints are there. You may also want to examine the
constraints between the partially solved elements and any completely solved
elements they border.
If the error is due to conflicting constraints, the error message may resemble one
of the following:
Encountered violated constraints

Could not constrain without violating n constraints

These messages indicate a violated user or system constraint.

Use the Display options along with Inq Elem and Show Violated to help
identify the cause of a constraint violation. Whenever a constraint is violated and
the reason for the violation is not clear, first concentrate on those entities that are
tagged as completely solved. The solver preview mode shows how these entities
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are getting modified. Are they being modified as you expected? If so, next look at
the solved and partially solved entities involved in the constraint that is being
violated. Remove or re-assign the problem constraints to eliminate the conflict.
Another possibility is that the error message will resemble:
Inconsistently constrained elements found

Unable to constrain all elements

These messages indicate that an internal constraint has been violated. Examples of
an internal constraint violation include:

• The implicit point that resides at the intersection of two or more elements
constrained so as to move off of one or more of those elements.

• The endpoints of an arc constrained so as not to be equidistant from the arc
center.

In this case, you need to identify and re-constrain the elements that are causing the
conflict. For example, to isolate all elements that caused an inconsistency in the
last solve, click Hide All to hide the entire drawing, then click Show All and click
the Inconsistent check box to display only the elements that caused the
inconsistency.
If the solver problem is due to a violated expression, the displays described above
will be used, plus the entry for the offending expression in the parameter
definition table is highlighted. To correct this situation, examine the highlighted
expression carefully. You may need to rewrite it to avoid the conflict. It is also
possible that the expression conflicts with geometric constraints on the part that
can be removed or re-assigned.
A final class of error messages indicates problems with rigid bodies. A message of
the form:
Unable to keep rigid body 'name' rigid

Unable to constrain while keeping rigid body 'name' rigid

indicates that competing constraints on the named rigid body are attempting to
change its shape. This generally indicates that there are too many constraints
assigned to the rigid body. Concentrate your debugging efforts on the named rigid
body and eliminate constraints that are not required.

Application
There are two basic uses that the Designers have for Parametric Design. The first
is to create master parts that will be used as templates for families of parts. The
second is to perform modifications that are beyond the normal scope of the Creo
Elements/Direct Drafting Modify buttons. The sections below describe each
application.
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Designing Master Parts
A "master part" is any constrained part that is designed to be used as a template
for generating variations. For this application, the constraint information is just as
important as the geometry of the part, and should be considered an integral part of
the part. In order for a master part to be used successfully, the constraints must be
robust enough to correctly generate the full range of required variations, and they
should be set up to be accessible and easy to use, especially if the master is to be
used by several people over an extended period of time.
To achieve these goals, the following procedure should be followed to prepare a
master part:

1. Clean the input part.
2. Constrain the part.
3. Parameterize constraints.
4. Evaluate and debug the part.

Clean the Input Part
To consistently generate variations from a part, it is important that the original be
free of geometric inconsistencies that could be carried over into the variations.
You should always look out for inconsistent geometry in any part that you intend
to use as a master part. If you find inconsistencies, either remove them by using

Clean Pnt, Clean Duplicate, and Clean Stacked in the Modify group
on the Parametric tab, or isolate problem areas from consideration by the solver by
collecting these entities into rigid bodies.

Constrain the Part
Constrain your part following the procedures described in the Strategy for
Assigning Constraints on page 644 section above. After you assign the initial set

of constraints, consider running No Keep in the Solve group on the Parametric
tab once. This serves two purposes. First, it quickly indicates whether your initial
constraints are valid. Second, it provides an extra level of geometry cleaning by
adjusting the sizes and positions of elements that fall within the Complete length
and angle tolerances. Advanced Topics and Tips on page 698 explains the
Complete tolerance capabilities.

Parameterize Constraints
Two basic design goals for any master part should be robustness and ease of use.
Parameters (described fully in Parameters on page 679) help you achieve both
goals. By defining parametric values for some or all of the appropriate constraints
on your part, you can reduce the number of constraints that the end user needs to
modify directly in order to produce the variation. Other constraints can be
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parameterized to depend on the values supplied by the user. In complex situations,
expressions and macros can be supplied to check or filter the user's input before
acting on it.
If the constraints that must be modified by the user are themselves parameterized,
the user need not reassign these constraints. Instead, they will appear in the
parameter value table, which provides a much simpler interface for the occasional
user.
For example, consider the following master part, which was used to generate the
variations shown in Figure 205. Master Part for Rocker Arm on page 653:

Figure 205. Master Part for Rocker Arm

For this part, we want to generate variations in which only the configuration of the
large arm changes. In all variations, we know that the outer radius of the arm
should depend on the inner radius. Rather than require the end user to calculate
this relationship and manually Assign both radii for each variation, we use
parameters to do most of the work.
After constraining the part normally, we assign a dimensional constraint to the
inner radius and give it the parameter name I_rad The outer radius also gets a
dimensional constraint, named O_rad. Figure 205. Master Part for Rocker Arm
on page 653 shows the constraints we supplied for this master part. The
remainders were generated by Complete.
Using the parameter definition table, we define the constraint represented by the
parameter O_rad to be (1.65 * I_rad). This defines the relationship between the
two dimensions. As a result, the user only needs to give a value for I_rad to
generate the variation. The I_rad parameter is available in the parameter value
table, so the user can easily change it and then Solve for variations.
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Another advantage of parameterization is that the parameter values can be stored
and recovered for later use. The Save and Input functions in the Current
Constraints dialog box allow you to write out the current parameter value table to
a file and later restore it. This feature lets you build a "library" of value tables that
can be used to drive the master part. The advantage of this is that a series of
standard parts based on a single master part can be stored as a single MI file (the
constrained master part) and a collection of parameter value files. This
arrangement takes up much less disk space than if an individual MI file were
stored for each part in the series, and is much easier to update if the geometry of
the master part needs to be changed. To recreate any member of the series, the
user need only load the master part, Input the desired parameter value table, and
Solve. Generating Variations on page 628 describes this functionality.

Evaluate or Debug the Part
Once you have finished constraining a master part, you must test it to ensure that
it generates variations as intended. The extent of the testing you do depends on the
complexity of the part and the intended users. Obviously, you should never release
a master part for use by others till you have thoroughly checked it to ensure that it
operates as intended.
The easiest way to test a master part is simply to modify constraints and Solve for

the variations you expect to be needed. Preview mode is especially useful for
this type of checking because it never modifies the original part. If you need to

examine the variation in more detail than Preview allows, you can use No
Keep in the Solve group on the Parametric tab, but ensure you write your original
master part out to a file first so that you can recover it.
Here are some tips to keep in mind while you test:

• Try small changes to the part first, until you get a feel for how it is behaving.
As you become more familiar with it, increase the size of the modifications
until you reach the maximum expected modification.

• Try modifying a single constraint or parameter at a time. In complex parts, the
interactions among different constraints are not always obvious until you
separate them out this way.

• Try supplying nonsense values or values beyond the expected maximum. Do
these break the part badly? If so, you may want to consider implementing
macros or expressions that limit the values that the part will accept. These
expressions can be incorporated directly into the constraint structure of the
master part.
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Advanced Modification
A second application for Parametric Design is to do modifications that cannot be
easily done with the standard Creo Elements/Direct Drafting Modify buttons.
The procedure for doing modifications is very similar to that for generating master
parts, but since you are generally working for yourself on a part that you have
designed yourself, the process can be less formal. Here are a few differences:

• Geometry cleaning may not be as important for this application, especially if
you've designed the original part yourself and know that it is correct.

• Constraints can be assigned more quickly. In many cases, it is sufficient to
anchor a few elements with Refelem constraints, run Complete, and
immediately modify for the variation you want.

• When you have the modification you want, make sure to free all constraints
from the variation and remove it from the zone. The zone and constraint data
for a complex part can take up significant amounts of memory while the part is
loaded, and will increase the size of the part's file when you store it.

Constraint Types
This chapter describes the usage and function for each of the available constraint
types.

Constraint Types
Each constraint type is identified by a unique icon as you assign it to the master.
Figure 206. Constraint Icons on page 656 shows these icons. You should take a
few minutes to ensure you recognize these icons and the constraint types they
represent.
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Figure 206. Constraint Icons

Angle
You assign Angle constraints to pairs of linear elements. At solve time, the relative
angle between the elements in each angle-constrained pair is adjusted as needed to
match the angle specified by the constraint. If this angle cannot be achieved due to
other constraints, the solve fails.
To assign an angle constraint:

1. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
2. In the Action area, click Assign.
3. In the Type box, select Angle.
4. Click Apply.
5. Click the two linear elements to be constrained.
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6. Choose the angle for the constraint by any of the following methods:

• Click OK or select another angle pair. The constraint value is set to the
actual angle between the lines at solve time, thus maintaining this angle in
the variation.

• Type a specific angle value in the user input line and press ENTER. The
elements will be adjusted to this angle.

• Type a parameter name or a Creo Elements/Direct Drafting expression that
defines the angle (string input). The value returned in the parameter or the
result of the expression is used to adjust the angle.

Each element in an angle-constrained pair is labeled with an angle icon, Figure
206. Constraint Icons on page 656, and a reference number that is unique to the
pair. If the constraint is set to a specific value or parameter name, that information
is appended to the icon.

Application Notes
An Angle constraint will replace an existing Parallel or Perpendic constraint on a
given pair of linear elements. This is because Parallel and Perpendic are simply
special cases of the Angle constraint.
The angle between the elements in an Angle pair is given as the difference
between the slopes of the two elements (see Slope on page 675). If the Angle
constraint is parameterized, this angle can be accessed via expression by
referencing the parameter name.
Complete will only extract angle constraints for line elements that share an
endpoint or fillet. If you are assigning angle constraints manually, the members of
the Angle pair need not be connected, Figure 207. Angle-Constrained Lines on
page 657.

Figure 207. Angle-Constrained Lines

Collinear
The Collinear constraint forces a pair of linear elements to become or remain
collinear during the solve process. If other constraints on the part prevent the
necessary adjustments to bring the pair together, the solve fails.
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To assign Collinear constraints:

1. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
2. In the Action area, click Assign.
3. In the Type box, select Collinear.
4. Click Apply.
5. Click the two linear elements to be constrained.

6. Click OK or assign the next constraint.
Each linear element in a collinear pair is labeled with the collinear icon, Figure
206. Constraint Icons on page 656, and a reference number that is unique to the
pair.

Application Notes
Lines need not be connected in order to assign or extract a Collinear constraint.
Figure 208. Collinear Lines on page 658 shows a common application for
Collinear constraints: "gluing" a line element to a construction line.

Figure 208. Collinear Lines

When adjusting a pair of lines to make them collinear, the Solve group buttons try
to use the smallest adjustment possible to bring the pair into line.

Dimension
Dimension constraints set the dimensions of elements in the master part to specific
values. The Solve group buttons on the Parametric tab attempt to adjust
constrained dimensions to the values given by the constraint. If this proves
impossible, the solve fails.
To assign Dimension constraints:

1. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
2. In the Action area, click Assign.
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3. In the Type box, select Dimension.
4. Click Apply.
5. Click the text of the dimension to be constrained.
6. Choose a value for the constraint. You have three options:

• Click OK or select another dimension. The actual value of the
constrained dimension at solve time will be assigned to the constraint. This
dimension will not change in the variation.

• Type a specific value for the dimension in the user input line and press
ENTER. The dimension is adjusted to this value at solve time.

• Type a parameter name or Creo Elements/Direct Drafting expression that
resolves to the dimension value (string input) in the user input line and
press ENTER. The dimension is adjusted to the result of the expression.

Dimension constraints are not identified by icons, but rather by a change to the
dimension text and color. Depending on how you define the dimensional
constraint, one of three displays will result at definition time and when you select
Show and Dimension or Show and All Types in the Generate Constraints dialog
box:

• Dimensions that are constrained to keep their current value during the solve
are redrawn in the current icon color (CYAN by default).

• Dimensions that are constrained to a given value are redrawn in the current
icon color (CYAN) and the main dimension text is replaced by the value given
to the constraint.

• Dimensions that are given a parametric value are redrawn in the current icon
color (CYAN) and the main dimension text is replaced by the parameter name,
which is drawn using the dimension's font.
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Note
An alternate display style for dimensional constraints can be specified by
calling PD_SHOW_USE_POSTFIX YES, either from the Creo Elements/
Direct Drafting command line or via the pd_def.mac file. This option
causes the parameter value to be written as a postfix to the main dimension
text, which remains unchanged, Figure 209. Dimension Constraints, Alternate
Style on page 660. Both the dimension text and postfix are redrawn in the
current icon color (CYAN), to indicate that a dimensional constraint has been
applied. The Parametric Design postfixes do not interfere with Creo Elements/
Direct Drafting dimension postfixes, if present.

Figure 209. Dimension Constraints, Alternate Style

You cannot assign a dimension constraint to symmetric single or symmetric
datum long dimensions.

Distance
You can assign a Distance constraint to any pair of geometric elements except for
spline-based entities (rational splines, bsplines, and ellipses). One or both
elements in a distance-constrained pair may also be dimension text, as described
below. At solve time, the relative distance between the extensions of the elements
in the pair is adjusted to the distance specified by the constraint. If this adjustment
cannot be made, the solve fails.
The extension of an element is its construction-geometry equivalent. For example,
the extension of a line segment encompasses any point that would fall on a
collinear construction line. The extension of an arc element encompasses any
point that would fall on a construction circle that shares the arc's center and radius.
Elements in a distance-constrained pair need not be of the same type; for example,
the distance between a circle and a linear element can be constrained, as can the
distance between a point element and an arc. Figure 210. Distance Determination
on page 661 illustrates how distance is defined for different combinations of
elements.
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Figure 210. Distance Determination

To assign a distance constraint:

1. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
2. In the Action area, click Assign.
3. In the Type box, select Distance.
4. Click Apply.
5. Click each of the two elements to be constrained.
6. Choose the distance for the constraint. You have three options:

• Click OK or select another distance pair. The constraint distance will
be set to the actual distance between the elements at solve time.

• Type a specific distance value in the user input line and press ENTER. The
distance will be adjusted to this value at solve time.

• Type a parameter name or Creo Elements/Direct Drafting expression that
defines the distance (string input) in the user input line and press ENTER.
The distance will be adjusted to the result of this expression or parametric
value at solve time.

Each element in a distance-constrained pair is labeled with the distance icon,
Figure 206. Constraint Icons on page 656, and a reference number that is unique
to the pair. If the constraint is set to a specific value or parameter name, that
information is appended to the icons.
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Distance Constraints and Dimension Text
By default, when a dimensioned element moves or resizes as a result of a
Parametric Design Solve, a new position for its dimension text is automatically
determined. You can override this automatic placement by assigning Distance
constraints directly to the text of the dimension(s) you want to control. This
mechanism allows you to control the position of the center of the dimension text
relative to the dimensioned element and relative to other elements in your
drawing.

Note
Only Distance constraints may be assigned to dimension text; no other
constraint types are allowed.

Application of distance constraints to dimension text must be done manually. The
automatic constraint generator will never attempt to add distance constraints to
dimensions. Because of this, the preferred method for applying distance
constraints to dimensions is to first completely constrain the part without any
constraints on the dimension position and then constrain only those dimension
positions which need to be controlled. To assign the constraint to dimension text,
click on the centerpoint of the main text element. Two constraints are generally
needed to fully constrain the dimension position; one for each degree of freedom.
In most cases, if you add only a single distance constraint, subsequent solves will
fail. Construction geometry can often be helpful for providing additional "distance
markers" in this application.

Application Notes
Several powerful parametric applications are made possible by distance-
constraining strategically located point elements with regard to other elements in a
drawing. In both of the following examples, point elements are created
specifically for use by Parametric Design. The point elements are necessary
because distance constraints can only be assigned to geometric elements, not
model points.
Figure 211. Distance Constraints to Control Line Length on page 663 shows how
distance constraints can be used to force a centerline to grow along with the rest of
a part as it is resized. A point element is first assigned to each end of the
centerline. Each point element is then distance-constrained to the nearest end of
the part, (a). This distance will be maintained as the part is resized, (b).

662 Creo Elements/Direct Drafting User's Guide: Fluent User Interface



Figure 211. Distance Constraints to Control Line Length

Figure 212. Distance Constraints to Control Text Position on page 663 shows how
distance constraints can be used to fix text labels to a given distance from a spline.
The distance is maintained as the spline is reshaped. Point elements are assigned
to the interpolation points of the spline and then distance-constrained to the
reference points of the text elements, (a). This distance will now be maintained as
the spline is changed, (b).

Figure 212. Distance Constraints to Control Text Position

Fillet
The Fillet constraint can be assigned to any arc that qualifies as a fillet in the
model. To qualify as a fillet, an arc must have at least one line segment or arc
element at each of its ends. When an arc is constrained to be a fillet, Solve will
ensure that it remains tangent to both the elements at its endpoints. The fillet may
change radius, length or orientation as a result of the solve.
To assign Fillet constraints:

1. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
2. In the Action area, click Assign.
3. In the Type box, select Fillet.
4. Click Apply.
5. Click the arc to be constrained.
6. Click an element at each end of the arc to complete the fillet.
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7. Click OK or assign the next constraint.
Fillet-constrained arcs are represented by the fillet icon, Figure 206. Constraint
Icons on page 656.

Application Notes
If you assign a Fillet constraint to an arc that has a line segment at each end,
Parametric Design ensures that the angle subtended by the arc will never become
greater than 180° by "flipping" the arc whenever this angle exceeds 180° in a
variation, Figure 213. Adjustment Made for Fillet Constraints on page 664. This
adjustment is only made in the case of an arc with a line segment at each end.

Figure 213. Adjustment Made for Fillet Constraints

If you intend for the angle subtended by the arc to be greater than 180° in the
generated part, do not use a fillet constraint; instead, use two Tangent constraints
to glue the ends of the arc to the appropriate elements.
Parametric Design fillet constraints give you better control than the Creo

Elements/Direct Drafting Modify button (under Fillet in the Engineering
group on the Drafting tab) for changing fillet radii. By applying other constraints
along with the fillet constraints, you can control exactly how elements tangent to a
fillet adjust to accommodate the new radius.

Horizontal
Line elements that are assigned a Horizontal constraint will be adjusted as
necessary at solve time to become horizontal. If Solve cannot make this
adjustment due to other constraints on the part, the solve fails. A Horizontal
constraint will not prevent a linear element from moving or changing length in the
variation; it only adjusts the slope of that element to be zero.
To assign Horizontal constraints:

1. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
2. In the Action area, click Assign.
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3. In the Type box, select Horizontal.
4. Click Apply.
5. Click the linear element to be constrained.

6. Click OK or assign the next constraint.
The horizontal icon, Figure 206. Constraint Icons on page 656, identifies
horizontally constrained lines.
A given element may have only one of the Horizontal, Vertical, or Slope
constraints assigned to it. If you attempt to assign a Horizontal constraint to an
element that is already assigned a Vertical constraint, the Horizontal constraint will
replace it.
The action taken when you assign a Horizontal constraint to an element that is
already assigned a Slope constraint depends on whether or not the Slope constraint
is parameterized. If it is not, then the Horizontal constraint simply replaces it. If
the Slope constraint is parameterized, however, the Horizontal constraint is not
assigned. Instead, the value of the parameter is adjusted to 0° or 180° (effectively
horizontal). This is done so as not to invalidate any expressions that may reference
the existing slope parameter.

Mirror
When a pair of elements are constrained to be a Mirror pair, the buttons in the
Solve group on the Parametric tab will attempt to move and/or resize both
elements as needed so that their extensions mirror each other across a specified
line of symmetry. The extension of an element is defined as the element's
construction-geometry equivalent. For example, the extension of an arc is the
construction circle that shares the centerpoint and radius of the arc. The extension
of a line element is a collinear construction line.
Both elements in the mirrored pair must be of the same type (e.g., both circles,
both lines, or both points), but need not be the same size. Mirrored lines may be of
different lengths, and an arc and a circle can mirror each other. Spline and
ellipsoid elements are not eligible for mirror constraints, though some measure of
control over these entities can be had by assigning point elements to their control/
interpolation points and then fixing those point elements. Figure 214. Mirrored
Element Pairs on page 666 shows several examples of mirrored element-pairs.
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Figure 214. Mirrored Element Pairs

To assign a mirror constraint:

1. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
2. In the Action area, click Assign.
3. In the Type box, select Mirror.
4. Click Apply.
5. Click a linear element to be the symmetry line for the mirrored pair.

If this element does not already have a symmetry-line constraint assigned to it,
one will be added.

6. Select a pair of elements to be mirrored across this line.

7. Click OK or select another pair of elements to be mirrored about the
original symmetry line.

When you successfully assign a mirror constraint, both elements in the mirrored
pair will be labeled with the mirror icon, and the line of symmetry will be labeled
with a symmetry line icon, Figure 206. Constraint Icons on page 656. The icon for
each symmetry line in the model is given a unique number, and the icon for each
member in the mirrored pair contains a number in the form s-p, where s is the
number of the symmetry line that this pair is bound to and p is the unique number
for this mirrored pair.

Application Notes
The symmetry line for a mirror constraint may be any linear element.
Complete only extracts mirrored pairs from areas that are orthogonal to defined
symmetry lines. If your symmetry lines have infinite length (e.g., construction
lines) this is no limitation, but if you choose a finite-length element as a symmetry
line, items must lie completely within the orthogonal boundary in order to be
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selected for mirroring. The two line segments on the right of Figure 215. Auto-
selection of Mirrored Pairs on page 667, for example, would not be extracted
because neither falls inside the boundary. If you are assigning mirrored pairs
manually, this limitation does not apply.

Figure 215. Auto-selection of Mirrored Pairs

Parallel
The Parallel constraint is assigned to pairs of linear elements. A pair of parallel-
constrained elements will be adjusted to be parallel at solve time. If other
constraints on the part prevent the pair from being made parallel, the solve fails.
The positions, lengths, and absolute slopes of parallel elements are not affected by
this constraint and may or may not change during the solve, but the slopes of the
lines will be the same.
To assign Parallel constraints:

1. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
2. In the Action area, click Assign.
3. In the Type box, select Parallel.
4. Click Apply.
5. Click the linear elements to be constrained.

6. Click OK or assign the next constraint.
Each linear element in a parallel pair is labeled with the parallel icon, Figure 206.
Constraint Icons on page 656, and a reference number that is unique to the pair.
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Application Notes
A given pair of linear elements may have only one of the Angle, Parallel, or
Perpendic constraints assigned to it. This is because Parallel and Perpendic are
simply special cases of the Angle constraint. If you attempt to assign a Parallel
constraint to a pair of elements that is already assigned a Perpendic constraint, the
Parallel constraint will replace it.
The action taken when you assign a Parallel constraint to a pair of elements that is
already assigned an Angle constraint depends on whether or not the Angle
constraint is parameterized. If it is not, then the Parallel constraint simply replaces
it. If the Angle constraint is parameterized, however, the Parallel constraint is not
assigned. Instead, the value of the parameter is adjusted to 0° or 180° (effectively
parallel). This is done so as not to invalidate any expressions that may reference
the existing angle parameter.
Parallel lines need not describe an orthogonal area in the part; Figure 216. Parallel
Lines on page 668 shows two sets of parallel lines.

Figure 216. Parallel Lines

Perpendicular
The Perpendic constraint is assigned to pairs of linear elements. A pair of
perpendicular-constrained elements will be adjusted to be perpendicular at solve
time. If other constraints on the part prevent this adjustment, Solve fails. The
positions, lengths, and absolute slopes of perpendicular elements are not affected
by this constraint and may change during the solve, but the slopes of the lines will
be at right angles to one another.
To assign Perpendic constraints:

1. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
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2. In the Action area, click Assign.
3. In the Type box, select Perpendic.
4. Click Apply.
5. Click the linear elements to be constrained.

6. Click OK or assign the next constraint.
Each linear element in a perpendicular pair is labeled with the perpendicular icon,
Figure 206. Constraint Icons on page 656, and a reference number that is unique
to the pair.

Application Notes
A given pair of linear elements may have only one of the Angle, Parallel, or
Perpendic constraints assigned to it. This is because Parallel and Perpendic are
simply special cases of the Angle constraint. If you attempt to assign a Perpendic
constraint to a pair of elements that is already assigned a Parallel constraint, the
Perpendic constraint will replace it.
The action taken when you assign a Perpendic constraint to an element pair that is
already assigned an Angle constraint depends on whether or not the Angle
constraint is parameterized. If it is not, then the Perpendic constraint simply
replaces it. If the Angle constraint is parameterized, however, the Perpendic
constraint is not assigned. Instead, the value of the parameter is adjusted to 90° or
270° (effectively perpendicular). This is done so as not to invalidate any
expressions that may reference the existing angle parameter.
Lines need not be in contact with one another to be constrained perpendicular.
Figure 217. Perpendicular Lines on page 669 shows three different pairs of
perpendicular lines.

Figure 217. Perpendicular Lines

Point on
Point on constrains a model point to remain on a given geometric element or its
extension.
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The point part of this constraint may be any visible model point. Line endpoints,
circle centers, spline control points, and text reference points may all be used if
visible. If necessary, click the Vertex check box in the Creo Elements/Direct
Drafting Show dialog box to make these elements visible.
The extension of an element is its construction-geometry equivalent. For example,
the extension of a line segment encompasses any point that would fall on a
collinear construction line. The extension of an arc element encompasses any
point that would fall on a construction circle that shares the arc's center and radius.
All Creo Elements/Direct Drafting geometric elements, including splines, B-
splines, and ellipses, are eligible to receive Point on constraints.
The constrained point may slide anywhere along the extension of the element it is
attached to, but will always remain in contact with the extension. If other
constraints prevent this contact, Solve fails.
To assign Point on constraints:

1. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
2. In the Action area, click Assign.
3. In the Type box, select Point on.
4. Click Apply.
5. Click the point to be constrained. You can select any visible model point (use

the Creo Elements/Direct Drafting Show dialog box to display model points if
needed). If no point element exists at that location, one will be created.

6. Click the geometry to be attached to the point.

7. Click OK or assign the next constraint.
The Point on icon, Figure 206. Constraint Icons on page 656, identifies this
constraint.

Application Notes
Two common applications for Point on constraints are shown in Figure 218. Point-
On Applications on page 671. Circles can be constrained to stay on a linear
element by fixing the centerpoint on the line. Conversely, elements can be
constrained to remain attached to the perimeter of a circle, ellipse or spline.
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Note
To assign a Point on constraint to the centerpoint of a circle or arc, you must
first display centerpoints (with the Vertex check box clicked in the Creo
Elements/Direct Drafting Show dialog box) and then click the centerpoint
directly.

Figure 218. Point-On Applications

Reference Element
Any element in a part (except ellipses) can be fixed in place with a Refelem
constraint. Reference elements are not changed in any way by Solve, so they will
appear in the same position in the variation as they do in the master part.
To assign Refelem constraints:

1. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
2. In the Action area, click Assign.
3. In the Type box, select Refelem.
4. Click Apply.
5. Click the element to be constrained.

6. Click OK or assign the next constraint.
Reference elements are labeled with the anchor icon, Figure 206. Constraint Icons
on page 656.
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Application Notes
You should almost always constrain one or two elements in the master part as
reference elements (construction geometry is good for this) so that Solve has a
frame of reference for generating the variation. Otherwise, the variation may not
be placed where you expect.

Reference Point
Any visible model point can be constrained to be a reference point. Solve places
reference points in the variation at the position specified by the constraint.
To assign a reference point:

1. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
2. In the Action area, click Assign.
3. In the Type box, select Refpoint.
4. Click Apply.
5. Click the point to be constrained. You may select any visible model point (use

the Creo Elements/Direct Drafting Show dialog box to display model points if
needed) If a point element does not exist at the location you click, one will be
created.

6. Specify a position for the reference point. You have two options:

• Click OK or select another point. The reference point will be placed
into the variation at its current position at solve time.

• Type a parameter name or Creo Elements/Direct Drafting expression that
resolves to the point position (string input) in the user input line and press
ENTER.

The reference point will be labeled with the position symbol, Figure 206.
Constraint Icons on page 656. If the reference point is set to a parameter name,
that information is appended to its icon.

Application Notes
Reference points, like reference elements, can be used to "anchor" portions of the
master part in place, so that they maintain their positions in the variation.
To assign a reference point constraint to a model point that is not usually visible,
for example, circle centers, spline control points, or text centers, you must first
display them (with Vertex check box clicked in the Creo Elements/Direct Drafting
Show dialog box) and then click them directly.
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A reference point can also be used to supply data to macros or expressions when
given a parametric value. If you supply a parameter label when assigning a
reference point, the coordinate value of the point can be accessed in an expression
by referencing the parameter name.

Same Distance
Samedist is assigned to two pairs of elements. All geometric elements except for
spline-based entities (rational splines, bsplines, and ellipses) are eligible. You can
assign constraints to the interpolation or control points of these entities, just not
the spline itself. Samedist forces the distance between the members of the first
pair of elements to be the same as the distance between the members of the second
pair. If other constraints prevent the two distances from being made equal, Solve
fails.
To assign Samedist constraints:

1. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
2. In the Action area, click Assign.
3. In the Type box, select Samedist.
4. Click Apply.
5. Click the two elements for the first pair.
6. Click the two elements for the second pair.

7. Click OK or assign the next constraint.
Each element in a same-distance set is labeled with the same-distance icon, Figure
206. Constraint Icons on page 656, and a reference number that is unique to the
set.

Application Notes
Samedist constraints are often useful for forcing two contours to become/remain
equidistant, Figure 219. Same Distance Application on page 674.
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Figure 219. Same Distance Application

Same Size
The Samesize constraint is applied to pairs of geometric elements, which must be
of the same geometric type. All elements except for spline-based entities (rational
splines, bsplines, and ellipses) and construction lines are eligible for this
constraint. The members of a same-size pair will be adjusted as needed by Solve
to become the same size. Specifically, the radii of circular elements and the length
of linear elements is adjusted. If the members of a same-size pair are not in fact
the same size at solve time, Solve will look at other constraints on the members of
the pair to determine which member should be changed to match the size of the
other.
To assign Samesize constraints:

1. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
2. In the Action area, click Assign.
3. In the Type box, select Samesize.
4. Click Apply.
5. Click the two elements to be constrained.

6. Click OK or assign the next constraint.
Each element in a same-size pair is labeled with the same-size icon, Figure 206.
Constraint Icons on page 656, and a reference number that is unique to the pair.

Size
You can assign Size constraints to lines and all circular elements. At solve time,
these elements will be adjusted to the size specified by the constraint. For circular
elements, the adjustment is made to the radius; for lines, the length is adjusted. If
the adjustment cannot be achieved, Solve fails.
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To assign a size constraint:

1. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
2. In the Action area, click Assign.
3. In the Type box, select Size.
4. Click the element to be constrained.
5. Choose the size for the constraint by any of the following methods:

• Click OK or select another element. The element will be held at its
current size at solve time. This is the default.

• Type a specific size (radius for circular elements, length for lines) in the
user input line and press ENTER.

• Type a parameter name or Creo Elements/Direct Drafting expression that
defines the size (string input) in the user input line and press ENTER.

Each size-constrained element pair is labeled with the size icon, Figure 206.
Constraint Icons on page 656. If the constraint is set to a specific value or
parameter name, that information is appended to the icon.

Slope
Slope constraints are assigned to linear elements. At solve time, the slope of these
elements will be adjusted to match the angle specified by the constraint. If the
adjustment cannot be made, Solve fails.

Note
Slope constraints do not fix the position or length of a line, which may change
unless otherwise constrained.

To assign a slope constraint:

1. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
2. In the Action area, click Assign.
3. In the Type box, select Slope.
4. Click Apply.
5. Click the linear element to be constrained.
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The current slope of this element is displayed in the Creo Elements/Direct
Drafting user input line.

6. Choose the angle for the constraint by any of the following methods:

• Click OK or select another element. The slope will be set to the actual
slope of the line at solve time.

• Type a specific angle value for the slope in the user input line and press
ENTER.

• Type a parameter name or Creo Elements/Direct Drafting expression that
defines the slope angle (string input) in the user input line and press
ENTER.

Each slope-constrained element is labeled with the slope icon, Figure 206.
Constraint Icons on page 656. If the constraint is set to a specific value or
parameter name, that information is appended to the icon.

Application Notes
A given element may have only one of the Horizontal, Vertical or Slope constraints
assigned to it. If you attempt to assign a Slope constraint to an element that is
already constrained Horizontal or Vertical, the Slope constraint will replace the
existing constraint.
Parametric Design defines the slope of a linear element as the angle which is
swept by rotating the vector (1,0) to the intrinsic vector of the element. This
intrinsic vector is the line that runs from the first to the second endpoint of the
element. The intrinsic vector of a construction line depends on how it was created.
This method is used so that rotations greater than 90° can be specified.
As a result of the method used to measure slope, it is not possible to visually
determine the slope of a linear element from the graphics display. For example, a
vertical line may have a slope of 90° or 270°, depending on whether it was
constructed from "top to bottom" or "bottom to top." You can, however, read the
current slope from the prompt line in step 3 of the assignment procedure above.

Symmetry Line
The Symmline constraint identifies a line of symmetry that can be used by
Complete to assign mirror constraints. If you want to assign mirror constraints by
hand, you should use Assign Mirror instead. You assign Symmline constraints to
linear elements, which are then labeled with the symmetry line icon, Figure 206.
Constraint Icons on page 656.
To assign Symmline constraints:

1. Click Parametric and then, in the Create group, click Constraints.
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The Generate Constraints dialog box opens.
2. In the Action area, click Assign.
3. In the Type box, select Symmline.
4. Click Apply.
5. Click the linear element to be constrained.

6. Click OK or assign the next constraint.

Application Notes
Parametric Design can automatically assign symmetry-line constraints to lines
having a particular color and linestyle. You enable this behavior by calling the
function PD_AUTO_SYMMETRY YES from the Creo Elements/Direct Drafting
command line, or by including it in your pd_def.mac file. The functions PD_
AUTO_SYMMETRY_COLOR and PD_AUTO_SYMMETRY_LINETYPE specify the
color and linetype. See Parametric Design Defaults on page 761 for more
information.
Complete only extracts mirrored pairs from areas that are orthogonal to defined
symmetry lines. If your symmetry lines have infinite length (e.g., construction
lines) this is no limitation, but if you choose a finite-length element as a symmetry
line, items must lie completely within the orthogonal boundary in order to be
selected for mirroring. The two line segments on the right of Figure 220. Auto-
selection of Mirrored Pairs on page 677, for example, would not be extracted
because neither falls inside the boundary. If you are assigning mirrored pairs
manually, this limitation does not apply.

Figure 220. Auto-selection of Mirrored Pairs
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Tangent
Tangent constraints are applied to pairs of geometric elements, at least one of
which must be circular (circle, construction circle, arc, or fillet). At solve time, the
elements are adjusted to ensure that their extensions are tangent. See Point on on
page 655 for an explanation of extensions. If this adjustment cannot be achieved,
Solve fails. Two elements are considered tangent if their extensions touch at one
point only, Figure 221. Tangent Pairs on page 678.

Figure 221. Tangent Pairs

To assign Tangent constraints:

1. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
2. In the Action area, click Assign.
3. In the Type box, select Tangent.
4. Click Apply.
5. Click the two elements to be constrained. One element must be circular.

6. Click OK or assign the next constraint.
Each element in a tangent pair is labeled with the tangent icon (see Figure 206.
Constraint Icons on page 656) and a reference number that is unique to the pair.

Application Notes
Complete will not extract a tangent constraint for a pair of elements unless the
elements themselves (not their extensions) are tangent. Solve, however, recognizes
linear and circular extensions when adjusting for tangency.
Solve attempts to maintain as much of the current configuration as possible when
adjusting to satisfy tangency constraints. When adjusting a circular and a linear
element to be tangent, Solve attempts to keep the circle on the same side of the
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line as it was originally. When adjusting two circles to be tangent, effort is taken
to ensure that if one circle is inside the other, it remains inside, and that circles
which are outside of each other stay that way.

Vertical
Linear elements that are assigned a Vertical constraint will be adjusted as
necessary at solve time to become vertical. If Solve cannot make this adjustment
due to other constraints on the element, Solve fails. A vertical constraint will not
prevent a linear element from moving or changing length in the variation; it only
adjusts the slope of that line to 90° or 270°.
To assign Vertical constraints:

1. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
2. In the Action area, click Assign.
3. In the Type box, select Vertical.
4. Click Apply.
5. Click the linear element to be constrained.

6. Click OK or assign the next constraint.
The vertical icon, Figure 206. Constraint Icons on page 656, identifies vertically
constrained lines.

Application Notes
A given element may have only one of the Horizontal, Vertical or Slope constraints
assigned to it. If you attempt to assign a Vertical constraint to an element that is
already assigned a Horizontal constraint, the Vertical constraint will replace it.
The action taken when you assign a Vertical constraint to an element that is
already assigned a Slope constraint depends on whether or not the Slope constraint
is parameterized. If it is not, then the Vertical constraint simply replaces it. If the
Slope constraint is parameterized, however, the Vertical constraint is not assigned.
Instead, the value of the parameter is adjusted to 90° or 270° (effectively vertical).
This is done so as not to invalidate any expressions that may reference the existing
slope parameter.

Parameters
A parameter is a named variable that you create with Parametric Design. You can
create a parameter implicitly by giving a parameter name when you assign one of
the several constraint types that support parameters; or you can create a parameter
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explicitly by adding a new entry to the parameter definition table, which you
access by clicking Advanced in the Current Constraints dialog box. Regardless of
how you create a parameter, it is given an entry in this table. By editing the entry,
you can assign a value to the corresponding parameter.
The value you assign to a parameter may be either a discrete numeric value or an
expression. An expression is any valid Creo Elements/Direct Drafting expression.
This line can reference other Parametric Design parameters, Creo Elements/Direct
Drafting macros, and any of the arithmetic and logical constructs supported by the
Creo Elements/Direct Drafting macro language.
The most important feature of parameters is that they can be assigned to
constraints. After you assign a parameter to a constraint, you can modify the
constraint by changing the parameter's value. Conversely, you can access the
current value of the constraint by inquiring the parameter. This capability makes
parameters an especially powerful tool for defining relationships among elements
in a part.

Creating Parameters

Creating Parameters Implicitly
Parametric Design implicitly creates a new parameter whenever you Assign one
of the following constraint-types and supply an unused parameter name (string)
when prompted to do so by the software:

• Angle

• Dimension

• Distance

• Refpoint

• Size

• Slope

The name you give must conform to the naming rules given in the Assigning
Parameters on page 682, section and must not be the same as an existing
parameter name. If you give an existing parameter name, that parameter is simply
assigned to the constraint and no new parameter is created.
When you create a new parameter with this procedure, Parametric Design
implicitly creates a default definition for the parameter and then binds it to the
constraint you're assigning.
By default, the new parameter is given the current value of the constraint. For
example, if you assign a size constraint to a 10 cm line and give the label 'Len_
3' at the prompt, Parametric Design will create a new parameter, Len_3, and
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give it a value of 100, assuming your current length units are mm. Parameters
always use the units they were created with. Len_3, for example, will always be
in mm even if you change your length units to inches.

Creating Parameters Explicitly
You can also create new parameters directly by adding entries to the parameter
definition table. Parameters that you create this way are not automatically
assigned to constraints on your part. For this reason, explicit creation is often used
to create parameters that will be used only to supply constants, sub-expressions, or
other values that have no relationship to the part.
To explicitly create a parameter:

1. Click Parametric and then, in the Show group, click Current.

The Current Constraints dialog box opens.
2. Click Advanced.

The Advanced dialog box opens. It contains the parameter definition table.

The parameter definition table provides the following commands for the
creation of new parameters:

Command Action
Length Create a new length parameter
Angle Create a new angle parameter
Point Create a new point parameter
User Create a new user (unitless) parameter

Each of these commands adds a new parameter to the table. These parameters
are not associated with constraints, but you can name and define them like any
other parameter. The new parameters can be referenced in other expressions
and can reference other parameters in their own expressions. Once defined,
you may use them for reference or assign them to constraints in your part.

3. To create a new parameter:

a. Click the required command (for example, Angle).

The Add Constrain dialog box opens.
b. Type a name for the new parameter (for example, 'Angle_4').
c. Click OK.

The name you give must be a suitable parameter label as described in Assigning
Parameters on page 682. An explicitly created parameter is given an initial value
of 0 and a value type of "unknown." Its value remains unknown until you assign it
a value or until you assign it to a drawing element.
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Assigning Parameters
Only the following constraint-types may be parameterized:

• Angle

• Dimension

• Distance

• Ref Point

• Size

• Slope

To assign a parameter to any of these constraint-types, you simply Assign the
constraint to the desired element or elements, and enter the parameter name
(enclosed in quotes) when prompted to do so.
Only those constraint types that support parameters will prompt you for them. If
the named parameter does not exist, then Parametric Design creates a new
parameter with this name, as explained above. If a parameter with this name does
exist and matches the unit requirements of the constraint, it becomes associated
with the constraint.
Parameter names are text strings. They must adhere to the naming rules for Creo
Elements/Direct Drafting macros. Parameters cannot have the same name as a
Creo Elements/Direct Drafting keyword, (for example, rad or CONFIRM). To
avoid such conflicts, parameter names should begin with an uppercase letter, and
contain only lowercase letters, integers, and/or the underscore (_) character in the
remaining positions. The names Distance, Rad, Dim_3, and My_line are
examples of valid parameter names. The software always displays parameter
names with the first letter uppercase and remaining characters lowercase,
regardless of how you enter them.
It is always a good idea to choose parameter names that are as descriptive as
possible - especially if you are parameterizing a part that other people will use as a
master part. A draftsperson is much more likely to understand the purpose of the
parameter Circle3_radius than the parameter Wwxyzz.
Once you assign a parameter name to a constraint, the parameter remains assigned
until you assign a different parameter name to this constraint, or until you Free the
constraint.

Editing Parameter Definitions
The parameter definition table can be used to display and edit the definitions of all
existing parameters on the current part. The parameter definition table is located
in the Advanced dialog box.
To open the Advanced dialog box:
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1. Click Parametric and then, in the Show group, click Current.

The Current Constraints dialog box opens.
2. Click Advanced.

The Advanced dialog box opens. It contains the parameter definition table.
The parameter definition table contains one entry for each parameter. Each entry
has five columns, which define the parameter:

• Name

• Kind

• Value

• New Value Type

• New Value or Expression

You can only edit the New Value or Expression column. The first four columns just
supply information. The following sections describe each column:

Name
The Name column gives the parameter name as you assigned it. This is simply the
label that identifies the parameter.

Kind
The Kind column declares the units for this parameter. Units are determined by the
type of constraint this parameter is assigned to. The following "kinds" of units are
recognized:

Kind Units
Angle An angle in the angular units in force when the parameter was

created (degrees, radians, and so on).
Length A linear distance in the linear units in force when the parameter

was created (mm, inches, miles, and so on).
Point An XY coordinate pair in the linear units in force when the

parameter was created; for example, 20,30.5.
User Unitless. A user parameter is never associated with a geometric

constraint, so the solver never has to convert this parameter into
system units. Only parameters created with the User option can be
user parameters.
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Value
The Value column shows the value that is currently associated with this parameter.
This value may change when you next Solve for a variation. The value for a
parameter is always given in the same units that were in force when the parameter
was first created.
Parameters that resolve to point values use two lines in the parameter table. The
value on the first line is the X coordinate of the point, while the second line
contains the Y coordinate.

New Value Type
The New Value Type column specifies the method that Solve will use to evaluate
this parameter. New Value Type must be one of the following:

Value Type Meaning
Value Set the value for this parameter to the specific value in the

New Value or Expression column. Assume that the given
value is in the correct units. Other parameters can depend on
this parameter via expressions. This value is available to any
geometric constraints that reference this parameter to solve
for the geometry.

Expression Generate a value for this parameter by resolving the
expression given in the New Value or Expression column.
Assumes that the expression is a valid Creo Elements/Direct
Drafting expression which resolves to a value of the correct
type. If the expression contains references to other
parameters then the expression is only evaluated after all
referenced parameters have a value. Conversely, other
parameters can depend on this parameter via expressions.
The value produced by this expression is available to all
geometric constraints that reference this parameter.
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Value Type Meaning
Geometry The value for this parameter is taken from geometry that is

solved for using constraints that are not associated with this
parameter. Other parameters can depend on this parameter
via expressions.
For example, take a part in which there are two circles
whose radii are parameterized as Radius_1 and Radius_
2. If the first circle is tangent to three fixed lines then the
value of Radius_1 is completely determined by the
"geometry" of the three lines. An expression for Radius_2
such as ( 2 * Radius_1 ) is then possible. This works because
Solve recognizes that the expression for Radius_2 should
not be evaluated until Radius_1 is known. Radius_1
can only be known after the three tangent line constraints are
evaluated.

Unknown This parameter has been named, but has no association to an
existing constraint and has no value or expression assigned.
This parameter type is not evaluated by the solver.

New Value or Expression
Use this column to assign new values for parameters. The value or expression
contained in this column at Solve time will be interpreted and assigned to the
corresponding parameter. If you leave this column blank, then the parameter value
is extracted from the geometry of the part.

Assigning a Specific Value to a Parameter
To assign a specific value to a parameter:

1. Click the parameter's New Value or Expression column.
2. Type a numeric value (in appropriate units) in the text box.
The number you provide is displayed in the New Value or Expression column and
the New Value Type column is set to "Value". This value will be assigned to this
parameter by the next Solve command.

Assigning an Expression to a Parameter
To assign an expression to a parameter:

1. Click the parameter's New Value or Expression column.
2. Type a valid Creo Elements/Direct Drafting expression. All expression input

must be enclosed in quotes. For example:
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(57 + Dist) Assign the sum of 57 and 'Dist' to the
parameter.

(IF (A < 8) 57 ELSE 45
END_IF)

Assign 57 if the value of 'A' is less than 8;
otherwise assign 45

(PNT_XY (X_OF 'PtA')
10)

Assign to a point parameter the x-value of
'PtA' and a y-value of 10.

My_macro Evaluate 'My_macro' and assign the result.
My_macro2 Rad Evaluate 'My_macro2', which needs a

parameter that passes in the value of 'Rad'

The expression you provide is displayed in the New Value or Expression column
and New Value Type becomes "Expression." The next use of the Solve group
buttons causes this expression to be evaluated by Parametric Design and the result
assigned to this parameter.

Extracting a Value from the Geometry
To extract a value from the geometry:

1. Click the parameter's New Value or Expression column.
2. Type an empty string ('') to clear the contents of the column.
The New Value or Expression column is now blank and New Value Type becomes
"Geometry." Subsequent use of the Solve group buttons causes Parametric Design
to extract a value for this parameter from the constrained geometry.
Geometry-type constraints are often useful for determining the locations of
elements in the part. Suppose for example that you have defined several
expressions that need to know the location of a particular point in the part. An
easy way to pass this data is with a parameterized Refpoint constraint:

• Assign the Refpoint constraint to the model point you are interested in. Give
the parameter name Pt1 to this constraint as you assign it.

• Use the parameter definition table to convert Pt1 to a "Geometry" type
parameter.

• Now, whenever you Solve, the new location of the model point will be
extracted and assigned to Pt1. Your expressions can access the location by
referencing Pt1.

Removing Parameters
To remove parameters from the part:

1. Click Parametric and then, in the Show group, click Current.

The Current Constraints dialog box opens.

686 Creo Elements/Direct Drafting User's Guide: Fluent User Interface



2. Click Advanced.

The Advanced dialog box opens. It contains the parameter definition table.
3. In the Name column, click the parameter that you want to remove.
4. Click Remove.
Parametric Design does not allow you to remove parameters that are currently
assigned to a constraint or that are referenced by another parameter via
expression. To remove parameters that are assigned to constraints, first either Free
the constraint that corresponds to the parameter or assign a new value to it, then
Remove the parameter entry. To remove a parameter that is referenced by other
parameters, you must first remove the offending references by editing the
expressions that contain them.

Showing Parameters
The Show command in the parameter definition table highlights all elements in the
part that currently have parameters assigned to them. Highlighting is done by
displaying the constraint icons of these elements along with the corresponding
parameter names. Parameter labels will be displayed using the current text font.
Highlighting is in CYAN by default.
The Show highlighting is removed whenever the buttons in the Solve group are
invoked. Alternatively, you can click Clear and select All Types in the Generate
Constraints dialog box to remove the highlighting.

Setting Parameter Values
A common strategy in Parametric Design is to define your parameters so that the
entire constraint structure of a part depends on several "Value"-type parameters.
This strategy has several advantages:

• It is often possible to generate new variations by simply changing a few key
value-type parameters.

• In situations where a Designer or Engineer is responsible for designing
constraints for a master part and a Draftsperson is responsible for generating
variations, this strategy "isolates" most of the constraint structure from the
Draftsperson, who only has to modify the values of a few parameters to
generate variations.

Parametric Design facilitates this strategy by giving easy access to all the
currently set "Value" parameters in the parameter value table in the Current
Constraints dialog box. Rather than display the entire parameter definition table
whenever you want to change a "Value" parameter, you can display the Current
Constraints dialog box, which contains only "Value" parameters.
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Each entry in the parameter value table contains the name of a currently defined
"Value" parameter along with the value that will be assigned to that parameter by
the next Solve command. This value corresponds to the New Value or Expression
column of the parameter definition table. Only those parameters with a type of
"Value" appear on this column. If there are too many entries to view at once, use
the scroll bar beside the table. To change the value of a parameter, simply select
its entry and enter the new value. A full description of the parameter value table
can be found in Generating Variations on page 628.

Note
While you can enter an expression rather than a value into the parameter value
table, it is not recommended that you do so, because this changes the type of
the parameter from "Value" to "Expression," and thus removes its entry from
the parameter value table (but not from the parameter definition table).

Dimension Driven Modification

Roadmap
Read this chapter to learn how to modify geometry by modifying parametric
dimensions. To learn how to assign constraints explicitly read Working with
Parametric Design on page 633 instead. To learn how to create, assign, and
modify parameters read Parameters on page 679.

Overview
Dimension Driven Modification simplifies access to some of the power of
parametric modification. Geometry can be modified by simply selecting
dimensions and entering new values.
Constraints associated with a number or a parameter (angle, dimension, distance,
size, slope) can be considered parametric dimensions. Regardless of how they
were created, all parametric dimensions can be modified by using the buttons

under Dimension in the Modify group on the Parametric tab.

Viewing Parametric Dimensions

Display
To display parametric dimensions associated with selected geometry:
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1. Click Parametric and then, in the Modify group, click Dimension.

2. Click Show.
Displaying parametric dimensions may require the automatic creation of
temporary geometry (which is not visible). For example, dimensioning the radius
of a construction circle is not allowed, so a real circle will be created temporarily
for the display of parametric dimensions. Any temporary geometry is deleted by
the Parametric Design module as soon as parametric dimensions are removed
from the display.
Parametric dimensions can be displayed only when a part is fully and properly
constrained. If the part is under-constrained when you click Show and then
Dimensions, you are asked to confirm the running of Complete. Complete can be
executed reliably when the part is mostly constrained — if the geometry was
created with Design Intent Capture enabled, for example. But if the part does not
contain any constraints, Complete should not be run till some initial constraints
have been assigned. Refer to Working with Parametric Design on page 633 for
information on constraint assignment.

Note
Parametric dimensions are only associated with constraints that contain a
number or a parameter. Constraints such as parallel, horizontal, same size,
reference element, and so on will not have parametric dimensions associated
with them. A combination of constraint editing and dimension creation can be
used to construct any desired parametric dimensions.

Hide
To hide parametric dimensions associated with selected geometry:

1. Click Parametric and then, in the Modify group, click Dimension.

2. Click Hide.
Especially with large parts, the ability to selectively display and hide parametric
dimensions can reduce screen clutter. A designer can quickly focus on the
parametric dimension of interest.

Parametric Design with Creo Elements/Direct Drafting Fluent User Interface 689



Display Attributes of Parametric Dimensions

Color
All parametric dimensions are displayed with the same color. To set the color
value use PD_DEFAULT_DIM_COLOR. For example, to specify green as the
color for parametric dimensions type PD_DEFAULT_DIM_COLOR 0,1,0 in the
user input line and press ENTER.
All other attributes are controlled by the current settings of the dimension module.

Location
Parametric dimensions — unlike other dimensions — are displayed in default
locations. You can move them for easier viewing.
To move a parametric dimension:

1. Click Parametric and then, in the Modify group, click Dimension.

2. Click Move.

Note
If you have the Dimension Advisor Module enabled, the parametric
dimensions are placed according to the selection made in the Strategy box in
the Options settings of the Dimension Settings dialog box (the Automatic
check box should be clicked in the Options settings).

Modifying Parametric Dimension Values
Once parametric dimensions are displayed, their values can be modified.
Changing the value of a parametric dimension results in a corresponding change
to the geometry of a drawing. The drawing can be updated after every
modification, or the drawing update can be deferred until many parametric
dimensions have been modified.

Immediate Modification

Immediate specifies that all geometry should be updated as soon as the value
of a parametric dimension is modified. This method can be useful with small
drawings — where the speed of updating the geometry and redrawing the screen
is not a concern. It can also be useful for experimenting with several different
values for one parametric dimension.
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To use Immediate:

1. Click Parametric and then, in the Modify group, click Dimension.

2. Click Immediate.
3. Type the new value in the user input line and press ENTER.

Deferred Modification

Deferred specifies that geometry should not be modified until the user makes
an explicit request. This method improves performance, because the drawing is
updated only once — even if the values of several parametric dimensions have
been modified.

Deferred is actually necessary when a set of parametric dimension
modifications do not have valid intermediate geometry. For example, consider a
triangle with sides of lengths 3, 4, and 5:

Figure 222. Triangle Requiring Deferred Modification

It would not be possible to change the side lengths to 30, 40, and 50 using
Immediate, because no valid triangle can be created with a combination of old and
new lengths.

Note

Often a combination of Immediate and Deferred is useful when
several parametric dimensions need modification.

To use Deferred:

1. Click Parametric and then, in the Modify group, click Dimension.
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2. Click Deferred.
3. Type the new value in the user input line and press ENTER.

Swapping Parametric Dimensions
The parametric dimensions generated by Complete many not be appropriate in all
cases. In these cases it is possible to create a traditional dimension and then
indicate that it should become a parametric dimension. For example, consider this
drawing and the parametric dimensions that were generated with Complete:

Figure 223. Parametric Dimensions Generated by "Complete"

If the center of the arc should be located from the right side, the buttons in the

Dimension tab can be used to create an appropriate dimension. Then click

Swap under Dimension in the Modify group on the Parametric tab, and the
newly-created dimension is selected to replace the parametric dimension
generated by Complete. The resulting parametric dimensions are:

Figure 224. Parametric Dimensions After Swapping
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Restrictions
In order for an exchange to occur both dimensions must control the same
geometry. For instance, in the example above the height of the rectangle could not
be exchanged for the distance from the center of the arc to the right edge.

Design Intent Capture

Roadmap
Read this chapter to learn how to create constraints as geometry is created. To
learn how to assign constraints and parameters explicitly, read Working with
Parametric Design on page 633 instead.

Overview
Design Intent Capture generates and assigns parametric constraints as geometry is
constructed. Constraint types depend on the method used to construct geometry.
For example, when creating one line perpendicular to another line a perpendicular
constraint will be created and associated with the two lines.
Design Intent Capture improves the speed, accuracy, and quality of parametric
constraint definition by combining the separate steps of geometry creation and
constraint assignment into one action.
Without Design Intent Capture constraints must be assigned after geometry has
been created. This forces the designer to remember the relationships between
geometric elements and record them by assigning constraints. Even worse, if the
geometry was created by someone else the designer must try to reason backward
and guess at the appropriate constraints. These problems are avoided by using
Design Intent Capture.
The quality of constraints in the final parametric drawing is usually much better
when Design Intent Capture is used compared with relying on Complete to
generate all constraints. Quite possibly a drawing will be fully constrained when
Design Intent Capture is used. But even if some additional constraints are
required, Complete will have a much better starting point.

Flexibility
Although Design Intent Capture generates constraints, the designer is free to
modify or remove any of them. The constraints are not history-based, so they may
be modified regardless of the order in which they were created. Any constraint can
be altered or removed without negating all of the work that occurred after the
constraint was generated.
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In other words, Design Intent Capture is a method of generating constraints — as
are Complete and direct assignment. All of the Parametric Design module's
constraint editing capabilities can be used on them. Refer to Working with
Parametric Design on page 633 for more information on editing constraints.

Enabling, Disabling and Inquiring
To enable Design Intent Capture:

• Type UA_DESIGN_INTENT ON in the user input line and press ENTER.
To disable Design Intent Capture:

• Type UA_DESIGN_INTENT OFF in the user input line and press ENTER.
To inquire the on/off status of Design Intent Capture use the arithmetic function
UA_GET_DESIGN_INTENT. A value of 0 is returned if Design Intent Capture is
disabled, and a value of 1 is returned if Design Intent Capture is enabled. For
example, to display the current on/off status of Design Intent Capture type
DISPLAY (UA_GET_DESIGN_INTENT) in the user input line and press
ENTER.

Elements Affected
The following methods of geometry creation generate parametric constraints when
Design Intent Capture is enabled:

• point
• line
• circle
• arc
• fillet
• chamfer
• construction line
• construction circle
• text
• equidistance
• overdraw

Constraint Creation
The Parametric Design module considers two guidelines when determining the
appropriate constraints to generate with Design Intent Capture:
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• construction technique
• CATCH information

Construction Technique
Different constraints will be generated depending on the method of geometry

creation. The Parallel, Perpendicular, Horizontal, Tangent by 2
buttons in the Draw group on the Drafting tab convey different intentions, and all
will result in different constraints.
Even if two drawings look identical, they probably will have different constraints
if different construction techniques were used to create them. For example,
consider these two lines. Each is connected to a fixed point at one end. But one

was created with 2 Points and the other was created with Angle & Length.
Both drawings look the same:

Figure 225. Lines Displayed Without Constraints

But the constraints are different:

Figure 226. Lines Displayed With Constraints

CATCH Information
Design Intent Capture also considers CATCH information when determining
which constraints to generate. With Copilot enabled, the ability to catch to
tangencies, etc. is much easier.
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For example, assume Copilot is enabled and 2 Points is invoked. If the
endpoints of the line are picked so that they are approximately tangent to two arcs,
then two tangent constraints will be created.

Note
Because different constraints are generated based on construction technique
and CATCH information only advanced users should enable Design Intent
Capture when macro files are being created or input.

Operations on Existing Geometry
In addition to operations which create geometry, Design Intent Capture applies to
operations that modify geometry. Constraints will be created, deleted, modified, or
transferred appropriately for different modification operations.

Delete
When geometry is deleted all relational parametric constraints will be transferred
to other geometry whenever possible. For example, consider three perpendicular
lines:

Figure 227. Perpendicular Lines with Constraints

If the middle line is deleted the perpendicular constraints associated with it will
also be deleted. But a new constraint will be generated so that the parallelism
between the remaining lines is kept:
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Figure 228. One Perpendicular Line Deleted

Split
When elements are split constraints will be assigned to maintain consistency
between the pieces. Each portion of a split line will be given a collinear constraint.
Split circles and arcs will be assigned same size constraints.
In addition to the basic constraints for split lines and arcs, other constraints may
need to be modified or assigned. For example, if a line with a size constraint is
split, a distance constraint will be created and associated with the endpoints of the
original line.

Merge
When elements are merged constraints will be combined whenever possible. For
example, when line segments are merged, the collinear constraint associated with
them will be removed (if it exists). Relational constraints between the segments
and other elements will be associated with the new, merged line.

Modify Keep, Stretch Keep, Mirror Keep

Geometry copied with the Modify buttons (Keep check box clicked) or Stretch
(Keep check box clicked) will also have all associated constraints copied.

Note
No constraints will exist between the original and the new copies of the
geometry.
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Mirrored elements will be assigned constraints so that both portions of the
geometry continue to have the mirror property. In other words, once geometry is
mirrored with Design Intent Capture both portions will remain mirror images of
each other — even as other modifications are made.

Modify NoKeep, Stretch NoKeep, Change_fillet
Design Intent Capture will attempt to modify constraint values without changing
any constraint types. For example, the radius of a fillet or the distance between
two elements may be changed, but a perpendicular constraint will not be changed
to a collinear constraint. If Design Intent Capture is not able to calculate a new
value for a constraint, the constraint will be eliminated.

Advanced Topics and Tips

Roadmap
The information in this section is mostly of interest to advanced Parametric
Design users. If you are new to Parametric Design, skip this section for now and
come back to it later.
Parametric Design has a number of useful features and applications that may not
be immediately obvious to the casual user. This chapter describes several of these
and provides some in-depth information on the workings of Complete and Solve.

Geometry Cleaning
Complete and Solve both have the ability to recognize and compensate for minor
geometric inconsistencies in a part. Common problems such as lines which are
slightly out of parallel, elements with zero length or radius, and small gaps
between "tangent" elements can be recognized and corrected.

Note
The "cleanup" capabilities used by Complete and Solve group buttons are

separate from the Clean Pnt, Clean Duplicate and Clean Stacked.
See Working with Parametric Design on page 633 for more information on the
Clean options.

Parametric Design handles most geometric inconsistencies by incorporating
tolerances into several of the rules used by Complete to extract constraints from a
part. If an element does not precisely fit the requirements for a given constraint,
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but is within the tolerance, the constraint is assigned anyway. Once Complete is

done, you need only No Keep in the Solve group on the Parametric tab to
adjust these elements into the precise configuration given by the constraint.
For example, Complete can extract a Horizontal constraint for any line element
with a slope that is 0 ± the current angular tolerance (given by PD_AUTO_
ANGLE_TOLERANCE). If the tolerance is 0.5, then lines with slopes of 0 ± 0.5
can be assigned Horizontal constraints. When the Solve group buttons are clicked,
these lines are adjusted as needed to become truly horizontal.
The following tolerances are used by Complete:
PD_AUTO_ZERO_DISTANCE_TOLERANCE: Specifies the absolute tolerance
used by Complete to compare a distance to zero. This tolerance is used to detect
coincident points, collinear lines and Point on constraints. Must be greater than or
equal to 0. The initial setting is 0.000001 mm.
PD_AUTO_SAME_DISTANCE_TOLERANCE: Specifies the absolute tolerance
used by Complete to compare two non-zero distances. Used in several areas; to
check whether two circular elements have the same radius, for example. Must be
greater than or equal to zero. The initial value is 0.000001 mm.
PD_AUTO_ANGLE_TOLERANCE: Specifies the absolute tolerance used to
compare angles. This tolerance is applied, for example, when checking whether
two lines are parallel or a single line is horizontal. Must be greater than or equal to
zero. The initial value is 0.000001 radians.
PD_AUTO_TANGENT_TOLERANCE: Specifies the absolute distance tolerance
used by Complete to check whether two elements are tangent. Applied only if one
of the extracted elements is circular. The tolerance is used to compare the radius
of the circular element to the distance from the circular element center point to the
other element. The number supplied must be greater than or equal to zero. The
initial setting is 0.000001 mm.
By default, these tolerances are set very small to ensure that Parametric Design
only compensates for true anomalies in the part and does not remove or "adjust
away" small details that are important to you. Setting a tolerance to 0 effectively
eliminates its effect on Complete. Depending on the type of parts you normally
work with, you may want to experiment with different values for each of these
tolerances until you arrive at a set of tolerances that provides maximum cleaning
without removing important details. Tolerances may be redefined on the Creo
Elements/Direct Drafting command line, and the default values can be changed by
editing the pd_def.mac file.
An additional tolerance, PD_RESOLVE_MERGE_TOLERANCE, is used directly
by the Solve group buttons to merge coincident points and remove very small
("zero length") elements from variations. Points that are within this tolerance are
merged, thus removing duplicate points and eliminating elements that are smaller
than the tolerance. The default, which is defined in pd_def.mac, is 0.000001
mm.
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Caution
It is usually a good idea to disable tolerance-based merging in motion-study or
kinematics applications where several entities are moved around in close
proximity to one another. In these applications, it is often the case that two
entities which are intended to remain separate come into close enough contact
that a point on each will fall within the merge tolerance. If merging is on, the
two entities will be effectively fused together, preventing further independent
motion. To disable merging, set the tolerance to -1.

A Simple Sketch Input Implementation
The preceding discussion of geometry cleaning has assumed that the tolerance
capabilities of the solver will be used to correct for small deficiencies in the input
geometry. Suppose however, that you expect substantial inconsistencies in a part
and that you don't care if you have to adjust it substantially to clean it up. A
"sketch input" application is a common situation where these assumptions would
be true. In these situations, you can use Parametric Design with relatively large
tolerances to "square up" a quickly-drawn part.
The following macro implements a simple "sketch input" application using
Parametric Design:
DEFINE SquareUp {A simple drawing
straightener}

{Accept linear and angular tolerances as arguments}

PARAMETER LinearTolerance

PARAMETER AngularTolerance

{Set adjustment tolerances to the supplied values }

PD_AUTO_ZERO_DISTANCE_TOLERANCE LinearTolerance

PD_AUTO_SAME_DISTANCE_TOLERANCE LinearTolerance

PD_AUTO_ANGLE_TOLERANCE AngularTolerance

PD_AUTO_TANGENT_TOLERANCE LinearTolerance

PD_RESOLVE_MERGE_TOLERANCE LinearTolerance
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{If AUTO must create new points, make sure we can delete them
later}

ADD_CURRENT_INFO "DELETE" END

{Load the entire current part into the zone}

PD_ZONE_ADD ALL {ZONE Add Mult ALL}

{Generate constraints; tolerances are applied}

PD_RESOLVE GENERATE {AUTO}

{Resolve conditionally. If the preview is OK, accept the
change}

PD_RESOLVE PREVIEW {SOLVE Preview}

WINDOW FIT

READ 'Please enter CONFIRM (c) or UNDO (u)' DEFAULT 'c'
Accept_flag

IF ((Accept_flag = 'c') OR (Accept_flag = 'C'))

PD_RESOLVE REPLACE {SOLVE NoKeep}

ELSE

END

END_IF

{If AUTO had to generate ref. points to constrain, remove them
now}

DELETE SELECT INFOS "DELETE" ALL END
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{Cleanup: remove constraints, zone data, DELETE info. reset
tolerances}

PD_FREE NOBAN ALLTYPES CONFIRM

PD_ZONE_REMOVE ALL

CHANGE_CURRENT_INFO "DELETE" "" END

PD_AUTO_ZERO_DISTANCE_TOLERANCE 1E-06

PD_AUTO_SAME_DISTANCE_TOLERANCE 1E-06

PD_AUTO_ANGLE_TOLERANCE 1E-06

PD_AUTO_TANGENT_TOLERANCE 1E-06

PD_RESOLVE_MERGE_TOLERANCE 1E-06

{Display what I've made!}

REDRAW

END_DEFINE {of SquareUp}

To get a feel for how this macro works, copy the text above into a file and then
input the file to Creo Elements/Direct Drafting.

Now quickly create the part below. Use Polygon under Line in the Draw
group on the Drafting tab with the Creo Elements/Direct Drafting catch-mode set
to OFF. Try to reproduce the figure as shown, but don't worry about
inconsistencies in your part.

Figure 229. Sample Polygon

Now type SquareUp 2 5 in the user input line and press ENTER.
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If all went well, Parametric Design has cleaned your "sketch." Specifically, gaps
of 2 mm or less should now be closed. Lines that were within +/- 5 degrees of
horizontal or vertical should now be "squared up." Also, lines that were not quite
collinear (+/- 2 mm) should now be snapped into place, Figure 230. A Cleaned
Sketch on page 703.

Figure 230. A Cleaned Sketch

If the first pass at this didn't work for you (remember, SquareUp is a very simple
macro that will handle many, but certainly not all cases!), reject the results and
experiment with different values for the length and angle tolerances.
As you experiment with SquareUp, it may be helpful to try it with severely
flawed sketches and to give "unreasonable" values for the linear and angular
tolerances to learn the strengths and weaknesses of this technique.

Zone Gymnastics
Parametric Design's zone mechanism is implemented using Creo Elements/Direct
Drafting infos. The info text PD_ZONE is used to specify which drawing elements
are in the Parametric Design zone. Any drawing element in the current part that
has the info text PD_ZONE attached to it is included in the zone. By treating the
zone as simply a collection of element infos, several powerful options for working
with the zone become available. The following sections contain a few ideas.

Automatic Inclusion
As shipped, the pd_def.mac file contains the string:

ADD_CURRENT_INFO "PD_ZONE" END

This causes all new geometry created during your Creo Elements/Direct Drafting
session to be automatically included in the zone (i.e., the PD_ZONE info is added
to all new geometry). You can turn off the auto-inclusion feature at startup by
removing this line from pd_def.mac. To turn off auto-inclusion from within
Creo Elements/Direct Drafting, you can type:
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CHANGE_CURRENT_INFO "PD_ZONE" ""

Note
These functions will not affect geometry input from an MI file. If the contents
of an MI file were in the zone when they were saved to the file, they will be
put into the zone when the file is restored. If the contents were not in the zone
when the file was created, they are not placed into the zone when the file is
restored.

Alternate Add/Remove Schemes
You can use Info commands instead of the screen menu to add or remove elements
from the zone. This can be useful when using Parametric Design from within a
macro. Typical commands might be:

Command Description
ADD_ELEM_INFO "PD_ZONE" Add selected elements to the zone
CHANGE_ELEM_INFO "PD_ZONE" "" Remove selected elements from the

zone

Pre-Define Multiple Zones
In an evolving, complex part, you may find that several different areas are
frequently being modified with Parametric Design. Each time you want to work
on a different area of the part, you need to redefine the contents of the zone. If
your part is truly complex, this may be a time-consuming task. If you want to
make sure that the same elements are always included in the zone each time you
work in a particular area, you'll have to be very careful when you assign elements
to the zone. This task may become even more difficult and error prone if several
people are working on the same part.
One solution to this problem is to use infos to pre-define several "quasi-zones" in
a part and then to activate each one as needed. Suppose, for example, you have a
part with three different areas that must regularly be modified with Parametric
Design. Try the following strategy:

• First, clear all zone infos from the part:
CHANGE_GLOBAL_INFO "PD_ZONE" ""

• Next, assign to all the elements in the first area an arbitrary info. Let's call it
"AREA_1": ADD_ELEM_INFO "AREA_1" (select elements)
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• Repeat this step for the second and third area, giving each its own info: ADD_
ELEM_INFO "AREA_2" (select elements) ADD_ELEM_INFO "AREA_3"
(select elements).

Now that each group of elements has a unique info associated with it, you can
easily "activate" each group for Parametric Design by swapping its info text for
the PD_ZONE info text and "deactivate" it by restoring the old info:

• To load the elements in "AREA_1" in the zone: CHANGE_GLOBAL_INFO
"AREA_1" "PD_ZONE".

• To remove "AREA_1" elements from the zone and load "AREA_3" elements
into the zone: CHANGE_GLOBAL_INFO "PD_ZONE" "AREA_1"
CHANGE_GLOBAL_INFO "AREA_3" "PD_ZONE".

• To remove "AREA_3" elements from the zone: CHANGE_GLOBAL_INFO
"PD_ZONE" "AREA_3".

Parametric Control of Splines
Creo Elements/Direct Drafting currently supports two types of spline entities:
rational cubic splines (C-splines), which are created with the SPLINE function,
and B-splines, which are created with the BSPLINE function. Earlier versions of
Creo Elements/Direct Drafting only supported C-splines. Parametric Design can
be used to parametrically control the shape of any spline, but the procedure for
constraining C-splines and the newer B-splines differs somewhat. The following
two sections give some tips and techniques for controlling each type of spline.

C-Splines
To parametrically control the shape of a C-spline, you first place point elements
on the data points used to create the spline and then assign the appropriate
constraints to these points to actually control the shape of the spline. Any
constraint that can be assigned to a point can be used.
To find the location of the C-spline's data points, turn on vertices with SHOW
VERTEX ON. Before assigning point elements to the spline data points, you
should also make sure that splitting is turned off.
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Note
By default, Creo Elements/Direct Drafting converts all rational splines in a
drawing into B-splines when you load it. The conversion will invalidate any
constraints that you have assigned to the data points of these rational splines.
Refelem constraints which are assigned directly to spline elements are not
invalidated, and will be carried over from the rational spline to the new B-
spline.

To prevent spline conversion and the subsequent invalidation of constraints on
rational splines, you must enter SPLINE_CONVERSION OFF prior to loading
any master part that contains constrained rational splines. Alternatively, you
could include this line in the Creo Elements/Direct Drafting pd_def file to
permanently disable spline conversion.

B-Splines
Unlike C-splines, which are controlled via their data points, the shape of a B-
spline can only be controlled by constraining its control points. To parametrically
set the shape of a B-spline, you must first display its control polygon, either with
the CNTRL POLY command on the screen menu, or by entering SHOW_CPOLY ON
and selecting the B-spline. With the control points displayed, use same method as
for C-splines to constrain them: place point elements on each control point and
then constrain those point elements. At solve time, as the control points move, the
shape of the spline will also change.
If you assign constraints only to the data points of a B-spline and it appears that
they are causing the spline to change shape, it's likely that splitting was on when
you placed the point elements on the data points and you are now manipulating
multiple B-splines!

Rigid Bodies: Applications and Tips
Rigid bodies are useful for a wide range of applications. The list below presents a
few ideas.

• Motion studies of linkage assemblies becomes much simpler. Make each link a
rigid body. Then use constraints to describe the motion between the links.
Your model will not be cluttered with constraints for the links, so you can
concentrate more on the interactions between links.

A feature of rigid bodies that is especially useful for motion studies is the fact
that a single element can legally belong to more than one rigid body. A single
point element included in two rigid bodies acts much like a hinge between
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them, while a single construction line works much like a slider. An arc or line
segment shared by two rigid bodies serves to "weld" them together.

• Parametrics can now control (to some degree) subparts and/or shared subparts.
Collect each subpart into a rigid body along with some geometry from the
current part. Construction geometry is often a good choice for this. You can
control the position and orientation of each subpart through constraints on the
construction geometry.

• Complicated parts often have large amounts of geometry which you want to
move as a group. Because the automatic constraint generator has a poor notion
of locality, it is usually simpler and more predictable to identify these groups
of entities manually.

• Control hatch angle. Suppose you want a hatching to remain at a given angle
to some line. Create a construction line collinear to this line (and constrain it
to be collinear), then make a rigid body out of the construction line and the
hatching. Use the construction line instead of the original line in the rigid body
so that you don't prevent the original line from changing size by including it in
the rigid body.

• Control the location and orientation of symbol subparts.
• Provide a form of model cleaning without modifying geometry. Stacked

elements, unclosed polygons, etc. can wreak havoc on parametric applications.

The usual approach to solving these problems is to use the Clean Pnt,

Clean Duplicate, and Clean Stacked to merge points and remove stacked
elements. In cases where it is not possible or desirable to clean the original
geometry, you may be able to use rigid bodies to isolate problem geometry
from the solver. Simply collect problem areas into rigid bodies so that the
solver does not need to examine individual elements too closely. Of course,
this approach may limit what you can accomplish with parametrics, as the
contents of the rigid bodies can only be moved and rotated, not resized.

Here are a few potential trouble spots that you should keep in mind while working
with rigid bodies:

• Be careful when creating a rigid body that contains only subparts. While these
are perfectly valid rigid bodies, remember that you cannot assign constraints to
subparts. As a result you would not be able to control the position or rotation
of the rigid body via constraints. It will remain in its original position in all
subsequent variations.

• Similarly, be careful when creating rigid bodies that contain just a subpart and
a single point element from the current part. Such a rigid body can be
translated via constraints, but its rotation cannot be changed.
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• A subpart may be assigned to more than one rigid body. At solve time,
however, it will always remain associated with one of the rigid bodies to
which it was assigned. All other rigid body associations will be ignored.

• Finally, consider the case of a rigid body that contains only a subpart and a
construction line. In this case it is possible to control the rotation of the rigid
body and translations that are perpendicular to the axis of the construction
line, but not translations along the axis of the construction line. The subpart
will retain it's original position along the axis of the construction line
regardless of subsequent rotation and off-axis translation.

Implementing Replication in Parametric Design
A common requirement when creating a family of parts is to have a particular
geometric feature replicated a variable number of times, depending on the overall
size or configuration of the surrounding geometry in each variation. A circular
plate, for example, might be expected to have 8 holes if its radius is 4 inches, and
12 holes if the radius is 6 inches.
While Parametric Design provides no functionality to perform such modifications
directly, the following procedure often does the trick:

1. Define the zone to be all of the geometry in the part except for the portion that
is to be replicated. Constrain the geometry in the zone as if you were setting
up a master part.

2. Create some additional parameterized constraints that can be used to query the
result of a variation. These can be Refpoint, Dimension, Distance, Angle, Size,
or Slope constraints. Assign these constraints so that they return the values
needed to determine the number of replications needed.

3. Write a macro to query the necessary parameters, compute the number of
replications from this data, and create those replications in the correct location.

4. Finally, write a macro which first invokes PD_RESOLVE to solve for the
geometry in the zone, and then calls the macro defined in the previous step to
take care of the replications.

A number of alternative strategies can be derived from this procedure. For
example, if both the number of replications and the size of the replicated geometry
needs to vary, consider using two different zones, one for the surrounding
geometry and one for a single instance of the replications. In this case, the final
macro might have the following logic:

1. Run PD_RESOLVE for the surrounding geometry.
2. Use PD_PARAM_INQ to read out the results.
3. Compute values for the input parameters for the instance of the replication

geometry from the result you've just obtained.
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4. Change the current zone to the replication geometry.
5. Use PD_PARAM_FIX calls to load the input parameters needed for the

replication geometry.
6. Run PD_RESOLVE for the replication geometry.
7. Use the buttons in the Modify tab to move, rotate and copy the replication

geometry as needed.

Allowing Rotation
It is often desirable for variations of a part to be able to rotate about a given point
as a condition for their creation. The simplest way to allow a part to rotate is to
define the reference constraints on the master part to be a reference point and a
line slope. Usually it is best if the reference point is on the line whose slope is
being constrained. After applying the reference constraints, constrain the rest of
the part without using slope constraints (i.e., no Slope, Horizontal, or Vertical
constraints. If you use Complete to generate constraints, make sure to check for
any system-generated slope constraints, and change these to angle-type
constraints.
Now by simply changing the value of the constrained slope the entire part will
rotate about the reference point.

Working with Multiple Parts
Parametric Design constraints and parameters are all local to a given Creo
Elements/Direct Drafting part. Thus, subparts can be stored independently from
the rest of a drawing with their complete parametric definition, and parameterized
subparts can be loaded into a drawing without corrupting the constraint and
parameter data for other parts already in the drawing.
There are two situations, however, in which the parametric data from more than
one part can come into contact. The interactions that occur are worth noting:
You can explicitly set up interrelationships between parts by writing macros like
the one given in the "Macros" example in Examples on page 715. This example
shows how a parameter in one part can have its value depend on the resulting
geometry in another part. Since a parameter can refer to an angle, slope, distance,
size, or dimension, and since any number of points can be parameterized for
output query, this method provides a very general solution to the problem.
A second (often less desirable) form of interaction can occur as a result of the

Creo Elements/Direct Drafting Smash and Gather buttons. Smash

and Gather have the following behavior:
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• If you use Gather without copying a subset of the constrained elements in
a parameterized part, all of the constraint and parameter data for that part is
lost.

• If you Gather all of the constrained elements in a part or Smash one
or more subparts, then the constraint and parameter data will be kept. Note,
however, that if the same parameter name exists in two or more of the parts
being merged, the results can be unpredictable. Generally, if there is a conflict
between parameter names, the parameter assigned to the part that is highest in
the parts tree is maintained. If both parts are at the same level, one or the other
will be selected, but it is impossible to predict which.

Using Modify With Parametric Design
The Creo Elements/Direct Drafting Modify tab buttons can generally be used along
with Parametric Design to modify geometry. The buttons on the Modify tab can be
used successfully between the time that a part is constrained and the time that
Solve is issued, but modifications during this time also affect the results of Solve.
These effects may be surprising if you are not expecting them, but can be very
useful once understood.

• If a parameterizable constraint (that is, Angle, Size, Distance, Slope, or
Dimension constraint) is assigned without giving an expression or parameter
name, then the value of the constraint is determined at solve time. Thus, any
modifications you make to such elements will be recognized by Solve. For
example, if you assign a valueless Size constraint to a 7 inch line, and then
Stretch that line to 12 inches prior to solving, Solve will keep the line at 12
inches.

• Collinear, Parallel, Perpendic, and Tangent constraints all have orientation
characteristics which can be affected by Modify.

○ The angle between two Parallel or Collinear lines can be 0 or 180 (see the
explanation of Slope constraints in Constraint Types on page 655). Solve
will use whatever angle is closest to the actual positions of the lines at
solve time.

○ Similarly, the angle between two Perpendic lines can be 90 or 270 degrees.
The preferred angle is the angle that it is closest to at solve time.

○ If a line and circle are constrained Tangent, Solve attempts to find a
location for the circle center point on the same side of the line that it
started out on at solve time.

○ If two non-concentric circles are constrained Tangent, there are three
possible solutions. Either the first circle will be inside the second, the
second circle will be inside the first or both circles will be tangent
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externally. Solve attempts to maintain the particular relationship that is in
place at solve time.

In all of the above cases, Modify can be used to change the location of the
constrained elements and thus change Solve's preferred solution, even
though the constraints haven't changed.

• Geometry constrained as reference elements can be modified at any time
before solving. Solve always leaves such elements in their current position at
solve time.

Modifying Constraint Icons
Parametric Design constraint icons are simply text elements whose contents and
location are managed by the software. While there is nothing to prevent you from
modifying the location, text attributes, or contents of the icons with Creo
Elements/Direct Drafting, doing so has several implications that you should be
aware of:

• Each constraint icon string is derived from the constraint and from the
applicable icon viewing commands (for example, Show and Clear). Modifying
the contents of the string, or deleting the string altogether, doesn't alter the
underlying constraint in any way.

• Copying an icon string or placing the leader line on a different element doesn't
copy the constraints to that element. In fact, a copy of an icon string is not
recognized by Parametric Design and becomes just another text element that
can be added to the zone and constrained!

• Any change in the attributes of an icon string, such as slant, will be forgotten
when the entire icon string is cleared from the screen. The next time the icon
string is constructed it will use the default settings for new text elements.

• The constraint icon characters are part of the hp_symbols font. These
characters are inserted into locations 65-96 of hp_symbols when Parametric
Design is enabled. You should not attempt to use these locations either before
or after Parametric Design is enabled. Unpredictable results can occur.

Automatic Constraint Generation
To extract constraints from an existing part, Complete uses the Parametric Design
solver to apply a set of extraction rules to the geometry in the zone. Understanding
how these rules work will help you to anticipate what kinds of constraints are
generated by Complete.
When you select Complete, the solver first scans the geometry for existing
constraints. If these fully constrain the part, Complete is done. If the existing set of
constraints does not fully constrain the part, the solver then starts to evaluate the
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under-constrained members of the part and assign new constraints to them
according to the rules listed below. Each time a new constraint is extracted, it is
added to the list of known constraints and the part is checked again to see whether
or not it is now fully constrained. As soon as it is, the process stops. Otherwise,
the solver continues to go down the list of rules, adding constraints and checking
until the part is fully constrained. The solver will not go on to a new rule until all
possible constraints have been extracted according to the current rule. A rule will
not be applied to elements that have the Ban flag set for the constraint type
assigned by the rule. The rules and their basic functions are (in order of
application):

Rule Action
Special
Symmetry lines

If PD_AUTO_SYMMETRY is on, find all lines that have the
auto-symmetry linetype and color and assign them Symmline
constraints.

Collinear Lines Find collinear lines and assign them Collinear constraints.
Coincident
Points

Find coincident points and constrain them together.

Points On
Geometry

Find suitable elements and assign them Point on constraints.

Mirrored
Elements

If symmetry lines are defined, find mirrored elements and
assign them Mirror constraints.

Dimensions Constrain any free dimensions to their current value.
Fillets Find arcs that qualify as fillets and assign them Fillet

constraints.
Parallel Lines Find parallel line elements and assign them Parallel constraints.
Perpendicular
Lines

Find perpendicular elements and assign them Perpendicular
constraints.

Tangent
Elements

Find tangent linear or circular elements and assign them
Tangent constraints.

Horizontal
Lines

Assign Horizontal constraints to horizontal elements.

Vertical Lines Assign Vertical constraints to vertical elements.
Mirrored Points If symmetry lines are defined, find mirrored points and assign

them Mirror constraints.
Same Radius Find circles with the same radius and assign Samesize

constraints.
Free Angle Find elements with free slopes and assign Angle constraints.
Free Slope Find elements with free slopes and assign Slope constraints.
Free Radii Find circles with free radii and assign Size constraints.
Free Length Find lines with free lengths and assign Size constraints.
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Rule Action
Free Elements Find any remaining free elements and constrain them with

Distance and/or Refelem constraints.
Free Parameter Look through the parameter table. For all parameters that do

not have a set value, assign the current value.

When extracting constraints from the part, the solver must determine the location
and connectivity of each element in order to decide if that element is a suitable
candidate for the constraint type currently being assigned. The user can specify
several tolerances for the solver to use when determining an element's location
and connectivity. These tolerances, described in detail in Geometry Cleaning on
page 698 above, allow the solver to handle minor inconsistencies that may occur
in the part.
Finally, after all the geometry has been examined and all new constraints have
been extracted, Complete goes back through the part looking for redundant or
unused constraints. These are removed. For example, if a line element is found
that is constrained horizontal and is also constrained collinear with another line
that is constrained horizontal, the horizontal constraint can be freed from the first
line.

A Short Description of the Solver
The Parametric Design solver is a constraint solution kernel. The input to this
kernel is a list of the geometric elements in the zone and the set of topological and
metric constraints assigned to the geometry. Using the geometry list and
constraints, the kernel can solve for the (new) location of the geometry.
The kernel is really just a smart sequencer of solution steps. Each step determines,
or partly determines, some geometric entity (point, line, etc.) This is done by
applying one (or more if necessary) constraints and some adjacent fixed entities to
make a change in some other entity. When a change is made to an entity,
constraints associated with that entity are scanned to see if one or more might be
applicable.
Once the solution sequence has been determined, an expanded set of algebraic
closed-form algorithms is invoked, rather than an iterative numerical technique.
These algorithms employ simple geometrical constructions, such as curve/curve
intersectors. The kernel is designed for speed and robustness, and to minimize
calculation error.
One of the limitations in the kernel is that coupled or circular constraints are not
resolved, since they usually imply a simultaneous system of equations, which the
kernel does not attempt to solve. In these situations, the kernel calls the automatic
constraint generator, which proposes an alternative set of constraints.
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How Expressions are Evaluated
User expressions for parameters are evaluated when all of the independent
parameters are known. When it is time to evaluate an expression, Solve constructs
the following macro:

DEFINE Pdeval
PARAMETER <independent parameter name 1>
:
PARAMETER <independent parameter name N>
<user expression>

END_DEFINE

The dependent parameter is then assigned to the value of

Pdeval <value of independent parameter 1> ...

For example, if the expression for parameter A is (B+10) and at some point in the
solution process B becomes 6, then Pdeval will be:

DEFINE Pdeval
PARAMETER B
(B+10)

END_DEFINE

And A is assigned to be the result of

Pdeval 6

A syntax error can occur during the evaluation. When this happens, a message is
displayed indicating which dependent parameter has the faulty expression and
Solve is terminated. Since the offending expression is the last expression to be
evaluated, you can view it by running EDIT_MACRO Pdeval immediately after
the failure occurs. This procedure may point out problems that might otherwise
escape attention, since there is very little syntax checking done when the
expression is defined.
For example, if the above sample expression were (rad+10) then the above macro
would be:

DEFINE Pdeval
(rad+10)

END_DEFINE

which fails because rad is a keyword and keywords are not recognized as
parameters, even if there was a parameter called Rad.
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Invisible Geometry
As constraints are created the Parametric Design module may need to create
points and construction lines to serve as reference geometry. For example, when
Design Intent Capture is enabled and LINE PARALLEL is invoked construction
lines are created between the original and new lines, so that the two lines will
remain both parallel and the same length.
Invisible Geometry is managed completely by the Parametric Design module.
Whenever delete, modify, or stretch operations are performed on real geometry,
the necessary changes are made to invisible geometry.

Viewing
Invisible geometry is displayed whenever an associated constraint is displayed.
Typically constraints are displayed in the Display dialog box.
Viewing invisible geometry can be helpful in understanding the relationship
between constraints and geometry.

Attributes
The only two types of invisible geometry that are created are points and
construction lines.
PD_NEW_POINT_VISIBILITY and PD_NEW_C_LINE_VISIBILITY
determine whether or not invisible geometry created by the Parametric Design
module should be displayed at all times or only when constraints are displayed.
Allowable qualifiers are VISIBLE and INVISIBLE.
Other functions that set display attributes of invisible geometry are:

• PD_NEW_POINT_COLOR

• PD_NEW_C_LINE_COLOR

• PD_NEW_POINT_LINETYPE

• PD_NEW_C_LINE_LINETYPE

Examples

Roadmap
Work through the examples in this chapter to familiarize yourself with the
Parametric Design software. If you have not yet done so, you should read
Introduction on page 624 before continuing. If you are not familiar with Creo
Elements/Direct Drafting, we also recommend that you read through Creo
Elements/Direct Drafting User's Guide before continuing.
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Introduction
This chapter contains several examples that will help you become familiar with
Parametric Design tools and techniques.
All the examples assume that you are at a workstation, have Creo Elements/Direct
Drafting up and running, and that Parametric Design is installed.
The first example introduces all the Parametric Design tools, proceeding step-by-
step through an extended session with a simple drawing. We strongly recommend
that you spend a little time going through this example before going on to the
others. Subsequent examples present particular techniques or applications that you
are likely to encounter as you use the software. These examples assume that you
are comfortable with the Parametric Design interface.
The Creo Elements/Direct Drafting parts used in the examples are included online
with the software. They are installed as uncompressed MI-format files in the pd_
demos\ directory. Several of the examples depend on information in these files,
so we encourage you to load each file as you work through the corresponding
example.
The examples were chosen to be simple, and yet introduce you to the breadth and
depth of this product. After going through these examples and carefully
considering the questions at the end of each one, you should have developed a feel
for nature of parametric design.
It would be a mistake to hope that you will be an expert Parametric Design user
after just using these examples. In the real world, geometry is often more
complicated. Models are underdimensioned, have unwanted symmetries, suffer
from geometric inaccuracies, or have other "features" that are difficult for the
automatic constraint generator to interpret correctly.
There are two rules of thumb that apply when using Parametric Design:

• If it isn't clear to you, at least in general, how a part should change in response
to a modified dimension, then AUTO will likely have trouble as well.

• The better you understand the interplay between the various constraint types,
and the rules governing each constraint type, the more effectively you'll be
able to use Parametric Design.

One very good way to become expert in the science of constraining a part, is to
practice using manual constraints on parts of increasing complexity. Use the
automatic constraint generator to see how it would solve a particular problem, but
make sure you understand the constraints that are generated. Once you fully
understand how the various constraint types can be used and you get used to using
the debugging tools, then begin to rely more on the automatic constraint generator.
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Example 1: Introductory Design Example
This example introduces the tools and working methods that the Designer or
Engineer must use to constrain parts and generate variations with the Parametric
Design module. During this first example, you will:

• Place the part in the zone.
• Fully constrain the part with manual and automatic methods.
• Examine the constraints.
• Modify the constraints needed for a variation.
• Solve for variations.
• Parametrize constraints to generate more useful variations.
• Add new geometry to a constrained part.
You should come away from this demo with a clear understanding of the tools and
basic working techniques for constraining parts — information that you can apply
in subsequent examples, which focus in more depth on particular applications of
Parametric Design.
As with all of the examples in this section, the part for this example is supplied on
line so that you can focus on parametric design instead of on drawing — after all,
the main goal of Parametric Design is to reduce the time you spend drawing!

Load the Part
The part shown in this example is supplied with Creo Elements/Direct Drafting.
To load this part:

1. Click File ▶ Open to open the Creo Elements/Direct Drafting File
Browser.

2. Double–click the pd_demos directory.
3. Select the demopart01.mi file and click Open.
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Figure 231. Demopart01

The important features of this part for parametric design are as follows:

• It is an ordinary Creo Elements/Direct Drafting part.
• It is fully dimensioned. The length and height are specified, as is the radius of

one corner. The location and radius of the holes is also given. Generally, a part
with full dimensioning works best for Parametric Design.

• It is "clean." There are no duplicate or stacked elements. Such inconsistencies
can lead to unexpected results. Parametric Design has several commands that
find and fix inconsistencies in a part, but you won't have to use them right
away!

• Construction lines have been used to mark the "origin" of the part as well as
the centerlines of the holes. Construction geometry, if available, is often very
useful to the Parametric Design solver. When possible, you should include
construction geometry to mark important features of a part: major axes, lines
of symmetry, centerlines of circles, and so on.

Include the Part in the Zone
Parametric Design only modifies elements included in the zone. To include the
entire part in the zone:

1. Click Parametric and then, in the Modify group, click Zone.

2. Click Add Multiple.
3. Type ALL in the user input line and press ENTER.

All elements are highlighted as they are added to the zone.

4. Click OK.
The entire part is now included in the zone.
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Fully Constrain the Part
Before you can use the Parametric Design solver to generate variations from an
existing part, each element in the zone must have one or more constraints assigned
to it. Enough constraints must be assigned to tell the solver exactly what to do
with each element in the part. If elements in the zone are not fully constrained or
are incorrectly constrained, the solver will not be able to generate the variation.
The best way to assign a full set of constraints is to first constrain all the elements
in the part in their current configuration. After the part is fully constrained in its
current configuration, you can modify constraints as needed to generate a
variation.
Both manual and automatic options are available for assigning constraints.
Typically, the manual options are used to assign a few important constraints like
reference elements, and then the Solve group buttons generate the remaining
constraints required to fully constrain the part.

Manually Fix Reference Elements
It is always a good idea to "anchor" a part by manually constraining one or more
elements from moving. This helps to give the software a frame of reference for
automatically assigning constraints later on. For this example, fix the lowest
horizontal and leftmost vertical construction lines in place with Refelem
constraints to anchor the part.

1. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
2. In the Action area, click Assign.
3. In the Type box, select Refelem.
4. Click Apply.
5. Click the lowest horizontal construction line (collinear with the bottom edge

of the plate).
6. Click the left-most vertical construction line (collinear with the left edge of the

plate).

7. Click OK.
Notice the reference-element icons. The leader lines of these icons are dotted so
that you know they are assigned to construction geometry and not to the edges of
the triangular plate. Each constraint type has its own unique icon. See Figure 206.
Constraint Icons on page 656 for a complete list of the constraint-type icons.
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Modify Constraints
To generate a variation that is different from the original, you must change one or
more constraints from their current values to the values you want to see in the
variation.

1. In the Generate Constraints dialog box, click Assign in the Action area.
2. In the Type box, select Dimension.
3. Click Apply.
4. Click the dimension text that gives the height of the triangle (40.5).
5. Type 55 and press ENTER.
6. Click the dimension text that gives the length of the triangle (65.25).
7. Type 55 and press ENTER.

8. Click OK.

The dimension text is updated.

Automatically Generate the Remaining Constraints
Rather than assign the remaining constraints by hand, which would take
considerable time, use the Complete option provided in the Generate Constraints
dialog box. This option evaluates the part and assigns sufficient constraints to
fully constrain it in its current configuration.

1. In the Generate Constraints dialog box, click Complete in the Action area.
2. Click Apply.

3. Click OK.

Solve
Now use the buttons in the Solve group to generate the variation.

1. Click Parametric and then, in the Solve group, click Preview.

The magenta outline shows how the variation will be created without
disrupting the current part (see Figure 232. Preview Mode on page 721).

2. Click OK.

3. Click Parametric and then, in the Solve group, click No Keep.

Your original part is now replaced with the variation. Notice that the
dimensions you assigned to be 55 earlier are now indeed 55. The hole
geometry has not moved.
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4. Click Undo to restore your original part.

Figure 232. Preview Mode

The Keep button in the Solve group on the Parametric tab, allows you to keep
both the original and the variation Figure 233. Part and Kept Variation on page

721. If you try Keep now, make sure you delete all the variations (but not the
master part) when you have finished.

Figure 233. Part and Kept Variation

Parameters
At this point, you've created a variation of your original part, but it's probably not
exactly what you want. One obvious flaw is that the holes in the plate are not
constrained to adjust along with the perimeter. Although you could move them by
giving new values to their dimensional constraints (just like you did for the length
and height of the plate), this is not efficient, because you would have to calculate
and re-enter these values each time you generated a variation with different
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dimensions. Parameters provide a much better method for accomplishing this.
Parameters allow you to use expressions to define relationships among
constraints.

Assign Parameter Names
First, assign parameter names to the appropriate dimensional constraints.

1. Unless you have already done so, click Parametric and then, in the Solve

group, click No Keep.

2. Click OK to replace the original part with the variation you created in the
last step.

3. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
4. In the Action area, click Assign.
5. In the Type box, select Dimension.
6. Click Apply.
7. Click the dimension text that gives the length of the triangle (55).
8. Type 'Base' in the user input line and press ENTER.
9. Click the dimension text that gives the height of the triangle (55).
10. Type 'Height' in the user input line and press ENTER.
11. Click the "12.37" dimension on the top hole.
12. Type 'Dim1' in the user input line and press ENTER.
13. Click the "29.69" dimension on the top hole.
14. Type 'Dim2' in the user input line and press ENTER.
15. Click the "10.01" dimension on the leftmost hole.
16. Type 'Dim3' in the user input line and press ENTER.
17. Click the "49.21" dimension on the rightmost hole.
18. Type 'Dim4' in the user input line and press ENTER.

19. Click OK.
The dimension text should now look like Figure 234. Parameter Names Assigned
on page 723.
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Figure 234. Parameter Names Assigned

With the names assigned, you now define the relationships among the parameters
in the parameter definition table. For this example, we will set up the parameters
so that all parameterized dimensions are functions of the Base parameter.

Define Parameter Values

1. Click Parametric and then, in the Show group, click Current.

The Current Constraints dialog box opens.
2. In the Name column, select the list entry for Height.
3. Click the parameter value entry field near Apply.
4. Type (.75 * Base) and click Apply.

The value for the Height constraint is now defined to be .75 of the value of
Base.

5. Click the Dim1 entry.
6. Type Dim3 and click Apply.
7. Click the Dim2 entry.
8. Type (Height - Dim3) and click Apply.
9. Click the Dim3 entry.
10. Type (.2 * Height) and click Apply.
11. Click the Dim4 entry.
12. Type (Base - Dim1) and click Apply.
13. Click Advanced to view the result of these changes in the parameter table.

Solve for Variations
With the parameters defined, you can now use the Solve group buttons on the
Parametric tab for variations:
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• Click Parametric and then, in the Solve group, click No Keep.

All the parameterized dimensions are now adjusted according to the
expressions you entered in the parameter definition table, Figure 235.
Variation of Demopart01 on page 724. The height is now .75 of the base, the
"Dim1" and "Dim3" dimensions are equal, and both are .2 of the base
dimension.

Figure 235. Variation of Demopart01

• Since all the linear dimensions are related to the base dimension, you only
need to modify this dimension to make the entire part adjust. Try assigning
several different values to the base dimension, solving after each change. You
can change this dimension one of three ways:

○ Using the Generate Constraints dialog box:

1. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
2. In the Action area, click Assign.
3. In the Type box, select Dimension.
4. Click Apply.
5. Click the dimension label.
6. Type the new value in the user input line and press ENTER.

○ Using the Current Constraints dialog box:

1. Click Parametric and then, in the Show group, click Current.

The Current Constraints dialog box opens.
2. Select the dimension that you want to change.
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3. Type a new value.
4. Click Apply.

○ By using the parameter value table:

1. Click Parametric and then, in the Show group, click Current.

The Current Constraints dialog box opens.
2. Click Advanced.

The Advanced dialog box opens. It contains the parameter value table.
3. Click the value you want to change in the New Value or Expression

column.
4. Type the new value and click Apply.

Adding New Geometry
It is often useful as you work with a constrained part to be able to add or delete
geometry. Many parametric design systems do not allow this, but Parametric
Design handles this situation easily. In the final section of this example, we'll add
a new feature to our triangular plate to illustrate how new geometry is integrated
into a constrained part.
First, let's modify the triangular plate by adding a small "lip" to the outside edge.

Use the Creo Elements/Direct Drafting Equidistance button to create a
contour that is 2.5 mm inside the edge of the plate. Dimension the width of this
new lip as shown in Figure 236. New Geometry on Demopart01 on page 725.

Figure 236. New Geometry on Demopart01
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To incorporate this new feature into the Parametric Design constraint system, you
only need to click Complete in the Current Constraints dialog box again. Clicking
Complete generates the additional constraints needed for the new geometry.
Subsequent use of the Solve group buttons recognizes the new feature:

1. After adding new geometry, click Parametric and then, in the Create group,

click Constraints.

The Generate Constraints dialog box opens.
2. Click Complete.
3. In the Generate Constraints dialog box, click Show in the Action area.
4. In the Act On box, select New.
5. In the Type box, select All Types.
6. Click Apply to see how the new geometry was constrained.
7. In some cases, the addition of new geometry adds information to the part that

causes existing constraints to become unnecessary. Complete will indicate if it
finds unused constraints. If applicable, display these constraints with Show,
Unused, All Types and Free them if you wish.

8. Change the value of the base dimension to 48.

9. Use No Keep in the Solve group on the Parametric tab to generate the
variation.

Note
The new lip adjusts along with the rest of the part.

To Consider
Here are a couple of additional tasks that you can try with this drawing. Both will
give you some practice with manual constraint assignment.

• Through the center of each hole, add a vertical and horizontal line that extends
a short distance beyond the circle (like a cross hair). Use manual constraints to
force each line to move with the hole and to continue to extend the correct
distance beyond the circle when the hole changes size. Hint: Apply Point on
and point-to-circle Distance constraints.

• Go back to the original geometry, but first remove the both fillets on the left
vertical line of the model. Go through exercise again, including the creation of
the equidistant inner contour. This time, Complete will not cause the inner
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contour to remain equidistant. Why? Can you add manual constraints to fix the
problem? Hint: Use Samedist constraints.

Example 2: Symmetry Lines
In this example, you're given a drawing of a plate with a large slotted hole and
several smaller boltholes. Your goal is to generate variations of this plate in which
the slotted hole has different sizes and configurations. Each variation should be
generated by simply changing the dimensions for the radius of the hole and the
width and depth of the slots.
To accomplish this task, you'll assign several Symmline constraints, which help to
maintain the configuration of hole as it changes size. You'll also use parameters to
control how the variation is generated.
As you work through this example, pay particular attention to the way in which
symmetry lines are used by Parametric Design, and how mirror constraints are
generated. You should come away from this example with a clear idea of how
mirroring works.

Load the Drawing

1. Click File ▶ Open to open the Creo Elements/Direct Drafting File
Browser.

2. Double–click the pd_demos directory.
3. Select the demopart02.mi file and click Open.

4. Click Parametric and then, in the Modify group, click Zone.

5. Click Add Multiple.
6. Type ALL in the user input line and press ENTER.

7. Click OK.
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Figure 237. Demopart02

Assign Reference Elements
To ensure that variations don't move around the page, anchor the part with
Refelem constraints on the four construction lines. These lines make ideal
reference elements because they run through the major axes of the part as well as
the centerpoint of the hole we want to modify, and because they would not move
in any of the variations we want to create.
To assign the reference elements:

1. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
2. In the Type box, select Refelem.
3. Click Apply.
4. Click each of the four construction lines that run through the part.

5. Click OK.
The default size for constraint icons is much too small for this part. And it is also
possible that several of the icons are overlapping. If you can't clearly see the
constraint icons now on the part, change their size and location:

1. Click File ▶ Settings ▶ Parametric ▶ Parametric Icon.

The Icon Setting dialog box opens.
2. In the Size box, type 30.
3. Click OK.
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4. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
5. In the Action area, click Clear and in the Type box, select All Types to clear the

small icons.
6. In the Action area, click Show and in the Type box, select All Types to display

the icons in the new size.
The icons are now visible, but may still be overlapping. If all four icons are not
visible, move them to uncover the obscured icons:

1. Click Parametric and then, in the Modify group, click Move Icon.
2. Click the constraint icon you want to move.

The icon is replaced with a "rubberband" line.
3. Drag the rubberband line to where you want the icon and click at that location.
4. Move the rest of the icons till you can see all the four icons.

Assign Symmetry Lines
The most notable feature of this part is that although only one of the slots around
the edge of the hole has known dimensions, the positions of the remaining slots
can be determined by mirroring this slot over one or more lines of symmetry. The
construction lines in the part serve as these symmetry lines. Figure 238. Symmetry
Lines in Demopart02 on page 730 shows the general method by which the width
of all the slots in this part can be determined by reflecting a known width over
lines of symmetry. Solve may not use this exact scheme, but the process it uses is
similar.
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Figure 238. Symmetry Lines in Demopart02

By assigning Symmline constraints to the construction geometry, you ask the
software to look for mirror relationships across these lines.
To assign the Symmline constraints:

1. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
2. In the Action area, click Assign.
3. In the Type box, select Symmline.
4. Click Apply.
5. Click the four construction lines that run through the center of the part.

6. Click OK.

Automatically Generate the Remaining Constraints
Having manually assigned the initial constraints, use Complete to generate the
remaining constraints needed to fully constrain the part.

1. In the Generate Constraints dialog box, click Complete in the Action area.
2. Click Apply.

3. Click OK.
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Examine Constraints
Following a Complete command, you should always check the part to make sure
that a reasonable set of constraints has been assigned. Check the following:

1. Are all important dimensions constrained?

a. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
b. In the Action area, click Show.
c. In the Act On box, select Used.
d. In the Type box, select Dimensions.
e. Click Apply.

Notice that the dimension for the top of the plate has not been constrained.
This is not needed in this case because other constraints fix this line.

2. Are there any Distance or Size constraints? Complete usually only assigns
these constraints as a "last resort" if it can find no other way to constrain an
element. A distance-constrained element may move along with other elements
when it not intended to.

In the Generate Constraints dialog box, click Show in the Action area and
select Size and Distance in the Type box to display any instances of these
constraints.

An alternate way to check the constraints on your part is using Inq Elem and

Inq Icon in the Show group on the Parametric tab. For this example, you can

use Inq Elem to see how Complete used the symmetry lines you defined to
constrain components of the center circle:

1. Click Parametric and then, in the Show group, click Inq Elem.
2. Click each line in the dimensioned slot of the part.

Notice how mirror constraints were extracted for each element in the slot.

Try clicking on other components around the center circle.

3. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
4. In the Action area, click Clear.
5. In the Type box, select All Types.
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6. Click OK when you have finished with Inq Elem.

Generate a Variation
The part is now fully constrained. To generate the first variation:

1. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
2. In the Action area, click Assign.
3. In the Type box, select Dimension.
4. Click Apply.
5. Click the dimension for the radius of the large hole (currently 373.32).
6. Type 250 in the user input line and press ENTER.
7. Click the dimension for the width of the slot (currently 28.48).
8. Type 20.75 in the user input line and press ENTER.
9. Click the dimension for length of the slot (currently 31.41).
10. Type 58 in the user input line and press ENTER.

11. Click OK.

12. Click Parametric and then, in the Solve group, click Preview.

The magenta outline shows how the variation will be drawn without changing
the part.

Alternatively, you can replace the master part with the new geometry by

clicking No Keep in the Solve group on the Parametric tab.

13. Click OK to remove the preview, or Undo if you solved with No
Keep.

Repeat this procedure several times, substituting new values of your choice.
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Figure 239. Demopart02 Variation

Parameterize
Suppose you are asked to generate several variations of this part in which the slots
change size proportionally to the radius of the large hole. You could accomplish
this using the methods shown above, but you would have to recalculate the
dimensions of the slots each time you re-sized the hole. Your task is much easier if
you parameterize the three dimensions in question. For example:

Assign Parameter Names

1. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
2. In the Action area, click Assign.
3. In the Type box, select Dimension.
4. Click Apply.
5. Click the dimension for the radius of the large hole.
6. Type 'HoleRad' in the user input line and press ENTER.
7. Click the dimension for length of the slot.
8. Type 'SlotLen' in the user input line and press ENTER.
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9. Click the dimension for the width of the slot.
10. Type 'SlotWid' in the user input line and press ENTER.

11. Click OK.

Define Parameter Values

1. Click Parametric and then, in the Show group, click Current.

The Current Constraints dialog box opens.

There should be three table entries; one for each parameter name you
assigned.

2. Click the list entry for HoleRad.
3. Click the parameter value entry text box.
4. Type 375 and click Apply.
5. Click the SlotLen entry.
6. Click the parameter value entry text box.
7. Type (0.084 * HoleRad) and click Apply.
8. Click the SlotWid entry.
9. Click the parameter value entry text box.
10. Type (0.076 * HoleRad) and click Apply.
Notice the "New Value Type" field for each of the three parameter definitions.
While HoleRad is defined directly by a value (375), SlotWid and SlotLen
are defined by evaluating expressions.
The parameters now define a variation very similar to the original part. If you
wish, you can use the buttons in the Solve group on the Parametric tab now (use

No Keep) to restore this configuration.

Generate Variations
Because HoleRad is defined as a "value" parameter, and both SlotWid and
SlotLen can be resolved from it, you need only change the value of HoleRad to
generate variations. Use the parameter value table to do this:

1. Click Parametric and then, in the Show group, click Current.

The Current Constraints dialog box opens.

Only parameters defined as "Value" parameters appear in the parameter value
table.

2. Click the HoleRad entry.
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3. Click the parameter value entry text box.
4. Type 425 and click Apply.

5. Click Parametric and then, in the Solve group, click No Keep to create the
variation.

6. Click OK to accept the variation.
As you can see, the dimensions of the slots now change with the hole radius. Input
several different values for HoleRad now.

Other Things to Try
• You may wish to try some other parameter definitions for this part. How

would you define parameters so that the width of the slots controls the radius
of the hole?

• Another interesting feature of this example is the way in which the small
boltholes are constrained. If you assign a new diameter to one hole, the rest
will resize when you solve. Why? Examine the constraints on these holes to
find out.

• Start again at the beginning of this example. After using Complete, try
modifying the position of the uppermost pair of boltholes (the pair whose y-
position is specified by the dimension 175.86). Modify this to be 240. The x-
position dimension (110) moves to be above the dimension 60. Use Distance
constraints on the dimension texts to keep them in the same relative positions.

• Normally either the top horizontal dimension of 1000 or the bottom horizontal
dimension of 500 will be extracted by the automatic constraint generator.
What if you wanted to be able to control both dimensions independently? This
would imply that the two vertical sides of the part need not remain vertical.
How would you constrain the part to allow this to happen?

This is a very simple example of a very common situation. The default part
contains obvious constraints that are unintended in general. Even in this
simple example, the number of unintended constraints that the automatic
constraint generator could extract is large (side lines are parallel, each side line
is perpendicular to the top and bottom lines, each side line is parallel and
perpendicular to some of the lines in the internal cutout and to some of the
construction lines, etc).

There are three general strategies for this situation. Try each one.

○ Use Complete and then Ban those unintended constraints. Continue this
process until the goal has been reached.
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○ Manually constrain the side elements so that Complete doesn't need to add
any constraints.

○ Use the Stretch buttons in the General group on the Modify tab to
change the default part to one that is more general.

Which is easiest?

Example 3: Two Views
In this example, you're given a drawing that contains a front and side view of the
same part. You need to change the size of several features in the part, but don't
want to have to redraw both views to reflect the changes. The goal, then, is to use
Parametric Design to carry the changes you make to one view over to the second
view.
The key to accomplishing this task is to use construction lines to transfer
constraints placed on one section of a part to another section.

Load the Drawing

1. Click File ▶ Open to open the Creo Elements/Direct Drafting File
Browser.

2. Double–click the pd_demos directory.
3. Select the demopart03.mi file and click Open.

4. Click Parametric and then, in the Modify group, click Zone.

5. Click Add Multiple.
6. Type ALL in the user input line and press ENTER.

7. Click OK.
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Figure 240. Demopart03

For this example, you will resize the hole and the ring indicated by the arrows in
Figure 240. Demopart03 on page 737. Modifications to the large hole in the front
face should carry over to the side view. Changing the width of the ring in the side
view should change the radii of the hidden-line circles in the front view.
The main mechanism used to carry dimension information from one section of the
part to the other is the construction line. When building this part, we included
many construction lines whose only purpose was to link elements for Parametric
Design. Look, for example, at the small hole in the side view. In most situations, it
would be considered excessive to place horizontal and vertical construction lines
on the perimeter as well as the center of this hole. For Parametric Design,
however, these lines are critical: The vertical lines "link" the diameter of this hole
with the two vertical holes in the side view, while the horizontal construction lines
give us a link to the front view.

Assign Reference Elements
With a two-view part like this, it is important to anchor both views so that they
don't move to overlap each other during the solve. For this part, assign Ref Elem
constraints to the two centerlines on the front face and to the vertical construction
line on the side view that's closest to the front view, Figure 241. Manually
Assigned Constraints on page 738:

1. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
2. In the Action area, click Assign.
3. In the Type box, select Refelem.
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4. Click Apply.
5. Click two centerlines and one construction line as shown in the figure below.

6. Click OK.

Figure 241. Manually Assigned Constraints

Assign Symmetry Lines
In addition to the reference elements, the configuration of this part suggests that it
would be useful to assign symmetry line constraints to the centerlines of the
elements that we're going to be resizing.

1. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
2. In the Action area, click Assign.
3. In the Type box, select Symmline.
4. Click Apply.
5. Click the four centerlines that run through the holes in the two views. Figure

241. Manually Assigned Constraints on page 738 shows the placement of
these constraints.

6. Click OK.

Automatically Generate the Remaining Constraints
Having manually assigned the important constraints for this example, use
Complete to generate the remaining constraints needed to fully constrain the part.
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Examine Constraints

When Complete finishes, examine the part carefully with both Show and Inq
Elem to see how Complete used the construction geometry to link up the elements

we want to resize. Inq Elem is especially useful for showing how individual
construction lines are associated with other geometric elements.

Generate the Variation
When you feel you understand the connections between the two views of the part,
modify the constraints on the hole and the ring and use the Solve group buttons to
see how Parametric Design makes use of these connections.

1. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
2. In the Action area, click Assign.
3. In the Type box, select Dimension.
4. Click Apply.
5. Click the dimension for the diameter of the large hole in the front view (This

dimension is currently 6.5).
6. Type 4.5 in the user input line and press ENTER.
7. Click the dimension for the inner diameter of the ring in the side view. (This

dimension is currently 31.8.)
8. Type 30.5 in the user input line and press ENTER.

9. Click OK.

10. Click Parametric and then, in the Solve group, click No Keep.
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Figure 242. Demopart03 Variation

To Consider
• What other dimensions can be carried over from view to view in this part with

the existing construction lines? Try resizing some other dimensions and see
how the solver handles them.

• Could you delete some of the construction geometry in this part and still
accomplish the example? How?

• Suppose that you want to increase the distance between the two views of this
part. This is trivial to do with Parametric Design, but there is one hitch: How
do you get the centerline that runs through both views to "stretch" as the views
move apart? Hint: Try adding a point element to each end of the center line
and then, for each point, fix the distance between it and an element in the
nearest view.

Example 4: Macros
Your task is to design a series of fan housings. The housings are identical except
that the air intakes and exhaust ports of each housing must vary to accommodate
fans of different power. It is important that the area of the air intakes equal the
area of the exhaust ports to maintain proper air flow through the housing.
Unfortunately, the intakes are wedge-shaped while the exhaust ports are slots. This
makes the area calculations more complicated.
To accomplish this task, you'll use a Creo Elements/Direct Drafting macro that:

1. Calls Parametric Design to design the air intakes.
2. Calculates the area of the intakes.
3. Transforms the area value into the exhaust port size.
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4. Calls Parametric Design to design the exhaust ports.
Most of the setup for this example has been done for you. The part,
demopart04.mi, has already been constrained and parameterized, and the
macros you need are already defined in the file demopart04.mac. As you work
through this example, focus on the contents of the macro and how they relate to
what you see on your screen.

Load the Drawing

1. Click File ▶ Open to open the Creo Elements/Direct Drafting File
Browser.

2. Double–click the pd_demos directory.
3. Select the demopart04.mi file and click Open.

Figure 243. Demopart04

Examine the Drawing
Take a few minutes now to look at the features of this drawing.
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• Notice the part structure. The front face is the top part, while the back face is a
sub-part named "slot-grid." Parametric Design only works on the current part,
so our macro must be able to switch from part to part.

• Both parts of the drawing are already in the zone.
• Examine the initial constraints on the top part, Figure 244. Intake Constraints

on page 742:

1. Make the top part current.

To make the top part current:

a. Click Structure and then, in the Parts group, click Edit.

b. Click Top.

2. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
3. In the Action area, click Show.
4. In the Act On box, select User.
5. In the Type box, select All Types.
6. Click Apply.

The Dimension, Distance, and Symmline constraints ensure that all four intake
ports retain their configuration in variations. The Refpoint constraints Pt1 and
Pt2 were created only to provide information to our macro. This is explained
later.

Figure 244. Intake Constraints

• Examine the constraints on the "slot_grid" part now. (Hint: make "slot_grid"
the current part in order to examine it). Notice that the slot radius has been
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parameterized as "Newrad." How did we ensure that all three exhaust ports
will remain the same size?

When you have finished looking at the constraints, make sure that top part is
current and that your main window shows both parts.

Examine the Parameters.
Display the parameter definition table to examine the parameters on the part:

1. Click Parametric and then, in the Show group, click Current.

The Current Constraints dialog box opens.
2. Click Advanced.

Assuming that the top part is active, there should be five parameters defined:
Bwid Gives the width of the bars between the air intakes. Set to

20.
Inrad Gives the inner radius of each air intake. Set to 25.
Outrad Gives the outer radius of each air intake. Set to 100.
Pt1 A reference point. Pt1 is a geometry parameter, so its

value will always correspond to the top corner of an air
intake, no matter how this part is resized.

Pt2 A reference point. The value of Pt2 will always
correspond to the bottom corner of Pt1's air intake.

To prove that the parameters work as we say they do, try them:

1. Change the value for "Out_rad" to 120. Click the "Outrad" entry in the
table and type 120.

2. Click Parametric and then, in the Solve group, click Preview.

Notice how the hole configuration changes.
3. Restore the parameters to their original values when you've finished

experimenting.

Take a look at the parameters on the exhaust ports now.
4. Make "slot_grid" the current part.
5. Preview a few variations of this part by inserting new values for the

"Newrad" parameter and solve using Preview in the Solve group on the
Parametric tab.

6. Set "Newrad" to 5 and solve by using No Keep in the Solve group on the
Parametric tab.
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7. Make the top part current.
The configuration of the parameters should give you an idea of the strategy we'll
use to accomplish our task. We can easily vary the size and configuration of the
four air intakes in the top part by changing the parameter values for "Bwid,"
"Inrad," and "Outrad." On the "slot_grid" part, we can vary the width of
all three exhaust ports by entering a new value for the "Newrad" parameter. All
that needs to be done now is to translate the area defined by "Bwid", "Inrad",
and "Outrad" to a radius that can be fed to "Newrad". This is exactly what our
macro, Do_it, does.

Try the Do_it Macro
Before looking closely at Do_it, let's try it. Do_it is defined in the file
demopart04.mac in the pd_demos\ directory. To load Do_it in your
system, type input `<Creo Elements/Direct Drafting
installation directory>\pd_demos\demopart04.mac' in the user
input line and press ENTER. <Creo Elements/Direct Drafting
installation directory> is the directory where you installed Creo
Elements/Direct Drafting.
Now, type Do_it in the user input line and press ENTER.
What happened? If all went well, the exhaust ports returned to their original size.
Now try this:

1. Display the parameter value table using the Current Constraints dialog box.
2. Change "Bwid" to 10, "Inrad" to 35, and "Outrad" to 75.
3. Type Do_it in the user input line and press ENTER.
It looks like your task is now very easy! All you need to do in order to generate
your fan housings is to enter the parameters for the intake ports in the parameter
table and type Do_it to compute the necessary width for the exhaust slots. Let's
look at Do_it now to see how it's done.

Examining Do_it
The definition for Do_it is listed below:
DEFINE Do_it {Generate holes in demopart04.mi}

EDIT_PART TOP {Setup: make sure we are at top
part}

SPOTLIGHT OFF

PD_RESOLVE REPLACE {Solve for front holes}

AREA_PROPERTY 1 Find_midp DEL_OLD '\temp\area'
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END {Get the area properties of 1
front hole}

{and write to a temporary file.
}

EDIT_PART 'slot_grid' {Goto the second part, slot_grid}

PD_PARAM_FIX 'Newrad' New_radius {Find radius needed to give
equivalent}

{area. Fix part radius to this
value.}

PD_RESOLVE REPLACE {Solve for back slots}

EDIT_PART TOP {Clean up: go back to top part}

DISPLAY ('Variations Generated. Done.')

END_DEFINE {of Do_it}

Do_it calls the macros Find_midp and New_radius, both of which are
listed here:
DEFINE Find_midp {find a point inside a front-face hole}

LOCAL A {Declare local variable A}

LOCAL B {Declare local variable B}

PD_PARAM_INQ 'Pt1' {Find Pt1 location from parameter
table}

LET A (PNT_XY (INQ 3) (INQ 4)) {assign Pt1 location to A}

PD_PARAM_INQ 'Pt2' {Find Pt2 location from parameter
table}

LET B (PNT_XY (INQ 3) (INQ 4)) {assign Pt2 location to B}

((A+B)/2) {Return midpoint of A and B}

END_DEFINE {of Find_midp}

DEFINE New_radius {Get area of front hole,}

{return radius of back slot.}

LOCAL L {Declare local variable L}
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LOCAL A {Declare local variable A}

LET A 'junk' {Set A to some junk value!}

LET L 200 {Set L to length of a back slot}

OPEN_INFILE 1 '\temp\area' {open file of area properties written
above}

WHILE ((SUBSTR A 1 3)<>'A =') {scan area_spec for the area (A=)
field}

READ_FILE 1 A {and load the area field into A}

LET A (TRIM A)

END_WHILE

LET A (SUBSTR A 4 (LEN A)) {set A to be just area value
(area of 1 hole}

LET A ((VAL A)*4) {total area of front holes is 4A}

(((SQRT(L*L + (PI*A)/3))-L)/PI){Given area of holes A and length
of slots L}

{return hole radius for
equivalent area. }

END_DEFINE {of New_radius}

The algorithm used by Do_it is as follows:

1. Solve the variation for the intake ports.
2. Use AREA_PROPERTIES to find the area properties of an intake port and

write this data to a file. Call the macro Find_midp to generate the point
which identifies this port.

3. Change the current part to the exhaust ports.
4. Call the macro New_radius to calculate the needed radius from the data in

the file written above. Assign this radius to "Newrad."
5. Solve the variation for the exhaust slots.
This procedure is straightforward, but does use some interesting features of both
Creo Elements/Direct Drafting and Parametric Design commands:

• Although Parametric Design only operates on the current part, a macro like
Do_it can easily manage interchanges among multiple parts.
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• The macro Find_midp uses the reference-point constraints Pt1 and Pt2 to
determine a point that is guaranteed to be inside an intake port. Since Pt1 and
Pt2 are constrained to always be on the corners of this port, the point between
them will always be inside the port. Passing this point to AREA_
PROPERTIES makes sure that we always get the properties for an intake port.
Note how PD_PARAM_INQ is used to grab the locations of these points from
the parameter table.

• New-radius simply reads the area data from a file and uses it along with hard-
coded data about the slot length to generate the appropriate radius. The output
is input to Parametric Design via PD_FIX_PARAM. Of course a much more
complex macro could be used to supply this input!

To Consider
• Currently, Do_it counts on the slot length being 200. How would you re-

write Do_it to inquire the slot length directly from the part? (Hint: You
probably need to add a new parameter to the part.)

• Do_it is not foolproof. You can cause problems by setting "B_wid" to 0.
How would you fix this flaw? How would you implement general error or
range checking in Do_it?

• Could you implement Do_it so that slot size drives intake size? So that either
dimension could drive the other?

• Do_it is linked very tightly to this particular drawing. How would you
generalize Do_it?

Example 5: Rigid Bodies
This example illustrates how rigid bodies can be used to reduce the number of
constraints in a drawing while allowing a complex range of motion. You're given a
drawing of a cam and follower. By collecting each into a rigid body, you can set
up a simple motion study using just six constraints.

Load the Drawing

1. Click File ▶ Open to open the Creo Elements/Direct Drafting File
Browser.

2. Double–click the pd_demos directory.
3. Select the demopart05.mi file and click Open.

4. Click Parametric and then, in the Modify group, click Zone.
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5. Click Add Multiple.
6. Type ALL in the user input line and press ENTER.

7. Click OK.

Figure 245. Demopart05

The goal of this example is to force the follower to stay in contact with the cam
profile as the cam rotates. By setting up both the cam and the follower as rigid
bodies, we dramatically reduce the number of constraints needed to implement
this action, and can concentrate more on interaction between the two pieces.
The demopart05.mi model is fairly simple. The only elements in the drawing
that are needed specifically for parametrics are the construction line and the three
point elements, which are used to facilitate placement of several Point on
constraints.

Create Rigid Bodies
The cam and the follower each need to be collected into a rigid body. The
construction line is the only part of the model that is not in a rigid body. Each rigid
body must be named before elements can be collected into it:

1. Click Parametric and then, in the Create group, click Rigid.

The Generate Rigids dialog box opens.
2. Type cam in the text box and click Assign.
3. Gather all of the cam geometry in the cam rigid body by enclosing it in a box.

4. Click OK.

748 Creo Elements/Direct Drafting User's Guide: Fluent User Interface



5. Repeat the procedure to create a rigid body called follower that contains all of
the follower geometry.

6. In the Generate Rigids dialog box, click Show and select each of the table
entries you just created to confirm the contents of each rigid body. The
construction line should not be included in either.

7. Click Close to close the Generate Rigids dialog box when you finish.

Assign Constraints
Only six constraints are needed to completely constrain this drawing. Assign each
one manually:

1. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
2. In the Action area, click Assign.
3. In the Type box, select Refelem.
4. Click Apply.
5. Click the construction line to fix it in place.
6. Use the same general method to assign a Refpoint constraint to the point

element at the centerpoint of the cam. This fixes the cam in place on the
construction line while allowing it to rotate.

7. Use the same general method to assign a Slope constraint to one of the small
line elements that cross at the centerpoint of the cam. Name this constraint
Rotation, but don't assign it a specific value yet.

Note that this constraint and the previous one are all that's needed to
completely constrain the "cam" rigid body. The reference point fixes
translation while the slope constraint fixes rotation.

8. Constrain the follower: Assign a Point on constraint between the left-most
point element on the follower and the construction line. Fix the rightmost
point element to the construction line with a second Point on constraint. These
two constraints fix the rotational degree of freedom for the follower, but its
motion along the axis of the construction line still needs to be fixed.

9. Assign a final Point on constraint between the left-most point element on the
follower and B-spline profile of the cam. This fixes the translation of the cam.

10. Click Parametric and then, in the Show group, click Inq Icon to confirm
that you've assigned each of the constraints as described above. The
constraints should resemble Figure 246. Demopart05 Constraints on page 750.
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As you examine the constraints, make sure you understand how each one
constrains the motion of the rigid body to which it's applied.

Figure 246. Demopart05 Constraints

Solve
Before running the solver on this drawing, it is important to turn off the point-
merging functionality of the Solve command. Remember that by default the solver
will merge any two points that fall within the PD_RESOLVE_MERGE_
TOLERANCE distance of one another. Normally this is desirable, as it helps to
keep the drawing clean. In this case however, it is possible for the endpoint of the
follower profile to come into contact with the endpoint of the cam profile as the
cam rotates. Were this to occur, these two points would be merged, and further
parametric manipulation of this drawing would be impossible. To keep this from
happening, type pd_resolve_merge_tolerance -1 in the user input line
and press ENTER.

Now, click Parametric and then, in the Solve group, click No Keep to generate
the initial variation.
To confirm that the follower will indeed maintain contact with the cam as it
rotates, open the Current Constraints dialog box and enter several different values
for the Rotation parameter, solving after each one.

To Consider
• Rotating the cam by "hand" (entering a new slope and re-solving) is fairly

tedious. It should be simple to write a macro to do this.
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• Try this example with pd_resolve_merge_tolerance set to the default
value (1E-6). Rotate the cam until the follower comes to rest at the very top of
the cam profile. What happens with the very next rotation?

• Try to replicate this example without using rigid bodies. How many
constraints are needed? How would you force the hatching on the cam to
rotate along with the elements?

Tutorial
The exercises presented in this tutorial familiarize you with:

• Dimension-Driven Modification
• Design-Intent Capture
The drawings and macros that are needed for this tutorial can be found in the
$MEDIR\pd_demos subdirectory (or in the subdirectory where you installed
Creo Elements/Direct Drafting).
This tutorial is intended for users who are already familiar with the Creo
Elements/Direct Drafting user interface for doing such things as creating
geometry, windowing, and dimensioning. Instructions for the mouse input device
are given first.

Exercise 1
In this exercise, you draw a plate and then modify its shape by changing the
driving dimensions.
Ensure that Copilot and Parametric Design are enabled in the System dialog box.

• Click File ▶ Settings ▶ System to open the System dialog box.

Draw the basic design

1. Click Drafting and then, in the Draw group, click the arrow next to Line.

2. Click Polygon.
3. Draw the shape shown in Figure 247 on page 752, starting at point S in the

direction shown.

4. Click Drafting and then, in the Draw group, click the arrow next to Circle.

5. Click Center & Radius.
6. Draw the hole (the offset is from points X at values 10 0).
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7. Click OK.
8. Dimension the drawing as indicated in Figure 247 on page 752.

Figure 247

Assign Constraints

1. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
2. In the Action area, click Assign.
3. In the Type box, select Refpoint.
4. Click Apply.
5. Click point S (see Figure 247 on page 752) to mark it as the reference point.
6. Assign the Dimension constraint to the dimensions (seeFigure 247 on page

752).

Modify the design
To modify the design:

1. Click Parametric and then, in the Modify group, click Dimension.

2. Click Show.
3. Enclose the design in a box.
Creo Elements/Direct Drafting displays the design's dimension in green to indicate
that these are the driving dimensions. It is the driving dimensions that are used to
modify the design according to the design-capture rules. These dimensions reflect
the way in which you created the design.
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Note

Remember to use Fit, Pan and Zoom for fitting, panning, and
zooming!

To modify the design:

1. Click Parametric and then, in the Modify group, click Dimension.

2. Click Deferred.
3. Click the dimension 40 (it changes to yellow).
4. Type 30 in the user input line and press ENTER.

5. Click OK.
The design changes according to the modified dimension.

Swap the dimensions

1. Click Parametric and then, in the Modify group, click Dimension.

2. Click Immediate.
3. Click the dimension 20 on the left of the drawing.
4. Type 25 in the user input line and press ENTER.

The shape changes. Since this is not the design you want, you need to re-
dimension it.

5. Click Undo.

6. Click Viewing and then, in the View group, click Redraw.
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7. Click Drafting and then, in the Annotate group, click the arrow next to
Angular.

8. Click Angle.

9. In the Orient gallery, click Direct.
10. Click the intersecting lines at S.

11. Click View and then, in the Viewing group, click Redraw.

12. Click Parametric and then, in the Modify group, click Dimension.

13. Click Show.
14. Enclose the entire design in a box.

15. Click Parametric and then, in the Modify group, click Dimension.

16. Click Swap and then click the yellow angle.
17. Click the dimension 15 (this dimension disappears because the angle becomes

the driving dimension).

18. Click View and then, in the Viewing group, click Redraw.

Copy the design
The next step is to repeat the above but this time copy the design to show that the
copy does not contain driving dimensions. The design changes and the position of
the hole remains relative to the defining offset.

1. Click Parametric and then, in the Modify group, click Dimension.

2. Click Deferred.
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3. Click the dimension 20 on the left of the drawing.
4. Type 25 in the user input line and press ENTER.

5. Click OK.
6. Click Modify and then, in the General group, click the Keep check box.

7. Click Modify and then, in the General group, click Move.
8. Enclose the design in a box and position the copied drawing.

9. Click Parametric, and then, in the Modify group, click Dimension.

10. Click Show.
11. Enclose both drawings in a box.

12. Click Parametric, and then, in the Modify group, click Dimension.

13. Click Deferred.
14. Click the dimension 25.
15. Type 20 in the user input line and press ENTER.

16. Click OK.
Both the original and the copy change shape — Creo Elements/Direct Drafting
remembers that you want both designs to have the same shape.

To clear the display:

1. In the Utilities group, click Delete.

2. In the Utilities group, click Select.

3. Click All.

4. Click Confirm
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Exercise 2
In this exercise, you copy and modify a cogwheel to demonstrate how to create
families of parts.

Create the basic design

1. Click File ▶ Open to open the Creo Elements/Direct Drafting File
Browser.

2. Double–click the pd_demos directory.
3. Select the cogwheel file and click Open.

Creo Elements/Direct Drafting displays a single tooth together with some
construction geometry.

4. Click Modify and then, in the General group, click the Keep check box.
5. Click Modify and then, in the General group, click the Repeat check box.

6. Click Modify and then, in the General group, click Rotate.

7. Click Center.
8. Type 29 (the repeat factor) in the user input line and press ENTER.
9. Click point A to mark the center of rotation.
10. Type 12 to define the rotation angle in the user input line and press ENTER.
11. Enclose the single tooth in a box.

12. Click View and then, in the Viewing group, click Fit.
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Identify the dimensions to change

1. Click Parametric and then, in the Modify group, click Dimension.

2. Click Show.
3. Click point B on arc of tooth.
4. Repeat for points C, D, and E.

5. Click View and then, in the Viewing group, click Fit.

6. Click Parametric and then, in the Modify group, click Dimension.

7. Click Deferred.
8. Click the dimensions in turn and move them to unclutter the drawing.

Change the tooth dimensions

1. Click Parametric and then, in the Modify group, click Dimension.

2. Click Deferred.

a. Click R40.
b. Type 55 in the user input line and press ENTER.
c. Click R39.
d. Type 54 in the user input line and press ENTER.
e. Click R31.
f. Type 35 in the user input line and press ENTER.
g. Click R30.
h. Type 34 in the user input line and press ENTER.

3. Click OK.
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Creo Elements/Direct Drafting updates the cogwheel accordingly.

4. Click View and then, in the Viewing group, click Fit.

5. Click Drafting and then, in the Draw group, click the arrow next to Circle.

6. Click Center & Radius.
7. Draw a circle with radius 4 mm at point G.
8. Click Modify and then, in the General group, click the Keep check box.
9. Click Modify and then, in the General group, click the Repeat check box.

10. Click Modify and then, in the General group, click Rotate.

11. Click Center.
12. Type 5 (the repeat factor) in the user input line and press ENTER.
13. Click point A to mark the center of rotation.
14. Type 60 to define the rotation angle in the user input line and press ENTER.
15. Enclose the 4 mm circle in a box.

16. Click Drafting and then, in the Annotate group, click the arrow next to
Circular.

17. Click Radius.
18. Dimension the radii of the six circles.

19. Click Parametric and then, in the Modify group, click Dimension.

20. Click Show.
21. Click the original circle (not one of the copies).
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Modify the design
The final step is to modify the design by changing parametric values.

1. Click Parametric and then, in the Modify group, click Dimension.

2. Click Immediate.
3. Click R4 (green dimension).
4. Type 3 in the user input line and press ENTER.

Creo Elements/Direct Drafting changes the radii of all six circles — the
yellow (annotation) dimensions are also updated.

5. In the Utilities group, click Delete and delete the six yellow dimensions.

6. Click Parametric and then, in the Create group, click Constraints.

The Generate Constraints dialog box opens.
7. In the Action area, click Show.
8. In the Type box, select Size.
9. Click Apply.

The Parametric module has used the actions performed during the creation of
the design to generate constraints for dynamic modification of the design.

10. In the Generate Constraints dialog box, click Assign in the Action area.
11. In the Type box, select Size.
12. Click Apply.
13. Click the original circle at G.
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14. Type 'Borehole_radius' in the user input line and press ENTER.

15. Click OK.

16. Click Parametric and then, in the Show group, click Current.

The Current Constraints dialog box opens.
17. Click Advanced.

The Advanced dialog box opens.
18. Click the value 3 in the New Value or Expression column.
19. Edit the value to 4 and click Apply.

20. Click Parametric and then, in the Solve group, click Preview.

21. Click Parametric and then, in the Solve group, click Keep.
22. Click the design.

23. Move the copy of the design to another location (you may need to use Pan
in the Viewing group on the View tab).

24. Click the destination point for the copy.

25. Click OK.

26. Click View and then, in the Viewing group, click Fit.
Note the smooth transition from simple design creation using the green driving
dimensions to parametric design.
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Hints and Tips
You have had a look now at the latest technology available in the Mechanical
Engineering CAD environment.
Here are some hints and tips when creating parametric drawings:

• To make sure your design intent drawing is always stored right away, enable
Parametric Design and Copilot every time you create geometry. This avoids
having to give any constraints afterwards.

• When you modify geometry using the Solve group buttons in the Parametric
tab, you can decide whether you want to keep the original geometry and let the
modified be a copy or if you want to modify the original geometry without a

copy. This is done by clicking either Keep or No Keep, respectively.
• When you specify a parameter, you can either specify a figure or enter an

expression that is evaluated when the design is solved. This is useful, for
example, when maintaining relations between width and height of designs.

• In case you want to do specific modification to more complex designs,
consider forming rigid bodies of geometry you want to move and translate as a
whole. This can facilitate the modification of large designs.

• How you create the design is important. For example, try creating Figure 46

on page 752 using horizontal and vertical geometry instead of using
Polygon. You would get very different results.

Parametric Design Defaults
User-changeable defaults exist for several entities used by Parametric Design.
All of these defaults may be set at Creo Elements/Direct Drafting startup time by
including the appropriate Parametric Design functions in the file pd_def.mac.
The default constraint icon size and color may also be set through Parametric
Design screen buttons.

Setting Icon Defaults From the Screen

Use Move Icon and the Icon Setting dialog box to set the location, size and
colors of Parametric Design information labels and highlighting.

Move Icon

Move Icon allows you to change the location of constraint icons on the part.
To move icons:

Parametric Design with Creo Elements/Direct Drafting Fluent User Interface 761



1. Click Parametric and then, in the Modify group, click Move Icon.
2. Click the icon to be moved.
3. Drag the cursor to the new location and click again.

Note
You can only change the position of the constraint icon itself; you cannot
change the position of the callout line on the referenced geometry.

Icon Size
To change the icon size:

1. Click File ▶ Settings ▶ Parametric ▶ Parametric Icon.

The Icon Setting dialog box opens.
2. In the Size box, type the new size.
3. Click OK.

Subsequent Show or Inq Icon functions draw constraint icons in the new size.
Existing icons can be cleared and re-displayed to get the new size. The Creo
Elements/Direct Drafting NEW_SCREEN function also re-displays icons in the
new size and location. The default icon size is the same as the Creo Elements/
Direct Drafting default text size, that is, 3.5 mm.

Set Color
To set the icon color:

1. Click File ▶ Settings ▶ Parametric ▶ Parametric Icon.

The Icon Setting dialog box opens.
2. In the Color box, select the new color.

Subsequent Show or Inq Icon functions draw constraint icons in the new color.
Existing icons must be cleared and re-displayed to get the new color. The initial
show color is CYAN.
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The PD_Defaults File
Parametric Design reads the file pd_def.mac at startup to determine defaults.
You can change these defaults by editing this file. As supplied, the pd_def.mac
file contains the following lines:
PD_AUTO_SYMMETRY_LINE YES Auto symmetry lines are
enabled and

PD_AUTO_SYMMETRY_COLOR YELLOW defined to be
yellow,

PD_AUTO_SYMMETRY_LINETYPE DOT_CENTER dot-centerlines.

Zero-distance tolerance
used by AUTO

PD_AUTO_ZERO_DISTANCE_TOLERANCE 1E-6 Distance tolerance used by
AUTO

PD_AUTO_SAME_DISTANCE_TOLERANCE 1E-6 Same-angle tolerance used
by AUTO

PD_AUTO_ANGLE_TOLERANCE 1E-6 Tolerance for determining
tangency in AUTO

PD_AUTO_TANGENT_TOLERANCE 1E-6 Tolerance for merging
elements in AUTO

Default SHOW color for
icons is CYAN

PD_RESOLVE_MERGE_TOLERANCE 1E-6 Default Icon size is 3.5

Dimensional constraints
replace dimension text

PD_SHOW_COLOR CYAN ZONE Auto On feature is
enabled

PD_SHOW_LABEL_SIZE 3.5 Default color for
generated points

PD_SHOW_USE_POSTFIX NO Linetype for generated
points

Visibility of generated
points

ADD_CURRENT_INFO "PD_ZONE" END Default color for
generated construction lines
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Linetype for generated
construction lines

PD_NEW_POINT_COLOR GREEN Visibility of generated
construction lines

PD_NEW_POINT_LINETYPE DOT_CENTER Default SOLVE Preview
color is MAGENTA

PD_NEW_POINT_VISIBILITY INVISIBLE Default color of
parametric dimensions is GREEN

Design Intent Capture
enabled by default

PD_NEW_C_LINE_COLOR GREEN

PD_NEW_C_LINE_LINETYPE DOT_CENTER

PD_NEW_C_LINE_VISIBILITY INVISIBLE

PD_PREVIEW_COLOR MAGENTA

PD_DEFAULT_DIM_COLOR GREEN

Design_intent_on

PD_AUTO_SYMMETRY_*
The PD_AUTO_SYMMETRY_* options enable and disable automatic symmetry
line constraining. When PD_AUTO_SYMMETRY_LINE is set to YES, the
constraint generator and solver will automatically assign symmetry-line
constraints to all lines that have the PD_AUTO_SYMMETRY_COLOR and PD_
AUTO_SYMMETRY_LINETYPE.

PD_AUTO_*_TOLERANCE
The PD_AUTO_*_TOLERANCE options set various tolerances used by
Complete to determine the relationships among elements in a part. These
tolerances are used to compensate for minor inconsistencies in a part (e.g., fillets
that are not quite tangent, slightly disconnected elements, lines slightly out of
parallel, etc.).

PD_AUTO_ZERO_DISTANCE_TOLERANCE
This function specifies the absolute tolerance used by Complete to compare a
distance to zero. This tolerance is used to detect coincident points, collinear lines
and point-on-element constraints. The number supplied must be greater than or
equal to zero. The initial setting is 0.000001 mm.
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PD_AUTO_SAME_DISTANCE_TOLERANCE
This function specifies the absolute tolerance used by Complete to compare two
non-zero distances. This tolerance may be used, for example, to check whether
two circular elements have the same radius. The number supplied must be greater
than or equal to zero. The initial value is 0.000001 mm.

PD_AUTO_ANGLE_TOLERANCE
This function specifies the absolute tolerance used by Complete to compare
angles. This tolerance is applied, for example, when checking whether two lines
are parallel or a single line is horizontal. The number supplied must be greater
than or equal to zero. The initial value is 0.000001 radians.

PD_AUTO_TANGENT_TOLERANCE
This function specifies the absolute distance tolerance used by Complete to check
whether two elements are tangent. This tolerance is applied only if one of the
extracted elements is circular. The tolerance is used to compare the radius of the
circular element to the distance from the circular element center point to the other
element. The number supplied must be greater than or equal to zero. The initial
setting is 0.000001 mm.

PD_RESOLVE_MERGE_TOLERANCE
PD_RESOLVE_MERGE_TOLERANCE specifies the absolute tolerance used by
the Parametric Design solver to decide whether the modification should result in
the merging of two or more points, or in the deletion of small elements. The merge
process can be eliminated by setting this tolerance to a negative number. The
initial setting is 0.000001 mm.

PD_SHOW_*
The PD_SHOW_COLOR and PD_SHOW_LABEL_SIZE options correspond to
the color and size settings in the Icon Setting dialog box.
PD_SHOW_USE_POSTFIX controls the display of dimensional constraints.
When set to the default value of NO, the constraint value replaces the normal
dimension text. If set to YES, the constraint value is displayed as a postfix to the
main dimension text. Earlier versions of the software always displayed
dimensional constraints as postfixes.

ADD_CURRENT_INFO
ADD_CURRENT_INFO "PD_ZONE" END causes the "PD_ZONE" info to be
included in all new geometry. As a result, all new geometry is added to the zone.
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PD_NEW_C_LINE_*
The PD_NEW_C_LINE_* options determine the default color, linetype, and
visibility for any new construction lines that are created when constraints are
created. The default color and linetype causes these construction lines to be
displayed as green lines. Visibility of these construction lines can be set so they
are either always visible or visible only when constraints are displayed.

PD_NEW_POINT_*
The PD_NEW_POINT_* options determine the default color, linetype, and
visibility for any new points that are created. Typically, these points are created
only when needed to fix point-on or reference-point constraints. The default color
and linetype causes these points to be displayed as green ×'s (crosses). Visibility
of these points can be set so they are either always visible or visible only when
constraints are displayed.

PD_PREVIEW_COLOR

PD_PREVIEW_COLOR sets the default color used by the Preview mode of
Solve. This color cannot be set from the screen menu.

PD_DEFAULT_DIM_COLOR
PD_DEFAULT_DIM_COLOR sets the default color used when parametric
dimensions are displayed for Dimension Driven Modification. This color cannot
be set from the screen menu.

766 Creo Elements/Direct Drafting User's Guide: Fluent User Interface



25
Toolbar and Classical Menu

Support
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Customizing Toolbars and Toolbar Items ................................................................... 770

From Creo Elements/Direct Drafting Rev. 18.1 onwards, MFC-based toolbar and
menu customizations (ASCII Format Layouts) created and saved in earlier
versions can be loaded in the Creo Elements/Direct Drafting Fluent user interface.
To load the customizations:

1. Click File ▶ Import/Export ▶ Import Macro ▶ Input Macro.

The Input Macro dialog box opens.
2. Select the macro and click Open.
Alternatively, you can use the INPUT command to load the customizations.

Note
After you load the customized toolbars and menus in Creo Elements/Direct
Drafting, you cannot modify or customize them.

You can also use the emulated “classical” menus and tables. You can load them by
specifying their macro name.
Emulated "classical" menus and tables (referencing the MENU and TABLE
commands) cannot be scaled to wrap to a changing number of rows and columns.
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The number of rows and columns always remain fixed as defined in the
underlying macro. Note that these menus are not saved for subsequent relaunch
when you exit Creo Elements/Direct Drafting.
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Displaying and Hiding Toolbars
To display or hide a toolbar:

1. Click View and then, in the Viewing group, click Toolbars.
2. Click Drafting.
3. Click or clear the check box of a toolbar to show or hide the toolbar,

respectively.

Excluding Toolbars
You can exclude a toolbar from loading in Creo Elements/Direct Drafting by
specifying the name of the toolbar in a text file.
To exclude a toolbar, add the name of the toolbar in the
FilterToolBars.txt file, which is available in the following path:
<Creo Elements/Direct Drafting Installation Folder>/
fluent_ui

Note
Creo Elements/Direct Drafting creates a copy of the
FilterToolBars.txt file in the AppData (Application Data) folder
after every session. If you make any changes to the FilterToolBars.txt
file, you have to remove its copy from the AppData (Application Data)
folder to implement the changes.

To avoid redundancy, toolbars like Command Line, Status Bar, and Main Toolbar
are excluded by default.

Managing Layouts
You can load, save, or reset toolbars in Creo Elements/Direct Drafting to manage
layouts.
To load a toolbar:

1. Click Miscellaneous and then, in the Toolbars group, click Load Toolbars.

The Load Toolbars dialog box opens.
2. Select the toolbar and click Open.
To save a toolbar:

Toolbar and Classical Menu Support 769



1. Click Miscellaneous and then, in the Toolbars group, click Save Toolbars.

The Save Toolbars dialog box opens.
2. Under Caption, select the toolbar.

Tip
To save multiple toolbars, press CTRL and select multiple toolbars.

3. Click Save.

The Save Toolbar dialog box opens.
4. Specify a name for the toolbar and click Save.
To reset a toolbar:

• Click Miscellaneous and then, in the Toolbars group, click Reset Toolbars.

Note
You can activate the Miscellaneous tab when you customize the ribbon. For
more information about customizing the ribbon, see Customizing the Creo
Elements/Direct Drafting Ribbon on page 32.

Customizing Toolbars and Toolbar Items
You can add, edit, or delete toolbars and toolbar items using the Customize dialog
box.
To open the Customize dialog box:

• Click File ▶ Customize.
The Customize dialog box displays a list of toolbars and toolbar items in Creo
Elements/Direct Drafting. When you start Creo Elements/Direct Drafting, all pre-
defined toolbars are loaded by default, but are hidden. You can display a toolbar
by clicking its check box in the Toolbars list of the Customize dialog box. You can

also display or hide toolbars using Toolbars in the Viewing group on the View
tab. For more information, see Displaying and Hiding Toolbars on page 769.
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Note
You retain a toolbar layout across Creo Elements/Direct Drafting sessions.
When you exit Creo Elements/Direct Drafting, the toolbar layout information
is stored in the layout_f.m file in the AppData (Application Data) folder.
Creo Elements/Direct Drafting loads this file (if available) when you start a
new session.

Creating a Custom Toolbar
To create a custom toolbar:

1. Click File ▶ Customize.

The Customize dialog box opens. The Toolbars pane opens by default.
2. Click Add.

The Add Toolbar dialog box opens.
3. In the Caption Key box, type a label for the toolbar.

Creo Elements/Direct Drafting displays this label in the user interface.
4. Click or clear the Locked check box to lock or unlock the toolbar, respectively.

Note
You cannot delete a locked toolbar.

5. In the Unique Name box, type a unique name for the toolbar.

This name is internal to Creo Elements/Direct Drafting.
6. In the On Right Click box, type a command, function, or macro name.

This command, function, or macro is executed when you right-click the
toolbar.

7. In the Domain box, type the name of the message file (if any).

Creo Elements/Direct Drafting refers to the message file for the localized
version (if applicable) of this toolbar.
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Note
Every toolbar and toolbar item in the Creo Elements/Direct Drafting user
interface is associated with a specific domain file. The domain file
contains the strings associated with the toolbar or toolbar items, which you
can edit. The strings include:

• Caption
• Category
• Tooltip
• List Items

8. Click OK.

Tip
• You can place the toolbar anywhere in the Creo Elements/Direct Drafting user

interface using a drag-and-drop operation.
• To display tooltips of the toolbar items, click the Show Tooltips check box in

the Toolbars pane of the Customize dialog box.

Selecting a Toolbar Menu Style
You can select the look and feel of the toolbar menus. You can view the toolbar
menus as icons, text, or both.
To select a toolbar menu style:

1. Click File ▶ Customize.

The Customize dialog box opens. The Toolbars pane opens by default.
2. In the Text Options box, select one of the following:

• Text below

• Text on right

• Text only

• Icon only
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Editing a Toolbar
To edit a toolbar:

1. Click File ▶ Customize.

The Customize dialog box opens. The Toolbars pane opens by default.
2. In the Toolbars list, select a toolbar.
3. Click Edit.

The Edit Toolbar dialog box opens.
4. Edit the settings.
5. Click OK.

Deleting a Toolbar
To delete a toolbar:

1. Click File ▶ Customize.

The Customize dialog box opens. The Toolbars pane opens by default.
2. In the Toolbars list, select a toolbar.
3. Click Destroy.

Creating a Custom Toolbar Item
To create a custom toolbar item:

1. Click File ▶ Customize.

The Customize dialog box opens. The Toolbars pane opens by default.
2. Click Toolbar Items.
3. Click Add.

The Add Toolbar Item dialog box opens.
4. Define the following parameters in the Add Toolbar Item dialog box:

Parameter Description
Caption Key Type a label for the toolbar item.

Creo Elements/Direct Drafting displays this label in
the user interface.

Enabled Click or clear the check box to enable or disable the
toolbar item, respectively.

Unique Name Type a unique name for the toolbar.
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Parameter Description

This name is internal to Creo Elements/Direct
Drafting.

Item Type Select a standard MS Windows item type.

Note
The item types in the Item Type list are context-
sensitive. For example, you can select items from
a context menu when you right-click a button that
is created by using Popup Button.

Submenu Select a submenu.
Note
The Submenu list is available only if you select
Popup Button in the Item Type list.

ToolTip Key Type a brief description of the toolbar item.
On Action Type a command, function, or macro name (for

example, change_color).
Creo Elements/Direct Drafting executes this
command, function, or macro when you click the
toolbar item.

On Right Click Type a command, function, or macro name.
Creo Elements/Direct Drafting executes this
command, function, or macro when you right-click
the toolbar item.

Category Key Define a category for the toolbar item.
Domain Type the name of the message file (if any).

Creo Elements/Direct Drafting refers to the message
file for the localized version of this toolbar item (if
applicable).

Note
Multiple toolbars may share the same domain file.
Optionally, you can create a separate domain file
for each toolbar.

Image Define an icon for the toolbar item:

a. In the Image area, click Edit.
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Parameter Description
The Image Editor dialog box opens.

b. Use the drawing tools to design the icon.
c. Click OK.

Tip
• To save the icon, click Store in the Image Editor

dialog box.
• To use an existing image as an icon, click Load in

the Image Editor dialog box.
List Keys Define an action string:

• Click to add an item to the list.

• Click to remove an item from the list.

• Click or to scroll within the list of keys.

Note
An action string requires an associated action
definition in a separate macro.

5. Click OK.

Note
Combo boxes, radio buttons, and check boxes require a separate macro. For
details about the Creo Elements/Direct Drafting user interface customization
capabilities, see TOOLBAR_ITEM in the Creo Elements/Direct Drafting /
Creo Elements/Direct 2D Access Programming Reference Guide.

Adding an Icon to the Toolbar
You can add icons (as buttons) to the Creo Elements/Direct Drafting toolbars.
To add an icon to a toolbar:

1. Click File ▶ Customize.

The Customize dialog box opens. The Toolbars pane opens by default.
2. Click Toolbar Items.
3. In the Categories list, select a category.
4. Select a toolbar item.

Toolbar and Classical Menu Support 775



5. Click Edit.

The Edit Toolbar Item dialog box opens.
6. In the Image area, click Edit.

The Image Editor dialog box opens.
7. Create an icon.

Tip
To add an existing icon, click Load in the Image Editor dialog box.

8. Click OK.

The icon is associated with the toolbar item.
9. Drag the toolbar item to the toolbar.

Tip
• To remove a button from a toolbar, drag the toolbar button to the Customize

dialog box.
• You can copy or move toolbar buttons to other toolbars.
• Press CTRL and place a toolbar button on the destination toolbar (with a drag-

and-drop operation) to copy the toolbar button.
• If the Customize dialog box is not open, you can use ALT to move toolbar

buttons or use ALT+CTRL to copy toolbar buttons to other toolbars.

Editing a Toolbar Item
To edit a toolbar item:

1. Click File ▶ Customize.

The Customize dialog box opens. The Toolbars pane opens by default.
2. Click Toolbar Items.
3. In the Categories list, select a category.
4. Select a toolbar item.
5. Click Edit.

The Edit Toolbar Item dialog box opens.
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6. Edit the parameter values.
7. Click OK.

Deleting a Toolbar item
To delete a toolbar item:

1. Click File ▶ Customize.

The Customize dialog box opens. The Toolbars pane opens by default.
2. Click Toolbar Items.
3. In the Categories list, select a category.
4. Select a toolbar item.
5. Click Destroy.

Note
• Destroy removes items from the Toolbar Items pane of the Customize dialog

box and deletes the associated files.
• You cannot undo Destroy.
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26
Managing drawings with Windchill

The Creo Elements/Direct Drafting and Windchill integration allows you to load,
save, and manage data created by Creo Elements/Direct Drafting in Windchill.

Activating the Windchill PDM Actions from Creo Elements/Direct
Drafting
1. Register Creo Elements/Direct Drafting with the Windchill Workgroup

Manager:

Install and start the Windchill Unified Workgroup Manager (UWGM) and set
the UWGM server as the primary server.

2. Activate the Windchill Workgroup Manager in Creo Elements/Direct Drafting:

Click File ▶ Modules ▶ Windchill Workgroup Manager.

The Windchill menu is now available in Creo Elements/Direct Drafting.

Windchill PDM commands
The following table describes the PDM commands that are inserted into Creo
Elements/Direct Drafting when connected to the Windchill Workgroup Manager.

Action Menu Location Description
Open from
Windchill

Windchill ▶ Open from
Windchill

[Also]
File ▶ Open from Windchill

Opens the Open from Windchill
window. By default, the
contents of your active
workspace are displayed. You
can also navigate to the server
common space to select an
object to open.

Save to Windchill ▶ Save to Workspace Opens the Save to Workspace
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Action Menu Location Description
Workspace [Also]

File ▶ Save to Workspace

window. Upon execution of the
save, the document is uploaded
to the server-side workspace.

Check out Windchill ▶ Check out Checks that the current
drawing is not already checked
out. If not, checks out the
current document to the
workspace.

Revise and
Check out

Windchill ▶ Revise and Check
out

Checks that the current
drawing is not already checked
out. If not, creates a new
revision of the current file and
checks the new revision out to
the workspace, replacing the
earlier revision in the
workspace and in Creo
Elements/Direct session.

Undo Check out Windchill ▶ Undo Check out Cancels the check out of the
current document.

Note
If the document was
checked out via the Revise
and Check out action, the
higher revision label is
maintained.

Custom Check
In

Windchill ▶ Custom Check In

[Also]
File ▶ Custom Check In

Accesses the Check In page
and allows you to change
check in options.

Auto Check In Windchill ▶ Auto Check In Automatically checks in the
current file to the
commonspace.

Load File from
Windchill

Windchill ▶ Load File from
Windchill

Opens the Open from Windchill
window, allowing you to
navigate to another document
with drawing geometry to load
into the current drawing.

Load Frame
from Windchill

Windchill ▶ Load Frame from
Windchill

Opens the Open from Windchill
window, allowing you to
navigate to a library containing
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Action Menu Location Description
frames and select a frame to
load into the current drawing.

Save Frame to
Windchill

Windchill ▶ Save Frame to
Windchill

Opens the Save to Workspace
window, allowing an
administrator to save a new
drawing recognized as a frame
to an appropriate library
workspace.

Text Reference Windchill ▶ Text Reference Calls or displays a submenu for
text references enabling a user
to assign, unassign, or update
text references to document
attributes. In addition, actions
are available to display
references, values, or a table of
name-value pairs.

Workgroup
Manager

Windchill ▶Managers ▶
Workgroup Manager

Opens the Windchill Workgroup
Manager (if closed); accesses
the Workgroup Manager (if
open).

Server
Management

Windchill ▶Managers ▶ Server
Management

Opens the Server Manager
window, where you can view
or change Windchill servers
and server active workspaces.

Event
Management

Windchill ▶Managers ▶ Event
Management

Opens the Event Manager on
the current server.

Update Windchill ▶ Update Checks the server for a later
iteration. If one is found,
replaces the drawing in session
and in the workspace with the
latest server iteration. An
Update action also updates all
drawing text references.
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Action Menu Location Description
View Drawing
Information

Windchill ▶ View Drawing
Information

Opens the server information
page (workspace view) for the
drawing in session.

Windchill
Workgroup
Manager Help

Windchill ▶Windchill
Workgroup Manager Help

[Also]
Help ▶Windchill Workgroup
Manager Help

Opens the Windchill
Workgroup Manager Help
Center.

For more information on the Windchill PDM commands, see the Windchill WGM
help from the Creo Elements/Direct Drafting user interface.
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Introduction
Creo Elements/Direct Drafting’s different internal and external encoding schemes
were Unicode incorporated for version 2007. Unicode allows text and symbols
from all languages to be consistently represented and manipulated by computers.
All textual and string data processed by Creo Elements/Direct Drafting is held
internally in Unicode (UTF-8) encoding. That means most of Drafting's
functionality processes user input from almost any language, and string data from
different languages can be mixed. For example, it is now possible to have
German, Japanese, and Russian characters within a single string, such as a part
name.
Drafting's font list contains all the Creo Elements/Direct true type fonts that are
dynamically converted to internal font format when referenced. An appropriate
font that contains all desired characters must be selected to display texts and
dimension texts correctly. Fonts containing characters from the whole Unicode
range are relatively rare, and they usually contain the word Unicode in their name
(for example, Arial Unicode MS).
Symbols are a special Creo Elements/Direct Drafting feature and display with hp_
symbols and hp_symbols2 fonts. They can still be composed in old-style escape
sequences (#15#XY#16) but for compatibility with Unicode are mapped to a
private-use Unicode area [E000-E1FF]:

• 15#XY#16 — 0xE000 + XY
• 30#XY#31 — 0xE100 + XY

MI file format
Version 3.20 MI files are encoded in Unicode (UTF-8). Files stored to older MI
versions are encoded as before, depending on the current locale. When loading
older MI formats, the Creo Elements/Direct Drafting loader uses the information
recorded in the info section (~1) of the MI file. MI formats without encoding
information in their info sections are treated as if encoded in ROMAN8 or SJIS
(Japanese locale).

Macro file encoding
Old macro files did not contain any encoding information. They were assumed to
be encoded for current locales (e.g. ROMAN8 for English and SJIS for Japanese
locales). However, this causes problems when using the same macros in different
locales.
Version 2007 supports macro Unicode but maintains backward compatibility.
We recommend you change old macro files such that their encoding is explicitly
specified with the DEFINE_ENCODING directive.
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Text macro files containing Unicode UTF-8 or UTF-16 BOMs (Byte Order
Markers), supported by most popular Windows text editors, are read as Unicode.
Files containing the DEFINE_ENCODING directive are always read in the
specified encoding. Otherwise they are treated as old macro files and encodings
are locale dependent:

• SJIS for Japanese
• BIG5 for traditional Chinese
• GB2312 for simplified Chinese
• ROMAN8 for all else

Limitations
The displaying of Unicode texts is limited. Features such as combining characters,
Arabic cursive connection, and bidirectional algorithm are not fully implemented.
CHR, NUM and # still work in old locale-dependent internal encodings
(ROMAN8 & SJIS). They return different results in different locales. They are
obsolete; their use is only for maintaining backward compatibility. For example,
((CHR 154)+(CHR 223)) or its equivalent (#154#223) displays a Japanese
character with Unicode code 22756 (hex 58E4) on a Japanese locale and two
Latin characters on other locales. To avoid problems and to display the same
character regardless of locale, use Unicode versions of these functions: (UCHR
22756), (UCHR '58E4'), #u22756, or #ux58E4.
Combinations of # and CHR to compose 2-byte characters and symbols are not
allowed. For example, ((CHR 154)+#223) does not work.
Strings that begin with (CHR 255) are icons and are not encoded in UTF-8. Pre-
2007 CoCreate Drafting versions let you compose icons using a large variety of
combinations (for example #255'abc'#212+CHR 12). In version 2007, only CHRs
can be used to compose icons.
MI files of versions prior to 2.90 that do not contain encoding information in their
info section (~1) load correctly only if loaded in the same locale as they were
drawn. For example, you have 2 options to correctly load a Japanese MI file of
version 2.80 in English Creo Elements/Direct Drafting:
1. Load the file in Japanese locale and store it back in new format:

a. CHANGE_LOCALE 'ja'
b. LOAD 'japanese.mi'
c. STORE MI ALL DEL_OLD 'japanese.mi'
d. CHANGE_LOCALE 'en'

2. Load the MI file in a text editor and manually add section ~1 at the beginning
of MI file:
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a. #~1
b. ENCODING:SJIS
c. Such files load correctly in any locale.

AIl modules call internal Creo Elements/Direct Drafting functions and use strings
in internal encoding. Before CoCreate Drafting 15.00 (2007) these strings were
encoded in ROMAN8 or SJIS, depending on locale. Compatibility is maintained
only for characters in range [0, 127]. If Application Interface (AI) modules use
characters in a different range, they must be changed and recompiled to support
UTF-8.

File names encoding
In CoCreate Drafting 2007, file names display in the same fashion as other
Windows applications. Prior to 2007 they were shown in the internal encoding,
which was different and dependant on locale. Files names were consequently
shown differently if extended characters were used.
You can set the MEEXTFN option in the .ini file to zero to keep the old
behavior.

Changed font concept
CoCreate Drafting 2007 does not distinguish between 1-byte and 2-byte fonts (in
terms of default settings or text properties). Because Creo Elements/Direct
Drafting now has Unicode support, there is just one current font at a time and each
text and dimension text has just one assigned font.
CoCreate Drafting 2007 includes new default fonts which have been combined
from the old 1- and 2-byte definitions:

• osd_default combines hp_i3098_v and hp_kanj2_c
• osd_default2 combines hp_i3098_c and hp_kanj2_c
• osd_default3 combines hp_d17_v and hp_kanj2_c
When loading old 2D files with texts or dimension texts using characters from 1-
and 2-byte fonts (fonts that are not already included in any of the osd_default
fonts), Creo Elements/Direct Drafting automatically combines the 2 fonts into a
single font containing the character definitions from both fonts. It names them "1-
byte=font name"#"1-byte=font name".
You can combine those fonts (1- and 2-byte fonts) into a single font using a new
command MERGE_TWO_FONTS.
TrueType fonts converted to Creo Elements/Direct Drafting fonts contain all
defined characters. Separate symbol fonts are used.
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Index

A
active
part, 432

ADD CURRENT INFO function, 765
Add Layer function, 514
Add Multiple command, 637
Add Single command, 637
Add Text
symbol command, 409

aligning dimensions, 357
alignment symbols, 408
All option, 648
angle
changing the hatch, 374
dimensioning, 294
hatching, 371
text, 389

Angle command, 294, 681
Angle constraint, 656
angles
measuring, 111

angular units
dimension, 331

arc
by center and end points, 159
by center and radius, 158
by diameter, 160
by point and radius, 159
by three points, 158
concentric, 159
dimensioning, 285, 292
drawing, 157
smooth connecting, 160

Arc command, 157, 292
area
changing a hatched, 373

measuring, 111
properties, 111

arrow
changing dimension line terminator
settings, 345
dimension line terminator settings,
315

Assign command, 641, 682
assigning
a z-value, 484
constraints, 639
parameters, 682
to the zone, 637

associated
properties, 131

associated data types, 199, 201
automatic
hatching, 367
snapping to end points of lines
(dimensioning), 263
stepping when datum dimensioning,
310

automatic constraint generation, 698,
711
autosave
time interval, 136

B
B-Splines, 161
background colors, 102, 104
backup
loading, 502

balloon
frame, 392

Ban command, 644
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banning constraints, 644
beeper
switching on or off, 59

bisect
angle, 180
lines, 180

BMP file
importing, 544

box
frame, 392

boxing
elements, 80

Broken function, 313
button, 21

C
calculator, 115
Cancel command, 88
canceling
a dimension text edit, 361
a hatch pattern, 373

cancelling
a command or function, 88

cascade timeout, 136
cascaded menus
delay time, 136

Catch Line function, 313
catch mode
changing, 107

Catch Range function, 314
center point
creating, 123

centering
the drawing, 613

Centerline command, 199
centerline dimensions, 271
chain
dimensioning, 272

Chain command, 272
chain dimension
inserting a segment, 363

Chain option, 240
chamfer
dimensioning, 298

Chamfer command, 196
chamfers
angle to first line, 198
by two distances, 198
by two points, 197
drawing, 196
given distance from a vertex, 197

Change Dim command, 343
Change Fillet command, 196
Change Hidden Face, 498
Change Hidden Line, 498
Change Layer layer function, 515
circle
by center and point on
circumference, 156
dimensioning, 286

Circle command, 156
circles
by diameter, 157
by radius and two elements, 157
by three points, 156
concentric circles, 156

classical menu
support, 767

Clean command, 245
Clean commands, 634
cleaning geometry, 633-634, 698
Clear command, 642
clearing constraints, 642
click
what does it mean?, 52

Clipboard, 607
closed spline, 162
closing Drafting, 60
CMT, 24
Collinear constraint, 657
color
changing, 98
dimension geometry, 311
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dimension text, 319
dimension text extension, 327
hatching, 371, 374
hidden face, 498
hidden line, 498
of geometry, text, hatching and
dimensions, 100
reference line, 397
surface symbols, 414
text, 391

color conversion, 105
color conversion map file
loading, 106
storing, 106

color information table, 102
coloring
layers, 516
URLs, 526

colors
converting, 101, 105
custom, 100
viewing, 101-102

command line, 24
command mini toolbar, 24
commands
canceling, 88
commonly used, 72
confirming, 88
dimensioning, 259
ending, 88
undoing, 88

commonly
used commands, 72

Complete command, 643-644, 698,
711
composite
symbols, 406

concentric
arcs, 159
circles, 156

confirming
commands, 88

delete operation, 88
modify operation, 88

constraints
Angle, 656
assigning, 639
automatic generation, 698, 711
banning, 644
clearing, 642
Collinear, 657
Dimension, 658
Distance, 660
Fillet, 663
freeing, 643
generating with Design Intent
Capture, 693
Horizontal, 664
icons, 655
Mirror, 665
Parallel, 667
parametizable, 682
Perpendic, 668
Point on, 669
Refelem, 671
Refpoint, 672
Samedist, 673
Samesize, 674
showing, 642
Size, 674
Slope, 675
Symmline, 676
Tangent, 678
tools, 639
Vertical, 679

construction
geometry, 175

construction circles
by center and circumference point,
181
by center and element, 181
by diameter, 182
by radius or point and two elements,
183
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by radius, point, and element, 182
by three elements, 183
by three points, 181
concentric, 181
drawing, 180

construction geometry
selecting for deletion, 82

construction lines
a tangent to two circles, 180
at an angle, 178
bisecting a line, 180
bisecting an angle, 180
by two points, 176
drawing, 176
horizontal, 176
parallel, 177
perpendicular, 178
tangent from a point to a circle, 179
vertical, 177

context menu, 24
Contour command, 243
contour level, 85
Contour level, 85
contours
drawing, 175
selecting, 84

control points, splines, 161-162
control spline
splitting into segments of equal
length, 236

Control Spline command, 164
control splines
adding a control point, 231
changing the shape, 232
changing the slope, 232
moving a control point, 231

convert
colors, 105

convert colors, 101
convert text to geometry, 394
Coordinate command, 278
coordinates

datum dimensioning, 278
Copilot functionality, 139
example, 145

Copy, 49
Copy Contour, 87
copy directories, 551
copy directories using recursive, 551
copy files using selection mechanism,
549
copy options, 553
Create command, 442
creating
a centerline, 199
a new center point, 123
a new window, 124
a part, 442
a viewport, 127
contours, 243
ellipses, 167
hyperbolas, 168
parabolas, 170
parameter value tables, 633
parameters, 680
reference line, 394
rigid body, 639
splines, 161
symmetric elements, 201

Creo Elements/Direct Annotation
changing colors, linetypes and
hatches, 603
dimensions, 599
elements, 599
hidden lines, 598
hiding or deleting, 601
introduction, 592
limitations, 594
loading a drawing, 595
preparing, 595
rules, 592
selecting a sheet or view, 596
sheet, 600
Sheet Browser, 595
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showing, 604
showing differences, 598
storing, 604
tangent lines, 598
unhiding, 602
view, 596

Creo Elements/Direct Drafting
common definitions, 52
exiting, 60
getting started with, 48
toolbox, 133
what is it, 12

Creo Elements/Direct Drafting
instance, 540
current
viewport, 119-120, 123, 127

Current Layer function, 514
current offset
setting, 481

Current Offset command, 481
Current Z Value command, 491
cursor
setting the size, 117

custom colors, 100
customizing the ribbon, 32
Cut, 49
Cut Middle option, 240

D
DA DB MATCH command, 301
DA DIM GEO SENSE command, 299
DA DIM PD SCAN command, 300
datum
dimensioning using coordinates, 278
dimensioning using long base lines,
278
dimensioning using short base lines,
278
dimensioning with automatic
stepping of dimension text, 310

datum dimension

inserting a segment, 363
Datum Long command, 278
Datum Short command, 278
Datum Step function, 310
datum target
symbols, 409

decimal places
dimension units, 331

default
z-value, 491

defaults, 761
defining
load value, 491
parameters, 682
printing or plotting parameters, 610
your own units, 66
zones, 633

delete
elements, 58

delete command, 73
Delete Face command, 496
deleting
a covering face, 496
a part, 438
all viewports, 129
an info, 519
elements, 73
general, 73
hatch, 380
hatching, 380
OLE object, 586
OLEs, 72
parameters, 686
pictures, 72
symbols, 404
text, 388
viewports, 129
z-values, 484
zone elements, 638

Deleting Macros, 135
design intent capture
benefits, 693
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constraint creation, 694
disabling, 694
elements affected, 694
enabling, 694
inquiring on/off status, 694
overview, 693

destination gap
reference line, 398

detail
dimensioning a detail part, 263
parts, 443

diameter
dimensioning, 291

Diameter command, 291
Dimension constraint, 658
dimension database, 301
dimension driven modification
benefits, 688
defer, 691
displaying parametric dimensions,
688
immediate, 690
overview, 688

dimension extension lines
breaking, 348
resetting, 354
slanting, 349
staggering, 350

dimension leader line
moving, 355

dimension lines
breaking, 348
catch line, 313
catch range, 314
changing line settings, 344
changing terminator settings, 345
color, 311
datum step, 310
inside the extension lines, 313
line settings, 308
minimum space, 312
offset line, 309

offset point, 312
resetting, 354
slanting, 349
space, 310
staggering, 350
terminator settings, 315
width, 309

Dimension Style table
dimensioning, 341

dimension text
absolute size, 322
brackets, 323
character width-to-height ratio, 323
color, 319
editing dimension, 359
font, 319
frame, 320
location, 321
moving, 354
orientation, 320
relative size, 322
rotating, 356
settings, 318
slant, 323

dimension text extensions
absolute size, 327
adding, 324
character width-to-height ratio, 327
clearing, 326
color, 327
deleting, 325
font, 327
opening, 326
predefining, 324
relative size, 328
saving, 326
slant, 328
special character, 328

dimension units
changing settings, 346
decimal places, 331
settings, 329
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dimensioning
a drawing, 252
assignment features, 261
automatic dimension positioning
option, 338
automatic location, 338
canceling a dimension text edit, 361
changing settings, 343
changing vertex, 352
cm, 330
database matching, 301
database-matching assignment, 261
degrees, 331
degrees minutes seconds, 331
Dimension Style table, 341
direct assignment, 261
features, 258
feet and fractional inches, 330
fractional inches, 330
fractional inches with sign, 330
fractional inches with text, 330
Geo Sense settings, 339
geometry sensing assignment, 262
gradian, 331
inch, 330
interrupt functions, 307
km, 330
meters, 330
mm, 330
most used table, 264
multiple elements, 263
position settings, 338
preparation, 265
radians, 331
Scan settings, 340
scanning constraints, 300
selection aids, 263
selection filtering, 332
single geometry features, 266
standards, 264-265
Strategy option, 338
style setting features, 264

um, 330
using the common commands, 261
using the selection commands, 261

dimensioningGeo Sense command
Geo Sense settings, 299

dimensions
aligning, 357
centerline, 271
chamfer, 298
controlling position, 662
freeze, 358
geometry sensing, 299
moving, 355
selecting, 84
showing, 121
underlining, 359

Display command, 637, 648
displaying
icons, 633
infos, 121
point coordinates, 111
the origin, 116
zones, 637

distance
hatching, 371

Distance constraint, 660
distances
measuring, 108

dithering
the effect, 101

dot grid, 116
drawing
a polyline, 172
an isometric ruler/grid, 119
auto save time interval, 136
centering, 613
creating a new file, 539
fitting a, 122
justifying, 613
panning across, 123
plotting, 606
points, 172

792 Creo Elements/Direct Drafting User's Guide: Fluent User Interface



positioning, 612
printing, 606
scales, 465
viewing a, 121

drawing area, 24
drawing geometry
selecting, 83

drawing scale
setting the, 67

Duplicate command, 246, 635
DWF translator, 557
DXF translator, 557
dynamic feedback, 140

E
Edit command, 440
Edit Environment command, 62
Edit Part command, 432
Edit Text command, 387
Edit Text Inplace command, 386
editing
a part, 440
an info, 519
dimension text, 359
text via text box, 386-387
the parent part, 441
the top part, 440

editing parameter dimensions, 682
element
merging, 245
splitting, 244

elements
adding to your selection, 80
boxing, 80
changing the linetype, 98
deleting, 73
enclosing within a polygon, 81
moving to a layer, 515
preselecting, 87
removing them from your selection,
80

selecting, 77, 81
ellipse
by axis end points and peripheral
point, 166
by center and two points, 166
by center, angle and radii, 166

Ellipse command, 165
enclosing
elements, 81

End command, 88
ending
a command or function, 88

enter
what does it mean?, 52

Enter Refline command, 394
entering
special characters, 384
text directly in the drawing, 383

environment
changing, 90
editing, 62
saving, 137
saving settings, 63

environment file
setting a drawing frame, 66
setting the current units, 65

Equidist command, 174
exiting Drafting, 60
exporting
font, 546
macro, 546
picture file, 547

expression, defined, 679
extension lines
dimension geometry, 256

external file formats
handling, 557

F
face
automatically generating, 493
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automatically generating in a part,
494
definition of term, 472
deleting, 496
generating a, 493
generating in a part ignoring holes,
494
manually generating, 493
measuring the area, 111
undoing, 495

features
dimensioning single features, 266
showing all, 120

file
identifying, 530
identifying using the file path name,
530
names, 529
organization, 529

File, 528
File Browser
opening a drawing, 532
saving a drawing, 536
saving a drawing under a different
name, 537

file tab, 19
filename
MS-DOS, 529

filenames, 529
filing, 528
fill on
text, 390

fillet
dimensioning, 286

Fillet command, 195
Fillet constraint, 663
fillet weld, 422
fillets
changing radius, 196
drawing, 195

Filter command, 332
fitting, 122

flag
frame, 392

Follow on/off
using, 117

font
dimension text, 319
dimension text extension, 327
exporting, 546
importing, 543
text, 391

font size
surface symbols, 414

form
symbols, 407

format
changing dimension text, 345

frame
balloon, 392
box, 392
dimension text, 320
flag, 392
loading a drawing frame, 66
options, 67
text, 392

Free command, 643, 682
freeing constraints, 643
Freeze command, 358
functions
dimensioning, 259

fundamentals
of dimensioning, 253

G
gaps
trivial vs non-trivial, 248

Gaps command, 248
Generate Face command, 493
Generate Hidden command, 501
Generate Part command, 486
Generate Rigids commands, 638
generating
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a face, 493
hidden lines, 470, 501

generation
mode, 475

Geo command, 83
Geo Sense
settings, 339
using, 299

geometric tolerancing symbols, 404
geometry
cleaning, 698
construction, 175
dimension geometry, 255
drawing, 151

geometry cleaning, 633
Get Text command, 398
getting
properties, 132

global
selection, 74

Global
selection option combined with
Modify command, 207

Global Selection, 50
graphics performance
enhancing, 137

grid
displaying, 116

group, 21
grouping, 241

H
hatch distance
fillet weld symbols, 424

hatch settings, 370
hatching
angle, 371
automatically, 367
canceling patterns, 373
Change command, 373
changing the angle, 374

changing the hatch color, 374
changing the hatch distance, 374
changing the hatch match point, 375
changing the hatch pattern, 376
changing to geometry, 380
deleting, 74, 380
manually, 368
setting patterns, 372
setting the hatch color, 371
setting the hatch distance, 371
setting the linetype, 371
setting the match point, 367
settings, 370
standard patterns, 378
your drawing, 366

hatching around text, 376
help
general, 58

Help command, 58
hidden
redrawing, 496

hidden face
color, 498

hidden line
color, 498
generating, 470, 501
introduction, 471
modes, 475

hidden lines
plotting, 502

Hidden Mode Off command, 496
Hidden Mode On command, 496
Hidden Settings, 497
hiding
ruler/grid, 119

hierarchy
parts, 431

highlighting, fly by, 26
horizontal
dimensions, 268
measuring distances, 110

Horizontal constraints, 664

Index 795



horizontal lines
drawing, 151

Horizontal move, 210
HP-GL
saving drawings, 538

HP-GL file
importing, 545

hyperbola
by center, focus and point, 169
by center, tangent and focus, 169
tangential to existing geometry, 169

Hyperbola command, 168

I
Icon command, 761
Icon commands, 633
icons
coloring, 762
constraint, 655
in Part Browser, 460
manipulating, 633
modifying, 711
moving, 761
purpose, 641
removing, 642
resizing, 762

IGES translator, 557
images
changing pixel color, 581
hiding and showing, 578
importing, 544
inverting black and white, 582
quality for redraw, 578
scaling, 584
transparency for overlay, 583

importing
font, 543
HP-GL file, 545
image, 544
macro, 543

Include Dimension command, 448

Include Element command, 445
Include Part command, 448
including
a dimension, 448
a part, 448
an element in another part, 445

Inconsistent option, 648
infos
adding infos to elements, 518
changing an info, 520
deleting an info, 519
displaying, 121
editing an info, 519
listing all infos, 522
listing namespaces, 522
PD RIGID, 638
PD STATUS, 649
selecting, 82
setting a current info, 518
setting zone, 636
what are they?, 517

Infos
PD ZONE, 703

initiating
a part, 441

Inplace command, 383
Input command, 632, 652
input parameter value tables, 632
Inquire command, 646
Inquire Element command, 646
Inquire Icon, 646
Inquire Z Value command, 488
interpolation points, splines, 161-162
interpolation spline
splitting into segments of equal
length, 236

Interpolation Spline command, 164
interpolation splines
adding an interpolation point, 227
appending, 224
changing the shape, 230
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changing the shape by moving an
interpolation point, 228
changing the slope at an
interpolation point, 228
changing the slope at any spline
point, 229
deleting a tangency condition, 230
deleting an interpolation point, 228
moving an interpolation point, 227
specifying the slope, 225

Inverse Black and White, 50
invisible geometry, 715
display attributes, 715, 765

isometric
views, 222

Isometric command, 222
isometric ruler/grid
drawing, 119

italic fonts for symbols, 414

J
JPEG file
importing, 544

justifying
the drawing, 613

K
Keep command, 207, 631, 647
Keep Scale option, 454
key commands
customizing, 57

L
language
switching, 59

layer
changing the color, 121

layers
adding, 514
adding elements to a layer, 514

coloring a layer, 516
dimensioning on, 264
moving elements to a layer, 515
selecting, 82
setting a layer active, 514
using, 511
using the Select block, 516
using the Show functions, 515, 522,
526

learning
Drafting, 48

Length command, 681
lengths
measuring, 109

line
spacing text, 390

line color
setting, 92

Line command, 151
line grid, 116
line size
setting, 92

line size vs line width, 95
line width
changing, 98
dimension lines, 309
reference line, 397
setting, 92

line width vs line size, 95
linear units
dimension, 329

lines
a perpendicular line, 153
by two points, 151
dimension lines, 256
drawing a rectangle, 155
given length and angle, 154
horizontal, 151
polygon, 151
tangent from point to arc or circle,
155
tangent to two arcs or circles, 155
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vertical lines, 152
linesize
selecting, 83

linetype
changing, 98
creating a user-defined pattern, 93
deleting user-defined linetype, 95
editing user-defined linetype, 95
exporting user-defined linetype, 95
hatching, 371
setting, 92

linetype length, 618
listing
all infos, 522

load, 106
Load Backup command, 502
Load File
Absolute, 541
As Subpart, 541
Check 2D, 542
Check 2D Retain Dependency, 542
Keep Scale, 542
Part, 541

Load Files command, 561
load value, 491
defining, 491

Load Z Value command, 491
loading, 528
a part, 541
a standard drawing frame, 66
a subpart, 542
recently used drawing files, 536
the backup drawing, 502

loading drawings
File Browser, 532
Navigator, 534

loading master parts, 629
location
symbols, 407

long base lines
datum dimensioning, 278

M
macro
exporting, 546
importing, 543

macro-sets, 135
macros
deleting, 135
editing, 135
loading, 135
recording, 133
renaming, 134
running, 134

manual
hatching, 368

manually
generating a face, 493

master part
creating, 652
defined, 629
evaluating, 654
loading, 629
preparation, 634

master parts
and parameters, 652

match point
changing the hatch, 375
setting hatching, 367

Max. feedback, 208
maximum
z-value, 489

Measure
calculator, 115

Measure function, 108
measuring
angles, 111
area properties, 111
distances, 108
horizontal distances, 110
lengths, 109
radius, 109
vertical distances, 110

Merge command, 245
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merging
a subpart, 453
an element, 245

methods
drawing, 150

minimum
z-value in assembly, 489

Minimum Space function, 312
Mirror command, 215
Mirror constraint, 665
mirroring
about a center point, 216
about a horizontal line, 215
about a vertical line, 216
about two points, 215
elements, 215

mode
generation, 475
view, 475

modes
hidden line, 475

modifier
symbols, 409

Modify
number of elements in visual
feedback, 208

modify command, 205
Modify command, 710
modifying
a part, 439
chain and datum dimensions, 363
dimension lines, 347
existing dimension text, 354
general, 205
keeping or removing original
elements, 207
mirroring, 215
moving by reference point, 210
moving horizontally, 210
moving multiple times, 212
moving vertically, 211
parameter values, 629

rotating, 212
scaling, 216
stretching, 220
using selection, 207

modifying parameter value tables, 629
more, 21
most recently used drawing files, 536
Move command, 209
Move Icon command, 761
moving
dimension, 355
dimension leader line, 355
dimension text, 354
OLE object, 586
symbols, 404
the ruler, 117
using the reference point, 210

moving multiple Drafting instances,
540
MS-DOS filenames, 529
Multiple move, 212
multiple parts, 709

N
names
file, 529

namespaces
listing, 522

naming
parts, 432

naming rules for parameters, 682
Navigator
opening a drawing, 534

New command, 441
No Keep command, 632, 648
normal
redrawing, 496
symbols, 406

O
oblique
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parallel perspective views, 218
offset
reference line, 398
setting the distance between the top
of extension lines and dimension
lines, 309

Offset
arc, 193
circle, 193
construction circles, 193
construction lines, 193
line, 193
point, 193
rectangle, 193

offset point
setting the distance between the
geometry feature and the
dimension extension lines, 312

Offset Point function, 312
OLE Browser, 589
OLE object
activating, 589
deleting, 586
hiding and showing, 589
linking and embedding, 586
moving, 586
scaling, 586
to back, 588
to front, 588

OLEs
deleting, 73

Open, 532
Check 2D, 533
Check 2D Retain Dependency, 533

open spline, 162
options
text, 391

organization
file, 529

orientation
dimension text, 320
of existing dimension text, 354

origin
displaying, 116

origin vertex
text, 392

overdraw, 175
Overdraw command, 175

P
panning
across a drawing, 123

parabola
by center, tangent and focus, 171
by focus, direction and end points,
171

Parabola command, 170
parallel
construction lines, 177
contours, 174
dimensions, 268, 270
lines, 152
perspective views, 218

Parallel constraint, 667
parameter definition table
fields, 682

parameter value table
application, 632, 687
creating, 633
illustrated, 629
modifying, 629
restoring, 632
saving, 632

parameters
assigning, 682
changing values, 629
creation, explicit, 681
creation, implicit, 680
defining, 682
definition table, 679
editing, 679, 682, 685-686
expressions, 679
naming rules, 682
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printing/plotting, 609
removing, 686
showing, 629, 687
text, 389
units, 683
value table, 629
value type, 684

Parametric Design
starting, 625

Parametric Design software
defaults, 761
overview, 624

parametric dimensions
display attributes, 690
modifying, 690
swapping, 692
viewing, 688

part
exporting, 545
setting z-values and generating faces
in, 486

part browser, 24
Part Browser
description, 459
icons, 460

Partially Determined option, 650
partname
unique, 468

parts
advantages of, 433
automatically generating all faces in,
494
changing ownership by drag and
drop, 461
changing to a symbol, 464
creating, 442
deleting, 438
detail parts, 443
dimensioning between, 263
dimensioning detail, 263
editing, 440
including a dimension, 448

including a part, 448
including an element, 445
initiating, 441
introduction, 430
modifying, 439
naming, 432
Part Browser, 459
part names, 432
renaming, 461
selecting, 83
setting a reference point, 465
sharing parts, 456
showing a part, 452
smashing, 453
spotlighting, 464
the active part, 432
the part structure, 430
the top part, 430
tree, 74, 468
unique partnames, 468
viewing, 462

Parts, 429
parts list, 102-103
parts scaling, Set Ref Point command,
467
Paste, 49
Paste As Subpart, 50
path name
identifying files, 530

pattern
changing the hatch, 376
hatching, 372

Pattern command, 372
PD RIGID info text, 638
PD STATUS info text, 649
pd_auto_angle_tolerance, 698
PD_AUTO_ANGLE_TOLERANCE
function, 765
pd_auto_same_distance_tolerance, 698
PD_AUTO_SAME_DISTANCE_
TOLERANCE function, 765

Index 801



PD_AUTO_SYMMETRY_COLOR
function, 764
PD_AUTO_SYMMETRY_LINE
function, 764
PD_AUTO_SYMMETRY_
LINETYPE function, 764
pd_auto_tangent_tolerance, 698
PD_AUTO_TANGENT_
TOLERANCE function, 765
pd_auto_zero_distance_tolerance, 698
PD_AUTO_ZERO_DISTANCE_
TOLERANCE function, 764
PD_DEFAULT_DIM_COLOR
command, 690, 766
PD_NEW_C_LINE_COLOR function,
766
PD_NEW_C_LINE_LINETYPE
function, 766
PD_NEW_C_LINE_VISIBILITY
function, 715, 766
PD_NEW_POINT_COLOR function,
766
PD_NEW_POINT_LINETYPE
function, 766
PD_NEW_POINT_VISIBILITY
function, 715, 766
PD_PREVIEW_COLOR function,
642, 647, 766
pd_resolve_merge_tolerance, 698
PD_RESOLVE_MERGE_
TOLERANCE function, 765
PD_SHOW_COLOR function, 765
PD_SHOW_LABEL_SIZE function,
765
PD_SHOW_USE_POSTFIX function,
765
PD_ZONE info text, 636, 703
Pen Settings, 97
pen width
changing, 98

Pens map, 97
pensize

selecting, 83
Perpendic constraints, 668
perpendicular
dimensions, 269
lines, 153

Picture, 577
inverting black and white, 582

Picture Browser, 583
picture color
printing, plotting, 620

pictures
deleting, 72
importing, 544

placing
the ruler/grid, 117

plot
fitting, 614

plot transformation map, 616
plotter
selecting, 610

plotting
boxed area, 614
complete drawing, 613
current show attributes, 615
current viewport, 613
drawing, 615
drawings, 606
hidden lines, 502
linetype length, 618
multiple drawing files, 621
picture color, 620
preview a print/plot, 620
Range, 613
scale, 614
scale factor, 614
starting output, 621
to a file, 611
truecolor, 616

Point command, 172, 681
point coordinates
displaying, 111

Point on constraint, 669
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points
creating, 172
showing, 120

Points command, 246, 635
Poly Element command, 172
polygons
drawing, 151

polyline, 172
smashing, 174

port (viewports), 125
position
dimensioning option, 338

positioning
drawing in print or plot, 612
welding symbols, 421

postfix
absolute size, 327
adding, 324
clearing, 326
color, 327
deleting, 325
dimension text, 255
font, 327
predefining, 323
ratio, 327
relative size, 328
saving, 326
slant, 328
special character, 328

prefix
absolute size, 327
adding, 324
adding a new prefix to a dimension,
307
clearing, 326
color, 327
deleting, 325
dimension, 253
font, 327
predefining, 324
ratio, 327
relative size, 328

saving, 326
slant, 328
special character, 328

Prefix function, 307
PreSelected, 87
preset, 106
preview, 102
Preview a Print/Plot, 620
preview colors, 102-103
Preview command, 631, 647
preview viewport, 102
print configuration
creating, 607
example, 608

Print Manager, 607
printer
selecting, 610

printing
boxed area, 614
complete drawing, 613
current show attributes, 615
current viewport, 613
drawing, 615
drawings, 606
linetype length, 618
multiple drawing files, 621
picture color, 620
preview a print/plot, 620
range, 613
scale, 614
scale factor, 614
starting output, 621
to a file, 611
truecolor, 616

printing/plotting
preview a print/plot, 620
settings, 609

profile
symbols, 407

projected reference point
drawing, 203
settings, 203
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prompt line, 24
properties
associated, 131
getting, 132
putting, 132

purging files directories, 553
Put Text command, 398
putting
properties, 132

Q
quick access toolbar, 21

R
radius
creating a fillet, 195
dimensioning, 285
measuring, 109

Radius command, 285
Range, 613
recalling
a window, 124

rectangle
drawing, 155

Redo, 50
redraw mode, 137
redrawing, 123
hidden, 496
normal, 496

Refelem constraint, 671
reference
point for a part, 465

reference line
adding manually, 423
color, 397
creating, 394
destination gap, 398
linetype, 397
offset, 398
selecting, 82
settings, 396

source gap, 398
terminator, 397
width, 397

reference line color
surface symbols, 414

reference lines for symbols
snap angle, 415

Refpoint constraint, 672
Remove command, 638, 686
removing
parameters, 686
zone elements, 638

renaming parts, 461
Repeat command, 207
replication, 708
Reset Show, 501
Reset Show command, 563
restoring
last view, 123

revision
symbols, 409

revision checking
loading files, 561
Reset Show, 563
Set Color, 563
Set Color command (revision
checking), 563
Show Difference, 563
supported MI formats, 559

RGB color, 101
ribbon, 21
rigid bodies, 706, 708
rigid body
clearing, 639
creating, 639
defined, 638
showing, 639

rotate
elements, 212

Rotate command, 212
rotating
about a center, 214
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dimension text, 356
the ruler/grid, 118
using a reference point, 214

rotation
print/plot output, 613

ruler
displaying, 116
moving, 117

ruler/grid
drawing an isometric, 119
hiding, 119
placing, 117
rotating, 118
setting the spacing, 116
using, 115

runout
symbols, 408

S
Samedist constraint, 673
Samesize constraint, 674
Save, 536
Save As, 537
Save command, 632, 652
Save Part, 545
saving drawings
File Browser, 536
in HPGL format, 538
under a different name, 537

saving parameter value tables, 632
scale
factor for plot, 614
multiple drawing, 465
setting, 614

Scale command, 216, 465
Scale Set Ref Point command, 467
scaling
by center, 217
elements, 216
OLE object, 586
using a reference point, 217

scaling parts
center or reference point, 467

Scan
settings, 340

screendump, 621
select
what does it mean?, 52

Select command, 77
Select command combined with
Modify command, 207
Select mechanism, 74
selecting
a viewport, 122
elements for modification, 207
what is displayed, 119

selection
a vertex, 82
boxing elements, 80
confirming, 88
construction geometry, 82
contours, 84
dimensions, 84
drawing elements, 77
drawing geometry, 83
elements within a polygon, 81
general, 74
global, 74
infos, 82
layers, 82
linesize, 83
parts, 83
pensize, 83
reference lines, 82
removing elements, 80
saving, 539
subtracting elements, 80
subtree, 83
text, 82
URLs, 87

selection filtering, 332
color filter, 336
geometry-type filter, 333
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line-slope filter, 334
linesize filter, 335
linetype filter, 335
pensize filter, 335

Set Ref Point command, 465
setting icon color, 762
setting icon size, 762
settings
copilot, 141
saving, 137
text, 388

Share command, 456
shared
parts, 456

shared parts
and z-values, 475

Sheet Browser, 595
short base lines
datum dimensioning, 278

show
functions with layers, 522

Show
functions with layers, 515, 526

Show command, 452, 629, 642, 687
Show Difference command, 563
SHOW function, 119
Show Gaps command, 249
Show Range, 499
showing
a part, 452
all features, 120
constraints, 642
dimensions, 121
parameters, 629, 687
points, 120

similar
elements, 217

Similar command, 217
single
geometry features dimensioning,
266

size

text, 389
Size constraint, 674
sketch input, 700
slant angle
text, 390

Slope constraint, 675
slot
centerlines, 199

Smash Subpart command, 453
smashing
subparts, 453

snapping
using the automatic snap feature,
263

Solve command, 631, 647
Solved option, 649
solving
errors, 648
Keep mode, 631, 647
modes, 631, 647
No Keep mode, 632, 648
Preview mode, 631, 647
solver described, 713
tolerances, 698

source gap
reference line, 398

space
dimension line option, 310
setting the minimum distance
between dimension lines and
geometry features, 312

special character
adding to dimension text extension,
324
entering, 384

special characters
adding, 307

specify
what does it mean?, 52

SPLINE_CONVERSION function,
705
splines, 161
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control points, 161-162
converting, 237
interpolation points, 161-162
open vs closed, 162
order, 223
parametric control, 705-706
splitting, 237

Split command, 244-245
splitting
an element, 244
an element or elements in a box, 245
elements automatically, 244

Spotlight command, 464
spotlighting
a part, 464

Stacked command, 247, 636
Staggered command, 247
standards
copper hatch, 379
dimensioning standards, 265
for hatch patterns, 378
iron hatch, 378
steel hatch, 379

status bar, 23-24
stepping
dimension text automatically, 310

store, 106
storing, 528
a window, 124

strategy
for constraining, 644, 647
for master parts, 652, 654

Strategy
dimensioning option, 338

Stretch command, 220
stretching elements, 220
structure
of parts, 430
parts, 431

subfix
absolute size, 327
adding, 324

clearing, 326
color, 327
deleting, 325
dimension text, 255
font, 327
predefining, 324
ratio, 327
relative size, 328
saving, 326
slant, 328
special character, 328

subpart
merging, 453

Subpart Keep Display option, 454
subtree
selecting, 83

superfix
absolute size, 327
adding, 324
clearing, 326
color, 327
deleting, 325
dimension text, 255
font, 327
predefining, 324
ratio, 327
relative size, 328
saving, 326
slant, 328
special character, 328

surface symbols, 412
color, 414
examples, 416
font size, 414
preconfigured symbols, 415
reference line color, 414
text character slant, 414

switching
infos on and off, 523
layers on & off, 516
URLs on & off, 526

Symbol command, 464
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symbols, 403
alignment, 408
changing a part to a symbol, 464
composite, 406
datum target, 409
deleting, 404
form symbols, 407
geometric tolerancing, 404
location, 407
modifiers, 409
moving, 404
normal, 406
profile, 407
revision, 409
runout, 408
setting size, 404
stretching, 423
surface, 412
symbol text, 409
welding, 412

SymLine command, 201
symmetric
dimensions, 270

Symmetric Long
command, 270

Symmetric Single
command, 270

Symmline constraint, 676
system defaults, 761

T
tab, 21
tangent
constructing, 180

Tangent constraint, 678
tangent constructing, 179
terminator
both, 316
changing dimension line settings,
345
dimension line settings, 315

filling on or off, 317
first, 316
position, 316
reference line, 397
relative size, 317
second, 316
size absolute, 317

text
angle, 389
changing dimension text settings,
345
changing settings, 393
character width-to-height ratio, 390
color, 391
copying properties, 398
deleting, 388
dimension, 253
editing via text box, 386-387
entering, 383
entering directly in the drawing, 383
fill on, 390
font, 391
frame, 392
general, 382
line spacing, 390
modifying dimension, 354
options, 391
origin, 392
parameters, 389
selecting, 82
settings, 388
size, 389
text slant angle, 390

Text Change command, 393
text character slant
surface symbols, 414

text file
loading, 385
storing, 385

text frame
dimension, the different types, 256

text functions
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welding symbols, 422
Text to Geometry command, 394
Text Window command, 376
TIFF file
importing, 544

tolerance
dimension text, 254
geometric tolerance group, 405
limit tolerancing, 254
plus and minus tolerancing, 254
upper and lower tolerancing, 255

tolerances
absolute size, 327
adding, 324
clearing, 326
color, 327
defined, 698
deleting, 325
font, 327
pd_auto_angle_tolerance, 698
pd_auto_same_distance_tolerance,
698
pd_auto_tangent_tolerance, 698
pd_auto_zero_distance_tolerance,
698
pd_resolve_merge_tolerance, 698
predefining, 324
ratio, 327
relative size, 328
saving, 326
slant, 328
special character, 328

toolbar
creating, 771
editing, 773
loading, 769
resetting, 769
saving, 769
support, 767

toolbar item
creating, 773
deleting, 777

editing, 776
toolbar items
customizing, 770

toolbar menu style
selecting, 772

toolbars
customizing, 770
deleting, 773
displaying or hiding, 769
excluding, 769

top part
what is it?, 430

trace
using the dimension trace, 263

Transform command, 218
Trim Extend command, 239
trimming
elements, 239
one element, 239
two elements, 239

Trimming command, 237
truecolor
plotting, 616
printing, 616

TrueType font
importing, 543
resolution, 544

U
UA_DESIGN_INTENT command,
694
UA_GET_DESIGN_INTENT
arithmetic function, 694
underlining
dimensions, 359

Undo, 50
Undo command, 88
UNDO command, 72
undoing
a face, 495
commands, 88
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Unicode, 782
units
angular dimension, 329
dimensioning, 329, 346
linear dimension, 329
setting, 65

Unshare command, 459
unsharing
a part, 459

unsharing parts, 459
Unsolved option, 649
URL
color, 526

URLs
selecting, 87

User command, 681
user input line, 24
user interface, 18

V
value
dimension text, 254
load, 491

values
Z, 473

variation, generating, 628
vertex
selecting a, 82
show, 119

vertical
dimensions, 268
lines, 152
measuring distances, 110

Vertical constraint, 679
Vertical move, 211
vertices
show, 119

view
mode, 475

View Parts command, 462
viewing

a drawing, 121
a part, 462
different z-values, 499

viewport
changing size, 128
creating, 127
deleting, 129
making it current, 127
maximizing, 128
moving, 128
redrawing, 128
selecting, 122
settings, 129

viewports
what are they?, 57

views
isometric, 222

VRML translator, 557

W
weld surface, 422
welding symbols
composing, 420
examples, 425
positioning, 421
preconfigured symbols, 424
reference line, 423
symbol elements, 421
text, 420
text functions, 422
weld setup, 424
weld surface, 422
welds, 422

welds
color, 424
hatch distance, 424
surface, 422

Windchill, 778
window, 121
creating, 124
recalling, 124
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restoring last view, 123
storing, 124
using normal functions, 122
zooming, 124

windows multiple Drafting instances,
540
working methods
advanced, 698
for designer, 626
for draftsperson, 626
summarized, 626

X
XML grammar (SVG) file save, 536

Z
z-value
above, 485
and shared parts, 475
assigning, 484
below, 485
between elements, 486
checking, 488
checking minimum, 489
current, 490
default, 491
deleting, 484
load, 491
maximum in assembly, 489
of a shared part, 490
of an element belonging to a shared
part, 488
same, 486
setting, 481
what is it?, 473

z-values
viewing, 499

zone
implementation, 703
manipulation of, 703, 705
multiple, 704

Zone commands, 633
zones
adding elements to, 637
defined, 633
removing elements, 638
showing contents, 637

zooming
in or out, 124
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