Inspection with Creo Elements/Direct 2D Access
Fluent User Interface
Creo Elements/Direct 2D Access 20.1
Copyright © 2019 PTC Inc. and/or Its Subsidiary Companies. All Rights Reserved.

User and training guides and related documentation from PTC Inc. and its subsidiary companies (collectively "PTC") are subject to the copyright laws of the United States and other countries and are provided under a license agreement that restricts copying, disclosure, and use of such documentation. PTC hereby grants to the licensed software user the right to make copies in printed form of this documentation if provided on software media, but only for internal/personal use and in accordance with the license agreement under which the applicable software is licensed. Any copy made shall include the PTC copyright notice and any other proprietary notice provided by PTC. Training materials may not be copied without the express written consent of PTC. This documentation may not be disclosed, transferred, modified, or reduced to any form, including electronic media, or transmitted or made publicly available by any means without the prior written consent of PTC and no authorization is granted to make copies for such purposes. Information described herein is furnished for general information only, is subject to change without notice, and should not be construed as a warranty or commitment by PTC. PTC assumes no responsibility or liability for any errors or inaccuracies that may appear in this document.

The software described in this document is provided under written license agreement, contains valuable trade secrets and proprietary information, and is protected by the copyright laws of the United States and other countries. It may not be copied or distributed in any form or medium, disclosed to third parties, or used in any manner not provided for in the software licenses agreement except with written prior approval from PTC. UNAUTHORIZED USE OF SOFTWARE OR ITS DOCUMENTATION CAN RESULT IN CIVIL DAMAGES AND CRIMINAL PROSECUTION.

PTC regards software piracy as the crime it is, and we view offenders accordingly. We do not tolerate the piracy of PTC software products, and we pursue (both civilly and criminally) those who do so using all legal means available, including public and private surveillance resources. As part of these efforts, PTC uses data monitoring and scouring technologies to obtain and transmit data on users of illegal copies of our software. This data collection is not performed on users of legally licensed software from PTC and its authorized distributors. If you are using an illegal copy of our software and do not consent to the collection and transmission of such data (including to the United States), cease using the illegal version, and contact PTC to obtain a legally licensed copy.

Important Copyright, Trademark, Patent, and Licensing Information: See the About Box, or copyright notice, of your PTC software.

UNITED STATES GOVERNMENT RIGHTS

PTC software products and software documentation are “commercial items” as that term is defined at 48 C.F.R. 2.101. Pursuant to Federal Acquisition Regulation (FAR) 12.212 (a)-(b) (Computer Software) (MAY 2014) for civilian agencies or the Defense Federal Acquisition Regulation Supplement (DFARS) at 227.7202-1(a) (Policy) and 227.7202-3 (a) (Rights in commercial computer software or commercial computer software documentation) (FEB 2014) for the Department of Defense, PTC software products and software documentation are provided to the U.S. Government under the PTC commercial license agreement. Use, duplication or disclosure by the U.S. Government is subject solely to the terms and conditions set forth in the applicable PTC software license agreement.

PTC Inc., 140 Kendrick Street, Needham, MA 02494 USA
## Contents

Preface ........................................................................................................................................... 6

The 2D Access User Interface ............................................................................................................... 7

Customizing the Creo Elements/Direct 2D Access Ribbon ................................................................. 12
  Creating a User-Defined Command ................................................................................................. 14
  Modifying a User-Defined Command .............................................................................................. 15
  Adding a Button (Command) to the Ribbon .................................................................................... 16
  Removing a Tab, Group, or Button from the Ribbon ..................................................................... 16
  Adding a Tab .................................................................................................................................... 17
  Adding a Group ............................................................................................................................... 18
  Adding an Element to the Ribbon .................................................................................................. 19
  Renaming a Tab, Group, or Button .................................................................................................. 20
  Hiding or Showing a Tab or a Group ............................................................................................... 20
  Modifying the Button Style ............................................................................................................ 21
  Changing the Order of a Tab, Group, or Button ............................................................................ 22
  Exporting and Re-using a User-Defined Tab ................................................................................... 23
  Exporting Ribbon Customization Settings ..................................................................................... 25
  Importing Ribbon Customization Settings ...................................................................................... 26
  Restoring the Default Ribbon Settings .......................................................................................... 26

Getting Started with Creo Elements/Direct 2D Access ................................................................... 28
  About Creo Elements/Direct 2D Access ......................................................................................... 29
  Starting Creo Elements/Direct 2D Access ....................................................................................... 29
  Switching Languages ....................................................................................................................... 29
  Switching the Bleeper On or Off ..................................................................................................... 30
  Basic Working Methods ................................................................................................................. 30
  Exiting Creo Elements/Direct 2D Access ......................................................................................... 38
  Customizing Creo Elements/Direct 2D Access ............................................................................. 38

Finding, Loading, and Handling Files .................................................................................................. 39
  Using the File Browser .................................................................................................................... 40
  Creating a New Creo Elements/Direct 2D Access Instance ............................................................ 43
  Importing Macros, Fonts and HPGL Files .................................................................................... 43
  Exporting Macro, Pictures, and Images ............................................................................................ 47

Viewing Drawings in Creo Elements/Direct 2D Access ..................................................................... 50
  Using View Functions ..................................................................................................................... 51
  Using Viewports to Display Several Views .................................................................................. 53
  Selecting What is Displayed on Your Screen ................................................................................... 58

Measuring in Creo Elements/Direct 2D Access ................................................................................ 62
  Changing the Catch Mode ............................................................................................................... 63
Measuring Distances ........................................................................................................63
Setting the Units of Measurement .................................................................................68
Using the Calculator........................................................................................................69
Using the Ruler or Grid.....................................................................................................69
Parts ...................................................................................................................................74
Parts Structure ................................................................................................................75
Viewing Parts ...................................................................................................................76
Showing Unselected Parts as Boxes .................................................................................77
Part Browser ....................................................................................................................78
Spotlighting Parts ..............................................................................................................80
Viewing Hidden Lines ......................................................................................................81
Introduction to Hidden Lines ..........................................................................................82
Checking Z-Values ..........................................................................................................83
Generating Hidden Lines ...............................................................................................85
Showing Hidden Lines On or Off ....................................................................................85
Showing Hidden Lines as Dashed Lines .........................................................................85
Plotting Hidden Lines .....................................................................................................86
Using Construction Geometry .........................................................................................87
Drawing Construction Lines ...........................................................................................88
Drawing Construction Circles ........................................................................................92
Revision Checking ............................................................................................................96
Using Revision Checking ...............................................................................................97
Using URLs with Creo Elements/Direct 2D Access ......................................................100
Listing URLs ..................................................................................................................101
Highlighting the Element or Part to which a Given URL is Attached .........................101
Accessing a URL ...............................................................................................................101
Using URL Elem. in Show Dialog Box .........................................................................102
Switching URLs On & Off .............................................................................................102
Assigning a Color to a URL ............................................................................................102
Further Information .........................................................................................................103
Linking and Embedding OLE Objects ..........................................................................104
Inserting an OLE Object .................................................................................................105
Editing an OLE Object in Creo Elements/Direct 2D Access ......................................106
Using the OLE Browser .................................................................................................107
Printing and Plotting ......................................................................................................109
Using the Print Manager ...............................................................................................110
Creating a Print Configuration .........................................................................................110
Defining the Print or Plot Settings ...............................................................................113
Previewing a Print or Plot .............................................................................................123
Starting a Print or Plot Job ............................................................................................124
Printing or Plotting Multiple Drawing Files .................................................................124
Dumping the Creo Elements/Direct 2D Access Screen ..............................................124
Further Information .......................................................................................................124
Toolbar and Classical Menu Support .............................................................................126
Displaying and Hiding Toolbars ................................................................. 128
Excluding Toolbars ................................................................................... 128
Customizing Toolbars and Toolbar Items .................................................... 128

Appendix A. Customizing Creo Elements/Direct 2D Access ...................... 136
   Customizing the Creo Elements/Direct 2D Access Environment .............. 137
   Customizing the Keyboard ........................................................................ 138
   Loading and Listing Text Fonts ................................................................. 139
   Customizing the Startup File ..................................................................... 141
   Creo Elements/Direct 2D Access Keywords ............................................ 142

Index ............................................................................................................. 144
Creo Elements/Direct 2D Access is a screen-only View and Plot facility for integration within an existing CAD system. The Creo Elements/Direct 2D Access software allows you to easily access any Creo Elements/Direct Drafting format 2D drawing.
The 2D Access User Interface

With Creo Elements/Direct 18.0, a Fluent user interface has been introduced for 2D Access. The Fluent user interface facilitates faster access to commands by grouping the commands according to their functionality.

The Creo Elements/Direct 2D Access consists of the following elements:

- File Tab on page 8
- Quick Access Toolbar on page 9
- Ribbon on page 9
- Status Bar on page 10
- Drawing Area on page 11
- Part Browser on page 11
- Context Menu on page 11
- Command Line on page 11
Figure 1: The 2D Access User Interface

You can middle-click to perform the following operations:

- Middle-click to end a command.
- Middle-click and rotate to zoom.
- Middle-click and drag to pan.

File Tab

The **File** button in the upper-left corner of the Creo Elements/Direct 2D Access window opens the **File** menu. The **File** menu contains the following commands:

- **New Session**: Opens a new window.
- **Open**: Opens a drawing from the file system.
• **Print**: Prints or plots a drawing. For more information, see Printing and Plotting on page 109.

• **Import/Export**: Imports or exports files. For more information, see Finding, Loading, and Handling Files on page 39.

• **Settings**: Changes the draw and system settings. For more information, see Viewing Drawings in Creo Elements/Direct 2D Access on page 50 and Measuring in Creo Elements/Direct 2D Access on page 62.

**Quick Access Toolbar**

The Quick Access toolbar is by default at the top of the Creo Elements/Direct 2D Access window. It provides quick access to frequently-used commands. You can customize the Quick Access toolbar by adding commands (buttons and menus) to it.

**Ribbon**

The ribbon contains commands organized as a set of tabs. On each tab, related commands are grouped. The following figure shows the different elements of a ribbon:

**Figure 1A: Ribbon**

1. **Tab**: The available tabs are:
   • **2D Access**
   • **Compare**
   • **View**

2. **Group**: Commands are placed within groups according to their functionality.

3. **Button**: Each button on the ribbon consists of an icon and a label. Some buttons also contain an arrow along with an icon and label.
   
   The ribbon has the following types of buttons:
• or (Large or small button with an icon and a label): Click this button to execute an operation.

• or (Large or small button with an icon and an arrow not separated by a line): An arrow indicates the existence of a list. Click this button to open a list of related commands. When no line separates a button, the icon and arrow perform the same action.

• or (Large or small button with an icon and an arrow separated by a line): A line, or separation, between the icon and arrow indicates that the icon and arrow perform different actions. Click the icon on this button to execute an operation. Click the arrow to open a list of related commands. The icon of the last-selected command in the current session is displayed on the button.

Note
○ The label remains unchanged irrespective of the last selection.
○ The tooltip displays the name of the command that the icon represents.
○ The procedural topics assume that the icon of the default command in a list is displayed on a button though you may see the icon of your last-selected command.

Status Bar
The status bar is at the bottom of the 2D Access window and has the following commands:
• : Confirms a command or selection.
• : Ends the current command.
• : Cancels the current command.
• : Highlights the active part in the graphics area.
• Switches the full screen mode on and off (alternatively, you can press F11).
• Defines a new viewing window.
• Displays the last view.
• Fits the content into the viewport.

The status bar also displays the coordinates at which the cursor is placed in the drawing area, the name of the current part and the catch range. For more information on catch, see Changing the Catch Mode on page 63.

Drawing Area
The drawing is displayed in the drawing area. The drawing area is in between the ribbon and the status bar.

Part Browser
The part browser displays the assembly structure with the parts and subparts, the unique ID, part-sharing information, scale, and symbol for the part or the subpart. Press F12 to hide or show the part browser.

Context Menu
The context menu opens when you right-click in the drawing area. The context menu displays commands from the Viewing group on the View tab.

Prompt Line
The Prompt Line tells you how to proceed to complete the current operation. In the absence of the Prompt Line, Creo Elements/Direct 2D Access displays the prompt in the status bar.

You can enable or disable Prompt Line by clicking or clearing the Prompt Line check box under Toolbars in the Viewing group on the View tab, respectively.

Command Line
In the Command Line (user input line) you can type the required values, when prompted.

You can enable or disable Command Line by clicking or clearing the Command Line check box under Toolbars in the Viewing group on the View tab, respectively.
Customizing the Creo Elements/Direct 2D Access Ribbon

Creating a User-Defined Command .......................................................... 14
Modifying a User-Defined Command ....................................................... 15
Adding a Button (Command) to the Ribbon ............................................. 16
Removing a Tab, Group, or Button from the Ribbon ............................... 16
Adding a Tab ......................................................................................... 17
Adding a Group .................................................................................... 18
Adding an Element to the Ribbon .......................................................... 19
Renaming a Tab, Group, or Button .......................................................... 20
Hiding or Showing a Tab or a Group ....................................................... 20
Modifying the Button Style ................................................................... 21
Changing the Order of a Tab, Group, or Button ....................................... 22
Exporting and Re-using a User-Defined Tab ........................................... 23
Exporting Ribbon Customization Settings .............................................. 25
Importing Ribbon Customization Settings .............................................. 26
Restoring the Default Ribbon Settings ................................................... 26

You can customize the Creo Elements/Direct 2D Access ribbon to quickly access frequently-used commands.

You can customize the ribbon by:

• Creating a User-Defined Command on page 14
• Modifying a User-Defined Command on page 15
• Adding a Button (Command) to the Ribbon on page 16
• Removing a Tab, Group, or Button from the Ribbon on page 16
• Adding a Tab on page 17
• Adding a Group on page 18
You can customize the ribbon using the **Options** dialog box. 

To open the **Options** dialog box:

- Click **File ▶ Options**.
  
  Alternatively, right-click the ribbon and select **Customize Quick Access Toolbar**.

  The **Options** dialog box opens. The **Customize Ribbon** pane is selected by default.

To apply and view the customized settings, click **OK** in the **Options** dialog box.

To cancel the modified settings, click **Cancel** in the **Options** dialog box.
Creating a User-Defined Command

You can create your commands and add them to the Creo Elements/Direct 2D Access ribbon.

To create a command:

1. Click File ▶ Options.

   The Options dialog box opens. The Customize Ribbon pane is selected by default.

2. Click New.

   The Create New Command dialog box opens.

3. In the Command ID area, type a name for the command in the Name box.

   Note
   Creo Elements/Direct 2D Access displays the specified name as the label for the button on the ribbon.

4. Optionally, type a tooltip for the command (button) in the Tool Tip box.

5. Optionally, type a category for the command in the Category box.

   The default category is View.

   If you type a new category name, a category is created with the specified name, and the command is added to the category.

6. Optionally, in the Icon area, click Browse to select an image for the button.

   Note
   • Creo Elements/Direct 2D Access supports PNG and BMP images for buttons.
   • Creo Elements/Direct 2D Access partially supports JPG and JPEG images for buttons. Creo Elements/Direct 2D Access converts these images to BMP images internally.

7. In the Command Action box, provide the action (function) details.

Note
Creo Elements/Direct 2D Access executes the specified function when you click the button.

8. Click **Add**.
   The command is now available in the **View** list of the **Choose commands from** box.

Note
You must provide at least a name and an action to create a command.

Modifying a User-Defined Command
You can modify the user-defined commands in Creo Elements/Direct 2D Access.
To modify a user-defined command:
1. Click **File ▶ Options**.
   The **Options** dialog box opens. The **Customize Ribbon** pane is selected by default.
2. In the **Choose commands from** box, select **User-Defined**.
   The user-defined commands are listed.
3. Select the command.
4. Click **Modify**.
   The **Create New Command** dialog box opens.

Note
**Modify** is activated only after you select a user-defined command.

5. Edit the settings.
6. Click **Modify** to save the edited settings.
If you want to delete the user-defined command, click **Delete** in the **Create New Command** dialog box.
Adding a Button (Command) to the Ribbon

You can add the default Creo Elements/Direct 2D Access buttons as well as user-defined buttons to the Creo Elements/Direct 2D Access ribbon.

To add a button to the ribbon:

1. Click **File ▶ Options**.
   The **Options** dialog box opens. The **Customize Ribbon** pane is selected by default.
2. In the **Customize the Ribbon** list, select the group to which you want to add a button.
3. In the **Choose commands from** box, select the tab name.
   The commands on the selected tab are listed.

   **Tip**
   To view the list of user-defined commands, select **User-Defined**.

4. Select a command and click **Add**.
   The button for the selected command is added to the group on the ribbon.

   **Note**
   - You can add buttons to user-defined groups only.
   - You cannot add buttons directly to a tab.

Removing a Tab, Group, or Button from the Ribbon

To remove a tab, group, or a button from the ribbon:

1. Click **File ▶ Options**.
   The **Options** dialog box opens. The **Customize Ribbon** pane is selected by default.
2. In the **Customize the Ribbon** list, select the tab, group, or button (command).
3. Click **Remove**.
The selected tab, group, or button is removed from the ribbon.

⚠️ Note
- You can remove the user-defined tabs and groups only.
- You cannot remove buttons of the default groups.

💡 Tip
You can also use the context menu to remove tabs, groups, or buttons.

Adding a Tab
You can add a tab to the Creo Elements/Direct 2D Access ribbon.

To add a tab:
1. Click File ▶ Options.
   The Options dialog box opens. The Customize Ribbon pane is selected by default.
2. In the Customize the Ribbon list, select a tab below which your tab should be added.
   The selected tab is highlighted.

⚠️ Note
- If you do not select a tab, your tab is added at the end of all tabs.
- If an item is already selected, your tab is added below the parent tab of the selected item.

3. Click New Tab.
   A tab is added below the selected tab. In addition, a group is automatically added to the tab.
4. Select the tab, click Rename, and specify a name for the tab.
Adding a Group
You can add a group to the Creo Elements/Direct 2D Access ribbon.

To add a group:
1. Click File ▶ Options.
   The Options dialog box opens. The Customize Ribbon pane is selected by default.
2. In the Customize the Ribbon list, select a tab or group.
   Ensure that you select a tab or group below which you need to add the group.
   The selected tab or group is highlighted.
3. Click New Group.
   A group is added below the selected tab or group.
4. Click Rename and specify a name for the group.

Note
If you do not select a tab or group, your group is added at the end of all groups of the first tab.

Tip
You can add groups to user-defined tabs only.

Tip
You can also use the context menu to add a new group.
Adding an Element to the Ribbon

You can add the following elements to the user-defined groups in the Creo Elements/Direct 2D Access ribbon:

- A button with an arrow not separated by a line (Menu)
- A button with an icon and an arrow, and separated by a line (Split Menu)
- A separator

For details about different types of buttons, see Ribbon on page 9.

Note

You can also add the default buttons similar to the buttons (created by using Menu or Split Menu) in the user-defined groups.

To add a new element:

1. Click File ▶ Options.

   The Options dialog box opens. The Customize Ribbon pane is selected by default.

2. In the Customize the Ribbon list, select a group to which you want to add a new element.

3. Click New Element.

4. Select one of the following:

   - Menu to add a button with an arrow not separated by a line.
     
     For example, ![View Arrow](image)
     
     The button is added at the end of the selected group.

   - Split Menu to add a button with an icon and an arrow separated by a line.
     
     For example, ![Check Box](image)
     
     For details about different types of buttons, see Ribbon on page 9.
     
     The button is added at the end of the selected group.

   - Separator to add a separator.
     
     A separator is added below the selected group.
Note
You can also add a separator between two buttons.

5. Click **Rename** and specify a name for the button (created by using **Menu** or **Split Menu**).

6. To add a command (button) to the button (created by using **Menu** or **Split Menu**), see Adding a Button (Command) to the Ribbon on page 16.

## Renaming a Tab, Group, or Button

To rename a tab, group, or button:

1. Click **File ▶ Options**.

   The **Options** dialog box opens. The **Customize Ribbon** pane is selected by default.

2. In the **Customize the Ribbon** list, click the tab, group, or button.

   The selected item is highlighted.

3. Click **Rename** and specify a name for the tab, group, or button.

   The new name is displayed in the **Customize the Ribbon** list and on the ribbon after you click **OK**.

Note
You can rename user-defined tabs and groups only.

Tip
You can also use the context menu for renaming elements on the ribbon.

## Hiding or Showing a Tab or a Group

You can select the tabs or groups that you want to hide or view on the ribbon.

To hide or show a tab or a group:

1. Click **File ▶ Options**.
The **Options** dialog box opens. The **Customize Ribbon** pane is selected by default.

2. In the **Customize the Ribbon** list, clear or click the check box of the tab or group to hide or show the tab or group, respectively.

### Modifying the Button Style

You can modify the appearance of a button on the ribbon.

To modify the appearance of a button:

1. Click **File ▶ Options**.

   The **Options** dialog box opens. The **Customize Ribbon** pane is selected by default.

2. In the **Customize the Ribbon** list, select a button.

   The **Modify** button is activated.

   **Tip**

   To select multiple buttons in the **Customize the Ribbon** list:
   
   • Press SHIFT+[button] for range selection of buttons. Buttons that are within a group are selected only if the group buttons are expanded.
   
   • Press CTRL+[button] for individual selection of buttons.

3. Click **Modify**.

   The **Modify Button** dialog box opens.

4. In the **Icon** area, click **Browse** to replace the current icon with a different icon.

   **Note**

   • Creo Elements/Direct 2D Access supports PNG, and BMP images for icons.
   
   • Creo Elements/Direct 2D Access partially supports JPG and JPEG images for icons. Creo Elements/Direct 2D Access converts these images to BMP images internally.

   To reset the icon, click **Reset**.
Note
You can change or reset the icon of the following:

- A user-defined button created by using **Menu**.
- A default button with an icon and an arrow, and not separated by a line.

5. In the **Button Layout** area, select one of the following:
   - **Small** to display the button as a small button.
   - **Small - No Icon** to display the button as a small button without the icon.
   - **Large** to display the button as a large button.

6. Optionally, click or clear the **Hide** check box to hide or display the label of the button, respectively, on the ribbon.

### Changing the Order of a Tab, Group, or Button

You can change the order of a tab, group, or button on the ribbon in Creo Elements/Direct 2D Access.

To change the order of a tab, group, or button:

1. Click **File ▶ Options**.
   
The **Options** dialog box opens. The **Customize Ribbon** pane is selected by default.

2. In the **Customize the Ribbon** list, select the button, group, or tab.

3. Click ▲ to move up or ▼ to move down.

Tip
You can also use the context menu to change the order of a tab, group, or button on the ribbon.
Exporting and Re-using a User-Defined Tab

You can export a user-defined tab and import it to a module. You can export a single user-defined tab at a time. You can also import a single user-defined tab or multiple user-defined tabs to a module at a time.

To export a user-defined tab:

1. Click File ▶ Options.
   The Options dialog box opens. The Customize Ribbon pane opens by default.
2. In the Customize the Ribbon list, select the user-defined tab.
3. Right-click and select Export Tab.
   The user-defined tab is exported as an XML file to the Modules subdirectory of the installation directory. The XML file carries the name of the user-defined tab and contains information about the commands or buttons on the user-defined tab.

   **Note**
   The Modules subdirectory of the installation directory is the default directory in which Creo Elements/Direct 2D Access saves the exported XML file. To change the default directory, use the ME_SET_MODULE_SEARCH_PATH command in the user input line. See ME_SET_MODULE_SEARCH_PATH in the Creo Elements/Direct Drafting / Creo Elements/Direct 2D Access Programming Reference Guide for details.

To import a single user-defined tab or multiple user-defined tabs to a module, use the REGISTER_MODULE command in the user input line to import the XML file in the Creo Elements/Direct 2D Access user interface. See REGISTER_MODULE in the Creo Elements/Direct Drafting / Creo Elements/Direct 2D Access Programming Reference Guide for details.

To start or stop the module:

1. Click File ▶ Modules.
2. Select the module.

   **Note**
   The modules (consisting of user-defined tabs) are removed when you exit Creo Elements/Direct 2D Access.
**Tip**

You can create macro files to perform activities like licensing-related tasks, if required, when you start or stop the module.

- You can create a macro file in the **Modules** subdirectory (default) or in the path specified using the **ME_SET_MODULE_SEARCH_PATH** command and the file name must be identical to the name of the user-defined module. For example, you can create a macro file `IBS.m` for the user-defined module `IBS` and include the load-specific macros in the file. Creo Elements/Direct 2D Access uses this macro file during the start of the module. Ensure that you have included the commands required to activate the buttons on the imported tabs in the macro file. You can also add licensing-related commands to the macro file.

- When you stop a user-defined module, Creo Elements/Direct 2D Access removes the tab of the corresponding module. You can create a macro file in the **Modules** subdirectory (default) or in the path specified using the **ME_SET_MODULE_SEARCH_PATH** command and the file name must be identical to the name of the user-defined module appended by `_unload`. For example, you can create a macro file `IBS_unload.m` for the user-defined module `IBS` and include the unload-specific macros in the file. You can add commands to release any licenses acquired for the module or perform the desired cleanup actions using this macro file.

To import a user-defined tab to the Creo Elements/Direct 2D Access ribbon, use the **IMPORT_TAB** command in the user input line and import the XML file. See **IMPORT_TAB** and **ME_SET_MODULE_SEARCH_PATH** in the Creo Elements/ Direct Drafting / Creo Elements/Direct 2D Access Programming Reference Guide for details.
Note

- You can specify the name of an existing tab for an imported tab. Importing a tab with a name similar to an existing tab does not affect the existing tab. Consequently Creo Elements/Direct 2D Access adds another tab with a similar name in the Creo Elements/Direct 2D Access ribbon.
- The import of user-defined tabs is independent to the registration of user-defined modules.
- The imported tabs are removed when you exit Creo Elements/Direct 2D Access. Consequently, they are unavailable when you start Creo Elements/Direct 2D Access next time.

You can modify (add elements to, move the elements, and so on) the imported user-defined tab or module by starting Creo Elements/Direct 2D Access with the moduleadmin option:

1. Click Start ▶ All Programs ▶ PTC ▶ Creo Elements Direct 2D Access [version].
2. Right-click Creo Elements Direct 2D Access [version].
4. In the Target box, append –moduleadmin at the end of the existing string.
5. Click OK.

Note

- If you start Creo Elements/Direct 2D Access without using –moduleadmin, the user-defined tabs are considered as system tabs and you cannot modify them.
- The imported tabs are available in the Creo Elements/Direct 2D Access ribbon even after you use Reset in the Options dialog box to restore default ribbon settings.

Exporting Ribbon Customization Settings

You can export the existing customization settings of the Creo Elements/Direct 2D Access ribbon to a XML file. The same customization settings can be used on other computers by importing the XML file in Creo Elements/Direct 2D Access. To export the ribbon customization settings:
1. Click File ▶ Options.
   
   The Options dialog box opens. The Customize Ribbon pane is selected by default.

2. Click Import/Export.

3. Click Export Customization.
   
   The Choose exported Creo UI file dialog box opens.

4. Specify the path and the file name for the XML file.

Importing Ribbon Customization Settings

You can import the XML file generated by Export Customization to replace the existing ribbon customization settings.

To import the ribbon customization settings:

1. Click File ▶ Options.
   
   The Options dialog box opens. The Customize Ribbon pane is selected by default.

2. Click Import/Export.

3. Click Import Customization.
   
   The Choose exported Creo UI file dialog box opens.

4. Select the XML file.

Note

The imported ribbon customization settings override the existing ribbon customization settings. It is recommended to export the existing ribbon customization settings before using Import Customization. You can then use the exported file to revert to the existing ribbon customization settings, if required.

Restoring the Default Ribbon Settings

You can reject the changes that you have made for customizing the ribbon. The default ribbon settings are restored after rejecting the ribbon customization changes.

To restore the default ribbon settings:

1. Click File ▶ Options.
The **Options** dialog box opens. The **Customize Ribbon** pane is selected by default.

2. Click **Reset**.
Getting Started with Creo Elements/Direct 2D Access

About Creo Elements/Direct 2D Access .........................................................29
Starting Creo Elements/Direct 2D Access ...................................................29
Switching Languages ..................................................................................29
Switching the Beeper On or Off .................................................................30
Basic Working Methods .............................................................................30
Exiting Creo Elements/Direct 2D Access ..................................................38
Customizing Creo Elements/Direct 2D Access ...........................................38
About Creo Elements/Direct 2D Access

Creo Elements/Direct 2D Access provides a full set of commands for viewing, measuring, and plotting any MI format drawings created in the Creo Elements/Direct Drafting 2D CAD system. In Creo Elements/Direct 2D Access, you cannot damage or alter such drawings in any way.

The functionality of Creo Elements/Direct 2D Access is a subset of the Creo Elements/Direct Drafting functionality. For further details and illustrated examples of this functionality, refer to the Creo Elements/Direct Drafting User's Guide: Fluent User Interface in the Creo Elements/Direct Drafting Help Center.

Starting Creo Elements/Direct 2D Access

To start Creo Elements/Direct 2D Access with the standard Fluent UI:

- Click Start ▶ All Programs ▶ PTC ▶ Creo Elements Direct 2D Access [version] ▶ Creo Elements Direct 2D Access [version].

To start Creo Elements/Direct 2D Access with alternative UI:

- Classic UI

- Windows UI

Switching Languages

By default, the Creo Elements/Direct 2D Access user interface is displayed in English. To switch to the language of your choice, type the appropriate command in the user input line and press ENTER:

<table>
<thead>
<tr>
<th>Language</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>English</td>
<td>change_locale 'en'</td>
</tr>
<tr>
<td>French</td>
<td>change_locale 'fr'</td>
</tr>
<tr>
<td>German</td>
<td>change_locale 'de'</td>
</tr>
<tr>
<td>Italian</td>
<td>change_locale 'it'</td>
</tr>
<tr>
<td>Spanish</td>
<td>change_locale 'es'</td>
</tr>
<tr>
<td>Japanese</td>
<td>change_locale 'ja'</td>
</tr>
</tbody>
</table>
Alternatively, specify this command above the `Startup_menus` string in the `startup.m` file contained in the Creo Elements/Direct 2D Access installation directory.

---

**Note**

If you installed Creo Elements/Direct 2D Access in Custom mode, any languages that you did not select during installation will not be available at Creo Elements/Direct 2D Access runtime.

---

**Switching the Beeper On or Off**

Optionally, you can enable or disable the "beeper" in Creo Elements/Direct 2D Access. Simply type `BEEPER ON` or `BEEPER OFF` in the user input line and press ENTER.

---

**Basic Working Methods**

You can quickly and easily delete elements or entire classes of elements from your drawing for visual clarity. The `Select` buttons help you to select or unselect given classes of elements.

---

**Deleting Elements**

Click `Delete` to delete drawing elements or pieces of text.

For example, to delete everything in the active part:

1. Click `Delete`.
2. Click `2D Access` and then, in the `Utilities` group, click `Select ▶▶ All`.
3. Click `Confirm`.

---

**Highlighting Elements Before Deletion**

The `Select` buttons enable you to select the elements that you want to delete (or modify).

1. Click `Delete`.
2. Click **2D Access** and then in the **Utilities** group, click **Select** and then click the required button.

   Depending upon the selected button, the elements selected for delete are highlighted. For example, click **Select** and then click **All**. All the elements in the drawing get highlighted.

   Alternatively, press F2 to open the **Select** window. Then click **Select** and **All**. All the elements in the drawing get highlighted.

3. When you are satisfied that the elements to be deleted have been correctly selected, click **Confirm**.

### Global Selection

Each time you select components, you can decide whether you want to select from the current part or from the whole parts tree. Global selection allows you to select components from the whole parts tree:

- In the **Select** window, click **Select**, **Global**, and **All**.

  If you do not click **Global**, Creo Elements/Direct 2D Access defaults to the current part.

### Example

1. Click **2D Access** and then, in the **Utilities** group, click **Delete**.

2. In the **Utilities** group, click **Select** ▶ **Advanced**.

   The **Select** window opens.

   Alternatively, press F2 to open the **Select** window.

3. Click **Select**, **Global**, **All**, **Confirm** and **OK**.

   This command string deletes all components of the parts tree even if the active part is not the top part.

   It should, however, be noted that even though all components (geometry, construction geometry, and text) contained within the parts tree will be deleted, it is not possible to delete the complete parts tree. The current part is never deleted and a path linkage to the top part is always maintained.
Selecting Drawing Elements

Click **Select** to let Creo Elements/Direct 2D Access know you are about to make a selection. Then press any option or combination of options from the selection block.

All options on the selection block can be chosen directly without clicking **Select**. However, if you do not click **Select** first:

- The elements you choose will not be highlighted on the screen for you to view before the operation of your choice. For example, deleting will be performed immediately.
- You will not be able to use the options **Add**, **Subtract**, **Not**, and so forth.

**Note**

If you want to select elements drawn in a particular color or linetype, you must first click **Select** and then specify the respective color or linetype.

Example

1. Click **2D Access** and then, in the **Utilities** group, click **Delete**.
2. In the **Utilities** group, click **Select** ▶▶ **Advanced**.
   
   The **Select** window opens.
   
   Alternatively, press F2 to open the **Select** window.
3. Click **Select** and then click **Color**.
   
   The **Color** dialog box opens.
4. In the **Color** box, select **Green** and then click **OK**.
5. Click **Confirm** and then click **OK**.

This deletes all elements drawn in green in the current part.

Adding Elements to Your Selection

This option allows you to add elements, either selected individually or enclosed in a box, to your current selection. For example:

1. Click **Delete**.
2. Press F2 to open the **Select** window.
3. Click **Select**.
4. Select several elements to be deleted.
5. Click Add.
6. Click Box.
7. Enclose further elements to be deleted in a box.
8. Click Confirm.
9. Click OK.

Subtracting Elements from Your Selection
To subtract elements from your current selection, click Subtract in the Select window.

Removing Elements from Your Selection
Click Not in the Select window to make the previous selection result unselected, and all previously unselected elements to be treated as selected.

Note
Not always works globally on all parts.

Enclosing Elements in a Box
To select a group of drawing elements by enclosing them in a box:
1. Click Box in the Select window.
2. Enclose the required elements in a box.
   The elements are shown in a different linetype and Creo Elements/Direct 2D Access prompts you to confirm that you want to delete them. Before you click Confirm, you may want to alter your selection by, for example, subtracting or adding some elements.
3. Click Confirm.
4. Click OK.

Enclosing Elements with a Polyline
If you need greater flexibility when selecting elements, use Polygon to enclose elements within a polyline. This is particularly useful when elements are not symmetrically grouped horizontally and vertically.
Figure 2. Selecting Elements with Polyline

Suppose you want to delete the elements 1, 2, and 3:

1. Click Delete.
2. Click 2D Access and then, in the Utilities group, click Select ▶▶ Polygon.
   Alternatively, press F2 to open the Select window and then click Poly.
3. Click a succession of points to define the enclosing polygon around elements 1, 2, and 3.
4. Close the polygon by clicking the start point again or type CLOSE in the user input line and press ENTER.

Selecting All Elements
To select everything contained in the current part (and subparts):

1. Click Delete.
2. Press F2 to open the Select window.
3. Click All.
4. Click OK.
   Creo Elements/Direct 2D Access prompts you to click Confirm if you really want to delete all elements selected. If not, click Cancel and select again.
5. Click Confirm.
6. Click OK.

Selecting a Vertex
Click Vertex in the Select window if you want to delete all elements that share a specified point.
Selecting Elements by Type
The Select window facilitates the selection of specific element types in your Creo Elements/Direct Drafting drawing.

Selecting Elements Using Information Strings
Click Info in the Select window to select all elements that have a particular information string associated with them. You are prompted to type the information concerned.

Selecting Layers
Click Layer in the Select window to select all elements assigned to a specified layer. When you choose this option, Creo Elements/Direct 2D Access prompts you for the layer information.

Selecting Text
Click Text in the Select window to select the required text. Creo Elements/Direct 2D Access prompts you to identify the text to be selected.

Selecting Reference Lines
Click Ref Line in the Select window to select reference lines.

Selecting Construction Geometry
Click CGeo in the Select window to select and highlight construction geometry. Alternatively, click CCircle to select construction circles only or click CLine to select construction lines only.

Selecting Drawing Geometry
Click Geo in the Select window to select and highlight drawing geometry. Alternatively, you can:
• Click Line to select lines.
• Click Circle to select circles.
• Click Arc to select arcs.
• Click Spline to select splines.
• Click Fillet to select fillets.
• Click Point to select points.
• Click Poly EI to select polyline elements.
To make a selection on pensize or linesize
1. Click Line Size or Pen Size in the Select window.
2. Type a value (for example, 2).
3. Click Confirm.
4. Click OK.

Selecting Parts
Click Part in the Select window to select elements in a particular part. Also, you can click Subtree to select a subtree of a part or assembly.

Example
To delete a selected part from anywhere in the parts tree:
1. Click Delete.
2. Press F2 to open the Select window.
3. Click Select, Global, Part, and OK.
4. Type the part name in the user input line and press ENTER.
5. Click Confirm.
6. Click OK.

Note
When deleting a part, you automatically delete all associated subparts.

Selecting Dimensions
Click Dim in the Select window to select and highlight dimensions. Alternatively, click Edit Dim in the Select window to select edited dimensions only.

Selecting URLs
Click URL in the Select window to select and highlight URLs.

Confirming Commands
Click Confirm to confirm that the deletion or modification you have defined should be implemented.
Pasting Elements from Other Applications

When you have cut or copied an item, you can paste this item such that it is owned by the current part using the As Subpart button.

To use As Subpart:

1. Click 2D Access and then, in the Clipboard group, click the arrow next to Paste.
2. Click As Subpart.

Refer to Linking and Embedding OLE Objects on page 104 for instructions on linking and embedding OLE objects in Creo Elements/Direct 2D Access.

Undo and Redo

In Creo Elements/Direct 2D Access, you can undo mistakes with Undo or Redo:

• On the Quick Access Toolbar, click to undo an operation or press CTRL +Z.
• On the Quick Access Toolbar, click to redo an operation (after you have clicked Undo) or press CTRL+Y.

Each time you click Undo or Redo, you undo or redo all the changes that were created by the last button you clicked.

You can set a limit on the number of steps to keep in the Undo history in the System dialog box.

1. Click File ▶ Settings ▶ System.
2. Click Environment.
3. In the Undo area, click one of the following:
   • Click Unlimited to allow unlimited number of steps for Undo.
   • Click Max steps and type the maximum number of steps allowed in the Undo history.
Limitations:

• You can undo or redo complete macros, but you cannot use **Undo** or **Redo** inside macros.

• **Undo** or **Redo** cannot undo or redo:
  ○ Commands related to parametric design or hidden lines.
    Once you have executed one of these commands, you can no longer undo or redo any of your previous commands.
  ○ The **RESET_SYSTEM** command.
  ○ Commands for default settings (although these commands do not affect the **Undo** or **Redo** history).

Undo and Redo with state history

Each time you enter a command and change your drawing, Creo Elements/Direct 2D Access adds a new state to the **Undo** or **Redo** history. Creo Elements/Direct 2D Access marks the new state with a unique ID. You can use several commands to work with these unique IDs. For further information, see the *Creo Elements/Direct Drafting / Creo Elements/Direct 2D Access Programming Reference Guide*.

Exiting Creo Elements/Direct 2D Access

To exit Creo Elements/Direct 2D Access, click **File** and then click **Exit**.

Creo Elements/Direct 2D Access prompts you to save changes, if any, before exiting.

Customizing Creo Elements/Direct 2D Access

You can quickly and easily customize Creo Elements/Direct 2D Access for your personal requirements. Detailed instructions are provided in the *Customizing Creo Elements/Direct 2D Access on page 136* chapter.
4

Finding, Loading, and Handling Files

Using the File Browser ................................................................. 40
Creating a New Creo Elements/Direct 2D Access Instance .............. 43
Importing Macros, Fonts and HPGL Files ...................................... 43
Exporting Macro, Pictures, and Images ........................................ 47

This chapter assumes that you are familiar with the directory structure and general file handling methods of your computer.
Using the File Browser

You can open a drawing file quickly and easily by means of the Creo Elements/Direct 2D Access File Browser. This File Browser adheres to standard MS Windows conventions. You do not need to remember long filenames and subdirectories as these are displayed. (You can still enter the file name in the command line if you wish.)

You can close the File Browser once the drawing has been opened or saved. Optionally, you can leave the File Browser open for further selections.

In the File related dialog boxes, the File Browser provides the following icons:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>🌂</td>
<td>Moves up one level in the directory hierarchy.</td>
</tr>
<tr>
<td>📁</td>
<td>Creates a new folder (directory) on the current directory level.</td>
</tr>
<tr>
<td>📎</td>
<td>Displays files and directories in various views. You can choose the following views:</td>
</tr>
<tr>
<td></td>
<td>• Thumbnails</td>
</tr>
<tr>
<td></td>
<td>• Tiles</td>
</tr>
<tr>
<td></td>
<td>• Icons</td>
</tr>
<tr>
<td></td>
<td>• List</td>
</tr>
<tr>
<td></td>
<td>• Details</td>
</tr>
</tbody>
</table>

In the dialog boxes associated with the File Browser, you can move, copy and delete files and directory using standard MS-Windows techniques.

Opening a Drawing File Using the File Browser

To open a drawing file by means of the Creo Elements/Direct 2D Access File Browser:

1. Click File ▶️ Open to display the File Browser.

   Alternatively, click Open on the Quick Access Toolbar or press CTRL+O.

2. If the file you want to open is not listed in the File pane of the File Browser, select the directory that contains the file in the Directory box.

   If this directory is specified in the File pane, double-click the directory name to list the files contained in it.

3. Click the filename.

   If a file is in a format other than MI (the default), then in the Filter box, click the applicable format:
• **Model Interface Standard (*.mi)**
• **Compressed MI (*.bi)**
• **Bundle (*.bdl)** (Creo Elements/Direct Modeling Bundle files)

**Note**
Only the 2D portions of such files are extracted, while any 3D portions are ignored.

• **Autodesk Drawing Interchange (*.dxf)**
• **Initial Graphics Exchange Format (*.igs)**
• **AutoCAD File Specification (*.dwg)**
• **JPEG - JFIF Compliant (*.jpg)**
• **Portable Network Graphics (*.png)**
• **Tagged Image File Format (*.tif)**
• **Windows or OS/2 Bitmap (*.bmp)**
• **All files (*.*)**

A preview image of the drawing file is displayed in the preview pane of the File Browser.

4. Optionally, click the following check box:

<table>
<thead>
<tr>
<th>Check 2D</th>
<th>Creo Elements/Direct 2D Access checks this file for invalid elements (such as extremely short lines) and removes such elements.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Check 2D Retain Dependency</strong></td>
<td>Creo Elements/Direct 2D Access reallocates dependent elements (such as dimensions or hatches) of removed invalid elements to plausible valid elements.</td>
</tr>
</tbody>
</table>
In some cases, a font may have been saved with an MI file. Creo Elements/Direct 2D Access automatically loads this font when you load the file. However, if the font in the file matches a font name already in your system, you can instruct Creo Elements/Direct 2D Access to overwrite your system font with the file font by clicking this box.

In some cases, a font may have been saved with an MI file. Creo Elements/Direct 2D Access automatically loads this font when you load the file. If you do not want new fonts loaded, click this check box.

5. Click **Open** to open this file in Creo Elements/Direct 2D Access.

   Alternatively, type the filename in the **Name** box and press ENTER.

6. Once the drawing is displayed in Creo Elements/Direct 2D Access, you can view and measure it.

---

**Note**

The preview image is pixel-based. It cannot be modified.

---

### Opening a Drawing File by Means of the Navigator

The Creo Elements/Direct 2D Access Navigator provides a scrollable sequence of preview images of the drawing files in the current directory. The Navigator thus facilitates the selection of drawings.

To open a drawing file by means of the Creo Elements/Direct 2D Access Navigator:

1. Click **File ▶▶ Open** to display the File Browser.

   Alternatively, click **Open** on the Quick Access Toolbar or press CTRL+O.

2. Click **Navigator** to display the Creo Elements/Direct 2D Access Navigator.

   The **Navigator** displays a preview image for each file provided in the formats listed above.

3. In the left pane of the **Navigator**, click the directory whose drawing files you want to view.
4. In the right pane of the **Navigator**, double-click the preview image to open its associated drawing file in Creo Elements/Direct 2D Access.

Once the drawing is displayed in Creo Elements/Direct 2D Access, you can view and measure it.

**Note**

To return to the File Browser, simply close the **Navigator**.

---

**Opening Most Recently Used Drawing Files**

By default, the four most recently used drawing files are listed (complete with filetype extension) in the Creo Elements/Direct 2D Access **File** menu. To load one of these files:

1. Click **File**.
2. Under **Recent Documents**, click the name of the drawing file you want to open.

---

**Creating a New Creo Elements/Direct 2D Access Instance**

Optionally, you can run multiple instances of Creo Elements/Direct 2D Access at the same time.

To create a new Creo Elements/Direct 2D Access instance:

- Click **Start ▶▶ All Programs ▶▶ PTC ▶▶ Creo Elements Direct 2D Access [version] ▶▶ Creo Elements Direct 2D Access [version]**.

**Note**

- Each instance runs in a separate window.
- All Creo Elements/Direct 2D Access instances are independent of each other.

---

**Importing Macros, Fonts and HPGL Files**

You can import the following files into your current Creo Elements/Direct Drafting drawing:
• Parts and Subparts
• Creo Elements/Direct Drafting Macros
• Fonts
• HPGL Files

Importing a Part

To load a part:

1. Click File ▶ Import/Export ▶ Import Part.

The Load File dialog box opens.

2. If the file that you want to import is not listed in the File pane of the File Browser:
   a. In the Directory box, select the directory that contains the drawing file that you want to import.
   b. Double-click the directory.

   If the directory is specified in the File pane, double-click the directory name to list the files contained in it.

3. Click or specify the filename.

4. If a file is provided in a format other than MI (the default), then in the Filter box, select the applicable file format. Refer to Opening a Drawing File Using the File Browser on page 40 for a list of supported formats.

   Optionally, you can click any or all of the following check box:

<table>
<thead>
<tr>
<th>As Subpart</th>
<th>Loads a drawing as a subpart of the active part.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Keep Scale</td>
<td>The original drawing scale is retained when the drawing file is loaded.</td>
</tr>
<tr>
<td>Check 2D</td>
<td>Creo Elements/Direct Drafting checks this file for invalid elements (such as extremely short lines) and removes such elements.</td>
</tr>
<tr>
<td>Check 2D Retain Dependency</td>
<td>Creo Elements/Direct Drafting reallocates dependent elements (such as dimensions or hatches) of removed invalid elements to plausible valid elements.</td>
</tr>
</tbody>
</table>

5. Click Open to add the file as a part to the current drawing in Creo Elements/Direct 2D Access.

Creo Elements/Direct 2D Access automatically loads the part into the position, relative to the origin, in which it was originally created.
**Note**

Creo Elements/Direct 2D Access loads the file immediately below the top part.

---

**Importing a Subpart**

You can import a part file as a subpart under the active part.

To import a subpart:

1. Click **File ➤ Import/Export ➤ Import Part**.

   The **Load File** dialog box opens.

2. If the file that you want to import is not listed in the File pane of the File Browser:
   a. In the **Directory** box, select the directory that contains the drawing file that you want to import.
   b. Double-click the directory.

   If the directory is specified in the File pane, double-click the directory name to list the files contained in it.

3. Click the **As Subpart** check box.

4. Click or specify the filename.

5. If a file is provided in a format other than MI (the default), then in the **Filter** box, select the applicable file format. Refer to Opening a Drawing File Using the File Browser on page 40 for a list of supported formats.

6. Click **Open** to add the file as a subpart to the current drawing in Creo Elements/Direct 2D Access.

Creo Elements/Direct Drafting automatically loads the part into the position, relative to the origin, in which it was originally created.

---

**Note**

Creo Elements/Direct 2D Access loads the file as a part. The part belongs to the active part and is placed under it in the parts hierarchy.
Importing a Creo Elements/Direct Drafting Macro

To import a Creo Elements/Direct Drafting macro:

1. Click File ▶ Import/Export ▶ Import Macro.
2. Click Macro.
3. Click one of the following:
   • Click Input Macro to import a macro provided in the ASCII format.
     The Input Macro dialog box opens.
   • Click Load Macro to import a macro provided in the binary format.
     The Load Macro dialog box opens.
4. Select the macro.
5. Click Open to open the macro in Creo Elements/Direct 2D Access.

Importing a Font

To import a font:

1. Click File ▶ Import/Export ▶ Import Font.
2. Click Load Font to import a font provided in the binary format.
   The Load Font dialog box opens.
3. Select a font and then click Open to load the font for use in Creo Elements/Direct 2D Access.

Importing an HPGL File

Creo Elements/Direct Drafting enables you to load HP-GL and HP-GL2 files.

To import a HP-GL (Hewlett-Packard Graphics Language) or HP-GL2 file:

1. Click File ▶ Import/Export ▶ Import HPGL.
   The Load HPGL/2 file dialog box opens.
2. Select the HPGL/2 file.
3. Click Open to open the file in Creo Elements/Direct 2D Access.
4. Specify the position for the imported HPGL/2 file.
Exporting Macro, Pictures, and Images
You can export the following from your current Creo Elements/Direct 2D Access session:

- Creo Elements/Direct 2D Access Macros
- Pictures
- Images

Exporting a Macro
To export a Creo Elements/Direct Drafting macro:

1. Click File ▶ Import/Export ▶ Export Macro.
2. Click one of the following:
   - Click Save Macro to export and save a macro in the ASCII format.
   - Click Store Macro to export and save a macro in the binary format.

   The Select Macro dialog box opens.
3. In the Name box, select a macro.
   Optionally, click the All check box to select all macros.
4. Click OK.

   The Save Macro dialog box opens.
5. In the Name box, type or select a macro file name (*.m).
6. Click Save to save the macro file.

Exporting a Picture
Creo Elements/Direct 2D Access allows you to export pictures in various image formats.

To export a picture:

1. Click File ▶ Import/Export ▶ Export Picture.
2. Select a single picture for export.
3. Type the name of the destination file with the desired file format (JPG, PNG, TIF, or BMP) and press ENTER.
Exporting as Image

Creo Elements/Direct 2D Access allows you to export a drawing as an image in high resolution pixel format.

To export a drawing as an image:

1. Click File ▶ Import/Export ▶ Export as Image.
2. Click one of the following:
   - Export as BMP
   - Export as JPEG
   - Export as PNG
   - Export as TIFF
3. To specify input, type PORT, BOX, or DEL_OLD in the user input line and press ENTER.
   Alternatively, type the name and the destination path for the drawing image file in the user input line and press ENTER to directly obtain the drawing image at the specified destination path.
4. If you type PORT in the user input line and press ENTER:
   a. Click a point, or type CURRENT or the viewport number in the user input line and press ENTER.
   b. Type RESOLUTION or destination for the drawing image file in the user input line and press ENTER.
      To specify the resolution for the drawing image, type RESOLUTION in the user input line and press ENTER. Then perform the following steps:
      - Type PAPER_TO_PIXELS in the user input line and press ENTER.
        Creo Elements/Direct Drafting recalculates paper format and dpi to X, Y resolution. You are then prompted for a paper format (A-E, A4-A0) or size, and then for the dpi.
      - Type the width and height of the pixels. Type -1 for either width or height to retain the ratio of the current viewport and specify the other dimension in pixels.
4. If you type BOX in the user input line and press ENTER:
   a. Enclose the required drawing area in a box and press ENTER.
   b. Type the name and the destination path for the drawing image file in the user input line and press ENTER.

Possible error messages are:
• Not enough memory available to perform the operation.
• ***The output image size is limited to a maximum of 4/3 billion pixels.
Viewing Drawings in Creo Elements/Direct 2D Access

Using View Functions ................................................................. 51
Using Viewports to Display Several Views ................................... 53
Selecting What is Displayed on Your Screen .............................. 58

This chapter describes how to view a drawing in Creo Elements/Direct 2D Access.
Using View Functions
This section describes how to control the area of the drawing shown in the current viewport using the buttons in the Viewing group on the View tab.

Viewing a Drawing in the Full Screen Mode
To view your drawing in the Full Screen mode:

• Click View and then, in the Viewing group, click Full Screen. Alternatively, press F11 to toggle between the Full Screen mode and the normal mode.

Redrawing
To redraw the drawing in the chosen viewport:

• Click View and then, in the Viewing group, click Redraw.
This is sometimes necessary if you have deleted several elements and traces are still visible on the screen. The contents of other viewports are not redrawn.

Fitting a Drawing
To fit the current drawing in the selected viewport:

• Click View and then, in the Viewing group, click Fit.

Panning Across a Drawing
Panning is a very useful function enabling you to move across the drawing to see those areas not currently displayed.
To pan in any direction:

1. Click View and then, in the Viewing group, click Pan.
2. Click a point in your drawing.
3. Specify the new screen position for this point. Alternatively, middle-click and drag to pan to the new position.

Creating a New View in a Window
To create a new window:
1. Click View and then, in the Viewing group, click Window.
2. Specify the two points (corners) of the area you want to enlarge.

**Restoring the Last View**

To return to the previous view:

- Click View and then, in the Viewing group, click Last.

**Zooming In or Out**

A window is always zoomed about its center point.

To zoom your window:

1. Click View and then, in the Viewing group, click Zoom.
2. Type a zoom factor in the user input line and press ENTER.

A number greater than 1 results in a window that covers a smaller area (zooming in). A number less than 1 (>0) or negative (<-1) gives a larger coverage (zooming out).

Alternatively, move the mouse towards the screen to zoom-in or move the mouse away from the screen to zoom-out and click a point in the viewport.

**Storing and Recalling Windows**

If you are likely to need the same view again, you can store it and recall it as required.

To store the current window coordinates:

- Right-click the viewport and click Store.

To recall the window that was stored last:

- Right-click the viewport and click Recall.

**Creating a New Center Point for Your Drawing**

To specify the new center point for the display:

- Click View and then, in the Viewing group, click Center.

Your drawing is repositioned so that this point is in the center of the chosen viewport.
Using Viewports to Display Several Views

You can divide the drawing area of the screen so that more than one view can be displayed. This is a very useful feature when you want to work on a detail drawing. The changes made to the detail are automatically repeated in the main drawing. Each division of the screen is called a viewport.

Viewports can be overlapped with other viewports. All viewports are continuously updated.

In the following example, the view in viewport 1 can be imagined as the view you would see if you were examining your drawing with a magnifying glass. To achieve this effect, simply zoom in to the drawing displayed in viewport 1 until you can see the required level of detail.

- Viewport 1 — contains a magnified view showing the required level of detail.
- Viewport 2 — contains the entire drawing and is used as a positional reference for the magnifying glass.

Examine the zoomed drawing in viewport 1 while moving the cursor (as a positional reference) in viewport 2. See Figure 3. Using Viewport 2 as a Reference on page 54 and Figure 4. Viewing Piston Assembly Detail in Viewport 1 on page 55.
Figure 3. Using Viewport 2 as a Reference

Position the cursor box over the required area.
Creating a Viewport

To create a new viewport:

1. Click **View** and then, in the **Window** group, click **New**.
2. Specify the new corner points for the new viewport.

The new viewport is marked by a sequential number in the top-right corner.

Making a Viewport Current

If a viewport is partially or totally covered by other viewports, it is made inactive. Its visual contents are not updated by any subsequent operations unless it is made the current viewport.

The current viewport is the one that is currently active, fully visible and up-to-date. The viewport number is displayed in inverse video in the top-right corner.

To change the current viewport:

1. Click **View** and then, in the **Window** group, click **Current**.
2. Click the viewport required.
Alternatively, type the viewport number in the user input line and press ENTER.

**Changing the Size of a Viewport**

To change the size of a viewport:

1. Click **View** and then, in the **Window** group, click **Change**.
2. Click the required viewport.
3. Specify the new corner points of the viewport.

**Moving a Viewport**

To move a viewport:

1. Click **View** and then, in the **Window** group, click **Move**.
2. Click the viewport.
3. Drag the cursor to the new position in the viewport.
   The contents of the viewport follow the viewport.

**Redrawing a Viewport**

To redraw a viewport:

1. Click **View** and then, in the **Window** group, click **Redraw**.
2. Click the viewport.
   The contents of the viewport are redrawn.

**Maximizing the Size of a Viewport**

You can maximize the size of any viewport such that the viewport occupies the entire Creo Elements/Direct 2D Access drawing area.

To maximize the size of the viewport:

1. Click **View** and then, in the **Window** group, click **Large**.
2. Click the viewport.

Any other viewport are now hidden behind the maximized viewport. To bring any of these hidden viewport to the foreground, make it current. To change the size of the maximized viewport, use **Change**.
Deleting a Viewport

To delete a viewport:

1. Click View and then, in the Window group, click Delete.
2. Click the viewport.

   Alternatively, type the viewport number in the user input line and press ENTER.

Deleting All Viewports

To delete all viewports:

1. Click View and then, in the Window group, click Delete.
2. Type ALL in the user input line and press ENTER.

Note

To view your current drawing in Creo Elements/Direct 2D Access after you have deleted all viewports, you need to create at least one new viewport.

Viewport Settings

The viewport settings are defined in the Viewport Settings dialog box.

To define the viewport settings:

1. Click File ▶ Settings ▶ Viewport.

   The Viewport Settings dialog box opens.

2. In the Border area:
   a. In the Color box, select a color for the viewport border.
   b. In the Width box, type the viewport border width.

3. In the Color of area:
   a. In the Background box, select the background color.
   b. In the Text box, select the color of the text.
   c. In the Cursor box, select the color of the cursor.

4. In the Invert area, select one of the following in the Invert Color box to invert display colors in a viewport:
   • White elements
If you select **White elements**, the elements that are white (or almost white) are displayed in black. This is the default for the **Creo Colors** color scheme.

- **Black elements**
  
  If you select **Black elements**, the elements that are black (or almost black) are displayed in white. This is the default for the **CoCreate Colors** color scheme.

- **Off**
  
  If you select **Off**, element colors are not inverted in the viewport.

5. Click **OK**.

---

**Note**

The viewport colors are defined by the selected color scheme.

## Selecting What is Displayed on Your Screen

This section describes how to use the **Show** dialog box to control exactly what is displayed on your screen.

To open the **Show** dialog box:

- Click **File ▶ Settings ▶ Show**.
  
  Alternatively, click **2D Access** and then, in the **Utilities** group, click **Show**.

---

**Note**

Before you plot your complete drawing, you are recommended to check what is included by clicking **Show All** in the **General** tab of the **Show** dialog box.

You can selectively display or hide:

- Construction geometry
- Geometry
- Dimensions
- Hatch
- Text
• Vertex
• Info
• Layers
• URLs

Note
• The Show settings apply to the current viewport.
• Any new viewports created automatically adopts the settings of the viewport that was active when they were created.

Showing All Features
To display all the features of your drawing:
1. Click File ▶ Settings ▶ Show.
   Alternatively, click 2D Access and then, in the Utilities group, click Show. The Show dialog box opens.
2. On the General tab, click Show All.
   It is useful to start with everything displayed, and then clear the check box of items that are not required.

Showing Points
To display all existing points on the drawing:
1. Click File ▶ Settings ▶ Show.
   Alternatively, click 2D Access and then, in the Utilities group, click Show. The Show dialog box opens.
2. On the General tab, click the Vertex check box.
   This is useful if you want to identify a point more accurately, or to check if two lines overlap. Points are displayed in the following colors (by default):
   • GREEN — end points
   • YELLOW — common end points
   • BLUE — single center points
   • MAGENTA — multiple center points
Showing Dimensions
To display all dimensions on a drawing:
1. Click File ▶ Settings ▶ Show.
   Alternatively, click 2D Access and then, in the Utilities group, click Show.
   The Show dialog box opens.
2. On the General tab, click the Dimension check box to display all the dimensions.

Changing the Layer Color
To change the color of a specified layer:
1. Click File ▶ Settings ▶ Show.
   Alternatively, click 2D Access and then, in the Utilities group, click Show.
   The Show dialog box opens.
2. Click the Layer tab.
3. Select the layer number.
4. In the Color box, select a color.
5. Click Color.

Displaying Infos
To display elements that contain attached infos:
1. Click File ▶ Settings ▶ Show.
   Alternatively, click 2D Access and then, in the Utilities group, click Show.
   The Show dialog box opens.
2. Click the Info Elem. tab.
3. Select the info to be displayed.
4. Click On to display elements that have information attached.

Setting the Redraw Mode
When working with large or complex drawings, you may want to change the
redraw mode in order to enhance the graphics performance.
To define settings for the redraw mode:
1. Click File ▶ Settings ▶ System.
The **System** dialog box opens.

2. Click **Redraw Mode**.

3. In the **Parts as Box** area:
   a. In the **Smaller than** box, type a size threshold (in pixels) below which parts are only shown as boxes.
   b. Optionally, in the **Box Color** box, select a color.

4. In the **Draw Dynamic** area:
   a. Click the check box of the items that you want to include in the redraw.
   b. Clear the check box of the items that you want to exclude from the redraw to enhance performance.

5. Click **OK**.
Measuring in Creo Elements/Direct 2D Access

Changing the Catch Mode ................................................................. 63
Measuring Distances ....................................................................... 63
Setting the Units of Measurement .................................................... 68
Using the Calculator ........................................................................ 69
Using the Ruler or Grid ................................................................... 69

This chapter describes how to measure in Creo Elements/Direct 2D Access. The combination of Catch and Measure functions provides a powerful tool for fast and accurate measurements.
Changing the Catch Mode

The Catch box enables you to select a point on the screen without putting the cursor directly on that point. The cursor automatically "snaps" to this point. The current catch mode is always displayed in the status bar. The system will catch to a given point only if the point lies within the (imaginary) circle around the edges of the cursor.

By default, the catch mode is set to All. You can change the catch mode to any of the following:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Catches to</th>
</tr>
</thead>
<tbody>
<tr>
<td>VERTEX</td>
<td>Vertex</td>
</tr>
<tr>
<td>ELEM</td>
<td>Element</td>
</tr>
<tr>
<td>INTERSECTION</td>
<td>Intersection</td>
</tr>
<tr>
<td>CENTER</td>
<td>Center point</td>
</tr>
<tr>
<td>GRID</td>
<td>Ruler/grid point</td>
</tr>
<tr>
<td>OFF</td>
<td>Switches Catch off</td>
</tr>
</tbody>
</table>

Select the catch mode in the Catch box on the status bar.

When Catch is set to All, Creo Elements/Direct 2D Access catches using the following order of priority:

1. VERTEX
2. INTERSECTION
3. RULER/GRID
4. ELEM

If the system finds a vertex within the catch range it catches to the closest such vertex; otherwise it searches for intersections and so on. If the system can't find any of these, it uses the given input point.

Measuring Distances

Creo Elements/Direct 2D Access allows you to obtain values for arc lengths, distances, point coordinates, angles, and areas using Measure buttons. These buttons are useful if you need to enter a value measured from existing features on the drawing. To illustrate this, consider the following example:

Example

Suppose you want to draw a vertical line starting at 100,100 and of the same length as an existing line drawn at an angle of 40 degrees:

1. Click 2D Access and then, in the Utilities group, click Measure.
2. Click 𝐿𝑒𝑛𝑔𝑡ℎ.
3. Click the existing line.

The measured length of this line is displayed in the user input line.

---

Note

- The Follow function is not active while 𝐌𝑒𝑎𝑠𝑢𝑟𝑒 is active.

---

Measuring Distance

To measure distance between any two points:

1. Click 2D Access and then, in the Utilities group, click 𝐌𝑒𝑎𝑠𝑢𝑟𝑒.
2. Click 𝐷𝑖𝑠𝑡𝑎𝑛𝑐𝑒.
3. Click the begin point and the end point in the drawing to measure the required distance.

The distance between the two points is displayed in the user input line.

Measuring a Radius

To measure the radius of a curved element:

1. Click 2D Access and then, in the Utilities group, click 𝐌𝑒𝑎𝑠𝑢𝑟𝑒.
2. Click 𝑅𝑎𝑑𝑖𝑢𝑠.
3. Click the curved element whose radius you want to measure.

The radius of the curved element is displayed in the user input line.

Measuring Lengths

To measure the length of any element (line, circle, arc, fillet, chamfer or spline):

1. Click 2D Access and then, in the Utilities group, click 𝐌𝑒𝑎𝑠𝑢𝑟𝑒.
2. Click 𝐿𝑒𝑛𝑔𝑡ℎ.

The length of the element is displayed in the user input line.
Measuring Horizontal Distances
To measure horizontal distance between two points:

1. Click 2D Access and then, in the Utilities group, click Measure.
2. Click Horizontal.
3. Click two points in the drawing to identify the horizontal distance you want to measure.
   The horizontal distance between the two points is displayed in the user input line.

⚠️ Note
This option is dependent on the current catch mode.

Measuring Vertical Distances
To measure vertical distance between two points:

1. Click 2D Access and then, in the Utilities group, click Measure.
2. Click Vertical.
3. Click two points in the drawing to identify the vertical distance you want to measure.
   The vertical distance between the two points is displayed in the user input line.

⚠️ Note
This option is dependent on the current catch mode.

Displaying Point Coordinates
To display the exact coordinates of any existing point:

1. Click 2D Access and then, in the Utilities group, click Measure.
2. Click Point.
3. Click the point.
The exact coordinates of this point are shown in the user input line.

**Note**

This option is dependent on the current catch mode.

### Measuring Angles

To measure the angle between two lines:

1. Click **2D Access** and then, in the **Utilities** group, click **Measure**.
2. Click **Angle**.
3. Click a point on the first line.
4. Click a point on the second line.

Similarly, to measure an arc segment angle, click the arc start and end points.

The angle between two tangents drawn at an intersection point of two circles can be measured by clicking a point on the first circle and then a point on the second circle.

### Measuring Area Properties

#### A Single Face

To calculate the area and area properties of a selected face, the face must be completely bounded by elements.

Creo Elements/Direct 2D Access calculates and displays the following area properties for a single face:

- Number of holes in the face.
- Density of the face.
- Perimeter length of the face (outer perimeter).
- Area.
- Center of Area (= Center of Mass).
- Principal Axes (of Inertia through the Center of Area).
- Second Moments of Area about principal axes.
- Second Moments of Area about coordinate system axes.
- Product of Second Moment of Area about coordinate system axes.
• Moments of Inertia about principal axes.
• Moments of Inertia about coordinate system axes.
• Product of Moment of Inertia about coordinate system axes.
• Section Moduli (about principal axes).
• Distance from first neutral axis to extreme fiber.
• Distance from second neutral axis to extreme fiber.
• Radii of Gyration.
• Angle between coordinate system and principal axes.

**Multiple Faces**

If you identify multiple faces, Creo Elements/Direct 2D Access uses the density values to calculate the Common Center of Mass. The density must be specified before a face is identified, otherwise the default value (1) or the previous density value is used.

Creo Elements/Direct 2D Access calculates and displays the following total values for multiple faces:

• Total Area.
• Center of Area (common).
• Center of Mass (common).
• Principal Axes through the (common) Center of Area.
• Second Moments of Area about (common) Principal Axes.
• Second Moments of Area about Coordinate System Axes.
• Product of Second Moment of Area about Coordinate System Axes.
• Moments of Inertia about (common) Principal Axes.
• Moments of Inertia about Coordinate System Axes.
• Product of Moment of Inertia about Coordinate System Axes.
• Radii of Gyration with respect to the (common) Center of Area.
• Angle between Coordinate System and (common) Principal Axes.

To display face area properties:

1. Click **2D Access** and then, in the **Utilities** group, click **Properties**.
2. Click **Area**.
3. Type the density value in the user input line and press ENTER.
   The default density value is 1.
Alternatively, select a face or faces.

4. Click **Confirm**.

The area properties are displayed in a standard text editor.

Optionally, you can save the list of area properties in a file.

### Setting the Units of Measurement

You can select angular and linear units using the buttons under **Angle Units** and **Length Units**, respectively. The current units are displayed in the **Format** group on the **2D Access** tab.

To set the angular unit:

1. Click **2D Access** and then, in the **Format** group, click **Angle Units**.
2. Click the required angular unit from the following:
   - **Degree**
   - **Gradian**
   - **Radian**
   - **User**

To set the linear unit:

1. Click **2D Access** and then, in the **Format** group, click **Length Units**.
2. Click the required linear unit from the following:
   - **cm**
   - **meters**
   - **km**
   - **mm**
   - **µm**
   - **inches**
   - **feet**
Defining Your Own Units

The User and user buttons in the Format group on the 2D Access tab allow you to define your own units in Creo Elements/Direct Drafting. For example, an input of 5 mm allows you to work in 5 mm units, and an input of 5 degrees allows you to work in 5 degree units.

Using the Calculator

Creo Elements/Direct 2D Access provides a standard MS Windows calculator. To use the scientific calculator:

1. Click 2D Access and then, in the Utilities group, click Calculator.
   
The Calculator application opens.

2. On the View menu of the Calculator, click Scientific.

Using the Ruler or Grid

The ruler simulates the T-square traditionally used with manual drafting methods. When used together with the grid point catch mode, the ruler allows you to draw with the help of a grid.

The grid is a useful drawing aid for alignment purposes.

Displaying a Ruler and/or a Grid

To display the ruler and/or the grid:

1. Click File ▶ Settings ▶ Grid.
   
The Grid Settings dialog box opens.

2. In the Grid area, click Dot or Line to display a dot or line grid, respectively.
3. In the **Ruler** area, click **Ruler** to display the ruler.
4. Click **OK**.

### Displaying the Origin

To display the coordinate origin:

1. Click **File ▶ Settings ▶ Grid**.
   - The **Grid Settings** dialog box opens.
2. In the **Ruler** area, click **Origin**.
   - The coordinate origin is indicated in the chosen viewport by an axes symbol.
   - If the ruler is active in the chosen viewport, it becomes unavailable.
3. Click **OK**.

### Setting the Cursor Size

You can use either a small cursor or a full screen cursor. A full screen cursor is particularly recommended for use with the ruler.

To change the cursor size:

1. Click **File ▶ Settings ▶ System**.
2. Click **Environment**.
3. In the **Cursor** area, click the **Large** check box to use the large (full screen) cursor.
4. In the **Cursor Size** box, type the size for the cursor.

**Note**

The catch range is not affected by the cursor size.

### Using Follow On/Off

The ruler is always located at the origin. The origin always tracks the ruler, and the ruler always tracks the origin. Optionally, you can use the **Follow** function to move the coordinate system origin with the origin of the ruler.

To make the origin follow the ruler:

1. Click **View** and then, in the **Viewing** group, click **Grid**.
2. Click **Follow**.
   The ruler automatically moves to each new point you create.

**Moving the Ruler**

To move the ruler:

1. Click **View** and then, in the **Viewing** group, click **Grid**.
2. Click **Move**.
3. Specify the new origin.
   The orientation of the ruler axes remains the same.

**Rotating the Ruler/Grid**

**With Respect to the X-Axis**

To rotate the ruler (or grid) so that the x-axis is at a given angle to the horizontal:

1. Click **View** and then, in the **Viewing** group, click **Grid**.
2. Click **Turn**.
3. Click **Absolute**.
4. Type the required angle in the user input line and press ENTER.

**Through a Given Angle**

To rotate the ruler (or grid) through a given angle:

1. Click **View** and then, in the **Viewing** group, click **Grid**.
2. Click **Turn**.
3. Click **Relative**.
4. Type the required rotation angle in the user input line and press ENTER.
   A positive value results in counterclockwise rotation.

**Setting the Ruler or Grid Spacing**

To change the spacing between the tick marks of the ruler or between the grid lines or dots:

1. Click **File ▶ Settings ▶ Grid**.
   The **Grid Settings** dialog box opens.
2. In the **Options** area, type the required distance (for example: 0.5) in the **Spacing** box.

   This entry is interpreted in terms of the current length unit.

If the spacing is very small, it may not be shown on the screen but it will still be used for catch when in ruler or grid catch mode. Use the buttons on the **View** tab if you want an enlarged view.

### Drawing an Isometric Ruler or Grid

To redraw the ruler or grid according to the isometric grid required for drawing top, front, or side views:

1. Click **View** and then, in the **Viewing** group, click **Grid**.
2. Click **Isometric** and then click any of the following:
   - Click **Front** to draw a front view.
   - Click **Top** to draw a top view.
   - Click **Side** to draw a side view.

### Hiding the Ruler or Grid

To hide the ruler/grid:

1. Click **View** and then, in the **Viewing** group, click **Grid**.
2. Click **Hide**.

**Hide** disables the ruler and/or grid. Alternatively, you can click **None** in the **Ruler** area of the **Grid Settings** dialog box.

### Placing the Ruler or Grid

To change the orientation of the axes:

1. Click **View** and then, in the **Viewing** group, click **Grid**.
2. Click **Place**.
3. Specify the new origin and two more points that define the new axis orientation.

**Figure 5. Ruler Axes on page 73** shows the ruler axes.
Figure 5. Ruler Axes
To understand how to use the buttons in the Parts group on the 2D Access tab, it is necessary for you to have a basic understanding of parts.

A complex drawing is likely to contain several parts. Design Engineers use parts to simplify the drawing into clearly defined groups of elements. Each part has a part name. It is possible to view or highlight only one part of a complex drawing at a time. This provides a clearer visual representation of the part in relation to the entire drawing.
Parts Structure

The use of parts in a drawing results in a parts structure. A parts structure can be thought of as a family-tree showing the relationships between all the parts. The structure is hierarchical and has many levels, each level containing information about the relationship between each part and its subparts. The highest level of the parts structure is called Top. The lowest level contains parts that cannot be subdivided any further.

If a part has subparts then it is called a parent part.

Summary

- Complex drawings are likely to contain parts.
- Parts are groups of elements.
- Each part has a name (part name).
- Parts containing subparts are called parent parts.
- You can selectively view, or highlight any part or group of parts, either by means of the Part Browser on page 78, or by means of the following buttons.

Editing Parts

Creo Elements/Direct 2D Access allows you to edit the parts using the buttons in the Parts group on the 2D Access tab.

You can use Part, Top, and Parent to edit parts. Creo Elements/Direct 2D Access displays the active part in normal linetypes and colors while all the other parts are shown in magenta dotted lines.

Editing a Part

To set a part as active:

1. Click 2D Access and then, in the Parts group, click Edit.
2. Click Part.
3. Select the part you want to make active.

Creo Elements/Direct 2D Access sets the clicked part as the active part.

Editing a Top Part

To set the highest part in the parts structure as active:
1. Click 2D Access and then, in the Parts group, click Edit.

2. Click Top.

**Editing the Parent Part**

Parts can contain subparts.

To set the parent of the active subpart as the new active part:

1. Click 2D Access and then, in the Parts group, click Edit.

2. Click Parent.

**Viewing Parts**

This section describes how to view individual parts of your drawing.

Use the View buttons in the Parts group on the 2D Access tab to look at individual parts of your drawing. The View buttons work only in the active viewport.

**Viewing a Part**

To look at an isolated part:

1. Click 2D Access and then, in the Parts group, click View.

2. Click Part.

3. Type the part name in the user input line and press ENTER or click an element of the part.

Creo Elements/Direct 2D Access draws only this part. Creo Elements/Direct 2D Access displays the part name in the top left-hand corner of the active viewport.

**Viewing All Parts**

To view all parts of a drawing in the current viewport:

1. Click 2D Access and then, in the Parts group, click View.

2. Click Top.
Creo Elements/Direct 2D Access redraws all the parts making up the drawing. Creo Elements/Direct 2D Access redraws the part name in the top left-hand corner of the active viewport. This is useful if you have been viewing a lower level and want to quickly redraw the drawing.

**Viewing Parent Part**

To view the parent of the currently viewed part:

1. Click **2D Access** and then, in the **Parts** group, click **View**.
2. Click **Parent**.
3. Type the part name in the user input line and press ENTER or click an element of the part.

**Showing Unselected Parts as Boxes**

This section describes how to look at selected groups of parts using the **Show** buttons in the **Parts** group on the **2D Access** tab. Creo Elements/Direct 2D Access replaces each part not selected by a box. The **Show** buttons operate only in the active viewport. Using boxes is useful when parts overlap.

**With Part**

To draw a part as a box representation:

1. Click **2D Access** and then, in the **Parts** group, click **Show**.
2. Click **Part**.
3. Click the required part.

Creo Elements/Direct 2D Access redraws the part as a box. Also, use **Part** to draw a boxed part as a normal part.

**With Part Boxed**

To change a part and all its subparts to a box representation:

1. Click **2D Access** and then, in the **Parts** group, click **Show**.
2. Click **Boxed**.
3. Select the part to be boxed or type its name in the user input line and press ENTER.

Creo Elements/Direct 2D Access redraws the parent part and all the subparts displayed as a box.

**With All**

You can restore all parts in the chosen viewport to their normal appearance:

1. Click **2D Access** and then, in the **Parts** group, click **Show**.
2. Click **All**.

Creo Elements/Direct 2D Access redraws the chosen viewport with all parts visible.

**Part Browser**

To display the **Part Browser**, press F12.

To perform an action on a given part, right-click the part in the **Part Browser** and click the required button.

---

**Note**

The **Part Browser** can be docked anywhere in the Creo Elements/Direct 2D Access window.

---

**What is Shown in the Part Browser?**

The Part Browser provides a graphical overview of the current parts structure in your drawing.

- Starting at the top part, this tree-like structure includes a separate branch for each part. Subparts of a part are shown as sub-branches of that part.
- Click the + (plus) sign icon to expand the tree.
- Click the - (minus) sign icon to collapse the tree.
- Click the check box to the left of any part icon to view the associated part (and any parts hierarchically below this part).
- Clear the check box to the left of any part icon to hide the associated part (and any parts hierarchically below this part).
The individual columns of the **Part Browser** provide the following information:

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Specifies the name of the part. The following icons are used to indicate the nature of the part:</td>
</tr>
<tr>
<td></td>
<td>The currently active part. Note that the currently active part is represented by a red icon.</td>
</tr>
<tr>
<td></td>
<td>Normal part or assembly. Any non-active parts and/or parts hierarchically below the active part are indicated by a green icon.</td>
</tr>
<tr>
<td></td>
<td>Shared part.</td>
</tr>
<tr>
<td>Share</td>
<td>A &quot;hash&quot; (#) character in this column indicates that the part is shared.</td>
</tr>
<tr>
<td>Scale</td>
<td>Indicates the drawing scale of the part.</td>
</tr>
<tr>
<td>Symbol</td>
<td>A small &quot;x&quot; indicates that the part is symbolic.</td>
</tr>
</tbody>
</table>

**The Part Browser Tree Context Menu**

To display the **Part Browser** tree context menu, right-click any part icon in the **Part Browser**. This context menu provides the following commands (some of which are also available in the **Parts** group on the **2D Access** tab):

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>View</td>
<td>Shows only the selected part. Creo Elements/Direct 2D Access fits this part into the current viewport. All other parts are hidden, and their icons are marked by a yellow X (see list of Part Browser icons above).</td>
</tr>
<tr>
<td>Symbol</td>
<td>Changes the part to a symbol.</td>
</tr>
<tr>
<td>Show</td>
<td>This command provides the following options:</td>
</tr>
<tr>
<td>Show</td>
<td>Shows the selected part (if it is presently shown as a box or if it is hidden).</td>
</tr>
<tr>
<td>ShowFlat</td>
<td>Shows the selected part but not its subparts (if any).</td>
</tr>
<tr>
<td>ShowAll</td>
<td>Shows the entire selected part complete with all of its subparts.</td>
</tr>
<tr>
<td>ShowBox</td>
<td>Shows the selected part as a box.</td>
</tr>
</tbody>
</table>
### Hide

This command provides the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hide</td>
<td>Hides the selected part.</td>
</tr>
<tr>
<td>HideFlat</td>
<td>Hides the selected part but not its subparts (if any).</td>
</tr>
<tr>
<td>HideAll</td>
<td>Hides the entire selected part complete with all of its subparts.</td>
</tr>
</tbody>
</table>

### Options

The **Icons** option enables you to display the Part Browser with or without icons. The **State Icons** option enables you to show or hide the (checkbox-like) state icons that indicate whether or not a part is visible.

### Save

You can click **Save** to save an ASCII representation of the current parts tree structure in a Creo Elements/Direct 2D Access list file.

### Delete

Deletes the selected part.

---

**Spotlighting Parts**

You can distinguish between the active part and all other parts by using a spotlight. The button works as an on or off switch. The **Spotlight** is on when you first load Creo Elements/Direct 2D Access.

1. To disable **Spotlight**, click ![Spotlight](image) in the status bar.

2. To enable **Spotlight**, click ![Spotlight](image) again in the status bar.
Viewing Hidden Lines

Introduction to Hidden Lines ................................................................. 82
Checking Z-Values ............................................................................. 83
Generating Hidden Lines .................................................................... 85
Showing Hidden Lines On or Off ......................................................... 85
Showing Hidden Lines as Dashed Lines ............................................. 85
Plotting Hidden Lines ........................................................................ 86
Introduction to Hidden Lines

This chapter shows how to display hidden lines in assembly drawings.

The 2D hidden line module is used with assembly drawings to automatically display lines that indicate hidden drawing features. In an assembly drawing, these lines are normally shown dashed.

Creo Elements/Direct 2D Access allows you to use the buttons in the Hidden group on the 2D Access tab for commands associated with hidden lines.

Before you can display an assembly drawing using the hidden lines mode, you must check to see that the faces of your drawing have been assigned z-values.

What are Faces?

Faces can be thought of as freely definable, infinitely thin, shaped areas that form part of an assembly. Faces can partially obscure or completely cover other faces and geometry lines (depending upon their z-values).

In simple terms, you could imagine faces as pieces of paper, laid one on top of another, thus obscuring elements with a lower z-value.

Figure 6. Faces - With Z-Values 0 and 1 on page 82 shows the faces of two components (one with z-value 0 and the other with z-value 1).

What are Z-Values?

A z-value is the numerical value assigned to an element to position it in the drawing at the appropriate logical level in the z-direction.

See Figure 7. Visualizing Z-Values on page 83.
Figure 7. Visualizing Z-Values

A face or line with a higher z-value covers a face or line with a lower z-value.

Figure 8. Z-Values 0, 1 and 2 on page 83 shows 3 faces assigned the z-values 0, 1 and 2.

Figure 8. Z-Values 0, 1 and 2

Hatches are treated as faces, this means hatched areas can cover geometry and faces. Hatches that are partially covered are displayed partially obscured.

Construction geometry, texts, leader lines and dimensions are always visible.

Note

A face does not necessarily need to have the same z-value as its boundary lines. In this case the boundary lines of the face may be partially covered by the face itself (solid lines may appear dashed in some cases). The linetype of the boundary lines is not changed.

Checking Z-Values

You can check the z-values of:

- Elements
- Shared parts
- Elements in shared parts

The z-value will be displayed on the User Prompt Line.
Checking the Z-Value of an Individual Element

To check the z-value of an individual element:

1. Click **2D Access** and then, in the **Hidden** group, click **Inquire Z Value**.
2. Click **Absolute**.
3. Select the element.
   
   Creo Elements/Direct 2D Access displays the absolute z-value of the element in the user input line.

Checking the Minimum or Maximum Z-Value in an Assembly Drawing

To check the minimum z-value:

1. Click **2D Access** and then, in the **Hidden** group, click **Inquire Z Value**.
2. Click **Minimum**.
   
   Creo Elements/Direct 2D Access displays the minimum z-value in the assembly drawing in the user input line.

To check the maximum z-value:

1. Click **2D Access** and then, in the **Hidden** group, click **Inquire Z Value**.
2. Click **Maximum**.
   
   Creo Elements/Direct 2D Access displays the maximum z-value in the assembly drawing in the user input line.

Checking the Z-Value of a Shared Part

To find the computed z-value of a shared part:

1. Click **2D Access** and then, in the **Hidden** group, click **Inquire Z Value**.
2. Click **Shared Part Offset**.
3. Select the shared part.

   Creo Elements/Direct 2D Access computes the z-value as the sum of the shared part's z-value and that of the shared parent part.
Checking the Z-Value of an Element in a Shared Part

To find the z-value of an element in a shared part:

1. Click **2D Access** and then, in the **Hidden** group, click **Inquire Z Value**.
2. Click **Shared Part Element**.
3. Select the element in the shared part.
   Creo Elements/Direct 2D Access displays the element’s z-value in the user input line.

Generating Hidden Lines

To generate hidden lines:

- Click **2D Access** and then, in the **Hidden** group, click **Generate**.

When you click **Generate** to generate hidden lines, Creo Elements/Direct 2D Access does the following:

- Geometry is modified by splitting geometric components if they are covered by faces with a higher z-value.
- Splines are converted.
- Shared parts are unshared.
- The parts tree, starting from the current part, will be smashed.

Showing Hidden Lines On or Off

After you generate hidden lines, you can show or hide them in the drawing.

To display the hidden lines in the drawing:

1. Click **2D Access** and then, in the **Hidden** group, click the arrow next to **Hidden Mode**.
2. Click **On** to display the hidden lines in the drawing.
3. Click **Off** to hide the hidden lines in the drawing.

Showing Hidden Lines as Dashed Lines

To view hidden lines as dashed lines:
1. Click 2D Access and then, in the Hidden group, click the arrow next to Hidden Mode.

2. Click ☑ On to display the hidden lines in the drawing.

3. Click ☑ Show Hidden.

**Plotting Hidden Lines**

If you are plotting your drawing, note that it is not possible to plot face colors.

In order to suppress plotting of hidden lines you must set the hidden line linetype and color appropriately. For more information, see the `PLOT_TRANSFORMATION` command in the online help.
Using Construction Geometry

Drawing Construction Lines ................................................................. 88
Drawing Construction Circles ............................................................... 92

This section shows how to add construction lines and circles to a drawing displayed in Creo Elements/Direct 2D Access. Construction geometry can be used to check the alignment of existing geometry.

Construction lines differ from real lines in that they are considered to be of infinite length. Only full construction circles can be drawn.

When creating construction lines you can either click positional points in the Creo Elements/Direct 2D Access drawing area, or you can enter the coordinates (separated by a comma) in the user input line.
**Drawing Construction Lines**

To draw construction lines:

1. Click **2D Access** and then, in the **Draw** group, click the arrow next to **2 Points**.

2. Click the required **Construction Line** button and perform the associated procedure.

<table>
<thead>
<tr>
<th>Construction Line Button</th>
<th>Purpose</th>
<th>Procedure</th>
</tr>
</thead>
</table>
| ![2 Points]              | Draw construction lines using two points. | a. Type the angle for the construction line in the user input line and press ENTER.  
b. Specify the second point.  
Alternatively, click the two points for the construction line. |
| ![Horizontal]           | Draw horizontal construction lines. | a. Type the y coordinate of the horizontal construction line in the user input line and press ENTER.  
or  
Click a point through which the horizontal construction line must pass.  
b. To draw several horizontal construction lines, type their y coordinates, separated by spaces, in the user input line and press ENTER. |
<p>| ![Vertical]              | Draw vertical construction lines. | a. Type the x |</p>
<table>
<thead>
<tr>
<th>Construction Line Button</th>
<th>Purpose</th>
<th>Procedure</th>
</tr>
</thead>
<tbody>
<tr>
<td>Button</td>
<td></td>
<td>coordinate of the vertical construction line in the user input line and press ENTER. or Click a point through which the vertical construction line must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>b. To draw several vertical construction lines, type their x coordinates, separated by spaces, in the user input line and press ENTER.</td>
</tr>
<tr>
<td>Parallel</td>
<td>Draw construction lines parallel to an existing line.</td>
<td>a. Type the separation distance of the line in the user input line and press ENTER. b. Click any existing line and then click the side on which the parallel construction line should be drawn. Multiple lines can be drawn at the previously set separation distance by clicking the original lines and the desired sides. Alternatively: a. Click any existing line.</td>
</tr>
<tr>
<td><strong>Construction Line Button</strong></td>
<td><strong>Purpose</strong></td>
<td><strong>Procedure</strong></td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-------------</td>
<td>---------------</td>
</tr>
<tr>
<td></td>
<td>b. Specify a point for the parallel construction line to pass through. You can draw multiple parallel construction lines by specifying further points for the lines to pass through. Alternatively, draw a set of parallel lines from an original line. For example, if you enter line separations as 10 20 30 40, four parallel lines are drawn at the given distances from the indicated line.</td>
<td></td>
</tr>
<tr>
<td><strong>Perpendicular</strong></td>
<td>Draw a construction line perpendicular to an existing line.</td>
<td>a. Click any existing line. b. Specify a point through which the perpendicular construction line must pass.</td>
</tr>
<tr>
<td><strong>Point &amp; Angle</strong></td>
<td>Draw a construction line at an angle.</td>
<td>a. Specify a point through which the construction line must pass. b. Specify a second point for the construction line. or Type the angle of the line with respect to the x axis in the user interface.</td>
</tr>
<tr>
<td>Construction Line Button</td>
<td>Purpose</td>
<td>Procedure</td>
</tr>
<tr>
<td>--------------------------</td>
<td>---------</td>
<td>-----------</td>
</tr>
<tr>
<td>Button</td>
<td></td>
<td>input line and press ENTER. A positive angle is measured in a counterclockwise arc from the horizontal. You can set the angle units in your Creo Elements/Direct 2D Access environment.</td>
</tr>
</tbody>
</table>
| **Tangent**              |         | a. Click the approximate point of tangency.  
b. Type the angle of the construction line in the user input line and press ENTER.  
*Note* The angle is measured in a counterclockwise arc from the horizontal. Alternatively, click the approximate point of tangency on the circle or spline and then specify a point through which the construction line must pass. |
<p>| <strong>Tangent by 2</strong>         | Draw a construction line as a tangent to two circles or splines. Click the approximate point of tangency on each of the two circles or splines. |</p>
<table>
<thead>
<tr>
<th>Construction Line Button</th>
<th>Purpose</th>
<th>Procedure</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>The construction line is drawn through the points of tangency that are closest to the points you indicated.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Specify the two end points of the line.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>A construction line is drawn perpendicular to the line at the appropriate position.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>To divide the line in two unequal parts:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>a. Type the bisector factor (value for the ratio of division) in the user input line and press ENTER.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>b. Specify first point on the line.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>c. Specify second point on the line.</td>
</tr>
</tbody>
</table>

### Bisector Angle

<table>
<thead>
<tr>
<th>Bisector Angle</th>
<th>Draw a construction line bisecting an angle.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>a. Specify the first line.</td>
</tr>
<tr>
<td></td>
<td>b. Specify the second line.</td>
</tr>
<tr>
<td></td>
<td>A construction line, defining the bisector angle, is drawn.</td>
</tr>
</tbody>
</table>

### Drawing Construction Circles

To draw a construction circle:

1. Click **2D Access** and then, in the **Draw** group, click the arrow next to **Center & Radius**.
2. Click the required **Construction Circle** button and perform the associated procedure.
<table>
<thead>
<tr>
<th>Construction Circle Button</th>
<th>Purpose</th>
<th>Procedure</th>
</tr>
</thead>
</table>
| ![Center & Radius](image) | Draw a construction circle by center and circumference point. | a. Specify the center of the construction line.  
b. Type the radius of the construction circle in the user input line and press ENTER.  
Alternatively, specify a point on the circumference.  
If multiple concentric circles are required, type the desired radii in the user input line and press ENTER or specify multiple peripheral points. |
| ![3 Points](image) | Draw a construction circle by three points on the circumference. | Specify two circumference points.  
The construction circle drawn varies with the movement of your cursor till you specify the third point. |
| ![Tangent & Center](image) | Draw a construction circle by a center and element. | a. Click the approximate point of tangency on the existing element.  
b. Specify the center of the construction circle to be drawn. |
| ![Concentric](image) | Draw concentric circles. | a. Click the existing circle.  
b. Type the radial offset of the new construction circle from the existing one, that is, the difference between the two radii, in the user |
<table>
<thead>
<tr>
<th>Construction Circle Button</th>
<th>Purpose</th>
<th>Procedure</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>input line and press ENTER.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>c. To draw several concentric construction circles, type the appropriate radial offsets separated by spaces in the user input line and press ENTER.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Click existing points through which the construction circles must pass.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or</td>
</tr>
<tr>
<td>Construction Circle Button</td>
<td>Purpose</td>
<td>Procedure</td>
</tr>
<tr>
<td>----------------------------</td>
<td>---------</td>
<td>-----------</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Specify a peripheral point on the construction circle. Creo Elements/Direct 2D Access calculates the best solution, or informs you that no solution is possible.</td>
</tr>
<tr>
<td><img src="image" alt="Tangent by 3" /></td>
<td>Draw a construction circle by three elements.</td>
<td>Click the approximate point of tangency of the construction circle on each of the three existing elements (none of which must be a spline).</td>
</tr>
</tbody>
</table>
Revision Checking

Using Revision Checking ......................................................................................................................................... 97

This chapter describes how to use the buttons and options that allow you to compare similar drawings. This facility is particularly useful in design offices where successive drawings are revised and you need to identify the differences between revisions.

The differences between the original and revised drawings are shown in color.
Using Revision Checking

To use the revision checking facility:

1. Click **Compare** and then, in the **Setup** group, click **Load Files**.
   
   The **Load** dialog box opens.

2. In the **Original** box, type the name of the original drawing file.
   
   For example, **dt_cs_rev06**.
   
   Alternatively, click **Browse** to select the original drawing file.

3. In the **Revised** box, type the name of the revised drawing file.
   
   For example, **dt_cs_rev10**.
   
   Alternatively, click **Browse** to select the revised drawing file.

4. Click **OK**.
   
   Creo Elements/Direct 2D Access displays the two drawings overlapping.

5. Click **Compare** and then, in the **Compare** group, click **Geometry**.
   
   Creo Elements/Direct 2D Access compares the location of the geometry and texts (without comparing the parts structure) in the two drawings and shows the result of the comparison in different colors according to the following defaults:

<table>
<thead>
<tr>
<th>Color</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blue</td>
<td>Identical geometry elements in both drawings</td>
</tr>
<tr>
<td>Green</td>
<td>Differences in the original drawing</td>
</tr>
<tr>
<td>Red</td>
<td>Differences in the modified drawing</td>
</tr>
</tbody>
</table>

6. Click **Compare** and then, in the **Compare** group, click **Annotation**.
   
   In addition to **Geometry**, **Annotation** also compares the properties of the geometry and texts — linetype, color, text attributes, info texts — and the dimensions and hatches in both drawings.

7. Click **Compare** and then, in the **Compare** group, click **Parts**.
   
   In addition to **Annotation**, **Parts** compares the parts structure in both drawings.
**Note**

If you modify a drawing solely by a scaling factor, clicking Parts displays all elements in red (indicating a difference). However, Geometry and Annotation display elements and annotation in blue (indicating identical elements).

---

**Note**

Both drawings must have the same location compared to the drawing origin to get meaningful results from the comparison.

---

**Viewing Single Drawings**

When both drawings are loaded, you can toggle between them using the buttons in the Show group of the Compare tab.

To view the original drawing only:

- Click Compare and then, in the Show group, click Original.

To view the revised drawing only:

- Click Compare and then, in the Show group, click Revised.

To view both the drawings:

- Click Compare and then, in the Show group, click Both.

---

**Resetting Colors and Showing Differences**

The colors generated after selecting a button in the Compare group can be reset to their original colors.

To view the drawings in the original colors:

- Click Compare and then, in the Show group, click Reset.

To view the drawing elements in different colors depending on the result of the last comparison:
• Click Compare and then, in the Show group, click Differences.

Changing the Color Scheme
To change the color scheme for changes in the original drawing:

1. Click Compare and then, in the Setup group, click the arrow next to Original.
2. Click a color.

To change the color scheme for changes in the revised drawing:

1. Click Compare and then, in the Setup group, click the arrow next to Revised.
2. Click a color.

To change the color scheme for identical elements:

1. Click Compare and then, in the Setup group, click the arrow next to Identical.
2. Click a color.

The color changes take effect with the next redraw.
Using URLs with Creo Elements/Direct 2D Access

Listed URLs ................................................................. 101
Highlighting the Element or Part to which a Given URL is Attached ....................... 101
Accessing a URL .................................................................. 101
Using URL Elem. in Show Dialog Box ........................................ 102
Switching URLs On & Off ...................................................... 102
Assigning a Color to a URL .................................................... 102
Further Information ................................................................ 103

Creo Elements/Direct Drafting enables you to attach any industrial standard Web page to drawings, parts and elements. All URLs used by Creo Elements/Direct Drafting drawings, parts and elements are handled using the buttons in the URL group on the 2D Access tab.
Listing URLs
To display a list of the URLs attached to the current drawing or to a part or to an element in the drawing:

1. Click **2D Access** and then, in the **URL** group, click the arrow next to [URL].
2. Click any of the following:
   - Click **Element** to list the URLs for an element or a group of elements. Then, select the element or group of elements.
     The **Element URLs** dialog box opens. It lists all the URLs associated with the element or group of elements.
   - Click **Part** to list the URLs for a part other than the current part. Then select the part.
     The **Part URLs** dialog box opens. It lists all the URLs associated with the part.

Highlighting the Element or Part to which a Given URL is Attached
To highlight the element or part to which a URL is attached:

1. Click **2D Access** and then, in the **URL** group, click **Show**.
   The **Global URLs** dialog box opens.
2. Select the URL.
3. Click **Show Elem.** to highlight the element associated with the URL.
4. Click **Show Parts** to highlight the part associated with the URL.

Accessing a URL
To access a URL attached to a part or element in a drawing:

1. Click **2D Access** and then, in the **URL** group, click the arrow next to [URL].
2. Click any of the following:
   - Click **Element** to list the URLs for an element or a group of elements. Then, select the element or group of elements.
     The **Element URLs** dialog box opens.
• Click Part to list the URLs for a part other than the current part. Then select the part.

The Part URLs dialog box opens.

3. Select the URL you want to access.

4. Click Browse to access this URL by means of your default Web browser or navigator.

You can also click Browse in the Global URLs dialog box to access the selected URL by means of your default Web browser or navigator.

Using URL Elem. in Show Dialog Box

To open the URL Elem. tab of the Show dialog box:

1. Click File ➤ Settings ➤ Show.
   Alternatively, click 2D Access and then, in the Utilities group, click Show.
   The Show dialog box opens.

2. Click the URL Elem. tab.

In the URL Elem. tab, you can:

• Switch URLs on and off.
• Box an area to show its URLs.
• Select a color for each URL.

Switching URLs On & Off

To switch URLs on or off:

1. Click File ➤ Settings ➤ Show.
   Alternatively, click 2D Access and then, in the Utilities group, click Show.
   The Show dialog box opens.

2. Click the URL Elem. tab.

3. Select the URL you want to switch on or off.

4. Click On or Off to display or hide all the elements associated with the selected URL, respectively.

Assigning a Color to a URL

You can color a URL to aid visualization.
To color a URL:

1. Click **File ▶▶ Settings ▶▶ Show**.
   
   Alternatively, click **2D Access** and then, in the **Utilities** group, click **Show**.
   
   The **Show** dialog box opens.

2. Click the **URL Elem.** tab.

3. Select a URL.

4. Select a color from the selection list and click **Color**.
   
   Creo Elements/Direct 2D Access indicates the element in the selected color that contains the URL.

**Further Information**

For further technical information about layers and infos, refer to the Creo Elements/Direct 2D Access help system.

Type **help layer** or **help info** or **help url** in the Creo Elements/Direct 2D Access user input line and press ENTER.

Creo Elements/Direct 2D Access displays further information about using layers or infos or URLs with Creo Elements/Direct Drafting.
12

Linking and Embedding OLE Objects

Inserting an OLE Object ................................................................. 105
Editing an OLE Object in Creo Elements/Direct 2D Access .............. 106
Using the OLE Browser ................................................................. 107

Files (such as spreadsheets, graphics or text pages) created in external applications can be included in Creo Elements/Direct 2D Access by inserting associated Object Linking and Embedding (OLE) objects.
Inserting an OLE Object

To insert an OLE object in a drawing using Creo Elements/Direct 2D Access:

1. Click File ▶ Import/Export ▶ Import OLE.
   
   The Insert Object dialog box opens. It lists all applications on your system that provide OLE capability.

2. In the Object Type box, select an application.

3. Select one of the following:
   - Create New
   - Create from File

Create New

Create New inserts a new OLE object of the selected application in your drawing.

To create a new OLE object:

1. In the Object Type box, select an object type.

2. Click the Display As Icon check box to represent the OLE object by the associated application icon in Creo Elements/Direct 2D Access.

   Optionally, click Change Icon to select a different icon for the OLE object.

3. Click OK.

   The Open dialog box opens.

4. Using the File Browser, select the OLE object.

   The default OLE object name is displayed in the user input line.

5. Retain the default OLE object name or type a name for the OLE object in the user input line and press ENTER.

6. Specify the insertion position for the OLE object in Creo Elements/Direct 2D Access.

   The OLE object is displayed in the Creo Elements/Direct 2D Access drawing.

Create from File

Create from File inserts the contents of a file as an object in your document so that you can activate the object using the application in which it was created.

To create an OLE object from an existing file:

1. Click Browse and browse to the file you want to link using the File Browser.
2. Click **Open**.

3. Optionally, click the **Link** check box to link the OLE object to its source application such that changes in the original file are reflected in the OLE object in Creo Elements/Direct 2D Access.

4. Click the **Display As Icon** check box to represent the OLE object by the associated application icon in Creo Elements/Direct 2D Access. Optionally, click **Change Icon** to select a different icon for the OLE object.

5. Click **OK**.

   The default OLE object name is displayed in the user input line.

6. Retain the default OLE object name or specify a name for the OLE object in the user input line.

7. Specify the insertion position for the OLE object in Creo Elements/Direct 2D Access.

   The OLE object is displayed in the Creo Elements/Direct 2D Access drawing.

---

**Editing an OLE Object in Creo Elements/Direct 2D Access**

Once the OLE object is inserted in the drawing, you can edit it as described in the following sections.

---

### Arranging OLE Objects

To arrange OLE objects:

1. Click **2D Access** and then, in the **OLE** group, click the arrow next to **Level**.

2. Click **To Front**, **To Back**, **Forward** or **Backward**, or **In Front Of** or **Behind**.

3. Select the **OLE** object you want to arrange.

### Activating an OLE Object

By activating an OLE object, you open the underlying file in its source application for editing. The OLE objects created by using **Create from File** reflects the changes in the underlying file.

To activate an OLE object:

1. Click **2D Access** and then, in the **OLE** group, click **Activate**.
2. Click the OLE object you want to activate.
You can also use the OLE Browser to activate an OLE object.

Renaming an OLE Object
You can rename an existing OLE object in a drawing.
To rename an OLE object:

1. Click 2D Access and then, in the OLE group, click Rename.
2. Select the OLE object to be renamed.
3. Type the new name of the OLE object in the user input line and press ENTER.
You can also use the OLE Browser to rename an OLE object.

Deleting an OLE Object
To delete an OLE object from your drawing:

1. Click 2D Access and then, in the OLE group, click Browser.
   The OLE Browser opens.
2. Select the OLE in the OLE Browser.
3. Click Delete.

Hiding and Showing OLE Objects
To improve system performance or to reduce screen clutter, OLE objects can be hidden or displayed using Show or Hide in the OLE Browser. If the drawing includes several OLE objects, you can choose to hide individual or all OLE objects. In the OLE Browser, select the OLE object and click the following:

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show</td>
<td>Unhides a hidden OLE object.</td>
</tr>
<tr>
<td>Hide</td>
<td>Hides an OLE object.</td>
</tr>
<tr>
<td>Box</td>
<td>Hides an OLE object but places a reference frame around the hidden image.</td>
</tr>
<tr>
<td>Icon</td>
<td>Displays an icon that represents the OLE object.</td>
</tr>
</tbody>
</table>

Using the OLE Browser
To open the OLE Browser:

- Click 2D Access and then, in the OLE group, click Browser.
The **OLE Browser** displays the following information about the OLE objects currently included in your drawing:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The name you specified for the OLE object</td>
</tr>
<tr>
<td>Z-level</td>
<td>Numerical value for the &quot;hidden&quot; level assigned to an image in the drawing</td>
</tr>
<tr>
<td>Show</td>
<td>Status of the <strong>SHOW</strong> command; ON, OFF, or ICON</td>
</tr>
<tr>
<td>X-Scale</td>
<td>Scaling factor in the x-direction</td>
</tr>
<tr>
<td>Y-Scale</td>
<td>Scaling factor in the y-direction</td>
</tr>
<tr>
<td>OLE Type</td>
<td>OLE object type</td>
</tr>
<tr>
<td>Program ID</td>
<td>Application object type</td>
</tr>
<tr>
<td>Class ID</td>
<td>OLE object class ID</td>
</tr>
</tbody>
</table>

Using the **OLE Browser**, you can perform the following actions on the OLE objects:

- Activate
- Delete
- Show
- Hide
- Box
- Convert to icon
- Rename
- Save
This chapter describes how to print and plot drawings and how to produce screen dumps.
Using the Print Manager

Creo Elements/Direct 2D Access spools all plots and screendumps either to the Print Manager or to the Clipboard, and not directly to an output device.

The Print Manager controls device selection, configuration, and spooling for the printers and plotters on your system. Once you send a plot from Creo Elements/Direct 2D Access to the Print Manager, the Print Manager takes over the process of producing the final output. By setting REQUEST_PRINT_SETUP, you can directly access the Print Manager's setup dialogs each time you plot or screendump.

The Clipboard temporarily stores a plot or screendump so that it can be electronically transferred or "pasted" into another application.

Note

Depending on the output device or devices on your system, the Print Manager may allow you to set several printer or plotter options in addition to those offered by Creo Elements/Direct 2D Access. Refer to your Windows documentation and hardware manuals for information on configuring your printer or plotter to work with Windows.

Creating a Print Configuration

To facilitate the creation of consistent print or plot output, Creo Elements/Direct 2D Access enables you to create any number of print configurations.

To create a print configuration:

1. Click File ▶ Print ▶ Print Setup.

   Alternatively, click Print Preview and Print on the Quick Access Toolbar or press CTRL+P.

   The Print dialog box opens.

2. Define the settings for the new print configuration.

   These settings are discussed in the following sections of this chapter.

3. In the Print configuration area, click Settings.

   The Print Configurations dialog box opens.

4. Type a name for the print configuration in the text box and click Add to add this new print configuration name to the list of print configurations.
Creo Elements/Direct 2D Access prompts for confirmation to add the print configuration to the list.

5. Click **OK**.

6. To save the print configuration for future use, select it and then, click **Store**. The **Store Print Configurations** dialog box opens.

7. In the **Name** box, type a name for the print configuration file (for example, `my_print.m`) for your print configuration file.

   **Note**

   This filename does not have to be the same as the print configuration name. However, ensure that the filename is readily identified.

8. Click **Save**.

9. Click **Close**.

**Example of a Print Configuration**

An example of a Creo Elements/Direct Drafting or Creo Elements/Direct 2D Access print configuration follows:

```
{ User specific customization }

WIN_PRT_MGR PAPER 'a3' ORIENTATION LANDSCAPE COPIES 1 END

PLOT_SCALE AUTO

PLOTTER_TYPE ADD MSWINDOW_GDI_PRINTER PRT_DRIVER 'HP LaserJet 1100' 'department_1' END

WIN_PRT_MGR PAPER 'a4' ORIENTATION PORTRAIT COPIES 1 END

PLOT_SCALE AUTO

PLOTTER_TYPE ADD MSWINDOW_GDI_PRINTER PRT_DRIVER 'HP DeskJet' 'department_2' END

WIN_PRT_MGR PAPER 'a4' ORIENTATION LANDSCAPE COPIES 1 END
```
PLOT_SCALE AUTO

PLOTTER_TYPE ADD MSWINDOW_GDI_PRINTER PRT_DRIVER 'HP LaserJet 1100' 'department_3' END

PLOTTER_TYPE 'department_3'

{ plot it }

PLOT 0,0 0 all BW_IMG NORM_VIDEO

The settings in this customize_p.m print configuration file imply the following:

- One copy of the drawing is printed to A4 paper in landscape orientation.
- The drawing is scaled to fit.
- The PLOTTER_TYPE variable is set to department_3. This is the printer that will be used as the output device.
- The entire drawing is printed in normal (as opposed to inverse) video.

Reusing a Saved Print Configuration

When you quit Creo Elements/Direct 2D Access, the system automatically saves your current print settings. These settings are used when you start Creo Elements/Direct 2D Access again.

You can see and modify your current configuration file by opening
<application data path>\PTC\Creo Elements Direct Drafting [version]\[version]\print_configurations\current_print_cfg.m.

You can also use existing or create your own configuration files. If you use the name convention (print_cfg_<configuration name>.m) for your own configuration files and place them in the print_configurations subdirectory, these files appear in the Print dialog box as a Print configuration. Configurations that you create with the Print dialog box are automatically stored in this subdirectory when you store your configuration.

To re-use binary legacy print configuration files (with file name <print configuration>.cfg) from a CoCreate Drafting version < 13.00:

1. Click File ▶ Print ▶ Print Setup.

   The Print dialog box opens.
Alternatively, press CTRL+P to open the Print dialog box.

2. In the Print configuration area, click Settings.
   The Print Configurations dialog box opens.

3. Click Load.
   The Load Print Configurations dialog box opens.

4. Select the print configuration file and click Open.
   The print configurations appears in the Print Configurations list.

5. Select the print configuration.

6. Click Close.
   The Print dialog box settings change to the settings defined for the loaded print configuration.

### Defining the Print or Plot Settings

Before printing or plotting a drawing, you should define exactly what will be printed or plotted and how the drawing will be printed or plotted.

### Setting the Plot or Print Destination

Creo Elements/Direct 2D Access can send plots and screen dumps either to the Windows Print Manager or to the Clipboard. You usually send plots to the Print Manager for output on the system's default printer or plotter. Send a plot to the Clipboard if you want to insert it in another Windows application. You can also define the output destination of a file by clicking Browse in the Print dialog box.

---

**Note**
Creo Elements/Direct 2D Access automatically derives the extension for the output file according to the selected printer or plotter.

---

### Selecting a Printer or Plotter

To set a printer or plotter:

1. Click File ➤ Print ➤ Print Setup.
   The Print dialog box opens. The Printer tabbed page opens by default.
   Alternatively, press CTRL+P to open the Print dialog box.
2. In the **Printer** area, select the printer or plotter in the **Name** box.
   
   Note the boxed plus sign beside some generic options.
   
   Expand the plus sign and select the model number, if required.

3. Click **Properties** and set the properties (such as the paper size and the resolution) of this printer or plotter.

If the printer or plotter you want to use is not included in this list, use standard Microsoft Windows techniques to install, set up and configure this printer or plotter.

**Note**

Refer to your Windows documentation and hardware manuals for information on configuring your printer or plotter to work with Windows.

---

**Routing the Print or Plot Output to a File**

To send the print or plot output to a file:

1. Click **File ▶️ Print ▶️ Print Setup**.
   
   The **Print** dialog box opens. The **Printer** tabbed page opens by default.
   
   Alternatively, press CTRL+P to open the **Print** dialog box.

2. In the **Printer** area, click the **Print to File** check box.

3. In the **Destination** box, type the file path and file name.

Ensure that you match the printer or plotter with the format of the output file. For example:

- If you want to create an HP-GL file, select an HP-GL compatible plotter.
- If you want to create a PostScript file, select a PostScript printer.
- If you want to create a PDF file, select the PDF Generic option.

After you click **Print**, the file is saved at the destination path with the specified name.

---

**Setting the Paper Size and Number of Copies**

To set the paper size and number of copies for printing or plotting:

1. Click **File ▶️ Print ▶️ Print Setup**.
   
   The **Print** dialog box opens. The **Printer** tabbed page opens by default.
Alternatively, press CTRL+P to open the Print dialog box.

2. In the Paper area, select the paper size in the Format box.

   To set a custom paper size, select Custom size in the Format box and define the size of the paper.

3. If you have a multi-sheet drawing, click the Use sheet format check box to automatically set the format and orientation of each sheet based on the sheet size.

4. To set the number of copies, type or select the number of copies in the Copies box.

**Setting Orientation**

To set the paper orientation:

1. Click File ▶ Print ▶ Print Setup.

   The Print dialog box opens. The Printer tabbed page opens by default.

   Alternatively, press CTRL+P to open the Print dialog box.

2. In the Orientation area, click Portrait or Landscape.

---

**Note**

If you set the paper size such that the height and width are equal, the orientation is set to landscape by default.

**Positioning Your Drawing**

To position your drawing:

1. Click File ▶ Print ▶ Print Setup.

   The Print dialog box opens.

   Alternatively, press CTRL+P to open the Print dialog box.

2. Click the Drawing tab and then, in the Position area, click any of the following:

   - Center (default setting) to position your drawing at the center of the paper.

     Creo Elements/Direct 2D Access places the bounding box centered on the paper.
• **Left** to position your drawing at the lower left corner prior to printing or plotting.

  Creo Elements/Direct 2D Access places the bounding box in the lower left corner of the paper.

**Specifying Linear Offsets**

To specify linear offsets for **Center** and **Left**:

1. Click **File ▶ Print ▶ Print Setup**.

   The **Print** dialog box opens.

   Alternatively, press CTRL+P to open the **Print** dialog box.

2. Click the **Drawing** tab and then, in the **Position** area, type an offset in the X direction and in the Y direction in the **X Offset** box and **Y Offset** box, respectively, for **Center** and **Left**. The print or plot output is moved accordingly in the X direction and/or Y direction.

   These offsets are interpreted in terms of the current length unit (such as mm) set up for your Creo Elements/Direct 2D Access environment.

**Setting a Rotation Angle**

To rotate the drawing output to the printer or plotter:

1. Click **File ▶ Print ▶ Print Setup**.

   The **Print** dialog box opens.

   Alternatively, press CTRL+P to open the **Print** dialog box.

2. Click the **Drawing** tab and then, in the **Position** area, type the angle of rotation in the **Rotation** box.

   The angle of rotation is interpreted in terms of the current angular units set up for your Creo Elements/Direct 2D Access environment.

**Selecting the Drawing Range for Printing or Plotting**

You can print/plot the complete drawing, the current viewport, or a boxed area.

To select the drawing range for a print or plot:

1. Click **File ▶ Print ▶ Print Setup**.

   The **Print** dialog box opens.

   Alternatively, press CTRL+P to open the **Print** dialog box.
2. Click the **Drawing** tab and then, in the **Range** area, click any of the following:

- **All** (default setting) to print or plot the entire drawing — irrespective of the current viewport contents.
- **Sheet** to print each Annotation sheet on a separate page.
- **Viewport** to print or plot the contents of the current viewport.

For example, if you are currently viewing a part, only the elements of that part contained within the window of the current viewport will be printed or plotted.

- **Box** to print or plot a specific area of a viewport.

Click **Pick** and then use your cursor in the drawing viewport to specify two opposite corners of a box. Only the contents of the boxed area will be printed or plotted. For example, suppose you are currently viewing a part, and the other parts or elements exist in the same area, but are not displayed. If you click **Box**, all the drawing elements existing in the boxed area (both displayed and hidden), are plotted.

### Setting the Plot Scale

This section describes how to set the scale to be used for the subsequent print/plot output.

You can set a scale factor or automatically scale the drawing as large as possible within the limits of your paper.

To set the print or plot scale factor:

1. Click **File** ▶ **Print** ▶ **Print Setup**.

   The **Print** dialog box opens.

   Alternatively, press CTRL+P to open the **Print** dialog box.

2. Click the **Drawing** tab and then, in the **Scale** area, click any of the following:

   - Click **Fit** to scale the print or plot output (as large as possible) within the limits of the defined paper size.
   - Click **Factor** (default setting) and type the required scaling factor in the **Factor** box.

   The entire print or plot output is scaled, but dimension values are not affected.

   *Figure 9. Operation of Print/Plot Scale on page 118 shows the operation of print/plot scale.*
Figure 9. Operation of Print/Plot Scale

If you set the plotting scale such that the drawing is too large for the paper, Creo Elements/Direct 2D Access warns you at the start of a plot by displaying the maximum scale possible. Pressing ESC aborts the plot and allows you to reset the plot scale. Otherwise, press SPACE BAR and the plot will continue, cutting off elements outside the paper format.

Setting the Content of the Print or Plot Output

Creo Elements/Direct 2D Access enables you to specify what will be included in the print/plot output:

To set the content of the print or plot output:

1. Click **File ▶ Print ▶ Print Setup**.

   The Print dialog box opens.

   Alternatively, press CTRL+P to open the Print dialog box.

2. Click the **Drawing** tab and then, in the **Content** area, click any of the following:

   - **Drawing** to print or plot the drawing using standard drawing conventions.
     
     Drawing lines, dimensions, text and hatching will be included in the print/plot output. Construction lines, spotlights for parts and so on are omitted. The drawing appears as a normal drawing irrespective of the screen status (that is, the plot is unaffected by the Show functions).

   - **Current Show** to print or plot the drawing as shown in the viewport.
     
     a. Select a viewport in which you can set your own drawing conventions.
     b. Use the Show functions to set the desired attributes.
     c. Click **Current Show**.

   The subsequent plots will contain whatever drawing conventions you have selected in the current viewport.
Defining Color Settings

Creo Elements/Direct 2D Access allows you to define the True Color, Plot Transformations and True Color & Screen Trans settings for your printer or plotter environment.

To define the color settings of your drawing:

1. Click File ▶ Print ▶ Print Setup.
   The Print dialog box opens.
   Alternatively, press CTRL+P to open the Print dialog box.
2. On the Drawing tab, in the Colors area, click Pens.
   The Plot Transformation dialog box opens.
3. In the Plot Transformation list, click True Color, or Plot Transformations, or True Color & Screen Trans.

True Color

In the Plot Transformations list, select True Color to create a color plot of your drawing that is suitable for output to color output devices capable of producing color rastering.

This feature is available on PostScript Level 2 printers and HP-GL/2 printers. This means, for example, if you have access to an HP DesignJet 650C color printer you can print any number of colors up to the capability of the printer.

Note

If you have a drawing that contains elements in white, and specify truecolor plotting, the elements are drawn in white. Normally, when sending drawings to a pen-plotter, the white elements on the screen are converted to black.
The following settings are available:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit</td>
<td>Displays a separate Pen Format dialog box to set a custom plot transformation map.</td>
</tr>
<tr>
<td>Reset</td>
<td>Restores the default Plot Transformations settings.</td>
</tr>
<tr>
<td>Default Color</td>
<td>Applies a default color-to-pen assignment map.</td>
</tr>
<tr>
<td>Default B/W</td>
<td>Applies a monochrome color-to-pen assignment map.</td>
</tr>
<tr>
<td>Default GDI</td>
<td>Applies a 125 – color plot pen color-to-pen assignment map.</td>
</tr>
</tbody>
</table>

The Plot Transformation map enables you to map the colors and pensizes of elements in your drawing for output to a printer or plotter.

To set up the Plot Transformations map:

1. In the Plot Transformations map, click the row you want to change.
   - The selected row is highlighted.
2. Click Edit.
   - The Pen Format dialog box opens.
3. In the Drawing area of the Pen Format dialog box:
   a. In the Linetype box, select a "from" linetype and then, in the To box, select a "to" linetype to which you want to map the "from" linetype. For example, if you want all dashed lines in the drawing to be plotted as dotted lines, map "from" dashed "to" dotted.
      - If you want to map all linetypes in the drawing to the associated linetypes on the plotter, click the All Linetypes check box.
   b. Click the Color Range check box and then, in the From (RGB) box, type the RGB value for a "from" color. In addition, in the To (RGB) box, type the RGB value for a "to" color to which you want to map the "from" color.
      - If you want to map all colors in the drawing to the associated colors on the plotter, click the All Colors check box.
   c. In the Pen Size box, type a "from" pensize and then, in the To box, type a "to" pensize to which you want to map the "from" pensize. For example, if you want pensize 0.3 in the drawing to be plotted by a 0.45 pen on the plotter, type 0.3 in the Pen Size box and 0.45 in the To box.
      - If you want to map all pensizes in the drawing to the associated pensizes on the plotter, click the All Pen Sizes check box.
Assigning a Specific Pen to a Given Linetype or Color Combination

To assign a specific plotter pen to a given linetype or color combination in the Plot Transformations map:

1. In the Color box of the Drawing area, select the color.
2. In the Linetype box of the Drawing area, select the linetype.
3. In the Linetype box of the Plotted As area, select the linetype to be plotted.
   If you want to print or plot using the linetype that is used in the drawing, click the Same Linetype check box.
4. In the Pen box, type or select the pen number.
5. In the Pen Width box, type a pen width.
   If you want to print or plot using the pen width that is used in the drawing, click the Same Pen Width check box.
6. Click OK to add the changed row to the Plot Transformations map.

For example, assume that you want to use a 0.3 mm blue pen to plot all dashed blue lines of the drawing. This pen is pen # 5 in your plotter.

1. In the Linetype box, select the dashed linetype and in the Color box, select Blue in the Drawing area of the Plot Transformations map.
2. In the Plotted As area, click the Same Linetype check box.
3. In the Pen Width box, type 0.3.
4. In the Pen box, type or select the pen number 5.

Repeat this procedure till the Plot Transformations map contains the required map of colors, linetypes, and associated plotter pens.

To restore the Plot Transformations default settings, click Reset.
To restore the default color settings, click Default Color.

Setting the Linetype Length

You can set the pattern length for any of the seven broken linetypes. Each broken linetype is a pattern repeated many times to produce a line. Using the Plot Linetype Length dialog box, you can specify the length of each pattern and thus alter the fineness of the line. Figure 10. Different Linetype Lengths on page 122 shows two DASH_CENTER lines drawn with different linetype lengths. The linetype length is shown arrowed.
The seven broken linetypes that you can set are:
- DASHED
- LONG_DASHED
- DOT_CENTER
- DASH_CENTER
- PHANTOM
- CENTER_DASH_DASH
- DOTTED

To set the linetype length and minimum space for individual broken linetypes:

1. Click **File** ➤ **Print** ➤ **Print Setup**.
   
   The **Print** dialog box opens.
   
   Alternatively, press CTRL+P to open the **Print** dialog box.

2. Click the **Drawing** tab and then, in the **Colors** area, click **Pattern Length**.
   
   The **Plot Linetype Length** dialog box opens.

3. In the **Linetype name** column, click the required linetype.

4. In the **Length** box, type or select a segment length for each broken linetype.

5. In the **Min. Dist.** box, type or select the minimum distance (the gap) between the broken line segments.

6. Click **Apply**.

7. Click **OK**.

Alternatively, to set all broken linetypes to the same segment length and the same minimum distance, specify the segment length and minimum distance and click **Apply to All** in the **Plot Linetype Length** dialog box.
Setting the Pixmap Color

When printing or plotting a drawing that includes embedded pixmaps, you can set the output of the image to be either Color or Black & White.

To set the pixmap color:

1. Click File ▶ Print ▶ Print Setup.
   Alternatively, press CTRL+P.
2. On the Pixmap tab, in the Pixmap area, click Color or Black & White.

Retaining or Inverting Black and White Pixmaps

To reverse the black and white pictures:

1. Click File ▶ Print ▶ Print Setup.
   The Print dialog box opens.
   Alternatively, press CTRL+P to open the Print dialog box.
2. Click the Pixmap tab and then, in the B&W Pixmap area, click Reverse.

Previewing a Print or Plot

Creo Elements/Direct 2D Access allows you to view print or plot output on your screen using the Plot Preview system viewport. You can open the viewport after you select all the necessary print settings (as a last step before printing), or open it to view while working on your drawing.

1. Click File ▶ Print ▶ Print Setup.
   The Print dialog box opens.
   Alternatively, press CTRL+P to open the Print dialog box.
2. Click the Show Preview check box.
   The Plot Preview system viewport appears.
3. Select a color setting for the Plot Preview viewport:
   • Original to preview color printer or plotter output.
   • Grayscale to preview black and white printer or plotter with dithering capability output.
   • B&W to preview black and white printer or plotter output.

The Plot Preview viewport is visible till you clear the Show Preview check box.
Starting a Print or Plot Job

When you have selected or specified all of the required print or plot output settings, click **Print** to send your drawing to either the Print Manager or to the Clipboard or to a file.

The Print Manager queues the drawing to the current default output device. The Clipboard temporarily stores the drawing so that it can be electronically pasted into another application.

Printing or Plotting Multiple Drawing Files

To plot or print multiple Creo Elements/Direct 2D Access drawing files from the File Browser:

1. In the Windows file browser, select the drawing file or files to be printed or plotted and right-click.
2. Click **Print**.

Dumping the Creo Elements/Direct 2D Access Screen

To copy the entire Creo Elements/Direct 2D Access screen to the Clipboard, press **ALT & PRINT**.

Then paste the screen dump in a graphics application of your choice for further processing. For example, in Microsoft® Paint, click **Edit ▶ Paste** to paste the Creo Elements/Direct 2D Access screen dump to the drawing area.

Writing a Creo Elements/Direct 2D Access Screendump to an Output File

Optionally, you can write a screen dump of the current Creo Elements/Direct 2D Access window directly to an output file.

See **Exporting as Image on page 48** for instructions.

Further Information

For further technical information about plotting or dumping, refer to the Creo Elements/Direct 2D Access help system.

Type `help plot` or `help bitmap_to_file` in the Creo Elements/Direct 2D Access command line and press **ENTER**.
Creo Elements/Direct 2D Access displays further information about plotting or dumping.
From Creo Elements/Direct 2D Access Rev. 18.1 onwards, MFC-based toolbar and menu customizations (ASCII Format Layouts) created and saved in earlier versions can be loaded in the Creo Elements/Direct 2D Access Fluent user interface.

To load the customizations:

1. Click File ▶ Import/Export ▶ Import Macro ▶ Input Macro.

   The Input Macro dialog box opens.

2. Select the macro and click Open.

Alternatively, you can use the INPUT command to load the customizations.

---

**Note**

After you load the customized toolbars and menus in Creo Elements/Direct 2D Access, you cannot modify or customize them.

You can also use the emulated “classical” menus and tables. You can load them by specifying their macro name.

Emulated "classical" menus and tables (referencing the MENU and TABLE commands) cannot be scaled to wrap to a changing number of rows and columns.
The number of rows and columns always remain fixed as defined in the underlying macro. Note that these menus are not saved for subsequent relaunch when you exit Creo Elements/Direct 2D Access.
Displaying and Hiding Toolbars

To display or hide a toolbar:

1. Click View and then, in the Viewing group, click Toolbars.
2. Click 2D Access.
3. Click or clear the check box of a toolbar to show or hide the toolbar, respectively.

Excluding Toolbars

You can exclude a toolbar from loading in Creo Elements/Direct 2D Access by specifying the name of the toolbar in a text file.

To exclude a toolbar, add the name of the toolbar in the FilterToolBars.txt file, which is available in the following path:

<Creo Elements/Direct 2D Access Installation Folder>/fluent_ui

Note

Creo Elements/Direct 2D Access creates a copy of the FilterToolBars.txt file in the AppData (Application Data) folder after every session. If you make any changes to the FilterToolBars.txt file, you have to remove its copy from the AppData (Application Data) folder to implement the changes.

To avoid redundancy, toolbars like Command Line, Status Bar, and Main Toolbar are excluded by default.

Customizing Toolbars and Toolbar Items

You can add, edit, or delete toolbars and toolbar items using the Customize dialog box.

To open the Customize dialog box:

• Click File ▶ Customize.

The Customize dialog box displays a list of toolbars and toolbar items in Creo Elements/Direct 2D Access. When you start Creo Elements/Direct 2D Access, all pre-defined toolbars are loaded by default, but are hidden. You can display a toolbar by clicking its check box in the Toolbars list of the Customize dialog box.
You can also display or hide toolbars using Toolbars in the Viewing group on the View tab. For more information, see Displaying and Hiding Toolbars on page 128.

**Note**
You retain a toolbar layout across Creo Elements/Direct 2D Access sessions. When you exit Creo Elements/Direct 2D Access, the toolbar layout information is stored in the layout_fv.m file in the AppData (Application Data) folder. Creo Elements/Direct 2D Access loads this file (if available) when you start a new session.

### Creating a Custom Toolbar
To create a custom toolbar:

1. Click File ▶ Customize.
   
   The Customize dialog box opens. The Toolbars pane opens by default.

2. Click Add.
   
   The Add Toolbar dialog box opens.

3. In the Caption Key box, type a label for the toolbar.
   
   Creo Elements/Direct 2D Access displays this label in the user interface.

4. Click or clear the Locked check box to lock or unlock the toolbar, respectively.

   **Note**
   You cannot delete a locked toolbar.

5. In the Unique Name box, type a unique name for the toolbar.
   
   This name is internal to Creo Elements/Direct 2D Access.

6. In the On Right Click box, type a command, function, or macro name.
   
   This command, function, or macro is executed when you right-click the toolbar.

7. In the Domain box, type the name of the message file (if any).
   
   Creo Elements/Direct 2D Access refers to the message file for the localized version (if applicable) of this toolbar.
Note
Every toolbar and toolbar item in the Creo Elements/Direct 2D Access user interface is associated with a specific domain file. The domain file contains the strings associated with the toolbar or toolbar items, which you can edit. The strings include:

- Caption
- Category
- Tooltip
- List Items

8. Click **OK**.

Tip
- You can place the toolbar anywhere in the Creo Elements/Direct 2D Access user interface using a drag-and-drop operation.
- To display tooltips of the toolbar items, click the **Show Tooltips** check box in the **Toolbars** pane of the **Customize** dialog box.

Selecting a Toolbar Menu Style
You can select the look and feel of the toolbar menus. You can view the toolbar menus as icons, text, or both.

To select a toolbar menu style:

1. Click **File ▶ Customize**.

   The **Customize** dialog box opens. The **Toolbars** pane opens by default.

2. In the **Text Options** box, select one of the following:
   - **Text below**
   - **Text on right**
   - **Text only**
   - **Icon only**
Editing a Toolbar
To edit a toolbar:
1. Click File ▶ Customize.
   The Customize dialog box opens. The Toolbars pane opens by default.
2. In the Toolbars list, select a toolbar.
3. Click Edit.
   The Edit Toolbar dialog box opens.
4. Edit the settings.
5. Click OK.

Deleting a Toolbar
To delete a toolbar:
1. Click File ▶ Customize.
   The Customize dialog box opens. The Toolbars pane opens by default.
2. In the Toolbars list, select a toolbar.
3. Click Destroy.

Creating a Custom Toolbar Item
To create a custom toolbar item:
1. Click File ▶ Customize.
   The Customize dialog box opens. The Toolbars pane opens by default.
2. Click Toolbar Items.
3. Click Add.
   The Add Toolbar Item dialog box opens.
4. Define the following parameters in the Add Toolbar Item dialog box:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Caption Key</td>
<td>Type a label for the toolbar item. Creo Elements/Direct 2D Access displays this label in the user interface.</td>
</tr>
<tr>
<td>Enabled</td>
<td>Click or clear the check box to enable or disable the toolbar item, respectively.</td>
</tr>
<tr>
<td>Unique Name</td>
<td>Type a unique name for the toolbar.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Description</td>
</tr>
<tr>
<td>---------------</td>
<td>-----------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>This name is internal to Creo Elements/Direct 2D Access.</td>
<td></td>
</tr>
</tbody>
</table>
| **Item Type** | Select a standard MS Windows item type.  

**Note**  
The item types in the Item Type list are context-sensitive. For example, you can select items from a context menu when you right-click a button that is created by using **Popup Button**. |
| **Submenu**   | Select a submenu.  

**Note**  
The Submenu list is available only if you select **Popup Button** in the Item Type list. |
| **ToolTip Key** | Type a brief description of the toolbar item. |
| **On Action** | Type a command, function, or macro name (for example, change_color).  
Creo Elements/Direct 2D Access executes this command, function, or macro when you click the toolbar item. |
| **On Right Click** | Type a command, function, or macro name.  
Creo Elements/Direct 2D Access executes this command, function, or macro when you right-click the toolbar item. |
| **Category Key** | Define a category for the toolbar item. |
| **Domain** | Type the name of the message file (if any).  
Creo Elements/Direct 2D Access refers to the message file for the localized version of this toolbar item (if applicable).  

**Note**  
multiple toolbars may share the same domain file. Optionally, you can create a separate domain file for each toolbar. |
| **Image** | Define an icon for the toolbar item:  
1. In the Image area, click **Edit**. |
Adding an Icon to the Toolbar

You can add icons (as buttons) to the Creo Elements/Direct 2D Access toolbars. To add an icon to a toolbar:

1. Click File ▶ Customize.

   The Customize dialog box opens. The Toolbars pane opens by default.

2. Click Toolbar Items.

3. In the Categories list, select a category.

**Note**

Combo boxes, radio buttons, and check boxes require a separate macro. For details about the Creo Elements/Direct 2D Access user interface customization capabilities, see TOOLBAR_ITEM in the Creo Elements/Direct Drafting / Creo Elements/Direct 2D Access Programming Reference Guide.
4. Select a toolbar item.
5. Click Edit.
   The Edit Toolbar Item dialog box opens.
6. In the Image area, click Edit.
   The Image Editor dialog box opens.
7. Create an icon.

   **Tip**
   To add an existing icon, click Load in the Image Editor dialog box.

8. Click OK.
   The icon is associated with the toolbar item.
9. Drag the toolbar item to the toolbar.

   **Tip**
   • To remove a button from a toolbar, drag the toolbar button to the Customize dialog box.
   • You can copy or move toolbar buttons to other toolbars.
   • Press CTRL and place a toolbar button on the destination toolbar (with a drag-and-drop operation) to copy the toolbar button.
   • If the Customize dialog box is not open, you can use ALT to move toolbar buttons or use ALT+CTRL to copy toolbar buttons to other toolbars.

**Editing a Toolbar Item**
To edit a toolbar item:
1. Click File ▶ Customize.
   The Customize dialog box opens. The Toolbars pane opens by default.
2. Click Toolbar Items.
3. In the Categories list, select a category.
4. Select a toolbar item.
5. Click Edit.
The **Edit Toolbar Item** dialog box opens.

6. Edit the parameter values.
7. Click **OK**.

**Deleting a Toolbar item**

To delete a toolbar item:

1. Click **File ▶ Customize**.
   
   The **Customize** dialog box opens. The **Toolbars** pane opens by default.

2. Click **Toolbar Items**.

3. In the **Categories** list, select a category.

4. Select a toolbar item.

5. Click **Destroy**.

---

**Note**

- **Destroy** removes items from the **Toolbar Items** pane of the **Customize** dialog box and deletes the associated files.

- You cannot undo **Destroy**.
Customizing Creo Elements/Direct 2D Access

Customizing the Creo Elements/Direct 2D Access Environment ............................................ 137
Changing the Creo Elements/Direct 2D Access Environment ............................................. 137
Customizing the Keyboard ........................................................................................................ 138
Example ..................................................................................................................................... 138
Loading and Listing Text Fonts ................................................................................................. 139
The System Fonts ......................................................................................................................... 140
Customizing the Startup File ....................................................................................................... 141
Creo Elements/Direct 2D Access Keywords .......................................................................... 142

Creo Elements/Direct 2D Access can be customized to suit your individual requirements.

⚠️ Note

You need to be fully conversant with Creo Elements/Direct 2D Access before you start customizing Creo Elements/Direct 2D Access.

When Creo Elements/Direct 2D Access is started up, it reads and executes a number of files which define a variety of functions such as the screen menus and Creo Elements/Direct 2D Access environment. These files are executable programs called macros which you can edit and store under your own filenames to be reloaded and used as required. It is therefore possible to create your own alternative definitions for the screen menus and Creo Elements/Direct 2D Access environment. This process is known as customizing.
Customizing the Creo Elements/Direct 2D Access Environment

The Creo Elements/Direct 2D Access environment consists of such things as the size and color of text, the plot scale, the drawing scale, and units.

All these are controlled by the settings of the environment functions, of which there are more than 70 in the system. An example of an environment function is DIM_COLOR. This can be set to produce dimensions with any of the colors available.

The current settings of the environment functions can be stored in a file. An extract of a Creo Elements/Direct 2D Access environment file is as follows:

```
MAX_FEEDBACK 100
CONFIGURE_EDITOR '$' 1 79
UNITS 1 MM
UNITS 1 DEG
CS_REF_PT 0,0
CS_AXIS 1,0 0,1
FOLLOW OFF
GRID_FACTOR 10
CURRENT_FONT 'hp_block_v'
TEXT_FRAME OFF
TEXT_ANGLE 0
TEXT_ADJUST 1
TEXT_LINESPACE 2.2
TEXT_FILL OFF
TEXT_SIZE 1
TEXT_RATIO 1
TEXT_SLANT 0
LINE WHITE SOLID END
C_LINE RED DOTTED END
TEXT WHITE END
```

At startup, the functions are set as shown in the listing to provide a standard environment. During normal use, the settings are changed from the screen menu.

It is also possible to change the function settings by editing the Creo Elements/Direct 2D Access environment. This method is useful because it gives an overview of the status of all environment functions at once. It also gives access to those functions that are inaccessible from File ▶ Settings.

A customized environment can be stored in a named file. This file can then be used to restore the same environment whenever it is required.

Changing the Creo Elements/Direct 2D Access Environment

To display the environment file:
1. Enter `edit_environment`.
The environment will be displayed and the function settings can be changed as required. When you have finished changing the environment, save the file and exit the text editor to implement all the changes to Creo Elements/Direct 2D Access.
The current environment can be stored for future use in a named file as follows:

1. Enter `save_environment`.
2. Enter `'env_filename'` (the name of your own choice).

To execute the stored file and redefine the system environment:

1. Enter `INPUT 'env_filename'`.

### Customizing the Keyboard

When working with Creo Elements/Direct 2D Access, you may carry out some operations more frequently than others. This section describes how you can customize the keyboard to reduce the time you spend on these operations.

At the top of your keyboard there are normally eight function keys labeled F1 to F8 that you can customize.

For example, you may set several directories as current during a Creo Elements/Direct 2D Access session. To save time, you can customize the function keys to set each directory as current. Once you have done this, you only need to press this key, then press ENTER and the named directory will be set to current.

Any command can be implemented in this way and eight examples are given in this section.

You use the `DEFINE_KEY` command to customize the function keys.

The syntax for this command is described below.

```
DEFINE_KEY key_number 'command_name'
```

The `key_number` defines which function key you are customizing (1 to 8).

The `command_name` is the command name.

### Example

The following example describes how to customize the eight function keys:

1. Enter `EDIT_FILE`. The system will prompt for a filename.
2. Enter "customize".

   Unless you have previously stored some customized files or macros in the file, the screen will now go blank (because the file is empty at the moment). Type your first command line. An example could be:
• `DEFINE_KEY 1 "CURRENT_DIRECTORY 'c:/users/alan/proj1'"

In the above line, 1 is the defined function key and `CURRENT_DIRECTORY 'c:/users/alan/proj1'` is the text to be displayed in the user input line.

You can define the other function keys in exactly the same way. An example of all eight defined keys is shown below.

```plaintext
DEFINE_KEY 1 "CURRENT_DIRECTORY 'c:/users/alan/proj1'"
DEFINE_KEY 2 "CURRENT_DIRECTORY 'd:/users/larry/proj2'"
DEFINE_KEY 3 "CURRENT_DIRECTORY 'd:/users/mary/proj3'"
DEFINE_KEY 4 "CURRENT_DIRECTORY 'k:/users/geoff/proj4'"
DEFINE_KEY 5 "CURRENT_DIRECTORY 'i:/users/steve/proj5'"
DEFINE_KEY 6 "CHANGE_VIEWPORT_SIZE"
DEFINE_KEY 7 "CHANGE_VIEWPORT_COLOR"
DEFINE_KEY 8 "EDIT_PART POINT"
```

The first five function keys set the named directories as current. Function keys 6 and 7 are used for altering the viewports. Function key 8 is used, in a drawing that contains parts, to make a picked part active.

3. After entering the command lines, press CTRL+D to store your changes in the file.

4. Input the file `customize` by entering `INPUT customize`.

The function keys will be defined and ready for your use.

**Loading and Listing Text Fonts**

A text font is a group of pre-defined geometrical patterns that can be placed on a drawing. Each pattern in a font is made up of straight lines joining points on a grid, and is associated with a keyboard character so that it can be easily called.

Although normally used for text (the standard system annotation and dimensioning texts are produced this way), text fonts can also produce special symbols. Because there can be many points in the grid, highly detailed symbols can be defined.

If you need special text or symbols, you can create them with your own customized text fonts and store them on disk ready for use. A good example of text font use is for producing company trademarks, logos, etc.

Text fonts are very versatile - these are some of the main features:

- Characters can be filled or unfilled.
- The character width-to-height ratio can be set.
- The character slant angle can be set (forwards or backwards).
- The line angle can be set (0 to 360 degrees).
The System Fonts

When the system is started up, a number of font files are loaded into memory. However, only one of them is the current font and available for immediate use.

Creo Elements/Direct Drafting’s different internal and external encoding schemes were Unicode incorporated for version 2007.

You can find out which fonts are in memory by entering LIST_FONTS. If no new fonts have been defined since system startup, the display will become as follows, and then you can return to the menu using ESC.

Fonts loaded:

- osd_default2
- osd_default3
- osd_default
- hp_def_font

Font used:

- osd_default

Current font:

- osd_default

This table gives the names of fonts that are in memory and has nothing to do with the files from which they are created. The fonts hp_Y14.5 and hp_i3098_v are loaded from files with the same names, but hp_def_font is created within the system and displays a box on the screen to represent the space that will be occupied by characters before they are drawn.

There are files available on the disk that create fonts when they are loaded. The complete list is:

<table>
<thead>
<tr>
<th>Font</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>osd_default</td>
<td>Default Creo Elements/Direct Drafting font containing hp_i3098_v and hp_kanji2_c characters with variable character spacing</td>
</tr>
<tr>
<td>osd_default2</td>
<td>Default Creo Elements/Direct Drafting font containing hp_i3098_c and hp_kanji2_c with fixed characters spacing</td>
</tr>
<tr>
<td>osd_default3</td>
<td>Default Creo Elements/Direct Drafting font containing hp_d17_v and hp_kanji2_c with variable characters spacing</td>
</tr>
<tr>
<td>hp_Y14.5</td>
<td>Used for symbols only</td>
</tr>
</tbody>
</table>

140 Inspection with Creo Elements/Direct 2D Access Fluent User Interface
ISO 3098 font with variable character spacing
ISO 3098 font with constant character spacing
Filled font with variable character spacing
Filled font with constant character spacing
DIN17 font with variable character spacing
DIN17 font with constant character spacing
Kanji Japanese and Greek font with variable character spacing
Kanji Japanese and Greek font with constant character spacing
Special characters for dimensioning: °, ±, minutes, seconds

To increase the speed of access, all the files listed above are stored as binary files on the disk and cannot be input. They have to be loaded using:
LOAD_FONT 'bin_filename'

bin_filename is the name of the binary file. It is possible for a binary file to contain more than one font, in which case they will all be loaded. Each of the system files contains only one font that has the same name as the filename. The LOAD_FONT command will not change the current font.

## Customizing the Startup File

**Note**
To edit the Creo Elements/Direct 2D Access startup file, you need to be logged in as an administrator.

If you exit Creo Elements/Direct 2D Access, any customized features that you have entered, although stored in files, are not defined when you start Creo Elements/Direct 2D Access. To redefine the customization, the files containing the customization must be input again.

If you want your customization automatically defined whenever you start Creo Elements/Direct 2D Access, you should edit the Creo Elements/Direct 2D Access startup file. The startup file contains the commands that load the system files when you start Creo Elements/Direct 2D Access. To edit the startup file:

1. Type EDIT_FILE 'startup' and press ENTER.

   A listing of the startup file will be displayed on the screen. The listing of the file is shown below.
   
   ```c
   INPUT 'passwords'
   LOAD_MODULE 'VIEW'
   LOAD_FONT 'hp_i3098_v'
   ```
2. Remove the braces {} from around {INPUT 'customize'} so that it reads:
   • INPUT 'customize'
3. Press CTRL+D to store your changes.

Check that all your files containing customized features are in the file called customize. If they are not, INPUT the filenames as described below.

For example, if you had two customized files: Custm_fk, and Sm_menu_1 you would include the following lines at the end of the customize file:
   • INPUT 'Custm_fk'
   • INPUT 'Sm_menu_1'

During startup, the startup file automatically loads customize which in turn will load the customized files: Custm_fk and Sm_menu_1.

**Creo Elements/Direct 2D Access Keywords**

Keywords are reserved words within Creo Elements/Direct 2D Access used to access relevant technical information from the help file.

Each keyword in the list is followed by an abbreviation indicating which type of keyword it is. (Enter help list_keywords to display the list.)

There are four types of keywords:
   • COMMANDS and FUNCTIONS (Cmd) or (Fnc): Command and function keywords such as DOT_GRID and REDRAW will start their corresponding action routine when typed by the user.
Keep in mind that functions can interrupt a command (or another function) without terminating it. Once a function has been executed, control is automatically returned to the previously unfinished command in which you were working.

- **QUALIFIERS (Qua):** Qualifiers such as `DEL_OLD` and `THREE_POINTS` do not have an action routine of their own. They are used by other commands and functions to select one of the many options available to that command or function.

- **PSEUDO COMMANDS (Psc):** Pseudo commands such as `IF` and `END_LOOP` are only used internally. They control the execution of macros.

- **ARITHMETIC FUNCTIONS (Afn):** Arithmetic functions such as `SIN` and `SQRT` are used within expressions. Their associated C function has to pick up the necessary parameters and calculate the function result.
# Index

## A
- angles
  - measuring, 66
- area
  - measuring, 66
  - properties, 66
- arithmetic functions, 143

## B
- beeper
  - switching on or off, 30
- bisect
  - angle, 92
  - lines, 92
- boxes, parts as, 77
- boxing
  - elements, 33
- button, 9

## C
- calculator, 69
- CATCH commands, 63
- catch mode, 63
- center point
  - creating, 52
  - centering
    - the drawing, 115
- Change to Hidden, 85
- changing
  - Creo Elements/Direct 2D Access, 136
- classical menu
  - support, 126
- Clipboard, 110
- coloring
  - URLs, 102
- command groups
  - CATCH, 63
- command line, 11
- commands
  - confirming, 36
  - commands vs functions, 142
  - Confirm command, 36
  - confirming
    - commands, 36
    - delete operation, 36
    - modify operation, 36
- construction circles
  - by center and circumference point, 93
  - by center and element, 93
  - by diameter, 94
  - by radius or point and two elements, 94
  - by radius, point, and element, 94
  - by three elements, 95
  - by three points, 93
  - concentric, 93
  - drawing, 92
- construction geometry
  - selecting for deletion, 35
- construction lines
  - a tangent to two circles, 91
  - at an angle, 90
  - bisecting a line, 92
  - bisecting an angle, 92
  - by two points, 88
  - drawing, 88
  - horizontal, 88
  - parallel, 89
perpendicular, 90
tangent from a point to a circle, 91
vertical, 88
context menu, 11
creating
a new center point, 52
a new window, 51
viewport, 55
Creo Elements/Direct 2D Access
basic working methods, 30
Creo Elements/Direct 2D Access
instance, 43
current
viewport, 51, 55, 58-59
cursor
setting the size, 70
customizing
Creo Elements/Direct 2D Access, 136
environment, 137
startup file, 141
the keyboard, 138
customizing Creo Elements/Direct 2D Access, 38

D
DEFINE_KEY command, 138
defining
printing/plotting parameters, 112
your own units, 69
delete command, 30
deleting
all viewports, 57
elements, 30
general, 30
OLE object, 107
viewports, 57
dimensions
selecting, 36
showing, 60
displaying

E
EDIT_PART
Parent option, 76
Top option, 75
elements
adding to your selection, 32
boxing, 33
deleting, 30
enclosing within a polyline, 33
removing them from your selection, 33
selecting, 32
selecting all, 34
enclosing
customizing the, 137
elements, 33
environment
changing the, 137
exit Creo Elements/Direct 2D Access, 38
exporting
macro, 47
picture file, 47

F

face
  measuring the area, 66
faces, what are they?, 82
features
  showing all, 59
File Browser
  opening a drawing, 40
file tab, 8
files
  how to find, 39
filing
  introduction, 39
fitting, 51
Follow on/off
  using, 70
font
  importing, 39
fonts
  system, 140
text, 139

G

generating
  hidden lines, 85
Geo command, 35
global
  selection, 31
graphics performance
  enhancing, 60
grids
  displaying, 69
group, 9

H

hidden lines
  displaying as dashed lines, 85
generating, 85
introduction, 82
plotting, 86
Hidden Mode
  On or Off, 85
hiding
  ruler/grid, 72
horizontal
  measuring distances, 65
HP-GL file
  importing, 46

I

icons
  in Part Browser, 78
importing
  font, 46
  HP-GL file, 46
  macro, 46
infos
  displaying, 60
  selecting, 35
isometric ruler/grid
drawing, 72

J

justifying
  the drawing, 115

K

keyboard
  customizing, 138
keywords
  commands and functions, 142

L

language
  switching, 29
layer
  changing the color, 60
layers
    selecting, 35
    using the Show functions, 102
learning
    Creo Elements/Direct 2D Access, 30
lengths
    measuring, 64
line grid, 69
linesize
    selecting, 36
linetype length, 121
Load File
    As Subpart, 44
    Check 2D, 44
    Check 2D Retain Dependency, 44
    Keep Scale, 44
Load Files command, 97
loading
    a subpart, 45
    introduction, 39
    recently used drawing files, 43
loading and listing
text fonts, 139
loading drawings
    File Browser, 40
    Navigator, 42

M
macro
    exporting, 47
    importing, 46
macros
    z-value in assembly, 84
Measure
    calculator, 69
Measure function, 63
measurement units, 68
measuring
    angles, 66
    area properties, 66
    distances, 63
    horizontal distances, 65
    lengths, 64
    radius, 64
    vertical distances, 65
minimum
    z-value in assembly, 84
more, 9
most recently used drawing files, 43
moving
    the ruler, 71
multiple Creo Elements/Direct 2D Access instances, 43

N
Navigator
    opening a drawing, 42

O
OLE Browser, 107
OLE object
    activating, 106
    deleting, 107
    hiding and showing, 107
    to back, 106
    to front, 106
OLE objects
    linking and embedding, 104
Open, 40
    Check 2D, 41
    Check 2D Retain Dependency, 41
origin
    displaying, 70

P
panning
    across a drawing, 51
parallel
    construction lines, 89
parameters
    printing/plotting, 113
parent part, 75
part browser, 11
Part Browser
description, 78
icons, 78
part, parent, 75
parts, 74
editing, 75
Part Browser, 78
selecting, 36
tree, 31
viewing, 76
Parts
structure, 75
parts as boxes, 77
Paste, 37
pensize
selecting, 36
pixmap color
printing, plotting, 123
placing
the ruler/grid, 72
plot
fitting, 117
plot transformation map, 119
plotter
selecting, 113
plotting
boxed area, 117
complete drawing, 117
current show attributes, 118
current viewport, 117
drawing, 118
drawings, 109
hidden lines, 85
linetype length, 121
multiple drawings, 124
pixmap color, 123
preview plot output, 123
Range, 116
scale, 117
scale factor, 117
starting output, 124
to a file, 114
truecolor, 119
point coordinates
displaying, 65
points
showing, 59
port (viewports), 53
positioning
drawing in print/plot, 115
Preview Print/Plot Output, 123
print configuration
template, 110
print configuration example, 111
Print Manager, 110
printer
selecting, 113
printing
boxed area, 117
complete drawing, 117
current show attributes, 118
current viewport, 117
drawing, 118
drawings, 109
linetype length, 121
multiple drawing files, 124
pixmap color, 123
preview plot/print output, 123
range, 116
scale, 117
scale factor, 117
starting output, 124
to a file, 114
truecolor, 119
printing/plotting
settings, 113
prompt line, 11
pseudo commands, 143
Q
qualifiers, 143
quick access toolbar, 9
R
radius
  measuring, 64
Range, 116
recalling
  a window, 52
Redo, 37
redraw mode, 60
redrawing, 51
reference line
  selecting, 35
Reset Show command, 98
restoring
  last view, 52
revision checking, 96
  loading files, 97
  Reset Show, 98
  Set Color, 98
  Show Difference, 99
ribbon, 9
rotating
  the ruler/grid, 71
rotation
  print/plot output, 116
ruler
  displaying, 69
  moving, 71
ruler/grid
  drawing an isometric, 72
  hiding, 72
  placing, 72
  rotating, 71
  setting the spacing, 71
  using, 69

S
scale
  factor for plot, 117
  setting, 117
screendump, 124
Select command, 32
Select mechanism, 30
selecting
  what is displayed, 58
selection
  a vertex, 34
  boxing elements, 33
  confirming, 36
  construction geometry, 35
  dimensions, 36
  drawing elements, 32
  drawing geometry, 35
  elements within a polyline, 33
  general, 30
  global, 31
  infos, 35
  layers, 35
  linesize, 36
  parts, 36
  pensize, 36
  reference lines, 35
  removing elements, 33
  subtracting elements, 33
  subtree, 36
  text, 35
  URLs, 36
Set Color command (revision checking), 98
setting the units of measurement, 68
Show
  functions with layers, 102
SHOW
  All option, 78
  Boxed option, 77
  function, 58
  Part option, 77
Show Difference command, 98
Show Hidden, 85
showing
  all features, 59
  dimensions, 60
  points, 59
SPOTLIGHT ON/OFF command, 80
spotlighting, 80
starting Creo Elements/Direct 2D
Access, 29
startup file
customizing, 141
editing, 141
status bar, 10-11
storing
a window, 52
subtree
selecting, 36
switching
URLs on and off, 102
system fonts, 140

T

tab, 9
tangent
constructing, 91
tangent constructing, 91
text
selecting, 35
text fonts
loading and listing, 139
toolbar
creating, 129
ing, 131
support, 126
toolbar item
creating, 131
deleting, 135
ing, 134
toolbar items
customizing, 128
toolbar menu style
selecting, 130
toolbars
customizing, 128
deleting, 131
displaying or hiding, 128
excluding, 128
turecolor plotting, 119
turecolor printing, 119
TrueType font
importing, 46

U

Undo, 37
units of measurement, 68
URL
color, 102
URLs
selecting, 36
user input line, 11
user interface, 7

V

values
Z, 82
vertex
selecting a, 34
show, 59
vertical
measuring distances, 65
vertices
show, 59
View command
Parent option, 77
Top option, 76
View commands
parts, 76
VIEW commands, 76
viewport
changing size, 56
creating, 55
deleting, 57
making it current, 55
maximizing, 56
moving, 56
redrawing, 56
settings, 57
**W**

window
  creating, 51
  recalling, 52
  restoring last view, 52
  storing, 52
  using normal functions, 51
  zooming, 52

windows
  multiple Creo Elements/Direct 2D
    Access instances, 43

working
  basic methods, 30

**Z**

z-value
  checking, 83
  checking maximum, 84
  checking minimum, 84
  of a shared part, 84
  what is it?, 82

zooming
  in or out, 52