Creo Tutorials > Creo Intelligent Fastener Tutorials > Advanced Tutorials > Assembling Fasteners > Exercise 2 – Assembling Fasteners on All Instances and Patterning
  
Exercise 2 – Assembling Fasteners on All Instances and Patterning
1. In Creo Parametric set the working directory to <downloaded files location>\IFXTraining\IFX_Asm\Exercise2 and open ifx-exercise-2.asm.
2. Click View > Saved Orientations and then click GLASS.
3. Click Tools > Screw > Assemble on point or axis. The Select References dialog box opens and the Position Reference box is activated.
4. Refer to the diagram below and select the references as described in the list below:
a. Select the axis as the Position Reference
b. Select the surface for Screw head placement.
c. Select the surface for Nut or Thread surface placement.
5. Click OK. The Screw Fastener Definition dialog box opens.
6. Configure screw connections using the Screw Fastener Definition dialog box as follows:
a. In the Screw box, select ISO 14579–8.8.
b. Click Measure a diameter and select the area around the axis you selected in step 3a.
c. Select the Side 1 Washers check box.
d. Click Set length automatically.
7. Click OK to close the dialog box. The Pattern Options dialog box opens.
8. Select Pattern fastener? and click OK.
 
* The threaded holes are created in the housing cover part but are not created in the housing part
9. Click Tools and then in the Intelligent Fastener group, click Delete.
10. Select one of the Socket Head Cap Screws. You are prompted to delete the fastener.
11. Click Yes. All the fasteners in the pattern are deleted.
12. Click Tools > Screw > Assemble on point or axis. The Select References dialog box opens.
13. Select the same references as described in steps 4a through 4c in this exercise. Notice that the same settings are still available in the Screw Fastener Definition dialog box.
14. Click OK to close the dialog box. The Pattern Options dialog box opens.
15. Select Assemble fastener on all instances? and then click OK to close the dialog box. Holes are created in the housing cover and the housing part.
16. Save and close the assembly.
17. Click File > Manage Session > Erase Not Displayed. The Erase Not Displayed dialog box opens.
18. Click OK to erase all files from memory.