Fundamentals > Working with the Model > Layers > Layer Basics > To Copy Layers Between Two Models in Session
To Copy Layers Between Two Models in Session
1. Click or in the Model Tree navigator window click and then click Layer Tree. The Layer Tree opens.
2. Select a layer that you want to copy.
3. Click Edit > Copy or right-click the selected layer and click Copy Layer on the shortcut menu. The definition of the selected layer is copied to the clipboard.
While copying a layer, you can copy only the layer definition and not its contents. If you copy a rule-based associative layer, the associated rules are also copied. You must regenerate the model after copying a rule-based associative layer. For a nested layer, only the parent layer is copied.
4. Open another model to which you want to copy the selected layer.
5. Click Edit > Paste or right-click the layer tree and select Layer > Paste Layer on the shortcut menu. The layers are copied to the selected model.
* If the name of the layer being copied already exists in the model to which it is being copied, the Existing Layer Name dialog box opens enabling you to specify a new name for the layer. Enter the new name as <Existing Layer Name>_##, where ## is a number, for example, All_PG_01, and click OK.