Fundamentals > Working with the Model > Search Tool > To Build a Query in the Search Tool
To Build a Query in the Search Tool
You build a query in the Search Tool to combine rules for a search you want to perform. Use the following procedure to build a query:
1. Click Tools > Find. The Search Tool dialog box opens.
2. Click Options > Build Query. The Query Builder dialog box opens.
3. Select an item type from the Look for list.
* To enable the Geometry tab, Component must be selected in the Look for list.
4. Select a model in the Look in list, if relevant.
5. Select from the available tabs and list boxes to customize the rules.
6. Click Add New to add the defined rule to the condition builder.
7. Create a new rule using the tabs and list boxes to be combined with the previous view using and or or operations.
8. Click Add New. The next rule is added to the condition builder.
* The default operator is or when adding new rules. The operator can be changed to and by clicking the Operator cell and selecting from the list.
9. When all the desired rules are combined, click Find Now. The search results from the combined query and corresponding locations are listed in items found section of the Search Tool dialog box.
* You can click Options > Save Query to save this query for later use.