Fundamentals > Working with the Model > Search Tool > About the Search Tool
  
About the Search Tool
The Search Tool allows you to find entities within your model without selecting from the graphics window or Model Tree. You can specify rules using the Attributes, History, Status, and Geometry tabs to help find specific information. You can create a layer of the found items, or select all or a subset of the found items by transferring them to the active selection section of the search tool.
You can also build and save simple and nested queries in the Search Tool. A nested query stores multiple queries (sub-queries) in one query to perform a refined search. A sub-query is used to store a rule for automatic selection of references instead of selecting individual references each time while building a query.
You have the option to find items that are not valid for the current selection. For example, if you want to find a horizontal reference for a sketching plane, the collector filters out all datum planes not orthogonal to the sketching plane. Filtered Selections, on the Options menu allows you to apply the filters.
The Search Tool is available by clicking  on the status bar or by clicking Tools > Find. You can select items by attributes such as name, ID, or number, annotations, or the last feature you created and create rules using wildcards. For example, Name is equal to A* searches for item names that begin with the letter A. The Criteria section displays the various comparison options, values, categories and other criteria based on the rule set for searching items.
Search results and corresponding locations are listed under items found of the Search Tool dialog box. The results are also highlighted in the Model Tree and graphics window. To select items, use to transfer items from items found to the Items Selected section of the Search Tool dialog box.
 
* If you are working outside a tool (no action specified), selected items are not cleared when you open the Search Tool. For example, if you select the feature and click Find Now, that feature is listed in the item selected section of the search tool. If the Search Tool is used while a tool is active, clicking the Close button appends only the search results and overrides any current selection.
The rules and values in the Search Tool reappear when a search is performed and you reopen the Search Tool to perform another search.
The Search Tool dialog box contains the following tabs and buttons:
Attributes—Search for items based on their attributes (Name, Type, Parameters, Size, Description, or Property)
History—Search for items based on their creation order or ID (including Last Feature, Failed Feature, and All, when applicable)
Status—Search for items based on their status (Regeneration, Layer, Display, Parent/Child, Copied Refs)
Geometry—Search for items based on geometrical relationships (Zone, Distance, Exterior Components)
Look for—Specify the type of item to search for, for example, feature, component, dimension, weld solid, and so on.
Look by—Create a more detailed query. For example, if you set Look for to Feature and set Look by to Dimension. The rules apply to dimensions but the found items are features that own the found dimensions.
Look in—(Available in Assembly and Drawing mode only) Select the active model. If the scope of your selection is already defined, this field is not displayed. The arrow button allows you to select the desired model from the graphics window or the Model Tree. Click the Include submodels check box to search the sub-models of the Look In model.
Find Now—Search by identified rules and display results under items found. If only one item is in the found list, it is automatically highlighted in the found list. If only one item is to be selected, select it from the list, and click to append it to the selection bin or double-click the item. You can also middle-click to add it to the selection bin and close the dialog box.
 
* Creo Parametric remembers the last used rule that was set for searching items in the current session. On starting the Search Tool again in the same session, you can directly click Find Now to use the last used rule without building a query. You can also save this rule as a query using the Options menu.
New Search—Start a new search.
Options—Set options, build, and save queries. Save the components gathered by a rule or set of rules into a layer using Save Query. This prompts for a new layer name, and creates a new layer in the layer tree. Build a query by combining rules that use Boolean AND and OR operations.