Fundamentals > Configuring Fundamentals > Configurations Options for Fundamentals
  
Configurations Options for Fundamentals
extended_context_prehighlight
yes*, no
Controls pre-highighting of extended context when over relevant commands.
datum_target_outside_text
Allows you to set the default position of the datum target area size text relative to the elbow in a case when the size text is displayed outside of the datum target frame This option provides you with two values:
near_elbow. — When the datum_target_outside_text is set to near_elbow, the fixed size elbow of the standard length is used. The text is located near the elbow. The text is vertically centered with the elbow. This value is set by default.
above_elbow — When the datum_target_outside_text is set to above_elbow, the text is located above the elbow. The length of the elbow depends on the length of the text string.
Switching the value of the datum_target_outside_text option affects all datum target symbols available in the current model or drawing. When a value of the datum_target_outside_text option is changed. All the datum target symbols are updated according to the chosen option where the size text is displayed outside the symbol frame
add_lower_level_comps_to_layer
no*, yes
Activates the Favor Current Layer option, which allows lower-level components to be added to top-level layers.
activate_window_automatically
yes*, no
Controls the automatic activation of the window after a window is selected.
af_copy_references_flag
no*, yes
Controls whether the Backup Refs column in the Annotation Feature dialog box is displayed. This column specifies whether the system creates backup references during creation or redefinition of an Annotation Element.
allow_confirm_window
yes*, no
Displays a confirmation window when you exit Creo Parametric.
angular_tol
0 0.000000<integer tolerance>
Sets default angular tolerance dimensions. The integer sets the number of decimal places, and the tolerance is the actual tolerance value. For example, 6 0.000025 sets a tolerance to 6 decimal places, and the default tolerance value is 0.000025.
For integer dimensions, the integer value is 0, and the tolerance is an integer. For example, 0 1 sets a tolerance of 1 for integer dimensions.
A value affects only models created after the tolerance option is specified in the configuration file.
auto_ae_param_file
<full path>
Specifies the location of the file in which Annotation Element parameters are automatically added each time you create an annotation element.
autohide_copied_group_af
yes*, no
Copies a feature group containing Annotation features and automatically hides from display the Annotation features in the new group.
auto_locate_in_tree
yes*, no
Expands the Model Tree and highlights the node of the selected object.
auto_propagate_ae
no*, yes
Causes the automatic, local propagation of Annotation Elements within a model after you create a feature.
auto_regen_views
yes*, no
Regenerates the drawing display whenever you change from one window to another.
yes—Regenerates both the drawing and the drawing view.
no—Regenerates the drawing but not the view unless you select View > Repaint, View > Update, or Edit > Regen.
autoplace_single_comp
yes*, no
Activates the Component Placement dialog box in drag-and-drop operations.
bell
no*, yes
Rings the keyboard bell when prompts appear.
blank_layer
0*, <layer ID>
Displays the specified layer in pre-Release 9.0 objects as empty, or blank, when you begin a Creo Parametric session. This configuration option is valid for layer IDs 1 – 32. After the object is stored in Release 9.0 or later, this setting is no longer necessary.
bmgr_pref_file
<path>
Specifies the location of the graph preference file for the Graph Tool settings, such as axis, line weights, label fonts, and so forth.Creo Parametric uses the settings in the text file to render your graphs to your specifications. After you create the text file, you add the bmgr_pref_file option to your config.pro file.
A sample graph preference file with the possible values follows:
X_Axis_Color 5.019608e-01f,5.019608e-01f,1.000000e+00f
X_Axis_DisplayLabel 1
X_Axis_GridColor 5.019608e-01f,5.019608e-01f,0.000000e+00f
X_Axis_GridEnabled 1
X_Axis_GridStyle 2
X_Axis_LabelColor 1.000000e+00f,1.000000e+00f,1.000000e+00f
X_Axis_LabelEnabled 1
X_Axis_LabelFont graphtool_font
X_Axis_LabelFontHeight 1.500000e-01f
X_Axis_Thickness 4
X_Axis_TickColor 1.000000e+00f,1.000000e+00f,1.000000e+00f
X_Axis_TickFont graphtool_font
X_Axis_TickFontHeight 1.000000e-01f
X_Axis_TickHorizontal 1
Y_Axis_Color 1.000000e+00f,0.000000e+00f,0.000000e+00f
Y_Axis_DisplayLabel 1
Y_Axis_GridColor 5.019608e-01f,5.019608e-01f,0.000000e+00f
Y_Axis_GridEnabled 1
Y_Axis_GridStyle 2
Y_Axis_LabelColor 1.000000e+00f,1.000000e+00f,1.000000e+00f
Y_Axis_LabelEnabled 1
Y_Axis_LabelFont graphtool_font
Y_Axis_LabelFontHeight 1.500000e-01f
Y_Axis_Thickness 2
Y_Axis_TickColor 1.000000e+00f,1.000000e+00f,1.000000e+00f
Y_Axis_TickFont graphtool_font
Y_Axis_TickFontHeight 1.000000e-01f
Y_Axis_TickHorizontal 1
bom_format
<file path>
Specifies the location of the BOM format file for a customized BOM.
browser_favorite
<full directory path name>
Specifies the directory for the local file system that appears in the Folder navigator in the Creo Parametric browser.
button_name_in_help
no*, yes
Specifies whether to display Help text associated with a menu command or a button.
clearance_triangulation
none, low, medium, high
Specifies the quality of surface triangulation used to obtain initial points for clearance and interference calculations.
clock
yes*, no
Determines whether a clock is displayed while Creo Parametric is working on a task.
color
yes*, no
Determines whether the model takes its assigned appearance.
yes—Displays the model in the assigned colors.
no—Displays the model in white for nonshaded display styles and in light gray for shaded display styles.
color_ramp_size
-1*
Specifies the number of shades in a color ramp for the display of multicolor, shaded models of simulation or analysis results or both. Your system graphics must support 256 colors and color maps that compress.
color_resolution
0.100000*
Specifies minimum allowable deviation between user-defined colors. Colors having RGB values within the tolerance of existing colors cannot be created. Decreasing this setting allows the definition of colors similar in RGB value.
color_windows
one_window*, all_windows
Specifies in which windows the model displays in color.
all_windows—Displays the model in color in all windows.
one_window—Displays the model in color only in the graphics window. In auxiliary windows, the model appears in the default system color.
compress_output_files
yes*, no
Specifies whether to store object files in a compressed format. Compressed files are fully compatible across systems. They are slower to read and write, and have a smaller file size. However, in some cases the compressed file size is larger than the uncompressed format.
conf_mouse_anim
no*, yes
Displays the presenter's mouse movements on the screen during a shared Creo Parametric session.
create_numbered_layers
no*, yes
Creates the default layers numbered 1 through 32 in drawing mode, and in part and assembly modes when no template is used.
def_layer
layer_<item_type
Adds item types to the specified default layer name. The variables, or item types, follow:
layer_annotation_element, layer_assem_member, layer_assy_cut_feat, layer_axis, layer_chamfer_feat, layer_comp_design_model, layer_comp_fixture, layer_comp_workpiece, layer_copy_geom_feat, layer_corn_chamf_feat, layer_cosm_round_feat, layer_cosm_sketch, layer_csys, layer_curve, layer_curve_ent, layer_cut_feat, layer_datum, layer_datum_plane, layer_datum_point, layer_detail_item, layer_dgm_conn_comp, layer_dgm_highway, layer_dgm_rail, layer_dgm_wire, layer_dim, layer_draft_constr, layer_draft_dim, layer_draft_dtm, layer_draft_entity, layer_draft_feat, layer_draft_geom, layer_draft_grp, layer_draft_hidden, layer_draft_others, layer_draft_refdim, layer_driven_dim, layer_dwg_table, layer_ext_copy_geom_feat, layer_feature, layer_geom_feat, layer_gtol, layer_hole_feat, layer_intchg_funct, layer_intchg_simp, layer_nogeom_feat, layer_note, layer_parameter_dim, layer_part_refdim, layer_point, layer_protrusion_feat, layer_quilt, layer_refdim, layer_rib_feat, layer_ribbon_feat, layer_round_feat, layer_sfin, layer_shell_feat, layer_skeleton_model, layer_slot_feat, layer_snap_line, layer_solid_geom, layer_surface, layer_symbol, layer_thread_feat, layer_trim_line_feat, layer_weld_feat
default_dec_places
2*
Sets the default number of decimal places (0-14) fornonangulardimensions in all model modes. It does not affect the decimal places as modified using Num Digits.
default_dim_num_digits_changes
yes*, no
Sets the default number of digits in a dimension to the last entered value. If you set this option to no, the system defaults to the value specified for the configuration option default_dec_places.
default_geom_analysis_type
quick*, saved, feature
Sets the default analysis type in geometry analysis tools. Some geometry analysis tools such as Offset, Draft, Reflection, and Shadow do not have the Feature analysis type. For such tools, Creo Parametric sets the default analysis type to Quick even if you set this configuration option to feature.
default_layer_model
<model name>
Specifies the name of the model that is used to drive the rule-based layer.
default_placement_surfacefinish
normal_to_Entity*, with_leaders, on_entity, free
Sets the default placement type for surface finish annotations within the Surface Finish dialog box.
normal_to_Entity—Attaches the symbol directly to a surface of the model such that the annotation is placed normal to the selected surface and in the annotation plane. However, if the annotation plane is not normal to the selected entity, then the surface finish annotation too is not normal to the entity.
with_leaders—Attaches the symbol to model surfaces using leaders.
on_entity—Attaches the symbol directly to a surface of the model.
free—Places the symbol without attaching it to model geometry.
default_tolerance_mode
nominal, limits*, plusminus, plusminussym
Sets the default display for dimension tolerances.
nominal—Displays dimensions without tolerances.
limits—Displays dimensions as upper and lower limits.
plusminus—Displays dimensions as nominal with plus-minus tolerances (the positive and negative values are independent).
plusminussym—Displays dimensions as nominal with a single value for both the positive and the negative tolerance.
 
* Groups brought in from other models carry the tolerance display mode that was in effect when they were created.
disable_search_path_check
no*, yes
Controls whether the search path is checked for name conflicts when creating, renaming, or copying models. A check ensures that only models with unique names are in session.
display
shade*, wireframe, hiddenvis, hiddeninvis, shadewithedges, shadewithreflect
Displays the model with all lines as specified. The display of lines is reflected in plotter, DXF, and IGES files.
shade—Displays all surfaces shaded.
wireframe—Displays all lines in black.
hiddenvis—Displays hidden lines in grey.
hiddeninvis—Removes hidden lines from the display.
shadewithedges—Displays all surfaces shaded with edge lines in black.
shadewithreflect—Displays all surfaces with high visual quality but slower enhanced realism, except for drawing models.
display_annotations
yes*, no
Controls the display of annotations in the graphics window in 3D models.
display_axes
yes*, no
Displays the datum axes.
display_axis_tags
no*, yes
Displays the name tags for the datum axis.
display_coord_sys
yes*, no
Displays the datum coordinate systems.
display_coord_sys_tags
yes*, no
Displays the name tags for the coordinate system.
display_full_object_path
no*, yes
Displays the object’s file name (including its object-type suffix and its version number) and its file path in the window title and Model Info display.
no—Displays only the object's name.
yes—Displays the object's full name and its file path.
display_layer
0*, <layer ID>
Displays the specified layer in pre-Release 9.0 objects when you begin a Creo Parametric session. This configuration option is valid for layer IDs 1 – 32. After the object is stored in Release 9.0 or later, this setting is no longer necessary.
display_plane_tags
no*, yes
Displays the datum tags.
display_planes
yes*, no
Displays the datum planes.
display_point_tags
no*, yes
Displays datum point tags.
display_points
yes*, no
Displays datum points and their names.
display_popup_viewer
file_open_only*, yes, no
Controls the display of the popup viewer depending on the values you specify. The values are as follows:
file_open_only—Displays the popup viewer only in the File Open dialog box. This is the default.
yes—Displays the popup viewer in the File Open dialog box, Creo Parametric browser, and the Model Tree.
no—Disables the display of the popup viewer
display_tol_by_1000
no*, yes
Displays tolerances for nonangular dimensions multiplied by 1000.
display_z_extension_lines
yes*, no
Controls the creation of Z-extension lines in driven dimensions.
dm_http_compression_level
0*
Sets the data compression factor (0–9, 0 = no compression) for data exchange with a Windchill server. Higher compressions can speed up uploads for a client over a slow network.
dynamic_preview
attached*, unattached, no
Controls the default state of geometry preview within the feature creation user-interface.
attached—Displays the geometry as it appears when you finalize the feature.
unattached—Displays the outline of the geometry you are defining.
no—Displays no preview.
edge_display_quality
normal*, high, very_high, low
Controls the display quality of an edge for a wireframe and for hidden-line removal by varying the tessellation.
normal—Provides a normal quality of edge display.
high—Increases tessellation by a factor of 2.
very_high—Increases tessellation by a factor of 3.
low—Decreases tessellation compared to normal, thus speeding up the display of an object.
enable_fsaa
Off*, 2X, 4X, 8X, 16X, 32X
Controls Full Screen Anti-Aliasing (FSAA) functionality. When enabled the display quality of the edges, curves, datums is smoother. As you move the setting from 2X to 32X the quality improves.
enable_learning_connector
yes*, no
Enables the Learning Connector, which provides links to context specific access to videos, training, help topics, and technical support articles. When the configuration option is set to yes, the Learning Connector button appears next to
enable_popup_help
yes*, no
Enables pop-up Help in the dialog boxes.
enable_transparent_text_bg
Yes*, No
Clears the background before displaying text.
export_report_format
comma_delimited*, rich_text
Controls the format in which the exported report is saved when you click Export Report in the difference report that is displayed as an HTML page in the embedded browser.
comma_delimited—Exports the report in comma separated value format, that is, the .csv format.
rich_text—Exports the report in text format, that is, the .txt format.
fast_highlight
no*, yes
Improves the performance of highlighting and reorienting large assembly models, regardless of display style (wireframe, hidden line, no hidden line, and shaded).
no—Uses standard highlight.
yes—Uses fast highlight. When you select components, the model geometry (solid, surface) and associated annotations, curves, and cables are highlighted. Datums of a selected component do not highlight unless they are also selected. For models of modest size and complexity, the slight increase in performance may not warrant the additional memory required to support this option.
file_timestamp_format
%dd-%Mmm-%yy %Hh:%mi:%ss %PM*
Controls the format of timestamps when you view a listing of files and directories in Web pages generated by Creo Parametric in the Creo Parametric browser and in dialog boxes. The format for the value of the configuration option is a string consisting of up to seven part: the year, month, and date, the hours, minutes, seconds, and the AM or PM designator. You can specify the parts in any order.
The default value is %dd-%Mmm-%yy %Hh:%mi:%ss %PM in most languages. However, in Japanese-language sessions, the default value is %yyyy/%mm/%dd %hh:%mi:%ss.
You can use the following formats when specifying the value of the timestamps:
%yyyy—4-digit year (for example 2005)
%yy—2-digit year (for example 05)
%MMM—Month (for example SEP)
%Mmm—Month (for example Sep)
%Month—Full month name (for example September)
%mm—Month number, padded to 2 digits (for example 09)
%m—Month number (for example 9)
%dd—Date, padded to 2 digits (for example 05)
%d—Date, no padding (for example 5)
%Hh—Hour, 12-hour format (for example 12)
%hh—Hour, 24-hour format (for example 00)
%PM—AM or PM
%mi—Minutes
%ss—Seconds
file_open_default_folder
working_directory, in_session, my_documents, pro_library, workspace, commonspace
Sets default directory from which to open a file when using File > Open.
working_directory—Searches the working directory.
in_session—Searches objects in session.
my_documents—Searches the My Documents folder.
pro_library—Searches the Library directory in Library.
workspace—Searches the Workspace in PDM application.
commonspace—Searches the Commonspace in Pro/INTRALINK.
default—Searches for the My Documents folder on Windows when you click File > Open, Creo Parametric opens the directory where the previous File Open dialog box was closed. In a linked session with a PDM application, searches the active workspace.
flip_arrow_scale
1.000000*
Sets a scale factor for enlarging the flip arrow for the direction for feature creation.
force_new_file_options_dialog
no*, yes
Forces the use of the New File Options dialog box when you click File > New. The Use default template check box in the New dialog box becomes unavailable.
full_hlr_for_cables
full*, partial, none
Determines whether hidden lines are shown or hidden with cables.
full—Removes the hidden lines from view when cables hide other geometry (only available when Hidden line is active).
partial—Cables hide other noninterfering cables, except when cables are routed together between the same locations.
none—Hidden lines are displayed, so the display process is faster.
general_undo_stack_limit
50*
Sets the number of undo or redo operations. If the number of operations exceeds 50, the first operation in the stack of operations is removed first, and so on.
geometry_analysis_color_scheme
<directory path>
Sets the location of the .txt file that contains the color scheme settings of geometry analysis color scale.
global_appearance_file
<directory name>
Sets the default directory for the global.dmt file. Use the full path to avoid problems.
highlight_geometry
yes*, no
Specifies whether items you select on the Model Tree are highlighted in the graphics area.
highlight_layer_items
yes*, no
Specifies whether items you select in the Layer Tree highlight in the graphics area.
info_output_format
html*, text
Sets the default format type for presentation of system information.
info_output_mode
both*, choose, file, screen
Sets the default method of presenting system information for audit trails, BOMs, names, and models. All other output displays on the screen.
both—Displays the output and writes it to a file.
choose—Displays the INFO OUTPUT menu, so you can choose the method of output.
file—Writes the output to a file.
screen—Displays the output.
kbd_cmd_abbreviation
off*, on
Enables or disables the use of abbreviations when you enter commands from the keyboard.
kbd_selection
no*, yes
Enables or disables the keyboard for selecting locations in the graphics area. If set to no, use of the mouse is required.
last_session_directory_path
<dir_path>
Sets the path for the pseinfo directory that contains the temporary files that store the information of the last Creo Parametric session. The default path is WFROOT/.Settings directory, where WFROOT directory is controlled by the environment variable PTC_WF_ROOT.
last_session_retrieval
yes*, no
yesCreo Parametric saves the information of the model and current environment settings to temporary files.
These files are saved in the pseinfo directory located at the path specified by the last_session_directory_path configuration option. Creo Parametric uses information from the previous session to retrieve models and environment settings in the next session.
no—Does not save the information of the model and environment settings of a session during exit of a Creo Parametric session. Therefore, the information from the previous session cannot be retrieved in the next session of Creo Parametric.
layer_item_highlight_limit
<integer>
Sets the upper limit for number of items that are highlighted in the graphics area. This limit is applicable to the items in the selected layers.
linear_tol
0 0.000000-1*
Sets the default linear tolerance dimensions. The first number in the value is an integer and indicates the decimal place being set in the tolerance, the second sets the actual tolerance value, and the third number indicates the number of decimal places displayed in the tolerance.
For example, if you set the value to 6 0.017550 5, Creo Parametric displays the tolerance as 0.01755. In this example, the value 6 0.017550 5 sets the tolerance to 6 decimal places, the default tolerance value to 0.017550, and the number of decimal places to be displayed to 5.
For integer dimensions, the integer would be 0 and the tolerance would be an integer. For example, 0 1 sets a tolerance of 1 for integer dimensions.
Any modifications to these options affect only new models that are created after the option modification.
linear_tol_0.0
<integer (range 0-9)>
Specifies a range for default tolerances of linear and angular dimensions.
These values affect only models created after the tolerance options are specified in the configuration file. Any subsequent modifications to these options affect only new models that were created after the option modification.
Similarly, you can also use the following configuration options with the same default value of the linear_tol_0.0. configuration option.
linear_tol_0.00
linear_tol_0.000
linear_tol_0.0000
linear_tol_0.00000
linear_tol_0.000000
lods_enabled
no*, yes
Uses level of detail (lod) in shaded models during dynamic orientation (panning, zooming, and spinning). During runtime, you can override this setting by clicking Tools > Levels of detail > Environment.
maintain_limit_tol_nominal
no*, yes
Maintains the nominal value of a dimension regardless of the changes that you make to the tolerance values.
mapkeys_execution
no_feedback*, execute_with_feedback, stop_at_failure
no_feedback—Provides no feedback when you run a mapkey.
execute_with_feedback—Displays a message on encountering a failure when you run a mapkey.
stop_at_failure—Stops on encountering a failure when you run a mapkey and displays a message
mass_prop_load_from_file
by_request*, always
Controls the use of values from the mass properties file for mass property calculation. The configuration option is applicable only when the value of the parameter PRO_MP_SOURCE is assigned. You can set the value from Relations, Mass Properties, Parameters, Family Table dialog box.
by_request—Uses the values in alternative parameters for mass property calculation. The mass properties file is used once for initialization of alternative parameters from Mass Properties dialog box.
always—Uses the values in the mass properties file for mass property calculation. The values in the mass properties file override the previous values of the alternative parameters.
mdl_tree_cfg_file
<path>
Specifies the Model Tree configuration file to be loaded when you start Creo Parametric.
measure_auto_replace_mode
yes, no*
Specifies how references are replaced in the Measure dialog box. Applies to distance, angle, and transform measurements only.
yes—For distance, angle, or transform measurements, when two references are selected, and you select a new reference, the new reference automatically replaces the second selected reference.
no*—References are not automatically replaced in the Measure dialog box. You must right-click a reference, choose Replace from the shortcut menu, and select a new reference.
measure_dec_places
-1*, <integer>
Controls the number of digits displayed after the decimal point for the measure analysis tools. If you do not change the default of -1, Creo Parametric uses the setting of the measure_sig_figures configuration option.
measure_dialog_expand
yes, no*
Specifies whether the Measure dialog box opens in an expanded condition by default.
yes—Opens the Measure dialog box fully expanded.
no*—Opens the Measure dialog box in the same condition as it was the last time it closed, either expanded or collapsed.
measure_ref_option_status
default*, all_on, all_off, keep_last
Specifies whether the reference entity options are automatically selected in the Measure dialog box.
default*—The system determines whether an option is selected based on the references and the measurement type.
all_on—Options are selected whenever they are available.
all_off—Options are not selected.
keep_last—Options are in the same condition that they were the last time the Measure dialog box closed, either selected or not.
measure_sig_figures
6*
Sets the number of significant figures in the results when you use the Model Size dialog box from the Info menu. The maximum value is 11.
menu_font
<variables>
Specifies the font used in the Creo Parametric menu bar, menus, and all their children. Provide the comma-delimited variables in any order, for example, italic bold, 24, times or 24,times, italic bold have the same effect. Any omitted variable uses the standard setting.
menu_manager_position
adaptive*, inside, outside
Determines the location of the Menu Manager.
outside—Positions the Menu Manager outside the active Creo Parametric window, such that the top-left corner of the menu manager is placed adjacent to the top-right corner of the active Creo Parametric window.
inside—Positions the Menu Manager inside the graphics area, such that the top-right corner of the Menu Manager is placed on the top-right corner of the graphics area.
adaptive—Positions the Menu Manager inside the graphics area when the space outside the Creo Parametric window is not adequate to contain the horizontal width of the Menu Manager.
menu_mapper_location
<directory path>
Sets the path to the Menu Mapper. When you click Help > Menu Mapper, Creo Parametric launches the Menu Mapper from the specified location.
The default path is http://www.ptc.com/community/proewf3/menu_mapper/en/index.htm.
mesh_spline_surf
no*, yes
Displays the blue mesh surface lines.
model_detail_options_file
$PRO_DIRECTORY\text\3d_inch.dtl*,<file name>.dtl, <file path with file name>
Sets the default model detail options values for new models.
model_notes_as_labels
no*, yes
Determines whether model notes display as full text (default) or labels.
model_tree_start
yes*, no
modify_abs_accur_on_interpret
yes*, no
Sets the default for whether or not the absolute accuracy value is interpreted when the model is interpreted using File > Prepare > Model Properties > Units > change > Set > Interpret dimensions.
Displays the Model Tree with its model (default).
modify_abs_accuracy_on_convert
yes*, no
Sets the default for whether or not the absolute accuracy value is converted when the model is converted using File > Prepare > Model Properties > Units > change > Set > Convert dimensions.
modify_abs_accuracy_on_scale
yes, no*
Sets the default for whether or not the absolute accuracy value is scaled when the model is scaled using Operations > Scale Model.
mp_analysis_default_source
MP_SOURCE*, Assigned, Computed
Sets the default value for the calculation option when you open the Mass Properties dialog box during mass properties analysis.
native_kbd_macros
no*, yes
Specifies support of keyboard macros in a native language, for example, German, rather than only English.
number_user_colors
200*
Specifies the maximum number of user-defined colors that are available within the Appearance Editor and the Entity Colors dialog boxes.
old_style_set_datum
yes*, no
Specifies whether to display in the Datum or Axis dialog box. The button allows you to create set datum tags with the old-style display.
 
* Even if the value of old_style_set_datum configuration option is set to no, the appears in the Datum or Axis dialog box when modifying a pre-existing old-style set datum.
online_resources_location
<directory path>
Sets the path to Online Resources. When you click Help > Online Resources, Creo Parametric launches the Online Resources page from the specified location.
The default path is http://www.ptc.com/community/proewf3/newtools/index.htm.
open_simplified_rep_by_default
no*, yes
Opens the Open Rep dialog box by default if you click Open on the File Open dialog box.
orientation
trimetric*, isometric, user_default
Establishes the initial default view position, or orientation. After you set the configuration options for x_axis and y_axis,the system defaults to the user-defined values. To override the orientation at runtime, click View > Orientation > Standard Orientation.
trimetric—Orients the model trimetrically.
isometric—Orients the model isometrically.
user_default.—Orients the model in the position specified in the configuration options x_axis and y_axis If you do not define these options, the system defaults to trimetric.
orientation_style
dynamic*, anchored
Sets the default viewing style irrespective of whether the Orient mode is enabled or disabled, that is, you are outside Orient mode or in the Orient mode, respectively. When Orient mode is enabled, you may change the viewing style as required.
dynamic—The Orientation Center is displayed as . Orientation is updated as the pointer moves. The model spins freely about the Orientation Center.
anchored—The Orientation Center is displayed as . The orientation is updated as the pointer moves. Model rotation is controlled by the direction and distance the pointer is moved from its initial position. The Orientation Center changes color at each 90-degree interval. When the pointer returns to the original position, the view is reset to where you started.
override_store_back
no*, yes
Stores all retrieved objects in the current working directory.
no—Stores objects in their original directories. If you do not have write permission to the original directory, the configuration option save_object_in_current takes effect.
yes—Stores objects in the current working directory.
parenthesize_ref_dim
no*, yes
Encloses reference dimensions in parentheses. If set to no, the reference dimensions are followed with the text "REF."
part_mp_calc_ignore_alt_mp
yes*, no
By default, to calculate the mass properties, Creo uses the calculated mass (mass=volume*density). If you set the value of the configuration option to no then Creo uses the value of PRO_MP_ALT_MASS (alternative mass) that you defined to calculate part mass properties if PRO_MP_SOURCE is Geometry and Parameters or Fully Assigned.
pick_aperture_radius
7.000000
Specifies the size of the area about the mouse when making selections. Units are 1/1000 of screen size.
planar_xsec_default_type
offset*, through
Set the default value for the constraint type for the planar cross sections.
plot_names
yes*, no
no—Gives plot files, except PostScript plots, the extension plt.
yes—Gives all plot files descriptive extensions:
hp—For Hewlett-Packard
hp2—For Hewlett-Packard hpgl2
cal—For Calcomp
ver—For Versatec
ger—For Gerber photoplotters
ps—For PostScript (including color)
preferred_save_as_type
*.prt *.igs *.set *.vda *.neu *.stp *.ntr *.ct *.cat *.stl *.iv *.obj *.slp *.unv *.wrl *.enm *.evs *.mdb *.edn *.emp *.evs *.edp *.gbf *.asc *.facet *.sat *.model *.ed *x_t *.ed*.jpg *.shd *.eps *.tif*.pic *.zip
Sets the order of the file types to customize the Type list in the Save a Copy dialog box.
prehighlight
yes*, no
Highlights selectable items beneath the pointer before selection. Prehighlighting provides a visual check to confirm that you will select the intended item.
prehighlight_tree
no*, yes
Specifies whether the selectable items beneath the pointer on the Model Tree, the Layer Tree, or the 3D Detail Tree are highlighted before you select them.
pro_colormap_path
<directory path>
Specifies the directory path for a color map (.map) file to be loaded from disk. Use the full path to avoid problems.
pro_crosshatch_dir
<directory name>
Specifies a default directory for your crosshatch library in which you can save crosshatching patterns for later retrieval. Use the full path of the default directory.
pro_datum_target_dir
<directory name , loadpoint/symbols/targets>
Sets the default directory for your user-defined datum target symbols. Use the full pathname to avoid problems. For example, /home/users/library/datum_target.
pro_editor_command
<command>
Enables an editor other than the system editor when the optional editor has been specified as the value for the option relation_file_editor.
The command specified will be executed as it is typed in the config.pro file. If the command does not open a new window, you can start the editor in the system window used to start Creo Parametric.
pro_material_dir
<directory name>
Sets the default directory for the part material library. Use the full path to avoid problems. For example, /home/users/library/material.
pro_plot_config_dir
<directory name>
Sets the directory of your user-defined plotter configuration file. Use the full path to avoid problems. For example, /home/users/plot_dir.
pro_unit_length
unit_inch*, unit_foot, unit_mm, unit_cm, unit_m
Sets the default units for new objects.
pro_unit_mass
unit_pound*, unit_ounce, unit_ton, unit_gram, unit_kilogram, unit_tonne
Sets the default units for mass for new objects.
prompt_on_erase_not_disp
no*, yes
Displays a prompt so you can choose whether to save undisplayed objects before they are erased. This option is used with the Erase > Not Displayed command on the View menu.
no—Erases all undisplayed objects without a prompt.
yes—Prompts you to choose whether to save undisplayed objects.
prompt_on_exit
no*, yes
Prompts you whether to save objects when you exit a Creo Parametric session. Your objects are not saved unless you set the option to yes.
propagate_change_to_parents
no*, yes
Determines which parent models to save when the option save_objects is set to changed or changed_and_specified.
no—Saves only parent models that have actually been changed.
yes—Saves any model that is a parent of a changed model.
propagate_inactive_annotation
yes*, no
Propagates inactive annotations.
provide_pick_message_always
no*, yes
Displays a description of an item in the message area after each selection.
no—Displays descriptions for an item only while querying
yes—Displays descriptions for items in all case, even when Query is not used. Queries include preselection highlighting, Next and Previous, and selections.
quick_print_drawing_template
<path and drawing template name>
Specifies the path and name of a drawing template to be used by the File > Print > Quick Drawing command.
quick_print_plotter_config_file
<path name to the plotter .pcf file>
Specifies the path and name of the default plotter configuration file (*.pcf) to be used by the File > Quick Print command.
If plotter is set to ms_print_mgr, no other options are necessary. If it isn't set to ms_print_mgr, adding to the plotter configuration file the values for plot_file_dir and plotter_command is recommended.
read_famtab_file_on_retrieve
no*, yes
no—Ignores filename.ptd.
yes—Creates and saves filename.ptd and uses that file on generic retrieval.
regen_backup_using_disk
no*, yes
Specifies whether the current model is backed up before each regeneration.
regen_backup_directory
<current directory>*, <dir_path>
Specifies the directory in which the system stores the backed up models. The primary default is the current directory. However, if that directory is read-only, the secondary default is the /tmp directory.
relation_file_editor
<editor>
Sets the editor used to edit relations.
relation_text_trail_output
yes*, no
Includes or excludes changes in the text area of the Relations dialog box in the trail file.
relation_tool_mapkey_behavior
Increment*, full_output
Controls how Creo Parametric runs mapkeys in the Relations dialog box.
Increment—Records the text set added or removed in the text area and saves it to the mapkey. Subsequently, on running the mapkey, adds or removes text incrementally to the current text set in the text area.
full_output—Records the original text set in the text area and saves it to the mapkey. Subsequently, on running the mapkey, the current text set in the text area is replaced with the recorded text set.
 
* You cannot record mapkeys if the value of relation_text_trail_output is set to no. However, you can run a mapkey that was recorded with this configuration option set to yes, regardless of this options's setting when you run the mapkey.
relations_num_const_units
yes*, no
Checks for units in a relation, issues a warning if units are missing, and prompts you to apply units.
If you want to add a relation to nonsolid models, such as notebook and bulks, you must always specify units for numeric constants. The setting of this configuration option is ignored for nonsolid models.
relations_units_sensitive
yes*, no
Checks for units when solving relations.
yes—Takes units into account. If units are missing, a warning appears.
no—Ignores units.
rename_drawings_with_object
none*, part, assem, both
Controls whether the system automatically copies drawing files associated with the part or assembly object types. The drawing files must have the same name as their objects.
none—Excludes the associated drawing when saving copies.
part—Copies the associated drawings of a part.
assem—Copies the associated drawings of an assembly and its components.
both—Copies the associated drawings for both parts and assemblies.
To ensure that only objects with unique names are in session, use the default no for disable_search_path_check. The system checks the search path for objects with duplicate names.
restricted_val_definition
<file name>
Specifies the location and name of the external file that contains definitions of the restricted-value parameters. Use the full directory path and name.
retain_display_memory
yes*, no
Determines whether the display of an object on the screen is kept in memory when you quit the window. The default yes speeds up the retrieval of objects.
retrieve_data_sharing_ref_parts
no*, yes, ignore_missing
Retrieves the referenced parts for dependent features with shared data, such as Inheritance, External Copy Geometry, External Shrinkwrap, and External Merge.
no—Ignores referenced parts in the retrieval.
yes—Prompts the user to accept each referenced part during the retrieval.
ignore_missing—Skips any missing referenced part, sends a message to that effect, and continues the retrieval process.
save_clipped_view
no*, yes
Specifies whether to save the model in the view clipped state.
save_dialog_for_existing_models
no*, yes
Controls whether the Save Object dialog box is shown when the storage location of the models is already known.
save_display
no*, yes
Displays the geometry and detail items, such as solid dimensions, in View-Only mode. Use this option to decrease model retrieval time. To override this setting during runtime, click Tools > Environment, and then select or clear Save display under Default actions.
save_instance_accelerator
saved objects*, none, explicit, always
Determines how instances are saved with the Family Tables of solid parts.
saved objects—Saves instance accelerator files if,
The instance is modified in one of the following ways.
Feature redefinition
Feature rerouting
Reference replacement
Feature reordering
Component replacement
Object integration
The instance verification status is not set to Failed.
The instance verification status is set to Unverified. In this case, when creating the accelerator file, Creo Parametric displays a message stating that the accelerator file was created for the nonverified instance.
none—Does not save instance accelerator files.
explicit—Saves instance accelerator files only when you explicitly save instances.
always—Always saves instance accelerator files, regardless of whether you are saving an instance explicitly or through a higher-level object.
You can override this configuration option at runtime by clicking File > Instance Operations, and clicking another command on the associated INST DBMS menu.
save_model_display
shading_lod*, wireframe
By default, the system always stores wireframe data in both parts and assemblies. The only information that the system saves in the assembly .asm file is the display setting of components that are intersected by assembly features. No shade data is saved with the file from creo 4. If option is set to shading_lod, the shade data is created on the fly on retrieval. This is not done if option is set to wireframe.
shading_lod—Saves wireframe data and shade data is generated on the fly on retrieval.
wireframe—Stores wireframe data in both parts and assemblies for a wireframe of the components.
save_modified_draw_models_only
yes*, no
Determines whether the system saves the model after you have changed it. If set to no, the system saves the model every time that you store the drawing.
save_object_in_current
no*, yes
Saves the object retrieved from a directory where you do not have write permission. See the override_store_back option. The objects to be saved are set by the save_objects configuration option.
no—Does not save the object.
yes—Saves the object in the current directory.
save_objects
changed_and_specified*, all, changed, changed_and_updated
Determines when an object and its dependent objects, such as a part used in an assembly, are stored.
changed_and_specified—Saves the top-level object plus any modified, dependent objects.
all—Stores all objects.
changed—Stores only modified objects.
changed_and_updated—Stores changed and modified objects.
save_unchanged_pdm_object
as_ref*, as_copy
Determines how to save an object retrieved from a Pro/PDM database. The object is saved in the current working directory.
as_ref—Saves the object as a reference only, that is, as a pointer to the Pro/PDM database.
as_copy—Saves the unchanged object.
saving_model_thumbnails
yes*, no
Saves a thumbnail image of the model to the Creo Parametric file.
search_path
<directory path>
Specifies an ordered list of directories in which to search for object or file retrieval. These directories, along with the current (working) directory and any directories in the search.pro file (see the configuration file option search_path_file) make up the Creo Parametric search path.
Separator Characters and Search Paths
You must enclose in quotation marks any search path with a separator character (space, comma, or semicolon) in a directory name, for example:
Windows: search_path "C:\Program Files\proe2001\models"
 
* For Windows NT, omit the last backslash (\) from the path, or enclose the path in quotation marks, or add a trailing space after the backslash.
Relative and Absolute Paths
The directory path names can be relative or absolute. You can use special characters, such as ".." in Windows, in specifying a relative path name.
Relative path names are initially resolved relative to the startup directory. If you subsequently reload the configuration file, the system reevaluates the relative path names relative to the current working directory and appends the new directories (if any) to the search path (the previous path remains in place).
It is better, therefore, to specify the full path names always (in other words, from root) so as to avoid problems if you change working directories or use the same configuration file in another startup directory.
Using More Than One Path
The option can have several path names on a single line, separated by commas, semicolons, or spaces. Whichever delimiter you choose, you must then use consistently. The option can appear any number of times in the configuration file, so it is not necessary to have more than one path name to a line. If objects with the same name are stored in more than one search-path directory, the system retrieves the first one that it finds, regardless of which object is the most recent.
Previously Defined Environment Variables
Search paths may also include previously defined environment variables. This is done by preceding the variable with $ in the search path definition. For example, the environment variable OBJ_TYPE can be used as follows:
search_path /partlib/$OBJ_TYPE/objs
search_path_file
<path>
Specifies the location of the search.pro file, which contains a list of directory path names. These directories, along with the current working directory, and any directories specified by the configuration option search_path, make up the Creo Parametric search path.
In the search.pro file, you specify an individual directory path on each line, starting with the first line in the file. Blank lines and comment lines (which begin with !) are permitted.
You can specify either the path for the search.pro file or just the path to the directory containing that file. In the latter case, the system looks for search.pro in that directory. Use the full path rather than a relative one to avoid problems if you change working directories or use the same configuration file in another startup directory.
Separator Characters and Search Paths
You must enclose in quotation marks any search path with a separator character (space, comma, or semicolon) in a directory name, for example:
Windows: search_path "C:\Program Files\proe2001\models"
 
* For Windows NT, omit the last backslash (\) from the path, or enclose the path in quotation marks, or add a trailing space after the backslash.
sel_insts_on_comp_retrieval
no*, yes
Prompts you to choose an instance when you retrieve instances of a family of assemblies and the table-driven components used in the assembly instances are themselves generics.
select_on_dtm_edges
all_modes*, sketcher_only
Specifies the method of selecting a datum plane. If you use Query frequently, set this option tosketcher_only.
all_modes—Click the visual boundary of the datum plane.
sketcher_only—Click the tag of the datum plane in modes other than Sketcher.
set_trail_single_step
no*, yes
Enables a trail file to be single-stepped by pressing ENTER.
shade_mfg_ref_models
yes*, no
Determines whether to process reference parts when generating the shaded image.
no—Does not shade reference parts (to save time).
yes—Shades reference parts.
shade_surface_feat
yes*, no
Displays surface features with shading.
shade_with
curves*, no
Displays datum curves on shaded objects.
shade_with_edge_tangent
yes*, no
Controls whether tangent edges are displayed in Shading With Edges mode or not.
show_dim_sign
no*, yes
Shows positive or negative values for dimensions. Dimensions for coordinate systems and datum point offsets always show negative or positive values, even if this option is set to no.
no—Displays positive dimensions by creating the geometry to the opposite side, if you enter a negative value for the dimension.
yes—Displays negative dimensions by creating the geometry to the same side, if the dimension you modify is negative, and if you enter a negative value.
show_selected_item_id
no*, yes
Specifies whether to display IDs of the items listed in the Pick From List dialog box for the queried model geometry or dimensions.
show_sketch_dims_in_feature
yes, no*
Sets the default display state of internal sketch dimensions in the feature definition environment.
spherical_map_size
256x256*, 512x512, 1024x1024
Specifies the size of the texture image of the spherical map (resolution) to be used for realtime rendering. Increasing the image size affects performance but improves quality of the image.
 
* This option is valid only in the OpenGL graphics mode and for graphics cards that do not support cubic environment mapping.
spin_center_display
yes*, no
Determines whether the spin center symbol is displayed.
To override the display setting during runtime, click Tools > Environment, and then select or clear Spin Center under Display in the Environment dialog box.
spin_rate_zoom_sensitive
no*, yes
Controls the sensitivity of the model to rotation.
yes—Reduces the sensitivity of the model to rotation.
spin_with_orientation_center
yes*, no
Displays the orientation center while reorienting the model.
spin_with_part_entities
no*, yes
Displays datum features during the dynamic spinning of a model.
spin_with_silhouettes
no*, yes
Displays silhouette lines during the dynamic spinning of a model.
start_model_dir
<directory path>
Provides the full path to the directory containing start parts and assemblies. For example:
start_model_dir C:\Users\Johndoe\Pro\Start_Models
start_model_dir/users/johndoe/pro/start_models
system_background_color
<0.000000 0.000000 0.000000
Defines the background color of the graphics window. The three real numbers from 0–100 specify a percentage of red, green, and blue, respectively, in the resulting color. For example, 0 0 49 defines a medium blue.
system_colors_file
<path>
Specifies the full path within theconfig.pro file that sets the default color of the graphics. To change the colors in session, click File > Options > System Colors, and then expand a list in which to change a system color.
In the system colors file, you can define default RGBvalues (<0.0000000.000000 0.000000 ) for the various graphics. See the next table. The three real numbers from 0–100 specify a percentage of red, green, and blue, respectively, in the resulting color. For example,0 0 49 defines a medium blue. The RGB values are identical to those in the R,G, and B boxes in the Color Editor dialog box. To access this dialog box, click a color button to open the color palette and then click More Colors.
Configuration Option
Graphics Affected
User Interface Option
system_background_color
background of the graphics window
Background
system_curves_color
curve entities
Curves
system_dimmed_menu_color
unavailable menu items
Highlight - Secondary
system_edge_high_color
edges
Highlight - Edge
system_geometry_color
solid wireframe entities
Geometry
system_hidden_color
hidden, solid wireframe entities
Hidden Line
system_highlight_color
primary highlight color
Highlight - Primary
system_letter_color
datum tags
Letter
system_section_color
datum entity labels or tags
Sketched Curve
system_sheetmetal_color
sheet metal parts
Sheet Metal
system_volume_color
Manufacturing volumes
Manufacturing Volume
system_curves_color
<0.000000 0.000000 0.000000>
Defines the default color for curve entities. The three real numbers from 0–100 specify a percentage of red, green, and blue, respectively, in the resulting color. For example,0 0 49 defines medium blue.
system_dimmed_menu_color
<0.000000 0.000000 0.000000>
Defines the default color of unavailable menu items. The three real numbers from 0–100 specify a percentage of red, green, and blue, respectively, in the resulting color. For example,0 0 49 defines a medium blue.
system_edge_high_color
<0.000000 0.000000 0.000000>
Defines the default color in which edges are highlighted. The three real numbers from 0–100 specify a percentage of red, green, and blue, respectively, in the resulting color. For example,0 0 49 defines a medium blue.
system_geometry_color
<0.000000 0.000000 0.000000>
Defines the default color of solid, wireframe entities. The three decimal values specify in order the percentage of red, green, and blue in the resulting color. For example, 0 0 49 defines a medium blue.
system_hidden_color
<0.000000 0.000000 0.000000>
Defines the default color for the display of hidden, solid wireframe entities. The three real numbers from 0–100 specify a percentage of red, green, and blue, respectively, in the resulting color. For example,0 0 49 defines a medium blue.
The system ignores this option if use_part_color_for_hidden_lines is set to yes.
system_highlight_color
<0.000000 0.000000 0.000000>
Defines the default color for the primary highlight color. The three real numbers from 0–100 specify a percentage of red, green, and blue, respectively, in the resulting color. For example,0 0 49 defines a medium blue.
system_letter_color
<0.000000 0.000000 0.000000>
Specifies the default RGB color for datum tags. The three real numbers from 0–100 specify a percentage of red, green, and blue, respectively, in the resulting color. For example,0 0 49 specifies a medium blue.
system_section_color
<0.000000 0.000000 0.000000>
Specifies the default color for sections. The three real numbers from 0–100 specify a percentage of red, green, and blue, respectively, in the resulting color. For example,0 0 49 defines a medium blue.
system_sheetmetal_color
<0.000000 0.000000 0.000000>
Specifies the default RGB value for sheetmetal parts. The three real numbers from 0–100 specify a percentage of red, green, and blue, respectively, in the resulting color. For example,0 0 49 specifies a medium blue.
system_volume_color
<0.000000 0.000000 0.000000>
Specifies the default color for Manufacturing volumes. The three real numbers from 0–100 specify a percentage of red, green, and blue, respectively, in the resulting color. For example,0 0 49 defines a medium blue.
tangent_edge_display
solid*, no, centerline, phantom, dimmed
Determines how edges between tangent surfaces are displayed.
solid—Displays edges as solid lines.
no—Does not display edges.
centerline—Displays edges in centerline font.
phantom—Displays edges in phantom font.
dimmed—Displays edges in a dimmed system color.
template_drawing
c_drawing.drw
Specifies the file name of the default drawing template.
template_solidpart
<filename>
Specifies the file name of the default drawing template for a part.
tol_display
no*, yes
Displays dimensions without or with tolerances.
tolerance_class
fine*, medium, coarse, very_coarse
Sets the default tolerance class for ISO-standard models. The system uses the tolerance class in conjunction with the dimension value when retrieving tolerances for general or broken-edge dimensions.
tolerance_standard
ansi*, iso
Sets the tolerance standard used when creating the model.
tolerance_table_dir
<directory path>
Sets the default directory for user-defined tolerance tables for ISO-standard models. All Holes and Shafts tables overwrite existing tables when loaded.
trail_delay
0*
Sets a delay in seconds between steps in a trail file.
trail_dir
<directory path>
Creates the trail file in the specified directory rather than in the startup directory.
use_8_plotter_pens
no*, yes
Specifies whether to support up to 8 plotter pens. The initial default is 4 pens.
use_part_color_for_hidden_lines
no*, yes
Uses a dimmed, user-defined part color for hidden lines and ignores the setting for system_hidden_color.
use_software_linefonts
no*, yes
no—Plots lines using the line font that most closely resembles the font used in Creo Parametric.
yes—Plots the exact line style used in Creo Parametric, dot by dot, dash by dash, and space by space.
visible_message_lines
<integer>
Sets the default number of message lines in the Creo Parametric message area.
warn_if_iso_tol_missing
no*, yes
Controls the display of a warning message in the Invalid ISO Tolerance dialog box. The Invalid ISO Tolerance dialog box is displayed when Creo Parametric validates an ISO tolerance table and finds a missing tolerance value in the selected table.
noCreo Parametric does not display a warning message.
yesCreo Parametric displays a warning message if a tolerance value in the selected table is missing.
When regenerating the model or the drawing, Creo Parametric saves a warning message in a log file for each dimension that has no corresponding tolerance value in the ISO tolerance table. After regenerating the model or the drawing, you can access this log file by clicking Info > Session Info > Message Log.
web_browser_history_days
20*
Stores history records for the Creo Parametric browser for the number of days specified.
web_browser_homepage
http://www.ptc.com/community/proewf/newtools/index.htm*
Specifies the path of the home page for the Creo Parametric browser.
windows_scale
1.000000*
Scales Creo Parametric windows with a given coefficient from 0.500000 through 1.000000. A value of 0.85 is usually adequate to allow dynamic menus to display to the right of the Creo Parametric window.
x_angle
0.000000*
Sets a default view orientation in degrees for models. The default orientation depends on which option—x_angle, y_angle, or orientation—is last in the configuration file. If none is used, the default is trimetric. See the orientation option.
 
* If these variables are in the configuration file, the settings appear in the Orientation dialog box: choose View > Orientation, select Preferences under Type, and look under Default Orientation.
y_angle
0.000000*
Sets a default view orientation in degrees for models. The default orientation depends on which option—x_angle, y_angle, or orientation—is last in the configuration file. If none is used, the default is trimetric. See the orientation option.
 
* If these variables are in the configuration file, the settings appear in the Orientation dialog box: choose View > Orientation, select Preferences under Type, and look under Default Orientation.