Fundamentals > Creo Parametric User Interface > The View Tab > Scenes > Modifying Lights
  
Modifying Lights
To Modify Lights from the Scene Dialog Box
1. On the View tab, click Scenes and click Edit Scene on the gallery. The Scene Editor dialog box opens.
2. Click the Lights tab.
3. Select the light that you want to modify.
4. In the Name box, you can specify a name for a light other than the default name. You cannot rename the default distant type of light.
5. Click the swatch to specify a color in the Color Editor for light bulb, spotlight, and distant light.
6. Select the source of light as follows:
Click Physical Light and select a type from the Light Presets list. If you select User Defined from the Light Presets list, do the following:
Select the source for the color temperature from the Color Temp list.
Adjust the Wattage slider to determine the wattage of the light source.
Adjust the Intensity slider to specify the intensity for the light.
 
* The Physical Light option is available for light bulb and spotlight.
7. Specify additional definitions for the spotlight:
Adjust the Angle slider to specify the angle of the Spotlight. Angle controls the size of the light beam. The spot angle is the diameter of the beam.
Use the Focus slider to adjust the focus of the light beam.
 
* Physical Light models physically correct light, where the light intensity falls off with the inverse square of the distance from the light source. The distance corresponds to model units.
8. Click Enable Shadows and use the slider to adjust the softness of the shadows.
 
You can enable shadows of a light one at a time. When you enable shadows for a light, previously enabled shadows of another light are disabled.
Change in softness of a shadow is visible when the Display Style is set to Shading With Reflection.
The values that you specify using the sliders can also be specified in the adjacent spin boxes for all the light types.
On the Photo-Realistic Render tab, when the real-time ray-tracing is activated, all the shadows are enabled, by default. You can change the softness of all these shadows in the scene
Select Show Light to display light in the graphics window. This enables you to adjust the position of the lights. In case of spotlights, the Show Light help in adjusting the spot angle.
9. From the Lock To list select one of the following options to fix the light to an object or view:
Studio—Fixes a light to the studio. The light illuminates the same point in the view at all times, independent model rotations.
Model—Fixes a light to the model. The light illuminates the same point on the model at all times, independent of the viewpoint.
Camera—The light is fixed in a position relative to the camera.
10. Click the Position and specify the following options in the Light Position dialog box:
Source Location—Positions the light in the x-, y-, or z-direction. This is independent of the default coordinate system. The z-direction is always perpendicular to the screen or view.
Aim Point Location—Aims the light.
 
* Aim Point Location is unavailable for light bulb, skylight, and environment light as these lights contain a number of light source points.
To Modify Lights from the Graphics Window
1. On the View tab, click Scenes and click Edit Scene on the gallery. The Scene Editor dialog box opens.
2. Click the Lights tab.
3. Select the light that you want to modify. The light icon is displayed in the graphics window.
Within the graphics window, you can modify the light in the following ways:
Place the pointer over the light source that you want to modify and drag it along the polar ring to the required location. To snap the light source to any geometry closest to the pointer, hold down the SHIFT key while dragging the light source.
You can move the aim point independently of the light source by dragging the aim point to the required location. This also changes the direction of the light. To snap the aim point to any geometry closest to the pointer, hold down the SHIFT key while dragging the aim point.
Change the spread angle of the spotlight by dragging the base edge of the spotlight. The base edge is highlighted when you move the pointer over it. You can also change the focus of the spotlight by dragging the arrowhead on the direction line of the aim point.
To move the entire silhouette sphere, drag the direction line of the aim point. In case of a spotlight, drag the black portion of the direction line to move the entire sphere.
 
* Changes to the light parameters in the graphics window are synchronized with the values in Lights tab and vice versa.