Fundamentals > User Interface Basics > Customizing the Non-ribbon User Interface > Customize Dialog Box
Customize Dialog Box
You can customize the user interface with the Customize dialog box. To open the Customize dialog box, click Tools > Customize Screen.
You can use this dialog box to:
Load different window configuration settings by loading a different file.
Specify the command buttons that appear in the window toolbars.
Add mapkeys and other commands to the menus and toolbars, move them from one location to another location, and remove them from the menus or toolbars.
Show or hide toolbar categories and customize the locations of toolbars on the screen.
Show commands for all categories using the All Commands option under the Categories section.
Control the location of the Model Tree and Navigation tabs.
Switch the display of icons in the top-level menus, using the Options > Menu display > Show icons command in the Customize dialog box.
* You can save the settings you make in the Customize dialog box. All settings are saved in the file. To save the settings, select Automatically save to (selected by default), and then accept the default file name, or enter a new file name, or navigate to the file in which you want to save the settings.
The following table lists the available commands in the Customize dialog box, along with a description of each command.
File > Open Settings
Opens the Open dialog box, from which you can load a different file.
File > Save Settings
Opens the Save Window Config Settings dialog box, in which you can save your current windows configuration settings as a new, custom configuration file with a new file name.
View > Show Mode Commands Only
Lists all commands that are applicable to active model of the current session.
Toolbars tabbed page
Allows you to add, remove, or reposition the available Creo Parametric toolbars
Commands tabbed page
Allows you to add (and delete) new menus and custom commands (including mapkeys) to the user interface. Also allows you to edit the image and text on a toolbar button, delete commands from the menu bar menus or toolbars, and set the relative position of individual toolbar buttons.
When you select a command name under Categories, its icon is displayed under Commands. The available commands are most helpful in the core modules, for example, Drawing, Sketcher, and Manufacturing. You can also place buttons that you have defined as mapkeys on the toolbar or on a menu bar menu.
Navigation Tabs tabbed page
Allows you to set placement and size of the Navigation tabs and the Model Tree, and show History by default.
Browser tabbed page
Allows you to set the width of the Creo Parametric browser, expand and animate it upon opening or closing Creo Parametric.
Options tabbed page
Allows you to change the size of secondary windows, and customize the menu display.
Automatically save to
Allows you to save settings automatically, in the custom named file of your choice, each time you make changes. The advantage of this option is that a could be easily modified and saved automatically, then read automatically when Creo Parametric is started at a later time.