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 PTC Product Focus  

What’s New in Sketcher for Wildfire 3.0 
 
With Pro/Engineer Wildfire 3.0 PTC has taken ease of use to the next level with several 
enhancements to Sketcher.  With this release it is easier to set up and enter sketcher, manage 
your sketch plane and reference plane before or after you enter sketcher, and easier to manage 
the references that are used for auto-dimensioning.  Below you will find information and 
descriptions for the following enhancements: 

• Cut, Copy, and Paste in Sketcher. 

• Locked/Modified Dimensions. 

• Sketcher Orientation Reference. 

• Sketch Setup. 

• Sketched Text. 

• Sketcher Palette. 

 
Cut, Copy and Paste in Sketcher 
 

You can use the cut and copy operations to remove or duplicate, respectively, a portion of a 
section or the complete section. You can cut or copy regular sketch geometry, construction 
geometry, centerlines, and strong dimensions and constraints associated with the selected 
geometry entities. The sketch entities that you cut or copy are placed on the clipboard.  

You can use the paste operation to place the cut or copied entities at a required location 
within an active section. When you perform the paste operation, the sketch geometry on the 
clipboard is not removed, allowing you to use the copied or cut sketch geometry multiple 
times. You can also use the cut, copy, and paste operations to move the contents of a 
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section across multiple sections. Additionally, you can translate, rotate, or scale the sketch 
geometry entities that you paste. 

You can undo or redo a cut or paste operation only in the current sketcher session.                                  

 
Locked/Modified Dimensions 
 
The locked state of the dimension is maintained when you quit or reenter the sketcher mode. 
Locking of dimensions allows you to avoid modifications made to the sections outside the 
sketcher mode by accidentally dragging a vertex or an entity. 
 
To Lock or Unlock a dimension: 
 

1. Select the dimension that you want to lock. 

2. Click Edit > Toggle Lock. Pro/ENGINEER locks the selected dimension or click Lock 
on the shortcut menu using the right mouse button. 

The locked dimensions appear in orange, that is, the default color for locked dimensions. 
Alternatively, set the color for locked dimensions by clicking View > Display Settings > 
System Colors and selecting the required color on the Sketcher tabbed page.  

To unlock the selected dimension, click Edit > Toggle Lock or click Unlock on the shortcut 
menu. 

You can also automatically lock an user-defined dimension by setting the value of the 
sketcher_dimension_autolock configuration option to yes. Alternatively, click Sketch > 
Options and select the Lock User Defined Dimensions option on the Miscellaneous 
tabbed page of the Sketcher Preferences dialog box. 

 

Sketcher Orientation Reference 
 
When you sketch a section in Sketcher, the orientation reference determines the orientation 

Customer PTC E-Newsletter 10/2/2006 Page 2 of 17 



of the sketch in the 2D environment. The orientation reference is used to define the 
horizontal and vertical constraints in the sketcher environment. 

When you select a sketching plane, the datum plane that is normal to the sketching plane is 
automatically selected as the default orientation reference. If such a datum plane does not 
exist, then the default orientation reference is based on an existing plane or the model 
default coordinate system. 

Note: The sketch orientation is based on the model default coordinate system, regardless of 
the existence of a coordinate system feature. 

If you select a sketching plane and the orientation reference is not selected automatically, 
then the sketching plane is oriented by projecting the X-axis of the default coordinate 
system onto the sketching plane. If the X-axis is normal to the sketching plane, then the Y-
axis is projected onto the sketching plane. The projection of the axis on the sketching plane 
is in the horizontal direction and points to the right.  

After you accept this automatically created orientation reference and proceed with sketch 
creation, you are prompted to select the dimensioning references irrespective of the value 
of the sketcher_auto_create_refs configuration option.  

If you are not satisfied with the automatically created orientation reference, you can change 
it by selecting a valid orientation reference. 

When you click Info > Feature to display information for a feature that is created using the 
default orientation reference, Default appears against Reference while no value is 
displayed for Orientation. 

 
Sketch Setup 
 
At anytime in the sketcher mode you can modify the sketch setup by selecting a new 
sketching plane or the orientation reference, or both. Whenever you select a new sketching 
plane or orientation reference, the active section is regenerated. The sketcher geometry 
appears with the new orientation settings. Upon regeneration, a message in the message 
pane indicates reference failures, if any, that you must resolve.  

When modifying the sketch setup, you can undo or redo the sketch setup operation to 
restore the previous or subsequent sketch setup, respectively. When you perform the undo 
or redo operations, the active section is regenerated and the sketcher geometry is 
reoriented accordingly. 

When modifying the sketch setup, you can create a new datum plane that you can use as 
the new sketching plane or orientation reference. 

When you change only the sketching plane, the existing orientation reference is retained if it 
is normal to the newly selected sketching plane. Otherwise, the existing orientation 
reference is replaced with the default orientation reference, that is, an existing plane or 
based on the model default coordinate system. 

Note: The sketch orientation is based on the model default coordinate system, regardless of 
the existence of a coordinate system feature. 

The integrity of the sketch is maintained when you modify the orientation or the orientation 
references. Modifying the orientation or the orientation reference is similar to a rigid 
rotation of the sketch geometry entities along with the model geometry. To maintain the 
integrity of the sketch, the constraints and dimensions behave in the following ways: 
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• All strong and weak constraints are preserved, except the horizontal, vertical, 
horizontal align, and vertical align constraint. 

• Horizontal and vertical constraints are replaced with appropriate parallel and 
orthogonal constraints with respect to the original orientation reference. If the original 
orientation reference is not a dimensioning reference, then the orientation reference is 
automatically added so that you can add the parallel and orthogonal constraints. 

• All strong or weak horizontal align and vertical align constraints are automatically 
deleted and replaced with weak dimensions or weak constraints or both by the 
sketcher solver. 

• All strong or weak dimensions, except for the point to point dimensions in the 
horizontal and vertical directions are preserved and retain their values. 

• The point to point dimensions in the horizontal and vertical directions are preserved, 
but their values are adjusted to reflect the new horizontal and vertical directions. 

Note: If relations are defined at the top level and involve point to point dimensions in the 
horizontal, vertical, or both directions, then modifying the orientation settings is not similar 
to a rigid rotation. Besides a rotation, the dimensions that are used in defining relations 
change and modify the shape of the sketch. This change of dimensions will happen if the 
point to point dimension is driving the relation or the dimension is driven by the relation. 

If you change the direction of sketch view, then the sketch dimensions and constraints are 
automatically changed in such a way that the sketch geometry goes through a rigid 
transformation and does not change its location relative to the model. 

If changing the sketching plane causes some external references to fail, a message in the 
message pane indicates reference failures, if any, that you must resolve. 

 
 
Sketched Text 
 
If you want to create text in a sketch it is done using the text option on the sketch menu. 

1. Click Sketch > Text and select a start point on the sketching plane to set text 
height and orientation. 

2. Click an end point. Sketcher creates a construction line between the start point and 
the end point. The length of the construction line determines the height of the text, 
while the angle of the line determines the text orientation. The Text dialog box 
opens. A green arrowhead appears at the start point of the text indicating the 
direction of the text. 

Note: By default the dimension associated with the length of the construction line that 
defines the height of the text, is a strong dimension. 

3. Under Text line, select Enter text manually or Use parameter. 

Note: Use parameter is available only in the 3D mode. 

• Enter text manually—Type a single line of up to 79 characters of text. 

• If required, click Text Symbol to insert special text symbols. The Text Symbol 
dialog box opens. Select the symbol that you want to insert. The symbol appears in 
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the Text line box and in the graphics area. Click Close to close the Text Symbol 
dialog box. 

• Use Parameter—Allows you to select a parameter that you have defined. The value 
of the parameter is displayed on the screen. 

• Click Use Parameter. The Select Parameter dialog box opens. 

• Under Look In, select Part, Feature, Annotation Element, Surface, or Edge to 
determine the object type. The name of the object type you select, appears in the 
Look In box. 

o Select a parameter from the Parameters Table and click OK. The name of 
the selected parameter appears in the Text line box and cannot be modified. 
The value of the parameter is displayed on the screen. 

4. Specify the following under Font in the Text dialog box.

o Font—Select a type face from a list of PTC-supplied fonts and TrueType fonts. 

o Position—Select a combination of horizontal and vertical positions to place 
the start point of the text string. 

Horizontal—Select the horizontal position from Left, Center, or Right. Left 
is the default. 

Vertical—Select the vertical position to place the dimension and the start 
point on the construction line that defines the height and orientation of the 
text string. Select from Bottom, Middle, or Top. Bottom is the default. 

You can use any combination of the horizontal and vertical positions to snap 
the start point of the text on to the construction line that defines the height 
and orientation of the text. 

• Aspect ratio—Use the slide bar to increase or decrease the aspect ratio 
of your text. 

• Slant angle—Use the slide bar to increase or decrease the slant angle of 
your text. 

5. Click Place along curve to place the text along a curve and select the curve on 
which you want to place the text. Select a combination of horizontal and vertical 
positions to place the start point of the text string along the selected curve. The 
horizontal position defines the start point on the curve. 

Note: When specifying the horizontal position for the start point of the text string, you 
can select the Center only if the selected curve is a linear curve. 

6. If required, click Flip to change the direction in which you want the text to flow. 

Note: When you click Flip, the construction line and the text string are placed at the 
other end of the opposite side of the selected curve. This placement is based on the 
start point of the text. 

7. Click Kerning to enable font kerning for the text string. This controls the space 
between certain pairs of characters, improving the appearance of the text string. 
 Kerning is a characteristic of the particular font. Alternatively, set the 
sketcher_default_font_kerning configuration option to automatically enable 
kerning for all the new text strings that you create. 
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8. Click OK to create the text. If you have selected Enter text manually, then the text 
is created on the sketching plane and if you have selected Use parameter, then the 
value of the parameter is displayed in the current sketcher window. 

Note: If you select a parameter that does not have a value, then the graphics area 
displays *** (three asterisks) as the value of the parameter. 

 
 

Sketcher Palette 
 
Sketcher provides you with a customizable library of predefined shapes that you can readily 
import into an active sketch. These shapes are presented in a palette. You can resize, 
translate, and rotate the shape when using it in an active sketch. 

Using a shape from the palette is similar to importing the corresponding section in an active 
section. Each shape in the palette appears as a thumbnail with the name of the defining 
section file. These thumbnails appear with the default line style and color for the sketcher 
geometry. 

You can use an existing section created in standalone Sketcher mode or a section created in 
Part or Assembly mode, to represent the user-defined shape. 

The sketcher palette has tabs representing categories of sections. Each tab has a unique 
name and contains at least one section of a certain category. There are four predefined tabs 
with predefined shapes: 

• Polygon—contains regular polygons 

• Stars—contains regular star shapes 

• Profiles—contains common profiles 

• Shapes—contains miscellaneous common shapes 
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You can add any number of tabs to the sketcher palette and place any number of shapes 
within each such defined tab. You can also add or remove shapes from the predefined tabs.  

The shape available in the sketcher palette is defined by section file present in the sketcher 
shape directory. Use the sketcher_palette_path configuration option to specify the path 
to the sketcher shape directory. If you are working in a PDM environment, you can use a 
PDM location as the path to specify the sketcher shape directory.  

Note: You must have adequate access rights to the PDM location to access the tabs and 
shapes. 

The label of the tab in the sketcher palette corresponds to the tab subdirectory that you 
define within the sketcher shape directory.  

Note: If you do not set the sketcher_palette_path configuration option, the current 
working directory is set as the sketcher shape directory, and only one user-defined tab 
appears in the sketcher palette. The label for this tab corresponds to the name of the 
working directory. The section files (files with .sec extension) within the working directory 
appear as the available shapes in the sketcher palette. 

If you change the contents of the sketcher shape directory, for example, add or remove a 
tab subdirectory or shape, then you must reload the sketcher palette to see these changes. 
To reload the sketcher palette, close and reopen the sketcher palette. 

The sketcher palette also has a preview pane. When you select a shape thumbnail in the 
sketcher palette, all the entities that will be imported into an active section appear in the 
preview pane. These entities can be sketcher geometry, construction geometry, internal 
strong dimensions, and constraints. 

When you use a shape from the sketcher palette in the current sketch, the following entities 
of the section that defines the shape are imported: 

• Geometry of the section 

• Construction geometry of the section 

• Strong constraints internal to the section (other than the vertical and horizontal 
constraints) 

• Strong dimensions internal to the section 

• Section relations 

Note: The locked state of the dimensions of the shape is retained when the shape is 
imported into an active section. 

 
 
Add a Tab to the Sketcher Palette 
 

Create a subdirectory within the sketcher shape directory. The subdirectory name 
appears as a tab label in the sketcher palette. 

Note: The subdirectory name appears as a tab label in the sketcher palette only if the 
subdirectory contains at least one section file, that is, a file with a .sec extension. 
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Add a Sketch to the Palette 
 

1. Create a new section or retrieve an existing section. 

2. Save the section to the subdirectory corresponding to the sketcher palette tab within 
the sketcher shape directory. The file name of the section appears as the name of 
the shape along with the thumbnail of the shape within the sketcher palette tab. 

 

To Use a Shape from the Sketcher Palette 
 

1. In the Sketcher mode, click Sketch > Data from File > Palette. The Sketcher 
Palette dialog box opens. 

Note: Alternatively, click on the Sketcher toolbar. 

2. Select the required tab on the sketcher palette. The thumbnail and the label 
corresponding to the shapes available within the selected tab appear. 

3. Click the thumbnail or the label corresponding to the required shape. The section 
corresponding to the selected shape appears in the preview pane. 

4. Double-click the same thumbnail or the label again to import the selected shape into 
the active section.  

The pointer changes to include a plus sign (+) indicating that you must select a 
location to place the selected shape. 

5. Place the selected shape into the active section in one of the following ways: 

By retaining the default size of the selected shape 

a. Click anywhere in the graphics window to select a location to place the shape. 

The shape with its default size, that is, one-fourth the graphics window, is placed at 
the selected location with the center of the shape coinciding with the selected 
location. The entities that define the shape remain selected. 

The Scale Rotate dialog box opens. Additionally, the Scale, Rotate, and Move 
handles appear on the imported shape. The Move handle coincides with the selected 
location. 

b. Scale, rotate, or move the shape as required. 

By resizing the selected shape 

a. Click and hold the left mouse button to specify the location of the shape. The 
imported shape appears in a very small size at the location you select.  

b. Drag the handle until the required size of the shape is achieved. 

c. Release the left mouse button to confirm the size of the shape. 

d. You can further scale and rotate the shape by specifying respective values in 
the Scale Rotate dialog box. 

e. Scale, rotate, or move the shape as required. 
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Note: By default, the imported shape does not snap when you place it. To enable 
snapping, move the Move handle on to the imported shape. To move the Move handle, 
right-click it and drag it to the required location on the imported shape. 

6. Middle-click to accept the position, orientation, and the size of the imported shape. 
The imported dimensions and constraints are created as strong dimensions and 
constraints. 

 
Back To Top

 

 PTC Product Focus  

Flex PLM Attribute Viewing and Updating 
 

Click Here To View 
 

Back To Top
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 Tips of the Month  

Quick Print in Pro/ENGINEER Wildfire 3.0 
 
Making a Quick Print of a Part or Assembly 
 

While using the Standard application (Part or Assembly), use the Quick Print command 
(File > Quick Print) to directly plot views for the active model, without manually creating a 
drawing.  

By specifying one of the following layouts and a printer configuration file, you can create the 
plot: 

• Manual Layout—Specifies the number of views per sheet, named views and a scale 
for each named view, and a display style for each view.  

• Projection Layout—Selects the projection layout based on a named view.  

• Drawing Template—Uses a template to define all aspects of the layout, except for 
the printer configuration. 

The plot reflects the layer settings, simplified representation state, explode state, and zone 
clipping for the current model, and appears as if a drawing were created and plotted. The 
file used to create the plot is automatically erased from your Pro/ENGINEER session. 
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Note:  

• In Part, Quick Print is not available for simplified representations. 

• In Assemby, Quick Print is available for geometry and graphics representations but 
not for symbolic representations. 

CCoonnffiigguurriinngg  ffoorr  DDiirreecctt  PPlloottttiinngg  
Use the following configuration options when you set up for direct plotting: 

• quick_print_plotter_config_file—Specifies the path for the default plotter 
configuration file (.pcf) when using the Quick Print command.  
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If plotter is set to ms_print_mgr, no other options are necessary. If it isn't set to 
ms_print_mgr, adding to the plotter configuration file the values for plot_file_dir and 
plotter_command is recommended.  

If you do not set quick_print_plotter_config_file, it defaults to 
<Pro/E_loadpoint>/text/plot_config/postscript.pcf on UNIX and <Pro/E 
loadpoint>/text/plot_config/ms_print_mgr.pcf on Windows. 

Note: The .pcf defined in the Quick Print dialog box overrides the configuration option 
setting. 

• quick_print_drawing_template—Specifies the path for the default drawing template 
file when using the Quick Print command with Drawing Template selected as your 
View Layout definition.   

• Some settings in the Quick Print dialog box may conflict with settings in the plotter 
configuration file. For example, plotter configuration file settings for plot_access and 
allow_file_naming may be overwritten by settings in Quick Print. 

• Some settings in the plotter configuration file are ignored by Quick Print because 
they do not apply to Quick Print. Settings in the plotter configuration file that are 
ignored by Quick Print include paper_size and paper_size_allowed. Plotter 
configuration options that work with Quick Print include plot_label, plot_sheets, 
plot_file_dir, and plot_segmented. 

 
 
Making a Quick Print of a Part or Assembly Using a Projection Layout 
 
 
 
After you click File > Quick Print, the Quick Print dialog box opens. Follow the procedure 
below when you select Projection Layout as your View Layout Definition. 

In the Plot Config File box, type the path to your plotter configuration .pcf file or click 
Browse and select the file. 

Note: If you have set the configuration option quick_print_plotter_config_file, the 
path to the plotter configuration file is automatically defined. You can override the 
configuration option by typing a path to or browsing to another .pcf file. 

Click Portrait or Landscape to specify the orientation of the sheet, and click the Standard 
Sizes box to select the size of the sheet. 

To use the same view scale and display style for all views, click the Use View Scale for all 
views and Use Display Style for all views check boxes. Note the View Scale and 
Display Style defaults for the Main View are listed in the Views area of the dialog box. 

Note: To assign unique view scales and display styles, clear these check boxes. 

Click the Saved View Name box for the Main view and select another name, or keep the 
default Standard Orientation name. 

Click in the View Scale and Display Style boxes to select a new values or style, or accept 
the defaults for the Main view. 
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In the View Layout area click the projection views you want. Projection views determine 
view layout and positioning. 

Note: Projection views are the unlabeled boxes in the View Layout area. 

Click a general view if needed. Each general view is listed in the Views area of the dialog 
box.  

o If you selected Use View Scale for all views or Use Display Style for all views, 
the values for View Scale and Display Style initially default to the values for Main. 
If you change a value for View Scale or Display Value for the Main View or any 
general view, then that value changes for all views listed. 

o If you cleared Use View Scale for all views and Use Display Style for all views 
check boxes, then you can make changes for Main or any general views, without 
affecting other values.  

Click OK to plot the part or assembly. 

Note:  

o If the plotter configuration file cannot be found, is missing required values, or is 
generating plotter errors, then an error dialog box opens after you click OK. 
Depending on the error, you can redirect to the correct plotter configuration file or 
edit the plotter configuration file from the dialog box.  

o If you have defined a model grid, and you are plotting a Project Layout View or 
Manual Layout View, the model grid is automatically plotted for all views with the 
correct orientation. For information on defining a model grid, see Detailed Drawings 
help. 

 
Back To Top

 Tips of the Month  

Line Plan “Views” Interface & Updating Data 
 

Click Here To View 
 

Back To Top
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 Announcements  
 

Educational Resource Library 
 
Learn things you always wanted to do - but didn't know you could. 
This one stop educational resource library will help you learn more about PTC Solutions and 
provide you with technical materials developed by the product experts to help you become more 
productive. 

Get tutorials, how-to videos and expert advice for:  

 Pro/ENGINEER  

 Conceptual and Industrial Design  
 Detailed Design  
 Simulation/Analysis  
 Production  
 Design Collaboration  

 Windchill PDMLink  

 Windchill ProjectLink  

 Pro/INTRALINK  

 PTC Online Tools 

 
Check out the Educational Resource Library today. 
  

PTC Tips & Techniques Newsletter Archives 

Miss an issue!  Can’t find that awesome technique you read about?  Fear not, you can click on 
the link below and go through our Customer PTC E-Newsletter archives. 

Click Here To Access 

It’s better than finding the Covenant of the Ark! 
 

PTC Tips & Techniques Webcasts: Work Smarter. Not Harder. 

Click below to see regularly scheduled Tips & Techniques technical Webcasts that are designed 
to provide you with the most popular time-saving tricks that Pro/ENGINEER users of all skill 
levels will find useful.  Get more out of your maintenance dollars! 

Tips & Techniques:  Work Smarter Not Harder!

 
 
E-PROFILES IS HERE!! 
We have been eagerly anticipating the debut of the new electronic version of Profiles Magazine 
and now it is here!  This new web site will supplement the print edition of the magazine and will 
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provide new useful features not feasible with paper media.  e-Profiles will provide you with 
24x7, worldwide access to key information previously available exclusively in the print version.  
"Tips & Tricks," a popular feature pioneered by Pro/USER, has also moved to the web and will 
be expanded as the site matures.   
Please take a few minutes to check out this new web site. We don't think you will be 
disappointed. 
 
http://profilesmagazine.com/
 
 
 
 

Back To Top
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 Upcoming Events & Training Class Schedules  
 
Upcoming, 2006  Your local Pro/Engineer User Groups 
    http://www.ptcuser.org/rugs/
 
 June 3 - 6, 2007  Tampa, Florida 

PTC/USER International Conference 
http://www.ptcuser.org/ 

 

Events 
Our seminars and conferences seek to provide you with relevant information regarding product 
development trends in your industry as well as innovative software learning experiences. Think 
of them as a constructive day off where you can share experiences and swap ideas with your 
peers.  
If you can't manage to get away, we'll bring it to you. Check back often for regularly scheduled 
live webcast events. 
 

You’re Invited to Attend…

 

Please visit the PTC Education Services website for the latest training information 
including course descriptions, schedules, locations, and pricing. 
 

• Attend a course at any PTC Center and receive a free copy of Pro/ENGINEER Wildfire 
Student Edition! 

 
http://www.ptc.com/services/edserv/index.htm

 

Live Instructor-Lead Virtual PTC Training Courses 

Virtual Classrooms provide interactive learning with a trained PTC instructor in convenient and 
manageable sessions that last approximately 4 hours over a series of days.  It's easy to join a 
class right from your desk using a phone or voice-over IP technology.  

Sessions are performed just like a traditional ILT (including interactive exercises where you and 
the instructor can work on lab exercises together) and feature some of our most popular ILT 
courses.  These sessions cover the exact same material as the traditional ILT in-center courses.  
Also look for some of our most frequently requested mini-topics delivered in the same format 
that are only an hour - two hours in duration.  

If you have any questions about these sessions or would like to see getting other courses, not on 
this list, on the schedule please feel free to contact me for more details.  They are a great way to 
bring training to you without you having to worry about location or being out from work for long 
stretches.  
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You can register for these sessions just as you would for any normal ILT class either by:  

1. calling order admin at http://www.ptc.com/services/edserv/training/registra.htm or 

2. you can go to PTC University directly at http://www.ptc.com/learning and submit a 
registration request directly.  All you have to do is search the catalog by typing in 
“virtual” in the search field and you will see a listing. 

 
 
PTC 

Note: This PTC E-Newsletter will continue to be used for the following: 

1) Inform you on events related to PTC products (user groups, conferences, training schedules, etc.) 

2) Educate you on solutions that are available at PTC 

3) Tips & Techniques using PTC Products 

Note: These messages are compiled in the local PTC office and will be distributed via 
e-mail.   

Back To Top
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