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Pro/Engineer Plastic Advisor 
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 PTC Product Focus  

ProductView Realizer : Constraint Concepts 
 
The Constraints tool allows you to model the functionality of a product by simulating the motion 
properties of mechanical devices. Constraints allow you to connect components together in such 
a way that when you move them they behave in a more useful manner. For example, for a model 
of the undercarriage of a plane, you could define constraints to cause the undercarriage to lower 
or retract. Or, you could add constraints to the model of a car to cause the suspension to go up 
and down, the doors to hinge open and closed, and the wheels to rotate in a logical fashion. 
 
The logical constructs involved in defining constraints are explained next. 
 

• The term mechanism is applied to a combination of bodies connected together so that 
they transmit motion in a determined manner. For example, you would create a 
mechanism to constrain the undercarriage of a plane.  Mechanisms are listed in the 
Mechanism window. 

 
• A body is the building block of a mechanism. The body defines a set of components that 

will move together. A body can either be a single component or a rigid body. All bodies 
in a mechanism must be connected by constraints.  
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• A ground is a defined object (or rigid body) which does not move. Every mechanism 
must have at least one ground.  Grounded bodies are marked with the  icon in the 
bodies interface. 

 
• A constraint (also known as a joint) is a connection between two bodies to constrain, or 

restrict, their movement in some way. For example, you could constrain a wheel 
component to an axle component so that the wheel only rotated around the axle. 
ProductView supports a number of different constraints types.  Constraints are defined by 
connecting pairs of markers.  The list of constraints for a mechanism is shown in the 
Constraints window. 

 
• A marker is similar to an orientation frame, but it is attached to a part and moves with it. 

Markers are used to define and illustrate locations where parts are constrained. A 
constraint is not directly attached to two components, but actually attached to two 
markers, which are each attached to components.  Markers are listed in the Markers 
window. 

 
All bodies in a mechanism must be connected by constraints. As a result, if you want to constrain 
two car doors so that each door is hinged, you would need to define two mechanisms, as each 
door works separately from the other one.  
 
Once you have created a mechanism, you can enable and disable it as needed to apply the 
constraints. When a mechanism is disabled, all of its bodies will have free motion. When a 
mechanism is enabled, the constraints for that mechanism are applied.   
 
Mechanisms are stored in annotation files. 
 
ProductView v. 6.4 Online Help, copyright 1999, Parametric Technology 
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 Tips of the Week  

How to Use Flexible Components in Wildfire 
 

Click Here To View 
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 Tips of the Week  

Creating a Mechanism in ProductView  
 
Pro/COLLABORATE and Windchill ProjectLink both provide built-in reporting capabilities.  
 
The following is a step-by-step process for creating a simple mechanism using ProductView 
Realizer.  The first step in the process is to load the appropriate geometry and create an 
annotation set that will hold our mechanism.  Then we will proceed to create the mechanism and 
associated constraints. 
 
1. Open the assembly of interest and load the geometry for which you want to create a 

mechanism.  This can be the entire assembly, or a sub-set of the assembly.  In this example, 
I’m using a sub-set of the PTC motor demo assembly. 
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2. Create an annotation set to store your mechanism.  You must first enable the Annotation 
tool.  To do this, choose Tools > Annotation, and then Annotation > New Annotation Set.  
Give the annotation a name and select OK.  For information on creating a new annotation 
set, see the on-line help for ProductView (choose Help > Help Topics or press F1 in the 
ProductView client). 

3. To define a constraint, you must first enable the Constraints tool. To do this, choose 
Tools > Constraints. The Constraints toolbar and menu commands are added to the 
ProductView window.  To view the mechanism window, choose Constraints > Show 
Mechanisms or select the  icon from the constraints toolbar. 

 
4. Every constraint begins with a mechanism. This stores the constraint information in one 

place. Choose Constraints > Mechanisms > Create Mechanism to create a new 
mechanism.  You can rename the mechanism by selecting it in the mechanism window. 
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5. (Optional) To define a rigid body in your mechanism, choose Constraints > Rigid 
Bodies > Create (Make sure that the mechanism is selected in the mechanism window prior 
to creating the rigid body or you will not be able to create it!).  To view the rigid body, you 
must select the rigid body tab in the mechanism window (see image below).  A rigid body is 
a collection of components that you want to appear as a single component, so that when one 
component moves, they all move. In this example we want the two cam gears (shown in red 
below) to function as one unit. These components can be modeled as separate parts, but for 
purposes of simulation, we want them all to appear to move together. To add components to 
the rigid body, select the two cam gears (final_cam_gear.prt and final_cam_gear2.prt) and 
choose Constraints > Rigid Bodies > Contents > Add Selected Components. 

 
6. Next we will add a constraint to the mechanism.  Each constraint defines how two 

components (or rigid bodies) interact.  We will create a revolute constraint between one of 
the cam gears (final_cam_gear.prt) and the crank case (final_crank_case.prt).  You will 
notice that because the two cam gears are part of a rigid body, the two gears will act as a 
single component when rotating the gear. 

7. The simplest method for creating a constraint is to use construction geometry.  First, 
create a construction axis down the center of the cam gear: 

a. Select your pick target by choosing View > Pick Target > Centerpoint of Arc. 
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b. To create the construction axis, choose Insert > Axis > Primary Axis of 
Geometry and then pick on the outside curve of the cam gear teeth.  You may 
need to zoom in close to one of the teeth to select it.  If you hold the left-mouse 
button while selecting, you will see a highlight point in the center of the gear 
when you’ve hit the correct spot.  The axis should go down the center of the cam 
gear. 

 
8. Next, highlight the construction axis (don’t forget to switch back to select mode by 

selecting the  icon) and, using the control key, select the cam gear and crank case.  
You should now have the construction axis and the two parts highlighted in red. 
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9. Create the constraint by choosing Constraints > Constraints > Create Constraint > 
Revolute.  The following dialog window will open: 

 
10. Choose Construction Geometry as the Selection Method.  You should notice that the 

Name fields contain the appropriate component names for Component 1 and 
Component 2 (final_cam_gear.prt and final_crank_case.prt, respectively).  The 
Geometry fields should both contain “Have construction geometry”.  If this is not the 
case, go back to step 8 and repeat.  Select Create to create the constraint. 

 
11. You should now have the “final_cam_gear.prt” and “final_crank_case.prt” listed in the 

constraints window.  You will find this under the Constraints Tab in the mechanism 
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window (see below). 

 
12. Before we can check the mechanism, you will need to ensure that at least one component 

in the mechanism is grounded.  Do this by selecting the  tab in the mechanism 
window.  Right-click the crankcase part and select Toggle Ground.  The icon should 
now look like this . 

13. Now that the mechanism is grounded, we can test it to see if it works.  Select 
Constraints > Mechanisms > Enable Mechanism.  You can select one of the cam gears 
(either one because they are defined as a rigid body) and try to move them.  They will 
only rotate about the construction axis that we defined with respect to the 
“final_crank_case.prt” (grounded body).  Note:  Remember to hit the “tab” key after 
selecting the cam gear to switch from translate mode to rotate mode. 

14. To add additional constraints to your mechanism, make sure to disable the mechanism.  
Do this by choosing Constraints > Mechanism > Disable Mechanism or right clicking 
on the mechanism name and selecting Disable Mechanism. 

15. Now, lets create another revolute constraint for the final_crank.prt. 
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a. First, create the construction axis down the center of the crank gear (see step 7b 
above).  It should look like this: 

 
b. Next, select the construction axis, the crank part (final_crank.prt) and the 

crankcase part (final_crank_case.prt).  Use the [Alt] button for multiple 
selections. 

c. Create the constraint by choosing Constraints > Constraints > Create 
Constraint > Revolute. 

d. Choose Construction Geometry as the Selection Method and select Create. 

16. You should now have a revolute constraint defined for the final_crank.prt and the 
final_crank_case.prt parts.  Enabling the mechanism should allow you to only rotate the 
crank within the limitations of the constraint.  You should also notice that there is no 
need to create a “ground” because the final_crank_case.prt is already grounded from the 
previous constraint definition. 

17. Finally, let’s create a gear constraint between the cam gear and the crank. 

a. Make sure that the mechanism is disabled by choosing Constraints > 
Mechanism > Disable Mechanism. 

b. Create construction axes for the cam gear (final_cam_gear.prt) and crank 
(final_crank.prt).  This step can be skipped if the axes were not deleted from the 
previous examples. 

c. Here we will use a slightly different method to create the constraint.  Ensure 
nothing is highlighted in the graphics window and choose Constraints > 
Constraints > Create Constraint > Gear.  The following window will appear: 

 
d. Select Construction Geometry for the Selection Method. 
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e. Now, select the cam_gear part (final_cam_gear.prt) and it’s construction axis.  
The Name and Geometry fields for Component 1 should be populated as shown 



below (don’t worry that the geometry field for Component 2 is also filled in). 

 

f. Select the push-pin  for Component 1 so that it is locked . 

g. Now, select the crank (final_crank.prt) and it’s construction axis.  Also select the 
push-pin  for Component 2 so that it is locked .  Select Create. 

 
18. You now have a gear constraint between the cam_gear and the crank.  Enable the 

mechanism to test your mechanism.  You’ll notice now that rotating either the cam_gears 
or the crank will allow the entire mechanism to function.  Also, don’t forget to update 
your annotation set (by selecting the capture view state icon  and then saving the .ed 
file) to preserve your mechanism for later use.  In fact, it’s a good idea to do this 
frequently throughout the process to save your work incrementally. 

For more information on creating mechanisms, construction geometry and annotation sets, see 
the on-line help for ProductView (choose Help > Help Topics or hit F1 on your keyboard). 
 

Back To Top 
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 Announcements  
 

Special Hardware offers for customers updating to Pro/ENGINEER Wildfire 
 
http://www.ptc.com/partners/hardware/current/wildfire_tlo.htm  
http://www.3dlabs.com/PTC/ 
 

PTC Sponsored Events 

Click below to see PTC sponsored events: 

http://www.ptc.com/company/news/events/index.htm  
 

Thinking About Pro/ENGINEER Wildfire?  Check this out. 

 

http://www.ptc.com/go/engineering/index.htm 

 

 
E-PROFILES IS HERE!! 
We have been eagerly anticipating the debut of the new electronic version of Profiles Magazine 
and now it is here!  This new web site will supplement the print edition of the magazine and will 
provide new useful features not feasible with paper media.  e-Profiles will provide you with 
24x7, worldwide access to key information previously available exclusively in the print version.  
"Tips & Tricks," a popular feature pioneered by Pro/USER, has also moved to the web and will 
be expanded as the site matures.  Future plans include several foreign-language editions of 
Profiles for our many international readers. Currently, Profiles is printed in English and 
Japanese. 
 
Please take a few minutes to check out this new web site. We don't think you will be 
disappointed. 
 
http://profilesmagazine.com/ 
 
 
 
 
 

Back To Top 
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 Upcoming Events & Training Class Schedules  
 
Upcoming, 2003  Your local Pro/Engineer User Groups 
    http://www.prouser.org/rugs/ 
 
June 8 - 11, 2003  Orlando, FL 

Pro/USER International Conference 
http://www.prouser.org/ 

 

Please visit the PTC Education Services website for the latest training information 
including course descriptions, schedules, locations, and pricing. 
 

• Attend a course at any PTC Center and receive a free copy of Pro/E 2001 Student 
Edition! 

 
http://www.ptc.com/services/edserv/index.htm 

 
PTC 

Note: This PTC E-Newsletter will continue to be used for the following: 

1) Inform you on events related to PTC products (user groups, conferences, training schedules, etc.) 

2) Educate you on products that are available at PTC 

3) Tips & Techniques using PTC Products 

Note: These messages are compiled in the local PTC office and will be distributed via 
e-mail.   

Back To Top 
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