Mathcad Licensing FAQ

This document answers the questions asked most frequently about licensing for Mathcad. This information is useful for users and administrators not familiar with Mathcad licensing, or those upgrading from previous versions of Mathcad, which were licensed differently.

If your question is not answered here, please visit the Mathcad Installation & Licensing Support Center to request assistance.

For questions about PTC license management policies, see the PTC Order and Licensing Support FAQ at http://www.ptc.com/olm/faq.htm.

Please select your version of Mathcad:

PTC Mathcad Prime 3.0 and later

I am an active Support customer and want to download and install Prime 3.0. How do I update my license?

Instructions for active support customers to update their license file to activate Prime 3.0 can be found here, and in the Electronic Software Download tool here.

PTC Mathcad Prime 2.0

I am an active Support customer and want to download and install Prime 2.0. How do I update my license?

I am upgrading from a Single User license and the Prime 2.0 License Wizard is asking for a prior version product code, where do I find it?

I just purchased Prime 2.0 new - is there a video of how to license Mathcad Prime 2.0?

Is there a document that shows all the screens in the Mathcad License Setup wizard for Prime 2.0?

I purchased Mathcad Prime 2.0 on the PTC e-store. What do I do now?

Where can I find the most commonly used Mathcad licensing tools?

I still own a Single User version 11 through 14.0 and need a new license file.

How do I obtain a license file for Professional – Individual and Professor Edition licenses?

How do I obtain a Student Edition license file?

If I'm upgrading from a prior version, do I need a new license file?

What types of Mathcad licenses are available?

How do I create an account on PTC.com?

I don't have Internet access where I installed Mathcad. How do I request a license file?

I uninstalled and reinstalled Mathcad, or applied a software update. Do I need a new license file?

I installed a trial version of Mathcad. How do I update my installation once I buy Mathcad?

Can I still run Mathcad if the workstation is not connected to a network?

Is it possible to license and run Mathcad Prime 2.0 and 15.0 side-by-side?

I am an active Support customer and want to download and install Prime 2.0. How do I update my license?

Instructions for active support customers to update their license file to activate Prime 2.0 can be found here, and in the Electronic Software Download tool here.

I am upgrading from a Single User license and the Prime 2.0 License Wizard is asking for a prior version product code, where do I find it?

The product code for your Single User (version 14.0 and prior) can be found under the Help -> About Mathcad menu item.

I just purchased Prime 2.0 new - is there a video of how to license Mathcad Prime 2.0?

Yes. For new customers, a video overview of the licensing process for Prime 2.0 can be viewed here. A video of the Student licensing procedure for both Prime 2.0 and 15.0 at once can be viewed here. If you are an active support customer and simply downloaded Prime 2.0 as your maintenance entitlement, please follow these instructions to update your license file.

Is there a document that shows all the screens in the Mathcad License Setup wizard for Prime 2.0?

Yes. A flow, screen by screen, of the licensing process for Prime 2.0 can be viewed here.

I purchased Mathcad Prime 2.0 on the PTC e-store. What do I do now?

In order to complete the licensing process, PTC must process your e-store order and email you a Software Order Fulfillment Confirmation, which contains your Product Code. Note that this Product Code is different than the order confirmation number you received from the e-store at the time of purchase.

You have the option to begin using Mathcad immediately by clicking the ‘Get Trial License’ button in the Mathcad License options dialog.

Please consult the licensing guide provided to you when you purchased online for detailed instructions.

Where can I find the most commonly used Mathcad licensing tools?

The Mathcad licensing tools have been consolidated in the Mathcad Support Center.

I still own a Single User version 11 through 14.0 and need a new license file.

If you are still on a Single User version from 11 – 14.0, there are online tools to request help. Our goal is to ensure users on these versions are able to access and use the software, so we provide assistance for both installation and licensing issues. Please visit the Mathcad Support Center.

How do I obtain a license file for Professional – Individual and Professor Edition licenses?

Here’s how to install your software and request your license key:

1.       Have ready your:

a.       Product Code from your Software Order Fulfillment Confirmation.

b.       PTC web account login. If you have not yet created your Basic Account, please visit https://www.ptc.com/appserver/common/account/basic.jsp

2.       Install Mathcad.

3.       Once installation is complete, open Prime 2.0. You will see a ‘License Status’ button under the toolbar.

4.       Click the License Status button, and then click ‘Get License’ to open the Mathcad License Setup wizard.

5.       The Mathcad License Wizard will open to the Welcome screen. Click Next to continue.

6.       Enter the login information for the PTC Basic Account you created in step 1b and click Next. If you still need an account, follow the highlighted link in the wizard to create your account.

7.       Enter your Product Code.

a.        If you are requesting a Home Use license, check the appropriate box.

b.       If you have purchased a Single User Upgrade, check the appropriate box and enter your prior version Product Code.

8.       Select which versions of Mathcad you want licensed and click Acquire License. After a few moments you should reach the Done screen, indicating that the license has been successfully installed. Click Exit.

How do I obtain a Student Edition license file?

See the instructions that came with your software shipment here.

If I'm upgrading from a prior version, do I need a new license file?

Yes, you must request a new license file to use with Mathcad Prime 2.0.

What types of Mathcad licenses are available?

There are three types of Mathcad Prime 2.0 licenses available for purchase: Floating, Individual (node locked), and Registered User.

Floating License: Also known as a concurrent usage license, this allows only one user at a given time. Different users may use the software at different times, but only one person may use it at any given time.

Node Locked License: Fixes the license to a specific machine, allowing it to only be used on that hardware, but comes at a reduced cost.

Registered User License: Requires one license for each user of the product, but the license file resides on the server much like a floating license. This licensing option should be used only when a customer wants a separate license for each specific user (like a node locked license above) but wants to manage these licenses from a central server.

How do I create an account on PTC.com?

A Basic account can be created here: https://www.ptc.com/appserver/common/account/basic.jsp. If you are an acadmic user, please create your account here: https://www.ptc.com/appserver/common/account/ptcacademic.jsp.

In order to access software downloads, licensing tools and other maintenance entitlements, you will need to upgrade your Basic account to a Customer Support account. This can be done here: https://www.ptc.com/appserver/common/account/secure/premiumAccount.jsp

I don't have Internet access where I installed Mathcad. How do I request a license file?

From another computer with internet access, browse to the Mathcad Support Center.

I uninstalled and reinstalled Mathcad, or applied a software update. Do I need a new license file?

Floating and registered user licenses are unaffected when you uninstall and reinstall Mathcad, or apply a software update. If you have customized your options file (ptc.opt) to include or exclude a specific workstation, update the file accordingly. For more information on modifying the options file, see the Administrator's Guide.

For all other license types – Individual, Student, Professor and Home Use - you must request a new license file if you have installed Mathcad to a new workstation or manually deleted your license file.

I installed a trial version of Mathcad. How do I update my installation once I buy Mathcad?

1.      Launch Mathcad. Click on the Mathcad orb in the upper left corner, select “Mathcad Options” and click the License tab.

2.       Click on Get License and follow the instructions.

3.       Enter your Product Code when prompted.

Can I still run Mathcad if the workstation is not connected to a network?

Mathcad installations that use Individual or Home Use licenses can run remotely. For information on borrowing a license from a server pool, consult the FLEXnet Licensing End User Guide.

Is it possible to license and run Mathcad Prime 2.0 and 15.0 side-by-side?

To run Mathcad 15.0 and Prime 2.0 side-by-side, first obtain your Prime 2.0 license file using the instructions above. Once this license file has been saved to your desktop, run the Mathcad 15.0 License Setup wizard by opening a command prompt (usually Start > Run > cmd) and typing “c:\Program Files\Mathcad\Mathcad 15\mathcad.exe” /license (make sure to include the quotes and all spaces). Point the wizard to your Prime 2.0 license file (C:\Program Files\Mathcad\Mathcad Prime 2.0\license\mathcad_license.dat). You can now run both Prime 2.0 and 15.0 at the same time.

 

Mathcad Prime 1.0

Mathcad Prime 1.0 Documentation

Mathcad Prime 1.0 Student Edition installation & licensing instructions

Is there a video overview of the Prime 1.0 licensing process?

Is there a document that shows all the screens in the License Setup wizard?

I purchased Mathcad Prime 1.0 on the PTC e-store. What do I do now?

Where can I find the most commonly used Mathcad licensing tools?

I still own a Single User version 11 through 14.0 and need a new license file

How do I obtain a license file for Professional – Individual and Professor Edition licenses?

How do I obtain a Mathcad Prime 1.0 Student Edition license file?

If I'm upgrading from a prior version, do I need a new license file?

What types of licenses are available?

What is a Home-Use License and how do I obtain one?

Do I need to install any software to manage my license file?

Can I manage multiple Individual licenses from a server?

Do I need to update my installation of FLEXlm?

How do I create an account on PTC.com?

I don't have Internet access where I installed Mathcad. How do I request a license file?

How do I receive my license files?

Can I request multiple server license files?

How do I point Mathcad to the appropriate license server or license file?

I uninstalled and reinstalled Mathcad, or applied a software update. Do I need a new license file?

I installed a trial version of Mathcad. How do I update my installation once I buy Mathcad?

Can I move my license to another server/workstation?

Can I still run Mathcad if the workstation is not connected to a network?

Is it possible to license Mathcad Prime 1.0 and 15.0 side-by-side?

Is there a video overview of the Prime 1.0 licensing process?

Yes, a 4 1/2 minute video overview of the entire license acquisition and setup process for locked licenses (Professional - Individual, Professor and Student) can be viewed here.

Is there a document that shows all the screens in the License Setup wizard?

Yes. A flow, screen by screen, of the licensing process for Prime 1.0 can be viewed here.

These Licensing Guides are also available:

Existing, active maintenance customers downloading from the ESD tool

New customers: Professional - Individual and Professor

I purchased Mathcad Prime 1.0 on the PTC e-store. What do I do now?

In order to complete the licensing process, PTC must process your e-store order and issue you a Software Order Fulfillment Confirmation, which includes your Sales Order Number (SON) and PTC Customer Number. Note that these numbers are different than the orders numbers you received from the e-store directly.

You have the following options immediately after purchasing via the PTC e-store:

  1. Wait for the Software Order Fulfillment Confirmation from PTC and run through the Mathcad License Setup once.
  2. Start using Mathcad immediately with a trial license and run through the Mathcad License Setup twice.

Please consult the licensing guide provided to you when you purchased online for detailed instructions on each option.

Where can I find the most commonly used Mathcad licensing tools?

To request a reissuance of a Mathcad Single User license for versions 14.0 go here.

As an active support customer, you have online access to the following tools:

To move a Professional or Professor license file from one computer to another go here.

To retrieve an existing Professional or Professor license file go here.

To view your customer information and current license status go here.

To request a report of all licensing information for a given customer or site go here.

To log a support request go here.

To order or download software updates go here.

I still own a Single User version 11 through 14.0 and need a new license file

PTC can no longer issue licenses for Mathcad versions 11-13, please see this announcement. If you are still on a Single User version 14.0, there is an online tool to request help. Our goal is to ensure users on these versions are able to access and use the software, so we provide assistance for both installation and licensing issues. This tool can be accessed here; you will need a Basic Account and your Product Code to submit your request.

How do I obtain a license file for Professional – Individual and Professor Edition licenses?

There are 3 basic steps to licensing your individual copy of Mathcad:

  1. Install Mathcad software on your workstation.
  2. Request a license file from PTC and save to your workstation.
  3. Tell Mathcad where your license file has been saved to your workstation.

Here’s how to install your software and request your license key:

1.      Have ready your:

a.       Sales order number and customer number. Found on the Software Order Fulfillment Confirmation, sent to the email provided with your software order.

b.      PTC web account login. If you have not yet created your Basic Account, please visit https://www.ptc.com/appserver/common/account/basic.jsp

2.      Install Mathcad:

a.       Insert the Mathcad CD into your CD ROM drive. If the installation program does not start automatically, you can start it manually by choosing ‘Run…’ from the Start menu, and typing D:\SETUP (where “D:” is your CD-ROM drive).  Or, browse to the Mathcad installation files on your network.

b.      After reading and accepting the software license agreement, select ‘Mathcad Prime 1.0’ as the product to be installed. On the following screen, select ‘Trial/New License’. Follow the remaining on-screen instructions to complete installation.

3.      Once installation is complete, open Prime. You will see a ‘License Status’ button under the toolbar.

4.      Click this button to open the Mathcad Options dialog, and click on the License tab. Click ‘Get License’ to open the Mathcad License Setup wizard.

5.      Select “I want to acquire a license via the Internet” and click Next.

6.      Select the type of license you purchased and click Next.

7.      On the next screen select the appropriate step. Hover your mouse over the options for additional explanations.

8.      Enter your Sales Order Number (SON) and Customer Number from the Software Order Fulfillment Confirmation. If you ordered an upgrade from a prior Single User version, you must enter your old Product Code for validation. Click Next.

9.      The Create Account screen appears. If you already have your PTC Basic Account from step 1b above, click Next. If you still need an account, click Create Account.

10.  Click ‘Go to the web page to complete the request’, and provide your Basic Account login information. Verify the information you entered is correct, and click Submit. The license file should be emailed to you within an hour. Click Finish for the Mathcad License Setup wizard.

11.  Once you receive the license via email, save the file to a location on your workstation.

12.  In the Mathcad Options dialog box, click Browse under License Configuration and point to the file you just saved to your workstation. Click Apply.

13.  The License Type and License Status will turn green once this process is successful.

How do I obtain a Mathcad Prime 1.0 Student Edition license file?

The Mathcad License Setup wizard obtains a license file for you. The wizard requires that you have a Basic Account for the PTC Web site and a unique Product Code (contained in the physical Mathcad packaging).

Enter your Student Edition product code in the field provided.

If I'm upgrading from a prior version, do I need a new license file?

Yes, you must request a new license file to use with Mathcad Prime 1.0.

If you are upgrading from a Single User, you will have purchased Mathcad Prime 1.0 and will receive a Sales Order Number (SON) and Customer Number from PTC in the Software Order Fulfillment Confirmation email. Use this information to request a new license file during the installation of the software. Step by step instructions are included in your software shipment, or can be found on our Reference Documents  web page.

If you are an existing Mathcad 14.0 or 15.0 active maintenance customer and are simply ‘revving’ your version of Mathcad to Prime 1.0, make sure you select ‘I want to retrieve a copy of the existing license for this computer’ during the Mathcad License Setup process. You must make this request from the same computer where Mathcad 14.0 or 15.0 is installed, as the process looks for your computer’s Host ID.

If you are an existing active maintenance customer and are ‘revving’ from a version prior to Mathcad 14.0, please submit a request to License Management for a new license key through the Customer Support Call Logger.

What types of licenses are available?

There are three types of Mathcad Prime 1.0 Professional licenses available for purchase: Floating, Individual (node locked), and Registered User.

Floating License: Also known as a concurrent usage license, this allows only one user at a given time. Different users may use the software at different times, but only one person may use it at any given time.

Node Locked License: Fixes the license to a specific machine, allowing it to only be used on that hardware, but comes at a reduced cost.

Registered User License: Requires one license for each user of the product, but the license file resides on the server much like a floating license. This licensing option should be used only when a customer wants a separate license for each specific user (like a node locked license above) but wants to manage these licenses from a central server.

What is a Home-Use License and how do I obtain one?

A Home-use license is a fully functional license of Mathcad that you can install on your home computer. Home-use licenses are free and they are available to active Maintenance Support customers. They can be downloaded through the licensing tool within your application. If you are not an active Maintenance Support customer, visit out Reactivation pages.

For active customers, watch the licensing video to learn how to install it.

Do I need to install any software to manage my license file?

Floating license files require a server to administer them. Individual and Home Use license files are tied to an individual workstation, and require no additional software.

Can I manage multiple Individual licenses from a server?

PTC does not support a server-based Individual license for Mathcad, and does not allow generation of such a license file at the license management web site. Alternate solutions are to either request Individual (workstation) license files or purchase a Registered User license.

Do I need to update my installation of FLEXlm?

Mathcad Prime 1.0 requires FLEXnet 10.x or later to administer floating and registered-user licenses. Users of versions prior to FLEXnet 10.8 must update their license server software. FLEXnet 10.8 for Windows is available on the Mathcad Prime 1.0 CD. You can also use the version of FLEXnet 10.8 or later for UNIX platforms that is provided with other PTC software.

For information on installing FLEXnet 10.8, see the Administrator's Guide, available on the Mathcad CD.

How do I create an account on PTC.com?

A Basic account can be created here: https://www.ptc.com/appserver/common/account/basic.jsp

In order to access software downloads, licensing tools and other maintenance entitlements, you will need to upgrade your Basic account to a Customer Support account. This can be done here: https://www.ptc.com/appserver/common/account/secure/premiumAccount.jsp

I don't have Internet access where I installed Mathcad. How do I request a license file?

From another computer with internet access select Configure New Software.

How do I receive my license files?

The Mathcad License Setup wizard handles license file requests automatically. Student Edition and 30 day trial license files are transmitted to the workstation at the conclusion of the request and saved to the licenses folder of your Mathcad installation.

For all Professional – Individual and Professor Edition license file requests, you will receive your license file as an email attachment. Save the file to your computer, then browse to this file using the Mathcad Options -> License tool.

Can I request multiple server license files?

You can divide your licenses between multiple license servers by requesting a license file for each server, so long as the total number of licenses you request does not exceed the terms of your purchase.

How do I point Mathcad to the appropriate license server or license file?

For all Professional – Individual and Professor Edition license file requests, you will receive your license file as an email attachment. Save the file to your computer, then browse to this file using the Mathcad Options -> License tool.

I uninstalled and reinstalled Mathcad, or applied a software update. Do I need a new license file?

Floating and registered user licenses are unaffected when you uninstall and reinstall Mathcad, or apply a software update. If you have customized your options file (ptc.opt) to include or exclude a specific workstation, update the file accordingly. For more information on modifying the options file, see the Administrator's Guide.

For all other license types – Individual, Student, Professor and Home Use - you must request a new license file if you have installed Mathcad to a new workstation or manually deleted your license file.

I installed a trial version of Mathcad. How do I update my installation once I buy Mathcad?

1.      Launch Mathcad. Click on the Mathcad orb in the upper left corner, select “Mathcad Options” and click the License tab.

2.       Click on Get License and follow the instructions above under How do I obtain a license file for Professional – Individual and Professor licenses starting with step #5.

Can I move my license to another server/workstation?

Launch Mathcad. Click on the Mathcad orb in the upper left corner, select “Mathcad Options” and click the License tab. Select Get License and then ‘I want to acquire a license via the Internet’. On the next screen select product you own, and then select ‘I want to transfer the right to use an existing license from one computer to another computer’.

As an alternative method, use the Reconfigure Software Licenses option on the PTC Customer Service Web site to de-allocate the license for the old CPU ID. Then use the Configure New Software option on the site to request a license file for the new CPU ID.

Can I still run Mathcad if the workstation is not connected to a network?

Mathcad installations that use Individual or Home Use licenses can run remotely. For information on borrowing a license from a server pool, consult the FLEXnet Licensing End User Guide.

Is it possible to license Mathcad Prime 1.0 and 15.0 side-by-side?

Yes, it is possible to use your Prime 1.0 license file to also activate Mathcad 15.0. To do this, obtain your Prime 1.0 license file as described above. Once this license file has been saved to your desktop, run the Mathcad 15.0 License Setup wizard by opening a command prompt (usually Start > Run > cmd) and typing “c:\Program Files\Mathcad\Mathcad 15\mathcad.exe” /license (make sure to include the quotes and all spaces). Point to this same license file. You can now run both Prime 1.0 and 15.0 at the same time.


Mathcad 14.0

Table of Content

  1. Licensing Basics
  2. Upgrading an Existing Installation
  3. Obtaining a License
  4. Configuring Mathcad to Use Your License File
  5. Reinstalling or Updating Mathcad
  6. Transferring a License to a New Server or Workstation
  7. Licensing and Remote Usage of Mathcad
  8. Obtaining Your Sales Order Number

Licensing Basics

What types of licenses are available?

There are three types of Mathcad 14.0 Enterprise licenses available for purchase: floating, node-locked, and registered-user.

Unlike previous versions of Mathcad, node-locked licenses for Mathcad 14 are created for each workstation, instead of the server. Users who previously used a node-locked server license file should request a registered-user license for Mathcad 14 instead.

Mathcad 14 Single-user edition uses a workstation-specific license to verify that you have purchased a valid copy of Mathcad.

Why am I prompted to obtain a license file when I install Mathcad? (Single-user only)

Licensing has replaced Product Activation as the method for ensuring that you have obtained a valid copy of Mathcad. The license file you receive allows Mathcad to start up.

Do I need to install any software to manage my license file?

Floating and registered-user license files require a server to administer them. Node-locked, home-use, and Single-user license files are tied to an individual workstation, and require no additional software.

Can I upgrade an existing node-locked server license to a Mathcad 14 license?

Currently, PTC does not support a counted (server) node-locked license for Mathcad, and does not allow generation such a license file at the license management web site. Alternate solutions are to either request individual (workstation) node-locked license files or purchase a registered-user license.

Upgrading an Existing Installation

Do I need to update my installation of FLEXlm?

Mathcad 14.0 requires FLEXnet 10.8 or later to administer floating and registered-user licenses. Users of versions prior to FLEXnet 10.8 must update their license server software. FLEXnet 10.8 for Windows is available on the Mathcad 14.0 CD. You can also use the version of FLEXnet 10.8 or later for UNIX platforms that is provided with other PTC software.

For information on installing FLEXnet 10.8, see the Administrator's Guide, available on the Mathcad CD.

If I'm upgrading, do I need a new license file?

Yes. You must request a new license file (server or workstation) to use with Mathcad 14.

I purchased a license for an Extension Pack (Image Processing, Signal Processing, Wavelets, and/or Data Analysis) for use with my prior Mathcad installation. How do I upgrade my license for this extension pack?

For Enterprise installations, all licenses enable use of all four extension packs, which are installed automatically with Mathcad.

For Single-user installations, extension packs that were purchased for a previous version of Mathcad are licensed when obtaining a Mathcad 14 license file with the Mathcad License wizard.

How do I license-manage both Mathcad 14 and a previous version of Mathcad? Can I do so with the same FLEXnet installation?

You can install FLEXnet10.8 alongside an existing FLEXlm installation, or you can use FLEXnet 10.8 to administer licenses for prior (pre-14) versions of Mathcad as well as Mathcad 14.

Note: Mathcad 14 licenses cannot be used to supplement Mathcad 13 licenses.

To manage Mathcad 13 or earlier licenses of Mathcad with FLEXnet 10.8:

  1. Request a license for your existing (FLEXlm) license server using the PTC Web site (www.ptc.com).
  2. Install FLEXnet 10.8 to the same server as your FLEXlm installation. Do not overwrite your FLEXlm installation.
  3. Launch LMTools from your FLEXnet installation.
  4. On the Config Services tab, confirm that the service you previously created to serve licenses for your pre-14 version of Mathcad is available.
  5. Close LMTools.

Use the version of LMTools provided with FLEXnet 10.8 to administer both your Mathcad 14 and pre-Mathcad licenses. Take care to select the proper service on the Config Services tab before modifying any service information. To perform a status enquiry, first select the correct service on the Service/License File tab.

Obtaining a License

How do I obtain an Enterprise license file?

You need the Sales Order Number (SON) from your Mathcad purchase and the CPU ID for each computer for which you are requesting a license file (the server for floating or registered-user licenses, or the workstation for node-locked and home-use licenses).

Access the PTC Technical Support web site. Click Configure New Software to request your license file(s).

  • For a floating or registered-user license, supply the CPU ID of the server.
  • For a node-locked or home-use license, provide the CPU ID of the workstation.
  • Specify only one CPU ID per request; you must make a separate request for each CPU ID.
  • If you plan to use the Extension Pack bundle, select both Mathcad and the Extension Pack when you request your floating, node-locked, or registered-user license file.

When you request a floating or registered-user license, specify the quantity of licenses you want to order. (Node-locked and home-use licenses can only be requested individually.)

How do I obtain a Single-user license file?

The Mathcad License Setup wizard obtains a license file for you. The wizard requires that you have a user account for the PTC web site.

How do I determine a computer's CPU ID?

To determine the CPU ID for a computer:

  1. Open a command-prompt window.
  2. At the command prompt, type ipconfig/all and press [Enter].
  3. Record the Physical Address, expressed as a series of 6 two-digit hexadecimal numbers, separated by dashes (such as 00-00-00-00-00-00). Provide this number when prompted for a CPU ID.

When validating your Mathcad license, the CPU ID in the license file is checked against all available CPU IDs on the host computer. As long as one of the CPU IDs on the host computer matches the CPU ID in the license file, the license validates and can be used. Other PTC products may not do this; consult the licensing documentation to help you determine the correct ID to use.

How do I determine a computer's Volume Serial Number?

  1. Open a command-prompt window.
  2. At the command prompt, type vol c: and press [Enter].

The volume serial number is expressed as a 8 character number separated by a dash (such as abcd-1234)

How do I create an account on PTC.com?

The Mathcad License Setup wizard guides Single-user edition users through the process of creating an account on PTC.com. You can also go to the PTC web site, click the My Account link, and then click the New Account link to create your account.

I don't have Internet access on the workstation where I installed Mathcad. How do I request a Single-user license file?

From a computer with internet access, browse to Mathcad Single User and Student Licenses Call Logger

How do I receive my license files?

The Mathcad License Setup wizard handles Single-user license file requests automatically. Single-user license files are transmitted to the workstation at the conclusion of the request and saved to the licenses folder of your Mathcad installation.

For all manual license file requests, including all Enterprise license file requests, you will receive your license file as an email attachment after you submit your request.

Can I request multiple server license files?

You can divide your licenses between multiple license servers by requesting a license file for each server, so long as the total number of licenses you request does not exceed the terms of your purchase.

Configuring Mathcad to Use Your License File

How do I point Mathcad to the appropriate license server or license file?

During installation, the Mathcad installer presents the Mathcad License Setup wizard, which allows you to specify the name of the license server or file that Mathcad should use. Enter mathcad /license at a command prompt to update this information.

Why can't the Mathcad License Setup wizard or the FLEXnet installer find my license file?

Mathcad requires that your license file name end with a .DAT extension. However, license files are attached to email as a text file with a .TXT extension. When prompted, to browse for your license file:

  1. Enter *.txt in the file name field to display the license file.
  2. Select the license file from the file list that results.

Both the Mathcad License Setup wizard and the FLEXnet installer create a file named license.dat when run. This license.dat file is then used to license manage Mathcad.

Reinstalling or Updating Mathcad

I uninstalled and reinstalled Mathcad, or applied a software update. Do I need a new license file?

Floating and registered-user licenses are unaffected when you uninstall and reinstall Mathcad, or apply a software update. If you have customized your options file (ptc.opt) to include or exclude a specific workstation, update the file accordingly. For more information on modifying the options file, see the Administrator's Guide.

For all other license types - node-locked, home-use, and Single-user - you must request a new license file if you have installed Mathcad to a new workstation or manually deleted your license file.

I installed a trial version of Mathcad. How do I update my installation once I buy Mathcad?

When you purchase Mathcad, you receive a product code. Run the Mathcad License Setup wizard by entering mathcad /license at a command prompt, and specify the new product code when prompted. The wizard will then obtain a new license for your installation.

Transferring a License to a New Server or Workstation

Can I move my Enterprise license to another server/workstation?

To move a license file from one server or workstation to another, use the Reconfigure Software Licenses option on the PTC Technical Support web site to de-allocate the license for the old CPU ID. Then use the Configure New Software option on the site to request a license file for the new CPU ID.

Can I transfer my Single-user installation of Mathcad to a new workstation?

Each Single-user product code can be used three times to obtain a license. Once you reach this limit, you must use the PTC Mathcad Single User and Student Licenses Call Logger to obtain an additional license.

Licensing and Remote Usage of Mathcad

Can I still run Mathcad if the workstation is not connected to a network?

Mathcad installations that use node-locked, home-use, or Single-user licenses can run remotely, or witFor the exact maximum borrowing period, consult your license file for the text "Borrow=xxx", where "xxx" is the maximum allowed borrowing period, in hours.

For more information on borrowing, consult the FLEXnet Licensing End User Guide.

Obtaining your Sales Order Number

For Customers with Active Maintenance or Expired Maintenance After November 2005 to present

If you do not currently have your Sales Order Number, you can access your Sales Order Number through the Business Asset Summary Web Tool online at http://www.ptc.com/support under the Licensing Tools section. You will need an Upgraded Web Support account to access the tool. You can Upgrade an existing basic ptc.com account here or you may need to create a new basic ptc.com account and Upgrade it through the new account process. You will need your Service Contract Number (SCN) and Customer Number to create your Upgraded Web Support account

For Customers with Expired Maintenance before November 2005

Please contact Customer Care to help you identify the information you will need. By re-activating Maintenance a new Sales Order Number will be generated.

Customer Care Telephone Numbers:

  • North America: 877-275-4782
  • Europe: 00800-78-24-43-57
  • Japan: +81 (0) 3-3346-8280
  • Asia & Pacific Rim: +852 2802-8982

For Customers who do not know their Customer Number or Service Contract Number

If you do not know your Customer Number or Service Contract Number, please contact the License Management department and a license management representative will be more than happy to assist you. For your local licensing contact, see the list available at http://www.ptc.com/olm/contacts.htm.

Mathcad 15.0

Reference Documents - Mathcad 15.0 Installation and Configuration Guides

Video - Licensing for existing maintenance customers

Video - Licensing for new and Single User upgrade customers

Table of Contents

  1. Licensing Basics
  2. Upgrading an Existing Installation
  3. Obtaining a License
  4. Configuring Mathcad to Use Your License File
  5. Reinstalling or Updating Mathcad
  6. Transferring a License to a new Server or Workstation
  7. Licensing and Remote Usage of Mathcad

Licensing Basics

What types of licenses are available?

There are two types of Mathcad 15.0 Professional licenses available for purchase: Floating and Individual (node locked).

Do I need to install any software to manage my license file?

Floating license files require a server to administer them. Individual and Home Use license files are tied to an individual workstation, and require no additional software.

Can I manage multiple Individual licenses from a server?

PTC does not support a server-based Individual license for Mathcad, and does not allow generation of such a license file at the license management web site. Alternate solutions are to either request individual (workstation) node-locked license files or purchase a registered-user license.

Upgrading an Existing Installation

Do I need to update my installation of FLEXlm?

Mathcad 15.0 requires FLEXnet 10.8 or later to administer floating and registered-user licenses. Users of versions prior to FLEXnet 10.8 must update their license server software. FLEXnet 10.8 for Windows is available on the Mathcad 15.0 CD. You can also use the version of FLEXnet 10.8 or later for UNIX platforms that is provided with other PTC software.

For information on installing FLEXnet 10.8, see the Administrator's Guide, available on the Mathcad CD.

If I'm upgrading from a prior version, do I need a new license file?

Yes, you must request a new license file to use with Mathcad 15.0.

I purchased a license for an Extension Pack (Image Processing, Signal Processing, Wavelets, and/or Data Analysis) for use with my prior Mathcad installation. How do I upgrade my license for this extension pack?

For all customers except Student Edition, Mathcad 15.0 licenses enable use of all four extension packs, which are installed automatically with Mathcad. When you receive your Mathcad 15.0 license file, it will allow access to the extension packs.

How do I license-manage both Mathcad 15.0 and a previous version of Mathcad? Can I do so with the same FLEXnet installation?

You can install FLEXnet 10.8 alongside an existing FLEXlm installation, or you can use FLEXnet 10.8 to administer licenses for prior versions of Mathcad as well as Mathcad 15.0.

Use the version of LMTools provided with FLEXnet 10.8 to administer both your Mathcad 15.0 and prior version Mathcad licenses. Take care to select the proper service on the Config Services tab before modifying any service information. To perform a status enquiry, first select the correct service on the Service/License File tab.

Note that Mathcad 15.0 and Mathcad 14.0 cannot be installed on the same workstation. Please see this Technical Point of Interest for more information.

Obtaining a License

How do I obtain a license file for Professional, Professor and University Edition licenses?

There are 3 basic steps to licensing your copy of Mathcad:

  1. Install Mathcad software on your workstation.
  2. Request a license file from PTC and save to your workstation.
  3. ell Mathcad where your license file has been saved to your workstation.

Here’s how to install your software and request your license key:

    1.        Have ready your:

    a.        Sales order number and customer number. Both can be found on the Shipment Confirmation document from PTC, emailed to the address provided in the software order.

    b.        PTC web account login. If you have not yet created your Basic Account, please visit www.ptc.com and click on “My Account” and then “Create a Basic Web Account”. 

    2.        Install Mathcad:

    a.        Insert the Mathcad CD into your CD ROM drive. If the installation program does not start automatically, you can start it manually by choosing ‘Run…’ from the Start menu, and typing D:\SETUP (where “D:” is your CD-ROM drive).  Or, browse to the Mathcad installation files on your network.

    b.        After reading and accepting the software license agreement, select ‘Mathcad’ as the product to be installed. On the following screen, select ‘Acquire a new license’. Follow the remaining on-screen instructions.

    3.        When the “Mathcad License Setup” screen appears, select “I want to acquire a license via the Internet” and click Next (if you have already retrieved your license file, skip to step 11).

    4.        Select the Mathcad product you ordered and click Next. (If you did not purchase a license, select “I want a trial license”, click Next, and follow the on-screen instructions instead of the steps below.)

    5.        On the next screen select the appropriate step. New users running this process for the first time select “I want to get a new Individual license for this computer”.

    6.        Enter your Sales Order Number (SON) and Customer Number from the Shipment Confirmation you received from PTC. If you ordered an upgrade from a prior Single User version, you must enter your old Product Code for validation. Click Next.

    7.        The Create Account screen appears. If you already have your PTC Basic Account from step 1b above, click Next. If you still need an account, click Create Account.

    8.        At this point you will be taken to the PTC website to verify the information you have entered. Verify the information is correct, and click Submit.

    9.        You will shortly receive your license file via e-mail. Save the file to a location on your workstation (must be the same hard drive where Mathcad is installed) that you will remember. You will need to point to this file in a subsequent step of the licensing process. When saving to your computer, change the file extension from .txt to .dat.

    10.     While waiting for your license files to arrive, allow the installation of Mathcad to continue, following the instructions on the screen.

    11.     When the installation of Mathcad is complete and you have received your license file via email, start the Mathcad License Setup program again by starting Mathcad. Or you can start License Setup by opening a command prompt (usually Start > Run > cmd) and typing “c:\Program Files\Mathcad\Mathcad 15\mathcad.exe” /license (make sure to include the quotes and all spaces).

    12.     Select ‘I want to configure Mathcad to use an existing license file’ and click Next.

    13.     Select ‘Use a license file’ and browse to where you saved the .dat file in step #9.  Follow the remaining instructions on screen to complete your installation of Mathcad.

How do I obtain a Student Edition license file?

The Mathcad License Setup wizard obtains a license file for you. The wizard requires that you have a user account for the PTC Web site (http://www.ptc.com) and a unique Product Code (contained in the physical Mathcad packaging).

How do I determine a computer's CPU ID?

In Mathcad 15.0 the License Setup wizard determines your computer's CPU ID automatically.

How do I create an account on PTC.com?

A Basic account can be created here: https://www.ptc.com/appserver/common/account/basic.jsp 

In order to access software downloads, licensing tools and other maintenance entitlements, you will need to upgrade your Basic account to a Customer Support account. This can be done here: https://www.ptc.com/appserver/common/account/secure/premiumAccount.jsp 

I don't have Internet access on the workstation where I installed Mathcad. How do I request a license file?

From another computer with internet access, select Configure New Software.

How do I receive my license files?

The Mathcad License Setup wizard handles license file requests automatically. Student Edition and 30 day trial license files are transmitted to the workstation at the conclusion of the request and saved to the licenses folder of your Mathcad installation.

For all Professional, Professor and University Edition license file requests, you will receive your license file as an email attachment after you submit your request. Follow the instructions above to complete the licensing of Mathcad 15.0.

Can I request multiple server license files?

You can divide your licenses between multiple license servers by requesting a license file for each server, so long as the total number of licenses you request does not exceed the terms of your purchase.

Configuring Mathcad to Use Your License File

How do I point Mathcad to the appropriate license server or license file?

During installation, the Mathcad installer presents the Mathcad License Setup wizard, which allows you to specify the name of the license server or file that Mathcad should use. Enter “c:\Program Files\Mathcad\Mathcad 15\mathcad.exe” /license (make sure to include the quotes and all spaces) at a command prompt to update this information.

Why can't the Mathcad License Setup wizard or the FLEXnet installer find my license file?

Mathcad requires that your license file name end with a .DAT extension. However, license files are attached to email as a text file with a .TXT extension. When prompted, to browse for your license file:

  1. Enter *.txt in the file name field to display the license file.
  2. Select the license file from the file list that results.

Both the Mathcad License Setup wizard and the FLEXnet installer create a file named license.dat when run. This license.dat file is then used to license manage Mathcad.

Reinstalling or Updating Mathcad

I uninstalled and reinstalled Mathcad, or applied a software update. Do I need a new license file?

Floating and registered user licenses are unaffected when you uninstall and reinstall Mathcad, or apply a software update. If you have customized your options file (ptc.opt) to include or exclude a specific workstation, update the file accordingly. For more information on modifying the options file, see the Administrator's Guide.

For all other license types – Individual, Student, Professor and Home Use - you must request a new license file if you have installed Mathcad to a new workstation or manually deleted your license file.

I installed a trial version of Mathcad. How do I update my installation once I buy Mathcad?

Run the Mathcad License Setup wizard by entering “c:\Program Files\Mathcad\Mathcad 15\mathcad.exe” /license (make sure to include the quotes and all spaces) at a command prompt, and follow the instructions above under How do I obtain a license file for Professional, Professor and University Edition licenses.

Transferring a License to a New Server or Workstation

Can I move my license to another server/workstation?

Run the Mathcad License Setup wizard by entering “c:\Program Files\\Mathcad\Mathcad 15\mathcad.exe” /license (make sure to include the quotes and all spaces) at a command prompt, and select ‘I want to acquire a license via the Internet’. On the next screen select product you own, and then select ‘I want to transfer the right to use an existing license from one computer to another computer’.

As an alternative method, use the Reconfigure Software Licenses option to move the license for the old CPU ID to a new computer.

Licensing and Remote Usage of Mathcad

Can I still run Mathcad if the workstation is not connected to a network?

Mathcad installations that use Individual or Home Use licenses can run remotely. For information on borrowing a license from a server pool, consult the FLEXnet Licensing End User Guide.