What’s New:
PTC Creo Parametric 3.0
Datecode M060
Contents

Fundamentals .............................................................................................................................................. 7
  3D Printing Is Available ......................................................................................................................... 8
  Engineering Notebook Powered by PTC Mathcad .............................................................................. 9
  Improvements in Mass Properties ...................................................................................................... 10
  View Normal Orientation ...................................................................................................................... 10
  Reorienting the Model Is Easier ............................................................................................................ 10
  The Window Is Automatically Activated .............................................................................................. 11
  Customizing Shortcut Menus .............................................................................................................. 11
  Digital Rights Management .................................................................................................................. 11

Design Exploration ................................................................................................................................. 13
  Design Exploration Is Available ........................................................................................................ 14
  Storing Changes in Design Exploration ............................................................................................ 15

Part Modeling (Part, PTC Creo Flexible Modeling) .................................................................................. 17
  Untrimming When Copying Surfaces ................................................................................................. 18
  Enhancements to the Collapse Feature ............................................................................................... 18
  Chordal Rounds .................................................................................................................................. 18
  Reorder Is Enhanced ............................................................................................................................ 19
  Read Only Features Are Easy to Identify ............................................................................................ 19
  Boundary Blend Enhancements .......................................................................................................... 20
  Flatten Quilt Enhancement .................................................................................................................. 21
  Chamfer Support in PTC Creo Flexible Modeling .............................................................................. 22
  Enhanced Rounds Support in PTC Creo Flexible Modeling .............................................................. 23
  Tangency Propagation and Control in PTC Creo Flexible Modeling .................................................. 24
  Pattern Propagation in PTC Creo Flexible Modeling ......................................................................... 24
  New Flexible Pattern Tool in PTC Creo Flexible Modeling ............................................................... 25
  Entry Point for Insert Mode .................................................................................................................. 25
  User Interface for Spinal Bend Is Enhanced .......................................................................................... 26
  Enhancements to Edit Reference ......................................................................................................... 26
  Displaying Missing References .......................................................................................................... 27
  Referencing a Pattern in Part Modeling ............................................................................................... 28
  Geometry Pattern on Variable Topology ............................................................................................. 28
  New Layout Feature .............................................................................................................................. 29
  Update Control for Layout Feature .................................................................................................... 29

Data Exchange (Interface, PTC Creo Unite) .............................................................................................. 31
  PTC Creo Unite Technology—Working in a Multi-CAD Environment ............................................. 32
  Automatic Conversion Using PTC Creo Unite Technology ............................................................... 32
  Creating Profiles Using PTC Creo 3.0 Unite Technology ................................................................. 33
  Solid Edge Import ............................................................................................................................... 34
  Importing Drawings from PTC Creo Elements/Direct ...................................................................... 34
Support for Product Manufacturing Information (PMI) When Importing .............................................. 35
Support for JT 9.5 ........................................................................................................................................ 36
Planar and Zonal Cross-Section Support for JT ......................................................................................... 37
Semantic Exchange of Annotations Support for JT ..................................................................................... 37
Support for Colors for JT ............................................................................................................................ 37
Support for Angle Control in JT ................................................................................................................ 38
Detailed Drawings ...................................................................................................................................... 39
User Interface for Creating Dimensions Is Improved .................................................................................... 40
User Interface for Creating Notes Is Improved ............................................................................................ 40
Geometric Tolerance Enhancements ........................................................................................................... 41
Security Marking Designation for Annotation ............................................................................................... 42
Hyperlinks to Combination States ................................................................................................................ 42
Symbols in Notes ......................................................................................................................................... 43
PTC Creo Layout ......................................................................................................................................... 45
Import Functionality Is Improved ................................................................................................................ 46
Hatching and Fill are Supported .................................................................................................................. 46
Chamfer is Improved ..................................................................................................................................... 47
New Sublayouts ............................................................................................................................................ 47
Sketching Enhancements ............................................................................................................................... 48
PTC Creo Layout Model Tree ......................................................................................................................... 49
Dimension Properties ................................................................................................................................... 50
Support for Parameters ................................................................................................................................. 50
Selection is Improved .................................................................................................................................... 50
Surfacing (Freestyle, Style, Technical Surfacing) .......................................................................................... 51
Aligning Freestyle Geometry ......................................................................................................................... 52
Joining Freestyle Geometry .......................................................................................................................... 52
Dragging in Freestyle ..................................................................................................................................... 53
Sweep Geometry in Style ............................................................................................................................... 53
Merging Surfaces in Style ............................................................................................................................. 54
Isoline Curve in Style .................................................................................................................................... 54
Evaluating Connections in Technical Surfacing ............................................................................................. 55
Knots Analysis is Improved .......................................................................................................................... 55
Rendering (Photorealistic Rendering) ........................................................................................................... 57
Manipulating HDR Images ........................................................................................................................... 58
Realistic Bump Mapping ............................................................................................................................... 58
Realistic Appearances .................................................................................................................................. 59
Improvements in Transparent Displays ........................................................................................................ 60
Ambient Occlusion Is Available ................................................................................................................... 60
Assembly Design (Intelligent Fastener, Assembly) ....................................................................................... 61
PTC Creo Intelligent Fastener ......................................................................................................................... 62
PTC Creo Intelligent Fastener (Lite) ................................................................................................................ 62
Update Control for Data Sharing Features .................................................................................................... 63
Notifications Are Collected and Easily Accessible ......................................................................................... 65
New Option for Controlling External References ......................................................................................... 66
Status Reporting Is Improved in Assemblies ................................................................................................. 66

What's New: PTC Creo Parametric 3.0
<table>
<thead>
<tr>
<th>Feature</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Performance Tuning for Solver Engine I/O Is Improved</td>
<td>102</td>
</tr>
<tr>
<td>Icons are Updated</td>
<td>103</td>
</tr>
<tr>
<td>Changing Entity Colors</td>
<td>104</td>
</tr>
<tr>
<td>Usability Improvements to Fasteners with Defined Preloads</td>
<td>104</td>
</tr>
<tr>
<td>Improvements to FEM Mode</td>
<td>105</td>
</tr>
<tr>
<td>Weighted Links in 2D Analysis</td>
<td>106</td>
</tr>
<tr>
<td>Simple Fracture Mechanics Is Added</td>
<td>107</td>
</tr>
<tr>
<td>Improved Process to Determine the Best Analysis</td>
<td>107</td>
</tr>
<tr>
<td>New Workflow for Creating Notes</td>
<td>109</td>
</tr>
<tr>
<td>Analysis Studies are Listed in the Model Tree</td>
<td>110</td>
</tr>
<tr>
<td>Improved Workflow for Interrogating Results</td>
<td>111</td>
</tr>
<tr>
<td>Defining Contact Interfaces with Finite Friction</td>
<td>112</td>
</tr>
<tr>
<td>Mapped Mesh Option for 2D Models</td>
<td>113</td>
</tr>
<tr>
<td>Display of Shells, Beams, and Fasteners is Improved</td>
<td>114</td>
</tr>
<tr>
<td>Analyze Models with Failed Features</td>
<td>115</td>
</tr>
<tr>
<td>Updated Process for Creating Linearized Stresses</td>
<td>116</td>
</tr>
<tr>
<td>Fatigue Analysis with Multiple Load Sets</td>
<td>117</td>
</tr>
</tbody>
</table>
Fundamentals

3D Printing Is Available.................................................................8
Engineering Notebook Powered by PTC Mathcad................................9
Improvements in Mass Properties..................................................10
View Normal Orientation ................................................................10
Reorienting the Model Is Easier .......................................................10
The Window Is Automatically Activated ..........................................11
Customizing Shortcut Menus..........................................................11
Digital Rights Management ............................................................11
3D Printing Is Available

Functionality for 3D printing is introduced in PTC Creo Parametric.

User Interface Location: Click **File ▶ Help ▶ 3D Print.**

**Benefits and Description**

PTC Creo is closing the gap between CAD systems and 3D printers.

You can use 3D printing for rapid and functional prototyping, and for end-user products created with the process of additive manufacturing. Additive manufacturing is quickly becoming a common manufacturing process on the same level as mold and casting and can improve efficiency in ways such as those listed below:

- Produce high-value parts with individual customization requirements.
- Greatly reduce the time it takes to make these parts.
- Reduce cost by avoiding the need to create expensive molds or casts that are typical in high-volume production.

To speed up the development of Additive Manufacturing functionality, PTC is partnering with Stratasys, a manufacturer for 3D printing equipment, to streamline 3D printing workflows by using direct interaction between PTC Creo and supported Stratasys 3D printers. Support for additional printers is planned.

Before the availability of 3D printing in PTC Creo Parametric, intermediary software to ensure that your designs were printable in 3D was required. With 3D Print functionality, designers can do all 3D printing work using standard PTC Creo models when connected to a supported Stratasys printer, and in this case the intermediary software is not required.

In PTC Creo 3.0 M040 you can perform the following actions with **3D Print** using a generic printer:

- Print parts and assemblies that were created in Creo Parametric using STL (stereolithography) files as an input to the software of the 3D printer. Most 3D printers use STL files as input.
- Define a user-defined printer for all other brands of 3D printers or when a Stratasys printer is not available. With the user-defined printer you can prepare your model for printing as described in the list below:
  - Define the printer box envelope.
  - Perform scaling.
  - Position the model on the tray, using the dragger.
  - Display a rough estimate of the support material for visualization purposes, not the actual support structure.
○ Perform printability validation for thin walls and narrow gaps. When you find an issue with the model, you can fix the issue in part or assembly mode.
○ Show a clipped view of the model, using the dragger.
○ Save the CAD data together with the model translation and rotation on the tray as an STL file. The quality of the printed model is set by the STL file resolution.

In PTC Creo 3.0 M040 you can perform the following actions with **3D Print** when using a supported Stratasys printer:

- Assign materials and colors to the model, define the finish as glossy or matte, and get an estimation of the maximal required support material.
- Position automatically.
- Control the speed of the printing by either printing each individual layer or printing two layers at a time. The speed of printing does not affect the amount of the required build and support materials.
- Calculate the required amount of build and support materials.

## Engineering Notebook Powered by PTC Mathcad

PTC Mathcad Prime 3.1 is integrated with PTC Creo Parametric. You can embed a PTC Mathcad Prime 3.1 worksheet directly within a PTC Creo Parametric model at the part or assembly level, to document design intent and share parameters between the worksheet and the model.

### Benefits and Description

You can embed a single worksheet for each PTC Creo Parametric object and then open, edit, and save the worksheet within the model. Embedding worksheets with the model is more efficient than saving them separately and saves time. You can use the embedded worksheet as a scratch pad to record design notes, to solve simple to complex calculations, and as the mathematical source for parameters in the model. This makes it easier and faster to document engineering knowledge and design intent inside the model and is a powerful way to link the two together.

You can also share data between PTC Mathcad and PTC Creo Parametric using the PTC Creo Parametric parameter table. The parameters in the embedded PTC Mathcad worksheet can be tagged as inputs or outputs. These parameters then become available in PTC Creo Parametric model in which the worksheet is embedded and can be used in the same way as native PTC Creo Parametric parameters. You can use the embedded PTC Mathcad worksheet to derive design parameters to use in PTC Creo Parametric or to analyze dimensions from your model using the extensive array of mathematical tools in PTC Mathcad.
Improvements in Mass Properties

The reporting and calculating of Mass Properties are simplified and improved.

Benefits and Description

Improvements to Mass Properties are described in the list below:

• Added an extended set of Mass Properties parameters to indicate the Coordinate system and transform that are used as a base for alternative parameters and used in calculations.
• Added a parameter to define the origin for inertia calculations.
• Created a better workflow in the Mass Properties report to avoid extra prompts and added information about the source of the Mass Property.
• Improved the treatment of a dependency on Mass Properties on a selected CSYS. When the CSYS is missing, Mass Properties are calculated correctly using the previous transform.
• Added the ability to set a default source for Mass Properties calculations in an analysis.
• Extended PTC Creo Parametric TOOLKIT support. Identifying Mass Properties that need updating is improved.

View Normal Orientation

You can orient planar entities normal to the view direction.

User Interface Location: Click View ➤ Saved Orientations ➤ View Normal.

Benefits and Description

You can orient the model so that the selected planar reference, such as a surface, sketch, datum plane, or cross section, is normal to the view direction. If a second reference is selected, the model is oriented towards the top of the graphics area, as if the reference was selected as Reference 2 in the Orientation dialog box.

Reorienting the Model Is Easier

You can orient your model to be normal to a plane, planar surface, cylinder, linear edge, or three vertices.

User Interface Location: Click View ➤ Named Views ➤ View Normal.

Benefits and Description
Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

There are new capabilities for orienting your model based on the geometry. You can select a planar face, a cylindrical face, or a conical face and choose to orient the model normal to that reference. The model is then oriented appropriately. In addition you can select three vertices and a plane is applied through those three vertices. The view is then oriented normal to that defined plane.

The Window Is Automatically Activated

The window you switch to is automatically activated.

Benefits and Description

When working with multiple windows, the window you switch to is automatically activated. You do not need to manually activate the window.

Customizing Shortcut Menus

You can customize a shortcut menu.

User Interface Location: Click File ▶ Options and then click Shortcut Menu.

Benefits and Description

You can remove and reorder commands in shortcut menus. This increases productivity by having easy access to the commands you use most frequently and by removing the commands you do not use. Shortcut menus are also modernized to improve usability.

Digital Rights Management

PTC Creo Digital Rights Management is discontinued and not available in PTC Creo 3.0. Digital Rights Management is supported in PTC Creo 2.0 and earlier.
Design Exploration

Design Exploration Is Available ................................................................. 14
Storing Changes in Design Exploration .................................................... 15
Design Exploration Is Available

You can use Design Exploration to explore changes to a design without committing to the change.

User Interface Location: Click File ▶ Manage Session ▶ Design Exploration session and then click Start or Open.

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

Changing a product design and exploring new ideas is a technical challenge, especially when developing complex systems with many interdependent components. Typically, this process involves manual backup of models to folders, repeatedly closing and cleaning the PTC Creo Parametric session, and manually revisiting and reviewing massive iterations until making a decision. Design Exploration helps to streamline the process of evaluating new designs and deciding on changes to the design. In PTC Creo Parametric, open a model. To start exploring new ideas click File ▶ Manage Session ▶ Design Exploration session ▶ Start to open a Design Exploration session and then in the Name box, type a name for the session. This is where all your exploration ideas are stored. A snapshot of your PTC Creo Parametric session content is saved to the checkpoint Pre-modified. You can now start to experiment with your design without risking the original models. As you make changes, you can add checkpoints. Each checkpoint stores only the incremental model changes since the last checkpoint. For your additional clarification, you can provide a checkpoint name, comments, and also define keywords to use, for example, in a search for the checkpoint Pre-modified. You can now switch between checkpoints without losing information. In your Design Exploration session, multiple model iterations are replaced as they are captured in the active checkpoint. That eliminates the need to manually backup models to different locations or clean up your session each time you want to switch between different design iterations.

When manipulating models in an active checkpoint that already has successors, you can create new checkpoint sequences and form different branches. With branching, you can develop and evaluate multiple ideas, simultaneously. Every branch represents a different direction of the design. If some checkpoints along the branch are no longer needed you can delete them without losing information in a later iteration. If you shorten the branch, iterations from a deleted checkpoint are merged into its successor. You can also delete a complete branch. You can navigate the Checkpoint Tree in Tree view, or in Timeline view. Checkpoints along the active path appear in a darker font making it easier to locate earlier checkpoints in same sequence. You can browse different branches that appear in a lighter grey font. When you are ready to make a decision, you can accept the
checkpoint with the chosen design and then return to the PTC Creo Parametric session. You can keep entire session data in the specified .TMZ file. All model iterations along the path to this checkpoint will be applied to the models from which you started the Design Exploration session.

**Storing Changes in Design Exploration**

Others can review your proposed changes.

**Benefits and Description**

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

If you want your design reviewed by others, you can distribute the .TMZ file containing your design. Others can then explore your ideas or add their own. By default, Design Exploration stores only incremental changes. The first Pre-modified checkpoint stores only the paths to the locations of the starting models. If you plan to send session data to a user that does not have access to same the file system or to the locations of the original models, you can have all the start models added into the .TMZ file. The content of the .TMZ file is encrypted and compressed to avoid confusing the experimental design with the actual design.
Part Modeling (Part, PTC Creo Flexible Modeling)

Untrimming When Copying Surfaces ................................................................. 18
Enhancements to the Collapse Feature ............................................................ 18
Chordal Rounds .................................................................................................. 18
Reorder Is Enhanced ......................................................................................... 19
Read Only Features Are Easy to Identify ......................................................... 19
Boundary Blend Enhancements ....................................................................... 20
Flatten Quilt Enhancement ............................................................................... 21
Chamfer Support in PTC Creo Flexible Modeling ........................................... 22
Enhanced Rounds Support in PTC Creo Flexible Modeling ............................. 23
Tangency Propagation and Control in PTC Creo Flexible Modeling ............... 24
Pattern Propagation in PTC Creo Flexible Modeling ........................................ 24
New Flexible Pattern Tool in PTC Creo Flexible Modeling ............................. 25
Entry Point for Insert Mode ............................................................................... 25
User Interface for Spinal Bend is Enhanced ..................................................... 26
Enhancements to Edit Reference ..................................................................... 26
Displaying Missing References ........................................................................ 27
Referencing a Pattern in Part Modeling .......................................................... 28
Geometry Pattern on Variable Topology .......................................................... 28
New Layout Feature .......................................................................................... 29
Update Control for Layout Feature ................................................................. 29
Untrimming When Copying Surfaces

You can untrim surfaces for native or imported geometry.

User Interface Location: Select a surface to copy and then click Model ▶ Copy. Click Model ▶ Paste and then right-click to select Untrim to envelope or Untrim to domain of definition.

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

When copying a surface or quilt you can use new options to untrim the geometry to its original definition or to the envelope of its definition. Surfaces can be untrimmed from both imported and native geometry. To untrim a surface, copy and paste the surface and then under Options in SURFACE: Copy either untrim to an envelope of the selected surface or untrim to the original domain of the surface. This creates an untrimmed dependent copy of the surface. In addition to untrimming a single surface, you can also untrim an entire quilt into individual surfaces. You can untrim the quilt to an envelope or to the original domain and create untrimmed surfaces for each patch in the surface.

Enhancements to the Collapse Feature

You can collapse any set of consecutive or geometrically-related features from PTC Creo Parametric or PTC Creo Direct.

User Interface Location: Click Model ▶ Editing ▶ Collapse.

Benefits and Description

You can use the Collapse command for a set of consecutive features or for all geometrically-related features, regardless of the first feature type, and regardless of whether the features are created in PTC Creo Parametric or PTC Creo Direct. If all geometrically-related features are selected, the resulting feature is an Independent Geometry feature. If a set of consecutive features is selected, the resulting feature is an Incremental Geometry feature. If the first feature is an import feature, the other features are collapsed into that import feature. Intent references are maintained and you have the option to keep Analysis, Annotation, Publish Geometry, and Cosmetic features.

Chordal Rounds

You can create a chordal or constant-width round.
User Interface Location: Click **Model ▶ Round**. In the **Round** tab, click **Sets ▶ Chordal**.

**Benefits and Description**

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

There is support for **Chordal** or constant-width rounds. For example, if you apply a round to the edge of the rear bumper in a model, you can see the transitions of the ends of the rounds blend towards triangular patches. Inside the round user interface click **Chordal**. Then, when changing the value of the round, you can see that the round maintains its constant width. You can add another round. The transition blends to a three-sided patch or point. Clicking **Chordal** results in a constant-width round. If you like, you can also select **C2 Continuous** to change this round to be curvature continuous. Changing the shape factor alters the cross-sectional shape of the round. If you click **Analysis ▶ Reflection** to apply a reflection analysis onto the geometry, you can see how cleanly the reflection lines transition across the patch structure. When you click **Shading With Reflections**, you can see clean reflections and highlights on the model.

**Reorder Is Enhanced**

**Reorder** functionality supports more flexible workflows.

User Interface Location: Click **Model ▶ Operations ▶ Reorder**.

**Benefits and Description**

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

Use the **Feature Reorder** dialog box for more flexible workflows when reordering features. You can still drag and drop features in the Model Tree, however, the **Feature Reorder** dialog box gives you more visibility into how reordering will impact other features. For example, if you move Extrude 2 after Round 4 you can see that the features depending on Extrude 2 are moved along with it. You can also reorder to and from groups and move nonsequential features.

**Read Only Features Are Easy to Identify**

Features set to **Read Only** are easy to identify in the Model Tree.
User Interface Location: Click **Model ▶ Operations ▶ Read Only**.

**Benefits and Description**

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

Click **Model ▶ Operations ▶ Read Only ▶ Set all as read only** and all the features are grouped together in the Model Tree. A lock icon 🗝️ appears next to **Read Only Features**. You can expand the **Read Only Features** but cannot modify the feature or references. In the Graphics window, you can see the dimensions for the feature, but cannot edit the dimensions. If you select **Set as last read only**, features from the beginning of the Model tree to the feature you select are set to **Read Only Features**.

**Boundary Blend Enhancements**

Resulting surface and connection quality is improved for **Boundary Blend**.

User Interface Location: Click **Model ▶ Boundary Blend**.

**Benefits and Description**

**Boundary Blend** is significantly improved, resulting in smoother surfaces and connections. Resulting surfaces are degree 5. A new **Optimize** option is added to further improve the quality of a single surface with 4 boundaries. This optimizes the connection influence throughout the surface and produces a smoother surface, especially in the corners.
Flatten Quilt Enhancement

You can flatten complex, freeform geometry.

User Interface Location: Click Model ▶ Surfaces ▶ Flatten Quilt.
Benefits and Description

The Flatten Quilt feature is enhanced to handle more complicated geometric scenarios where the quilt to flatten is not rectangular in shape. There is also support for symmetry.

Chamfer Support in PTC Creo Flexible Modeling

Chamfers are supported in PTC Creo Flexible Modeling with the tools to recognize chamfers and edit chamfers and with functionality to remove and recreate chamfers during Flexible Modeling operations.

User Interface Location: Click Flexible Modeling ▶ Rounds/Chamfers ▶ Recognize Chamfers or click Flexible Modeling ▶ Edit Chamfer.

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

Chamfers are supported in PTC Creo Flexible Modeling with the tools to recognize chamfers and edit chamfers and with functionality to remove and recreate chamfers during Flexible Modeling operations. If the chamfer geometry is created with a PTC Creo Parametric 3.0 or later Chamfer feature, it is automatically handled as a chamfer. If the chamfer geometry was created in an
earlier release or is imported, the chamfer-like geometry is extended and intersected to complete the **Flexible Modeling** operation. You can use the **Recognize Chamfers** tool to select chamfer-like geometry and have it handled as a chamfer, and not like regular geometry. As is the case with rounds, to maintain the engineering intent of the chamfer, the chamfer is removed before the **Flexible Modeling** operation and then recreated after the operation.

Click **Edit Chamfer** to edit chamfers and chamfer-like geometry. As with rounds, you can remove a chamfer or change its size and dimension scheme.

---

**Enhanced Rounds Support in PTC Creo Flexible Modeling**

Conic and curvature continuous rounds are supported in PTC Creo Flexible Modeling, and you can choose not to treat round-like geometry as an engineering round.

User Interface Location: Click **Flexible Modeling ▶ ▶ Edit Round** or click **Flexible Modeling ▶ ▶ Rounds/Chamfers**.

**Benefits and Description**

Watch a [video](#) on PTC University Learning Exchange, demonstrating the enhancement described below.

Conic and curvature continuous rounds are recognized and treated as round geometry, and can also be edited with **Edit Round**.

When you click **Edit Round** the current characteristics of a round surface appear and you can remove the round, or change the type to **Circular**, **Conic**, **C2 Continuous**, **D1 x D2 Conic**, or **D1 x D2 C2**.

As with circular rounds, conic and curvature continuous rounds are automatically recognized as round geometry. To preserve the engineering intent of the round geometry in your design, they are removed before a **Flexible Modeling** operation, and recreated after the operation.

If you do not want the round geometry to be treated as an engineering round, click **Not Rounds** and select the surface. The round geometry is now treated as a general surface. It is not removed and recreated, and, in the case of a circular round, changes can be propagated through the round if you choose the option to maintain tangency.
Tangency Propagation and Control in PTC Creo Flexible Modeling

There is support for maintaining tangent connections to adjacent geometry in PTC Creo Flexible Modeling.

User Interface Location: Click **Flexible Modeling** and then in the **Move, Offset**, or **Modify Analytic** tool, click [ ].

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

You can maintain tangent connections to adjacent geometry when you make geometric modifications to selected geometry. Geometry that is selected for modification with a tool on the **Flexible Modeling** tab such as **Move, Offset**, or **Modify Analytic** may be connected with tangency to neighboring surfaces. If that is the case, you may want the neighboring surfaces to be adjusted along with the primary surface to maintain that tangent connection. On the tab for the tool click [ ]. Default conditions are applied automatically to the neighboring geometry and you can also apply user-defined conditions to control how it should be adjusted to accommodate the changes to the primary geometry. You can fix surfaces, edges, or axes, specify that tangency should be maintained or lost, and maintain constant radii. The ability to control the propagation of geometric edits to tangentially attached surfaces provides you with additional power and flexibility.

Pattern Propagation in PTC Creo Flexible Modeling

You can easily propagate changes to pattern members from any other pattern member.

User Interface Location: Click **Flexible Modeling** and then in the tab for the **Move, Offset, Modify Analytic, Edit Round, or Edit Chamfer** tool, click **Options**.

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.
Propagating changes from one pattern member to all other pattern members is more flexible. Geometric changes made to any pattern member with tools on the Flexible Modeling tab such as Move, Offset, Modify Analytic, Edit Round, and Edit Chamfer, can be propagated out to all other members of the pattern. Make your geometric edits where they make the most sense to you and then easily propagate the changes to other pattern members.

**New Flexible Pattern Tool in PTC Creo Flexible Modeling**

You can use the **Flexible Pattern** tool to leverage the round and chamfer handling capabilities of PTC Creo Flexible Modeling while creating a pattern of geometry.

User Interface Location: Click **Flexible Modeling ▶ Flexible Pattern**.

**Benefits and Description**

Watch a [video](#) on PTC University Learning Exchange, demonstrating the enhancement described below.

You can use the **Flexible Pattern** tool to leverage the round and chamfer handling capabilities of PTC Creo Flexible Modeling while creating a pattern of geometry.

By default **Flexible Pattern** removes any round or chamfer attachment geometry, extends the one-sided edges of the patterned geometry until it intersects solid geometry, and then recreates the round or chamfer attachment geometry. With the **Attachment** options, you can control whether or not round and chamfer attachment geometry is recreated after it is removed, and whether or not the one-sided edges are extended.

On the **References** tab you can click the **Transform selected attachment rounds/chamfers** check box to treat attachment round and chamfer geometry the same as the rest of the patterned geometry. They will not be removed and recreated, and, if the **Attach pattern members** check box is selected, their one-sided surface edges are extended.

**Entry Point for Insert Mode**

The entry point for the Insert Mode functionality is simplified.

User Interface Location: In the Model Tree right-click a feature and select **Insert Here** or drag and then insert a feature.
Benefits and Description
The Insert Mode user interface is modernized to eliminate confusion.

User Interface for Spinal Bend is Enhanced
The user interface for Spinal Bend is modernized and an option to maintain the length of the original geometry is added.
User Interface Location: Click Model ▶️ Engineering ▶️ Spinal Bend.

Benefits and Description
Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

Spinal Bend has a modernized user interface and enhanced functionality.
By default, the Spinal Bend tool bends all of the selected geometry along the spine to match the length of the spine. If the spine is longer than the geometry, the geometry is stretched along the spine. If the spine is shorter than the geometry, the geometry is compressed along the spine.
By default the tool bends all of the selected geometry, but you have the option to bend only a portion of it by either a specified depth or up to a reference.
You also have the option to keep the original length of the geometry that is bent, instead of adjusting it to the length of the spine. You can also choose to remove the unbent portion of the geometry, or keep it.

Enhancements to Edit Reference
The Edit References user interface and functionality is enhanced.
User Interface Location: Click Model ▶️ Operations ▶️ Edit References or Model ▶️ Operations ▶️ Replace References.

Benefits and Description
Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.
Whether you are editing references used for feature creation, or replacing references for all downstream children, the workflows are more intuitive, flexible, and powerful. With **Edit References** you can change the references that are used to create one or more features. In the new user interface you can see the list of original references used by the feature or features, and make changes to them. You can roll the model to just before the earliest affected feature, and preview the results of your change.

Missing references appear in red in their last regenerated location to help you select an appropriate replacement reference.

From the **Child handling** section you can control all of the features that were children of the existing references. As you assign new references to the features, you can flip the direction of the feature creation. You also have the option to apply that same new reference to other children of the original reference.

With **Replace References** you can replace a reference for all children that use it. Again, you can roll the model to the earliest affected feature, and you can preview the results of your change. If you do not want to replace the reference for all children, you can deselect some children.

### Displaying Missing References

The last successfully regenerated location of a missing reference is highlighted.

#### Benefits and Description

Watch a [video](#) on PTC University Learning Exchange, demonstrating the enhancement described below.

References are occasionally lost as you make changes to iterate on your design. For example, several dependent features may fail as a result of changing the profile of a particular feature.

Missing references can be highlighted and displayed in several different ways, including while investigating the failure with the **Reference Viewer**.

You can choose to edit the references of the failed feature directly from the **Reference Viewer**. The **Edit References** dialog box opens, from which you can see the missing reference, select an appropriate replacement reference, and preview the result.

You can also choose to edit the definition of a failed feature, and the missing references are displayed to help you select appropriate replacement references. This is also true for missing references in Sketcher. You can see the previous location of the missing reference, and replace it with a new reference.
Referencing a Pattern in Part Modeling

Create features that reference any pattern member and use a Reference pattern to propagate them to all other pattern members.

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

Duplicating a feature from one pattern member to all other pattern members with a Reference pattern is more powerful and flexible. Features that reference any member of a pattern can be duplicated so that they reference all other members of the pattern. Previously, the features to be patterned had to reference the first member of the pattern.

You no longer need to know which pattern member is the lead member. Create your features where they make the most sense to you. The changes are then automatically duplicated to the other pattern members.

Geometry Pattern on Variable Topology

You can pattern geometry over variable topology with Geometry Pattern.

User Interface Location: Click Model ▶ Pattern ▶ Geometry Pattern.

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

On the Geometry Pattern tab there are options to help you create patterns of geometry over variable topology:

- Copies the geometry without trying to attach those copies to the solid. It creates a quilt at each of the pattern instance locations. These quilts are not merged to the existing solid geometry.

- Extends the edges of the one-sided surfaces of the geometry to be copied, so that it can be merged and solidified with the existing solid geometry. This is similar to the Attach tool in PTC Creo Flexible Modeling.
New Layout Feature

There is a new data sharing feature specifically designed for working with PTC Creo Layout files.

User Interface Location: Click Model ▶ Get Data ▶ Layout Feature.

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

There is a new data sharing feature specifically designed for using PTC Creo Layout files in 3D models. The new Layout Feature combines component-style placement of the layout model with the ability to copy specific layout content into the 3D model.

When you create a Layout Feature, you start by selecting the layout that you want to use. You then need to place the layout inside the 3D model using the same tools that are used to assemble any other 3D model. You can reference any of the geometry in the layout model for placement or use a coordinate system.

After the layout file is placed, you can then select the geometry that you want to copy. The layout model in the Model Tree can expand to show the sublayouts, structure nodes, and tags contained in the layout. This enables you to leverage the organization scheme that was added to the layout in the 2D environment. You can select any of these sublayouts, nodes, or tags from the Model Tree, or from the Graphics window. You can also select any individual entities or datums to be copied. When you expand the Layout Feature in the Model Tree you can see that the Layout Feature contains the entire layout model as well as some copied content. The layout model is not copied into the part, it is only referenced like a component of an assembly. To hide the layout model, right-click and select Hide layout items.

When you expand the copied content you will see only the items that were copied. These items are also visible in the graphics area.

If you have copied a simple profile with no intersecting loops, you can directly create an extrude or revolve feature using this geometry. You can select the Layout Feature and then select Extrude or Revolve and then specify the depth. For more complex profiles you can enter Sketcher and choose which parts of the profile you want to reference with your sketch.

Update Control for Layout Feature

Update Control, which is part of Design Exploration, includes some additional capabilities when it is used with the new Layout data sharing feature.
User Interface Location: Right-click the **Layout Feature** and select **Update Control**.

**Benefits and Description**

Watch a [video](#) on PTC University Learning Exchange, demonstrating the enhancement described below.

This assembly contains some parts that use Layout features to drive their geometry. The **Update Control** setting for the **Layout Feature** is currently set to **Manual Update with Notification**. This means that the **Layout Feature** maintains associativity to the layout file, but does not automatically propagate changes. Instead, you are notified that the layout has been modified and you have the opportunity to investigate those changes before updating the feature.

Now you can make some changes to the layout in the 2D environment. You can make some changes to the geometry by moving some entities and adding some new entities. You can also add a new node and create some geometry in that node. When you return to the 3D model, notice the yellow notification icon in the Model Tree next to the **Layout Feature**.

When you right-click the **Layout Feature** and select **Update Control** you have the options to show the differences, remove the notification, or directly proceed with the update.

The **Show Differences** environment for a **Layout Feature** contains additional options beyond what is available for regular 3D geometry. Click **Isolate** to remove all unrelated geometry from the display so you can focus only on the **Layout Feature**. Use geometry display filters to see on an entity-by-entity basis what geometry is changed, added, or deleted and any geometry that is outdated or unchanged. In the Model Tree you can see what sublayouts, nodes, or tags are changed, added, or deleted.

If you select **Update**, the **Layout Feature** is updated and changes are propagated to its children.
Data Exchange (Interface, PTC Creo Unite)

PTC Creo Unite Technology—Working in a Multi-CAD Environment ........................................ 32
Automatic Conversion Using PTC Creo Unite Technology ......................................................... 32
Creating Profiles Using PTC Creo 3.0 Unite Technology .......................................................... 33
Solid Edge Import ......................................................................................................................... 34
Importing Drawings from PTC Creo Elements/Direct ................................................................. 34
Support for Product Manufacturing Information (PMI) When Importing .................................. 35
Support for JT 9.5 ........................................................................................................................ 36
Planar and Zonal Cross-Section Support for JT ........................................................................... 37
Semantic Exchange of Annotations Support for JT ................................................................. 37
Support for Colors for JT ............................................................................................................. 37
Support for Angle Control in JT ................................................................................................. 38
PTC Creo Unite Technology—Working in a Multi-CAD Environment

There are multiple enhancements in the area of multi-CAD design.

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

With PTC Creo Unite technology it is no longer necessary to install additional third-party software or licenses to work with non-PTC Creo data. CAD consolidation is easier than ever. CATIA, SolidWorks, and NX files can simply be opened and referenced in PTC Creo. Format-specific profiles and templates help to load non-PTC Creo data as easy as native PTC Creo data. Once defined, these profiles automatically control what information gets into session without additional dialog boxes or user interaction. You can start to work with non-PTC Creo assemblies immediately. PTC Creo automatically tracks changes made to the non-PTC Creo data in their native systems and keeps the data up to date. It is also easy to distinguish the different formats in the Model Tree by their individual icons and file extensions.

In addition to new capabilities of updating and exporting SolidWorks data, PTC Creo 3.0 provides the ability to import Solid Edge parts and assemblies. During the import process of Solid Edge data, you can decide what information you want to import or can use the standard template for non-PTC Creo data. Imported geometry can easily be referenced using all available assembly constraints. PTC Creo 3.0 provides support for all major CAD formats to integrate, develop, and validate complete product designs. See article CS188975 for information about the current limitations of PTC Creo Unite technology working with PTC Creo View and PTC Windchill PDMLink 10.2.

Whether your goal is to improve collaboration between multiple formats or consolidate to a single CAD tools, with PTC Creo Unite technology it is easier than ever to work in a multi-CAD design environment.

Automatic Conversion Using PTC Creo Unite Technology

With PTC Creo Unite technology it is no longer necessary to install additional third-party software or licenses to work with non-PTC Creo data. CAD consolidation is easier than ever.
Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

CATIA, SolidWorks, and NX files can simply be opened and referenced in PTC Creo. It is easy to distinguish the different formats in the Model Tree by their individual icons and native file extensions.

PTC Creo 3.0 has enhanced functionality to modify designs in context. If you try to modify non-PTC Creo data in the context of a multi-CAD assembly, a message appears confirming that these changes will not be reflected in the native model. You can then select Convert or Do not convert. If you select Convert you can choose to automatically convert the non-PTC Creo data to PTC Creo data or to use advanced conversion tools. When you choose an automatic conversion, only the components that are required for the modification are converted into PTC Creo components. This ensures maximum reuse of existing non-PTC Creo files and prevents the overhead of managing multiple file formats and business objects for each component.

After converting the necessary components, PTC Creo can still maintain a link to the original non-PTC Creo files to retrieve updates based on changes made outside of PTC Creo. You also have the option to keep the newly created PTC Creo components separate from the original source files.

PTC Creo 3.0 provides support for all major CAD formats to integrate, develop and validate complete product designs. Whether your goal is to improve collaboration between multiple formats or consolidate to a single CAD tool, with PTC Creo Unite technology it is easier than ever to work in a multi-CAD design environment.

Creating Profiles Using PTC Creo 3.0 Unite Technology

There are multiple enhancements in the area of multi-CAD design. With PTC Creo Unite it is no longer necessary to install third-party software or licenses to work with non-PTC Creo data.

User Interface Location: Click File ▶️ Options to open the options dialog box for your application and then click Data Exchange.

Benefits and Description
Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

CATIA, SolidWorks, and NX files can simply be opened and referenced in PTC Creo. Format-specific profiles and templates help to load non-PTC Creo data as easy as native PTC Creo data.

Opening and importing options and format-specific profiles are controlled by selecting **Data Exchange** in the options dialog box for your PTC Creo application. With the help of the **Import Profile Editor**, you can create and modify profiles. Once defined, these profiles automatically control what information gets into session without additional dialog boxes or user interaction. You can start to work with non-PTC Creo assemblies immediately.

PTC Creo 3.0 provides support for all major CAD formats to integrate, develop, and validate complete product designs. Whether your goal is to improve collaboration between multiple formats or consolidate to a single CAD tool, with PTC Creo Unite technology it is easier than ever to work in a multi-CAD design environment.

**Solid Edge Import**

You can import and then work with Solid Edge data in PTC Creo Parametric.

User Interface Location: Click **File ▶️ Open** and then set the **Type** filter to **Solid Edge**. Click **Import**.

**Benefits and Description**

With the Solid Edge converter, you can import Solid Edge parts and assemblies. There is no need to install Solid Edge software to work with Solid Edge data.

**Importing Drawings from PTC Creo Elements/Direct**

You can import 2–D drawings created in PTC Creo Elements/Direct Modeling or PTC Creo Elements/Direct Drafting.

User Interface Location: Click **File ▶️ Open** and then in the **Type** box, select **Creo Elements Direct** (.bdl, .pkg, .sdp, .sda, .sdac, .sdpc) or **Creo Elements/Direct Drawing** (.mi, .bi, .bdl).

**Benefits and Description**

---

What's New: PTC Creo Parametric 3.0
Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

You can directly import a 2–D drawing, such as a drawing with two sheets, from PTC Creo Elements/Direct Modeling or PTC Creo Elements/Direct Drafting. Click File ▶ Open and in the Type box you can select to open a PTC Creo Elements/Direct drawing file such as an .mi or .bdl file. If you are opening an .mi file, the Import MI dialog box opens where you can find additional options to control the import. Under Sheets, you can see the two sheets. You can for example, click the Import Associative Dimensions check box to import these dimensions and measure the actual length of the imported 2–D geometry. From the Properties tab you can map Colors, Layers, Line Fonts, Hatch Line Fonts, and Text Fonts and save these changes by clicking Save Mapping. You can modify all 2-D geometry and annotations that are imported. If a sheet is added to the imported drawing, then the 2-D geometry and annotations can be modified for that sheet also. With this new functionality, you can leverage and reuse drawings created with PTC Creo Elements/Direct.

Support for Product Manufacturing Information (PMI) When Importing

Associative PMI and sections are supported when importing 3–D models created in PTC Creo Elements/Direct Modeling.

User Interface Location: Click File ▶ Open and then in the Type box, select Creo Elements Direct (.bdl, .pkg, .sdp, .sda, .sdac, .sdpc).

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

Semantic PMI and cross sections are supported when you import a 3–D model from PTC Creo Elements/Direct Modeling. In this example, an assembly you create in PTC Creo Elements/Direct Modeling contains documentation planes with dimensions that reference different parts of the assembly and documentation planes with annotations for a single part. The assembly also contains two cross
sections. When the PTC Creo Elements/Direct Modeling assembly is imported, PTC Creo Parametric supports the direct access of PTC Creo Elements/Direct Modeling 3–D model data as described below:

- The imported model with PMI appears in the Graphics window, including the view sets of the documentation planes.
- The part opens with the corresponding PMI information.
- When modifying the part with a tool such as Move, the dimension is automatically updated.

In the assembly, the PMI is also in sync with the geometry changes and all cross sections are recognized, making it easier to work with the imported assembly.

Support for JT 9.5
You can export to JT 9.5 and import JT 9.5 files.

Benefits and Description
You can open JT 9.5 files and import them into PTC Creo Parametric. You can also export from PTC Creo Parametric to JT 9.5 compliant files.
Planar and Zonal Cross-Section Support for JT

When importing JT or exporting to JT, there is support for the import and export of planar and zonal cross sections.

Benefits and Description
In parts and assemblies there is support for the import and export of planar and zonal cross sections. Cross-section definitions are included as part of exported combined views. In addition, the locations of cross sections are preserved.

Semantic Exchange of Annotations Support for JT

When importing from JT or exporting to JT, there is support for the semantic exchange of annotations.

Benefits and Description
This enhancement includes support for the items described in the list below:

- Import from and export to JT with dimensions as semantic
- Import from and export to JT with 3D notes as semantic
- Support for linear, angular, or radial dimensions
- Support for the semantic representation of annotations that preserve the datum and geometric references of the Product Manufacturing Information (PMI) data

Export to JT must be either to a `jt_brep` data structure or to a `XT_brep` data structure, in order to preserve PMI data. In both cases, the graphical content is exported. You can import and export single or multiple notes with PMI data attached to the reference geometry, such as edges and surfaces. Annotation references are available after export. You can use the reference in the PMI for additional modification.

Support for Colors for JT

There is support for colors when exporting to JT and importing from JT.
Benefits and Description
When exporting to JT and importing from JT, there is support for color as described in the list below:

- For Parts
  - Part color and quilt color are supported.
  - There is no overriding face color.

- For Assemblies
  - Direct component color such as colors assigned to top-level part or subassembly components are supported.
  - Indirect component color, such as colors assigned to sublevel components in a subassembly branch of the assembly, are supported.
  - Sublevel parts and subassembly colors are supported.
  - Assembly direct or indirect quilt color is not supported.
  - Direct and indirect face color of assembly or part-level quilts and solids is not supported.

- Color support is the same for facet and brep.

Support for Angle Control in JT
There is support for angle control when exporting to JT.

Benefits and Description
When exporting to JT, support for angle control includes the items described below:

- Control the absolute maximum angle between two adjacent line segments in curve approximation.
- Control the angle in a range of zero to ninety degrees.
- Export the model with three Levels of Detail (LODs) in a single export to JT. The angle control is specified in the `jt.config` configuration file.

Support for angle control works best when used in conjunction with the correct chordal height. By default 30, 60, and 90 degree angle values are used for three LODs. As a result of this enhancement, you can control the LODs, get a finer or coarser mesh, and control the angle along the curved edge.
Detailed Drawings

User Interface for Creating Dimensions Is Improved .................................................... 40
User Interface for Creating Notes Is Improved ............................................................... 40
Geometric Tolerance Enhancements .............................................................................. 41
Security Marking Designation for Annotation ............................................................... 42
Hyperlinks to Combination States ................................................................................. 42
Symbols in Notes ............................................................................................................. 43
User Interface for Creating Dimensions Is Improved

You can preview the dimension.

User Interface Location: Click Annotate ▶ Dimension.

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

When you select Dimension and then choose your first reference, a preview of the dimension is attached to the pointer. You can then place the dimension where you want. If you press CTRL to select additional references, the preview of the dimension updates, based on the selected references. You can use the same approach to quickly create common reference dimensions where you select the first reference as the baseline and then select additional references. As you select each reference, you see a preview of each dimension and then you can drag and place the dimension where you like. Certain dimension types have additional options to use during the dimension creation. When selecting an arc, for example, you can choose whether or not you want the arc dimension to be shown as a Diameter, Radius, Angular, or Arc Length. This is done during dimension creation so you can select exactly what you want and then place it in the correct location. Sometimes the orientation of the dimension can vary depending on the types of references selected. If you select the center of two circles for example, depending on where you place the pointer, you can orient a particular dimension by dragging it to a different location with the pointer. Alternatively, you can right-click to open a shortcut menu and select a Horizontal, Vertical, Slanted, Parallel To, or Perpendicular orientation.

User Interface for Creating Notes Is Improved

There are note commands in the ribbon for various placement options.

User Interface Location: Click Annotate ▶ Note.

Benefits and Description.

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.
The ribbon contains various placement options for Note:

- Unattached Note
- Offset Note
- On Item Note
- Tangent Leader Note
- Normal Leader Note
- Leader Note

After you select the Note placement option that you want, a preview of the note text box is attached to the pointer and moves as you select different references and then place the note. This gives you the benefit of seeing where you want the note to go, before you place it. You can add text directly to the note in the Graphics window. You can also click Format ▶ Note from File to enter text for the note from a file. You can start the note, for example, retrieve some text from a file, and then add the text to the note. Formatting changes can be made using the small formatting toolbar that appears when you select text. Click Format ▶ Insert Field to insert a parametric field into a note. You can select from a list of common parameter names that are available in a drawing, instead of having to remember the exact syntax of the parameter.

**Geometric Tolerance Enhancements**

Geometric tolerances are enhanced to better support ISO and ASME standards.

User Interface Location: Click Annotate ▶ Geometric Tolerance.

**Benefits and Description**

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

Geometric tolerances are enhanced to provide better support for ASME and ISO drawing standards. If you follow the ASME standard, you can add the translation modifier to any of the datum references by clicking the Translation check box for that particular datum in the Geometric Tolerance dialog box. Another enhancement for the ASME standard is the ability to add the All over symbol to the leader elbow of the geometric tolerance. All over symbol is found on the Symbols tab of the Geometric Tolerance dialog box. If you follow the ISO standard, you can include the reciprocity symbol along with the maximum or least material condition modifier. The reciprocity options are found on the Tol value tab in the Material.
condition box of the Geometric Tolerance dialog box. The functionality for specifying additional text around the geometric tolerance symbol is also improved.

- There are options for adding text above, below, to the right, or to the left of the GTOL symbol.
- You can set the justification of the text that is added either above or below the GTOL. You can justify this text to the right or to the left, or center it, depending on whether you follow ISO or ASME standards.

Security Marking Designation for Annotation

You can designate a note as a security marking.

User Interface Location: Select a note or symbol that is standalone, flat-to-screen, and unattached. The Format tab appears. Click Format ▶ Security Marking.

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

You can designate a note annotation placed with a flat-to-screen annotation plane as a security marking. For example, in this model the note on the lower left is a proprietary notice, which needs to be permanently displayed in all combination states. If you toggle through the various combination states, you can see that this note is currently assigned only to the Notes combination state. If you select the note, then click the Format tab, you can see the Security Marking command. Click Security Marking to designate the note as a security marking. The note is identified in the Detail Tree with a security marking icon and is automatically added to all existing combination states in the model. As you toggle through these combination states again, you can see the note in the Graphics window and in the Detail Tree. If you select the note, the commands Remove from State and Erase are not active. To erase this note or remove it from any combination state, its security marking status must first be cleared. Any notes that have been designated as security marking are permanently visible in PTC Creo View when the model is published with an appropriate adapter.

Hyperlinks to Combination States

You can designate a note as a hyperlink to a combination state.

User Interface Location: Click Format ▶ Hyperlink.
Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

A note annotation can contain a hyperlink to a combination state. Select an annotation and click Format ▶ Hyperlink to open the Edit Hyperlink dialog box. In the Type the URL or internal link box you can see a list of all of the combination states in the model. Select the combination state that you want and click OK. Then, when you click on the note, the view switches to the designated combination state. This functionality is helpful for setting up a combination state to assist in navigating all of the combination states in a large or complex model. You can designate each note as a hyperlink to a specified combination state.

Symbols in Notes
You can embed symbols in a note annotation.

Benefits and Description
You can embed a custom symbol inside a note annotation, in the same way that you embed a symbol in a note in a 2–D drawing. When editing a note, type the name of the symbol that you want to embed in the note and the symbol is embedded. For the name of the symbol follow the syntax &sym(symbol_name) where you replace symbol_name with the name of your custom symbol.
Import Functionality is Improved .......................................................... 46
Hatching and Fill are Supported ............................................................... 46
Chamfer is Improved .............................................................................. 47
New Sublayouts ..................................................................................... 47
Sketching Enhancements ........................................................................ 48
PTC Creo Layout Model Tree ................................................................. 49
Dimension Properties ............................................................................ 50
Support for Parameters .......................................................................... 50
Selection is Improved ............................................................................ 50
Import Functionality Is Improved

There is additional functionality available when importing 3D models.

User Interface Location: Click Design ▶ Import.

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

The model appears in the Import dialog box with semitransparent shading. This makes it easier for you to see the cross section in the model. There are two new areas in the Import dialog box:

- **Color**—Select Part if you want the imported entities to take their colors from the models or Layout to follow the default color of the layout.

- **Hatching**—Hatching is supported in PTC Creo Layout. Select Import to import the hatching from the 3D model or select Don’t import.

After a section is imported you can click View and then click or clear the Hatching & Fill check box to toggle the display of hatching. With the display of hatching turned off, it is easier to see if the imported entities match the colors of the original 3D models.

Hatching and Fill are Supported

There is support for hatching and fill.

User Interface Location: Click Design ▶ Hatching & Fill.

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

To create hatching, start by selecting a closed loop of entities and then select the Hatching & Fill tool. The Hatching & Fill tab appears on the ribbon with commands you can use to change the cosmetic appearance of the hatching. You can select the hatching pattern from a library of predefined hatching styles that are based on ANSI and ISO standards. You can select a Color for the hatching and set a value for the Angle of the hatch pattern. You can also increase or decrease the spacing in the hatch pattern by clicking Scale Up and Scale Down. To create more hatching areas, keep the Hatching & Fill tab open and select additional closed loops in which
you want to apply hatching. This is a quick way to apply hatching to a multiple areas in the design. Solid fill is also supported and can be added with or without hatching. Click **Fill** to select the color for the solid fill. If you want a solid fill without the hatching, you can select **No Hatch** from the hatching library.

### Chamfer is Improved

There are improvements to the **Chamfer** tool.  
User Interface location: Click **Design ▶ Chamfer**.

**Benefits and Description**

Watch a [video](#) on PTC University Learning Exchange, demonstrating the enhancement described below.

The **Chamfer** tool is enhanced to provide more control over the size of the chamfer during creation. After you select the references, a set of dimensions appears in the Graphics window to control the size of the chamfer. You can select the type of dimensioning scheme that you want and then type in the values for the dimensions. The geometry updates as you type different values for the dimensions so you can see the results immediately. Middle-click to complete the chamfer. The most recently used dimension scheme is the default when you create subsequent chamfers. In addition, a list of the most recently used dimension values are available in the dimension boxes. These enhancements to the **Chamfer** tool improve your efficiency when creating designs.

### New Sublayouts

There is support for a structured hierarchy of layout files.  
User Interface Location: Click **Organize ▶ New Sublayout**.

**Benefits and Description**

Watch a [video](#) on PTC University Learning Exchange, demonstrating the enhancement described below.

There is support for the concept of a structured hierarchy of layouts, much like an assembly of layout files. A layout that is added to another layout is a sublayout.
One way that you can create a sublayout is to convert an existing structure node to a sublayout. The geometry associated with the node is now part of the sublayout. One of the main uses for this technology is concurrent design. You can split a design into multiple sublayouts that can be worked on independently. You can open the sublayout in its own window and modify it independently of the top-level layout. In this case, you can make some changes to the geometry while this sublayout is opened in its own window. When you finish working on the sublayout and return to the window with the top-level layout, you can see that the modifications made to the sublayout are reflected in the top-level layout.

Another use for this sublayout technology is to have multiple dependent copies of the same object. You may, for example, add a sublayout to the top-level layout. The added sublayout comes in at a default location and you can then position it where you want. It is possible to have more than one occurrence of the same sublayout in the top level. You can, for example, create another occurrence and position that occurrence in a different location.

Much like working in an assembly, you can also activate any of the sublayouts and make changes to them in the context of the top-level layout. Any changes you make to that sublayout are immediately reflected in all the other occurrences.

Sublayouts can also be embedded in the top-level layout. Embedded sublayouts are treated exactly the same as regular sublayouts with the exception that there is no separate file saved. You can also easily convert any sublayout between embedded and extracted at any time.

**Sketching Enhancements**

The sketching experience in PTC Creo Layout is improved.

**Benefits and Description**

Watch a [video](#) on PTC University Learning Exchange, demonstrating the enhancement described below.

A number of improvements have been made to the sketching experience inside PTC Creo Layout.

Snapping to existing geometry is more robust. When using any geometry creation tool, you do not need to add existing geometry as a reference to be able to snap to it. Guides and snapping are also improved when dragging geometry. Guides are available for any references in the geometry that are being dragged, not only to the entity at the pointer. You can also add references to stationary geometry while you are dragging.
When using the **Linear** or **Radial** pattern tools, you can reposition the pattern increment and snap it to any existing geometry. As a result, you can define the increment of the pattern based on some other geometry in your design.

You can create temporary dimensions to help with precise placement of geometry. When using any geometry creation tool, place the pointer on the entity that you want to dimension to and press R. You can create two temporary dimensions to fully locate the geometry. Press TAB to switch between the two dimensions when entering values. The temporary dimensions disappear when the geometry is placed.

Temporary dimensions are also available when dragging existing geometry. You can place the pointer on a selected entity and press R to add the first dimension reference and then place the pointer on an unselected entity and press R again to add the second dimension reference. Next, type in a value and left-click to complete the operation.

Centerlines are finite in length and the workflow for creating a centerline is the same as for a regular line. Select the start and end points to place the centerline.

### PTC Creo Layout Model Tree

The navigator is updated to a structured Model Tree

**Benefits and Description**

![Video Icon](image)

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

The navigator is updated to a structured Model Tree. **Tags**, **Property Tags**, nodes and sublayouts are listed together in a single view. Each sublayout lists its own **Tags**, **Property Tags**, and nodes.

All of the tags or property tags from all of the sublayouts are listed in the single **Aggregate Tags** location. This makes it easier to control the visibility of any tags without having to expand all of the sublayouts in the Model Tree and then selecting those tags individually. When you open the **Assign Node** dialog box to add items to a node or sublayout, you can see the exact Model Tree structure. This makes it easier to find the node of sublayout that you want.

All of the information from the Model Tree in PTC Creo Layout is also visible when the layout file is used in PTC Creo Parametric making it easier to navigate the layout in the 3D environment.
Dimension Properties
You can edit some of the properties of a dimension.

Benefits and Description
Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

You can place additional text in a dimension. Select a dimension, right-click and select Edit Text. You can place the pointer before or after the dimension value and type the text you need. You can also edit some of the properties of a dimension. If you right-click a dimension and choose Properties, you can edit the Nominal value of the dimension, override the nominal value with another value you specify, and control the number of Decimal places.

Support for Parameters
Parameters are supported.

Benefits and Description
PTC Creo Layout supports parameters. You can add parameters to a layout from the Tools tab. Parameters in PTC Creo Layout may be called out in notes or drawing formats. They may not be used in relations or to drive geometry and they do not propagate to the 3D models.

Selection is Improved
Selection is improved.

Benefits and Description
Selection in PTC Creo Layout is improved. You can add or remove individual items from the selection set, by pressing and holding CTRL and clicking the items. You can add multiple items to the selection set using Box, Lasso, or Fence selection by pressing and holding CTRL and then clicking the items. Notice the small plus sign next to the pointer indicating that items will be added to selection. You can remove multiple items from the selection set using Box, Lasso or Fence selection by pressing and holding CTRL+SHIFT and then clicking the items. Notice the small minus sign next to the pointer indicating that items will be removed from selection.
Surfacing (Freestyle, Style, Technical Surfacing)

Aligning Freestyle Geometry .................................................................52
Joining Freestyle Geometry ..................................................................52
Dragging in Freestyle............................................................................53
Sweep Geometry in Style .......................................................................53
Merging Surfaces in Style .....................................................................54
Isoline Curve in Style ...........................................................................54
Evaluating Connections in Technical Surfacing ......................................55
Knots Analysis is Improved ....................................................................55
Aligning Freestyle Geometry

You can align Freestyle geometry to curves and edges.

User Interface Location: Inside a Freestyle feature, click Align.

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

In Freestyle you can align the Freestyle control mesh to external curves and edges. Therefore, you can parametrically control your freestyle geometry. For example, if you are working on a bike model, you may want to build the surfaces around the pedal. These surfaces are defined parametrically by the neighboring geometry. After the part is activated, you can use Freestyle to build this geometry. Starting with a sphere, you can build out the geometry to get it close to the neighboring surfaces. The part in this case is symmetrical so you can mirror it. After the part is mirrored, you can select the faces you want to delete and leave open. You can then take the edges of the open loops and align them to the edges of the neighboring geometry. When aligned, you can specify the continuity between the Freestyle geometry and the surrounding geometry. In this example, you create a normal connection. After establishing the connection, continue to refine your shape. You also need to define the location for the pedals. Again, when the geometry is close, you can align the external edges of your geometry. After making some final adjustments, the geometry is complete. You can then return to the top-level assembly and make changes to the skeleton model that is driving the shape of the frame. When regenerated, the Freestyle geometry is also updated to remain connected and tangent to the surrounding geometry.

Joining Freestyle Geometry

You can join edges or faces inside of Freestyle.

User Interface Location: Inside a Freestyle feature, click Connect ▶ Join.

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.
You can join faces and edges of the control mesh within **Freestyle**. Previously you had to delete two faces, build out the new geometry, and then use **Connect** to fill the gap. Now you can use **Join** to more easily get the same results. Select a face and pull it out. There is now a space you want to close. Select the surface on the face that you pulled out first, and then select the surface above it. Click **Join** to join the faces and close the gap. The first face selected remains and the second face selected moves on top of the first face. The second face selected, always moves over the first face selected. You can also join edges. If you delete the faces you can achieve the same results by selecting the edges and clicking **Join**. This makes it easier to alter the topology and shape of surfaces without having to delete and recreate faces or edges.

### Dragging in Freestyle

The **Improve performance during dragging** option is added.

User Interface Location: Inside a **Freestyle** feature, in the **Options** dialog box, click the **Improve performance during dragging** check box.

**Benefits and Description**

**Improve performance during dragging** improves performance when you are editing the control mesh, by reducing the quality of the surfaces and connections during manipulation. **Improve performance during dragging** is enabled by default. To change this default, set the configuration option `freestyle_drag_performance` to `no`.

### Sweep Geometry in Style

Sweep geometry in **Style** inherits the degree of the defining curves. In addition, connections are possible.

User Interface Location: Click **Model ▶ Style ▶ Surface**.

**Benefits and Description**

Watch a [video](#) on PTC University Learning Exchange, demonstrating the enhancement described below.
The sweep capability inside the **Style** feature is enhanced. When creating a sweep, the resulting swept surface inherits the degree of the defining curves. For example, if you create a sweep along a degree 5 curve using a profile curve that is degree 3, the resulting swept surface will be degree 5 x 3. In addition, you can right-click the glyph and select the type of connection that you want for the Sweep:

- Position
- Tangent
- Curvature
- Draft

This also works for sweeps with multiple trajectories.

### Merging Surfaces in Style

You can control whether to merge **Style** surfaces after completing the **Style** feature.

**User Interface Location:** When inside a **Style** feature click **Operations ▶ Preferences ▶ Merge surfaces on exit.**

**Benefits and Description**

The **Merge surfaces on exit** option lets you determine if you want to merge surfaces when you complete your **Style** feature. By default, surfaces are merged. To change this default, set the configuration option `style_merge_surfaces` to `no`.

### Isoline Curve in Style

You can create an isoline curve in **Style**.

**User Interface Location:** When inside a **Style** feature, click **Curve ▶ Curve from Surface ▶ Create an Isoline.**

**Benefits and Description**

Watch a [video](#) on PTC University Learning Exchange, demonstrating the enhancement described below.

When creating a **Curve from Surface** inside **Style**, you can choose to create this as an isoline curve. You have control over the parameterization of this curve. The curve always regenerates at the defined parameterization and can be fully redefined.
Evaluating Connections in Technical Surfacing

You can evaluate the connections of surfaces and curves.

User Interface Location: Click Analysis ▶ Inspect Geometry ▶ Connection.

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

You can analyze curves and surfaces in your model for Position, Tangency, and Curvature continuity using Connection. You can see where geometric connections are not met based on the desired input and tolerance.

Click Analysis ▶ Inspect Geometry ▶ Connection to open the Connection Analysis dialog box. You can analyze the Position, Tangency, or Curvature connections between surfaces or curves. For example, if you select Tangency (G1), you can perform a tangency analysis of the entire quilt. To see only areas that fail against tangency, select the Show only connections that fail check box. Areas that fail against tangency appear in red. Clear the check box to see areas that fail in red and areas that pass in green. To see notes that show the maximum value of any given area, select Maximal in the Notes box. Tolerance values for Position, Tangency, and Curvature appear in the Tolerance box. If you select Curvature you can see breaks in curvature in certain areas. Select the Enable tooltips check box, put the pointer on the area where there are breaks in the curvature and the value of the curvature appears at that point.

It is also possible to display the results as spikes by selecting Show spikes.

Knots Analysis is Improved

The Knots tool is improved.

User Interface Location: Click Analysis ▶ Inspect Geometry ▶ Knots or click Style ▶ Knots.

Benefits and Description

The Knots tool is enhanced. You can use the options listed below to define the items to display in the analysis:

• Knots—Shows the curve or surface knots.
• Control Mesh—Shows the curve control points or the surface control mesh.
• Both—Shows both the knots and the control points or control mesh.
Rendering (Photorealistic Rendering)

- Manipulating HDR Images ................................................................. 58
- Realistic Bump Mapping ................................................................. 58
- RealisticAppearances ................................................................. 59
- Improvements in Transparent Displays ........................................... 60
- Ambient Occlusion Is Available .................................................... 60
Manipulating HDR Images

You can view and manipulate High Dynamic Range (HDR) images in the Graphics window.

User Interface Location: Click View ▶ Display Style ▶ Shading With Reflections. Click Render and then in the Scenes dialog box, click Lights ▶ Environment.

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

In Shading With Reflections mode you can visualize and manipulate your HDR image. The HDR image is used for the background, lighting, and reflections on your model. This gives you a more realistic and immersive environment and is closely matched to the results obtained when rendering the image using PTC Creo Advanced Rendering Extension.

Click View ▶ Shading With Reflections. You can see high quality and realistic reflections on the model’s appearance. You have full control over the environment that is used. Click Render ▶ Lights ▶ Environment and choose the HDR image. You can then choose a different image and the reflections and lighting on your model are automatically updated. Click Perspective View to see the HDR image as the background. When you rotate the model, the HDR image moves also. You can control the settings of the HDR image by using sliders for Rotate, Height, Zoom, Intensity, and Saturation. As you change settings, the model changes dynamically so you can visualize your product in a realistic environment.

Realistic Bump Mapping

You can see realistic bump maps in the Graphics window.

User Interface Location: Click Render ▶ Appearance Gallery ▶ Edit Model Appearances.

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

When applying texture maps as a bump map you can see and control the result in the graphics area. When in Shading With Reflections mode you can visualize the effect of procedural bump maps such as Rough or Cast.
You can apply realistic textures and bump maps to the geometry. For example, you may want to assign an appearance of tire tracks to a tire. Open the tire separately and assign an appearance to it such as rubber. Then, assign a new appearance with a texture map of a tire tread to selected surfaces of the tire. You can make adjustments such as changing the scale, changing to cylindrical mapping, and then changing the height of the bump. The texture map is visible on the model. In the assembly, you see the tire and the tread. If you select View ▶ Shading With Reflections, you see the tread with the reflections. In addition to bump maps, you can also for example, alter the body by adding a Rough bump. If you change the scale and the size of the bump, you can see the effect appearing on the car body.

Realistic Appearances
There is a new library of realistic appearances.
User Interface Location: Click Render ▶ Appearance Gallery.

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

You can interactively represent realistic materials inside the Graphics window. These appearances closely match the results obtained when rendering using PTC Creo Advanced Rendering Extension. You can choose between different material classes.

The appearance of material is more accurately represented when Display Style is set to Shading With Reflections. When using Shading With Reflections you can see realistic reflections on your model. Click Render ▶ Appearance Gallery ▶ Library to see a list of different material types and classifications. You can assign a paint such as red, to the car body and realistic reflections of the red car body appear. You can assign glass to objects on the car and get realistic looking glass, including reflections in the glass. These appearances are closely mapped to the results you would get when rendering this image using the PTC Creo Advanced Rendering Extension. If you assign a red glossy plastic material to the wheels, for example, you can see that it looks like plastic. If you then change the material class to metal, you can see that wheel appears as a red anodized metal. If you set an appearance for the taillights to be red clear plastic, the lights appear as a translucent plastic in the rear-light assembly.
Improvements in Transparent Displays

Improvements have been made to the display quality and performance of transparent objects.

User Interface Location: Click File ▶ Options ▶ Model Display. Click the Enable transparency check box and then select Order Independent in the Transparency box.

Benefits and Description

Use Order Independent to improve the overall display quality and performance of transparent objects and to keep transparency artifacts from appearing.

Ambient Occlusion Is Available

Realism is improved when using ambient occlusion.

User Interface Location: Click File ▶ Options ▶ Model Display and then click the Enable ambient occlusion effect check box.

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

When Display Style is set to Shading With Reflections, there is support for ambient occlusion. Ambient occlusion improves the realism of the display by shading or darkening areas in your model that are occluded by other items in the geometry. This makes the model look more realistic. You can clearly see the effects of ambient occlusion in your model.
Assembly Design (Intelligent Fastener, Assembly)

PTC Creo Intelligent Fastener ........................................................................................................62
PTC Creo Intelligent Fastener (Lite) .................................................................................................62
Update Control for Data Sharing Features ......................................................................................63
Notifications Are Collected and Easily Accessible .........................................................................65
New Option for Controlling External References ..............................................................................66
Status Reporting Is Improved in Assemblies .....................................................................................66
Improvements for Chooser Dialog Boxes .........................................................................................66
Updating in a Session Is Improved .....................................................................................................67
Improvements in Family Tables .........................................................................................................67
Identifying Active Components is Easier ............................................................................................67
PTC Creo Intelligent Fastener

PTC Creo Intelligent Fastener is a new solution for creating fasteners and it requires a separate license. The lite version of PTC Creo Intelligent Fastener is available in PTC Creo Parametric without a separate license.

User Interface Location: Click **Tools ▶▶ Screw**.

Benefits and Description

Watch a [video](#) on PTC University Learning Exchange, demonstrating the enhancement described below.

You can perform the actions listed below using functionality available with Intelligent Fastener:

- **Assemble in all instances**—In some cases you cannot pattern a screw connection because multiple parts need to be drilled. To do so, assemble the desired screw and select the pattern option **Assemble fastener on all instances?**. The holes in the required parts are created.

- **Define screw connection orientation**—If you create a screw connection where one side of the placement surface is not parallel to the other, you may want to align the connection. You can do this by defining an orientation in the **Select References** dialog box. In this case you can also define the square taper washer to even out the angle of offset. Click **Assemble fastener on all instances?** because the washer needs to be rotated on the right I beam.

- **Assemble dowel pins**—Select the location and second the surface that divides the two parts. In the **Definition Dowel Pin Fastener** dialog box you can select different standards and hole definitions.

- **Check existing screw connections**—You can check existing screw connections from the **Check Screw Fasteners** dialog box. For example you can change the thickness of the cover, and then click **Tools ▶▶ Intelligent Fastener ▶▶ Check Screw Fastener** to open the dialog box. Intelligent Fastener automatically detects that the assembled screw is too short. Double-click to go to the definition and correct the screw length.

PTC Creo Intelligent Fastener (Lite)

There is a new solution for assembling standard fixing hardware. The lite version of PTC Creo Intelligent Fastener is available in PTC Creo Parametric without a separate license.

User Interface Location: Click **Tools ▶▶ Screw**.
Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

In the lite version of PTC Creo Intelligent Fastener you can assemble screw connections with ease. To define the position of a screw connection you can choose between a datum point, an axis, or a hole. After defining the Position References, you can define the screw connection using one of the methods described below:

- Select two aligning surfaces to define a screw connection with thread.
- Select two opposing surfaces to define a screw and nut connection.

Next, configure the screw connection from the Screw Fastener Definition dialog box. In the Screw box, you can select from a variety of standard parts predefined in the library of intelligent fasteners. There are several ways of completing the definition:

- Select the diameter or measure the diameter in the model.
- Select the length or set the length automatically. You can also permanently set the length to be automatically calculated.
- Choose between different hole tolerances.
- Define counterbores for either the screw head or nut or for both.

To verify the connection you can see the current definition in the 2D — Preview. You can also preview the current state in the 3D model. Click OK to assemble the screw connection and to create the holes in the required parts. You can also reassemble, redefine, and delete screws. If you reassemble on a patterned reference, your connection is patterned also. Delete, deletes all parts and holes created by the Intelligent Fastener.

Update Control for Data Sharing Features

Update Control functionality helps to make parametric top-down design more manageable and predictable.

User Interface Location: Right-click a data sharing feature and select one of the following:

- Update Control ▶ Automatic Update
- Update Control ▶ Manual Update with Notification
- Update Control ▶ Manual Update
- Update Control ▶ No Dependency
Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

You can use **Update Control** in PTC Creo Parametric to control design changes along with using Design Exploration to first experiment with design changes and then decide if you want to apply them. This process is especially useful when working with advanced top-down design features such as **Copy Geometry** or **Layout Feature**. In complex or sensitive designs a small change can have a major impact. You can use **Update Control** so that you are notified about the changes and then use Design Exploration to preview and investigate before making an update. You can also explore the impact of the update by starting Design Exploration.

Your model may, for example, use a skeleton that drives the geometry of some parts through external **Copy Geometry** features. To avoid unpredictable changes and control the update you can right-click on the external **Copy Geometry** feature, select **Update Control** and then select one of the commands described in the list below:

- **Manual Update with Notification**—Identifies out-of-date features in the Model Tree and the Notification Center
- **Automatic Update**—Automatically updates the feature when the parent reference objects change
- **Manual**—Requires that you manually update the feature when the parent reference objects change
- **No dependency**—Permanently breaks external dependencies.

You may make changes to the skeleton that results in the feature showing an out-of-date notification. You have the choice of keeping the feature out of date, updating it, or investigating the change further to understand the potential impact of making the update, before doing the update. Click **Update Control ▶ Show Differences** to preview changed references in the Graphics window, and to filter the changed and outdated objects. To proceed with the change you can click **Update** on the **Show Differences** tab and propagate those changes to the child-referencing object. This eliminates the requirement that existed in previous PTC Creo Parametric releases to temporarily set the **Copy Geometry** feature to Dependent, and then set it back to Independent for subsequent changes. If you are not sure about the change, then you can try out this update or experiment with other changes without risking work in progress. From the **Show Differences** tab, click **Design Exploration**. Notice that two checkpoints, described below, are created in the **Checkpoint Tree**:
• **Pre-modified**—Contains the original models retrieved at beginning of the PTC Creo Parametric session. You can undo all iterations, including the last one.

• **Entry checkpoint**—Contains the iteration that models are in at the time you open Design Exploration. If you close Design Exploration and do not accept any checkpoint, you return to the PTC Creo Parametric session at the same point you were in before opening Design Exploration.

**Update Control** allows you to better monitor and control design changes and their impact to referencing models. This makes complex and concurrent design projects easier and more streamlined.

### Notifications Are Collected and Easily Accessible

When doing design work, you can see a collection of notifications.

**Benefits and Description**

Watch a [video](#) on PTC University Learning Exchange, demonstrating the enhancement described below.

With the Notification manager you can quickly identify, locate, and fix common modeling issues, or events that require your attention. To easily access the Notification Center, click on the bottom-right of the window to see the total number of issues identified in current model. When you open the Notification Center you see a summary of the different categories of reported issues. You can expand a category or the entire list and sort by type or by object. You can also find the specific node in the Model Tree and immediately address the issue, such as redefining a failed component placement. The Model Tree is enhanced. Issues in collapsed nodes are easily tracked all the way up the tree. Nodes in which there are problems appear in bold font.

From the [PTC Creo Parametric Options](#) dialog box, you can customize the notifications. PDM-related statuses are automatically synced with PTC Windchill when regenerated.

The Notification Center helps you to find and fix design issues easier and faster than before.
New Option for Controlling External References

It is easier to reference assembly objects ad hoc without keeping unwanted dependencies.

User Interface Location: Click File ▶ Options ▶ Update Control ▶ Copied feature references update ▶ No dependency.

Benefits and Description

You can easily break dependency when setting a newly created copied feature to No dependency. Reference control is improved and simplified. If you edit parts in an assembly and want to use assembly references without creating an external dependency, you can set those dependencies to be automatically broken immediately after creation. This eliminates the need for manual workflows and reduces design errors.

Status Reporting Is Improved in Assemblies

The handling of external children with missing parents during regeneration, is improved.

Benefits and Description

Status reporting is improved. The status of the feature versus the parent is much clearer. The statuses of all features, feature parents, feature specific attributes, and feature states are in separate columns. This lets you see the state of the feature without having to open an advanced tool. You can reference a component even if it is in failed status. You can also dismiss this failure by right-clicking the failed component and selecting Fix location. This action disables all constraints including the problematic ones that lead to the failure and adds a fixed constraint. Unfix removes the fixed constraint.

Improvements for Chooser Dialog Boxes

The Chooser dialog boxes for defining simplified representations and for managing envelopes are improved.
Benefits and Description

It is easier to work in the Chooser dialog boxes with the improvements described in the list below:

- You can start to make selections on the Model Tree immediately after the dialog box opens. You no longer need to wait until all the assembly graphics are loaded.
- The graphic preview does not refresh each time you make a selection in the Model Tree. This makes overall performance faster and smoother.

Updating in a Session Is Improved

There are improvements in performance and stability for updating in a session.

User Interface Location: Right-click a part in Model Tree that is in a newer version of PTC Windchill PDM than the part that is in the session, and click **Update**.

Benefits and Description

When working in a linked session with PTC Windchill PDM, the performance for update operations is significantly improved.

Improvements in Family Tables

**Family Table** functionality is improved.

Benefits and Description

There is improved stability for **Family Table** instance accelerators and in the general interaction between family tables and simplified representations.

Identifying Active Components is Easier

It is easier to distinguish active components from inactive components.

User Interface Location: In the Graphics window, right-click a component and select **Activate**.

Benefits and Description

Watch a **video** on PTC University Learning Exchange, demonstrating the enhancement described below.
The quality of the display when working in an assembly with inactive components is improved. When you activate a component in the assembly you can see clearly in the Graphics window what components are active and what components are inactive. This helps you to more effectively understand the context of the part on which you are working. If for example, you change the Display Style from Shading With Edges to Shading With Reflections, the appearance of both the active and inactive components changes.
Advanced Framework Design

Assembling and Measuring is Improved .......................................................... 70
Copying Subassemblies is Easier ................................................................. 70
More Options are Available from Shortcut Menus ....................................... 71
Assembling and Measuring is Improved

You can more easily assemble connector and equipment elements and take measurements when defining a connector or equipment element.

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

The assembly of connector and equipment elements is easier. You can select all required references in one action.

Another improvement is the ability to take measurements when defining a connector or equipment element. There are three methods of measuring:

• Select 2 points or lines to measure the distance. The measurement is inserted into the active input panel automatically and appears in the message area.
• Select a line to measure the curve length.
• Select one cylinder to measure the diameter.

Copying Subassemblies is Easier

It is easier to copy subassemblies.

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

It is easier to copy subassemblies. When you copy a subassembly, the Copy Component Definition dialog box opens. From this dialog box you can type a new name for the assembly, select the components that you want to copy, and type a new name for one or more components. You can also click Automatic Selection to select only required parts and to exclude standard parts such as screws and nuts. To select or remove components in the model window, use the plus or minus buttons. After the definition is complete, the new subassembly can be built in like any other profile. Simply apply joints to adjust the new subassembly.
More Options are Available from Shortcut Menus

You can access many options to perform tasks from shortcut menus.

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

There are many actions you can take by right-clicking and using the shortcut menus. For example, you can modify the section size of a profile or multiple profiles at one time. You can also modify connector or equipment elements. Profiles can be located, moved, copied, replaced, reassembled, and deleted by using options on shortcut menus. This improves efficiency by reducing the number of times you need to open the Profiles dialog box.
## Electrical Design (Cabling, ECAD, Harness Manufacturing)

- Import Conductor Information .............................................................. 74
- Bundle Transitions in Cabling ................................................................ 74
- Improved Support for Cabling in PTC Creo View ........................................ 75
- ECAD Subtype for Assemblies ................................................................. 75
- ECAD Flex Rigid Boards ......................................................................... 76
- Harness Manufacturing ........................................................................... 76
Import Conductor Information

When working in PTC Creo 3.0 M040 and later, you can import conductor information using an EDA file.

User Interface Location: Click **Model ▶ ▶ Conductor Information ▶ ▶ Conductor Explorer**.

**Benefits and Description**

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

You can import conductor information using an EDA file. During the import you can control which conductors to import and on which layer to import the conductors. To select the conductors to import use **Simple Search**, for example, to import only the ground net, or use **Advanced Search** or **Box Select**. With **Box Select**, define an area on the board on which to import the conductor information. You can control how the conductors are imported. For example you can set **Pin Pads** set to **Surfaces**, **Via Pads** to **Entities**, **Routes** to **Surfaces**, and **Planes** to **Quilts**. After the filtering and configuration are set, you can import the conductor information. Then, use the **Conductor Explorer** dialog box to perform actions, such as those included in the list below:

- Review the conductor information.
- Convert the routes from surfaces to quilts.
- Colorize selected conductors to make them easier to find.
- Control whether to view the conductor information by layers or net name.
- With a net selected, zoom to the selected net.

**Bundle Transitions in Cabling**

There is support for bundle transitions in Cabling.

User Interface Location: Click **Cabling ▶ Create Bundle**.

**Benefits and Description**

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.
Bundle transitions are supported in Cabling Design. For example, you may want to create bundle transitions where there is a main path and then several cables exiting to the left. The left area is where the bundle transitions would occur. You can create a bundle with BUNDLE OPTS set to Round and Along Path. Click Centerline and then select a to and from location. From BUNDLE OPTS, select all wires except the Network wire and then accept all defaults. When the bundle is created you can see that where the wires exit, there is now a transition and the bundles get smaller. Transition bundles are controlled by the configuration options listed below:

- `bundle_transition_create_method`—This is set to automatic.
- `cable_bundle_transition_length`—Transition length is controlled by the formula larger diameter multiplied by a percentage. The default percentage is 50.

**Improved Support for Cabling in PTC Creo View**

Support for harnesses in PTC Creo View is improved.

**Benefits and Description**

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

If you save a PTC Creo Parametric assembly as a `.pvz` file and open it in PTC Creo View, the harness is broken out into discrete wires. You can select each wire individually and then press F7 to see the parameters of each individual wire.

**ECAD Subtype for Assemblies**

There is a new assembly subtype for ECAD designs.

**User Interface Location:** Click File ▶ New ▶ Assembly ▶ ECAD.

**Benefits and Description**

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.
With the new **ECAD** subtype, PTC Creo Parametric and PTC Windchill can differentiate between a standard assembly and an ECAD assembly. When you select the **ECAD** subtype, a user interface specific to ECAD is provided so you can efficiently create a board outline. To assemble an electromechanical component, select either the top or bottom of the board and then select the X and Y reference. The electromechanical component can then be dragged into a desired position.

**ECAD Flex Rigid Boards**

There is a new solution for creating Rigid Flex board designs.

User Interface Location: Click **File ▶ New ▶ Assembly ▶ ECAD**.

**Benefits and Description**

Watch a [video](https://www.ptc.com) on PTC University Learning Exchange, demonstrating the enhancement described below.

The new ECAD rigid flex solution provides a dedicated user interface for creating rigid flex boards. To create a flexible area click **Flat**, select an area of the board, and then edit dimensions to define the shape. After defining the shape click **Join** to join the rigid section to the flexible area. Click **Flat Pattern Preview** to preview the board and to check for overlapping sections and disjointed board sections. Click **Flat Pattern Preview** again to close the preview. You can create other ECAD features such as mounting holes and ECAD areas. All the design work is done within the bent state. After defining the board, you can activate the ECAD assembly. Click **Flat Pattern** to see the flat state of the board. You can see that the ECAD area and the hole have moved with the flattened state. Click **Flat Pattern** again to return to the bent state. You can access ECAD collaboration and import the ECAD design changes all within the bent state. Components are assembled to each rigid section of the board. You can then exit ECAD Collaboration and click **Flat Pattern** to preview the flattened state and check the components, the ECAD area, and the ECAD holes in the flattened state.

**Harness Manufacturing**

There is a new out-of-the-box solution for all cabling customers who are on active maintenance.

User Interface Location: Click **Applications ▶ Harness Mfg.**
Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

You can easily create manufacturing documentation for your 3D cable harnesses. Select **Applications ▶ Harness Mfg** to open the **Harness Manufacturing Extension** dialog box. You can use the options in this dialog box to perform the actions described in the list below:

- **Harness**—Select the harness for which you want to create manufacturing documentation.
- **Subharness**—Select the subharness if the selected harness contains subharnesses.
- **Drawing templates**—Click ![Folder](image) and browse to a template or take no action to accept the default template.
- **Bend to fit**—Bends the flattened harness to fit onto the page.
- **Cosmetics**—Select to include cosmetic features or clear the check box so cosmetic features are not included.

The default parameters used in the Bill of Material (BOM) are index, quantity, model name, and description. For the **Model “Description”** parameter, you can map any appropriate property of the 3D part to populate the BOM. When you are satisfied with your settings, click **Flatten Harness**. A fully detailed drawing is generated containing the items described in the list below:

- From-to list
- Fully dimensioned view and reference designation information for each component
- Sheet template that was used
- Pin-out view for each connector
- Three dimensional view of the harness in the context of the 3D Assembly
Manufacturing (NC Manufacturing)

New User Interface for Volume Milling ................................................................. 80
Linking in Roughing Steps Is Enhanced .............................................................. 80
New User Interface for Trajectory Milling .......................................................... 81
Tool Axis Control for Cut Line Milling ............................................................... 82
Multitask Machining ......................................................................................... 83
Tapered Thread Milling ..................................................................................... 84
New User Interface for Volume Milling

The new user interface for Volume Milling is modernized and includes the standard PTC Creo ribbon.

User Interface Location: Click Mill ▶ Roughing ▶ Volume Rough.

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

The Volume Milling user interface is modernized. It is in the Roughing group along with Roughing. Click Mill ▶ Roughing ▶ Volume Rough to see the new Volume Milling user interface and experience the streamlined workflow. In this example, you can select the reference, Mill Window, and copy the parameters of an existing NC sequence to have a toolpath on which you can start working. To get visual feedback and to preview the toolpath as you are defining it, click . From Tool Motions you can access a set of commands to accurately define the entry and exit, or to add a CL command. To edit the cut itself, click Tool Motions, select the cut, and then click Edit to open the Volume Milling Cut dialog box. From this dialog box you can perform actions such as changing the order of the machining of the different regions.

In general when you create a volume milling toolpath, the geometry is scanned, regions are identified, tool trajectories are defined, and approach and exit are applied. In the Volume Milling Cut dialog box click Regions ▶ Show Regions and then click a region number to see the selected region highlighted in the Graphics window. Click the up and down arrows to change the cutting order of the regions. Click Preview ▶ CL Data to see the CL Data of the entire toolpath. Click a line in the CL Data and the corresponding position of the tool appears highlighted in the Graphics window.

Linking in Roughing Steps Is Enhanced

There are two new machining parameters for optimizing linking in Roughing steps.

User Interface Location: Click Mill ▶ Roughing ▶ Volume Rough.

Benefits and Description
Watch video on PTC University Learning Exchange, demonstrating the enhancement described below.

Retracts are commonly seen in Roughing steps such as those created with a constant load scan type in Volume Milling. This is the case in this example, using a window as the reference. In these instances, the tool goes all the way up to the retract plane, for example. To keep the tool on the surface at cutting speed instead of going up the retract, you can set the machining parameter MIN_RETRACT_DISTANCE. For example, if you type a high value for MIN_RETRACT_DISTANCE in comparison to the part itself, the tool stays on the surface as much as possible within in a particular region, instead of going into the retract. The retracts between regions should continue to be applied. This helps to optimize linking by eliminating many of the retracts on volume milling, roughing, and re-roughing sequences.

In other cases, such as when machining hard materials, instead of having the tool stay on the surface, you may want it to go up slightly. These small lifts are over areas that were previously defined to have the tool stay on the surface. For this action set the parameter LIFT_TOOL_CLEARANCE. If you type a small value such as .3, the tool lifts a small distance by going up using an arc or a helix. The tool flies just above the material at rapid feed and reengages the material at cutting speed. These two machining parameters improve efficiency in roughing sequences.

New User Interface for Trajectory Milling

Trajectory-based toolpaths are accessible from a single entry point. You can easily define the toolpath and switch from one toolpath to another. You can define the tool axis on the fly and see the results of the definition in the Graphics window as you work.

User Interface Location: Click Mill ▶ Trajectory Milling.

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

You can create 3, 4, and 5–axis trajectory toolpaths from a single command.

Click Mill ▶ Trajectory Milling to open the Trajectory tab. In Trajectory tab select from the box furthest to the left to select 3, 4, or 5–axis machining. The default is 3–axis machining. For example, you may want to select a ball end mill such as BEM_4 from the tool list and click Tool Motions ▶ Curve Cut to open the Curve Cut dialog box. Select the curve and then from the Curve Cut dialog box set options such as Offset Cut and Side to Machine to get the desired toolpath. Then,
click OK to create the 3–axis trajectory. To change this toolpath from a 3–axis trajectory to a 4–axis trajectory, select 4–axis machining. Notice that the Axis Control tab is highlighted in yellow. This means you need to provide a parameter or a reference and in this case the collector is expecting a plane. Click Axis Control and then select a plane. The plane you select appears in the Axis Control Plane box. Open the PLAY PATH dialog box and play the path. You can see the 4–axis trajectory has been defined using the selected plane. Close the dialog box, click Axis Control again, and click another plane from the part to see how easy it is to control the tool axis. Play the path again to see the new 4–axis trajectory using the plane you selected.

For another example, select 5–axis machining and click Tool Motions ▶ Edit ▶ Axis Control. In the Control Type box select At a Location. When this option is selected, you can create as many axes to control the tool inclination as you like, on the fly. To do so, select points on the curve and then preview the tool and the tool axis. Using the dragger to define the axis, you can define the tilt and lead angle of tool. You can also dynamically see the transition from one axis to the other. Click OK and then play the path again to see the result.

It is easy to define corner conditions using Trajectory Milling. For example, select 3–axis machining and click Tool Motions ▶ Curve Cut. Select a curve, click the Offset Cut check box and select a Side to Machine. From the Curve Cut dialog box under Corner Conditions, select one of the corner types listed below:

- Sharp
- Fillet
- Chamfer
- Loop
- Straight

The values you need to provide are based on the type of corner you select. If you are creating a Loop curve, a positive value for Convex Radius places the loop on one side and a negative value on the other side.

With these enhancements you can create better toolpaths more efficiently.

**Tool Axis Control for Cut Line Milling**

You can define the tool axis on the fly and use the dragger to define the entry and exit points on the outer outline.

User Interface Location: Click Mill ▶ Milling ▶ Cut Line Milling.

**Benefits and Description**
Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

On the user interface, **Cut Line Milling** is separate from **Surface Milling**. In this example having previously created a cutline, select the cut line in the Model Tree and click Mill ▶ Milling ▶ Cut Line Milling. Click **Cut Lines** and select the Auto Cutline check box to automatically create the inner and outer definition of the cut lines. In the **Cut Line Milling** tab, click to preview the results. If what you see is not what you expected, you may want to go to Parameters and make some changes. In the Graphics window, you can preview the results of your changes. Click **Cut Lines** again and select Inner Cutline. In the Graphics window, notice the small dragger that is related to the inner cut line. You can drag the center point that was automatically created to a new position. If you click Outer Cutline another control appears in the Graphics window that you can use to control where the tool engages the material.

When defining a 5–axis cut line, you can control the axis. Click **Axis Control**. The default for a cut line is normal to surface but if you select At a Location you can select different location points with the dragger. In the Graphics window, you control the **Lead Angle** and **Tilt Angle** of the tool. You can define as many tool axes on the fly as required to control the inclination of the tool.

**Multitask Machining**

You can define four heads and two spindles. Each head has its own set of tools. Synchronization is possible between any toolpath.

User Interface Locations:

- Click **Manufacturing ▶ Work Center ▶ Mill-Turn**.
- Click **Turn ▶ Area Turning**.
- Click **Manufacturing ▶ Operations**.
- Click **Manufacturing ▶ Synchronization**.

**Benefits and Description**

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.
NC Manufacturing is rearchitected at the **Work Center**, **Operation**, and NC sequence levels as described in the list below:

- **Work Center**—Click **Manufacturing ▶▶ Work Center ▶▶ Mill-Turn** to open the **Mill-Turn Work Center** dialog box. In this dialog box, **Number of Heads** is expanded to four, **Number of Spindles** to two, and there is one set of tools assigned to each head. Therefore, in the Graphics window you can see the main spindle, sub spindle, and four heads that are configurable.

- **Operations**—Click **Manufacturing ▶▶ Operation**. In the **Operations** tab click **Clearance** to define a **Main spindle retract** and a **Sub spindle retract** which are independent of each other. Click **Home Point** to define a home point for each head. From the **Operations** tab, you can also define the **Main Spindle** and **Sub Spindle** coordinate systems.

- **NC Sequence**—As an example because it works with all NC sequences in the ribbon, click **Turn ▶▶ Area Turning**. From the **Area Turning** tab you can assign the head in which you want to work, select the tool for the head, assign the toolpath to the main or sub spindle, and assign the specific coordinate system.

Also, synchronization functionality is improved. On the Model Tree, preselect the operation that references a machine tool with two or more heads and click **Synchronize**. The selected operation remains highlighted. Alternatively, right-click the operation and select **Synchronize** from the shortcut menu. The **Synchronize** dialog box opens from which you can synchronize steps on different machine tool heads. Notice there is a column for each of the heads. You can select a toolpath from each column and then right-click and select **Synchronize at start** or **Synchronize at a point**. If you **Synchronize at start**, synchronization is ready. If you instead choose **Synchronize at a point**, the **Edit Synchronization** dialog box opens. Each head is assigned a color in the dialog box that matches the color of the toolpath that appears in the Graphics window. You can then select points in the toolpaths to synchronize the toolpaths. Click **Apply** to add the toolpath synchronization. From the **Synchronize** dialog box you can also click **Gantt Chart** to see the synchronization details in a chart format.

You can play the path by using the controls at the bottom of the **Synchronize** dialog box.

### Tapered Thread Milling

You can create tapered thread milling toolpaths such as National Pipe Thread Taper (NPT) and custom types.

**User Interface Location:** Click **Mill ▶▶ Milling ▶▶ Thread Milling**.

**Benefits and Description**
Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

In a part with a **Thread Milling** toolpath, right-click the NC sequence in the Model Tree and select **Edit Definition**. In the **Thread Milling** tab, click \[ \] from the list of thread types, to cut an NPT thread for a standard pipe taper. In this case no other parameter is needed because you are using 1.7899 degrees as the **TAPER_ANGLE**. In the Graphics window you can see the resulting toolpath.

To cut a thread with a user-defined taper angle, click \[ \]. The **Parameters** tab is highlighted because **TAPER_ANGLE** is empty. Type a value for **TAPER_ANGLE** and you can see the results in the Graphics window.
Mold Design and Casting (Mold Design and Casting, PTC Creo Mold Analysis)

PTC Creo Mold Analysis ..................................................................................................................88
Creating a Parting Surface Using Extend Curve .............................................................................88
Creating a Parting Surface Using Fill Loops ..................................................................................88
Draft Analysis Is Improved ...........................................................................................................89
Check for 3–D Thickness .................................................................................................................89
PTC Creo Mold Analysis

You can use PTC Creo Mold Analysis to verify the part design for manufacturing, to avoid molding defects such as an incomplete cavity filling.

User Interface Location: Click **Mold Analysis** from the **Applications** tab on the ribbon.

Benefits and Description

You can perform mold filling analyses directly in PTC Creo Parametric. The results of the analysis appear in the graphics window. You can use the auto-meshing function to prepare the model for analysis in less time.

Creating a Parting Surface Using Extend Curve

You can create a parting surface by extending curve chains.

User Interface Location: Click **Mold ▶ Parting Surface ▶ Extend Curve**. Click **Cast ▶ Extend Curve**.

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

You can create a parting surface more efficiently. The most commonly used extensions are built into this tool. Multiple extension sets are applicable to each parting surface feature. Automated transitions are also supported. Click the **Create Transitions** check box to automatically create transitions.

Creating a Parting Surface Using Fill Loops

You can create a parting surface with a closed curve chain.

User Interface Location: Click **Mold ▶ Parting Surface ▶ Fill Loops**; Click **Cast ▶ Fill Loops**.

Benefits and Description
Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

You can create parting surface with closed loops. If needed, you can fit the surface to a plane or a surface.

**Draft Analysis Is Improved**

Displayed results are more realistic and there is support for three-color plotting.

User Interface Location: Click Analysis ▶ Draft; Click Mold ▶ Draft; Click Cast ▶ Draft.

**Benefits and Description**

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

Results for a draft analysis appear with lighting and surface boundary lines when Display Style is set to Shading. The minimum number for fringe plotting is reduced to three.

**Check for 3–D Thickness**

You can check the wall thickness variant on the model.

User Interface Location: Click Analysis ▶ Thickness; Click Mold ▶ Thickness; Click Cast ▶ Thickness.

**Benefits and Description**

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

You can perform a true 3–D thickness check. For example, you can identify critical areas on a molded part and make changes to avoid molding problems such as short shot and sink mark.
Sheetmetal (Sheetmetal Design)

Flatten Form and Flat Pattern Are Enhanced ................................................................. 92
Die Form User Interface Is Improved ........................................................................ 92
Improvements to Bend Reliefs ................................................................................. 93
Rip Connect and Sketched Rip Tools Are Enhanced ............................................. 93
Bending Coplanar Surfaces in a Single Feature ......................................................... 94
Flatten Form and Flat Pattern Are Enhanced

The Flatten Form and Flat Pattern tools are enhanced.

User Interface Location: Open a sheetmetal part and click Model ▶ Form ▶ Flatten Form or Model ▶ Flat Pattern.

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

Flatten Form and Flat Pattern tools can accommodate wall geometry that is added to the form geometry. For example, in a model with many form features, a couple of these forms may have some of the geometry cut away and additional walls may have been added to the forms. Flatten Form supports these forms with additional wall geometry. When the forms are flattened, the contours are projected to the flat plane. If you are looking for a different result, you can first unbend the additional walls that are attached to the form geometry and then flatten the forms. The Flat Pattern feature is enhanced to optionally unbend the additional wall geometry first before flattening the form geometry. This is controlled by clicking the Unbend form geometry check box in Flat Pattern ▶ Options.

Die Form User Interface Is Improved

The Die Form workflow is modernized and consistent with the Punch Form tool.

User Interface Location: Open a sheetmetal part and click Model ▶ Form ▶ Die Form.

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

Like the Punch Form tool, the Die Form tool can, depending on the reference model, be created as a dependent merge or as an independent inheritance with options to vary the form. In addition to assembly constraints, you can quickly place the die form reference part as an on-surface coordinate system or by using component interfaces. By default, if the reference model has a coordinate-system component interface configured, you can select the surface and two offset references to place the form as an on-surface coordinate system. You can modify
the die shape surfaces which are automatically found even if you have not defined them in the form model, and choose the die model surfaces to exclude. You can also design the reference model to support multiple thicknesses of sheet metal because you can add the rounds in the feature instead of in the reference model. You can also place the die form using component interfaces. To do so, switch the placement type to component interfaces and place the form coincident with the already-located coordinate system. You can create a point pattern which references a sketch of coordinate systems. Look at the reference model used to create these forms. Notice the coordinate system component interface which enables the form to be placed as an on-surface coordinate system or by component interfaces. Notice also the sheet metal Annotation Feature which you can use to define the die surfaces and the excluded surfaces of the reference model.

Improvements to Bend Reliefs

The handling of bend reliefs in the Bend tool is improved.

User Interface Location: Open a sheetmetal part and click Model ▶ Bend ▶ Relief.

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

Bend reliefs are automatically placed at the ends of the bend line and as needed along the line. This means you can quickly and easily bend a portion of an existing wall into a tab. The default type of relief is [Rip]. When you trim the ends of the bend line, the rip reliefs are automatically placed at the ends of the bend line. Whatever relief you specify in the Relief dialog box, is automatically placed. For example, you can change the relief to Obrround or change one side relief to No relief. If No relief is selected, the bend relief is extended to the edge of the part. The Bend tool is enhanced to create bend reliefs as needed along the bend line so you can create designs more quickly and with fewer features. You can specify a relief definition that extends beyond the bend line and those bend reliefs are automatically placed at each side of the bend tabs. Previously this process required creating multiple features.

Rip Connect and Sketched Rip Tools Are Enhanced

There is more flexibility when creating sheet metal designs.

User Interface Location: Open a sheetmetal part and click Model ▶ Rip ▶ Rip Connect or Model ▶ Rip ▶ Sketched Rip.
Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

You can use **Sketched Rip** and **Rip Connect** to create a zero-width rip connection between two different contours on the same surface. You no longer need to split the surface into two distinct pieces. For example, you can easily turn the material between two cuts into a bent tab.

**Bending Coplanar Surfaces in a Single Feature**

You can use the **Bend** tool to bend multiple coplanar surfaces in a single feature.

User Interface Location: Click **Model ▶ Bend**.

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

If you sketch a line on coplanar but discontinuous surfaces, you can create a bend on these surfaces. For example, you can create a similar bend on surfaces on the bottom of the troughs. In this case, you can use a straight edge as a bend reference and offset it from the part edge. You can then specify the length of the bend line by dragging it out so the correct geometry is bent and then preview the geometry before it is bent. Flipping the bend in the other direction to get the bend you are looking for, may be necessary. To flatten this kind of geometry, unbend it in two stages. First, unbend the bends on the coplanar surfaces, then unbend the trough geometry.
PTC Creo Simulate

New User Interface for Results in PTC Creo Simulate .................................................. 96
PTC Creo Unite Technology — Working in a Multi-CAD Environment ........................ 97
Automatic Conversion Using PTC Creo Unite Technology ........................................... 98
Creating Profiles Using PTC Creo 3.0 Unite Technology ................................................ 99
Solid Edge Import .............................................................................................................. 99
Support for Mapkeys .......................................................................................................... 100
Support for Unicode in PTC Creo Simulate ..................................................................... 101
Performance Improvements in PTC Creo Simulate .......................................................... 101
Support for ANSYS 14.5 in PTC Creo Simulate ............................................................... 102
Support for MSC Nastran 2012 in PTC Creo Simulate ...................................................... 102
Performance Tuning for Solver Engine I/O Is Improved ..................................................... 102
Icons are Updated ............................................................................................................. 103
Changing Entity Colors ................................................................................................. 104
Usability Improvements to Fasteners with Defined Preloads ........................................ 104
Improvements to FEM Mode ............................................................................................ 105
Weighted Links in 2D Analysis ....................................................................................... 106
Simple Fracture Mechanics Is Added ............................................................................. 107
Improved Process to Determine the Best Analysis ......................................................... 107
New Workflow for Creating Notes .................................................................................. 109
Analysis Studies are Listed in the Model Tree ................................................................. 110
Improved Workflow for Interrogating Results ................................................................. 111
Defining Contact Interfaces with Finite Friction .............................................................. 112
Mapped Mesh Option for 2D Models .............................................................................. 113
Display of Shells, Beams, and Fasteners is Improved .................................................... 114
Analyze Models with Failed Features ........................................................................... 115
Updated Process for Creating Linearized Stresses ......................................................... 116
Fatigue Analysis with Multiple Load Sets ...................................................................... 117
New User Interface for Results in PTC Creo Simulate

The new user interface for showing results in PTC Creo Simulate includes the standard PTC Creo ribbon.

User Interface Location: In PTC Creo Simulate, click **Home ▶ Simulate Results**. In PTC Creo Parametric click **Home ▶ Utilities ▶ Simulate Results**.

Benefits and Description

Watch a [video](#) on PTC University Learning Exchange, demonstrating the enhancement described below.

There is a new modern interface for displaying results in PTC Creo Simulate that you can access from PTC Creo Simulate or PTC Creo Parametric. The logically organized interface with commonly used tasks, sorted into application-specific ribbon tabs and groups, makes it easy to use and for new users, easier to learn. In addition to the ribbon interface, there are other improvements that are described in the list below:

- **Search for commands**—Use **Command Search** to search for and see the location of commands. Click ![Command Search](#) and start to type a command in the **Command Search** box. As you type, a list of commands that match your search criteria appear. Place the pointer on a command in the list to see the command highlighted in the ribbon.

- **Commands are consolidated and added**—New commands are added and other commands are consolidated to improve efficiency.
  - With the displacement magnitude fringe window selected, click **View ▶ Continuous Tone** to set the tone changes to continuous. You no longer need to edit that specific results window to define tone change from within the **Result Window Definition** dialog box.
  - Under **View** the **Capping & Cutting Surfs** group is added—Functionality is consolidated to a group where you can create, edit or delete a capping or cutting surface.

- **Manage the window view**—There are new ways to manage the window. Click **Cascade** to cascade views. Click **Hide** to hide a view.

- **Manage the Graphics window**—As you could previously, you can open multiple docked windows at the same time. Although only one docked window can be active at a time, you can double-click a different window to
easily activate it. The active window has a blue border and the Graphics toolbar appears within it. This toolbar provides access to common commands such as Refit, Repaint, Zoom In, Zoom Out and Named Views.

• Additional commands available from shortcut menus—You can right-click in the active window to select commands such as Model Max, New Cutting/Capping Surface, or Full Screen. This makes it easier and faster to perform tasks.

Regardless of whether you are a new or advanced user, the new modern interface for results in PTC Creo Simulate improves your ability to inspect your analysis, validate your design, or identify areas in your model that need improvement.

PTC Creo Unite Technology — Working in a Multi-CAD Environment

There are multiple enhancements in the area of multi-CAD design.

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

With PTC Creo Unite technology it is no longer necessary to install additional third-party software or licenses to work with non-PTC Creo data. CAD consolidation is easier than ever. CATIA, SolidWorks, and NX files can simply be opened and referenced in PTC Creo. Format-specific profiles and templates help to load non–PTC Creo data as easy as native PTC Creo data. Once defined, these profiles automatically control what information gets into session without additional dialog boxes or user interaction. You can start to work with non-PTC Creo assemblies immediately. PTC Creo automatically tracks changes made to the non-PTC Creo data in their native systems, and keeps the data up to date. It is also easy to distinguish the different formats in the Model Tree by their individual icons and file extensions.

In addition to new capabilities of updating and exporting SolidWorks data, PTC Creo 3.0 provides the ability to import Solid Edge parts and assemblies. During the import process of Solid Edge data, you can decide what information you want to import or can use the standard template for non-PTC Creo data. Imported geometry can easily be referenced using all available assembly constraints. PTC Creo 3.0 provides support for all major CAD formats to integrate, develop, and validate complete product designs. See article CS188705 for information about the current limitations of PTC Creo Unite technology working with PTC Creo View and PTC Windchill PDMLink 10.2.
Whether your goal is to improve collaboration between multiple formats or consolidate to a single CAD tool, with PTC Creo Unite technology it is easier than ever to work in a multi-CAD design environment.

**Automatic Conversion Using PTC Creo Unite Technology**

With PTC Creo Unite technology it is no longer necessary to install additional third-party software or licenses to work with non-PTC Creo data. CAD consolidation is easier than ever.

**Benefits and Description**

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

CATIA, SolidWorks, and NX files can simply be opened and referenced in PTC Creo. It is easy to distinguish the different formats in the Model Tree by their individual icons and native file extensions.

PTC Creo 3.0 has enhanced functionality to modify designs in context. If you try to modify non-PTC Creo data in the context of a multi-CAD assembly, a message appears confirming that these changes will not be reflected in the native model. You can then select **Convert** or **Do not convert**. If you select **Convert** you can choose to automatically convert the non-PTC Creo data to PTC Creo data or to use advanced conversion tools. When you choose an automatic conversion, only the components that are required for the modification are converted into PTC Creo components. This ensures maximum reuse of existing non-PTC Creo files and prevents the overhead of managing multiple file formats and business objects for each component.

After converting the necessary components, PTC Creo can still maintain a link to the original non-PTC Creo files to retrieve updates based on changes made outside of PTC Creo. You also have the option to keep the newly created PTC Creo components separate from the original source files.

PTC Creo 3.0 provides support for all major CAD formats to integrate, develop and validate complete product designs. Whether your goal is to improve collaboration between multiple formats or consolidate to a single CAD tool, with PTC Creo Unite technology it is easier than ever to work in a multi-CAD design environment.
Creating Profiles Using PTC Creo 3.0 Unite Technology

There are multiple enhancements in the area of multi-CAD design. With PTC Creo Unite it is no longer necessary to install third-party software or licenses to work with non-PTC Creo data.

User Interface Location: Click File ▶ Options to open the options dialog box for your application and then click Data Exchange.

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

CATIA, SolidWorks, and NX files can simply be opened and referenced in PTC Creo. Format-specific profiles and templates help to load non–PTC Creo data as easy as native PTC Creo data.

Opening and importing options and format-specific profiles are controlled by selecting Data Exchange in the options dialog box for your PTC Creo application. With the help of the Import Profile Editor, you can create and modify profiles. Once defined, these profiles automatically control what information gets into session without additional dialog boxes or user interaction. You can start to work with non-PTC Creo assemblies immediately.

PTC Creo 3.0 provides support for all major CAD formats to integrate, develop, and validate complete product designs. Whether your goal is to improve collaboration between multiple formats or consolidate to a single CAD tool, with PTC Creo Unite technology it is easier than ever to work in a multi-CAD design environment.

Solid Edge Import

You can import and then work with Solid Edge data.

User Interface Location: Click File ▶ Open and then set the Type filter to Solid Edge. Click Import.

Benefits and Description

With the Solid Edge converter, you can import Solid Edge parts and assemblies. There is no need to install Solid Edge software to work with Solid Edge data.
Support for Mapkeys

You can create and execute mapkey commands directly within PTC Creo Simulate.

User Interface Location: Click File ▶️ Options ▶️ Environment ▶️ Mapkeys Settings.

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

For frequently used command sequences, mapkeys can help you to be more productive. A Mapkey is a keyboard macro that maps frequently used keyboard sequences to a certain keyboard key or to sets of keys. You can open the Mapkeys dialog box in the two ways described below:

- Click File ▶️ Options ▶️ Environment ▶️ Mapkeys Settings.
- Click and type mapkey in the search box. Place the pointer on mapkey in the search list.

Mapkeys map frequently used commands to one or more keyboard keys. To start, click New in the Mapkeys dialog box and then in the Key sequence box, define a key sequence such as ME. When you press ME after you define the mapkey, a sequence of operations is executed. In the Name box, type a name for the sequence such as Mesh, to indicate this key sequence is for creating a mesh. In the Description box, provide additional details. Next, record the sequence of operations. Click Record to start recording your keystrokes.

For this example, click Refine Model ▶️ AutoGEM and then click Create to create the mesh and to see the results in the Graphics window. When you finish reviewing the results you can close the results windows or you can first pause the macro and then add the closing of the windows to the macro. Click Pause in the Record Mapkey dialog box. The Resume Prompt dialog box opens. In this dialog box add some information describing the next step such as When finished, click Resume to proceed. Click OK in the Resume Prompt dialog box. Then, click Close to close all the dialog boxes that are open. In the AutoGEM dialog box prompt, click No so the mesh is not saved. Click Stop and OK. The sequence of operations you just performed is captured in the mapkey. The Mapkeys dialog box opens. Click Save all to save the macro you created to your config.pro file for future use. To execute the macro press ME and the mesh results appear immediately. The macro pauses so that you can review the results. Click Resume as prompted and the operation is completed. You can use this mapkey to perform the same action on any model or assembly. You see the elements created for the part or assembly, review them, and exit. In addition you
can add mapkeys as an icon in a group or tab in the ribbon. Mapkeys are optional, however, they improve productivity by streamlining the execution of commands that are frequently used.

Support for Unicode in PTC Creo Simulate

There is support for Unicode. This makes it easier to understand and analyze models containing text in more than one language.

Benefits and Description

Unicode is now supported in PTC Creo Simulate as it has been supported in PTC Creo Parametric. All text strings appear correctly, regardless of their language even when the locale is set to a different language. As a result, sharing models is easier because text strings are legible. Any new text string is maintained and legible in all other locales. For most names, text strings must be 32 characters or less and for most descriptions, 260 characters or less. Characters can be single byte or multibyte. There is Unicode support for object names, descriptions, and other text strings that are stored inside files and appear in the user interface. Process guide templates, results window definition, and template files are not supported.

Performance Improvements in PTC Creo Simulate

A number of enhancements are implemented to improve the overall performance. These changes help solve various analyses faster so you can spend less time waiting for the analysis to converge on a solution.

Benefits and Description

Performance is improved in a number of areas including those described in the list below:

• **Thin Solid**—The existing **Thin Solid** AutoGEM option makes it easier to mesh thin regions with wedge and brick elements. **Thin Solid** is enhanced to minimize the p-level of the element edges that are perpendicular to the top and bottom surfaces. The p-level defaults to a maximum of p=3. This enhancement reduces the complexity of the solution to be solved and shortens the time to converge on a solution.

• Dynamic Analysis—You can already quickly calculate the stresses in dynamic analyses, based on the superposition of modal stresses that are calculated in the associated modal analysis. The calculation of stresses in dynamic analyses is further improved by calculating the superposition of modal displacement for
displacement, velocity, or acceleration results in dynamic analyses. To take advantage of this enhancement, ensure that the **Rotations** check box in the **Output** tab of the **Modal Analysis Definition** dialog box is selected. This makes it easier to perform dynamic analyses and faster to gather results.

- **Modal Analysis Improvements**—In modal analysis you can output the modal participation factors and effective masses, to help determine whether additional modes are needed to accurately capture the response for the dynamic analysis. While these factors vary with applied loads, it is assumed that these factors are computed for translations along the WCS X, Y, and Z directions and for rotations about the WCS origin in the X, Y, and Z directions. To take advantage of this enhancement, click the **Mass Participation Factors** check box in the **Output** tab of the **Modal Analysis Definition** dialog box. This improves your ability to perform a more accurate dynamic analysis.

**Support for ANSYS 14.5 in PTC Creo Simulate**

There is support for the latest release of ANSYS.

**Benefits and Description**

There is support for ANSYS 14.5. As a result you can run your FEM analysis with the latest ANSYS solver.

**Support for MSC Nastran 2012 in PTC Creo Simulate**

There is support for the latest release of MSC Nastran.

**Benefits and Description**

There is support for MSC Nastran 2012. As a result, you can run your FEM analysis with the latest MSC Nastran solver.

**Performance Tuning for Solver Engine I/O Is Improved**

The solver engine is tuned to improve the I/O buffering to make better use of the large cache of modern hard drives.
Benefits and Description
When running an analysis, the process of transferring data between memory and disk (Disk I/O), especially during the solver engine postprocessing step, can be time consuming. When using older hard drives, these results files appear to be written in small blocks at a time. For larger models with large results files, this is inefficient and time consuming. The solver engine I/O performance is improved and tuned for modern magnetic hard disks. These hard disks typically have larger onboard cache and solid state disk drives. As a result of this tuning, processing time is faster when creating results files.

Icons are Updated
New icons help to provide a clearer understanding of the functionality.

Benefits and Description

- New icons in the Model Tree under Analyses display the following analyses types found in the model:
  - Static
  - Modal
  - Buckling
  - Prestress Static
  - Prestress Modal
  - Dynamic Time
  - Dynamic Frequency
  - Dynamic Shock
  - Dynamic Random
  - Steady State Thermal
  - Transient Thermal

These new icons are also used to define analyses in the Analyses and Design Studies dialog box:

- —Icon for the new Hard Surface type of mesh control.
- —Icon for the new Crack type of idealization.
Changing Entity Colors

You can easily change the colors for entities and use these colors in future sessions.

User Interface Location: Click File ▶ Options ▶ System Colors and then make a selection under Simulation Entity Colors.

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

You can change the colors of the PTC Creo Simulate entities. Entities are grouped into the types listed below:

- **Modeling Entity**
- **Load and Constraint**
- **AutoGEM and FEM Mesh**
- **Miscellaneous**
- **Simulate Results**

Under **Modeling Entity**, for example, you can change the colors for Shell, Beam, Mass, Crack, Weld, and so on.

In this example, if you mesh an object, you will see the colors representing the solid mesh elements in the Graphics window. Click File ▶ Options ▶ System Colors and then under **AutoGEM and FEM Mesh**, you can see the colors that currently represent Wedge Element and Brick Element. If you change these colors in the PTC Creo Simulate Options dialog box, the colors in the model change immediately. To keep the new colors and to see these colors in future sessions, click OK. You can customize your environment based on your preferences.

Usability Improvements to Fasteners with Defined Preloads

Fasteners with preloads to automatically scale the preload force applied to a deformed structure to be equal to the specified preload force.

User Interface Location: Click Refine Model ▶ Fastener and then in the Fastener Definition dialog box, select Account for Stiffness.
**Benefits and Description**

You may want to apply a preload to a fastener which simulates the degree to which a bolt or a screw is tightened and then compresses the components. This is controlled by the preload force which defines the tensile force in the fastener. The tensile force results from tightening the bolt or screw.

When a fastener is applied with a preload, the preload force defines the load that the fastener applies on the undeformed geometry of the model. As the model deforms, the compressive force of the fastener on the structure relaxes, causing the actual preload force applied to become smaller than the specified value defined in the **Fastener Definition** dialog box. If you want to specify the preload force which will be exerted on the deformed geometry, you must scale the specified value to account for the force decrease. This is performed by running an initial analysis to determine the decreased preload force, scaling the specified preload force to account for the decreased force, and running the final analysis.

You can continue to follow this process or automate it by selecting **Account for Stiffness** in addition to selecting **Include Preload** in the **Fastener Definition** dialog box. As a result, the two analyses described below are performed:

- The initial analysis determines all the scaling factors required for each fastener with defined preloads and scales the forces exerted on the deformed geometry to meet the defined preload force value. The preload force value is specified in the **Fastener Definition** dialog box.
- A second analysis automatically accounts for the scaled force values and provides the final results. You can then view the initial forces and the scaled forces in the status report for the study. In the results window only the measure values from the final analysis are available.

**Improvements to FEM Mode**

Functionality is added to FEM mode to make it more like Native mode.

**User Interface Locations:** When in FEM mode use any of the paths in the list below:

- **Click** Home ▶ Force/Moment. In the **Force/Moment Load** dialog box click Advanced and then in the Spatial Variation box, select Interpolated Over Entity.
- **Click** Home ▶ Mesh ▶ Settings. In the **FEM Mesh Settings** dialog box, click the Create Solid-Shell Links check box.
- **Click** Home ▶ Force/Moment. In the **Force/Moment Load** dialog box click Advanced and then in the Distribution box, select Total Load at Point.
Benefits and Description

The enhancements listed below are added to help close the functional gap between FEM Mode and Native Mode:

- **Interpolated Load Variation**—You can interpolate loads in FEM Mode to vary the defined load linearly, quadratically, or cubically along a selected entity. Interpolated loads in FEM mode apply to the items listed below:
  - *Force/Moment* for surface and edge
  - Pressure
  - Heat for surface and edge
  - Prescribed temperature for surface and edge
- **Solid-Shell Links**—Depending on the model, the mesh created in FEM Mode automatically creates solid-shell links for all solid-shell interfaces where there is a bond connection and the nodes are merged. This is controlled through a new **FEM Mesh Settings** option which is active by default. To achieve a realistic solid-shell interface, an automatic mesh control is applied along the affected edges to create element sizes close to half the shell thickness on both sides of the edges. The shell and solid elements are connected by weighted links.
- **Total Load at Point**—You can apply a force or moment load and control the distribution as **Total Load at Point** in FEM Mode. This is available under **Distribution** when you click **Advanced** in the **Force/Moment Load** dialog box. This option applies a distributed load on a curve or surface that is statically equivalent to a load applied to a single point.

Weighted Links in 2D Analysis

Support for weighted links is extended to 2D plane stress, plain strain, and axisymmetric models.

User Interface Location: To select a 2D mode of operation click **Home ▶ Model Setup** and then select **2D Plane Stress (Thin Plate)**, **2D Plane Strain (Infinitely Thick)**, or **2D Axisymmetric**. To create a weighted link click **Refine Model ▶ Weighted Link**.

Benefits and Description

Following the same process for applying weighted links for 3D models, you can apply weighted links to any type of 2D model. With this extended functionality you can apply the mass or load from a single-source dependent point and distribute it to a collection of targeted geometric entities which are independent references within the 2D model type. These geometric entities can be a combination of points, edges, and surfaces. As is the case with weighted links for 3D models, you control the translational degrees of freedom in the X and Y axes in 2D models.
Simple Fracture Mechanics Is Added

You can create simple fracture mechanics to determine if initial cracks in your model will grow under specified loading conditions.

User Interface Location: Click Refine Model ▶ Crack.

Benefits and Description

A new Crack idealization is available in both Structure and Thermal modes. This new idealization requires a license for PTC Creo Advanced Simulation Extension. With the new Crack idealization, you can select curve references for 2D models and individual surfaces for 3D models. When running AutoGEM, these references are treated as hard curves and hard surfaces.

Simulate checks are introduced to evaluate if there is a crack that cuts through the entire model. If so, a warning appears in the Diagnostics dialog box for the analysis.

The measure type, Stress Intensity Factor, is available in the Measure Definition dialog box. When selected, you can choose from one of the measure components listed below:

- **Mode I (Opening)** for 2D models
- **Mode II (Sliding)** for 2D models
- **Mode III (Tearing)** for 3D models

For Stress Intensity Factor you can select two spatial evaluation references, a crack and a point on the boundary of the crack. Using Crack idealization, you can easily perform simple fracture mechanics simulations on your models and determine if an initial crack could result in a failed design.

Improved Process to Determine the Best Analysis

It is easier to determine which type of analysis to run.

Benefits and Description

Watch a [video](#) on PTC University Learning Exchange, demonstrating the enhancement described below.

The solver is enhanced to help you decide what kind of analysis is best to run for your model. In this example the part is constrained based on the four holes in the component and there is an applied force load depicting a downward force of 100
newtons. A material is defined and assigned to the component. It is this material and its defined properties that the solver uses to determine if the analysis you choose is accurate for the given component.

Before beginning, in the Model Tree, right-click the material that is assigned and select Edit Definition. In the Material Assignment dialog box, you see that the material is thermoplastic. Click More next to Material. In the Material Definition box you can see under Failure Criterion that the failed criterion is set as Distortion Energy (von Mises). For this failure criterion you need to enter the defined Tensile Yield Stress for this material. It is this information that the solver uses to determine if the stress results in the material exceed the yield stress for the material that is assigned. To start, run a static analysis with a small deformation. Click Analyses and Studies to open the Analyses and Design Studies dialog box. Click New ▶ File ▶ Static Analysis. In the Name box type a name such as Static_sd for a small deformation. Select Single-Pass Adaptive as the convergence method and click OK and then run the analysis from the Analyses and Design Studies dialog box. After the analysis is complete the diagnostics appear.

Review the warning messages in the diagnostics window. In this case, the following warning appears: The strains are large during this analysis, which may lead to inaccurate results. You should consider using the Calculate Large Deformations option, if applicable. This helps you to determine if you chose the correct analysis. In this case the correct analysis was not run, based on the conditions of the model such as the constraints, the load, and the material assigned. The following warning also appears: The yield condition has been exceeded for the material(s) listed below. You should consider using an elasto-plastic material, if applicable. This helps you to determine if you chose the correct material, based on the analysis that you are trying to perform.

Based on the information you received, you can update these scenarios to resolve the problems brought to your attention from the warning messages. First, in the Model Tree, right-click the material and in the Material Assignment dialog box, click More, next to Material. In the Materials box select an elasto-plastic material such as steel.mtl. Click the arrow button to move the selected material to the Materials in Model list. In the Materials in Model list select STEEL and then click OK. In the Material Assignment dialog box Material changes to STEEL. Click OK and then click Analyses and Studies to run an analysis. In this case click File ▶ New Static and in the Static Analysis Definition dialog box type a name for the analysis such as Static_LDA. Click the Calculate large deformations and Plasticity check boxes. Select the Single-Pass Adaptive method and OK and then from the Analyses and Design Studies dialog box run the analysis. After running the second analysis the two previous warning messages received during the static analysis with small deformation no longer appear in the diagnostics. This gives you confidence that this analysis with the defined elasto-plastic material has not exceeded the yield conditions based on the failure criterion. In addition, since you
have set the calculations of large deformations, you know that the material has not exceeded the yield stress for the material assigned. You can have confidence that results displayed are accurate.

Whether you are a designer, a design engineer, or an analyst, the easy-to-use interface and robust solver helps you to obtain high-quality results.

**New Workflow for Creating Notes**

The workflow for creating notes is similar to the workflow in PTC Creo Parametric.

User Interface Location: Click **Tools** and then select a type of note from the **Notes** group.

**Benefits and Description**

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

You can continue to create a part, assembly, or feature note by right-clicking the item in the Model Tree and selecting **Create a Note**. You can also create notes from the ribbon. Click **Tools** and then in the **Notes** group you can select from the types of notes listed below:

- **Unattached Note**
- **Tangent Leader Note**
- **Leader Note**
- **On Item Note**
- **Normal Leader Note**

You enter the content of any note from the **Note** dialog box. In this dialog box you create the note and define information about the model or feature, without defining its placement. In this example, right-click the assembly and select **Create a Note** > **Assembly**. In the text area of the **Note** dialog box, you may want to provide the name of the actual component. You can click **Insert** to insert text **From File** or **From Note** and you can click **Symbols** to select from text symbols to include in your note. After you define your note click **OK**. **Annotations** appears in the Model Tree. If you expand **Annotations** you can see the note that you created. The note is unattached and does not appear in the Graphics window. To change the display, placement, or other attributes of the note, right-click the note, select **Note Type**, and then select **On Item**, **Leader**, **Normal Leader**, or **Tangent Leader**. You can also right-click the note and select to **Delete**, **Rename**, or get the model **Information** pertaining to the selected note. You can repeat this operation to create a note on a particular part. For example, select the first component in the assembly, right-click
and select Create a Note ▶ Part. The Note dialog box opens. You can for example, type the name of the material. Click OK and you can see the second annotation appears under Annotations in the Model Tree. It is grayed out and unattached. Right-click the note and select Note Type ▶ Leader. In the Graphics window, use the pointer to define the placement of the note associated to the component. For example, you can select an edge and then drag the pointer to preview placement of the note relative to the edge. Middle-click to place the note. This enhancement makes it easy to create notes and keep them in the model without cluttering the display of the model. You can capture important information at the assembly or the component level without being forced to place the note in the Graphics window.

Analysis Studies are Listed in the Model Tree

Saved analyses are listed in the Model Tree.

User Interface Location: In the Model Tree, under Analyses.

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

You can view and access saved analyses studies from the Model Tree. When you save an analysis, you can see that analysis at the bottom of the Model Tree under Analyses. If you expand Analyses, you can see the analysis listed with an icon representing the analysis type. Previously you accessed analyses through the Analyses and Design Studies dialog box. With this enhancement you can quickly interrogate, copy, and edit existing studies all from the Model Tree. If you right-click an analysis, you can Edit Definition, Copy, Delete, Rename, or get additional Information such as Simulation Entity. For example, you can create a New Fatigue analysis. It is important to give the analysis a unique and meaningful name. This is the name you see in the Model Tree. After you name the analysis and click OK, you can see it listed in the Model Tree. Run the analysis and save the model. The analyses remain in the Model Tree and are available when you open the model later. This enhancement is available in both Structure and Thermal modes. In the next example, a model is open in Thermal Mode and has a Thermal analysis. Note how that the analysis is listed in the Model Tree. Depending on whether you are running in Thermal Mode or in Structure Mode, you may want to see both analyses in the Model Tree. In the Model Tree under Settings, click Tree Filters. In the Model Tree Items dialog box, click Simulate and then click the Thermal entities in Structure and Structure entities in Thermal check boxes. You then see the
analyses from both modes when you are in **Structure Mode** or **Thermal Mode**. You can view all the analyses types without switching between modes or opening a dialog box.

**Improved Workflow for Interrogating Results**

In the results windows there is a new object-action workflow. You can select common commands directly within the Graphics window and interrogate the results in the results window.

User Interface Location: Click **Home ▶ Simulate Results**.

**Benefits and Description**

Watch a [video](#) on PTC University Learning Exchange, demonstrating the enhancement described below.

The results windows are enhanced to support the object-action workflow for many common operations. Previously you had to first select the tool from the ribbon. Now you can right-click to access these tools or you can select objects directly in the Graphics window. For example, you can edit the legend directly in the Graphics window. If you select $117.736$ in the legend, you can immediately enter a new value. Type $100$ and you are prompted with the question, **Do you want to redistribute levels linearly from first to last?** If you click **Yes** the legend updates and the corresponding fringe plot is updated on the model. In addition if you right-click on the legend the following commands are available for selection:

- **Continuous Tone**
- **Show View Min Max**
- **Scale Between Min Max**
- **Reset**
- **Invert Color Scale**
- **Hide**

Alternatively, you can click **Format** and then select **Edit** from the **Legend** group. When you have the pointer in the Graphics window you can right-click to access the commands listed below:

- **Dynamic Query**
- **Model Max**
- **View Max**
- **Edit**
For example, right-click in the Graphics window and select Model Max. The Model Max is immediately displayed in the Graphics window. You also can perform the same actions by using commands in the ribbon. If you need to edit the Result Window Definition, you can double-click in the Graphics window to open the Result Window Definition dialog box instead of clicking Edit in the ribbon. Notice the two lists that are available in the top left of the Graphics window. You can use these lists to select the different quantity types for the model results. When you make changes to your selections in these lists, the updates appear immediately in the Graphics window. This makes interrogating your model easier. You no longer need to edit the display in the Result Window Definition dialog box. These enhancements improve the usability of the Results window so that you can efficiently inspect your analysis, validate your design, and identify areas in your model that may need improvement.

Defining Contact Interfaces with Finite Friction

You can define contact interfaces with finite friction. As a result, you can determine if sliding has occurred between components and the tangential force load transferred across each interface.

User Interface Location: Click Refine Model ▶ Interface.

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

You can perform a large deformation contact analysis with finite friction in both 2D and 3D models. In this example you go through the process of defining a contact interface on an assembly. Click Refine Model ▶ Interface to open the Interface Definition dialog box. In the Type box select Contact and in the Reference
box select **Surface-Surface**. After making a selection in the Graphics window you can select the **Properties** of the interface. In the **Friction** box you can select from the types of friction described in the list below:

- **None**—Defines a frictionless contact interface so that the components can freely slip relative to each other.
- **Infinite**—Defines a contact interface where the two components cannot slip relative to each other.
- **Finite**—You define a static coefficient of friction in addition to a dynamic coefficient of friction between the two references.

For this example, select **Finite**. You can now define the **Static Coefficient of Friction**, as 0.15. You can also define the **Dynamic Coefficient of Friction** or for this example, click the **Same as static** check box. After applying finite friction to the contact interface, you can determine if sliding has occurred during a contact analysis. You can also determine how much sliding has occurred at each interface by using the new measure for tangential force, from which you can determine the tangential force load transferred for each of these interfaces. A user-defined measure, **Reaction_Y** is also defined. This represents the overall force required to push and snap this component into place.

Click **Home ▶▶ Analyses and Studies** to start the analysis process. In the **Analyses and Design Studies** dialog box, click **File ▶▶ New Static** and in the **Static Analysis Definition** dialog box, type a name for the analysis. Click the **Nonlinear / use load histories, Calculate large deformations** check boxes. Because contacts are represented with interfaces in the model, the **Contacts** check box is automatically selected. On the **Convergence** tab, click the **Press fit (initial interpenetration)** check box for the defined analysis. On the **Output** tab, under **Output Steps**, select **User-defined Output Steps**. In the **Number of Master Steps** box type 11 and then click **Space Equally** and **OK**. In the **Analyses and Design Studies** dialog box, run the analysis and display the study status. Review the report as you run the analysis. When the report is complete, scroll up to see when the slippage first occurred. In this example it occurred after step 7. You can now review the results. There are three results windows. On the left there is a graph for **Reaction_Y**. **Reaction_Y** is a user-defined measure created to represent the force required to snap the component into place. On the right you can see the tangential force across **Interface2**. In the middle there is an animation of the overall stress applied to the assembly as the components are snapping into place.

With this enhancement you can determine how much sliding occurs at each interface and the tangential force load that is being transferred for the interface.

**Mapped Mesh Option for 2D Models**

You can use the control option **Mapped Mesh** for 2D models.

User Interface Location: Click **Refine Model ▶▶ Control ▶▶ Mapped Mesh**.
Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

Click Refine Model ▶ Control ▶ Mapped Mesh. The Mapped Mesh option is helpful for the conditions listed below:

- If you have 2D models with contact interfaces where the accuracy of the calculated pressure is dependent on the refinement of the mesh in the contact area
- When performing a large deformation analysis
- On models with elasto-plastic material

In this example there is a 2D assembly of a shock absorber shim stack. This shim stack controls the flow of dampening oil within the shock absorber. During the compression or rebound stroke, the increased pressure of the shim stack deforms, allowing the oil to flow. In this example, you want to determine the total deformation of the stack and then tune the shims by changing the thickness, diameter, or the number of shims. The given interfaces between the shims are already defined and the given pressure load is applied. Click Refine Model ▶ AutoGEM to review the mesh. You can see that the resulting mesh is automatically generated. Since this analysis will be run with large deformation calculations enabled, you should try to refine the mesh at the given contact regions. Click Control ▶ Mapped Mesh to open the Mapped Mesh Control dialog box. Next select the geometry. The first area in which to map the mesh is the top shim. As you select from the surface geometry it automatically creates a quad mapped mesh in that region. You can see QUAD1 appears under Meshing Regions. Notice that this is a default three by three mesh. In the Default box, you can control the density of the mesh, or under Edge Sets you can select a given edge and subdivide that mesh along that reference. Note that only the Quad and Tri shapes are available under Region Shape.

Create another region to complete the operation. Click AutoGEM to create the mesh again. Where the mapped mesh regions were defined, the mesh is more refined. Now, when you run the analysis, the run time is shorter.

Display of Shells, Beams, and Fasteners is Improved

Shells, beams, and fasteners can be displayed as Wireframe, Shaded, or Transparent.

User Interface Location: Click the Simulation Display icon—.
Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

In this example, there is a model of an aircraft wing built using surface geometry. To analyze this, you need to create shell elements. Click Refine Model ▶ Shell to open the Shell Definition dialog box. In the Graphics window, select specific geometry. As you make your selections you can see the Surfaces listed in the dialog box. Define the thickness and click OK. The shell is created and is displayed as a solid. Click to open the Simulation Display dialog box. On the Settings tab in the Shells box, you can choose from Outline, Wireframe, Shaded, or Transparent. Select Transparent and then click OK. The shell updates and appears as transparent. If you select the shell, you see notes that indicate the thickness of the shell including its units at a specific location.

In the next example, you see the display enhancement for beams. In the Graphics window is a sketch feature that represents a frame structure. Click Refine Model ▶ Beam to open the Beam Definition dialog box. For references, select the curve and add it to the collector. For the Beam Section use the predefined Beam 1 and click OK. You can see the beam on the model as a shaded object. Click to open the Simulation Display dialog box. On the Settings tab in the Beam box, select Transparent, and click OK. The beam updates, and appears as transparent.

In the next example, first place a fastener in the model. Click Refine Model ▶ Fastener to open the Fastener Definition dialog box. Next, select references. Based on the reference selected, the Diameter box is automatically populated. Choose your material and define the Fastener Head and Nut Diameter. Click OK and the fastener is created and is displayed as solid. You can change the display of the fastener from the Simulation Display dialog box.

This enhancement helps you to better visualize the shape, size, and location of shells, beams, and fasteners in your model.

Analyze Models with Failed Features

You can analyze a model with a failed feature.

Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.
With this enhancement, models containing failed features can be opened in PTC Creo Simulate and analyzed. It is a good practice to resolve failed features in a model. In some cases, however, in the process of simplifying the model for analysis, features may be impacted due to child and parent relationships. In this case, moving a feature may result in the failure of other features.

In this example there is a model containing a number of failed features. You can still open this model in PTC Creo Simulate. After opening the model you receive a warning about the failure of the model to regenerate and information about what analyses types can be run for the model. The failed features are listed in the Model Tree but you can still define many of the traditional PTC Creo Simulate features such as forces, displacements, idealizations, connections, surface or volume regions and so on. The only limitation is when running an analysis or design study. In the Analyses and Design Studies dialog box, click File. You can see that New Sensitivity Design Study and New Optimization Design Study are not available.

This enhancement lets you continue analyzing your data, even with failed features.

**Updated Process for Creating Linearized Stresses**

You can easily create linearized stress plots for your model.

User Interface Location: In the Results Window, click Linearized Stress.

**Benefits and Description**

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

In this example there is a simple pipe assembly. To generate the linearized stress you need to run a static analysis. In this example, a static analysis has been run for a pipe. Previously, to view the linearized stress results you would open the Result Window Definition dialog box, then select Model in the Display Type box, and Linearized Stress on the Quantity tab. The process has changed. Now, in the Display Style box select Fringe and on the Quantity tab select Stress. You can then set Display Options and click OK and Show. In the Graphics window you can see the von Mises stress in your model. In the ribbon click Linearized Stress to open the Linearized Stress Report dialog box. From this dialog box it is easy to select points to display the linearized stress. Click the arrow next to Point 1 and then select a point on the model. In the Points Selection dialog box, click OK. For the Point 2 select On Opposite Surface and you can see the results in the Graphics.
window. The detail of the linearized stress looks at the nodal data for the complex stress pattern found along the line and breaks it down into the following components:

- **Membrane**—Overall average stress
- **Bending**—The difference in stress from the inside point to the outside point
- **Mem+Bend**—The sum of the Membrane and Bending numbers
- **Peak**—The highest stress found along the line

If you zoom into the model you can see the Point 1 and Point 2 and the resulting data that is represented in the graph. From the Component box, you can choose a component such as von Mises and the graph and corresponding numbers update. This information defines what the stress will be along that line between those two points. Click Done.

With this improved workflow you can quickly determine the linearized stress across critical areas of your data.

### Fatigue Analysis with Multiple Load Sets

You can perform a fatigue analysis with multiple load sets.

**User Interface Location:** In the Analyses and Design Studies dialog box click File ▶ New Fatigue.

#### Benefits and Description

Watch a video on PTC University Learning Exchange, demonstrating the enhancement described below.

Depending on the type of load being applied, you may prefer to group these loads separately rather than put them into a single load set. In addition you may want to analyze certain loads but not others.

In this example, you are working with a gearbox component. In the Model Tree you can see three loads. As is the case with any fatigue analysis, you need to define a material that has a fatigue criteria set. Right-click Material Assignment1 and select Edit Definition to open the Material Assignment dialog box to see what material is assigned. Click More to open the Material dialog box. Under Materials in Model select the material. In this example select GRAY\_CAST\_IRON and click OK to open the Material Definition dialog box. In the Fatigue area of this dialog box define a Unified Material Law (UML). In the Material Type box Other, is added to the list of materials. In the Surface Finish box, the list of finishes is updated. When working with a model from an earlier release, a conversion is required. If this is the case, a warning appears indicating that some of the surface finishes defined in the model are no longer supported. You are
prompted to provide the **Failure Strength Reduction Factor** to take these finishes into account. After the materials are defined and applied click **OK** to close multiple dialog boxes.

The first analysis you need to run is the static analysis. Click **Analyses and Studies** to open the **Analyses and Design Studies** dialog box. For this example, you can see that the analysis, Gearbox, is completed. Click **File ▶ New Fatigue** to run a fatigue analysis. In the **Fatigue Analysis Definition** dialog box there are some changes. The **Previous Analysis** tab is first, followed by the **Load History** tab. On the **Previous Analysis** tab, you can see that the load sets from the model are listed. For this example, select the three load sets and click the **Load History** tab where you define the **Desired Endurance**. For this example, **Desired Endurance** is set to 2e+5. Next, define the load criteria for each load set. In the **Load Set** box, select the load. Select an **Amplitude Type** such as **Zero-Peak**. Complete this operation for each of the load sets in the model. Click **OK** and then from the **Analyses and Design Studies** dialog box, run the analysis. After the analysis is completed, you can view the results. In this example you review the fatigue fringe plot for **Log Life**. In the **Results** window you can see that most of the model has a **Log Life** of 20. This means ten to the power of twenty cycles will pass before the crack initiates. You can review the model and see areas that have a lower defined **Log Life**. To get a better perspective, you can select in the legend and type a value such as 15. This redistributes the levels from first to last so that you can get a better idea of where there are potential issues in the model.

This enhancement improves your ability to analyze a model with multiple loads and to determine the life expectancy of your design.