Getting Started with Creo® Parametric TOOLKIT 3.0
Datecode M110
Copyright © 2016 PTC Inc. and/or Its Subsidiary Companies. All Rights Reserved.

User and training guides and related documentation from PTC Inc. and its subsidiary companies (collectively "PTC") are subject to the copyright laws of the United States and other countries and are provided under a license agreement that restricts copying, disclosure, and use of such documentation. PTC hereby grants to the licensed software user the right to make copies in printed form of this documentation if provided on software media, but only for internal/personal use and in accordance with the license agreement under which the applicable software is licensed. Any copy made shall include the PTC copyright notice and any other proprietary notice provided by PTC. Training materials may not be copied without the express written consent of PTC. This documentation may not be disclosed, transferred, modified, or reduced to any form, including electronic media, or transmitted or made publicly available by any means without the prior written consent of PTC and no authorization is granted to make copies for such purposes. Information described herein is furnished for general information only, is subject to change without notice, and should not be construed as a warranty or commitment by PTC. PTC assumes no responsibility or liability for any errors or inaccuracies that may appear in this document.

The software described in this document is provided under written license agreement, contains valuable trade secrets and proprietary information, and is protected by the copyright laws of the United States and other countries. It may not be copied or distributed in any form or medium, disclosed to third parties, or used in any manner not provided for in the software licenses agreement except with written prior approval from PTC.

UNAUTHORIZED USE OF SOFTWARE OR ITS DOCUMENTATION CAN RESULT IN CIVIL DAMAGES AND CRIMINAL PROSECUTION.

PTC regards software piracy as the crime it is, and we view offenders accordingly. We do not tolerate the piracy of PTC software products, and we pursue (both civilly and criminally) those who do so using all legal means available, including public and private surveillance resources. As part of these efforts, PTC uses data monitoring and scouring technologies to obtain and transmit data on users of illegal copies of our software. This data collection is not performed on users of legally licensed software from PTC and its authorized distributors. If you are using an illegal copy of our software and do not consent to the collection and transmission of such data (including to the United States), cease using the illegal version, and contact PTC to obtain a legally licensed copy.

Important Copyright, Trademark, Patent, and Licensing Information: See the About Box, or copyright notice, of your PTC software.

UNITED STATES GOVERNMENT RIGHTS

PTC software products and software documentation are “commercial items” as that term is defined at 48 C.F. R. 2.101. Pursuant to Federal Acquisition Regulation (FAR) 12.212 (a)-(b) (Computer Software) (MAY 2014) for civilian agencies or the Defense Federal Acquisition Regulation Supplement (DFARS) at 227.7202-1(a) (Policy) and 227.7202-3 (a) (Rights in commercial computer software or commercial computer software documentation) (FEB 2014) for the Department of Defense, PTC software products and software documentation are provided to the U.S. Government under the PTC commercial license agreement. Use, duplication or disclosure by the U.S. Government is subject solely to the terms and conditions set forth in the applicable PTC software license agreement.

PTC Inc., 140 Kendrick Street, Needham, MA 02494 USA
## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>7</td>
</tr>
<tr>
<td>Creo Parametric TOOLKIT Concepts</td>
<td>9</td>
</tr>
<tr>
<td>What Can You Do with Creo Parametric TOOLKIT?</td>
<td>10</td>
</tr>
<tr>
<td>Communication Modes for Creo Parametric TOOLKIT</td>
<td>10</td>
</tr>
<tr>
<td>Installing and Testing the Creo Parametric TOOLKIT Development Environment</td>
<td>11</td>
</tr>
<tr>
<td>Installing Creo Parametric TOOLKIT</td>
<td>12</td>
</tr>
<tr>
<td>Setting Up the Development Environment</td>
<td>12</td>
</tr>
<tr>
<td>Testing the Creo Parametric TOOLKIT Installation</td>
<td>13</td>
</tr>
<tr>
<td>Using the Creo Parametric TOOLKIT Documentation</td>
<td>21</td>
</tr>
<tr>
<td>Using the Creo Parametric TOOLKIT APIWizard</td>
<td>22</td>
</tr>
<tr>
<td>Viewing the PDF Version of the User's Guide</td>
<td>23</td>
</tr>
<tr>
<td>Using the Release Notes</td>
<td>23</td>
</tr>
<tr>
<td>Using Extended Resources</td>
<td>25</td>
</tr>
<tr>
<td>Locating Example Code</td>
<td>26</td>
</tr>
<tr>
<td>Using the User's Guide</td>
<td>27</td>
</tr>
<tr>
<td>Contacting PTC Technical Support</td>
<td>27</td>
</tr>
<tr>
<td>Joining the PTC/USER Community</td>
<td>27</td>
</tr>
<tr>
<td>Index</td>
<td>29</td>
</tr>
</tbody>
</table>
Introduction

*Getting Started with Creo Parametric TOOLKIT* introduces the techniques and practices of developing applications with Creo Parametric TOOLKIT for Creo Parametric. This guide outlines the installation procedure for Creo Parametric TOOLKIT and helps you locate the Creo Parametric TOOLKIT functions and documentation. Familiarity with the basics of Creo Parametric TOOLKIT will help you understand and create advanced applications.

The following table lists conventions and terms used throughout this book.

<table>
<thead>
<tr>
<th>Convention</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>UPPERCASE</td>
<td>Creo Parametric-type menu name (for example, PART).</td>
</tr>
<tr>
<td><strong>Boldface</strong></td>
<td>Windows-type menu name or menu or dialog box option (for example, <strong>View</strong>), or utility (for example, <code>promonitor</code>). Function names also appear in boldface font.</td>
</tr>
<tr>
<td><em>Emphasis</em></td>
<td>Important information appears in italics. Italic font also indicates file names and function arguments.</td>
</tr>
<tr>
<td>Choose</td>
<td>Highlight a menu option by placing the arrow cursor on the option and pressing the left mouse button.</td>
</tr>
<tr>
<td>Select</td>
<td>A synonym for “choose” as above, Select also describes the actions of selecting elements on a model and checking boxes.</td>
</tr>
<tr>
<td>Element</td>
<td>An element describes redefinable characteristics of a feature in a model.</td>
</tr>
<tr>
<td>Mode</td>
<td>An environment in Creo Parametric in which you can perform a group of closely related functions (Drawing, for example).</td>
</tr>
<tr>
<td>Model</td>
<td>An assembly, part, drawing, format, notebook, case study, sketch, and so on.</td>
</tr>
</tbody>
</table>
### Convention Description

<table>
<thead>
<tr>
<th>Convention</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Option</td>
<td>An item in a menu or an entry in a configuration file or a setup file.</td>
</tr>
<tr>
<td>Solid</td>
<td>A part or an assembly.</td>
</tr>
<tr>
<td>&lt;creo_loadpoint&gt;</td>
<td>The location where the Creo applications are installed, for example, C:\Program Files\PTC\Creo 1.0.</td>
</tr>
<tr>
<td>&lt;creo_toolkit_loadpoint&gt;</td>
<td>The location where the Creo Parametric TOOLKIT application is installed, that is, &lt;creo_loadpoint&gt;&lt;datecode&gt;\Common Files\protoolkit.</td>
</tr>
</tbody>
</table>

### Intended Audience

This guide is for programmers experienced with C/C++ programming prior to working with Creo Parametric TOOLKIT. The experience of the programmer should include:

- Training in fundamentals of Pro/ENGINEER Wildfire 4.0 or later, or equivalent
- Good experience with using Creo Parametric in the areas being customized
- C/C++ experience with knowledge of pointers, data structures, and dynamic memory management
- Use of Microsoft Visual Studio

In addition, you must have the Creo Parametric TOOLKIT development license to develop, build, and test applications.

### Scope and Purpose

This guide is not a complete summary of Creo Parametric TOOLKIT techniques. It directs you through the process of building and testing a simple Creo Parametric TOOLKIT application. It introduces the basic concepts of Creo Parametric TOOLKIT to new users. It also provides pointers to resources that enhance your knowledge about Creo Parametric TOOLKIT.

The guide focuses only on running a Creo Parametric TOOLKIT DLL application in an interactive session of Creo Parametric. It does not cover any other application configuration.

### Comments

PTC welcomes your suggestions and comments on its documentation. You can send comments to the following e-mail address: MCAD-documentation@ptc.com.

Please include the name of the application and its release number with your comments. For online books, provide the book title.
Creo Parametric TOOLKIT
Concepts

What Can You Do with Creo Parametric TOOLKIT? ......................................................... 10
Communication Modes for Creo Parametric TOOLKIT .............................................. 10

Creo Parametric TOOLKIT is the customization toolkit for Creo Parametric. Customers and partners can expand the capabilities of Creo Parametric by writing C or C++ programming language code using Creo Parametric TOOLKIT and then seamlessly integrating the resulting application into Creo Parametric. PTC provides new releases of Creo Parametric TOOLKIT concurrently with releases of Creo Parametric.

Creo Parametric TOOLKIT uses an object-oriented design. A library of C functions provides safe and controlled access to the Creo Parametric database and applications. Many data structures for transfer of information between Creo Parametric and the application are not directly visible to the application. Contents of these data structures are accessible only with Creo Parametric TOOLKIT functions. The sections in this chapter describe the capabilities and modes of communication of Creo Parametric TOOLKIT.
What Can You Do with Creo Parametric TOOLKIT?

With Creo Parametric TOOLKIT you can:

- Automate modeling for derived or single-use models driven by geometric or parametric constraints
- Monitor the state of the user's interactive session to enforce company rules or offer design advice
- Integrate external applications requiring access to Creo Parametric data or operations
- Extend the Creo Parametric user interface with custom processes seamlessly embedded into the interface
- Automate tedious or difficult Creo Parametric operations with applications designed to save design time and prevent mistakes.
- Create processes to run automatically without a user interface on demand or at designated times.

Communication Modes for Creo Parametric TOOLKIT

Creo Parametric TOOLKIT supports synchronous applications that are invoked from commands within a session of Creo Parametric. Modes of communication for synchronous applications may be:

- **DLL mode**—A dynamically-linked library (DLL) is loaded by the Creo Parametric executable at runtime. Communication between the DLL and Creo Parametric is as fast as possible and hence the DLL mode is the preferred mode for application development.

- **Spawn (multiprocess) mode**—A separate executable is spawned by Creo Parametric. Spawn-mode applications interact with Creo Parametric through interprocess communications and hence are slower than the DLL mode. This mode is typically used as a part of asynchronous mode applications, where the external application starts or connects to external sessions of Creo Parametric as needed.

Another mode available is asynchronous mode applications, where the external application starts or connects to external sessions of Creo Parametric as needed.
Installing and Testing the Creo Parametric TOOLKIT Development Environment

Installing Creo Parametric TOOLKIT ................................................................. 12
Setting Up the Development Environment ..................................................... 12
Testing the Creo Parametric TOOLKIT Installation ........................................ 13

This chapter discusses the process to install Creo Parametric TOOLKIT and to test the development environment. The test application and other sample code described in this guide assume the use of a Windows environment.
Installing Creo Parametric TOOLKIT

Creo Parametric TOOLKIT is on the Creo Parametric DVD-ROM. When you install Creo Parametric, select **API Toolkits** to install Creo Parametric TOOLKIT.

An installation of Creo Parametric TOOLKIT contains directories under the Creo Parametric load point.

<table>
<thead>
<tr>
<th>Directory</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>protoolkit</td>
<td>Top-level directory</td>
</tr>
<tr>
<td>protoolkit/includes</td>
<td>Include files</td>
</tr>
<tr>
<td>protoolkit/&lt;machine_type&gt;/obj</td>
<td>Library files and sample makefiles</td>
</tr>
<tr>
<td>protoolkit/protk_apps</td>
<td>Sample application source and message files</td>
</tr>
</tbody>
</table>

Setting Up the Development Environment

Before you build your first Creo Parametric TOOLKIT application, set up the supported compilers, sample make files, and the appropriate licensing for your application development environment.
Platform and Compiler Support

Creo Parametric TOOLKIT runs on the same platforms as Creo Parametric. The Platform Support notes at [http://www.ptc.com/partners/hardware/current/support.htm](http://www.ptc.com/partners/hardware/current/support.htm) describes the compilers supported by PTC.

Licensing for Creo Parametric TOOLKIT

Creo Parametric TOOLKIT requires a license for developing and testing applications. To check if you have the Creo Parametric TOOLKIT license option, run the Ptcstatus utility from the Creo Parametric load point. Check for the license option TOOLKIT. You can check the license option in Creo Parametric user interface. Click File ➤ Help ➤ System Information. In the INFORMATION WINDOW, under Configured Option Modules check for the license option TOOLKIT. In case the license is not available please contact your system administrator.

When you first build an application using Creo Parametric TOOLKIT, the application is considered "locked." The application requires the Creo Parametric TOOLKIT development license when you test it in Creo Parametric. Loading a locked application into a session of Creo Parametric that lacks the Creo Parametric TOOLKIT license causes an error as the application starts.

Before you distribute an executable for a Creo Parametric TOOLKIT application to your end user, you must unlock it. Unlocking allows the end user to run the application without having the Creo Parametric TOOLKIT license. The unlocking process is initiated with the following command:

<creo_loadpoint>/<datecode>/Parametric/bin/protk_unlock <filename>

In the previous command, filename is the full path to the Creo Parametric TOOLKIT application.

Testing the Creo Parametric TOOLKIT Installation

After you have installed Creo Parametric TOOLKIT, compile, link, and run a simple Creo Parametric TOOLKIT application on each computer for development use. This process provides an independent test of the following items:
• The installation of Creo Parametric TOOLKIT is present, complete, and visible.
• The version of Creo Parametric has the Creo Parametric TOOLKIT license option added to it.
• All the necessary C development tools, especially the C compiler and linker, are present in versions supported by Creo Parametric TOOLKIT.

Makefiles
PTC provides sample makefiles for each platform. These makefiles:
• Document the compiler and linker flags to be used for each platform
• Serve as templates for structuring your own application makefiles
Refer to these makefiles when creating a new application. Update the flags in your application makefiles when moving to a new release of Creo Parametric.

Using the Microsoft Visual Studio Solution
PTC provides a ready-to-use Visual Studio solution on the Windows platform to create and test Creo Parametric TOOLKIT applications by using a makefile or by setting up the Visual Studio development environment. For the version of Visual Studio compatible with the release of Creo Parametric TOOLKIT, refer to the hardware notes at http://www.ptc.com/partners/hardware/current/support.htm.

This ready-to-use Visual Studio solution has the following advantages:
• Provides an effective way to build and test sample applications provided by PTC.
• Provides a pre-configured Visual Studio development environment for use with Creo Parametric TOOLKIT.
• Supports Intellisense for Creo Parametric TOOLKIT functions.

Note
The supported version of Visual Studio changes with every release of Creo Parametric TOOLKIT, and hence the compiler flags and libraries also change. For every release, you must download the latest version of the ready-to-use solution from the Creo Parametric TOOLKIT load point.

When you install Creo Parametric TOOLKIT, the file protk_install_example.zip is installed under the <creo_toolkit_loadpoint> at <machine_type>/obj. To use this solution:
1. Unzip `protk_install_example.zip`. The following directories and files are available:

<table>
<thead>
<tr>
<th>Directory or File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>make_install</code></td>
<td>Contains the makefile project and the <code>protk.dat</code> file.</td>
</tr>
<tr>
<td><code>make_install.sln</code></td>
<td>Specifies the ready-to-use Visual Studio solution file.</td>
</tr>
</tbody>
</table>

2. Open Microsoft Visual Studio.
3. Click **File ▶ Open ▶ Project/Solution**. The **Open Project** dialog opens.
4. Browse the `protk_install_example` directory and select `make_install.sln`.
5. Click **Open** to access the solution file. The `make_install` makefile project is available in Visual Studio.

**Running the Makefile Project**

1. Click **Build ▶ Build make_install**. The application should build without errors. This creates the Creo Parametric TOOLKIT DLL file called `pt_inst_test.dll`. If the application fails, check that the environment variable `PROTOOL_SRC` is set correctly.
2. Unlock the application, using the following command:
   `<creo_loadpoint>/<datecode>/Parametric/bin/protk_unlock.bat <path to executables or DLLs to unlock>`
3. Run Creo Parametric from the `make_install` directory that contains the `protk.dat` file. The Creo Parametric TOOLKIT application adds the command **Install Test** under the **File ▶ Tools** menu in the **TOOLKIT** group in the **Home** tab on the Creo Parametric ribbon user interface.

**Note**

Refer to the Creo Parametric Help for more information on customizing the Ribbon.

4. Click **Tools** and then click **File ▶ Install Test**. The **Install Test Results** message window opens, indicating that the installation test has succeeded.
5. Click OK.

To run other sample applications provided by PTC, follow these steps:

1. Copy the required makefile from `<creo_toolkit_loadpoint>/machine_type/obj` to the `make_install` directory of the ready-to-use Visual Studio solution.
   
   If you are working on a 64-bit Windows platform, copy the file from `<creo_toolkit_loadpoint>/x86e_win64/obj`.

2. Copy the text directory associated with the sample application from `<creo_toolkit_loadpoint>/protk_appls/app_name/text` to the `make_install` directory.

3. Open Visual Studio and set the values of the following variables in the makefile:
   
   ```
   PROTOOL_SRC = ../../../protoolkit
   PROTOOL_SYS = $(PROTOOL_SRC)/$(PRO_MACHINE_TYPE)
   ```

4. Click `Project ▶ Properties` to update the NMake properties of the project.

5. Click `Build ▶ Rebuild make_install`. The application builds and creates a new .dll file.

6. Update the `protk.dat` file located in the `make_install` directory with the name of the sample application and the DLL file.

7. Modify the `exec_file` and `text_dir` fields in the `protk.dat` file to specify the full path to the .dll file and \text directory, respectively.

8. Start Creo Parametric.


10. Click Register to register the updated `protk.dat` file. The Register auxiliary application dialog box opens.
11. Browse to the full path and select `protk.dat`.
12. Click **Open**. The Creo Parametric TOOLKIT application runs.

**Creating Your Own Microsoft Visual Studio Project**

The Creo Parametric TOOLKIT load point includes the source of a simple application called `pt_install_test` designed specifically to help you test the installation. The steps to build and run the test application follow.

1. Open Microsoft Visual Studio.
2. Create a project named `ProTOOLKITInstall` in an empty directory. Set this project to be a makefile project.

3. Set the **Debug Configuration Settings** to run the Creo Parametric makefile as shown in the following table and figure:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Command line</td>
<td><code>nmake /f make_install dll</code></td>
</tr>
<tr>
<td>Output</td>
<td><code>pt_inst_test.dll</code></td>
</tr>
<tr>
<td>Clean all commands</td>
<td><code>del pt_inst_test.*</code></td>
</tr>
<tr>
<td>Rebuild all commands</td>
<td><code>nmake /f make_install dll</code></td>
</tr>
<tr>
<td>Include search path</td>
<td><code>&lt;creo_loadpoint&gt;\&lt;datecode&gt;\Common Files\protoolkit\includes</code></td>
</tr>
</tbody>
</table>
4. Set the **Release Configuration Settings** to the same settings as the **Debug Configuration Settings**. Click **Finish**.

5. Copy the file `make_install` from `<creo_toolkit_loadpoint>/ <machine>/obj` to your project directory, that is, the directory `ProTOOLKITInstall` that also contains `ProTOOLKITInstall.vcproj`. If you are working on a 64-bit Windows platform, copy the file from `<creo_toolkit_loadpoint>/x86e_win64/obj`.

6. Click **Project ▶ Add Existing Item** to add the makefile to the project. In the **Add Existing Item** window, view all files and select the file `make_install`.

7. Edit the setting for **PROTOOL_SRC (EXTERNAL USE - DEFAULT)** in `make_install` to point to the Creo Parametric TOOLKIT installation directory, that is, `< creo_loadpoint>/ <datecode>/Common Files/protoolkit`.

---

**Note**

If the Creo Parametric load point is in a directory containing spaces, use the DOS short names.
8. On the Windows 64–bit platform select the platform as follows, else go to the next step:
   a. Click Build ▶ Configuration Manager.
   c. Type x64 as the platform and click OK.
9. Click Build ▶ Rebuild Solution.
   The application should build without errors. This creates the Creo Parametric TOOLKIT DLL file called pt_inst_test.dll. If it fails, check that the path to the Creo Parametric TOOLKIT installation directory is set correctly in the makefile in step 7.
10. In the install_test directory, create a text file called protk.dat. This registry file provides Creo Parametric information about the Creo Parametric TOOLKIT application. The protk.dat file should contain the following lines:
    ```
    name install_test
    startup_dll
    exec_file pt_inst_test.dll
    text_dir <creo_toolkit_loadpoint>/protk_appls/pt_install_test
    end
    ```
11. Run Creo Parametric from the directory that contains the protk.dat file. The Creo Parametric TOOLKIT application adds the command Install Test under the File ▶ Tools menu in the TOOLKIT group in the Home tab on the Creo Parametric ribbon user interface.
    If you encounter an error, or if the Creo Parametric TOOLKIT command does not appear in the Creo Parametric TOOLKIT group, verify if the Creo Parametric version that you ran has the Creo Parametric TOOLKIT license included.
12. Click Tools and then click File ▶ Install Test. The Creo Parametric TOOLKIT Install Test Results message window opens, indicating that the installation test has succeeded.
The previous chapters assisted you with the setup of the Creo Parametric TOOLKIT development environment. You will learn how to effectively use the documentation and extended resources in this chapter. PTC includes the following documentation with Creo Parametric TOOLKIT:

- Creo Parametric TOOLKIT APIWizard—An online document with cross-links between the user’s guide, function descriptions, and sample applications.
- Creo Parametric TOOLKIT Release Notes—A printable document that provides release-specific information for Creo Parametric TOOLKIT.
Using the Creo Parametric TOOLKIT APIWizard

The Creo Parametric TOOLKIT APIWizard is installed in the directory <creo_toolkit_loadpoint>/protkdoc. Start the APIWizard by pointing your browser to the index.html file. The Creo Parametric TOOLKIT APIWizard starts. With the APIWizard, you can browse documentation for objects, functions, and the Creo Parametric TOOLKIT User's Guide. The following sections describe how to display and use the APIWizard frames in your Web browser.

Using the Selection Frame

The selection frame on the left of the Creo Parametric TOOLKIT APIWizard, controls what data appears in the display frame on the right. Specify the data to view by choosing Creo Parametric TOOLKIT Categories, or Creo Parametric TOOLKIT Objects, or Creo Parametric TOOLKIT User's Guide menu items.

- **Categories**—Displays an alphabetical list of the Creo Parametric TOOLKIT function categories. Creo Parametric TOOLKIT objects and functions are displayed as subnodes of the categories.

- **Objects**—Displays an alphabetical list of the Creo Parametric TOOLKIT objects. Creo Parametric TOOLKIT functions are displayed as subnodes of the objects.

- **User's Guide**—Displays the Creo Parametric TOOLKIT User's Guide table of contents in a tree structure. All chapters are displayed as subnodes of the guide.

Use the Find button in the left selection frame to search for data from the Creo Parametric TOOLKIT User's Guide or for API specifications from the header files.

Using the Display Frame

The display frame on the right of the Creo Parametric TOOLKIT APIWizard displays the following items:

- User's guide contents
- Object and object hierarchy descriptions
- Function descriptions
- Header files
- Code examples for functions
Viewing the PDF Version of the User's Guide


Using the Release Notes

*Creo Parametric TOOLKIT Release Notes* provides release-specific information for Creo Parametric TOOLKIT. It describes new functions of Creo Parametric TOOLKIT and also includes critical functions that require adjustment of existing code. It also lists the changes in Creo Parametric that can affect behavior in Creo Parametric TOOLKIT. The release notes is installed at `<creo_toolkit_loadpoint>`. Use Acrobat Reader to open the file `Creo_Toolkit_RelNotes.pdf`.
Using Extended Resources

Locating Example Code .................................................................................................................. 26
Using the User's Guide .................................................................................................................. 27
Contacting PTC Technical Support .............................................................................................. 27
Joining the PTC/USER Community ................................................................................................. 27

This chapter provides the resources for support in working with Creo Parametric TOOLKIT for the following areas:

• Example code provided
• Tips for optimum use of the Creo Parametric TOOLKIT User's Guide
• Technical Support
• PTC User Community

As you become more familiar with these resources, you'll find that they overlap in areas of expertise. A PTC online account is required to access PTC documentation from the Web. Register for an account at https://www.ptc.com/appserver/common/account/basic.jsp.
Locating Example Code

PTC provides many sample applications with Creo Parametric TOOLKIT in directories under the path `protoolkit/protk_appls`. This section describes some of the sample applications. You can refer to the APIWizard and the `protoolkit/protk_appls` directory for other sample applications.

**pt_userguide**

<table>
<thead>
<tr>
<th>Location</th>
<th>Makefile</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>protoolkit/protk_appls/pt_userguide</code></td>
<td><code>make_userguide</code></td>
</tr>
</tbody>
</table>

Consolidates examples that access the user interface. All these examples are also referred to in the *Creo Parametric TOOLKIT User's Guide*.

**pt_examples**

<table>
<thead>
<tr>
<th>Location</th>
<th>Makefile</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>protoolkit/protk_appls/pt_examples</code></td>
<td><code>make_examples</code></td>
</tr>
</tbody>
</table>

It consists of examples of Creo Parametric TOOLKIT applications. It provides a user interface to access many areas of Creo Parametric TOOLKIT. This application covers Creo Parametric TOOLKIT functions and modules. The directory `pt_examples` includes subdirectories containing utility functions.

**pt_async**

<table>
<thead>
<tr>
<th>Location</th>
<th>Makefile</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>protoolkit/protk_appls/pt_async</code></td>
<td><code>make_async</code></td>
</tr>
</tbody>
</table>

Provides an example application for simple and full asynchronous mode.

Other Sample Applications

The following table lists all the sample applications available with the Creo Parametric TOOLKIT installation. Please refer to the *Creo Parametric TOOLKIT User’s Guide* for more information.

<table>
<thead>
<tr>
<th>Sample Application</th>
<th>Location</th>
<th>Makefile</th>
</tr>
</thead>
<tbody>
<tr>
<td>pt_af_examples</td>
<td><code>protoolkit/protk_appls/pt_af_examples</code></td>
<td><code>make_af_examples</code></td>
</tr>
<tr>
<td>pt_autoaxis</td>
<td><code>protoolkit/protk_appls/pt_async</code></td>
<td><code>make_async</code></td>
</tr>
<tr>
<td>pt_basic</td>
<td><code>protoolkit/protk_appls/pt_basic</code></td>
<td><code>make_basic</code></td>
</tr>
<tr>
<td>pt_geardesign</td>
<td><code>protoolkit/protk_appls/pt_geardesign</code></td>
<td><code>make_geardesign</code></td>
</tr>
</tbody>
</table>
Using the User's Guide

The *Creo Parametric TOOLKIT User's Guide* is the primary resource to extend your knowledge of Creo Parametric TOOLKIT. Tips on how to use the guide follow:

- Chapter 1 deals with fundamentals. Beginners should study it thoroughly.
- Next, complete chapters 4-21 grouped under the Core and User Interface functional areas. They contain basic information useful to almost all Creo Parametric TOOLKIT users.
- After that, you can jump to any of the remaining chapters that describes the functionality in the areas that you intend to customize.

Contacting PTC Technical Support

Technical support for Creo Parametric and Creo Parametric TOOLKIT is available 24 hours a day, 7 days a week. You can contact Technical Support by phone, fax, e-mail, or FTP. You can easily access the most current technical support contact information from within Creo Parametric by clicking the Support link on the Creo Parametric homepage.

Joining the PTC/USER Community

PTC/USER Community provides education and communication services for users of PTC software. This nonprofit corporation offers an annual international conference and connects you to more experienced PTC software users, including Creo Parametric TOOLKIT developers. Visit [http://www.ptcuser.org](http://www.ptcuser.org) for more details.
A

APIWizard
display frame, 22
selection frame, 22

C

communication modes, 10
DLL, 10
Spawn, 10
compiler support, 13
contacting Technical Support, 27

D

development environment, setting up, 12
DLL mode, 10
documentation
APIWizard, 22
release notes, 23
user’s guide (PDF), 23

I

Install Test application, 13
installation
Creo Parametric TOOLKIT, 12
testing, 13

L

licensing, 13

M

makefiles, 14

modes of communication, 10

P

PDF
release notes, 23
user’s guide, 23
platform support, 13
PTC/USER Community, 27

R

running the Install Test application, 13

S

sample code, 26
spawn mode, 10
support
compiler, 13
platform, 13

T

Technical Support, contacting, 27
testing the installation, 13

U

using
APIWizard, 22
release notes, 23
user’s guide, 23, 27